Vorsteuerung (D2)

1.1 EinleitungPAGEREF _Toc304468616 \h2

1.2 Beschreibung 3

1.3 Parameter 10

1.3.1 Übersicht 10

1.3.2 Beschreibung 17

1.3.3 Beispiel Parametrierung der Vorsteuerung mit additiven Sollwerten 19

1.3.3.1 Geschwindigkeitsvorsteuerung 19

1.3.3.2 Beschleunigungsvorsteuerung 22

Mehr:

button Einleitung

button Beschreibung

button Parameter


Einleitung

Aufgabe

Im Normalbetrieb ohne Vorsteuerung entstehen durch den Schleppabstand auf gekrümmten Bahnen Konturfehler, insbesondere bei einem Bahnverbund mit Achsen unterschiedlicher Dynamik.

Durch den Einsatz einer Vorsteuerung kann der Schleppabstand und somit auch der Konturfehler minimiert werden. Bei Spindeln ist eine Vorsteuerung vor allem beim Gewindeschneiden mit endlos drehender Spindel erforderlich, da für das Erzielen eines guten Bearbeitungsergebnisses sowohl die Bahnachsen als auch die Spindel den Sollwertvorgaben möglichst schleppabstandsfrei folgen müssen.

Die Vorsteuerung der Steuerung kompensiert den Schleppfehler aus der aktuellen Geschwindigkeit und der Beschleunigung. Durch entsprechende Parametrierung in den Achsparameterlisten [AXIS] und auch im NC-Programm kann die Vorsteuerung an die Maschinendynamik bzw. die geforderte Konturgenauigkeit angepasst werden.

Es ist zu beachten, dass mit eingeschalteter Vorsteuerung die Achsen überschwingen können.

Die Parametrierung der Vorsteuerung ist deshalb sorgfältig vorzunehmen. Die Gewichtungsfaktoren in den Achsparameterlisten und im NC-Pro-gramm sind korrekt einzustellen.

Wirkungsbereich

Die Vorsteuerung ist für alle Achs- und Antriebstypen verfügbar [AXIS].


Beschreibung

Prinzip

Die Ursache des Schleppfehlers ist die regelungstechnische Zeitverzögerung von Geschwindigkeit, Beschleunigung und Ruck im Lageregler zur berechneten Führungsgröße im Interpolator. Die Vorsteuerung berechnet im Interpolator den sich theoretisch einstellenden Schleppfehler, der sich aufgrund der aktuellen Geschwindigkeit, Beschleunigung und Ruck im Lageregler ergeben würde und ermittelt daraus einen Geschwindigkeitssollwert vVorsteuerung der auf den Ausgang des Lagereglers addiert wird (Abbildung 1-1). Dieser zusätzliche Sollwert kann mit einem Faktor gewichtet werden.

Die zu erwartenden Schleppabstände lassen sich nach der Beziehung

für konstante Geschwindigkeit nach

für konstante Beschleunigung und nach

für konstanten Ruck berechnen. Hierbei ist Ta die mechanische Zeitkonstante des Antriebs.

Alternativ können die in der Steuerung berechneten Sollgeschwindigkeiten und Sollbeschleunigungen als additive Geschwindigkeits- und Drehmomentsollwerte an den Antriebsregler übertragen werden und dort in die jeweiligen Regelkreise als additive Sollwerte eingespeist werden (siehe Abbildung 1.2).

Vorsteuerungsarten | Die Steuerung unterscheidet aufgrund der Ursache des Schleppfehlers die Vorsteuerungsarten q Geschwindigkeitsvorsteuerung, q Beschleunigungsvorsteuerung und q Ruckvorsteuerung. Alle Vorsteuerungsarten können getrennt voneinander aktiviert bzw. parametriert werden.
Aktivierung | Der Parameter P-AXIS-00223 aktiviert die Vorsteuerung für jede Achse bzw. Spindel. Mit dem Setzen der entsprechenden Bits werden die Vorsteuerungsarten ausgewählt und zudem weitere Steuerungsinformationen aktiviert. Die Anwahl der Vorsteuerung erfolgt im NC-Programm.

Gewichtung

Die Vorsteuerung kann mit zwei achsspezifischen Gewichtungsfaktoren gewichtet werden. Mit dem Parametern P-AXIS-00228 und P-AXIS-00229 wird die gesamte Vorsteuerung gewichtet.

Die Bescheunigungsvorsteuerung kann zusätzlich mit einer Ersatzzeitkonstante Ta gewichtet werden, die aus den Parametern P-AXIS-00225 und P-AXIS-00226 bestimmt wird.

Die Ruckvorsteuerung kann ebenfalls mit einem Faktor

gewichtet werden, die aus den Parametern P-AXIS-00337 und P-AXIS-00338 bestimmt wird.

Erfahrungsgemäß sollte die gesamte Vorsteuerung mit einem Faktor im Bereich 0.71 gewichtet werden. Bei Werten >1 eilt die Achse voraus und verschlechtert die Konturgenauigkeit.

Abbildung 1-1: Blockschaltbild der konventionellen Vorsteuerung

Abbildung 1-2: Blockschaltbild Vorsteuerung mit additiven Sollwerten

Parametrierung für PROFIdrive-Antriebe

Die Steuerung unterstützt bei PROFIdrive-Antrieben zur Zeit ausschließlich das Telegramm 5. PROFIdrive-Antriebe benötigen zusätzlich die Parameter

q P-AXIS-00092: Lagegeberinkremente pro Motorumdrehung und

q P-AXIS-00165: Zeitversatz Sollwerte-Vorsteuerungsgrößen,

die in den Achsparameterlisten einzustellen sind.

Ferner kann bei den PROFIdrive-Antrieben mit dem Parameter P-AXIS-00223 ausgewählt werden, wie der berechnete Vorsteuerwert an den Antrieb übergeben wird:

q P-AXIS-00223, Bit 9 = 0: Der Vorsteuerwert wird als Schleppfehler in die Regelabweichung (XERR  Signal-Nr.25) einberechnet.

q P-AXIS-00223, Bit 9 = 1: Der Vorsteuerwert wird als Drehzahl im Drehzahlsollwert (NSOLL_B  Signal-Nr.7) einberechnet.

SERCOS-Antriebe: Wenn bei SERCOS-Antrieben die Vorsteuerung nicht im Antrieb, sondern in der NC-Steuerung erfolgen soll, muss der Kv-Faktor in der Achsparameterliste gleich dem Kv-Faktor des SERCOS-Antriebs (S-0-0104) eingestellt werden.

Hinweis: Die Vorsteuerung wird bei SERCOS-Antrieben in der Regel im Antrieb selbst vorgenommen und mit folgenden Parametern eingestellt:

IDN: S-0-0296: Velocity feed forward gain

IDN: S-0-0348: Acceleration feed forward gain

Programmierung

Die Programmierung der Vorsteuerung im NC-Programm erfolgt mit den modal wirksamen Befehlen G135 , G136 und G137 [PROG].

Anwahl der Vorsteuerung

Bei jedem Programmstart wird die Vorsteuerung explizit ausgeschaltet. Die achsgruppenspezifische Aktivierung der Vorsteuerung wird mit dem NC-Befehl G135 programmiert.

Gewichtung der Vorsteuerung

Eine achsspezifische, prozentuale Gewichtung der berechneten Vorsteuergrößen erfolgt über G136. Sie ist für alle Achsen auf 100% begrenzt. Nach jedem Programmstart werden die Gewichtungsfaktoren auf 100% zurückgesetzt. Wenn die Vorsteuerung während des NC-Programms ein- bzw. ausgeschaltet wird, bleiben die Gewichtungsfaktoren auf den durch G136 eingestellten Werten gesetzt. Für Achsen bei denen kein G136 programmiert wurde, bleibt der Gewichtungsfaktor auf 100%.

Es ist auch möglich, die Anwahl und Gewichtung der Vorsteuerung in einem Satz einzugeben.

Abwahl der Vorsteuerung

Mit G137 wird die Vorsteuerung achsgruppenspezifisch ausgeschaltet.

Ausschalten einzelner Achsen

Bei Achsen, für die nach der globalen Anwahl mit G135 keine Vorsteuerung erfolgen soll, muss mit G136 als prozentuale Gewichtung 0% angegeben werden.

Beispiel:

G135 (Anwahl der Vorsteuerung; Gewichtung)
(für alle Achsen 100%)

G136 X80 Y95 Z0 (Gewichtung; Hier wird die Z-Achse)
(nicht vorgesteuert)

Parametrierung der Spindel

Die Programmierung der Vorsteuerung für Spindeln im NC-Programm erfolgt ebenfalls mit den modal wirksamen Befehlen G135 , G136 und G137 [PROG].

Mit diesen Befehlen kann spindelspezifisch die Vorsteuerung programmiert werden. Die Befehle dürfen nicht gleichzeitig zusammen mit anderen spindelspezifischen Befehlen verwendet werden.

Beispiel:

S[G135] (Aktivierung der Vorsteuerung für S)

S[G136=80] (Angabe der Vorsteuergewichtung in %)

S[G137] (Deaktivierung der Vorsteuerung)

S2[G135 G136=90] (Aktivierung mit Gewichtung 90% für S2)

S2[G136=0] (Änderung der Gewichtung auf 0%)

S1[G135] (Aktivierung mit Defaultgew. 100% für S1)

Zeitverzögerung

Für die Berechnung der Vorsteuerungswerte ergibt sich eine Zeitverzögerung von mindestens einem Takt zwischen dem Interpolator und dem Lageregler.

Auswirkungen der Zeitverzögerung bei der Messfahrt

Bei einer Meßfahrt kann im ungünstigsten Fall ein Fehler erzeugt werden, da der Interpolator, welcher den Meßtasterhub überwacht, die Weganteile im Satzpuffer zwischen Interpolator und Lagerregler nicht berücksichtigt. Durch vergrößern des wirklichen Hubs des Messtasters im Parameter P-AXIS-00086 (hub_messtaster) kann dies verhindert werden.

Beispiel

Die folgenden Abbildungen zeigen für eine einfache Verfahrbewegung die gemessenen Schleppabstände mit und ohne Geschwindigkeits- bzw. Beschleunigungsvorsteuerung. Abbildung 1-2 zeigt einen deutlichen Schleppabstand während der gesamten Verfahrbewegung.

Mit eingeschalteter Geschwindigkeitsvorsteuerung treten nur in den Beschleunigungsphasen Schleppabstandsspitzen auf, im Bereich mit konstanter Geschwindigkeit wird der Schleppabstand vollständig durch die Vorsteuerung kompensiert (Abbildung 1-3). Durch die zusätzliche Beschleunigungsvorsteuerung kann der Schleppabstand in den Beschleunigungsphasen weiter reduziert werden (Abbildung 1-4).

Abbildung 1-2: Schleppabstand ohne Vorsteuerung

Abbildung 1-3: Schleppabstand mit Geschwindigkeitsvorsteuerung

Abbildung 1-4: Schleppabstand mit Geschwindigkeits- und Beschleunigungsvorsteuerung


Parameter

Mehr:

button Übersicht

button Beschreibung

button Beispiel Parametrierung der Vorsteuerung mit additiven Sollwerten


Übersicht

Konstante | Beschreibung
V_SATZ_ANZ | Maximale Anzahl gepufferter Sätze

ID | Parameter | Beschreibung
P-AXIS-00092 | incr_per_rev | Lagegeberinkremente pro Motorumdrehung
P-AXIS-00165 | shift_time | PROFIdrive: Zeitversatz Sollwerte-Vorsteuerungsgrößen
P-AXIS-00205 | v_reso_denom | Nenner Skalierungsfaktor Geschwindigkeitsskalierung
P-AXIS-00206 | v_reso_num | Zähler Skalierungsfaktor Geschwindigkeitsskalierung
P-AXIS-00207 | v_time_base | Zeitbasis für den Skalierungsfaktor der Geschwindigkeitsskalierung
P-AXIS-00223 | vorsteuerung | Vorsteuermodus
P-AXIS-00225 | vs_a_faktor | Ersatzzeitkonstante für die Beschleunigungs-Vorsteuerung, Zähler
P-AXIS-00226 | vs_a_nenner | Ersatzzeitkonstante für die Beschleunigungs-Vorsteuerung, Nenner
P-AXIS-00228 | vs_v_faktor | Gewichtungsfaktor für die Vorsteuerung, Zähler
P-AXIS-00229 | vs_v_nenner | Gewichtungsfaktor für die Vorsteuerung, Nenner
P-AXIS-00325 | torque_scale_num | Zähler Skalierungsfaktor Drehmomentskalierung
P-AXIS-00326 | torque_scale_denom | Nenner Skalierungsfaktor Drehmomentskalierung
P-AXIS-00337 | jerk_fact_num | Gewichtungsfaktor für die Ruckvorsteuerung, Zähler
P-AXIS-00338 | jerk_fact_denom | Gewichtungsfaktor für die Ruckvorsteuerung, Nenner
P-AXIS-00389 | velocity_delay_time | Verzögerungszeit für Geschwindigkeitsvorsteuerwert
P-AXIS-00390 | acceleration_delay_time | Verzögerungszeit für Beschleunigungsvorsteuerwert
P-AXIS-00391 | load | Motorlast
P-AXIS-00392 | acc_reference_value | Gewichtungsfaktor für die Umrechnung der Beschleunigungsvorsteuerwerte in das Motorformat.


Beschreibung

P-AXIS-00092 | Lageinkremente pro Motorumdrehung
Parameter | getriebe[i].incr_per_rev
Beschreibung | Mit diesem Parameter werden die Anzahl der Lagegeberinkremente pro Motorumdrehung angegeben. Dieser Wert wird zur Berechnung der Lageauflösung verwendet.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00092 ≤ MAX(UNS32)
Dimension | -
Standardwert | -
Anmerkungen | -

P-AXIS-00165 | Zeitversatz Sollwerte-Vorsteuergrößen
Parameter | vorsteuer.shift_time
Beschreibung | Mit diesem Parameter kann ein Zeitversatz in NC-Takten zwischen der Ausgabe der Sollwerte und der Ausgabe der berechneten Vorsteuergrößen definiert werden. Bei einem Wert > 0 werden die Vorsteuergrößen vor dem zugehörigen Sollwert ausgegeben. Hiermit kann das Verhalten der Achse bei Verwendung der Vorsteuerung optimiert werden.
Datentyp | UNS16
Datenbereich | 0 ≤ P-AXIS-00165 ≤ V_SATZ_ANZ -1
Dimension | Takte
Standardwert | -
Anmerkungen | Dieser Parameter gilt nur für PROFIdrive-Antriebe

P-AXIS-00205 | Nenner Geschwindigkeitsskalierung
Parameter | antr.v_reso_denom
Beschreibung | Nenner der Geschwindigkeitsskalierung.
Datentyp | UNS32
Datenbereich | 0 < v_reso_nom < MAX(UNS32)
Dimension | translatorisch: um | rotatorisch: 0,001°
Standardwert | 36
Anmerkungen |

P-AXIS-00206 | Zähler Geschwindigkeitsskalierung
Parameter | antr.v_reso_num
Beschreibung | Zähler der Geschwindigkeitsskalierung.
Datentyp | UNS32
Datenbereich | 0 < v_reso_nom < MAX(UNS32)
Dimension | translatorisch: Inkremente | rotatorisch: Inkremente
Standardwert | 1
Anmerkungen |

P-AXIS-00207 | Zeitbasis Geschwindigkeitsskalierung
Parameter | antr.v_time_base
Beschreibung | Mit diesem Parameter wird die Zeitbasis für die Geschwindigkeitsskalierung eingestellt. Mögliche Werte sind: 0 : pro Minute 1 : pro Sekunde 2 : pro Abtastintervall
Datentyp | UNS16
Datenbereich | 0 .. 2
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0 (pro Minute)
Anmerkungen |

P-AXIS-00223 | Vorsteuermodus
Parameter | vorsteuer.vorsteuerung
Beschreibung | Mit diesem Parameter können verschiedene Modi für die Vorsteuerung eingestellt werden.
Datentyp | UNS16
Datenbereich | 0x0000 | Keine Vorsteuerung
 | 0x0001 | Geschwindigkeitsvorsteuerung
 | 0x0002 | Beschleunigungsvorsteuerung
 | 0x0004 | Ruckvorsteuerung
 | 0x0100 | Wenn die Geschwindigkeitsvorsteuerung aktiv ist, erfolgt diese durch Ausgabe eines additiven Geschwindigkeitssollwertes.
 | 0x0200 | Wenn die Beschleunigungsvorsteuerung aktiv ist, erfolgt diese durch Ausgabe eines additiven Drehmoment/Stromsollwertes.
Dimension | -
Standardwert | -
Anmerkungen |

P-AXIS-00225

Ersatzzeitkonstante für die Beschleunigungs-Vorsteuerung, Zähler

Parameter

vorsteuer.vs_a_faktor

Beschreibung

Dieser Parameter beschreibt den Zähler der mechanischen Zeitkonstante TA des Antriebs, der als Verzögerungsglied erster Ordnung modelliert wird. Im Laplace-Bereich hat der Antrieb folgende Übertragungsfunktion:

Bei der Beschleunigungs-Vorsteuerung wird die Beschleunigungsführungsgröße mit dieser mechanischen Ersatzzeitkonstante..

..des Antriebes gewichtet.

Datentyp

SGN32

Datenbereich

0 ≤ P-AXIS-00225 ≤ MAX(SGN32)

Dimension

μ s

Standardwert

-

Anmerkungen

-

P-AXIS-00226

Ersatzzeitkonstante für die Beschleunigungs-Vorsteuerung, Nenner

Parameter

vorsteuer.vs_a_nenner

Beschreibung

Dieser Parameter beschreibt den Nenner der mechanischen Zeitkonstante TA des Antriebs, der als Verzögerungsglied erster Ordnung modelliert wird. Im Laplace-Bereich hat der Antrieb folgende Übertragungsfunktion:

Bei der Beschleunigungs-Vorsteuerung wird die Beschleunigungsführungsgröße mit dieser mechanische Ersatzzeitkonstante..

..des Antriebes gewichtet.

Datentyp

SGN32

Datenbereich

0 ≤ P-AXIS-00226 ≤ MAX(SGN32)

Dimension

1

Standardwert

-

Anmerkungen

-

P-AXIS-00228 | Gewichtungsfaktor für die Vorsteuerung, Zähler
Parameter | vorsteuer.vs_v_faktor
Beschreibung | Dieser Parameter beschreibt den Zähler des Gewichtungsfaktors der Geschwindigkeits- und Beschleunigungsvorsteuerung.
Datentyp | SGN32
Datenbereich | 0 ≤ P-AXIS-00228 ≤ MAX(SGN32)
Dimension | -
Standardwert | -
Anmerkungen | Erfahrungsgemäß sollte der Gewichtungsfaktor im Bereich 0.7  1 eingestellt werden. Bei Werten >1 eilt die Achse voraus und verschlechtert die Konturgenauigkeit.

P-AXIS-00229 | Gewichtungsfaktor für die Vorsteuerung, Nenner
Parameter | vorsteuer.vs_v_nenner
Beschreibung | Dieser Parameter beschreibt den Zähler des Gewichtungsfaktors der Geschwindigkeits- und Beschleunigungsvorsteuerung.
Datentyp | SGN32
Datenbereich | 0 ≤ P-AXIS-00229 ≤ MAX(SGN32)
Dimension | -
Standardwert | -
Anmerkungen | Erfahrungsgemäß sollte der Gewichtungsfaktors im Bereich 0.7  1 eingestellt werden. Bei Werten >1 eilt die Achse voraus und verschlechtert die Konturgenauigkeit.

P-AXIS-00325 | Zähler Skalierungsfaktor Drehmomentskalierung
Parameter | antr. torque_scale_num
Beschreibung | Nenner des Skalierungsfaktors für die Drehmomentvorgabe an den Antrieb. Der Faktor wird als Quotient angegeben. Dieser Quotient ist der Wert, der an den Antrieb ausgegeben werden muss, damit der Motor sein Nennmoment abgibt.
Datentyp | UNS32
Datenbereich | 0 < v_reso_nom < MAX(UNS32)
Dimension | translatorisch: Inkremente | rotatorisch: Inkremente
Standardwert | 1
Anmerkungen |

P-AXIS-00326 | Nenner Skalierungsfaktor für Drehmoment
Parameter | antr.torque_scale_denom
Beschreibung | Nenner des Skalierungsfaktors für die Drehmomentvorgabe an den Antrieb. Der Faktor wird als Quotient angegeben. Dieser Quotient ist der Wert, der an den Antrieb ausgegeben werden muss, damit der Motor sein Nennmoment abgibt.
Datentyp | UNS32
Datenbereich | 0 < torque_scale_denom MAX < (UNS32)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 1
Anmerkungen |

P-AXIS-00337 | Gewichtungsfaktor für Ruckvorsteuerung, Zähler
Parameter | vorsteuer.jerk_fact_num
Beschreibung | Mit diesem Parameter wird der Zähler des Gewichtungsfaktors für die Ruckvorsteuerung angegeben. Der resultierende Gewichtungsfaktor ist definiert als:
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00337 ≤ MAX(UNS32)
Dimension | -
Standardwert | -
Anmerkungen | -

P-AXIS-00338 | Gewichtungsfaktor für Ruckvorsteuerung, Nenner
Parameter | vorsteuer.jerk_fact_denom
Beschreibung | Mit diesem Parameter wird der Nenner des Gewichtungsfaktors für die Ruckvorsteuerung angegeben. Der resultierende Gewichtungsfaktor ist definiert als:
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00338 ≤ MAX(UNS32)
Dimension | -
Standardwert | -
Anmerkungen | -

P-AXIS-00389

Verzögerungszeit für Geschwindigkeitsvorsteuerung

Parameter

vorsteuer.velocity_delay_time

Beschreibung

Falls für die Geschwindigkeitsvorsteuerung die Verwendung eines additiven Geschwindigkeitssollwertes aktiviert ist, kann mit diesem Parameter die Ausgabe des Geschwindigkeitsvorsteuerwertes gegenüber dem Lagesollwert verzögert werden.

Die Verzögerungszeit ist in us anzugeben, die maximale Verzögerung beträgt einen Interpolatortakt.

Der optimale Wert für diesen Parameter ist abhängig vom verwendeten Antriebsregler und ist vom Hersteller des Regelgerätes zu erfragen.

Datentyp

UNS16

Datenbereich

0 < Interpolatorzykluszeit

Dimension

us

Standardwert

0

Anmerkungen

Die maximal einstellbare Verzögerungszeit beträgt einen Interpolatortakt. Wird eine größere Verzögerungszeit parametriert wird die Fehlermeldung 70349 (siehe P-ERR-70349) ausgegeben und die Verzögerungszeit auf 0 gesetzt.

P-AXIS-00390

Verzögerungszeit für Beschleunigungsvorsteuerung

Parameter

vorsteuer.acceleration_delay_time

Beschreibung

Falls für die Beschleunigungsvorsteuerung die Verwendung eines additiven Drehmomentsollwertes aktiviert ist, kann mit diesem Parameter die Ausgabe des Beschleunigungsvorsteuerwertes gegenüber dem Lagesollwert verzögert werden.

Die Verzögerungszeit ist in us anzugeben, die maximale Verzögerung beträgt einen Interpolatortakt.

Der optimale Wert für diesen Parameter ist abhängig vom verwendeten Antriebsregler und ist vom Hersteller des Regelgerätes zu erfragen.

Datentyp

UNS16

Datenbereich

0 < Interpolatorzykluszeit

Dimension

us

Standardwert

0

Anmerkungen

Die maximal einstellbare Verzögerungszeit beträgt einen Interpolatortakt. Wird eine größere Verzögerungszeit parametriert wird die Fehlermeldung 70348 (siehe P-ERR-70348) ausgegeben und die Verzögerungszeit auf 0 gesetzt.

P-AXIS-00391 | Lastträgheitsmoment
Parameter | getriebe[].load
Beschreibung | In diesem Parameter ist zur Parametrierung der Beschleunigungsvorsteuerung mit additivem Drehmomentsollwert das gesamte Lasträgheitsmoment anzugeben. Dieses setzt sich zusammen aus dem Trägheitsmoment des Motors sowie dem auf die Motorwelle bezogenen Lastträgheitsmoment. Im Falle einer translatorisch bewegten Achse sind die bewegten Massen in ein äquivalentes, auf die Motorwelle bezogenes Lastträgheitsmoment umzurechnen.
Datentyp | REAL64
Datenbereich | 0 < P-AXIS-00391 <= MAX_REAL64
Dimension | kg (Linearmotor), kg * m2 (rotatorischer Motor)
Standardwert | 1e-6
Anmerkungen | -

P-AXIS-00392 | Bezugswert für Drehmomentskalierung
Parameter | antr.acc_reference_value
Beschreibung | Dieser Parameter dient der Parametrierung des Umrechnungsfaktors in das antriebsseitig verwendete Drehmomentformat . Es ist das Nennmoment des Motors einzutragen.
Datentyp | REAL64
Datenbereich | 0 .. MAX_REAL64
Dimension | Nm (N bei Linearmotor)
Standardwert | 1
Anmerkungen | -


Beispiel Parametrierung der Vorsteuerung mit additiven Sollwerten

Mehr:

button Geschwindigkeitsvorsteuerung

button Beschleunigungsvorsteuerung


Geschwindigkeitsvorsteuerung

Konfigurierung

Zur Verwendung der Geschwindigkeitsvorsteuerung ist zunächst in P-AXIS-00223 die Geschwindigkeitsvorsteuerung und die Ausgabe des Geschwindigkeitsvorsteuerwertes als additiver Sollwert zu konfigurieren:

vorsteuer.vorsteuerung 0x101 #0x001: Activation velocity feedforward
#0x100: Output as additive velocity command value

In den zyklischen Prozessdaten ist der additive Geschwindigkeitssollwert zu konfigurieren.

Wird die Ausgabe der Geschwindigkeitsvorsteuerung als additiver Sollwert aktiviert und ist in den zyklischen Prozessdaten der additive Geschwindigkeitssollwert nicht konfiguriert, so wird die Fehlermeldung 70350 (siehe P-ERR-70350) ausgegeben.

Geschwindigkeits-skalierung

Nun muss noch die Geschwindigkeitsskalierung parametriert werden. Hierzu werden die Parameter P-AXIS-00205, P-AXIS-00206 und P-AXIS-00207 verwendet.

In den Parameter P-AXIS-00205 ist dabei die Geschwindigkeit einzutragen, die sich unter Berücksichtigung aller Übertragungselemente (z. B. Getriebeübersetzung und Spindelsteigung) für die Achse einstellt, wenn der Wert von P-AXIS-00206 auf der Geschwindigkeitsschnittstelle ausgegeben wird. In P-AXIS-00207 ist die auf der Geschwindigkeitsschnittstelle verwendete Zeitbasis einzutragen.

Beispiel:

Bei einem SERCOS-Antrieb mit einer Spindelsteigung von 10 mm/U und der Defaultskalierung für Geschwindigkeitsdaten (10-4 U/min) ergibt sich bei Ausgabe des Wertes 10000 als Geschwindigkeitssollwert an den Antrieb eine translatorische Achsgeschwindigkeit von 10 mm/min (10000 * 10-4U/min * 10 mm/U). Für die Parameter P-AXIS-00205, P-AXIS-00206 und P-AXIS-00207 sind daher die folgenden Werte einzustellen:

antr.v_time_base 0 #Timebase per Minute
antr.v_reso_num 10000 #Outputvalue to drive
antr.v_reso_denom 10000 #Resulting axis velocity in um/v_time_base

Wenn zusätzlich noch ein Getriebe mit einem Übersetzungsverhältnis von i=3 (nMotor/nLast) berücksichtigt wird reduziert sich bei gleichem Ausgabewert die translatorische Geschwindigkeit der Achse auf 3,333 mm/min (10000 * 10-4U/min / i * 10 mm/U). Damit ergeben sich für P-AXIS-00206 und P-AXIS-00207 die folgenden Werte:

antr.v_time_base 0 #Timebase per Minute
antr.v_reso_num 10000 #Outputvalue to drive
antr.v_reso_denom 3333 #Resulting axis velocity in um/v_time_base

Zusätzlich kann noch die Ausgabe des Geschwindigkeitsvorsteuerwertes gegenüber dem Lagesollwert verzögert werden, diese Verzögerung kann durch den Parameter P-AXIS-00389 eingestellt werden.

Die maximal einstellbare Verzögerungszeit beträgt einen Lagereglertakt. Wird eine größere Verzögerungszeit parametriert wird die Fehlermeldung 70349 (siehe P-ERR-70349) ausgegeben und die Verzögerungszeit auf 0 gesetzt.

Der resultierende Parametersatz ist damit:

vorsteuer.vorsteuerung 0x101 #0x001: Activation velocity feedforward
#0x100: Output as additive velocity command value
vorsteuer.velocity_delay_time 150 # Delay velocity feedforward against position
# command value in us
antr.v_time_base 0 #Timebase per Minute
antr.v_reso_num 10000 #Outputvalue to drive
antr.v_reso_denom 3333 #Resulting axis velocity in um/v_time_base


Beschleunigungsvorsteuerung

Konfigurierung

Zur Verwendung der Beschleunigungsvorsteuerung ist zunächst in P-AXIS-00223 die Beschleunigungsvorsteuerung und die Ausgabe des Beschleunigungsvorsteuerwertes als additiver Sollwert zu konfigurieren:

vorsteuer.vorsteuerung 0x202 #0x002: Activation acceleration feedforward
#0x200: Output as additive torque command value

Zusätzlich ist in den zyklischen Prozessdaten der additive Drehmoment/Stromsollwert zu konfigurieren.

Wird die Ausgabe der Beschleunigungsvorsteuerung als additiver Sollwert aktiviert und ist in den zyklischen Prozessdaten der additiver Drehmoment-/Stromsollwert nicht konfiguriert, so wird die Fehlermeldung 70351 (siehe P-ERR-70351) ausgegeben.

Berechnung
Drehmoment

Bei der Beschleunigungsvorsteuerung über einen additiven Drehmoment/Stromsollwert wird anhand der Gleichung

das vom Motor aufzubringende Drehmoment berechnet.

Dieses Drehmoment wird in das vom Motor verwendete Format umskaliert und an den Antrieb ausgegeben.

Da zur Berechung der Winkelbeschleunigung Wissen über den mechanischen Aufbau der Achse benötigt wird, ist es ratsam die Wegauflösung der Achse durch Angabe der Parameter P-AXIS-00092, P-AXIS-00363, P-AXIS-00362, P-AXIS-00334 und P-AXIS-00223 zu konfigurieren.

Wenn einer der beiden Parametern P-AXIS-00363 und P-AXIS-00362 ein Wert ungleich 1 zugewiesen wird, berechnet sich die Wegauflösung nach der Formel:

Parametersatz

Für eine Achse mit einer Motorgeberauflösung von 220 Inkrementen pro Umdrehung, einer Getriebeübersetzung von 3 und einer Spindelsteigung von 5 mm/U ergibt sich der folgende Parametersatz:

antr.feed_const_num 50000 #feedconstant 5mm per revolution
antr.feed_const_denom 1 #
getriebe[].incr_per_rev 10485676 #2**20 increments per motor revolution
getriebe[].wegaufz 3 #gearbox ratio: input revolutions
getriebe[].wegaufn 1 #gearbox ratio: output revolutions

Als weiterer Parameter wird die gesamte Motorlast (Jges) benötigt. Jges setzt sich zusammen aus Summe der Trägheitsmomente des Motors und des auf die Motorwelle bezogenen Lastmoments. Der resultierende Wert ist in Parameter P-AXIS-00391 in der Dimension kg*m2 einzutragen.

getriebe[].load 0.48 #Total motor load 0.48 kg*m**2

Mit den nun vorliegenden Parametern ist es möglich das benötigte Motormoment zu berechnen. Zur Berechnung des an den Antrieb auszugebenden Drehmoment/Stromsollwertes sind noch die folgenden Parameter nötig:

Das Nennmoment des Motors als Bezugsgröße für die Drehmomentskalierung in P-AXIS-00392 sowie den Drehmomentskalierungsfaktor in den Parametern P-AXIS-00325 und P-AXIS-00326.

Der Wert für P-AXIS-00392 kann dem Motordatenblatt entnommen werden:

antr.acc_reference_value 0.45 #stall torque in Nm

Für die Parameter P-AXIS-00325 und P-AXIS-00326 ist der Wert anzugeben, der als additiver Drehmomentsollwert ausgegeben werden muss, damit der Motor sein Nennmoment abgibt. Dieser Wert ist abhängig von der im Antrieb verwendeten Drehmomentskalierung.

Wird zum Beispiel bei einem Antrieb eine prozentuale Gewichtung in 0,1% bezogen auf den Maximalstrom des Antriebsverstärkers verwendet so ergibt sich bei einem Maximalstrom von 3,16 A und einem Nennstrom von 1,58 A für P-AXIS-00325 und P-AXIS-00326:

Mögliche Werte für P-AXIS-00325 und P-AXIS-00326 wären damit z. B:

antr.torque_scale_num 500
antr.torque_scale_denom 1

Zusätzlich kann noch die Ausgabe des Beschleunigungsvorsteuerwertes gegenüber dem Lagesollwert verzögert werden, diese Verzögerung kann durch den Parameter P-AXIS-00390 eingestellt werden.

Die maximal einstellbare Verzögerungszeit beträgt einen Lagereglertakt. Wird eine größere Verzögerungszeit parametriert, so wird die Fehlermeldung 70348 (siehe P-ERR-70348) ausgegeben und die Verzögerungszeit auf 0 gesetzt.

Durch die Parameter P-AXIS-00225 und P-AXIS-00226 kann der auszugebende Vorsteuerwert gewichtet werden. Im folgenden Beispiel wird der Vorsteuerwert mit dem Faktor 1,2 gewichtet.

vorsteuer.vs_a_faktor 12 # Weighting acceleration feedforward numerator
vorsteuer.vs_a_nenner 10 # Weighting acceleration feedforward denominator

Der resultierende Parametersatz ist damit:

vorsteuer.vorsteuerung 0x202 #0x002: Activation acceleration feedforward
#0x200: Output as additive torque command value
antr.feed_const_num 50000 #feedconstant 5mm per revolution
antr.feed_const_denom 1 #
getriebe[].incr_per_rev 10485676 #2**20 increments per motor revolution
getriebe[].wegaufz 3 #gearbox ratio: input revolutions
getriebe[].wegaufn 1 #gearbox ratio: output revolutions
antr.acc_reference_value 0.45 #stall torque in Nm
antr.torque_scale_num 500
antr.torque_scale_denom 1
vorsteuer.acceleration_delay_time 150 # Delay acceleration feedforward against
# position command value in us
vorsteuer.vs_a_faktor 12 # Weighting acceleration feedforward numerator
vorsteuer.vs_a_nenner 10 # Weighting acceleration feedforward denominator