Achskollisionsüberwachung (C3)

1.1 EinleitungPAGEREF _Toc304465531 \h8

1.2 Beschreibung 8

1.3 Parameter 10

1.3.1 Übersicht 10

1.3.2 Beschreibung 10

Mehr:

button Einleitung

button Beschreibung

button Parameter


Einleitung

Mit der Funktion Achs-Kollisionsüberwachung wird die mechanische Kollision von Vorschubeinheiten verhindert, die sich in ihren Verfahrbereichen überschneiden. Die Verfahrbereiche verlaufen hierbei parallel zueinander.

Dies ist beispielsweise der Fall bei einem Linearantrieb mit zwei Primärteilen, wie er in Portalmaschinen oder stabkinematischen Maschinen zum Einsatz kommt.

Abbildung 1-1: Drei Schlitten auf einem Linearantrieb

Abbildung 1-2: Beispiel Hexapod


Beschreibung

Bei der Kollisionsüberwachung werden die in der CNC generierten Positions-Sollwerte eines Achspaares in Echtzeit überwacht. Unterschreitet der Abstand der beiden Positionen unter Berücksichtigung des zum Anhalten benötigten Bremswegs den minimal zulässigen Abstand, so werden die Achsen entsprechend der vorgegebenen dynamischen Daten unverzüglich gestoppt und die CNC gibt die Meldung 70092 aus.

Nach dem CNC-RESET müssen die beiden Achsen voneinander weg-positioniert werden.

Zwei Achsen deren gegenseitiger Abstand überwacht wird werden auch als Kollisionspaar bezeichnet.

Es besteht die Möglichkeit mehrere Kollisionspaare zu bilden, ebenso kann auch der Abstand einer Achse zu zwei anderen Achsen überwacht werden.

Bei der Stillsetzung der Achsen aufgrund einer Kollisionserkennung wird im Allgemeinen die programmierte Kontur verlassen.

Parameter

Zur Kollisionsüberwachung wird jeweils für eine Achse (die Masterachse) im Parameter P-AXIS-00043 die logische Achsnummer der anderen Achse (des Kollisionspartners) angegeben.

Für beide beteiligte Achsen ist im Parameter P-AXIS-00015 (achs_mode) das Bit 0x8000 zu setzen.

Der minimal zulässige Abstand zwischen den Bezugspunkten der Schlitten wird über den Parameter P-AXIS-00045 (coll_offset) der Masterachse angegeben. Falls zwei Achsen gegenseitig als Kollisionspaar konfiguriert wurden so wird bei unterschiedlich konfiguriertem Parameter P-AXIS-00043 der größere der beiden Werte verwendet.

Befinden sich die Kollisionsachsen in unterschiedlichen CNC-Kanälen, so kann über den Parameter P-AXIS-00044 (coll_decelerate_chan) ein Anhalten in beiden Kanälen erzwungen werden, wenn eine Kollisionsachse einen Antriebsfehler meldet

Abbildung 1-3: Minimal zulässiger Abstand

Beispiel

Initialisierung in der Achsparameterliste der Achse 1

kopf.achs_nr 1

achs_mode 0x8001

Initialisierung in der Achsparameterliste der Achse 2

kopf.achs_nr 2

achs_mode 0x8001

kenngr.coll_check_ax_nr 1

kenngr.coll_offset 200000

Initialisierung in der Achsparameterliste der Achse 3

kopf.achs_nr 3

achs_mode 0x8001

kenngr.coll_check_ax_nr 2

kenngr.coll_offset 300000

Die Kollisionsüberwachung wird erst aktiv, nachdem für die entsprechen-den Achsen eine Referenzpunktfahrt durchgeführt wurde.

Bewegungsrichtung der Achsen

Bei der Kollisionsüberwachung wird davon ausgegangen dass sich die beteiligten Achsen mechanisch gleichsinnig bewegen, d. h. wenn für beide Achsen eine Bewegung in positiver Richtung programmiert wurde bewegen sich die Achsen mechanisch ebenfalls in dieselbe Richtung. Falls diese Vorraussetzung nicht erfüllt ist muss dies durch Setzen des Parameters P-AXIS-00262 (coll_moving_dir_inverted) in der Parameterliste der Masterachse angezeigt werden.

Abbildung 1-4: Kollisionspaar mit mechanisch inversen Bewegungsrichtungen

Beispiel

Initialisierung in der Achsparameterliste der Achse X1

kopf.achs_nr 1

achs_mode 0x8001

Initialisierung in der Achsparameterliste der Achse X2

kopf.achs_nr 2

achs_mode 0x8001

kenngr.coll_check_ax_nr 1

kenngr.coll_offset 200000

kenngr.coll_moving_dir_inverted 1

Nullpositionen der Achsen

Falls die Kollisionsachsen nicht dieselbe Nullposition haben ist der Versatz zwischen den beiden Positionen in den Parameter P-AXIS-00263 (coll_zero_position_offset) einzutragen. Der Wert vom P-AXIS-00263 ist dabei gleich der Position des Nullpunktes des Kollisionspartners im Achskoordinatensystem der Masterachse.

Abbildung 1-5: Kollisionspaar mit unterschiedlichen Nullpositionen

Beispiel

In diesem Beispiel sind zwei Kollisionspaare definiert:

1. Paar: X1-Achse mit X2-Achse wobei die X2-Achse die Masterachse und X1 die Partnerachse ist.

2. Paar: X2-Achse mit X3Achse wobei die X3-Achse die Masterachse und X2 die Partnerachse ist.

Initialisierung in der Achsparameterliste der Achse X1

kopf.achs_nr 1

achs_mode 0x8001

Initialisierung in der Achsparameterliste der Achse X2

kopf.achs_nr 2

achs_mode 0x8001

kenngr.coll_check_ax_nr 1

kenngr.coll_offset 200000

kenngr.coll_zero_position_offset -100000

Achsverzögerung bei der Kollisionsüberwachung

Standardmäßig wird für die Kollisionsüberwachung der Wert von P-AXIS-00008 (a_max) verwendet um die Bremswege zu berechnen und die Achsen im Kollisionsfall abzubremsen.

Durch den Parameter P-AXIS-00267 (coll_use_a_emergency) kann diese Verzögerung auf den im Parameter P-AXIS-00003 (a_emergency) definierten Wert umgestellt werden.

Bremsweg-
betrachtung

Die aktuelle Geschwindigkeit einer Achse ergibt sich zu:

vt = (sollwtn - sollwtn-1) / TA vt aktuelle Geschwindigkeit

TA Interpolations-Zykluszeit

sollw Positions-Sollwerte in Takt n und n-1

Der minimale Bremsweg ergibt sich aus der eingestellten Verzögerung für die Kollisionsüberwachung (Parameter P-AXIS-00008 (a_max), P-AXIS-00267 (coll_use_a_emergency), P-AXIS-00003 (a_emergency)) und der aktuellen Geschwindigkeit zu:

sbrems = ½ (vt2/acoll)

Mit:

sbrems : Bremsweg

vt : aktuelle Geschwindigkeit

acoll : Verzögerung für Kollisionsüberwachung

Abbildung 1-4: Mögliche Kollisionsszenarien


Parameter

Mehr:

button Übersicht

button Beschreibung


Übersicht

ID | Parameter | Beschreibung
P-AXIS-00043 | coll_check_ax_nr | Logische Nummer der zugehörigen Paarachse
P-AXIS-00044 | coll_decelerate_chan | Stoppen von Kollisionsachsen in unterschiedlichen Kanälen
P-AXIS-00045 | coll_offest | Minimal zulässiger Positionsabstand der Kollisionsachsen
P-AXIS-00262 | coll_moving_dir_inverted | Kollisionsachsen haben unterschiedliche mechanische Bewegungsrichtung
P-AXIS-00263 | coll_zero_position_offset | Offset zwischen den Nullpositionen der Kollisionsachsen
P-AXIS-00267 | coll_use_a_emergency | Kollisionsbetrachung mit P-AXIS-00003 (a_emergency) durchführen.


Beschreibung

P-AXIS-00043 | Logische Nummer der zugehörigen Paarachse
Parameter | kenngr.coll_check_ax_nr
Beschreibung | Logische Achsnummer der zu überwachenden Achse. Für diese Achse muss im Achsmode das Bit 0x8000 gesetzt sein
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00043 ≤ MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00044 | Stoppen von Kollisionsachsen in unterschiedlichen Kanälen
Parameter | kenngr.coll_decelerate_chan
Beschreibung | Gehören Kollisionsachsen zu unterschiedlichen Kanälen, kann über diesen Parameter ein Anhalten im anderen Kanal erzwungen werden, wenn eine Kollisionsachse einen Antriebsfehler meldet
Datentyp | BOOLEAN
Datenbereich | 0: Kein Einfluss auf Kollisionspartnerachse 1: Anhalten der Kollisionspartnerachse im anderen Kanal
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00045 | Minimal zulässiger Positionsabstand der Kollisionsachsen
Parameter | kenngr.coll_offset
Beschreibung | Minimal zulässiger Positionsabstand der Kollisionsachsen
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00045 ≤ MAX(UNS32)
Dimension | translatorisch: 0.1 µm | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00262 | Kollisionsachsen haben unterschiedliche mechanische Bewegungsrichtung
Parameter | kenngr.coll_moving_dir_inverted
Beschreibung | Wenn sich die Kollisionsachsen bei einer programmierten Bewegung in dieselbe Richtung mechanisch nicht in dieselbe Richtung bewegen so ist dieser Parameter auf 1 zu setzen.
Datentyp | BOOLEAN
Datenbereich | 0: Achsen bewegen sich bei gleichsinniger Beauftragung mechanisch gleichsinnig. 1: Achsen bewegen sich bei gleichsinniger Beauftragung mechanisch entgegensetzt.
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | -

P-AXIS-00263 | Nullpunktdifferenz zwischen den Kollisionsachsen.
Parameter | kenngr.coll_zero_position_offset
Beschreibung | Offset zwischen den Nullpositionen der Kollisionsachsen. Es ist die Position des Nullpunktes der Partnerachse im Koordinatensystem der Masterachse anzugeben.
Datentyp | SGN32
Datenbereich | MIN(SGN32) ≤ P-AXIS-00263 ≤ MAX(UNS32)
Dimension | translatorisch: 0,1 µm | rotatorisch: -
Standardwert | 0
Anmerkungen | -

P-AXIS-00267 | Kollisionsbetrachtung mit P-AXIS-00003 (a_emergency) durchführen.
Parameter | kenngr.coll_use_a_emergency
Beschreibung | Zur Berechnung der Bremswege und zum Abbremsen der Achsen bei erkannter Kollision wird P-AXIS-00003 anstelle von P-AXIS-00008 verwendet.
Datentyp | BOOLEAN
Datenbereich | 0: Kollisionsüberwachung mit P-AXIS-00008 (a_max). 1: Kollisionsüberwachung mit P-AXIS-00003 (a_emergency).
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | -