Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Overview

INSYS Modem 56k small INT 2.0

Einleitung

Dieses Applikations- Beispiel demonstriert wie aus der TwinCAT PLC über die Serielle- Schnittstelle mit einem INSYS Modem 56k small INT 2.0 kommuniziert und mittels AT Befehlen eine SMS über das Festnetz versendet werden kann.

Des Weiteren beschreibt dieses Applikationsbeispiel auch wie mit dem INSYS Modem 56k small INT 2.0 eine SMS ans Festnetz geschickt und anschließend zur E-Mail umgewandelt weiter an ihren Bestimmungsort gesandt wird.


Requirements

Voraussetzungen

  • Microsoft Windows mit TwinCAT PLC (ab Version 2.10) für die Programmierung und Inbetriebnahme
  • TwinCAT PLC Serial Communication Library
  • BK9000 mit KL6031 und KL9010 oder Embedded-PC (z.B. CX9000) mit N030-Schnittstelle (RS232)
  • Programmierkenntnisse in IEC 61131-3 unter TwinCAT
  • Analoger Telefonanschluss
  • Nummer des Festnetz SMS Services
  • INSYS Modem 56k small INT 2.0
  • INSYS HSComm Modem Konfigurationswerkzeug


Modem Details

Modembeschreibung

Zum Senden einer SMS ins Festnetz wird ein INSYS Modem 56k small INT 2.0 verwendet.
Link zur Herstellerhomepage hier.

INSYS Modem 56k small:
• schmale Bauform
• RS232 Schnittstelle
• Versand von Meldungen per AT-Befehl
• INSYS Modem 56k small INT: international einsetzbar

Technische Daten

Netzschnittstelle, Leitungsanforderung | analoges Telefonnetz
Übertragungsgeschwindigkeit | bis zu 56 kbps
Software update | flash (INT), patch (EU)
Zulassungen | R&TTE, CTR21
Einsatz | INSYS Modem 56k small INT: international einsetzbar
Vorschriften | entwickelt nach den geltenden CE Richtlinien, Fertigung nach ISO 9002
Features |
Konfiguration | INSYS Modem 56k small INT: Parametriersoftware unter Windows, AT-Befehle, Fernkonfiguration
Verbindung | automatische Rufannahme, Hardware-/Software-Handshake, Geschwindigkeit fest einstellbar, Sleep Modus, Autobauding, Rufnummernanzeige
Datenformate | 10 and 11 bit: 7E1, 7O1, 7N2, 7E2, 7O2, 8N1, 8E1, 8O1, 8N2
Protokolle | V.90, V.34+, V.34, V.32bis, V.32, V.23, V.22bis, V.22, V.21, Bell Norm 103/212, Fax Class 1/2
Kompression | MNP5, V.42bis LAPM, MNP 10, 10 EC, V.44
Fehlerkorrektur | MNP 2/3/4 und V.42
Sicherheitsfunktionen | INSYS Modem 56k small INT: Security Callback, Security Callback an Anrufer (mit Caller ID), Passwortschutz für Datenverbindung, selektive Rufannahme (mit Caller ID)
Alarmfunktion | INSYS Modem 56k small INT: SMS-Versand per AT-Befehl (auch an Fax/E-Mail)
Elektrische Merkmale |
Spannungsversorgung | 10…32 VDC
Stromaufnahme | 140 mA
Anwendungsschnittstelle | RS232, 9 polige SUB-D-Buchse
Netz-Schnittstelle | RJ-12 (Western)
Physikalische Merkmale |
Größe | (BxLxH) 23×110×75 mm
Betriebstemperatur | 0…+55 °C
Luftfeuchtigkeit | 0…95% (nicht kondensierend)


Modem Settings

Modemeinstellung

Laden Sie die Konfigurations- Software HSComm von der INSYS Homepage.

1. Verbinden Sie Ihren PC mit dem Modem wie im INSYS Modem Handbuch beschrieben.

2. Nach der Installation starten Sie die Konfigurations- Software HSComm.

3. Lassen Sie das automatische Auslesen der aktuell eingestellten Parameter durchlaufen.

4. Gleichen Sie die Parameter Ihres Modems wie folgend an.

  1. serielle Schnittstelle
    • Handshake: RTS/CTS
    • DTR Behandlung: Auflegen
    • Initialisierungsstring: frei lassen
  2. Telefonschnittstelle
    • Fehlerkorrektur: V.42 oder MNP4 gewünscht
    • internationale Einstellungen: TBR21 (Europa)
    • Wähltonerkennung: abwählen
    • automatische Rufannahme nach ( auf den wert 5 setzen) x Klingeln.
  3. Zugriffsschutz
    • kein Zugriffsschutz
    • Echo: abwählen
    • V: auswählen
    • Q: abwählen

5. Gleichen Sie die Alarmfunktionsparameter ihres Modems wie folgend an.

  1. Aktion bei Alarm
    • Alarmierung: Alarmierung aktiv
    • Verbindungsart: SMS an Festnetz
    • Zeichen für Amtsholung: Achten Sie darauf ob Sie ein Zeichen für die Amtsholung benötigen.
    • Telefonnummer: erhält keinen Wert
    • Service Center Nummer: Entnehmen Sie bitte die für Sie geeignete Service Center Nummer der Provider Liste. Sollte ihr Provider nicht aufgelistet sein, wenden sie sich bitte direkt an den Providers.
    • FAX- Sammelmeldung: abgewählt
    • Anwahlversuche: 3
    • Alarmtext: erhält keinen Wert

6. Senden Sie die neuen Parameter zum Modem.

Siehe auch

Provider Liste


ConnectionToN030

Anschluss an die CXxxxx-N030 Schnittstelle eines Embedded-PC's (z.B. CX9000, CX9001, CX9010, CX1xxx, ... )

Das INSYS 56K Small Modem besitzt eine 9-polige RS232 D-Sub Buchse. Von den 9 Leitungen werden nur 4 Leitungen zur Kommunikation verwendet.

Beachten Sie unbedingt die Installationshinweise des Herstellers und entnehmen Sie der unten stehenden Tabelle die Belegung der Buchse.

Schließen Sie das Modem an den CX1010-N030 an, wie im Bild dargestellt:

INSYS Modem 56k small INT 2.0 D-Sub Buchsen Belegung!

Einstellungen der Schnittstelle

Stellen Sie die N030-Schnittstelle im TwinCAT System Manager auf folgende Werte ein:

  • 64 Datenbytes im Prozessabbild
  • RS232
  • 38400 Baudrate
  • 8 Datenbits
  • Parität Gerade
  • 1 Stoppbit


ConnectionToKL6031

Anschluss an eine KL6031

Das INSYS 56K Small Modem besitzt eine 9-polige RS232 D-Sub Buchse. Von den 9 Leitungen werden nur 4 Leitungen zur Kommunikation verwendet.

Beachten Sie unbedingt die Installationshinweise des Herstellers und entnehmen Sie die Belegung der 9-poligeb RS232 D-Sub Buchse der unten stehenden Tabelle.

Schließen Sie das Modem auf folgende Weise an die Klemme KL6031 an:

INSYS Modem 56k small INT 2.0 D-Sub Buchsen Belegung.

Einstungen der Klemme

Stellen Sie die Klemme KL6031 mit Hilfe der KS2000 Software auf folgende Werte ein:

  • 22 Datenbytes im Prozessabbild
  • RTS / CTS
  • 38400 Baud
  • 8 Datenbits
  • Keine Parität
  • 1 Stoppbit

Alternativ hierzu können Sie auch die Klemme aus dem SPS-Programm heraus konfigurieren (siehe Beispielprogramm). Hierdurch entfällt das Einstellen der Klemme mit der KS2000.


Providerlist

Providerliste zum SMS an Mobilnetz oder Festnetz

Im Folgenden finden Sie eine Überblick über die wichtigsten Mobilfunk-Provider in Deutschland, Österreich und der Schweiz (Stand 2007).
Alle Angaben sind ohne Gewähr von Richtigkeit und Vollständigkeit.

Die angegebenen Nummern sind ggf. nur für bestimmte Verträge mit dem Netzbetreiber gültig.

Land | Betreiber | Netzt | SMS Service Center Nummer (SCN) | Fax-Präfix | Nummer des E-Mail-Gateways
D | T-Moblie | T-D1 | +49 171 076 0000 +49 171 076 2522 | 99 (deutsch) 98 (englisch) | 80000
D | Vodafone D2 | D2 Vodafone | +49 172 227 0000 +49 172 227 0042 +49 172 227 0111 +49 172 227 0010 +49 172 227 0222 +49 172 227 0333 | 99 | 3400
D | E-plus | E-plus | +49 177 060 0000 +49 177 061 0000 +49 177 061 0000 | 1551 | 767 62 45
D | O2 | O2 | +49 176 0000 443 +49 176 0000 433 | 329 | 6245
A | max.mobile |  | +43 676 021 | 6762 | 6761
A | One(Connect) |  | +43 699 000 1999 | - | -
CH | Orange | Orange | +41 78 777 7070 |  |
Ch | Swisscom | Swiss GSM | +41 79 499 900 0 +41 79 499 812 3 |  |
CH | TDC | sunrise | +41 76 598 0000 |  |


Sampels

Programmbeispiele

Zum Senden einer SMS wird eine Zeichenfolge mit dem Text und der Nummer des Empfängers zusammengesetzt.

Beachten Sie bitte das die Zeichenfolge von Provider zu Provider unterschiedlich sein kann und dementsprechend angepasst werden muss.

Wie die Zeichenfolge zu ihrem Provider zusammengesetzt wird, entnehmen Sie bitte der Modem Beschreibung.

  1. Senden einer SMS über einen Festnetzanschluss

    • Programm für N030
    • Programm für KL6031

  2. Senden einer SMS als E-Mail über einen Festnetzanschluss

    • Programm für N030
    • Programm für KL6031


Voraussetzungen

Im folgenden Anwendungsbeispiel wird die Anbindung eines INSYS MoRoS ISDN 1.3 mit einem CX9010 und einem PC beschrieben.

  • Microsoft Windows mit TwinCAT PLC (ab Version 2.10)
  • PC und Embedded-PC CX9010
  • ISDN-Telefonanschluss
  • INSYS MoRoS ISDN 1.3

Informationen zum Modem INSYS MoRoS ISDN 1.3 finden Sie auf der INSYS Homepage.


Kommunikationsprinzip

Das folgende Schaubild zeigt über welche Kommunikationswege bzw. IP-Adressvergaben die Kommunikation zwischen dem PC einem Modem und einem CX stattfindet


Router Konfiguration

1. Verbinden Sie zur Konfiguration des MoRoS ISDN 1.3 Routers Ihren PC über das Netzwerk, wie in der MoRoS Dokumentation beschrieben.

2. Öffnen Sie das Webinterface des Modems.
Default-IP: 192.168.1.1
Benutzername: insys
Passwort: moros
Rufen Sie im Webbrowser die Konfigurationsseite des MoRoS auf:

3. Parametrieren Sie die IP-Adressen für die angeschlossenen Geräte am 4-Port-Switch:

4. Richten Sie die Dial-In Verbindung ein

5. Aktivieren und parametrieren Sie das Portforwarding:


Routing Einstellung

Eingesetzt wird ein PC mit dem eine Verbindung zu einem CX9010 hergestellt wird.

AmsNetId – PC: 10.7.16.9.1.1
AmsNetId – CX: 5.2.70.151.1.1
Die Routen können entweder über den „Add Route“ – Dialog im TwinCAT System Manager oder aber per Hand eingetragen werden.
Für das automatische Eintragen über den „Add Route“ – Dialog ist jedoch die durch das Modem vergebene IP-Adresse oder aber die im CX fest eingestellte IP-Adresse erforderlich.

Das nachfolgende Beispiel zeigt das Eintragen der Routen per Hand und den Verbindungsaufbau über eine DFÜ-Netzwerkverbindung.

1. Richten Sie die Route in dem PC zu dem CX9010 ein.
Öffnen Sie hierzu den TwinCAT – Router und fügen Sie einen neuen Eintrag hinzu

Der Name kann beliebig gewählt werden. Unter „AMS Net Id“ wird die AmsNetId des CX9010 eingetragen. Die Adresse entspricht nicht der tatsächlichen IP-Adresse des CX sondern der konfigurierten PPP-Verbindungsadresse „Eigene IP-Adresse“ im Menü „Dial-In“ im MoRos.

2. Richten Sie anschließend die Route im CX9010 zum PC ein.
Hierzu öffnen Sie auf dem CX den Explorer und navigieren sich zu Hard Disk\System\TcAmsRemoteMgr.exe und starten das Programm.

Gehen Sie dort auf Add und fügen Sie die Route zu Ihrem PC ein.

Der Name kann beliebig vergeben werden. Unter „AMS Net Id“ wird die AmsNetId des PCs eingetragen. Die Adresse entspricht der IP-Adresse des Modems wie unter Modem-Konfiguration Punkt 2. beschrieben.

3. Starten Sie den CX neu. Starten Sie ebenfalls den TwinCAT Router auf dem PC neu (System->Restart/Config).
4. Richten Sie anschließend die Modemverbindung per DFÜ Netzwerk auf dem PC ein.
Hierzu gehen Sie in die Netzwerkverbindungen und richten eine neue Verbindung ein.
Wählen Sie in den folgenden Dialogen das Erstellen einer DFÜ-Verbindung aus.

Benutzername und Passwort entsprechen den Einstellungen unter Modem-Konfiguration Punkt 4.