Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


SmartDriveMX

Beckhoff Knowledge Base: HORA SmartDrive MX

Einleitung

Im Folgenden wird gezeigt, wie Sie einen Heizkörperstellantrieb der Firma HORA (www.hora.de) an die Beckhoff Hardware anbinden und zwischen TwinCAT kommunizieren können.

Beispiel: SmartDrive MX und BC9191

Dieses Beispiel zeigt ein einfaches SPS-Programm, wie ein HORA Heizkörperstellantrieb SmartDrive MX über EnOcean angesprochen werden kann.

Beispieldateien entpacken

Hardware

Einrichtung der Komponenten

Es wird folgende Hardware benötigt:

  • 1x Busklemmen Controller BC9191 mit CAN-Bus
  • 1x EnOcean-Sender und -Empfänger KL6583-0000
  • 1x HORA Heizkörperstellantrieb SmartDrive MX
  • 1x Endklemme KL9010

Richten Sie die EnOcean Hardware und die HORA Komponenten, wie in den entsprechenden Dokumentationen beschrieben, ein.

Dieses Beispiel geht davon aus, dass die EnOcean Id vom Heizkörperstellantrieb bekannt ist.

Software

Erläuterungen zum SPS-Programm sind als Kommentare im Quellcode zu finden.

Beispiel: SmartDrive MX und CX5010

Dieses Beispiel zeigt ein einfaches SPS-Programm, wie ein HORA Heizkörperstellantrieb SmartDrive MX über EnOcean angesprochen werden kann.

Beispieldateien entpacken

Hardware

Einrichtung der Komponenten

Es wird folgende Hardware benötigt:

  • 1x Embedded PC CX5010
  • 1x EnOcean-Masterklemme KL6581
  • 1x EnOcean-Sender und -Empfänger KL6583-0000
  • 1x HORA Heizkörperstellantrieb SmartDrive MX
  • 1x Endklemme KL9010

Richten Sie die EnOcean Hardware und die HORA Komponenten, wie in den entsprechenden Dokumentationen beschrieben, ein.

Dieses Beispiel geht davon aus, dass die EnOcean Id vom Heizkörperstellantrieb bekannt ist.

Software

Erläuterungen zum SPS-Programm sind als Kommentare im Quellcode zu finden.