Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Kommunikation mit Cross Point XM3 Card Reader

Beckhoff Knowledge Base: Kommunikation mit Cross Point XM3 Card Reader

Einführung

Im Folgenden wird ein Beispiel gezeigt, wie Sie zwischen TwinCAT und dem XM3 Card Reader der Firma Cross Point (www.crosspoint.nl) kommunizieren können.
Das Beispiel beschränkt sich hierbei auf die Grundfunktionen, die notwendig sind um den XM3 Card Reader in eine Applikation einzubinden.

TwinCAT fragt zyklisch den Kartenleser nach einer Karte ab. Wurde diese am Kartenleser erkannt, so wird die Überprüfung der Kartennummer auf Gültigkeit in TwinCAT durchgeführt. Dem entsprechend wird am Kartenleser eine LED gesetzt oder ein Signalton ausgegeben. Das eventuelle Öffnen der Tür könnte hierbei mit einer digitalen Ausgangsklemme (z.B. KL2622) realisiert werden.

Voraussetzungen

  • Microsoft Windows 2000/XP/2003/CE
  • TwinCAT PLC (ab Version 2.10)
  • TwinCAT PLC Serial Communication Library
  • BC9000 mit KL6021, KL9512 und KL9010.
  • Programmierkenntnisse mit dem TwinCAT PLC-Control
  • XM3 Card Read der Firma Cross Point

Anschluss des Kartenlesers

Schließen Sie den XM3 Card Reader auf folgende Weise an die Klemmen an:

Die KL9512 wird für die 12V DC-Versorgung des XM3 Card Reader benutzt.

Einstellen der Klemmen

Stellen Sie bitte die KL6021 Klemme mit Hilfe der KS2000 Software oder Registerkommunikation auf folgende Werte ein:

  • 5 Datenbytes im Prozessabbild
  • Halbduplex
  • 9600 Baud
  • 8 Datenbits
  • Keine Parität
  • 1 Stopbit

Kommunikationsbeispiele

Das folgende Beispiel bezieht sich auf die Beispiel-Applikation "Cross Point Sample.zip". Der XM3 Card Reader hat hierbei die Adresse 1:

Funktionsbaustein | XM3-Command | Anfrage an XM3 (in HEX) | Rückgabe von XM3 (in HEX) | Bedeutung
FB_XM3_SetLED | CM1 | 01 04 02 F8 | FE FE FF | Grüne LED an
FB_XM3_SetLED | CM1 | 01 04 04 FE | FE FE FF | Rote LED an
FB_XM3_SetLED | CM1 | 01 04 00 FA | FE FE FF | Alle LEDs ausschalten
FB_XM3_SetBeep | CM2 | 01 05 02 F9 | FE FE FF | Piep an
FB_XM3_SetBeep | CM2 | 01 05 08 F3 | FE FE FF | Piep aus
FB_XM3_SetBeep | CM2 | 01 05 00 FB | FE FE FF | Alle Geräusche ausschalten
FB_XM3_GetCardId | EC3 | 01 0B 03 9A 01 00 6D | FE FB 08 1A 00 00 00 00 00 00 00 E8 | Abfragen, ob Karte anliegt (hier: keine Karte anliegend)
FB_XM3_GetCardId | EC3 | 01 0B 03 9A 01 00 6D | FE FB 08 1A 00 88 52 00 00 00 80 B2 | Abfragen, ob Karte anliegt (hier: Karte anliegend)
FB_XM3_GetCardId | EN2 | 01 03 FD | FE FC D0 00 52 88 F7 01 01 FF FE FE FF | Auslesen der Kartennummer (hier: 00 52 88)

Hinweis: Weitere Informationen zu den RS485-Protokoll des XM3 Card Readers erhalten sie bei der Firma Cross Point (www.crosspoint.nl).

Beispiel-Applikation

Die Erstellung des SPS-Programms entnehmen Sie bitte dem nachfoldenden Beispiel:

Cross Point Sample.zip

Hinweis: Dieses Beispiel ist für die Busklemmen-Controller-Serie BC erstellt worden.