Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Einleitung

Der TwinCAT RemoteManager bietet die Möglichkeit, mehrere unterschiedliche TwinCAT Versionen zu verwalten. Der TwinCAT RemoteManager unterstützt verschiedene Versionen des TwinCAT System Managers und des TwinCAT PLC Controls und erlaubt somit die Nutzung einer exakten Version zur Projekt-Pflege und/oder -Weiterentwicklung auch direkt an Anlagen. Dabei wählt der TwinCAT RemoteManager je nach Targetversion, Projektdatei oder Symbol-Datei die genaue Version der Progammierwerkzeuge aus.

Verfügbare Versionen sind unter "\TwinCAT\Versions\" installiert und werden entweder bei einer aktuellen TwinCAT 2.10 Installation eingerichtet oder stehen mit einer Versions CD zur Verfügung. Der TwinCAT RemoteManager unterstützt ebenfalls bei Auswahl eines Remotesystems ein Upload der Version (nur beim Standardumfang sinnvoll).

Nach dem Start des TwinCAT RemoteManagers stellt dieser eine Versionsübersicht der installierten Komponenten des Systems zusammen:


PLC

Bei den Eigenschaften der PLC stehen nach Auswahl eines Projektes oder Auswahl des Zielsystems Versionsinformationen zur Verfügung. Der TwinCAT RemoteManager stellt die Version dar, mit der das Projekt erstellt bzw. zuletzt übersetzt wurde und wählt die entsprechende Version in der Versionsliste aus. Über den "Start"-Knopf startet das TwinCAT PLC Control der selektierten Version und lädt das PLC Projekt.

Beschreibung der PLC Ansicht im Detail:

  • PLC Control Versions: Liste der verfügbaren PLC Control Versionen (die zum Projekt passende ist vorselektiert)
  • Project: Dateiname des PLC Projektes
  • Path: Pfadinformation zum PLC Projekt
  • Run-Time prj: Falls verfügbar das aktuelle im Zielsystem laufende Projekt
  • Project is created with version: Version mit dem das Projekt erstellt bzw. übersetzt wurde
  • Run-Time No. und Port: Aktuelle Laufzeitsystem-Nummer und Port
  • Number of Run-Times: Anzahl der Laufzeitsysteme
  • Target System: Verwendeter Compiler (x86, C166, ARM)
  • Target Compiler Version: Compiler Version mit dem das Projekt zur PLC geladen wurde
  • PLC Source available: Anzeige, ob ein PLC Projekt als Source auf der PLC verfügbar ist


IO

Bei den Eigenschaften IO stehen nach Auswahl eines Projektes oder Auswahl des Zielsystems Versionsinformationen zur Verfügung. Der TwinCAT RemoteManager stellt die Version dar, mit der das Projekt erstellt wurde und wählt die entsprechende Version in der Versionsliste aus. Über den "Start"-Knopf startet der TwinCAT System Manager der selektierten Version.

Beschreibung der IO Ansicht im Detail:

  • System Manager Versions: Liste der verfügbaren System Manager Versionen (die zum Projekt passende ist vorselektiert)
  • Project: Dateiname der IO Konfiguration
  • Path: Pfadinformation zum IO Projekt
  • Project is created with version: Version mit dem das Projekt erstellt bzw. übersetzt wurde