Übersicht

In dieser Rubrik ist das Thema "Fernwartung" zusammengefaßt.

"Fernwartung" ist ein mit sehr unterschiedlichen, sehr vielfältigen Anforderungen versehenes Themenfeld. Aus einer zunächst sehr einfachen Anforderungen kann häufig auch eine Mischung aus physikalischen Gegebenheiten (LAN / Modem / ..), gepaart mit IT Technologieen (IP Forwarding, VLAN, Routern, ..) und verschiedenen Protokollen (TCP / HTTP) versehen mit unterschiedlichen Programmierplattformen (Java-VM, Ajax, .NET) gewürzt mit unterschiedlichen Betriebssystem (XP, CE..) letzlich eine scheinbar nicht zu lösende Aufgaben entstehen.

In diesem Bereich finden man eine Auflistung von Artikeln zu diesen unterschiedlichen Szenarien.


BECKHOFF Routing über Gateway

BECKHOFF Routing über Gateway PC

Beispiel: ADS Routing via Gateway

In diesem Beispiel wird beschrieben, wie ein ADS-Teilnehmer (z.B. TwinCAT PLC-Control, TwinCAT Systemmanager, Third-Party Scada-Systeme, etc...) in einem heterogenen Netzwerk zu einer TwinCAT-SPS kommunizieren können.

Konkret ist hier das Szenario: Ein "Service-Notebook" (hier nun genannt SN-PC1) aus dem IP-Segment 172.16.5.x soll über einen Gateway-PC (hier nun GW-PC2) mit einem TwinCAT Controller (TC-PC3) kommunizieren.

In diesem Artikel werden die notwendigen hierachischen ADS-Routingeinträge beschrieben. Diese können manuell oder vom "TwinCAT Remote Manager" erzeugt werden.

ADS-Routing: Logische ADS Zieladresse und physikalische (IP) Zieladresse

Hintergrundinformation: ADS ist ein nachrichtenbasierendes Kommunikationssystem. Das Versenden einer ADS Nachricht vom SN-PC1 zum TC-PC3 kann nicht im direkten Eintrag "ADS-NETID und TCPIP von TC-PC3" erfolgen: Die IP Adresse von TC-PC3 ist im IP Segment von SN-PC1 nicht erreichbar.

Aus Sicht vom SN-PC1 ist die auf ADS bezogene "logische Zieladresse" zwar die ADSNetID von TC-PC3, als "physikalische Transport ADresse" ist aber der GW-PC2.

Diese Art der ADS-Routenkonfiguration ist hier genau dokumentiert:

Voraussetzung für alle PCs: TwinCAT 2.10 Build 1244 (oder höher)

ADS-Routing Einstellungen der PC's:

Hinweis: Diese Registryeinträge können manuell eingetragen werden, wir empfehlen jedoch das Tool "TwinCAT Remote Manager"

SN-PC1 (Service Notebook)

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\Remote\GW-PC2]
"Address"="172.16.5.80"
"AmsNetId"=hex:c0,a8,03,50,01,01  -> 192.168.3.80.1.1
...

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\Remote\GW-PC2\TC-PC3]
"Address"="192.168.3.21"
"AmsNetId"=hex:c0,a8,03,15,01,01   -> 192.168.3.21.1.1
...

GW-PC2 (Gateway)

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\Remote\SN-PC1]
"Address"="172.16.5.65"
"AmsNetId"=hex:ac,10,05,41,01,01   -> 172.16.5.65.1.1
...

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\Remote\TC-PC3]
"Address"="192.168.3.21"
"AmsNetId"=hex:c0,a8,03,15,01,01   -> 192.168.3.21.1.1
...

TC-PC3 (TwinCAT Controller)

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\Remote\PC2]
"Address"="192.168.3.80"
"AmsNetId"=hex:c0,a8,03,50,01,01  -> 192.168.3.80.1.1
...

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\Remote\PC2\PC1]
"Address"="172.16.5.65"
"AmsNetId"=hex:ac,10,05,41,01,01   -> 172.16.5.65.1.1
...


BECKHOFF routing via gateway

BECKHOFF routing through a firewall

Szenario: ADS Verbindung durch eine Firewall

Dieses Beispiel dient zur Veranschaulichung wie ein ADS Gerät (z.B. TwinCAT Engineering PC, Visualisierung usw) mit einer TwinCAT Laufzeit durch eine Firewall kommunizieren kann.

Firewallregeln/Portfilter Einstellungen

Es müssen folgende Regeln bzw. Filter für eingehende Verbindungen zur TwinCAT Laufzeit konfiguriert sein, um eine ADS Verbindung aufbauen zu können:

Direction | Port(dec) | Port(hex) | Protocol | Action
Incoming | 48898 | 0xBF02 | TCP | Allow
Incoming | 48899 | 0xBF03 | UDP | Allow