Übersicht BC

Die folgende Auflistung bietet einen Überblick über vorhandene SPS-Bibliotheken mit der Zielplattform BCxxx(165).

Dabei wird unterschieden zwischen

  • "Standard-Bibliotheken": Auslieferung als Bestandteil der verschiedenen TwinCAT-Level
  • "Weitere Bibliotheken": Erhältlich als jeweils separates Produkt
Standard Bibliotheken | Zielplattform | Auslieferung mit | Beschreibung
TwinCAT PLC Lib: System BC | BCxxxx (165) | TwinCAT PLC | Bibliothek mit diversen Funktionen und Funktionsbausteinen für den Zugriff auf Systemfunktionen der SPS Controller (BCxxxx).
TwinCAT PLC Lib: Utilities BC | BCxxxx (165) | TwinCAT PLC | Bibliothek mit diversen nützlichen Funktionsbausteinen (RTC oder DCF77-Dekoder ) für die SPS Controller (BCxxxx).
TwinCAT PLC Lib: Helper BC | BCxxxx (165) | TwinCAT PLC | Bibliothek mit Funktionen für den direkten Zugriff auf Speicherbereiche des SPS-Laufzeitsystems der SPS Controller (BCxxxx).
TwinCAT PLC Lib: ADS BC | BC9000 (165) | TwinCAT PLC | Bibliothek mit ADS-Funktionen für den SPS Controller.
TwinCAT PLC Lib: IP Utilities BC | BC9000 (165) | TwinCAT PLC | Bibliothek mit nützlichen Funktionen zur Netzwerkkonfiguration für den SPS Controller.
TwinCAT PLC Lib: MODBUS TCP BC | BC9000 (165) | TwinCAT PLC | Bibliothek mit Funktionen für den Zugriff auf MODBUS TCP für den SPS Controller.
TwinCAT PLC Lib: SMTP TCP BC | BC9000 (165) | TwinCAT PLC | Bibliothek mit Funktionen für den SMTP Protokoll auf dem SPS Controller.

Weitere Bibliotheken | Zielplattform | Beschreibung
TwinCAT PLC Lib: Serial Communication BC | BCxxxx (165) | Bibliothek mit Bausteinen zur seriellen Kommunikation über Busklemmen für BCxxxx Busklemmen-Controller.
TwinCAT PLC Lib: Serial Communication 3964R BC | BCxxxx (165) | Bibliothek mit Bausteinen zur seriellen Kommunikation mit 3964R-Protokoll über Busklemmen für BCxxxx Busklemmen-Controller.
TwinCAT PLC Lib: Serial Communication RK512 BC | BCxxxx (165) | Bibliothek mit Bausteinen zur seriellen Kommunikation mit RK512-Protokoll über Busklemmen für BCxxxx Busklemmen-Controller.
TwinCAT PLC Lib: Serial Communication Modbus RTU BC | BCxxxx (165) | Bibliothek mit Bausteinen zur seriellen Modbus Kommunikation über Busklemmen. Das verwendete Protokoll ist Modbus-RTU, mit dem sich z. B. Bedienterminals anschließen lassen.
TS4100 | TwinCAT PLC Lib: Controller Toolbox | BCxxxx (165) | Bibliothek mit Bausteinen zur Lösung regelungstechnischer Aufgaben.