Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


TCPlcLibSystemCX9000_Overview

TwinCAT PLC Library: SystemCX9000

Übersicht

In dieser Bibliothek sind Funktionen und Funktionsbausteine enthalten, die spezielle Features auf dem Embedded PC CX9000 nutzen.

Funktionen

Name | Beschreibung
F_CX9000SetWatchdog | Aktiviert/Deaktiviert Hardware Watchdog (Auto-Reboot des CX9000 bei SPS-Problemen)
F_GetVersionTcSystemCX9000 | Mit dieser Funktion können Versionsinformationen der SPS-Bibliothek ausgelesen werden.

Anforderungen

Komponente | Version
TwinCAT auf dem Entwicklungsrechner | 2.10 Build 1316 oder höher
CX9000-Windows CE-Image | 1.5 oder höher


FUNCTION_BLOCK F_CX9000SetWatchdog

TwinCAT PLC Library: SystemCX9000

FUNCTION_BLOCK FB_CX9000SetWatchdog

Die Funktion F_CX9000SetWatchdog aktiviert einen Hardware-Watchdog auf dem CX9000. Der Watchdog wird über bEnable = TRUE und die tTimeOut-Zeit aktiviert. Die tTimeOut-Zeit kann maximal 65 Sekunden und 535 Millisekunden sein.

Wenn der Watchdog einmal aktiviert wurde, muß die Funktion zyklisch in kürzeren Abständen aufgerufen werden als tTimeOut, da bei Ablauf der tTimeOut-Zeit der CX9000 automatisch einen Neustart durchführt. Der Watchdog kann daher dafür eingesetzt werden um Systeme automatisch neu zu Booten, die in eine Endlosschleife gelaufen sind bzw. bei denen die PLC steht.

Der Watchdog kann über bEnable = FALSE bzw. die tTimeOut-Zeit = T#0s deaktiviert werden.

Achtung:
Der Watchdog muß vor der Verwendung von Breakpoints, einem SPS-Reset bzw. Urlöschen und vor einem TwinCAT Stop, einem Wechsel in den Konfig-Mode oder dem Aktivieren der Konfiguration deaktiviert werden, da es sonst unmittelbar zum Reboot des CX9000 nach Ablauf der tTimeOut-Zeit kommt!

FUNCTION F_CX9000SetWatchdog

VAR_INPUT

VAR_INPUT
    tTimeOut		: TIME;
    bEnable 		: BOOL;
END_VAR

tTimeOut : Watchdogzeit, nach deren Ablauf ein Neustart durchgeführt wird.

bEnable : Aktivieren bzw. Deaktivieren des Watchdogs.


FUNCTION F_GetVersionTcSystemCX9000

Mit dieser Funktion können Versionsinformationen der SPS-Bibliothek ausgelesen werden.

FUNCTION F_GetVersionTcSystemCX9000 : UINT

VAR_INPUT
    nVersionElement : INT;
END_VAR

nVersionElement : Versionselement, das gelesen werden soll. Mögliche Parameter:

  • 1 : major number;
  • 2 : minor number;
  • 3 : revision number;
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | PC (i386) | TcSystemCX9000.Lib