Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Übersicht

Die Bibliothek beinhaltet Funktionsbausteine für den Zugriff auf Systemfunktionen der SPS Controller ( BCxxxx Controller ).

Anforderungen

Die Systemfunktionen werden von den SPS Controllern mit folgendem Firmwarestand unterstützt:

BC2000 ab Version : B5

BC3100 ab Version : BF

BC4000 ab Version : B3

BC7300 ab Version : B3

BC8x00 ab Version : B2

BC9000 ab Version : B4

Einige der Funktionen besitzen einen boolischen Eingangsparameter ( bDummy : BOOL ). Dieser Parameter hat für die Funktionsausführung keine Bedeutung und kann beliebig gesetzt werden.

Inhalt der Bibliothek

Funktionen

Name | Beschreibung
GetSysInfo | Liest die Systeminformationen des SPS Controllers
PresetSysTick | Setzt den internen System-Tick des SPS-Controllers
GetSysTick | Liest den internen System-Tick des SPS Controllers
GetFBusStatus | Liest den Feldbusstatus des SPS Controllers
GetTBusStatus | Liest den Klemmenbusstatus
TrigTBusCycle | Triggert den Klemmenbuszyklus
Reboot | Reset des SPS Controllers


GetSysInfo

TwinCAT PLC Library: System BC

FUNCTION GetSysInfo

Mit der Funktion "GetSysInfo" können Systeminformationen des SPS Controllers ausgelesen werden.

FUNCTION GetSysInfo : WORD

VAR_INPUT

VAR_INPUT
    bDummy	: BOOL(*At least one input required for functions*)
END_VAR

Die Systeminformationen sind in dem Rückgabeparameter der Funktion auf folgende Weise verschlüsselt:

Rückgabewert | Beschreibung
Bit 0 gesetzt | Die Feldbus- und Klemmenbus-Statusinformationen sind vorhanden
Bit 1 gesetzt | Der System-Tick ist vorhanden ( Controller mit einer älteren Firmware unterstützen dieses Feature nicht ).
Bit 2 gesetzt | Die SPS-Zykluszeit Watchdog-Überwachung ist aktiviert.
Bit 3 - 15 | reserviert

Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.7.0 und höher | BCxxxx (165) | PlcSystemBC.Lb6


PresetSysTick

FUNCTION PresetSysTick

Mit der Funktion "PresetSysTick" kann der Wert des internen System-Ticks gesetzt werden. Der System-Tick des SPS Controllers ist ein 32Bit Zähler, der jede Millisekunde inkrementiert wird. Beim Erfolg wird der neue Wert des Systems-Ticks als Rückgabeparameter von der Funktion zurückgegeben.

FUNCTION PresetSysTick : DWORD

VAR_INPUT

VAR_INPUT
    iVAlue : DWORD;
END_VAR

iValue: Der neue Wert des System-Ticks.

Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.7.0 und höher | BCxxxx (165) | PlcSystemBC.Lb6


GetSysTick

FUNCTION GetSysTick

Mit der Funktion "GetSysTick" kann der Wert des internen System-Ticks ausgelesen werden. Der System-Tick des SPS Controllers ist ein 32Bit Zähler, der jede Millisekunde inkrementiert wird. Der Zähler wird bei einem Reset oder Power-OFF des Controllers zurückgesetzt, kann aber mit der Funktion PresetSysTick auf einen bestimmten Wert gesetzt werden.

FUNCTION GetSysTick : DWORD

VAR_INPUT

VAR_INPUT
    bDummy	: BOOL(*At least one input required for functions*)
END_VAR
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.7.0 und höher | BCxxxx (165) | PlcSystemBC.Lb6


GetFBusStatus

FUNCTION GetFBusStatus

Die SPS Controller können als Teilnehmer an einem Feldbus angeschlossen werden. Mit der Funktion "GetFBusStatus" kann der Status des Feldbusses ermittelt werden.

FUNCTION GetFBusStatus : WORD

VAR_INPUT

VAR_INPUT
    bDummy	: BOOL(*At least one input required for functions*)
END_VAR

Der Feldbusstatus ist in dem Rückgabeparameter auf folgende Weise verschlüsselt:

Controller Typ | Wert | Beschreibung
BC2000 | 0 | Feldbus OK
 | Bit 0 gesetzt | Feldbusfehler
 | Bit 1 - 15 | reserviert
BC3100 | 0 | Feldbus OK
 | Bit 0 gesetzt | Feldbusfehler
 | Bit 1 - 3 | reserviert
 | Bit 4 - 5 | DP-State: 0: Slave in WAIT-PRM (keine Verbindung zum Master) 1: Slave in WAIT-CFG (Hochlauf) 2: Slave in DATA-EXCH (OK)
 | Bit 6 - 7 | WD-State: 0: Baudrate wird gesucht 1: Baudrate gefunden 2: Ansprechüberwachung aktiviert
 | Bit 8 - 11 | Baudrate: 0: 12 MBaud 1: 6 MBaud 2: 3 MBaud 3: 1.5 MBaud 4: 500 kBaud 5: 187.5 kBaud 6: 93.75 kBaud 7: 45.45 kBaud 8: 19.2 kBaud 9: 9.6 kBaud
 | Bit 12 - 15 | reserviert
BC9000 | Bit 0 gesetzt | Fehler AMS/ADS Kommunikation
 | Bit 1 gesetzt | Fehler MODBUS/TCP
 | Bit 2 - 14 | reserviert
 | Bit 15 gesetzt | kein LINK (keine Kommunikation mit dem Feldbus)

Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.7.0 und höher | BCxxxx (165) | PlcSystemBC.Lb6


GetTBusStatus

FUNCTION GetTBusStatus

Mit der Funktion "GetTBusStatus" kann der Klemmenbusstatus ausgelesen werden.

FUNCTION GetTBusStatus : WORD

VAR_INPUT

VAR_INPUT
    bDummy	: BOOL(*At least one input required for functions*)
END_VAR

Der Rückgabeparameter hat folgende Bedeutung:

Rückgabewert | Beschreibung
Bit 0 gesetzt | allgemeiner K-Bus Fehler
Bit 1 gesetzt | allgemeiner Konfigurationsfehler
Bit 2 - 3 | reserviert
Bit 4 gesetzt | SPS Zykluszeitüberwachung
Bit 5 - 15 | reserviert
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.7.0 und höher | BCxxxx (165) | PlcSystemBC.Lb6


TrigTBusCycle

FUNCTION TrigTBusCycle

Mit der Funktion "TrigTBusCycle" kann aus der SPS-Task ein zusätzlicher Klemmenbuszyklus angestoßen werden.

FUNCTION TrigTBusCycle : INT

VAR_INPUT

VAR_INPUT
    iProcessImage 	: UINT; (* 0-3 *)
END_VAR

iProcessImage: Die Nummer des Prozess-Images. Zulässige Werte 0-3.

Die Fehlercodes sind in dem Rückgabeparameter der Funktion auf folgende Weise verschlüsselt:

Rückgabewert | Beschreibung
0 | kein Fehler
1 | Klemmbusfehler
2 | Der Zugriff wurde verweigert. Klemmenbus ist aktiv.
3 | Process-Image nicht initialisiert
-2 | Unzulässige Nummer für das Process-Image. Erlaubt 0 - 3
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.7.0 und höher | BCxxxx (165) | PlcSystemBC.Lb6


Reboot

FUNCTION Reboot

Die Funktion führt einen Reset des SPS Controllers.

FUNCTION Reboot : WORD

VAR_INPUT

VAR_INPUT
    bDummy	: BOOL(*At least one input required for functions*)
END_VAR
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.7.0 und höher | BCxxxx (165) | PlcSystemBC.Lb6