Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Übersicht

TwinCAT PLC Bibliothek: MP-Bus

Einleitung

Die MP-Bus-Bibliothek ist eine TwinCAT SPS Bibliothek zum Datenaustausch mit MP-Bus Geräten.

Diese Bibliothek ist nur in Verbindung mit einer MP-Bus-Masterklemme KL6771 einzusetzen.


Zielgruppen

Diese Softwarebibliothek ist für Gebäudeautomation-Systempartner der Beckhoff Automation GmbH. Die Systempartner sind tätig in dem Bereich Gebäudeautomation und beschäftigen sich mit Errichtung, Inbetriebsetzung, Erweiterung, Wartung und Service von mess-, steuer- und regelungstechnischen Anlagen der technischen Gebäudeausrüstung.


Anforderungsprofil des Anwenders

Für den Nutzer dieser Bibliothek werden folgende Grundkenntnisse vorausgesetzt:

  • TwinCAT PLC Control
  • TwinCAT System Manager
  • PC und Netzwerkkenntnisse
  • Aufbau und Eigenschaften der Beckhoff Embedded-PC und deren Busklemmensystem.
  • Technologie von MP-Bus Geräten
  • Einschlägige Sicherheitsvorschriften der technischen Gebäudeausrüstung


Einführung

MP-Bus = Multi-Point Bus

Der MP-Bus (Multi-Point) ist ein einfacher Sensor-/Aktor-Bus, welcher für bestimmte Gewerke der Gebäudeautomation genutzt wird. Der MP‑Bus dient zur Steuerung von Stellantrieben im HLK-Bereich, für Klappen, Regelventile und Volumenstromregler aus dem Produktportfolio von Belimo. Es können bis zu acht unterschiedliche Geräte aus dem Bereich HLK in 3‑Leitertechnik an einen MP‑Bus-Master angeschlossen werden. Zusätzlich kann an jeden dieser acht Teilnehmer ein Sensor angeschlossen werden, der durch den MP‑Bus angesprochen wird. Eine zusätzliche Produktreihe mit MP‑Bus-Anschluss ist das Fensterlüftungssystem FLS von Belimo (Anschluss der Belimo-Antriebe siehe Dokumentation Belimo).

Der MP‑Bus wurde von der Firma Belimo für den Anschluss von Ventilen, Drossel-, Lüftungs- und Brandschutzklappen sowie für Fensterlüftungssysteme entwickelt.


Topologie

Es gibt keinerlei Einschränkungen bzgl. des topologischen Aufbaus der MP‑Bus-Stränge: Stern-, Ring-, Baum- oder gemischte Topologien sind möglich. Die Länge des gesamten Busstrangs ist abhängig vom gewählten Kabelquerschnitt und Art sowie Anzahl der angeschlossenen Antriebe! Weitere Informationen enthält die Dokumentation der Firma Belimo.


Programmierung

Inhalt
Allgemeine Informationen
Verknüpfung mit dem TwinCAT System Manager

Bausteine

Bausteine | Beschreibung
KL6771 | Kommunikation mit einer MP-Bus-Masterklemme KL6771.

Funktionsbausteine

Bausteine | Beschreibung
MP_DamperLinearActuator | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Klappen- und Hubventilantrieb.
MP_EV | Dieser Funktionsbaustein dient der Ansteuerung eines Regelkugelhahn der Baureihe P6..W..EV-BAC.
MP_MPX | Für BELIMO Raum Sensor MS24A-R..-MPX
MP_PTH | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines PTH Sensors.
MP_Smoker | Dieser Funktionsbaustein dient zur Steuerung und Überwachung einer Brandschutzklappe.
MP_UST_3 | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Multi IO Moduls UST3.
MP_VAV | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Volumenstromreglers.
MP_Window | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Fensterlüfungssystems FLS.
MPL_DamperLinearActuator | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Klappen- und Hubventilantrieb.

Funktionen

Bausteine | Beschreibung
NI1000_LuS_TO_INT | Diese Funktion berechnet aus einem Widerstand NI1000 L&S eine Temperatur
NI1000_TO_INT | Diese Funktion berechnet aus einem Widerstand NI1000 eine Temperatur.
NTC_TO_INT | Diese Funktion berechnet aus einem Widerstand NTC eine Temperatur
PT1000_TO_INT | Diese Funktion berechnet aus einem Widerstand PT1000 eine Temperatur

Slave Adressierung

Bausteine | Beschreibung
MP_Addressing | Dieser Funktionsbaustein ermöglicht das Adressieren eines MP-Bus Slaves.

Enums

Datentypen | Beschreibung
Data_Window | Lüftungsart
MP_Error | Fehlermeldungen
UST3_Ex | Skalierung der Spannung
UST3_R_set | Skalierung des Widerstandes

Strukturen

Datentypen | Beschreibung
DataKL6771 | Verbindet die Sende- und Empfangs-Bausteine mit dem Baustein KL6771
MP_BUS_MPX_ERROR | Fehlermeldungen der "MPX" Senoren
MP_Serial_Number | Seriennummer des Gerätes
UST3_SET | Datenstruktur zur Einstellung der Skalierung und dem Einstellen der Widerstandsmessung


Allgemeine Informationen

Hinweis 		Installation
Ab TwinCAT 2.11 Build 2229 (R3 und x64 Engineering) werden die Bibliotheken "TcMPBus.lib/.lb6/.lbx" standardmäßig mitinstalliert.

Hinweis 		Name der Bibliothek
Diese Bibliothek ersetzt die "TcKL6771.lib/.lb6./.lbx". Es hat sich nur der Name der Bibliothek geändert. Die Bausteine sind kompatibel.

Hardware Dokumentation im Beckhoff Information System: KL6771 - MP-Bus-Masterklemme

Weitere erforderliche Bibliotheken

Für PC-Systeme (x86) und Embedded-PCs (CXxxxx):

  • Standard.lib
  • TcBase.lib
  • TcSystem.lib

Für Busklemmen-Controller der Serie BCxx00:

  • Standard.lb6
  • PlcHelperBC.lb6

Für Busklemmen-Controller der Serie BCxx50, BCxx20 und BC9191:

  • Standard.lbx
  • TcBaseBCxx50.lbx
  • TcSystemBCxx50.lbx

Für Busklemmen-Controller der Serie BXxx00:

  • Standard.lbx
  • TcBaseBX.lbx
  • TcSystemBX.lbx

Hinweis 		Speicherauslastung
Durch Einbinden der Bibliothek wird bereits SPS-Programmspeicher verbraucht. Abhängig vom Applikationsprogramm kann daher der verbleibende Speicher nicht ausreichend sein.


KL6771 - Verknüpfung mit dem TwinCAT System Manager

Wie verknüpfe ich die KL6771 mit dem System Manager?

Bild 1

Wählen Sie "All Types" und "Continuous" an (siehe Bild 2).

Bild 2

Klicken Sie mit der Maus auf die erste Variable der KL6771 "Parameter Status" an. Drücken Sie dann die >SHIFT< Taste und halten Sie diese gedrückt. Gehen Sie mit dem Mauszeiger auf die letzte Variable der KL6771 "Input Data 10" und klicken Sie wiederum die linke Maustaste. Jetzt lassen Sie die >SHIFT< Taste wieder los. Alle Daten der Klemme müssen jetzt markiert sein (siehe Bild 3). Anschließend den Button "OK" drücken.

Bild 3

Sie können die Verknüpfung jetzt kontrollieren. Gehen Sie dazu auf die KL6771 und öffnen Sie diese. Alle Daten der Klemme müssen jetzt mit einem kleinen Pfeil markiert sein (siehe Bild 4). Ist dies der Fall fahren Sie genauso mit den Ausgängen fort.

Bild 4


Integration in TwinCAT (CX9020)

Dieses Beispiel beschreibt, wie ein einfaches SPS-Programm für MP-Bus in TwinCAT geschrieben werden kann und wie es mit der Hardware verknüpft wird. Es soll ein einzelner Klappenantrieb angesteuert und per Taster verändert werden.

Beispieldateien entpacken

Hardware

Einrichtung der Komponenten

Es wird folgende Hardware benötigt:

  • 1x Busklemmen Controller CX9020
  • 1x Digitale 2-Kanal-Eingangsklemme KL1002 (für die Öffnen und Schließen Funktion)
  • 1x MP-Bus-Masterklemme KL6771
  • 1x Endklemme KL9010

Richten Sie die Hardware sowie die MP-Bus-Komponenten wie in den entsprechenden Dokumentationen beschrieben ein.

Dieses Beispiel geht davon aus, dass die Adresse vom Klappenantrieb bekannt ist.

Software

Erstellung des SPS-Programms

Erstellen Sie ein neues SPS-Projekt für PC-basierte Systeme (ARM) und fügen die Bibliothek TcMPBus.lib hinzu.

Erzeugen Sie als Nächstes die folgenden globalen Variablen:

VAR_GLOBAL
    bOpen           AT %I* : BOOL;
    bClose          AT %I* : BOOL;
    arrKL6771_IN    AT %I* : ARRAY[0..11] OF BYTE;
    arrKL6771_OUT   AT %Q* : ARRAY[0..11] OF BYTE;
    stDataKL6771           : DataKL6771;
END_VAR

bOpen: Eingangsvariable für den Öffnen-Taster.

bClose: Eingangsvariable für den Schließen-Taster.

arrKL6771_IN: Eingangsvariable für die MP-Bus-Klemme.

arrKL6771_OUT: Ausgangsvariable für die MP-Bus-Klemme.

stDataKL6771: Wird für die Kommunikation mit MP-Bus benötigt (siehe DataKL6771).

Alle Bausteine bei MP-Bus müssen in einer Task ausgeführt werden.

Legen Sie daher ein MAIN-Programm (CFC) an in dem die Bausteine KL6771() und MP_DamperLinearActuator aufgerufen werden. Achten Sie beim Kommunikationsbaustein darauf, mit arrKL6771_IN, arrKL6771_OUT und stDataKL6771 zu verknüpfen.

Der Eingang SetPoint wird in Abhängikeit der gewählten Funktion gesetzt. Verknüpfen Sie dazu die globalen Variablen bOpen und bClose mit einer Hilfsvariable.

Gehen Sie in die Taskkonfiguration und geben Sie der Task eine niedrigere Intervall-Zeit. Genauere Informationen dazu finden Sie in der Beschreibung des Bausteins KL6771().

Laden Sie das Projekt als Bootprojekt auf den CX und speichern Sie es ab.

Konfiguration im System Manager

Legen Sie ein neues System-Manager-Projekt an, wählen Sie als Zielsystem den CX und lassen Sie nach dessen Hardware suchen.

Fügen Sie das oben angelegte SPS-Programm unter SPS-Konfiguration hinzu.

Verknüpfen Sie die globalen Variablen des SPS-Programms nun mit den Ein- und Ausgängen der Busklemmen, erzeugen Sie die Zuordnungen und aktivieren Sie die Konfiguration. Starten Sie dann das Gerät im Run-Modus.
Ihr CX ist jetzt einsatzbereit.

Nach Betätigen der Taster kann der Klappenantrieb gefahren werden. Die aktuelle Position steht in der Variable wActValue.


Integration in TwinCAT (BC9191)

Dieses Beispiel beschreibt, wie ein einfaches SPS-Programm für MP-Bus in TwinCAT geschrieben werden kann und wie es mit der Hardware verknüpft wird. Es soll ein einzelner Klappenantrieb angesteuert und per Taster verändert werden.

Beispieldateien entpacken

Hardware

Einrichtung der Komponenten

Es wird folgende Hardware benötigt:

  • 1x Busklemmen Controller BC9191
  • 1x Potenzialeinspeiseklemme 24V DC
  • 1x Digitale 2-Kanal-Eingangsklemme KL1002 (für die Öffnen und Schließen Funktion)
  • 1x MP-Bus-Masterklemme KL6771
  • 1x Endklemme KL9010

Richten Sie die Hardware sowie die MP-Bus-Komponenten wie in den entsprechenden Dokumentationen beschrieben ein.

Dieses Beispiel geht davon aus, dass die Adresse vom Klappenantrieb bekannt ist.

Software

Erstellung des SPS-Programms

Erstellen Sie ein neues SPS-Projekt für BC-basierte Systeme (BCxx50 über AMS) und fügen die Bibliotheken TcMPBus.lbx und TcSystemBCxx50.lbx hinzu. Gehen Sie danach im Menü auf Projekt → Optionen... → Übersetzungsoptionen und wählen LREAL als REAL übersetzen an.

Erzeugen Sie als Nächstes die folgenden globalen Variablen:

VAR_GLOBAL
    bOpen           AT %I* : BOOL;
    bClose          AT %I* : BOOL;
    arrKL6771_IN    AT %I* : ARRAY[0..11] OF BYTE;
    arrKL6771_OUT   AT %Q* : ARRAY[0..11] OF BYTE;
    stDataKL6771           : DataKL6771;
END_VAR

bOpen: Eingangsvariable für den Öffnen-Taster.

bClose: Eingangsvariable für den Schließen-Taster.

arrKL6771_IN: Eingangsvariable für die MP-Bus-Klemme.

arrKL6771_OUT: Ausgangsvariable für die MP-Bus-Klemme.

stDataKL6771: Wird für die Kommunikation mit MP-Bus benötigt (siehe DataKL6771).

Alle Bausteine bei MP-Bus müssen in einer Task ausgeführt werden.

Legen Sie daher ein MAIN-Programm (CFC) an in dem die Bausteine KL6771() und MP_DamperLinearActuator aufgerufen werden. Achten Sie beim Kommunikationsbaustein darauf, mit arrKL6771_IN, arrKL6771_OUT und stDataKL6771 zu verknüpfen.

Der Eingang SetPoint wird in Abhängikeit der gewählten Funktion gesetzt. Verknüpfen Sie dazu die globalen Variablen bOpen und bClose mit einer Hilfsvariable.

Gehen Sie in die Taskkonfiguration und geben Sie der Task eine niedrigere Intervall-Zeit. Genauere Informationen dazu finden Sie in der Beschreibung des Bausteins KL6771().

Laden Sie das Projekt als Bootprojekt auf den BC und speichern Sie es ab.

Konfiguration im System Manager

Legen Sie ein neues System-Manager-Projekt an, wählen Sie als Zielsystem den BC und lassen Sie nach dessen Hardware suchen.

Fügen Sie das oben angelegte SPS-Programm unter SPS-Konfiguration hinzu.

Verknüpfen Sie die globalen Variablen des SPS-Programms nun mit den Ein- und Ausgängen der Busklemmen, erzeugen Sie die Zuordnungen und aktivieren Sie die Konfiguration. Starten Sie dann das Gerät im Run-Modus.
Ihr BC ist jetzt einsatzbereit.

Nach Betätigen der Taster kann der Klappenantrieb gefahren werden. Die aktuelle Position steht in der Variable wActValue.


Bausteine

Bausteine | Beschreibung
KL6771 | Kommunikation mit einer MP-Bus-Masterklemme KL6771.

Funktionsbausteine

Bausteine | Beschreibung
MP_DamperLinearActuator | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Klappen und Hubventilantrieb.
MP_EV | Dieser Funktionsbaustein dient der Ansteuerung eines Regelkugelhahn der Baureihe P6..W..EV-BAC.
MP_MPX | Für BELIMO Raum Sensor MS24A-R..-MPX
MP_PTH | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines PTH Sensors.
MP_Smoker | Dieser Funktionsbaustein dient zur Steuerung und Überwachung einer Brandschutzklappe.
MP_UST_3 | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Multi IO Moduls UST3.
MP_VAV | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Volumenstromreglers.
MP_Window | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Fensterlüfungssystems FLS.
MPL_DamperLinearActuator | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Klappen und Hubventilantrieb.

Funktionen

Bausteine | Beschreibung
NI1000_LuS_TO_INT | Diese Funktion berechnet aus einem Widerstand NI1000 L&S eine Temperatur
NI1000_TO_INT | Diese Funktion berechnet aus einem Widerstand NI1000 eine Temperatur.
NTC_TO_INT | Diese Funktion berechnet aus einem Widerstand NTC eine Temperatur
PT1000_TO_INT | Mit dieser Funktion berechnet aus einem Widerstand PT1000 eine Temperatur

Slave Adressierung

Bausteine | Beschreibung
MP_Addressing | Dieser Funktionsbaustein ermöglicht das Adressieren eines MP-Bus Slaves.


KL6771

Anwendung

Dieser Funktionsbaustein übernimmt die Kommunikation mit der MP-Bus-Masterklemme KL6771. Über diesen Baustein wird die KL6771 konfiguriert und der Datenaustausch mit dem MP-Netzwerk gestartet.

Einschränkungen:

  • Dieser Baustein darf nur einmal pro KL6771 aufgerufen werden!

  • Im PLC-Projekt darf dieser Baustein nur einmal pro Zyklus aufgerufen werden!

VAR_INPUT

KL6771_IN          : ARRAY [0..11] OF BYTE;

KL6771_IN: Wird mit dem Eingangsprozessabbild der MP-Bus-Masterklemme verbunden.

VAR_OUTPUT

KL6771_OUT         : ARRAY [0..11] OF BYTE;
strDataKL6771      : DataKL6771;
bError             : BOOL;
ErrorCode          : MP_Error;
BusLoad            : INT := -1;

KL6771_OUT: Wird mit dem Ausgangsprozessabbild der MP-Bus-Masterklemme verbunden.

strDataKL6771: Datenstruktur die mit den verschiedenen MP-Bus-Funktionsbausteinen verbunden wird und die Kommunikation mit dem KL6771 Baustein beinhaltet (siehe DataKL6771).

bError: Der Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable ErrorCode beschrieben.

ErrorCode: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

BusLoad: Auslastung des MP-Bus in Prozent.


Funktionsbausteine

Bausteine | Beschreibung
MP_DamperLinearActuator | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Klappen und Hubventilantrieb.
MP_EV | Dieser Funktionsbaustein dient der Ansteuerung eines Regelkugelhahn der Baureihe P6..W..EV-BAC.
MP_MPX | Für BELIMO Raum Sensor MS24A-R..-MPX
MP_PTH | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines PTH Sensors.
MP_Smoker | Dieser Funktionsbaustein dient zur Steuerung und Überwachung einer Brandschutzklappe.
MP_UST_3 | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Multi IO Moduls UST3.
MP_VAV | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Volumenstromreglers.
MP_Window | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Fensterlüfungssystems FLS.
MPL_DamperLinearActuator | Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Klappen und Hubventilantrieb.


MP_DamperLinearActuator

Anwendung

Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Klappen- und Hubventilantrieb.

Über MP_Address wird vorgegeben, mit welchem MP-Busteilnehmer der Baustein kommunizieren soll. bStart aktiviert die Kommunikation mit dem MP-Bus Teilnehmer. Über bBusy wird angezeigt, dass der Baustein aktiv ist. Bleibt bStart auf TRUE, wird mit der Zeit TMPolling der Teilnehmer zyklisch angesprochen. Die Zeit ist größer 1 sec einzustellen. Mit bError wird ein Fehler in der Kommunikation mit dem Antrieb angezeigt. Die Art des Fehlers kann mit iErrorID ausgelesen werden.

Positive Flanke von bReset löscht anstehende Fehlermeldungen des Antriebs. Damit werden Fehler zurückgesetzt, die die Ausgangsvariablen bErr_MecOcld, bErr_ActHunt und bErrMecTrv betreffen. Sollte der Fehler noch anstehen, werden diese Fehlerbits vom Antrieb erneut gesetzt.

Mit SetPoint wird die Stellung der Klappe von 0..100% eingestellt. Die aktuelle Stellung des Antriebs wird über ActValue ausgelesen.

Sollte am Antrieb ein Sensor angeschlossen sein, ist über iSensorTyp anzugeben welcher Sensor dies ist. Ist kein Sensor angeschlossen, so ist der Wert "0" einzutragen oder die Variable wird offen gelassen. Ein digitaler Sensor ist mit "1" zu parametrieren. Der Zustand des Sensors kann dann über bMP_Sensor_Digi abgefragt werden. Analoge Sensoren "2..6" werden in der Variable iMP_Sensor_Analog ausgegeben.

VAR_INPUT

MP_Address             : USINT := 1;
bStart                 : BOOL;
bReset                 : BOOL;
iSensorTyp             : INT;
SetPoint               : USINT;
strDataKL6771          : DataKL6771;
TMpolling              : TIME := t#10s;

MP_Address: MP-Bus Adresse des Slaves.

bStart: Positive Flanke startet den Baustein. Liegt dauerhaft ein TRUE an so wird mit der Zeit TMPolling der Baustein zyklisch aktiv.

bReset: Positive Flanke setzt die Fehlermeldungen des Antriebs zurück.

iSensorTyp: "0" oder offen - kein Sensor angeschlossen, "1" digitaler Sensor angeschlossen, "2" analoger Sensor angeschlossen - Spannung Ausgabe in mV, "3..6" Ausgabe eines Widerstandes in Ohm. Zum Umrechnen in eine Temperatur sind entsprechenden Konvertierungsfunktionen vorhanden.

SetPoint: 0..100% Soll-Klappenstellung des Antriebs.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

TMpolling: Zeit mit der der Baustein den Antrieb ansprechen soll. Default 10s, minimale Zeit 1s.

VAR_OUTPUT

bBusy                  : BOOL;
ActValue               : WORD;
bMP_Sensor_Digi        : BOOL;
iMP_Sensor_Analog      : INT;
iErrorID               : MP_Error;
bError                 : BOOL;
bErr_MecOvld           : BOOL;
bErr_ActHunt           : BOOL;
bErr_MecTrv            : BOOL;
bPositionSetByHand     : BOOL;
bSynchronisationActive : BOOL;

bBusy: Dieses Bit wird solange gesetzt, wie der Baustein aktiv ist.

ActValue: Enthält die aktuelle Position (0..100%) des Antriebs.

bMP_Sensor_Digi: Ist ein digitaler Sensor angeschlossen, wird der Zustand über diese Variable angezeigt. iSensorTyp muss "1" sein.

iMP_Sensor_Analog: Ist ein analoger Sensor angeschlossen, wird der Wert über diese Variable angezeigt. iSensorTyp muss "2..6" sein.

iErrorID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

bError: Der Ausgang wird TRUE, sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorID beschrieben.

bErr_MecOvld: Antriebsfehler "Überlast", Sollposition konnte nicht erreicht werden.

bErr_ActHunt: Antriebsfehler "Regelschwingung", Antrieb pendelt hin und her.

bErr_MecTrv: Antriebsfehler "Stellwinkel überschritten", Antriebsdrehwinkel gegenüber Adaption um mehr als 10° überschritten.

bPositionSetByHand: Die Position des Antriebs wurde von Hand verändert.

bSynchronisationActive: Der Antrieb synchronisiert sich.


MP_EV

Anwendung

Dieser Funktionsbaustein dient der Ansteuerung eines Regelkugelhahn der Baureihe P6..W..EV-BAC. Weitere Informationen finden Sie unter www.belimo.ch.

Über MP_Address wird vorgegeben, mit welchem MP-Busteilnehmer der Baustein kommunizieren soll. bStart aktiviert die Kommunikation mit dem MP-Bus Teilnehmer. Über bBusy wird angezeigt, dass der Baustein aktiv ist. Bleibt bStart auf TRUE, wird mit der Zeit TMPolling der Teilnehmer zyklisch angesprochen. Die Zeit ist größer 1s einzustellen. Mit bError wird ein Fehler in der Kommunikation mit dem Antrieb angezeigt. Die Art des Fehlers kann mit iErrorId ausgelesen werden.

VAR_INPUT

MP_Address                    : USINT := 1;
bStart                        : BOOL;
strDataKL6771                 : DataKL6771;
TMpolling                     : TIME := t#10s;
nOverreideControl             : E_MPBus_Override := MPBus_Override_Auto;
nRelSetpoint                  : INT;

MP_Address: MP-Bus Adresse des Slaves.

bStart: Positive Flanke startet den Baustein. Liegt dauerhaft ein TRUE an so wird mit der Zeit TMPolling der Baustein zyklisch aktiv.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

TMpolling: Zeit mit der der Baustein den Antrieb ansprechen soll. Default 10s, minimale Zeit 1s.

nOverreideControl: Der relative Sollwert nRelSetpoint wird im Überschreiben Modus ignoriert. Wird der Befehl nicht innerhalb von 120min wiederholt, deaktiviert sich das Überschreiben.

nRelSetpoint: Der Sollwert wird entweder als Positions-Sollwert oder als Vorlauf-Sollwert interpretiert.

VAR_OUTPUT

bBusy                         : BOOL;
bError                        : BOOL;
iErrorId                      : MP_Error;
nAbsPos                       : INT;
rT1_SI                        : REAL;
rT2_SI                        : REAL;
rDELTA_T                      : REAL;
rP_SI                         : REAL;
nE_COOLING_SI                 : DINT;
nE_HEATING_SI                 : DINT;
nRelFlow                      : INT;
rAbsFlow_SI                   : REAL;
nRelPos                       : INT;
nRelSetPointRead              : INT;
bErrorStateT1                 : BOOL;
bErrorStateT2                 : BOOL;
bErrorStateFlowSensorErr      : BOOL;
bErrorStateMechanicalOverload : BOOL;

bBusy: Dieses Bit wird solange gesetzt, wie der Baustein aktiv ist.

bError: Der Ausgang wird TRUE, sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorId beschrieben.

iErrorId: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

nAbsPos: Absolute Position in °.

rT1_SI: Temperatur 1 (remote) in °C.

rT2_SI: Temperatur 2 (embedded) in °C.

rDELTA_T: Delta Temperature in °C.

rP_SI: Energie in kW.

nE_COOLING_SI: Kühlenergie in kWh.

nE_HEATING_SI: Heizenergie in kWh.

nRelFlow: Relativer Durchfluss in %.

rAbsFlow_SI: Absoluter Durchfluss in l/min.

nRelPos: Relative Position in %.

nRelSetPointRead: Der Sollwert wird entweder als Positions-Sollwert oder als Vorlauf-Sollwert (bezogen auf Vmax) interpretiert in %.

bErrorStateT1: Fehler Temperatur Sensor T1.

bErrorStateT2: Fehler Temperatur Sensor T2.

bErrorStateFlowSensorErr: Durchfluss Sensor hat einen Fehler.

bErrorStateMechanicalOverload: Mechanische Überlast erkannt.


MP_MPX

Anwendung

Für BELIMO Raumm Sensor MS24A-R..-MPX.

MS24A-R01-MPX Temperature

MS24A-R02-MPX Temperature, CO2

MS24A-R03-MPX Temperature, VOC

MS24A-R04-MPX Temperature, CO2, VOC

MS24A-R05-MPX Temperature, Humidity

MS24A-R06-MPX Temperature, Humidity, CO2

MS24A-R07-MPX Temperature, Humidity, VOC

MS24A-R08-MPX Temperature, Humidity, CO2, VOC

VAR_INPUT

MP_Address         : USINT := 1;
bStart             : BOOL;
strDataKL6771      : DataKL6771;
TMpolling          : TIME := t#10s;
bTemp_C_F          : BOOL;

MP_Address: MP-Bus Adresse des Slaves.

bStart: Positive Flanke startet den Baustein. Liegt dauerhaft ein TRUE an so wird mit der Zeit TMPolling der Baustein Zyklisch aktiv.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

TMpolling: Zeit mit der der Baustein den Sensor ansprechen soll. Default 10s, minimale Zeit 1s.

bTemp_C_F: FALSE = °C / TRUE = °F.

VAR_OUTPUT

bBusy              : BOOL;
bError             : BOOL;
iErrorId           : MP_Error;
strMPX_ERR         : MP_BUS_MPX_ERROR;
iU                 : INT;
bDigital           : BOOL;
iTemp              : INT;
iCO2               : INT;
iVOC               : INT;
iHumidity          : INT;
bFlushStatus       : BOOL;

bBusy: Dieses Bit wird solange gesetzt wie der Baustein aktiv ist.

bError: Der Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorId beschrieben.

iErrorId: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

strMPX_ERR: Fehlermeldungen des Sensors (siehe MP_BUS_MPX_ERROR).

iU: 0..10 V UNIT 1 mV.

bDigital: DI 24 V.

iTemp: 0..50 °C Unit: 0.01°C.

iCO2: 0..2000 ppm Unit: 1 ppm.

iVOC: 0..2000 ppm Unit: 1 ppm (pseudo).

iHumidity: 10..90% Unit: 0.01%.

bFlushStatus: VOC Gradientenschwelle überschritten, FALSE = Luftqualität OK, TRUE = Luftqualität nicht OK, flush.


MP_PTH

Anwendung

Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines PTH Sensors.

Über MP_Address wird vorgegeben, mit welchem MP-Busteilnehmer der Baustein kommunizieren soll. bStart aktiviert die Kommunikation mit dem MP-Bus Teilnehmer. Über bBusy wird angezeigt, dass der Baustein aktiv ist. Bleibt bStart auf TRUE, wird mit der Zeit TMPolling der Teilnehmer zyklisch angesprochen. Die Zeit ist größer 1s einzustellen. Mit bError wird ein Fehler in der Kommunikation mit dem Sensor angezeigt. Die Art des Fehlers kann mit iErrorId ausgelesen werden.

Sollte am Sensor ein Externer-Sensor angeschlossen sein, ist über iSensorTyp anzugeben, welcher Sensor dies ist. Ist kein Sensor angeschlossen, so ist der Wert "0" einzutragen oder die Variable wird offen gelassen. Ein digitaler Sensor ist mit "3" zu parametrieren. Der Zustand des Sensors wird über die Variable iYSensor ausgegeben.

VAR_INPUT

MP_Address         : USINT := 1;
bStart             : BOOL;
iSensorTyp         : INT;
strDataKL6771      : DataKL6771;
TMpolling          : TIME := t#10s;

MP_Address: MP-Bus Adresse des Slaves.

bStart: Positive Flanke startet den Baustein. Liegt dauerhaft ein TRUE an, so wird mit der Zeit TMPolling der Baustein zyklisch aktiv.

iSensorTyp: "0" oder offen - kein Sensor angeschlossen, "1" analoger Sensor angeschlossen Spannung Ausgabe in mV, "2" Ausgabe eines Widerstandes in Ohm - 1,0 Ohm , "3" Ausgabe eines Widerstandes in Ohm - 0,1 Ohm, "4" digitaler Sensor.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

TMpolling: Zeit mit der der Baustein den Sensor ansprechen soll. Default 10s, minimale Zeit 1s.

VAR_OUTPUT

bBusy              : BOOL;
bError             : BOOL;
iErrorId           : MP_Error;
iDampness          : INT;
iPressure          : INT;
iTemperature       : INT;
iYSensor           : INT;
byPTH_Error        : BYTE;

bBusy: Dieses Bit wird solange gesetzt, wie der Baustein aktiv ist.

bError: Der Ausgang wird TRUE, sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorId beschrieben.

iErrorId: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

iDampness: Relative Feuchte in 0,01%.

iPressure: Differenzdruck, Ausgabe in 0,1 Pa.

iTemperature: Temperatur in 0,01°C.

iYSensor: Y-Eingang, iSensorTyp = "1" - Spannung 0..10V Ausgabe in [mV], iSensorTyp = "2" Widerstand Ausgabe in 1,0 Ohm, iSensorTyp = "3" Widerstand Ausgabe in 0,1 Ohm, iSensorTyp = "4" digitaler Schalter 0 oder 1.

byPTH_Error: Sensor Fehler - 0 - kein Fehler.

byPTH_Error | Beschreibung
Bit 0 | Wartungsfehler
Bit 1 | Störmeldung, Fühlerdefekt
Bit 2 | -
Bit 3 | -
Bit 4 | Sensor (Temperatur/Feuchte) defekt
Bit 5 | AD-Wandler (Druck) defekt
Bit 6 | AD-Wandler (Y-Eingang) defekt
Bit 7 | -


MP_Smoker

Anwendung

Dieser Funktionsbaustein dient zur Steuerung und Überwachung einer Brandschutzklappe.

Über MP_Address wird vorgegeben, mit welchem MP-Busteilnehmer der Baustein kommunizieren soll. bStart aktiviert die Kommunikation mit dem MP-Bus Teilnehmer. Über bBusy wird angezeigt, dass der Baustein aktiv ist. Bleibt bStart auf TRUE wird mit der Zeit TMPolling der Teilnehmer zyklisch angesprochen. Die Zeit ist größer 1s einzustellen, maximal 30s. Mit bError wird ein Fehler in der Kommunikation mit dem Antrieb angezeigt. Die Art des Fehlers kann mit iErrorID ausgelesen werden.

Positive Flanke von bReset löscht anstehende Fehlermeldungen des Antriebs. Damit werden Fehler zurückgesetzt, die die Ausgangsvariablen bErr_MecOcld, bErr_ActHunt und bErrMecTrv betreffen. Sollte der Fehler noch anstehen werden diese Fehlerbits vom Antrieb erneut gesetzt.

Über bOpen_Close wird die Brandschutzklappe geöffnet oder geschlossen. Ein TRUE bewirkt das Öffnen einer Brandschutzklappe, ein FALSE ein Schließen der Klappe. Über bOpen wird angezeigt, dass die Klappe geöffnet ist und über bClosed geschlossen ist. Sind beide Bits auf FALSE, öffnet oder schließt der Antrieb grade.

Mit einer positiven Flanke von bTest wird ein Testlauf der Brandschutzklappe angestoßen. Gesetzte Fehler können hiermit zurückgenommen werden, wenn sie nicht mehr vorliegen.

VAR_INPUT

MP_Address         : USINT := 1;
bStart             : BOOL := TRUE;
bTest              : BOOL;
bOpen_Close        : BOOL;
bReset             : BOOL;
strDataKL6771      : DataKL6771;
TMpolling          : TIME := t#10s;

MP_Address: MP-Bus Adresse des Slaves.

bStart: Positive Flanke startet den Baustein. Liegt dauerhaft ein TRUE an, so wird mit der Zeit TMPolling der Baustein zyklisch aktiv.

bTest: Positive Flanke startet den Testlauf einer Brandschutzklappe.

bOpen_Close: TRUE öffnet eine Klappe, FALSE schließt eine Klappe.

bReset: Positive Flanke setzt die Fehlermeldungen des Antriebs zurück.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

TMpolling: Zeit mit der der Baustein den Antrieb ansprechen soll. Default 10s, minimale Zeit 1s.

VAR_OUTPUT

bBusy              : BOOL;
bError             : BOOL;
iErrorId           : MP_Error;
bOpen              : BOOL;
bClosed            : BOOL;
bErr_MecTrv        : BOOL;
bErr_MecOvld       : BOOL;
bErr_EmFlt         : BOOL;
bErr_DmpTrv        : BOOL;
bErr_DctAlm        : BOOL;
bErr_SmAlm         : BOOL;

bBusy: Dieses Bit wird solange gesetzt, wie der Baustein aktiv ist.

bError: Der Ausgang wird TRUE, sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorId beschrieben.

iErrorId: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

bOpen: Brandschutzklappe ist geöffnet.

bClosed: Brandschutzklappe ist geschlossen.

bErr_MecTrv: Antriebsfehler "Stellwinkel überschritten", Antriebsdrehwinkel gegenüber Adaption um mehr als 10° überschritten.

bErr_MecOvld: Antriebsfehler "Überlast", Sollposition konnte nicht erreicht werden.

bErr_EmFlt: Antriebsfehler "Sicherheitsrelevante Störung", Umgebungstemperatur über 72°C oder Motortemperatur größer 85°C, Fehler kann nur im Werk zurückgesetzt werden.

bErr_DmpTrv: Antriebsfehler "Klappengängigkeitsfehler", wird gelöscht sollte der Testlauf in Ordnung sein.

bErr_DctAlm: Antriebsfehler "Kanaltemperatur zu groß", Antrieb pendelt hin und her.

bErr_SmAlm: Antriebsfehler "Alarm Rauchmelder".


MP_UST_3

Anwendung

Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Multi IO Moduls UST3.

Über MP_Address wird vorgegeben, mit welchem MP-Busteilnehmer der Baustein kommunizieren soll. bStart aktiviert die Kommunikation mit dem MP-Bus-Teilnehmer. Über bBusy wird angezeigt, dass der Baustein aktiv ist. Bleibt bStart auf TRUE wird mit der Zeit TMPolling der Teilnehmer zyklisch angesprochen. Die Zeit ist größer als eine Sekunde einzustellen. bError zeigt einen Fehler in der Kommunikation mit dem Antrieb an. Die Art des Fehlers kann mit iErrorID ausgelesen werden.

Die Eingangsdaten bRelay_R1 bis bRelay_R3 schalten die Relais R1 bis R3 (PIN 15 bis PIN 17). Die Variable iUa schaltet den analogen Ausgang 0..10 V auf PIN 5. Dabei entspricht ein Digit einem mV.

Die Datenstruktur SETTINGS wird für die Parametrierung des UST3 verwendet. Es kann die Skalierung der analogen Eingangsdaten eingestellt, sowie die Widerstandsmessung auf PIN4 aktiviert werden. Für die Widerstandsmessung kann die Skalierung des Widerstandsmesswert geändert werden. Dies kann auch im laufenden Betrieb erfolgen. iU1 ist der Analoge Eingang auf PIN 3. Dabei entspricht ein Digit einem mV oder, wenn man die Skalierung in der Datenstruktur SETTINGS umgestellt hat, 250 µV. Das gleiche gilt auch für die analogen Eingänge iU2_YSensor (PIN 4) oder auch iU3 (PIN 7).iU2_YSensor kann auch als Widerstandsmessung genutzt werden. Dies muss über die Datenstruktur SETTINGS eingestellt werden. bDigital_S1 bis bDigital_S3 entsprechen den digitalen Eingängen des UST3, PIN 7 bis PIN 9.

Alle Daten werden von der MP-Bus-Masterklemme KL6771 automatisch gepollt. Die Pollgeschwindigkeit hängt ab von der Anzahl der angeschlossenen MP-Bus-Teilnehmer und der eingestellten Pollzeit. Die digitalen Eingänge eignen sich nicht für den Anschluss von Tastern oder Sensoren die nur kurze Impulse ausgeben. Um einen Pegelwechsel sicher mitzubekommen, muss dieser minimal eine Sekunde anliegen.

VAR_INPUT

MP_Address         : USINT := 1;
bStart             : BOOL;
strDataKL6771      : DataKL6771;
TMpolling          : TIME := t#10s;
bRelay_R1          : BOOL;
bRelay_R2          : BOOL;
bRelay_R3          : BOOL;
iUa                : UINT;
SETTINGS           : UST3_SET;

MP_Address: MP-Bus Adresse des Slaves.

bStart: Positive Flanke startet den Baustein. Liegt dauerhaft ein TRUE an, so wird mit der Zeit TMPolling der Baustein zyklisch aktiv.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

TMpolling: Zeit mit der der Baustein den Antrieb ansprechen soll. Default 10s, minimale Zeit 1s.

bRelay_R1: Relais PIN 15.

bRelay_R2: Relais PIN 16.

bRelay_R3: Relais PIN 17.

iUa: Analoger Ausgang PIN 5 (1 mV = 1 Digit).

SETTINGS: Datenstruktur zum Einstellen der Skalierung und der Widerstandsmessung (siehe UST3_SET).

VAR_OUTPUT

bBusy              : BOOL;
bError             : BOOL;
iErrorId           : MP_Error;
iU1                : INT;
iU2_YSensor        : INT;
iU3                : INT;
bDigital_S1        : BOOL;
bDigital_S2        : BOOL;
bDigital_S3        : BOOL;
iResistor          : INT;

bBusy: Dieses Bit wird solange gesetzt, wie der Baustein aktiv ist.

bError: Der Ausgang wird TRUE, sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorId beschrieben.

iErrorId: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

iU1: Analoger Eingang PIN 3 (1 Digit = 1 mV oder 1 Digit = 250 µV).

iU2_YSensor: Analoger Eingang PIN 4 (1 Digit = 1 mV oder 1 Digit = 250 µV).

iU3: Analoger Eingang PIN 7 (1 Digit = 1 mV oder 1 Digit = 250 µV).

bDigital_S1: Digitaler Eingang PIN 8.

bDigital_S2: Digitaler Eingang PIN 9.

bDigital_S3: Digitaler Eingang PIN 7.

iResistor: Widerstandswert PIN 4.


MP_VAV

Anwendung

Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Volumenstromreglers.

Über MP_Address wird vorgegeben, mit welchem MP-Busteilnehmer der Baustein kommunizieren soll. bStart aktiviert die Kommunikation mit dem MP-Bus Teilnehmer. Über bBusy wird angezeigt, dass der Baustein aktiv ist. Bleibt bStart auf TRUE, wird mit der Zeit TMPolling der Teilnehmer zyklisch angesprochen. Die Zeit ist größer 1 sec einzustellen. Mit bError wird ein Fehler in der Kommunikation mit dem Antrieb angezeigt. Die Art des Fehlers kann mit iErrorID ausgelesen werden.

Positive Flanke von bReset löscht anstehende Fehlermeldungen des Antriebs. Damit werden Fehler zurückgesetzt, die die Ausgangsvariablen bErr_MecOcld, bErr_ActHunt und bErrMecTrv betreffen. Sollte der Fehler noch anstehen, werden diese Fehlerbits vom Antrieb erneut gesetzt.

Mit SetPoint wird der Volumenstrom von 0..100% eingestellt. Die aktuelle Stellung der Klappe wird über ActValue ausgelesen.

Sollte am Antrieb ein Sensor angeschlossen sein, ist über iSensorTyp anzugeben welcher Sensor dies ist. Ist kein Sensor angeschlossen, so ist der Wert "0" einzutragen oder die Variable wird offen gelassen. Ein digitaler Sensor ist mit "1" zu parametrieren. Der Zustand des Sensors kann dann über bMP_Sensor_Digi abgefragt werden. Analoge Sensoren "2..6" werden in der Variable iMP_Sensor_Analog ausgegeben.

Eine positive Flanke der Eingänge bOpen oder bClose öffnet bzw. schließt die Klappe des Antriebs. Eine negative Flanke der beiden Eingänge löscht den Befehl wieder.

Mit MaxVol und MinVol kann ein maximaler und ein minimaler Volumenstrom im Antrieb hinterlegt werden. Eine positive Flanke von bSet schreibt die Daten zum Antrieb. Den aktuellen Wert erhalten Sie in den Ausgangsdaten act_MaxVol und act_MinVol. Der aktuellen Volumenstrom wird in der Variable AirVolume_m3h ausgegeben.

VAR_INPUT

MP_Address             : USINT := 1;
bStart                 : BOOL;
bSet                   : BOOL;
bOpen                  : BOOL;
bClose                 : BOOL;
bReset                 : BOOL;
iSensorTyp             : INT;
SetPoint               : USINT;
MaxVol                 : WORD;
MinVol                 : WORD;
strDataKL6771          : DataKL6771;
TMpolling              : TIME := t#10s;

MP_Address: MP-Bus Adresse des Slaves.

bStart: Positive Flanke startet den Baustein. Liegt dauerhaft ein TRUE an, so wird mit der Zeit TMPolling der Baustein zyklisch aktiv.

bSet: Positive Flanke schreibt die Daten MaxVol und MinVol zum Antrieb.

bOpen: Positive Flanke öffnet die Klappen des Antriebs, eine negative Flanke löscht die Zwangsbelüftung.

bClose: Positive Flanke schließt die Klappen des Antriebs, eine negative Flanke löscht die Zwangsverschließung.

bReset: Positive Flanke setzt die Fehlermeldungen des Antriebs zurück.

iSensorTyp: "0" oder offen - kein Sensor angeschlossen, "1" digitaler Sensor angeschlossen, "2" analoger Sensor angeschlossen - Spannung Ausgabe in mV, "3..6" Ausgabe eines Widerstandes in Ohm. Zum Umrechnen in eine Temperatur sind entsprechenden Konvertierungsfunktionen vorhanden.

SetPoint: 0..100% Soll-Volumenstrom.

MaxVol: 30..100% Maximaler-Volumenstrom.

MinVol: 0..100% Minimaler-Volumenstrom.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

TMpolling: Zeit mit der der Baustein den Antrieb ansprechen soll. Default 10s, minimale Zeit 1s.

VAR_OUTPUT

bBusy                  : BOOL;
bError                 : BOOL;
iErrorID               : MP_Error;
ActValue               : WORD;
bMP_Sensor_Digi        : BOOL;
iMP_Sensor_Analog      : INT;
AirVolume_m3h          : WORD;
iVnom_m3h              : INT;
act_MaxVol             : INT;
act_MinVol             : INT;
bErr_ActHunt           : BOOL;
bErr_MecTrv            : BOOL;
bErr_MecOvld           : BOOL;

bBusy: Dieses Bit wird solange gesetzt, wie der Baustein aktiv ist.

bError: Der Ausgang wird TRUE, sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorId beschrieben.

iErrorID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

ActValue: Enthält die aktuelle Position (0..100%) des Antriebs.

bMP_Sensor_Digi: Ist ein digitaler Sensor angeschlossen, wird der Zustand über diese Variable angezeigt. iSensorTyp muss "1" sein.

iMP_Sensor_Analog: Ist ein analoger Sensor angeschlossen, wird der Wert über diese Variable angezeigt. iSensorTyp muss "2..6" sein.

AirVolume_m3h: Ausgabe des Volumenstroms in m³/h.

iVnom_m3h: Nominal Luftvolumenstrom in m3/h. Dieser Ausgang ist ab Version 1.12.0 verfügbar.

act_MaxVol: Maximal eingestellter Volumenstrom in %.

act_MinVol: Minimal eingestellter Volumenstrom in %.

bErr_ActHunt: Antriebsfehler "Regelschwingung", Antrieb pendelt hin und her.

bErr_MecTrv: Antriebsfehler "Stellwinkel überschritten", Antriebsdrehwinkel gegenüber Adaption um mehr als 10° überschritten.

bErr_MecOvld: Antriebsfehler "Überlast", Sollposition konnte nicht erreicht werden.


MP_Window

Anwendung

Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Fensterlüftungssystems FLS.

Über MP_Address wird vorgegeben, mit welchem MP-Busteilnehmer der Baustein kommunizieren soll. bStart aktiviert die Kommunikation mit dem MP-Bus Teilnehmer. Über bBusy wird angezeigt, dass der Baustein aktiv ist. Bleibt bStart auf TRUE wird mit der Zeit TMPolling der Teilnehmer zyklisch angesprochen. Die Zeit ist größer 1 sec einzustellen. Mit bError wird ein Fehler in der Kommunikation mit dem FLS angezeigt. Die Art des Fehlers kann mit iErrorId ausgelesen werden.

Über ManuelMode kann man die Handbedienung aktivieren bzw. deaktivieren. Mit WindowSettings kann die Art des Lüftens vorgegeben werden.

VAR_INPUT

MP_Address             : USINT := 1;
bStart                 : BOOL;
WindowSettings         : Data_Window;
ManuelMode             : BOOL;
strDataKL6771          : DataKL6771;
TMpolling              : TIME := t#10s;

MP_Address: MP-Bus Adresse des Slaves.

bStart: Positive Flanke startet den Baustein. Liegt dauerhaft ein TRUE an, so wird mit der Zeit TMPolling der Baustein zyklisch aktiv.

WindowSettings: Soll-Einstellungen für das Lüften (siehe Data_Window).

ManuelMode: FALSE: Handbedienung zugelassen. TRUE: Handbedienung deaktiviert.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

TMpolling: Zeit mit der der Baustein den Antrieb ansprechen soll. Default 10s, minimale Zeit 1s.

VAR_OUTPUT

bBusy                  : BOOL;
bError                 : BOOL;
iErrorId               : MP_Error;
WindowState            : Data_Window;
Window_Mech_Error      : BOOL;
Memory_Error           : BOOL;

bBusy: Dieses Bit wird solange gesetzt, wie der Baustein aktiv ist.

bError: Der Ausgang wird TRUE, sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorId beschrieben.

iErrorId: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

WindowState: Ist-Einstellungen für das Lüften (siehe Data_Window).

Window_Mech_Error: Fenster oder Antrieb ist blockiert.

Memory_Error: Antrieb hat einen Memory Fehler. Neu programmieren oder ersetzen.


MPL_DamperLinearActuator

Anwendung

Dieser Funktionsbaustein dient zur Steuerung und Überwachung eines Klappen- und Hubventilantrieb.

Über MP_Address wird vorgegeben, mit welchem MP-Busteilnehmer der Baustein kommunizieren soll. bStart aktiviert die Kommunikation mit dem MP-Bus Teilnehmer. Über bBusy wird angezeigt, dass der Baustein aktiv ist. Bleibt bStart auf TRUE, wird mit der Zeit TMPolling der Teilnehmer zyklisch angesprochen. Die Zeit ist größer 1 sec einzustellen. Mit bError wird ein Fehler in der Kommunikation mit dem Antrieb angezeigt. Die Art des Fehlers kann mit iErrorID ausgelesen werden.

Mit SetPoint wird die Stellung der Klappe von 0..100% eingestellt. Die aktuelle Stellung des Antriebs wird über ActValue ausgelesen.

VAR_INPUT

MP_Address             : USINT := 1;
bStart                 : BOOL;
SetPoint               : USINT;
strDataKL6771          : DataKL6771;
TMpolling              : TIME := t#10s;

MP_Address: MP-Bus Adresse des Slaves.

bStart: Positive Flanke startet den Baustein. Liegt dauerhaft ein TRUE an, so wird mit der Zeit TMPolling der Baustein zyklisch aktiv.

SetPoint: 0..100% Soll-Klappenstellung des Antriebs.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

TMpolling: Zeit mit der der Baustein den Antrieb ansprechen soll. Default 10s, minimale Zeit 1s.

VAR_OUTPUT

bBusy                  : BOOL;
ActValue               : WORD;
iErrorID               : MP_Error;
bError                 : BOOL;

bBusy: Dieses Bit wird solange gesetzt, wie der Baustein aktiv ist.

ActValue: Enthält die aktuelle Position (0..100%) des Antriebs.

iErrorID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

bError: Der Ausgang wird TRUE, sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorID beschrieben.


Funktionen

Bausteine | Beschreibung
NI1000_LuS_TO_INT | Diese Funktion berechnet aus einem Widerstand NI1000 L&S eine Temperatur
NI1000_TO_INT | Diese Funktion berechnet aus einem Widerstand NI1000 eine Temperatur.
NTC_TO_INT | Diese Funktion berechnet aus einem Widerstand NTC eine Temperatur
PT1000_TO_INT | Diese Funktion berechnet aus einem Widerstand PT1000 eine Temperatur


NI1000_LuS_TO_INT

TwinCAT PLC Bibliothek: MP-Bus

NI1000_LuS_TO_INT : INT

Anwendung

Diese Funktion berechnet aus einem Widerstand NI1000 L&S eine Temperatur.

Schließen Sie diese Funktion an iMP_Sensor_Analog an. Als Ausgabewert erhalten Sie eine INT Variable, die die Temperatur in einer Auflösung von 0.01°C ausgibt (Beispiel 20,5°C entspricht 2050).

Kleinster, gültiger Wert 872 Ohm entspricht -30°C, ist der Wert kleiner so wird 16#7FFD ausgegeben.

Größter, gültiger Wert 1586 Ohm entspricht 115°C, ist der Wert größer so wird 16#7FFE ausgegeben.

VAR_INPUT

MP_Value      : WORD;

MP_Value: Eingang für einen ohmschen NI1000 L&S Sensor.

NI1000_LuS_TO_INT: Temperatur in 0.01°C.


NI1000_TO_INT

TwinCAT PLC Bibliothek: MP-Bus

NI1000_TO_INT : INT

Anwendung

Diese Funktion berechnet aus einem Widerstand NI1000 eine Temperatur.

Schließen Sie diese Funktion an iMP_Sensor_Analog an. Als Ausgabewert erhalten Sie eine INT Variable, die die Temperatur in einer Auflösung von 0.01°C ausgibt (Beispiel 20,5°C entspricht 2050).

Kleinster, gültiger Wert 867 Ohm entspricht -25°C, ist der Wert kleiner so wird 16#7FFD ausgegeben.

Größter, gültiger Wert 1583 Ohm entspricht 95°C, ist der Wert größer so wird 16#7FFE ausgegeben.

VAR_INPUT

MP_Value      : WORD;

MP_Value: Eingang für einen ohmschen NI1000 Sensor

NI1000_TO_INT: Temperatur in 0.01°C.


NTC_TO_INT

TwinCAT PLC Bibliothek: MP-Bus

NTC_TO_INT : INT

Anwendung

Diese Funktion berechnet aus einem Widerstand NTC eine Temperatur.

Schließen Sie diese Funktion an iMP_Sensor_Analog an. Als Ausgabewert erhalten Sie eine INT Variable, die die Temperatur in einer Auflösung von 0.01°C ausgibt (Beispiel 20,5°C entspricht 2050).

Kleinster, gültiger Wert 104 Ohm entspricht 145°C, ist der Wert kleiner so wird 16#7FFD ausgegeben.

Größter, gültiger Wert 48555 Ohm entspricht -20°C, ist der Wert größer so wird 16#7FFE ausgegeben.

VAR_INPUT

MP_Value      : WORD;

MP_Value: Eingang für einen ohmschen NTC Sensor.

NTC_TO_INT: Temperatur in 0.01°C.


PT1000_TO_INT

TwinCAT PLC Bibliothek: MP-Bus

PT1000_TO_INT : INT

Anwendung

Diese Funktion berechnet aus einem Widerstand PT1000 eine Temperatur.

Schließen Sie diese Funktion an iMP_Sensor_Analog an. Als Ausgabewert erhalten Sie eine INT Variable, die die Temperatur in einer Auflösung von 0.01°C ausgibt (Beispiel 20,5°C entspricht 2050).

Kleinster, gültiger Wert 862 Ohm entspricht -35°C, ist der Wert kleiner so wird 16#7FFD ausgegeben.

Größter, gültiger Wert 1592 Ohm entspricht 155°C, ist der Wert größer so wird 16#7FFE ausgegeben.

VAR_INPUT

MP_Value      : WORD;

MP_Value: Eingang für einen ohmschen PT1000 Sensor.

PT1000_TO_INT:Temperatur in 0.01°C.


Slave Adressierung

Bausteine | Beschreibung
MP_Addressing | Dieser Funktionsbaustein ermöglicht das Adressieren eines MP-Bus Slaves.


MP_Addressing

Anwendung

Dieser Funktionsbaustein ermöglicht das Adressieren eines MP-Bus Slaves. Des Weiteren kann über diesen Baustein auch die Seriennummer der Slaves ausgelesen werden.
Mit MP_Address wird entweder die Slave Adresse übergeben, die der Slave beim Adressieren bekommen soll, oder die Adresse, bei welchem Teilnehmer die Seriennummer ausgelesen werden soll. Mit steigender Flanke des bReadAddr wird die Seriennummer ausgelesen. Diese wird über MP_Serial_Numer_Out ausgegeben. Eine positive Flanke von bAddrAuto adressiert einen Slave mit der Adresse MP_Address. Der Baustein wartet mit der eingestellten TMOUT Zeit auf das Senden des Slaves mit seiner Seriennummer. Das Auslösen der Übermittlung der Seriennummer ist von Slave zu Slave unterschiedlich. Bitte entnehmen Sie der Dokumentation der MP-Bus Teilnehmer, wie die Seriennummer verschickt werden kann (meist ist ein Schalter auf dem Antrieb, der dies durch Drücken auslöst). Während der TMOUT Zeit werden keine Telegramme zu den Slaves versendet.

Eine positive Flanke von bAddrManual löst eine manuelle Adressierung aus. Dafür muss die Seriennummer des Antriebs in MP_Serial_Number_In hinterlegt sein. Die Seriennummer der Slaves sind einem Aufkleber am Antrieb zu entnehmen.

Beispiel: 00234-00016-002-031 In der Variable MP_Serial_Numer_IN ist folgendes einzutragen:

YearAndWeek = 234

DayAndNumber = 16

DeviceFamily = 2

TestStation = 31

FamilySuffix = wird nicht ausgewertet und ist daher nicht zu berücksichtigen.

bBusy wird gesetzt solange der Baustein aktiv ist. Ein Fehler wird mit bError angezeigt und die Fehlernummer kann mit iErrorId ausgelesen werden.

VAR_INPUT

MP_Address                : USINT := 1;
bAddrAuto                 : BOOL;
bReadAddr                 : BOOL;
bAddrManual               : BOOL;
MP_Serial_Number_IN       : MP_Serial_Number;
TMOUT                     : TIME := t#30s;
strDataKL6771             : DataKL6771;

MP_Address: Die MP Adresse die für die Adressierung verwendet werden soll oder für das Lesen der Seriennummer. Gültige Werte (1..8).

bAddrAuto: Positive Flanke startet den Baustein. Der Baustein unterbindet alle anderen MP-Bus Kommunikationen und wartet mit der eingestellten TMOUT Zeit bis ein MP-Bus Slave seine Seriennummer zum Beispiel durch Drücken eines Schalters übermittelt hat. Es wird dann die MP-Bus Adresse an den Slave übertragen, die in der Variable MP_Address konfiguriert wurde.

bReadAddr: Positive Flanke startet den Baustein. Der Baustein liest die Seriennummer des MP-Bus Slaves mit der Adresse MP_Address aus.

bAddrManual: Positive Flanke startet den Baustein. Der Baustein adressiert den Slave mit der Seriennummen MP_Serial_Number_IN. Die Soll-Adresse des Slave wird mit MP_Address konfiguriert.

MP_Serial_Number_IN: Seriennummer des Gerätes (siehe MP_Serial_Number).

TMOUT: Zeit nach der die automatische Adressierung abgebrochen wird.

strDataKL6771: Datenstruktur die mit dem KL6771() Baustein verbunden sein muss (siehe DataKL6771).

VAR_OUTPUT

bBusy                     : BOOL;
bError                    : BOOL;
iErrorId                  : MP_Error;
MP_Serial_Number_OUT      : MP_Serial_Number;

bBusy: Dieses Bit wird solange gesetzt, wie der Baustein aktiv ist.

bError: Der Ausgang wird TRUE, sobald ein Fehler auftritt. Dieser Fehler wird über die Variable iErrorId beschrieben.

iErrorId: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird bError TRUE.

MP_Serial_Number_OUT: Die Seriennummer vom adressierten oder angefragten Slave (siehe MP_Serial_Number).


Datentypen

Enums

Datentypen | Beschreibung
Data_Window | Lüftungsart
MP_Error | Fehlermeldungen
UST3_Ex | Skalierung der Spannung
UST3_R_set | Skalierung des Widerstandes

Strukturen

Datentypen | Beschreibung
DataKL6771 | Verbindet die Sende- und Empfangs-Bausteine mit dem Baustein KL6771()
MP_BUS_MPX_ERROR | Fehlermeldungen der "MPX" Senoren
MP_Serial_Number | Seriennummer des Gerätes
UST3_SET | Datenstruktur zur Einstellung der Skalierung und dem Einstellen der Widerstandsmessung


Enums

Datentypen | Beschreibung
Data_Window | Lüftungsart
MP_Error | Fehlermeldungen
UST3_Ex | Skalierung der Spannung
UST3_R_set | Skalierung des Widerstandes


Data_Window

Mit diesem ENUM kann die Art des Lüftens vorgegeben werden.

TYPE Data_Window :
(
  Window_Close   := 8,
  Window_Unlock  := 9,
  Window_Open    := 16#0A,
  Window_20      := 16#0B,
  Window_40      := 16#0C,
  Window_60      := 16#0D,
  Window_80      := 16#0E,
  Window_100     := 16#0F,
  Auto_Close     := 1,
  Auto_5_15min   := 2,
  Auto_8_30min   := 3,
  Auto_10_50min  := 4,
  Auto_open      := 5,
  Auto           := 0,
)
END_TYPE

Window_Close: Schließt das Fenster.

Window_Unlock: Wenn Sie "Unlock" benutzen, nehmen Sie den Schalter im Fenster, um die MP Bus Kommunikation neu zu starten.

Window_Open: Öffnet das Fenster.

Window_20: Öffnet das Fenster 20%.

Window_40: Öffnet das Fenster 40%.

Window_60: Öffnet das Fenster 60%.

Window_80: Öffnet das Fenster 80%.

Window_100: Öffnet das Fenster 100%.

Auto_Close: Automatisches Schließen.

Auto_5_15min: Automatisches Lüften alle 5..15min.

Auto_8_30min: Automatisches Lüften alle 8..30min.

Auto_10_50min: Automatisches Lüften alle 10..50min.

Auto_open: Automatisches Lüften öffnen.

Auto: Automatikbetrieb.


MP_Error

Fehlermeldungen der Bibliothek.

TYPE MP_Error :
(
  NO_MP_ERROR                          := 0,
  WRONG_TERMINAL                       := 1,
  NO_ANSWER_FROM_KL6771                := 2,
  WRONG_MP_ADDRESS_IS_0                := 10,
  WRONG_MP_ADDRESS                     := 11,
  WRONG_SET_POINT                      := 21,
  MP_BUS_TIMEOUT_NO_ANSWER_FROM_SLAVE  := 25,
  KL6771_TIME_OUT                      := 31,
  MP_ADDRESS_IS_IN_USE                 := 32,
  MP_DISABLED                          := 33,
  MP_BUS_ERROR                         := 87,
  MP_NO_ANSWER_ON_EVENT                := 88,
  MP_NO_ANSWER                         := 89,
  MP_COM_BREAK                         := 90,
  MP_LENGTH_PARITY_ERROR               := 98,
  MP_CROSS_PARITY_ERROR                := 99,
  MP_MASTER_CONFLICT_ERROR             := 101,
  MP_GAP_TIMEOUT_ERROR                 := 102,
  MP_NO_ANSWER_SLAVE                   := 103,
  MP_ANSWER_ERROR_FLAG                 := 110,
  MP_ANSWER_WRONG_LEN                  := 111,
  MP_ANSWER_WRONG_TELEG                := 112,
)
END_TYPE

NO_MP_ERROR: Kein Fehler.

WRONG_TERMINAL: Falsche Klemme angeschlossen.

NO_ANSWER_FROM_KL6771: Keine Antwort von der MP-Bus-Masterklemme KL6771. Üblicherweise gibt es bei dieser Meldung keine Verbindung zur Klemme. Klemme im System Manager mit den Variablen verknüpft? Klemme falsch gesteckt? Alles bereinigen, alles Übersetzen und im System Manager neu eingelesen?

WRONG_MP_ADDRESS_IS_0: MP-Bus Adresse ist 0. Es sind nur Adressen von 1-8 erlaubt.

WRONG_MP_ADDRESS: MP-Bus Adresse ist >8. Es sind nur Adressen von 1-8 erlaubt.

WRONG_SET_POINT: Falscher Set Point.

MP_BUS_TIMEOUT_NO_ANSWER_FROM_SLAVE: MP-Bus Timeout, keine Antwort vom Slave.

KL6771_TIME_OUT: KL6771 Timeout.

MP_ADDRESS_IS_IN_USE: MP-Bus Adresse ist im Gebrauch.

MP_DISABLED: MP-Bus gesperrt.

MP_BUS_ERROR: MP-Bus Fehler.

MP_NO_ANSWER_ON_EVENT: MP-Bus keine Antwort auf ein Ereignis.

MP_NO_ANSWER: MP-Bus keine Antwort.

MP_COM_BREAK: MP-Bus Abbruch Kommunikation.

MP_LENGTH_PARITY_ERROR: MP-Bus length parity Fehler.

MP_CROSS_PARITY_ERROR: MP-Bus cross parity Fehler.

MP_MASTER_CONFLICT_ERROR: MP-Bus MASTER_CONFLICT_ERROR.

MP_GAP_TIMEOUT_ERROR: MP-Bus GAP Timeout.

MP_NO_ANSWER_SLAVE: MP-Bus keine Antwort vom Slave.

MP_ANSWER_ERROR_FLAG: MP-Bus Fehlerbit im Antwortelegramm ist gesetzt.

MP_ANSWER_WRONG_LEN: MP-Bus falsche Telegrammlänge.

MP_ANSWER_WRONG_TELEG: MP-Bus falsches Telegramm empfangen.


UST3_Ex

Skalierung der Spannung.

TYPE UST3_Ex :
(
  Ex_1mV    := 0,
  Ex_250uV  := 1,
)
END_TYPE

Ex_1mV: Skalierung 0..11 V.

Ex_250uV: Skalierung 0..3 V.


UST3_R_set

Skalierung des Widerstandes.

TYPE UST3_R_set :
(
  R_1Ohm     := 0,
  R_250mOhm  := 1,
  R_4Ohm     := 2,
)
END_TYPE

R_1Ohm: Skalierung 0..20kOhm.

R_250mOhm: Skalierung 0..5kOhm.

R_4Ohm: Skalierung 0..262kOhm.


Strukturen

Datentypen | Beschreibung
DataKL6771 | Verbindet die Sende- und Empfangs-Bausteine mit dem Baustein KL6771().
MP_BUS_MPX_ERROR | Fehlermeldungen der "MPX" Senoren.
MP_Serial_Number | Seriennummer des Gerätes.
UST3_SET | Datenstruktur zum Einstellen der Skalierung und der Widerstandsmessung.


DataKL6771

Verbindet die Sende- und Empfangs-Bausteine mit dem Baustein KL6771().

TYPE DataKL6771 :
STRUCT
  OrderNumber  : BYTE;
  ReciveData   : BOOL;
  SendData     : BOOL;
  Error        : BOOL;
  ErrorID      : MP_Error;
  pNumber      : DWORD;
END_STRUCT
END_TYPE

OrderNumber: Internes Byte.

ReciveData: Daten werden empfangen.

SendData: Daten werden gesendet.

Error: Der Ausgang wird TRUE sobald ein Fehler auftritt. Dieser Fehler wird über die Variable ErrorID beschrieben.

ErrorID: Der Ausgang gibt im Fehlerfall einen Fehlercode aus (siehe MP_ERROR). Gleichzeitig wird Error TRUE.

pNumber: Interner Pointer.


MP_BUS_MPX_ERROR

Fehlermeldungen der "MPX" Sensoren (Funktionsbaustein MP_MPX).

TYPE MP_BUS_MPX_ERROR :
STRUCT
  MP_BUS_MPX_TempSensorErr      : BOOL;
  MP_BUS_MPX_HumiditySensorErr  : BOOL;
  MP_BUS_MPX_CO2SensorErr       : BOOL;
  MP_BUS_MPX_VocSensorErr       : BOOL;
END_STRUCT
END_TYPE

MP_BUS_MPX_TempSensorErr: Der Temperatursensor ist fehlerhaft.

MP_BUS_MPX_HumiditySensorErr: Der Feuchtigskeitsensor ist fehlerhaft.

MP_BUS_MPX_CO2SensorErr: Der CO2 Sensor ist fehlerhaft.

MP_BUS_MPX_VocSensorErr: Der VOC Sensor ist fehlerhaft.


MP_Serial_Number

Seriennummer des Gerätes.

TYPE MP_Serial_Number :
STRUCT
  YearAndWeek   : WORD;
  DayAndNumber  : WORD;
  DeviceFamily  : BYTE;
  TestStation   : BYTE;
  FamilySuffix  : BYTE;
END_STRUCT
END_TYPE

YearAndWeek: Jahr und Woche.

DayAndNumber: Tag und Nummer.

DeviceFamily: Gerätefamilie.

TestStation: Prüfstation.

FamilySuffix: Gerätefamilie Suffix.


UST3_SET

Datenstruktur zum Einstellen der Skalierung und der Widerstandsmessung.

TYPE UST3_SET :
STRUCT
  E1        : UST3_Ex;
  E2        : UST3_Ex;
  E3        : UST3_Ex;
  R_SET     : UST3_R_set;
  R_ON_OFF  : BOOL;
END_STRUCT
END_TYPE

E1: Parameter U1 (siehe UST3_Ex).

E2: Parameter U2 (siehe UST3_Ex).

E3: Parameter U3 (siehe UST3_Ex).

R_SET: Parameter Y (siehe UST3_R_set).

R_ON_OFF: Messung R oder U.


Download Beispiele

BXxx00-Controller

BXxx00-Controller "Default-Config":

CX oder PC TwinCAT PLC

TwinCAT PLC Control:

TwinCAT System Manager:

TwinCAT PLC "Manuelle Zuweisung der MP-Bus Adresse"

TwinCAT PLC Control:

TwinCAT System Manager:


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.