Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Einführung

DALI (Digital Addressable Lighting Interface) ist eine Definition zur Standardisierung digitaler Schnittstellen von Vorschaltgeräten. Mit diesem Standard (IEC 62386) sind die Hersteller von Beleuchtungskomponenten in der Lage, komplexe Beleuchtungsaufgaben einfach und komfortabel zu lösen.

Die Busklemme KL6811 (DALI-Master) wird als normale Busklemme in das Busklemmensystem integriert und ist somit feldbusunabhängig. Über den jeweiligen Buskoppler werden die DALI-Daten an die Vorschaltgeräte weitergeleitet. Buscontroller bieten zusätzlich die Möglichkeit SPS-Programme in IEC61131-3 dezentral auszuführen.

Die hier vorliegende Version der DALI-Library ersetzt die bisherige Version der DALI-Library. Die ältere DALI-Library finden Sie mit Anleitung unter TcPlcLibDALIV1.zip. Sie sollten bei neueren Projekten nur noch die aktuelle Version einsetzen, da die ältere Version nicht weiterentwickelt wird.

Systemeigenschaften

DALI ist definiert für:

  • max. 64 Einzelgeräte
  • max. 16 Gruppen
  • max. 16 Szenen

Bei DALI wurde die Intelligenz nicht zu 100% zentralisiert. Das bedeutet, dass viele Einstellungen und Lichtwerte in Form von Variablen im Vorschaltgerät gespeichert sind:

  • Kurzadresse
  • Gruppenzugehörigkeit
  • Lichtszenenwerte
  • Dimmgeschwindigkeit
  • Notstromlichtwert
  • Einschaltlichtwert bei Spannungsrückkehr

Hinweis

Entsprechend der IEC 62386 muss ein DALI-Master bestimmte Befehle innerhalb von 100 ms wiederholen, damit sie von den DALI-Slaves ausgeführt werden. Um den doppelten Aufruf der Befehle im Anwenderprogramm zu vermeiden, wiederholt die KL6811 selbstständig bestimmte Befehle. Im Anhang der Dokumentation zur KL6811 finden Sie eine Auflistung der Befehle, die von der Klemme selbstständig wiederholt werden.

Weitere Informationen zu DALI finden Sie auf der Homepage der DALI Activity Group (http://www.dali-ag.org) und in der Norm IEC 62386.


Dimmkurve

Da das menschliche Auge gerade bei geringer Beleuchtungsstärke extrem empfindlich reagiert, werden unregelmäßige oder sprunghafte Änderungen ebenso wie lineare Veränderungen der Beleuchtungsstärke in diesem Bereich als unangenehm empfunden. Deshalb erfolgt der Dimmverlauf einer DALI-Beleuchtungsanlage in einer, der Augenempfindlichkeit des Menschen nachempfundenen, logarithmischen Dimmkurve.

Die Berechnung der Dimmkurve erfolgt nach der Formel:
n: 8-Bit Steuerwert
X: Lampenleistungswert in %

Es ergibt sich folgende Dimmkurve:


Allgemeine Informationen

Hinweis 		Installation
Ab TwinCAT 2.11 Build 2229 (R3 und x64 Engineering) werden die Bibliotheken "TcDALIV2.lib/.lb6/.lbx" standardmäßig mitinstalliert.

Hardware Dokumentation im Beckhoff Information System: KL6811 - Masterklemme für DALI/DSI

Weitere erforderliche Bibliotheken

Für PC-Systeme (x86) und Embedded-PCs (CXxxxx):

  • Standard.lib
  • TcBase.lib
  • TcSystem.lib

Für Busklemmen-Controller der Serie BCxx00:

  • Standard.lb6
  • TcPlcUtilitiesBC.lb6
  • PlcHelperBC.lb6
  • PlcSystemBC.lb6

Für Busklemmen-Controller der Serien BCxx50, BCxx20 und BC9191:

  • Standard.lbx
  • TcBaseBCxx50.lbx
  • TcSystemBCxx50.lbx

Für Busklemmen-Controller der Serie BXxx00:

  • Standard.lbx
  • TcBaseBX.lbx
  • TcSystemBX.lbx

Hinweis 		Speicherauslastung
Durch Einbinden der Bibliothek wird bereits SPS-Programmspeicher verbraucht. Abhängig vom Applikationsprogramm kann daher der verbleibende Speicher nicht ausreichend sein.


Integration in TwinCAT (CX9020)

Dieses Beispiel beschreibt, wie ein einfaches SPS-Programm für DALI in TwinCAT geschrieben werden kann und wie es mit der Hardware verknüpft wird. Es soll eine einzelne dimmbare Lampe angesteuert und per Taster verändert werden.

Beispieldateien entpacken

Hardware

Einrichtung der Komponenten

Es wird folgende Hardware benötigt:

  • 1x Embedded-PC CX9020
  • 1x Digitale 2-Kanal-Eingangsklemme KL1002 (für die Dimm und Reset Funktion)
  • 1x DALI-Klemme KL6811
  • 1x Endklemme KL9010

Richten Sie die Hardware sowie die DALI-Komponenten wie in den entsprechenden Dokumentationen beschrieben ein.

Dieses Beispiel geht davon aus, dass ein Dimm-Taster auf den ersten und ein Reset-Taster auf den zweiten Eingang der KL1002 gelegt wurde und sich an der DALI-Adresse 0 eine dimmbare Lampe befindet. Stellen Sie die Fade-Rate des Vorschaltgerätes zunächst auf 7 um ein ansprechendes Dimmen zu erzielen.

Software

Erstellung des SPS-Programms

Erstellen Sie ein neues SPS-Projekt für PC-basierte Systeme (ARM) und fügen die Bibliothek TcDALIV2.lib hinzu.

Erzeugen Sie als Nächstes die folgenden globalen Variablen:

VAR_GLOBAL
    bSwitch          AT %I* : BOOL;
    bReset           AT %I* : BOOL;
    stDALIInData     AT %I* : ST_DALIV2InData;
    stDALIOutData    AT %Q* : ST_DALIV2OutData;
    stCommandBuffer         : ST_DALIV2CommandBuffer;
END_VAR

bSwitch : Eingangsvariable für den Dimm-Taster.

bReset : Eingangsvariable für den Reset-Taster.

stDALIInData : Eingangsvariable für die DALI-Klemme.

stDALIOutData : Ausgangsvariable für die DALI-Klemme.

stCommandBuffer : Wird für die Kommunikation mit DALI benötigt.

Legen Sie anschließend ein Programm (CFC) für die Hintergrundkommunikation mit DALI an. In diesem wird der Baustein FB_DALIV2Communication aufgerufen. Achten Sie beim Kommunikationsbaustein darauf, mit stDALIInData, stDALIOutData und stCommandBuffer zu verknüpfen.

Legen Sie ein MAIN-Programm (CFC) an in dem der Baustein FB_DALIV2Dimmer1Switch aufgerufen wird. Der Eingang bSwitchDimm des Dimmer-Bausteins wird mit der globalen Variable bSwitch verknüpft und stCommandBuffer mit der globalen Variable stCommandBuffer.

Hinweis 		Parameter
Die eingetragenen Parameter nMinlevelMasterDevice und nMaxLevelMasterDevice müssen unbedingt dem Minimal- und Maximalwert des angesprochenen Gerätes entsprechen, da es sonst zu Fehlfunktionen kommen kann.

Gehen Sie in die Taskkonfiguration und legen Sie eine neue Task für die Hintergrundkommunikation an. Fügen Sie dieser Task das Programm für die Kommunikation hinzu. Geben Sie dieser Task eine höhere Priorität (kleinere Zahl) und eine niedrigere Intervall-Zeit als der Standard-Task. Genauere Informationen dazu finden Sie in der Beschreibung des Bausteins FB_DALIV2Communication.

Laden Sie das Projekt als Bootprojekt auf den CX und speichern Sie es ab.

Konfiguration im System Manager

Legen Sie ein neues System-Manager-Projekt an, wählen Sie als Zielsystem den CX und lassen Sie nach dessen Hardware suchen.

Fügen Sie das oben angelegte SPS-Programm unter SPS-Konfiguration hinzu. Beim Aufklappen des SPS-Projekts in der Baumansicht werden die beiden Tasks aufgelistet. Beim Erweitern der Tasks ist sicherzustellen, dass alle globalen Ein- und Ausgangsvariablen der Standard-Task zugeordnet sind. Da die Variablen stDALIInData und stDALIOutData jedoch schneller abgearbeitet werden sollen, müssen diese mit Drag&Drop auf die Hintergrund-Kommunikations-Task verschoben werden.

Verknüpfen Sie die globalen Variablen des SPS-Programms nun mit den Ein- und Ausgängen der Busklemmen, erzeugen Sie die Zuordnungen und aktivieren Sie die Konfiguration. Starten Sie dann das Gerät im Run-Modus.
Ihr CX ist jetzt einsatzbereit.

Durch kurzes oder längeres Drücken auf den Dimm-Taster kann nun die Lampe geregelt werden. Mit dem Reset-Taster können Sie die Einträge in arrBufferMaximumDemandMeter und arrBufferOverflowCounter zurücksetzen.


Integration in TwinCAT (BC9191)

Dieses Beispiel beschreibt, wie ein einfaches SPS-Programm für DALI in TwinCAT geschrieben werden kann und wie es mit der Hardware verknüpft wird. Es soll eine einzelne dimmbare Lampe angesteuert und per Taster verändert werden.

Beispieldateien entpacken

Hardware

Einrichtung der Komponenten

Es wird folgende Hardware benötigt:

  • 1x Busklemmen Controller BC9191
  • 1x Potenzialeinspeiseklemme 24V DC
  • 1x Digitale 2-Kanal-Eingangsklemme KL1002 (für die Dimm und Reset Funktion)
  • 1x DALI-Klemme KL6811
  • 1x Endklemme KL9010

Richten Sie die Hardware sowie die DALI-Komponenten wie in den entsprechenden Dokumentationen beschrieben ein.

Dieses Beispiel geht davon aus, dass ein Dimm-Taster auf den ersten und ein Reset-Taster auf den zweiten Eingang der KL1002 gelegt wurde und sich an der DALI-Adresse 0 eine dimmbare Lampe befindet. Stellen Sie die Fade-Rate des Vorschaltgerätes zunächst auf 7 um ein ansprechendes Dimmen zu erzielen.

Software

Erstellung des SPS-Programms

Erstellen Sie ein neues SPS-Projekt für BC-basierte Systeme (BCxx50 über AMS) und fügen die Bibliotheken TcDALIV2.lbx und TcSystemBCxx50.lbx hinzu. Gehen Sie danach im Menü auf Projekt → Optionen... → Übersetzungsoptionen und wählen LREAL als REAL übersetzen an.

Erzeugen Sie als Nächstes die folgenden globalen Variablen:

VAR_GLOBAL
    bSwitch          AT %I* : BOOL;
    bReset           AT %I* : BOOL;
    stDALIInData     AT %I* : ST_DALIV2InData;
    stDALIOutData    AT %Q* : ST_DALIV2OutData;
    stCommandBuffer         : ST_DALIV2CommandBuffer;
END_VAR

bSwitch : Eingangsvariable für den Dimm-Taster.

bReset : Eingangsvariable für den Reset-Taster.

stDALIInData : Eingangsvariable für die DALI-Klemme.

stDALIOutData : Ausgangsvariable für die DALI-Klemme.

stCommandBuffer : Wird für die Kommunikation mit DALI benötigt.

Da BC-Geräte nur über eine Task verfügen, kann die Kommunikation mit DALI nicht separat ausgeführt werden.

Legen Sie daher ein MAIN-Programm (CFC) an in dem die Bausteine FB_DALIV2Communication und FB_DALIV2Dimmer1Switch aufgerufen werden. Achten Sie beim Kommunikationsbaustein darauf, mit stDALIInData, stDALIOutData und stCommandBuffer zu verknüpfen.

Der Eingang bSwitchDimm des Dimmer-Bausteins wird mit der globalen Variable bSwitch verknüpft und stCommandBuffer mit der globalen Variable stCommandBuffer.

Hinweis 		Parameter
Die eingetragenen Parameter nMinlevelMasterDevice und nMaxLevelMasterDevice müssen unbedingt dem Minimal- und Maximalwert des angesprochenen Gerätes entsprechen, da es sonst zu Fehlfunktionen kommen kann.

Gehen Sie in die Taskkonfiguration und geben Sie der Task eine niedrigere Intervall-Zeit. Genauere Informationen dazu finden Sie in der Beschreibung des Bausteins FB_DALIV2Communication.

Laden Sie das Projekt als Bootprojekt auf den BC und speichern Sie es ab.

Konfiguration im System Manager

Legen Sie ein neues System-Manager-Projekt an, wählen Sie als Zielsystem den BC und lassen Sie nach dessen Hardware suchen.

Fügen Sie das oben angelegte SPS-Programm unter SPS-Konfiguration hinzu.

Verknüpfen Sie die globalen Variablen des SPS-Programms nun mit den Ein- und Ausgängen der Busklemmen, erzeugen Sie die Zuordnungen und aktivieren Sie die Konfiguration. Starten Sie dann das Gerät im Run-Modus.
Ihr BC ist jetzt einsatzbereit.

Durch kurzes oder längeres Drücken auf den Dimm-Taster kann nun die Lampe geregelt werden. Mit dem Reset-Taster können Sie die Einträge in arrBufferMaximumDemandMeter und arrBufferOverflowCounter zurücksetzen.


Variablen

Jedes DALI-Vorschaltgerät besitzt eine bestimmte Anzahl von Variablen (Parameter), aus denen verschiedene Informationen ausgelesen oder auch einzelne Parameter verändert werden können.

Name | Vorgabewert | Rücksetzwert | Gültigkeitsbereich | Größe | Bemerkung
ACTUAL DIM LEVEL | ? | 254 | 0, MIN LEVEL ... MAX LEVEL | 1 Byte |
POWER ON LEVEL | 254 | 254 | 1 ... 254 | 1 Byte |
SYSTEM FAILURE LEVEL | 254 | 254 | 0 ... 255 | 1 Byte |
MIN LEVEL | PHYSICAL MIN LEVEL | PHYSICAL MIN LEVEL | PHYSICAL MIN LEVEL ... MAX LEVEL | 1 Byte |
MAX LEVEL | 254 | 254 | MIN LEVEL ... 254 | 1 Byte |
FADE RATE | 7 | 7 | 1 ... 15 | 1 Byte |
FADE TIME | 0 | 0 | 0 ... 15 | 1 Byte |
SHORT ADDRESS | 255 | keine Änderung | 0 ... 63, 255 | 1 Byte |
SEARCH ADDRESS | FF FF FF | FF FF FF | 00 00 00 ... FF FF FF | 3 Byte |
RANDOM ADDRESS | FF FF FF | FF FF FF | 00 00 00 ... FF FF FF | 3 Byte |
GROUP 0-7 | 0 | 0 | 0 ... 255 | 1 Byte |
GROUP 8-15 | 0 | 0 | 0 ... 255 | 1 Byte |
SCENE 0 | 255 | 255 | 0 ... 255 | 1 Byte |
... | ... | ... | ... | ... |
SCENE 15 | 255 | 255 | 0 ... 255 | 1 Byte |
STATUS INFORMATION | ???? ???? | 0?10 0??? | 0 ... 255 | 1 Byte | nur Lesen
VERSION NUMBER | Hersteller abhängig | Hersteller abhängig | 0 ... 255 | 1 Byte | nur Lesen
DEVICE TYPE | Hersteller abhängig | Hersteller abhängig | 0 ... 255 | 1 Byte | nur Lesen
PHYSICAL MIN LEVEL | Hersteller abhängig | Hersteller abhängig | 1 ... 254 | 1 Byte | nur Lesen

?: unbestimmt

ACTUAL DIM LEVEL

Diese Variable beinhaltet den aktuellen Lampenleistungswert der Lampe.
Mit dem Baustein FB_DALIV2QueryActualLevel() kann der Wert ausgelesen werden.

POWER ON LEVEL

Wird das Vorschaltgerät mit Spannung versorgt, wird die Lampe mit dem Leistungswert angesteuert, der in der Variablen POWER ON LEVEL abgelegt ist. Voraussetzung ist, dass der DALI-Bus schon mit Spannung versorgt wird und in Ruhepegel ist. Der Bereich von POWER ON LEVEL wird durch die beiden Variablen MIN LEVEL und MAX LEVEL begrenzt.
Die Variable kann mit dem Baustein FB_DALIV2QueryPowerOnLevel() gelesen und mit dem Baustein FB_DALIV2StoreDTRAsPowerOnLevel() geschrieben werden.

SYSTEM FAILURE LEVEL

Tritt ein Fehler am DALI-Bus auf (Ruhespannung länger als 500ms unterhalb des festgelegten Pegelbereichs), so wird die Lampe mit dem Leistungswert aus der Variablen SYSTEM FAILURE LEVEL angesteuert. Steht 255 (Maske) in der Variablen, so ändert sich die Lampenleistung nicht. Begrenzt wird der Wertebereich durch MIN LEVEL und MAX LEVEL.
Die Variable kann mit dem Baustein FB_DALIV2QuerySystemFailureLevel() gelesen und mit dem Baustein FB_DALIV2StoreDTRAsSystemFailureLevel() geschrieben werden.

MIN LEVEL / MAX LEVEL

Die Ausgabe des Lampenleistungswertes wird durch die Variablen MIN LEVEL und MAX LEVEL innerhalb des Vorschaltgeräts begrenzt. Ausnahme sind die Leistungswerte 0 (Aus) und 255 (Maske).

FADE RATE

Die FADE RATE (Stufengeschwindigkeit) legt die Veränderungsgeschwindigkeit (in Stufen pro Sekunde) für die Änderung des Lampenleistungswertes fest. Auswirkung hat diese Variable auf die Befehle FB_DALIV2Up() und FB_DALIV2Down(). Die absolute Stufengeschwindigkeit wird nicht direkt angegeben, sondern nach folgender Formel berechnet:

T = absolute Stufengeschwindigkeit
n = Wert, der in der Variablen FADE RATE abgelegt wurde

Es ergeben sich folgende Werte:

n | absolute Stufengeschwindigkeit
0 | nicht erlaubt
1 | 357,796 Stufen/s
2 | 253,000 Stufen/s
3 | 178,898 Stufen/s
4 | 126,500 Stufen/s
5 | 89,449 Stufen/s
6 | 63,250 Stufen/s
7 | 44,725 Stufen/s
8 | 31,625 Stufen/s
9 | 22,362 Stufen/s
10 | 15,813 Stufen/s
11 | 11,181 Stufen/s
12 | 7,906 Stufen/s
13 | 5,591 Stufen/s
14 | 3,953 Stufen/s
15 | 2,795 Stufen/s

FADE TIME

Die FADE TIME (Stufenzeit) legt die Zeit für die Veränderung des aktuellen Lampenleistungswertes zum geforderten Wert fest. Im Falle einer ausgeschalteten Lampe ist die Vorheiz- und Zündzeit nicht in der Stufenzeit enthalten. Betroffen sind dabei die Bausteine FB_DALIV2DirectArcPowerControl() und FB_DALIV2GoToScene(). Die absolute Stufenzeit wird nicht direkt angegeben, sondern nach folgender Formel berechnet:

T = absolute Stufenzeit
n = Wert, der in der Variablen FADE TIME abgelegt wurde

Es ergeben sich folgende Werte:

n | absolute Stufenzeit
0 | < 0,707 s
1 | 0,707 s
2 | 1,000 s
3 | 1,414 s
4 | 2,000 s
5 | 2,828 s
6 | 4,000 s
7 | 5,657 s
8 | 8,000 s
9 | 11,314 s
10 | 16,000 s
11 | 22,627 s
12 | 32,000 s
13 | 45,255 s
14 | 64,000 s
15 | 90,510 s

SHORT ADDRESS

In dieser Variable ist die Kurzadresse abgelegt. Eine gültige Kurzadresse liegt im Wertebereich von 0 bis 63. Wird 255 in die Variable geschrieben, so gilt die Kurzadresse als gelöscht. Gesetzt werden kann die Kurzadresse mit den Bausteinen FB_DALIV2SetShortAddress() und FB_DALIV2StoreDTRAsShortAddress(). Durch den Aufruf des Bausteins FB_DALIV2QueryMissingShortAddress() wird abgefragt, ob ein Vorschaltgerät noch keine Kurzadresse besitzt.

SEARCH ADDRESS

Die Suchadresse wird nur bei der Vergabe von den Kurzadressen benötigt.

RANDOM ADDRESS

Die Zufallsadresse, auch als Langadresse bezeichnet, wird vom Hersteller bei Auslieferung der Vorschaltgeräte vorgegeben. Mit Hilfe des Bausteins FB_DALIV2QueryRandomAddress() kann die 3 Byte lange Zufallsadresse ausgelesen werden.

GROUP 0-7 / GROUP 8-15

Innerhalb eines DALI-Netzes existieren 16 Gruppen. Jedes Vorschaltgerät kann einer, mehreren oder keiner Gruppe gehören. Befehle, die an eine Gruppe geschickt werden, wirken sich auf alle Vorschaltgeräte aus, die zu der entsprechenden Gruppe gehören. Der Baustein FB_DALIV2QueryGroups() liest die beiden 8-Bit Variablen aus und fasst diese zu einem 16-Bit-Wert zusammen. Jedes Bit repräsentiert die Zugehörigkeit zu einer Gruppe.

SCENE 0-15

Jedes DALI-Vorschaltgerät kann Lampenleistunsgwerte für 16 verschiedene Szenen abspeichern. Pro Szene gilt ein Lampenleistungswert. Wird der Befehl zum Aufruf einer Szene (FB_DALIV2GoToScene()) an einem Teilnehmer, eine Gruppe oder an alle (Sammelruf) aufgerufen, so werden jeweils die entsprechenden Lampen auf den abgespeicherten Wert gesetzt. Begrenzt wird die Ausgabe durch MAX LEVEL, MIN LEVEL und PHYSICAL MIN LEVEL.

STATUS INFORMATION

Die Statusinformation enthält die wichtigsten Zustandsmeldungen eines Vorschaltgerätes. Mit dem Baustein FB_DALIV2QueryStatus() kann der 8-Bit-Wert ausgelesen werden. Die Bedeutung der einzelnen Bit ist wie folgt definiert:

Bit | Beschreibung
0 | Status des Vorschaltgerätes. 0: OK.
1 | Lampenausfall. 0: OK.
2 | Lampenleistung ein. 0: AUS.
3 | Grenzwertfehler. 0: letzter angeforderter Lampenleistungswert liegt zwischen MIN LEVEL und MAX LEVEL oder AUS.
4 | Stufung fertig: 0: Stufung beendet. 1: Stufung aktiv.
5 | Rücksetzzustand. 0: Nein.
6 | Kurzadresse fehlt. 0: Nein.
7 | Störung Stromversorgung. 0: Nein, Rücksetzen oder Lampenleistungssteuerbefehl wurde nach dem letzten Einschalten empfangen.

VERSION NUMBER

Die Versionsnummer entspricht der Versionsnummer der IEC-Norm, nach der das Vorschaltgerät entwickelt und hergestellt wurde. Die Versionsnummer kann nur gelesen werden und wird vom Hersteller der Vorschaltgeräte vorgegeben. Die Hauptversion (nMajorVersion) und die Unterversion (nMinorVersion) können einen Wertebereich von je 0 bis 15 (4-Bit) annehmen.

DEVICE TYPE

Der Wert kann mit dem Baustein FB_DALIV2QueryDeviceType() ausgelesen werden. Folgende Gerätetypen sind laut Norm IEC 62386 definiert:

Wert | Beschreibung
0 | Standardgerät.
1 | Gerät für Notbeleuchtung.
2 | Gerät für Entladungslampen.
3 | Gerät für Niedervolt-Halogenlampen.
4 | Gerät zum Dimmen von Glühlampen.
5 | Gerät zur Umwandelung von digitalen Signalen in Gleichspannungssignale.
6 | Gerät für Licht emittierende Dioden (LED).
7 | Gerät für Schaltfunktionen.
8 | Gerät zur Farb-/Farbtemperatursteuerung.
9 | Sequenzer.

PHYSICAL MIN LEVEL

Der physikalisch kleinste mögliche Lampenleistungswert wird vom Hersteller in der Variablen PHYSICAL MIN LEVEL abgelegt. Der Wert kann mit dem Baustein FB_DALIV2QueryPhysicalMinimumLevel() nur ausgelesen werden.


Basis - Funktionsbausteine

Name | Beschreibung
FB_DALIV2Communication | Liest sequentiell die DALI-Befehle aus den Puffern aus und gibt diese zu der KL6811 weiter.
FB_DALIV2SendDALICommand | Dieser Baustein dient zum allgemeinen Senden eines DALI-Kommandos, definiert per Befehlsnummer und, falls erforderlich, Übergabeparameter.


FB_DALIV2Communication

Die Bausteine für die DALI-Befehle greifen nicht direkt auf das Prozessabbild der KL6811 zu, sondern legen die einzelnen DALI-Befehle in drei verschiedene Puffer ab. Der Baustein FB_DALIV2Communication() liest sequentiell die DALI-Befehle aus diesen drei Puffern aus und gibt die DALI-Befehle zu der KL6811 weiter. Hierdurch wird sichergestellt, dass nicht mehrere Bausteine gleichzeitig auf das Prozessabbild der KL6811 zugreifen. Jeder dieser drei Puffer wird mit einer anderen Priorität (hoch, mittel oder niedrig) abgearbeitet. Der Anwender der SPS-Library kann durch den Parameter eCommandPriority, den es bei den meisten Bausteinen gibt, beeinflussen mit welcher Priorität der jeweilige DALI-Befehl von dem Baustein FB_DALIV2Communication() bearbeitet werden soll.

Die Puffer, in denen die DALI-Befehle abgelegt werden, sind alle in einer Variablen vom Typ ST_DALIV2CommandBuffer enthalten. Pro KL6811 gibt es eine Instanz vom Baustein FB_DALIV2Communication() und eine Variable vom Typ ST_DALIV2CommandBuffer. Der Baustein FB_DALIV2Communication() sollte, wenn möglich, in einer separaten, schnelleren Task aufgerufen werden.

Über die Ausgänge des Bausteins kann ermittelt werden, wie stark die Puffer ausgelastet sind. Hierzu werden drei Arrays ausgegeben, bei dem jedes Element (0, 1 oder 2) für einen der drei Buffer (hoch, mittel oder niedrig) steht. Sollten Sie feststellen, dass einer der drei Puffer regelmäßig überläuft, so sollten Sie folgende Maßnahmen in Betracht ziehen:

- Wie stark sind die einzelnen SPS-Task ausgelastet? Der TwinCAT System Manager bietet zur Analyse entsprechende Hilfsmittel an.

- Versuchen Sie die Zykluszeit der Task, in der der Baustein FB_DALIV2Communication() aufgerufen wird, zu verringern. Der Wert sollte nicht größer als 6 ms sein, optimal sind 2 ms.

- Überprüfen Sie die Zykluszeit der SPS-Task, in der die Bausteine für die einzelnen DALI-Befehle aufgerufen werden. Dieser Wert sollte zwischen 10 ms und 60 ms liegen.

- Vermeiden Sie möglichst das Pollen (regelmäßiges Auslesen) von Werten. Lesen Sie nur dann Werte aus, wenn diese auch benötigt werden.

- Verteilen Sie die einzelnen Vorschaltgeräte gleichmäßig auf mehrere DALI-Linien. Da pro SPS-Zyklus mehrere DALI-Linien gleichzeitig bearbeitet werden, erhöht sich hierdurch der Datendurchsatz insgesamt.

VAR_INPUT

bResetMaximumDemandCounter    : BOOL;
bResetOverflowCounter         : BOOL;

bResetMaximumDemandCounter: Eine positive Flanke setzt den gespeicherten Wert der maximalen Befehlspuffer-Auslastung, arrBufferMaximumDemandMeter (0 - 100%, siehe VAR_OUTPUT), zurück.

bResetOverflowCounter: Eine positive Flanke setzt den gespeicherten Wert der Anzahl der Befehlspuffer-Überläufe, arrBufferOverflowCounter (siehe VAR_OUTPUT), zurück.

VAR_OUTPUT

arrBufferDemandMeter          : ARRAY [0..2] OF BYTE;
arrBufferMaximumDemandMeter   : ARRAY [0..2] OF BYTE;
arrBufferOverflowCounter      : ARRAY [0..2] OF UINT;
bLineIsBusy                   : BOOL;
bLineIsInitialized            : BOOL;

arrBufferDemandMeter: Belegung des jeweiligen Puffers (0 - 100%).

arrBufferMaximumDemandMeter: Bisherige maximale Auslastung des jeweiligen Puffers (0 - 100%).

arrBufferOverflowCounter: Bisherige Anzahl der Pufferüberläufe.

bLineIsBusy: Solange der Baustein FB_DALIV2Communication() aktiv ist, ist dieser Ausgang gesetzt.

bLineIsInitialized: Wird der Baustein das erste Mal aufgerufen (z.B. beim Starten der Steuerung), so wird eine Initialisierung durchgeführt. Während dieser Zeit können keine DALI-Befehle bearbeitet werden.

VAR_IN_OUT

stDALIInData        : ST_DALIV2InData;
stDALIOutData       : ST_DALIV2OutData;
stCommandBuffer     : ST_DALIV2CommandBuffer;

stDALIInData: Struktur im Eingangsprozessabbild der KL6811. Sie dient zur Kommunikation von der KL6811 zur SPS.

stDALIOutData: Struktur im Ausgangsprozessabbild der KL6811. Sie dient zur Kommunikation von der SPS zur KL6811.

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SendDALICommand

Dieser Baustein dient zum allgemeinen Senden eines DALI-Kommandos, definiert per Befehlsnummer und, falls erforderlich, Übergabeparameter. Dabei kann weiterhin eingestellt werden, ob der Befehl zweimal wiederholt gesendet wird und ob auf eine Antwort gewartet werden soll. Letzteres kann beispielsweise dazu benutzt werden, eine schnelle Abfolge von Step-Up-Befehlen zu realisieren.

VAR_INPUT

bStart                       : BOOL;
nAddr                        : BYTE;
eAddrType                    : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority             : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nCommand                     : INT := 0;
nParameter                   : BYTE := 0;
bWaitingForDALISlaveResponse : BOOL := FALSE;
bRepeatCommand               : BOOL := FALSE;
bSuppressResponseBuffer      : BOOL := FALSE;
nDeviceType                  : BYTE := 0;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nCommand: Nummer des zu sendenden DALI-Befehls.

nParameter: Parameter zur Wertübergabe.

bWaitingForDALISlaveResponse: Bei FALSE wird nicht auf die Antwort des DALI-Vorschaltgerätes gewartet. Die Anwendung ist im Zusammenhang mit jeder Art von Abfragebefehlen sinnlos.

bRepeatCommand: Entscheidet, ob das Kommando zweimal hintereinander gesendet werden soll.

bSuppressResponseBuffer: Falls TRUE anliegt, wird der interne Software-Puffer nicht mit der Antwort vom Baustein FB_DALIV2Communication() gefüllt.

nDeviceType: Kennung für den Gerätetyp.

Wert | Beschreibung
0 | Standardgerät
1 | Gerät für Notbeleuchtung.
2 | Gerät für Entladungslampen.
3 | Gerät für Niedervolt-Halogenlampen.
4 | Gerät zum Dimmen von Glühlampen.
5 | Gerät zur Umwandelung von digitalen Signalen in Gleichspannungssignale.
6 | Gerät für Licht emittierende Dioden (LED).
7 | Gerät für Schaltfunktionen.
8 | Gerät zur Farb-/Farbtemperatursteuerung.
9 | Sequenzer.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;
nResponseData : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nResponseData: Der empfangende Wert von DALI-Vorschaltgerät, falls ein Abfragebefehl aufgerufen wurde.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;


Leistungsregelung - Funktionsbausteine

Name | Beschreibung
FB_DALIV2DirectArcPowerControl | Lampenleistung direkt vorgeben.
FB_DALIV2Down | Lampenleistung verringern.
FB_DALIV2EnableDAPCSequence | Start einer Direct Arc Power Control (DAPC) Sequenz.
FB_DALIV2GoToScene | Szene aufrufen.
FB_DALIV2Off | Lampe ausschalten.
FB_DALIV2OnAndStepUp | Lampe evtl. einschalten und Lampenleistung um eine Stufe erhöhen.
FB_DALIV2RecallMaxLevel | Lampenleistung auf den Wert MAX LEVEL setzen.
FB_DALIV2RecallMinLevel | Lampenleistung auf den Wert MIN LEVEL setzen.
FB_DALIV2StepDown | Lampenleistung um eine Stufe verringern.
FB_DALIV2StepDownAndOff | Lampenleistung um eine Stufe verringern und Lampe evtl. ausschalten.
FB_DALIV2StepUp | Lampenleistung um eine Stufe erhöhen.
FB_DALIV2Up | Lampenleistung erhöhen.


FB_DALIV2DirectArcPowerControl

Liegt der Parameter nArcPowerLevel außerhalb von MAX VALUE oder MIN VALUE, so wird die Lampe auf den entsprechend kleinsten oder größten Wert geschaltet. Ist die Lampe ausgeschaltet, so wird diese durch den Befehl eingeschaltet.

Die Geschwindigkeit in der der angegebene Sollwert erreicht werden soll, wird durch die Variable FADE TIME angegeben.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nArcPowerLevel    : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nArcPowerLevel: Lampenleistungswert.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Down

Die Lampe wird für 200ms dunkler gedimmt. Ist die Lampenleistung bereits auf den Wert MIN LEVEL, so wird die Helligkeit nicht verändert. Die Lampe wird mit diesem Befehl nicht ausgeschaltet.
Die Geschwindigkeit, mit der innerhalb der 200ms gedimmt werden soll, wird durch die Variable FADE RATE angegeben.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2EnableDAPCSequence

Mit diesem Befehl wird eine Direct Arc Power Control (DAPC) Sequenz gestartet. Nach diesem Befehl müssen DirectArcPowerControl-Befehle mit dem Baustein FB_DALIV2DirectArcPowerControl() versendet werden. Zwischen den einzelnen Befehlen dürfen nicht mehr als 200ms liegen; ansonsten wird die Sequenz beendet.

Hinweis: Dieser Befehl kann nur von DALI-Geräten, die der Norm IEC 62386 entsprechen, ausgeführt werden.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2GoToScene

Dieser Baustein setzt den Lampenleistungswert auf den für die Szene nScene gespeicherten Wert. Wenn das Vorschaltgerät nicht zur Szene gehört, dann bleibt der Lampenleistungswert unverändert. Ist die Lampe ausgeschaltet, so wird diese mit dem Befehl eingeschaltet.
Die Geschwindigkeit, mit der der Lampenleistungswert erreicht werden soll, wird durch die Variable FADE TIME angegeben.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nScene            : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nScene: Szene, die aufgerufen werden soll (0 - 15).

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Off

Die DALI-Lampen werden unmittelbar ausgeschaltet.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer    : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2OnAndStepUp

Dieser Baustein setzt den aktuellen Lampenleistungswert unmittelbar um eine Stufe höher. Ist die Lampe ausgeschaltet, so wird diese eingeschaltet und auf MIN LEVEL gesetzt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2RecallMaxLevel

Dieser Baustein setzt den aktuellen Lampenleistungswert stufenlos auf MAX LEVEL. Wenn die Lampe ausgeschaltet ist, wird sie mit diesem Befehl eingeschaltet.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2RecallMinLevel

Dieser Baustein setzt den aktuellen Lampenleistungswert stufenlos auf MIN LEVEL. Wenn die Lampe ausgeschaltet ist, wird sie mit diesem Befehl eingeschaltet.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StepDown

Dieser Baustein setzt den aktuellen Lampenleistungswert unmittelbar um eine Stufe tiefer. Mit diesem Befehl werden die Lampen nicht ausgeschaltet. Hat der Lampenleistungswert bereits MIN LEVEL erreicht, so wird der Wert nicht weiter verringert.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StepDownAndOff

Dieser Baustein setzt den aktuellen Lampenleistungswert unmittelbar um eine Stufe tiefer. Hat der Lampenleistungswert bereits MIN LEVEL erreicht, so wird die Lampe ausgeschaltet.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StepUp

Dieser Baustein setzt den aktuellen Lampenleistungswert unmittelbar um eine Stufe höher. Mit diesem Befehl werden die Lampen nicht eingeschaltet. Hat der Lampenleistungswert bereits MAX LEVEL erreicht, so wird der Wert nicht weiter erhöht.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Up

Die Lampe wird für 200ms heller gedimmt. Ist die Lampenleistung bereits auf den Wert MAX LEVEL, so wird die Helligkeit nicht verändert. Die Lampe wird mit diesem Befehl nicht eingeschaltet.

Die Geschwindigkeit, mit der innerhalb der 200ms gedimmt werden soll, wird durch die Variable FADE RATE angegeben.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


Konfiguration - Funktionsbausteine

Name | Beschreibung
FB_DALIV2AddToGroup | Fügt ein oder mehrere Vorschaltgeräte zu einer Gruppe hinzu.
FB_DALIV2EnableWriteMemory | Schaltet den Schreibzugriff per FB_DALIV2WriteMemoryLocation() auf den internen Speicher des Vorschaltgerätes frei.
FB_DALIV2RemoveFromGroup | Ein oder mehrere Vorschaltgeräte aus einer Gruppe entfernen.
FB_DALIV2RemoveFromScene | Entfernt das Vorschaltgerät aus einer Szene.
FB_DALIV2Reset | Alle Variablen werden auf die Standardwerte zurückgesetzt.
FB_DALIV2StoreActualLevelInDTR | Schreibt den aktuellen Lampenleistungswert in das DTR.
FB_DALIV2StoreDTRAsFadeRate | Schreibt den Wert des DTR in die Variable FADE RATE.
FB_DALIV2StoreDTRAsFadeTime | Schreibt den Wert des DTR in die Variable FADE TIME.
FB_DALIV2StoreDTRAsMaxLevel | Schreibt den Wert des DTR in die Variable MAX LEVEL.
FB_DALIV2StoreDTRAsMinLevel | Schreibt den Wert des DTR in die Variable MIN LEVEL.
FB_DALIV2StoreDTRAsPowerOnLevel | Schreibt den Wert des DTR in die Variable POWER ON LEVEL.
FB_DALIV2StoreDTRAsScene | Speichert den Inhalt des DTR als Lampenleistungswert zu einer Szene.
FB_DALIV2StoreDTRAsShortAddress | Speichert den Inhalt des DTR als Kurzadresse oder löscht die Kurzadresse.
FB_DALIV2StoreDTRAsSystemFailureLevel | Schreibt den Wert des DTR in die Variable SYSTEM FAILURE LEVEL.


FB_DALIV2AddToGroup

Die adressierten Vorschaltgeräte werden zu der entsprechenden Gruppe (nGroup) hinzugefügt. Eine gültige Gruppenummer liegt im Wertebereich von 0 bis 15.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nGroup            : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nGroup: Gruppennummer (0-15).

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2EnableWriteMemory

Schaltet den Schreibzugriff per FB_DALIV2WriteMemoryLocation() auf den internen Speicher des Vorschaltgerätes frei.

Hinweis: Dieser Befehl kann nur von DALI-Geräten, die der Norm IEC 62386 entsprechen, ausgeführt werden.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer  : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2RemoveFromGroup

Ein oder mehrere Vorschaltgeräte werden aus einer Gruppe entfernt. Eine gültige Gruppennummer liegt im Wertebereich von 0 bis 15.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nGroup            : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nGroup: Gruppe, aus der die Vorschaltgeräte entfernt werden sollen.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2RemoveFromScene

Ein oder mehrere Vorschaltgeräte werden aus einer Szene entfernt. Eine gültige Szenennummer liegt im Wertebereich von 0 bis 15.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nScene            : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

nScene: Szene, aus der die Vorschaltgeräte entfernt werden sollen.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Reset

Mit diesem Baustein werden alle Variablen des Vorschaltgerätes auf die Standardwerte zurückgesetzt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreActualLevelInDTR

Der Baustein schreibt den aktuellen Lampenleistungswert in das DTR. Hierbei wird der aktuelle Lampenleistungswert nicht verändert.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsFadeRate

Schreibt den Wert des DTR in die Variable FADE RATE. Der mögliche Wertebereich beträgt 1 bis 15.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsFadeTime

Der Baustein schreibt den Wert des DTR in die Variable FADE TIME (Stufenzeit). Der mögliche Wertebereich beträgt 1 bis 15.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsMaxLevel

Dieser Baustein schreibt den Wert des DTR in die Variable MAX LEVEL. Wird ein Wert kleiner als MIN LEVEL angegeben, so wird der Wert auf MIN LEVEL gesetzt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsMinLevel

Dieser Baustein schreibt den Wert des DTR in die Variable MIN LEVEL (minimal erlaubte Lampenleistung). Wird ein Wert größer als MAX LEVEL angegeben, so wird der Wert auf MAX LEVEL gesetzt. Ist der Wert kleiner als PHYSICAL MIN LEVEL, so wird MIN LEVEL auf PHYSICAL MIN LEVEL gesetzt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsPowerOnLevel

Dieser Baustein schreibt den Wert des DTR in die Variable POWER ON LEVEL.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsScene

Der Inhalt des DTR wird zu der angegebenen Szene als Lampenleistungswert gespeichert. Der Wertebereich der Szenennummer geht von 0 bis 15.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nScene            : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nScene: Szene, dessen Lampenleistungswert geändert werden soll.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsShortAddress

Der Inhalt des DTR (Data Transfer Register) wird bei dem entsprechenden Vorschaltgerät als Kurzadresse abgespeichert. Die Struktur des DTR ist 0AAA AAA1 (A: Signifikantes Adressbit) oder 1111 1111 (Maske). Steht 1111 1111 im DTR, so wird die Kurzadresse aus dem Vorschaltgerät entfernt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsSystemFailureLevel

Dieser Baustein schreibt den Wert des DTR in die Variable SYSTEM FAILURE LEVEL.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer   : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


Abfrage - Funktionsbausteine

Name | Beschreibung
FB_DALIV2QueryActualLevel | Auslesen der Variable ACTUAL DIM LEVEL (aktuelle Lampenleistung).
FB_DALIV2QueryBallast | Abfrage, ob Vorschaltgerät betriebsbereit ist.
FB_DALIV2QueryContentDTR | Auslesen des DTR (Data Transfer Register).
FB_DALIV2QueryContentDTR1 | Auslesen des DTR1 (Data Transfer Register 1).
FB_DALIV2QueryContentDTR2 | Auslesen des DTR2 (Data Transfer Register 2).
FB_DALIV2QueryDeviceType | Abfrage des Gerätetyps.
FB_DALIV2QueryFadeTimeFadeRate | Auslesen der Variablen FADE RATE (Stufengeschwindigkeit) und FADE TIME (Stufenzeit).
FB_DALIV2QueryGroups | Abfrage der Gruppenzugehörigkeit.
FB_DALIV2QueryGroups0UpTo7 | Abfrage der Gruppenzugehörigkeit (Gruppe 0 bis 7).
FB_DALIV2QueryGroups8UpTo15 | Abfrage der Gruppenzugehörigkeit (Gruppe 8 bis 15).
FB_DALIV2QueryLampFailure | Abfrage, ob ein Lampenausfall vorliegt.
FB_DALIV2QueryLampPowerOn | Abfrage, ob die Lampe eingeschaltet ist.
FB_DALIV2QueryLimitError | Abfrage, ob der letzte Lampenleistungswert nicht eingehalten werden konnte.
FB_DALIV2QueryMaxLevel | Auslesen der Variable MAX LEVEL (maximal erlaubte Lampenleistung).
FB_DALIV2QueryMinLevel | Auslesen der Variable MIN LEVEL (minimal erlaubte Lampenleistung).
FB_DALIV2QueryMissingShortAddress | Abfrage, ob das Vorschaltgerät keine Kurzadresse besitzt.
FB_DALIV2QueryPhysicalMinLevel | Auslesen der Variable PHYSICAL MIN LEVEL (physikalisch kleinste mögliche Lampenleistung).
FB_DALIV2QueryPowerFailure | Abfrage, ob das Vorschaltgerät seit dem Einschalten kein Reset oder keinen Lampenleistungssteuerbefehl empfangen hat.
FB_DALIV2QueryPowerOnLevel | Auslesen der Variable POWER ON LEVEL (Einschaltlampenleistung).
FB_DALIV2QueryRandomAddress | Auslesen der Variable RANDOM ADDRESS (Direktadresse/Langadresse).
FB_DALIV2QueryRandomAddressH | Auslesen des High-Bytes der Variable RANDOM ADDRESS (Direktadresse/Langadresse).
FB_DALIV2QueryRandomAddressL | Auslesen des Low-Bytes der Variable RANDOM ADDRESS (Direktadresse/Langadresse).
FB_DALIV2QueryRandomAddressM | Auslesen des Middle-Bytes der Variable RANDOM ADDRESS (Direktadresse/Langadresse).
FB_DALIV2QueryResetState | Abfrage, ob sich das Vorschaltgerät im Rücksetzzustand befindet.
FB_DALIV2QuerySceneLevel | Abfrage vom Lampenleistungswert einer Szene.
FB_DALIV2QueryStatus | Auslesen der Variable STATUS INFORMATION (Statusinformationen).
FB_DALIV2QuerySystemFailureLevel | Auslesen der Variable SYSTEM FAILURE LEVEL (Lampenleistungswert bei Systemfehler).
FB_DALIV2QueryVersionNumber | Auslesen der Variable VERSION NUMBER (Versionsnummer).
FB_DALIV2ReadMemoryLocation | Auslesen eines 8-Bit Wertes aus dem Speicher des Vorschaltgerätes.


FB_DALIV2QueryActualLevel

Die Variable ACTUAL DIM LEVEL (aktuelle Lampenleistung) wird vom Vorschaltgerät ausgelesen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;
nActualLevel : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nActualLevel: Lampenleistung.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryBallast

Der Baustein gibt Auskunft, ob ein bestimmtes Vorschaltgerät betriebsbereit ist.

Mit diesem Befehl kann sehr einfach festgestellt werden, ob sich an einer DALI-Linie überhaupt Vorschaltgeräte befinden. Hierzu wird der Baustein mit dem Parameter eAddrType = eDALIV2AddrTypeBroadcast aufgerufen. Sind die Ausgänge bBallast FALSE und nError 0, so befindet sich an der DALI-Linie kein Vorschaltgeräte. Ist der Ausgang nError 0 und der Ausgang bBallast TRUE, so befindet sich genau ein Vorschaltgerät an der DALI-Linie. Wenn mehrere Vorschaltgeräte angeschlossen sind, so wird an nError eine 5 (mehrere Vorschaltgeräte haben geantwortet) zurückgegeben. Hierbei ist es gleichgültig ob die Vorschaltgeräte Kurzadressen haben oder nicht.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;
bBallast : BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bBallast: Ist der Ausgang aktiv, so ist das entsprechende Vorschaltgerät betriebsbereit.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryContentDTR

Der Inhalt des DTR (Data Transfer Register) wird aus dem Vorschaltgerät ausgelesen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy          : BOOL;
bError         : BOOL;
nErrorId       : UDINT;
nContentDTR    : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nContentDTR: Inhalt des DTR (Data Transfer Register).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryContentDTR1

Der Inhalt des DTR1 (Data Transfer Register 1) wird aus dem Vorschaltgerät ausgelesen.

Hinweis: Dieser Befehl kann nur von DALI-Geräten, die der Norm IEC 62386 entsprechen, ausgeführt werden.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy          : BOOL;
bError         : BOOL;
nErrorId       : UDINT;
nContentDTR1   : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nContentDTR1: Inhalt des DTR1 (Data Transfer Register 1).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryContentDTR2

Der Inhalt des DTR2 (Data Transfer Register 2) wird aus dem Vorschaltgerät ausgelesen.

Hinweis: Dieser Befehl kann nur von DALI-Geräten, die der Norm IEC 62386 entsprechen, ausgeführt werden.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy          : BOOL;
bError         : BOOL;
nErrorId       : UDINT;
nContentDTR2   : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nContentDTR2: Inhalt des DTR2 (Data Transfer Register 2).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryDeviceType

Es wird aus dem Vorschaltgerät der Gerätetyp (DEVICE TYPE) ausgelesen. Folgende Gerätetypen sind laut Norm IEC 62386 definiert:

Wert | Beschreibung
0 | Standardgerät
1 | Gerät für Notbeleuchtung.
2 | Gerät für Entladungslampen.
3 | Gerät für Niedervolt-Halogenlampen.
4 | Gerät zum Dimmen von Glühlampen.
5 | Gerät zur Umwandelung von digitalen Signalen in Gleichspannungssignale.
6 | Gerät für Licht emittierende Dioden (LED).
7 | Gerät für Schaltfunktionen.
8 | Gerät zur Farb-/Farbtemperatursteuerung.
9 | Sequenzer.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;
nDeviceType : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nDeviceType: Kennung für den Gerätetyp (siehe Tabelle oben).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryFadeTimeFadeRate

Die Variablen FADE TIME (Stufenzeit) und FADE RATE (Stufengeschwindigkeit) werden aus dem Vorschaltgerät ausgelesen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy     : BOOL;
bError    : BOOL;
nErrorId  : UDINT;
nFadeTime : BYTE;
nFadeRate : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nFadeTime: Stufenzeit (0 bis 15).

nFadeRate: Stufengeschwindigkeit (1 bis 15).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryGroups

Die Variablen GROUP 0-7 und GROUP 8-15 werden aus dem Vorschaltgerät ausgelesen und zu einen 16-Bit-Wert verknüpft. Jedes Bit repräsentiert eine Gruppe. Bit 0 Gruppe 0 und Bit 15 Gruppe 15. Ist das Bit gesetzt, so gehört das Vorschaltgerät der entsprechenden Gruppe an.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;
nGroups  : WORD;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nGroups: Gruppenzugehörigkeit.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryGroups0UpTo7

Die Variable GROUP 0-7 wird aus dem Vorschaltgerät ausgelesen und zu einen 8-Bit-Wert verknüpft. Jedes Bit repräsentiert eine Gruppe. Bit 0 Gruppe 0 und Bit 7 Gruppe 7. Ist das Bit gesetzt, so gehört das Vorschaltgerät der entsprechenden Gruppe an.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy          : BOOL;
bError         : BOOL;
nErrorId       : UDINT;
nGroups0UpTo7  : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nGroups0UpTo7: Gruppenzugehörigkeit.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryGroups8UpTo15

Die Variable GROUP 8-15 wird aus dem Vorschaltgerät ausgelesen und zu einen 8-Bit-Wert verknüpft. Jedes Bit repräsentiert eine Gruppe. Bit 0 Gruppe 8 und Bit 7 Gruppe 15. Ist das Bit gesetzt, so gehört das Vorschaltgerät der entsprechenden Gruppe an.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy          : BOOL;
bError         : BOOL;
nErrorId       : UDINT;
nGroups8UpTo15 : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nGroups8UpTo15: Gruppenzugehörigkeit.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryLampFailure

Der Baustein gibt Auskunft, ob ein bestimmtes Vorschaltgerät ein Lampenproblem hat.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;
bLampFailure : BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bLampFailure: Ist der Ausgang aktiv, so hat das entsprechende Vorschaltgerät einen Lampenausfall.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryLampPowerOn

Der Baustein gibt Auskunft, ob die Lampe von einem bestimmten Vorschaltgerät eingeschaltet ist.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;
bLampPowerOn : BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bLampPowerOn: Ist der Ausgang aktiv, so ist die Lampe des entsprechenden Vorschaltgerätes eingeschaltet.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryLimitError

Der Baustein gibt Auskunft, ob der letzte Lampenleistungswert an einem bestimmten Vorschaltgerät nicht eingehalten wurde, da er über MAX LEVEL oder unter MIN LEVEL lag.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;
bLimitError : BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bLimitError: Ist der Ausgang aktiv, so wurde der letzte Lampenleistungswert nicht eingehalten.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryMaxLevel

Die Variable MAX LEVEL (maximal erlaubte Lampenleistung) wird aus dem Vorschaltgerät ausgelesen. Dieser Wert legt die Grenze der Lampenleistungsbefehle nach oben fest.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy     : BOOL;
bError    : BOOL;
nErrorId  : UDINT;
nMaxLevel : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nMaxLevel: maximal erlaubte Lampenleistung (0 - 254).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryMinLevel

Die Variable MIN LEVEL (minimal erlaubte Lampenleistung) wird aus dem Vorschaltgerät ausgelesen. Dieser Wert legt die Grenze der Lampenleistungsbefehle nach unten fest.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;
nMinLevel    : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nMinLevel: minimal erlaubte Lampenleistung (0 - 254).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryMissingShortAddress

Der Baustein gibt Auskunft, ob ein bestimmtes Vorschaltgerät keine Kurzadresse besitzt.

Mit diesem Befehl kann festgestellt werden, ob sich an einer DALI-Linie Vorschaltgeräte ohne Kurzadresse befinden. Hierzu wird der Baustein mit dem Parameter eAddrType = eDALIV2AddrTypeBroadcast aufgerufen. Sind die Ausgänge bMissingShortAddress FALSE und nError 0, so haben alle Vorschaltgeräte eine gültige Kurzadresse. Ist der Ausgang nError 0 und der Ausgang bMissingShortAddress TRUE, so hat genau ein Vorschaltgerät keine Kurzadresse. Wenn mehrere Vorschaltgeräte keine Kurzadresse haben, so wird an nError eine 5 (mehrere Vorschaltgeräte haben geantwortet) zurückgegeben.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy                : BOOL;
bError               : BOOL;
nErrorId             : UDINT;
bMissingShortAddress : BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bMissingShortAddress: Ist der Ausgang aktiv, so besitzt das entsprechende Vorschaltgerät keine Kurzadresse.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryPhysicalMinLevel

Die Variable PHYSICAL MIN LEVEL (physikalisch kleinstmögliche Lampenleistung) wird aus dem Vorschaltgerät ausgelesen. Der Wert kann nur gelesen werden und wird vom Hersteller fest vorgegeben.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy             : BOOL;
bError            : BOOL;
nErrorId          : UDINT;
nPhysicalMinLevel : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nPhysicalMinLevel: physikalisch kleinstmögliche Lampenleistung (0 - 254).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryPowerFailure

Abfrage, ob das Vorschaltgerät seit dem Einschalten keinen Reset oder keinen Lampenleistungssteuerbefehl empfangen hat.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;
bPowerFailure : BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bPowerFailure: Ist der Ausgang aktiv, so wurde noch kein Lampenleistungssteuerbefehl an das Vorschaltgerät gesendet.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryPowerOnLevel

Die Variable POWER ON LEVEL (Einschaltlampenleistung) wird aus dem Vorschaltgerät ausgelesen. Direkt nach dem Anlegen der Stromversorgung schaltet das Vorschaltgerät die Lampe auf diesen Lampenleistungswert.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;
nPowerOnLevel : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nPowerOnLevel: Einschaltlampenleistung (0 - 254).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryRandomAddress

Die Variable RANDOM ADDRESS (Zufallsadresse) wird aus dem Vorschaltgerät ausgelesen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy          : BOOL;
bError         : BOOL;
nErrorId       : UDINT;
nRandomAddress : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nRandomAddress: Zufallsadresse / Langadresse des Vorschaltgerätes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryRandomAddressH

Das höherwertige Byte der Variable RANDOM ADDRESS (Zufallsadresse) wird aus dem Vorschaltgerät ausgelesen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy           : BOOL;
bError          : BOOL;
nErrorId        : UDINT;
nRandomAddressH : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nRandomAddressH: Das höherwertige Byte der Zufallsadresse / Langadresse.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryRandomAddressL

Das niederwertige Byte der Variable RANDOM ADDRESS (Zufallsadresse) wird aus dem Vorschaltgerät ausgelesen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy           : BOOL;
bError          : BOOL;
nErrorId        : UDINT;
nRandomAddressL : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nRandomAddressL: Das niederwertige Byte der Zufallsadresse / Langadresse.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryRandomAddressM

Das mittlere Byte der Variable RANDOM ADDRESS (Zufallsadresse) wird aus dem Vorschaltgerät ausgelesen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy           : BOOL;
bError          : BOOL;
nErrorId        : UDINT;
nRandomAddressM : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nRandomAddressM: Das mittlere Byte der Zufallsadresse / Langadresse.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryResetState

Der Baustein gibt Auskunft, ob sich ein bestimmtes Vorschaltgerät im Rücksetzzustand befindet.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;
bResetState : BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bResetState: Ist der Ausgang aktiv, so befindet sich das entsprechende Vorschaltgerät im Rücksetzzustand.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QuerySceneLevel

Der Lampenleistungswert der entsprechenden Szene wird aus dem Vorschaltgerät ausgelesen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nScene            : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nScene: Szene, von dem der Lampenleistungswert ausgelesen werden soll (0 - 15).

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;
nSceneLevel : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nSceneLevel: Lampenleistungswert der Szene.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryStatus

Die Variable STATUS INFORMATION (Statusinformationen) wird aus dem Vorschaltgerät ausgelesen. Die Statusinformation enthält die acht wichtigsten Zustandsmeldungen eines Vorschaltgerätes. Hierbei ist die Bedeutung der einzelnen Bit wie folgt definiert:

Bit | Beschreibung
0 | Status des Vorschaltgerätes. 0: OK.
1 | Lampenausfall. 0: OK.
2 | Lampenleistung ein. 0: AUS.
3 | Grenzwertfehler. 0: letzter angeforderter Lampenleistungswert liegt zwischen MIN LEVEL und MAX LEVEL oder AUS.
4 | Stufung fertig: 0: Stufung beendet. 1: Stufung aktiv.
5 | Rücksetzzustand. 0: Nein.
6 | Kurzadresse fehlt. 0: Nein.
7 | Störung Stromversorgung. 0: Nein, Rücksetzen oder Lampenleistungssteuerbefehl wurde nach dem letzten Einschalten empfangen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;
nStatus     : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nStatus: Statusinformationen (siehe Tabelle oben).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QuerySystemFailureLevel

Die Variable SYSTEM FAILURE LEVEL (Lampenleistungswert bei Systemfehler) wird aus dem Vorschaltgerät ausgelesen. Wird am DALI-Bus ein Fehler (z.B. das Fehlen der Versorgungsspannung) erkannt, so schaltet das Vorschaltgerät die Lampe auf diesen Lampenleistungswert.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy               : BOOL;
bError              : BOOL;
nErrorId            : UDINT;
nSystemFailureLevel : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nSystemFailureLevel: Lampenleistungswert bei einem Systemfehler.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryVersionNumber

Die Variable VERSION NUMBER (Versionsnummer) wird aus dem Vorschaltgerät ausgelesen. Die Versionsnummer entspricht der Versionsnummer der IEC-Norm, nach der die Software und die Hardware des Vorschaltgerätes entwickelt und hergestellt wurde. Die Versionsnummer kann nur gelesen werden und wird vom Hersteller vorgegeben. Die Hauptversion (nMajorVersion) und die Unterversion (nMinorVersion) können einen Wertebereich von je 0 bis 15 (4-Bit) annehmen.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;
nMajorVersion : BYTE;
nMinorVersion : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nMajorVersion: Hauptversionsnummer.

nMinorVersion: Unterversionsnummer.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2ReadMemoryLocation

Es wird ein Byte aus dem Speicher des Vorschaltgerätes ausgelesen. Die genaue Speicherbank wird durch das DTR1 angegeben und die Adresse innerhalb der Speicherbank durch das DTR.

Hinweis: Dieser Befehl kann nur von DALI-Geräten, die der Norm IEC 62386 entsprechen, ausgeführt werden.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy     : BOOL;
bError    : BOOL;
nErrorId  : UDINT;
nData     : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nData: gelesenes Byte aus dem Speicher des Vorschaltgerätes.

VAR_IN_OUT

stCommandBuffer   : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


Spezielle Befehle - Funktionsbausteine

Name | Beschreibung
FB_DALIV2Compare | Das Vorschaltgerät vergleicht seine Zufallsadresse (RANDOM ADDRESS) mit der Suchadresse (SEARCH ADDRESS).
FB_DALIV2EnableDeviceType | Es wird auf einen anwendungsbezogenen Erweiterungsbefehl umgeschaltet.
FB_DALIV2Initialise | Startet die Adressierung der Vorschaltgeräte.
FB_DALIV2PhysicalSelection | Alle Vorschaltgeräte, die diesen Befehl empfangen, gehen in die Betriebsart physikalische Auswahl.
FB_DALIV2ProgramShortAddress | Alle ausgewählten Vorschaltgeräte speichern den Wert nShortAddress (SHORT ADDRESS) als Kurzadresse ab.
FB_DALIV2QueryShortAddress | Ist die Zufallsadresse (RANDOM ADDRESS) gleich der Suchadresse (SEARCH ADDRESS) so sendet das Vorschaltgerät seine Kurzadresse.
FB_DALIV2Randomise | Die Vorschaltgeräte erzeugen eine neue Zufallsadresse (RANDOM ADDRESS).
FB_DALIV2SearchAddr | Dieser Baustein setzt die Suchadresse (SEARCH ADDRESS).
FB_DALIV2SearchAddrH | Dieser Baustein setzt die oberen 8 Bit der 24-Bit Suchadresse (SEARCH ADDRESS).
FB_DALIV2SearchAddrL | Dieser Baustein setzt die unteren 8 Bit der 24-Bit Suchadresse (SEARCH ADDRESS).
FB_DALIV2SearchAddrM | Dieser Baustein setzt die mittleren 8 Bit der 24-Bit Suchadresse (SEARCH ADDRESS).
FB_DALIV2SetDTR | Schreibt einen 8-Bit-Wert in das DTR aller Vorschaltgeräte.
FB_DALIV2SetDTR1 | Schreibt einen 8-Bit-Wert in das DTR1 aller Vorschaltgeräte.
FB_DALIV2SetDTR2 | Schreibt einen 8-Bit-Wert in das DTR2 aller Vorschaltgeräte.
FB_DALIV2Terminate | Bei allen Vorschaltgeräten wird die Adressierung beendet.
FB_DALIV2VerifyShortAddress | Ist bei dem Vorschaltgerät die Kurzadresse gleich dem Parameter nShortAddress, so wird der Ausgang bAnswer auf TRUE gesetzt.
FB_DALIV2Withdraw | Vorschaltgeräte, bei denen die Zufallsadresse (RANDOM ADDRESS) gleich der Suchadresse (SEARCH ADDRESS) ist, dürfen nicht länger auf den Befehl FB_DALIV2Compare() reagieren.
FB_DALIV2WriteMemoryLocation | Schreibt einen 8-Bit-Wert in den Speicher eines Vorschaltgerätes. Zuvor muss der Zugriff auf den Speicher mit dem Befehl FB_DALIV2EnableWriteMemory() freigeschaltet werden.


FB_DALIV2Compare

Das Vorschaltgerät vergleicht seine Zufallsadresse (RANDOM ADDRESS) mit der Suchadresse (SEARCH ADDRESS). Ist die Zufallsadresse kleiner oder gleich der Suchadresse und ist das Vorschaltgerät nicht ausgeschlossen, dann wird der Ausgang bAnswer auf TRUE gesetzt.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;
bAnswer      : BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bAnswer: Die Zufallsadresse ist kleiner oder gleich der Suchadresse.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2EnableDeviceType

Dieser Befehl muss jedes Mal vor einem anwendungsbezogenen Erweiterungsbefehl gesendet werden. Hierdurch reagieren nur die Vorschaltgeräte, die auch zu dem entsprechenden Gerätetyp (DEVICE TYPE) gehören. Für den Gerätetyp 0 braucht der Befehl nicht angewendet werden. Folgende Gerätetypen sind laut Norm IEC 62386 definiert:

Wert | Beschreibung
0 | Standardgerät
1 | Gerät für Notbeleuchtung.
2 | Gerät für Entladungslampen.
3 | Gerät für Niedervolt-Halogenlampen.
4 | Gerät zum Dimmen von Glühlampen.
5 | Gerät zur Umwandelung von digitalen Signalen in Gleichspannungssignale.
6 | Gerät für Licht emittierende Dioden (LED).
7 | Gerät für Schaltfunktionen.
8 | Gerät zur Farb-/Farbtemperatursteuerung.
9 | Sequenzer.

VAR_INPUT

bStart             : BOOL;
eCommandPriority   : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nDeviceType        : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nDeviceType: Kennung für den Gerätetyp (siehe Tabelle oben).

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Initialise

Mit diesem Befehl wird die Adressierung der Vorschaltgeräte gestartet. Durch den Baustein FB_DALIV2Terminate() muss die Adressierung wieder beendet werden. Die maximale Dauer ist auf 15 min begrenzt. Jedes Vorschaltgerät beendet selbstständig, nach Ablauf der 15 min, die Adressierung. Die Reaktion der Vorschaltgeräte, die diesen Befehl empfangen, ist von dem Parameter nParameter abhängig:

Wert (binär) | Beschreibung
0000 0000 | Alle Vorschaltgeräte reagieren.
0AAA AAA1 | Vorschaltgeräte mit der Adresse AAA AAA reagieren.
1111 1111 | Vorschaltgeräte ohne Kurzadresse reagieren.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nParameter        : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nParameter: Gibt vor, welche Vorschaltgeräte auf diesen Befehl reagieren sollen (siehe Tabelle oben).

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2PhysicalSelection

Alle Vorschaltgeräte, die diesen Befehl empfangen, gehen in die Betriebsart physikalische Auswahl. In dieser Betriebsart wird das Vergleichen der Zufallsadresse (RANDOM ADDRESS) mit der Suchadresse (SEARCH ADDRESS) gesperrt.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2ProgramShortAddress

Alle ausgewählten Vorschaltgeräte speichern den Wert nShortAddress (SHORT ADDRESS) als Kurzadresse ab.

Ausgewählt bedeutet:

  • Die Zufallsadresse (RANDOM ADDRESS) des Vorschaltgerätes ist gleich der Suchadresse (SEARCH ADDRESS).
  • Die physikalische Auswahl wurde vom Vorschaltgerät festgestellt, da die Lampe vom Vorschaltgerät getrennt wurde (nach dem Empfang des Befehls FB_DALIV2PhysicalSelection()).

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nShortAddress     : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nShortAddress: Kurzadresse, die den ausgewählten Vorschaltgeräten zugewiesen werden soll (0 - 63).

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryShortAddress

Ist das Vorschaltgerät ausgewählt, so sendet es seine Kurzadresse (SHORT ADDRESS).

Ausgewählt bedeutet:

  • Die Zufallsadresse (RANDOM ADDRESS) des Vorschaltgerätes ist gleich der Suchadresse (SEARCH ADDRESS).
  • Die physikalische Auswahl wurde vom Vorschaltgerät festgestellt, da die Lampe vom Vorschaltgerät getrennt wurde (nach dem Empfang des Befehls FB_DALIV2PhysicalSelection()).

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;
nShortAddress : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nShortAddress: Kurzadresse vom Vorschaltgerät (0 - 63).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Randomise

Die Vorschaltgeräte erzeugen eine neue Zufallsadresse (RANDOM ADDRESS).

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SearchAddr

Dieser Baustein setzt die Suchadresse (SEARCH ADDRESS).

VAR_INPUT

bStart              : BOOL;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nSearchAddr         : UDINT;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nSearchAddr: Suchadresse.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SearchAddrH

Dieser Baustein setzt die oberen 8 Bit der 24-Bit Suchadresse (SEARCH ADDRESS).

VAR_INPUT

bStart              : BOOL;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nHighByteSearchAddr : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nHighByteSearchAddr: oberen 8 Bit der 24-Bit Suchadresse.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SearchAddrL

Dieser Baustein setzt die unteren 8 Bit der 24-Bit Suchadresse (SEARCH ADDRESS).

VAR_INPUT

bStart              : BOOL;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nLowByteSearchAddr  : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nLowByteSearchAddr: unteren 8 Bit der 24-Bit Suchadresse.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SearchAddrM

Dieser Baustein setzt die mittleren 8 Bit der 24-Bit Suchadresse (SEARCH ADDRESS).

VAR_INPUT

bStart              : BOOL;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nMidByteSearchAddr  : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nMidByteSearchAddr: mittleren 8 Bit der 24-Bit Suchadresse.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SetDTR

Der Befehl steht nur als Sammelruf (Broadcast) zur Verfügung. Es wird das DTR aller Vorschaltgeräte beschrieben.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nDTR              : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nDTR: Wert, der in das DTR geschrieben werden soll.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SetDTR1

Der Befehl steht nur als Sammelruf (Broadcast) zur Verfügung. Es wird das DTR1 aller Vorschaltgeräte beschrieben.

Hinweis: Dieser Befehl kann nur von DALI-Geräten, die der Norm IEC 62386 entsprechen, ausgeführt werden.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nDTR1             : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nDTR1: Wert, der in das DTR1 geschrieben werden soll.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SetDTR2

Der Befehl steht nur als Sammelruf (Broadcast) zur Verfügung. Es wird das DTR2 aller Vorschaltgeräte beschrieben.

Hinweis: Dieser Befehl kann nur von DALI-Geräten, die der Norm IEC 62386 entsprechen, ausgeführt werden.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nDTR2             : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nDTR2: Wert, der in das DTR2 geschrieben werden soll.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Terminate

Bei allen Vorschaltgeräten wird die Adressierung beendet.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2VerifyShortAddress

Ist bei dem Vorschaltgerät die Kurzadresse gleich dem Parameter nShortAddress, so wird der Ausgang bAnswer auf TRUE gesetzt.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nShortAddress     : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nShortAddress: Kurzadresse mit der die eigene Kurzadresse verglichen werden soll.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;
bAnswer     : BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bAnswer: Parameter nShortAddress ist gleich der eigenen Kurzadresse.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Withdraw

Vorschaltgeräte, bei denen die Zufallsadresse (RANDOM ADDRESS) gleich der Suchadresse (SEARCH ADDRESS) ist, dürfen nicht länger auf den Befehl FB_DALIV2Compare() reagieren.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2WriteMemoryLocation

Der Befehl steht nur als Sammelruf (Broadcast) zur Verfügung. Der Wert nData wird in den Speicher des Vorschaltgerätes geschrieben. Die genaue Speicherbank wird durch das DTR1 angegeben und die Adresse innerhalb der Speicherbank durch das DTR. Damit dieser Befehl wirksam ist, muss zuvor der Befehl FB_DALIV2EnableWriteMemory() aufgerufen werden.

Hinweis: Dieser Befehl kann nur von DALI-Geräten, die der Norm IEC 62386 entsprechen, ausgeführt werden.

VAR_INPUT

bStart            : BOOL;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nData             : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nData: Wert, der in den Speicher des Vorschaltgerätes geschrieben werden soll.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DSIDirectArcPowerControl

Der Parameter nArcPowerLevel gibt die Helligkeit vor, auf die die Lampe geschaltet wird.

nArcPowerLevel | Bemerkung
0 | Lampe wird ausgeschaltet
1 | Lampe wird auf die minimale Helligkeit geschaltet
255 | Lampe wird auf die maximale Helligkeit geschaltet

Vorschaltgeräte mit DSI-Schnittstelle haben keine Kurzadresse. Alle Vorschaltgeräte an einer DSI-Linie erhalten den gleichen Wert.

Beachten Sie bitte, dass die KL6811 in den DSI-Mode umgeschaltet werden muss. Einzelheiten hierzu finden Sie in der Anleitung zur KL6811.

DSI-Vorschaltgeräte und DALI-Vorschaltgeräte können nicht an einer Linie gemischt werden. Es ist aber möglich, mehrere KL6811 an einem Controller in je unterschiedlichen Betriebsarten (DSI/DALI) zu betreiben.

VAR_INPUT

bStart               : BOOL;
eCommandPriority     : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nArcPowerLevel       : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nArcPowerLevel: Lampenleistungswert (0 ... 255).

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


Adressierung - Funktionsbausteine

Name | Beschreibung
FB_DALIV2AddressingPhysicalSelection | Adressiert die Vorschaltgeräte nach dem Adressierungsverfahren durch 'physikalische Auswahl'.
FB_DALIV2AddressingRandomAddressing | Adressiert die Vorschaltgeräte nach dem Zufallsprinzip.
FB_DALIV2AddressingIntRandomAddressing | Adressiert die Vorschaltgeräte nach dem Zufallsprinzip. Es wird hierbei die interne Adressierungsfunktion der KL6811 genutzt.
FB_DALIV2SetShortAddress | Vorschaltgeräte erhalten eine (neue) Kurzadresse.
FB_DALIV2SwapShortAddress | Vertauschen der Kurzadressen zweier Vorschaltgeräte.
FB_DALIV2SwapShortAddressList | Vertauscht Kurzadressen mehrerer Vorschaltgeräte.
FB_DALIV2ChangeAddressList | Mit diesem Funktionsbaustein können die Kurzadressen mehrerer Vorschaltgeräte geändert werden.


FB_DALIV2AddressingIntRandomAddressing

Dieser Funktionsbaustein adressiert die Vorschaltgeräte nach dem Zufallsprinzip. Der Anwender hat keinen Einfluss darauf, welches Vorschaltgerät welche Kurzadresse zugewiesen bekommt. Die Vergabe der Kurzadressen erfolgt aufsteigend.

Durch eine positive Flanke an dem Eingang bStart wird der Baustein gestartet und der Ausgang bBusy geht auf TRUE. Abhängig von den gewählten Optionen (Parameter nOptions) werden anschließend die Gruppenzugehörigkeit und die Szenen gelöscht. Die Klemme adressiert jetzt selbständig alle Vorschaltgeräte. Sind alle Vorschaltgeräte adressiert, so geht der Ausgang bBusy wieder auf FALSE. Die Ausgangsvariable nAddressedDevices gibt Auskunft darüber, wie viele Vorschaltgeräte eine Kurzadresse erhalten haben. Abhängig davon, wie viele Vorschaltgeräte angeschlossen sind, kann die Abarbeitung dieses Bausteines mehrere Minuten dauern. Dadurch, das die Adressierung von der Klemme direkt ausgeführt wird, ist diese Methode etwas schneller als der Baustein FB_DALIV2AddressingRandomAddressing(). Allerdings liefert dieser Baustein keine Rückmeldungen während des Adressierens. Auch kann das Adressieren nicht vorzeitig abgebrochen werden.

Dieser Baustein kann nur ausgeführt werden, wenn die Firmware der Klemme den Stand 2A oder Neuer hat.

VAR_INPUT

bStart                   : BOOL;
nStartWithShortAddress   : BYTE;
nOptions                 : DWORD := DALIV2_OPTION_OPTICAL_FEEDBACK;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert und somit die Adressierung gestartet.

nStartWithShortAddress: Kurzadresse, die dem ersten Vorschaltgerät zugewiesen wird (0 ... 63).

nOptions: Optionen für die Adressierung der Vorschaltgeräte (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_COMPLETE_NEW_INSTALLATION | Es werden alle Vorschaltgeräte neu adressiert, auch die, die schon eine Kurzadresse haben.
DALIV2_OPTION_DELETE_ALL_GROUP_ASSIGNMENTS | Vor dem Adressieren werden bei allen Vorschaltgeräten, auch bei denen die evtl. nicht adressiert werden, die Gruppenzugehörigkeiten (siehe Variablen GROUP 0-7 und GROUP 8-15) gelöscht.
DALIV2_OPTION_DELETE_ALL_SCENE_ASSIGNMENTS | Vor dem Adressieren werden bei allen Vorschaltgeräten, auch bei denen die evtl. nicht adressiert werden, die Szenen (siehe Variablen SCENE 0 bis SCENE 15) gelöscht.
DALIV2_OPTION_OPTICAL_FEEDBACK | Vor dem Adressieren werden alle Vorschaltgeräte auf MIN LEVEL gesetzt. Neu adressierte Vorschaltgeräte erhalten nach der Zuweisung der Kurzadresse die Helligkeit MAX LEVEL.

VAR_OUTPUT

bBusy                    : BOOL;
bError                   : BOOL;
nErrorId                 : UDINT;
nAddressedDevices        : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nAddressedDevices: Ist das Adressieren abgeschlossen (bBusy ist FALSE), so wird an diesem Ausgang die Anzahl der adressierten Vorschaltgeräte angezeigt.

VAR_IN_OUT

stCommandBuffer          : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2AddressingPhysicalSelection

Dieser Funktionsbaustein adressiert die Vorschaltgeräte nach dem Adressierungsverfahren durch 'physikalische Auswahl'. Damit ist gemeint, dass die einzelnen Vorschaltgeräte durch Entfernen der Leuchtmittel selektiert und somit adressiert werden. Die Vergabe der Kurzadressen erfolgt aufsteigend, in der gleichen Reihenfolge wie die Leuchtmittel entfernt werden.

Durch eine positive Flanke an dem Eingang bStart wird der Baustein gestartet und der Ausgang bBusy geht auf TRUE. Abhängig von den gewählten Optionen (Parameter nOptions) werden anschließend die Gruppenzugehörigkeit und die Szenen gelöscht. Der Ausgang eCurrentAddressingState gibt den Anwender den nächsten notwendigen Arbeitsschritt vor. Hierdurch wird z.B. vorgegeben ob bei dem nächsten Vorschaltgerät das Leuchtmittel entfernt, oder ob es wieder eingesetzt werden soll. Die Ausgangsvariable arrAddressedDevices gibt Auskunft darüber, welche Vorschaltgeräte schon eine Kurzadresse erhalten haben. Sind alle Vorschaltgeräte adressiert, so wird durch eine positive Flanke an dem Eingang bStop die Adressierung beendet und der Ausgang bBusy geht wieder auf FALSE.

VAR_INPUT

bStart                   : BOOL;
bStop                    : BOOL;
nStartWithShortAddress   : BYTE;
nOptions                 : DWORD := DALIV2_OPTION_OPTICAL_FEEDBACK;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert und somit die Adressierung gestartet.

bStop: Über eine positive Flanke an diesem Eingang wird der Baustein deaktiviert und somit die Adressierung gestoppt.

nStartWithShortAddress: Kurzadresse, die dem ersten Vorschaltgerät zugewiesen wird (0 ... 63).

nOptions: Optionen für die Adressierung der Vorschaltgeräte (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_COMPLETE_NEW_INSTALLATION | Es werden alle Vorschaltgeräte neu adressiert, auch die, die schon eine Kurzadresse haben.
DALIV2_OPTION_DELETE_ALL_GROUP_ASSIGNMENTS | Vor dem Adressieren werden bei allen Vorschaltgeräten, auch bei denen die evtl. nicht adressiert werden, die Gruppenzugehörigkeiten (siehe Variablen GROUP 0-7 und GROUP 8-15) gelöscht.
DALIV2_OPTION_DELETE_ALL_SCENE_ASSIGNMENTS | Vor dem Adressieren werden bei allen Vorschaltgeräten, auch bei denen die evtl. nicht adressiert werden, die Szenen (siehe Variablen SCENE 0 bis SCENE 15) gelöscht.
DALIV2_OPTION_OPTICAL_FEEDBACK | Vor dem Adressieren werden alle Vorschaltgeräte auf MIN LEVEL gesetzt. Neu adressierte Vorschaltgeräte erhalten nach der Zuweisung der Kurzadresse die Helligkeit MAX LEVEL.

VAR_OUTPUT

bBusy                    : BOOL;
bError                   : BOOL;
nErrorId                 : UDINT;
arrAddressedDevices      : ARRAY [0..63] OF BOOL;
eCurrentAddressingState  : E_DALIV2CurrentAddressingState;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

arrAddressedDevices: Wird einem Vorschaltgerät eine Kurzadresse zugewiesen, so wird in dem Array das entsprechende Element auf TRUE gesetzt. Der Index spiegelt dabei die Kurzadresse des Vorschaltgerätes wider.

eCurrentAddressingState: Die Ausgangsvariable gibt den aktuellen Arbeitsschritt an (siehe Tabelle).

Element | Beschreibung
eDALIV2AddrStateIdle | Es findet keine Adressierung statt.
eDALIV2AddrStateRemoveLamp | Der Baustein wartet darauf, dass an einem Vorschaltgerät das Leuchtmittel entfernt wird.
eDALIV2AddrStateReinsertLamp | Der Baustein hat das Vorschaltgerät erkannt an dem das Leuchtmittel entfernt wurde (das Vorschaltgerät ist selektiert) und wartet jetzt darauf, dass es wieder eingesetzt wird.
eDALIV2AddrStateAddressingLamp | Das selektierte Vorschaltgerät wird adressiert.

VAR_IN_OUT

stCommandBuffer          : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2AddressingRandomAddressing

Dieser Funktionsbaustein adressiert die Vorschaltgeräte nach dem Zufallsprinzip. Der Anwender hat keinen Einfluss darauf, welches Vorschaltgerät welche Kurzadresse zugewiesen bekommt. Die Vergabe der Kurzadressen erfolgt aufsteigend.

Durch eine positive Flanke an dem Eingang bStart wird der Baustein gestartet und der Ausgang bBusy geht auf TRUE. Abhängig von den gewählten Optionen (Parameter nOptions) werden anschließend die Gruppenzugehörigkeit und die Szenen gelöscht. Der Baustein adressiert jetzt selbständig alle Vorschaltgeräte. Die Ausgangsvariable arrAddressedDevices gibt Auskunft darüber, welche Vorschaltgerätes schon eine Kurzadresse erhalten haben. Sind alle Vorschaltgeräte adressiert, so geht der Ausgang bBusy wieder auf FALSE. Die Adressierung kann vorzeitig durch eine positive Flanke am Eingang bCancel abgebrochen werden. Abhängig davon, wie viele Vorschaltgeräte angeschlossen sind, kann die Abarbeitung dieses Bausteines mehrere Minuten dauern.

VAR_INPUT

bStart                   : BOOL;
bCancel                  : BOOL;
nStartWithShortAddress   : BYTE;
nOptions                 : DWORD := DALIV2_OPTION_OPTICAL_FEEDBACK;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert und somit die Adressierung gestartet.

bCancel: Über eine positive Flanke an diesem Eingang wird der Baustein deaktiviert und somit die Adressierung abgebrochen.

nStartWithShortAddress: Kurzadresse, die dem ersten Vorschaltgerät zugewiesen wird (0 ... 63).

nOptions: Optionen für die Adressierung der Vorschaltgeräte (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_COMPLETE_NEW_INSTALLATION | Es werden alle Vorschaltgeräte neu adressiert, auch die, die schon eine Kurzadresse haben.
DALIV2_OPTION_DELETE_ALL_GROUP_ASSIGNMENTS | Vor dem Adressieren werden bei allen Vorschaltgeräten, auch bei denen die evtl. nicht adressiert werden, die Gruppenzugehörigkeiten (siehe Variablen GROUP 0-7 und GROUP 8-15) gelöscht.
DALIV2_OPTION_DELETE_ALL_SCENE_ASSIGNMENTS | Vor dem Adressieren werden bei allen Vorschaltgeräten, auch bei denen die evtl. nicht adressiert werden, die Szenen (siehe Variablen SCENE 0 bis SCENE 15) gelöscht.
DALIV2_OPTION_OPTICAL_FEEDBACK | Vor dem Adressieren werden alle Vorschaltgeräte auf MIN LEVEL gesetzt. Neu adressierte Vorschaltgeräte erhalten nach der Zuweisung der Kurzadresse die Helligkeit MAX LEVEL.
DALIV2_OPTION_WITHOUT_RANDOMISE | Der Befehl RANDOMISE wird vor der Adressierung nicht aufgerufen. Hierdurch behalten alle Vorschaltgeräte ihre bisherige Zufallsadresse (RANDOM ADDRESS) bei. Benutzen Sie diese Option nur, wenn es zwingend notwendig ist.

VAR_OUTPUT

bBusy                    : BOOL;
bError                   : BOOL;
nErrorId                 : UDINT;
nCurrentSearchAddress    : UDINT;
arrAddressedDevices      : ARRAY [0..63] OF BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nCurrentSearchAddress: Aktuelle Suchadresse (SEARCH ADDRESS).

arrAddressedDevices: Wird einem Vorschaltgerät eine Kurzadresse zugewiesen, so wird in dem Array das entsprechende Element auf TRUE gesetzt. Der Index spiegelt dabei die Kurzadresse des Vorschaltgerätes wider.

VAR_IN_OUT

stCommandBuffer          : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2ChangeAddressList

Mit diesem Funktionsbaustein können die Kurzadressen mehrerer Vorschaltgeräte geändert werden. Im Gegensatz zum Baustein FB_DALIV2SwapShortAddressList ist es nicht notwendig, dass eine freie, unbenutzte Kurzadresse in der DALI-Line vorhanden ist.

In dem Array arrChangeAddressList vom Typ ST_DALIV2ChangeAddressList wird eine Liste mit den Vorschaltgeräten übergeben, bei denen die Kurzadresse geändert werden soll. Die Liste hat 64 Einträge von 0 bis 63. jeder Eintrag enthält eine Variable nOldAddress und nNewAddress mit dem die Adresszuordnung parametriert wird. Das Listen-Ende wird mit einen 255-Eintrag bei nOldAddress programmiert, so dass nicht unbedingt die ganze Liste ausgefüllt werden muss. Fehlt diese Eintrag jedoch, so werden alle Einträge angenommen. Beim Start des Bausteines (positive Flanke an bStart) wird zunächst das Listen-Ende anhand des beschriebenen Eintrages ermittelt und danach der gültige Listenbereich auf folgende Fehleinträge hin untersucht:

  • Adresseinträge > 63
  • doppelter Adress-Eintrag auf der Ursprungsseite nOldAddress (würde keinen Sinn machen)
  • doppelter Adress-Eintrag auf der Zielseite nNewAddress (führt zu Doppelvergabe einer Adresse und damit zu Fehlern)

Der Baustein ermittelt dann anhand der Kurzadressen die internen Langadressen der DALI-Geräte und trägt diese jeweils in die Parameter nRandomAddressHigh, nRandomAddressMiddle und nRandomAddressLow der Liste ein. Tritt bei diesen Abfragen ein Fehler auf, so führt das zu einem Fehlereintrag für das jeweilige Gerät in dem Listenelement nErrors (siehe ST_DALIV2ChangeAddressList). Der weitere Ablauf im Baustein hängt nun von der Option DALIV2_OPTION_SAFE_ADDRESSING (Eingang nOptions) ab. Ist sie gesetzt, so erfolgt eine sichere Neuadressierung: zunächst werden alle Kurzadressen der gewählten DALI-Geräte gelöscht. Danach werden an alle gewünschte Neuadressen Statusanfragen in die DALI-Linie geschickt. 2 Fälle sind nun möglich:

  • Antwortet ein Gerät auf diese Anfrage, so ist diese gewünschte Neu-Adresse schon anderweitig vergeben. Die zuvor "gelöschten" DALI-Geräte werden mit ihren alten Adressen programmiert und eine Fehlermeldung ausgegeben.

  • Antwortet kein Gerät auf diese Statusanfrage, so werden die zuvor "gelöschten" DALI-Geräte mit den gewünschten neuen Adressen belegt.

In beiden Fällen wird die Neuprogrammierung hinterher überprüft. Treten beim Löschen, bei der Statusabfrage oder bei der Neuprogrammierung Fehler auf, so führt dies zu einem Fehlereintrag für das jeweilige Gerät in dem Listenelement nErrors (siehe ST_DALIV2ChangeAddressList).
Ist die Option DALIV2_OPTION_SAFE_ADDRESSING (Eingang nOptions) nicht gesetzt, so wird auf das Löschen der Kurzadressen sowie auf die Statusabfrage zum Vorhandensein gewünschter Neuadressen verzichtet und die neuen Adressen direkt programmiert. Dies ist dadurch möglich, dass die Programmierung über die zuvor ermittelte Langadresse erfolgt. Die Neuprogrammierung wird in diesem Falle nicht verifiziert.

Die einzelnen Bits im Listenelement nErrors haben folgende Bedeutung:

Bit | Fehler
0 | Fehler beim Lesen des High-Bytes der Langadresse (nRandomAddressHigh).
1 | Fehler beim Lesen des Middle-Bytes der Langadresse (nRandomAddressMiddle).
2 | Fehler beim Lesen des Low-Bytes der Langadresse (nRandomAddressLow).
3 | Fehler beim Löschen einer Kurzadresse.
4 | Fehler beim Verifizieren einer Kurzadresse.
5 | Fehler beim Programmieren einer Kurzadresse.

VAR_INPUT

bStart              : BOOL;
bCancel             : BOOL;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityHigh;
nOptions            : DWORD := 0;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nOptions: Optionen für das Schreiben der Variablen (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_SAFE_ADDRESSING | Sichere Adressierung: Alte Kurz-Adressen werden gelöscht, die neuen auf schon Vorhandensein hin überprüft und die Neu-Programmierung verifiziert.

VAR_OUTPUT

bBusy                    : BOOL;
bError                   : BOOL;
nErrorId                 : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

arrChangeAddressList     : ARRAY [0.. 63] OF ST_DALIV2ChangeAddressList;
stCommandBuffer          : ST_DALIV2CommandBuffer;

arrChangeAddressList: Verweis auf die Liste mit den zu ändernden Kurzadressen.


FB_DALIV2SetShortAddress

Mit Hilfe dieses Bausteins erhalten ein oder mehrere Vorschaltgeräte eine (neue) Kurzadresse. Gültige Kurzadressen liegen im Wertebereich von 0 bis 63. Wird als Kurzadresse 255 übergeben, so wird die Kurzadresse im Vorschaltgerät gelöscht.
Wollen Sie einem Gerät eine Kurzadresse geben, welches noch keine Kurzadresse hat, so müssen Sie den Befehl als Broadcast versenden (eAddrType = eDALIV2AddrTypeBroadcast). Hierdurch bekommen alle Vorschaltgeräte, die an der DALI-Klemme angeschlossen sind, die Kurzadresse nAddr. Also auch die Vorschaltgeräte, die bisher noch keine Kurzadresse hatten.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nNewShortAddress  : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

nNewShortAddress: Neue Kurzadresse (0-15) oder Maske (255).

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SwapShortAddress

Mit diesem Funktionsbaustein können die Kurzadressen zweier Vorschaltgeräte vertauscht werden. Hierzu ist es allerdings notwendig, dass in der DALI-Line eine freie, unbenutzte Kurzadresse vorhanden ist.

VAR_INPUT

bStart                   : BOOL;
nShortAddress01          : BYTE;
nShortAddress02          : BYTE;
nFreeShortAddress        : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nShortAddress01: Kurzadresse vom ersten Vorschaltgerät (0 ... 63).

nShortAddress02: Kurzadresse vom zweiten Vorschaltgerät (0 ... 63).

nFreeShortAddress: Freie Kurzadresse (0 ... 63).

VAR_OUTPUT

bBusy                    : BOOL;
bError                   : BOOL;
nErrorId                 : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer          : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2SwapShortAddressList

Mit diesem Funktionsbaustein können die Kurzadressen mehrerer Vorschaltgeräte vertauscht werden. Hierzu ist es allerdings notwendig, das in der DALI-Line eine freie, unbenutzte Kurzadresse vorhanden ist.

In dem Parameter arrSwapShortAddressList wird eine Liste mit den Vorschaltgeräten übergeben, bei denen die Kurzadresse geändert werden soll. Der Index der Struktur entspricht dabei der Kurzadresse des Vorschaltgerätes. Das Element nNewShortAddress enthält die neue Kurzadresse. bShortAddressValid muss auf TRUE gestest werden, damit bei dem entsprechenden Vorschaltgerät die Kurzadresse geändert wird. Durch eine positive Flanke an dem Eingang bStart wird der Baustein gestartet und der Ausgang bBusy geht auf TRUE. Abhängig von den gewählten Optionen (Parameter nOptions) werden alle Lampen auf den Wert MIN LEVEL gesetzt. Die Elemente vom Ausgang arrSwapedShortAddresses werden zurückgesetzt. Wird bei einem Vorschaltgerät die neue Kurzadresse gesetzt, so wird bei dem Ausgang arrSwapedShortAddresses das entsprechende Element auf TRUE gesetzt. Die die Option DALIV2_OPTION_OPTICAL_FEEDBACK aktiv, so wird zusätzlich noch die Lampe auf den Wert MAX LEVEL geschaltet.

VAR_INPUT

bStart                   : BOOL;
bCancel                  : BOOL;
nFreeShortAddress        : BYTE;
nOptions                 : DWORD := DALIV2_OPTION_OPTICAL_FEEDBACK;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

bCancel: Über eine positive Flanke an diesem Eingang wird der Baustein deaktiviert und somit das Tauschen der Kurzadressen abgebrochen.

nFreeShortAddress: Freie Kurzadresse (0 ... 63).

nOptions: Optionen für das Vertauschen der Kurzadressen (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_OPTICAL_FEEDBACK | Vor dem Vertauschen der Kurzadressen werden alle Vorschaltgeräte auf MIN LEVEL gesetzt. Nach dem Zuweisen der neuen Kurzadresse wird die Helligkeit vom jeweiligen Vorschaltgerät auf MAX LEVEL geändert.

VAR_OUTPUT

bBusy                    : BOOL;
bError                   : BOOL;
nErrorId                 : UDINT;
arrSwapedShortAddresses  : ARRAY [0..63] OF BOOL;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

arrSwapedShortAddresses: Wird einem Vorschaltgerät eine Kurzadresse zugewiesen, so wird in dem Array das entsprechende Element auf TRUE gesetzt. Der Index spiegelt dabei die Kurzadresse des Vorschaltgerätes wider.

VAR_IN_OUT

arrSwapShortAddressList  : ARRAY [0.. 63] OF ST_DALIV2SwapShortAddressList;
stCommandBuffer          : ST_DALIV2CommandBuffer;

arrSwapShortAddressList: Verweis auf die Liste mit den zu vertauschenden Kurzadressen.


Einstellungen - Funktionsbausteine

Name | Beschreibung
FB_DALIV2GetSettings | Funktionsblock zum Auslesen aller Gerätedaten von allen Vorschaltgeräten an einer DALI-Linie.
FB_DALIV2GetSettingsSingleDevice | Funktionsblock zum Auslesen aller Gerätedaten von einem Vorschaltgerät an einer DALI-Linie.
FB_DALIV2SetSettings | Funktionsblock zum Setzen aller Gerätedaten von allen Vorschaltgeräten an einer DALI-Linie.


FB_DALIV2GetSettings

Dieser Baustein liest von allen Vorschaltgeräten einer DALI-Line die Variablen (MIN LEVEL, MAX LEVEL, FADE TIME, ...) aus, und speichert diese in einer Struktur vom Typ ST_DALIV2DeviceSettings.

Durch eine positive Flanke an dem Eingang bStart wird der Baustein gestartet und der Ausgang bBusy geht auf TRUE. Zunächst wird geprüft, ob ein Vorschaltgerät überhaupt vorhanden ist. Ist dies der Fall, so wird in der jeweiligen Struktur (siehe ST_DALIV2DeviceSettings) das Bit bPresent gesetzt und anschließend nacheinander die Einstellungen des Vorschaltgerätes ausgelesen und in die betreffenden Variablen der Struktur geschrieben. Wird ein Gerät als nicht vorhanden erkannt, so wird das Auslesen übersprungen und mit dem nächsten Gerät begonnen. Der Index der Struktur spiegelt dabei die Adresse des Gerätes wider, d.h. vom Gerät mit der Kurzadresse 0 liegen die Daten in arrDALIDeviceSettings[0] bis hin zu dem Gerät mit der Kurzadresse 63 in arrDALIDeviceSettings[63]. Tritt während des Auslesevorganges ein Lesefehler bei einem Gerät auf, so wird das entsprechende Bit in nErrors der jeweiligen Struktur gesetzt, ohne dass jedoch der Funktionsbaustein an sich in Störung geht. In der folgenden Tabelle wird aufgelistet, welches Bit in der Variablen nErrors gesetzt wird, wenn beim Auslesen einer Variablen aus einem Vorschaltgerät ein Fehler aufgetreten ist:

Bit | Fehler
0 | Bei dem Versuch das Vorschaltgerät zu suchen, ist ein Fehler aufgetreten.
1 | Fehler beim Auslesen der Variable ACTUAL DIM LEVEL.
2 | Fehler beim Auslesen der Variable POWER ON LEVEL.
3 | Fehler beim Auslesen der Variable SYSTEM FAILURE LEVEL.
4 | Fehler beim Auslesen der Variable MIN LEVEL.
5 | Fehler beim Auslesen der Variable MAX LEVEL.
6 | Fehler beim Auslesen der Variable FADE RATE.
7 | Fehler beim Auslesen der Variable FADE TIME.
8 | Fehler beim Auslesen der Variable RANDOM ADDRESS.
9 | Fehler beim Auslesen der Variablen GROUP 0-7 und GROUP 8-15.
10 | Fehler beim Auslesen der Variablen SCENE 0 bis SCENE 15.
11 | Fehler beim Auslesen der Variable STATUS INFORMATION.
12 | Fehler beim Auslesen der Variable VERSION NUMBER.
13 | Fehler beim Auslesen der Variable DEVICE TYPE.
14 | Fehler beim Auslesen der Variable PHYSICAL MIN LEVEL.

Nach Abarbeitung des Bausteines wechselt der Ausgang bBusy von TRUE nach FALSE. Abhängig davon, wie viele Vorschaltgeräte angeschlossen sind, kann die Abarbeitung dieses Bausteines mehrere Sekunden dauern.

VAR_INPUT

bStart              : BOOL;
bCancel             : BOOL;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nOptions            : DWORD;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

bCancel: Über eine positive Flanke an diesem Eingang wird der Baustein deaktiviert und somit das Auslesen der Variablen abgebrochen.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nOptions: Optionen für das Auslesen der Variablen (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_ACTUAL_DIM_LEVEL | Die Variable ACTUAL DIM LEVEL wird ausgelesen.
DALIV2_OPTION_POWER_ON_LEVEL | Die Variable POWER ON LEVEL wird ausgelesen.
DALIV2_OPTION_SYSTEM_FAILURE_LEVEL | Die Variable SYSTEM FAILURE LEVEL wird ausgelesen.
DALIV2_OPTION_MIN_LEVEL | Die Variable MIN LEVEL wird ausgelesen.
DALIV2_OPTION_MAX_LEVEL | Die Variable MAX LEVEL wird ausgelesen.
DALIV2_OPTION_FADE_RATE_FADE_TIME | Die Variablen FADE RATE und FADE TIME werden ausgelesen.
DALIV2_OPTION_RANDOM_ADDRESS | Die Variable RANDOM ADDRESS wird ausgelesen.
DALIV2_OPTION_GROUPS | Die Variablen GROUP 0-7 und GROUP 8-15 werden ausgelesen.
DALIV2_OPTION_SCENE_LEVELS | Die Variablen SCENE 0 bis SCENE 15 werden ausgelesen.
DALIV2_OPTION_STATUS_INFORMATION | Die Variable STATUS INFORMATION wird ausgelesen.
DALIV2_OPTION_VERSION_NUMBER | Die Variable VERSION NUMBER wird ausgelesen.
DALIV2_OPTION_DEVICE_TYPE | Die Variable DEVICE TYPE wird ausgelesen.
DALIV2_OPTION_PHYSICAL_MIN_LEVEL | Die Variable PHYSICAL MIN LEVEL wird ausgelesen.
DALIV2_OPTION_DONT_CLEAR_DEVICE_SETTINGS | Vor dem Lesen wird die Variable arrDALIDeviceSettings nicht gelöscht.
DALIV2_OPTION_ALL | Alle Variablen werden ausgelesen.

VAR_OUTPUT

bBusy             : BOOL;
bError            : BOOL;
nErrorId          : UDINT;
nCurrentShortAddr : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nCurrentShortAddr: Kurzadresse vom aktuellem Vorschaltgerät von dem gerade versucht wird die Variablen auszulesen.

VAR_IN_OUT

stCommandBuffer       : ST_DALIV2CommandBuffer;
arrDALIDeviceSettings : ARRAY [0..63] OF ST_DALIV2DeviceSettings;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

arrDALIDeviceSettings: Verweis auf ein Array mit 64 Elementen vom Typ ST_DALIV2DeviceSettings. In dieser Variablen werden die Einstellungen von jedem einzelnen DALI-Vorschaltgerät abgelegt.


FB_DALIV2GetSettingsSingleDevice

Im Gegensatz zum Baustein FB_DALIV2GetSettings() liest dieser Baustein die Variablen (MIN LEVEL, MAX LEVEL, FADE TIME, ...) von nur einem bestimmten Gerät aus und speichert diese in einer Struktur vom Typ ST_DALIV2DeviceSettings.

Durch eine positive Flanke an dem Eingang bStart wird der Baustein gestartet und der Ausgang bBusy geht auf TRUE. Anschließend werden nacheinander die Einstellungen des Vorschaltgerätes ausgelesen und in die betreffenden Variablen der Struktur geschrieben.Tritt während des Auslesevorganges ein Lesefehler bei einem Gerät auf, so wird das Element nErrors der jeweiligen Struktur gesetzt, ohne dass jedoch der Funktionsbaustein an sich in Störung geht. In der folgenden Tabelle wird aufgelistet, welches Bit in der Variablen nErrors gesetzt wird, wenn beim Auslesen einer Variablen aus einem Vorschaltgerät ein Fehler aufgetreten ist:

Bit | Fehler
0 | Bei dem Versuch das Vorschaltgerät zu suchen, ist ein Fehler aufgetreten.
1 | Fehler beim Auslesen der Variable ACTUAL DIM LEVEL.
2 | Fehler beim Auslesen der Variable POWER ON LEVEL.
3 | Fehler beim Auslesen der Variable SYSTEM FAILURE LEVEL.
4 | Fehler beim Auslesen der Variable MIN LEVEL.
5 | Fehler beim Auslesen der Variable MAX LEVEL.
6 | Fehler beim Auslesen der Variable FADE RATE.
7 | Fehler beim Auslesen der Variable FADE TIME.
8 | Fehler beim Auslesen der Variable RANDOM ADDRESS.
9 | Fehler beim Auslesen der Variablen GROUP 0-7 und GROUP 8-15.
10 | Fehler beim Auslesen der Variablen SCENE 0 bis SCENE 15.
11 | Fehler beim Auslesen der Variable STATUS INFORMATION.
12 | Fehler beim Auslesen der Variable VERSION NUMBER.
13 | Fehler beim Auslesen der Variable DEVICE TYPE.
14 | Fehler beim Auslesen der Variable PHYSICAL MIN LEVEL.

Nach Abarbeitung des Bausteines wechselt der Ausgang bBusy von TRUE nach FALSE.

VAR_INPUT

bStart              : BOOL;
bCancel             : BOOL;
nAddr               : BYTE;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nOptions            : DWORD;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

bCancel: Über eine positive Flanke an diesem Eingang wird der Baustein deaktiviert und somit das Auslesen der Variablen abgebrochen.

nAddr: Die Adresse des Gerätes, dessen Werte gelesen werden sollen.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nOptions: Optionen für das Auslesen der Variablen (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_ACTUAL_DIM_LEVEL | Die Variable ACTUAL DIM LEVEL wird ausgelesen.
DALIV2_OPTION_POWER_ON_LEVEL | Die Variable POWER ON LEVEL wird ausgelesen.
DALIV2_OPTION_SYSTEM_FAILURE_LEVEL | Die Variable SYSTEM FAILURE LEVEL wird ausgelesen.
DALIV2_OPTION_MIN_LEVEL | Die Variable MIN LEVEL wird ausgelesen.
DALIV2_OPTION_MAX_LEVEL | Die Variable MAX LEVEL wird ausgelesen.
DALIV2_OPTION_FADE_RATE_FADE_TIME | Die Variablen FADE RATE und FADE TIME werden ausgelesen.
DALIV2_OPTION_RANDOM_ADDRESS | Die Variable RANDOM ADDRESS wird ausgelesen.
DALIV2_OPTION_GROUPS | Die Variablen GROUP 0-7 und GROUP 8-15 werden ausgelesen.
DALIV2_OPTION_SCENE_LEVELS | Die Variablen SCENE 0 bis SCENE 15 werden ausgelesen.
DALIV2_OPTION_STATUS_INFORMATION | Die Variable STATUS INFORMATION wird ausgelesen.
DALIV2_OPTION_VERSION_NUMBER | Die Variable VERSION NUMBER wird ausgelesen.
DALIV2_OPTION_DEVICE_TYPE | Die Variable DEVICE TYPE wird ausgelesen.
DALIV2_OPTION_PHYSICAL_MIN_LEVEL | Die Variable PHYSICAL MIN LEVEL wird ausgelesen.
DALIV2_OPTION_DONT_CLEAR_DEVICE_SETTINGS | Vor dem Lesen wird die Variable stDALIDeviceSettings nicht gelöscht.
DALIV2_OPTION_ALL | Alle Variablen werden ausgelesen.

VAR_OUTPUT

bBusy             : BOOL;
bError            : BOOL;
nErrorId          : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer       : ST_DALIV2CommandBuffer;
stDALIDeviceSettings  : ST_DALIV2DeviceSettings;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

stDALIDeviceSettings: Verweis auf eine Struktur vom Typ ST_DALIV2DeviceSettings. In dieser Variablen werden die Einstellungen vom DALI-Vorschaltgerät abgelegt.


FB_DALIV2SetSettings

Dieser Baustein initialisiert die Variablen (MIN LEVEL, MAX LEVEL, FADE TIME, ...) aller Vorschaltgeräte einer DALI-Line mit den Werten, die in einer Struktur vom Typ ST_DALIV2DeviceSettings abgelegt sind.

Durch eine positive Flanke an dem Eingang bStart wird der Baustein gestartet und der Ausgang bBusy geht auf TRUE. Zunächst wird geprüft, ob in der jeweiligen Struktur (siehe ST_DALIV2DeviceSettings) das Bit bPresent gesetzt ist. Ist dieses der Fall, so werden alle Variablen vom Vorschaltgerät, die nicht schreibgeschützt sind, mit den jeweiligen Werten der Struktur initialisiert. Der Index der Struktur spiegelt dabei die Adresse des Vorschaltgerätes wider, d.h. vom Gerät mit der Kurzadresse 0 liegen die Daten in arrDALIDeviceSettings[0] bis hin zu dem Vorschaltgerät mit der Kurzadresse 63 in arrDALIDeviceSettings[63]. Tritt während des Schreibvorganges ein Fehler bei einem Gerät auf, so wird das Element nErrors der jeweiligen Struktur gesetzt, ohne dass jedoch der Funktionsbaustein an sich in Störung geht. In der folgenden Tabelle wird aufgelistet, welches Bit in der Variablen nErrors gesetzt wird, wenn beim Schreiben einer Variablen in einem Vorschaltgerät ein Fehler aufgetreten ist:

Bit | Fehler
2 | Fehler beim Schreiben der Variable POWER ON LEVEL.
3 | Fehler beim Schreiben der Variable SYSTEM FAILURE LEVEL.
4 | Fehler beim Schreiben der Variable MIN LEVEL.
5 | Fehler beim Schreiben der Variable MAX LEVEL.
6 | Fehler beim Schreiben der Variable FADE RATE.
7 | Fehler beim Schreiben der Variable FADE TIME.
9 | Fehler beim Schreiben der Variablen GROUP 0-7 und GROUP 8-15.
10 | Fehler beim Schreiben der Variablen SCENE 0 bis SCENE 15.

Nach Abarbeitung des Bausteines wechselt der Ausgang bBusy von TRUE nach FALSE. Abhängig davon, wie viele Vorschaltgeräte angeschlossen sind, kann die Abarbeitung dieses Bausteines mehrere Sekunden dauern.

VAR_INPUT

bStart              : BOOL;
bCancel             : BOOL;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nOptions            : DWORD;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

bCancel: Über eine positive Flanke an diesem Eingang wird der Baustein deaktiviert und somit das Initialisieren der Variablen abgebrochen.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nOptions: Optionen für das Schreiben der Variablen (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_POWER_ON_LEVEL | Die Variable POWER ON LEVEL wird initialisiert.
DALIV2_OPTION_SYSTEM_FAILURE_LEVEL | Die Variable SYSTEM FAILURE LEVEL wird initialisiert.
DALIV2_OPTION_MIN_LEVEL | Die Variable MIN LEVEL wird initialisiert.
DALIV2_OPTION_MAX_LEVEL | Die Variable MAX LEVEL wird initialisiert.
DALIV2_OPTION_FADE_RATE | Die Variable FADE RATE wird initialisiert.
DALIV2_OPTION_FADE_TIME | Die Variable FADE TIME wird initialisiert.
DALIV2_OPTION_GROUPS | Die Variablen GROUP 0-7 und GROUP 8-15 werden initialisiert.
DALIV2_OPTION_SCENE_LEVELS | Die Variablen SCENE 0 bis SCENE 15 werden initialisiert.
DALIV2_OPTION_ALL | Alle Variablen werden initialisiert.
DALIV2_OPTION_PUSH_DALI_COMMANDS | Der Puffer, der die Rückmeldungen von den Vorschaltgeräten enthält, wird nicht ausgelesen. Dadurch wird das Schreiben schneller, Fehler jedoch nicht erkannt.

VAR_OUTPUT

bBusy             : BOOL;
bError            : BOOL;
nErrorId          : UDINT;
nCurrentShortAddr : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nCurrentShortAddr: Kurzadresse vom aktuellem Vorschaltgerät bei dem gerade versucht wird, die Variablen zu initialisieren.

VAR_IN_OUT

stCommandBuffer        : ST_DALIV2CommandBuffer;
arrDALIDeviceSettings  : ARRAY [0..63] OF ST_DALIV2DeviceSettings;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

arrDALIDeviceSettings: Verweis auf ein Array mit 64 Elementen vom Typ ST_DALIV2DeviceSettings. In dieser Variablen werden die Einstellungen von jedem einzelnen DALI-Vorschaltgerät abgelegt.


Leistungsregelung - Funktionsbausteine

Name | Beschreibung
FB_DALIV2ConstantLightControlEco | einfacher Funktionsblock zur Konstantlichtregelung von DALI-Geräten.
FB_DALIV2Ramp | Funktionsblock zur Realisierung einer Lichtrampe.
FB_DALIV2Dimmer1Switch | Funktionsblock zum Dimmen von DALI-Geräten mit einem Taster.
FB_DALIV2Dimmer1SwitchEco | Speicherplatzsparende Variante des FB_DALIV2Dimmer1Switch ohne Sonderfunktionen.
FB_DALIV2Dimmer1SwitchMultiple | Funktionsblock zum Dimmen von DALI-Geräten mit einem Taster. Für Anwendungen bei denen bis zu fünf DALI-Linien (0..4) installiert sein können.
FB_DALIV2Dimmer2Switch | Funktionsblock zum Dimmen von DALI-Geräten mit zwei Tastern.
FB_DALIV2Dimmer2SwitchEco | Speicherplatzsparende Variante des FB_DALIV2Dimmer2Switch ohne Sonderfunktionen.
FB_DALIV2Light | Funktionsblock zur Steuerung von Lampen.
FB_DALIV2LightControl | Funktionsblock zur tageslichtabhängigen Lichtsteuerung mit bis zu 30 Stützpunkten.
FB_DALIV2Ramp | Funktionsblock zur Realisierung einer Rampe.
FB_DALIV2Sequencer | Funktionsblock zur Realisierung von Lichtsequenzen mit bis zu 50 Stützpunkten.
FB_DALIV2StairwellDimmer | Funktionsblock zur Steuerung von Treppenhausbeleuchtungen.


FB_DALIV2ConstantLightControlEco

Der Baustein FB_DALIV2ConstantLightControlEco() dient zur Konstantlichtregelung mit DALI-Vorschaltgeräten.

Durch zyklisches Auf- und Abdimmen wird versucht, auf einen vorgegebenen Sollwert zu regeln. Die Dynamik der Regelung wird durch eine Totzeit (tDeadTime) bestimmt. Die Totzeit legt die Wartezeit zwischen den einzelnen Befehlen zur Veränderung der Stellgröße fest. Je kleiner die Totzeit, desto schneller wird nachgeregelt. Eine frei definierbare Hysterese (nHysteresis) verhindert ein ständiges Schwingen um den Sollwert. Liegt der Istwert im Bereich der Hysterese um den Sollwert, so wird die Helligkeit der Lampen nicht verändert. Per Option kann festgelegt werden, ob die Lampen automatisch ein- und ausgeschaltet werden sollen (siehe Tabelle unten).

Anmerkung zum Parameter nMasterDevAddr

Das DALI-System bietet die Möglichkeit, Lampen nicht nur einzeln zu steuern, sondern diese auch gruppenweise oder mit Sammelbefehlen anzusprechen. Da die einzelnen Geräte Teilnehmer von verschiedenen Gruppen sein können, kann die Situation entstehen, dass vor einer Gruppen- bzw. Sammelansteuerung die einzelnen Lampen verschiedene Helligkeitszustände innehaben. Um dennoch eine Aussage darüber treffen zu können, ob die Lampen nun ein- oder ausgeschaltet werden sollen, wird jeder Gruppe ein Referenzgerät (Master-Device) zugeordnet, nach dessen Zustand sich die restlichen Geräte richten. Soll mit dem Baustein eine einzelne Lampe angesteuert werden, eAddrType = eAddrTypeShort, so braucht kein Master-Device angegeben werden. Der Parameter nMasterDevAddr ist in diesem Fall ohne Bedeutung.

VAR_INPUT

bEnable                    : BOOL := TRUE;
bOn                        : BOOL;
bOff                       : BOOL;
bToggle                    : BOOL;
nSetpointValue             : UINT := 500;
nActualValue               : UINT;
nHysteresis                : UINT := 50;
tDeadTime                  : TIME := t#10s;
nAddr                      : BYTE := 0;
eAddrType                  : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr             : BYTE := 0;
tCycleActualLevelMasterDev : TIME := t#0s;
nOptions                   : DWORD := 0;

bEnable: Schaltet den Baustein frei. Ist dieser Eingang auf FALSE, so sind die Eingänge bOn, bOff und bToogle gesperrt. Außerdem werden keine Stellgrößen ausgegeben.

bOn: Schaltet die angesprochenen Geräte auf MAX_LEVEL und aktiviert die Konstantlichtregelung.

bOff: Schaltet die angesprochenen Geräte aus und deaktiviert die Konstantlichtregelung.

bToggle: Je nach Zustand des Referenzgerätes wird die Beleuchtung ein- oder ausgeschaltet.

nSetpointValue: An diesem Eingang wird der Sollwert vorgegeben.

nActualValue: An diesem Eingang wird der Istwert angelegt.

nHysteresis: Regelhysterese um den Sollwert. Liegt der Istwert innerhalb dieses Bereiches, so werden die Stellgrößen der Lampen nicht verändert.

tDeadTime: Totzeit zwischen den einzelnen Befehlen, mit denen die Stellgröße der DALI-Lampen verändert wird.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

nMasterDevAddr: Adresse des Master-Gerätes (Referenzgerät) bei Gruppen- und Sammelschaltungen.

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) der Referenzlampe ausgelesen wird. Damit das Regeln der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt. Der ausgelesene Wert wird an dem Ausgang nActualLevelMasterDev ausgegeben.

nOptions: Optionen (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_SWITCH_ON_AND_OFF | Es werden zum Verändern der Stellgröße die DALI-Befehle ON_AND_STEP_UP und STEP_DOWN_AND_OFF verwendet. Hierdurch werden die Lampen, nach dem Erreichen vom MIN_LEVEL ausgeschaltet. Liegt die Regelabweichung oberhalb der Hysterese, werden die Lampen wieder eingeschaltet. Ist diese Option nicht gesetzt, so werden die Befehle STEP_UP und STEP_DOWN eingesetzt. Die Lampen bleiben dadurch immer eingeschaltet.
DALIV2_OPTION_SWITCH_ON_WITH_MIN_LEVEL | Wird durch die Konstandlichtregelung das Licht wieder eingeschaltet, so wird durch diese Option immer der Befehl MIN_LEVEL verwendet. Ist die Option nicht gesetzt wird MAX_LEVEL aufgerufen. Diese Option steht ab V2.9.3 der SPS-Bibliothek zur Verfügung.

VAR_OUTPUT

nActualLevelMasterDev   : BYTE;
nDeviation              : INT;
bControllerIsActive     : BOOL;
bBusy                   : BOOL;
bError                  : BOOL;
nErrorId                : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

nDeviation: Aktuelle Regelabweichung (Sollwert - Istwert).

bControllerIsActive: Dieser Ausgang wird gesetzt, sobald die Regelung aktiviert wurde.

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Dimmer1Switch

Eine einzelne DALI-Lampe, eine DALI-Gruppe oder eine komplette DALI-Line kann mit diesem Baustein über einen Taster geschaltet und gedimmt werden.

Bedienung über den Eingang bSwitchDimm

Durch ein kurzes Signal am Eingang bSwitchDimm, wird das Licht ein- oder ausgeschaltet. Liegt das Signal länger als tSwitchOverTime (empfohlener Richtwert: 200ms) an, so wird in den Dimmermodus umgeschaltet. Das Ausgangssignal fährt zyklisch zwischen nMinLevelMasterDev und nMaxLevelMasterDev. Um den maximalen oder minimalen Wert besser einstellen zu können, verweilt das Ausgangssignal für die Zeit tCycleDelay auf dem minimalen bzw. maximalen Wert. Wird das Signal wieder weggenommen, so bleibt das aktuelle Ausgangssignal anstehen. Durch einen erneuten Impuls auf den Eingang, wird der Ausgang auf 0 gesetzt. Wird im Dimmermodus das Signal bSwitchDimm kurzzeitig weggenommen, so ändert der Baustein seine Dimmrichtung.

Bedienung über die Eingänge bOn und bOff

Wird eine positive Flanke an den Eingängen bOn oder bOff angelegt, so wird das Licht direkt ein- oder ausgeschaltet. Beim Ausschalten wird der Ausgangswert auf 0 gesetzt. Das Verhalten beim Einschalten kann durch die Memoryfunktion beeinflusst werden (siehe unten).

Bedienung über die Eingänge bSetDimmValue und nDimmValue

Ändert sich der Wert nDimmValue, so werden die angesprochenen Geräte direkt auf diesen Helligkeitswert gesteuert. Wichtig ist hierbei, dass sich der Wert ändert. Durch eine Änderung auf den Wert 0, wird die Beleuchtung ausgeschaltet. Durch eine positive Flanke an den Eingang bSetDimmValue wird der Wert nDimmValue direkt an den Ausgang ausgegeben. Das direkte Ändern des Ausgangs kann durch ein statisches 1-Signal am Eingang bSetDimmValue unterdrückt werden. Hierdurch kann ein Wert am Eingang nDimmValue angelegt werden, der erst bei der nächsten positiven Flanke, von bSetDimmValue an den Ausgang übergeben wird.

Mit Hilfe der Eingänge bSetDimmValue und nDimmValue können z.B. verschiedene Beleuchtungsszenarien realisiert werden. Das direkte Setzen des Ausgangs, mit Hilfe von nDimmValue, kann dazu benutzt werden, um bestimmte Helligkeiten anzufahren. Entweder direkt oder durch kontinuierliches Verändern des Wertes. nDimmValue muss einen Wert zwischen nMinLevelMasterDev und nMaxLevelMasterDev haben. Ausnahme ist der Wert 0. Liegt der Wert außerhalb des Bereichs, so wird der Ausgangswert auf die obere, bzw. untere Grenze begrenzt.

Memoryfunktion

Beim Einschalten muss unterschieden werden, ob die Memoryfunktion (Eingang bMemoryModeOn) aktiv ist oder nicht. Ist die Memoryfunktion aktiv, so wird beim Einschalten der zuletzt eingestellte Wert als Helligkeitswert übernommen. Ist die Memoryfunktion nicht aktiv, so wird den angesprochenen Geräten ein Helligkeitswert zugewiesen, der über den Parameter nOnValueWithoutMemoryMode vorgegeben wird. Hierbei ist es gleichgültig, ob das Licht über den Eingang bOn oder über den Eingang bSwitchDimm geschaltet wird. Zu beachten ist, dass der Parameter nOnValueWithoutMemoryMode zwischen nMinLevelMasterDev und nMaxLevelMasterDev liegen muss. Ist dieses nicht der Fall, so wird der Ausgangswert auf die untere bzw. obere Grenze angepasst.

Anmerkung zum Parameter tSwitchOverTime

Wird für den Parameter tSwitchOverTime eine Dauer von 0 vorgegeben, so kann mit dem Eingang bSwitchDimm das Licht nur gedimmt werden. Ein Ein-/Ausschalten ist nur mit den Eingängen bOn und bOff möglich.

Anmerkung zum Parameter nMasterDevAddr

Das DALI-System bietet die Möglichkeit, Lampen nicht nur einzeln zu steuern, sondern diese auch gruppenweise oder mit Sammelbefehlen anzusprechen. Dadurch das die einzelnen Geräte Teilnehmer von verschiedenen Gruppen sein können, kann die Situation entstehen, dass vor einer Gruppen- bzw. Sammelansteuerung die einzelnen Lampen verschiedene Helligkeitszustände innehaben. Um dennoch eine Aussage darüber treffen zu können, ob die Lampen nun ein- oder ausgeschaltet werden sollen, werden jeder Gruppe ein Führungsgerät (Master-Device) zugeordnet, nach dessen Zustand sich die restlichen Geräte richten. Soll mit dem Baustein eine einzelne Lampe angesteuert werden, eAddrType = eAddrTypeShort, so braucht kein Master-Device angegeben werden. Der Parameter nMasterDevAddr ist in diesem Fall ohne Bedeutung.

VAR_INPUT

bSwitchDimm                : BOOL;
bOn                        : BOOL;
bOff                       : BOOL;
bSetDimmValue              : BOOL;
nDimmValue                 : BYTE;
tSwitchOverTime            : TIME := t#400ms;
tCycleDelay                : TIME := t#500ms;
bMemoryModeOn              : BOOL := FALSE;
nOnValueWithoutMemoryMode  : BYTE := 254;
nAddr                      : BYTE := 0;
eAddrType                  : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr             : BYTE := 0;
nMinLevelMasterDev         : BYTE := 126;
nMaxLevelMasterDev         : BYTE := 254;
tCycleActualLevelMasterDev : TIME := t#0s;

bSwitchDimm: Schaltet oder dimmt die angesprochenen Geräte.

bOn: Schaltet die angesprochenen Geräte auf den letzten Ausgangswert oder auf den Wert nOnValueWithoutMemoryMode.

bOff: Schaltet die angesprochenen Geräte aus (Wert 0).

bSetDimmValue: Eine positive Flanke an diesem Eingang setzt die angesprochenen Geräte direkt auf den Helligkeitswert, der am Eingang nDimmValue ansteht. Ändert sich der Wert nDimmValue , so wird der Helligkeitswert direkt auf den geänderten Wert eingestellt, wenn der Eingang bSetDimmValue auf FALSE steht.

nDimmValue: siehe bSetDimmValue.

tSwitchOverTime: Umschaltzeit zwischen Licht ein/aus und Licht dimmen für den Eingang bSwitchDimm.

tCycleDelay: Wartezeit, wenn der Min- bzw. Max-Wert erreicht ist.

bMemoryModeOn: Schaltet auf Memoryfunktion um, so das beim Einschalten der vorherige Wert an den Ausgang geschrieben wird.

nOnValueWithoutMemoryMode: Einschaltwert, wenn die Memoryfunktion nicht eingeschaltet ist.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen.

nMinLevelMasterDev: Minimalwert des Master-Gerätes.

nMaxLevelMasterDev: Maximalwert des Master-Gerätes.

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Dimmen der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

VAR_OUTPUT

nActualLevelMasterDev     : BYTE;
bBusy                     : BOOL;
bError                    : BOOL;
nErrorId                  : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Dimmer1SwitchEco

Der Baustein FB_DALIDimmer1SwitchEco() stellt die speicherplatzsparende Variante des FB_DALIV2Dimmer1Switch() dar. Er ist ohne die Sonderfunktion "Memoryfunktion ausschalten" ausgestattet.

Bedienung über den Eingang bSwitchDimm

Durch ein kurzes Signal am Eingang bSwitchDimm, wird das Licht ein- oder ausgeschaltet. Liegt das Signal länger als tSwitchOverTime (empfohlener Richtwert: 200ms) an, so wird in den Dimmermodus umgeschaltet, die Helligkeit erhöht, bzw. verringert sich gleichmäßig. Die Dimmrichtung wird durch kurzzeitiges Wegnehmen des Signals bSwitchDimm geändert.

Bedienung über die Eingänge bOn und bOff

Wird eine positive Flanke an den Eingängen bOn oder bOff angelegt, so wird das Licht direkt ein- oder ausgeschaltet. Beim Ausschalten wird der Ausgangswert auf 0 gesetzt.

Bedienung über die Eingänge bSetDimmValue und nDimmValue

Ändert sich der Wert nDimmValue, so werden die angesprochenen Geräte direkt auf diesen Helligkeitswert gesteuert. Wichtig ist hierbei, dass sich der Wert ändert. Durch eine Änderung auf den Wert 0, wird die Beleuchtung ausgeschaltet. Durch eine positive Flanke an den Eingang bSetDimmValue wird der Wert nDimmValue direkt an den Ausgang ausgegeben. Das direkte Ändern des Ausgangs kann durch ein statisches 1-Signal am Eingang bSetDimmValue unterdrückt werden. Hierdurch kann ein Wert am Eingang nDimmValue angelegt werden, der erst bei der nächsten positiven Flanke, von bSetDimmValue an den Ausgang übergeben wird.

Mit Hilfe der Eingänge bSetDimmValue und nDimmValue können z.B. verschiedene Beleuchtungsszenarien realisiert werden. Das direkte Setzen des Ausgangs, mit Hilfe von nDimmValue, kann dazu benutzt werden, um bestimmte Helligkeiten anzufahren. Entweder direkt oder durch kontinuierliches Verändern des Wertes.

Memoryfunktion

Im Gegensatz zum FB_DALIV2Dimmer1Switch(), bei der die Memoryfunktion über den Eingang bMemoryModeOn aktiviert oder ausgeschaltet werden kann, ist bei dieser speicherplatzsparenden Version die Memoryfunktion immer aktiv. Das bedeutet, dass beim Einschalten der zuletzt eingestellte Wert als Helligkeitswert übernommen wird. Hierbei ist es gleichgültig, ob das Licht über den Eingang bOn oder über den Eingang bSwitchDimm geschaltet wird.

Anmerkung zum Parameter tSwitchOverTime

Wird für den Parameter tSwitchOverTime eine Dauer von 0 vorgegeben, so kann mit dem Eingang bSwitchDimm das Licht nur gedimmt werden. Ein Ein-/Ausschalten ist nur mit den Eingängen bOn und bOff möglich.

Anmerkung zum Parameter nMasterDevAddr

Das DALI-System bietet die Möglichkeit, Lampen nicht nur einzeln zu steuern, sondern diese auch gruppenweise oder mit Sammelbefehlen anzusprechen. Dadurch das die einzelnen Geräte Teilnehmer von verschiedenen Gruppen sein können, kann die Situation entstehen, dass vor einer Gruppen- bzw. Sammelansteuerung die einzelnen Lampen verschiedene Helligkeitszustände innehaben. Um dennoch eine Aussage darüber treffen zu können, ob die Lampen nun ein- oder ausgeschaltet werden sollen, werden jeder Gruppe ein Führungsgerät (Master-Device) zugeordnet, nach dessen Zustand sich die restlichen Geräte richten. Soll mit dem Baustein eine einzelne Lampe angesteuert werden, eAddrType = eAddrTypeShort, so braucht kein Master-Device angegeben werden. Der Parameter nMasterDevAddr ist in diesem Fall ohne Bedeutung.

VAR_INPUT

bSwitchDimm                : BOOL;
bOn                        : BOOL;
bOff                       : BOOL;
bSetDimmValue              : BOOL;
nDimmValue                 : BYTE;
tSwitchOverTime            : TIME := t#400ms;
nAddr                      : BYTE := 0;
eAddrType                  : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr             : BYTE := 0;
tCycleActualLevelMasterDev : TIME := t#0s;

bSwitchDimm: Schaltet oder dimmt die angesprochenen Geräte.

bOn: Schaltet die angesprochenen Geräte auf den letzten Ausgangswert.

bOff: Schaltet die angesprochenen Geräte aus (Wert 0).

bSetDimmValue: Eine positive Flanke an diesem Eingang setzt die angesprochenen Geräte direkt auf den Helligkeitswert, der am Eingang nDimmValue ansteht. Ändert sich der Wert nDimmValue, so wird der Helligkeitswert direkt auf den geänderten Wert eingestellt, wenn der Eingang bSetDimmValue auf FALSE steht.

nDimmValue: siehe bSetDimmValue.

tSwitchOverTime: Umschaltzeit zwischen Licht ein/aus und Licht dimmen für den Eingang bSwitchDimm.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen.

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Dimmen der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

VAR_OUTPUT

nActualLevelMasterDev     : BYTE;
bBusy                     : BOOL;
bError                    : BOOL;
nErrorId                  : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Dimmer1SwitchMultiple

Funktionsblock zum Schalten und Dimmen von DALI-Geräten mit einem Taster. Für Anwendungen bei denen bis zu fünf DALI-Linien (0..4) installiert sein können. Die Grundfunktion dieses Funktionsbausteines ist aus der Beschreibung des FB_DALIV2Dimmer1Switch() zu entnehmen.

VAR_INPUT

bSwitchDimm                : BOOL;
bOn                        : BOOL;
bOff                       : BOOL;
bSetDimmValue              : BOOL;
nDimmValue                 : BYTE;
tSwitchOverTime            : TIME := t#400ms;
tCycleDelay                : TIME := t#500ms;
bMemoryModeOn              : BOOL := FALSE;
nOnValueWithoutMemoryMode  : BYTE := 254;
nAddr                      : BYTE := 0;
eAddrType                  : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr             : BYTE := 0;
nMasterDevLine             : BYTE := 0;
nMinLevelMasterDev         : BYTE := 126;
nMaxLevelMasterDev         : BYTE := 254;
tCycleActualLevelMasterDev : TIME := t#0s;
nDALILineEnable            : BYTE := 2#0000_0001;

bSwitchDimm: Schaltet oder dimmt die angesprochenen Geräte aller aktivierten DALI-Linien.

bOn: Schaltet die angesprochenen Geräte aller aktivierten DALI-Linien auf den letzten Ausgangswert oder auf den Wert nOnValueWithoutMemoryMode.

bOff: Schaltet die angesprochenen Geräte aller aktivierten DALI-Linien aus (Wert 0).

bSetDimmValue: Eine positive Flanke an diesem Eingang setzt die angesprochenen Geräte aller aktivierten DALI-Linien direkt auf den Helligkeitswert, der am Eingang nDimmValue ansteht. Ändert sich der Wert nDimmValue , so wird der Helligkeitswert direkt auf den geänderten Wert eingestellt, wenn der Eingang bSetDimmValue auf FALSE steht.

nDimmValue: siehe bSetDimmValue.

tSwitchOverTime: Umschaltzeit zwischen Licht ein/aus und Licht dimmen für den Eingang bSwitchDimm.

tCycleDelay: Wartezeit, wenn der Min- bzw. Max-Wert erreicht ist.

bMemoryModeOn: Schaltet auf Memoryfunktion um, so dass beim Einschalten der vorherige Wert an den Ausgang geschrieben wird.

nOnValueWithoutMemoryMode: Einschaltwert, wenn die Memoryfunktion nicht eingeschaltet ist.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType : Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen (0 - 63).

nMasterDevLine: Linie, in der sich das Master-Gerät für Gruppen- und Sammelkonfiguration befindet. Je Funktionsbaustein gibt es nur ein Master-Gerät, das aus einer der aktivierten DALI-Linien zu wählen ist. Es gibt die Linien 0 bis 4.

nMinLevelMasterDev: Minimalwert des Master-Gerätes.

nMaxLevelMasterDev: Maximalwert des Master-Gerätes.

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Dimmen der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

nDALILineEnable: Eingangsvariable in Form eines Bitmuster. Eine 1 im Bitmuster sagt aus, dass die DALI-Linie aktiviert ist. Beispiel: 2#01001 dies bedeutet, dass die DALI-Linien 0 und 3 aktiviert sind.

VAR_OUTPUT

nActualLevelMasterDev : BYTE;
bBusy                 : BOOL;
bError                : BOOL;
nErrorId              : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer00    : ST_DALIV2CommandBuffer;
stCommandBuffer01    : ST_DALIV2CommandBuffer;
stCommandBuffer02    : ST_DALIV2CommandBuffer;
stCommandBuffer03    : ST_DALIV2CommandBuffer;
stCommandBuffer04    : ST_DALIV2CommandBuffer;

stCommandBuffer00 - stCommandBuffer04 : Verweise auf die Strukturen zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Dimmer2Switch

Der Funktionsbaustein FB_DALIDimmer2Switch() entspricht im Funktionsumfang dem Funktionsbaustein FB_DALIV2Dimmer1Switch(). Der Unterschied besteht darin, das bei dem Funktionsbaustein FB_DALIDimmer2Switch() zwei Schalter angeschlossen werden. Hierdurch kann der Bediener gezielt auf- oder abdimmen.

Bedienung über die Eingänge bSwitchDimmUp und bSwitchDimmDown

Durch ein kurzes Signal am Eingang bSwitchDimmUp bzw. bSwitchDimmDown, wird das Licht ein- oder ausgeschaltet. Liegt das Signal länger als tSwitchOverTime (empfohlener Richtwert: 200ms) an, so wird in den Dimmermodus umgeschaltet. Die angesteuerten Geräte werden nun auf nMaxLevelMasterDev bzw. nMinLevelMasterDev gedimmt. Wird das Signal wieder weggenommen, so bleibt das aktuelle Ausgangssignal anstehen. Durch einen erneuten Impuls auf einen der Eingänge, wird der Ausgang auf 0 gesetzt.

Bedienung über die Eingänge bOn und bOff

Wird eine positive Flanke an den Eingängen bOn oder bOff angelegt, so wird das Licht direkt ein- oder ausgeschaltet. Beim Ausschalten wird der Ausgangswert auf 0 gesetzt. Das Verhalten beim Einschalten kann durch die Memoryfunktion beeinflusst werden (siehe unten).

Bedienung über die Eingänge bSetDimmValue und nDimmValue

Ändert sich der Wert nDimmValue, so werden die angesprochenen Geräte direkt auf diesen Helligkeitswert gesteuert. Wichtig ist hierbei, dass sich der Wert ändert. Durch eine Änderung auf den Wert 0, wird die Beleuchtung ausgeschaltet. Durch eine positive Flanke an den Eingang bSetDimmValue wird der Wert nDimmValue direkt an den Ausgang ausgegeben. Das direkte Ändern des Ausgangs kann durch ein statisches 1-Signal am Eingang bSetDimmValue unterdrückt werden. Hierdurch kann ein Wert am Eingang nDimmValue angelegt werden, der erst bei der nächsten positiven Flanke, von bSetDimmValue an den Ausgang übergeben wird.
Mit Hilfe der Eingänge bSetDimmValue und nDimmValue können z.B. verschiedene Beleuchtungsszenarien realisiert werden. Das direkte Setzen des Ausgangs, mit Hilfe von nDimmValue, kann dazu benutzt werden, um bestimmte Helligkeiten anzufahren. Entweder direkt oder durch kontinuierliches Verändern des Wertes. nDimmValue muss einen Wert zwischen nMinLevelMasterDev und nMaxLevelMasterDev haben. Ausnahme ist der Wert 0. Liegt der Wert außerhalb des Bereichs, so wird der Ausgangswert auf die obere, bzw. untere Grenze begrenzt.

Memoryfunktion

Beim Einschalten muss unterschieden werden, ob die Memoryfunktion (Eingang bMemoryModeOn) aktiv ist oder nicht. Ist die Memoryfunktion aktiv, so wird beim Einschalten der zuletzt eingestellte Wert als Helligkeitswert übernommen. Ist die Memoryfunktion nicht aktiv, so wird den angesprochenen Geräten ein Helligkeitswert zugewiesen, der über den Parameter nOnValueWithoutMemoryMode vorgegeben wird. Hierbei ist es gleichgültig, ob das Licht über den Eingang bOn oder über den Eingang bSwitchDimmUp / bSwitchDimmDown geschaltet wird. Zu beachten ist, das der Parameter nOnValueWithoutMemoryMode zwischen nMinLevelMasterDev und nMaxLevelMasterDev liegen muss. Ist dieses nicht der Fall, so wird der Ausgangswert auf die untere bzw. obere Grenze angepasst.

Anmerkung zum Parameter tSwitchOverTime

Wird für den Parameter tSwitchOverTime eine Dauer von 0 vorgegeben, so kann mit dem Eingang bSwitchDimmUp bzw. bSwitchDimmDown das Licht nur gedimmt werden. Ein Ein-/Ausschalten ist nur mit den Eingängen bOn und bOff möglich.

Anmerkung zum Parameter nMasterDevAddr

Das DALI-System bietet die Möglichkeit, Lampen nicht nur einzeln zu steuern, sondern diese auch gruppenweise oder mit Sammelbefehlen anzusprechen. Dadurch das die einzelnen Geräte Teilnehmer von verschiedenen Gruppen sein können, kann die Situation entstehen, dass vor einer Gruppen- bzw. Sammelansteuerung die einzelnen Lampen verschiedene Helligkeitszustände innehaben. Um dennoch eine Aussage darüber treffen zu können, ob die Lampen nun ein- oder ausgeschaltet werden sollen, werden jeder Gruppe ein Führungsgerät (Master-Device) zugeordnet, nach dessen Zustand sich die restlichen Geräte richten. Soll mit dem Baustein eine einzelne Lampe angesteuert werden, eAddrType = eAddrTypeShort, so braucht kein Master-Device angegeben werden. Der Parameter nMasterDevAddr ist in diesem Fall ohne Bedeutung.

VAR_INPUT

bSwitchDimmUp              : BOOL;
bSwitchDimmDown            : BOOL;
bOn                        : BOOL;
bOff                       : BOOL;
bSetDimmValue              : BOOL;
nDimmValue                 : BYTE;
tSwitchOverTime            : TIME := t#400ms;
bMemoryModeOn              : BOOL := FALSE;
nOnValueWithoutMemoryMode  : BYTE := 254;
nAddr                      : BYTE := 0;
eAddrType                  : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr             : BYTE := 0;
nMinLevelMasterDev         : BYTE := 126;
nMaxLevelMasterDev         : BYTE := 254;
tCycleActualLevelMasterDev : TIME := t#0s;

bSwitchDimmUp: Schaltet oder dimmt die angesprochenen Geräte auf.

bSwitchDimmDown: Schaltet oder dimmt die angesprochenen Geräte ab.

bOn: Schaltet die angesprochenen Geräte auf den letzten Ausgangswert oder auf den Wert nOnValueWithoutMemoryMode.

bOff: Schaltet die angesprochenen Geräte aus (Wert 0).

bSetDimmValue: Eine positive Flanke an diesem Eingang setzt die angesprochenen Geräte direkt auf den Helligkeitswert, der am Eingang nDimmValue ansteht. Ändert sich der Wert nDimmValue, so wird der Helligkeitswert direkt auf den geänderten Wert eingestellt, wenn der Eingang bSetDimmValue auf FALSE steht.

nDimmValue: siehe bSetDimmValue.

tSwitchOverTime: Umschaltzeit zwischen Licht ein/aus und Licht dimmen für die Eingänge bSwitchDimmUp und bSwitchDimDown.

bMemoryModeOn: Schaltet auf Memoryfunktion um, so das beim Einschalten der vorherige Wert an den Ausgang geschrieben wird.

nOnValueWithoutMemoryMode: Einschaltwert, wenn die Memoryfunktion nicht eingeschaltet ist.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen.

nMinLevelMasterDev: Minimalwert des Master-Gerätes.

nMaxLevelMasterDev: Maximalwert des Master-Gerätes.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Dimmen der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

VAR_OUTPUT

nActualLevelMasterDev : BYTE;
bBusy                 : BOOL;
bError                : BOOL;
nErrorId              : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Dimmer2SwitchEco

Der Baustein FB_DALIDimmer2SwitchEco() stellt die speicherplatzsparende Variante des FB_DALIV2Dimmer2Switch() dar. Er ist ohne die Sonderfunktion "Memoryfunktion ausschalten" ausgestattet.

Bedienung über die Eingänge bSwitchDimmUp und bSwitchDimmDown

Durch ein kurzes Signal am Eingang bSwitchDimmUp bzw. bSwitchDimmDown, wird das Licht ein- oder ausgeschaltet. Liegt das Signal länger als tSwitchOverTime (empfohlener Richtwert: 200ms) an, so wird in den Dimmermodus umgeschaltet. Die angesteuerten Geräte werden nun gedimmt. Wird das Signal wieder weggenommen, so bleibt das aktuelle Ausgangssignal anstehen. Durch einen erneuten Impuls auf einen der Eingänge, wird der Ausgang auf 0 gesetzt.

Bedienung über die Eingänge bOn und bOff

Wird eine positive Flanke an den Eingängen bOn oder bOff angelegt, so wird das Licht direkt ein- oder ausgeschaltet. Beim Ausschalten wird der Ausgangswert auf 0 gesetzt.

Memoryfunktion

Im Gegensatz zum FB_DALIV2Dimmer2Switch(), bei der die Memoryfunktion über den Eingang bMemoryModeOn aktiviert oder ausgeschaltet werden kann, ist bei dieser speicherplatzsparenden Version die Memoryfunktion immer aktiv. Das bedeutet, dass beim Einschalten der zuletzt eingestellte Wert als Helligkeitswert übernommen wird. Hierbei ist es gleichgültig, ob das Licht über den Eingang bOn oder über den Eingang bSwitchDimm geschaltet wird.

Anmerkung zum Parameter tSwitchOverTime

Wird für den Parameter tSwitchOverTime eine Dauer von 0 vorgegeben, so kann mit dem Eingang bSwitchDimmUp bzw. bSwitchDimmDown das Licht nur gedimmt werden. Ein Ein-/Ausschalten ist nur mit den Eingängen bOn und bOff möglich.

Anmerkung zum Parameter nMasterDevAddr

Das DALI-System bietet die Möglichkeit, Lampen nicht nur einzeln zu steuern, sondern diese auch gruppenweise oder mit Sammelbefehlen anzusprechen. Dadurch das die einzelnen Geräte Teilnehmer von verschiedenen Gruppen sein können, kann die Situation entstehen, dass vor einer Gruppen- bzw. Sammelansteuerung die einzelnen Lampen verschiedene Helligkeitszustände innehaben. Um dennoch eine Aussage darüber treffen zu können, ob die Lampen nun ein- oder ausgeschaltet werden sollen, werden jeder Gruppe ein Führungsgerät (Master-Device) zugeordnet, nach dessen Zustand sich die restlichen Geräte richten. Soll mit dem Baustein eine einzelne Lampe angesteuert werden, eAddrType = eAddrTypeShort, so braucht kein Master-Device angegeben werden. Der Parameter nMasterDevAddr ist in diesem Fall ohne Bedeutung.

VAR_INPUT

bSwitchDimmUp              : BOOL;
bSwitchDimmDown            : BOOL;
bOn                        : BOOL;
bOff                       : BOOL;
bSetDimmValue              : BOOL;
nDimmValue                 : BYTE;
tSwitchOverTime            : TIME := t#400ms;
nAddr                      : BYTE := 0;
eAddrType                  : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr             : BYTE := 0;
tCycleActualLevelMasterDev : TIME := t#0s;

bSwitchDimmUp: Schaltet oder dimmt die angesprochenen Geräte auf.

bSwitchDimmDown: Schaltet oder dimmt die angesprochenen Geräte ab.

bOn: Schaltet die angesprochenen Geräte auf den letzten Ausgangswert.

bOff: Schaltet die angesprochenen Geräte aus (Wert 0).

bSetDimmValue: Eine positive Flanke an diesem Eingang setzt die angesprochenen Geräte direkt auf den Helligkeitswert, der am Eingang nDimmValue ansteht. Ändert sich der Wert nDimmValue, so wird der Helligkeitswert direkt auf den geänderten Wert eingestellt, wenn der Eingang bSetDimmValue auf FALSE steht.

nDimmValue: siehe bSetDimmValue.

tSwitchOverTime: Umschaltzeit zwischen Licht ein/aus und Licht dimmen für den Eingang bSwitchDimm.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen.

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Dimmen der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

VAR_OUTPUT

nActualLevelMasterDev : BYTE;
bBusy                 : BOOL;
bError                : BOOL;
nErrorId              : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Light

Der Baustein FB_DALIV2Light() ist ein einfacher Baustein zum Ein- und Ausschalten von DALI-Lampen.

Bedienung

Durch eine positive Flanke an den Eingang bOn wird das Licht auf den Maximalwert (MAX LEVEL) des Vorschaltgerätes gesetzt. Nach fehlerfreier Ausführung des Funktionsbausteines erhält der Ausgang bLight den Zustand TRUE. Durch eine positive Flanke an dem Eingang bOff wird das Licht ausgeschaltet und der Ausgang bLight wird auf FALSE gesetzt. Wird an bToggle eine positive Flanke angelegt, so liest sich der Funktionsbaustein zunächst den aktuellen Lichtwert des Master-Gerätes aus und beurteilt dann, ob sich das Licht im Ein- oder Auszustand befindet. Je nach getroffener Aussage wird das Licht dann in den jeweiligen anderen Zustand versetzt, also von An nach Aus, bzw. von Aus nach An umgeschaltet.

Anmerkung zum Parameter nMasterDevAddr

Das DALI-System bietet die Möglichkeit, Lampen nicht nur einzeln zu steuern, sondern diese auch gruppenweise oder mit Sammelbefehlen anzusprechen. Dadurch das die einzelnen Geräte Teilnehmer von verschiedenen Gruppen sein können, kann die Situation entstehen, dass vor einer Gruppen- bzw. Sammelansteuerung die einzelnen Lampen verschiedene Helligkeitszustände besitzen. Um dennoch eine Aussage darüber treffen zu können, ob die Lampen nun ein- oder ausgeschaltet werden sollen, werden jeder Gruppe ein Führungsgerät (Master-Device) zugeordnet, nach dessen Zustand sich die restlichen Geräte richten. Soll mit dem Baustein eine einzelne Lampe angesteuert werden, eAddrType = eAddrTypeShort, so braucht kein Master-Device angegeben werden. Der Parameter nMasterDevAddr ist in diesem Fall ohne Bedeutung.

VAR_INPUT

bOn                        : BOOL;
bOff                       : BOOL;
bToggle                    : BOOL;
nAddr                      : BYTE := 0;
eAddrType                  : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr             : BYTE := 0;
tCycleActualLevelMasterDev : TIME := t#0s;

bOn: Schaltet die angesprochenen Geräte ein (auf den Wert MAX LEVEL).

bOff: Schaltet die angesprochenen Geräte aus (auf den Wert 0).

bToggle: Negiert den Zustand der angesprochenen Geräte.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen.

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Dimmen der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

VAR_OUTPUT

bLight       : BOOL;
bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;

bLight: Zustand der Lampe oder Gruppe nach dem Aufrufen des Bausteins.

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2LightControl

Funktionsblock zur tageslichtabhängigen Lichtsteuerung mit bis zu 30 Stützpunkten.

Kernstück dieses Funktionsblockes ist eine Eingangs-/Stellgrößen-Tabelle von 30 Elementen mit einer Schwellwertumschaltung. Erreicht der Istwert der Helligkeit den Bereich eines Stützpunktes (arrControlTable[n].nActualValue-arrControlTable[n].nSwitchRange/2 ... arrControlTable[n].nActualValue+arrControlTable[n].nSwitchRange/2) so springt die Stellgröße auf den entsprechenden WertarrControlTable[n].nControlValue (siehe Diagramm). Daran angekoppelt ist ein Rampenbaustein, der die Stellgröße in der Zeit tRampTime anfährt. Beim Einschalten mit einer positiven Flanke an bOn wird das Licht jedoch zunächst auf die nächstgelegene Stellgröße direkt geschaltet. Erst dann wird die Steuerung aktiviert. Während die Steuerung aktiv ist, kann jederzeit mit einer positiven Flanke an bOn "nachgestartet" und damit das Licht auf die nächstgelegene Stellgröße direkt gesteuert werden. Eine positive Flanke an bOff schaltet alle angesteuerten Lampen direkt ab.

Es muß nicht der ganze Bereich der Tabelle genutzt werden. Das erste Tabellenelement, welches als Tabellenende nSwitchRange eine 0 hat, wird als Beginn des unbenutzten Bereiches angesehen.

Anmerkung zum Parameter nMasterDevAddr

Das DALI-System bietet die Möglichkeit, Lampen nicht nur einzeln zu steuern, sondern diese auch gruppenweise oder mit Sammelbefehlen anzusprechen. Dadurch, daß die einzelnen Geräte Teilnehmer von verschiedenen Gruppen sein können, kann die Situation entstehen, dass vor einer Gruppen- bzw. Sammelansteuerung die einzelnen Lampen verschiedene Helligkeitszustände innehaben. Um dennoch eine Aussage darüber treffen zu können, ob die Lampen nun ein- oder ausgeschaltet werden sollen, werden jeder Gruppe ein Führungsgerät (Master-Device) zugeordnet, nach dessen Zustand sich die restlichen Geräte richten. Soll mit dem Baustein eine einzelne Lampe angesteuert werden, eAddrType = eAddrTypeShort, so braucht kein Master-Device angegeben werden. Der Parameter nMasterDevAddr ist in diesem Fall ohne Bedeutung.

VAR_INPUT

bEnable                          : BOOL := TRUE;
bOn                              : BOOL;
bOff                             : BOOL;
nActualValue                     : UINT;
tRampTime                        : TIME := t#30s;
arrControlTable                  : ARRAY[1..30] OF ST_DALIV2ControlTable;
nOptions                         : DWORD := 0;
nAddr                            : BYTE := 0;
eAddrType                        : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr                   : BYTE := 0;
tCycleActualLevelMasterDev       : TIME := t#0s;

bEnable: Solange dieser Eingang auf TRUE steht, sind die Eingänge bOn und bOff aktiv. Ein negativer Zustand deaktiviert die Eingänge und setzt den Baustein nach Abarbeitung der letzten notwendigen DALI-Befehle zurück. Es werden dann keine DALI-Befehle außer die zyklische Abfrage der Helligkeit des Mastergerätes mehr ausgegeben.

bOn: Eine steigende Flanke schaltet die angesteuerten Lampen direkt auf die nächst gelegene Stellgröße.

bOff: Eine steigende Flanke schaltet die angesteuerten Lampen unmittelbar aus.

nActualValue: Iswert der Helligkeit.

tRampTime: Zeitdauer, in der die Stellgröße auf den nächsten Wert gesteuert wird (voreingestellter Wert: 30s).

arrControlTable: Eingangs-/Stellgrößen-Tabelle. arrControlTable[1] bis arrControlTable[30] des Typen ST_DALIV2ControlTable.

nOptions: Reserviert für zukünftige Entwicklungen.

nAddr: Adresse des Einzelgerätes bei Einzelansteuerung oder der Gruppe bei Gruppenansteuerung.

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund die aktuelle Stellgröße (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Dimmen der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

VAR_OUTPUT

nActualLevelMasterDev  : BYTE;
bBusy                  : BOOL;
bControlActive         : BOOL;
bError                 : BOOL;
nErrorId               : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

bBusy: Dieser Ausgang ist immer dann aktiv, solange eine Befehlsabarbeitung (bOn, bOff, bToggle oder Rampenfahrt) aktiv ist.

bControlActive: Dieser Ausgang wird gesetzt, sobald die Lichtsteuerung aktiviert wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Ramp

Funktionsblock zur Realisierung einer Lichtrampe.

Durch eine steigende Flanke am Eingang bOn wird das Licht auf den Maximalwert der Master-Lampe geschaltet - eine steigende Flanke am Eingang bOff schaltet das Licht wieder aus. Steigende Flanken am Eingang bToggle invertieren den jeweiligen Lichtzustand. Eine positive Flanke am Eingang bStart läßt den Baustein das Licht vom aktuellen Wert auf nEndLevel dimmen. Die dazu benötigte Zeit wird durch tRampTime festgelegt. Alle Eingänge sind nur aktiv, solange bEnable auf TRUE steht, ansonsten wird der Baustein intern zurückgesetzt und keine weiteren DALI-Befehle mehr ausgegeben.
Bei jedem Start der Dimm-Rampe findet eine Überprüfung statt, ob der Wert nEndLevel innerhalb der zulässigen Grenzen (MIN LEVEL ... MAX LEVEL) des Master-Gerätes liegen. Der Wert "0" ist ebenfalls erlaubt.

Rampenrealisierung

Grundsätzlich ist der Baustein so konzipiert, dass er innerhalb der vorgegebenen Rampenzeit die nötige Anzahl an OnAndStepUp- bzw. StepDownAndOff-Befehlen zeitlich gleichmäßig verteilt ausgibt.
Die Abarbeitung dieser Step- und Query-Befehle benötigt jedoch ihrerseits Zeit. Je weiter die Rampenzeit verringert wird, desto wahrscheinlicher wird die Tatsache, dass die intern berechnete Zeit für einen StepUp- bzw StepDown- Befehl nicht mehr ausreichend ist; die tatsächliche Rampenzeit wird im Vergleich zur eingestellten immer größer.
Um auch kleine Rampen realisieren zu können wird unterhalb eines intern voreingestellten Grenzwert von 11s Rampenzeit die Funktionsweise des Bausteines vom Schritt-Betrieb auf DirectArcPower-Betrieb umgeschaltet. Der DALI-Befehl DirectArcPowerControl steuert die entsprechenden Lampen von ihrem aktuellen Wert innerhalb der FADE TIME auf den eingestellten Endwert. Insgesamt gibt es 16 verschiedene Fade-Time-Werte, die jeweils im AnVorschaltgerät einer jeden Lampe hinterlegt sind und folgende Werte annehmen können:

nFadeTime | tFadeTime (s)
0 | <0,0707
1 | 0,707
2 | 1,000
3 | 1,414
4 | 2,000
5 | 2,828
6 | 4,000
7 | 5,657
8 | 8,000
9 | 11,314
10 | 16,000
11 | 22,627
12 | 32,000
13 | 45,255
14 | 64,000
15 | 90,510

Für die am Baustein eingestellte Rampe wird der nächste Wert aus der Tabelle genommen und in alle anzusteuernden Vorschaltgeräte einprogrammiert. Bei 6s wäre das beispielsweise Stufe 7 = 5,657s. Derselbe Wert würde ebenfalls für eine Rampenzeit von 5s genommen werden. Ein genaues Zeitverhalten ist somit leider nicht möglich. Nach erfolgreicher Beendigung der Rampenansteuerung wird der Wert in alle Vorschaltgeräte zurück übertragen, den das Mastergerät vor der Zeiteinstellung innehatte.
Während der Rampenfahrt wird der Ausgabewert nActualLevelMasterDev als intern berechneter Wert ausgegeben um den DALI-Bus nicht mit ständigen Abfrage-Befehlen zu belasten. Dieser Berechnung liegen die Start-Endwert-Differenz sowie die gewählte Rampenzeit zugrunde. Da es sich um einen berechneten Wert handelt, kann er durch Rundungen und Befehlsverzögerungen mit Fehlern behaftet sein und soll nur zur Orientierung dienen. Nach Beendigung der Rampe jedoch wird die Helligkeit direkt abgefragt und der Ausgabewert ist wieder exakt.

Anmerkung zum Parameter nMasterDevAddr

Das DALI-System bietet die Möglichkeit, Lampen nicht nur einzeln zu steuern, sondern diese auch gruppenweise oder mit Sammelbefehlen anzusprechen. Dadurch , daß die einzelnen Geräte Teilnehmer von verschiedenen Gruppen sein können, kann die Situation entstehen, dass vor einer Gruppen- bzw. Sammelansteuerung die einzelnen Lampen verschiedene Helligkeitszustände innehaben. Um dennoch eine Aussage darüber treffen zu können, ob die Lampen nun ein- oder ausgeschaltet werden sollen, werden jeder Gruppe ein Führungsgerät (Master-Device) zugeordnet, nach dessen Zustand sich die restlichen Geräte richten. Soll mit dem Baustein eine einzelne Lampe angesteuert werden, eAddrType = eAddrTypeShort, so braucht kein Master-Device angegeben werden. Der Parameter nMasterDevAddr ist in diesem Fall ohne Bedeutung.

VAR_INPUT

bEnable                          : BOOL := TRUE;
bOn                              : BOOL;
bOff                             : BOOL;
bToggle                          : BOOL;
bStart                           : BOOL;
nEndLevel                        : BYTE := 254;
tRampTime                        : TIME := t#8s;
nOptions                         : DWORD := 0;
nAddr                            : BYTE := 0;
eAddrType                        : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr                   : BYTE := 0;
tCycleActualLevelMasterDev       : TIME := t#0s;

bEnable: Solange dieser Eingang auf TRUE steht, sind die Eingänge bOn, bOff, bToggle und bStart aktiv. Ein negativer Zustand deaktiviert die Eingänge und setzt den Baustein nach Abarbeitung der letzten notwendigen DALI-Befehle zurück. Es werden dann keine DALI-Befehle außer die zyklische Abfrage der Helligkeit des Mastergerätes mehr ausgegeben.

bOn: Eine steigende Flanke schaltet die angesteuerten Lampen direkt auf den Maximalwert der Master-Lampe.

bOff: Eine steigende Flanke schaltet die angesteuerten Lampen unmittelbar aus.

bToggle: Eine steigende Flanke schaltet die angesteuerten Lampen unmittelbar aus, wenn die Master-Lampe nicht ausgeschaltet ist und umgekehrt ein, wenn die Master-Lampe aus ist.

bStart: Liegt an diesem Eingang eine steigende Flanke an, so wird das Licht vom derzeitigen Wert (ausschlaggebend ist hier das Master-Gerät) auf nEndLevel herauf bzw. herabgedimmt. Die dafür benötigte Zeit wird mit tRampTime festgelegt. Der Dimmvorgang kann jederzeit durch bOn, bOff oder bToggle unterbrochen werden.

nEndLevel: Zielwert des Dimmvorgangs. (Gültiger Wertebereich:0 oder MIN LEVEL ... MAX LEVEL).

tRampTime: Rampenzeit, siehe bStart. (Voreingestellter Wert: 8 Sekunden).

nOptions: Reserviert für zukünftige Entwicklungen.

nAddr: Adresse des Einzelgerätes bei Einzelansteuerung oder der Gruppe bei Gruppenansteuerung.

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Dimmen der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

VAR_OUTPUT

nActualLevelMasterDev           : BYTE;
bBusy                           : BOOL;
bError                          : BOOL;
nErrorId                        : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

bBusy: Dieser Ausgang ist immer dann aktiv, solange eine Befehlsabarbeitung (bOn, bOff, bToggle oder Rampenfahrt) aktiv ist.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Sequencer

Funktionsblock zur Realisierung von Lichtsequenzen mit bis zu 50 Stützpunkten.

Kernstück dieses Funktionsblockes ist ein Rampenbaustein, der einzelne, in einer Tabelle definierte Helligkeitswerte in einer einstellbaren Zeit anfährt und auf diesem Helligkeitswert dann eine ebenfalls definierbare Zeit verweilt. Nach dem Verweilen wird dann der nächste Wert angefahren. Die Tabelle arrSequenceTable besteht, wie bereits erwähnt, aus 50 Einträgen mit den Werten für nTargetValue (Zielwert), tRampTime (Zeit zum Erreichen des Zielwertes) und tProlongTime (Verweilzeit auf dem Zielwert). Es ist nicht zwingend notwendig, alle 50 Werte zu nutzen. Ein 0-Eintrag aller 3 Werte markiert das Ende einer Sequenz. Darüber hinaus ist es mit dem Eingang nStartIndex möglich, eine Lichtsequenz an jeder beliebigen Stelle der Tabelle beginnen zu lassen. Dadurch lassen sich auch innerhalb der 50 Einträge mehrere verschiedene Lichtsequenzen programmieren, die untereinander jeweils durch 0-Eintrags-Elemente getrennt sind:

Sequenz 1 beispielsweise sieht im zeitlichen Verlauf folgendermaßen aus (nStartIndex=1, nOptions.bit0=TRUE, Erläuterung siehe unten):

Darüber hinaus lässt sich der Baustein "normal" ein- und ausschalten (Ein: Maximalwert der Lampen, Aus: 0) sowie über den Eingang bToggle zwischen "Ein" und "Aus" hin und herschalten. Alle Befehlseingänge sind jedoch nur dann aktiv, wenn der Eingang bEnable auf TRUE steht. Wird er zurück auf FALSE gesetzt, so werden keine Befehle mehr angenommen und der Lichtwert behält seinen aktuellen Zustand - auch aus einer Rampenfahrt heraus.

Hinweis: Dieser Baustein basiert, wie eingangs erwähnt, auf dem FB_DALIV2Ramp. Der Rampenbaustein versucht die eingestellte Rampenzeit so genau wie möglich abzubilden. Dennoch ist es notwendig einmalig, wie zyklisch Daten aus dem DALI-Vorschaltgeräten abzufragen, was je nach eingestellter PLC-Zykluszeit unterschiedlich dauert. Daher sind Ungenauigkeiten in der Rampenzeit nicht ausgeschlossen.

VAR_INPUT

bEnable                    : BOOL := TRUE;
bOn                        : BOOL;
bOff                       : BOOL;
bToggle                    : BOOL;
bStart                     : BOOL;
nStartIndex                : USINT := 0;
arrSequenceTable           : ARRAY [1..nMaxSequenceValues] OF ST_DALIV2SequenceTable;
nOptions                   : DWORD := 0;
nAddr                      : BYTE := 0;
eAddrType                  : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr             : BYTE := 0;
tCycleActualLevelMasterDev : TIME := t#0s;

bEnable: Solange dieser Eingang auf TRUE steht, sind die Eingänge bOn, bOff, bToggle und bStart aktiv. Ein negativer Zustand deaktiviert die Eingänge und setzt den Baustein zurück.

bOn: Eine steigende Flanke schaltet nActualLevelMasterDevice direkt auf den Maximalwert .

bOff: Eine steigende Flanke schaltet nActualLevelMasterDevice unmittelbar auf "0".

bToggle: Schaltet den Lichtzustand zwischen An (Maximalwert) und Aus (0) jeweils hin und her.

bStart: Eine positive Flanke startet eine Lichtsequenz ab dem unter nStartIndex definierten Anfang.

nStartIndex: Siehe bStart.

arrSequenceTable: Lichtwert-Tabelle mit den dazugehörigen Rampen- und Verweilzeiten.

nOptions: Parametriereingang. Die Setzen (bzw. Nicht-Setzen) der einzelnen Bits dieser Variablen vom Typ DWORD hat folgende Wirkung:

Bit | Beschreibung
0 | nicht gesetzt: Der Baustein stoppt nach Ablauf einer Sequenz seine Aktivität. Eine erneute positive Flanke an bStart wäre für einen Sequenz-Neustart nötig. gesetzt: Nach Ablauf einer Sequenz läuft der Baustein automatisch an der an nStartIndex definierten Stelle weiter.
1..31 | -- reserviert für zukünftige Optionen --

nAddr: Adresse des Einzelgerätes bei Einzelansteuerung oder der Gruppe bei Gruppenansteuerung.

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Ansteuern der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

VAR_OUTPUT

nActualLevelMasterDev           : BYTE;
nActualIndex                    : USINT;
bLight                          : BOOL;
bSequenceActive                 : BOOL;
bBusy                           : BOOL;
bError                          : BOOL;
nErrorId                        : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

nActualIndex : Verweis auf das aktuelle Element in der Sequenz-Tabelle. Ist eine Sequenz beendet (bSequenceActive = FALSE , s.u.) wird dieser Ausgang zu "0".

bLight: Dieser Ausgang ist solange gesetzt, wie nActualLevelMasterDev größer als "0" ist.

bSequenceActive : Bei Abarbeitung einer Sequenz wird dieser Ausgang auf TRUE gesetzt.

bBusy: Dieser Ausgang ist immer dann aktiv, solange eine Befehlsabarbeitung (bOn, bOff, bToggle oder Rampenfahrt) aktiv ist.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den spezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf "0" zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StairwellDimmer

Funktionsblock zur Steuerung von Treppenhausbeleuchtungen.

Durch eine steigende Flanke am Eingang bSwitch wird das Licht auf den Wert nPresenceValue geschaltet. Durch eine fallende Flanke an bSwitch wird ein Timer mit der Laufzeit von tPresenceDuration gestartet. Nach Ablauf dieses Timers werden die angesteuerten Lampen innerhalb der Zeit tFadeTime auf den Wert nProlongValue gedimmt. Dieser Wert wird über den Zeitraum tProlongDuration beibehalten. Danach wird das Licht ausgeschaltet. Eine positive Flanke am Eingang bOff schaltet das Licht sofort aus, eine erneute steigende Flanke am Eingang bSwitch schaltet das Licht jederzeit - auch während der Dimm- und Wartezeiten - wieder ein.
Bei jedem Einschalten des Lichtes findet eine Überprüfung statt, ob die Werte nPresenceValue und nProlongValue innerhalb der zulässigen Grenzen (MIN LEVEL ... MAX LEVEL) des Master-Gerätes liegen. Der Wert "0" ist ebenfalls erlaubt. Darüber hinaus ist es möglich, daß nPresenceValue kleiner als nProlongValue ist oder beide Werte identisch sind.

Anmerkung zum Parameter nMasterDevAddr

Das DALI-System bietet die Möglichkeit, Lampen nicht nur einzeln zu steuern, sondern diese auch gruppenweise oder mit Sammelbefehlen anzusprechen. Dadurch das die einzelnen Geräte Teilnehmer von verschiedenen Gruppen sein können, kann die Situation entstehen, dass vor einer Gruppen- bzw. Sammelansteuerung die einzelnen Lampen verschiedene Helligkeitszustände innehaben. Um dennoch eine Aussage darüber treffen zu können, ob die Lampen nun ein- oder ausgeschaltet werden sollen, werden jeder Gruppe ein Führungsgerät (Master-Device) zugeordnet, nach dessen Zustand sich die restlichen Geräte richten. Soll mit dem Baustein eine einzelne Lampe angesteuert werden, eAddrType = eAddrTypeShort, so braucht kein Master-Device angegeben werden. Der Parameter nMasterDevAddr ist in diesem Fall ohne Bedeutung.

VAR_INPUT

bEnable                     : BOOL := TRUE;
bSwitch                     : BOOL;
bOff                        : BOOL;
nPresenceValue              : BYTE := 254;
nProlongValue               : BYTE := 200;
tPresenceDuration           : TIME := t#30s;
tFadeOffDuration            : TIME := t#10s;
tProlongDuration            : TIME := t#20s;
nOptions                    : DWORD := 0;
nAddr                       : BYTE := 0;
eAddrType                   : E_DALIV2AddrType := eDALIV2AddrTypeShort;
nMasterDevAddr              : BYTE := 0;
tCycleActualLevelMasterDev  : TIME := t#0s;

bEnable: Solange dieser Eingang auf TRUE steht, sind die Eingänge bOn und bOff aktiv. Ein negativer Zustand deaktiviert die Eingänge und setzt den Baustein nach Abarbeitung der letzten notwendigen DALI-Befehle zurück. Es werden dann keine DALI-Befehle außer die zyklische Abfrage der Helligkeit des Mastergerätes mehr ausgegeben.

bSwitch: Bei steigender Flanke: Die angesteuerten Lampen werden direkt auf nPresenceValue geschaltet. Bei fallender Flanke: Starten der Präsenzzeit (siehe Grafik).

bOff: Schaltet die angesteuerten Lampen unmittelbar aus.

nPresenceValue: Wert, auf den die angesteuerten Lampen während der Präsenzzeit geschaltet werden sollen. (Gültiger Wertebereich:0oder MIN LEVEL ... MAX LEVEL -voreingestellter Wert: 254).

nProlongValue: Wert, auf den die angesteuerten Lampen während der Verweilzeit geschaltet werden sollen. (Gültiger Wertebereich:0oder MIN LEVEL ... MAX LEVEL -voreingestellter Wert: 200).

tPesenceDuration: Dauer der Präsenzzeit, bei der die angesteuerten Lampen nach einer fallenden Flanke an bSwitch auf nPresenceValue geschaltet werden. (Voreingestellter Wert: 30 Sekunden).

tFadeOffDuration: Zeitdauer, in der der Helligkeitswert von nPresenceValue auf nProlongValue gesteuert wird. (Voreingestellter Wert: 10 Sekunden).

tProlongDuration: Dauer der Verweilzeit. (Voreingestellter Wert: 20 Sekunden).

nOptions: Reserviert für zukünftige Entwicklungen.

nAddr: Adresse des Einzelgerätes bei Einzelansteuerung oder der Gruppe bei Gruppenansteuerung.

nMasterDevAddr: Adresse des Master-Gerätes bei Gruppen- und Sammelschaltungen.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

tCycleActualLevelMasterDev: Zykluszeit, mit der im Hintergrund der aktuelle Istwert (ACTUAL DIM LEVEL) ausgelesen wird. Damit das Dimmen der Lampen nicht gestört wird, wird das Auslesen immer in der niedrigsten Priorität durchgeführt. Wird der Wert auf 0 gesetzt, so wird das Auslesen gesperrt.

VAR_OUTPUT

nActualLevelMasterDev   : BYTE;
bBusy                   : BOOL;
bError                  : BOOL;
nErrorId                : UDINT;

nActualLevelMasterDev: Aktueller Ausgabewert des Master-Gerätes (bei eAddrType = eAddrTypeShort immer des jeweilig angesprochenen Gerätes).

bBusy: Dieser Ausgang ist immer dann gesetzt, wenn eine Lichtänderung aktiv ist, also Ein, Aus und Rampenfahrt. Dabei spielen Start- und Zielwert keine Rolle. Auch bei einer Rampenfahrt von bspw. 100 nach 100 in 10s würde dieser Ausgang gesetzt sein.

bCycleActive: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Zyklus abgearbeitet bzw. die Lampen ausgeschaltet wurden.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


Interior Automation - Funktionsbausteine

Name | Beschreibung
FB_DALIV2IAPIR | Dieser Baustein liest zyklisch den Zustand eines IA PIR-Sensors aus und skaliert aus dem empfangenen Wert die gemessene Helligkeit und die erkannte Präsenz.


FB_DALIV2IAPIR

Dieser Baustein liest zyklisch den Zustand eines IA PIR-Sensors aus und skaliert aus dem empfangenen Wert die gemessene Helligkeit und die erkannte Präsenz.

Es können zwei verschiedene Zykluszeiten vorgegeben werden. Eine Zykluszeit, die benutzt wird wenn keine Präsenz erkannt wurde, und eine die bei aktiver Präsenz zum Einsatz kommt. Hierdurch besteht die Möglichkeit, die Zugriffe auf den DALI-Bus zu minimieren. Ist Präsenz erkannt, so kann in der Regel eine langsamere Zykluszeit (z.B. 20 s) gewählt werden, da die Lichtregelung und das Ausschalten der Beleuchtung nicht zeitkritisch sind. Ist keine Präsenz vorhanden, so sollte eine kleinere Zykluszeit (z.B. 2s) gewählt werden. Dadurch erfolgt das Einschalten der Beleuchtung beim Betreten des Raums mit einer möglichst geringen Reaktionszeit.

Weitere Informationen und eine Beschreibung der elektrischen und physikalischen Eigenschaften finden Sie in der Produktbeschreibung des IA PIR-Sensors.

VAR_INPUT

bReadDirectly            : BOOL := FALSE;
tCycleTimeIfOccupancy    : TIME := t#20s;
tCycleTimeIfNoOccupancy  : TIME := t#2s;
nAddr                    : BYTE := 0;
eAddrType                : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority         : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bReadDirectly: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

tCycleTimeIfOccupancy: Zykluszeit bei aktiver Präsenz.

tCycleTimeIfNoOccupancy: Zykluszeit bei nicht aktiver Präsenz.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bOccupancy    : BOOL;
nBrightness   : INT;
nRawValue     : BYTE;
bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;

bOccupancy: Der Ausgang ist gesetzt, wenn der Sensor Präsenz erkennt.

nBrightness: Gemessene Helligkeit in Lux.

nRawValue: Der ausgelesene Wert vom Sensor vor der Umrechnung.

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer    : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2234 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.9.0


Tridonic - Funktionsbausteine

Name | Beschreibung
FB_DALIV2SmartSPOT | Dieser Baustein liest zyklisch den Zustand eines smartSPOT-Sensors oder MSensor 02 aus und skaliert aus dem empfangenen Wert die gemessene Helligkeit und die erkannte Präsenz.


FB_DALIV2SmartSPOT

Dieser Baustein liest zyklisch den Zustand eines smartSPOT-Sensors oder MSensor 02 aus und skaliert aus dem empfangenen Wert die gemessene Helligkeit und die erkannte Präsenz.

Es können zwei verschiedene Zykluszeiten vorgegeben werden. Eine Zykluszeit, die benutzt wird wenn keine Präsenz erkannt wurde, und eine die bei aktiver Präsenz zum Einsatz kommt. Hierdurch besteht die Möglichkeit, die Zugriffe auf den DALI-Bus zu minimieren. Ist Präsenz erkannt, so kann in der Regel eine langsamere Zykluszeit (z.B. 20 s) gewählt werden, da die Lichtregelung und das Ausschalten der Beleuchtung nicht zeitkritisch sind. Ist keine Präsenz vorhanden, so sollte eine kleinere Zykluszeit (z.B. 2s) gewählt werden. Dadurch erfolgt das Einschalten der Beleuchtung beim Betreten des Raums mit einer möglichst geringen Reaktionszeit.

Die gemessene Helligkeit des Sensors ist abhängig von der Reflektion der im Raum vorhandenen Möbel. Der gemessene Wert beträgt nur 20 % bis 40 % von der reellen Helligkeit auf der gemessenen Fläche. Beispiel: 500 Lux auf dem Tisch mit einem Reflektionsgrad von 30 % ergibt einen Helligkeitswert von 150 Lux. Der Messbereich des Sensors ist so ausgelegt, dass die übliche Helligkeit am Arbeitsplatz von 200 Lux bis 1000 Lux geregelt werden kann.

Soll der Baustein mit dem MSensor 02 eingesetzt werden, so muss sich dieser im Slave-Mode befinden.

Weitere Informationen und eine Beschreibung der elektrischen und physikalischen Eigenschaften finden Sie in der Produktbeschreibung des smartSPOT-Sensors oder des MSensor 02.

VAR_INPUT

bReadDirectly            : BOOL := FALSE;
tCycleTimeIfOccupancy    : TIME := t#20s;
tCycleTimeIfNoOccupancy  : TIME := t#2s;
nAddr                    : BYTE := 0;
eAddrType                : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority         : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bReadDirectly: Durch eine positive Flanke an diesem Eingang werden die Istwerte unmittelbar gelesen.

tCycleTimeIfOccupancy: Zykluszeit für das Auslesen der Istwerte bei aktiver Präsenz.

tCycleTimeIfNoOccupancy: Zykluszeit für das Auslesen der Istwerte bei nicht aktiver Präsenz.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bOccupancy    : BOOL;
nBrightness   : INT;
nRawValue     : BYTE;
bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;

bOccupancy: Der Ausgang ist gesetzt, wenn der Sensor Präsenz erkennt.

nBrightness: Gemessene Helligkeit in Lux.

nRawValue: Der ausgelesene Wert vom Sensor vor der Umrechnung.

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer    : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


Notbeleuchtung - Einführung

Im Folgenden werden die Funktionsbausteine und Variablen für Notlichtversorgungsgeräte mit DALI-Schnittstelle beschrieben. Alle folgenden Funktionsbausteine rufen 'anwendungsbezogene Erweiterungsbefehle' auf. Laut DALI-Normung (IEC 62386) liegen diese Befehle im Bereich 224 bis 255. Da es verschiedene anwendungsbezogene Erweiterungsbefehle gibt, muss mit dem Funktionsbaustein FB_DALIV2EnableDeviceType() festgelegt werden, welche Art von Vorschaltgeräten (Notbeleuchtung, Entladungslampen, ...) auf die Erweiterungsbefehle reagieren sollen. Eine genaue Beschreibung der einzelnen DALI-Kommandos und der Variablen für Notlichtversorgungsgeräte finden sie in der Norm IEC 62386 Part 202.


Notbeleuchtung - Variablen

Jedes DALI-Notlichtversorgungsgerät besitzt eine bestimmte Anzahl von Variablen (Parameter), aus denen verschiedene Informationen ausgelesen, oder auch einzelne Parameter verändert werden können.

Name | Vorgabewert | Rücksetzwert | Gültigkeitsbereich | Größe | Bemerkung
EMERGENCY LEVEL | EMERGENCY MAX LEVEL | keine Änderung | EMERGENCY MIN LEVEL ... EMERGENCY MAX LEVEL oder MASK | 1 Byte |
EMERGENCY MIN LEVEL | Hersteller abhängig | keine Änderung | 1 ... EMERGENCY MAX LEVEL oder MASK | 1 Byte | nur Lesen
EMERGENCY MAX LEVEL | Hersteller abhängig | keine Änderung | EMERGENCY MIN LEVEL ... 254 oder MASK | 1 Byte | nur Lesen
PROLONG TIME | 4 | keine Änderung | 0 ... 255 | 1 Byte |
TEST DELAY TIME | 0 | 0 | 00 00 ... FF FF | 2 Byte |
FUNCTION TEST DELAY TIME | 0 | keine Änderung | 00 00 ... FF FF | 2 Byte |
DURATION TEST DELAY TIME | 0 | keine Änderung | 00 00 ... FF FF | 2 Byte |
FUNCTION TEST INTERVAL | 7 | keine Änderung | 0, 1 ... 255 | 1 Byte |
DURATION TEST INTERVAL | 13 | keine Änderung | 0, 1 ... 97 | 1 Byte |
TEST EXECUTION TIMEOUT | 7 | keine Änderung | 0 ... 255 | 1 Byte |
BATTERY CHARGE | ???? ???? | keine Änderung | 0 ... 255 | 1 Byte |
DURATION TEST RESULT | 0 | keine Änderung | 0 ... 255 | 1 Byte |
LAMP EMERGENCY TIME | 0 | keine Änderung | 0 ... 255 | 1 Byte |
LAMP TOTAL OPERATION TIME | 0 | keine Änderung | 0 ... 255 | 1 Byte |
RATED DURATION | Hersteller abhängig | keine Änderung | 0 ... 255 | 1 Byte | nur Lesen
EMERGENCY MODE | ???? ???? | keine Änderung | 0 ... 255 | 1 Byte |
FEATURES | Hersteller abhängig | keine Änderung | 0 ... 255 | 1 Byte | nur Lesen
FAILURE STATUS | ???? ???? | keine Änderung | 0 ... 255 | 1 Byte |
EMERGENCY STATUS | ???? ???? | keine Änderung | 0 ... 255 | 1 Byte |
EXTENDED VERSION NUMBER | 1 | keine Änderung | 0 ... 255 | 1 Byte | nur Lesen

?: unbestimmt

EMERGENCY LEVEL

Diese Variable beinhaltet die Notbeleuchtungsstärke der Lampe. Begrenzt wird dieser Wert durch die Variablen EMERGENCY MAX LEVEL und EMERGENCY MIN LEVEL. Mit dem Baustein FB_DALIV2QueryEmergencyLevel() kann der Wert ausgelesen werden.

EMERGENCY MIN LEVEL / EMERGENCY MAX LEVEL

Die Ausgabe der Notbeleuchtungsstärke wird durch die Variablen EMERGENCY MIN LEVEL und EMERGENCY MAX LEVEL innerhalb des Vorschaltgerätes begrenzt. Ausnahmen sind die Leistungswerte 0 (Aus) und 255 (Maske). Durch den Hersteller des Vorschaltgerätes werden der EMERGENCY MIN LEVEL und der EMERGENCY MAX LEVEL fest vorgegeben. Mit den Bausteinen FB_DALIV2QueryEmergencyMinLevel() und FB_DALIV2QueryEmergencyMaxLevel() können die beiden Variablen aus dem Vorschaltgerät ausgelesen werden.

PROLONG TIME

Die Verlängerungszeit gibt an, um welche Zeitspanne der Notbetrieb verlängert werden soll nach der Rückkehr der Netzspannung. Die Einheit beträgt 30 Sekunden pro Schritt. Über den Baustein FB_DALIV2QueryTestTiming() kann der Wert aus dem Vorschaltgerät ausgelesen werden. Beschrieben wird diese Variable über den Baustein FB_DALIV2StoreDTRAsProlongTime().

TEST DELAY TIME

Über die Variable TEST DELAY TIME werden die Variablen FUNCTION TEST DELAY TIME, DURATION TEST DELAY TIME FUNCTION TEST INTERVAL und DURATION TEST INTERVAL gesetzt. Hierdurch wird das Zeitverhalten für den Funktionstest und den Betriebsdauertest wie folgt festgelegt:

Funktionstest:
Mit FB_DALIV2SetDTR() das höherwertige Byte für die Variable FUNCTION TEST DELAY TIME (Verzögerungszeit für den Funktionstest) in das DTR (Data Transfer Register) schreiben.
Mit FB_DALIV2StoreDTRAsTestDelayTimeHighByte() den Inhalt des DTR in das höherwertige Byte der 16-Bit-Variable TEST DELAY TIME schreiben.
Mit FB_DALIV2SetDTR() das niederwertige Byte für die Variable FUNCTION TEST DELAY TIME (Verzögerungszeit für den Funktionstest) in das DTR (Data Transfer Register) schreiben.
Mit FB_DALIV2StoreDTRAsTestDelayTimeLowByte() den Inhalt des DTR in das niederwertige Byte der 16-Bit-Variable TEST DELAY TIME schreiben.
Mit FB_DALIV2SetDTR() den Wert für die Variable FUNCTION TEST INTERVAL (Intervallzeit für den Funktionstest) in das DTR (Data Transfer Register) schreiben.
Mit FB_DALIV2StoreDTRAsFunctionTestInterval() wird der Inhalt des DTR in die Variable FUNCTION TEST INTERVAL geschrieben. Außerdem wird der Inhalt der Variablen TEST DELAY TIME in die Variable FUNCTION TEST DELAY TIME kopiert.

Betriebsdauertest:
Mit FB_DALIV2SetDTR() das höherwertige Byte für die Variable DURATION TEST DELAY TIME (Verzögerungszeit für den Betriebsdauertest) in das DTR (Data Transfer Register) schreiben.
Mit FB_DALIV2StoreDTRAsTestDelayTimeHighByte() den Inhalt des DTR in das höherwertige Byte der 16-Bit-Variable TEST DELAY TIME schreiben.
Mit FB_DALIV2SetDTR() das niederwertige Byte für die Variable DURATION TEST DELAY TIME (Verzögerungszeit für den Betriebsdauertest) in das DTR (Data Transfer Register) schreiben.
Mit FB_DALIV2StoreDTRAsTestDelayTimeLowByte() den Inhalt des DTR in das niederwertige Byte der 16-Bit-Variable TEST DELAY TIME schreiben.
Mit FB_DALIV2SetDTR() den Wert für die Variable FUNCTION TEST INTERVAL (Intervallzeit für den Funktionstest) in das DTR (Data Transfer Register) schreiben.
Mit FB_DALIV2StoreDTRAsDurationTestInterval() wird der Inhalt des DTR in die Variable DURATION TEST INTERVAL geschrieben. Außerdem wird der Inhalt der Variablen TEST DELAY TIME in die Variable DURATION TEST DELAY TIME kopiert.

FUNCTION TEST DELAY TIME

In dieser Variablen ist die Verzögerungszeit für den Funktionstest festgelegt. Nach dieser Zeit wird zum ersten Mal der Funktionstest ausgeführt. Die Einheit dieser Variablen beträgt 15 Minuten pro Schritt. Abgefragt werden kann diese Variable über den Baustein FB_DALIV2QueryTestTiming(). Beschrieben wird diese Variable über TEST DELAY TIME (siehe oben).

DURATION TEST DELAY TIME

In dieser Variablen ist die Verzögerungszeit für den Betriebsdauertest festgelegt. Nach dieser Zeit wird zum ersten Mal der Betriebsdauertest ausgeführt. Die Einheit dieser Variablen beträgt 15 Minuten pro Schritt. Abgefragt werden kann diese Variable über den Baustein FB_DALIV2QueryTestTiming(). Beschrieben wird diese Variable über TEST DELAY TIME (siehe oben).

FUNCTION TEST INTERVAL

In dieser Variablen ist die Intervallzeit für den Funktionstest festgelegt. In diesen Zeitabständen wird der Funktionstest periodisch ausgeführt. Die Einheit dieser Variablen beträgt 1 Tag pro Schritt. Abgefragt werden kann diese Variable über den Baustein FB_DALIV2QueryTestTiming(). Beschrieben wird diese Variable über TEST DELAY TIME (siehe oben).

DURATION TEST INTERVAL

In dieser Variablen ist die Intervallzeit für den Betriebsdauertest festgelegt. In diesen Zeitabständen wird der Betriebsdauertest periodisch ausgeführt. Die Einheit dieser Variablen beträgt 1 Woche pro Schritt. Abgefragt werden kann diese Variable über den Baustein FB_DALIV2QueryTestTiming(). Beschrieben wird diese Variable über TEST DELAY TIME (siehe oben).

TEST EXECUTION TIMEOUT

Der Funktionstest oder Betriebsdauertest kann durch verschiedene Ereignisse unterbrochen werden. Mit der Variablen TEST EXECUTION TIMEOUT kann die maximale Ausführungszeit festgelegt werden, in der der jeweilige Test abgeschlossen sein muss. Die Einheit dieser Variablen beträgt 1 Tag pro Schritt. Abgefragt werden kann diese Variable über den Baustein FB_DALIV2QueryTestTiming(). Beschrieben wird diese Variable über den Baustein FB_DALIV2StoreDTRAsTestExecutionTimeout().

BATTERY CHARGE

Der aktuelle Ladezustand vom Akku ist in dieser Variablen abrufbar. 0 bedeutet minimale Ladung und 254 bedeutet maximale Ladung. Kann der Ladezustand vom Vorschaltgerät nicht ermittelt werden, so enthält diese Variable den Wert 255. Mit dem Baustein FB_DALIV2QueryBatteryCharge() kann diese Variable ausgelesen werden.

DURATION TEST RESULT

Das Ergebnis eines Betriebsdauertestes ist in dieser Variablen abgelegt. Die Einheit beträgt 2 Minuten pro Schritt. Der Wert ist nur dann gültig, wenn in der Variablen EMERGENCY STATUS das Bit 2 gesetzt ist (siehe unten). Abgefragt werden kann die Variable DURATION TEST RESULT mit der Funktion FB_DALIV2QueryDurationTestResult().

LAMP EMERGENCY TIME

Die Laufzeit der Lampe im Notbetrieb (Versorgung mit Hilfe des Akkus) wird in dieser Variablen abgespeichert. Die Einheit beträgt 1 Stunde pro Schritt. Abgefragt wird diese Variable mit dem Baustein FB_DALIV2QueryLampEmergencyTime() und zurückgesetzt mit dem Baustein FB_DALIV2ResetLampTime().

LAMP TOTAL OPERATION TIME

Die gesamte Laufzeit der Lampe wird in dieser Variablen abgespeichert. Die Einheit beträgt 4 Stunden pro Schritt. Abgefragt wird diese Variable mit dem Baustein FB_DALIV2QueryLampTotalOperationTime() und zurückgesetzt mit dem Baustein FB_DALIV2ResetLampTime().

RATED DURATION

Die Nennbetriebsdauer des Akkus ist in dieser Variablen abgelegt. Die Einheit beträgt 2 Minuten pro Schritt. Der Wert kann mit dem Baustein FB_DALIV2QueryRatedDuration() gelesen werden und ist vom Hersteller des Vorschaltgerätes fest vorgegeben.

EMERGENCY MODE

In EMERGENCY MODE wird der aktuelle Modus vom Vorschaltgerät abgelegt. Mit dem Baustein FB_DALIV2QueryEmergencyMode() kann die Variable ausgelesen werden.

Bit | Beschreibung
0 | Rücksetz Modus. 0: Nein.
1 | Bereitschaft Notbetrieb (Normalbetrieb). 0: Nein.
2 | Notbetrieb. 0: Nein.
3 | verlängerter Notbetrieb nach Rückkehr der Netzspannung. 0: Nein.
4 | Funktionstest aktiv. 0: Nein.
5 | Betriebsdauertest aktiv. 0: Nein.
6 | angeschlossener Unterdrückungstaster aktiv. 0: nicht aktiv bzw. nicht vorhanden.
7 | angeschlossene Netzspannung aktiv. 0: Aus.

FEATURES

Die unterstützten Leistungsmerkmale des Vorschaltgerätes können mit dem Baustein FB_DALIV2QueryFeatures() aus dieser Variablen ausgelesen werden. Der Inhalt dieser Variablen wird vom Hersteller des Vorschaltgerätes fest vorgegeben und kann nicht geändert werden.

Bit | Beschreibung
0 | integriertes Notlichtversorgungsgerät. 0: Nein.
1 | Notlichtversorgungsgerät in Dauerschaltung. 0: Nein.
2 | schaltbares Notlichtversorgungsgerät in Dauerschaltung. 0: Nein.
3 | Autotestfähigkeit. 0: Nein.
4 | Einstellbare Stärke der Notbeleuchtung. 0: Nein.
5 | angeschlossener Unterdrückungstaster wird unterstützt. 0: Nein.
6 | Physikalische Auswahl wird unterstützt. 0: Nein.
7 | reserve

FAILURE STATUS

Mögliche Fehlerzustände werden in dieser Variablen angezeigt und können mit dem Baustein FB_DALIV2QueryFailureStatus() ausgelesen werden.

Bit | Beschreibung
0 | Störung im Schaltkreis des Vorschaltgerätes. 0: Nein.
1 | Störung Akkubetriebsdauer. 0: Nein.
2 | Störung Akku. 0: Nein.
3 | Störung am Leuchtmittel der Notbeleuchtung. 0: Nein.
4 | Zeitüberschreitung beim Funktionstest aufgetreten. 0: Nein.
5 | Zeitüberschreitung beim Betriebsdauertest aufgetreten. 0: Nein.
6 | Funktionstest fehlgeschlagen. 0: Nein.
7 | Betriebsdauertest fehlgeschlagen. 0: Nein

EMERGENCY STATUS

Der aktuelle Zustand vom Vorschaltgerät wird angezeigt. Mit dem Baustein FB_DALIV2QueryEmergencyStatus() kann der Inhalt der Variablen ausgelesen werden.

Bit | Beschreibung
0 | Unterdrückungsmodus. 0: Nein.
1 | Funktionstest abgeschlossen und Ergebnis ist gültig. 0: Nein.
2 | Betriebsdauertest abgeschlossen und Ergebnis ist gültig. 0: Nein.
3 | Akkuladung betriebsbereit. 0: in Gang.
4 | verzögerter Start vom Funktionstest. 0: Nein.
5 | verzögerter Start vom Betriebsdauertest. 0: Nein.
6 | Identifikation aktiv. 0: Nein.
7 | ausgewählt. 0: Nein

EXTENDED VERSION NUMBER

Die erweiterte Versionsnummer kann mit dem Baustein FB_DALIV2QueryExtendedVersionNumber() ausgelesen werden. Die Versionsnummer kann nur gelesen werden und wird vom Hersteller der Vorschaltgeräte vorgegeben.


Notbeleuchtung - Low-Level-Funktionsbausteine

Name | Beschreibung
FB_DALIV2Inhibit | Es wird für 15 Minuten verhindert, dass das Vorschaltgerät in den Notbetrieb umschaltet.
FB_DALIV2QueryBatteryCharge | Die Variable BATTERY CHARGE (Akku Ladezustand) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryDurationTestResult | Die Variable DURATION TEST RESULT (Ergebnis vom Betriebsdauertest) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryEmergencyLevel | Die Variable EMERGENCY LEVEL (Notfallbeleuchtungsstärke) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryEmergencyMaxLevel | Die Variable EMERGENCY MAX LEVEL (maximale Notfallbeleuchtungsstärke) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryEmergencyMinLevel | Die Variable EMERGENCY MIN LEVEL (minimale Notfallbeleuchtungsstärke) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryEmergencyMode | Die Variable EMERGENCY MODE (Modus der Notbetrieb) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryEmergencyStatus | Die Variable EMERGENCY STATUS (Zustand Notbetrieb) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryFailureStatus | Die Variable FAILURE STATUS (Fehlerzustände) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryFeatures | Die Variable FEATURES (Leistungsmerkmale) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryLampEmergencyTime | Die Variable LAMP EMERGENCY TIME (Notbetriebszeit der Lampe) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryLampTotalOperationTime | Die Variable LAMP TOTAL OPERATION TIME (gesamte Betriebszeit) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryRatedDuration | Die Variable RATED DURATION (Nennbetriebsdauer) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryTestTiming | Je nach Inhalt des DTR (Data Transfer Register) werden die Variablen FUNCTION TEST DELAY TIME, DURATION TEST DELAY TIME, FUNCTION TEST INTERVAL, DURATION TEST INTERVAL, TEST EXECUTION TIMEOUT oder PROLONG TIME aus dem Vorschaltgerät ausgelesen.
FB_DALIV2ReLightResetInhibit | Das Vorschaltgerät wird zurück in den Notbetrieb geschaltet (wenn die Netzspannung fehlt).
FB_DALIV2ResetDurationTestDoneFlag | Das Flag 'Betriebsdauertest abgeschlossen und Ergebnis ist gültig' wird zurückgesetzt.
FB_DALIV2ResetFunctionTestDoneFlag | Das Flag 'Funktionstest abgeschlossen und Ergebnis ist gültig' wird zurückgesetzt.
FB_DALIV2ResetLampTime | Die Variablen LAMP EMERGENCY TIME und LAMP TOTAL OPERATION TIME werden zurückgesetzt.
FB_DALIV2Rest | Schaltet die Lampe aus, wenn der Notbetrieb aktiv ist.
FB_DALIV2StartDurationTest | Der Betriebsdauertest wird gestartet.
FB_DALIV2StartFunctionTest | Der Funktionstest wird gestartet.
FB_DALIV2StopTest | Stoppt jede Art von Funktionstest oder Betriebsdauertest.
FB_DALIV2StoreDTRAsDurationTestInterval | Schreibt den Wert des DTR (Data Transfer Register) in die Variable DURATION TEST INTERVAL.
FB_DALIV2StoreDTRAsEmergencyLevel | Schreibt den Wert des DTR (Data Transfer Register) in die Variable EMERGENCY LEVEL.
FB_DALIV2StoreDTRAsFunctionTestInterval | Schreibt den Wert des DTR (Data Transfer Register) in die Variable FUNCTION TEST INTERVAL.
FB_DALIV2StoreDTRAsProlongTime | Schreibt den Wert des DTR (Data Transfer Register) in die Variable PROLONG TIME.
FB_DALIV2StoreDTRAsTestDelayTimeHighByte | Schreibt den Wert des DTR (Data Transfer Register) in das höherwertige Byte der Variablen TEST DELAY TIME.
FB_DALIV2StoreDTRAsTestDelayTimeLowByte | Schreibt den Wert des DTR (Data Transfer Register) in das niederwertige Byte der Variablen TEST DELAY TIME.
FB_DALIV2StoreDTRAsTestExecutionTimeout | Schreibt den Wert des DTR (Data Transfer Register) in die Variable TEST EXECUTION TIMEOUT.

Hinweis: Diese Befehle gehören zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.


FB_DALIV2Inhibit

Es wird für 15 Minuten verhindert, dass das Vorschaltgerät in den Notbetrieb umschaltet. Durch den Baustein FB_DALIReLightResetInhibit() kann das Unterdrücken des Notbetriebes wieder aufgehoben werden.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryBatteryCharge

Die Variable BATTERY CHARGE (Akku Ladezustand) wird aus dem Vorschaltgerät ausgelesen. Wird 255 zurückgeliefert, so kann der Wert vom Vorschaltgerät nicht ermittelt werden.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy             : BOOL;
bError            : BOOL;
nErrorId          : UDINT;
nBatteryCharge    : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nBatteryCharge: Ladezustand des Akkus. 0: leer / 254: voll.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryDurationTestResult

Die Variable DURATION TEST RESULT (Ergebnis vom Betriebsdauertest) wird aus dem Vorschaltgerät ausgelesen. Die Einheit beträgt 2 Minuten pro Schritt. Ein Wert von 255 bedeutet den maximalen Wert von 8,5 Stunden oder länger. Der Wert ist nur dann gültig, wenn in der Variablen EMERGENCY STATUS das Bit 2 gesetzt ist.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy               : BOOL;
bError              : BOOL;
nErrorId            : UDINT;
nDurationTestResult : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nDurationTestResult: Ergebnis vom Betriebsdauertest in 2 Minuten Schritten.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryEmergencyLevel

Die Variable EMERGENCY LEVEL (Notbeleuchtungsstärke) wird aus dem Vorschaltgerät ausgelesen. Wird 255 zurückgeliefert, so kann der Wert vom Vorschaltgerät nicht ermittelt werden.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy           : BOOL;
bError          : BOOL;
nErrorId        : UDINT;
nEmergencyLevel : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nEmergencyLevel: Notbeleuchtungsstärke des Vorschaltgerätes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryEmergencyMaxLevel

Die Variable EMERGENCY MAX LEVEL (maximale Notbeleuchtungsstärke) wird aus dem Vorschaltgerät ausgelesen. Wird 255 zurückgeliefert, so kann der Wert vom Vorschaltgerät nicht ermittelt werden.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy              : BOOL;
bError             : BOOL;
nErrorId           : UDINT;
nEmergencyMaxLevel : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nEmergencyMaxLevel: maximale Notbeleuchtungsstärke des Vorschaltgerätes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryEmergencyMinLevel

Die Variable EMERGENCY MIN LEVEL (minimale Notbeleuchtungsstärke) wird aus dem Vorschaltgerät ausgelesen. Wird 255 zurückgeliefert, so kann der Wert vom Vorschaltgerät nicht ermittelt werden.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy              : BOOL;
bError             : BOOL;
nErrorId           : UDINT;
nEmergencyMinLevel : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nEmergencyMinLevel: minimale Notbeleuchtungsstärke des Vorschaltgerätes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryEmergencyMode

Die Variable EMERGENCY MODE (Modus Notbetrieb) wird aus dem Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | Rücksetz Modus. 0: Nein.
1 | Bereitschaft Notbetrieb (Normalbetrieb). 0: Nein.
2 | Notbetrieb. 0: Nein.
3 | verlängerter Notbetrieb nach Rückkehr der Netzspannung. 0: Nein.
4 | Funktionstest aktiv. 0: Nein.
5 | Betriebsdauertest aktiv. 0: Nein.
6 | angeschlossener Unterdrückungstaster aktiv. 0: nicht aktiv bzw. nicht vorhanden.
7 | angeschlossene Netzspannung aktiv. 0: Aus.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy          : BOOL;
bError         : BOOL;
nErrorId       : UDINT;
nEmergencyMode : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nEmergencyMode: Modus vom Notbetrieb (siehe Tabelle oben).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryEmergencyStatus

Die Variable EMERGENCY STATUS (Zustand Notbetrieb) wird aus dem Vorschaltgerät ausgelesen.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

Bit | Beschreibung
0 | Unterdrückungsmodus. 0: Nein.
1 | Funktionstest abgeschlossen und Ergebnis ist gültig. 0: Nein.
2 | Betriebsdauertest abgeschlossen und Ergebnis ist gültig. 0: Nein.
3 | Akkuladung betriebsbereit. 0: in Gang.
4 | verzögerter Start vom Funktionstest. 0: Nein.
5 | verzögerter Start vom Betriebsdauertest. 0: Nein.
6 | Identifikation aktiv. 0: Nein.
7 | ausgewählt. 0: Nein

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy            : BOOL;
bError           : BOOL;
nErrorId         : UDINT;
nEmergencyStatus : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nEmergencyStatus: Zustand vom Notbetrieb (siehe Tabelle oben).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryFailureStatus

Die Variable FAILURE STATUS (Fehlerzustand) wird aus dem Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | Störung im Schaltkreis des Vorschaltgerätes. 0: Nein.
1 | Störung Akkubetriebsdauer. 0: Nein.
2 | Störung Akku. 0: Nein.
3 | Störung am Leuchtmittel der Notbeleuchtung. 0: Nein.
4 | Zeitüberschreitung beim Funktionstest aufgetreten. 0: Nein.
5 | Zeitüberschreitung beim Betriebsdauertest aufgetreten. 0: Nein.
6 | Funktionstest fehlgeschlagen. 0: Nein.
7 | Betriebsdauertest fehlgeschlagen. 0: Nein

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy          : BOOL;
bError         : BOOL;
nErrorId       : UDINT;
nFailureStatus : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nFailureStatus: Der Fehlerzustand des Vorschaltgerätes (siehe Tabelle oben).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryFeatures

Die Variable FEATURES (Leistungsmerkmale) wird aus dem Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | integriertes Notlichtversorgungsgerät. 0: Nein.
1 | Notlichtversorgungsgerät in Dauerschaltung. 0: Nein.
2 | schaltbare Notlichtversorgungsgerät in Dauerschaltung. 0: Nein.
3 | Autotestfähigkeit. 0: Nein.
4 | Einstellbare Stärke der Notbeleuchtung. 0: Nein.
5 | angeschlossener Unterdrückungstaster wird unterstützt. 0: Nein.
6 | physikalische Auswahl wird unterstützt. 0: Nein.
7 | Reserve

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy     : BOOL;
bError    : BOOL;
nErrorId  : UDINT;
nFeatures : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nFeatures: Leistungsmerkmale des Vorschaltgerätes (siehe Tabelle oben).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryLampEmergencyTime

Die Variable LAMP EMERGENCY TIME (Notbetriebszeit der Lampe) wird aus dem Vorschaltgerät ausgelesen. Die Einheit beträgt 1 Stunde pro Schritt. Ein Wert von 255 bedeutet den maximalen Wert von 254 Stunden oder länger. Die Variable wird immer am Anfang des 1-Stunden-Intervalls erhöht. Wird der maximale Wert von 255 erreicht, so wird dieser nicht weiter erhöht. Durch den Befehl FB_DALIV2ResetLampTime() wird die Variable wieder zurückgesetzt.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy              : BOOL;
bError             : BOOL;
nErrorId           : UDINT;
nLampEmergencyTime : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nLampEmergencyTime: Notbetriebszeit der Lampe vom Vorschaltgerät.

VAR_IN_OUT

stCommandBuffer  : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryLampTotalOperationTime

Die Variable LAMP TOTAL OPERATION TIME (gesamte Betriebszeit der Lampe) wird aus dem Vorschaltgerät ausgelesen. Die Einheit beträgt 4 Stunden pro Schritt. Ein Wert von 255 bedeutet den maximalen Wert von 1016 Stunden oder länger. Die Variable wird immer am Anfang des 4-Stunden-Intervalls erhöht. Wird der maximale Wert von 255 erreicht, so wird dieser nicht weiter erhöht. Durch den Befehl FB_DALIV2ResetLampTime() wird die Variable wieder zurückgesetzt.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy                   : BOOL;
bError                  : BOOL;
nErrorId                : UDINT;
nLampTotalOperationTime : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nLampTotalOperationTime: Gesamte Betriebszeit der Lampe vom Vorschaltgerät.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryRatedDuration

Die Variable RATED DURATION (Nennbetriebsdauer) wird aus dem Vorschaltgerät ausgelesen. Die Einheit beträgt 2 Minuten pro Schritt.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy          : BOOL;
bError         : BOOL;
nErrorId       : UDINT;
nRatedDuration : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nRatedDuration: Nennbetriebsdauer vom Vorschaltgerät.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryTestTiming

Dieser Baustein liest die Prüfzeiten (Intervalle, Dauer bis zum nächsten Ereignis, etc.) aus dem Vorschaltgerät. Dies geschieht in Abhängigkeit vom Wert, der am Eingang nDTR anliegt. Der Hintergrund ist, dass das DALI-Grundkommando 242 "Query Test Timing" zusammen mit dem Inhalt des Data-Transfer-Register (DTR) funktioniert, welches vorher entsprechend beschrieben werden muss. Der Baustein FB_DALIV2QueryTestTiming fasst diese beiden Aktionen zusammen. Folgende Daten werden in Abhängigkeit vom Wert nDTR aus dem Gerät ausgelesen:

nDTR | ausgelesener Wert
0 (2#0000 0000) | Wenn Automatik Test aktiviert ist: Zeit bis zum nächsten Function-Test (high-byte) in Viertelstunden Wenn Automatiktest nicht aktiviert ist: MASK (255)
1 (2#0000 0001) | Wenn Automatik Test aktiviert ist: Zeit bis zum nächsten Function-Test (low-byte) in Viertelstunden Wenn Automatiktest nicht aktiviert ist: MASK (255)
2 (2#0000 0010) | Wenn Automatik Test aktiviert ist: Zeit bis zum nächsten Duration-Test (high-byte) in Viertelstunden Wenn Automatiktest nicht aktiviert ist: MASK (255)
3 (2#0000 0011) | Wenn Automatik Test aktiviert ist: Zeit bis zum nächsten Duration-Test (low-byte) in Viertelstunden Wenn Automatiktest nicht aktiviert ist: MASK (255)
4 (2#0000 0100) | Wenn Automatik Test aktiviert ist: Test-Intervall des Function-Test in Tagen Wenn Automatiktest nicht aktiviert ist: MASK (255)
5 (2#0000 0101) | Wenn Automatik Test aktiviert ist: Test-Intervall des Duration-Test in Wochen Wenn Automatiktest nicht aktiviert ist: MASK (255)
6 (2#0000 0110) | Test-Ausführungs-Timeout in Tagen (maximaler Ausführungszeitraum für einen Test). Gilt nur für den Automatiktest!
7 (2#0000 0111) | Lampen-Ein-Verlängerungszeit nach Verlassen des Notfall-Betriebes, gemessen in 0,5 min-Schritten

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nDTR              : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nDTR: In Abhängigkeit dieses Eingangs werden entsprechende Werte gelesen, s.o.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;
nValue      : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nValue: Ergebnis.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2ReLightResetInhibit

Das Vorschaltgerät wird zurück in den Notbetrieb geschaltet (wenn die Netzspannung fehlt). Hierdurch wird die Funktion des Bausteins FB_DALIV2Inhibit() aufgehoben.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2ResetDurationTestDoneFlag

Das Flag 'Betriebsdauertest abgeschlossen und Ergebnis ist gültig' wird zurückgesetzt. Das Flag ist in der Variable EMERGENCY STATUS (Zustand Notbetrieb) Bit 2 und kann mit dem Baustein FB_DALIQueryEmergencyStatus() abgefragt werden.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2ResetFunctionTestDoneFlag

Das Flag 'Funktionstest abgeschlossen und Ergebnis ist gültig' wird zurückgesetzt. Das Flag ist in der Variable EMERGENCY STATUS (Zustand Notbetrieb) Bit 1 und kann mit dem Baustein FB_DALIQueryEmergencyStatus() abgefragt werden.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2ResetLampTime

Die Variable LAMP EMERGENCY TIME (Notbetriebszeit der Lampe) und LAMP TOTAL OPERATION TIME (gesamte Betriebszeit der Lampe) werden zurückgesetzt.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2Rest

Mit diesem Baustein wird die Lampe ausgeschaltet wenn der Notbetrieb aktiv ist. Ansonsten wird auf Normalbetrieb umgeschaltet für den Fall das die Netzspannung wieder vorhanden ist oder der Baustein FB_DALIV2ReLightResetInhibit() aufgerufen wurde.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy         : BOOL;
bError        : BOOL;
nErrorId      : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StartDurationTest

Der Betriebsdauertest wird gestartet. Wird der Betriebsdauertest verzögert gestartet, so wird dieses in der Variable EMERGENCY STATUS (Zustand Notbetrieb) Bit 5 angezeigt.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StartFunctionTest

Der Funktionstest wird gestartet. Wird der Funktionstest verzögert gestartet, so wird dieses in der Variable EMERGENCY STATUS (Zustand Notbetrieb) Bit 4 angezeigt.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StopTest

Stoppt jede Art von Funktionstest oder Betriebsdauertest.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsDurationTestInterval

Schreibt den Wert des DTR (Data Transfer Register) in die Variable DURATION TEST INTERVAL (Intervallzeit Betriebsdauertest).

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsEmergencyLevel

Schreibt den Wert des DTR (Data Transfer Register) in die Variable EMERGENCY LEVEL (Notbeleuchtungsstärke).

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsFunctionTestInterval

Schreibt den Wert des DTR (Data Transfer Register) in die Variable FUNCTION TEST INTERVAL (Intervallzeit Funktionstest).

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsProlongTime

Schreibt den Wert des DTR (Data Transfer Register) in die Variable PROLONG TIME (Verlängerungszeit).

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsTestDelayTimeHighByte

Schreibt den Wert des DTR (Data Transfer Register) in das höherwertige Byte der Variable TEST DELAY TIME.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer  : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsTestDelayTimeLowByte

Schreibt den Wert des DTR (Data Transfer Register) in das niederwertige Byte der Variable TEST DELAY TIME.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer  : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StoreDTRAsTestExecutionTimeout

Schreibt den Wert des DTR (Data Transfer Register) in die Variable TEST EXECUTION TIMEOUT (maximale Ausführungszeit für einen Test).

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 1 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 1 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Notbeleuchtungen intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


Notbeleuchtung - High-Level-Funktionsbausteine

Name | Beschreibung
FB_DALIV2EmergencyLightingDT | Dieser Baustein dient zur Dauer-Prüfung (Duration-Test) eines DALI-Notbeleuchtungs-Gerätes. Die Testergebnisse werden zum Test-Ende über einen FIFO-Buffer (IN-OUT-Variable fbStringRingBuffer) geschrieben, welcher seinerseits durch den Baustein FB_DALIV2FileLogging() in eine Datei ausgelesen wird.
FB_DALIV2EmergencyLightingFT | Dieser Baustein dient zur Funktions-Prüfung (Function-Test) eines DALI-Notbeleuchtungs-Gerätes. Die Testergebnisse werden zum Test-Ende über einen FIFO-Buffer (IN-OUT-Variable fbStringRingBuffer) geschrieben, welcher seinerseits durch den Baustein FB_DALIV2FileLogging() in eine Datei ausgelesen wird.
FB_DALIV2FileLogging | Dieser Baustein liest die in Bausteinen FB_DALIV2EmergencyLightingFT() und FB_DALIV2EmergencyLightingDT() jeweils beschriebenen FIFO-Puffer (IN-OUT-Variable fbStringRingBuffer) aus und schreibt die Inhalte in eine Log-Datei.
FB_DALIV2GetSettingsType01 | Dieser Baustein liest von allen Notbeleuchtungs-Vorschaltgeräten einer DALI-Line die Variablen (BATTERY CHARGE, DURATION TEST RESULT, LAMP EMERGENCY TIME ...) aus, und speichert diese in einer Struktur.
FB_DALIV2SetSettingsType01 | Dieser Baustein initialisiert die Variablen (EMERGENCY LEVEL, FUNCTION TEST DELAY TIME, DURATION TEST DELAY TIME ...) aller Notbeleuchtungs-Vorschaltgeräten einer DALI-Line mit den Werten, die in einer Struktur abgelegt sind.


FB_DALIV2EmergencyLightingDT

Dieser Baustein dient zur Dauer-Prüfung (Duration-Test) eines DALI-Notbeleuchtungs-Gerätes. Die Testergebnisse werden zum Test-Ende über einen FIFO-Buffer (IN-OUT-Variable fbStringRingBuffer) geschrieben, welcher seinerseits durch den Baustein FB_DALIV2FileLogging() in eine Datei ausgelesen wird. Ereignisse, die den Test verhindern oder unterbrechen werden zusätzlich zur Ergebnis-Meldung an den Ausgängen bError und nErrorID angezeigt.

Folgende Ereignisse verhindern die Ausführung eines Dauer-Tests:

  • Das Gerät läuft im automatischen Dauertest-Modus, d.h. ein Testintevall ist im Gerät programmiert.
  • Das Gerät führt gerade einen Test aus bzw. ein Test steht automatisch bevor (Funktionstest oder Dauertest)
  • Die Notfall-Batterie ist nicht vollständig geladen
  • Das Gerät befindet sich zu Testbeginn nicht in der Notfall-Bereitschaft ("normal-mode")

Zu den Ereignissen, die einen begonnenen Dauer-Test unterbrechen gehören diese:

  • Das Gerät hat nach dem Teststart den Dauer-Test-Modus nicht erreicht
  • Der Test ist nicht richtig beendet worden, d.h. das Gerät befindet sich nach dem Teststart und einer gewissen Wartezeit irgendwann weder im Test-Modus noch (wieder zurück) im Notfall-Bereitschafts-Modus ("normal-mode")
  • Ein DALI-Kommando wurde fehlerhaft abgearbeitet
  • Die Timeout-Zeit ist abgelaufen

Hinweis: Dieser Baustein ist nur in der PC-Version der DALIV2-Bibliothek verfügbar.

VAR_INPUT

bStart           : BOOL;
bStop            : BOOL;
nAddr            : BYTE;
sController      : STRING(20);
sLineName        : STRING(10);
sDescription     : STRING(20);
sLocation        : STRING(20);
stDateTime       : TIMESTRUCT;
tTimeout         : TIME := t#120m;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

bStop: Ist ein Dauertest erfolgreich gestartet worden, so wird intern der Emergency-Mode und der Emergency-Status zyklisch abgefragt, um zu beurteilen, wann der Test beendet ist und ob Fehler während des Tests auftreten. Eine positive Flanke am bStop-Eingang bricht den Dauertest in genau dieser Phase ab und gibt eine entsprechende Meldung in der Log-Datei. Dies ist dann sinnvoll, wenn lediglich beurteilt werden soll ob die Notbeleuchtung eine bestimmte Zeit lang (bis zum Zeitpunkt des Stoppens) läuft.

nAddr: Adresse des zu testenden Gerätes.

sController: Controller-Zugehörigkeit des DALI-Gerätes. Dient zur Beschreibung in der Log-Datei.

sLineName: Linien-Zugehörigkeit des DALI-Gerätes. Dient zur Beschreibung in der Log-Datei.

sDescription: Weitere ergänzende Beschreibung des Gerätes in der Log-Datei.

sLocation: Beschreibung des Einbauortes.

stDateTime: Eingang für aktuelles Datum und Zeit.

tTimeout: Zeit in der der Test abgeschlossen sein muss.

VAR_OUTPUT

tElapsedTestTime : TIME;
nEmergencyMode   : BYTE;
nEmergencyStatus : BYTE;
bBusy            : BOOL;
bError           : BOOL;
nErrorId         : UDINT;

tElapsedTestTime: Testdauer. Bei steigender Flanke an bStart wird die Zeitausgabe auf 0 gesetzt und läuft dann solange hoch, wie der Baustein aktiv ist. Mit einer fallenden Flanke an bBusy behält der Ausgang seinen derzeitigen Wert, sodass auch nach der Bausteinabarbeitung die Testdauer noch zur Verfügung steht.

nEmergencyMode: Während des Tests wird an diesem Ausgang der derzeit intern abgefragte Emergency-Mode des DALI-Gerätes ausgegeben.

nEmergencyStatus: dto. für Emergency-Status.

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung des Tests ein Fehler, wie oben beschrieben, aufgetreten ist. Durch das erneute Ausführen eines Tests wird dieser Ausgang zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines neuen Tests auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer    : ST_DALIV2CommandBuffer;
fbStringRingBuffer : FB_MemRingBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

fbStringRingBuffer: Verweis auf den FIFO-Buffer, in denen die Log-Einträge abgelegt werden.

Ein Beispielprogramm zeigt die richtige Belegung der Eingänge sowie die Verknüpfung zum Logger-Baustein FB_DALIV2FileLogging(). Dabei werden 3 Vorschaltgeräte und dessen Lampen jeweils am 8. jeden Monats getestet.

Die Log-Datei würde dann für die 3 adressierten Geräte beispielsweise folgendes anzeigen:

Am 8. Juli sind noch keine der Vorschaltgeräte eingebaut, was zu DALI-Kommando-Fehlern bei allen Geräten führt.
Am 8. August ist immerhin schon die erste Lampe angeschlossen, nur die Batterie ist noch nicht voll geladen.
Am 8. September schließlich sind alle Geräte betriebsbereit und haben ihren ersten Dauertest erfolgreich abgeschlossen.

Es ist zu beachten, daß beim Öffnen der Datei ggf. die Spaltenbreite zur Sichtbarkeit der Daten erweitert werden muß.

Hinweis: Während eine Datei geöffnet ist, ist es dem Log-Baustein nicht möglich, Daten in diese Datei zu schreiben!


FB_DALIV2EmergencyLightingFT

Dieser Baustein dient zur Funktions-Prüfung (Function-Test) eines DALI-Notbeleuchtungs-Gerätes. Die Testergebnisse werden zum Test-Ende über einen FIFO-Buffer (IN-OUT-Variable fbStringRingBuffer) geschrieben,, welcher seinerseits durch den Baustein FB_DALIV2FileLogging() in eine Datei ausgelesen wird. Ereignisse, die den Test verhindern oder unterbrechen werden zusätzlich zur Ergebnis-Meldung an den Ausgängen bError und nErrorID angezeigt.

Folgende Ereignisse verhindern die Ausführung eines Funktionstest:

  • Das Gerät läuft im automatischen Funktionstest-Modus, d.h. ein Testintevall ist im Gerät programmiert.
  • Das Gerät führt gerade einen Test aus bzw. ein Test steht automatisch bevor (Funktionstest oder Dauertest)
  • Das Gerät befindet sich zu Testbeginn nicht in der Notfall-Bereitschaft ("normal-mode")

Zu den Ereignissen, die einen begonnenen Funktionstest unterbrechen gehören diese:

  • Das Gerät hat nach dem Teststart den Funktionstest-Modus nicht erreicht
  • Der Test ist nicht richtig beendet worden, d.h. das Gerät befindet sich nach dem Teststart und einer gewissen Wartezeit irgendwann weder im Test-Modus noch (wieder zurück) im Notfall-Bereitschafts-Modus ("normal-mode")
  • Ein DALI-Kommando wurde fehlerhaft abgearbeitet
  • Die Timeout-Zeit ist abgelaufen

Hinweis: Dieser Baustein ist nur in der PC-Version der DALIV2-Bibliothek verfügbar.

VAR_INPUT

bStart           : BOOL;
nAddr            : BYTE;
sController      : STRING(20);
sLineName        : STRING(10);
sDescription     : STRING(20);
sLocation        : STRING(20);
stDateTime       : TIMESTRUCT;
tTimeout         : TIME := t#120m;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse des zu testenden Gerätes.

sController: Controller-Zugehörigkeit des DALI-Gerätes. Dient zur Beschreibung in der Log-Datei.

sLineName: Linien-Zugehörigkeit des DALI-Gerätes. Dient zur Beschreibung in der Log-Datei.

sDescription: Weitere ergänzende Beschreibung des Gerätes in der Log-Datei.

sLocation: Beschreibung des Einbauortes.

stDateTime: Eingang für aktuelles Datum und Zeit.

tTimeout: Zeit in der der Test abgeschlossen sein muss.

VAR_OUTPUT

tElapsedTestTime : TIME;
nEmergencyMode   : BYTE;
nEmergencyStatus : BYTE;
bBusy            : BOOL;
bError           : BOOL;
nErrorId         : UDINT;

tElapsedTestTime: Testdauer. Bei steigender Flanke an bStart wird die Zeitausgabe auf 0 gesetzt und läuft dann solange hoch, wie der Baustein aktiv ist. Mit einer fallenden Flanke an bBusy behält der Ausgang seinen derzeitigen Wert, sodass auch nach der Bausteinabarbeitung die Testdauer noch zur Verfügung steht.

nEmergencyMode: Während des Tests wird an diesem Ausgang der derzeit intern abgefragte Emergency-Mode des DALI-Gerätes ausgegeben.

nEmergencyStatus: dto. für Emergency-Status.

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung des Tests ein Fehler, wie oben beschrieben, aufgetreten ist. Durch das erneute Ausführen eines Tests wird dieser Ausgang zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines neuen Tests auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer    : ST_DALIV2CommandBuffer;
fbStringRingBuffer : FB_MemRingBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

fbStringRingBuffer: Verweis auf den FIFO-Buffer, in denen die Log-Einträge abgelegt werden.

Ein Beispielprogramm zeigt die richtige Belegung der Eingänge sowie die Verknüpfung zum Logger-Baustein FB_DALIV2FileLogging(). Dabei werden 3 Vorschaltgeräte und dessen Lampen jeweils immer am Dienstag getestet.

Die Log-Datei würde dann für die 3 adressierten Geräte beispielsweise folgendes anzeigen:

Am 25. August sind noch keine der Vorschaltgeräte eingebaut, was zu DALI-Kommando-Fehlern bei allen Geräten führt.
Am 1. September ist immerhin schon die erste Lampe angeschlossen, jedoch ist der automatische Test im Vorschaltgerät noch aktiviert, was zu einem Testabbruch führt.
Am 8. September schließlich sind alle Geräte betriebsbereit und haben ihren ersten Funktionstest erfolgreich abgeschlossen.

Es ist zu beachten, daß beim Öffnen der Datei ggf. die Spaltenbreite zur Sichtbarkeit der Daten erweitert werden muß.

Hinweis: Während eine Datei geöffnet ist, ist es dem Log-Baustein nicht möglich, Daten in diese Datei zu schreiben!


FB_DALIV2FileLogging

Dieser Baustein liest die in Bausteinen FB_DALIV2EmergencyLightingFT() und FB_DALIV2EmergencyLightingDT() jeweils beschriebenen FIFO-Puffer (IN-OUT-Variable fbStringRingBuffer) aus und schreibt die Inhalte in eine Log-Datei.

Hinweis: Dieser Baustein ist nur in der PC-Version der DALIV2-Bibliothek verfügbar.

VAR_INPUT

bStart           : BOOL;
sPathName        : STRING;
sNetId           : STRING;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

sPathName: Enthält den Pfad- und Dateinamen der zu öffnenden Pufferdatei. Hinweis: Der Pfad kann nur auf das lokale File System des Rechners zeigen! Das bedeutet, Netzwerkpfade können hier nicht angegeben werden!

sNetId: Hier kann ein String mit der Netzwerkadresse des TwinCAT-Rechners angegeben werden, auf dem die Pufferdatei geschrieben/gelesen werden soll. Für den lokalen Rechner kann auch ein Leerstring angegeben werden.

VAR_OUTPUT

bBusy            : BOOL;
bError           : BOOL;
nErrorId         : UDINT;

bBusy: Bei der Aktivierung des Funktionsbausteins wird dieser Ausgang gesetzt und bleibt gesetzt, bis der Log-Puffer geleert ist.

bError: Sollte ein ADS-Fehler bei der Übertragung in die Log-Datei erfolgen, dann wird dieser Ausgang gesetzt, nachdem der bBusy-Ausgang zurückgesetzt wurde.

nErrId: Liefert bei einem gesetzten bError-Ausgang die ADS-Fehlernummer oder den Befehlsspezifischen Fehlercode (Tabelle).

VAR_IN_OUT

fbStringRingBuffer : FB_MemRingBuffer;

fbStringRingBuffer: Verweis auf den FIFO-Buffer, in denen die Log-Einträge abgelegt werden.

Ein Beispielprogramm zeigt die richtige Belegung der Eingänge sowie die Verknüpfung zum Logger-Baustein FB_DALIV2FileLogging. Das Erscheinungsbild der jeweiligen Log-Datei ist unter den Funktionsbausteinen FB_DALIV2EmergencyLightingDT() und FB_DALIV2EmergencyLightingFT() dargestellt


FB_DALIV2GetSettingsType01

Dieser Baustein liest von allen Notbeleuchtungs-Vorschaltgeräten einer DALI-Line die Variablen (BATTERY CHARGE, DURATION TEST RESULT, LAMP EMERGENCY TIME ...) aus, und speichert diese in einer Struktur vom Typ ST_DALIV2DeviceSettingsType01.

Durch eine positive Flanke an dem Eingang bStart wird der Baustein gestartet und der Ausgang bBusy geht auf TRUE. Zunächst wird geprüft, ob ein Vorschaltgerät überhaupt vorhanden ist. Ist dies der Fall, so wird in der jeweiligen Struktur (siehe ST_DALIV2DeviceSettingsType01) das Bit bPresent gesetzt und anschließend nacheinander die Einstellungen des Vorschaltgerätes ausgelesen und in die betreffenden Variablen der Struktur geschrieben. Wird ein Gerät als nicht vorhanden erkannt, so wird das Auslesen übersprungen und mit dem nächsten Gerät begonnen. Der Index der Struktur spiegelt dabei die Adresse des Gerätes wider, d.h. vom Gerät mit der Kurzadresse 0 liegen die Daten in arrDALIDeviceSettingsType01[0] bis hin zu dem Gerät mit der Kurzadresse 63 in arrDALIDeviceSettingsType01[63]. Tritt während des Auslesevorganges ein Lesefehler bei einem Gerät auf, so wird das entsprechende Bit in nErrors der jeweiligen Struktur gesetzt, ohne dass jedoch der Funktionsbaustein an sich in Störung geht. In der folgenden Tabelle wird aufgelistet, welches Bit in der Variablen nErrors gesetzt wird, wenn beim Auslesen einer Variablen aus einem Vorschaltgerät ein Fehler aufgetreten ist:

Bit | Fehler
0 | Bei dem Versuch das Vorschaltgerät zu suchen, ist ein Fehler aufgetreten.
1 | Fehler beim Auslesen der Variable BATTERY CHARGE
2 | Fehler beim Auslesen der Variable DURATION TEST RESULT
3 | Fehler beim Auslesen der Variable LAMP EMERGENCY TIME
4 | Fehler beim Auslesen der Variable LAMP TOTAL OPERATION TIME
5 | Fehler beim Auslesen der Variable EMERGENCY LEVEL
6 | Fehler beim Auslesen der Variable EMERGENCY MIN LEVEL
7 | Fehler beim Auslesen der Variable EMERGENCY MAX LEVEL
8 | Fehler beim Auslesen der Variable RATED DURATION
9 | Fehler beim Auslesen der Variable FUNCTION TEST DELAY TIME
10 | Fehler beim Auslesen der Variable DURATION TEST DELAY TIME
11 | Fehler beim Auslesen der Variable FUNCTION TEST INTERVAL
12 | Fehler beim Auslesen der Variable DURATION TEST INTERVAL
13 | Fehler beim Auslesen der Variable TEST EXECUTION TIMEOUT
14 | Fehler beim Auslesen der Variable PROLONG TIME
15 | Fehler beim Auslesen der Variable EMERGENCY MODE
16 | Fehler beim Auslesen der Variable FEATURES
17 | Fehler beim Auslesen der Variable FAILURE STATUS
18 | Fehler beim Auslesen der Variable EMERGENCY STATUS

Nach Abarbeitung des Bausteines wechselt der Ausgang bBusy von TRUE nach FALSE. Abhängig davon, wie viele Vorschaltgeräte angeschlossen sind, kann die Abarbeitung dieses Bausteines mehrere Sekunden dauern.

VAR_INPUT

bStart              : BOOL;
bCancel             : BOOL;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityHigh;
nOptions            : DWORD;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

bCancel: Über eine positive Flanke an diesem Eingang wird der Baustein deaktiviert und somit das Auslesen der Variablen abgebrochen.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nOptions: Optionen für das Auslesen der Variablen (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_BATTERY_CHARGE | Die Variable BATTERY CHARGE wird ausgelesen.
DALIV2_OPTION_DURATION_TEST_RESULT | Die Variable DURATION TEST RESULT wird ausgelesen.
DALIV2_OPTION_LAMP_EMERGENCY_TIME | Die Variable LAMP EMERGENCY TIME wird ausgelesen.
DALIV2_OPTION_LAMP_TOTAL_OPERATION_TIME | Die Variable LAMP TOTAL OPERATION TIME wird ausgelesen.
DALIV2_OPTION_EMERGENCY_LEVEL | Die Variable EMERGENCY LEVEL wird ausgelesen.
DALIV2_OPTION_EMERGENCY_MIN_LEVEL | Die Variable EMERGENCY MIN LEVEL wird ausgelesen.
DALIV2_OPTION_EMERGENCY_MAX_LEVEL | Die Variable EMERGENCY MAX LEVEL wird ausgelesen.
DALIV2_OPTION_RATED_DURATION | Die Variable RATED DURATION wird ausgelesen.
DALIV2_OPTION_NEXT_FUNCTION_TEST | Die Variable FUNCTION TEST DELAY TIME wird ausgelesen.
DALIV2_OPTION_NEXT_DURATION_TEST | Die Variable DURATION TEST DELAY TIME wird ausgelesen.
DALIV2_OPTION_FUNCTION_TEST_INTERVAL | Die Variable FUNCTION TEST INTERVAL wird ausgelesen.
DALIV2_OPTION_DURATION_TEST_INTERVAL | Die Variable DURATION TEST INTERVAL wird ausgelesen.
DALIV2_OPTION_TEST_EXECUTION_TIMEOUT | Die Variable TEST EXECUTION TIMEOUT wird ausgelesen.
DALIV2_OPTION_PROLONG_TIME | Die Variable PROLONG TIME wird ausgelesen.
DALIV2_OPTION_EMERGENCY_MODE | Die Variable EMERGENCY MODE wird ausgelesen.
DALIV2_OPTION_FEATURES | Die Variable FEATURES wird ausgelesen.
DALIV2_OPTION_FAILURE_STATUS | Die Variable FAILURE STATUS wird ausgelesen.
DALIV2_OPTION_EMERGENCY_STATUS | Die Variable EMERGENCY STATUS wird ausgelesen.
DALIV2_OPTION_ALL | Alle Variablen werden ausgelesen.

VAR_OUTPUT

bBusy             : BOOL;
bError            : BOOL;
nErrorId          : UDINT;
nCurrentShortAddr : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nCurrentShortAddr: Kurzadresse vom aktuellen Vorschaltgerät von dem gerade versucht wird die Variablen auszulesen.

VAR_IN_OUT

stCommandBuffer             : ST_DALIV2CommandBuffer;
arrDALIDeviceSettingsType01 : ARRAY [0..63] OF ST_DALIV2DeviceSettingsType01;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

arrDALIDeviceSettingsType01: Verweis auf ein Array mit 64 Elementen vom Typ ST_DALIV2DeviceSettingsType01. In dieser Variablen werden die Einstellungen von jedem einzelnen DALI-Vorschaltgerät abgelegt.


FB_DALIV2SetSettingsType01

Dieser Baustein initialisiert die Variablen (EMERGENCY LEVEL, FUNCTION TEST DELAY TIME, DURATION TEST DELAY TIME ...) aller Notbeleuchtungs-Vorschaltgeräten einer DALI-Line mit den Werten, die in einer Struktur vom Typ ST_DALIV2DeviceSettingsType01 abgelegt sind.

Durch eine positive Flanke an dem Eingang bStart wird der Baustein gestartet und der Ausgang bBusy geht auf TRUE. Zunächst wird geprüft, ob in der jeweiligen Struktur (siehe ST_DALIV2DeviceSettingsType01) das Bit bPresent gesetzt ist. Ist dieses der Fall, so werden alle Variablen vom Vorschaltgerät, die nicht schreibgeschützt sind, mit den jeweiligen Werten der Struktur initialisiert. Der Index der Struktur spiegelt dabei die Adresse des Vorschaltgerätes wider, d.h. vom Gerät mit der Kurzadresse 0 liegen die Daten in arrDALIDeviceSettingsType01[0] bis hin zu dem Vorschaltgerät mit der Kurzadresse 63 in arrDALIDeviceSettingsType01[63]. Tritt während des Schreibvorganges ein Fehler bei einem Gerät auf, so wird das Element nErrors der jeweiligen Struktur gesetzt, ohne dass jedoch der Funktionsbaustein an sich in Störung geht. In der folgenden Tabelle wird aufgelistet, welches Bit in der Variablen nErrors gesetzt wird, wenn beim Schreiben einer Variablen in einem Vorschaltgerät ein Fehler aufgetreten ist:

Bit | Fehler
5 | Fehler beim Schreiben der Variable EMERGENCY LEVEL
9 | Fehler beim Schreiben der Variable FUNCTION TEST DELAY TIME
10 | Fehler beim Schreiben der Variable DURATION TEST DELAY TIME
11 | Fehler beim Schreiben der Variable FUNCTION TEST INTERVAL
12 | Fehler beim Schreiben der Variable DURATION TEST INTERVAL
13 | Fehler beim Schreiben der Variable TEST EXECUTION TIMEOUT
14 | Fehler beim Schreiben der Variable PROLONG TIME

Nach Abarbeitung des Bausteines wechselt der Ausgang bBusy von TRUE nach FALSE. Abhängig davon, wie viele Vorschaltgeräte angeschlossen sind, kann die Abarbeitung dieses Bausteines mehrere Sekunden dauern.

VAR_INPUT

bStart              : BOOL;
bCancel             : BOOL;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityHigh;
nOptions            : DWORD;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

bCancel: Über eine positive Flanke an diesem Eingang wird der Baustein deaktiviert und somit das Auslesen der Variablen abgebrochen.

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nOptions: Optionen für das Auslesen der Variablen (siehe Tabelle). Die einzelnen Konstanten müssen miteinander ODER verknüpft werden.

Konstante | Beschreibung
DALIV2_OPTION_EMERGENCY_LEVEL | Die Variable EMERGENCY LEVEL wird initialisiert.
DALIV2_OPTION_NEXT_FUNCTION_TEST | Die Variable FUNCTION TEST DELAY TIME wird initialisiert.
DALIV2_OPTION_NEXT_DURATION_TEST | Die Variable DURATION TEST DELAY TIME wird initialisiert.
DALIV2_OPTION_FUNCTION_TEST_INTERVAL | Die Variable FUNCTION TEST INTERVAL wird initialisiert.
DALIV2_OPTION_DURATION_TEST_INTERVAL | Die Variable DURATION TEST INTERVAL wird initialisiert.
DALIV2_OPTION_TEST_EXECUTION_TIMEOUT | Die Variable TEST EXECUTION TIMEOUT wird initialisiert.
DALIV2_OPTION_PROLONG_TIME | Die Variable PROLONG TIME wird initialisiert.
DALIV2_OPTION_ALL | Alle Variablen werden initialisiert.
DALIV2_OPTION_PUSH_DALI_COMMANDS | Der Puffer, der die Rückmeldungen von den Vorschaltgeräten enthält, wird nicht ausgelesen. Dadurch wird das Schreiben schneller, Fehler jedoch nicht erkannt.

VAR_OUTPUT

bBusy                : BOOL;
bError               : BOOL;
nErrorId             : UDINT;
nCurrentShortAddr    : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nCurrentShortAddr: Kurzadresse vom aktuellen Vorschaltgerät bei dem gerade versucht wird, die Variablen zu initialisieren.

VAR_IN_OUT

stCommandBuffer                  : ST_DALIV2CommandBuffer;
arrDALIDeviceSettingsType01      : ARRAY [0..63] OF ST_DALIV2DeviceSettingsType01;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

arrDALIDeviceSettingsType01: Verweis auf ein Array mit 64 Elementen vom Typ ST_DALIV2DeviceSettingsType01. In dieser Variablen werden die Einstellungen von jedem einzelnen DALI-Vorschaltgerät abgelegt.


Entladungslampen - Einführung

Im Folgenden werden die Funktionsbausteine und Variablen für Entladungslampen mit DALI-Schnittstelle beschrieben. Alle folgenden Funktionsbausteine rufen 'anwendungsbezogene Erweiterungsbefehle' auf. Laut DALI-Normung (IEC 62386) liegen diese Befehle im Bereich 224 bis 255. Da es verschiedene anwendungsbezogene Erweiterungsbefehle gibt, muss mit dem Funktionsbaustein FB_DALIV2EnableDeviceType() festgelegt werden, welche Art von Vorschaltgeräten (Notbeleuchtung, Entladungslampen, ...) auf die Erweiterungsbefehle reagieren sollen. Eine genaue Beschreibung der einzelnen DALI-Kommandos und der Variablen für Entladungslampen mit DALI-Schnittstelle finden sie in der Norm IEC 62386 Part 203.


Entladungslampen - Variablen

Jedes DALI-Vorschaltgerät für Entladungslampen besitzt eine bestimmte Anzahl von Variablen (Parameter), aus denen verschiedene Informationen ausgelesen, oder auch einzelne Parameter verändert werden können.

Name | Vorgabewert | Rücksetzwert | Gültigkeitsbereich | Größe | Bemerkung
HID STATUS | 0 | 0 | 0 ... 255 | 1 Byte |
ACTUAL HID FAILURE | ???? ???? | keine Änderung | 0 ... 255 | 1 Byte |
STORED HID FAILURE | ???? ???? | keine Änderung | 0 ... 255 | 1 Byte |
HID FEATURES | Hersteller abhängig | keine Änderung | 0 ... 255 | 1 Byte | nur Lesen
THERMAL OVERLOAD TIME | 0 | keine Änderung | 00 00 ... FF FF | 2 Byte |
THERMAL LOAD | ???? ???? | keine Änderung | 0 ... 255 | 1 Byte |
EXTENDED VERSION NUMBER | 1 | keine Änderung | 0 ... 255 | 1 Byte | nur Lesen

?: unbestimmt

HID STATUS

In HID STATUS wird der aktuelle Zustand vom Vorschaltgerät abgelegt. Mit dem Baustein FB_DALIV2QueryHIDStatus() kann der Wert ausgelesen werden.

Bit | Beschreibung
0 | Anlaufzeit betriebsbereit. 0: Nein.
1 | Der Lampenleistungswert hat seinen angeforderten Sollwert erreicht. 0: Nein.
2 | Vorschaltgerät wartet auf das Zünden der Lampe. 0: Nein.
3 | reserve
4 | reserve
5 | reserve
6 | Identifikation aktiv. 0: Nein.
7 | reserve

ACTUAL HID FAILURE

In dieser Variablen stehen alle Informationen über den Fehlerzustand vom Vorschaltgerät. Ausgelesen wird die Variable mit dem Baustein FB_DALIV2QueryActualHIDFailure(). Die jeweiligen Bits werden gesetzt sobald ein Fehler auftritt und automatisch wieder zurückgesetzt sobald der Fehler wieder zurückgegangen ist.
Solange Bit 4 oder Bit 7 gesetzt sind, ist auch das Bit 1 in der Variablen STATUS INFORMATION gesetzt. Der Baustein FB_DALIV2QueryLampeFailure() liefert in diesem Fall am Ausgang bLampFailure ein TRUE.

Bit | Beschreibung
0 | Versorgungsspannung zu niedrig. 0: Nein.
1 | Versorgungsspannung zu hoch. 0: Nein.
2 | Übertemperatur am Umformer. 0: Nein.
3 | reserve
4 | Zeitüberschreitung beim Zünden der Lampe. 0: Nein.
5 | reserve
6 | Lampenspannung außerhalb der Spezifikation. 0: Nein.
7 | Lampenzyklusfehler. 0: Nein.

STORED HID FAILURE

In dieser Variablen stehen alle Informationen über den Fehlerzustand vom Vorschaltgerät. Ausgelesen wird die Variable mit dem Baustein FB_DALIV2QueryStoredHIDFailure(). Zurückgesetzt werden die Fehlermeldungen durch Ausschalten vom Vorschaltgerät oder durch den Baustein FB_DALIV2ResetStoredHIDFailure().

Bit | Beschreibung
0 | Versorgungsspannung zu niedrig. 0: Nein.
1 | Versorgungsspannung zu hoch. 0: Nein.
2 | Übertemperatur am Umformer. 0: Nein.
3 | reserve
4 | Zeitüberschreitung beim Zünden der Lampe. 0: Nein.
5 | reserve
6 | Lampenspannung außerhalb der Spezifikation. 0: Nein.
7 | Lampenzyklusfehler. 0: Nein.

HID FEATURES

Die unterstützten Leistungsmerkmale des Vorschaltgerätes können mit dem Baustein FB_DALIV2QueryHIDFeatures() aus dieser Variablen ausgelesen werden. Der Inhalt dieser Variablen wird vom Hersteller des Vorschaltgerätes fest vorgegeben und kann nicht geändert werden.

Bit | Beschreibung
0 | 'Versorgungsspannung zu niedrig' kann abgefragt werden. 0: Nein.
1 | 'Versorgungsspannung zu hoch' kann abgefragt werden. 0: Nein.
2 | 'Übertemperatur am Umformer' kann abgefragt werden. 0: Nein.
3 | reserve
4 | reserve
5 | reserve
6 | 'Lampenspannung außerhalb der Spezifikation' kann abgefragt werden. 0: Nein.
7 | Physikalische Auswahl wird unterstützt. 0: Nein.

THERMAL OVERLOAD TIME

Sobald Übertemperatur erkannt wird, wird die Variable THERMAL OVERLOAD TIME in 15-Minuten-Schritten erhöht. Diese Variable kann nicht zurückgesetzt werden. Ein werden von 65535 (0xFFFF) entspricht hierbei einer Zeit von 16.383 Stunden und 45 Minuten oder höher. Mit den Bausteinen FB_DALIV2QueryThermalOverloadTimeHB() und FB_DALIV2QueryThermalOverloadTimeLB() kann die Variable THERMAL OVERLOAD TIME ausgelesen werden.
Der Schwellwert für die Erkennung der Übertemperatur wird durch die Variable THERMAL LOAD festgelegt (siehe unten).

THERMAL LOAD

In der Variablen THERMAL LOAD wird ein Prozentwert im Bereich von 0% bis 127,5% in 0,5%-Schritten definiert. Somit entspricht 255 einen Wert von 127,5%. Ausgelesen werden kann die Variable mit dem Baustein FB_DALIV2QueryThermalLoad().

EXTENDED VERSION NUMBER

Die erweiterte Versionsnummer kann mit dem Baustein FB_QueryV2ExtendedVersionNumber() ausgelesen werden. Die Versionsnummer kann nur gelesen werden und wird vom Hersteller der Vorschaltgeräte vorgegeben.


Entladungslampen - Funktionsbausteine

Name | Beschreibung
FB_DALIV2QueryActualHIDFailure | Die Variable ACTUAL HID FAILURE (aktueller Fehlerzustand) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryHIDFeatures | Die Variable HID FEATURES (Leistungsmerkmale) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryHIDStatus | Die Variable HID STATUS (Zustand) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryStoredHIDFailure | Die Variable STORED HID FAILURE (gespeicherter Fehlerzustand) wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryThermalLoad | Die Variable THERMAL LOAD wird ausgelesen.
FB_DALIV2QueryThermalOverloadTime | Die 16-Bit-Variable THERMAL OVERLOAD TIME wird ausgelesen.
FB_DALIV2QueryThermalOverloadTimeHB | Das höherwertige Byte der 16-Bit-Variable THERMAL OVERLOAD TIME wird ausgelesen.
FB_DALIV2QueryThermalOverloadTimeLB | Das niederwertige Byte der 16-Bit-Variable THERMAL OVERLOAD TIME wird ausgelesen.
FB_DALIV2ResetStoredHIDFailure | Die Variable STORED HID FAILURE (gespeicherte Lampenstörungen) wird zurückgesetzt.

Hinweis: Diese Befehle gehören zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.


FB_DALIV2QueryActualHIDFailure

Die Variable ACTUAL HID FAILURE (aktueller Fehlerzustand) wird aus dem Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | Versorgungsspannung zu niedrig. 0: Nein.
1 | Versorgungsspannung zu hoch. 0: Nein.
2 | Übertemperatur am Umformer. 0: Nein.
3 | reserve
4 | Zeitüberschreitung beim Zünden der Lampe. 0: Nein.
5 | reserve
6 | Lampenspannung außerhalb der Spezifikation. 0: Nein.
7 | Lampenzyklusfehler. 0: Nein.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy             : BOOL;
bError            : BOOL;
nErrorId          : UDINT;
nActualHIDFailure : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nActualHIDFailure: Inhalt der Variablen ACTUAL HID FAILURE.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryHIDFeatures

Die Variable HID FEATURES (Leistungsmerkmale) wird aus dem Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | 'Versorgungsspannung zu niedrig' kann abgefragt werden. 0: Nein.
1 | 'Versorgungsspannung zu hoch' kann abgefragt werden. 0: Nein.
2 | 'Übertemperatur am Umformer' kann abgefragt werden. 0: Nein.
3 | Reserve
4 | Reserve
5 | Reserve
6 | 'Lampenspannung außerhalb der Spezifikation' kann abgefragt werden. 0: Nein.
7 | Physikalische Auswahl wird unterstützt. 0: Nein.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;
nHIDFeatures : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nHIDFeatures: Inhalt der Variable HID FEATURES.

VAR_IN_OUT

stCommandBuffer   : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryHIDStatus

Die Variable HID STATUS (Zustand) wird aus dem Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | Anlaufzeit betriebsbereit. 0: Nein.
1 | Der Lampenleistungswert hat seinen angeforderten Sollwert erreicht. 0: Nein.
2 | Vorschaltgerät wartet auf das Zünden der Lampe. 0: Nein.
3 | Reserve
4 | Reserve
5 | Reserve
6 | Identifikation aktiv. 0: Nein.
7 | Reserve

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy      : BOOL;
bError     : BOOL;
nErrorId   : UDINT;
nHIDStatus : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nHIDStatus: Inhalt der Variable HID STATUS.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryStoredHIDFailure

Die Variable STORED HID FAILURE (gespeicherter Fehlerzustand) wird aus dem Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | Versorgungsspannung zu niedrig. 0: Nein.
1 | Versorgungsspannung zu hoch. 0: Nein.
2 | Übertemperatur am Umformer. 0: Nein.
3 | ´Reserve
4 | Zeitüberschreitung beim Zünden der Lampe. 0: Nein.
5 | Reserve
6 | Lampenspannung außerhalb der Spezifikation. 0: Nein.
7 | Lampenzyklusfehler. 0: Nein.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy             : BOOL;
bError            : BOOL;
nErrorId          : UDINT;
nStoredHIDFailure : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nStoredHIDFailure: Inhalt der Variable STORED HID FAILURE.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryThermalLoad

Die Variable THERMAL LOAD wird ausgelesen. Diese beinhaltet einen Prozentwert im Bereich von 0% bis 127,5% in 0,5%-Schritten.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;
nThermalLoad : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nThermalLoad: Inhalt der Variable THERMAL LOAD.

VAR_IN_OUT

stCommandBuffer  : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryThermalOverloadTime

Die 16-Bit-Variable THERMAL OVERLOAD TIME wird ausgelesen.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.

VAR_INPUT

bStart             : BOOL;
nAddr              : BYTE;
eAddrType          : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority   : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy                  : BOOL;
bError                 : BOOL;
nErrorId               : UDINT;
nThermalOverloadTime   : WORD;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nThermalOverloadTime: Der Wert der 16-Bit-Variable THERMAL OVERLOAD TIME.

VAR_IN_OUT

stCommandBuffer    : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryThermalOverloadTimeHB

Das höherwertige Byte der 16-Bit-Variable THERMAL OVERLOAD TIME wird ausgelesen.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy                  : BOOL;
bError                 : BOOL;
nErrorId               : UDINT;
nThermalOverloadTimeHB : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nThermalOverloadTimeHB: Das höherwertige Byte der Variable THERMAL OVERLOAD TIME.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2QueryThermalOverloadTimeLB

Das niederwertige Byte der 16-Bit-Variable THERMAL OVERLOAD TIME wird ausgelesen.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy                  : BOOL;
bError                 : BOOL;
nErrorId               : UDINT;
nThermalOverloadTimeLB : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nThermalOverloadTimeLB: Das niederwertige Byte der Variable THERMAL OVERLOAD TIME.

VAR_IN_OUT

stCommandBuffer  : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2ResetStoredHIDFailure

Die Variable STORED HID FAILURE (gespeicherte Lampenstörungen) wird zurückgesetzt.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy    : BOOL;
bError   : BOOL;
nErrorId : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


Farb-/Farbtemperatursteuerung - Einführung

Im Folgenden werden die Funktionsbausteine und Variablen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle beschrieben. Alle folgenden Funktionsbausteine rufen 'anwendungsbezogene Erweiterungsbefehle' auf. Laut DALI-Normung (IEC 62386) liegen diese Befehle im Bereich 224 bis 255. Da es verschiedene anwendungsbezogene Erweiterungsbefehle gibt, muss mit dem Funktionsbaustein FB_DALIV2EnableDeviceType() festgelegt werden, welche Art von Vorschaltgeräten (Notbeleuchtung, Entladungslampen, ...) auf die Erweiterungsbefehle reagieren sollen. Eine genaue Beschreibung der einzelnen DALI-Kommandos und der Variablen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle finden Sie in der Norm IEC 62386 Part 209.


Farb-/Farbtemperatursteuerung - Variablen

Jedes DALI-Vorschaltgerät für Farb-/Farbtemperatursteuerung besitzt eine bestimmte Anzahl von Variablen (Parameter), aus denen verschiedene Informationen ausgelesen, oder auch einzelne Parameter verändert werden können.

Einige Variablen können direkt über DALI-Befehle ausgelesen werden (z.B. FB_QueryColourStatus() oder FB_QueryRGBWAFControl()). Der Baustein FB_QueryColourValue() kann dazu genutzt weitere Variablen auszulesen.

Name | Vorgabewert | Rücksetzwert | Gültigkeitsbereich | Größe | notwendige Farbdarstellung (1) | Bemerkung
TEMPORARY x-COORDINATE | 65535 | 65535 | 0 ...65535 | 2 Bytes | 0, 2 |
REPORT x-COORDINATE | 65535 | 65535 | 0 ... 65535 | 2 Bytes | 0 |
x-COORDINATE | ? | keine Änderung | 0 ... 65535 | 2 Bytes | 0 |
TEMPORARY x-COORDINATE | 65535 | 65535 | 0 ... 65535 | 2 Bytes | 0, 2 |
REPORT x-COORDINATE | 65535 | 65535 | 0 ... 65535 | 2 Bytes | 0 |
x-COORDINATE | ? | keine Änderung | 0 ... 65535 | 2 Bytes | 0 |
TEMPORARY COLOUR TEMPERATURE Tc | 65535 | 65535 | 1 ... 65535 | 2 Bytes | 1 |
REPORT COLOUR TEMPERATURE Tc | 65535 | 65535 | 1 ... 65535 | 2 Bytes | 1 |
COLOUR TEMPERATURE Tc | ? | keine Änderung | 1 ... 65535 | 2 Bytes | 1 |
COLOUR TEMPERATURE Tc COOLEST | ? | COLOUR TEMPERATURE Tc PHYSICAL COOLEST | COLOUR TEMPERATURE Tc PHYSICAL COOLEST ... COLOUR TEMPERATURE Tc WARMEST, 65535 | 2 Bytes | 1 | nur Lesen
COLOUR TEMPERATURE Tc WARMEST | ? | COLOUR TEMPERATURE Tc PHYSICAL WARMEST | COLOUR TEMPERATURE Tc COOLEST ... COLOUR TEMPERATURE Tc PHYSICAL WARMEST, 65535 | 2 Bytes | 1 | nur Lesen
COLOUR TEMPERATURE Tc PHYSICAL COOLEST | ? | keine Änderung | 1 - COLOUR TEMPERATURE Tc PHYSICAL WARMEST, 65535 | 2 Bytes | 1 | nur Lesen
COLOUR TEMPERATURE Tc PHYSICAL WARMEST | ? | keine Änderung | COLOUR TEMPERATURE Tc PHYSICAL COOLEST - 65534, 65535 | 2 Bytes | 1 | nur Lesen
TEMPORARY PRIMARY N DIMLEVEL | 65535 | 65535 | 0 ... 65535 | bis zu 12 Bytes | 2 |
REPORT PRIMARY N DIMLEVEL | 65535 | 65535 | 0 ... 65535 | bis zu 12 Bytes | 2 |
PRIMARY N DIMLEVEL | ? | keine Änderung | 0 ... 65535 | bis zu 12 Bytes | 2 |
x-COORDINATE PRIMARY N | ? | keine Änderung | 0 ... 65535 | bis zu 12 Bytes | 0, 2 | nur Lesen
y-COORDINATE PRIMARY N | ? | keine Änderung | 0 ... 65535 | bis zu 12 Bytes | 0, 2 | nur Lesen
TY PRIMARY N | ? | keine Änderung | 0 ... 65535 | bis zu 12 Bytes | 0, 2 | nur Lesen
TEMPORARY RED DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
REPORT RED DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
RED DIMLEVEL | ? | keine Änderung | 0 ... 255 | 1 Byte | 3 |
TEMPORARY GREEN DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
REPORT GREEN DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
GREEN DIMLEVEL | ? | keine Änderung | 0 ... 255 | 1 Byte | 3 |
TEMPORARY BLUE DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
REPORT BLUE DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
BLUE DIMLEVEL | ? | keine Änderung | 0 ... 255 | 1 Byte | 3 |
TEMPORARY WHITE DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
REPORT WHITE DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
WHITE DIMLEVEL | ? | keine Änderung | 0 ... 255 | 1 Byte | 3 |
TEMPORARY AMBER DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
REPORT AMBER DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
AMBER DIMLEVEL | ? | keine Änderung | 0 ... 255 | 1 Byte | 3 |
TEMPORARY FREECOLOUR DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
REPORT FREECOLOUR DIMLEVEL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
FREECOLOUR DIMLEVEL | ? | keine Änderung | 0 ... 255 | 1 Byte | 3 |
TEMPORARY RGBWAF CONTROL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
REPORT RGBWAF CONTROL | 255 | 255 | 0 ... 255 | 1 Byte | 3 |
RGBWAF CONTROL | 63 | keine Änderung | 0 ... 255 | 1 Byte | 3 |
ASSIGNED COLOUR | 0x0102 0304 0506 | 0x0102 0304 0506 | 0x0000 0000 0000 ... 0x0606 0606 0606 | 6 Bytes | 3 | nur Lesen MSB: Kanal 0 LSB: Kanal 5
TEMPORARY COLOUR TYPE | 255 | 255 | 0x10, 0x20, 0x40, 0x80, 0xFF | 1 Byte | 0, 1, 2, 3 |
REPORT COLOUR TYPE | 255 | 255 | 0x10, 0x20, 0x40, 0x80, 0xFF | 1 Byte | 0, 1, 2, 3 |
SCENE 0–15 COLOUR TYPE | 65535 | 65535 | 0x10, 0x20, 0x40, 0x80, 0xFF | 16 Bytes | 0, 1, 2, 3 | nur Lesen
SCENE 0–15 COLOUR VALUE | 65535 | 65535 | 0 ... 65535 | 32 Bytes ... 192 Bytes | 0, 1, 2, 3 | nur Lesen
POWER ON COLOUR TYPE | herstellerabhängig | herstellerabhängig | 0x10, 0x20, 0x40, 0x80, 0xFF | 1 Byte | 0, 1, 2, 3 | nur Lesen
POWER ON COLOUR VALUE | herstellerabhängig | herstellerabhängig | 0 ... 65535 | 2 Bytes ... 12 Bytes | 0, 1, 2, 3 | nur Lesen
SYSTEM FAILURE COLOUR TYPE | herstellerabhängig | herstellerabhängig | 0x10, 0x20, 0x40, 0x80, 0xFF | 1 Byte | 0, 1, 2, 3 | nur Lesen
SYSTEM FAILURE COLOUR VALUE | herstellerabhängig | herstellerabhängig | 0 ... 65535 | 2 Bytes ... 12 Bytes | 0, 1, 2, 3 | nur Lesen
GEAR FEATURES/STATUS | ??00 0001b | ??00 0001b | ??00 0000b, ??00 0001b | 1 Byte | 0, 1, 2, 3 |
COLOUR STATUS | ? | keine Änderung | 0 ... 255 | 1 Byte | 0, 1, 2, 3 |
COLOUR TYPE FEATURES | ? | keine Änderung | 0 ... 255 | 1 Byte | 0, 1, 2, 3 | nur Lesen

?: unbestimmt

Bei 1-Byte-Werten wird der Wert 255 auch als MASK bezeichnet.

Bei 2-Byte-Werten wird der Wert 65535 wird auch als MASK bezeichnet.

(1): Gibt an, welche Farbdarstellung das DALI-Vorschaltgerät unterstützen muss, damit es die entsprechende Variable enthält:

Wert | Beschreibung
0 | xy-Koordinaten
1 | Farbtemperatur Tc
2 | Primär(farbe) N
3 | RGBWAF

ASSIGNED COLOUR

In ASSIGNED COLOUR wird die Zuordnung zwischen Ausgangskanal und Farbe definiert. Jedes Byte enthält die Farbe des entsprechenden Kanals.

Mit dem Baustein FB_DALIV2QueryAssignedColour() kann der Wert ausgelesen werden.

Wert | Beschreibung
0 | keine Farbe zugeordnet
1 | Rot
2 | Grün
3 | Blau
4 | Weiß
5 | Bernsteingelb
6 | frei wählbare Farbe

COLOUR TYPE

COLOUR TYPE definiert die vom DALI-Vorschaltgerät unterstützten Farbdarstellungen.

Mit dem Baustein FB_DALIV2QueryColourValue() können die Werte ausgelesen werden.

Wert | Beschreibung
0x10 | xy-Koordinaten
0x20 | Farbtemperatur Tc
0x40 | Primär(farbe) N
0x80 | RGBWAF
0xFF | keine Farbänderung

COLOUR STATUS

COLOUR TYPE enthält Informationen über den aktuellen Status des DALI-Vorschaltgerätes.

Mit dem Baustein FB_DALIV2QueryColourStatus() können die Werte ausgelesen werden.

Bit | Beschreibung
0 | xy-coordinate-Farbpunkt liegt außerhalb des gültigen Bereichs.
1 | Farbtemperatur Tc liegt außerhalb des gültigen Bereichs.
2 | automatische Kalibrierung ist aktiv.
3 | automatische Kalibrierung war erfolgreich.
4 | Farbdarstellung xy-coordinate aktiv.
5 | Farbdarstellung colour temperature Tc aktiv.
6 | Farbdarstellung primary N aktiv.
7 | Farbdarstellung RGBWAF aktiv.

GEAR FEATURES/STATUS

GEAR FEATURES/STATUS enthält Informationen über den aktuellen Status des DALI-Vorschaltgerätes.

Mit dem Baustein FB_DALIV2QueryGearFeaturesStatus() können die Werte ausgelesen und mit dem Baustein FB_DALIV2StoreGearFeaturesStatus() beschrieben werden.

Bit | Beschreibung
0 | automatische Aktivierung.
1 - 5 | reserviert.
6 | automatische Kalibrierung wird unterstützt.
7 | Wiederherstellung der automatischen Kalibrierung wird unterstützt.

RGBWAF CONTROL

RGBWAF CONTROL enthält weitere Informationen über die Zuordnung zwischen Ausgangskanal und Farbe.

Mit dem Baustein FB_DALIV2QueryColourValue() können die Werte ausgelesen werden.

Bit | Beschreibung
0 | Ausgangskanal 0 / Rot
1 | Ausgangskanal 1 / Grün
2 | Ausgangskanal 2 / Blau
3 | Ausgangskanal 3 / Weiß
4 | Ausgangskanal 4 / Bernsteingelb
5 | Ausgangskanal 5 / Frei wählbare Farbe
6 - 7 | 00 = Kanalsteuerung 01 = Farbsteuerung 10 = Standardisierte Farbsteuerung 11 = Reserviert

COLOUR TYPE FEATURES

COLOUR TYPE FEATURES enthält die vom DALI-Vorschaltgerät unterstützten Farbdarstellungen.

Mit dem Baustein FB_DALIV2QueryColourTypeFeatures() können die Werte ausgelesen werden.

Bit | Beschreibung
0 | Das Vorschaltgerät unterstützt die Farbdarstellung per xy-Koordinaten.
1 | Das Vorschaltgerät unterstützt die Farbdarstellung per Farbtemperatur Tc.
2 - 4 | Anzahl der vom Vorschaltgerät unterstützten Primärfarben. Ein Wert von 0 bedeutet, dass diese Farbdarstellung per Primärfarben nicht unterstützt wird.
5 - 7 | Anzahl der vom Vorschaltgerät unterstützten RGBWAF-Kanäle. Ein Wert von 0 bedeutet, dass diese Farbdarstellung per RGBWAF nicht unterstützt wird.


Farb-/Farbtemperatursteuerung - Funktionsbausteine

Name | Beschreibung
FB_DALIV2Activate | Startet eine neue Überblendung. Eine laufende Überblendung wird zuvor beendet.
FB_DALIV2AssignColourToLinkedChannel | Verknüpfte Ausgangskanäle werden der festgelegten Farbe zugeordnet.
FB_DALIV2ColourTemperatureTcStepCooler | Der Wert COLOUR TEMPERATURE Tc wird um 1 Mirek verringert.
FB_DALIV2ColourTemperatureTcStepWarmer | Der Wert COLOUR TEMPERATURE Tc wird um 1 Mirek erhöht.
FB_DALIV2CopyReportToTemporary | Die Meldung Farbeinstellungen wird zu den temporären Farbeinstellungen kopiert.
FB_DALIV2QueryAssignedColour | Liest die zugewiesene Farbe des vorgegebenen Ausgangskanals aus.
FB_DALIV2QueryColourStatus | Die Variable COLOUR STATUS wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryColourTypeFeatures | Die vom Vorschaltgerät unterstützten Farbdarstellungen werden ausgelesen.
FB_DALIV2QueryColourValue | Der vorgegebene Farbwert wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryGearFeaturesStatus | Die Variable GEAR FEATURES/STATUS wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2QueryRGBWAFControl | Die Variable RGBWAF CONTROL wird aus dem Vorschaltgerät ausgelesen.
FB_DALIV2SetTemporaryColourTemperatureTc | Speichert den Wert in die Variable TEMPORARY COLOUR TEMPERATURE Tc des Vorschaltgerätes.
FB_DALIV2SetTemporaryPrimaryNDimlevel | Speichert den Wert in die Variable TEMPORARY PRIMARY N DIMLEVEL des Vorschaltgerätes.
FB_DALIV2SetTemporaryRGBDimlevel | Speichert die Werte in die Variablen TEMPORARY RED DIMLEVEL, TEMPORARY GREEN DIMLEVEL und TEMPORARY BLUE DIMLEVEL des Vorschaltgerätes.
FB_DALIV2SetTemporaryRGBWAFControl | Speichert den Wert in die Variable TEMPORARY RGBWAF CONTROL des Vorschaltgerätes.
FB_DALIV2SetTemporaryWAFDimlevel | Speichert die Werte in die Variablen TEMPORARY WHITE DIMLEVEL, TEMPORARY AMBER DIMLEVEL und TEMPORARY FREECOLOUR DIMLEVEL des Vorschaltgerätes.
FB_DALIV2SetTemporaryXCoordinate | Speichert den Wert in die Variable TEMPORARY x-COORDINATE des Vorschaltgerätes.
FB_DALIV2SetTemporaryYCoordinate | Speichert den Wert in die Variable TEMPORARY y-COORDINATE des Vorschaltgerätes.
FB_DALIV2StartAutoCalibration | Das Kalibrierungsverfahren wird gestartet um die x-Koordinate, die y-Koordinate und den TY-Wert aller unterstützen Primärfarben zu messen.
FB_DALIV2StoreColourTemperatureTcLimit | Speichert den Wert in die Variable COLOUR TEMPERATURE Tc COOLEST, COLOUR TEMPERATURE Tc WARMEST, COLOUR TEMPERATURE Tc PHYSICAL COOLEST oder COLOUR TEMPERATURE Tc PHYSICAL WARMEST des Vorschaltgerätes.
FB_DALIV2StoreGearFeaturesStatus | Speichert den Wert in die Variable GEAR FEATURES/STATUS des Vorschaltgerätes.
FB_DALIV2StoreTYPrimaryN | Speichert den Wert in die Variable TY PRIMARY N des Vorschaltgerätes.
FB_DALIV2StoreXyCoordinatePrimaryN | Kopiert den Wert aus den Variablen TEMPORARY x-COORDINATE und TEMPORARY y-COORDINATE in die Variablen x-COORDINATE PRIMARY N und y-COORDINATE PRIMARY N.
FB_DALIV2XCoordinateStepDown | Die Variable x-COORDINATE wird um 256 Schritte (256 / 65536) ohne Überblendung reduziert.
FB_DALIV2XCoordinateStepUp | Die Variable x-COORDINATE wird um 256 Schritte (256 / 65536) ohne Überblendung erhöht.
FB_DALIV2YCoordinateStepDown | Die Variable y-COORDINATE wird um 256 Schritte (256 / 65536) ohne Überblendung reduziert.
FB_DALIV2YCoordinateStepUp | Die Variable y-COORDINATE wird um 256 Schritte (256 / 65536) ohne Überblendung erhöht.

Hinweis: Diese Befehle gehören zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.


FB_DALIV2Activate DEF

TwinCAT PLC Lib: DALI

FB_DALIV2Activate

Eine laufende Überblendung wird beendet und eine neue Überblendung gestartet. Hierbei wird nur die Farbe geändert.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Farbtemperatur Tc
  • Primär(farbe) N
  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2AssignColourToLinkedChannel

Verknüpfte Ausgangskanäle werden der festgelegten Farbe (siehe Tabelle) zugeordnet. Die verknüpften Kanäle werden durch Bit 0 bis Bit 5 der Variablen TEMPORARY RGBWAF CONTROL angegeben. Die Kanalzuordnung wird nicht geändert, wenn TEMPORARY RGBWAF CONTROL den Wert 255 (MASK) enthält. Alle TEMPORARY COLOUR SETTINGS werden nach der Verwendung dieses Befehls auf MASK gesetzt.

Wert | Beschreibung
0 | keine Farbe zugeordnet
1 | Rot
2 | Grün
3 | Blau
4 | Weiß
5 | Bernsteingelb
6 | frei wählbare Farbe

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register) verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nColour           : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nColour: Farbe, die den Ausgangskanälen zugeordnet wird (siehe Tabelle).

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2ColourTemperatureTcStepCooler

Der Wert COLOUR TEMPERATURE Tc wird ohne Überblendung um 1 Mirek verringert. Falls der Wert COLOUR TEMPERATURE Tc bereits den Wert COLOUR TEMPERATURE Tc COOLEST hat, erfolgt keine Änderung.

Kann die Farbtemperatur von dem DALI-Vorschaltgerät nicht erreicht werden, so wird in COLOUR STATUS Bit 1 (Colour temperature Tc out of range) gesetzt. Dieser Befehl wird vom DALI-Vorschaltgerät nur dann ausgeführt, wenn in der Variablen COLOUR STATUS das Bit 5 (Colour type colour temperature Tc active) gesetzt ist.

Für die Umrechnung von oder nach Kelvin stehen die Funktionen KELVIN_TO_MIREK und MIREK_TO_KELVIN zur Verfügung.

Der Baustein unterstützt die Farbdarstellungen:

  • Farbtemperatur Tc

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2ColourTemperatureTcStepWarmer

Der Wert COLOUR TEMPERATURE Tc wird ohne Überblendung um 1 Mirek erhöht. Falls der Wert COLOUR TEMPERATURE Tc bereits den Wert COLOUR TEMPERATURE Tc WARMEST hat, erfolgt keine Änderung.

Kann die Farbtemperatur von dem DALI-Vorschaltgerät nicht erreicht werden, so wird in COLOUR STATUS Bit 1 (Colour temperature Tc out of range) gesetzt. Dieser Befehl wird vom DALI-Vorschaltgerät nur dann ausgeführt, wenn in der Variablen COLOUR STATUS das Bit 5 (Colour type colour temperature Tc active) gesetzt ist.

Für die Umrechnung von oder nach Kelvin stehen die Funktionen KELVIN_TO_MIREK und MIREK_TO_KELVIN zur Verfügung.

Der Baustein unterstützt die Farbdarstellungen:

  • Farbtemperatur Tc

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2CopyReportToTemporary

Die Meldung Farbeinstellungen wird zu den temporären Farbeinstellungen kopiert.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Farbtemperatur Tc
  • Primär(farbe) N
  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2QueryAssignedColour

Die Variable ASSIGNED COLOUR wird aus dem DALI-Vorschaltgerät ausgelesen. Diese enthält die zugewiesene Farbe (siehe Tabelle) des vorgegebenen Ausgangskanals (0 - 5) aus. Wird eine nicht existierende Kanalnummer angegeben, so wird 255 (MASK) zurückgeliefert.

Wert | Beschreibung
0 | keine Farbe zugeordnet
1 | Rot
2 | Grün
3 | Blau
4 | Weiß
5 | Bernsteingelb
6 | frei wählbare Farbe

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register) verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nChannel          : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nChannel: Kanalnummer (0 - 5).

VAR_OUTPUT

bBusy           : BOOL;
bError          : BOOL;
nErrorId        : UDINT;
nAssignedColour : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nAssignedColour: zugewiesene Farbe des Kanals (siehe Tabelle).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2QueryColourStatus

Die Variable COLOUR STATUS wird aus dem DALI-Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | xy-coordinate-Farbpunkt liegt außerhalb des gültigen Bereichs.
1 | Farbtemperatur Tc liegt außerhalb des gültigen Bereichs.
2 | automatische Kalibrierung ist aktiv.
3 | automatische Kalibrierung war erfolgreich.
4 | Farbdarstellung xy-coordinate aktiv.
5 | Farbdarstellung colour temperature Tc aktiv.
6 | Farbdarstellung primary N aktiv.
7 | Farbdarstellung RGBWAF aktiv.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Farbtemperatur Tc
  • Primär(farbe) N
  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy           : BOOL;
bError          : BOOL;
nErrorId        : UDINT;
nColourStatus   : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nColourStatus: Farbstatus (siehe Tabelle oben).

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2QueryColourTypeFeatures

Die Variable COLOUR TYPE FEATURES wird aus dem DALI-Vorschaltgerät ausgelesen. Dieser enthält die vom DALI-Vorschaltgerät unterstützten Farbdarstellungen.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Farbtemperatur Tc
  • Primär(farbe) N
  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy                         : BOOL;
bError                        : BOOL;
nErrorId                      : UDINT;
bSupportsXyCoordinate         : BOOL;
bSupportsColourTemperatureTc  : BOOL;
nNumberOfPrimaryColors        : BYTE;
nNumberOfRGBWAFChannels       : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

bSupportsXyCoordinate: Das Vorschaltgerät ist xy-coordinate fähig.

bSupportsColourTemperatureTc: Das Vorschaltgerät ist Colour temperature Tc fähig.

nNumberOfPrimaryColors: Anzahl der vom Vorschaltgerät unterstützten Primärfarben. Ein Wert von 0 bedeutet, dass diese Farbdarstellung nicht unterstützt wird.

nNumberOfRGBWAFChannels: Anzahl der vom Vorschaltgerät unterstützten RGBWAF-Kanäle. Ein Wert von 0 bedeutet, dass diese Farbdarstellung nicht unterstützt wird.

VAR_IN_OUT

stCommandBuffer     : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2QueryColourValue

Die vorgegebene Variable (Farbwert) wird aus dem DALI-Vorschaltgerät ausgelesen. Der auszulesende Wert, wird durch nParamter definiert (siehe Tabelle unten).

Bestimmte Variablen können direkt über DALI-Befehle ausgelesen werden (z.B. FB_QueryColourStatus() oder FB_QueryRGBWAFControl()). Weitere Einzelheiten zu den Variablen finden sie hier.

Wert | Beschreibung
0 | x-COORDINATE
1 | y-COORDINATE
2 | COLOUR TEMPERATURE Tc
3 | PRIMARY N DIMLEVEL 0
4 | PRIMARY N DIMLEVEL 1
5 | PRIMARY N DIMLEVEL 2
6 | PRIMARY N DIMLEVEL 3
7 | PRIMARY N DIMLEVEL 4
8 | PRIMARY N DIMLEVEL 5
9 | RED DIMLEVEL
10 | GREEN DIMLEVEL
11 | BLUE DIMLEVEL
12 | WHITE DIMLEVEL
13 | AMBER DIMLEVEL
14 | FREECOLOUR DIMLEVEL
15 | RGBWAF CONTROL
64 | x-COORDINATE PRIMARY N 0
65 | y-COORDINATE PRIMARY N 0
66 | TY PRIMARY N 0
67 | x-COORDINATE PRIMARY N 1
68 | y-COORDINATE PRIMARY N 1
69 | TY PRIMARY N 1
70 | x-COORDINATE PRIMARY N 2
71 | y-COORDINATE PRIMARY N 2
72 | TY PRIMARY N 2
73 | x-COORDINATE PRIMARY N 3
74 | y-COORDINATE PRIMARY N 3
75 | TY PRIMARY N 3
76 | x-COORDINATE PRIMARY N 4
77 | y-COORDINATE PRIMARY N 4
78 | TY PRIMARY N 4
79 | x-COORDINATE PRIMARY N 5
80 | y-COORDINATE PRIMARY N 5
81 | TY PRIMARY N 5
82 | NUMBER OF PRIMARIES
128 | COLOUR TEMPERATURE Tc COOLEST
129 | COLOUR TEMPERATURE Tc PHYSICAL COOLEST
130 | COLOUR TEMPERATURE Tc WARMEST
131 | COLOUR TEMPERATURE Tc PHYSICAL WARMEST
192 | TEMPORARY x-COORDINATE
193 | TEMPORARY y-COORDINATE
194 | TEMPORARY COLOUR TEMPERATURE Tc
195 | TEMPORARY PRIMARY N DIMLEVEL 0
196 | TEMPORARY PRIMARY N DIMLEVEL 1
197 | TEMPORARY PRIMARY N DIMLEVEL 2
198 | TEMPORARY PRIMARY N DIMLEVEL 3
199 | TEMPORARY PRIMARY N DIMLEVEL 4
200 | TEMPORARY PRIMARY N DIMLEVEL 5
201 | TEMPORARY RED DIMLEVEL
202 | TEMPORARY GREEN DIMLEVEL
203 | TEMPORARY BLUE DIMLEVEL
204 | TEMPORARY WHITE DIMLEVEL
205 | TEMPORARY AMBER DIMLEVEL
206 | TEMPORARY FREECOLOUR DIMLEVEL
207 | TEMPORARY RGBWAF CONTROL
208 | TEMPORARY COLOUR TYPE
224 | REPORT x-COORDINATE
225 | REPORT y-COORDINATE
226 | REPORT COLOUR TEMPERATURE Tc
227 | REPORT PRIMARY N DIMLEVEL 0
228 | REPORT PRIMARY N DIMLEVEL 1
229 | REPORT PRIMARY N DIMLEVEL 2
230 | REPORT PRIMARY N DIMLEVEL 3
231 | REPORT PRIMARY N DIMLEVEL 4
232 | REPORT PRIMARY N DIMLEVEL 5
233 | REPORT RED DIMLEVEL
234 | REPORT GREEN DIMLEVEL
235 | REPORT BLUE DIMLEVEL
236 | REPORT WHITE DIMLEVEL
237 | REPORT AMBER DIMLEVEL
238 | REPORT FREECOLOUR DIMLEVEL
239 | REPORT RGBWAF CONTROL
240 | REPORT COLOUR TYPE

Antworten, die eine aktive Farbdarstellung betreffen, sind nur gültig, wenn die Farbdarstellung des angeforderten Farbwertes aktiv ist (siehe FB_DALIV2QueryColourStatus()) oder das Vorschaltgerät in der Lage ist, eine Neuberechnung des geforderten Farbwertes von der aktiven Farbdarstellung in einen Farbwert einer anderen Farbdarstellung durchzuführen.

Falls das Vorschaltgerät die Koordinaten nicht kennt oder die Primärfarbe nicht vorliegt, muss die Antwort 255 (MASK) sein.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register) und DTR1 verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Farbtemperatur Tc
  • Primär(farbe) N
  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart           : BOOL;
nAddr            : BYTE;
eAddrType        : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nParameter       : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nParameter: Farbwert, der ausgelesen werden soll (siehe Tabelle oben).

VAR_OUTPUT

bBusy           : BOOL;
bError          : BOOL;
nErrorId        : UDINT;
nValue          : UINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nValue: Enthält den ausgelesenen Wert.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2QueryGearFeaturesStatus

Die Variable GEAR FEATURES/STATUS wird aus dem DALI-Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | automatische Aktivierung.
1 - 5 | reserviert.
6 | automatische Kalibrierung wird unterstützt.
7 | Wiederherstellung der automatischen Kalibrierung wird unterstützt.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Farbtemperatur Tc
  • Primär(farbe) N
  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy               : BOOL;
bError              : BOOL;
nErrorId            : UDINT;
nGearFeaturesStatus : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nGearFeaturesStatus: Statusinformationen (siehe Tabelle oben).

VAR_IN_OUT

stCommandBuffer     : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2QueryRGBWAFControl

Die Variable RGBWAF CONTROL wird aus dem DALI-Vorschaltgerät ausgelesen.

Bit | Beschreibung
0 | Ausgangskanal 0 / Rot
1 | Ausgangskanal 1 / Grün
2 | Ausgangskanal 2 / Blau
3 | Ausgangskanal 3 / Weiß
4 | Ausgangskanal 4 / Bernsteingelb
5 | Ausgangskanal 5 / Frei wählbare Farbe
6 - 7 | 00 = Kanalsteuerung 01 = Farbsteuerung 10 = Standardisierte Farbsteuerung 11 = Reserviert

Falls ein Ausgangskanal bzw. eine Farbe nicht unterstützt wird, so ist das entsprechende Bit FALSE.

Der Baustein unterstützt die Farbdarstellungen:

  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy            : BOOL;
bError           : BOOL;
nErrorId         : UDINT;
nRGBWAFControl   : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nRGBWAFControl: Informationen über die Kanalzuordnung (siehe Tabelle oben).

VAR_IN_OUT

stCommandBuffer   : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2SetTemporaryColourTemperatureTc

Speichert den Wert in die Variable TEMPORARY COLOUR TEMPERATURE Tc des DALI-Vorschaltgerätes. Der Wert kann mit dem Funktionsblock FB_DALIV2QueryColourValue() ausgelesen werden.

Der Wert wird in Einheiten von 1 Mirek ausgedrückt. Ein Wert von 0 wird ignoriert und deshalb nicht gespeichert. Die Farbtemperatur Tc kann von 1 Mirek (1000000 K) bis 65534 Mirek (15,26 K) variieren.

Für die Umrechnung von oder nach Kelvin stehen die Funktionen KELVIN_TO_MIREK und MIREK_TO_KELVIN zur Verfügung.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register) und DTR1 verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • Farbtemperatur Tc

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nValue            : UINT;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nValue: Der Wert, der in die Variable TEMPORARY COLOUR TEMPERATURE Tc geschrieben wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2SetTemporaryPrimaryNDimlevel

Speichert den Wert in die Variable TEMPORARY PRIMARY N DIMLEVEL des Vorschaltgerätes. Der Wert kann mit dem Funktionsblock FB_DALIV2QueryColourValue() ausgelesen werden.

Der Wert wird in Einheiten von 1 / 65536 ausgedrückt. Der Höchstwert des PRIMARY N DIMLEVEL ist 0,99997 und wird auf einem linearen Maßstab interpretiert.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register), DTR1 und DTR2 verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • Primär(farbe) N

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart              : BOOL;
nAddr               : BYTE;
eAddrType           : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nPrimaryColour      : BYTE;
nValue              : UINT;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nPrimaryColour: Primärfarbe (0 - 5).

nValue: Der Wert, der in die Variable TEMPORARY PRIMARY N DIMLEVEL geschrieben wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2SetTemporaryRGBDimlevel

Speichert die Werte in die Variablen TEMPORARY RED DIMLEVEL, TEMPORARY GREEN DIMLEVEL und TEMPORARY BLUE DIMLEVEL des DALI-Vorschaltgerätes. Die Werte können mit dem Funktionsblock FB_DALIV2QueryColourValue() ausgelesen werden.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register), DTR1 und DTR2 verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart                  : BOOL;
nAddr                   : BYTE;
eAddrType               : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority        : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nTemporaryRedDimlevel   : BYTE;
nTemporaryGreenDimlevel : BYTE;
nTemporaryBlueDimlevel  : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nTemporaryRedDimlevel: Der neue Wert für TEMPORARY RED DIMLEVEL.

nTemporaryGreenDimlevel: Der neue Wert für TEMPORARY GREEN DIMLEVEL.

nTemporaryBlueDimlevel: Der neue Wert für TEMPORARY BLUE DIMLEVEL.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2SetTemporaryRGBWAFControl

Speichert den Wert in die Variable TEMPORARY RGBWAF CONTROL des DALI-Vorschaltgerätes. Der Wert kann mit dem Funktionsblock FB_DALIV2QueryColourValue() ausgelesen werden. Der Eingang nTemporaryRGBWAFControl enthält dabei die neue Zuordnung (siehe Tabelle).

Bit | Beschreibung
0 | Ausgangskanal 0 / Rot
1 | Ausgangskanal 1 / Grün
2 | Ausgangskanal 2 / Blau
3 | Ausgangskanal 3 / Weiß
4 | Ausgangskanal 4 / Bernsteingelb
5 | Ausgangskanal 5 / Frei wählbare Farbe
6 - 7 | 00 = Kanalsteuerung 01 = Farbsteuerung 10 = Standardisierte Farbsteuerung 11 = Reserviert

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register) verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart                   : BOOL;
nAddr                    : BYTE;
eAddrType                : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority         : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nTemporaryRGBWAFControl  : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nTemporaryRGBWAFControl: Enthält die Zuordnung (siehe Tabelle oben).

VAR_OUTPUT

bBusy           : BOOL;
bError          : BOOL;
nErrorId        : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2SetTemporaryWAFDimlevel

Speichert die Werte in die Variablen TEMPORARY WHITE DIMLEVEL, TEMPORARY AMBER DIMLEVEL und TEMPORARY FREECOLOUR DIMLEVEL des DALI-Vorschaltgerätes. Die Werte können mit dem Funktionsblock FB_DALIV2QueryColourValue() ausgelesen werden.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register), DTR1 und DTR2 verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart                        : BOOL;
nAddr                         : BYTE;
eAddrType                     : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority              : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nTemporaryWhiteDimlevel       : BYTE;
nTemporaryAmberDimlevel       : BYTE;
nTemporaryFreecolourDimlevel  : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nTemporaryWhiteDimlevel: Der neue Wert für TEMPORARY WHITE DIMLEVEL.

nTemporaryAmberDimlevel: Der neue Wert für TEMPORARY AMBER DIMLEVEL.

nTemporaryFreecolourDimlevel: Der neue Wert für TEMPORARY FREECOLOUR DIMLEVEL.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2SetTemporaryXCoordinate

Speichert den Wert in die Variable TEMPORARY x-COORDINATE des DALI-Vorschaltgerätes. Der Wert kann mit dem Funktionsblock FB_DALIV2QueryColourValue() ausgelesen werden.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register) und DTR1 verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Primär(farbe) N

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart           : BOOL;
nAddr            : BYTE;
eAddrType        : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nValue           : UINT;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nValue: Der Wert, der in die Variable TEMPORARY x-COORDINATE geschrieben wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2SetTemporaryYCoordinate

Speichert den Wert in die Variable TEMPORARY y-COORDINATE des DALI-Vorschaltgerätes. Der Wert kann mit dem Funktionsblock FB_DALIV2QueryColourValue() ausgelesen werden.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register) und DTR1 verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Primär(farbe) N

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart           : BOOL;
nAddr            : BYTE;
eAddrType        : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nValue           : UINT;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nValue: Der Wert, der in die Variable TEMPORARY y-COORDINATE geschrieben wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2StartAutoCalibrationl

TwinCAT PLC Lib: DALI

FB_DALIV2StartAutoCalibration

Das Kalibrierungsverfahren wird gestartet um die x-Koordinate, die y-Koordinate und den TY-Wert aller unterstützen Primärfarben zu messen.

Der Befehl startet einen 15-min-Zeitgeber oderstößt ihn erneut an. Bit 2 der Variablen COLOUR STATUS ist 1, während der Zeitgeber aktiv ist (siehe FB_DALIV2QueryColourStatus()). Nach Ablauf des Zeitgebers, werden die letzte Farbdarstellung, der letzte Farbwert und das letzte Lampenleistungsniveau direkt wieder gespeichert.

Während der Zeitgeberperiode führt das DALI-Vorschaltgerät ein Kalibrierungsverfahren durch, um die x-Koordinate, die y-Koordinate und den TY-Wert aller unterstützten Primärfarben zu messen. Während des laufenden Kalibrierungsverfahrens reagiert das DALI-Vorschaltgerät auf keinen Befehl, außer TERMINATE, QUERY COLOUR STATUS und START AUTO CALIBRATION. Außerdem wird zu Beginn der Kalibrierung in der Variablen COLOUR STATUS das Bit 3 auf 0 gesetzt. Der Befehl TERMINATE beendet das Verfahren und hält den Zeitgeber an.

Wenn die Kalibrierung erfolgreich war, wird in COLOUR STATUS Bit 3 auf 1 gesetzt und der Zeitgeber angehalten. Wenn die Kalibrierung nicht erfolgreich war, so werden die letzten erfolgreichen Kalibrierungsdaten wiederhergestellt wenn das DALI-Vorschaltgerät hierzu in der Lage ist. Anschließend wird Bit 3 von COLOUR STATUS auf 1 gesetzt. Die Fähigkeit, die letzten erfolgreichen Kalibrierungsdaten wiederherzustellen, ist ein Merkmal des Betriebsgerätes (siehe Befehl QUERY GEAR FEATURES/STATUS).

Aufgrund der Tatsache, dass die Kalibrierung länger als 15 min dauern kann, sollte der Status der automatischen Kalibrierung mit dem Befehl QUERY COLOUR STATUS periodisch überprüfen und der Zeitgeber der Kalibrierung mit dem Befehl START AUTO CALIBRATION neu gestartet werden (wenn notwendig).

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Farbtemperatur Tc
  • Primär(farbe) N
  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart           : BOOL;
nAddr            : BYTE;
eAddrType        : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2StoreColourTemperatureTcLimit

Speichert den Wert in die Variable COLOUR TEMPERATURE Tc COOLEST, COLOUR TEMPERATURE Tc WARMEST, COLOUR TEMPERATURE Tc PHYSICAL COOLEST oder COLOUR TEMPERATURE Tc PHYSICAL WARMEST des DALI-Vorschaltgerätes. Die Werte können mit dem Funktionsblock FB_DALIV2QueryColourValue() ausgelesen werden. Der Eingang nSelectLimitValue definiert den Grenzwert der neu gesetzt werden soll:

Wert | Grenzwert | Beschreibung
0 | COLOUR TEMPERATURE Tc COOLEST | niedrigster möglicher Wert, aber immer gleich oder wärmer als der niedrigste mögliche physikalische Wert.
1 | COLOUR TEMPERATURE Tc WARMEST | höchster möglicher Wert, aber immer gleich oder kälter als der höchste mögliche physikalische Wert.
2 | COLOUR TEMPERATURE Tc PHYSICAL COOLEST | niedrigster möglicher physikalischer Wert.
3 | COLOUR TEMPERATURE Tc PHYSICAL WARMEST | höchster möglicher physikalischer Wert.

Für die Umrechnung von oder nach Kelvin stehen die Funktionen KELVIN_TO_MIREK und MIREK_TO_KELVIN zur Verfügung.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register), DTR1 und DTR2 verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • Farbtemperatur Tc

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart              : BOOL;
nAddr               : BYTE;
eAddrType           : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority    : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nSelectLimitValue   : BYTE;
nValue              : UINT;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nSelectLimitValue: Gibt den Grenzwert vor, der neu gesetzt werden soll (siehe Tabelle oben).

nValue: Der Wert, der in die ausgewählte Variable geschrieben wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2StoreGearFeaturesStatus

Speichert den Wert in die Variable GEAR FEATURES/STATUS des DALI-Vorschaltgerätes. Mit dem Baustein FB_DALIV2QueryGearFeaturesStatus() können die Werte ausgelesen werden.

Falls Bit 0 auf 1 gesetzt wird, müssen alle Befehle zur Steuerung der Lampenleistung, mit Ausnahme von ENABLE DAPC SEQUENCE, automatisch einen Farbübergang auslösen.

Bit | Beschreibung
0 | automatische Aktivierung.
1 - 7 | reserviert.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register) verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten
  • Farbtemperatur Tc
  • Primär(farbe) N
  • RGBWAF

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart                : BOOL;
nAddr                 : BYTE;
eAddrType             : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority      : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nGearFeaturesStatus   : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nGearFeaturesStatus: Wert, der in die Variable GEAR FEATURES/STATUS geschrieben wird.

VAR_OUTPUT

bBusy              : BOOL;
bError             : BOOL;
nErrorId           : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer    : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2StoreTYPrimaryN

Speichert den Wert in die Variable TY PRIMARY N des DALI-Vorschaltgerätes.

Der Wert wird in Einheiten von 0,5 lm ausgedrückt, was einen möglichen Bereich von TYmin = 0 lm bis TYmax = 32767 lm ergibt. Ein Wert von 65535 (MASK) bedeutet 'unbekannt'. Der Parameter nPrimaryColour gibt die Primärfarbe an und muss im Bereich von 0 bis 5 liegen, abhängig von der verfügbaren Anzahl von Primärfarben. Für jeden anderen Wert wird der Befehl ignoriert.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR (Data Transfer Register), DTR1 und DTR2 verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • Primär(farbe) N

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nPrimaryColour    : BYTE;
nValue            : UINT;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nPrimaryColour: Primärfarbe (0 - 5).

nValue: Der Wert, der in die Variable TY PRIMARY N geschrieben wird.

VAR_OUTPUT

bBusy           : BOOL;
bError          : BOOL;
nErrorId        : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2StoreXyCoordinatePrimaryN

Kopiert den Wert aus den Variablen TEMPORARY x-COORDINATE und TEMPORARY y-COORDINATE in die Variablen x-COORDINATE PRIMARY N und y-COORDINATE PRIMARY N.

Der Parameter nPrimaryColour gibt die Primärfarbe an und muss im Bereich von 0 bis 5 liegen, abhängig von der verfügbaren Anzahl von Primärfarben. Für jeden anderen Wert wird der Befehl ignoriert.

Dieser Befehl ist dazu vorgesehen, die zur Primärfarbe dazugehörigen aktuellen xy-Koordinaten zu speichern. xy-Koordinaten außerhalb des Farbenraum-Chromatizitäts-Diagramms sind nicht sinnvoll und sollten deshalb vermieden werden.

Durch den Funktionsblock werden bei allen DALI-Vorschaltgeräten der DALI-Linie die DTR2 (Data Transfer Register) verändert.

Der Baustein unterstützt die Farbdarstellungen:

  • Primär(farbe) N

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nPrimaryColour    : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nPrimaryColour: Primärfarbe (0 - 5).

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2XCoordinateStepDown

Die Variable x-COORDINATE wird um 256 Schritte (256 / 65536) ohne Überblendung reduziert.

Falls der neue Farbwert nicht mit einer Farbe übereinstimmt, die vom DALI-Vorschaltgerät erreicht werden kann, muss dies durch das Bit 0 von COLOUR STATUS (xy-coordinate-Farbpunkt liegt außerhalb des gültigen Bereichs), angezeigt werden. Der Befehl wird nur dann ausgeführt, wenn das Bit 4 vom COLOUR STATUS (Farbdarstellung xy-coordinate aktiv) gesetzt ist.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2XCoordinateStepUp

Die Variable x-COORDINATE wird um 256 Schritte (256 / 65536) ohne Überblendung erhöht.

Falls der neue Farbwert nicht mit einer Farbe übereinstimmt, die vom DALI-Vorschaltgerät erreicht werden kann, muss dies durch das Bit 0 von COLOUR STATUS (xy-coordinate-Farbpunkt liegt außerhalb des gültigen Bereichs), angezeigt werden. Der Befehl wird nur dann ausgeführt, wenn das Bit 4 vom COLOUR STATUS (Farbdarstellung xy-coordinate aktiv) gesetzt ist.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2YCoordinateStepDown

Die Variable y-COORDINATE wird um 256 Schritte (256 / 65536) ohne Überblendung reduziert.

Falls der neue Farbwert nicht mit einer Farbe übereinstimmt, die vom DALI-Vorschaltgerät erreicht werden kann, muss dies durch das Bit 0 von COLOUR STATUS (xy-coordinate-Farbpunkt liegt außerhalb des gültigen Bereichs), angezeigt werden. Der Befehl wird nur dann ausgeführt, wenn das Bit 4 vom COLOUR STATUS (Farbdarstellung xy-coordinate aktiv) gesetzt ist.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


FB_DALIV2YCoordinateStepUp

Die Variable y-COORDINATE wird um 256 Schritte (256 / 65536) ohne Überblendung erhöht.

Falls der neue Farbwert nicht mit einer Farbe übereinstimmt, die vom DALI-Vorschaltgerät erreicht werden kann, muss dies durch das Bit 0 von COLOUR STATUS (xy-coordinate-Farbpunkt liegt außerhalb des gültigen Bereichs), angezeigt werden. Der Befehl wird nur dann ausgeführt, wenn das Bit 4 vom COLOUR STATUS (Farbdarstellung xy-coordinate aktiv) gesetzt ist.

Der Baustein unterstützt die Farbdarstellungen:

  • xy-Koordinaten

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 8 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 8 allen anwendungsbezogenen Erweiterungsbefehlen für Lampen zur Farb-/Farbtemperatursteuerung mit DALI-Schnittstelle intern automatisch vorangestellt.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

VAR_OUTPUT

bBusy       : BOOL;
bError      : BOOL;
nErrorId    : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


KELVIN_TO_MIREK

Umrechnung der Farbtemperatur von Kelvin in Mirek.

Mirek ist die Einheit, die bei den meisten DALI-Befehlen verwendet wird. Der Rückgabewert ist begrenzt und liegt im Bereich von 0 ... 65535 (siehe Tabelle).

Mirek = 1.000.000 / (Farbtemperatur in Kelvin).

Kelvin | Mirek
0 | 65535
15 | 65535
16 | 62500
1000 | 1000
10000 | 100
1000000 | 1
1000001 | 0

VAR_INPUT

fKelvin            : LREAL;

fKelvin: Farbtemperatur in Kelvin.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


MIREK_TO_KELVIN

Umrechnung der Farbtemperatur von Mirek in Kelvin.

Mirek ist die Einheit, die bei den meisten DALI-Befehlen verwendet wird. Der Rückgabewert ist begrenzt und liegt im Bereich von ca. 15,259 ...1000001 (siehe Tabelle).

Mirek = 1.000.000 / (Farbtemperatur in Kelvin).

Mirek | Kelvin
0 | 1000001
1 | 1000000
100 | 10000
1000 | 1000
10000 | 100
65534 | 15,259
65535 | 15,259

VAR_INPUT

nMirek            : UINT;

nMirek: Farbtemperatur in Mirek.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 ab Build 2244 | PC/CX, BX oder BC | TcDALIV2-Bibliothek ab V2.10.0


Philips propritäre Entladungslampen - Einführung

Die Firma Philips hat eigene DALI-Befehle für spezielle Entladungslampen definiert. Diese Befehle gehen über die Möglichkeiten der DALI-Befehle nach Norm IEC 62386 Part 203 hinaus. Allerdings sind diese Befehle nur für bestimmte Vorschaltgeräte der Firma Philips anwendbar. Für eine genauere Beschreibung der Befehle wenden Sie sich bitte an die Firma Philips.


Philips propritäre Entladungslampen - Variablen

Name | Vorgabewert | Rücksetzwert | Gültigkeitsbereich | Größe | Bemerkung
PAEC_ENABLED | 0 | keine Änderung | 0 ... 1 | 1 Byte |
CONTROL GEAR SEGMENT ADDRESS | 0 | keine Änderung | 0 ... 255 | 1 Byte |
SEGMENT ADDRESS | 0 | 0 | 0 ... 255 | 1 Byte |
UIC | Hersteller abhängig | keine Änderung | 00 00 00 00 00 00 00 00 ... FF FF FF FF FF FF FF FF | 8 Byte | nur Lesen
LAMPTYPE | 0 | keine Änderung | 0 ... 255 | 1 Byte |
HID LAMP LEVEL | ???? ???? | 0 | 0 ... 255 | 1 Byte |
FADE UP | 0 | keine Änderung | 0 ... 255 | 1 Byte |
FADE DOWN | 0 | keine Änderung | 0 ... 255 | 1 Byte |
FAILURE STATUS | 0 | 0 | 0 ... 255 | 1 Byte |
OPERATION TIME | 0 | keine Änderung | 0 ... 255 | 1 Byte |
OVERTEMPERATURE TIME | 0 | keine Änderung | 0 ... 255 | 1 Byte |
CONTROL GEAR TEMPERATURE | 0 | 0 | 0 ... 255 | 1 Byte |
OVERTEMPERATURE LEVEL | 255 | keine Änderung | 0 ... 255 | 1 Byte |
TIMEOUT | 0 | keine Änderung | 0 ... 255 | 1 Byte |
MAINS VOLTAGE | 0 | 0 | 0 ... 255 | 1 Byte |
LAMP VOLTAGE | 0 | 0 | 0 ... 255 | 1 Byte |

?: unbestimmt


Philips propritäre Entladungslampen - Funktionsbausteine

Name | Beschreibung
FB_DALIV2PhilipsChangePAEC | Aktiviert oder deaktiviert das "Application Extended Command Set".
FB_DALIV2PhilipsQueryCtrlGearOperationTime | Liest die Ausführungszeit des Vorschaltgerätes aus.
FB_DALIV2PhilipsQueryCtrlGearOvertempLevel | Liest das Übertemperatur Schwellwert des Vorschaltgerätes aus.
FB_DALIV2PhilipsQueryCtrlGearOvertempTime | Liest die Übertemperatur Zeit des Vorschaltgerätes aus.
FB_DALIV2PhilipsQueryCtrlGearTemperature | Liest die Temperatur des Vorschaltgerätes aus.
FB_DALIV2PhilipsQueryFailureStatus | Liest den Fehlerstatus aus.
FB_DALIV2PhilipsQueryHIDLampLevel | Liest den Lampenstatus aus.
FB_DALIV2PhilipsQueryHIDMaxFadeDownRate | Liest die maximale Ausblendrate aus.
FB_DALIV2PhilipsQueryHIDMaxFadeUpRate | Liest die maximale Einblendrate aus.
FB_DALIV2PhilipsQueryLampType | Liest den Lampentyp aus.
FB_DALIV2PhilipsQueryLampVoltage | Liest die Lampenspannung aus.
FB_DALIV2PhilipsQueryMainsVoltage | Liest die Hauptspannung aus.
FB_DALIV2PhilipsQueryTimeout | Liest die Auszeit aus.
FB_DALIV2PhilipsQueryUICByte | Liest das ein Byte der UIC aus.
FB_DALIV2PhilipsSetDTRAsSegmentAddress | Speichert die Daten, die im Data Transfer Register (DTR) gehalten werden in das Segment Address Register.
FB_DALIV2PhilipsSetTestMode | Setzt das Vorschaltgerät in den Testmodus.
FB_DALIV2PhilipsStoreDTRAsLampType | Speichert die Daten im Data Transfer Register (DTR) als Lampentyp.
FB_DALIV2PhilipsStoreDTRAsOvertempLevel | Speichert die Daten im Data Transfer Register (DTR) als Übertemperatur Schwellwert.
FB_DALIV2PhilipsStoreDTRAsSegmentAddress | Speichert die Daten im Data Transfer Register (DTR) als Segment Address Register.
FB_DALIV2PhilipsStoreDTRAsTimeout | Speichert die Daten im Data Transfer Register (DTR) als Auszeit.

Hinweis: Diese Befehle gehören zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 2 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 2 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Endladungsleuchten intern automatisch vorangestellt.


Interior Automations propritärer PIR Sensor - Einführung

Die Firma Interior Automation hat eigene DALI-Befehle für PIR Sensoren definiert. Diese Befehle gehen über die Möglichkeiten der DALI-Befehle nach Norm IEC 62386 hinaus. Für eine genauere Beschreibung der Befehle wenden Sie sich bitte an die Firma Interior Automation.


Interior Automations propritärer PIR Sensor - Funktionsbausteine

Name | Beschreibung
FB_DALIV2IAPIRPhysicalIndicatorOff | Deaktiviert die rote LED.
FB_DALIV2IAPIRPhysicalIndicatorOn | Aktiviert die rote LED.
FB_DALIV2IAPIRQueryExtendedVersion | Liest die Software Versionsnummer aus.
FB_DALIV2IAPIRQueryFlags | Liest die Eigenschaften aus.
FB_DALIV2IAPIRQuerySensitivity | Liest die Sensorempfindlichkeit aus.
FB_DALIV2IAPIRQueryTimeout | Liest die Auszeit aus.
FB_DALIV2IAPIRStartIdentification | Lässt die grüne LED 10 Sekunden blinken.
FB_DALIV2IAPIRStoreDTRAsFlags | Speichert die Daten im Data Transfer Register (DTR) als Eigenschaften.
FB_DALIV2IAPIRStoreDTRAsSensitivity | Speichert die Daten im Data Transfer Register (DTR) als Sensorempfindlichkeit.
FB_DALIV2IAPIRStoreDTRAsTimeout | Speichert die Daten im Data Transfer Register (DTR) als Auszeit.

Hinweis: Diese Befehle gehören zu den anwendungsbezogenen Erweiterungsbefehlen für DALI-Geräte. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type 128 vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type 128 allen anwendungsbezogenen Erweiterungsbefehlen für DALI-Geräte intern automatisch vorangestellt.


FB_DALIV2QueryExtendedVersionNumber

Die Variable EXTENDED VERSION NUMBER (erweiterte Versionsnummer) wird aus dem Vorschaltgerät ausgelesen.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type intern automatisch vorangestellt. Welcher Device Type aktiviert werden soll, kann am Eingang nDeviceType eingestellt werden.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nDeviceType       : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nDeviceType: Kennung für den Gerätetyp (siehe Tabelle unter FB_DALIV2EnableDeviceType()).

VAR_OUTPUT

bBusy                  : BOOL;
bError                 : BOOL;
nErrorId               : UDINT;
nExtendedVersionNumber : BYTE;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

nExtendedVersionNumber: erweiterte Versionsnummer des Vorschaltgerätes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


FB_DALIV2StartIdentification

Es wird eine 10-Sekündige Erkennungsprozedur des Vorschaltgerätes gestartet. Das Verhalten wird durch dem Hersteller festgelegt. In der Regel wird die Lampe nach einem bestimmten Muster ein- und ausgeschaltet.

Hinweis: Dieser Befehl gehört zu den anwendungsbezogenen Erweiterungsbefehlen. Diese funktionieren nur dann, wenn ihnen der Befehl Enable Device Type vorangeht, welcher mit dem Funktionsblock FB_DALIV2EnableDeviceType() gesendet werden kann. Ab Version 2.6.0 der Bibliotheken TcDALIV2 und TcDALIV2AppExtCmds jedoch wird der Befehl Enable Device Type intern automatisch vorangestellt. Welcher Device Type aktiviert werden soll, kann am Eingang nDeviceType eingestellt werden.

VAR_INPUT

bStart            : BOOL;
nAddr             : BYTE;
eAddrType         : E_DALIV2AddrType := eDALIV2AddrTypeShort;
eCommandPriority  : E_DALIV2CommandPriority := eDALIV2CommandPriorityMiddle;
nDeviceType       : BYTE;

bStart: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert.

nAddr: Adresse eines Teilnehmers oder einer Gruppe.

eAddrType: Kurzadresse, Gruppenadresse oder Sammelruf (Broadcast).

eCommandPriority: Priorität (hoch, mittel oder niedrig), mit der der Befehl von der Library abgearbeitet wird.

nDeviceType: Kennung für den Gerätetyp (siehe Tabelle unter FB_DALIV2EnableDeviceType()).

VAR_OUTPUT

bBusy        : BOOL;
bError       : BOOL;
nErrorId     : UDINT;

bBusy: Bei der Aktivierung des Bausteins wird der Ausgang gesetzt und bleibt so lange aktiv bis der Befehl abgearbeitet wurde.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in nErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt. Siehe Fehlercodes.

VAR_IN_OUT

stCommandBuffer : ST_DALIV2CommandBuffer;

stCommandBuffer: Verweis auf die Struktur zur Kommunikation (Puffer) mit dem FB_DALIV2Communication()-Baustein.


Fehlercodes

Wert (hex) | Wert (dez) | Beschreibung
0x0000 | 0 | kein Fehler.
0x0001 | 1 | keine Antwort von der DALI-Klemme.
0x0002 | 2 | keine Antwort von dem DALI-Vorschaltgerät.
0x0003 | 3 | Überlauf Kommunikationspuffer.
0x0004 | 4 | keine Antwort von dem Kommunikationsbaustein.
0x0005 | 5 | DALI-Kollision auf dem Rückkanal (Backward Channel) erkannt: während der Übertragung eines DALI-Telegramms wurde eine Kollision mit den Sendedaten eines anderen DALI-Slaves erkannt.
0x0006 | 6 | DALI-Kollision auf dem Hinkanal (Foreward Channel) erkannt: während der Übertragung eines DALI-Telegramms wurde eine Kollision mit den Sendedaten eines anderen DALI-Masters erkannt. Der Fehler tritt ebenfalls auf, sobald die 24V an den Powerkontakten der KL6811 fehlen.
0x0007 | 7 | bei Nutzung des internen DALI-Netzteils der KL6811: Überlastung des internen DALI-Netzteils der KL6811 (Busunterspannung).
0x0008 | 8 | Parameter eCommandPriority liegt außerhalb des gültigen Bereichs.
0x0009 | 9 | Parameter eAddrType liegt außerhalb des gültigen Bereichs.
0x000A | 10 | Parameter nAddr ist eine Kurzadresse und liegt außerhalb des gültigen Bereichs.
0x000B | 11 | Parameter nAddr ist eine Gruppenadresse und liegt außerhalb des gültigen Bereichs.
0x000C | 12 | Parameter nGroup liegt außerhalb des gültigen Bereichs.
0x000D | 13 | Parameter nScene liegt außerhalb des gültigen Bereichs.
0x000E | 14 | Parameter nStartWithShortAddress liegt außerhalb des gültigen Bereichs.
0x000F | 15 | keine weiteren freien Kurzadressen.
0x0010 | 16 | Parameter nNewShortAddress liegt außerhalb des gültigen Bereichs.
0x0011 | 17 | Parameter nShortAddress01 liegt außerhalb des gültigen Bereichs.
0x0012 | 18 | Parameter nShortAddress02 liegt außerhalb des gültigen Bereichs.
0x0013 | 19 | Parameter nFreeShortAddress liegt außerhalb des gültigen Bereichs.
0x0014 | 20 | Die Kurzadresse im Parameter nFreeShortAddress ist innerhalb der DALI-Linie belegt.
0x0015 | 21 | Parameter arrSwapShortAddressList enthält ungültige Werte.
0x0016 | 22 | Parameter nHysteresis liegt außerhalb des gültigen Bereichs.
0x0017 | 23 | Parameter nProlongValue ist außerhalb des gültigen Bereiches.
0x0018 | 24 | Lampenwert des Master-Device ist zu lange 255 -> möglicher Defekt.
0x0019 | 25 | Parameter nEndLevel ist außerhalb des gültigen Bereiches.
0x001A | 26 | Zielwert nEndLevel ist nach doppelter Rampenzeit noch nicht erreicht worden.
0x001B | 27 | FB_DALIV2LightControl: In der Wertetabelle arrControlTable existieren Sollwerte (nSetpoint), die außerhalb des gültigen DALI-Bereiches liegen (0..254).
0x001C | 28 | FB_DALIV2LightControl: Die Switchrange (nSwitchRange) im ersten oder zweiten Element der Wertetabelle arrControlTable ist 0. Damit wird davon ausgegangen, dass die Tabelle keinen oder nur einen Wertesatz hat.
0x001D | 29 | FB_DALIV2LightControl: 2 benachbarte Eingangswerte nActualValue in der Wertetabelle arrControlTable liegen zu dicht beieinander d.h. im Schaltbereich des anderen.
0x001E | 30 | FB_DALIV2LightControl: Ein Sollwert (nSetpoint) der Wertetabelle arrControlTable liegt außerhalb des gültigen Bereiches. Wird nur nach bStart abgefragt.
0x001F | 31 | Interne Statusabfrage des Master-Gerätes liefert nach der Dimmzeit noch zu lange "Stufung aktiv". Siehe STATUS INFORMATION (Bit 4).
0x0020 | 32 | Parameter nPresenceValue ist außerhalb des gültigen Bereiches.
0x0021 | 33 | Zeitüberschreitung bei der internen Adressierung (siehe auch FB_DALIV2AddressingIntRandomAddressing()). Die Klemme hat, nach dem Starten der interen Adressierung, keine Antwort zurückgeliefert.
0x0022 | 34 | Bei der internen Adressierung (siehe auch FB_DALIV2AddressingIntRandomAddressing()) hat die Klemme einen Fehler zurückgeliefert.
0x0023 | 35 | Mindestens ein Test läuft gerade oder steht automatisch bevor.
0x0024 | 36 | Das Gerät befindet sich im Automatik-Test-Modus.
0x0025 | 37 | Die Batterien des Notlicht-Gerätes sind für einen Dauertest nicht vollständig aufgeladen.
0x0026 | 38 | Test unterbrochen - Kein gültiger Emergency-Modus / Emergency-Status.
0x0027 | 39 | Test unterbrochen: Test-modus wurde nicht erreicht.
0x0028 | 40 | Test wegen Timeout-Überschreitung unterbrochen.
0x0029 | 41 | Fehler bei der Abarbeitung eines DALI-Kommandos.
0x002A | 42 | Fehler beim Schreiben in die Log-Datei.
0x002B | 43 | Gerät ist nicht im "normal-mode".
0x002C | 44 | FB_DALIV2Sequencer: Der Startindex nStartIndex ist außerhalb des gültigen Bereiches [1..50].
0x002D | 45 | FB_DALIV2Sequencer: Der Startindex nStartIndex verweist auf eine Stelle, die ihrerseits ein Sequenzende (Nulleinträge) markiert.
0x002E | 45 | FB_DALIV2ChangeAddressList: Die Änderungsliste arrChangeAddressList ist leer.
0x002F | 46 | FB_DALIV2ChangeAddressList: Die Änderungsliste arrChangeAddressList enthält einen ungültigen Kurz-Adressen-Eintrag (>63).
0x0030 | 47 | FB_DALIV2ChangeAddressList: Die Änderungsliste arrChangeAddressList enthält einen doppelten Listeneintrag bei den Kurz-Adressen.
0x0031 | 48 | FB_DALIV2ChangeAddressList: Die Änderungsliste arrChangeAddressList enthält einen Eintrag für eine neue Kurzadresse, die jedoch schon für ein Gerät vergeben ist, welches nicht von den Änderungen betroffen ist. Die Adressen wurden zurück-geändert.


E_DALIV2AddrType

TYPE E_DALIV2AddrType :
(
    eDALIV2AddrTypeShort      := 0,
    eDALIV2AddrTypeGroup      := 1,
    eDALIV2AddrTypeBroadcast  := 2
);
END_TYPE


E_DALIV2CommandPriority

TYPE E_DALIV2CommandPriority :
(
    eDALIV2CommandPriorityHigh    := 0,
    eDALIV2CommandPriorityMiddle  := 1,
    eDALIV2CommandPriorityLow     := 2
);
END_TYPE


E_DALIV2CurrentAddressingState

TYPE E_DALIV2CurrentAddressingState :
(
    eDALIV2AddrStateIdle           := 0,
    eDALIV2AddrStateRemoveLamp     := 1,
    eDALIV2AddrStateReinsertLamp   := 2,
    eDALIV2AddrStateAddressingLamp := 3
);
END_TYPE


ST_DALIV2ChangeAddressList

STRUCT
    nOldAddress           : BYTE;
    nNewAddress           : BYTE;
    nRandomAddressHigh    : BYTE;
    nRandomAddressMiddle  : BYTE;
    nRandomAddressLow     : BYTE;
    nErrors               : DWORD;
END_STRUCT


ST_DALIV2ControlTable

STRUCT
    nActualValue    : UINT;
    nControlValue   : BYTE;
    nSwitchRange    : UINT;
END_STRUCT

nActualValue: Gemessener Helligkeitswert.

nControlValue: Zugehöriger Umschaltpunkt/Stützpunkt für die Stellgröße. Gültiger Wertebereich: 0 oder nMinLevelMasterDev ... nMaxLevelMasterDev.

nSwitchRange: Schwellwert um die Stützstelle, bei der umgeschaltet wird. Der Eintrag "0" kennzeichnet den Anfang des nicht genutzten Bereiches der Tabelle.


ST_DALIV2DeviceSettings

STRUCT
    nErrors              : DWORD;
    bPresent             : BOOL;
    nActualLevel         : BYTE;
    nPowerOnLevel        : BYTE;
    nSystemFailureLevel  : BYTE;
    nMinLevel            : BYTE;
    nMaxLevel            : BYTE;
    nFadeRate            : BYTE;
    nFadeTime            : BYTE;
    nRandomAddress       : DWORD;
    nGroups              : WORD;
    nSceneLevels         : ARRAY [0..15] OF BYTE;
    nStatus              : BYTE;
    nMajorVersion        : BYTE;
    nMinorVersion        : BYTE;
    nDeviceType          : BYTE;
    nPhysicalMinLevel    : BYTE;
END_STRUCT


ST_DALIV2DeviceSettingsType01

STRUCT
    nErrors                     : DWORD;
    bPresent                    : BOOL;
    nBatteryCharge              : UINT;    (*0..254, 255->Error*)
    tDurationTestResult         : TIME;    (*0..510 min*)
    tLampEmergencyTime          : TIME;    (*0..255 h*)
    tLampTotalOperationTime     : TIME;    (*0..1024 h*)
    nEmergencyLevel             : BYTE;    (*0..254*)
    nEmergencyMinLevel          : BYTE;    (*0..254*)
    nEmergencyMaxLevel          : BYTE;    (*0..254*)
    tRatedDuration              : TIME;    (*0..510 min*)
    nNextFunctionTest           : UINT;    (*0..255*)
    nNextDurationTest           : UINT;    (*0..255*)
    nFunctionTestInterval       : UINT;    (*0..255*)
    nDurationTestInterval       : UINT;    (*0..255*)
    nTestExecutionTimeout       : UINT;    (*0..255*)
    nProlongTime                : UINT;    (*0..255*)
    nEmergencyMode              : BYTE;
    nFeatures                   : BYTE;
    nFailureStatus              : BYTE;
    nEmergencyStatus            : BYTE;
END_STRUCT

Anmerkung: Folgende Variablen erfahren beim Auslesen eine Anpassung an ihren Ziel-Darstellungsbereich, also abweichend von der Auslese-Darstellung des DALI-Gerätes:
tDurationTestResult : TIME; (*0..510 min*)
tLampEmergencyTime : TIME; (*0..255 h*)
tLampTotalOperationTime : TIME; (*0..1024 h*)
tRatedDuration : TIME; (*0..510 min*)

Bei den übrigen Variabeln macht die Umrechnung entweder keinen Sinn (z.B. nEmergencyLevel) oder eine Darstellung ist nicht möglich, wie beispielsweise nNextDurationTest da der Bereich des Variablentyps TIME nicht ausreicht.


ST_DALIV2InData

STRUCT
    nStatus  : BYTE;
    nDummy   : BYTE;
    nData    : WORD;
END_STRUCT


ST_DALIV2OutData

STRUCT
    nCtrl   : BYTE;
    nDummy  : BYTE;
    nData   : WORD;
END_STRUCT


ST_DALIV2SequenceTable

STRUCT
    nTargetValue        : BYTE;
    tRampTime           : TIME;
    tProlongTime        : TIME;
END_STRUCT

nTargetValue: Zielwert.

tRampTime: Zeit zum Erreichen des Zielwertes.

tProlongTime: Verweilzeit auf dem Zielwert.


ST_DALIV2SwapShortAddressList

STRUCT
    bShortAddressValid    : BOOL;
    nNewShortAddress      : BYTE;
END_STRUCT