Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Übersicht

Mit den SPS-Funktionen und -Funktionsbausteinen können Unterstationen (Slaves) nach der IEC 60870-5-104 Norm in TwinCAT SPS realisiert werden.

Die SPS-Bibliothek verfügt über zwei Software-Schnittstellen. Die Endapplikation setzt auf einer der Schnittstellen auf. Die Wahl der Schnittstelle hängt von den Anforderungen an die Endapplikation ab. Im Folgenden werden die Eigenschaften beider Schnittstellen kurz beschrieben.

"High level"-Schnittstelle: IEC 60870-5-104 Unterstation

Bei dieser Schnittstelle handelt es sich um eine sogenannte "Ein-Baustein-Lösung". Alle Funktionalitäten sind in einem SPS-Baustein gekapselt. Der Baustein implementiert die wichtigsten Dienste und Funktionen. Diese Implementierung ist für über 90% der Anwendungen ausreichend.

Pro: Sehr kleiner SPS-Programmieraufwand um eine laufende Applikation zu erhalten; Alle Dienste wie Generalabfrage, Zählerabfrage, Uhrzeitsynchronisation, Befehlsausführung, spontane Datenübertragung usw sind bereits in dem Baustein implementiert und werden automatisch ausgeführt; Das Mapping der IEC<->SPS Prozessdaten und das der Datenpunkte wird über Funktionsaufrufe konfiguriert; Der SPS-Programmierer muss nicht sehr gut mit der Protokollnorm vertraut sein;

Contra: Die SPS-Applikation hat nur einen geringen Einfluss auf die Protokollausführung; Kein Einfluss auf die Ausführung der Dienste, diese werden intern automatisch ausgeführt; Zeitstempel werden von dem Baustein automatisch generiert und können nicht verändert (von extern übergeben) werden; Es ist z.B. nur die direkte Befehlsausführung möglich; Schlechtere Performance bei vielen Datenpunkten.

Diese Schnittstelle empfiehlt sich wenn Sie:

  • Mit der Protokollnorm nicht vertraut sind;
  • Eine einfache Applikation mit einer handvoll Datenpunkten implementieren möchten (<1000);
  • Keine grossen Performace-Anforderungen an die Applikation stellen;
  • Keine besondere Befehlsausführung wie Select/Execute oder Daten + Zeistempel von externen Geräten versenden möchten;
  • Keine Funktionalitäten benötigen die laut Kompatibilitätsliste nicht unterstützt werden;

"Low level"-Schnittstelle: IEC 60870-5-104 Transport Interface

Diese Schnittstelle setzt bei dem Protokollstack tiefer an und ermöglicht das Versenden und/oder Empfangen einzelner Frames (ASDU's).

Pro: Sehr flexibel; Alle Eigenschaften im ASDU-Frame können manipuliert werden (z.B. ein eigener Zeitstempel, Select/Execute oder eine besondere Befehlsausführung usw); Weil nur die benötigten Dienste implementiert werden kann eine hohe Performance erreicht werden; Hohe Performace bei vielen Datenpunkten;

Contra: Grösserer Programmieraufwand; Alle Dienste wie Generalabfrage, Zählerabfrage, Uhrzeitsynchronisation, Befehlsausführung, spontane Datenübertragung usw. müssen von dem SPS-Programmierer selbst implementiert (ausprogrammiert) werden; Der SPS-Programmierer muss mit der Protokollnorm vertraut sein.

Diese Schnittstelle empfielt sich wenn Sie:

  • Mit der Protokollnorm vertraut sind;
  • Eine Protokollkonverter-Applikation implementieren möchten;
  • In der Applikation die verfügbaren Norm-Funktionalitäten fast vollständig implementieren müssen;
  • Besondere Funktionalitäten wie z.B. das weiterleiten der Zeitstempel von einem Modbusgerät oder die Kontrolle über die Befehlsausführung haben möchten;
  • Funktionalitäten benötigen die laut Kompatibilitätsliste nicht unterstützt werden;
  • Viele Datenpunte haben (>1000) und eine hohe Performace benötigen;

Kompatibilitätsliste

für TwinCAT SPS Bibliothek: IEC 60870-5-104 Unterstation (bezieht sich auf die "High level"-Schnittstelle). Hier können Sie die Kompatibilitätsliste öffnen/abspeichern (gezipptes PDF).

Systemvoraussetzungen

  • Programmierumgebung:
    • Windows NT (XP, XPe/WES, Vista, W7, WES7, ...);
    • TwinCAT Installation Level: TwinCAT PLC oder höher;
    • TwinCAT System Version 2.9.0 Build >= 1030 (CX (ARM) Build >= 1301) oder höher;
  • Zielplattform:
    • Industrie PC oder Embedded PC/CX (x86, ARM);
    • Betriebssystem:
      • Windows NT (XP, XPe/WES, Vista, W7, WES7, ...);
      • Windows CE (x86) (image v1.75 oder höher);
      • Windows CE (ARM) (image v2.13 oder höher);
    • TwinCAT SPS-Laufzeitsystem Version 2.9.0 oder höher;

Produktkomponenten

  • TcIEC870_5_104Slave.Lib (implementiert die Beckhoff IEC60870-5-104 Unterstation). Diese Bibliothek muss in dem SPS-Projekt eingebunden werden. Alle anderen Bibliotheken werden automatisch hinzugefügt.
  • TcIEC870_5_104.Lib (implementiert das Übertragungsprotokoll nach der IEC60870-5-104 Norm);
  • TcIEC870_5_101.Lib (implementiert die Verbindungsfunktionen und gemeinsame Datentypen );
  • TcSocketHelper.Lib (TCP/IP Hilfsfunktionen);
  • TcpIp.Lib (TCP/IP Basisfunktionen);
  • TwinCAT TCP/IP Connection Server;

Installation

Windows NT (XP, XPe/WES, Vista, W7, WES7, ...)

Die SPS-Bibliotheken werden während der Installation in den ..\TwinCAT\Plc\Lib-Ordner hineinkopiert. Der TwinCAT TCP/IP Connection Server wird in die Liste der TwinCAT Server eingetragen. Beim TwinCAT Start wird der TCP/IP Connection Server automatisch gestartet und beim TwinCAT Stop gestoppt.

Windows CE

Produktversion für das Laufzeitsystem unter Windows CE ist als separates Produkt verfügbar. Führen Sie folgende Schritte aus wenn Sie eine Produktversion für Windows CE erworben haben:

  • Installieren Sie das Produkt zuerst wie gewohnt auf Ihrem Programmier-PC. Die SPS-Bibliotheken werden während der Installation in den ..\TwinCAT\Plc\Lib-Ordner hineinkopiert.
  • X86 CPU (CX1000, CX1020, IPC):
    • Nach der Installation finden Sie im Ordner: ...\TwinCAT\CE\TCPIP\Install\ ein Cabinet-File für das CE-Laufzeitsystem.
    • Kopieren Sie die darin befindliche Datei: TcTCPIPSvrCe.I586.CAB in einen Ordner auf dem CE-Laufzeitsystem.
  • ARM CPU (CX9000), TwinCAT PLC Library: IEC 60870-5-104 Unterstation (slave) v2.0.4 und höher:
    • Nach der Installation finden Sie im Ordner: ...\TwinCAT\CE\TCPIP\Install\ ein Cabinet-File für das CE-Laufzeitsystem.
    • Kopieren Sie die darin befindliche Datei: TcTCPIPSvrCe.ARMV4I.CAB in einen Ordner auf dem CE-Laufzeitsystem.
  • Auf dem CE-System: Installieren Sie (durch einen Doppelklick auf das das Cabinet-File) die CE-Komponenten.
  • Rebooten Sie das CE-Gerät. Der TwinCAT TCP/IP Connection Server wird mit dem CE-Betriebssystem automatisch gestartet.

Hinweis: Dies ist nur eine kurze Produktinformation (kein vollständiges Handbuch). Bitte installieren Sie sich die vollständige Ausgabe des Beckhoff Information System.

Sie finden es

  • auf sämtlichen Beckhoff-Produkt-DVDs
  • auf unserem FTP-Server: http://download.beckhoff.com/download/Software/TwinCAT/InfoSystem/All/Install/InfoSys.exe
  • auf unserem Web-Server http://www.beckhoff.com

Beispiele

Beispiele befinden sich in der Beckhoff Information System Dokumentation der SPS-Bibliotheken.

Link zu "High level" Beispiel-Übersichtsseite: IEC 60870-5-104 Unterstation;

Link zu "Low level" Beispiel-Übersichtsseite: IEC 60870-5-104 Transport Interface;

Weiterführende Dokumentation

  • Dokumentation zur TwinCAT PLC Library ("High level"-Schnittstelle): IEC 60870-5-104 Unterstation;
  • Dokumentation zur TwinCAT PLC Library ("Low level"-Schnittstelle): IEC 60870-5-104 Transport Interface;
  • Dokumentation zur TwinCAT PLC Library: IEC 60870-5-101 Common Data Types;
  • Dokumentation: TwinCAT TCP/IP Connection Server;
  • IEC 60870-5-1 Transmisstion frame formats;
  • IEC 60870-5-2 Link transmission procedures;
  • IEC 60870-5-3 General structure of application data;
  • IEC 60870-5-4 Definition and coding of application information elements;
  • IEC 60870-5-5 Basic application functions;
  • IEC 60870-5-101 Companion Standard for basic telecontrol tasks;
  • IEC 60870-5-101:1995/A1:2000 Companion Standard for basic telecontrol tasks. Amendment 1;
  • IEC 60870-5-101:1995/A2:2001 Companion Standard for basic telecontrol tasks. Amendment 2;
  • IEC 60870-5-104:2000 Network access for IEC 60870-5-101 using standard transport profiles;