Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Übersicht

TS1800-0030 | TwinCAT PLC HMI CE

Überblick

Das TwinCAT PLC HMI CE ist ein System zur Ausführung von Visualisierungen auf BECKHOFF CE basierenden Steuerungen, die mit dem TwinCAT Programmiersystem erstellt wurden.

Wenn ein Steuerungsprogramm entsprechende Visualisierungen enthält, werden diese nach dem Start von der TwinCAT Steuerungssoftware automatisch im Vollbildmodus dargestellt und der Benutzer kann darüber per Mausklick oder Tastatur die im zugrunde liegenden Projekt enthaltenen Steuer- und Überwachungsfunktionen bedienen. Dies ist auch möglich, wenn die TwinCAT PLC Projektdatei mit einem Leseschutz versehen ist. Der Anwender hat keine Möglichkeit, das Steuerungsprogramm zu editieren, Menüs und Funktionsleisten stehen nicht zur Verfügung, es handelt sich um eine reine 'Bedienung' der enthaltenen Visualisierungselemente.

Die wesentlichen Steuer- und Überwachungsfunktionen in einem Projekt müssen also beim Erstellen eines für die Bedienversion vorgesehenen Projektes auf Visualisierungselemente gelegt werden und damit im Online Modus bedient werden.

Hierzu gibt es spezielle Eingabemöglichkeiten im Konfigurationsdialog eines Visualisierungselements.

Durch die nahtlose Integration in TwinCAT PLC Control bietet die Visualisierung mit TwinCAT PLC HMI CE folgende Vorteile:

• Es kann direkt mit den TwinCAT PLC Control Variablen des Steuerungsprogramms gearbeitet werden.

• Die Verwendung von Ausdrücken in der Visualisierungskonfiguration ist möglich (z.B. „Variable1+ Variable2" "12 + 5")

• Ein Platzhalterkonzept ermöglicht objektorientiertes Arbeiten.


Installation, Start und Bedienung

1. Allgemein

  • Das BECKHOFF Produkt "TwinCAT PLC HMI CE" ist ein Visualisierungspaket für Beckhoff Steuerungen basierend auf dem Betriebssystem CE.
  • Das Produkt "TwinCAT PLC HMI CE" kann vorinstalliert auf den CE Geräten bei Beckhoff bestellt werden.

2. Produktbeschreibung

Eine ausführliche Beschreibung der Funktionalität finden Sie unter TwinCAT PLC Control, "Visualisierung"

3. Voraussetzung

"TwinCAT PLC HMI CE" benötigt

  • ein BECKHOFF-CE Gerät mit mindestens 128 MB RAM.
  • ein BECKHOFF-CE basierendes Image ab Version 1.90.
  • auf dem CE-Gerät mindestens den TwinCAT-Level "PLC"
  • Um Benutzer Interfaces zu erstellen ist TwinCAT V2.10 Build 1242 (oder höher) auf dem Host-PC erforderlich.

4. Lizenz

Das Produkt "TwinCAT PLC HMI CE" ist nicht kostenlos - es wird eine Lizenz pro CPU benötigt.

4.1 Vorinstalliert auf dem CE Gerät / Lizenz

Bei entsprechender Bestellung ist die "TwinCAT PLC HMI CE" Lösung bereits vorinstalliert auf dem CE Gerät verfügbar und bereits lizensiert.

4.2 Installation der TwinCAT PLC HMI CE

Nach Installation der Software "TwinCAT PLC HMI CE" auf Ihrem Host-PC müssen Sie die Datei "..\TwinCAT\CE\TwinCAT_PLC_HMI_CE\*.cab" per Compact Flash Adapter , FTP-Server oder per Public Folder auf das CE Gerät kopieren.

Wenn sich die Installationsdatei "TwinCAT_PLC_HMI_CE.xxxx.CAB" auf dem CE Gerät befindet, kann sie mit einem Doppelklick ausgeführt werden.

WICHTIG:

  • Zielplattform X86: Für X86 basierende Geräte muss die Datei "TwinCAT_PLC_HMI_CE.I586.CAB" auf dem Zielgerät installiert werden
  • Zielplattform ARM: Für ARM basierende Geräte (z.B. CX9xxx, CP6608 ..) muss die Datei "TwinCAT_PLC_HMI_CE.ARM.CAB" auf dem Zielgerät installiert werden

HINWEIS:

  • Als Zielpfad muss der vorgewählte (default) Pfad "\hard disk" mit "OK" bestätigt werden!
  • Nach Bestätigung mit "OK" wird die Installation im Zielordner ausgeführt:

  • Nach der Installation der Komponente in den korrekten Zielordner "\hard disk" wird die Installationsdatei TwinCAT_PLC_HMI_CE.xxxx.CAB automatisch entfernt.

  • Beenden Sie das CE Gerät einmalig nach der Installation per "Start-> Suspend". Erst dann werden die Einstellungen in der Registry auf die Compact Flash des CE Geräts gesichert.
  • Die Konfiguration der Targt Visu kann in TwinCAT PLC Control vorgenommen werden.

5. Konfiguration

Die Konfiguration "TwinCAT PLC HMI CE" erfolgt in TwinCAT PLC Control.

Nach der Erstellung der User Interface Bildschirme im PLC Control muss der Download zum Geräte einmalig aktiviert werden.
Die Aktivierung erfolgt im TwinCAT PLC Control: Wählen Sie Menü "Projekt" , "Optionen..." die Kategorie "TwinCAT" und "Enable CE Target Visualization".

HINWEIS:: Die "TwinCAT PLC HMI CE" Visualisierung ist nicht kostenlos. Es wird eine Lizenz pro CPU benötigt.

Die Bildschirmauflösung in folgender Datei definiert: "C:\TwinCAT\PLC\TwinCAT PLC Control.ini"

[TwinCAT PLC Control]
VisuWidth=640
VisuHeight=480


Feature Overview

TS1800 | TwinCAT PLC HMI

Feature Übersicht der Visualisierung mit TwinCAT

Die folgende Tabelle gibt einen Überblick über die einzelnen Möglichkeiten der Visualisierung mit TwinCAT

 | PLC Control | PLC HMI | PLC HMI Web | PLC HMI CE | Comment
Current test version: | Build 1010 | 2.10.0.900 | 1.0.0.7 | 1.0.9.10 | Ab TwinCAT 2.10 Build 1334
Rectangle |  |  |  |  |
Rounded rectangle |  |  |  |  |
Ellipse |  |  |  |  |
Polygon |  |  |  |  |
Curve |  |  |  |  |
Pie |  |  |  |  |
Bitmap |  |  |  |  |
Visualisation |  |  |  |  |
Button |  |  |  |  |
WMF/JPG File |  |  |  |  |
Table |  |  |  |  |
ActiveX element |  |  |  |  |
Trend |  |  |  | / | HMI CE: Only online trend is available
Alarm table |  |  |  |  |
Meter |  |  |  |  |
Bar display |  |  |  |  |
Histogram |  |  |  |  |
Invisible elements |  |  |  |  |
Change color |  |  |  |  |
Background bitmap |  |  |  |  |
Button background |  |  |  |  |
Tooltip |  |  |  |  | HMI CE: Elements not too near to the edge or tooltip is outside the window
Security |  |  |  |  |
Placeholder |  |  | / | / | Web/HMI CE: Zoom to visu with placeholders in the zoom command is not possible
Print function |  |  |  |  |
Password change |  |  |  |  |
Change user level |  |  |  |  |
Language dialog |  |  |  |  |
Language automatic change |  |  |  |  |
Exit |  |  |  |  |
Trace |  |  |  |  |
Text input 'Text' |  |  |  |  | Web: Please don't exceed the maximum string length of your variable HMI CE: The hidden function is not supported
Text input 'Numpad' |  |  |  |  | HMI CE: The hidden function is not supported
Text input 'Keypad' |  |  |  |  | Web: Please don't exceed the maximum string length of your variable HMI CE: The hidden function is not supported

Restrictions


Einschränkungen

Interne Befehle

PRINT
Dieser Befehl zum Ausdrucken der aktuellen Visualisierung kann für die Target-Visualisierung nicht verwendet werden.

EXITPROGRAM
Dieser Befehl zum Beenden des Programms kann für die Target-Visualisierung nicht verwendet werden.

TRACE
Dieser Befehl zum Öffnen des Fensters zur Traceaufzeichnung kann für die Target-Visualisierung nicht verwendet werden.

SAVEPROJECT
Dieser Befehl zum Speichern des Projekts kann für die Target-Visualisierung nicht verwendet werden.

Grafikformate

Innerhalb der Target-Visualisierung werden zur Zeit nur einfache Bitmaps unterstützt. Noch nicht unterstützt werden die Formate .jpg, .tif, .ico. Unterstützung für das Format .jpg ist ab der Version 1.0.9 der TargetVisu DLL verfügbar.

Sonstiges

Slider in Tabelle
Der Slider für das Scrollen kann gegenwärtig nicht angezeigt werden.

Texte
 Clipping Texte, die über die Grenzen des Elementes hinaus reichen, werden gegenwärtig noch nicht abgeschnitten

Alarmbehandlung
Das Alarming wird derzeit von der Target-Visualisierung nicht unterstützt.

Trend
Die Target-Visualisierung unterstützt ab der Version 1.0.8 den Online-Trend (ohne History).

Platzhalter
Die Übergabe von Parametern zur Ersetzung von Platzhaltern beim Aufruf wird von der Target-Visualisierung nicht unterstützt.
Beispiel:
<Visuname>(<Platzhalter1>:=<Text1>, <Platzhalter2>:=<Text2>,..., <Platzhalter n>:=<Textn>)

VAR_IN_OUT
VAR_IN_OUT Variablen können in der TwinCAT HMI CE nicht verwendet werden.

Visu-Seite
Wenn eine Visu-Seite mit der HMI CE angezeigt werden soll, sollte sie speziell für diese Form der Visualisierung entwickelt werden. Dies ist nötig da Scroll Bars zur Zeit in der HMI CE nicht unterstützt werden.