Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Überblick

Dieses Dokument bietet eine Übersicht über Funktion, Struktur und Bedienung des Engineering Interface (ENI).

Weiterführende Dokumente sind:

- ENI Server Quickstart – Übersicht und Erste Schritte

- Online Hilfe zu ENI Server, ENI Admin, ENI Control (Bestandteile der ENI Server Suite) und ENI Explorer

- TwinCAT PLC Control Handbuch bzw. Online Hilfe zur TwinCAT Version 2.9


Engineering Interface (ENI)

Funktion des ENI

Das ENI (TwinCAT Engineering Interface) dient dazu, die Bausteine (Objekte) eines TwinCAT PLC Projekts in einem zentralen eigenständigen Datenablagesystem zu verwalten, das anderen Benutzern und Applikationen ebenfalls zugänglich ist.

Damit werden folgende Anforderungen bezüglich der Datenverwaltung während der Erstellung eines Automatisierungsprojektes erfüllt:

Zugriff verschiedener Applikationen auf dieselben Projektdaten:

Neben dem Programmiersystem können auch andere Tools, die über die ENI-Schnittstelle verfügen, auf eine gemeinsame Datenbank zugreifen. Beispielsweise externe Visualisierungen, ECAD-Systeme etc., die die im TwinCAT PLC Control erzeugten Daten benötigen oder selbst Daten erzeugen, die andererseits im Programmiersystem benötigt werden.

Mehrbenutzerbetrieb:

Die aktuelle Version der Bausteine eines Projekts kann einer ganzen Gruppe von Anwendern zugänglich gemacht werden. Die von einem Benutzer ausgecheckten Bausteine sind für die anderen Benutzer als 'in Bearbeitung' markiert und nicht veränderbar. Somit können mehrere Anwender parallel am gleichen Projekt arbeiten, ohne gegenseitig Objektversionen zu überschreiben.

Versionsverwaltung für Projekte und zugehörige Ressourcen (gemeinsam genutzte Objekte):

Wurde ein Objekt aus der Datenbank ausgecheckt, modifiziert und wieder eingecheckt, wird in der Datenbank eine neue Version des Objekts erzeugt, die alten Versionen bleiben jedoch erhalten und können bei Bedarf ebenfalls wieder abgerufen werden. Für jedes Objekt und für ein gesamtes Projekt wird die Änderungshistorie aufgezeichnet. Versionen können auf Unterschiede geprüft werden.

Struktur und Kommunikation

Das ENI bedient ein Datenablagesystem für Projektdatenobjekte. Bei diesem kann es sich um ein bereits bestehendes Datenbanksystem oder lokales Dateisystem handeln. Damit das Ablagesystem auch auf einem anderen Rechner liegen kann (sonst wäre kein Mehrbenutzerbetrieb möglich), ist die ENI-Schnittstelle in einen Server- und einen Client-Teil aufgetrennt.

ENI Server

Der Engineering Interface Server läuft als separater Dienst. Als Protokoll zur Kommunikation wird HTTP mit XML als Nutzdaten verwendet. Die Verwaltung und Kontrolle des Servers erfolgt über die Programme 'ENI Admin' und 'ENI Control'. (ENI Server, ENI Admin und ENI Control sind Bestandteile der ENI Server Suite.)

ENI Client

Die Clients des ENI Servers sind beispielsweise ein TwinCAT PLC Control Programmiersystem, aber auch andere Applikationen, die auf die Datenablage zugreifen müssen. Alle Clients sind gleichberechtigt.

Verbindung zwischen ENI Server und Datenbanksystem (DB)

Das ENI definiert kein eigenes Ablageformat. Die Anbindung an ein bestehendes Datenhaltungssystem erfolgt über entsprechende Treiber (Database Interface). Verfügbar sind Treiber für die Datenbanksysteme 'Visual SourceSafe 5.0', 'Visual SourceSafe 6.0', 'Tortoise SVN' und ein lokales Dateisystem. Für die Anbindung an andere bestehende Ablagesysteme kann dem Anwender ein ENI Driver Development Kit zur Verfügung gestellt werden.

Welches Datenablagesystem ein ENI Server aktuell bedient, wird in ENI Control festgelegt. Die Clients des Servers können dann auf genau dieses System zugreifen.

HTTP als Kommunikationsprotokoll, XML für die Übertragung

Beim Datenaustausch mit dem ENI-Server kommen das HTTP-Protokoll und das allgemein akzeptierte Standard-Format XML zum Einsatz. Das HTTP-Protokoll ermöglicht ein Arbeiten durch Firewalls hindurch und das Durchführen bestimmter Operationen mittels Standard-Tools.

Es gibt eine Client-C++ DLL (Client Interface), mit deren Hilfe das Protokoll in C++-Klassen gekapselt werden kann, so daß nicht zwingendermaßen nur HTTP- und XML-Software für den Zugriff auf den ENI Server einsetzbar ist.


Struktur im Datenablagesystem (ENI Explorer)

Der ENI Server verwaltet die Bausteine, die vom PLC Control oder anderen Clients erzeugt wurden, im Dateiablagesystem in einer Ordnerstruktur. Sie werden dort als Objekte gehalten, die durch einen Typ und Zugriffsrechte gekennzeichnet sind. Außerdem wird, falls von der Datenbank unterstützt, für jedes Objekt eine Versionshistorie geführt. Innerhalb eines Ordners müssen Objekte durch Name und Typ eineindeutig sein.

ENI Explorer

Der ENI Explorer existiert analog zum Explorer unter Windows als eigenständiges Programm, das über die entsprechenden ENI-Zugangsdaten mit dem gewünschten ENI Server verbunden werden kann. Es ist wie ENI Server, ENI Admin und ENI Control Bestandteil der ENI Server Suite. Unabhängig vom verwendeten Datenhaltungssystem und vom TwinCAT PLC Control kann die Ordner/Objekt-Struktur, die im ENI vorliegt, im ENI Explorer dargestellt werden und die gewünschten Datenbankfunktionen können direkt dort aufgerufen werden. Auch Objekttyp, Zugriffsrechte und aktueller Auscheck-Status und Benutzer werden angezeigt.

Integration in das TwinCAT PLC Control

Das TwinCAT PLC Control ist ein möglicher Client des ENI Servers. Für jedes Projekt kann die Verbindung zum ENI Server definiert werden und danach die gewünschten Bausteine des Projekts als Objekte im Datenhaltungssystem angelegt werden. Dazu werden sie einer der drei vorgesehenen Objektkategorien zugeordnet. Die Objektablage ist vollständig, das heißt neben dem Bausteininhalt werden auch die Bausteineigenschaften wie z.B. Zugriffsrechte im XML-Format übertragen. Ein automatisierter Austausch mit dem Datenhaltungssystem kann für jede Objektkategorie definiert werden.

XML-Format für die Objekte

Das folgende Beispiel zeigt die Darstellung eines Bausteins im XML-Format. Enthalten sind z.B. die Angaben zu: Bausteinname (<name>), Bausteintyp (<pou>), Pfad des Bausteins in der Object Organizer Struktur (<path>), Zugriffsrechte für die acht möglichen Arbeitsgruppen (<accesslevels>), sowie der Bausteininhalt im Deklarationsteil (<interface>) und Programmteil, der in diesem Fall in Strukturiertem Text erstellt ist (<st>,<body>).

<?xml version="1.0"
encoding="ISO-8859-1"?>
<pou>
    <accesslevels> rw,rw,r,rw,r,rw,rw,rw
</accesslevels>
    <path> \/Sprachen </path>
    <name> ST_EXAMPLE </name>
    <flags> 4 </flags>
    <interface>
        <![CDATA[PROGRAM ST_EXAMPLE
        VAR
            YVAL: INT := -250;
            BOTTOM: INT := -250;
            RUN_STRING: STRING(20) := 'Start';
            OFFSET: INT := 2;
        END_VAR
        ]]>
        </interface>
        <st>
            <body>
                <![CDATA[RUN_STRING:='Start';
                IF (YVAL < 0) THEN
                    YVAL := YVAL + OFFSET;
                    BOTTOM := YVAL + OFFSET;
                END_IF
                ]]>
            </body>
        </st>
</pou>

Kategorien für ENI Objekte

Bezüglich der Verwaltung über die ENI-Schnittstelle werden verschiedene Kategorien von Datenobjekten unterschieden:

  1. Projektspezifische Objekte: Bausteine, die speziell für ein bestimmtes Projekt erstellt wurden.
  2. Gemeinsame Objekte: Bausteine, die üblicherweise in mehreren Projekten verwendet werden, z.B. Bausteinbibliotheken.
  3. Automatisch erzeugte Übersetzungsobjekte: Daten, die erst während der Verarbeitung durch eine Applikation entstehen z.B.Symboldateien, die beim Kompilieren eines Projekts erzeugt werden (entsprechen also nicht direkt einem Objekt !)
  4. Lokale Objekte (werden nicht im Datenablagesystem verwaltet)

Die Zuordnung eines Objekts zu einer der Kategorien 1,2 oder 4 erfolgt in den Projektoptionen (automatisiert) bzw. Objekteigenschaften (individuell).

Die ENI-Parameter können für jede der Objekt-Kategorien 1-3 getrennt konfiguriert werden.

Struktur des Projekts im Datenablagesystem

Für ein Projekt wird im angebundenen Datenablagesystem und damit "im ENI" unter der "root", die im ENI Control konfiguriert wurde, ein oder mehrere Pfade angelegt, Ordner, in denen die Projektbausteine als Objekte dargestellt werden (beispielsweise könnte für jede ENI-Objekt-Kategorie ein eigener Ordner definiert werden).

Jedes Projektobjekt erhält einen Datentyp. Dies wirkt sich so aus, daß die aus dem TwinCAT PLC Control übernommenen Bausteinnamen eine typspezifische Erweiterung und ein Typen-Symbol erhalten und damit die Objekte außerhalb des Programmiersystems darstellen.

Bedienung der ENI-Schnittstelle im TwinCAT PLC Control

Im TwinCAT PLC Control kann das ENI als Projektoption aktiviert werden. Daraufhin stehen Dialoge für die folgenden Funktionen zur Verfügung:

  1. Festlegung in den Projektoptionen, ob und zu welcher ENI-Objektkategorie ein neu angelegtes Objekt zugeordnet werden soll.
  2. Konfiguration der Art der Verbindung zum ENI in den Projektoptionen für jede der drei ENI-Objekt-Kategorien (Projektobjekte, Gemeinsame Objekte, Übersetzungsdateien):
  • Zugangsdaten: Port; Zugriffsrechte; Projekt in der ENI-Ablage, mit dem das aktuelle Projekt verbunden wird)
  • Festlegung, welcher Austausch mit dem Datenablagesystem wann und wie automatisch ablaufen sollen (z.B. Abrufen der Objekte aus der Datenbank immer beim Öffnen eines Projekts oder Auschecken bei jeder begonnenen Änderung etc.)
  3. Individuelle Zuordnung eines Objekts zu einer Objektkategorie (siehe oben) in den Objekteigenschaften jeden Objekts
  4. Eingabe von Benutzername und Passwort über einen Datenbank-Login-Dialog (Projekt-Menü, ) für den Zugang zum Datenhaltungssystem
  5. Datenbankbefehle im Projekt-Menü, für einzelne Objekte bzw. für das ganze Projekt:
  • Abrufen / Alles Abrufen
  • Auschecken / Alles Auschecken
  • Einchecken / Alles Einchecken
  • Auschecken rückgängig / ... für alle Objekte
  • Versionsgeschichte für Objekt bzw. Projekt
  • Änderungen anzeigen
  • Version Labeln
  • Gemeinsame Objekte (aus dem Datenbanksystem ins lokale Projekt) einfügen
  • Status auffrischen


ENI Admin und ENI Control

Bestimmte Einstellungen können nur lokal am ENI Server vorgenommen werden. Hierzu stehen die Programme 'ENI Admin' und 'ENI Control' zur Verfügung. Sie werden wie ENI Server und ENI Explorer mit der ENI Server Suite installiert, die durch ein Icon in der Systemleiste Ihres Computers angezeigt wird.

ENI Admin (ENIAdmin.exe) erfordert zum Start die Eingabe des Administrator-Passworts. Hier werden Benutzer, Benutzergruppen, Zugriffsrechte und das Administratorpasswort definiert, hier erfolgt die Lizenzverwaltung und eine Anzeige der Objektdatentypen.

ENI Control (ENIService.exe) verlangt beim Start ebenfalls das ENI Administrator Passwort. Es dient zum Einstellen des gewünschten Datenbanktreibers und wird hierzu bereits während der Installation über das Setup benützt. Außerdem bietet es die Möglichkeit, den ENI Service, der normalerweise automatisch gestartet wird, gezielt zu stoppen und neu zu starten sowie ihn über ein anderes Benutzerkonto laufen zu lassen. Zusätzlich können bestimmte Kommunikationsparameter (Kommunikations-Timeout, Port etc.) der Server-Client-Verbindung verändert werden. Auch eine Ereignisanzeige (Event Log) steht zur Verfügung.


Übersicht: Quickstart und erste Schritte

Dieses Dokument bietet einen Kurzüberblick über die ENI Funktionalität und eine Anleitung zur Installation und Erstkonfiguration des ENI Servers im Hinblick auf die Anbindung eines TwinCAT PLC Control Projekts an eine Datenbank. Mit dem ENI Server werden auch die zu dessen Verwaltung benötigten Programme ENI Admin und ENI Control sowie der ENI Explorer installiert.

ENI - Kurzüberblick

Das ENI ist das ENgineering Interface des TwinCAT PLC Controls. Es besteht aus einem Server und einem Client-Teil.

Der ENI Server läuft als separater Service. Typische Clients sind ein oder mehrere Programmiersysteme und andere Tools, die auf dieselben Sourcen zugreifen wollen, die in einem gemeinsamen Datenablagesystem (DB) verwaltet werden. Bezüglich der Arbeit mit dem PLC Control ermöglicht dies eine Versionsverwaltung für Projekte, den Mehrbenutzerbetrieb und den Zugriff auf die Projekt-Objekte durch externe Programme.

Die unterstützten Datenbanksysteme

Das Server Konzept ermöglicht es, eine gemeinsame Datenbank auf einen entfernten Rechner zu legen. Standardmäßig unterstützt der ENI Server bisher ein lokales Dateisystem und die Datenbanksysteme 'Visual SourceSafe 5.0', 'Visual SourceSafe 6.0' und 'Tortoise SVN'.

Es gibt jedoch die Möglichkeit, den ENI Server auch auf andere Datenbanksysteme anzupassen. Die entsprechende Beschreibung finden Sie im ENI Driver Development Kit — Programmer's Guide (nicht Bestandteil dieser Dokumentation).

Die Kommunikation mit dem ENI Server

Als Client-Server-Protokoll wird TCP/IP verwendet. Sehen Sie ausführliche Information zur Kommunikation in den Dokumenten

- ENI Client Development Kit – Programmers Guide (nicht Bestandteil dieser Dokumentation)

- ENI Driver Development Kit XML-Format für ENI Objekte (nicht Bestandteil dieser Dokumentation).

ENI im TwinCAT PLC Control:

Die Verwendung des ENI im TwinCAT PLC Control ist optional. Weitere Informationen zu dieser Projektoption entnehmen Sie bitte dem Benutzerhandbuch zum TwinCAT PLC Control der Version 2.9.

Installation und Start:

Die Installation des ENI Servers erfolgt mit dem Setup. Nach der Installation und bei jedem Rechner-Neustart wird die Verfügbarkeit des ENI Servers durch ein Icon in der Systemleiste angezeigt und der ENI Server Service wird automatisch gestartet. Solange der ENI Server läuft, leuchtet das Icon.

Administration

Die Verwaltung des ENI Servers erfolgt über die Programme ENI Control und ENI Admin: Mit ENI Control werden grundlegende Server-Einstellungen vorgenommen, die im laufenden Betrieb nicht geändert werden können, z.B. Datenbankverbindung, Kommunikationseinstellungen u.ä. Außerdem kann der ENI Server hiermit gestartet und beendet werden. Mit ENI Admin können im laufenden Betrieb Benutzer, Gruppen und Zugriffsrechte konfiguriert, sowie Funktionen zum Lizenzmanagement ausgeführt werden.

Die ENI Programme können sowohl über das Start-Menü wie auch über ein an das ENI Icon gekoppeltes Menü geöffnet werden. Letzteres erscheint, wenn mit der rechten Maustaste auf das Icon in der System-Leiste (Sys-Tray, rechts unten) geklickt wird. Hier finden Sie auch die 'Event Log' Ereignisanzeige, die ansonsten auch aus ENI Control gestartet werden kann.

QuickStart

Vorbereitungen

  1. Installieren Sie die Datenbank, die über den ENI Service bedient werden soll, gemäß der dort beiliegenden Installationsanleitung. Idealerweise liegt die Datenbank auf dem selben Rechner wie der ENI Server.
  2. Starten Sie die Datenbank.
  3. Datenbank anlegen
  • Datenbank 'Lokales Dateisystem': Legen Sie ein neues leeres Verzeichnis an.

Anmerkungen vor der Installation

Betriebsmodus und Lizenz:

  • 'Server' Modus: Eine Lizenz ist erforderlich und lizenzabhängig stehen die entsprechenden Standard-Datenbanktreiber zur Verfügung. Der Server kann von jedem beliebigen Rechner im Netzwerk angesprochen werden. Neben der Tool-Kooperation dient dies der verteilten Entwicklung.

Die Verbindung zwischen Client und ENI Server erfordert TCP/IP.

Administratorrechte auf dem Rechner sind erforderlich.

Im Verlauf der Installation werden Sie nach einem ENI Administrator-Passwort gefragt. Bei der Erstinstallation kann diese Abfrage ohne Eingabe mit OK bestätigt werden.

Die Installation beinhaltet auch die Installation der Programme ENI Admin und ENI Control, die der Verwaltung und Handhabung des ENI dienen. Zusätzlich wird das Programm ENI Explorer mit installiert.

Installation

  1. Legen Sie die Installations-CD ein.
  2. Bereits während der Installation wird das Programm ENI Control zur Einstellung der Datenbankverbindung aufgerufen: Dabei erscheint zunächst der Dialog 'Enter Administrator Password'. Falls es sich um eine Erstinstallation handelt, wird er ohne Eingabe eines Passworts mit OK geschlossen, falls das ENI Control bereits vorher installiert war, muss das gültige Administrator-Passwort eingegeben werden. Daraufhin öffnet sich der Dialog 'Database', in dem der Anwender wie im folgenden beschrieben, den Treiber für das gewünschte Datenhaltungssystem und den "Root"-Pfad für die Objektablage in der gewählten Datenbank einstellen kann.

Name | Beschreibung
Select Database Driver Im Auswahlfeld neben 'Select Database Driver' finden Sie alle installierten Treiber. Sollte der gewünschte Treiber in der Liste nicht vorhanden sein, klicken Sie auf die erste Schaltfläche neben der Liste und wählen die entsprechende Treiberdatei auf dem Rechner aus. Die verfügbaren Treiber hängen von der installierten ENI-Lizenz ab. Die lizenzfreie Version der ENI Server Suite enthält nur den Treiber für ein lokales Dateisystem. Folgende Treiberdateien sind derzeit lizenzabhängig verfügbar:
  • "File System Driver" (ENIDrvFileSystem.edd, lokales Dateisystem)
  • "SourceSafe 5.0" (ENIDrvSourceSafe5.edd)
  • "SourceSafe 6.0" /ENIDrvSourceSafe6.edd)
  • "Tortoise SVN" (ENIDrvSVN.edd)
Location of 'srcsafe.ini' | nur für 'Visual SourceSafe 5.0' bzw. '..6.0': Stellen Sie den Pfad der ini-Datei des SourceSafe ein. Diese liegt im Installationsverzeichnis des SourceSafe. Sie können zum Einstellen des Pfads einen Browse-Dialog zu Hilfe nehmen, der durch einen Doppelklick auf das Eingabefeld geöffnet wird.
Root project Geben Sie hier den Pfad des Projekts an, der hier für die Datenbank angelegt wurde,

- für 'File System Driver': z.B. "D:\project1\...."

- für 'Visual SourceSafe 5.0' bzw. '..6.0': z.B. "$/project1".

Unterhalb dieses Verzeichnisses können später durch die entsprechende Definition in den TwinCAT PLC Control Projektoptionen ein oder mehrere Verzeichnisse angelegt werden, in denen die zu verwaltenden Objekte gehalten werden. Alternativ ist es auch möglich, die Verzeichnisse vorab direkt in der Datenbank anzulegen. In diesem Fall stehen Sie dann bei der Konfiguration bereits zur Auswahl.
ENI user | Ein spezielles Benutzerkonto, das vom ENI Server für interne Aufgaben verwendet wird. Dieses Konto muss in der Benutzerverwaltung der Datenbank angelegt sein.
ENI password | Das Passwort zu dem eben genannten Benutzerkonto.

Schließen Sie den Dialog mit OK.

  3. Nun startet die Installationsroutine den ENI Server. Im Erfolgsfall erhalten Sie die Möglichkeit, mittels ENI Admin eine Benutzerkonfiguration anzulegen: Per Default ist bereits ein Konto vordefiniert: Sie finden in der Spalte 'User Name' dazu den Eintrag "DefaultUser".

Bitte beachten Sie zur Benutzerdefinition folgendes:

  • Wenn im ENI Admin ein Benutzerkonto angelegt wird, muss, um es verwenden zu können, auch in der Datenbank ein entsprechendes Konto (mit identischem Namen und Passwort) existieren. Bei Visual SourceSafe beispielsweise benutzen Sie zur Benutzerverwaltung Visual SourceSafe Admin.
  • Jedes Benutzerkonto sollte einer Gruppe zugeordnet sein. Selektieren Sie hierzu die gewünschte Gruppe, klicken Sie auf 'Edit' und fügen Sie die betreffenden Benutzerkonten zur Gruppe hinzu.
  4. Durch Schließen von ENI Admin wird die Installationsroutine beendet; ENI Server sollte nun auf Ihrem System automatisch gestartet und einsatzbereit sein. In diesem Fall wird in ENI Control der 'Current Status' Running angezeigt, das ENI Icon in der Systemleiste leuchtet..

Start

  • Nach erfolgreicher Installation und später bei jedem Rechner-Neustart wird der ENI Server Dienst automatisch gestartet, das ENI Icon in der Systemleiste beginnt zu leuchten.
  • ENI Control bzw. ENI Admin müssen explizit gestartet werden, können jedoch nicht gleichzeitig laufen. Diese Programme erscheinen nach der Installation im ENI Server Start-Menü, sind jedoch auch über das Menü verfügbar, das sich öffnet, wenn mit der rechten Maustaste auf das ENI-Icon in der Systemleiste geklickt wird.

Anbindung eines TwinCAT PLC Control Projekts

Anbindung eines Projekts an den ENI Server:

1. Starten Sie das TwinCAT PLC Control und öffnen Sie ein beliebiges Projekt.

2. - Wählen Sie den Befehl 'Projekt' 'Optionen' 'Projektdatenbank'.

  • Aktivieren Sie die Option 'Projektdatenbank (ENI) verwenden'.
  • Klicken Sie auf 'ENI konfigurieren...'.
  • Konfigurieren Sie in der Kategorie 'Projektobjekte' die ENI Verbindung wie folgt:
Name | Beschreibung
TCP/IP-Adresse | Adresse des Rechners, auf dem ENI Server installiert ist; z.B. "localhost"
Port | Nummer des Ports, auf dem ENI Server hört. Default: 80
Projektname | Name bzw. Pfad des Projekts, wie er in der Datenbank unterhalb dem in ENI Control bei Datenbankanbindung unter Root eingegebenen Pfad erscheinen soll (z.B. "project1\projektobjekte" -> erscheint dann beispielsweise im Visual SourceSafe unter $/project1/projektobjekte, wenn als Root "$/" definiert wurde.)

Belassen Sie die restlichen Einstellungen unverändert.

3. Klicken Sie auf 'Weiter' und machen Sie für dieses Einführungsbeispiel in den Kategorien 'Gemeinsame Objekte und 'Übersetzungsdateien' identische Angaben wie unter 'Projektobjekte'.

4. Schließen Sie die Optionsdialoge mit OK. Sie werden gebeten, sich beim ENI Server einzuloggen: Geben Sie Name und Passwort eines gültigen Benutzerkontos an.

5. Zum jetzigen Zeitpunkt ist zwar das Projekt mit der Datenbank verbunden, die Bausteine selbst sind jedoch noch "lokal". Um sie in die Datenbank zu übertragen, wählen Sie den Befehl 'Projekt' 'Datenbankverknüpfung' 'Mehrfach festlegen' und wählen Sie im Dialog Objekteigenschaften die Datenbankoption 'Projekt'. Selektieren Sie in dem erscheinenden Baum alle Bausteine, die Sie in die Datenbank stellen möchten, und bestätigen Sie mit OK:

6. Nun sind die ausgewählten Bausteine über die im Optionsdialog 'Projektobjekte' konfigurierte Verbindung mit der Datenbank verbunden. Für diese Bausteine stehen nun alle typischen Datenbankfunktionen im Kontextmenü zur Verfügung.


Datenbank: Tortoise SVN

Installation:

Download: Tortoise SVN, Version: 1.5.9

Einstellungen ENI Control:

Der Treiber wird während der Installation in den Standard-Pfad C:\Program Files\Beckhoff\TwinCAT ENI Server\Drivers kopiert.

Communication Einstellungen

Führen Sie ENIControl.exe aus, klicken auf den Karteireiter „Communication“ und nehmen die Einstellungen wie in Bild 1 gezeigt vor.

Bild 1: Communication-Einstellungen in ENI Control

Einstellungen Datenbank

Führen Sie ENIControl.exe aus, klicken auf den Karteireiter „Database“, suchen nach ENIDrvSVN.edd und installieren den Treiber, der in den oben erwähnten Pfad kopiert wurde. Bevor Sie mit den Einstellungen fortfahren sollten Sie ein SVN-Repository erstellen.

Bild 2: Lokale Repository-Einstellungen in ENI Control.

Repository-Einstellungen:

Der Begriff Subversion Repository bezeichnet eine Sequenz von Ordnerstrukturen. Jede Struktur ist ein Schnappschuss der Dateien und Verzeichnisse in Ihrem Repository zu einem bestimmten Zeitpunkt. Diese Schnappschüsse sind das Ergebnis von Client-Operationen und werden Revisionen genannt.

Es gibt zwei Möglichkeiten, Daten in SVN-Repositories abzulegen. Anders gesagt können zwei Arten von Repositories angelegt werden:

  1. Native Filesystem (FSFS)
  2. Berkeley Datenbank (BDB)

Repository Anlegen:

  1. Öffnen Sie den Windows Explorer
  2. Erzeugen Sie einen neuen Ordner und nennen ihn z.B. SVNRepository
  3. Klicken Sie mit der rechten Maustaste auf den neu erstellten Ordner und wählen TortoiseSVN -> Create Repository here… (Repository hier erstellen)
    Jetzt wird im neuen Ordner ein Repository erstellt. Diese Dateien dürfen nicht editiert werden!!!. Sollten Fehler auftreten, stellen Sie sicher, dass der Ordner leer und nicht schreibgeschützt ist.
  4. Beim Anlegen kann man zwischen den beiden oben erwähnten Arten der Subversion-Datenbank wählen.

Bild 3: Repository Anlegen

Lokaler Zugriff auf das Repository:

Für den Zugriff auf Ihr lokales Repository benötigen Sie den Pfad zu diesem Order. Die Subversion muss alle Repository-Pfade in der Form file:///C:/SVNRepository/ vorfinden. Es sind durchgängig Slashes zu verwenden. (Beispiel: Bild 2)

Für den Zugriff auf ein Repository in einem gemeinsamen Netzwerk können Sie entweder ein drive mapping ausführen oder den UNC-Pfad nutzen. UNC-Pfade werden in der Form file://ServerName/path/to/repos/ angegeben. Hier müssen nur 2 Slashes an Anfang eingegeben werden. (Beispiel: Bild 4).

Bild 4. Repository auf einem anderen Netzwerk-PC

Achtung

In einem gemeinsamen Netzwerk darf ein Berkeley DB Repository weder erstellt noch auf ein solches Repository zugegriffen werden. Es kann nur lokal existieren. Es funktioniert auch nicht, wenn Sie das Netzwerklaufwerk auf einen Laufwerkbuchstaben mappen. Wenn Sie eine Berkeley DB in einem gemeinsamen Netzwerk nutzen, sind die Ergebnisse unberechenbar. Es können sofort mysteriöse Fehlern auftreten oder Sie merken erst nach Monaten, dass Ihre Repository Datenbank subtil zerstört wurde.

Tip:

Wenn Sie in einem gemeinsamen Netzwerk auf ein Repository zugreifen müssen, erstellen Sie das Repository im Format fsfs (Native Filesystem). Wenn Sie auch einen Zugriff zum Server bereitstellen müssen, benötigen Sie Subversion Server 1.1 oder höher.