Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemein

Die Fliegende Säge (Parallel-Slave-Achse) ist eine Slave-Achse, die auf eine fahrende Master-Achse an einer bestimmten Position – parallel zur Master-Achse fahrend - geschwindigkeitsmäßig auf die Mastergeschwindigkeit aufsynchronisiert wird. Unterstellt ist dabei, dass bei Kopplung der Slave-Achse an die Master-Achse die Master-Achse mit (konstanter) Sollgeschwindigkeit fährt und dass die Slave-Achse in ihrer Grundposition (Koppelposition) steht. Die Slave-Achse startet automatisch, wenn die Master-Achse die dynamische Koppelposition erreicht hat. Verwirklicht ist das Ganze teils als Streckensteuerung (Slave-Beschleunigungs-Phase (ruckbegrenzt) und Slave Parallel-Fahrt), sowie teils zeitgesteuert (Slave-Verzögerungs-Phase (ruckbegrenzt) und Slave Stillstand).

Die Fliegende Diagonal-Säge (Diagonal-Slave-Achse) ist eine Slave-Achse, die schräg (mit konstantem Winkel) zu einer Master-Achse auf die fahrende Master-Achse an einer gegebenen Position so geschwindigkeitsmäßig aufsynchronisiert, dass die Geschwindigkeitskomponente der Slave-Achse in Richtung der Mastergeschwindigkeit nach der Synchronisation gleich der Mastergeschwindigkeit ist.

Interfaces

Die Interfaces bestehen aus dem System Manager, SPS-Bausteinen und dem zyklischen NC-SPS-Achs-Interface.

Ablauf

Der Ablauf besteht aus den Phasen

  1. Logisches Ankoppeln an die Master-Achse (die Slave-Achse bleibt stehen).
  2. Dynamisches Ankoppeln an die Master-Achse: Beschleunigungsphase.
  3. Parallelfahrt zur Master-Achse.
  4. Stop: Dynamisches Abkoppeln von der Master-Achse: Bremsphase.
  5. Stillstand.
  6. Logisches Abkoppeln.

Synchronbedingung

Die Synchronbedingung des ruckbegrenzten/linearen Beschleunigungsalgorithmus impliziert eine Zwangsbedingung zwischen den Koppelpositionen von Master und Slave sowie den Synchronpositionen von Master und Slave.

Start und Stop

Bei Achsstart wird nach Erreichen der dynamischen Koppelposition in jedem Aufruf der Satzausführungstask mittels der der Startparameter (Mastersynchronposition und Slavesynchronposition) und der generellen Dynamikparameter ein ruckbegrenztes Beschleunigungsprofil mit der aktuellen Mastergeschwindigkeit als Sollgeschwindigkeit generiert, das streckengesteuert zur Sollwertgenerierung der Slave-Achse dient.

Bei Stopp wird mit den generellen Dynamikdaten ein zeitgesteuertes Bremsprofil berechnet, die Slave-Achse dynamisch vom Master abgekoppelt und Über das Bremsprofil abgebremst.

Positions-Kompensation

On-line Positionskorrektur der Fliegenden Säge, bei der auf einer vorgegebenen Strecke die Slave-Achse um eine bestimmte Strecke mehr oder weniger verfahren wird, als der Kopplung an die Master-Achse entspricht. Die Dynamik der Kompensation muss parametriert werden. Ist die gewünschte Kompensation mit den gegebenen Kompensationsstartdaten nicht durchführbar, dann wird automatisch die maximal mögliche Kompensation durchgeführt. Die Kompensation kann über Stopp der Kompensation vorzeitig beendet werden. Die Kompensation sollte nur in der Synchronphase eingesetzt werden.

Achtung:

Falls die Kompensationsdifferenz D negativ ist (Verzögern) sein, ist eine (doppelte) Bewegungsumkehr möglich.

Fliegende Diagonal-Säge

Ist v die aktuelle Sollgeschwindigkeit der Parallelslave-Achse, dann ist die Geschwindigkeit der Diagonalslave-Achse v/sin(θ), wobei θ, 0.0° < θ ≤ 90.0°, den Komplementärwinkel zwischen Masterrichtung und Slaverichtung bezeichnet.

Fliegende Säge und fliegende Diagonal-Säge auf Geschwindigkeit

Die Fliegende Säge auf Geschwindigkeit (Parallel-Slave-Achse) ist eine Slave-Achse, die auf eine fahrende Master-Achse, parallel zur Master-Achse fahrend, maximal schnell geschwindigkeitsmäßig auf die Mastergeschwindigkeit aufsynchronisiert wird. Unterstellt ist dabei, daß bei Kopplung der Slave-Achse an die Master-Achse die Master-Achse mit (konstanter) Sollgeschwindigkeit fährt und dass die Slave-Achse in ihrer Grundposition (Koppelposition) steht. Verwirklicht ist das Ganze teils als Streckensteuerung (Slave-Beschleunigungs-Phase (ruckbegrenzt) und Slave Parallel-Fahrt), sowie teils zeitgesteuert (Slave-Verzögerungs-Phase (ruckbegrenzt) und Slave Stillstand).

Die Fliegende Diagonal-Säge auf Geschwindigkeit (Diagonal-Slave-Achse) ist eine Slave-Achse, die schräg (mit konstantem Winkel) zu einer Master-Achse auf die fahrende Master-Achse so schnell wie möglich so geschwindigkeitsmäßig aufsynchronisiert, dass die Geschwindigkeitskomponente der Slave-Achse in Richtung der Mastergeschwindigkeit nach der Synchronisation gleich der Mastergeschwindigkeit ist.

Fliegende Säge mit Online Umwandlung in Master PTP Achse

Dieser vielseitigste Slave-Typ wird als Fliegende Säge gestartet und koppelt am Synchronpunkt auf die Geschwindigkeit der Masterachse auf, kann dann in der Synchronphase per Positionskompensation erneut ortsmäßig synchronisiert werden und schließlich in der Sychronphase on-line vom Master abgekoppelt werden und selber in eine PTP Masterachse umgewandelt werden, die dann entweder kräftefrei gemacht wird, oder auf ein bei bei der Ankoppelinstruktion oder der Abkoppelinstruktion mitgegebenes Geschwindigkeitsniveau als Endlosachse weiterfährt und letztendlich per Instruktion 'Neue Endposition' auf ihre endgültige Zielposition fährt.


Interfaces

Der Benutzer kann die fliegende Säge über den System Manager oder SPS-Bausteine bedienen. Außerdem steht ihm (im System Manager und über die SPS) ein zyklisches NC-SPS Achs-Interface zur Verfügung, das das Achs-Prozessabbild beinhaltet und Zugriff auf diverse Variablen ermöglicht.

PLC-Document

Es gibt eine besondere SPS-Dokumentation zur fliegenden Säge.

System Manager

Der System Manager bietet den Zugriff auf alle Funktionalitäten der fliegenden Säge:

  • Logisches Koppeln mit Angabe der Masterachse und Setzen der Synchronpositionen.
  • Stopp.

SPS-Bausteine

Die SPS Library bietet den Zugriff auf alle Slave-Achs Funktionalitäten :

  • Logisches Koppeln mit Angabe der Masterachse und Setzen der Synchronpositionen.
  • Stopp.

NC-SPS-Interface

Das zyklische NC-SPS Achs-Interface beinhaltet das Achs-Prozessabbild und insbesondere Zugriff auf die Koppelinformation (Koppelflag).


Ablauf

Der Ablauf besteht aus den Phasen

  1. Logisches Ankoppeln an die Master-Achse (die Slave-Achse bleibt stehen).
  2. Dynamisches Ankoppeln an die Master-Achse: Beschleunigungshase.
  3. Parallelfahrt zur Master-Achse.
  4. Stop: Dynamisches Abkoppeln von der Master-Achse: Bremsphase.
  5. Stillstand
  6. Logisches Abkoppeln.

Logisches Ankoppeln

Durch das (logische) Ankoppeln werden der Slave-Achse fast alle Funktionalitäten gesperrt. Die Achse steht in Grundposition und wartet darauf, dass die Master-Achse die dynamische Koppelposition überfährt.

Dynamisches Ankoppeln

Wenn die Master-Achse die dynamische Koppelposition überfährt startet die Slave-Achse automatisch. In jedem Aufruf der Satzausführungstask wird ein volles ruckbegrenztes Beschleunigungsprofil von Geschwindigkeit 0.0 auf die aktuelle Mastergeschwindigkeit berechnet. Der jeweils aktuelle Wert wird über eine Streckensteuerung als Sollwert der Slave-Achse übergeben.

Beschleunigungsphase

Die Beschleunigungsphase ist als Streckensteuerung ausgelegt. D.h. die Slave-Achse richtet sich sowohl geschwindigkeitsmäßig als auch positionsmäßig nach den aktuellen Daten der Master-Achse und folgt damit allen Geschwindigkeitsschwankungen und Bewegungsinversionen der Master-Achse. Wenn die Master-Achse ihre Synchronposition überfährt, hat auch die Slave-Achse ihre Synchronposition und damit die aktuelle Mastergeschwindigkeit erreicht und tritt in die Parallelphase ein.

Parallelphase

In der Parallelphase ist die fliegende Säge wie im Zustand einer linearen Slave-Achse affin (mit Koppelfaktor 1.0) an den Master gekoppelt.

Dynamisches Abkoppeln

Um die Parallelfahrt zu beenden wird der Slave vom Benutzer gestoppt. Dazu wird von dem aktuellen dynamischen Zustand (Beschleunigung, Geschwindigkeit) ein ruckbegrenztes zeitgesteuertes Dynamikprofil auf Geschwindigkeit 0.0 erzeugt, der Slave dynamisch vom Master entkoppelt und auf dem berechneten Dynamikprofil abgebremst.

Logisches Abkoppeln

Die Position an der der Slave zum Stillstand kommt, hängt neben der Geschwindigkeit wesentlich vom Beschleunigungszustand (im Augenblick des Aufrufs der Stop-Funktion) der Achse ab. Nach Stillstand kann die Slave-Achse von der Master-Achse abgekoppelt werden.

Das logische Abkoppeln ist jederzeit möglich, jedoch führt das Abkoppeln in Fahrt zu einem Schleppabstand.

Rücklaufsperre

In den streckengesteuerten Phasen (Beschleunigung, Parallelfahrt) ist die Slave-Achse so mit der Master-Achse synchronisiert, dass sie jeden Bewegungsrücklauf mitmacht. Um zu verhindern, dass bei einem weiten Rücklauf die Slave-Achse über ihre Grundposition (Halterung) zurückfährt gibt es eine Rücklaufsperre, die den Rücklauf über die Grundposition hinaus verhindert. Diese Sperre wirkt instantan (Schleppabstand). Wenn der Master in der ursprünglichen Richtung wieder über seine alte Koppelposition fährt, läuft der Slave automatisch instantan wieder an.

Ablauf: Masterstart, Slavestart, Aufsynchronisieren, Synchronphase, Slavestopp, Masterstopp.


Synchronbedingung

Die der fliegenden Säge zugrundeliegende Achs-Synchronisierung hängt entscheidend vom Beschleunigungsalgorithmus der Slave-Achse ab. Erläutert wird hier die Achs-Synchronbedingung für den ruckbegrenzten 3-Phasen Algorithmus. Der Synchronbedingung liegen folgende Achsvariablen zugrunde (zu beachten ist dabei, dass Master und Slave bei gleichen Einheiten i.A. verschiedene Koordinatensysteme haben):

  1. Slave-Synchronposition,
  2. Slave-Grundposition = logische Slave-Koppelposition = dynamische Slave-Koppelposition,
  3. Master-Synchronposition,
  4. logische Master-Koppelposition (Position der Master-Achse bei Master-Slave-Kopplung),
  5. dynamische Master-Koppelposition (Position der Master-Achse bei dynamischem Slave-Start).

Synchronbedingung des ruckbegrenzten Beschleunigungsalgorithmus

Die Slave-Achse braucht vom Anfangs-Zustand (Grundposition, Geschwindigkeit 0.0, Beschleunigung 0.0) zum End-Zustand (Synchronposition, Mastergeschwindigkeit, Masterbeschleunigung) eine bestimmte Zeit, in der die Master-Achse die Strecke von der dynamischen Master-Koppelposition bis zur Master-Synchronposition verfährt. D.h. von den vier Positionen (Slave-Synchronposition, Slave-Koppelposition, Master-Synchronposition, dynamische Master-Koppelposition) sind drei unabhängig und damit die vierte gegeben. Bei den zugrundeliegenden Algorithmen gilt für den Zusammenhang der Positionen:

|dynamischen Master-Koppelposition - Master-Synchronposition| = 2 × |Slave-Koppelposition - Slave-Synchronposition|.

Daraus folgt, dass der Abstand der dynamischen Master-Koppelposition bis zur Master-Synchronposition größer als zwei mal dem Abstand Slave-Koppelposition - Slave-Synchronposition sein muss. Bei Start werden die beiden Synchronpositionen explizit mitgegeben, die Slave-Koppelposition ist intern bekannt, so dass daraus die dynamische Master-Koppelposition berechnet werden kann. Ist die Synchronisierung nicht durchführbar, weil der Master schon zu nah an der Koppelposition steht, wird das Koppeln mit Fehler abgebrochen.

Synchronbedingung der Fliegenden Diagonalsäge.

Synchronbedingung: |0.0 - 1000.0| = 2.0 x |5000.0 - 1000.0|

Masterstart bei -1000.0 mm, Masterkoppelposition-logisch -200.0 mm, Masterkoppelposition-dynamisch 0.0 mm, Mastersynchronposition 1000.0 mm.

Slavewarteposition = Slavekoppelposition-logisch = Slvekoppelposition-dynamisch 500.0 mm, Slavesynchronposition = 1000.0 mm.

Es reicht aus wenn die Masterkoppelposition-logisch echt kleiner als die Masterkoppelposition-dynamisch ist.


Koppeln, Start und Stopp

Nach Erreichen der dynamischen Koppelposition wird in jedem Aufruf der Satzausführungstask mittels der der Startparameter (Mastersynchronposition und Slavesynchronposition) und der generellen Dynamikparameter ein ruckbegrenztes Beschleunigungsprofil mit der aktuellen Mastergeschwindigkeit als Sollgeschwindigkeit generiert das streckengesteuert zur Sollwertgenerierung der Slave-Achse dient.

Bei Stopp wird mit den generellen Dynamikdaten ein zeitgesteuertes Bremsprofil berechnet, die Slave-Achse dynamisch vom Master abgekoppelt und Über das Bremsprofil abgebremst.

Koppelparameter

P_ms (Master-Synchronposition im Master-Koordinatensystem)>

P_ss (Slave-Synchronposition im Slave-Koordinatensystem)

θ Diagonalwinkel

cf Koppelfaktor zur Mastergeschwindigkeit. Der Koppelfaktor darf die Richtung der Achse nicht umkehren.

interne Parameter: (P_sc Slave-Koppelposition, P_mcd dynamische Master-Koppelposition)

Es gibt keinen expliziten Start. Die Startdaten werden intern berechnet und der Start wird automatisch durchgeführt.

Startparameter

Startparameter | Bedeutung und Randbedingungen
Master-Synchronposition P_ms | Position an der sich der Master (in seinem Koordinatensystem) befinden soll, wenn der Slave aufsynchronisiert sein soll, |P_ms - P_mcd| = 2 × |P_ss - P_sc|
Slave-Synchronposition P_ss | Position an der sich der Slave (in seinem Koordinatensystem) befinden soll, wenn er auf den Master aufsynchronisiert sein soll, |P_ms - P_mcd| = 2 × |P_ss - P_sc|
Koppelfaktor cf | Koppelfaktor cf ≠ 0.0
Diagonalwinkel θ | Komplementärwinkel zwischen Masterrichtung und Slaverichtung, 0.0° < θ ≤ 90.0°, Parallelslave: θ = 90.0°

Interfaces

System Manager

SPS-Bausteine

Stopp

Der Stop hat höchste Priorität und muss in allen Dynamikphasen, bis auf die Stoppphase selber, funktionieren (nicht in der Vorphase und nicht in der Standphase). Der Stop funktioniert auch während eines eventuellen Rücklaufs. Dem 3-Phasenalgorithmus der Stoppdynamik wird dann eine Zusatzphase vorgeschaltet, wenn die Slave-Achse nicht beschleunigungsfrei ist und damit keine Bewegungsinversion impliziert ist. In dieser Zusatzphase fährt die Slave-Achse von der aktuellen Beschleunigung auf Beschleunigung 0.0.

Achtung: Der Stopp der fliegenden Säge darf zeitlich nicht länger andauern als die Positionierung der Masterachse ansonsten wird der Stopp abgebrochen.

Es gibt keine expliziten Stoppparameter. Diese (Verzögerung, Ruck) werden den globalen Dynamikdaten der Achse entnommen.

Interfaces

System Manager

SPS-Bausteine


Positionskompensation

On-line Positionskorrektur der Fliegenden Säge, bei der auf einer vorgegebenen Strecke die Slave-Achse um eine bestimmte Strecke mehr oder weniger verfahren wird, als der Kopplung an die Master-Achse entspricht. Die Dynamik der Kompensation muss parametriert werden. Ist die gewünschte Kompensation mit den gegebenen Kompensationsstartdaten nicht durchführbar, dann wird automatisch die maximal mögliche Kompensation durchgeführt. Die Kompensation kann über Stopp der Kompensation vorzeitig beendet werden. Die Kompensation sollte nur in der Synchronphase eingesetzt werden.

Achtung:

Falls die Kompensationsdifferenz D negativ ist (Verzögern) sein, ist eine (doppelte) Bewegungsumkehr möglich.

Generelle Hinweise

Die Positionskompensation von Slave-Achsen ist eine Variante der Positionskompensation von linearen Slave-Achsen.

Besonderheiten

  1. Die Kompensation sollte erst nach erfolgter Synchronisation (also nach Ende der Beschleunigungsphase) erfolgen.
  2. Die Kompensation sollte vor Einleitung der Bremsphase beendet sein.
  3. Die Kompensation berücksichtigt die Positionsdehnung bei der Diagonalsäge.

Masterdaten: Start von 1000.0 auf -10,000.0 mit Synchronposition -1000.0

Slavestartposition -500.0 mit Slavesynchronposition -1000.0

Kompensationsdaten: A± = 1000.0 mm/sec/sec, V = 500.0 mm/sec, VP = 2000.0 mm/sec, Kompensationsdifferenz ±200.0 mm, Kompensationslänge 2000.0 mm.


Fliegende Diagonal-Säge

Übersicht

Der fliegende Diagonalsäge (Diagonal-Slave) ist eine Slave-Achse, die schräg (mit konstantem Diagonalwinkel θ) zu einer Master-Achse auf die fahrende Master-Achse so geschwindigkeitsmäßig aufsynchronisiert, dass die Geschwindigkeitskomponente der Slave-Achse in Richtung der Mastergeschwindigkeit gleich der Mastergeschwindigkeit ist.

Geometrie: Diagonalwinkel θ

Sei v die aktuelle Sollgeschwindigkeit einer Parallelslave-Achse, dann ist die Geschwindigkeit der Diagonalslave-Achse v/sin(θ), wobei θ, 0.0° < θ ≤ 90.0°, den Komplementärwinkel zwischen Masterrichtung und Slaverichtung bezeichnet. In der Synchronphase ist daher die Slave-Achse mit dem Koppelfaktor 1/sin(θ) an die Master-Achse gekoppelt.

Diagonalsäge: Geometrie

Synchronbedingung des ruckbegrenzten/linearen diagonalen Beschleunigungsalgorithmus

Die Diagonal-Slave-Achse braucht vom Anfangs-Zustand (Grundposition, Geschwindigkeit 0.0, Beschleunigung 0.0) zum End-Zustand (Synchronposition, Mastergeschwindigkeit, Masterbeschleunigung) eine bestimmte Zeit in der die Master-Achse die Strecke von der dynamischen Master-Koppelposition bis zur Master-Synchronposition verfährt. Bei den zugrundeliegenden Algorithmen gilt:

|Slave-Koppelposition - Slave-Synchronposition| = 0.5 ×|dynamischen Master-Koppelposition - Master-Synchronposition| / sin(θ).

Daraus folgt, dass der Abstand der dynamischen Master-Koppelposition bis zur Master-Synchronposition größer als 2.0× sin(θ) mal dem Abstand Slave-Koppelposition - Slave-Synchronposition sein muss.

Dynamik

Die aktuelle Geschwindigkeit der Slave-Achse nach Erreichen der Parallelphase ist gleich 1.0/sin(θ) mal der aktuellen Geschwindigkeit der Masterachse. Diese Geschwindigkeit ist größer als die Geschwindigkeit der Master-Achse, da die Slave-Achse neben die Parallel-Komponente (Master-Geschwindigkeit) noch die Orthogonal-Komponente aufbringen muss.


Fliegende Säge und fliegende Diagonal-Säge auf Geschwindigkeit

Übersicht

Die Fliegende Säge auf Geschwindigkeit (Parallel-Slave-Achse) ist eine Slave-Achse, die auf eine fahrende Master-Achse, parallel zur Master-Achse fahrend, maximal schnell geschwindigkeitsmäßig auf die Mastergeschwindigkeit aufsynchronisiert wird. Unterstellt ist dabei, dass bei Kopplung der Slave-Achse an die Master-Achse die Master-Achse mit (konstanter) Sollgeschwindigkeit fährt und dass die Slave-Achse in ihrer Grundposition (Koppelposition) steht. Verwirklicht ist das Ganze teils als Streckensteuerung (Slave-Beschleunigungs-Phase (ruckbegrenzt) und Slave Parallel-Fahrt), sowie teils zeitgesteuert (Slave-Verzögerungs-Phase (ruckbegrenzt) und Slave Stillstand).

Die Fliegende Diagonal-Säge auf Geschwindigkeit (Diagonal-Slave-Achse) ist eine Slave-Achse, die schräg (mit konstantem Winkel) zu einer Master-Achse auf die fahrende Master-Achse so schnell wie möglich so geschwindigkeitsmäßig aufsynchronisiert, dass die Geschwindigkeitskomponente der Slave-Achse in Richtung der Mastergeschwindigkeit nach der Synchronisation gleich der Mastergeschwindigkeit ist.

Generelles

Bis auf die Art der Aufkopplung ist die Fliegende (Diagonal-) Säge auf Geschwindigkeit algorithmisch identisch mit der fliegenden (Diagonal-) Säge auf Position (und Geschwindigkeit). Die Richtung der Slaveachse ist dabei als Richtung der Masterachse festgelegt. Falls die Masterachse im Koppelzeitpunkt keine Richtung hat (z.B. eine EncoderAchse, die zufällig steht), wird das Koppeln abgebrochen.

Koppelparameter

θ Diagonalwinkel

Die weiteren Startdaten werden intern berechnet und der Start wird sofort automatisch durchgeführt.

Startparameter

Startparameter | Bedeutung und Randbedingungen
Diagonalwinkel θ | Komplementärwinkel zwischen Masterrichtung und Slaverichtung, 0.0° < θ ≤ 90.0°, Parallelslave: θ = 90.0°

Interfaces

System Manager

SPS-Bausteine

Die Slave-Achse koppelt fliegend so schnell wie möglich auf Geschwindigkeit auf.


Fliegende Säge mit Online Umwandlung in Master PTP Achse

Dieser vielseitigste Slave-Typ wird als Fliegende Säge gestartet und koppelt am Synchronpunkt auf die Geschwindigkeit der Masterachse auf, kann dann in der Synchronphase per Positionskompensation erneut ortsmäßig synchronisiert werden und schließlich in der Sychronphase on-line vom Master abgekoppelt werden und selber in eine PTP Masterachse umgewandelt werden, die dann kräftefrei gemacht wird und der dann alle Master-Funktionen zur Verfügung stehen..

Voraussetzungen

Logische Voraussetzung der Umwandlung ist die Bedingung, dass (i) die fliegende Säge als Parallelslave gestartet worden ist und dass (ii) die aktuelle Richtung der fliegenden Säge mit der logischen Richtung bei Start übereinstimmt. Dynamisch ist es ist am günstigsten die fliegende Säge in der Synchronphase umzuwandeln.

Dynamische Voraussetzung einer Umwandlung ist, dass die neuen Dynamikparameter so beschaffen sind, dass die neue Masterachse jederzeit gestoppt werden kann, sodass i.A. die neuen Dynamikparameter (diejenigen der neuen Masterachse) nicht schwächer sein dürfen als die alten Dynamikparameter (in der Synchronphase: diejenigen der alten Masterachse der fliegenden Säge; ansonsten: diejenigen der alten Masterachse der fliegenden Säge) multipliziert mit dem Koppelfaktor.

Physikalische Voraussetzung einer dynamisch glatten Umwandlung ist, dass die Geschwindigkeit der fliegenden Säge zum Zeitpunkt der Umwandlung nicht allzu sehr fluktuiert.

Zustand nach der Umwandlung

Nach der Umwandlung ist die fliegende Säge eine PTP-Masterachse mit voller Funktionalität. Die der Achse zum Zeitpunkt der Umwandlung mitgegebene Instruktion impliziert, dass nach der Umwandlung die Achse zuerst kräftefrei gemacht wird (also auf Beschleunigung 0 fährt), sodann die dabei erreichte Geschwindigkeit beibehält, per Definition Override 100% hat, und auf Zielposition ±∞ fährt, wobei die Richtung im Zeitpunkt der Umwandlung beibehalten wird.

Funktionalitäten nach der Umwandlung

Es stehen alle Masterfunktionen zur Verfügung: Override, Stop, Positionskompensation, 'Neue Endposition' und 'Neue Geschwindigkeit und neue Endposition'..

Startparameter

Startparameter | Bedeutung und Randbedingungen
Master-Synchronposition P_ms | Position an der sich der Master (in seinem Koordinatensystem) befinden soll, wenn der Slave aufsynchronisiert sein soll, |P_ms - P_mcd| = 2 × |P_ss - P_sc|
Slave-Synchronposition P_ss | Position an der sich der Slave (in seinem Koordinatensystem) befinden soll, wenn er auf den Master aufsynchronisiert sein soll, |P_ms - P_mcd| = 2 × |P_ss - P_sc|
Diagonalwinkel θ | Parallelslave: θ = 90.0°
Koppelfaktor cf | Koppelfaktor cf ≠ 0.0

Interfaces

System Manager

SPS-Bausteine


TwinCAT NC SLAVES Fliegende Säge

Übersicht

Allgemeines

PLC Library

Beispielprogramm


NC

Übersicht

Die TwinCAT NC ist die Zusammenfassung der Funktionsgruppen die der Steuerung und Reglung von Achsen oder synchronisierten Achsgruppen dienen. Eine NC-Task besteht aus einem oder mehreren Kanälen vom Typ PTP-Kanal, Fifo-Kanal oder NCI-Kanal und deren Unterbestandteilen. Nach dem Aufstarten befinden sich die NC-Achsen im Allgemeinen in einem oder mehreren PTP-Kanälen und werden dann, wenn nötig, durch Umkonfiguration, in einen anderen Kanal versetzt.

Sicherheitsfunktionalitäten

Informieren Sie sich vor der Inbetriebnahme von Achsen über die TwinCAT Sicherheitsfunktionalitäten.

Interfaces: System Manager und SPS

Das Einfügen einer NC-Task, die Konfiguration der NC-Kanäle und der Achsen sowie die Bedienung der meisten Funktionalitäten ist im System Manager im NC Teil und in der SPS-Dokumentation (NC-Configuration Library, NC-Library, NCI-Configuration Library, NCI Interpreter Library) beschrieben.

Hardware I/O

Normal-Text.

NC-SPS Interface

Normal-Text.

Achsen

TwinCAT unterstützt diverse Achstypen. Das sind Servo-Achsen, Eil-Schleich-Achsen, Schrittmotor-Achsen, 'Low-Cost' Schrittmotor-Achsen, Encoder-Achsen und Simulationsachsen.

Achsbestandteile

Jede Achse besteht, je nach Achs-Typ, aus diversen Bestandteilen. Dazu gehören der Encoder (Geber), der Drive (Antrieb), der Regler (Contoroller) und der Sollwertgenerator sowie das SPS-Interface. Es gibt auch komplexere Achsen, die aus mehreren Encodern, umschaltbaren Reglern oder wechselnden Sollwertgeneratoren bestehen.

Achsinbetriebnahme

Zur Achsinbetriebnahme gehören insbesondere die Kenntnis und Nutzung der Sicherheitsfunktionalitäten der NC sowie das Ergreifen der notwendigen Sicherheitsvorkehrungen und die Einhaltung einer bestimmten Reihenfolge der Inbetriebnahmeschritte der Achsbestandteile (Encoder, Antrieb und Regler) sowie die Einstellung der Achsparameter.

PTP

Die PTP (Point To Point (Punkt zu Punkt)) Achsfunktionalität ist eine Steuerung zur eindimensionalen Positionierung von Achsen, speziell Servo-Achsen. Eindimensional heißt nicht unbedingt linear, sondern in einem vorgegebenen Koordinatensystem (kartesische Koordinaten, Kreiskoordinaten) wird eine Komponente interpoliert.

Die PTP ist die Grundlage der gesamten TwinCAT NC, da sich die Achsen bei Systemstart im Normalfall im PTP-Modus befinden und somit lagegeregelt sind. Die erweiterten TwinCAT NC Funktionalitäten werden von den PTP-Modi durch Umkonfiguration (FIFO, NCI) oder Kopplung (alle Slavetypen) erreicht.

Slave-Achsen

Achsen deren Sollwerte (Position, Geschwindigkeit, Beschleunigung) in funktionaler Abhängigkeit von den Sollwerten anderer Achsen (Master-Achsen, virtuellen Achsen, Slave-Achsen, Simulationsachsen) - insbesondere von deren Positions-Sollwerten - generiert werden heißen Slave-Achsen. Diese Achsen sind i.A. – bis auf An- und Abkoppeln - ohne eigene Funktionalität (speziell ohne Start und ohne Stop) und laufen über eine Streckensteuerung synchron zur Master-Achse (die selber wieder eine Slave-Achse sein kann).

Bei der Ankopplung einer Master-Achse (zukünftige Slave-Achse) an eine Master-Achse behält die Slave-Achse ihre eigene Lagereglung.

FIFO

Die TwinCAT NC FIFO-GRUPPE bietet die Möglichkeit, extern generierte Sollwerte einer Gruppe von Achsen über die NC auszugeben und die Achsgruppe somit synchron zu verfahren. Dabei liegen die Positionssollwerte der Achsen in Abhängigkeit von einer festen aber beliebigen Zykluszeit (FIFO-Zykluszeit) in Form eines FIFO vor, das seinerseits über die SPS nachgefüllt wird. Das FIFO dient der zeitgesteuerten synchronen Abarbeitung der Position einer Gruppe von Achsen. Das FIFO enthält eine fest eingestellte Anzahl von vorgegebenen Stützstellen, zwischen denen die NC Position interpoliert und daraus die Geschwindigkeit ermittelt. Die Achspositionen des FIFO werden

  • entweder aus einer in der SPS liegenden, off-line berechneten, großen Tabelle ausgelesen oder
  • durch eine Funktion in der SPS erzeugt

und im SPS Zyklus permanent durch ein SPS-Programm an das Fifo der NC durchgereicht.

NCI

Die TwinCAT NCI ist die Funktionsgruppe (bestehend aus Interpreter/SPS-Bausteine, Satzvorbereitungstask, Look Ahead, Satzausführungstask, zyklisches Kanalinterface, zyklisches Achsinterface) zur Steuerung vorgegebener synchronisierter Achsbewegungen in drei Dimensionen gemäß den DIN 66025 Konventionen und diversen Erweiterungen. On-line Eingriffe auf allen Ebenen (Interpreter-Stopp, programmierter Halt, Override) sind möglich.


NC

Übersicht

Die TwinCAT NC ist die Zusammenfassung der Funktionsgruppen die der Steuerung und Reglung von Achsen oder synchronisierten Achsgruppen dienen. Eine NC-Task besteht aus einem oder mehreren Kanälen vom Typ PTP-Kanal, Fifo-Kanal oder NCI-Kanal und deren Unterbestandteilen. Nach dem Aufstarten befinden sich die NC-Achsen im Allgemeinen in einem oder mehreren PTP-Kanälen und werden dann, wenn nötig, durch Umkonfiguration, in einen anderen Kanal versetzt.

Sicherheitsfunktionalitäten

Informieren Sie sich vor der Inbetriebnahme von Achsen über die TwinCAT Sicherheitsfunktionalitäten.

Interfaces: System Manager und SPS

Das Einfügen einer NC-Task, die Konfiguration der NC-Kanäle und der Achsen sowie die Bedienung der meisten Funktionalitäten ist im System Manager im NC Teil und in der SPS-Dokumentation (NC-Configuration Library, NC-Library, NCI-Configuration Library, NCI Interpreter Library) beschrieben.

Hardware I/O

Normal-Text.

NC-SPS Interface

Normal-Text.

Achsen

TwinCAT unterstützt diverse Achstypen. Das sind Servo-Achsen, Eil-Schleich-Achsen, Schrittmotor-Achsen, 'Low-Cost' Schrittmotor-Achsen, Encoder-Achsen und Simulationsachsen.

Achsbestandteile

Jede Achse besteht, je nach Achs-Typ, aus diversen Bestandteilen. Dazu gehören der Encoder (Geber), der Drive (Antrieb), der Regler (Controller) und der Sollwertgenerator sowie das SPS-Interface. Es gibt auch komplexere Achsen, die aus mehreren Encodern, umschaltbaren Reglern oder wechselnden Sollwertgeneratoren bestehen.

Achsinbetriebnahme

Zur Achsinbetriebnahme gehören insbesondere die Kenntnis und Nutzung der Sicherheitsfunktionalitäten der NC sowie das Ergreifen der notwendigen Sicherheitsvorkehrungen und die Einhaltung einer bestimmten Reihenfolge der Inbetriebnahmeschritte der Achsbestandteile (Encoder, Antrieb und Regler) sowie die Einstellung der Achsparameter.

PTP

Die PTP (Point To Point (Punkt zu Punkt)) Achsfunktionalität ist eine Steuerung zur eindimensionalen Positionierung von Achsen, speziell Servo-Achsen. Eindimensional heißt nicht unbedingt linear, sondern in einem vorgegebenen Koordinatensystem (kartesische Koordinaten, Kreiskoordinaten) wird eine Komponente interpoliert.

Die PTP ist die Grundlage der gesamten TwinCAT NC, da sich die Achsen bei Systemstart im Normalfall im PTP-Modus befinden und somit lagegeregelt sind. Die erweiterten TwinCAT NC Funktionalitäten werden von den PTP-Modi durch Umkonfiguration (FIFO, NCI) oder Kopplung (alle Slavetypen) erreicht.

Slave-Achsen

Achsen deren Sollwerte (Position, Geschwindigkeit, Beschleunigung) in funktionaler Abhängigkeit von den Sollwerten anderer Achsen (Master-Achsen, virtuellen Achsen, Slave-Achsen, Simulationsachsen) - insbesondere von deren Positions-Sollwerten - generiert werden heißen Slave-Achsen. Diese Achsen sind i.A. – bis auf An- und Abkoppeln - ohne eigene Funktionalität (speziell ohne Start und ohne Stop) und laufen über eine Streckensteuerung synchron zur Master-Achse (die selber wieder eine Slave-Achse sein kann).

Bei der Ankopplung einer Master-Achse (zukünftige Slave-Achse) an eine Master-Achse behält die Slave-Achse ihre eigene Lagereglung.

FIFO

Die TwinCAT NC FIFO-GRUPPE bietet die Möglichkeit, extern generierte Sollwerte einer Gruppe von Achsen über die NC auszugeben und die Achsgruppe somit synchron zu verfahren. Dabei liegen die Positionssollwerte der Achsen in Abhängigkeit von einer festen aber beliebigen Zykluszeit (FIFO-Zykluszeit) in Form eines FIFO vor, das seinerseits über die SPS nachgefüllt wird. Das FIFO dient der zeitgesteuerten synchronen Abarbeitung der Position einer Gruppe von Achsen. Das FIFO enthält eine fest eingestellte Anzahl von vorgegebenen Stützstellen, zwischen denen die NC Position interpoliert und daraus die Geschwindigkeit ermittelt. Die Achspositionen des FIFO werden

  • entweder aus einer in der SPS liegenden, off-line berechneten, großen Tabelle ausgelesen oder
  • durch eine Funktion in der SPS erzeugt

und im SPS Zyklus permanent durch ein SPS-Programm an das Fifo der NC durchgereicht.

NCI

Die TwinCAT NCI ist die Funktionsgruppe (bestehend aus Interpreter/SPS-Bausteine, Satzvorbereitungstask, Look Ahead, Satzausführungstask, zyklisches Kanalinterface, zyklisches Achsinterface) zur Steuerung vorgegebener synchronisierter Achsbewegungen in drei Dimensionen gemäß den DIN 66025 Konventionen und diversen Erweiterungen. On-line Eingriffe auf allen Ebenen (Interpreter-Stopp, programmierter Halt, Override) sind möglich.