Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Messtasterauswertung mit AX2000-B200 (Lightbus)

TwinCAT NC Touch Probe

Messtasterauswertung mit AX2xxx-B200 (Lightbus)

Die AX2000 und AX2500 Antriebsverstärkerserie mit Lightbus-Schnittstelle (AX2xxx-B200) ist in der Lage, Istpositionen mit Hilfe seines digitalen Eingangs zu latchen. Um diese Funktion zu nutzen, müssen einige Konfigurationsschritte im TwinCAT System Manager durchgeführt werden.

Zuerst muss auf dem 'AX2xxx' Einstelldialog die Checkbox Variable I/O Data aktiviert werden. Dadurch ändert sich das I/O Interface für dieses Gerät. Durch die zusätzlichen E/A-Variablen wird auch die benötigte Eingangsvariable für die Messtasterauswertung eingeblendet. Nachdem die Checkbox aktiviert wurde, kann der Antrieb mit der NC Achse verknüpft werden.

Die Checkbox für Optimized Telegram Count muss in diesem Fall deaktiviert bleiben, andernfalls würden die Messtasterinformationen wieder aus dem Datensatz entfernt.

Der AX2xxx Antriebsverstärker hat 4 digitale Eingänge, aber nur der digitale Eingang 2 kann verwendet werden um das Latch-Signal zu triggern. Der digitale Eingang 2 muss vorab als Messtastereingang konfiguriert werden. Dies kann auf drei verschiedene Arten geschehen:
A) mit der Konfigurationssoftware Drive, die jedem Antriebsverstärker beiliegt,
B) über den Karteireiter AX2xxx-B200 Online innerhalb des TwinCAT System Managers oder
C) per ASCII Kommando mit Hilfe von MS Windows HyperTerminal.

Um den Positions-Latch Modus zu aktivieren, ist das Kommando IN2MODE mit Parameterwert 26 auszuführen. Anschließend muss das Kommando SAVE und COLDSTART ausgeführt werden, um die Änderung dauerhaft im EEPROM-Bereich des Antriebs abzulegen.

SPS Programmsequenz

Der Antrieb ist nun vorbereitet um Positionsdaten latchen zu können. Das SPS-Programm sollte nun die Messtastersequenz mit Hilfe eines vorhandenen Satzes von diesbezüglichen NC ADS Funktionen bearbeiten.

  1. Die Messtasterfunktion ist mit Hilfe des ADSWRITE Funktionsbausteines zu aktivieren.
    Das Latch-Signal kann so konfiguriert werden, dass es auf eine steigende oder fallende Flanke am Trigger-Signal wartet.

    Aktivierung bei steigender Flanke: ADS Encoder-Funktion, IDXGRP 16#5200+EncoderID, IDXOFFS 16#201
    Aktivierung bei fallender Flanke: ADS Encoder-Funktion, IDXGRP 16#5200+EncoderID, IDXOFFS 16#202
  2. Das Latch Valid Bit (Bit 16) innerhalb des zyklischen Interfaces ist zu beachten. Es signalisiert, dass das Latch-Signal getriggert wurde. Das Flag kann auch gelesen werden, in dem die Bibliotheksfunktion AxisExternalLatchValid genutzt wird.
  3. Nachdem das Latch gültig ist, muss der Positions-Latch-Wert per ADSREAD Funktionsbaustein gelesen werden.
    Lesen des Positionswertes: ADS Encoder-Status, IDXGRP 16#5100+ EncoderID , IDXOFFS 16#205
    Anschließend kann wieder mit Schritt 1 begonnen werden, um damit den Positionswert zu latchen.

    4. Es ist zu beachten, dass eine möglicher Achs-Reset eine bereits begonnene Latch-Prozedur deaktiviert. Dies ist unter anderem mit dem Hintergrund des Wartens auf das Latch Valid Signal zu berücksichtigen. Nach einem Achs-Reset wird das Latch Valid Flag (Bit 16) erst dann wieder auf 'TRUE' wechseln, nachdem das Latch Signal per ADSWRITE (Schritt 1) erneut aktiviert wurde. Der Status von Latch Enabled kann zwischenzeitlich optional gelesen werden, während auf das Latch Valid Flag gewartet wird (ADS Encoder-Status, IDXGRP 16#5100+ EncoderID , IDXOFFS 16#201).

    Eine typische SPS-Applikation nutzt ADS-Port 500 um mit der NC via ADSREAD- oder ADSWRITE-Kommandos zu kommunizieren. Für Highspeed-Applikationen kann auch Port 501 der NC-SAF Task genutzt werden. Falls Port 501 genutzt wird, empfiehlt es sich, eine schnelle SPS Task mit der NC-SAF Zykluszeit zu synchronisieren (z. B. 2 ms). Solch eine Konfiguration kann ADS Kommandos in 2-3 Zyklen bearbeiten, was wiederum einer typischen Abarbeitungszeit von 4 bis 6 ms entspricht.

SPS Funktionsbaustein

Die oben beschriebene SPS Programmsequenz kann durch den Funktionsbaustein MC_TouchProbe in der Bibliothek TcMC.lib ausgeführt werden. Dadurch wird die Programmierung der Messtasterfunktion wesentlich vereinfacht.


Messtasterauswertung mit AX2000-B750 (SERCOS)

TwinCAT NC Touch Probe

Messtasterauswertung mit AX2xxx-B750 (SERCOS)

Die AX2000 und AX2500 Antriebsverstärkerserie mit SERCOS-Schnittstelle (AX2xxx-B750) ist in der Lage, Istpositionen mit Hilfe seines digitalen Eingangs zu latchen. Um diese Funktion zu nutzen, müssen einige Konfigurationsschritte im TwinCAT System Manager durchgeführt werden.

Hinzufügen von Statusinformationen zum SERCOS Istwertkanal

IDN 130

Fügen Sie IDN 130 zum Istwertkanal des Antriebs hinzu. Danach muss der Antriebsverstärker mit der logischen NC-Achse verknüpft werden. Hierbei ist wichtig, dass Antrieb nach dem Zufügen von IDN 130 verknüpft wird. Falls der Antrieb bereits vorher mit der NC-Achse verknüpft wurde, ist diese Verknüpfung zu lösen, dann zunächst IDN 130 hinzuzufügen und erst danach die Verknüpfung erneut herzustellen.

Alternativ können hier auch IDN 131, IDN 132 und IDN 133 zum Istwertkanal hinzugefügt werden.

Einstellen der SERCOS Parameter

Die Konfiguration des digitalen Triggereingangs wird durch die Parametrierung einiger SERCOS-Parameter vorgenommen. Diese IDNs können im SERCOS "Online"-Menü des jeweiligen Antriebs beeinflusst werden. Alternativ können Sie die notwendigen IDNs auch, durch Zufügen in den "Startup"-Dialog des Antriebs, automatisch während des Starts des SERCOS Rings in den Antrieb herunterladen. Letztere Vorgehensweise ist nachfolgend beschrieben.

IDN 303

TwinCAT benutzt das Real-Time Bit 2 für die Latch-Funktion. IDN 303 muss auf den Wert 405 gesetzt werden, falls Messtaster 1 genutzt wird, bzw. auf den Wert 406, falls Messtaster 2 genutzt wird.

IDN 307

Die IDN 307 (Real-Time Status Bit 2) muss auf 409 gesetzt werden falls Messtaster 1 genutzt wird, bzw. entsprechend auf den Wert 411 für den Messtaster 2.

IDN 169

Der Messtaster-Steuerparameter IDN 169 definiert die Flanke des Triggersignals. Der Wert der an IDN 169 geschrieben werden muss ist eine binäre Kombination der unteren 4 Bits. Ein Wert = 1 definiert dementsprechend eine steigende Flanke an Messtastereingang 1.

IDN P3001

Der AX2000 Antrieb besitzt 4 digitale Eingänge aber nur Eingang 2 kann zur Triggerung des Latch-Signals genutzt werden. Der digitale Eingang 2 muss vorab als Triggereingang konfiguriert werden. Dies kann durch die Einstellung von IDN 3001 auf einen Wert von 26 geschehen. P-0-3001 wird im Dialog Neu.. SERCOS Wert nicht aufgelistet, kann aber manuell, wie in nachfolgender Abbildung gezeigt, hinzugefügt werden.

Das SPS-Programm

Der Antrieb ist nun vorbereitet um Positionsdaten latchen zu können. Das SPS-Programm sollte nun die Erfassungssequenz für den Messtaster bearbeiten. Dies geschieht mit einem Satz von NC ADS Funktionsbausteinen. Die nachfolgende Prozedur geht davon aus, dass sich der SERCOS Ring in Phase 4 befindet.

IDN 170

IDN 170 startet die Messtastererfassung. Ein Wert der an IDN 170 geschrieben wird kann nicht permanent im Antrieb gespeichert werden und ein Zufügen zur SERCOS Startup-Liste ist auch nicht möglich. Stattdessen muss das SPS-Programm einen Wert in diesen Parameter herunterladen.

Programmsequenz

  1. Der Funktionsbaustein IOF_SER_IDN_Write wird genutzt um einen Wert 3 in IDN 170 herunterzuladen. Dieser Schritt ist nur einmal beim Aufstarten des Systems notwendig.
  2. Aktivierung der Messtasterfunktion durch den ADSWRITE Funktionsbaustein an die entsprechende NC ADS-Portnummer (siehe unten).
    Die Latch-Signalauswertung kann so konfiguriert werden, dass sie auf eine steigende oder eine fallende Flanke des Triggereingangs wartet.
    Aktivierung durch steigende Flanke: ADS Encoder-Funktion, IDXGRP 16#5200+EncoderID, IDXOFFS 16#201
    Aktivierung durch fallende Flanke: ADS Encoder-Funktion, IDXGRP 16#5200+EncoderID, IDXOFFS 16#202
  3. Das Latch Valid Flag (Bit 16) in dem zyklischen Achsinterface muss beobachtet werden, da es signalisiert ob Latch bereits getriggert wurde. Dieses Flag kann auch gelesen werden, in dem die Bibliotheksfunktion AxisExternalLatchValid benutzt wird.
  4. Nachdem dem das Latch-Signal gültig ist, muss der Positions-Latch-Wert per ADSREAD Funktionsbaustein ausgelesen werden.
    Positionswert lesen: ADS Encoder-Status, IDXGRP 16#5100+EncoderID, IDXOFFS 16#205
    Der nächste Positionswert kann ermittelt werden, indem Schritt 3 wiederholt wird.

Es ist zu beachten, dass ein Achs-Reset Kommando eine laufende Messtasterauswertung deaktiviert. Dies ist vor allem zu beachten während die Programmsequenz auf das Latch Valid Flag (Bit 16) wartet. Nach einem Achs-Reset würde das Latch Valid Flag erst dann wieder auf 'TRUE' wechseln, nachdem die Latch-Funktion erneut aktiviert wurde. Der Status Latch Enabled kann zwischenzeitlich optional gelesen werden, während auf das Latch Valid Flag gewartet wird (ADS Encoder Zustand, IDXGRP 16#5100+EncoderID, IDXOFFS 16#201).

Eine typische SPS-Applikation nutzt ADS-Port 500 um mit der NC via ADSREAD- oder ADSWRITE-Kommandos zu kommunizieren. Für Highspeed-Applikationen kann auch Port 501 der NC-SAF Task genutzt werden. Falls Port 501 genutzt wird, empfiehlt es sich, eine schnelle SPS Task mit der NC-SAF Zykluszeit zu synchronisieren (z. B. 2 ms). Solch eine Konfiguration kann ADS Kommandos in 2-3 Zyklen bearbeiten, was wiederum einer typischen Abarbeitungszeit von 4 bis 6 ms entspricht.

SPS Funktionsbaustein

Die oben beschriebene SPS Programmsequenz kann bis auf den Schritt 1 (Schreiben von IDN 170) durch den Funktionsbaustein MC_TouchProbe in der Bibliothek TcMC.lib ausgeführt werden. Dadurch wird die Programmierung der Messtasterfunktion wesentlich vereinfacht.