Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Einleitung

Zum Entwerfen der Bewegungen einer Kurvenscheibe dient ein Kurvenscheibeneditor. Der in das TwinCAT integrierte Kurvenscheibeneditor ist im System Manager unter der NC-Configuration unter dem Punkt Tables zu finden.

Hier können zusätzliche Master und darunter entsprechende Slaves eingefügt werden (rechte Maustaste). Wenn man in dem Baum auf den Master klickt, kann auf den Eigenschaftsseiten nicht nur die Eigenschaften des Masters sondern auch der zugehörigen Slaves eingestellt werden.

Die generelle Vorgehensweise beim Entwerfen einer Kurvenscheibe ist dabei an die der VDI-Richtlinie 2143 angelehnt. Der grobe Entwurf der Bewegung - der Bewegungssplan - definiert dabei die Anfangs- und Endpunkte der Bewegungsabschnitte. In dem Editor wird allerdings nicht unterschieden zwischen der Bewegungsskizze und dem Bewegungsdiagram, der die detaillierte Bewegungsbeschreibung enthält.

Die Bedienung des Kurvenscheibeneditors ist grafisch orientiert. Nach der grafisch interaktiven Eingabe der Punkte in dem Grafikfenster, werden die Koordinaten der Punkte in dem Tabellenfenster darüber dargestellt. Neue Punkte können nur über die Grafik hinzugefügt werden und vorhanden Punkte könne auch nur über die Grafik gelöscht werden. Die Eigenschaften der Punkte - die Werte der Koordinaten oder die Ableitungen - können auch interaktiv in dem Tabellenfenster manipuliert werden.

In dem grafischen Bereich lassen sich nicht nur die Position, sondern auch die Geschwindigkeit, Beschleunigung und der Ruck darstellen.

Den Wechsel der Darstellung kann man durch rechten Mausklick im Grafikfenster in dem folgenden Menü umstellen:

So wird für jede Ableitung ein separates Grafikfenster eröffnet.

Der Kurvenscheibeneditor ist ein flexibles Werkzeug, der den Anwender optimal unterstützt und nur minimal einschränkt. Dadurch liegt allerdings die Verantwortung für die Wahl der Parameter beim Anwender. So sollte zum Beispiel der Anwender genau kontrollieren ob Anfangspunkt und Endpunkt genau den Vorgaben entsprechen. Auf der anderen Seite wird der Anwender aber auch optimal unterstützt bei der Kontrolle der Geschwindigkeiten, Beschleunigungen und des Rucks durch die grafischen Anzeigemöglichkeiten.

Bei all den Möglichkeiten sollte der Anwender aber immer Bedenken, das die Physik die Grenzen der möglichen Bewegung vorgibt.


Eigenschaften des Master

TS1510 | TwinCAT CAM Design Tool (Kurvenscheibeneditor)

Eigenschaften des Masters

Auf der Eigenschaftsseite des Masters:

Können das Minimum und das Maximum der Masterposition festgelegt werden.

Mit dem Schalter Normed kann gewählt werden zwischen der genormten Darstellung und einer physikalischen Darstellung, die die Geschwindigkeiten, Beschleunigungen und den Ruck der Slaves in Abhängigkeit der Zeit darstellt. Die genormte Darstellung bezieht diese Darstellungen auf die Masterposition.

Für die physikalische Darstellung wird die Geschwindigkeit des Masters benötigt, dabei unterscheidet man zuerst zwischen einer linearen und einer Drehachse (Angabe der Werte in Winkel in Grad). Die Wahl zwischen linear und Drehachse legt beim Übertragen der Daten in die NC den Tabellentyp ob linear oder zyklisch fest.

Beim rotatorischen Master werden die ersten und zweiten Ableitungen am Ende gleich den entsprechenden am Anfang des Bewegungszyklus gesetzt, wenn die Anfangsposition des Slaves dem Minimum und die Endposition dem Maximum des Masters entspricht.

Mit Fixed Table werden die Tabellen mit den Tabellenwerten (Masterwert, Slavewert) in definiertem Abstand der Masterwerte (Increment) gewählt.

Mit dem Increment wird für die Ausgabe der Tabellen in eine Datei das Inkrement der Masterposition festgelegt. Für das Erzeugen einer äquidistanten Tabelle sollte die Gesamtlänge (tatsächliches Maximum minus Minimum) durch das Increment teilbar sein. Beim Speichern des Projektes in der Registry werden automatisch die Informationen für das Erzeugen und Übertragen der Tabellen mit diesem Increment in die NC erzeugt.

Mit den Motion Function werden die vollständigen Informationen des Slaves in die NC übertragen. Es werden also nur die Randpunkte der Segmente mit den entsprechenden Informationen wie zum Beispiel den Bewegungsgesetz in die NC geladen. Die NC rechnet dann zur Laufzeit für die aktuelle Masterposition die zugehörigen Slavewerte (Slaveposition, -geschwindigkeit und -beschleunigung) aus. Probleme, die ihren Ursprung in der Diskretisierung der Daten in der Tabelle hatten, sind damit prinzipiell nicht mehr vorhanden.

Achtung: Funktionalitäten wie zum Beispiel spezielle Bewegungsgesetze die in der NC im Moment noch nicht zur Verfügung stehen, werden im Kurvenscheibeneditor rot gekennzeichnet. Diese dürfen also nicht ausgewählt werden.

Der Rounding Value rundet die Masterpositionen in der grafischen Eingabe mit dem angebenen Wert.

Zum importieren von Slaves kann per rechtem Mausklick auf den Master in der Baumansicht in dem Menü

der Punkt Import Slave... gewählt werden.

Hier können die Daten des Masters inklusiv der Slavedaten auch exportiert werden. Der Import dieser Daten ist über die Baumansicht unter dem Punkt Tables möglich.


Eigenschaften des Slaves

Eigenschaften des Slaves:

Auf der Eigenschaftsseite des Slaves:

können das Maximum und Minimum der Position, Geschwindigkeit, Beschleunigung und des Rucks festgelegt werden. Diese Werte werden bei der ersten Darstellung der Grafikfenster als Vorgabe verwendet. Die Anpassung an die aktuellen Werte des Diagramms kann in dem jeweiligen Grafikfenster mit dem Befehl [image] Anpassung an die Extremwerte erfolgen.

Der Rounding Value rundet die Slavepositionen in der grafischen Eingabe mit dem angegebenen Wert.

Mit Export können die Werte des Slaves in einer ASCII-Datei in der Form Masterposition, Slaveposition jeweils in einer Zeile abgespeichert werden. Das Inkrement der Masterposition wird dabei auf der Eigenschaftsseite des Masters festgelegt.

Mit Import können Dateien in der eben beschriebenen Form eingelesen werden. Die Werte werden dann als kubische Splines dargestellt. Der Typ des Splines muss in Abhängigkeit der Werte dabei noch in der Tabelle angepasst werden.

Mit Download können die aktuellen Daten zur NC übertragen werden. Allerdings mit der Einschränkung, daß der Slave nicht gekoppelt ist, da die Tabellen komplett gelöscht und neu mit Daten gefüllt werden.

Mit Upload können die Informationen der Motion Function von der NC geladen werden. Die bereits vorhandenen Daten können komplett gelöscht und die Daten der NC sowohl in der Tabelle als auch in der Grafik manipuliert werden.

Achtung: Beim Upload von zyklischen Daten müssen die Periodenlänge des Masters mit der der geladenen Daten übereinstimmen. Zur direkten Überprüfung der Daten kann der Master auf linear (nichtzyklisch) gestellt werden.

Die Table Id gibt die eindeutige Identifikationszahl (1..255) der Tabelle an, mit der Tabellendaten in der NC abgelegt werden. Sie kann per rechtem Mausklick in dem Menü

mit dem Befehl Change Id... verändert werden.

Mit Export Slave... können die Daten des Bewegungsdiagramms in einer Exportdatei (*.tce) gespeichert werden. Diese Daten können unter einem Master wieder importiert werden.


Grafikfenster

Die Position des Slaves und der Ableitungen wird jeweils in einem separatem Grafikfenster dargestellt.

In der zugehörigen Toolbar gibt es zum einen Buttons, die sich nur auf die Grafik beziehen,

und zum anderen die speziellen Befehle des Kurvenscheibeneditors

Die Grafikbefehle unterteilen sich in den Eingabemodus: und die Zoom und Verschiebebefehle:

Zoom

Zoom alles

Verschieben (Wenn der Schalter Pan outside im Popupmenü eingeschaltet ist, kann man auch über die Grenzen hinweg verschieben.
Dieser Befehl ist erst dann aktiv, wenn der Zoombefehl aufgerufen wurde.

Übersichtsfenster ein/ausschalten. Das Fenster lässt sich nur dann einschalten, wenn man in das Fenster hineingezoomt hat.

Wenn das Übersichtsfenster eingeschaltet ist, kann man in dem Fenster nicht nur erkennen, in welchen Ausschnitt die Grafik ist, sondern man kann darin den Ausschnitt verschieben oder einen neuen Ausschnitt zoomen.

Mit den horizontalen und vertikalenScrollBars kann man den Grafikausschnitt verschieben, wobei der horizontale Scrollbar für alle Grafikfenster gleichzeitig gilt.

Wenn man eine IntelliMouse mit ScrollWheel verwendet, kann man mit dem ScrollWheel zoomen.

Die Toolbar mit den Befehlen kann durch rechten Mausklick (im Grafikfenster) in dem folgenden Menü ein- oder ausgeblendet werden:

Mit eingeschalteter Option Horizontal Scroll Bar ist für dieses Fenster ebenfalls ein horizontaler Scroll Bar vorhanden. Alle horizontalen Scroll Bars sind synchronisiert.

Mit der Option Cross on Point werden die Anfangs- und Endpunkte der Bewegungsabschnitte mit einem Kreuz gekennzeichnet.

Der Show Online Data stellt die Tabellendaten, die sich momentan in der NC befinden mit der zugehörigen Tabellen ID, als kubischen Spline dar. Dadurch kann es momentan zu einer verzerrten Darstellung kommen, da die linearen Tabellen als natürliche Splines (zweite Ableitung an den Rändern gleich Null) dargestellt werden. Die Daten werden in der gleichen Farbe nur etwas dunkler dargestellt.

Die Daten werden automatisch per ADS übertragen, sobald der Online Mode eingeschaltet wird. Durch ein und ausschalten des Modus können die aktuellen Daten gelesen werden.

Beim Speichern des Projektes in der Registry werden automatisch die Informationen für das Erzeugen und Übertragen der Tabellen in die NC erzeugt.

Mit Download Data werden die Daten zur NC übertragen. Hier gilt die Einschränkung (siehe Eigenschaften des Slaves), daß der Slave nicht gekoppelt ist, für die Motion Function nicht. Es werden also nur die Daten übertragen.


Tabellenfenster

In dem Tabellenfenster werden die Werte der Bewegungsabschnitte dargestellt.:

Tabellenüberschrift | Beschreibung
Function | Gibt den Funktionstyp an (siehe Funktionstypen)
X start | Anfangswert der Position des Masters (Das Icon vor dem Wert zeigt den Typ des Punktes an)
Y start | Anfangswert der Position des Slaves
Y' start | Anfangswert der Geschwindigkeit des Slaves
Y'' start | Anfangswert der Beschleunigung des Slaves
Y''' start | Anfangswert des Rucks des Slaves
X end | Endwert der Position des Masters (Das Icon vor dem Wert zeigt den Typ des Punktes an)
Y end | Endwert der Position des Slaves
Y' end | Endwert der Geschwindigkeit des Slaves
Y'' end | Endwert der Beschleunigung des Slaves
Y''' end | Endwert des Rucks des Slaves
Symmetrie | Symmetriewert des Bewegungsgesetzes

Die Werte können per Tastatur geändert werden, dabei werden aber die Einschränkungen beachtet, die durch die Wahl des Funktionstypen oder der Randbedingungen der Punkte gemacht worden sind.

Da die Bewegungsabschnitte normalerweise zusammenhängen - außer Gleitpunkte - sind der Endpunkt mit den Ableitungen am Ende eines Abschnittes gleich den entsprechenden Werten am Anfang des folgenden Bewegungsabschnittes. Daher sollte man normalerweise immer die Anfangswerte manipulieren. Außerdem sollte man bei einem fertig entworfenem Bewegungsdiagramm die Übereinstimmung von Anfangs- und Endpunkten überprüfen, falls man in der Grafik Unstimmigkeiten feststellt. Falls sich in der Tabelle bestimmte Werte nicht verändern lassen, sollte man über die Randbedingungen der Punkte nachdenken und sie gegebenenfalls ändern. Die Randbedingungen schränken die Möglichkeiten der Funktionen auf den Abschnitten ihrem Typ entsprechend ein.

Die Symmetrie der Funktionen lässt sich nur bei den Typen: Polynom3, Polynom5, Polynom8, Sinusline, ModSinusline, Bestehorn, AccTrapezoid verändern. Normalerweise liegt der Wendepunkt der Kurve (Beschleunigung = 0) bei 50% = 0.5. Dieser Wert lässt sich nicht nur in der Tabelle modifizieren sondern auch in der Grafik (siehe Beispiel 6).

Funktionstypen

Der Funktionstyp kann neben den Standardtypen (Synchron/Automatic) , die per Kommando in der Grafik verändert werden können, auch in der Kombobox verändert werden. Beim ersten Anklicken der Kombobox - oder eines Feldes der ersten Spalte - wird im Fenster der Position temporär ein Rechteck aufgespannt mit den Eckpunkten Anfangspunkt und Endpunkt des Abschnitts. Sobald man ein anderes Feld im Tabellenfenster antippt, wird entweder für dieses das Rechteck gezeigt oder kein Rechteck mehr angezeigt.

Die Typen entsprechen denen der VDI-Richtlinie 2143 zusätzlich kommen noch die kubischen Splines mit den Randbedingungen natürlich, tangential und periodisch hinzu.

Typ | Beschreibung | Randbedingung
Synchron | Synchrone Bewegung ( konstantes Übersetzungsverhältnis von Slave zu Master entspricht der normierten Geschwindigkeit ) | konstante Geschwindigkeit v, Beschleunigung a=0
Automatic | Automatische Anpassung an die Randwerte (Geschwindigkeit, Beschleunigung) |
Polynom3 | Polynom 3ter Potenz | v=0, a=0
Polynom5 | Polynom 5ter Potenz (eingeschränkte Version Rast in Rast) | v=0, a=0
Polynom8 | Polynom 8ter Potenz | v=0, a=0
Sinusline | Sinuslinie (siehe VDI-Richtlinie 2143) | v=0, a=0
ModSinusline | modifizierte Sinuslinie (siehe VDI-Richtlinie 2143) | v=0, a=0
Bestehorn | Sinuslinie a la Bestehorn (siehe VDI-Richtlinie 2143) | v=0, a=0
AccTrapezoid | Beschleunigungstrapez | v=0, a=0
SinusSyncKombi | Sinus Geraden Kombination | v=0, a=0
ModSinusline_VV | modifizierte Sinuslinie von Geschwindigkeit in Geschwindigkeit | a=0
HarmonicKombi_RT | harmonische Kombination von Rast in Umkehr | v=0; Startpunkt: a=0
HarmonicKombi_TR | harmonische Kombination von Rast in Umkehr | v=0; Endpunkt: a=0
HarmonicKombi_VT | harmonische Kombination von Geschwindigkeit in Umkehr | Startpunkt: a=0; Endpunkt: v=0
HarmonicKombi_VT | harmonische Kombination von Umkehr in Geschwindigkeit | Startpunkt: v=0; Endpunkt: a=0
AccTrapezoid_RT | Beschleunigungstrapez von Rast in Umkehr | v=0; Startpunkt: a=0
AccTrapezoid_RT | Beschleunigungstrapez von Umkehr in Rast | v=0; Endpunkt: a=0
Polynom7_MM | Polynom 7ter Potenz mit Anpassung an die Randwerte (Geschwindigkeit, Beschleunigung und Ruck) |
Spline | Innerer Abschnitt eines kubischen Splines |
Spline Natural | Start- oder Endabschnitt eines natürlichen kubischen Splines | a=0
Spline Tangential | Start- oder Endabschnitt eines tangentialen kubischen Splines |
Spline Periodic | Start- oder Endabschnitt eines zyklischen kubischen Splines |
Polyline | Start- oder Endabschnitt eines linearen Splines |

Das Ändern des Splinetyps beim ersten Punkt bedingt auch die Änderung des Splinetyps insgesamt und damit auch den vom Endpunkt.

Wenn man den Splinetyp Spline Tangential wählt, sollte man die Randbedingungen (erste Ableitung am Anfangspunkt und Endpunkt) modifizieren.

Bei den Bewegungsgesetzen mit Randbedingungen steht das R (Rest) für Rast , V (Velocity) für Geschwindigkeit, T (Turn) für Umkehr und M (Motion) für Bewegung.


Kommandos

Die Kommandos des Kurvenscheibeneditors, die durch die Toolbar des jeweiligen Grafikfenster aufrufbar sind:

können nur dann aufgerufen werden, wenn von den Grafikbefehlen

der Eingabemodus [image] aktiviert ist.

Die Kommandos gelten jeweils nur für das jeweilige Fenster.

Anpassung an die Extremwerte

Die Koordinaten des Fensters werden an die Extremwerte der Bewegung angepasst

Messen des Abstand

Von dem zuerst mit der linken Maustaste angeklicktem Punkt wird der horizontale und vertikale Abstand zu dem aktuellen Punkt oben rechts im Fenster ausgegeben (Maustaste bitte gedrückt lassen).

Aktuelle Position

Von dem aktuellen mit der linken Maustaste angeklicktem Punkt wird die absolute horizontale und vertikale Position oben rechts im Fenster ausgegeben (Maustaste bitte gedrückt lassen).

Horizontale Verschiebung

Verschiebt den ausgewählten Punkt horizontal

Im Geschwindigkeitsfenster für synchrone Funktionen: Verschiebung auf der Geraden im Positionsfenster

Temporär kann der linke Rand des Grafikbereichs damit verschoben werden, um die Skala besser lesen zu können.

Vertikale Verschiebung

Verschiebt den ausgewählten Punkt vertikal

Im Geschwindigkeitsfenster für synchrone Funktionen: Anpassung der Position im Positionsfenster an die Geschwindigkeit

Im Beschleunigungsfenster für Automatic Funktion: Anpassung der Beschleunigung

Verschiebung

Verschiebt den ausgewählten Punkt

Die folgenden Befehle gelten nur in dem Grafikfenster der Position:

Punkt einfügen

Fügt an der Position des Cursors einen Punkt ein

Synchrone Funktion

Der ausgewählte Abschnitt wird mit einer synchronen Funktion durchlaufen

Automatische Funktion

Für den ausgewählte Abschnitt wird automatisch eine optimale Funktion gewählt

inklusiv der Anpassung der Randwerte

Punkt löschen

Der ausgewählte Punkt wird gelöscht und der entsprechende Abschnitt ebenso

Die folgenden vier Punktbefehle definieren bestimmte Randbedingungen für die Punkte:

Die Punktart wird entsprechend im Tabellenfenster vor dem Punkt angezeigt. Durch die Einschränkung kann es dazu kommen, das die Endwerte eines Abschnittes mit den folgenden Anfangswerten nicht übereinstimmen.

Rastpunkt

Der ausgewählte Punkt wird als Rastpunkt definiert ( Randbedingung: v=0, a=0)

Geschwindigkeitspunkt

Der ausgewählte Punkt wird als Geschwindigkeitspunkt definiert ( Randbedingung: a=0)

Umkehrpunkt

Der ausgewählte Punkt wird als Umkehrpunkt definiert ( Randbedingung v=0)

Bewegungspunkt

Der ausgewählte Punkt wird als Bewegungspunkt definiert ( keine Randbedingungen)

Ignorepunkt

Der ausgewählte Punkt wird als Ignorepunkt definiert. Beim Download in die NC als Motion Function wird er als IGNOREPUNKT übertragen. In der Darstellung und beim Download als Tabellenpunkte wird er ignoriert. Durch Setzen eines der oberen vier Punktetypen wird diese Auswahl wieder zurückgesetzt.

Gleitpunkt

An der Position des Cursors wird die Start- oder Endposition des folgende/ vorherigen

Abschnittes gesetzt ohne Änderung des gewählten Abschnittes.

Mit dem horizontalen Verschieben kann dann der Punkt auf dem Abschnitt bewegt werden.

Lösche Gleitpunkt

Der Gleitpunkt wird gelöscht und die Abschnitte wieder wie vorher zusammengefügt

Rückgängig - Undo

Der letzte Änderungsbefehl des Slaves wird rückgangig gemacht. Dieser Befehl kann mehrfach angewandt werden.

Wiederherstellen - Redo

Das letzte Befehl rückgängig wird zurückgenommen die Daten entsprechend wieder hergestellt. Dieser Befehl kann mehrfach angewandt werden.


Übersicht

In den folgenden einfachen Beispielen soll die prinzipielle Vorgehensweise beim Erstellen eines Bewegungsdiagramms gezeigt werden.

Beispiel 1:

Für eine Drehbewegung soll für einer vorgegebenen Bereich der Masterposition eine bestimmte lineare Bewegung des Slaves erfolgen.

Beispiel 2:

Für eine Drehbewegung soll an einer vorgegebenen Masterposition eine bestimmte Slaveposition durchfahren werden mit einer definierten Geschwindigkeit

Beispiel 3:

Für eine Drehbewegung soll für einer vorgegebenen Bereich der Masterposition eine bestimmte lineare Bewegung des Slaves erfolgen. Die Bewegung hat keine Rast.

Beispiel 4:

Auf eine vorgegebene Bewegung soll aufsynchronisiert bzw. absynchronisiert werden.

Beispiel 5:

Eine Rast in Umkehr Bewegung soll realisiert werden

Beispiel 6:

Für eine Rast in Rast Bewegung soll durch grafisch interaktives verändern des Symmetriewertes die Beschleunigungen angepasst werden.

.


Beispiel 1

Beispiel 1:

In diesem einfachen Beispiel soll die Vorgehensweise beim Erstellen eines Bewegungsdiagramms gezeigt werden.

Aufgabenstellung:

Für eine Drehbewegung mit einer Masterachse von 0 bis 360 Grad, soll folgende Slavebewegung realisiert werden:

  1. Eine Rast (Stillstand der Slaveachse) von 0 bis 30 Grad
  2. Eine lineare Bewegung von 150 Grad bis 240 Grad von der Slaveposition 20mm zur Slaveposition 40mm.
  3. Eine Rast (Stillstand der Slaveachse) von 340 bis 360 Grad
  4. Die übrigen Bewegungsabschnitte sollen stoßfrei und ruckbegrenzt an die obigen anschließen.

in einer neuen Konfiguration des System Managers fügen wir unter den NC Configuration mit rechtem Mausklick per Append Task einen neuen Task ein. In den darin enthaltenen Tables erzeugen wir mit rechtem Mausklick per Append Table einen neuen Master und darunter wiederum einen Slave per Append Slave.

Nachdem man Slave 1 in dem Baum selektiert hat, erscheinen sowohl das Grafik- als auch das Tabellenfenster.

In dem Grafikfenster wird mit dem Befehl Punkt einfügen die Punkte ungefähr an den Stellen im Fenster angeklickt. Darauf werden die entsprechenden Werte in dem Tabellenfenster eingefügt.

Damit aus dem Bewegungsplan ein Bewegungsdiagramm wird. müssen jetzt noch ein paar Informationen hinzugefügt werden. Für den ersten, dritten und fünften Abschnitt definieren wir mit dem Befehl Synchrone Funktion per Mausklick in den entsprechenden Abschnitten, das dort ein lineare Bewegung stattfinden soll. In dem zweiten und vierten Abschnitt wird mit dem Befehl Automatische Funktion die automatisch Anpassung an die Randbedingungen realisiert.

Mit den Befehlen zum Verschieben kann jetzt die Position der Punkte manipuliert werden.

Per rechtem Mausklick und auswählen von Select 3 Graph View werden außer der Position des Slaves im ersten Grafikfenster auch die Geschwindigkeit im zweiten Grafikfenster und die Beschleunigung im dritten Grafikfenster dargestellt.

Die Größe der Fenster lässt sich interaktiv verändern, wenn man mit der Maus auf den Rand positioniert und dann mit linkem Mausklick diesen verschiebt.

Damit die exakten Positionen realisiert werden, gibt man jetzt diese in der Tabellenansicht ein.

In der Tabelle kann mit den gleichen Befehlen (Basisbefehle) wie im MS-Excel gearbeitet werden. Das Ausschneiden und Einfügen (Cut & Paste) ist in den einzelnen Zellen möglich.

In dem Eigenschaftsfenster des Slaves kann das entworfene Bewegungsdiagramm als Datei gespeichert werden.


Beispiel 2

Beispiel 2:

In diesem weiteren einfachen Beispiel soll die Vorgehensweise beim Erstellen eines Bewegungsdiagramms gezeigt werden.

Aufgabenstellung:

Für eine Drehbewegung mit einer Masterachse von 0 bis 360 Grad, soll folgende Slavebewegung realisiert werden:

  1. Eine Rast (Stillstand der Slaveachse) von 0 bis 50 Grad
  2. Eine Geschwindigkeit von -0.4 (normiert) in der Masterposition 150 und der Slaveposition 45.
  3. Eine Rast (Stillstand der Slaveachse) von 270 bis 360 Grad

in einer neuen Konfiguration des System Managers fügen wir unter den NC Configuration mit rechtem Mausklick per Append Task einen neuen Task ein. In den darin enthaltenen Tables erzeugen wir mit rechtem Mausklick per Append Table einen neuen Master und darunter wiederum einen Slave per Append Slave.

Nachdem man Slave 1 in dem Baum selektiert hat, erscheinen sowohl das Grafik- als auch das Tabellenfenster.

In dem Grafikfenster wird mit dem Befehl Punkt einfügen die Punkte ungefähr an den Stellen im Fenster angeklickt. Darauf werden die entsprechenden Werte in dem Tabellenfenster eingefügt.

Damit aus dem Bewegungsplan ein Bewegungsdiagramm wird. müssen jetzt noch ein paar Informationen hinzugefügt werden. Für den ersten, und vierten Abschnitt definieren wir mit dem Befehl Synchrone Funktion per Mausklick in den entsprechenden Abschnitten, das dort ein lineare Bewegung verwendet werden soll. In dem zweiten und dritten Abschnitt wird mit dem Befehl Automatische Funktion die automatisch Anpassung an die Randbedingungen realisiert.

Per rechtem Mausklick und auswählen von Select 3 Graph View werden außer der Position des Slaves im ersten Grafikfenster auch die Geschwindigkeit im zweiten Grafikfenster und die Beschleunigung im dritten Grafikfenster dargestellt.

Die Geschwindigkeit von -0.4 wird einfach in der Tabelle eingeben.

Die Beschleunigung ist standardmäßig auf den Wert Null eingestellt. Da man an dieser Stelle aber keinen Nulldurchgang der Beschleunigung erzwingen will, sondern einen möglichst ruckarmen Verlauf realisieren will. Verschiebt man jetzt interaktiv in dem Beschleunigungsfenster den dritten Punkt vertikal. Wenn man den Ruck dabei kontrollieren will, kann man einfach auch den Ruck darstellen durch rechten Mausklick und Auswahl von Select 4 Graph View.

In dem Eigenschaftsfenster des Slaves kann das entworfene Bewegungsdiagramm als Datei gespeichert werden.


Beispiel 3

Beispiel 3:

In diesem weiteren einfachen Beispiel soll die Vorgehensweise beim Erstellen eines Bewegungsdiagramms gezeigt werden.

Aufgabenstellung:

Für eine Drehbewegung mit einer Masterachse von 0 bis 360 Grad, soll folgende Slavebewegung realisiert werden:

  1. Eine Geschwindigkeit von -0.2 (normiert) von der Masterposition 140 bis 240 und ab der Slaveposition 10.
  2. Die Bewegung hat keine Rast.

in einer neuen Konfiguration des System Managers fügen wir unter den NC Configuration mit rechtem Mausklick per Append Task einen neuen Task ein. In den darin enthaltenen Tables erzeugen wir mit rechtem Mausklick per Append Table einen neuen Master und darunter wiederum einen Slave per Append Slave.

Nachdem man Slave 1 in dem Baum selektiert hat, erscheinen sowohl das Grafik- als auch das Tabellenfenster.

In dem Grafikfenster wird mit dem Befehl Punkt einfügen die Punkte ungefähr an den Stellen im Fenster angeklickt. Darauf werden die entsprechenden Werte in dem Tabellenfenster eingefügt.

Damit aus dem Bewegungsplan ein Bewegungsdiagramm wird. müssen jetzt noch ein paar Informationen hinzugefügt werden. Für den zweiten Abschnitt definieren wir mit dem Befehl Synchrone Funktion per Mausklick in dem Abschnitt, das dort ein lineare Bewegung verwendet werden soll. In dem ersten und dritten Abschnitt wird mit dem Befehl Automatische Funktion die automatisch Anpassung an die Randbedingungen realisiert. Per rechtem Mausklick und auswählen von Select 3 Graph View werden außer der Position des Slaves im ersten Grafikfenster auch die Geschwindigkeit im zweiten Grafikfenster und die Beschleunigung im dritten Grafikfenster dargestellt.

In den Eigenschaften des Masters wird eingestellt, dass es sich um eine rotatorische Achse handelt. Da die Anfangsposition dem Minimum des Masters und die Endposition dem Maximum des Masters entspricht. werden die ersten und zweiten Ableitungen am Ende des Diagramms gleich denen am Anfang gesetzt. Die Geschwindigkeit und Beschleunigung am Anfang kann jetzt noch interaktiv (vertikales Verschieben) in den Fenstern angepasst werden.

Nach dem Speichern der Daten in der Registry und erneuten Starten des TwinCAT können die Online Daten dargestellt werden

.

Sie werden in der gleichen Farbe gepunktet dargestellt.


Beispiel 4

Beispiel 4:

In diesem weiteren einfachen Beispiel soll die Vorgehensweise beim Erstellen eines Bewegungsdiagramms gezeigt werden.

Aufgabenstellung:

Für eine Drehbewegung mit einer Masterachse von 0 bis 360 Grad, soll folgende Slavebewegung realisiert werden:

  1. Eine Rast (Stillstand der Slaveachse) von 0 bis 30 Grad
  2. Auf eine vorgegebene Bewegung (von der Masterposition 100 und der Slaveposition 10 zu den Positionen 200 bzw. 90 mit der Bewegungsfunktion Polynom 8er Potenz) soll aufsynchronisiert bzw. absynchronisiert werden.
  3. Eine Rast (Stillstand der Slaveachse) von 300 bis 360 Grad

in einer neuen Konfiguration des System Managers fügen wir unter den NC Configuration mit rechtem Mausklick per Append Task einen neuen Task ein. In den darin enthaltenen Tables erzeugen wir mit rechtem Mausklick per Append Table einen neuen Master und darunter wiederum einen Slave per Append Slave.

Nachdem man Slave 1 in dem Baum selektiert hat, erscheinen sowohl das Grafik- als auch das Tabellenfenster.

In dem Grafikfenster wird mit dem Befehl Punkt einfügen die Punkte ungefähr an den Stellen im Fenster angeklickt. Darauf werden die entsprechenden Werte in dem Tabellenfenster eingefügt.

Damit aus dem Bewegungsplan ein Bewegungsdiagramm wird. müssen jetzt noch ein paar Informationen hinzugefügt werden. Für den ersten, dritten und fünften Abschnitt definieren wir mit dem Befehl Synchrone Funktion per Mausklick in den entsprechenden Abschnitten, das dort ein lineare Bewegung verwendet werden soll. In dem zweiten und vierten Abschnitt wird mit dem Befehl Automatische Funktion die automatisch Anpassung an die Randbedingungen realisiert.

Per rechtem Mausklick und auswählen von Select 3 Graph View werden außer der Position des Slaves im ersten Grafikfenster auch die Geschwindigkeit im zweiten Grafikfenster und die Beschleunigung im dritten Grafikfenster dargestellt.

Mit dem Befehl Gleitpunkt und Antippen eines Punktes in der ersten Hälfte des dritten Abschnitts wird der Endpunkt des zweiten Abschnitts auf den Funktionsgraphen des dritten aufgesetzt. Mit dem Befehl Gleitpunkt und Antippen eines Punktes in der zweiten Hälfte des dritten Abschnitts wird der Anfangspunkt des vierten Abschnitts auf den Funktionsgraphen des dritten aufgesetzt. Jetzt sollte in der Tabelle für den dritten Abschnitt die Master und Slavepositionen gesetzt und der Funktionstyp in der Kombobox auf Polynom8 geändert werden. Ebenso werden jetzt die Master- und Slavepositionen des ersten und fünften Abschnitts gesetzt.

Mit der vertikalen Verschiebung kann jetzt der Endpunkt des dritten bzw. der Anfangspunkt des vierten Abschnitts auf dem dritten verschoben werden, dabei werden die erste und zweite Ableitung automatisch angepasst.

Per rechtem Mausklick und Export Slave .. kann das entworfene Bewegungsdiagramm als Exportdatei gespeichert werden, die dann später in irgendeinem Projekt im System Manager wieder importiert werden kann.


Beispiel 5

Beispiel 5:

In diesem einfachen Beispiel soll die Vorgehensweise beim Erstellen eines Bewegungsdiagramms gezeigt werden.

Aufgabenstellung:

Für eine Drehbewegung mit einer Masterachse von 0 bis 360 Grad, soll folgende Slavebewegung realisiert werden:

  1. Eine Rast (Stillstand der Slaveachse) von 0 bis 20 Grad
  2. Eine Umkehr bei 180 Grad bei einer Slaveposition von 100.
  3. Eine Rast (Stillstand der Slaveachse) von 340 bis 360 Grad

in einer neuen Konfiguration des System Managers fügen wir unter den NC Configuration mit rechtem Mausklick per Append Task einen neuen Task ein. In den darin enthaltenen Tables erzeugen wir mit rechtem Mausklick per Append Table einen neuen Master und darunter wiederum einen Slave per Append Slave.

Nachdem man Slave 1 in dem Baum selektiert hat, erscheinen sowohl das Grafik- als auch das Tabellenfenster.

In dem Grafikfenster wird mit dem Befehl Punkt einfügen die Punkte ungefähr an den Stellen im Fenster angeklickt. Darauf werden die entsprechenden Werte in dem Tabellenfenster eingefügt.

Damit aus dem Bewegungsplan ein Bewegungsdiagramm wird. müssen jetzt noch ein paar Informationen hinzugefügt werden. Für den ersten und vierten Abschnitt definieren wir mit dem Befehl Synchrone Funktion per Mausklick in den entsprechenden Abschnitten, das dort ein lineare Bewegung stattfinden soll. In dem zweiten Abschnitt wird in der Tabelle der Typ der Funktion als Beschleunigungstrapez von Rast in Umkehr (AccTrapezoid_RT: Rest in Turn) und in dem dritten Abschnitt als Beschleunigungstrapez von Umkehr in Rast (AccTrapezoid_TR) gewählt.

Per rechtem Mausklick und auswählen von Select 3 Graph View werden außer der Position des Slaves im ersten Grafikfenster auch die Geschwindigkeit im zweiten Grafikfenster und die Beschleunigung im dritten Grafikfenster dargestellt.

Die Größe der Fenster lässt sich interaktiv verändern, wenn man mit der Maus auf den Rand positioniert und dann mit linkem Mausklick diesen verschiebt.

Damit die exakten Positionen realisiert werden, gibt man jetzt diese in der Tabellenansicht ein.

Da die Randbedingungen in dem Punkt (180,100) noch so sind, dass die zweite Ableitung Null ist, ergibt sich die obige Darstellung. Hier werden aber noch Polynome 5ter Ordnung für die Funktion genutzt, da das Beschleunigungstrapez diese Randbedingungen nicht erfüllen kann. Wenn an der Masterposition der Umkehr jetzt interaktiv in der Grafik der Beschleunigung der Punkt in die negative Richtung verschoben wird, kann ab einer definierten Beschleunigung das Beschleunigungstrapez verwendet werden.

Die Beschleunigung in dem Umkehrpunkt kann dann noch weiter interaktiv manipuliert werden.


Beispiel 6

Beispiel 6:

In diesem einfachen Beispiel soll die Vorgehensweise beim Erstellen eines Bewegungsdiagramms gezeigt werden.

Aufgabenstellung:

Für eine Drehbewegung mit einer Masterachse von 0 bis 360 Grad, soll folgende Slavebewegung realisiert werden:

  1. Eine Rast (Stillstand der Slaveachse) von 0 bis 20 Grad
  2. Die Rast von 170 bis 190 Grad mit einer Slaveposition von 100, soll jeweils mit einem Polynom 8ter Potenz verbunden werden.
  3. Eine Rast (Stillstand der Slaveachse) von 340 bis 360 Grad

in einer neuen Konfiguration des System Managers fügen wir unter den NC Configuration mit rechtem Mausklick per Append Task einen neuen Task ein. In den darin enthaltenen Tables erzeugen wir mit rechtem Mausklick per Append Table einen neuen Master und darunter wiederum einen Slave per Append Slave.

Nachdem man Slave 1 in dem Baum selektiert hat, erscheinen sowohl das Grafik- als auch das Tabellenfenster.

In dem Grafikfenster wird mit dem Befehl Punkt einfügen die Punkte ungefähr an den Stellen im Fenster angeklickt. Darauf werden die entsprechenden Werte in dem Tabellenfenster eingefügt.

Damit aus dem Bewegungsplan ein Bewegungsdiagramm wird. müssen jetzt noch ein paar Informationen hinzugefügt werden. Für den ersten, dritten und fünften Abschnitt definieren wir mit dem Befehl Synchrone Funktion per Mausklick in den entsprechenden Abschnitten, das dort ein lineare Bewegung stattfinden soll. In dem zweiten und vierten Abschnitt wird in der Tabelle der Typ der Funktion als Polynom 8ter Potenz festgelegt.

Per rechtem Mausklick und auswählen von Select 3 Graph View werden außer der Position des Slaves im ersten Grafikfenster auch die Geschwindigkeit im zweiten Grafikfenster und die Beschleunigung im dritten Grafikfenster dargestellt.

Die Größe der Fenster lässt sich interaktiv verändern, wenn man mit der Maus auf den Rand positioniert und dann mit linkem Mausklick diesen verschiebt.

Damit die exakten Positionen realisiert werden, gibt man jetzt diese in der Tabellenansicht ein.

In der Grafik der Beschleunigung sind jetzt an dem Nulldurchgang ebenfalls Punkte zu sehen, diese können horizontal verschoben werden. Dadurch wird der Symmetriewert verändert. So können die positive und negative Beschleunigung interaktiv angepasst werden.

Diese Möglichkeit besteht aber nur für die Rast in Rast Bewegungsgesetze (Polynom3, Polynom5, Polynom8, Sinusline, ModSinusline, Bestehorn, AccTrapezoid), die keine weiteren Parameter zum Verändern haben.