Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


TcDriveTopServer - Overview

TS6371 | TwinCAT DriveTopServer

Allgemeine Informationen zum TwinCAT DriveTopServer

Der TwinCAT DriveTopServer und die Indramat DriveTop Software ( © Rexroth Indramat ) bieten neben dem TwinCAT Systemmanager eine weitere Möglichkeit zur Initialisierung und Visualisierung der Parameterdaten von Indramat Antrieben in einem SERCOS System.

Aus der Sichtweise des SERCOS Interfaces nutzt der DriveTopServer die TwinCAT ADS Kommunikation. Als Schnittstelle zur DriveTop Software ist der Datenaustausch auf DDE Dienste nach DriveTop Konvention abgebildet. Andere Programme können weiterhin parallel den ADS Servicekanal nutzen.

Der TwinCAT DriveTopServer stellt die gesamte Bandbreite an Funktionalitäten der Indramat DriveTop Software zur Verfügung. Der DriveTopServer unterstützt alle TwinCAT SERCOS Masterkarten ab v2.7 Build 455.

Voraussetzungen für den TcDriveTopServer

•TwinCAT System Service mit konfiguriertem SERCOS Interface (v2.7 Build 455).

•Indramat DriveTop Software

Installation/Deinstallation

Die Installation ersetzt den Indramat Driveserver und somit die Kommunikation über die serielle Schnittstelle. Eine Installation ist nur möglich, sofern eine unterstütze Version (13Vxx) der DriveTop Software bereits installiert wurde. Eine Deinstallation restauriert wieder den Original Indramat Driveserver.

Anmerkung: Da bei der Installation des DriveTopServers einige Registry-Einträge und gegebenenfalls INI-Dateien verändert werden, ist es ratsam vor einer Deinstallation der DriveTop Software zunächst den DriveTopServer zu deinstallieren.

In Windows NT/2000 integriert

Der TcDriveTopServer befindet sich nach dem Start in Windows - Systray.

Verbindungsaufbau DriveTop <> TwinCAT DriveTopServer

Die Verbindung zwischen der DriveTop Anwendung (Client) und dem TwinCAT DriveTopServer wird über 'Optionen/Verbindung/Online RS232/485 am Antrieb' aufgebaut. Abgebaut wird die Verbindung über '.../Keine Verbindung'. Beim Abbau der Verbindung wird der TcDriveTopServer heruntergefahren. Die DDE Verbindung lässt sich ebenfalls über das Beenden des DriveTopServers schließen.

Ist die Verbindung hergestellt, wird nach verfügbaren SERCOS Antrieben im Bus gesucht. Anschließend ist das entsprechende Device beim DriveTop selektierbar.

Konfiguriertes TwinCAT ADS Interface

Die Verbindung zwischen der DriveTop Anwendung (Client) und dem TwinCAT DriveTopServer setzt ein konfiguriertes SERCOS Ringsystem und die Verfügbarkeit über die TwinCAT ADS Schnittstelle voraus. Ist die ADS Schnittstelle nicht verfügbar, beendet sich der DriveTopServer nach Bestätigung einer Message automatisch.

Mehrere SERCOS Ringe innerhalb eines PC Systems

Befinden sich in einem System mehrere SERCOS Interface-Karten, sind die Antriebe ebenfalls über den TwinCAT DriveTopServer und ein DriveTop komfortabel parametrierbar. Verfügbare Antriebe werden in der Liste des DriveTop Tools dargestellt. Der Adressbereich der Antriebe ist von 0 bis 127 zulässig.

Resultieren aus der Vielzahl der SERCOS Ringe identische Antriebsadressen, werden diese reorganisiert und von 0 aufsteigend dargestellt. Diese Adressen sind für diesen Fall als virtuell zu betrachten und entsprechen nicht mehr den physikalischen Einstellungen. Zur leichten Handhabung ist es ratsam, die Achsbezeichnungen signifikant zu gestalten.