Übersicht

In dieser Beckhoff Information System Rubrik ist das Thema "Connectivity" zusammengefaßt. Es ist gegliedert in folgenden Teile:

1. TwinCAT ADS Referenz

ADS Einführung / Übersicht

Der erste Teil ist eine Einführung in die Beckhoff ADS-Welt. ADS steht für "Automation Device Specification" und beschreibt eine geräte- und Feldbus-unabhängige Schnittstelle. Diese Schnittstelle ist von Beckhoff spezifiziert worden, das Protokoll ist detailliert offengelegt und dokumentiert.

Für die Microsoft Windows Betriebssysteme (NT / Windows 2000 / XP / Vista /... und CE) stehen kostenlose ADS-Komponenten (ADS-OCX / DLL / NET / ...) zur Integration in Compiler bzw.Tools für eigene Anwendungen zur Verfügung.

Die ADS-Komponenten werden mit dem TwinCAT-System installiert und befinden sich im Verzeichnis "..\TwinCAT\Ads Api".
Alternativ sind die ADS-Komponenten (Ausnahme: ADS-OCX, diese ist dem TwinCAT Basissystem zugehörig) in dem kostenlosen Supplement-Produkt "TwinCAT ADS Communication Library" zusammengefaßt.

2. TwinCAT ADS Beispiele

Compiler Integration / ADS Beispiele

Dieser Teil enthält viele Beispiele zur Integration der ADS-Komponenten in eigene Anwendungen und Werkzeuge, sowie Beispiele zur Anwendung der ADS-Schnittstellen.

3. TwinCAT ADS Device Dokumentation

Übersicht ADS Geräte und deren Dienste

ADS beschreibt das Interface und den Nachrichtenaustausch zwischen Objekten. In diesem Teil werden die ADS-Server beschrieben:

Beispiel: Welche ADS-Server stehen zur Verfügung und sind per ADS erreichbar, um welche Dienste auszuführen?

4. Fernwartung / Ferndiagnose

Übersicht Fernwartung

Das Thema Fernwartung ist umfangreich, in diesem Teil werden verschiedenen Varianten vorgestellt:

  • Reine IT Lösungen (Standard Betriebssystemfunktionen oder Lösungen von Drittanbietern)
  • TwinCAT-Netzwerk-Fähigkeiten im lokalen LAN bzw. globalen WAN und in komplett Microsoft-basierenden oder heterogenen Netzen
  • Fernzugriffe per Modem
  • Webbasierende Diagnose- und Konfigurationsmöglichkeiten

5. TwinCAT Supplement Produkte

Übersicht Supplement Produkte

Das TwinCAT System ist flexibel, mit diversen Softwaremodulen vielfältig erweiterbar. Für den Bereich "Connectivity" stehen u.a. folgende optionale TwinCAT Supplement-Erweiterungen zur Verfügung:

  • TwinCAT OPC Server
  • TwinCAT TCP Server
  • TwinCAT Modbus TCP Server
  • TwinCAT SMTP/SMS Server
  • TwinCAT PLC Serial Communication
  • TwinCAT PLC Serial Communication 3964R-RK512
  • TwinCAT PLC Modbus RTU
  • TwinCAT IEC-60870-5-10x
  • ...