CNC Einbindung

TwinCAT CNC: Überblick

TwinCAT CNC

Das Produkt TwinCAT CNC basiert auf dem Produkt TwinCAT PLC ergänzt durch den leistungsfähigen CNC-Kern. Diese Kombination ermöglicht eine vollständige CNC Maschinensteuerung als Software auf einem Industrie PC zu realisieren. Die Echtzeit, Feldbus und IEC 61131 Eigenschaften von TwinCAT und die Leistungsfähigkeit des CNC-Kerns ergeben ein z.Zt. konkurrenzloses, modernes Steuerungssystem, das deutlich flexibler, performanter und erweiterbarer ist als herkömmliche Systeme.

Der folgende Überblick beschreibt die Einbindung des CNC-Kerns in TwinCAT. Es wird eine gute Kenntnis des TwinCAT PLC Produktes vorausgesetzt und bei spezielleren Punkten, die den CNC-Kern betreffen, wird auf entsprechende Dokumente verwiesen. Es werden daher in diesem Dokument nur die Punkte angesprochen, die im TwinCAT System für die Einbindung des CNC-Kerns erweitert wurden:

Eigenschaften

Installation

Konfiguration im TwinCAT System Manager

Konfiguration über Beschreibungsdateien (*.LIS Dateien )

High Level Interfaces (HLI)

Werkzeugverwaltung

Meldungen und Fehlermeldungen

Dokumentation


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Eigenschaften

TwinCAT CNC ist eine mehrkanälige CNC Steuerung, die u.a. interpolierende fünf-achs Bearbeitungen ermöglicht. Die Programmierung der Bahnbewegung erfolgt in DIN 66025. Eine direkte Kommunikation zur integrierten IEC 61131 SPS ermöglicht schnelle und echtzeitfähige Eingriffe in die CNC, um auch komplexe Abläufe realisieren zu können.

Über das E/A System von TwinCAT besteht eine Anbindung an alle relevanten Feldbussysteme inklusive der für die Achsansteuerung interessanten digitalen Schnittstellen SERCOS interface und Profibus DP im taktsynchronen Betrieb (Profibus MC).

Die Kommunikation zu Oberflächenprogrammen (z.B. Bedienoberfläche) erfolgt direkt per ADS oder über die integrierte SPS, mit der wiederum per ADS oder OPC kommuniziert werden kann. Die SPS kann dabei über das HLI Interface auf nahezu denselben Datenbestand zugreifen wie die CNC selbst und ermöglicht noch zusätzliche Logik zu integrieren.


Installation des CNC-Kerns

Die Installation der TwinCAT CNC Version erfolgt in zwei Schritten:
Im ersten Schritt wird eine TwinCAT Version, mit Level NC I installiert. Anschließend (nach Reboot) muss die TwinCAT CNC Installation aufgerufen werden (zweiter Reboot erforderlich).


Konfiguration

TwinCAT CNC: Überblick

Konfiguration des CNC-Kerns im TwinCAT System Manager

Die Basis-Konfiguration des CNC-Kerns erfolgt im TwinCAT System Manager. Alle Einstellungen, die auch andere Systembestandteile betreffen und die gesamte E/A Konfiguration des CNC-Kerns, werden auf übliche Weise im System Manager durchgeführt.

Nach der Installation von TwinCAT CNC erscheint im Baum des System Managers ein zusätzlicher Toplevel Punkt "CNC Konfiguration". Das Aktivieren der CNC Funktion erfolgt durch Anfügen einer "CNC Task" unterhalb der CNC Konfiguration (z.B. über das Kontextmenü der CNC Konfiguration). Nachdem ein geeigneter Name für die Task angegeben wurde kann eine Prototyp Datei für die allgemeine Konfiguration des CNC Kerns angegeben werden.

Die ausgewählte Prototyp-Datei wird als Kopie in die System Manager Konfiguration übernommen und kann bei Bedarf editiert werden. Die für die Basis-Konfiguration notwendigen Einträge in der Konfigurationsdatei werden vom System Manager automatisch angepasst. Der Baum im System Manager hat nun folgenden Aufbau:

Es wurden 3 Tasks, ein Prozessabbild und eine Achsengruppe angelegt, die z.Zt. noch keine Achsen beinhaltet. Die erste Task, die "CNC-Task GEO", arbeitet im Interpolationstakt der CNC und berechnet u.a. die jeweiligen Sollwerte für die Achsen und führt gegebenenfalls die Regelung der Achsen durch. Diese Task sollte die höchstpriore Task im System sein. Die "CNC-Task SDA" übernimmt die Dekodierung und Aufbereitung der NC-Programme und sollte daher niederprior als die GEO Task sein. Die "CNC-Task COM" ist für die Kommunikationsanbindung des CNC-Kerns zuständig. Über diese Task werden sämtliche ADS Aufträge abgewickelt.

Zum Betreiben des CNC Kerns müssen noch jeweils mindestens eine Achse und ein Kanal angelegt werden. Kanäle werden unterhalb der "CNC-Task GEO" als Unterelemente (z.B. über Kontextmenü) hinzugefügt. Beim Anfügen werden wieder Prototyp-Konfigurationsdateien abgefragt, die bereits eine Grobkonfiguration des Kanals beinhalten können. Es wird jeweils eine Prototypdatei für SDA Daten, Nullpunktverschiebungsdaten, Platzversatzdaten und - wenn keine externe Werkzeugverwaltung aktiv ist - auch eine für Werkzeugdaten abgefragt.

Achsen werden unterhalb der Achsengruppe angelegt. Auch hier wird dieser nach einer Prototypdatei gefragt, die bereits eine Achstyp spezifische Konfiguration beinhalten kann. Wie bereits bei der Hauptkonfigurationsdatei des CNC-Kerns, kontrolliert der TwinCAT System Manager einige Einträge in den Konfigurationsdateien für Achsen und Kanäle. Dadurch wird eine in sich konsistente und auch mit anderen Systembestandteilen übereinstimmende Konfiguration sichergestellt.

Achskonfiguration

Nach dem Einfügen von Achsen wird deren Achstyp automatisch auf Simulation eingestellt und die Achsen haben keine E/A Anbindung. Dieses kann über den Achstyp Reiter der jeweiligen Achse verändert werden. Dazu ist im ersten Schritt der gewünschte Achstyp auszuwählen. Z.Zt. stehen folgende Achstypen zur Auswahl:

  1. Simulation
  2. SERCOS interface
  3. Profibus (im taktsynchronen Betrieb, mit und ohne "Dynamic Servo Control" (DSC))

Prozessdaten

Nach der Auswahl des gewünschten Achstyps (außer bei Simulationsachsen) kann eine automatische Verknüpfung mit dem entsprechenden Antriebsgerät durchgeführt werden. Dieses Gerät muss allerdings zuvor im System Manager angelegt worden sein. Außerdem sollte die Prozessdatenkonfiguration des jeweiligen Antriebsgerätes bereits erfolgt sein, da diese in die CNC Konfiguration übernommen werden.

Durch Betätigen des Verknüpfungsbuttons erscheint eine Auswahlliste aller im System verfügbaren Antriebsgeräte, die zum angewählten Achstyp kompatibel sind:

Nach Auswahl des entsprechenden Gerätes werden die Prozessdaten in die CNC-Achse übernommen und verknüpft. Es werden außerdem passende Einträge in der Achskonfigurationsdatei vorgenommen, die dem CNC Kern die Anordnung und Typen der Prozessdaten mitteilen.

Kanalzuordnung

Jeder Achse kann bereits während der Konfiguration ein Kanal zugeordnet werden. Hierbei handelt es um eine Defaultzuordnung, d.h. diese Zuordnung kann zur Laufzeit verändert werden. Zur Kanalzuordnung gehört neben der Angabe des entsprechenden Kanals auch die Achsbezeichnung, die die Achse in NC-Programmen dieses Kanals erhalten soll, sowie der kanalspezifische Achsindex, den die Achse erhalten soll.


Konfiguration über Beschreibungsdateien

TwinCAT CNC: Überblick

Konfiguration über Beschreibungsdateien (*.lis Dateien)


Implementation des High Level Intefaces (HLI)

TwinCAT CNC: Überblick

Implementation des High Level Interfaces (HLI)

Das High Level Interface (HLI) dient als Kommunikationsdatenstruktur zwischen dem CNC Kern und der SPS. Es handelt sich um einen gemeinsam genutzten Speicherbereich, der in unterschiedlichen Abschnitten jeweils von der einen Seite versorgt und von der anderen Seite gelesen und gegebenenfalls quittiert wird. Das HLI-Interface gliedert sich in globale, kanal- und achsspezifische Bereiche sowie in Datenbereiche für gemeinsam benutzte Variablen (VE) und den "Channel Task Manager" (CTM). Die Anzahl der jeweiligen Bereiche wird vom System Manager teilweise automatisch (Achsen und Kanäle) und manuell (CTM und VE) vorgegeben:

Der Speicher für das HLI-Interface wird vom CNC Kern angelegt und initialisiert. Wenn das SPS Programm anläuft, kann das Programm per ADS den Pointer auf den gemeinsam benutzten Speicherbereich abfragen und dann eigene Pointer auf die Bestandteile des Interface initialisieren. Dieser Vorgang wird von einer mitgelieferten SPS Bibliothek automatisiert. Dazu ist zu Programmbeginn ein entsprechender Baustein aus der Bibliothek aufzurufen.

Der interne Aufbau des HLI-Interfaces wird in einer separaten Dokumentation beschrieben.


Kommunikation zum CNC-Kern

in Vorbereitung


Realisierung der Werkzeugverwaltung

Zur Nutzung der Werkzeugverwaltung des CNC Kerns steht die interne oder externe Werkzeugverwaltung zur Verfügung.

Bei der externen Werkzeugverwaltung werden die Daten in der SPS gehalten und vom CNC Kern abgefragt und gegebenenfalls aktualisiert.

Der Aufbau der Werkzeugverwaltung des CNC Kerns wird in einer separaten Dokumentation beschrieben.


Meldungen und Fehlermeldungen

Meldungen und Fehler von der CNC werden über das HLI Interface an die SPS weitergereicht. Sie werden dann von der SPS verwaltet und dem TwinCAT Eventlogger weitergeleitet. Nähere Informationen zum Eventlogger ist in dessen Dokumentation zu finden.

Detailliertere Meldungen können mit dem "99-Punkte Programm" vom CNC Kern abgerufen werden.


Verweis auf andere Dokumentationen

TwinCAT CNC: Dokumentationen

TwinCAT CNC Dokumentationen

Systembeschreibung
TwinCAT CNC Systemparameter

Anwenderdokumentationen
TwinCAT CNC Programmieranleitung TwinCAT CNC Diagnose

Allgemeine Parametrierung
TwinCAT CNC Hochlaufliste TwinCAT CNC Handbetriebparameter

Achsspezifische Parametrierung
TwinCAT CNC Achsparameter TwinCAT CNC Achskorrekturwertliste TwinCAT CNC Inbetriebnahme von Achsen

Kanalspezifische Parametrierung
TwinCAT CNC Kanalparameter | TwinCAT CNC Werkzeugdaten | TwinCAT CNC Nullpunktverschiebungen | TwinCAT CNC Platzversatzdaten
TwinCAT CNC Externe Variablen | TwinCAT CNC Kinematische Transformationen |  |

Funktionsbeschreibungen
Schleppabstandsüberwachung | Softwareendschalter | Positionsüberwachung | Handbetriebsoffsetgrenzen
Losekompensation | Achsfilter | Pendelachsen | Achskopplung über HLI
Parametrierung des DRIVE Befehls |  |  |
M- und H- Funktionen | Koordinatensysteme und Verschiebungen | Achskollisionsüberwachung | Messen
Achskompensationen | Satzvorlauf | Vorwärts-/Rückwärtsfahren auf der Bahn | Echtzeitinformationen in der CNC
Syntaxcheck | Externe Werkzeugverwaltung | Gantrybetrieb | CNC Programmverschlüsselung
ADS Zugriff auf die CNC | Arbeits- und Schutzräume | Einschieben eines CNC Programms | Konturvisualisierung
Data Streaming | Online Werkzeugkompensation | CNC Zyklen | Export von V.E. Variablen
Dynamik Kenngrößen | HSC Funktionen |  |
Referenzpunktfahrt | Einzelschrittbetrieb | Abstandsregelung | Vorsteuerung
Spindel | Spindelbetriebsarten |  |

Schnittstellenbeschreibung
TwinCAT CNC HLI Interface

Stand: Funktionsbeschreibungen: 07.12.2011