Übersicht Building Automation Framework

Die Raumautomation hat in den letzten Jahren immer mehr an Bedeutung gewonnen. Hierunter versteht man die gewerkeübergreifende Automation innerhalb von Räumen bzw. bei größeren Räumen auch von Zonen. Funktionen aus dem Bereich Beleuchtung, Klimatisierung, Sonnenschutz und Fenster werden so miteinander kombiniert, dass für den Betreiber eine verbesserte Energiebilanz erreicht wird. Heizen oder Kühlen bei geöffnetem Fenster oder zusätzliche Beleuchtung bei genügend Tageslicht verschlechtert die Energieeffizienz. Besonderes Potenzial bietet z.B. eine intelligente Fassadensteuerung. So kann an sonnigen Wintertagen die Beschattung am Wochenende so angefahren werden, dass die Räume durch die Sonne ausreichend geheizt werden. Im Sommer wird durch eine Sommernachtauskühlung die Kühllast reduziert. Nicht belegte Räume werden komplett beschattet. Beleuchtung und Beschattung können so aufeinander abgestimmt werden, dass eine konstant gleichbleibende Lichtstärke kontinuierlich vorhanden ist. Für den Nutzer entsteht erhöhter Nutzungskomfort.

Von Gebäuden wie Büros, Hotels, Schulen, Museen oder Ladenlokalen wird heute erwartet, dass sie sich schnell und einfach an die wechselnden Anforderungen unterschiedlicher Nutzer anpassen lassen. Hier werden besondere Anforderungen an das Automationssystem gestellt, damit Änderungen der Flächenaufteilung oder -nutzung ohne Umverdrahtung erfolgen können. Diese Anpassungen sind mit dem TwinCAT Building Automation Framework auch ohne Programmierkenntnisse möglich. Eine flache Systemarchitektur und ein einheitliches Tool für alle Gewerke lassen Änderungen und Erweiterungen durch den Benutzer einfach und schnell zu.

Gerade bei mittleren bis größeren Gebäuden wird der Systemintegrator vor besondere Herausforderungen gestellt. Die große Anzahl der Datenpunkte und die Tatsache, dass das Projekt in den meisten Fällen über mehrere Controller verteilt ist, erfordert leistungsfähige Werkzeuge zur Inbetriebnahme. Datenpunkte, Funktionen und deren Zusammenhänge, sowie die Kommunikation der Controller untereinander müssen übersichtlich dargestellt werden.

Hier setzt das TwinCAT Building Automation Framework an. Das Konzept der parametrierbaren SPS-Bibliothek bietet auf der einen Seite die Möglichkeit, Funktionen der Raumautomation komfortabel zu parametrieren. Sensoren, Aktoren, Gruppen, Regler, Zeitschaltfunktionen, Wetterstationen, Energieerfassung und Szenen sind in einer SPS-Bibliothek enthalten, die durch ein Konfigurationsprogramm, dem TwinCAT Building Automation Manager, intuitiv parametriert werden. Auf der anderen Seite kann die Funktion des Controllers durch eigene SPS-Bausteine in IEC 61131-3 erweitert werden. Funktionsblöcke bieten die Möglichkeit, innerhalb der SPS auf die konfigurierten Module zuzugreifen.

Das TwinCAT Building Automation Framework bietet besondere Unterstützung bei der Kommunikation der Controller untereinander. Gruppen die Aktoren oder Sensoren beinhalten, sind nicht auf den lokalen Controller begrenzt. Gruppen können auch Elemente von Controllern enthalten, die über ein Netzwerk miteinander verbunden sind. Auch Szenen sind nicht auf den lokalen Controller begrenzt. So kann eine Szene eine weitere Szene aktivieren. Diese Szene kann sich auf einem beliebigen anderen Controller befinden. Das TwinCAT Building Automation Framework stellt alle notwendigen Ressourcen für die Kommunikation der Controller untereinander zur Verfügung. Basis hierbei sind die TwinCAT Echtzeit Netzwerkvariablen. Durch diese wird eine fast verzögerungsfreie Kommunikation sichergestellt.

Das Building Automation Framework stellt folgende Funktionen bereit:

  • digitale Sensoren
  • analoge Sensoren
  • Zähler
  • Lampen
  • Jalousieantriebe
  • Ventil-Stellantriebe
  • Fensterantriebe
  • Gruppen mit Sensoren oder Aktoren
  • Beleuchtungen
  • Beschattungen
  • Heizen/Kühlen
  • Raumbediengeräte
  • Szenen
  • Zeitschaltfunktionen
  • Wetterstationen
  • Energieerfassung
  • Sicherheitsbeleuchtung (per DALI)
  • DALI
  • EnOcean
  • ...

In Anlehnung an die VDI 3813 - Teil 2 sind mit dem TwinCAT Building Automation Framework verschiedene Funktionen der Raumautomation realisierbar, wie z.B.:

  • Konstantlichtregelung
  • Helligkeitsabhängiges Automatiklicht
  • Zeitprogramme für die Betriebsarten der Klimaregelung und Begrenzung der Beleuchtungsstärke
  • Fensterüberwachung
  • Präsenzumschaltung
  • Sonnenschutz-Thermoautomatik
  • freie Nachtkühlung
  • ...

Ergänzt werden die Möglichkeiten des TwinCAT Building Automation Framework durch Zusatzmodule. Derzeit werden Module angeboten für die Erzeugung von Klemmenlisten, Einlesen von Excellisten, Dokumentieren der eingestellten Parameter bis hin zur Generierung von Bedienungsoberflächen.

Unterschiede Framework - Bibliothek

Eine Bibliothek stellt Funktionen zu bestimmten Aufgabenstellungen bereit, in Form einer Sammlung von Funktionen, Funktionsblöcken und Datentypen eines Aufgabengebietes. Ein Framework stellt eine Schicht über verschiedene Bibliotheken dar und vereinfacht somit die Softwareentwicklung. Frameworks enthalten bereits Funktionalität, die in die eigentliche Implementierung eingebunden werden kann. Im Gegensatz zur Bibliothek, aus der der Programmierer bei Bedarf einzelne Funktionsblöcke verwendet, gibt das Framework die Struktur für die Anwendung vor.

Zitat aus: Entwurfsmuster - Elemente wiederverwendbarer objektorientierter Software (Gamma, Helm, Johnson und Vlissides von Addison-Wesley):
"Ein Framework ist eine Menge von kooperierenden Klassen (Funktionsblöcke), die einen wiederverwendbaren Entwurf für einen bestimmten Anwendungskontext vorgeben. Das Framework bestimmt dabei die Architektur der Applikation."

Ein Vorteil von Frameworks ist, dass sie bereits fertig entworfene und implementierte Softwarestrukturen bereitstellen, die wieder verwendet werden können. So muss der Entwickler z. B. Grundfunktionalitäten, wie das Verwalten von Gruppenobjekten, nicht jedesmal neu implementieren. Durch die Kapselung von Implementierungsdetails wird die Anwendung modularer und die Softwarequalität steigt. Ein weiterer Vorteil von Frameworks ist die Erweiterbarkeit. Das Framework stellt dem Entwickler feste Punkte bereit, an denen er intervenieren und das Framework konfigurieren und erweitern kann.


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Architektur

TS8100 | TwinCAT Building Automation Framework V2.2x

Architektur Building Automation Framework

Das TwinCAT Building Automation Framework besteht im Wesentlichen aus zwei Bestandteilen: dem TwinCAT Building Automation Manager und einer SPS-Bibliothek, in der das Applikationsprogramm enthalten ist. Der TwinCAT Building Automation Manager dient dazu, das Applikationsprogramm zu parametrieren und das E/A-Mapping zu generieren. Für das Generieren des E/A-Mappings erzeugt der TwinCAT Building Automation Manager für jeden Controller eine Projektdatei für den TwinCAT System Manager (*.tsm-Datei) und aktiviert diese.

Während der TwinCAT Building Automation Manager nur zur Inbetriebnahme benötigt wird, enthält die SPS-Bibliothek mit dem Applikationsprogramm alle notwendigen Funktionsbausteine, die zur Laufzeit notwendig sind. Im Gegensatz zu den meisten anderen SPS-Bibliotheken enthält die SPS-Bibliothek vom Building Automation Framework nicht einzelne Funktionsblöcke die erst noch von einem Programmierer zu einem lauffähigen Programm zusammengestellt werden müssen, sondern ein vollständiges und lauffähiges SPS-Programm. Nach dem Einfügen der SPS-Bibliothek ist es nur noch notwendig, die Einstiegsroutinen aufzurufen. Alles Weitere läuft eigenständig in der SPS-Bibliothek. Damit dieses möglich ist, werden mit der SPS-Bibliothek alle notwendigen globalen Variablen mitgeliefert. Diese dienen dazu, die Parameter vom TwinCAT Building Automation Manager aufzunehmen. Des Weiteren werden die globalen Variablen für die interne Kommunikation der einzelnen Objekte benutzt. Durch die globalen Variablen wird auch die Zuordnung der Objekte untereinander definiert, ohne dass das SPS-Programm neu kompiliert werden muss.

Für die spätere Anwendung des TwinCAT Building Automation Framework ist es von Vorteil, die Zusammenhänge der einzelnen Objekte (digitale Signale, Lampen, Zeitschaltuhr, Gruppen, ...) untereinander zu verstehen. Alle Objekte haben eine klar definierte Aufgabe und kommunizieren über fest definierte Schnittstellen untereinander. Die Zuordnung der Objekte untereinander geschieht über mehrere Schichten. Jede Schicht hat eine eindeutige Aufgabe und kommuniziert mit den anderen Schichten ebenfalls über definierte Schnittstellen.

E/A-Prozessabbild

Auf der untersten Ebene ist das Prozessabbild, über welches das Applikationsprogramm mit der Hardware kommuniziert. Die Verbindung zwischen dem Applikationsprogramm und dem Prozessabbild wird über das E/A-Mapping definiert. Der Anwender legt fest, welcher Aktor, Sensor oder welches Subsystem (DALI-Linie, EnOcean-Linie, ...) welcher Feldbusklemme zugeordnet wird. Bei der Aktivierung der Konfiguration erzeugt der TwinCAT Building Automation Manager automatisch das E/A-Mapping. Grundsätzlich können nur Sensoren, Aktoren oder Subsysteme mit dem Prozessabbild verknüpft werden.

Aktoren, Sensoren und Subsysteme

Informationen, die über Eingangsklemmen eingelesen werden, müssen in der Regel aufbereitet werden. Dazu gehören Funktionen wie z.B. Skalierung, Filterung, Negierung, Ersatzwertgenerierung, Flankenauswertung oder Verzögerung. Allen darüber liegenden Objekten stehen somit 'saubere' Eingangssignale zur Verfügung. Auf der Sensorebene können Schwellwertschalter definiert werden. Bei Über- oder Unterschreitung des Istwertes ist es somit möglich, Szenen zu aktivieren.

Ein Aktorobjekt repräsentiert eine Lampe, Jalousieantrieb, Ventil-Stellantrieb oder einen Fensterantrieb. Das Aktorobjekt nimmt Schaltbefehle entgegen, bereitet diese auf und generiert die Prozessdaten. Über die Parameter des Aktorobjektes kann das Verhalten des Aktors festgelegt werden. Stellgrößenbegrenzung einer Lampe oder die Fahrdauer eines Jalousieantriebes sind hier nur einige Beispiele.

Nicht jedes Sensorobjekt oder Aktorobjekt ist direkt mit einer Feldbusklemme verbunden. In einigen Fällen erfolgt die Verknüpfung indirekt über einen weiteren Feldbus wie z.B. DALI, EnOcean oder RS485. Ein Subsystemobjekt abstrahiert den Zugriff auf solch ein Subsystem. Alle notwendigen Dienste, die zum Betrieb und zur Konfiguration benötigt werden, sind ebenfalls in dem Subsystemobjekt enthalten. So gibt es z.B. ein Subsystemobjekt für DALI-Linien, das mit der entsprechenden DALI-Feldbusklemme verbunden wird. Konfiguration und Adressierung der DALI-Teilnehmer kann mit Hilfe des DALI-Objektes durchgeführt werden. Auch stellt ein DALI-Objekt alle notwendigen Schnittstellen zur Verfügung, damit ein Lampenobjekt auf eine einzelne DALI-Lampe zugreifen kann. Ein Lampenobjekt kann wahlweise einem Kanal einer Feldbusklemme oder einer DALI-Lampe eines DALI-Subsystems zugeordnet werden. Die Schnittstelle zum Steuern einer Lampe ist immer die gleiche, egal ob es sich um ein Lampenobjekt für DALI oder um ein Lampenobjekt für eine Dimmerklemme handelt. Der Zugriff der darüber liegenden Ebenen ist somit 'feldbusneutral' und vereinfacht die weitere Verwendung erheblich.

Aktorgruppen und Sensorgruppen

Sehr häufig ist es notwendig, Sensoren oder Aktoren zu gruppieren. So kann es in einem Raum mehrere Jalousieantriebe geben, die immer gleichzeitig gefahren werden. Oder mehrere Temperaturfühler, dessen Mittelwert an die Regelung weitergegeben wird. Für diese Aufgabe gibt es für jedes Sensor- oder Aktorenobjekt ein äquivalentes Gruppenobjekt. Ein Aktorgruppenobjekt enthält einen Verweis auf eine Liste mit den jeweiligen Gruppenelementen. Nimmt das Gruppenobjekt einen Schaltbefehl entgegen, so wird dieser an alle Gruppenelemente weitergeleitet. Die Zustände der einzelnen Elemente werden ebenfalls gesammelt und ausgewertet. So kann aus jedem Gruppenobjekt ausgelesen werden, wie viele Elemente diesem Objekt zugeordnet sind oder wie viele von denen einen Fehler melden. So wie bei Sensorobjekten, können auch Sensorgruppen mit Hilfe von Schwellwertschaltern Szenen aufrufen.

Gruppenobjekte sind nicht begrenzt auf einen Controller. Es können Elemente nicht nur vom lokalen Controller zugeordnet werden, sondern auch von beliebigen Controllern, die sich im gleichen Netzwerk befinden. Der TwinCAT Building Automation Manager erzeugt die notwenige Infrastruktur. Damit eine nahezu verzögerungsfreie Kommunikation möglich ist, kommen hierbei TwinCAT-Netzwerkvariablen zum Einsatz.

Besondere Bedeutung hat das Lampengruppenobjekt, wenn mehrere DALI-Lampen eingetragen werden. Die DALI-Lampen können von der gleichen DALI-Linie, einer weiteren DALI-Linie vom gleichen Controller oder von einer DALI-Linie eines anderen Controllers stammen. Das TwinCAT Building Automation Framework stellt sicher, dass die DALI-Teilnehmer den richtigen DALI-Gruppen zugeordnet werden und die notwendigen TwinCAT-Netzwerkvariablen zur Kommunikation zwischen den Controllern angelegt werden. Mit einem Gruppenobjekt kann somit eine Lampengruppe gesteuert werden, die sich über das gesamte Netzwerk verteilt.

Szenen

Szenen haben im TwinCAT Building Automation Framework eine zentrale Funktion. Sensorobjekte, Gruppenobjekte, Zeitschaltkanalobjekte und Wetterstationsobjekte können ausschließlich Szenen aufrufen. Dadurch laufen in den Szenen alle ereignisgesteuerten Befehle zusammen. Das Auslösen einer Szene hat zur Folge, dass die hinterlegten Befehle ausgeführt werden. Es können Befehle von beliebigen lokalen Objekten enthalten sein. Da Szenen auch über das Netzwerk aufrufbar sind, bieten Szenen eine leistungsfähige Methode, gebäudeglobale Aktionen auszuführen (Außenbeleuchtung, Betriebsartenumschaltung der Klimatechnik, o.ä.). Auch eine Kaskadierung von Szenenaufrufen ist möglich. So kann eine Szene eine andere Szene aufrufen. Diese Szene kann sich auf dem gleichen oder auch auf einem anderen Controller befinden.

Funktionseinheiten

Sensorobjekte, Aktorobjekte und Gruppenobjekte haben die Aufgabe, den Zugriff auf die Hardware zu vereinheitlichen. Ebenfalls sind in den Objekten grundlegende Funktionen enthalten, um die Ein- und Ausgabe zu beeinflussen. Schaltfunktionen sind über Schwellwertschalter möglich. Für eine Klimaregelung oder eine Konstantlichtregelung ist dieses aber nicht ausreichend. Diese Aufgabe übernehmen Funktionseinheiten. Funktionseinheiten stellen das Bindeglied zwischen Sensoren und Aktoren dar. Die Werte der Sensoren werden je nach Aufgabe entsprechend ausgewertet und die zugeordneten Aktoren angesteuert.

Zeitschaltkanäle

Immer wieder kehrende Ereignisse können durch Zeitschaltkanäle aktiviert werden. Hierzu stehen Objekte für Tages-, Wochen- und Monatszeitschaltkanäle bereit. Neben der absoluten Uhrzeit kann auch der Sonnenauf- oder Untergang als Ereignis ausgewählt werden.

Wetterstationen

Die Werte der Wetterstationen können über Wetterstationsobjekte im Netzwerk verteilt und auf jedem Controller individuell ausgewertet werden. Für jeden Messwert kann mindestens ein Schwellwertschalter parametriert werden. Dieser kann wahlweise bei Über- oder Unterschreitung beliebige Szenen aufrufen. Das Konzept der virtuellen Wetterstation unterstützt das Verteilen der Wetterdaten über ein Netzwerk. Die Übertragung der Daten erfolgt fast verzögerungsfrei auf Basis der Echtzeit-Netzwerkvariablen von TwinCAT. Hierzu wird ein virtuelles Wetterstationsobjekt mit dem Objekt einer 'realen' Wetterstation eines anderen Controllers verbunden. Der TwinCAT Building Automation Manager erzeugt bei der Aktivierung der Konfiguration alle notwendigen TwinCAT Netzwerkvariablen.

Zusammengesetzte Module

Zusammengesetzte Module stellen die oberste Ebene dar. Sie ermöglichen den Zugriff auf verschiedene Objekte ohne einem speziellen Gewerk, wie Beleuchtung oder Klimatisierung, zugeordnet zu sein. Anwendung findet dieses z.B. bei Raumbediengeräten, die häufig Zugriff auf verschiedene Funktionseinheiten haben und gleichzeitig auch in der Lage sein müssen, Szenen aufzurufen. Das TwinCAT Building Automation Framework bietet zwei Objekttypen, mit denen Beleuchtungs-, Beschattungs- und Szenenmanagement mit einfachen digitalen Ein- und Ausgängen realisiert werden können. Über Taster lassen sie die einzelnen Beleuchtungen dimmen, die Beschattungen einzeln fahren und Szenen aufrufen. Die Szenen können aber auch über die Taster verändert und persistent abgespeichert werden.

Globale Variablen

Die einzelnen Objekte nutzen globale Variablen, um untereinander Informationen und Befehle auszutauschen. In der SPS-Bibliothek des TwinCAT Building Automation Framework werden alle notwendigen Variablen mitgeliefert, sodass es nicht notwendig ist, diese explizit anzulegen.


Unterschiede zur Version V2.12

Die Version V2.20 wurde gegenüber der Version V2.12 grundlegend erweitert und verbessert. Durch die neuen Funktionen wird der gesamte Funktionsbereich der Raumautomation abgedeckt. Neben den Erweiterungen wurden aber auch vorhandene Leistungsmerkmale überarbeitet. Damit Projekte, die mit V2.12 erstellt wurden, weiterhin gepflegt werden können, können die Versionen V2.12 und V2.20 parallel auf dem gleichen Rechner installiert und genutzt werden. Die Projektdateien können einfach durch die Dateiendung unterschieden werden. Aufgrund einiger Erweiterungen können allerdings alte Projekte nicht direkt in der Version V2.20 eingelesen werden. Eventuell wird es in Zukunft ein Migrationswerkzeug geben, das möglichst viele Informationen aus einem alten Projekt in ein neues übernimmt. In der folgenden Tabelle ist eine Übersicht mit den wichtigsten Erweiterungen und Änderungen:

V2.12 | V2.20 | Verbesserung
Dateiendung der Projektdatei ist *.bam. | Dateiendung der Projektdatei ist *.bamx. | Die einzelnen Projektdateien können schon durch die Dateiendung den einzelnen Versionen zugeordnet werden.
Es wird TwinCAT V2.10 vorausgesetzt. | Es wird TwinCAT V2.11 vorausgesetzt. | Der CX5000 kann dadurch unterstützt werden.
Unterstützt EnOcean via KL6021-0023. | Unterstützt EnOcean via KL6021-0023 und via KL6581. | Mehrere EnOcean-Empfänger können an einer Klemme angeschlossen werden.
Nur Signalgruppen können Szenen aufrufen. | Signale und Signalgruppen können Szenen aufrufen. | Es muss bei einem Signal nicht immer eine Gruppe angelegt werden, um eine Szene aufzurufen.
Für die Beleuchtung gibt es 2 Varianten. | Für die Beleuchtung gibt es 6 Varianten. | Es stehen jetzt auch Beleuchtungen für Treppenhausbeleuchtung, Dämmerungsschalter, Sicherheitsbeleuchtung, o.ä. zur Verfügung.
- | Objekte für Zeitschaltkanäle, zusammengesetzte Module und Wetterstationen sind hinzugekommen. | Wichtige Leistungsmerkmale stehen somit mit der neuen Version zur Verfügung.
Die Übertragung der Befehle geschieht per ADS/TCP. | Die Übertragung der Befehle geschieht über TwinCAT-Netzwerkvariablen. | Netzwerkvariablen können einfacher in das System integriert werden. Es ist nicht notwendig, im TwinCAT-Router der Controller alle Teilnehmer einzutragen. Die Übertragung per TwinCAT Netzwerkvariablen ist deutlich leistungsfähiger, da mit einem Telegramm an mehrere Teilnehmer der gleiche Befehl gesendet werden kann.
Der Zugriff auf die Objekte in der SPS erfolgt über globale Variablen. | In der SPS stehen für jeden Objekttyp Funktionsblöcke zur Verfügung. Über diese Funktionsblöcke kann jedes Objekt angesprochen werden. | Das Erweitern des SPS-Programms mit eigenen SPS-Funktionen ist insbesondere für die grafischen Darstellungsarten einfacher geworden.
- | Kopieren, Einfügen, Importieren und Exportieren wird vom TwinCAT Building Automation Manager unterstützt. | Die Projekterstellung wird erheblich vereinfacht. Einmal parametrierte Elemente können beliebig häufig vervielfältigt werden.
- | Das Suchen von E/A-Geräten und Feldbusklemmen wird unterstützt. | Das Eintragen der E/A-Geräte kann dadurch beschleunigt werden.
Die Zuordnung der Sensoren zu den Funktionseinheiten geschieht über eine Ereignis/Aktions-Zuordnung an dem Sensor. | An der Funktionseinheit erfolgt die Zuordnung aller Sensoren und aller Aktoren. | Die Übersicht wird deutlich verbessert. Es ist leichter zu erkennen welche Sensoren und Aktoren Einfluss auf die Funktionseinheit nehmen.


Setup

Systemvoraussetzungen

  • Beckhoff TwinCAT PLC (V2.11 oder höher)
  • .NET Framework (V4.0 oder höher)
  • Die TcBAFramework.exe befindet sich auf der Beckhoff Software CD unter den TwinCAT Supplement Installationen.

Installation

  1. Ausführen der *.exe Datei des TwinCAT Supplements.
  2. Klicken Sie auf Weiter, lesen Sie die Lizenz Vereinbarung sorgfältig, akzeptieren Sie diese und klicken auf Weiter.
  3. Tragen Sie den Benutzernamen, Name der Firma und die Seriennummer ein.

    Sollten Sie keine Seriennummer haben, so geben Sie DEMO ein für die Testversion.
    Akzeptieren Sie durch Klick auf Weiter.
  4. Klicken Sie auf Installieren zum Starten der Installation.
  5. Am Ende auf Fertig stellen klicken zum abschließen der Installation.

Nach der Installation enthält der TwinCAT Systemordner im Windows Startup einen neuen Ordner namens TwinCAT Building Automation Framework V2.20.
Dieser Ordner enthält den TwinCAT Building Automation Manager.

Deinstallation

  1. Öffnen Sie die Systemsteuerung und wählen Programme und Funktionen aus.
  2. Wählen Sie TwinCAT Building Automation Framework V2.20 aus und klicken auf Deinstallieren.
  3. Zum Starten der Deinstallation mit Ja bestätigen.
  4. Nach der Deinstallation klicken Sie auf Fertig stellen zum Fertigstellen der Entfernung vom Building Automation Framework V2.20.


Erste Schritte

In diesem Beispiel wird mit dem Building Automation Manager ein Projekt für einen Raum erstellt der eine Lampe und eine Jalousie beinhaltet.

Hardware

Die folgende Hardware wird benötigt:

  • CX1010 (embedded PC)
  • KL1104 (4-Kanal digitale Eingangsklemme, 24 V DC) → 1 Taster für die Lampe und 2 Taster für die Jalousie
  • KL9260 (Einspeiseklemme, 230V AC) → Einspeisung für die folgenden zwei Klemmen
  • KL2751 (1-Kanal Universal-Dimmer, 230 V AC) → Ausgang für die dimmbare Lampe
  • KL2722 (2-Kanal Triac Ausgangsklemme, 230 V AC) → Ausgang für die Jalousie
  • KL9010 (Endklemme)

Hinweis
Seien Sie vorsichtig beim Umgang mit 230V-Geräten. Falsche Verwendung kann leicht zu Verletzungen, Schäden am Gerät oder Kurzschlüssen führen. Lassen Sie nur qualifiziertes Personal mit diesen Geräten arbeiten und lesen Sie die entsprechende Hardware-Dokumentation.

Einrichten der SPS

  1. Registrieren Sie den CX1010 als Remote Computer bei TwinCAT.
  2. Das lokale TwinCAT Programm muss im Start- oder Konfig-Modus laufen.
  3. Erstellen Sie einen Ordner für Ihr Projekt.
  4. Kopieren Sie das Building Automation SPS Projekt dort hin (üblicherweise zu finden unter C:\TwinCAT\BAFrameworkV2.20\BAManager\Samples\FirstSteps).
    Stellen Sie sicher, dass das Projekt NICHT schreibgeschützt ist.
  5. Öffnen Sie das Building Automation SPS Projekt mit dem TwinCAT PLC Control.
  6. Wählen Sie PC oder CX (x86) als Zielsystem in der SPS Konfiguration aus.
  7. Loggen Sie sich auf den CX1010 ein (dies führt zur Kompilierung und Runterladen des Programms).
  8. Richten Sie dieses Projekt als Boot Projekt für den CX1010 ein.
  9. Starten der SPS.
  10. Speichern des Projekts. Stellen Sie sicher, dass sich die *.tpy Datei nun in Ihrem Projektordner befindet.

Hinweis
Lesen Sie die Dokumentation vom TwinCAT PLC Control falls Sie nicht mit dessen Handhabung vertraut sind.

Es empfiehlt sich die Teilnahme an einer TwinCAT Schulung.

Benutzung des Building Automation Manager

Um die Applikation zu Starten gehen Sie auf Start → Alle Programme → TwinCAT System → TwinCAT Building Automation Framework → TwinCAT Building Automation Manager.
Der Building Automation Manager sollte wie folgt aussehen:

Hinweis
Sollte der BA Manager nicht so aussehen, dann Klicken Sie bitte auf Datei → Neu.

Hinzufügen der Hardware

Zuerst fügen Sie den Controller an. Rechtsklick auf Controller im Controller Tab und wählen Sie Objekt hinzufügen... aus.

Der folgende Dialog erscheint:

Dieser Dialog wird immer benutzt, wenn Elemente hinzugefügt werden sollen. Er listet alle möglichen Elemente auf die an dieser Position hinzugefügt werden können.
Wenn Sie keinen Namen vergeben, dann wird der Standard Name benutzt. Dieser kann nachträglich noch geändert werden.
Wir wollen nur einen CX1010 hinzufügen, also wählen Sie den CX1010 aus.

Nun können Sie die allgemeinen Informationen über den neuen CX1010 einsehen. Auf dieser Seite können Sie den Namen des Elements ändern, die interne Id und den Typ sehen, Kommentare hinzufügen oder das Element deaktivieren.

Zum Herstellen einer Verbindung wählen Sie den Einstellungen Tab aus und klicken auf die Suchen (Ethernet)... Schaltfläche.

Es gibt nun zwei verschiedene Möglichkeiten den CX1010 im Netzwerk zu finden:

  1. Eingabe des Host Namen oder der IP vom CX1010. Anschließend klicken Sie auf Host Name / IP.
  2. Klicken Sie auf Broadcast Suche. Es werden alle Geräte im Netzwerk aufgelistet.

Wählen Sie Ihr Gerät aus und betätigen Sie die Hinzufügen Schaltfläche.

Die Informationen vom Gerät werden im Einstellungen Tab angezeigt:

Klicken Sie links auf das + vom CX1010 1 Knoten, wählen Sie E/A Geräte aus und fügen Sie ein CX1100 Netzteil/Klemmenanschaltung an.
Fügen Sie einen CX1100-KB (Klemmen-Koppler) am CX1100 Netzteil/Klemmenanschaltung 1 an.
Nun fügen Sie alle oben erwähnten Klemmen an den Koppler CX1100-KB (Klemmen-Koppler) 1 an. Wenn Sie damit fertig sind sollte das ganze so aussehen:

Klicken Sie auf Applikationsprogramm in der Baumansicht und wählen Sie den Einstellungen Tab aus. Hier muss die *.tpy Datei Ihres Building Automation SPS Projekts eingetragen werden. Dazu klicken Sie auf Ändern... und Öffnen die *.tpy Datei Ihres Projekts.

Hinweis
Es empfiehlt sich alle projektbezogenen Dateien in einem Ordner zu haben.
Die Relativ zur BAMX-Datei Option wird verfügbar nachdem das Projekt zum ersten Mal gespeichert wurde. Um zu speichern klicken Sie auf Datei → Speichern unter....

Sensoren und Aktoren erstellen

Sensoren müssen mit den Eingangskanälen und Aktoren mit den Ausgangskanälen der Hardware verbunden werden.
Klicken Sie auf das + links vom Applikationsprogramm Knoten und anschließend auf das + links von Sensoren. Fügen Sie 3 Typ 1 - standard digitales Signal an (verwenden Sie das Anzahl Eingabefeld, um sie in einem Schritt hinzuzufügen).
Wählen Sie den Einstellungen Tab des ersten digitalen Signals aus und klicken Sie auf die verknüpft mit... Schaltfläche.

Verknüpfen Sie den ersten Kanal der KL1104.

Wiederholen Sie diesen Vorgang für die anderen digitalen Signale und verknüpfen Kanal 2 und 3 mit der KL1104.

Erweitern Sie Aktoren und fügen eine Typ 1 - standard Lampe an. Verknüpfen Sie den Analogausgang der Lampe mit dem Kanal 1 der KL2751. Fügen Sie einen Typ 1 - standard Jalousieantrieb an und verknüpfen Digitalausgang Hoch mit Kanal 1 und Digitalausgang Runter mit Kanal 2 der KL2722.

Erstellen von Gruppen und Funktionseinheiten

Um die Funktionalität herzustellen, muss sich jeder Sensor und Aktor innerhalb einer Gruppe befinden. Diese muss dann von einer Funktionseinheit aufgerufen werden.

Erweitern Sie Aktorgruppen und fügen eine Typ 1 - standard Lampengruppe an. Wählen Sie den Lampen Tab aus und betätigen die Bearbeiten Schaltfläche.
Wählen Sie die Type 1 - standard Lampe 1 aus und klicken auf >> (oder führen Sie einen Doppelklick auf die Type 1 - standard Lampe 1 aus).

Nun wird das Element auf die rechte Seite verschoben, um zu verdeutlichen, dass es ausgewählt wurde.

Wiederholen Sie diesen Vorgang mit der Jalousieantriebsgruppe.

Sensorgruppen erstellen

Die Sensorgruppen ermöglichen das Erstellen und Anpassen der Funktionalität. Sie beinhalten die Information welche Aktion von welcher Funktionseinheit aufgerufen werden soll, wenn etwas am Sensor passiert.

Erweitern Sie die Sensorgruppen und fügen 3 Typ 1 - standard digitale Signalgruppe an. Wählen Sie den Signale Tab der 1. (2., 3.) Gruppe aus und fügen das 1. (2., 3.) digitale Signal hinzu.

Erweitern Sie die Funktionseinheiten und fügen einen Typ 1 - Dimmer an. Wählen Sie im Sensoren / Aktoren Tab der neuen Funktionseinheit die Lampengruppe aus die Sie zuvor erstellt haben, indem Sie auf Bearbeiten klicken. Wählen Sie die Typ 1 - standard digitale Signalgruppe 1 für das Hoch / Runter Dimmen aus durch einen Klick auf Bearbeiten.

Wiederholen Sie diesen Vorgang für die Jalousien. Wählen Sie die Typ 1 - standard digitale Signalgruppe 2 für Hoch aus und 3 für Runter.

Entwerfen des Gebäudes

Der Building Automation Manager ermöglicht das Entwerfen der gesamten Struktur Ihres Gebäudes und das Hinzufügen der dazugehörigen Funktionseinheiten. Wählen Sie den Gebäude Tab aus und fügen ein Gebäude mit einer Etage und einem Raum an. Wählen Sie den Inhalte Tab von Bereich 1 aus und fügen diesem die Funktionseinheiten Type 1 - Dimmer 1 und Type 1 - standard Beschattung 1 hinzu.

Aktivieren der Konfiguration

Zuerst speichern Sie das Projekt erneut durch einen Klick auf Datei → Speichern unter....

Der Konfiguration aktivieren Dialog kann über das Menü Aktion → Konfiguration aktivieren aufgerufen werden. Wählen Sie den CX1010 1 aus und klicken auf gesamte Konfiguration aktivieren.

Warten Sie, bis der Building Automation Manager mit der Aktivierung der Konfiguration fertig ist. Wenn im Meldungen Fenster im unteren Bereich des BA Manager keine Warnungen oder Fehler angezeigt werden, dann verlief alles einwandfrei.

Gratulation, Sie haben Ihr erstes und voll funktionsfähiges Building Automation Projekt erstellt!


Overview Building Automation Manager

Der Building Automation Manager wird zum Entwerfen und konfigurieren Ihrer Gebäudeautomatisierungen verwendet. Darüber hinaus kann die gesamte Gebäudestruktur umgesetzt werden. All dies wird in einer sehr visuellen und selbsterklärenden Benutzeroberfläche durchgeführt.


Hauptfenster

Das Hauptfenster vom Building Automation Manager ist unterteilt in 4 Hauptbereiche, welche nachfolgend erklärt werden.

1 Navigationsbaum

Auf der linken Seite des Hauptfensters befindet sich der Navigationsbaum.
Klicken Sie hier für detaillierte Informationen zu diesem Element.

2 Informations und Einstellungs Fenster

Das große Kontrollelement auf der rechten Seite des Hauptfensters wird zum Konfigurieren und Einstellen der ausgewählten Elemente im Navigationsbaum benutzt.
Informationen zu den individuellen Optionen eines Elements erhalten Sie auf den entsprechenden Dokumentationsseiten.

3 Toolbar

Mit der Toolbar im oberen Bereich des Hauptfensters können Sie Projekte öffnen, speichern und neu erzeugen. Mehr Funktionen stehen in einem speziellen Kontext zur Verfügung.
Um zum Optionsfenster zu gelangen klicken Sie auf Optionen → Einstellungen. Dort können Sprache und andere Verhaltensweisen des Building Automation Manager eingestellt werden.

4 Nachrichtenfenster

Im unteren Bereich des Hauptfensters befindet sich das Nachrichtenfenster.
Eine detaillierte Beschreibung dieses Kontrollelements erhalten Sie hier.


Navigationsbaum

Der Navigationsbaum ermöglicht den Zugriff auf die gesamte Systemkonfiguration und dessen Einstellungen.

Zur Darstellung der Informationen wird ein hierarchisches System (ähnlichem dem Dateisystem des Windows Explorer) benutzt. Wird ein Knoten ausgewählt so erscheint dessen Einstellungsfenster auf der rechten Seite des Hauptfensters. Informationen zu den individuellen Optionen eines Elements erhalten Sie auf den entsprechen Dokumentationsseiten. Um einen Unterknoten anzulegen Rechtsklicken Sie auf den Elternknoten und wählen Objekt hinzufügen... aus. Im nachfolgenden Dialog muss das hinzuzufügende Element festgelegt werden. Es können der Name, der Typ und die Anzahl eingestellt werden. Zum Entfernen eines Knotens wählen Sie ihn aus und wählen nach einem Rechtsklick Objekt löschen aus. Beachten Sie, dass einige Elemente nicht entfernt werden können.

Controller Tab

Dieser Tab enthält die Hardware die Sie verwenden und die Funktionalität die sie zur Verfügung stellt. Es können mehrere Controller hinzugefügt werden. Jeder Controller besitzt ein Applikationsprogramm und E/A Geräte. Das Applikationsprogramm enthält Sensoren (digital und analog) und Aktoren (Lampen, Jalousieantriebe, Fensterantriebe, Ventil Stellantriebe...). Sensoren und Aktoren müssen sich in Gruppen befinden, um eine Funktionalität zu erhalten. Diese Funktionalität wird im Funktionseinheiten Knoten definiert und konfiguriert.
Subsysteme, wie DALI und EnOcean, werden ebenfalls unterstützt (zu finden im Subsysteme Knoten).

Im E/A Geräte Knoten muss die benutzte Hardware festgelegt werden. Ähnlich dem TwinCAT System Manager können hier die Geräte mit ihrem Koppler und Klemmen konfiguriert werden. Die Ein- und Ausgänge der Hardware können dann mit den Sensoren und Aktoren verknüpft werden. Auf Änderungen die eine Aktivierung erfordern, wird durch einen rot umrandeten Controller hingewiesen.

Beim Auswählen einer Kategorie zeigt das Informationsfenster auf der rechten Seite eine Liste aller Elemente, ungeachtet ihrer Ordnerzugehörigkeit. Die Elemente können sortiert, umbenannt oder entfernt werden. Beim Entfernen können mehrere Elemente gleichzeitig ausgewählt werden.
Die Kategorie bietet weiterhin ein Rechtsklick-Menü mit Druckoptionen für die Liste an.

Gebäude Tab

Die Gebäudestruktur im Gebäude Tab bietet die Möglichkeit, alle erstellten Elemente (z.B. Lampen, Jalousien, Beleuchtungseinheiten ...) örtlich nach Gebäude, Etage und Raum einzuteilen. Zusätzlich erlaubt die Inhaltsliste eines Raumes den direkten Zugriff auf das Online Menü des jeweiligen ausgewählten Elements.
Es wäre auch denkbar die Informationen aus der Gebäudestruktur für Werkzeuge zu nutzen, wie z.B. bei der Berichtfunktion (Werkzeuge → Berichte...).


Nachrichtenfenster

Das Nachrichtenfenster gibt Auskunft über die Aktionen die der Building Automation Manager durchführt. Es gibt 3 Typen von Nachrichten:
  • Meldungen: Diese Nachrichten enthalten allgemeine Informationen. Sollten nur die Meldungen zu sehen sein, dann arbeitet alles einwandfrei.
  • Warnungen: Warnungen sind in den meisten Fällen harmlos, weise allerdings auf Unregelmäßigkeiten hin. Diese Nachrichten sollten vermieden werden.
  • Fehler: Fehler weisen auf ernste Probleme hin. Das Projekt kann nicht einwandfrei arbeiten, wenn Fehler auftreten.
Es stellt ebenso ein Rechtsklick-Menü zur Verfügung mit den folgenden Optionen:
  • Löschen: Entfernt alle Nachrichten im Nachrichtenfenster.
  • Öffnen: Ersetzt vorhandene Nachrichten mit denen aus der Datei.
  • Speichern: Speichert alle Nachrichten in eine *.xml Datei.
  • Schließen: Blendet das Nachrichtenfenster aus.


Verknüpfungs Dialog

Dieser Dialog wird Aufgerufen, sobald ein Sensor oder Aktor mit dem Kanal einer Klemme oder eine SPS Variable mit einer Klemmenvariablen verknüpft werden soll. Die übliche Vorgehensweise ist ein Klick auf einen Sensor, Aktor oder Symbol im Navigationsbaum, Auswahl des Einstellungen Tab und betätigen der verknüpft mit... Schaltfläche für den entsprechenden Ein- oder Ausgang.

Mögliche Verknüpfungen werden in einer hierarchischen Baumstruktur aufgelistet (ähnlichem der des Windows Explorer).

Hinweis
Nur Kanäle die kompatibel zum entsprechenden Sensor/Aktor sind werden angezeigt.
Für Symbole stehen nur Klemmenvariablen mit derselben Bit Größe zur Auswahl.

Um eine Auswahl zu tätigen Linksklicken Sie im Baum auf die Verknüpfung (sie wird farbig hervorgehoben). Klicken Sie auf OK um die ausgewählte Verknüpfung zu bestätigen. Hatten Sie nicht vor den Sensor/Aktor/Symbol zu (erneut-)verknüpfen, dann betätigen Sie Abbrechen.

Die Filter Option ermöglicht die Anzeige aller zutreffenden Klemmenkanäle oder aber das Ausblenden aller bereits verknüpften und/oder blockierten (deaktivierten) Kanäle.

Sie können ebenso die Namensgebung der verknüpften Elemente beeinflussen. Diese Optionen sind beibehalten beider Namen, Namen vom Sensor/Aktor für den Klemmenkanal übernehmen oder Namen vom Klemmenkanal für den Sensor/Aktor übernehmen. Diese Möglichkeit steht nicht für Symbole zur Verfügung!


Kopieren und Einfügen

Das Kopieren und Einfügen bietet die Möglichkeit ganze TwinCAT Building Automation Manager Elemente zu kopieren. Zuerst muss das zu kopierende Element im Navigationsbaum markiert werden. Danach erfolgt der Aufruf der Funktionen Kopieren und Einfügen. Im Navigationsbaum befindet sich nun eine Kopie des Elements.

Neben den bekannten Tastenkürzeln Strg + C (Kopieren) und Strg + V (Einfügen) aus Windows, können diese Funktionen noch auf drei weiteren Wegen aufgerufen werden.

Die erste Möglichkeit bietet die Menüleiste im Eintrag Bearbeiten. Auch hier einfach das Element im Navigationsbaum markieren, auf Bearbeiten gehen, Kopieren auswählen und anschließend wieder Einfügen aufrufen.

Eine weitere Möglichkeit bietet die Werkzeugleiste über die entsprechenden Symbole. Ist diese nicht zu sehen, so kann sie über Ansicht → Werkzeugleiste eingeblendet werden.

Als letzte Variante ist das Kopieren und Einfügen über das Kontextmenü der Maus erreichbar.


Info

In diesem Dialog kann das Projekt mit zusätzlichen Informationen versehen werden. Nach abspeichern des Projekts lässt sich über das Ordnersymbol das Verzeichnis der *.bamx Datei öffnen.


Einstellungen

Weitere Einstellungen zum Projekt können hier vorgenommen werden.

Auf allen hier im Dialog ausgewählten Controllern wird beim Aktivieren der Konfiguration die Projektdatei geladen. Der Pfad dazu wird mit einem Rechtsklick in der entsprechenden Zeile angegeben. Es kann zwischen dem Bootverzeichnis und einem selbst definierten Pfad gewählt werden. Achten Sie darauf, dass der Ordner bereits auf dem Zielgerät existiert!

Hier können geografische Angaben zum Projekt eingetragen werden.

Die geografische Breite ist die im Winkelmaß (also in Grad) angegebene nördliche oder südliche Entfernung eines Ortes der Erdoberfläche vom Äquator. Die Breite kann Werte von 0° (am Äquator) bis ±90° (an den Polen) annehmen. Dabei gibt ein positives Vorzeichen die nördliche Richtung und ein negatives Vorzeichen die südliche Richtung an. Die geografische Länge ist ein Winkel, der ausgehend vom Nullmeridian 0° (künstlich festgelegte Nord-Süd-Linie) Werte bis ±180° annehmen kann. Ein positives Vorzeichen gibt die Länge in östlicher Richtung und ein negatives Vorzeichen in westlicher Richtung an.


Import

Importiert eine Exportdateien die mit der Exportfunktion des TwinCAT Building Automation Managers erstellt wurden.

Nach Aufruf der Importfunktion und Auswahl der Exportdatei können, je nach Inhalt, noch einmal die enthaltenen Elemente betrachtet werden.


Export

Exportiert eine Auswahl von TwinCAT Building Automation Manager Elementen samt Parametern Exportdatei. Der Inhalt lässt sich anschließend, unter Berücksichtigung der Typkompatibilität, in andere TwinCAT Building Automation Manager Projekte importieren.

Zu Beginn wählt man die Art des Inhalts aus. Es kann der gesamte Controller, Teile des Applikationsprogramms oder Teile der E/A-Geräte exportiert werden.

Im nächsten Schritt können dann die Elemente ausgewählt werden.

Nach Betätigen der Schaltfläche Fertig stellen wird die Exportdatei im angegebenen Verzeichnis gespeichert.


Klemmenstatistiken

Das Werkzeug Klemmenstatistiken stellt in einer OOXML (Office Open XML) Tabelle Informationen über die im Projekt verwendeten Klemmen zusammen.

Die Tabelle enthält folgende Informationen:

  • Klemmentyp
  • Anzahl der Klemmen
  • Anzahl der Kanäle einer Klemme
  • Anzahl der genutzten und ungenutzten Kanäle
  • Anzahl der ungenutzte Kanäle in Prozent

Unter dem Menüpunkt Werkzeuge → Berichte... kann im nachfolgenden Auswahldialog das Werkzeug für die Klemmenstatistiken aufgerufen werden.

In der Hauptform werden zunächst alle Controller aufgelistet. Um die Klemmen eines Controllers mit in die Statistik aufzunehmen, muss dieser angewählt werden. Jeder angewählte Controller erhält sein eigenes Arbeitsblatt innerhalb der Tabelle. Nach Betätigen der Speichern... Schaltfläche kann ein Name sowie der Speicherpfad der Tabelle angegeben werden.

Des Weiteren besteht die Möglichkeit sich eine Gesamtübersicht erstellen zu lassen. Hierzu muss vor dem Erzeugen die Kontrollbox Sämtliche Informationen der Controller zu einem Arbeitsblatt zusammenfassen angewählt werden. Alle Klemmen der ausgewählten Controller werden nun nicht mehr auf separate Arbeitsblätter verteilt, sondern zu einem zusammengefasst.

Zum Betrachten der erzeugten *.xlsx Datei wird eine Tabellenkalkulation mit OOXML (Office Open XML) Unterstützung benötigt, wie z.B. Microsoft Excel 2010, OpenOffice.org 3 oder LibreOffice 3.


Webseiten Generator Desktop

Der Webseiten Generator Desktop erzeugt Bedienoberflächen für das Leistungsprofil von Desktop PCs. Die Bedienung ist entsprechend auf die Monitorgröße von PCs sowie Maus und Tastatur ausgelegt.

Mit folgenden Browserversionen wurde getestet:
  • Microsoft Internet Explorer 6 (Windows CE)
  • Microsoft Internet Explorer 9
  • Mozilla Firefox 5
  • Google Chrome 11
  • Apple Mobile Safari 3 (IPhone, IPod touch, IPad)
  • Apple Safari 5
  • Opera 11

Unter dem Menüpunkt Werkzeuge → Webseiten Generatoren... kann im nachfolgenden Auswahldialog der Webseiten Generator Desktop aufgerufen werden.

Der Dialog bietet die Möglichkeit den Speicherort für die Webseiten anzugeben. Ist Festplatte angewählt, so können Sie über die Durchsuchen Schaltfläche einen Ort auf der Festplatte auswählen. Bei Anwahl von FTP werden die Seiten direkt in einem FTP Verzeichnis abgelegt.

Je nach verwendetem Image wird der Web Service ausgewählt. Sollte dieser nicht im Standardverzeichnis liegen, kann der Pfad unter Benutzerdefiniert angepasst werden.

Weiterhin können Sie den drei Schnellzugriffstasten durch Betätigen der Bearbeiten Schaltfläche jeweils eine Szene zuweisen. Zur Anzeige von Wetterdaten ist über die Bearbeiten Schaltfläche die Angabe einer Wetterstation möglich.

Abschließend wird der Vorgang durch Betätigen von Erzeugen gestartet.

Nach Aufruf der Seite gelangen Sie zur Hauptansicht. Von dort kann in alle Unterbereiche navigiert werden. Im ausgewählten Bereich angekommen sind nun alle zugewiesenen Elemente steuerbar.


Webseiten Generator Mobile

Der Webseiten Generator Mobile erzeugt Bedienoberflächen für das Leistungsprofil von Smartphones. Die Bedienung ist entsprechend auf die Größe von Smartphone Displays und deren Berührungssteuerung ausgelegt. Die Browser müssen jQuery Mobile unterstützen.

Mit folgenden Browsern wurde getestet:
  • Microsoft Internet Explorer 9
  • Mozilla Firefox 5
  • Google Chrome 11
  • Apple Mobile Safari 3 (IPhone, IPod touch, IPad)
  • Apple Safari 5
  • Opera 11

Unter dem Menüpunkt Werkzeuge → Webseiten Generatoren... können Sie im nachfolgenden Auswahldialog den Webseiten Generator Mobile aufrufen.

Der Dialog bietet die Möglichkeit den Speicherort für die Webseiten anzugeben. Ist Festplatte angewählt, so können Sie über die Durchsuchen Schaltfläche einen Ort auf der Festplatte auswählen. Bei Anwahl von FTP wird die Seite direkt in einem FTP Verzeichnis abgelegt.

Je nach verwendetem Image wird der Web Service ausgewählt. Sollte dieser nicht im Standardverzeichnis liegen, kann der Pfad unter Benutzerdefiniert angepasst werden.

Weiterhin können Sie zur Anzeige von Wetterdaten über die Bearbeiten Schaltfläche eine Wetterstation angeben.

Abschließend wird der Vorgang durch Betätigen von Erzeugen gestartet.

Nach Aufruf der Seite gelangen Sie zur Hauptansicht. Von dort kann in alle Unterbereiche navigiert werden. Im ausgewählten Bereich angekommen sind nun alle zugewiesenen Elemente steuerbar.


Kommandodatei Generator

Es kann schon mal notwendig sein, dass SPS Programme mehrerer Controller aktualisiert werden müssen. Bei dieser Aufgabenstellung unterstützt Sie der Kommandodatei Generator. Er erzeugt eine ausführbare *.bat Datei die eine *.ini Anweisungsliste abarbeitet. Außer dem Starten der *.bat Datei ist kein weiteres Eingreifen des Anwenders erforderlich. Völlig automatisch wird Controller für Controller angewählt, das SPS Programm erneut aufgespielt, ein Bootprojekt erzeugt, die Laufzeit in den Run Modus versetzt und wieder ausgeloggt.

Unter dem Menüpunkt Werkzeuge → Erweiterungen... kann im nachfolgenden Auswahldialog der Kommandodatei Generator aufgerufen werden.

Im Hauptdialog werden alle Controller aufgelistet die für diesen Vorgang gültig sind. Das heißt ein Controller mit einer AmsNetId und ein Applikationsprogramm mit einer verlinkten *.tpy Datei. Um einen Controller zum Aktualisierungsvorgang hinzuzufügen, muss dieser angewählt werden. Für eine größere Anzahl an Controllern steht die Option Alle auswählen zur Verfügung. Hierbei werden entweder alle Controller an- oder abgewählt.

Nach Betätigen der Erzeugen Schaltfläche werden die beiden Dateien im ausgewählten Verzeichnis abgespeichert.

query off ok
out open CommandFileBuilder.log
out clear

file open "TcBAFrameworkV2.20_Sample.pro"
delay 3000
chooseruntime 192.168.10.5.1.1:801
delay 2000
online login
delay 4000
createbootproject
delay 6000
online run
delay 1000
online logout
delay 1000
file close

out close
file quit

Hier ist einmal der Inhalt der *.ini Datei aufgelistet der nach Ausführen der *.bat Datei abgearbeitet wird.

Zu Beginn wird die Logdatei KommandodateiGenerator.log angelegt in die alle Logeinträge aus dem TwinCAT PLC Control geschrieben werden. Es folgt das Öffnen der Projektdatei mit anschließendem Login in das Zielsystem. Danach wird das Projekt auf die Steuerung geladen, ein Bootprojekt erzeugt und das Laufzeitsystem in den Run Modus versetzt. Nach dem Logout wird das Projekt wieder geschlossen, die Ausgabe in die Logdatei gestoppt und das Kommandofenster der *.bat Datei beendet.

Mehr Informationen zum Thema Kommandozeilenbefehlen im TwinCAT PLC Control erhalten Sie im Beckhoff Information System unter dem Pfad:
Beckhoff Information System → TwinCAT → TwinCAT PLC → TwinCAT PLC Control → Anhang → Kommandozeilenbefehle


Projekt Generator

Der Projekt Generator erzeugt aus einer OOXML (Office Open XML) Tabelle ein Building Automation Manager Projekt.

Unter dem Menüpunkt Werkzeuge → Erweiterungen... kann im nachfolgenden Auswahldialog der Projekt Generator aufgerufen werden.

Es erscheint der bekannte Windows Dialog zum Öffnen von Dateien in dem die gewünschte *.xlsx Datei ausgewählt wird. Durch Betätigen der Öffnen Schaltfläche wird umgehend mit der Auswertung der Tabelle begonnen. Nach der Durchführung können alle Fenster geschlossen werden bis man sich wieder im Hauptfenster des Building Automation Managers befindet.

Hinweis
Der Import einer OOXML Tabelle erstellt ein neues Projekt! Ein bereits bestehendes Projekt kann nicht erweitert werden.

Erstellen der Tabelle

Für ein erfolgreiches Einlesen der OOXML Tabelle ist ein gültiger Aufbau notwendig. Dieser umfasst definierte Spalten- und Arbeitsblattbeschriftungen sowie Einträge innerhalb der Tabelle.

Controller Arbeitsblatt

Das erste Arbeitsblatt definiert die verwendeten Controller. Es muss Controller heißen. Wie in der Grafik zu sehen ist wird jeder Controller durch mind. 2 Zeilen definiert.

Die erste Zeile enthält:

  • Controller Type: Gibt den Controllertyp an.

    Erlaubte Controllertypen:

    • CX1000
    • CX1010
    • CX1020
    • CX1030
    • CX5000
    • CX9001
    • CX9000
    • CX9010
    • IpcCpX86
    • IpcCpArm
  • Notation: Der Name des Controllers.
  • Comment: Kommentar zum Controller (optional).
  • Ip: Die IP Adresse (valides IPv4) des Controllers (nicht bei KBUS).
  • TPY File Path: Pfad zum SPS Projekt, um die *.tpy Datei zu erhalten.

Die zweite Zeile enthält:

  • BK Type: Gibt den Typen des Buskopplers an. Erlaubter Wert ist KBUS (nur CX-Geräte). Der angegebene Typ des Buskopplers muss natürlich auch vom Controllertyp unterstützt werden. Sehen Sie dazu bitte in der entsprechenden Dokumentation nach.
  • Notation: Name des Buskopplers und des Arbeitsblatts. Diese Namen müssen identisch sein!

Buskoppler Arbeitsblatt

Diese Arbeitsblätter enthalten die an den Buskoppler angeschlossenen Klemmen, Sensoren, Aktoren und Subsysteme. Jede Klemme wird durch mindestens 2 Zeilen definiert. Bei kanallosen Klemmen (z.B. Endklemme KL9010) wird nur die oberste Zeile benötigt.

Die erste Zeile enthält:

  • Terminal Type: Typ der Klemme.
  • Terminal/Channel Notation: Name der Klemme.

Die zweite Zeile enthält:

  • Channel No.: Kanal der Klemme die verknüpft werden soll.
  • Terminal/Channel Notation: Name des Kanals.
  • Sensor/Actuator/Line Type: Typ des zu erstellenden Sensors/Aktors/Subsystems mit dem der Kanal anschließend verlinkt wird (optional).

    Erlaubte Sensor/Aktor/Subsystem Typen:

    • DIGITAL SIGNAL TYPE 1 - 3
    • ANALOG SIGNAL TYPE 1 - 3
    • LAMP TYPE 1 - 3
    • BLIND DRIVE TYPE 1 - 2
    • WINDOW DRIVE TYPE 1
    • VALVE ACTUATOR 2 POINT
    • VALVE ACTUATOR 3 POINT
    • VALVE ACTUATOR CONTINUOUS
    • ENOCEAN LINE TYPE 1 - 2
    • DALI LINE TYPE 1
  • Sensor/Actuator/Line Notation: Name des Sensors/Aktors/Subsystems.
  • Function: Parameter für den Aktor. Erlaubte Werte für

    LAMP TYPE 1

    • DIGITAL
    • ANALOG

    BLIND DRIVE TYPE 1

    • UP
    • DOWN

    WINDOW DRIVE TYPE 1 und VALVE ACTUATOR 3 POINT

    • OPEN
    • CLOSE
  • Parameter 1 - 4: Zusätzliche Parameter

Achten Sie darauf, dass Klemmenkanal, Sensor/Aktor/Subsystem und ggf. Funktion zueinander passen. Ein Kanal einer analogen Ausgangsklemme mit einem digitalen Signal zu verbinden wäre beispielsweise nicht erlaubt.

Definieren Sie ein Element vom Typ LAMP TYPE 1, BLIND DRIVE TYPE 1, WINDOW DRIVE TYPE 1 oder VALVE ACTUATOR 3 POINT, so muss eine Funktion definiert werden.

Außer bei der Namensvergabe von Elementen wird im gesamten Dokument nicht auf Groß- und Kleinschreibung und das Trennen von Wörtern geachtet. Es sind also beispielsweise auch die Eingaben EnOceanLineType1 und cx 9 0 0 0 zulässig.

Ferner müssen nur die Kanäle einer Klemme aufgelistet werden, die Sie auch verwenden möchten. Achten Sie darauf, dass die von ihnen aufgelisteten Kanäle vorhanden sind.

Verbinden Sie bei Subsystemen den ersten Kanal der entsprechenden Klemme mit der zugehörigen Subsystem Linie.

EnOcean

EnOcean Module können direkt mitdefiniert werden. Fügen Sie dazu für jedes EnOcean Modul den entsprechenden Inhalt in folgenden Spalten hinzu:

  • Sensor/Actuator/Line Type: DIGITAL SIGNAL TYPE 1 oder ANALOG SIGNAL TYPE 1.
  • Sensor/Actuator/Line Notation: Namen des Moduls.
  • Parameter 1: Id der Klemme.
  • Parameter 2: Transmitter Id des Moduls.
  • Parameter 3: Modultyp.

    Erlaubte Werte:

    • PTM 100 (nur bei DIGITAL SIGNAL TYPE 1)
    • PTM 200 (nur bei DIGITAL SIGNAL TYPE 1)
    • PTM 250 (nur bei DIGITAL SIGNAL TYPE 1)
    • STM 100
    • STM 250
  • Parameter 4: Ist abhängig vom gewählten Modultyp und beschreibt den Daten-Byte und -Bit (bei PTM Modulen somit den Gummikontakt).

    Erlaubte Werte bei PTM 100:

    • STATE O / CHANNEL A
    • STATE O / CHANNEL B
    • STATE O / CHANNEL C
    • STATE O / CHANNEL D
    • STATE I / CHANNEL A
    • STATE I / CHANNEL B
    • STATE I / CHANNEL C
    • STATE I / CHANNEL D

    Erlaubte Werte bei PTM 200 und PTM 250:

    • STATE O / CHANNEL A
    • STATE O / CHANNEL B
    • STATE I / CHANNEL A
    • STATE I / CHANNEL B
    Bei STM 100 und STM 250 muss das Daten-Byte (Low Word) gesetzt werden (Wertebereich: 0-3). Optional kann das Daten-Bit (High Word) durch "." getrennt dahinter geschrieben werden (Wertebereich: 0-7).
    Die Bedeutung dieser Bits wird in der EnOcean Dokumentation beschrieben.
DALI

DALI Lampen können ebenfalls direkt mitdefiniert werden. Fügen Sie dazu für jede DALI Lampe den entsprechenden Inhalt in folgenden Spalten hinzu:

  • Sensor/Actuator/Line Type: LAMP TYPE 2.
  • Sensor/Actuator/Line Notation: Namen der Lampe.
  • Parameter 1: DALI Adresse der Lampe.

Für einen schnelleren Einstieg kann über den nachfolgenden Link eine Vorlage bezogen werden. Diese Tabelle enthält bereits den Grundaufbau und zu jedem möglichen Typ einen Beispieleintrag.

Vorlage mit Beispieleinträgen aller Typen


Eigene Werkzeuge erstellen

Der TwinCAT Building Automation Manager bietet die Möglichkeit eigene Werkzeuge (AddIns) zu erstellen. AddIns haben die Möglichkeit über ein Objektmodel auf die interne Datenhaltung des TwinCAT Building Automation Managers zuzugreifen. Diese Zugriffe können lesend, sowie schreibend erfolgen. Somit können AddIns erstellt werden, mit denen eine Dokumentation der Anlage automatisch generiert werden kann. Ebenfalls realisierbar sind AddIns zum Einlesen von Dateien (z.B. Exeldateien) aus denen die Projektdatei erzeugt wird. Besonders von Bedeutung ist die Möglichkeit ganze Bedieneroberflächen zu generieren.

Die nachfolgenden Ausführungen zeigen alle notwendigen Schritte auf, um eine Grundlage für die eigentliche AddIn Entwicklung zu schaffen. Das vollständige Microsoft Visual Studio 2010 Projekt steht am Ende der Seite im Downloadbereich zur Verfügung.

Voraussetzungen

  • Microsoft Visual Studio 2010 (oder höher)
  • Microsoft .NET Framework 4.0 (oder höher)
  • Kenntnisse in der Programmiersprache C#

Projekt erstellen

Starten Sie das Microsoft Visual Studio 2010 und legen Sie ein neues Projekt an. Das Projekt muss vom Typ Class Library sein.

Entfernen Sie die standardmäßig erstellte Class1.cs Datei im Solution Explorer und fügen Sie dem Projekt eine neue Windows Form hinzu. Markieren Sie die neu hinzugefügte Form1.cs Datei und öffnen Sie die Code Ansicht. Der zu sehende Quelltext sollte nun wie folgt aussehen:

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Linq;
using System.Text;
using System.Windows.Forms;

namespace Sample
{
    public partial class Form1 : Form
    {
        public Form1()
        {
            InitializeComponent();
        }
    }
}

Referenzen hinzufügen

Der nächste Schritt umfasst das Hinzufügen von drei Referenzen.

  • System.ComponentModel.Composition: Stellt die benötigten Attribute ExportMetadata und Export bereit.
  • TcBAManager.AddIn: Bietet Zugriff auf Klassen die zur Arbeit mit dem TwinCAT Building Automation Manager notwendig sind.
  • TcBAManager.AddIn.Contract: Schnittstellen und Aufzählungstypen die das AddIn dem TwinCAT Building Automation Manager zur Verfügung stellen.
Rechtsklicken Sie im Solution Explorer auf References und wählen Add Reference... aus. Im neu geöffneten Fenster wählen Sie den .NET Tab aus und suchen nun die Referenz System.ComponentModel.Composition. Ein Doppelklick fügt sie zum Projekt hinzu.

Als nächstes folgen die Referenzen vom TwinCAT Building Automation Manager. Dazu betätigen Sie den Browse Tab und navigieren in das TwinCAT Building Automation Manager Verzeichnis (standardmäßig C:\TwinCAT\BAFrameworkV2.20\BAManager). Dort befinden sich die TcBAManager.AddIn.dll und die TcBAManager.AddIn.Contract.dll. Fügen Sie beide dem Projekt hinzu. Das Fenster kann nun geschlossen werden.

Bereitstellung

Damit das AddIn im TwinCAT Building Automation Manager zur Verfügung steht und korrekt angezeigt werden kann, sind ein paar Erweiterungen im Quelltext der Form1.cs Datei notwendig.

Beginnen Sie mit der Erweiterung der Namensräume. Es kommen System.ComponentModel.Composition, TwinCAT.BAManager.AddIns.Model und TwinCAT.BAManager.AddIns.Contract hinzu.

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Linq;
using System.Text;
using System.Windows.Forms;
using System.ComponentModel.Composition;
using TwinCAT.BAManager.AddIns.Model;
using TwinCAT.BAManager.AddIns.Contract;

namespace Sample
{
    public partial class Form1 : Form
    {
        public Form1()
        {
            InitializeComponent();
        }
    }
}

Erweitern Sie nun den Konstruktor um die Schnittstellen IAddInContractV1 und IDisposable. Anschließend folgen die Attribute über die zusätzliche Informationen innerhalb des TwinCAT Building Automation Managers zur Verfügung gestellt werden.

Dazu gehören der Anzeigename und die Beschreibung in der entsprechenden Sprache, die Versionsnummer und der AddIn Typ. Dieser legt den Anzeigeort des AddIns beim Menüpunkt Werkzeuge innerhalb des TwinCAT Building Automation Managers fest.

Die Angabe beim Attribut Export dient dem TwinCAT Building Automation Manager zur Identifikation gültiger AddIns.

Nun muss noch die Schnittstelle IAddInContractV1 implementiert und die globale Variable der Klasse Project angelegt und initialisiert werden.

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Linq;
using System.Text;
using System.Windows.Forms;
using System.ComponentModel.Composition;
using TwinCAT.BAManager.AddIns.Model;
using TwinCAT.BAManager.AddIns.Contract;

namespace Sample
{
    [ExportMetadata("Name1031", "Beispiel")]
    [ExportMetadata("Name1033", "Sample")]
    [ExportMetadata("Description1031", "Ein Beispielprogramm.")]
    [ExportMetadata("Description1033", "A sample program.")]
    [ExportMetadata("Version", "V1.0.0")]
    [ExportMetadata("Target", AddInTarget.Extension)]
    [Export(typeof(IAddInContractV1))]
    public partial class Form1 : Form, IAddInContractV1, IDisposable
    {

        private Project project;

        public Form1()
        {
            InitializeComponent();
            project = Project.Instance;
        }

        public Form AddInUserControl
        {
            get
            {
                return this;
            }
        }
    }
}

Die Instanz der Klasse Project bietet jetzt den Zugriff auf alle vom TwinCAT Building Automation Manager zur Verfügung gestellten Funktionen und Informationen.

Da es sich bei diesem Projekt um eine Klassenbibliothek handelt, müssen Sie zum Starten und Debuggen vorher noch in den Eigenschaften des Projekts ein externes Programm definieren mit dem das AddIn gestartet werden soll. Gehen Sie dazu in den Solution Explorer und rufen Sie mit einem Rechtsklick auf das Projekt die Properties auf. Im Menüpunkt Debug tragen Sie bei Start external program den Pfad zum TwinCAT Building Automation Manager ein.

Wechseln Sie zum Menüpunkt Build und tragen Sie im Bereich Output den Pfad zum AddIn Ordner des TwinCAT Building Automation Managers ein (standardmäßig C:\TwinCAT\BAFrameworkV2.20\BAManager\AddIns). Die Eigenschaften können nun geschlossen werden.

Zum Schluss muss noch verhindert werden, dass der gesamte TwinCAT Building Automation Manager beim Kompilieren in den AddIn Ordner kopiert wird. Hierfür gehen Sie in den Solution Explorer und erweitern den Ordner References. Öffnen Sie mit einem Rechtsklick die Eigenschaften der Referenz TcBAManager.AddIn und setzen Copy Local auf false. Wiederholen Sie diesen Vorgang für die Referenz TcBAManager.AddIn.Contract.

Informationen und Funktionen der Schnittstelle

Das Abfragen oder Setzen einfacher Informationen von Objekten, wie z.B. Name oder Kommentar, erfolgt über die Eigenschaften. Komplexere Informationen, wie z.B. Verlinkungen oder belegte Klemmenkanäle, stehen als XML Dokument zur Verfügung und können mit der Methode GetParameters( ) abgefragt bzw. mit SetParameters( ) gesetzt werden. Die Struktur zum Setzen von Parametern entspricht dabei exakt der gelieferten Struktur von GetParameters( ).

Des Weiteren können auch Meldungen in das Meldungsfenster des TwinCAT Building Automation Managers abgesetzt werden.

Einen ausführlichen Einblick in die Funktionen und den Aufbau liefert das angehängte Projekt AddIns.Test im Downloadbereich.

Anwendungs Snippets

Für die nachfolgenden Snippets dient das Projekt aus den vorherigen Schritten als Grundlage.

Snippet 1 - Szenen auslesen

Erstellen Sie mit dem TwinCAT Building Automation Manager ein neues Projekt und fügen Sie diesem einen beliebigen Controller mit mindestens vier Szenen und Lampen hinzu. Die erste Szene erhält ein Kommando, dass die erste Lampe einschaltet. Wiederholen Sie diesen Vorgang für die anderen Szenen.

foreach (Controller controller in project.Controllers)
{
    var scenes = from scene in controller.Scenes
                 where (scene.Id % 2) == 0
                 select scene;
    Debug.WriteLine("Controller {0}: {1} ", controller.Id, controller.Name);
    foreach (Scene scene in scenes)
    {
        XmlDocument doc = scene.GetParameters();
        Debug.WriteLine("  Scene {0}: {1}", scene.Id, scene.Name);
    }
}

Nach Aufruf des AddIns werden alle Szenen des Controllers, deren Id durch zwei teilbar ist, einer neuen Liste übergeben und anschließend in die Debug Konsole ausgegeben.

Die Methode GetParameters( ) liefert den Szeneninhalt in folgender XML Struktur:

‹?xml version="1.0" encoding="utf-16" ?›
‹Scene Id="2"›
    ‹ExternalImplementation›false‹/ExternalImplementation›
    ‹SumUpScenes›false‹/SumUpScenes›
    ‹SceneItem›
        ‹EntityControllerId›1‹/EntityControllerId›
        ‹EntityType›ActuatorLampBase‹/EntityType›
        ‹EntityId›2‹/EntityId›
        ‹EntityCommandId›3‹/EntityCommandId›
    ‹/SceneItem›
‹/Scene›

Snippet 2 - Projekt erstellen

project.CreateNew("Sample");

Controller controllerCX1010 = project.Controllers.Add(5);
controllerCX1010.Name = "My CX1010";

FieldBusDevice fieldBusDeviceCX1010 = controllerCX1010.FieldBusDevices.Add(1);
FieldBusCoupler fieldBusCouplerCX1010 = fieldBusDeviceCX1010.FieldBusCouplers.Add(4);

Terminal terminalKL2012 = fieldBusCouplerCX1010.Terminals.Add(project.TerminalDescriptions["2012_0"]);
terminalKL2012.Name = "My KL2012";

Lamp lampType1 = controllerCX1010.Lamps.Add(1);
lampType1.Name = "My Lamp";

XmlDocument doc = new XmlDocument();
doc.LoadXml(@"
    ‹Lamp›
        ‹Link›
            ‹LinkChannelId›0‹/LinkChannelId›
            ‹BusDeviceId›1‹/BusDeviceId›
            ‹BusCouplerId›1‹/BusCouplerId›
            ‹TerminalId›1‹/TerminalId›
            ‹ChannelId›1‹/ChannelId›
            ‹ControllerId›1‹/ControllerId›
        ‹/Link›
    ‹/Lamp›
");

lampType1.SetParameters(doc);

Hier wird ein neues Projekt mit Controller, Feldbusgerät, Feldbuskoppler, Klemme und Lampe erzeugt. Nach Erstellung der Parameter zum Verlinken der Lampe mit dem ersten Klemmenkanal wird die XML Struktur mit der Methode SetParameters( ) der Lampe übergeben.

Einen ausführlichen Einblick in die XML Struktur der jeweiligen Elemente liefert das Projekt AddIns.Test im Downloadbereich.

Schließen Sie das AddIn und den AddIn Auswahldialog. Das neu erzeugte Projekt erscheint jetzt im Navigationsbaum.

Downloadbereich

Projektvorlage für die AddIn Entwicklung.

  • Sample

Projekt das Funktionen und Aufbau der Schnittstelle aufzeigt.

  • AddIns.Test


Controller Einstellungen

Beim Klick auf einen Controller im Navigationsbaum erhält man Zugang zu dessen Einstellungen.

Allgemein
  • Name: Der Name des Elements kann hier geändert werden.
  • Id: Die einzigartige Id des Elements.
  • Typ: Der Typ des Elements.
  • Kommentar: Hinzufügen eines Kommentars für das Element erfolgt hier.
  • Gesperrt: Ein Hacken in dieser Box deaktiviert das Element in der aktuellen Konfiguration.

Einstellungen
  • Suchen (Ethernet)...: Suche des Controllers im Netzwerk. Der entsprechende Dialog wird mit betätigen der Suchen (Ethernet) ... Schaltfläche aufgerufen.
  • lokalen Host ausw.: Kann als Alternative zu Suchen (Ethernet)... benutzt werden und fügt den lokalen TwinCAT Host als Controller ein.
  • Host Name: Eintragung des Controller Namen durch eine erfolgreiche Suche im Netzwerk.
  • IP Adresse: Eintragung der IP Adresse des Controllers durch eine erfolgreiche Suche im Netzwerk.
  • AMS Net Id: Eintragung der AMS Net Id des Controllers durch eine erfolgreiche Suche im Netzwerk.
  • Benutzername: Name des Benutzers mit Administratorrechten auf dem Zielgerät.
  • Passwort: Passwort des angegebenen Benutzers.
  • Speichern der E/A Konfiguration (TSM-Datei): Aktivieren der Kontrollbox zum Erstellen einer TwinCAT System Manager kompatiblen *.tsm Datei, wenn das Projekt aktiviert wird. Die *.tsm Datei wird mit dem Namen des Zielsystems beim BAM Projekt abgelegt.
  • Ping beim Überprüfen vom Online-Status unterdrücken: Besitzt der Controller eine Firewall die Ping Übertragungen unterbindet, so könnte es zu Fehlermeldungen kommen, obwohl die Kommunikation zu TwinCAT normal abläuft. In diesem Fall kann die Einstellung den Ping unterdrücken.
  • Netzwerkvariablen an den folgenden Ethernet Adapter binden: Wählen Sie einen Ethernet Adapter aus an den die Netzwerkvariablen gebunden werden sollen.

Router Einstellungen
  • Listet alle TwinCAT Routeneinträge des Ziel Controllers auf.

Online
  • Stellt Echtzeitwerte des Controllers zur Verfügung.


Applikationsprogramm Einstellungen

Beim Klicken auf Applikationsprogramm im Navigationsbaum erhalten Sie Zugriff auf die Einstellungen des SPS Programms die zum Framework gehören. Weiterhin kann mit einem Rechtsklick das Verzeichnis in dem sich das SPS Programm befindet geöffnet werden. Ist das TwinCAT PLC Control installiert lässt sich die *.pro Datei direkt aufrufen. Dazu müssen die *.tpy und *.pro Datei denselben Namen haben.

Einstellungen

Parameter
  • Verzeichnis: Zeitgleich mit dem Kompilieren eines SPS Programms im TwinCAT PLC Control und Hochladen auf den Controller, wird eine *.tpy Datei im SPS Programmverzeichnis erzeugt. Der Pfad der zum Controller gehörenden *.tpy Datei muss hier eingetragen oder ausgewählt werden.
  • Relativ zur BAMX-Datei: Ist die Kontrollbox aktiviert, wird nur der (relative) Pfad der Projektdatei (*.bamx Datei) (z.B. .\TcBAFrameworkV2.20.tpy) hinterlegt, statt des ausführlichen (absoluten) Pfades zur *.tpy Datei (z.B. C:\BAM First Steps\TcBAFrameworkV2.20.tpy).
  • Ändern... / Neu einlesen: Diese Option dient zur Auswahl oder zum erneuten Einlesen der *.tpy Datei.

Leistungsmerkmale

In diesem Dialog wird aufgelistet, wie viele Sensoren, Aktoren etc. von der SPS verarbeitet werden können und wie viele verwendet werden. Weiterhin wird der höchste in Benutzung befindliche Array-Index aller Module angezeigt. (Ist der höchste benutzte Array-Index größer, als die derzeitige Anzahl, dann wurde zuvor ein Modul mit einem kleineren Index entfernt.)

Online

Zustand
  • Version: Zeigt die derzeitige Version der laufenden SPS an.
  • Berechnete Sonnenrichtung: Ergebnis der Berechnung für die Sonnenausrichtung mit den eingegebenen Koordinaten (Projekt → Einstellungen → Position).
  • Berechnete Sonnenhöhe: Ergebnis der Berechnung für die Sonnenhöhe.
  • Berechneter Sonnenaufgang: Voraussichtlicher Sonnenaufgang.
  • Berechneter Sonnenuntergang: Voraussichtlicher Sonnenuntergang.
  • Lokale Zeit und Datum: Lokale Uhrzeit und Datum des Controllers auf dem die SPS ausgeführt wird.
  • Mittlere Greenwich-Zeit und Datum: Greenwich-Zeit (GMT).
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Symbole

Unabhängige SPS Ein- und Ausgangsvariablen werden im BA Manager angezeigt und können mit jeder Klemme (Variablen) derselben Bit Größe verknüpft werden. Diese Variablen werden separat aufgelistet (Ein- und Ausgang) und stehen unter Applikationsprogramm→Symbole im Navigationsbaum zur Verfügung.

Wie füge Ich benutzerdefinierte Ein- und Ausgangsvariablen hinzu?

  • Fügen Sie mit dem TwinCAT PLC Control eine SPS Variable zum Applikationsprogramm hinzu. Arrays und Strukturen werden ebenfalls unterstützt. Die Position der Variablen innerhalb des Projekts ist hierbei nicht entscheidend.

    Hinweis
    Die Variable muss im Ein- oder Ausgangsbereich liegen.
    Beispiel
    VAR(* wird angezeigt *)
    Var1  AT %IX5.3  : BOOL;
    Var2  AT %I*     : INT;
    Var3  AT %QB17   : WORD;
    Var4  AT %Q*     : REAL;

    (* wird nicht angezeigt *)
    Var5  AT %M*     : BOOL;
    Var6             : UINT;
END_VAR
    Var1 to Var4 wird im BA Manager angezeigt.
    Var5 wird nicht angezeigt, weil im Speicherbereich angelegt.

    Var6 wird nicht angezeigt, weil im Speicherbereich angelegt und steht daher nicht im Ein- und Ausgangsbereich zur Verfügung.

    Für weitere Informationen zum Anlegen von Variablen und Reservieren von Speicherbereichen lesen Sie bitte die TwinCAT PLC Control Dokumentation.
  • Kompilieren Sie das Projekt erneut, damit die *.tpy erneut erzeugt wird.
  • Lesen Sie die *.tpy Datei erneut in den BA Manager ein indem Sie Applikationsprogramm im Navigationsbaum für den entsprechenden Controller auswählen und im Einstellungen Menü im Informations und Einstellungs Fenster auf der rechten Seite auf Neu einlesen klicken.

  • Die Symbole werden nun im Navigation tree aufgelistet.

Wie konfiguriere Ich benutzerdefinierte Symbole?

  • Linksklick auf ein Symbol.
  • Wählen Sie das Einstellungen Menü im Informations und Einstellungs Fenster auf der rechten Seite aus.
  • Die Klemmen Zuordnung Sektion erscheint im unteren Bereich des Einstellungen Menüs.
  • Klicken Sie auf die verknüpft mit... Schaltfläche. Es erscheint der Verknüpfungs Dialog.


Symbol Einstellungen

Allgemein
  • Name: Name des Symbols im SPS Programm.
  • Typ: Variablen Typ des Symbols.
  • Pfad: Pfad des Symbols im SPS Programm.
  • Kommentar: Kommentar für das Symbol im SPS Programm.

Einstellungen
  • Klemmen Zuordnung: Klicken Sie auf verknüpft mit..., um das Symbol mit einer Klemmenvariablen der selben Bit Größe zu verknüpfen.


Digitale Signale

Die folgenden digitalen Signale sind verfügbar:

  • Standard Digitales Signal
  • EnOcean Digitales Signal
  • DALI smartSPOT Digitales Signal
  • Vörwärts-/Rückwärts-Zähler per KL1512 Digitales Signal


Standard Digitales Signal

Ein Standard Digitales Signal liest und analysiert digitale Signale die mit einer Standard digitalen Eingangsklemme verknüpft sind.

Einstellungen

Parameter
  • Einschaltverzögerung: Einschaltverzögerung.
  • Ausschaltverzögerung: Ausschaltverzögerung.
  • Zeitfenster langer/doppelter Tastendruck: Zeit bis zur Feststellung eines langen und doppelten Tastendrucks, die zur Aktivierung von Szenen benutzt werden, siehe unten. Ein gedrückt halten des Tasters über diese Zeitspanne hinaus, wird als langer Tastendruck gewertet. Ein zweimaliges Betätigen des Tasters innerhalb dieser Zeitspanne, wird als doppelter Tastendruck gewertet.
  • Eingang negieren: Negiert den digitalen Eingang.

Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die entsprechenden Eingangsklemmen mit diesem Modul verknüpft werden können.

Zähler

Parameter
  • Multiplizierer: Multiplikator des Zählers.
  • Offset: Verschiebung die dem Zähler hinzugefügt wird.
  • Einheit: Einheit vom skalierten Wert. Nur für die Anzeige im Building Automation Framework.
  • Richtung: Zählrichtung.

Szenen

Ein Betätigen der Neu Schaltfläche im Szenen Menü öffnet einen Dialog in dem die analysierten Ereignisse
  • steigende Flanke
  • fallende Flanke
  • Flankenänderung
  • Tastendruck
  • doppelter Tastendruck
  • langer Tastendruck
(siehe Logikschaltbild oben) zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Zustand
  • Wert: Der resultierende Wert (siehe Logikschaltbild oben).
  • Rohwert: Rohwert der digitalen Eingangsklemme inklusive der aktivierten / deaktivierten Negation (siehe Logikschaltbild oben).
  • Zähler: Derzeitiger Wert des Zählers.
  • Zähler setzen: Wert auf den der Zähler gesetzt werden soll.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


EnOcean Digitales Signal

Ein EnOcean Digitales Signal analysiert die Telegramme eines digitalen EnOcean Transmitters.

Einstellungen

Parameter
  • Einschaltverzögerung: Einschaltverzögerung.
  • Ausschaltverzögerung: Ausschaltverzögerung.
  • Zeitfenster langer/doppelter Tastendruck: Zeit bis zur Feststellung eines langen und doppelten Tastendrucks, die zur Aktivierung von Szenen benutzt werden, siehe unten. Ein gedrückt halten des Tasters über diese Zeitspanne hinaus, wird als langer Tastendruck gewertet. Ein zweimaliges Betätigen des Tasters innerhalb dieser Zeitspanne, wird als doppelter Tastendruck gewertet.
  • Eingang negieren: Negiert den digitalen Eingang.

Subsystem Zuordnung
  • Transmitter Id: Id des EnOcean Transmitters.
  • Id der KL6583 (nur für 6581): Id der Klemme.
  • Watchdog: EnOcean Module senden regelmäßig Telegramme und ähneln daher Bewegungsmeldern. Für Schaltmodule ist eine Watchdog Funktion jedoch nicht sinnvoll und sollte deaktiviert werden, indem der Wert auf 0s gesetzt wird.
  • Modultyp: Der richtige Transmitter Typ, wie er in der Anleitung / Hersteller Referenz zu finden ist, muss hier angegeben werden.
  • Data Byte / Data Bit: Das zutreffende Data Byte / Data Bit des gewünschten Wertes muss hier angegeben werden.
Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die entsprechende EnOcean Linie mit diesem Modul verknüpft werden kann.

Zähler

Parameter
  • Multiplizierer: Multiplikator des Zählers.
  • Offset: Verschiebung die dem Zähler hinzugefügt wird.
  • Einheit: Einheit vom skalierten Wert. Nur für die Anzeige im Building Automation Framework.
  • Richtung: Zählrichtung.

Szenen

Ein Betätigen der Neu Schaltfläche im Szenen Menü öffnet einen Dialog in dem die analysierten Ereignisse
  • steigende Flanke
  • fallende Flanke
  • Flankenänderung
  • Tastendruck
  • doppelter Tastendruck
  • langer Tastendruck
(siehe Logikschaltbild oben) zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Zustand
  • Wert: Der resultierende Wert (siehe Logikschaltbild oben).
  • Rohwert: Rohwert der digitalen Eingangsklemme inklusive der aktivierten / deaktivierten Negation (siehe Logikschaltbild oben).
  • Zähler: Derzeitiger Wert des Zählers.
  • Zähler setzen: Wert auf den der Zähler gesetzt werden soll.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


DALI smartSPOT Digitales Signal

Das digitale DALI smartSpot Signal wertet die Präsenzmeldung von einem DALI SmartSpot aus.

Einstellungen

Parameter
  • Einschaltverzögerung: Einschaltverzögerung.
  • Ausschaltverzögerung: Ausschaltverzögerung.
  • Zykluszeit für die Abfrage vom Istwert bei Präsenz: Zeit, in der Anwesenheit erkannt wurde.
  • Zykluszeit für die Abfrage vom Istwert ohne Präsenz: Zeit, in der keine Anwesenheit erkannt wurde.
  • Eingang negieren: Negiert den digitalen Eingang.
Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die entsprechende DALI Linie mit diesem Modul verknüpft werden kann.

Zähler

Parameter
  • Multiplizierer: Multiplikator des Zählers.
  • Offset: Verschiebung die dem Zähler hinzugefügt wird.
  • Einheit: Einheit vom skalierten Wert. Nur für die Anzeige im Building Automation Framework.
  • Richtung: Zählrichtung.

Szenen

Ein Betätigen der Neu Schaltfläche im Szenen Menü öffnet einen Dialog in dem die analysierten Ereignisse
  • steigende Flanke
  • fallende Flanke
  • Flankenänderung
zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

State
  • Wert: Anwesenheitserkennung.
  • Rohwert: Rohwert der digitalen Eingangsklemme inklusive der aktivierten / deaktivierten Negation (siehe Logikschaltbild oben).
  • Zähler: Derzeitiger Wert des Zählers.
  • Zähler setzen: Wert auf den der Zähler gesetzt werden soll.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Vorwärts-/Rückwärts-Zähler per KL1512 Digitales Signal

Das digitale Signal Vorwärts-/Rückwärts-Zähler ist mit der Zählerklemme KL1512 verbunden und stellt den aktuellen Zählerstand bereit.

Einstellungen

Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die entsprechende Zählerklemme mit diesem Modul verknüpft werden kann.

Zähler

Parameter
  • Multiplizierer: Multiplikator des Zählers.
  • Offset: Verschiebung die dem Zähler hinzugefügt wird.
  • Einheit: Einheit vom skalierten Wert. Nur für die Anzeige im Building Automation Framework.
  • Richtung: Zählrichtung.

Online

State
  • Zähler: Derzeitiger Wert des Zählers.
  • Zähler setzen: Wert auf den der Zähler gesetzt werden soll.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Analoge Signale

Die folgenden analogen Signale sind verfügbar:

  • Standard Analoges Signal
  • EnOcean Analoges Signal
  • DALI smartSPOT Analoges Signal


Standard Analoges Signal

Das Standard analoge Signal analysiert den Wert einer analogen Eingangsklemme.

Einstellungen

Parameter
  • unterer Rohwert,
    oberer Rohwert,
    unterer Skalierungswert,
    oberer Skalierungswert:     Diese Parameter bilden die lineare Gleichung für den Rohwert ↔ skalierter Wert.
    Der untere Rohwert muss immer kleiner, als der obere Rohwert sein.
  • Offset: Normalerweise ist das Verhältnis zwischen dem Rohwert und dem Skalierungswert durch die lineare Gleichung gegeben, wie oben beschrieben. Der Offset wird dem berechneten Skalierungswert für die Feinabstimmung hinzugefügt.
  • Einheit: Einheit vom skalierten Wert. Nur für die Anzeige im Building Automation Framework.
  • Zeitkonstante PT2 Filter: Falls erforderlich kann der berechnete Skalierungswert vom PT2-Filter gedämpft werden. Wenn diese Funktion nicht genutzt werden soll, dann muss der Wert auf 0ms gesetzt werden.
  • Fehler Modus: Gibt vor, wie mit Fehlern verfahren werden soll.
  • Ersatzwert: Im Fehlerfall wird ersatzweise dieser Wert verwendet.
Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die entsprechende Eingangsklemme mit diesem Modul verknüpft werden kann.

Schwellwertschalter

Zwei Schwellwertschalter können für den Skalierungswert verwendet werden. Die steigende und fallende Flanke der Schalter können Szenen aufrufen (siehe Szenen Menü unten). Zusätzlich kann eine Hysterese und Verzögerung festgelegt werden, um das Verhalten des skalierten Wertes zu dämpfen.

Szenen

Ein Betätigen der Neu Schaltfläche im Szenen Menü öffnet einen Dialog in dem die steigende und fallende Flanke der Schwellwertschalter zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Zustand
  • skalierter Wert: Berechneter skalierter Wert, wie im Einstellungsmenü beschrieben (Rohwert → lineare Gleichung → zusätzlicher Offset → PT2-Filter → skalierter Werte).
  • Rohwert: Empfangener Rohwert von der analogen Eingangsklemme.
  • Zustand Schwellwertschalter 1/2: Aktiv, wenn der skalierte Wert den Schwellwertschalter überschreitet, ansonsten inaktiv.
  • Ersatzwert wird benutzt: Gibt an, ob der Ersatzwert benutzt wird.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


EnOcean Analoges Signal

Ein EnOcean Analoges Signal analysiert die analogen Ausgabewerte eines EnOcean Transmitters.

Einstellungen

Parameter
  • unterer Rohwert,
    oberer Rohwert,
    unterer Skalierungswert,
    oberer Skalierungswert:     Diese Parameter bilden die lineare Gleichung für den Rohwert ↔ skalierter Wert.
    Der untere Rohwert muss immer kleiner, als der obere Rohwert sein.
  • Offset: Normalerweise ist das Verhältnis zwischen dem Rohwert und dem Skalierungswert durch die lineare Gleichung gegeben, wie oben beschrieben. Der Offset wird dem berechneten Skalierungswert für die Feinabstimmung hinzugefügt.
  • Einheit: Einheit vom skalierten Wert. Nur für die Anzeige im Building Automation Framework.
  • Zeitkonstante PT2 Filter: Falls erforderlich kann der berechnete Skalierungswert vom PT2-Filter gedämpft werden. Wenn diese Funktion nicht genutzt werden soll, dann muss der Wert auf 0ms gesetzt werden.
  • Fehler Modus: Gibt vor, wie mit Fehlern verfahren werden soll.
  • Ersatzwert: Im Fehlerfall wird ersatzweise dieser Wert verwendet.

Subsystem Zuordnung

  • Transmitter Id: Id des EnOcean Transmitters.
  • Id der KL6583 (nur für 6581): Id der Klemme.
  • Watchdog: EnOcean Module senden regelmäßig Telegramme und ähneln daher Temperatursensoren. Für Schaltmodule ist eine Watchdog Funktion jedoch nicht sinnvoll und sollte deaktiviert werden, indem der Wert auf 0s gesetzt wird.
  • Modultyp: Der richtige Transmitter Typ, wie er in der Anleitung / Hersteller Referenz zu finden ist, muss hier angegeben werden.
  • Data Byte / Data Bit: Das zutreffende Data Byte des gewünschten Wertes muss hier angegeben werden.
Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die entsprechende EnOcean Linie mit diesem Modul verknüpft werden kann.

Schwellwertschalter

Zwei Schwellwertschalter können für den Skalierungswert verwendet werden. Die steigende und fallende Flanke der Schalter können Szenen aufrufen (siehe Szenen Menü unten). Zusätzlich kann eine Hysterese und Verzögerung festgelegt werden, um das Verhalten des skalierten Wertes zu dämpfen.

Szenen

Ein Betätigen der Neu Schaltfläche im Szenen Menü öffnet einen Dialog in dem die steigende und fallende Flanke der Schwellwertschalter zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Zustand
  • skalierter Wert: Berechneter skalierter Wert, wie im Einstellungsmenü beschrieben. (Rohwert → lineare Gleichung → zusätzlicher Offset → PT2-Filter → skalierter Werte)
  • Rohwert: Empfangener Rohwert von der analogen Eingangsklemme.
  • Zustand Schwellwertschalter 1/2: Aktiv, wenn der skalierte Wert den Schwellwertschalter überschreitet, ansonsten inaktiv.
  • Ersatzwert wird benutzt: Gibt an, ob der Ersatzwert benutzt wird.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


DALI smartSPOT Analoges Signal

Ein DALI smartSPOT analoges Signal wertet die Helligkeit von einem DALI smartSPOT aus.

Einstellungen

Parameter
  • Offset: Der Offset wird dem empfangenen Wert zur Feinabstimmung hinzugefügt.
  • Zeitkonstante PT2 Filter: Falls erforderlich kann der empfangene Wert vom PT2-Filter gedämpft werden. Wenn diese Funktion nicht genutzt werden soll, dann muss der Wert auf 0ms gesetzt werden.
  • Abfragezeit bei Präsenz / Abfragezeit bei nicht Präsenz: Wie alle DALI Geräte sendet der smartSPOT die Informationen nicht von sich aus. Eine Abfrageroutine ist erforderlich, um die aktuellen Informationen zu erhalten.
    Es ist sinnvoll die Präsenz häufiger abzufragen, wenn der überwachte Raum nicht belegt ist. Hierzu können in Abhängigkeit der Raumbelegung zwei verschiedene Abfragezeiten angegeben werden. Die Belegung wird vom smartSPOT selbst erkannt.
  • Einheit: Einheit vom skalierten Wert. Nur für die Anzeige im Building Automation Framework.
  • Fehler Modus: Gibt vor, wie mit Fehlern verfahren werden soll.
  • Ersatzwert: Im Fehlerfall wird ersatzweise dieser Wert verwendet.
Subsystem Zuordnung
  • Kurzadresse: DALI Kurzadresse vom smartSPOT.
Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die entsprechende DALI Linie mit diesem Modul verknüpft werden kann.

Schwellwertschalter

Zwei Schwellwertschalter können für den Skalierungswert verwendet werden. Die steigende und fallende Flanke der Schalter können Szenen aufrufen (siehe Szenen Menü unten). Zusätzlich kann eine Hysterese und Verzögerung festgelegt werden, um das Verhalten des skalierten Wertes zu dämpfen.

Szenen

Ein Betätigen der Neu Schaltfläche im Szenen Menü öffnet einen Dialog in dem die steigende und fallende Flanke der Schwellwertschalter zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Zustand
  • Helligkeit: Die zuletzt abgefragte und berechnete Helligkeit vom smartSPOT.
  • Rohwert: Der zuletzt abgefragte Rohwert vom smartSPOT.
  • Zustand Schwellwertschalter 1/2: Aktiv, wenn der skalierte Wert den Schwellwertschalter überschreitet, ansonsten inaktiv.
  • Ersatzwert wird benutzt: Gibt an, ob der Ersatzwert benutzt wird.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Lampen

Die folgenden Lampen sind verfügbar:

  • Standard Lampe
  • DALI Lampe
  • DALI Lampe für Notbeleuchtung


Standard Lampe

Dieses Modul dient zum Ansteuern von Lampen über einen digitalen und/oder analogen Ausgang. Um Gruppen mit anderen Lampenarten zusammenstellen zu können, z.B. DALI, wird die zu Grunde liegende Spanne einer analogen Lampe an der Dimmerklemme von 0..32767 in Prozent dargestellt. Für digitale Lampen entspricht der Wert 0% dem ausgeschaltet Zustand und jeder andere Wert dem eingeschalteten Zustand. Falls erforderlich werden die Werte für weitere Gruppenberechnungen herangezogen.

Einstellungen

Parameter
  • minimale Stellgröße: Der kleinste Wert auf den die Lampe gedimmt werden kann, wenn analog.
  • maximale Stellgröße: Der größte Wert auf den die Lampe gedimmt werden kann.
  • Anzahl der Dimmstufen: Menge, um die der Lampenwert beim Hoch Dimmen / Runter Dimmen Befehl erhöht / verringert werden soll.
  • Stellgröße Systemstart: Anfangswert der Lampe nach dem die SPS Applikation gestartet ist. Wenn die Lampe gezielt auf einen Wert unterhalb des Minimums oder oberhalb des Maximums gesetzt, dann wird sie automatisch auf die entsprechende Grenze gesetzt. Ausnahme sind hierbei 0%, was die Lampe ausschaltet.
  • Wiedereinschaltmodus: Wenn ausgewählt, wird sich der letzte Wert der Lampe vorm Ausschalten gemerkt. Beim erneuten einschalten durch den Ein Befehl wird die Lampe auf den hinterlegten Wert gesetzt.
  • Digitalausgang negieren / Analogausgang negieren: 0% entspricht an und 100% aus. Es gelten die oben erwähnten Einschränkungen: Werte unterhalb der minimalen Stellgröße setzt die Lampe auf ihr Minimum und Werte oberhalb der maximalen Stellgröße auf ihr Maximum. 0% ist möglich, schaltet die Lampe aber in diesem Fall ein.

Online

Befehle
  • Hoch Dimmen: Dieser Befehl erhöht den Lichtwert um die eingetragene Dimmstufe. Der Befehl funktioniert nur, wenn die Lampe bereits eingeschaltet ist. Eine Erhöhung des Wertes über die Grenze hinaus ist nicht möglich.
  • Runter Dimmen: Dieser Befehl verringert den Lichtwert um die eingetragene Dimmstufe, wird die Lampe jedoch nicht ausschalten.
  • Ein: Schaltet die Lampe auf ihr Maximum ein oder auf den Wiedereinschaltwert, insofern der Wiedereinschaltmodus aktiviert wurde.
  • Aus: Schaltet die Lampe aus. Ist der Wiedereinschaltmodus aktiv, wird vorher der aktuelle Lichtwert gespeichert.
  • maximale Stellgröße ausgeben: Die Lampe wird auf ihren maximalen Wert gesetzt.
  • minimale Stellgröße ausgeben: Die Lampe wird auf ihren minimalsten Wert gesetzt.
  • Stellgröße vorgeben: Der eingetragene Wert wird übernommen, sobald die Übernehmen Schaltfläche betätigt wurde. Wenn die Lampe gezielt auf einen Wert unter- oder oberhalb ihrer Grenzen gesetzt wird, dann erhält sie automatisch einen angepassten Wert entsprechend der Begrenzung. Ausnahme sind 0%, was die Lampe ausschaltet.
  • Betriebsstundenzähler setzen: Der eingetragene Wert wird übernommen, sobald die Übernehmen Schaltfläche betätigt wurde.
Zustand
  • Stellgröße: Aktueller Ausgabewert.
  • Wiedereinschaltwert: Wenn der Wiedereinschaltmodus ausgewählt wurde, dann wird vorm Ausschalten der Lampe der letzte Lichtwert gespeichert. Wird die Lampe wieder durch den Ein Befehl eingeschaltet erhält sie den hinterlegten Wert.
  • Betriebsstundenzähler: Betriebszeit der Lampe.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


DALI Lampe

Dieses Modul dient zum Ansprechen von DALI-Vorschaltgeräten. Um Gruppen mit Standard Lampen zusammenstellen zu können wird die zu Grunde liegende Spanne einer DALI Lampe von 0..254 in Prozent dargestellt. Die Berechnung ist linear: 0% entsprechen 0 (DALI), 50% 127 (DALI) und 100% 254 (DALI).

Einstellungen

Parameter
  • minimale Stellgröße: Der kleinste Wert auf den die Lampe gedimmt werden kann.
  • maximale Stellgröße: Der größte Wert auf den die Lampe gedimmt werden kann. Ein ändern dieser Werte wird nicht die internen minimalen und maximalen Werte des Vorschaltgerätes beeinflussen, da diese immer überwiegen.
  • Anzahl der Dimmstufen: Menge, um die der Lampenwert beim Hoch Dimmen / Runter Dimmen-Befehl erhöht / verringert werden soll.
  • Stellgröße Systemstart: Anfangswert der Lampe nach dem die SPS Applikation gestartet ist. Wenn die Lampe gezielt auf einen Wert unterhalb des Minimums oder oberhalb des Maximums gesetzt, dann wird sie automatisch auf die entsprechende Grenze gesetzt. Ausnahme sind hierbei 0%, was die Lampe ausschaltet.
  • Stellgröße bei Systemfehler: Der Wert der DALI Lampe im Fehlerfall. Dies ist der Wert im Falle eines Verbindungsabbruchs zur DALI Klemme.
  • Zykluszeit für die Abfrage der Stellgröße: Da nicht alle DALI Befehle die Vorschaltgeräte auf absolute Werte setzen ist es gelegentlich notwendig diese abzufragen. Der eingetragene Wert gibt das Intervall der Abfrage vor.
  • Wiedereinschaltmodus: Wenn ausgewählt, wird sich der letzte Wert der Lampe vorm Ausschalten gemerkt. Beim erneuten einschalten durch den Ein Befehl wird die Lampe auf den hinterlegten Wert gesetzt.
Subsystem Zuordnung
  • Kurzadresse: Die Kurzadresse des entsprechenden DALI Geräts.
  • verknüpft mit...: Die DALI Linie mit dem installierten Vorschaltgerät muss hier eingetragen werden. Die Schaltfläche öffnet einen Dialog zur Auswahl der DALI Klemme.

Online

Befehle
  • Hoch Dimmen: Dieser Befehl erhöht den Lichtwert um die eingetragene Dimmstufe. Der Befehl funktioniert nur, wenn die Lampe bereits eingeschaltet ist. Eine Erhöhung des Wertes über die Grenze hinaus ist nicht möglich.
  • Runter Dimmen: Dieser Befehl verringert den Lichtwert um die eingetragene Dimmstufe, wird die Lampe jedoch nicht ausschalten.
  • Ein: Schaltet die Lampe auf ihr Maximum ein oder auf den Wiedereinschaltwert, insofern der Wiedereinschaltmodus aktiviert wurde.
  • Aus: Schaltet die Lampe aus. Ist der Wiedereinschaltmodus aktiv, wird vorher der aktuelle Lichtwert gespeichert.
  • maximale Stellgröße ausgeben: Die Lampe wird auf ihren maximalen Wert gesetzt.
  • minimale Stellgröße ausgeben: Die Lampe wird auf ihren minimalsten Wert gesetzt.
  • Stellgröße vorgeben: Der eingetragene Wert wird übernommen, sobald die Übernehmen Schaltfläche betätigt wurde. Wenn die Lampe gezielt auf einen Wert unter- oder oberhalb ihrer Grenzen gesetzt wird, dann erhält sie automatisch einen angepassten Wert entsprechend der Begrenzung. Ausnahme sind 0%, was die Lampe ausschaltet.
  • Betriebsstundenzähler setzen: Der eingetragene Wert wird übernommen, sobald die Übernehmen Schaltfläche betätigt wurde.
Zustand
  • Stellgröße: Aktueller Ausgabewert. Wird die Lampe auf einen neuen Wert gesetzt, so wird dieser zuerst im Stellgröße Feld angezeigt ungeachtet dessen, ob die Lampe diesen schon tatsächlich erreicht hat. Verantwortlich dafür ist die interne Dimmrate des Vorschaltgeräts. Die Lampe wird sich langsam dem Zielwert nähern und mit einer geringeren Zykluszeit für die Abfrage der Stellgröße kann man den Dimmvorgang beobachten. Am Ende wird der Lampenwert, so weit wie es nur geht, den Prozentwert erreicht haben.
  • Wiedereinschaltwert: Wenn der Wiedereinschaltmodus ausgewählt wurde, dann wird vorm Ausschalten der Lampe der letzte Lichtwert gespeichert. Wird die Lampe wieder durch den Ein Befehl eingeschaltet erhält sie den hinterlegten Wert.
  • Betriebsstundenzähler: Betriebszeit der Lampe.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


DALI Lampe für Notbeleuchtung

Dieses Modul dient zum Ansteuern von DALI-Vorschaltgeräten für die Notbeleuchtung. Um Gruppen mit Standard Lampen zusammenstellen zu können wird die zu Grunde liegende Spanne einer DALI Lampe von 0..254 in Prozent dargestellt. Die Berechnung ist linear: 0% entsprechen 0 (DALI), 50% 127 (DALI) und 100% 254 (DALI).

Einstellungen

Parameter
  • minimale Stellgröße: Der kleinste Wert auf den die Lampe gedimmt werden kann.
  • maximale Stellgröße: Der größte Wert auf den die Lampe gedimmt werden kann. Ein ändern dieser Werte wird nicht die internen minimalen und maximalen Werte des Vorschaltgerätes beeinflussen, da diese immer überwiegen.
  • Anzahl der Dimmstufen: Menge, um die der Lampenwert beim Hoch Dimmen / Runter Dimmen Befehl erhöht / verringert werden soll.
  • Stellgröße Systemstart: Anfangswert der Lampe nach dem die SPS Applikation gestartet ist. Wenn die Lampe gezielt auf einen Wert unterhalb des Minimums oder oberhalb des Maximums gesetzt, dann wird sie automatisch auf die entsprechende Grenze gesetzt. Ausnahme sind hierbei 0%, was die Lampe ausschaltet.
  • Stellgröße bei Systemfehler: Der Wert der DALI Lampe im Fehlerfall. Dies ist der Wert im Falle eines Verbindungsabbruchs zur DALI Klemme.
  • Zykluszeit für die Abfrage der Stellgröße: Da nicht alle DALI Befehle die Vorschaltgeräte auf absolute Werte setzen ist es gelegentlich notwendig diese abzufragen. Der eingetragene Wert gibt das Intervall der Abfrage vor.
  • Wiedereinschaltmodus: Wenn ausgewählt, wird sich der letzte Wert der Lampe vorm Ausschalten gemerkt. Beim erneuten einschalten durch den Ein Befehl wird die Lampe auf den hinterlegten Wert gesetzt.
Subsystem Zuordnung
  • Kurzadresse: Die Kurzadresse des entsprechenden DALI Geräts.
  • verknüpft mit...: Die DALI Linie mit dem installierten Vorschaltgerät muss hier eingetragen werden. Die Schaltfläche öffnet einen Dialog zur Auswahl der DALI Klemme.

Online

Befehle
  • Hoch Dimmen: Dieser Befehl erhöht den Lichtwert um die eingetragene Dimmstufe. Der Befehl funktioniert nur, wenn die Lampe bereits eingeschaltet ist. Eine Erhöhung des Wertes über die Grenze hinaus ist nicht möglich.
  • Runter Dimmen: Dieser Befehl verringert den Lichtwert um die eingetragene Dimmstufe, wird die Lampe jedoch nicht ausschalten.
  • Ein: Schaltet die Lampe auf ihr Maximum ein oder auf den Wiedereinschaltwert, insofern der Wiedereinschaltmodus aktiviert wurde.
  • Aus: Schaltet die Lampe aus. Ist der Wiedereinschaltmodus aktiv, wird vorher der aktuelle Lichtwert gespeichert.
  • maximale Stellgröße ausgeben: Die Lampe wird auf ihren maximalen Wert gesetzt.
  • minimale Stellgröße ausgeben: Die Lampe wird auf ihren minimalsten Wert gesetzt.
  • Stellgröße vorgeben: Der eingetragene Wert wird übernommen, sobald die Übernehmen Schaltfläche betätigt wurde. Wenn die Lampe gezielt auf einen Wert unter- oder oberhalb ihrer Grenzen gesetzt wird, dann erhält sie automatisch einen angepassten Wert entsprechend der Begrenzung. Ausnahme sind 0%, was die Lampe ausschaltet.
  • Betriebsstundenzähler setzen: Der eingetragene Wert wird übernommen, sobald die Übernehmen Schaltfläche betätigt wurde.
Zustand
  • Stellgröße: Aktueller Ausgabewert. Wird die Lampe auf einen neuen Wert gesetzt, so wird dieser zuerst im Stellgröße Feld angezeigt ungeachtet dessen, ob die Lampe diesen schon tatsächlich erreicht hat. Verantwortlich dafür ist die interne Dimmrate des Vorschaltgeräts. Die Lampe wird sich langsam dem Zielwert nähern und mit einer geringeren Zykluszeit für die Abfrage der Stellgröße kann man den Dimmvorgang beobachten. Am Ende wird der Lampenwert, so weit wie es nur geht, den Prozentwert erreicht haben.
  • Wiedereinschaltwert: Wenn der Wiedereinschaltmodus ausgewählt wurde, dann wird vorm Ausschalten der Lampe der letzte Lichtwert gespeichert. Wird die Lampe wieder durch den Ein Befehl eingeschaltet erhält sie den hinterlegten Wert.
  • Betriebsstundenzähler: Betriebszeit der Lampe.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Blind Drives

TS8100 | TwinCAT Building Automation Framework V2.2x

Jalousieantriebe

Die folgenden Jalousieantriebe sind verfügbar:

  • Standard Jalousieantriebe
  • Jalousieantriebe verbunden mit KL2532/KL2552


Standard Jalousieantrieb

Dieses Modul dient zum Ansteuern von Jalousieantrieben über zwei digitale Ausgänge.

Einstellungen

Parameter
  • Fahrdauer: Gesamte Fahrdauer der Jalousie.
  • Fahrdauer bei Schrittbetrieb: Fahrdauer für einen Schritt.
  • Dauer Richtungswechsel: Zeit zum Drehen der Lamellen von einer Grenze zur anderen (Lichtdurchlässigkeit von unten / Lichtdurchlässigkeit von oben).
  • Ruhepause beim Richtungswechsel: Wartezeit, beim Ändern der Fahrtrichtung.
  • Rückfahrtzeit nach Erreichen der Position: Wenn eine Jalousie zu einer bestimmten Position runter fährt, ausgenommen 100% (vollständig geschlossen), dann kann es notwendig sein die Lamellen zu drehen, um die Lichtdurchlässigkeit von unten zu vermeiden (z.B. bei Schlafzimmern oder Bädern). Dieser Wert gibt die Drehzeit für die Lamellen vor.
  • Ausrichtung: Ausrichtung der Jalousie. 0° = Norden, 90° = Osten, 180° = Süden, 270° = Westen.
  • Digitalausgang Hoch/Runter negieren: Negiert die Ansteuerung an den digitalen Ausgängen.

Sensoren / Aktoren

In diesem Menü kann das digitale Signal/die digitale Signalgruppe eingetragen werden, um das Runterfahren der Jalousie zu sperren. Dieses können z.B. Fensterkontakte sein. Dadurch kann das automatische Runterfahren der Jalousien von geöffneten Terrassentüren vermieden werden.

Online

Befehle
  • Schritt Hoch/Runter: Fährt die Jalousie für einen Schritt hoch/runter. Siehe auch Parameter Fahrdauer bei Schrittbetrieb.
  • Hoch/Runter: Fährt die Jalousie hoch/runter.
  • Stopp: Hält die Jalousie an.
  • Sicherheitsposition Setzen: Fährt die Sicherheitsposition an. In diesem Fall wird die Jalousie komplett hochgefahren. Es werden keine weiteren Befehle, außer Sicherheitsposition Rücksetzen, akzeptiert.
  • Sicherheitsposition Rücksetzen: Die Sperrung in der Sicherheitsposition wird aufgehoben.
  • Position vorgeben: Die Jalousie wird auf die entsprechende Position gefahren. 100% entspricht vollständig geschlossen, 0% vollständig geöffnet.
Zustand
  • Position: Aktuelle Position in %. 100% entspricht vollständig geschlossen, 0% vollständig geöffnet.
  • Fahrtrichtung: Ist die Jalousie in Bewegung, so wird hier die aktuelle Fahrtrichtung angezeigt.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Jalousieantrieb verbunden mit KL2532

Dieses Modul dient zum Ansteuern von Jalousieantrieben über die KL2532.

Einstellungen

Befehle
  • temporärer Download: Wenn man Parameter verändern möchte, um die Jalousie zu testen, benötigt man mit einem normalen Download der Parameter (aktiveren der Konfiguration) verhältnismäßig viel Zeit. Zur Arbeitserleichterung und Zeitersparnis besteht daher die Möglichkeit eines temporären Downloads. Hierbei werden nicht erst die Module der SPS gestoppt um die Parameter runterzuschreiben, sondern die Parameter der Jalousie werden temporär und nicht persisten übergeben. Diese Änderungen werden nach einem Neustart der SPS oder aktiveren der Konfiguration unwirksam.
Parameter
  • Schleppabstand: Maximal erlaubte Steuerabweichung (berechnete Stellgröße vom Controller ↔ Position des Encoder/Resolver). Der Motor wird gestoppt, wenn der Wert überschritten wurde.
  • Schleppabstand beim Eichen: Entspricht Schleppabstand, nur während des Eichens.
  • Skalierungsfaktor: Der Geber zählt die Impulse (Inkremente). Um daraus einen Weg (Position) zu berechnen, muss man wissen, wieviele mm pro 1 Impuls (Inkrement) zurückgelegt werden. So lange sich am Geber nichts ändert, bleibt der Wert so.
    Beispiel: Geber hat 123423 Impulse (Inkremente) gezählt. Eingetragen sind 0,0123628 mm/inc. 123423 Imulse (Inkremente) * 0,0123628mm/inc = 1525,8538644 mm.
  • Kp-Verstärkungsfaktor: Beschleunigungsrampe des Motors.
  • Schrittweite: Zurückgelegte Entfernung der Jalousie, wenn per Schritt-Befehl gefahren.
  • Eichen des Zählers erzwingen: Bei Verwendung eines Encoders kann es zu kleinen Abweichungen kommen, die vom Gewicht der Jalousie, ihrer Größe und der Fahrtgeschwindigkeit abhängen. Daher ist es notwendig die Jalousie gelegentlich zu eichen. Wenn der Wert für Eichen des Zählers erzwingen durch die Anzahl hochfahrender Antriebe überschritten wurde, dann eicht sich die Jalousie automatisch neu.
  • Umkehrlose: Positionsfehler der Auftritt, wenn sich die Fahrtrichtung ändert.
  • Pausenzeit beim Reversieren: Pausenzeit, wenn die Richtung während der Reversierung geändert wird.
  • Nach Systemstart automatisch Eichen: Im Falle eines Stromausfalls geht die aktuelle Position verloren und die Jalousie muss erneut geeicht werden. Ist diese Funktion aktiviert eicht die SPS die Jalousie nach dem Aufstarten automatisch erneut. Anderenfalls wird die Jalousie nach Empfang des ersten Fahrtbefehls geeicht.
  • Verhalten ohne direkte Sonneneinstrahlung: Hier wird das Verhalten der Jalousie festgelegt, wenn sie durch ihre Ausrichtung nicht direkt der Sonneneinstrahlung ausgesetzt ist (Norden, Osten, Süden oder Westen).
    • Jalousielamellen waagerecht fahren
    • Jalousie hochfahren
    • Keine Veränderung

Arbeitsbereich

Parameter
  • Ausrichtung: Ausrichtung der Jalousie (0°: Norden, 90°: Osten, 180°: Süden, 270°: Westen 0), siehe Arbeitsbereich)
  • Offset Sonnenrichtung - Erreichen Arbeitsbereich: Siehe Arbeitsbereich
  • Offset Sonnenrichtung - Verlassen Arbeitsbereich: Siehe Arbeitsbereich
  • Sonnenhöhe - Erreichen Arbeitsbereich: Siehe Arbeitsbereich

Positionen

Parameter
  • Endlage Oben: Position des oberen Grenzschalters in mm.
  • Endlage Unten: Position des unteren Grenzschalters in mm.
  • Winkel der Jalousie bei Beschattung: Winkel, in den gefahren werden soll, wenn die Jalousie abwärts bewegt wird (bevorzugte Position).
  • Winkel der Jalousie beim runter fahren (Ab-Winkel): Winkel der Lamellen, wenn die Jalousie vollständig geschlossen ist.
  • Differenz zwischen 0° (waagerecht) und Ab-Winkel: Der Verfahrweg der Jalousie zwischen der Stellung ganz unten (ca. 80°) und der waagerechten Position (0°). Dieser Abstand wird benötigt, um die Winkelberechnungen durchzuführen.
  • Länge der Jalousielamellen: Breite der Lamellen (Berechnung der Cut off Position).
  • Abstand der Jalousielamellen: Abstand zwischen den Lamellen (Berechnung der Cut off Position).
  • Offset Sonnenwinkel: Dieser Offset wird zum berechneten Lamellenwinkel hinzugefügt und dient zur Winkelkorrektur der Lamellen.

Dynamik

Geschwindigkeiten
  • Eilganggeschwindigkeit hoch: Eilganggeschwindigkeit, wenn die Jalousie hochgefahren wird.
  • Eilganggeschwindigkeit runter: Eilganggeschwindigkeit, wenn die Jalousie runtergefahren wird.
  • Schleichganggeschwindigkeit: Schleichganggeschwindigkeit kurz bevor die Jalousie auf ihre Position gefahren wird.
  • Schleichganggeschwindigkeit für Anfahren eines Winkels: Geschwindigkeit beim Setzen eines vorgegebenen Winkels im Automatikbetrieb.
  • Geschwindigkeit während des Eichens: Geschwindigkeit während des Eichens.
Eil-/Schleichweg
  • Schleichweg hoch: Abstand zum Ziel, wenn der Jalousieantrieb von Eil- auf Schleichganggeschwindigkeit geschalten wird (hochfahren der Jalousie).
  • Schleichweg runter: Dito, aber für runterfahren.
  • Bremsweg hoch: Abstand zum Ziel , wenn der Jalousieantrieb gestoppt wird. (hochfahren der Jalousie)
  • Bremsweg runter: Dito, aber für runterfahren.

Online

Hinweis
Alle Befehle die von Gruppen oder Funktionseinheiten gesendet werden, haben eine höhere Priorität. Das bedeutet, wenn z.B. der Automatikbetrieb einer Funktionseinheit aktiviert ist, wird die Jalousie von diesem Modul gesteuert. Alle anderen zu dieser Jalousie gesendeten Befehle werden überschrieben. Einzige Ausnahme ist das Anfahren der Sicherheitsposition.
Befehle
  • Schritt Hoch: Fährt die Jalousie schrittweise hoch - die Schrittweite kann unter Einstellungen eingetragen werden (siehe Schrittweite).
  • Hoch: Hochfahren mit Eilganggeschwindigkeit. Die Eilganggeschwindigkeit kann unter Dynamik eingetragen werden (siehe Eilganggeschwindigkeit hoch).
  • langsam Hoch: Hochfahren mit Schleichganggeschwindigkeit. Die Schleichganggeschwindigkeit kann unter Dynamik eingetragen werden (siehe Schleichganggeschwindigkeit).
  • Hoch Hand: Die Jalousie wird so lange hoch gefahren, wie die Schaltfläche gedrückt wird. Im Gegensatz zu Schritt Hoch wird hierbei ohne Geberauswertung gefahren. Diese Funktion dient hauptsächlich für die Inbetriebnahme, wenn noch nicht klar ist, ob die Jalousie richtig angeschlossen ist. Beim Fahren ohne Geberauswertung kann es bei unachtsamer Anwendung zu Schäden an der Jalousie kommen.
  • Stopp: Stoppt die Jalousie.
  • Schritt Runter: Fährt die Jalousie schrittweise runter - die Schrittweite kann unter Einstellungen eingetragen werden (siehe Schrittweite).
  • Runter: Herunterfahren mit Eilganggeschwindigkeit. Die Eilganggeschwindigkeit kann unter Dynamik eingetragen werden (siehe Eilganggeschwindigkeit runter).
  • langsam Runter: Runterfahren mit Schleichganggeschwindigkeit. Die Schleichganggeschwindigkeit kann unter Dynamik eingetragen werden (siehe Schleichganggeschwindigkeit).
  • Runter Hand: Die Jalousie wird so lange runter gefahren, wie die Schaltfläche gedrückt wird. Im Gegensatz zu Schritt Runter wird hierbei ohne Geberauswertung gefahren. Diese Funktion dient hauptsächlich für die Inbetriebnahme, wenn noch nicht klar ist, ob die Jalousie richtig angeschlossen ist. Beim Fahren ohne Geberauswertung kann es bei unachtsamer Anwendung zu Schäden an der Jalousie kommen.
  • Auf bevorzugte Position fahren: Fährt die Jalousie auf die bevorzugte Position. Der Wert kann unter Positionen im Feld Winkel der Jalousie bei Beschattung eingetragen werden.
  • Sicherheitsposition Setzen: Die Jalousie wird auf die Obergrenze gefahren. Keine anderen Befehle, außer Sicherheitsposition Rücksetzen, werden in dieser Zeit akzeptiert. Sollte die Jalousie nicht geeicht sein, so wird dies vorher durchgeführt.
  • Sicherheitsposition Rücksetzen: Dieser Befehl hebt die interne Sicherheitspositionssperre auf und Fahrbefehle werden wieder akzeptiert.
  • Position vorgeben: Die Jalousie wird zur entsprechende Position gefahren. Diese Position kann in prozentualer Beschattung und Lamellenwinkel oder in Millimetern angegeben werden. Der ausgewählte Eintrag wird bestätigt mit betätigen der entsprechenden Übernehmen Schaltfläche.
  • Betriebsmodus setzen: Diese Funktion kann für Testzwecke genutzt werden
    • Normal: Kein Testmodus. Auf den Antrieb kann normal zugegriffen werden.
    • Eichen: Starten des Eichens.
    • Reversieren: Die Jalousie fährt permanent zwischen der oberen und unteren Grenze hin und her. Die Fahrten werden gezählt und im Feld Zähler Reversieren angezeigt.
    • Winkel auf maximale Beschattung: Die Jalousie wird an die Cut off Position gefahren. Steht die Sonne nicht im Arbeitsbereich der Jalousien, so ist dies nicht möglich.
    • Winkel auf maximale Ausleuchtung: Die Lamellen werden auf einen Winkel gestellt der ein Maximum an Sonneneinstrahlung durchlässt. Steht die Sonne nicht im Arbeitsbereich der Jalousien, so ist dies nicht möglich.
    • Komplett geschlossen: Die Jalousie wird vollständig geschlossen.
    • Jalousie horizontal: Zuerst wird die Jalousie an ihre untere Grenze gefahren. Anschließend werden die Lamellen auf eine horizontale Position gesetzt. - 0°.
Zustand
  • Position: Zeigt die aktuelle Position in Prozent und Millimetern an.
  • Geschwindigkeit: Zeigt die aktuelle Geschwindigkeit in Prozent und Millimetern pro Sekunde an.
  • Fahrtrichtung: Aktuelle Fahrtrichtung.
  • Zähler Reversieren: Anzahl der Antriebe im Reversierungsmodus.
  • Anzahl der Eichungen: Zähler für Eichungen der nur erhöht wird, wenn der Parameter Eichen des Zählers erzwingen (siehe Einstellungen) größer ist, als 0.
  • Kalibrierung abgeschlossen: Gibt an, ob eine Jalousie geeicht wurde (Aktiv: Eichen abgeschlossen, Inaktiv: Eichen unvollständig).
  • Zuletzt angesteuerter Winkel: Zeigt den zuletzt angesteuerten Winkel an.
  • Betriebsmodus: Zeigt den aktuell ausgewählten Betriebsmodus an (siehe Betriebsmodus setzen).
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Arbeitsbereich

Der Arbeitsbereich ist der Bereich, wo die Sonne auf die Jalousie scheint. Nur, wenn die Jalousie direkter Sonnenstrahlung ausgesetzt ist, wird eine automatische Positionierung benötigt und überhaupt möglich. Der Arbeitsbereich kann durch bestimmte Parameter verändert werden.

Sonnenrichtung:

1.Arbeitsbereich

2.Offset Sonnenrichtung - Erreichen Arbeitsbereich

3.Offset Sonnenrichtung - Verlassen Arbeitsbereich

Die Jalousieausrichtung beträgt Süden = 180°.

Sonnenhöhe :

1.Arbeitsbereich

4.Sonnenhöhe - Erreichen Arbeitsbereich


Eichen

Um die Jalousie an eine bestimmte Position fahren zu können, muss die aktuelle Position zu jeder Zeit bekannt sein. Eichen bedeutet also die Jalousie an eine Position zu fahren an der die absolute Position bekannt ist - oberste Position. Die Jalousie wird mit der Geschwindigkeit während des Eichens kurz runter und wieder hochgefahren, bis der Motor aufgrund der Überladungserkennung anhält. An dieser Stelle wird die Position auf 0 gesetzt. Am Ende wird die Jalousie an den oberen Grenzschalter gefahren.
Nach einem Neustart der SPS, muss die Jalousie erneut geeicht werden. Dies geschieht automatisch nach dem Aufstarten oder nach Empfang des ersten Fahrtbefehls. Zum Einstellen sehen Sie Jalousieantrieb verbunden mit KL2532 - Einstellungen.

Hinweis
Wenn die Jalousie während des Eichens stecken bleiben sollte, dann wird der Antrieb die Überladungserkennung fälschlicherweise als ein Erreichen der obersten Position interpretieren. In diesem Fall schlägt das Eichen fehl.


Cut off

In der Cut off Position ist die Sonne nicht direkt sichtbar, dennoch ist es möglich durch die Jalousie zu sehen und genügend Tageslicht durch zu lassen.

1. Möglichkeit durch die Jalousie zu sehen.

2. Sonnenstrahlen gelangen nicht hindurch.


Ventil Stellantriebe

Die folgenden Ventil Stellantriebe sind verfügbar:

  • 2-Punkt Ventil Stellantrieb
  • 3-Punkt Ventil Stellantrieb
  • Stetiges Ventil Stellantrieb


2-Punkt Ventil Stellantrieb

Dieses Modul steuert ein 2-Punkt Ventil Stellantrieb.

Einstellungen

Parameter
  • Digitalausgang negieren: Invertiert den Ausgang der das Ventil steuert.

Online

Befehle
  • Öffnen: Öffnet das Ventil. Der Ausgang wird aktiv sein, falls er nicht im Einstellungen Menü negiert wurde.
  • Schließen: Schließt das Ventil. Der Ausgang wird inaktiv sein, falls er nicht im Einstellungen Menü negiert wurde.
Zustand
  • Fahrtrichtung: Zeigt den aktuellen Zustand des Ventils an.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


3-Punkt Ventil Stellantrieb

Dieses Modul steuert ein 3-Punkt Ventil Stellantrieb.

Einstellungen

Parameter
  • Digitalausgang Schließen negieren: Invertiert die Regelung der schließenden Spule.
  • Digitalausgang Öffnen negieren: Invertiert die Regelung der öffnenden Spule.

Online

Befehle
  • Öffnen: Öffnet das Ventil. Der Öffner-Ausgang wird aktiv, falls er nicht im Einstellungen Menü negiert wurde.
  • Schließen: Schließt das Ventil. Der Schließer-Ausgang wird aktiv, falls er nicht im Einstellungen Menü negiert wurde.
  • Stopp: Beide Ausgänge werden deaktiviert, insofern sie nicht negiert wurden.
Zustand
  • Fahrtrichtung: Zeigt den aktuellen Zustand des Ventils an.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Stetiges Ventil Stellantrieb

Dieses Modul steuert ein stetiges Ventil Stellantrieb.

Einstellungen

Parameter
  • Analogausgang negieren: Im Building Automation Framework wird die Stellgröße in Prozent angegeben. Für die analoge Ausgangsklemme wird der Prozentwert in einen Integer von 0 bis 32767 konvertiert. Ist die Negation aktiv, so wird der Prozentwert von 32767 bis 0 konvertiert.
    Beispiele:
    Stellgröße | Wert Analogausgang | Wert Analogausgang (negiert)
    0% | 0 | 32767
    20% | 6553 | 26214
    40% | 13107 | 19660
    60% | 19660 | 13107
    80% | 26214 | 6553
    100% | 32767 | 0

Online

Befehle
  • Öffnen: Öffnet das Ventil vollständig. Die Stellgröße wird auf 100% gesetzt.
  • Schließen: Schließt das Ventil vollständig. Die Stellgröße wird auf 0% gesetzt.
  • Stellgröße vorgeben: Ein Wert zwischen 0% und 100% kann hier für die Stellgröße vorgegeben und mit betätigen von Übernehmen gesetzt werden.
Zustand
  • Stellgröße: Aktuelle Stellgröße.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Fensterantriebe

Die folgenden Fensterantriebe sind verfügbar:

  • Standard Fensterantrieb


Standard Fensterantrieb

Dieses Modul dient zum Ansteuern von Fensterantrieben.

Einstellungen

Parameter
  • Fahrdauer: Gesamte Fahrdauer des Fensters.
  • Ruhepause beim Richtungswechsel: Wartezeit bei schlagartiger Richtungsänderung.
  • Digitalausgang Schließen/Öffnen negieren: Negiert den Steuerausgang, so dass das Fenster mit einem Tiefpegel am Ausgangsmodul gefahren wird.

Online

Befehle
  • Öffnen: Öffnet das Fenster.
  • Schließen: Schließt das Fenster.
  • Stopp: Das fahrende Fenster wird angehalten.
  • Sicherheitsposition Setzen: Anfahren der Sicherheitsposition ist aktiviert. Das Fenster fährt nun in Schließrichtung mit der angegebenen Fahrzeit + 10%. Keine anderen Befehle, außer Sicherheitsposition Rücksetzen, werden in dieser Zeit akzeptiert.
  • Sicherheitsposition Rücksetzen: Dieser Befehl hebt die interne Sicherheitspositionssperre. Alle anderen Befehle sind wieder zugänglich.
  • Position vorgeben: Das Fenster fährt nach betätigen der Übernehmen Schaltfläche den gegebenen Wert an. 0% entspricht vollständig geschlossen, 100% vollständig geöffnet.
Zustand
  • Position: Aktuelle Position in %. 0% entspricht vollständig geschlossen, 100% vollständig geöffnet.
  • Fahrtrichtung: Aktuelle Bewegungsrichtung.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Digitale Signalgruppe

TS8100 | TwinCAT Building Automation Framework V2.2x

Digitale Signalgruppen

Die folgenden digitalen Signalgruppen sind verfügbar:

  • Standard Digitale Signalgruppe


Standard Digitale Signalgruppe

Die Standard Digitale Signalgruppe kombiniert mehrere digitale Signale zu einer Gruppe.

Einstellungen

Parameter
  • Einschaltverzögerung: Zeitverzögerung beim Einschalten.
  • Ausschaltverzögerung: Zeitverzögerung beim Ausschalten.
  • Zeitfenster langer / doppelter Tastendruck: Erkennungszeit für einen langen und doppelten Tastendruck, die zum Aufrufen von Szenen verwendet werden. Siehe unten. Wird der Taster länger gedrückt, als die angegebene Zeit, entspricht dies einem langen Tastendruck. Ein zweimaliges betätigen des Tasters innerhalb dieser Zeit entspricht einem doppelten Tastendruck.

Das Endergebnis der Signalgruppe berechnet sich aus den einzelnen digitalen Signalen - nicht ihrer Rohwerte.

Signale

Alle Geräte die zu einer digitalen Gruppe kombiniert werden sollen, müssen in diesem Menü ausgewählt werden.
Ein betätigen der Bearbeiten Schaltfläche öffnet ein Fenster, in dem alle definierten digitalen Signale ausgewählt werden können. Die Auswahl eines digitalen Signals und anschließende betätigen der Löschen Schaltfläche entfernt das digitale Signal aus der Gruppe. Dabei wird das digitale Signal nur aus der Gruppe und nicht aus der gesamten Applikation entfernt.

Szenen

Ein Betätigen der Neu Schaltfläche im Szenen Menü öffnet einen Dialog in dem die analysierten Ereignisse
  • steigende Flanke
  • fallende Flanke
  • Flankenänderung
  • Tastendruck
  • doppelter Tastendruck
  • langer Tastendruck
(siehe Logikschaltbild oben) zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Zustand
  • Wert: Logische ODER-Verknüpfung aller nicht fehlerhaften digitalen Signalwerte gefolgt von der Ein- und Ausschaltverzögerung (siehe Logikschaltbild oben).
  • Rohwert: Nur logische ODER-Verknüpfung aller nicht fehlerhaften digitalen Signalwerte.
  • Anzahl der Signale Anzahl digitaler Signale die zu dieser Gruppe gehören.
  • Anzahl der fehlerhaften Signale: Anzahl digitaler Signale die zu dieser Gruppe gehören und sich in einem Fehlerzustand befinden.
  • Anzahl der aktiven Signale: Anzahl digitaler Signale die zu dieser Gruppe gehören und aktiv sind.
  • Restzeit Ein-/Ausschaltverzögerung: Zeigt die Restzeit der Zeitgeber an.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Analoge Signalgruppe

TS8100 | TwinCAT Building Automation Framework V2.2x

Analoge Signalgruppen

Die folgenden analogen Signalgruppen sind verfügbar:

  • Standard Analoge Signalgruppe


Standard Analoge Signalgruppe

Die Standard Analoge Signalgruppe kombiniert mehrere analoge Signale zu einer Gruppe. Ähnlich einem einzelnen analogen Modul können zwei Schwellwertschalter für die Gruppe definiert werden. Der analoge Gruppenwert ist der Mittelwert aller analogen Module in dieser Gruppe.

Einstellungen

Zwei Schwellwertschalter können für den Mittelwert definiert werden. Die steigende und fallende Flanke dieser Schalter ermöglichen den Aufruf von Szenen (siehe Szenen Menü unten). Zusätzlich kann eine Hysterese und eine Verzögerung definiert werden, um das Verhalten des Durchschnittswertes der Gruppe zu dämpfen. Die eingetragene Einheit ist nur für die Anzeige im Building Automation Framework.

Signale

Alle Geräte die zu einer analogen Gruppe kombiniert werden sollen, müssen in diesem Menü ausgewählt werden.
Ein betätigen der Bearbeiten Schaltfläche öffnet ein Fenster, in dem alle definierten digitalen Signale ausgewählt werden können. Die Auswahl eines analogen Signals und anschließende betätigen der Löschen Schaltfläche entfernt das analoge Signal aus der Gruppe. Dabei wird das analoge Signal nur aus der Gruppe und nicht aus der gesamten Applikation entfernt.

Szenen

Ein Betätigen der Neu Schaltfläche im Szenen Menü öffnet einen Dialog in dem die steigende und fallende Flanke der Schwellwertschalter zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Zustand
  • Mittelwert: Berechneter Mittelwert aller nicht fehlerhaften skalierten analogen Signalwerte.
  • Mittelwert der Rohdaten: Berechneter Rohmittelwert aller nicht fehlerhaften analogen Rohsignalwerte.
  • Anzahl der Signale Anzahl analoger Signale die zu dieser Gruppe gehören.
  • Anzahl der fehlerhaften Signale: Anzahl analoger Signale die zu dieser Gruppe gehören und sich in einem Fehlerzustand befinden.
  • Anzahl der Signale, die den Ersatzwert benutzen: Zeigt an, wie viele Signale ihren Ersatzwert benutzen.
  • Zustand Schwellwertschalter 1/2: Aktiv, wenn der Mittelwert in den Schwellwert überschreitet, ansonsten inaktiv.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Lampengruppen

Die folgenden Lampengruppen sind verfügbar:

  • Standard Lampengruppe


Standard Lampengruppe

Die Standard Lampengruppe kombiniert mehrere Lampen zu einer Gruppe.

Lampen

Alle Geräte die zu einer Lampengruppe gehören sollen, müssen in diesem Menü ausgewählt werden.
Ein betätigen der Bearbeiten Schaltfläche öffnet ein Fenster, in dem alle definierten Lampen ausgewählt werden können. Die Auswahl einer Lampe und anschließende betätigen der Löschen Schaltfläche entfernt die Lampe aus der Gruppe. Dabei wird die Lampe nur aus der Gruppe und nicht aus der gesamten Applikation entfernt.

Online

Befehle
  • Hoch Dimmen: Dieser Befehl erhöht den Lichtwert aller zugewiesenen Lampen um ihre eingetragene Dimmstufe. Der Befehl kann nur ausgeführt werden, wenn die Lampe bereits eingeschalten ist. Eine Erhöhung des Wertes über das Maximum hinaus ist nicht möglich.
  • Runter Dimmen: Dieser Befehl verringert den Lichtwert um die eingetragene Dimmstufe, wird die Lampe aber nicht ausschalten.
  • Ein: Schaltet die zugewiesenen Lampen auf ihr Maximum oder ihren Wiedereinschaltwert ein, was davon abhängt, ob der Wiedereinschaltmodus aktiv ist oder nicht. Der Wiedereinschaltmodus kann für jede Lampe aus der Gruppe separat aktiviert werden.
  • Aus: Schaltet alle zugewiesenen Lampen aus. Ist der Wiedereinschaltmodus aktiv, so wird vor dem Ausschalten der momentane Lichtwert gespeichert.
  • maximale Stellgröße ausgeben: Jede Lampe innerhalb der Gruppe wird auf ihre höchste Stufe geschalten.
  • minimale Stellgröße ausgeben: Jede Lampe innerhalb der Gruppe wird auf ihre niedrigste Stufe geschalten.
  • Stellgröße vorgeben: Die Lampen übernehmen den eingetragenen Wert nach betätigen der Übernehmen Schaltfläche. Ist der Wert größer, als das Maximum einer der Lampen, so werden diese auf die höchste Stufe geschalten. Ist der Wert niedriger, als das Minimum, jedoch nicht 0, so wird die Lampe auf ihre niedrigste Stufe geschalten. Der Wert 0 schaltet alle Lampen aus.
State
  • Mittelwert der Stellgrößen: Mittelwert aller eingeschalteten (nicht fehlerhaften) Lampen.
  • Mittelwert der Wiedereinschaltwerte: Zeigt den mittleren Wiedereinschaltwert aller Lampen in der Gruppe an.
  • Anzahl der Lampen: Anzahl der Lampen in der Gruppe.
  • Anzahl der fehlerhaften Lampen: Anzahl der Lampen in der Gruppe die sich in einem Fehlerzustand befinden.
  • Anzahl der aktiven Lampen: Anzahl der Lampen in der Gruppe die eingeschalten sind (Lichtwert nicht 0%).
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Jalousieantriebsgruppen

Die folgenden Jalousieantriebsgruppe sind verfügbar:

  • Standard Jalousieantriebsgruppe


Jalousieantriebsgruppen

TS8100 | TwinCAT Building Automation Framework V2.2x

Standard Jalousieantriebsgruppe

Die Jalousieantriebsgruppe kombiniert mehrere Jalousieantriebe zu einer Gruppe.

Jalousieantriebe

Ein Betätigen der Bearbeiten Schaltfläche im Jalousieantriebe Menü öffnet einen Dialog in dem einfach einzelne Jalousieantriebe der Gruppe hinzugefügt werden können.

Online

Befehle
  • Schritt Hoch: Dieser Befehl hebt alle Jalousien in der Gruppe um ihre individuell eingetragene Fahrdauer bei Schrittbetrieb.
  • Schritt Runter: Dieser Befehl senkt alle Jalousien in der Gruppe um ihre individuell eingetragene Fahrdauer bei Schrittbetrieb.
  • Hoch: Lässt alle Jalousien in der Gruppe hochfahren.
  • Runter: Lässt alle Jalousien in der Gruppe runterfahren.
  • Stopp: Alle Jalousien werden angehalten.
  • Auf bevorzugte Position fahren: Fährt alle Jalousien auf die bevorzugte Position.
  • Sicherheitsposition Setzen: Wenn aktiviert, dann wird die Sicherheitsposition angefahren. In diesem Fall wird die Jalousie hochgefahren mit der eingetragenen Fahrtgeschwindigkeit + 10%. Keine anderen Befehle, außer Sicherheitsposition Rücksetzen, werden in dieser Zeit akzeptiert.
  • Sicherheitsposition Rücksetzen: Hebt die Sicherheitspositionssperre auf.
  • Position vorgeben: Die Jalousie wird zur entsprechende Position gefahren. Diese Position kann in prozentualer Beschattung und Lamellenwinkel oder in Millimetern angegeben werden. Der ausgewählte Eintrag wird bestätigt mit Betätigen der entsprechenden Übernehmen Schaltfläche.
    Der Winkel wird nur von Jalousieantrieben ausgewertet, die dieses Leistungsmerkmal auch unterstützen.
  • Betriebsmodus setzen: 6 verschiedene Betriebsmodi können ausgewählt und mit der Übernehmen Schaltfläche aktiviert werden:
    1. Normal: Auf die Antriebe kann mit allen Befehlen zugegriffen werden, wie oben beschrieben.
    2. Eichen: Alle Antriebe werden referenziert.
    3. Reversieren: Die Jalousien werden abwechselnd hoch und runter gefahren. Einstellungen für diese Betriebsart werden für jeden einzelnen Jalousieantrieb individuell in dessen Parametern festgelegt.
    4. Winkel auf maximale Beschattung: Die Jalousielamellen werden auf einen Winkel gesetzt, der am besten den Raum abdunkelt.
    5. Winkel auf maximale Ausleuchtung: Die Jalousielamellen werden auf einen Winkel gesetzt, der das meiste Sonnenlicht durchlässt.
    6. Komplett geschlossen: Die Jalousien werden vollständig geschlossen.
    7. Jalousie horizontal: Zuerst werden die Jalousien an ihre untere Grenze gefahren. Anschließend werden die Lamellen auf eine horizontale Position gesetzt. - 0°.
Zustand
  • Mittelwert der Positionen: Mittelwert aller aktiven (nicht fehlerhaften) Jalousieantriebe. 100% entspricht vollständig geschlossen, 0% vollständig geöffnet.
  • Anzahl der Jalousieantriebe: Anzahl der Jalousieantriebe in der Gruppe.
  • Anzahl der fehlerhaften Jalousieantriebe: Anzahl der Jalousieantriebe in der Gruppe die sich in einem Fehlerzustand befinden.
  • Anzahl der fehlerhaften Jalousieantriebe die Hoch fahren: Anzahl der Jalousieantriebe die derzeit hochfahren.
  • Anzahl der fehlerhaften Jalousieantriebe die Runter fahren: Anzahl der Jalousieantriebe die derzeit runterfahren.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Ventil Stellantriebsgruppe

TS8100 | TwinCAT Building Automation Framework V2.2x

Ventil Stellantriebsgruppen

Die folgenden Ventil Stellantriebsgruppen sind verfügbar:

  • Standard Ventil Stellantriebsgruppe


Standard Ventil Stellantriebsgruppe

Die Standard Ventil Stellantriebsgruppe kombiniert mehrere Ventil Stellantriebe zu einer Gruppe.

Ventil Stellantriebe

Alle Geräte die zu einer Ventil Gruppe kombiniert werden sollen, müssen in diesem Menü ausgewählt werden.
Ein betätigen der Bearbeiten Schaltfläche öffnet ein Fenster, in dem alle definierten Ventile ausgewählt werden können. Die Auswahl eines Ventils und anschließende betätigen der Löschen Schaltfläche entfernt das Ventil aus der Gruppe. Dabei wird das Ventil nur aus der Gruppe und nicht aus der gesamten Applikation entfernt.

Online

Befehle
  • Öffnen: Der Öffnen Befehl wird für alle zugewiesenen Ventil Stellantriebe ausgeführt.
  • Schließen: Der Schließen Befehl wird für alle zugewiesenen Ventil Stellantriebe ausgeführt.
  • Stopp: Der Stopp Befehl aller Ventil Stellantriebe in der Gruppe wird ausgeführt.
  • Stellgröße vorgeben: Der eingetragene Wert wir nach betätigen der Übernehmen Schaltfläche gesetzt. Die Stellgröße ist in Prozent anzugeben. 0% entsprechen vollständig geschlossen, 100% vollständig geöffnet.
Zustand
  • Mittelwert der Stellgrößen: Zeigt den Mittelwert der Stellgrößen aller Ventile in der Gruppe an.
  • Anzahl der Ventil Stellantriebe: Anzahl der Ventil Stellantriebe in der Gruppe.
  • Anzahl der fehlerhaften Ventil Stellantriebe: Anzahl der Ventil Stellantriebe in der Gruppe die sich in einem Fehlerzustand befinden.
  • Anzahl der Ventil Stellantriebe die Zu fahren: Anzahl der Ventil Stellantriebe in der Gruppe die gerade geschlossen werden.
  • Anzahl der Ventil Stellantriebe die Auf fahren: Anzahl der Ventil Stellantriebe in der Gruppe die gerade geöffnet werden.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Fensterantriebsgruppen

Die folgenden Fensterantriebsgruppen sind verfügbar:

  • Standard Fensterantriebsgruppe


Standard Fensterantriebsgruppe

Die Standard Fensterantriebsgruppe kombiniert mehrere Fensterantriebe zu einer Gruppe.

Fensterantriebe

Alle Geräte die zu einer Fensterantriebsgruppe kombiniert werden sollen, müssen in diesem Menü ausgewählt werden.
Ein betätigen der Bearbeiten Schaltfläche öffnet ein Fenster, in dem alle definierten Fensterantriebe ausgewählt werden können. Die Auswahl eines Fensterantriebs und anschließende betätigen der Löschen Schaltfläche entfernt den Fensterantrieb aus der Gruppe. Dabei wird der Fensterantrieb nur aus der Gruppe und nicht aus der gesamten Applikation entfernt.

Online

Befehle
  • Öffnen: Öffnet alle Fenster der Gruppe.
  • Schließen: Schließt alle Fenster der Gruppe.
  • Stopp: Alle Fensterantriebe werden angehalten.
  • Sicherheitsposition Setzen: Wenn aktiviert, wird die Sicherheitsposition angefahren und alle Fenster geschlossen. Keine anderen Befehle, außer Sicherheitsposition Rücksetzen, werden in dieser Zeit akzeptiert.
  • Sicherheitsposition Rücksetzen: Hebt die Sicherheitspositionssperre auf.
  • Position vorgeben: Alle Fenster werden nach betätigen der Übernehmen Schaltfläche an die entsprechende Position gefahren. Die Position ist in Prozent anzugeben. 0% entspricht vollständig geschlossen, 100% vollständig geöffnet.
Zustand
  • Mittelwert der Positionen: Mittelwert der Position aller aktiven (nicht fehlerhaften) Fensterantriebe. 0% entspricht vollständig geschlossen, 100% vollständig geöffnet.
  • Anzahl der Fensterantriebe: Anzahl aller Fensterantriebe in der Gruppe.
  • Anzahl der fehlerhaften Fensterantriebe: Anzahl der Fensterantriebe die sich in einem Fehlerzustand befinden.
  • Anzahl der Fensterantriebe die Zu fahren: Anzahl der Fensterantriebe die sich momentan schließen.
  • Anzahl der Fensterantriebe die Auf fahren: Anzahl der Fensterantriebe die sich momentan öffnen.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Beleuchtungen

Die folgenden Beleuchtungen sind verfügbar:

  • Dimmer
  • Treppenhausbeleuchtung
  • Dämmerungsschalter
  • tageslichtabhängige Lichtsteuerung
  • Konstantlichtregelung
  • Funktions- und Dauertest für die Sicherheitsbeleuchtung


Dimmer

Die Funktionseinheit Dimmer stellt die Standardlösung für einfaches Ein-/Ausschalten und dimmen einer Lampe/Lampengruppe dar.

Einstellungen

Parameter
  • Zeitdauer bis Selbsthaltung: Zeit, die bis zur Unterscheidung zwischen kurzen und langen Tastendruck vergehen soll.
  • Wechsel Modus: Wird Wechseln mit den Ein/Aus-Befehlen der Funktionseinheit verwendet, dann wechselt die Lampe/Lampengruppe zwischen dem Wiedereinschaltwert der Funktionseinheit und aus. Bei Auswahl von Wechseln mit dem lokalen Wiedereinschaltwert und Aus-Befehl wechselt die Lampe/Lampengruppe zwischen dem Wiedereinschaltwert der Lampe(n) und aus.
  • Hoch Dimmen Option: Beschreibt, was die Lampe/Lampengruppe tut, wenn ein kurzer Tastendruck bei digitales Signal (Gruppe) - Hoch Dimmen erkannt wurde.
  • Runter Dimmen Option: Beschreibt, was die Lampe/Lampengruppe tut, wenn ein kurzer Tastendruck bei digitales Signal (Gruppe) - Runter Dimmen erkannt wurde.

Sensoren / Aktoren

In diesem Menü müssen die Lampe/Lampengruppe, sowie die digitalen Signale/Signalgruppen zum Schalten der zugewiesenen Lampe/Lampengruppe eingetragen werden. Grundsätzlich gibt es zwei verschiedene Methoden zum Steuern der Lampe/Lampengruppe: Mit zwei Tastern zum Hoch und Runter dimmen oder mit einem Taster, der abwechselnd Hoch und Runter dimmt. Eine Kombination beider Methoden ist möglich.

Online

Befehle
  • Hoch Dimmen: Dieser Befehl erhöht den Lichtwert der zugewiesenen Lampen um ihre eingetragene Dimmstufe. Der Befehl kann nur ausgeführt werden, wenn die Lampe bereits eingeschalten ist. Eine Erhöhung des Wertes über das Maximum hinaus ist nicht möglich.
  • Runter Dimmen: Dieser Befehl verringert den Lichtwert um die eingetragene Dimmstufe, wird die Lampe jedoch nicht ausschalten.
  • Ein: Schaltet die Lampe auf ihr Maximum ein oder auf den Wiedereinschaltwert, insofern der Wiedereinschaltmodus aktiviert wurde. Der Wiedereinschaltmodus kann für jede Lampe separat aktiviert werden.
  • Aus: Schaltet alle zugewiesenen Lampen aus. Ist der Wiedereinschaltmodus aktiv, so wird vor dem Ausschalten der momentane Lichtwert gespeichert.
  • maximale Stellgröße ausgeben: Jede Lampe wird auf ihren maximalen Wert gesetzt.
  • minimale Stellgröße ausgeben: Jede Lampe wird auf ihren minimalen Wert gesetzt.
  • Aus ↔ Wiedereinschaltwert: Die Schaltrichtung hängt vom Mittelwert der Lampe/Lampengruppe ab. Wenn der Wert größer 0 ist, dann werden alle Lampen ausgeschaltet. Ist der Wert gleich 0, so werden alle Lampen entweder auf ihren Wiedereinschaltwert oder ihren maximalen Wert gesetzt, falls der Wiedereinschaltmodus für die Lampe nicht aktiviert wurde.
  • Aus ↔ max. Stellgröße: Ähnlich, wie bei Aus ↔ Wiedereinschaltwert, nur das alle Lampen zwischen Aus und ihrem maximalen Wert geschalten werden.
  • Stellgröße vorgeben: Die Lampen übernehmen den eingetragenen Wert nach betätigen der Übernehmen Schaltfläche. Ist der Wert größer, als das Maximum einer der Lampen, so werden diese auf die höchste Stufe geschalten. Ist der Wert niedriger, als das Minimum, jedoch nicht 0, so wird die Lampe auf ihre niedrigste Stufe geschalten. Der Wert 0 schaltet alle Lampen aus.
Zustand
  • Mittelwert der Stellgröße: Mittelwert aller aktiven (nicht fehlerhaften) Lampen.
  • Wiedereinschaltwert: Vor dem Ausschalten der Funktionseinheit wird der momentane Lichtwert in dieser Variablen gespeichert. Wurde die Option Wechseln mit den Ein/Aus-Befehlen der Funktionseinheit unter Wechsel Modus ausgewählt, werden alle Lampen in der Funktionseinheit mit deaktiviertem Wiedereinschaltmodus wieder auf diesen Lichtwert gesetzt, wenn sie über den Aus ↔ Wiedereinschaltwert Befehl eingeschaltet werden.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Treppenhausbeleuchtung

Die Treppenhausbeleuchtung beinhaltet eine konstante Sequenz. Nach einer steigenden Flanke am Bewegungssensor wird das Licht mit der Stellgröße während der Präsenz eingeschaltet und die Sequenz gestartet:
  • Warten auf eine fallende Flanke am Bewegungssensor
  • Wartezeit für die Stellgröße während der Präsenz
  • Wechseln zur Stellgröße während der Nachlaufzeit
  • Wartezeit für die Stellgröße während der Nachlaufzeit
  • Ausschalten

Eine andere steigende Flanke am Bewegungssensor startet die Sequenz jederzeit erneut.

Einstellungen

Parameter
  • Stellgröße während der Präsenz: Lichtwert, wenn die Sequenz aktiviert wird.
  • Stellgröße während der Nachlaufzeit: Lichtwert zum Andeuten, dass die Sequenz bald endet.
  • Verlängerung der Präsenz: Zeit, die der Lichtwert auf der Stellgröße während der Präsenz verbleibt, nachdem eine fallende Flanke am Bewegungssensor registriert wurde.
  • Dauer der Nachlaufzeit: Zeit, die der Lichtwert auf der Stellgröße während der Nachlaufzeit bleibt, bevor das Licht ausgeschaltet wird.

Sensoren / Aktoren

In diesem Menü muss die Lampe/Lampengruppe, sowie das digitale Signal/die digitale Signalgruppe mit dem Bewegungsmelder zum Schalten der zugewiesenen Lampe/Lampengruppe eingetragen werden.

Online

Befehle
  • Start: Mit dieser Schaltfläche lässt sich die Dimmsequenz von Hand starten.
  • Aus: Schaltet die zugewiesenen Lampen aus und beendet die Sequenz sofort.
Zustand
  • Mittelwert der Stellgröße: Mittelwert aller aktiven (nicht fehlerhaften) Lampen.
  • verbleibende Dauer: Verbleibende Zeit bis die Lampe ausgeschaltet wird.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Dämmerungsschalter

Der Dämmerungsschalter, grundlegend ein 2-Punkt-Regler, definiert sich durch eine Stellgröße, einer Hysterese, sowie einem Wirksinn. Die Schaltwerte liegen halb über der Hysterese und unter dem Basis Schaltwert, welcher durch einen Offset angepasst werden kann: der Sollwertverschiebung. Der Wirksinn der Regelung (Einschalten bei...) lässt dem Benutzer die Wahl den Ausgang der Regelung, bei Überschreitung oder Unterschreitung des Sollwertes, auf true zu Schalten:

Einstellungen

Parameter
  • Basis Schaltwert: Schaltwert des Dämmerungsschalters. Kann durch einen Offset, Schaltwertverschiebung, angepasst werden, siehe Online Menü.
  • Regel Hysterese: Schalthysterese um den Basis Schaltwert, siehe Diagramm oben.
  • Wirksinn der Regelung: Verhalten des Dämmerungsschalters:
    • Einschalten bei Unterschreitung: die Lampen werden eingeschaltet, wenn der gemessene Wert den Schaltwert unterschreitet.
    • Einschalten bei Überschreitung: die Lampen werden eingeschaltet, wenn der gemessene Wert den Schaltwert überschreitet.
  • Einschaltverzögerung / Ausschaltverzögerung: Mit diesem Parameter kann eine zusätzliche zeitliche Hysterese definiert werden.
  • Einschaltwert: Lichtwert, bei dem der Dämmerungsschalter die zugewiesenen Lampen einschaltet.
  • Wechsel Modus: Wird Wechseln mit den Ein/Aus-Befehlen der Funktionseinheit verwendet, dann wechselt die Lampe/Lampengruppe zwischen dem Wiedereinschaltwert der Funktionseinheit und aus. Bei Auswahl von Wechseln mit dem lokalen Wiedereinschaltwert und Aus-Befehl wechselt die Lampe/Lampengruppe zwischen dem Wiedereinschaltwert der Lampe(n) und aus.
  • Initialisierungs Modus: Diese Option lässt den Benutzer entscheiden, was die zugewiesenen Lampen tun sollen, wenn der Dämmerungsschalter die Initialisierung startet und der gemessene Wert innerhalb der Hysterse liegt.
  • Schrittweite für das Ändern der Sollwertverschiebung: Bezieht sich auf das Online Menü, wo die Schaltwertverschiebung mit den Hoch/Runter Schaltflächen schrittweise erhöht/verringert werden kann. Hier wird dafür die Schrittweite angegeben.
  • Minimal / Maximal zulässiger Wert für die Sollwertverschiebung: Der max/min Wert der Schaltwertverschiebung.

Sensoren / Aktoren

In diesem Menü muss die Lampe/Lampengruppe, sowie die Wetterstation mit den Lichtsensoren eingetragen werden.

Online

Befehle
  • Hoch Dimmen: Dieser Befehl erhöht den Lichtwert der zugewiesenen Lampen um ihre eingetragene Dimmstufe. Der Befehl kann nur ausgeführt werden, wenn die Lampe bereits eingeschalten ist. Eine Erhöhung des Wertes über das Maximum hinaus ist nicht möglich.
  • Runter Dimmen: Dieser Befehl verringert den Lichtwert um die eingetragene Dimmstufe, wird die Lampe jedoch nicht ausschalten.
  • Ein: Schaltet die Lampe auf ihr Maximum ein oder auf den Wiedereinschaltwert, insofern der Wiedereinschaltmodus aktiviert wurde. Der Wiedereinschaltmodus kann für jede Lampe separat aktiviert werden.
  • Aus: Schaltet alle zugewiesenen Lampen aus. Ist der Wiedereinschaltmodus aktiv, so wird vor dem Ausschalten der momentane Lichtwert gespeichert.
  • maximale Stellgröße ausgeben: Jede Lampe wird auf ihren maximalen Wert gesetzt.
  • minimale Stellgröße ausgeben: Jede Lampe wird auf ihren minimalen Wert gesetzt.
  • Aus ↔ Wiedereinschaltwert: Die Schaltrichtung hängt vom Mittelwert der Lampe/Lampengruppe ab. Wenn der Wert größer 0 ist, dann werden alle Lampen ausgeschaltet. Ist der Wert gleich 0, so werden alle Lampen entweder auf ihren Wiedereinschaltwert oder ihren maximalen Wert gesetzt, falls der Wiedereinschaltmodus für die Lampe nicht aktiviert wurde.
  • Aus ↔ max. Stellgröße: Ähnlich, wie bei Aus ↔ Wiedereinschaltwert, nur das alle Lampen zwischen Aus und ihrem maximalen Wert geschalten werden.
  • Stellgröße vorgeben: Die Lampen übernehmen den eingetragenen Wert nach betätigen der Übernehmen Schaltfläche. Ist der Wert größer, als das Maximum einer der Lampen, so werden diese auf die höchste Stufe geschalten. Ist der Wert niedriger, als das Minimum, jedoch nicht 0, so wird die Lampe auf ihre niedrigste Stufe geschalten. Der Wert 0 schaltet alle Lampen aus.
  • Schaltwertverschiebung setzen: Eingabefeld für die Schaltwertverschiebung, entweder direkt oder schrittweise mit Hoch und Runter für die eingetragenen Schrittweite (siehe Einstellungen Menü). Die Angabe wird durch die Maximal und Minimal Werte aus dem Einstellungen Menü begrenzt.
  • Regelung Freigeben/Sperren: Versetzt den Dämmerungsschalter in den Automatik-/Handbetrieb. Wird die SPS gestartet, so ist die Regelung freigegeben.

Alle Eingabefunktionen sind nur möglich, wenn die Regelung gesperrt ist, mit Ausnahme der Sollwertverschiebung und der Freigeben/Sperren Funktionen.

Zustand
  • Mittelwert der Stellgröße: Mittelwert aller aktiven (nicht fehlerhaften) Lampen.
  • Istwert: Gemessenes Lichtniveau.
  • Schaltwertverschiebung: Aktuelle Schaltwertverschiebung.
  • Schaltwert: Aktueller Schaltwert, resultierend aus dem Basis Schaltwert und dem Wiedereinschaltwert.
  • Wiedereinschaltwert: Vor dem Ausschalten der Funktionseinheit wird der momentane Lichtwert in dieser Variablen gespeichert. Wurde die Option Wechseln mit den Ein/Aus-Befehlen der Funktionseinheit unter Wechsel Modus ausgewählt, werden alle Lampen in der Funktionseinheit mit deaktiviertem Wiedereinschaltmodus wieder auf diesen Lichtwert gesetzt, wenn sie über den Aus ↔ Wiedereinschaltwert Befehl eingeschaltet werden.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


tageslichtabhängige Lichtsteuerung

Die tageslichtabhängige Lichtsteuerung ist ein offener Regelkreis der hauptsächlich aus einem anlogen Sensor/ einer anlogen Sensorgruppe für Tageslichtmessung, einer Hauptlampe/Hauptlampengruppe und zwei Unterlampen/Unterlampengruppen besteht. Die lineare Gleichung für die Hauptlampe/Hauptlampengruppe muss in einer 2-Punkt Form angegeben werden: ein Istwert für die Stellgröße bei 0% und ein Istwert für die Stellgröße bei 100%. Der Lichtwert der Unterlampen/Unterlampengruppen berechnet sich aus dem Niveau der Hauptlampe/Hauptlampengruppe multipliziert mit den Verstärkungsfaktoren. Aufgrund dieser Tatsache werden die drei Linien immer denselben Nullpunkt haben. Die lineare Gleichung muss daher vorsichtig berechnet werden. Falsche Knoten und/oder Verstärkungsfaktoren können dazu führen, dass die Lichtwerte an ihre Grenzen stoßen.

Hier einige Beispiele als Diagramm:

Einstellungen

Parameter
  • Zeitdauer bis Selbsthaltung: Zeit, die bis zur Unterscheidung zwischen kurzen und langen Tastendruck vergehen soll.
  • Einschaltverzögerung / Ausschaltverzögerung: Mit diesem Parameter kann eine zusätzliche Zeitverzögerung zum Ein- oder Ausschalten der Lampe definiert werden (0 ↔ min Wert). Das bewahrt die Lampen davor Schaden zu nehmen, wenn der vermeintliche Wert bei vielen Schaltvorgängen um 0% liegt.
  • Stellgröße ist 100% bei einem Istwert von: Erster Knoten der linearen Funktion.
  • Stellgröße ist 0% bei einem Istwert von: Zweiter Knoten der linearen Funktion.
  • Faktor Stellgröße von Unterlampe/Unterlampengruppe 1 / Faktor Stellgröße von Unterlampe/Unterlampengruppe 2: Verstärkungsfaktoren der Unterlampe/Unterlampengruppe in Bezug auf die Hauptlampe/Hauptlampengruppe.
  • Hoch Dimmen Option: Beschreibt, was die Lampe/Lampengruppe tut, wenn ein kurzer Tastendruck bei digitales Signal (Gruppe) - Hoch Dimmen erkannt wurde.
  • Runter Dimmen Option: Beschreibt, was die Lampe/Lampengruppe tut, wenn ein kurzer Tastendruck bei digitales Signal (Gruppe) - Runter Dimmen erkannt wurde.
  • Wechsel Modus: Wird Wechseln mit den Ein/Aus-Befehlen der Funktionseinheit verwendet, dann wechselt die Lampe/Lampengruppe zwischen dem Wiedereinschaltwert der Funktionseinheit und aus. Bei Auswahl von Wechseln mit dem lokalen Wiedereinschaltwert und Aus-Befehl wechselt die Lampe/Lampengruppe zwischen dem Wiedereinschaltwert der Lampe(n) und aus.

Sensoren / Aktoren

In diesem Menü müssen die Lampen/Lampengruppen, sowie die digitalen Signale/Signalgruppen zum Schalten der zugewiesenen Lampe/Lampengruppe eingetragen werden. Grundsätzlich gibt es zwei verschiedene Methoden zum Steuern der Lampe/Lampengruppe: Mit zwei Tastern zum Hoch und Runter dimmen oder mit einem Taster, der abwechselnd Hoch und Runter dimmt. Eine Kombination beider Methoden ist möglich.

Zusätzlich kann ein Bewegungsmelder benutzt werden, um die Lichtregelung zu aktiveren: eine steigende Flanke bei digitales Signal (Gruppe) - Bewegungssensor aktiviert die Regelung, eine fallende flanke deaktiviert sie und schaltet sie aus.

Online

Befehle
  • Hoch Dimmen: Dieser Befehl erhöht den Lichtwert der zugewiesenen Lampen um ihre eingetragene Dimmstufe. Der Befehl kann nur ausgeführt werden, wenn die Lampe bereits eingeschalten ist. Eine Erhöhung des Wertes über das Maximum hinaus ist nicht möglich.
  • Runter Dimmen: Dieser Befehl verringert den Lichtwert um die eingetragene Dimmstufe, wird die Lampe jedoch nicht ausschalten.
  • Ein: Schaltet die Lampe auf ihr Maximum ein oder auf den Wiedereinschaltwert, insofern der Wiedereinschaltmodus aktiviert wurde. Der Wiedereinschaltmodus kann für jede Lampe separat aktiviert werden.
  • Aus: Schaltet alle zugewiesenen Lampen aus. Ist der Wiedereinschaltmodus aktiv, so wird vor dem Ausschalten der momentane Lichtwert gespeichert.
  • maximale Stellgröße ausgeben: Jede Lampe wird auf ihren maximalen Wert gesetzt.
  • minimale Stellgröße ausgeben: Jede Lampe wird auf ihren minimalen Wert gesetzt.
  • Aus ↔ Wiedereinschaltwert: Die Schaltrichtung hängt vom Mittelwert der Lampe/Lampengruppe ab. Wenn der Wert größer 0 ist, dann werden alle Lampen ausgeschaltet. Ist der Wert gleich 0, so werden alle Lampen entweder auf ihren Wiedereinschaltwert oder ihren maximalen Wert gesetzt, falls der Wiedereinschaltmodus für die Lampe nicht aktiviert wurde.
  • Aus ↔ max. Stellgröße: Ähnlich, wie bei Aus ↔ Wiedereinschaltwert, nur das alle Lampen zwischen Aus und ihrem maximalen Wert geschalten werden.
  • Stellgröße vorgeben: Die Lampen übernehmen den eingetragenen Wert nach betätigen der Übernehmen Schaltfläche. Ist der Wert größer, als das Maximum einer der Lampen, so werden diese auf die höchste Stufe geschalten. Ist der Wert niedriger, als das Minimum, jedoch nicht 0, so wird die Lampe auf ihre niedrigste Stufe geschalten. Der Wert 0 schaltet alle Lampen aus.
  • Regelung Freigabe/Sperren: Versetzt die tageslichtabhängige Lichtsteuerung in den Automatik-/Handbetrieb. Wird die SPS gestartet, so ist die Regelung freigegeben.

Alle Eingabefunktionen sind nur möglich, wenn die Regelung gesperrt ist, mit Ausnahme der Freigeben/Sperren Funktionen. Zusätzlich ist es möglich die aktive Steuerung zu sperren und alle Lampen mit der Aus Schaltfläche auszuschalten. Diese Funktion kann z.B. für Präsentationen genutzt werden, wenn ein Konferenzraum abgedunkelt werden soll. Die nächste steigende Flanke am Bewegungsmelder gibt die Regelung wieder frei, so dass die Ausschaltverzögerung des digitalen Signals/der digitalen Signalgruppe (Bewegungsmelder), groß genug sein muss, um eine sichere Präsenzerkennung über einen langen Zeitraum gewährleisten zu können.

Zustand
  • Stellgröße: Mittelwert der aktiven (nicht fehlerhaften) Lampe/Lampen der Lampenhauptgruppe.
  • Stellgröße - Unterlampe (Gruppe) 1: Mittelwert der Stellgröße für die Unterlampe/ Lampen der Unterlampengruppe 1 in Prozent.
  • Stellgröße - Unterlampe (Gruppe) 2: Mittelwert der Stellgröße für die Unterlampe/ Lampen der Unterlampengruppe 2 in Prozent.
  • Istwert: Gemessenes Lichtniveau.
  • Wiedereinschaltwert: Vor dem Ausschalten der Funktionseinheit wird der momentane Lichtwert in dieser Variablen gespeichert. Wurde die Option Wechseln mit den Ein/Aus-Befehlen der Funktionseinheit unter Wechsel Modus ausgewählt, werden alle Lampen in der Funktionseinheit mit deaktiviertem Wiedereinschaltmodus wieder auf diesen Lichtwert gesetzt, wenn sie über den Aus ↔ Wiedereinschaltwert Befehl eingeschaltet werden.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Konstantlichtregelung

Die Konstantlichtregelung ist ein geschlossener Regelkreis der die Lichtwerte von drei Lampen/Lampengruppen reguliert: einer Hauptlampe/Hauptlampengruppe und zwei Unterlampen/Unterlampengruppen. Der aktuelle Wert zur Berechnung der Sollwertabweichung wird von einem analogen Sensor/einer analogen Sensorgruppe geliefert. Ein zusätzlicher Bewegungsmelder aktiviert/deaktiviert das Steuerungssystem automatisch. Da für die Lichtregelung keine schnellen Wechsel der Lichtwerte beabsichtigt werden, dämpft eine Regelverzögerung (Wartezeit) das System die umso kürzer wird, je größer die Abweichung ist. Weiterhin ist eine Regelhysterese implementiert um zu verhindern, dass das System um den Sollwert schwankt. Die Werte für die Hysterese und maximale Regelverzögerung können im Einstellungen Menü eingetragen werden. Die folgenden zwei Diagramme zeigen das Verhalten der Regelung. Bitte beachten Sie, dass der aktuelle Lichtwert vom (äußeren) Tageslicht, sowie von der Innenbeleuchtung beeinflusst wird. Ohne die Einwirkung der Innenbeleuchtung wäre die ganze Regelung nur ein einfacher offener Regelkreis. Darum sieht man auf den Diagrammen, dass der aktuelle Lichtwert der Stellgröße folgt. Die Schrittweite ist konstant und wurde auf 0,39% gesetzt, was 1 DALI Schritt entspricht.

Bild 1: Hysterese ist groß genug, um ein Pendeln der Reglung zu vermeiden.

Bild 2: Hysterese ist zu klein. Die Reglung beginnt um den Sollwert zu pendeln.

Initialwert

Da die Funktionseinheit ein geschlossener Regelkreis ist, wird die resultierende Stellgröße ständig neu berechnet und kann nicht in nur einem SPS Zyklus ermittelt werden. Daher ist es notwendig mit einem Wert nahe der resultierenden Stellgröße zu Starten.
Maßgeblich für diese Berechnung ist das Verhältnis von Regelabweichung / Sollwert beim Aktivieren der Regelung. Wenn dieser Wert größer oder gleich dem Parameter Faktorgrenze Aktivierung Regelung ist, dann wird die Stellgröße auf 100% gesetzt. Wenn der Wert kleiner oder gleich dem Parameter Faktorgrenze Aktivierung Regelung ist, dann berechnet sich der Wert für die Stellgröße aus der resultierenden linearen Gleichung:

Einstellungen

Parameter
  • Wechsel Modus: Wird Wechseln mit den Ein/Aus-Befehlen der Funktionseinheit verwendet, dann wechselt die Lampe/Lampengruppe zwischen dem Wiedereinschaltwert der Funktionseinheit und aus. Bei Auswahl von Wechseln mit dem lokalen Wiedereinschaltwert und Aus-Befehl wechselt die Lampe/Lampengruppe zwischen dem Wiedereinschaltwert der Lampe(n) und aus.
  • Zeitdauer bis Selbsthaltung: Zeit, die bis zur Unterscheidung zwischen kurzen und langen Tastendruck vergehen soll.
  • Basis Sollwert: Schaltwert der Konstantlichtregelung. Kann durch einen Offset, Schaltwertverschiebung, angepasst werden, siehe Online Menü.
  • maximale Regelverzögerung: Maximum an Wartezeit, bevor wieder eine neue Stellgröße übernommen wird. Siehe Einleitung.
  • Regelhysterese: Hysterese Band um den Sollwert (1/2 Hysterese drüber und 1/2 Hysterese drunter). Ein Istwert außerhalb dieses Bereichs wird die Regelung dazu veranlassen neue Stellgrößen zu berechnen.
  • Faktorgrenze Aktivierung Regelung: Siehe Einleitung.
  • Faktor Stellgröße von Lampenuntergruppe 1 / Faktor Stellgröße von Lampenuntergruppe 2: Verstärkungsfaktor der Lampenuntergruppen bezogen auf die Lampenhauptgruppe.
  • Hoch Dimmen Option: Beschreibt, was die Lampe/Lampengruppe tut, wenn ein kurzer Tastendruck bei digitales Signal (Gruppe) - Hoch Dimmen erkannt wurde.
  • Runter Dimmen Option: Beschreibt, was die Lampe/Lampengruppe tut, wenn ein kurzer Tastendruck bei digitales Signal (Gruppe) - Runter Dimmen erkannt wurde.
  • Schrittweite für das Ändern der Sollwertverschiebung: Bezieht sich auf das Online Menü, wo die Sollwertverschiebung durch betätigen der Hoch/Runter Schaltflächen erhöht/verringert werden kann.
  • Minimal / Maximal zulässiger Wert für die Sollwertverschiebung: Der max/min Wert für die Sollwertverschiebung.

Sensoren / Aktoren

In diesem Menü müssen die Lampen/Lampengruppen, sowie die digitalen Signale/Signalgruppen zum Schalten der zugewiesenen Lampe/Lampengruppe eingetragen werden. Grundsätzlich gibt es zwei verschiedene Methoden zum Steuern der Lampe/Lampengruppe: Mit zwei Tastern zum Hoch und Runter dimmen oder mit einem Taster, der abwechselnd Hoch und Runter dimmt. Eine Kombination beider Methoden ist möglich.

Zusätzlich kann ein Bewegungsmelder benutzt werden, um die Lichtsteuerung zu aktiveren: eine steigende Flanke bei digitales Signal (Gruppe) - Bewegungssensor aktiviert den Controller, eine fallende flanke deaktiviert ihn und schaltet ihn aus.

Hoch und runter dimmen während einer aktiven Regelung hat einen besonderen Effekt: Der Lichtwert erhöht/verringert sich und nach 5 Sekunden ohne Aktivierung einer Dimm Funktion wird der aktuelle Lichtwert als resultierender Sollwert (Basis Sollwert + Sollwertverschiebung) gesetzt, so dass die Regelabweichung dann 0 beträgt. Bevor dieser neue Sollwert übernommen wird, kann sich eine kleine Korrektur am Lichtwert bemerkbar machen. Durch das Dimmen mit einem Dimmen Befehl kann es dazu kommen, dass alle Lampen/Lampengruppen um denselben Wert geändert werden und eine Korrektur für die Verstärkungsfaktoren von der Hauptlampe/Hauptlampengruppe ↔ Unterlampe/Unterlampengruppe durchgeführt werden muss.

Online

Befehle
  • Hoch Dimmen: Dieser Befehl erhöht den Lichtwert der zugewiesenen Lampen um ihre eingetragene Dimmstufe. Der Befehl kann nur ausgeführt werden, wenn die Lampe bereits eingeschalten ist. Eine Erhöhung des Wertes über das Maximum hinaus ist nicht möglich.
  • Runter Dimmen: Dieser Befehl verringert den Lichtwert um die eingetragene Dimmstufe, wird die Lampe jedoch nicht ausschalten.
  • Ein: Schaltet die Lampe auf ihr Maximum ein oder auf den Wiedereinschaltwert, insofern der Wiedereinschaltmodus aktiviert wurde. Der Wiedereinschaltmodus kann für jede Lampe separat aktiviert werden.
  • Aus: Schaltet alle zugewiesenen Lampen aus. Ist der Wiedereinschaltmodus aktiv, so wird vor dem Ausschalten der momentane Lichtwert gespeichert.
  • maximale Stellgröße ausgeben: Jede Lampe wird auf ihren maximalen Wert gesetzt.
  • minimale Stellgröße ausgeben: Jede Lampe wird auf ihren minimalen Wert gesetzt.
  • Aus ↔ Wiedereinschaltwert: Die Schaltrichtung hängt vom Mittelwert der Lampe/Lampengruppe ab. Wenn der Wert größer 0 ist, dann werden alle Lampen ausgeschaltet. Ist der Wert gleich 0, so werden alle Lampen entweder auf ihren Wiedereinschaltwert oder ihren maximalen Wert gesetzt, falls der Wiedereinschaltmodus für die Lampe nicht aktiviert wurde.
  • Aus ↔ max. Stellgröße: Ähnlich, wie bei Aus ↔ Wiedereinschaltwert, nur das alle Lampen zwischen Aus und ihrem maximalen Wert geschalten werden.
  • Stellgröße vorgeben: Die Lampen übernehmen den eingetragenen Wert nach betätigen der Übernehmen Schaltfläche. Ist der Wert größer, als das Maximum einer der Lampen, so werden diese auf die höchste Stufe geschalten. Ist der Wert niedriger, als das Minimum, jedoch nicht 0, so wird die Lampe auf ihre niedrigste Stufe geschalten. Der Wert 0 schaltet alle Lampen aus.
  • Sollwertverschiebung setzen: Eingabefeld für die Sollwertverschiebung, entweder direkt oder schrittweise mit Hoch und Runter für die eingetragenen Schrittweite (siehe Einstellungen Menü). Die Angabe wird durch die Maximal und Minimal Werte aus dem Einstellungen Menü begrenzt.
  • Regelung Freigeben/Sperren: Versetzt die Konstantlichtregelung in den Automatik-/Handbetrieb. Wird die SPS gestartet, so ist die Regelung freigegeben.

Alle Eingabefunktionen sind nur möglich, wenn die Regelung gesperrt ist, mit Ausnahme von Sollwertverschiebung ändern und der Freigeben/Sperren Funktionen. Zusätzlich ist es möglich die aktive Steuerung zu sperren und alle Lampen mit der Aus Schaltfläche auszuschalten. Diese Funktion kann z.B. für Präsentationen genutzt werden, wenn ein Konferenzraum abgedunkelt werden soll. Die nächste steigende Flanke am Bewegungsmelder gibt den Controller wieder frei, so dass die Ausschaltverzögerung der digitalen Signalgruppe, die den Bewegungsmelder darstellt, groß genug sein muss, um eine sichere Präsenzerkennung über einen langen Zeitraum gewährleisten zu können.

Zustand
  • Mittelwert der Stellgröße: Mittelwert der aktiven (nicht fehlerhaften) Lampe/Lampen der Lampenhauptgruppe.
  • Istwert: Gemessenes Lichtniveau.
  • Sollwert: Aktueller Sollwert resultierend aus dem Basis Sollwert und der Sollwertverschiebung.
  • Sollwertverschiebung: Aktuelle Sollwertverschiebung.
  • Regelabweichung: Die Abweichung in Sekunden.
  • Regelverzögerung: Zeigt die Regelabweichung in Sekunden an.
  • Wiedereinschaltwert: Vor dem Ausschalten der Funktionseinheit wird der momentane Lichtwert in dieser Variablen gespeichert. Alle Lampen in der Funktionseinheit, bei denen der Wiedereinschaltmodus aktiviert ist, werden wieder auf diesen Lichtwert gesetzt, wenn sie über den Aus ↔ Wiedereinschaltwert Befehl eingeschaltet werden.
  • Stellgröße - Unterlampe (Gruppe) 1: Mittelwert der Stellgröße für die Unterlampe/ Lampen der Unterlampengruppe 1 in Prozent.
  • Stellgröße - Unterlampe (Gruppe) 2: Mittelwert der Stellgröße für die Unterlampe/ Lampen der Unterlampengruppe 2 in Prozent.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Funktions- und Dauertest für die Sicherheitsbeleuchtung

folgt...


Beschattungen

Die folgenden Beschattungen sind verfügbar:

  • Standard Beschattung
  • Beschattung in Abhängigkeit des Sonnenstandes


Standard Beschattung

Die Standard Beschattung steuert einen Jalousieantrieb/eine Jalousieantriebsgruppe.

Einstellungen

Parameter
  • Zeitdauer bis Selbsthaltung: Zeit, die bis zur Verarbeitung der Befehle der Sensoren/der Sensorgruppen (siehe Sensoren / Aktoren) vergehen soll.

Sensoren / Aktoren

In diesem Menü muss der Jalousieantrieb/die Jalousieantriebsgruppe, sowie die digitalen Signale/Signalgruppen mit den enthaltenen Tastern zum hoch- und runterfahren eingetragen werden. Das digitale Signal (Gruppe) - Hoch/Runter, üblicherweise mit einem Taster verknüpft, ermöglicht das hoch- und runterfahren der Jalousie(n). Der Ausgang wird unverzüglich gesperrt. Wenn mit nur einem Taster für Hoch- und Runterfahren gearbeitet wird, dann fährt das digitale Signal (Gruppe) - Hoch/Runter die Jalousie in die eingestellte Richtung, beim nächsten Druck stoppt es sie, beim nächsten fährt es sie in die Gegenrichtung, beim nächsten stoppt es sie, usw..

Online

Befehle
  • Schritt Hoch/Runter: Fährt die Jalousien schrittweise hoch/runter. Standard Jalousien (Typ 1) werden mit einer einstellbaren Zeit gefahren. Jalousien die an eine KL2532 angebunden sind, werden für die eingetragene Schrittweite gefahren.
  • Hoch/Runter: Fährt die Jalousien hoch/runter. Jalousien die an eine KL2532 angebunden sind, werden über die Eilganggeschwindigkeit bewegt. Die Eilganggeschwindigkeit muss im Dynamik Bereich des Jalousieantriebs eingetragen werden.
  • Stopp: Hält die Jalousien an.
  • Position vorgeben: Fährt die Jalousien zur entsprechenden Position. Diese Position muss in einer prozentualen Beschattung und Lamellenwinkel angegeben werden.
Zustand
  • Mittelwert der Positionen: Aktueller Mittelwert der Positionen des Jalousieantriebs/der Jalousieantriebe. 100% entspricht vollständig geschlossen, 0% vollständig geöffnet.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Beschattung in Abhängigkeit des Sonnenstandes

Je nach Lichteinfall und Sonnenstand werden die Lamellen interaktiv reguliert. Dieser wird so berechnet, dass immer eine nutzungsoptimierte Raumausleuchtung erreicht wird. Anhand der Außentemperatur wird zwischen Sommer und Winterbetrieb unterschieden. Eine konsequente Nutzung der Sonnenenergie reduziert im Winter die Heizungsenergie. Im Sommer wird die Kühllast durch eine optimale Beschattung reduziert ohne den Raum komplett zu verdunkeln. Optional kann durch einen Bewegungsmelder und durch einen Temperaturfühler im Raum die Energiebilanz weiter verbessert werden.

Für die Nutzung dieser Funktionseinheit werden besondere Jalousieantriebe (Jalousieantrieb verbunden mit KL2532) vorausgesetzt.

Einstellungen

Befehle
  • temporärer Download: Wenn man Parameter verändern möchte, um die Jalousie zu testen, benötigt man mit einem normalen Download der Parameter (aktiveren der Konfiguration) verhältnismäßig viel Zeit. Zur Arbeitserleichterung und Zeitersparnis besteht daher die Möglichkeit eines temporären Downloads. Hierbei werden nicht erst die Module der SPS gestoppt um die Parameter runterzuschreiben, sondern die Parameter der Jalousie werden temporär und nicht persisten übergeben. Diese Änderungen werden nach einem Neustart der SPS oder aktiveren der Konfiguration unwirksam.
Parameter
  • Zeit bis zur Selbsthaltung der Taster: Zeit, die bis zur Verarbeitung der Befehle der Sensoren/Sensorgruppen (siehe Sensoren / Aktoren) vergehen soll.
  • Umschaltverzögerung nach Wegfall der Präsenz: Dieser Parameter ist nur gültig, wenn ein Präsenzmelder angeschlossen ist. Wird ein Taster betätigt, wird der Automatikmodus der Jalousie gestoppt. Ist der Präsenzmelder nicht mehr aktiv (Raum ist leer), startet eine Zeit mit der hier eingestellten Dauer. Nach Ablauf dieser Zeit wird der Automatikmodus wieder eingeschaltet.
  • Verhalten bei ausgeschalteter Automatik: Funktion die ausgeführt werden soll, wenn der Automatikmodus ausgeschaltet ist.
    • Jalousie nicht verändern
    • Jalousielamellen waagerecht fahren
    • Jalousie hoch fahren
    • Jalousie komplett zu
  • Schwellwert hohe Außenhelligkeit: Wenn der Schwellwertschalter überschritten wurde, dann wird die unter Verhalten bei hoher Außenhelligkeit festgelegte Aktion ausgeführt (siehe unten).
  • Schwellwert geringe Außenhelligkeit: Wenn der Schwellwertschalter unterschritten wurde, dann wird die unter Verhalten bei geringer Außenhelligkeit festgelegte Aktion ausgeführt (siehe unten).
  • Verhalten bei hoher Außenhelligkeit: Die folgenden Aktionen können für hohe Helligkeit ausgewählt werden:
    • Jalousie zu fahren
    • Sonnenstandsverfolgung max. Beschattung (Cut off)
  • Verhalten bei geringer Außenhelligkeit: Eine dieser Funktionen kann für geringe Helligkeit ausgewählt werden:
    • Jalousielamellen waagerecht fahren
    • Jalousie hoch fahren
    • Sonnenstandsverfolgung max Lichteintrag: Die Lamellen werden auf einen Winkel für maximalen Lichteintrag gestellt.
    • Sonnenstandsverfolgung max Beschattung (Cut off)
  • Schwellwert Raumtemperatur:
    • Ein: Ein Überschreiten dieser Temperatur hat zur Folge, dass die ausgewählte Aktion unter Verhalten bei geringer Raumtemperatur (siehe unten) deaktiviert wird.
    • Aus: Ein Unterschreiten dieser Temperatur hat zur Folge, dass die ausgewählte Aktion unter Verhalten bei geringer Raumtemperatur (siehe unten) ausgeführt wird.
  • Verhalten bei geringer Raumtemperatur: Hier wird die Funktion ausgewählt die ausgeführt werden soll, wenn die Temperatur den oben erwähnten Schwellwert unterschreitet (nur im Winterbetrieb).
    • Jalousielamellen waagerecht fahren
    • Jalousie hoch fahren
    • Sonnenstandsverfolgung max Lichteintrag: Die Lamellen werden auf einen Winkel für maximalen Lichteintrag gestellt.
    • Sonnenstandsverfolgung max Beschattung (Cut off).

Sensoren / Aktoren

In diesem Menü muss der Jalousieantrieb/die Jalousieantriebsgruppe, sowie die digitalen und analogen Signale/Signalgruppen zum hoch- und runterfahren, zur Bewegungserkennung, zum sperren der Automatik und erfassen der Raumtemperatur eingetragen werden.

Online

Befehle
  • Schritt Hoch/Runter: Fährt die Jalousie(n) schrittweise hoch/runter. Standard Jalousien (Typ 2) werden mit einer einstellbaren Zeit gefahren. Jalousien die an eine KL2532 angebunden sind, werden für die eingetragene Schrittweite gefahren.
  • Hoch/Runter: Fährt die Jalousie(n) hoch/runter. Jalousien die an eine KL2532 angebunden sind, werden über die Eilganggeschwindigkeit bewegt. Die Eilganggeschwindigkeit muss im Dynamik Bereich des Jalousieantriebs eingetragen werden.
  • Stopp: Hält die Jalousie(n) an.
  • Position vorgeben: Fährt die Jalousie(n) zur entsprechenden Position. Diese Position muss in einer prozentualen Beschattung und Lamellenwinkel angegeben werden.
  • Steuerungsmodus setzen: Hier kann der Automatik- oder Handbetrieb ausgewählt werden. Die Auswahl wird nach betätigen der Übernehmen Schaltfläche aktiviert.
  • Simulationsart setzen: Sommer- oder Wintersimulation aktivieren oder den Simulationsmodus deaktivieren.
Zustand
  • Mittelwert Position: Aktueller Mittelwert der Positionen des Jalousieantriebs/der Jalousieantriebe. 100% entspricht vollständig geschlossen, 0% vollständig geöffnet.
  • Raumtemperatur: Die momentane Raumtemperatur kann hier abgelesen werden.
  • Bewegungsmelder: Gibt an, ob Bewegungen erkannt wurden.
  • Außenhelligkeit: Zeigt die Außenhelligkeit an.
  • Jahreszeit: Anzeige der Jahreszeit.
  • Betriebsmodus: Zeigt den aktuellen Betriebsmodus an.
  • Steuerungsmodus: Zeigt den aktuellen Steuerungsmodus an.
  • Simulationsmodus: Gibt an, welcher Simulationsmodus aktiv ist.
    • Simulation aus
    • Simulation Sommerbetrieb
    • Simulation Winterbetrieb
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


HLKs

Die folgenden HLK Funktionseinheiten (Heizung, Lüftung und Klima) sind verfügbar:

  • Heizen und Kühlen


Heating and Cooling

TS8100 | TwinCAT Building Automation Framework V2.2x

Heizen und Kühlen

Der Temperaturregler kann zur Steuerung von Heiz- und Kühlventilen benutzt werden. Es werden sowohl thermische als auch stetige Antriebe unterstützt.

Funktionsprinzip

Das folgende Diagramm zeigt den Aufbau des Temperaturreglers.

Energieniveau

Die Energieabgabe kann durch das Energieniveau an die Nutzung des Gebäudes angepasst werden. Je länger ein Gebäude bzw. ein Raum nicht genutzt wird, desto weiter kann sein Energieniveau abgesenkt werden.

Energieniveau | Beschreibung
Komfort | Wenn der Raum belegt ist, befindet er sich im Komfortbetrieb. Die Aktivierung des Komfortbetriebes kann durch einen Zeitschaltkanal oder direkt durch eine Anwesenheitserkennung erfolgen.
Bereitschaft | Das Energieniveau Bereitschaft ist für einen ungenutzten Raum, der jedoch in Kürze wieder belegt sein kann.
Absenkung | Das Energieniveau Absenkung ist für einen ungenutzten Raum, der erst in einigen Stunden wieder belegt wird. Der Absenkbetrieb wird zum Beispiel nachts durch einen Zeitschaltkanal aktiviert.
Gebäudeschutz | Diese Betriebsart wird bei langen Abwesenheitszeiten z.B. in den Betriebsferien oder auch bei einem geöffneten Fenster aktiviert. Das Energieniveau ist sehr niedrig und dient lediglich dem Schutz des Gebäudes vor Frost- oder Überhitzungsschäden.

Der Wechsel zwischen den verschiedenen Energieniveaus erfolgt üblicherweise zeitgesteuert durch Zeitschaltkanäle. Fensterkontakte oder Bewegungsmelder, die durch digitale Signale an die Heizungsregelung angebunden werden, können diese Vorgabe überschreiben. So setzt ein Fensterkontakt das Energieniveau immer auf Gebäudeschutz. Ist ein Bewegungsmelder mit der Heizungsregelung verbunden, so muss dieser aktiv sein, damit das Energieniveau Komfort aktiviert werden kann.

Das berechnete Energieniveau wird im Dialog Online angezeigt.

Sollwertberechnung

Jedes Energieniveau hat je einen Basissollwert für den Heizbetrieb und für den Kühlbetrieb. Somit werden insgesamt 8 Basissollwerte vorgegeben. Je nach Energieniveau (Komfort, Bereitschaft, Absenkung oder Gebäudeschutz) und Regelfunktion (Heizen oder Kühlen) wird der entsprechende Basissollwert berücksichtigt.

Neben den Basissollwerten kann für den Heizbetrieb und für den Kühlbetrieb je eine zentrale Sollwertverschiebung als Parameter vorgegeben werden. Des Weiteren kann eine lokale Sollwertverschiebung (Sollwertverschiebung Benutzer) als Befehl eingestellt werden. Die lokale Sollwertverschiebung kann z.B. durch ein analoges Signal (Potentiometer eines Raumbediengerätes) verändert werden.

Der resultierende Sollwert setzt sich zusammen aus:

  • einem der 8 Basissollwerte.
  • der lokalen Sollwertverschiebung (Sollwertverschiebung Benutzer). Keine Auswirkung beim Energieniveau Gebäudeschutz.
  • der zentralen Sollwertverschiebung. Keine Auswirkung beim Energieniveau Gebäudeschutz.
  • der Sollwertverschiebung durch die Sommerkompensation.

Funktionsauswahl (Umschaltung Heizen/Kühlen)

Der Wechsel zwischen Heiz- und Kühlbetrieb (Regelfunktion) erfolgt automatisch anhand der Differenz zwischen Ist- und Sollwert (Regelabweichung). Mit Hilfe einer Nachlaufzeit kann die Umschaltung verzögert werden. Werden Taupunktfühler über eine digitale Signalgruppe angebunden, so wird der Kühlbetrieb gesperrt, sobald die digitale Signalgruppe mit den Taupunktfühlern aktiv ist. Liegt der Istwert innerhalb der neutralen Zone, so verbleibt die Regelung in der aktuellen Regelfunktion.

Je nach Energieniveau verschieben sich die Sollwerte für das Heizen und Kühlen. Dadurch ändert sich auch die Größe der neutralen Zone. Das folgende Diagramm zeigt die Kennlinien bei aktivem Energieniveau Bereitschaft:

Bei diesem Beispiel erfolgt der Wechsel vom Heizbetrieb in den Kühlbetrieb erst bei einem Istwert von 28 °C. Wäre das Energieniveau auf Komfort eingestellt, so würde der Wechsel schon bei 24 °C erfolgen. Durch diese Eigenschaft sinkt der Energiebedarf bei gleichzeitiger Senkung des Energieniveaus.

Die berechnete Regelfunktion wird im Dialog Online angezeigt.

Sommerkompensation

Mit Hilfe der Sommerkompensation werden zu hohe Temperaturunterschiede zwischen der Außentemperatur und der Raumtemperatur im Sommer vermieden. Dieses dient der Energieeinsparung bei gleichzeitiger Komfortsteigerung. Überschreitet die Außentemperatur einen einstellbaren Grenzwert, so wird der Sollwert angehoben. Der Faktor, um den der Sollwert angehoben wird, kann von 0,0 bis 10,0 eingestellt werden.

Einstellungen

Parameter

  • Sollwertverschiebung Heizen: zentrale Sollwertverschiebung während des Heizens.
    Liegt Sollwertverschiebung Heizen im positiven Bereich, so wirkt sich dieses auf die folgenden Sollwerte aus:
    Heizen | Kühlen
    Energieniveau | Gebäudeschutz | Absenkung | Bereitschaft | Komfort | Komfort | Bereitschaft | Absenkung | Gebäudeschutz
    Basissollwerte [°C] | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
    Sollwertverschiebung [K] - - - +3 +3 +3 - -
    Sollwert [°C] | 12 | 15 | 19 | 24 | 27 | 31 | 35 | 40
    Liegt Sollwertverschiebung Heizen im negativen Bereich, so wirkt sich dieses auf die folgenden Sollwerte aus:
    Heizen | Kühlen
    Energieniveau | Gebäudeschutz | Absenkung | Bereitschaft | Komfort | Komfort | Bereitschaft | Absenkung | Gebäudeschutz
    Basissollwerte [°C] | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
    Sollwertverschiebung [K] - - -3 -3 - - - -
    Sollwert [°C] | 12 | 15 | 16 | 18 | 24 | 28 | 35 | 40
  • Sollwertverschiebung Kühlen: zentrale Sollwertverschiebung während des Kühlens.
    Liegt Sollwertverschiebung Kühlen im positiven Bereich, so wirkt sich dieses auf die folgenden Sollwerte aus:
    Heizen | Kühlen
    Energieniveau | Gebäudeschutz | Absenkung | Bereitschaft | Komfort | Komfort | Bereitschaft | Absenkung | Gebäudeschutz
    Basissollwerte [°C] | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
    Sollwertverschiebung [K] - - - - +3 +3 - -
    Sollwert [°C] | 12 | 15 | 19 | 21 | 27 | 31 | 35 | 40
    Liegt Sollwertverschiebung Kühlen im negativen Bereich, so wirkt sich dieses auf die folgenden Sollwerte aus:
    Heizen | Kühlen
    Energieniveau | Gebäudeschutz | Absenkung | Bereitschaft | Komfort | Komfort | Bereitschaft | Absenkung | Gebäudeschutz
    Basissollwerte [°C] | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
    Sollwertverschiebung [K] - - - - -3 - - -
    Sollwert [°C] | 12 | 15 | 19 | 21 | 21 | 28 | 35 | 40
    Falls der Sollwert Bereitschaft über Absenkung hinaus verschoben wird, wird der Sollwert Absenkung mitgeführt.
    Heizen | Kühlen
    Energieniveau | Gebäudeschutz | Absenkung | Bereitschaft | Komfort | Komfort | Bereitschaft | Absenkung | Gebäudeschutz
    Basissollwerte [°C] | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
    Sollwertverschiebung [K] - - - - +8 +8 - -
    Sollwert [°C] | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
  • Sollwertverschiebung Benutzer - Begrenzung Min: Untergrenze für die lokale Sollwertverschiebung.
  • Sollwertverschiebung Benutzer - Begrenzung Max: Obergrenze für die lokale Sollwertverschiebung.
  • Sollwertverschiebung Benutzer - Schrittweite: Schrittweite für die lokale Sollwertverschiebung.
  • Nachlaufzeit bei Wechsel zwischen Heizen und Kühlen: Verzögerungszeit, bevor zwischen Heiz- und Kühlbetrieb (Regelfunktion) gewechselt wird.
  • Komfort: Ist das Energieniveau Komfort aktiv, so wird als Basissollwert der entsprechende Sollwert benutzt.
  • Bereitschaft: Ist das Energieniveau Bereitschaft aktiv, so wird als Basissollwert der entsprechende Sollwert benutzt.
  • Absenkung: Ist das Energieniveau Absenkung aktiv, so wird als Basissollwert der entsprechende Sollwert benutzt.
  • Gebäudeschutz: Ist das Energieniveau Gebäudeschutz aktiv, so wird als Basissollwert der entsprechende Sollwert benutzt.

Sommerkompensation

Parameter

  • Freigabe: Freigabe/sperren der Sommerkompensation.
  • Startwert - Außentemperatur: Außentemperatur bei der begonnen wird den Sollwert um den angegebenen Faktor anzupassen.
  • Endwert - Außentemperatur: Außentemperatur bei der aufgehört wird den Sollwert um den angegebenen Faktor anzupassen.
  • Faktor: Faktor, mit dem der Sollwert angepasst wird. Der Wert darf nicht kleiner als 0 und größer als 10 sein.

PID-Regler

Für die Regelfunktionen Heizen und Kühlen stehen separate PID-Regler zur Verfügung. Die Parameter der Regler können in diesem Dialog eingestellt werden.

Parameter

  • Totzone: Um unnötiges Verfahren und damit frühzeitiges Verschleißen der Ventile zu vermeiden, kann für das Ausgangssignal eine Totzone eingestellt werden.
  • Regelverstärkung - Kp: Verstärkung des Reglers.
  • Integrierzeit - Ti: Integrierzeit des Reglers.
  • Vorhaltezeit - Tv: Vorhaltezeit des Reglers.
  • Dämpfungszeit - Td: Dämpfungszeit des Reglers.
  • Arbeitsbereichsbegrenzung - Ymin: Untergrenze des Arbeitsbereichs.
  • Arbeitsbereichsbegrenzung - Ymax: Obergrenze des Arbeitsbereichs.
  • PWM Periodendauer: Periodendauer des PWM-Signals. Das PWM-Signal dient zur Ansteuerung von thermischen Antrieben.

Sensoren / Aktoren

In diesem Dialog werden die Sensoren und Aktoren eingetragen, die für die Regelung notwendig sind.

Online

Befehle

  • Energieniveau setzen: Durch diese vier Schaltflächen, kann das gewünschte Energieniveau ausgewählt werden. Der Wert kann durch Fensterkontakte oder Bewegungsmelder überschrieben werden.
  • Sollwertverschiebung setzen: Die lokale Sollwertverschiebung (Sollwertverschiebung Benutzer) kann in diesem Feld verändert werden. Die Schaltflächen Hoch und Runter erhöhen bzw. verringern die lokale Sollwertverschiebung. Der Parameter Sollwertverschiebung Benutzer - Schrittweite (siehe Dialog Einstellungen) gibt die Schrittweite an, um der sich die lokale Sollwertverschiebung ändern soll. Das Feld wird nicht angezeigt, wenn im Dialog Sensoren/Aktoren ein analoges Signal für die Sollwertverschiebung ausgewählt wurde.

    Liegt Sollwertverschiebung im positiven Bereich, so wirkt sich dieses auf die folgenden Sollwerte aus:
    Heizen | Kühlen
    Energieniveau | Gebäudeschutz | Absenkung | Bereitschaft | Komfort | Komfort | Bereitschaft | Absenkung | Gebäudeschutz
    Basissollwerte [°C] | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
    Sollwertverschiebung [K] - - - +3 +3 +3 - -
    Sollwert [°C] | 12 | 15 | 19 | 24 | 27 | 31 | 35 | 40

    Liegt Sollwertverschiebung im negativen Bereich, so wirkt sich dieses auf die folgenden Sollwerte aus:
    Heizen | Kühlen
    Energieniveau | Gebäudeschutz | Absenkung | Bereitschaft | Komfort | Komfort | Bereitschaft | Absenkung | Gebäudeschutz
    Basissollwerte [°C] | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
    Sollwertverschiebung [K] - - -3 -3 -3 - - -
    Sollwert [°C] | 12 | 15 | 16 | 18 | 21 | 31 | 35 | 40
Zustand
  • Komfort, Bereitschaft, Absenkung and Gebäudeschutz: Berechnete Sollwerte für die einzelnen Energieniveaus und Regelfunktionen.
  • berechneter Sollwert: Sollwert der für die weitere Regelung herangezogen wird. Das berechnete Energieniveau und die berechnete Regelfunktion bestimmen, welcher der 8 Sollwerte benutzt wird.
  • Raumtemperatur: Aktuelle Raumtemperatur (Istwert).
  • Sollwertverschiebung: Zeigt die lokale Sollwertverschiebung (Sollwertverschiebung Benutzer) an.
  • Sollwertverschiebung Sommerkompensation Zeigt die Sollwertverschiebung der Sommerkompensation an.
  • Außentemperatur: Zeigt die Außentemperatur an, falls eine Wetterstation mit der Klimaregelung verbunden wurde.
  • Bewegungsmelder: Zeigt den Zustand der Bewegungsmelder an, falls Bewegungsmelder mit der Klimaregelung verbunden wurden.
  • Fensterkontakt: Zeigt den Zustand der Fensterkontakte an, falls Fensterkontakte mit der Klimaregelung verbunden wurden.
  • Taupunktfühler: Zeigt den Zustand der Taupunktfühler an, falls Taupunktfühler mit der Klimaregelung verbunden wurden.
  • berechnetes Energieniveau: Das tatsächliche Energieniveau. Dieses ergibt sich aus der Vorgabe für das Energieniveau und optional aus den Zuständen der Bewegungsmelder und Fensterkontakte.
  • berechnete Regelfunktion: Die tatsächliche Regelfunktion. Dieses ergibt sich aus der Regelabweichung und optional aus den Zuständen der Taupunktfühler.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.

Online Heizen/Kühlen

Zustand

  • stetige Stellgröße: Stellgröße für die Ansteuerung der stetigen Ventil-Stellantriebe.
  • getaktete Stellgröße: Stellgröße für die Ansteuerung der thermischen Ventil-Stellantriebe.
  • Regelabweichung: Differenz zwischen Sollwert und Istwert (Sollwert - Istwert).


Fenster

Die folgenden Fenster sind verfügbar:
  • Standard Fenster


Standard Fenster

Die Funktionseinheit Standard Fenster steuert einen Fensterantrieb/eine Fensterantriebsgruppe.

Einstellungen

Parameter
  • Zeitdauer bis Selbsthaltung: Zeit, die bis zur Verarbeitung der Befehle des Sensors/der Sensorgruppen (siehe Sensoren / Aktoren) vergehen soll.

Sensoren / Aktoren

In diesem Menü muss der Fensterantrieb/die Fensterantriebsgruppe, sowie die digitalen Signale/Signalgruppen mit den enthaltenen Tastern zum Schließen und Öffnen eingetragen werden.

Online

Befehle
  • Öffnen: Öffnet alle zugewiesenen Fenster.
  • Schließen: Schließt alle zugewiesenen Fenster.
  • Stopp: Alle fahrenden Fenster werden angehalten.
  • Position vorgeben: Der eingetragene Wert wird auf den Fensterantrieb/die Fensterantriebe angewandt, sobald die Übernehmen Schaltfläche betätigt wurde.
Zustand
  • Mittelwert der Positionen: Aktueller Mittelwert aller aktiven (nicht fehlerhaften) Fensterantriebe. 100% entspricht vollständig geöffnet, 0% vollständig geschlossen.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Zusammengesetzte Module

Die folgenden Zusammengesetzten Module sind verfügbar:

  • 8fach + 2 Tastermodul
  • 16fach + 2 Tastermodul


8fach + 2 Tastermodul

Ein Tastermodul ist eine spezielle Funktion des Building Automation Frameworks, um eine einfache, aber umfangreiche Raumbedienung über ein Tastenfeld zu realisieren. Durch eine effektive Mehrfachbelegung der Taster können mit 10 einzelnen Tastern bis zu 3 Jalousien, 6 dimmbare Beleuchtungen und 8 Szenen bedient werden. Des Weiteren ist es möglich die Beleuchtungen der 6 Szenen über das Tastenfeld zu verändern und persistent in der Steuerung zu speichern. Diese Module sind im BA-Manager als Zusammengesetzte Module implementiert und sind voll funktionsfähig, sobald die Einstellungen im BA-Manager vorgenommen und aktiviert wurden.
Zwei Szenen Schnelltaster können, unabhängig vom aktuellen Modus, Szenenaufrufe zugewiesen werden. Diese sind dazu gedacht, dass auch Personen die nicht vertraut sind mit dem Umgang von Tastermodulen die Raumautomatisierung nutzen können (durch Standard Szenen, wie Grundbeleuchtung oder Raum Aus).

Einstellungen

Parameter
  • autom. Rücksetzen der Betriebsart: Zeit, in der das System automatisch vom Beschattungs- und Beleuchtungsmodus in den Szenenmodus zurück schaltet.
  • Zeitdauer bis Selbsthaltung: Zeit, nach der ein Tastendruck als haltend, statt als gedrückt gewertet wird.

Taster

Nutzen Sie dieses Menü, um die Taster Funktionen mit den entsprechenden digitalen Signalen zu verknüpfen.

LEDs Rückmeldungen

In diesem Menü können Lampen ausgewählt werden die den aktuellen Status der Taster anzeigen.

Szenen

Zuweisen einer Szene auf die Taster.

Beschattungen/Fenster

Wählen Sie eine Beschattungskonfiguration und/oder Fenster, dass mit dem entsprechenden Taster gesteuert werden soll.

Parameter
  • Zustand der Beschattungen/Fenster anzeigen: Aktivieren, um festzustellen, ob die LEDs den Zustand der Beschattung und Fenster widerspiegeln sollen.

Beleuchtung

Auswählen einer Beleuchtungskonfiguration die vom entsprechenden Taster gesteuert werden soll.

Parameter
  • Zustand der Beleuchtungen anzeigen: Aktivieren, um festzustellen, ob die LEDs den Zustand der Beleuchtung widerspiegeln sollen.

Online

Zustand
  • Taster 1...6,
    Szenen Schnelltaster 1...2,
    Umschaltt. Beschattungen,
    Umschaltt. Beleuchtungen:     Zeigt den Zustand der Taster an.
  • Betriebsart: Zeigt die aktuelle Betriebsart an.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


16fach + 2 Tastermodul

Ein Tastermodul ist eine spezielle Funktion des Building Automation Frameworks, um eine einfache, aber umfangreiche Raumbedienung über ein Tastenfeld zu realisieren. Durch eine effektive Mehrfachbelegung der Taster können mit 18 einzelnen Tastern bis zu 7 Jalousien, 14 dimmbare Beleuchtungen und 16 Szenen bedient werden. Des Weiteren ist es möglich die Beleuchtungen der 16 Szenen über das Tastenfeld zu verändern und persistent in der Steuerung zu speichern. Diese Module sind im BA-Manager als Zusammengesetzte Module implementiert und sind voll funktionsfähig, sobald die Einstellungen im BA-Manager vorgenommen und aktiviert wurden.
Zwei Szenen Schnelltaster können, unabhängig vom aktuellen Modus, Szenenaufrufe zugewiesen werden. Diese sind dazu gedacht, dass auch Personen die nicht vertraut sind mit dem Umgang von Tastermodulen die Raumautomatisierung nutzen können (durch Standard Szenen, wie Grundbeleuchtung oder Raum Aus).

Einstellungen

Parameter
  • autom. Rücksetzen der Betriebsart: Zeit, in der das System automatisch vom Beschattungs- und Beleuchtungsmodus in den Szenenmodus zurück schaltet.
  • Zeitdauer bis Selbsthaltung: Zeit, nach der ein Tastendruck als haltend, statt als gedrückt gewertet wird.

Taster

Nutzen Sie dieses Menü, um die Taster Funktionen mit den entsprechenden digitalen Signalen zu verknüpfen.

LEDs Rückmeldungen

In diesem Menü können Lampen ausgewählt werden die den aktuellen Status der Taster anzeigen.

Szenen

Zuweisen einer Szene auf die Taster.

Beschattungen/Fenster

Wählen Sie eine Beschattungskonfiguration und/oder Fenster, dass mit dem entsprechenden Taster gesteuert werden soll.

Parameter
  • Zustand der Beschattungen/Fenster anzeigen: Aktivieren, um festzustellen, ob die LEDs den Zustand der Beschattung und Fenster widerspiegeln sollen.

Beleuchtung

Auswählen einer Beleuchtungskonfiguration die vom entsprechenden Taster gesteuert werden soll.

Parameter
  • Zustand der Beleuchtungen anzeigen: Aktivieren, um festzustellen, ob die LEDs den Zustand der Beleuchtung widerspiegeln sollen.

Online

State
  • Taster 1...14,
    Szenen Schnelltaster 1...2,
    Umschaltt. Beschattungen,
    Umschaltt. Beleuchtungen:     Zeigt den Zustand der Taster an.
  • Betriebsart: Zeigt die aktuelle Betriebsart an.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Szenen

Die folgenden Szenen sind verfügbar:
  • Standard Szene


Standard Szene

Eine Szene kann verschiedene Befehle zu Aktoren, Aktorgruppen, Funktionseinheiten, Sensoren, Sensorgruppen und Szenen selbst schicken. Auf diese Weise ist es möglich einen Raum, eine Etage oder ein ganzes Gebäude mit nur einem Aufruf an bestimmte Umstände anzupassen.

Einstellungen

Parameter
  • Szenen aufaddieren: Wenn aktiviert, werden alle Lichtbefehle die den Wert direkt auf 0 setzen ignoriert. Dies verhindert ein Ausschalten der Beleuchtung, wenn diese Szene aufgerufen wird.

Befehle

Ein Betätigen der Schaltfläche Neu öffnet den Szenenassistent.

Szenenassistent

Der Szenenassistent führt Sie durch die drei Schritte der Szenenkonfiguration.

Schritt 1 - Befehlsempfänger

Wählen Sie den Befehlsempfänger aus der aktiviert werden soll, wenn die Szene aufgerufen wird.

Schritt 2 - Befehl

Auswahl des Befehls den der Befehlsempfänger ausführen soll.

Schritt 3 - Befehlsparameter (optional)

Kann der ausgewählte Befehl weitere Parameter entgegennehmen können diese hier eingetragen werden.

Online

Befehle
  • Aufrufen: Die Szene wird aufgerufen.
  • Ausschalten: Alle Elemente, die in dieser Szene enthalten sind, erhalten den Befehl Aus oder Stopp. Unterstützt ein Element keines der beiden Befehle, so wird es ignoriert.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehlercode und der Fehlerparameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Zeitschaltkanäle

Folgende Zeitschaltkanäle sind verfügbar:

  • Täglicher Zeitschaltkanal
  • Wöchentlicher Zeitschaltkanal (einzelne Wochentage)
  • Wöchentlicher Zeitschaltkanal (fortlaufende Wochentage)
  • Monatliche Zeitschaltkanal (n'te Tag im Monat)
  • Monatlicher Zeitschaltkanal (einzelner Wochentag im Monat)


Täglicher Zeitschaltkanal

Der tägliche Zeitschaltkanal stellt eine einfache Zeitschaltuhr mit einstellbarer Periodizität dar.

Einstellungen

Parameter
  • Start: Zeit: Absolute Startzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit aktiv.
    Start: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag aktiv.
    Start: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag aktiv.
  • Ende: Zeit: Absolute Endzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit inaktiv.
    Ende: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag inaktiv.
    Ende: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag inaktiv.
Serienmodel
  • Alle n Tag(e): Periodizität.
  • 1. Tag: Von diesem Tag an werden alle Schalttage anhand der Periodizität berechnet.

Verhalten

Die Periodizität wird am Tag der Initialisierung der SPS berechnet. Der Zeitschaltkanal ist nur von der Startzeit bis zur Endzeit aktiv, wenn die Startzeit vor der Endzeit liegt. Befindet sich die Endzeit vor der Startzeit arbeitet der Zeitschaltkanal umgekehrt. Erhalten Start- und Endzeit die gleiche Zeit hat dies einen undefinierten Zustand zur Folge der als Eingabefehler gewertet wird.

Es ist auch möglich die Sonnenaufgang/Sonnenuntergang Funktion zur Berechnung beider Zeiten mit Offset am Schalttag zu nutzen. Diese können positiv oder negativ sein. Die errechnete Start- und Endzeit wird automatisch durch Tagesanfang (00:00:00:000) und Tagesende (23:59:59:999) begrenzt.

Szenen

In diesem Menü werden die Szenen angegeben die aufgerufen werden sollen, wenn der Zeitschaltkanal aktiv oder inaktiv ist.

Online

Zustand
  • Wert: Zeigt den aktuellen Zustand des Zeitschaltkanals an.
  • Verbleibende Zeit An: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.
  • Verbleibende Zeit Aus: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Wöchentlicher Zeitschaltkanal (einzelne Wochentage)

Der wöchentliche Zeitschaltkanal (einzelne Wochentage) schaltet nur an ausgewählten Wochentagen mit einer einstellbaren Periodizität.

Einstellungen

Parameter
  • Start: Zeit: Absolute Startzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit aktiv.
    Start: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag aktiv.
    Start: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag aktiv.
  • Ende: Zeit: Absolute Endzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit inaktiv.
    Ende: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag inaktiv.
    Ende: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag inaktiv.
Serienmodel
  • Alle n Woche(n): Periodizität.
  • 1. Woche: Von dieser Woche an werden alle anderen Schalttage anhand der Periodizität berechnet.
  • Montag...Sonntag: Auswählbare Schalttage.

Verhalten

Der Zeitplan wird durch eine Anfangswoche und einer Periodizität festgelegt. Kalenderwochen die vor der Anfangswoche liegen enthalten keine Schaltereignisse. Alle danach enthalten Schaltereignisse entsprechend der ausgewählten Wochentage in jeder n-ten Woche.

Der Zeitschaltkanal ist nur von der Startzeit bis zur Endzeit des Schalttags aktiv, wenn die Anfangstageszeit vor der Endtageszeit liegt. Befindet sich die Endtageszeit vor der Anfangstageszeit arbeitet der Zeitschaltkanal umgekehrt. Erhalten Anfang- und Ende die gleiche Zeit hat dies einen undefinierten Zustand zur Folge der als Eingabefehler gewertet wird.

Es ist auch möglich die Sonnenaufgang/Sonnenuntergang Funktion zur Berechnung beider Zeiten mit Offset am Schalttag zu nutzen. Diese können positiv oder negativ sein. Die errechnete Start- und Endzeit wird automatisch durch Tagesanfang (00:00:00:000) und Tagesende (23:59:59:999) begrenzt.

Szenen

In diesem Menü werden die Szenen angegeben die aufgerufen werden sollen, wenn der Zeitschaltkanal aktiv oder inaktiv ist.

Online

Zustand
  • Wert: Zeigt den aktuellen Zustand des Zeitschaltkanals an.
  • Verbleibende Zeit An: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.
  • Verbleibende Zeit Aus: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Wöchentlicher Zeitschaltkanal (fortlaufende Wochentage)

Der wöchentliche Zeitschaltkanal (einzelne Wochentage) schaltet von einem Wochentag bis zu einem anderen.

Einstellungen

Parameter
  • Start: Zeit: Absolute Startzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit aktiv.
    Start: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag aktiv.
    Start: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag aktiv.
  • Ende: Zeit: Absolute Endzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit inaktiv.
    Ende: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag inaktiv.
    Ende: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag inaktiv.
Serienmodel
  • Alle n Woche(n): Die Woche (beginnend ab Montag) in der die SPS gestartet wird, ist immer eine Schaltwoche. Ab dieser Woche werden alle folgenden Schaltwochen anhand dieser Periodizität berechnet.
  • Montag...Sonntag: Auswählbare Schalttage.

Verhalten

Die Periodizität wird anhand der startenden Kalenderwoche (beginnend ab Montag, entsprechend der ISO 8601) berechnet.

Der Zeitschaltkanal wird innerhalb einer Woche aktiviert oder deaktiviert, wenn die Anfangstageszeit vor der Endtageszeit liegt (bezogen auf die Woche). Befindet sich die Endtageszeit vor der Anfangstageszeit wird der Kanal in der Folgewoche der Aktivierung deaktiviert. Ähnliche Anfangs- und Endzeiten führen zu einer einwöchentlichen Aktivierung des Kanals.

Es ist auch möglich die Sonnenaufgang/Sonnenuntergang Funktion zur Berechnung beider Zeiten mit Offset am Schalttag zu nutzen. Diese können positiv oder negativ sein. Die errechnete Start- und Endzeit wird automatisch durch Tagesanfang (00:00:00:000) und Tagesende (23:59:59:999) begrenzt.

Szenen

In diesem Menü werden die Szenen angegeben die aufgerufen werden sollen, wenn der Zeitschaltkanal aktiv oder inaktiv ist.

Online

Zustand
  • Wert: Zeigt den aktuellen Zustand des Zeitschaltkanals an.
  • Verbleibende Zeit An: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.
  • Verbleibende Zeit Aus: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Monatliche Zeitschaltkanal (n'te Tag im Monat)

Der monatliche Zeitschaltkanal (n'te Tag im Monat) ermöglicht die Definition eines Schaltereignisses für einen einzelnen Tag im Monat für mehrere Monate im Jahr.

Einstellungen

Parameter
  • Start: Zeit: Absolute Startzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit aktiv.
    Start: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag aktiv.
    Start: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag aktiv.
  • Ende: Zeit: Absolute Endzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit inaktiv.
    Ende: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag inaktiv.
    Ende: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag inaktiv.
Serienmodel
  • Immer am n-ten des: Die explizit auswählbaren Schalttage (1te...31te).
  • Januar...Dezember: Auswählbare Schaltmonate.

Verhalten

Im Gegensatz zu den täglichen und wöchentlichen Schaltfunktionen sind die Schalttage explizit benannt. Es muss keine Periodizität berechnet werden die von der Initialisierungszeit der SPS abhängt.

Der Zeitschaltkanal ist nur von der Startzeit bis zur Endzeit des Schalttags aktiv, wenn die Anfangstageszeit vor der Endtageszeit liegt. Befindet sich die Endtageszeit vor der Anfangstageszeit arbeitet der Zeitschaltkanal umgekehrt. Erhalten Anfang- und Ende die gleiche Zeit hat dies einen undefinierten Zustand zur Folge der als Eingabefehler gewertet wird.

Es ist auch möglich die Sonnenaufgang/Sonnenuntergang Funktion zur Berechnung beider Zeiten mit Offset am Schalttag zu nutzen. Diese können positiv oder negativ sein. Die errechnete Start- und Endzeit wird automatisch durch Tagesanfang (00:00:00:000) und Tagesende (23:59:59:999) begrenzt.

Szenen

In diesem Menü werden die Szenen angegeben die aufgerufen werden sollen, wenn der Zeitschaltkanal aktiv oder inaktiv ist.

Online

Zustand
  • Wert: Zeigt den aktuellen Zustand des Zeitschaltkanals an.
  • Verbleibende Zeit An: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.
  • Verbleibende Zeit Aus: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Monatlicher Zeitschaltkanal (einzelner Wochentag im Monat)

Der monatliche Zeitschaltkanal (einzelner Wochentag im Monat) ermöglicht die Definition eines Schaltereignisses für einen einzelnen Wochentag im Monat für mehrere Monate im Jahr.

Einstellungen

Parameter
  • Start: Zeit: Absolute Startzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit aktiv.
    Start: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag aktiv.
    Start: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag aktiv.
  • Ende: Zeit: Absolute Endzeit am Schalttag. Der Zeitschaltkanal ist ab dieser Zeit inaktiv.
    Ende: Sonnenaufgang + Offset: Der Zeitschaltkanal ist ab Sonnenaufgang + Offset (in Minuten) am Schalttag inaktiv.
    Ende: Sonnenuntergang + Offset: Der Zeitschaltkanal ist ab Sonnenuntergang + Offset (in Minuten) am Schalttag inaktiv.
Serienmodel
  • Jeden n-ten Wochentag: Die explizit auswählbaren Schalttage (1te...4te Montag...Sonntag).
  • Januar...Dezember: Auswählbare Schaltmonate.

Verhalten

Im Gegensatz zu den täglichen und wöchentlichen Schaltfunktionen sind die Schalttage explizit benannt. Es muss keine Periodizität berechnet werden die von der Initialisierungszeit der SPS abhängt.

Der Zeitschaltkanal ist nur von der Startzeit bis zur Endzeit des Schalttags aktiv, wenn die Anfangstageszeit vor der Endtageszeit liegt. Befindet sich die Endtageszeit vor der Anfangstageszeit arbeitet der Zeitschaltkanal umgekehrt. Erhalten Anfang- und Ende die gleiche Zeit hat dies einen undefinierten Zustand zur Folge der als Eingabefehler gewertet wird.

Es ist auch möglich die Sonnenaufgang/Sonnenuntergang Funktion zur Berechnung beider Zeiten mit Offset am Schalttag zu nutzen. Diese können positiv oder negativ sein. Die errechnete Start- und Endzeit wird automatisch durch Tagesanfang (00:00:00:000) und Tagesende (23:59:59:999) begrenzt.

Szenen

In diesem Menü werden die Szenen angegeben die aufgerufen werden sollen, wenn der Zeitschaltkanal aktiv oder inaktiv ist.

Online

Zustand
  • Wert: Zeigt den aktuellen Zustand des Zeitschaltkanals an.
  • Verbleibende Zeit An: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.
  • Verbleibende Zeit Aus: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Wetterstationen

Folgende Wetterstationen sind verfügbar:

  • Virtuelle Wetterstation
  • Wetterstation 'Elsner P03'
  • Wetterstation 'Thies Clima Sensor D'
  • Wetterstation mit analoge / digitale Signale


Virtuelle Wetterstation

Die virtuelle Wetterstation erlaubt den Zugriff auf Messwerte von einer remote angeschlossenen Wetterstation.

Einstellungen

Parameter
  • Umschaltwert Sommerbetrieb / Winterbetrieb: Schwellwert zur Erkennung eines Jahreszeitenwechsels.
Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die Remote Wetterstation mit diesem Modul verknüpft werden können.

Schwellwertschalter

In Abhängigkeit der einzelnen Werte können Schwellwertschalter definiert werden. Im Dialog Szenen (siehe unten) besteht die Möglichkeit, Szenen durch die Schwellwertschalter aufzurufen. So kann z.B. eine Szene angelegt werden, die alle Jalousien nach oben fährt. Der 1. Schwellwertschalter für die Windgeschwindigkeit schaltet bei 6.0 m/s (Hysterese 1 m/s) ein. Die Einschaltverzögerung von 6 Sekunden sorgt dafür, dass kurze Sturmböen unterdrückt werden. Im Dialog Szenen wird ein Ereignis angelegt, das beim Auslösen des Schwellwertschalters die entsprechende Szene aufruft und dadurch die Jalousien nach oben fahren.

Parameter
  • Temperatur: Schwellwert für die Temperatur.
  • Windgeschwindigkeit 1,
    Windgeschwindigkeit 2,
    Windgeschwindigkeit 3:     Schwellwerte für die Windgeschwindigkeit.
  • Helligkeit Ost,
    Helligkeit Süd,
    Helligkeit West:     Schwellwerte für die Helligkeit.
  • Dämmerung: Schwellwert für die Dämmerung.
  • Niederschlag: Schwellwert für den Niederschlag.
  • relative Luftfeuchtigkeit: Schwellwert für die relative Luftfeuchtigkeit.

Szenen

Ein Betätigen der Schaltfläche Neu im Menü Szenen öffnet einen Dialog in dem die steigende und fallende Flanke der Schwellwertschalter zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Befehle
  • Werte forcieren Ein/Aus: Aktiviert oder deaktiviert das Forcieren der Werte. Der eingetragene Wert kann mit einem Tastendruck auf die Runter schreiben Schaltfläche in die SPS geschrieben werden.
Zustand
  • Temperatur: Aktuelle Außentemperatur.
  • Windgeschwindigkeit: Momentane Windgeschwindigkeit.
  • Helligkeit Ost: Helligkeit auf der Ostseite.
  • Helligkeit Süd: Helligkeit auf der Südseite.
  • Helligkeit West: Helligkeit auf der Westseite.
  • Dämmerung: Zeigt die Tageshelligkeit an.
  • Niederschlag: Gibt den Niederschlag an.
  • relative Luftfeuchtigkeit: Gemessene relative Luftfeuchtigkeit.
  • gedämpfte Temperatur: Über den Tag gemessene Durchschnittstemperaturen.
  • Jahreszeit: Zeigt die Jahreszeit in Abhängigkeit der gedämpften Temperatur an.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehlercode und der Fehlerparameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Wetterstation 'Elsner P03'

Erfassung verschiedener Wetterdaten, wie z.B. Temperatur, Windgeschwindigkeit oder Helligkeit mit der Elsner P03.

Einstellungen

Parameter
  • Umschaltwert Sommerbetrieb / Winterbetrieb: Schwellwert zur Erkennung eines Jahreszeitenwechsels.
Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die serielle Kommunikations-Linie mit diesem Modul verknüpft werden kann.

Schwellwertschalter

In Abhängigkeit der einzelnen Werte können Schwellwertschalter definiert werden. Im Dialog Szenen (siehe unten) besteht die Möglichkeit, Szenen durch die Schwellwertschalter aufzurufen. So kann z.B. eine Szene angelegt werden, die alle Jalousien nach oben fährt. Der 1. Schwellwertschalter für die Windgeschwindigkeit schaltet bei 6.0 m/s (Hysterese 1 m/s) ein. Die Einschaltverzögerung von 6 Sekunden sorgt dafür, dass kurze Sturmböen unterdrückt werden. Im Dialog Szenen wird ein Ereignis angelegt, das beim Auslösen des Schwellwertschalters die entsprechende Szene aufruft und dadurch die Jalousien nach oben fahren.

Parameter
  • Temperatur: Schwellwert für die Temperatur.
  • Windgeschwindigkeit 1,
    Windgeschwindigkeit 2,
    Windgeschwindigkeit 3:     Schwellwerte für die Windgeschwindigkeit.
  • Helligkeit Ost,
    Helligkeit Süd,
    Helligkeit West:     Schwellwerte für die Helligkeit.
  • Dämmerung: Schwellwert für die Dämmerung.
  • Niederschlag: Schwellwert für den Niederschlag. Beachten Sie, dass der Niederschlag bei dieser Wetterstation nur die Werte 0.0 (kein Niederschlag) oder 1.0 (Niederschlag) annehmen kann.

Szenen

Ein Betätigen der Schaltfläche Neu im Dialog Szenen öffnet einen weiteren Dialog in dem die steigende und fallende Flanke der Schwellwertschalter zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Befehle
  • Werte forcieren Ein/Aus: Aktiviert oder deaktiviert das Forcieren der Werte. Der eingetragene Wert kann mit einem Tastendruck auf die Runter schreiben Schaltfläche in die SPS geschrieben werden.
Zustand
  • Temperatur: Aktuelle Außentemperatur.
  • Windgeschwindigkeit: Momentane Windgeschwindigkeit.
  • Helligkeit Ost: Helligkeit auf der Ostseite.
  • Helligkeit Süd: Helligkeit auf der Südseite.
  • Helligkeit West: Helligkeit auf der Westseite.
  • Dämmerung: Zeigt die Tageshelligkeit an.
  • Niederschlag: Gibt den Niederschlag an.
  • gedämpfte Temperatur: Über den Tag gemessene Durchschnittstemperaturen.
  • Jahreszeit: Zeigt die Jahreszeit in Abhängigkeit der gedämpften Temperatur an.
  • Sommerzeit: Gibt an, ob die Sommerzeit aktiv ist.
  • Datum und Uhrzeit: Zeigt Datum und Uhrzeit an die vom Zeitsignalsender DCF77 empfangen werden.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehlercode und der Fehlerparameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Wetterstation 'Thies Clima Sensor D'

Erfassung verschiedener Wetterdaten, wie z.B. Temperatur, Windgeschwindigkeit oder Helligkeit mit dem Thies Clima Sensor D.

Einstellungen

Parameter
  • Umschaltwert Sommerbetrieb / Winterbetrieb: Schwellwert zur Erkennung eines Jahreszeitenwechsels.
Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die serielle Kommunikations-Linie mit diesem Modul verknüpft werden kann.

Schwellwertschalter

In Abhängigkeit der einzelnen Werte können Schwellwertschalter definiert werden. Im Dialog Szenen (siehe unten) besteht die Möglichkeit, Szenen durch die Schwellwertschalter aufzurufen. So kann z.B. eine Szene angelegt werden, die alle Jalousien nach oben fährt. Der 1. Schwellwertschalter für die Windgeschwindigkeit schaltet bei 6.0 m/s (Hysterese 1 m/s) ein. Die Einschaltverzögerung von 6 Sekunden sorgt dafür, dass kurze Sturmböen unterdrückt werden. Im Dialog Szenen wird ein Ereignis angelegt, das beim Auslösen des Schwellwertschalters die entsprechende Szene aufruft und dadurch die Jalousien nach oben fahren.

Parameter
  • Temperatur: Schwellwert für die Temperatur.
  • Windgeschwindigkeit 1,
    Windgeschwindigkeit 2,
    Windgeschwindigkeit 3:     Schwellwerte für die Windgeschwindigkeit.
  • Helligkeit Ost,
    Helligkeit Süd,
    Helligkeit West:     Schwellwerte für die Helligkeit.
  • Dämmerung: Schwellwert für die Dämmerung.
  • Niederschlag: Schwellwert für den Niederschlag. Beachten Sie, dass der Niederschlag bei dieser Wetterstation nur die Werte 0.0 (kein Niederschlag) oder 1.0 (Niederschlag) annehmen kann.
  • relative Luftfeuchtigkeit: Schwellwert für die relative Luftfeuchtigkeit.

Szenen

Ein Betätigen der Schaltfläche Neu im Dialog Szenen öffnet einen Dialog in dem die steigende und fallende Flanke der Schwellwertschalter zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Online

Befehle
  • Werte forcieren Ein/Aus: Aktiviert oder deaktiviert das Forcieren der Werte. Der eingetragene Wert kann mit einem Tastendruck auf die Runter schreiben Schaltfläche in die SPS geschrieben werden.
Zustand
  • Temperatur: Aktuelle Außentemperatur.
  • Windgeschwindigkeit: Momentane Windgeschwindigkeit.
  • Helligkeit Ost: Helligkeit auf der Ostseite.
  • Helligkeit Süd: Helligkeit auf der Südseite.
  • Helligkeit West: Helligkeit auf der Westseite.
  • Dämmerung: Zeigt die Tageshelligkeit an.
  • Niederschlag: Gibt den Niederschlag an.
  • relative Luftfeuchtigkeit: Gemessene relative Luftfeuchtigkeit.
  • gedämpfte Temperatur: Über den Tag gemessene Durchschnittstemperaturen.
  • Jahreszeit: Zeigt die Jahreszeit in Abhängigkeit der gedämpften Temperatur an.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehlercode und der Fehlerparameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Wetterstation mit analoge / digitale Signale

TS8100 | TwinCAT Building Automation Framework V2.2x

Wetterstation mit analogen / digitalen Signalen

Erfassung verschiedener Wetterdaten, wie z.B. Temperatur, Windgeschwindigkeit oder Helligkeit mit analogen und digitalen Signalen.

Einstellungen

Parameter
  • Umschaltwert Sommerbetrieb / Winterbetrieb: Schwellwert zur Erkennung eines Jahreszeitenwechsels.

Schwellwertschalter

In Abhängigkeit der einzelnen Werte können Schwellwertschalter definiert werden. Im Dialog Szenen (siehe unten) besteht die Möglichkeit, Szenen durch die Schwellwertschalter aufzurufen. So kann z.B. eine Szene angelegt werden, die alle Jalousien nach oben fährt. Der 1. Schwellwertschalter für die Windgeschwindigkeit schaltet bei 6.0 m/s (Hysterese 1 m/s) ein. Die Einschaltverzögerung von 6 Sekunden sorgt dafür, dass kurze Sturmböen unterdrückt werden. Im Dialog Szenen wird ein Ereignis angelegt, das beim Auslösen des Schwellwertschalters die entsprechende Szene aufruft und dadurch die Jalousien nach oben fahren.

Parameter
  • Temperatur: Schwellwert für die Temperatur.
  • Windgeschwindigkeit 1,
    Windgeschwindigkeit 2,
    Windgeschwindigkeit 3:     Schwellwerte für die Windgeschwindigkeit.
  • Helligkeit Ost,
    Helligkeit Süd,
    Helligkeit West:     Schwellwerte für die Helligkeit.
  • Dämmerung: Schwellwert für die Dämmerung.
  • Niederschlag: Schwellwert für den Niederschlag.
  • relative Luftfeuchtigkeit: Schwellwert für die relative Luftfeuchtigkeit.

Szenen

Ein Betätigen der Schaltfläche Neu im Menü Szenen öffnet einen Dialog in dem die steigende und fallende Flanke der Schwellwertschalter zum Aufrufen einer Szene genutzt werden können. Die Szene muss dazu vorher angelegt worden sein.

Sensoren

In diesem Menü müssen alle Signale zur Messung eingetragen werden.

Online

Befehle
  • Werte forcieren Ein/Aus: Aktiviert oder deaktiviert das Forcieren der Werte. Der eingetragene Wert kann mit einem Tastendruck auf die Runter schreiben Schaltfläche in die SPS geschrieben werden.
Zustand
  • Temperatur: Aktuelle Außentemperatur.
  • Windgeschwindigkeit: Momentane Windgeschwindigkeit.
  • Helligkeit Ost: Helligkeit auf der Ostseite.
  • Helligkeit Süd: Helligkeit auf der Südseite.
  • Helligkeit West: Helligkeit auf der Westseite.
  • Dämmerung: Zeigt die Tageshelligkeit an.
  • Niederschlag: Gibt den Niederschlag an.
  • relative Luftfeuchtigkeit: Gemessene relative Luftfeuchtigkeit.
  • gedämpfte Temperatur: Über den Tag gemessene Durchschnittstemperaturen.
  • Jahreszeit: Zeigt die Jahreszeit in Abhängigkeit der gedämpften Temperatur an.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehlercode und der Fehlerparameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Subsysteme

Folgende Subsysteme sind verfügbar:

  • DALI
  • EnOcean
  • Serielle Kommunikation
  • Energiemessung


DALI

Das Digital Adressable Lighting Interface (DALI) ist ein einfaches Bussystem für die Gebäudeautomation, das die Signale zur digitalen Ansteuerung von Betriebsgeräten der Lichttechnik überträgt. Die DALI-Linie via KL6811 bietet die Möglichkeit DALI-Geräte mit einzubinden, um sie zu konfigurieren und mit ihnen zu arbeiten.

Einstellungen

Parameter
  • Schwellwert, ab der DALI-Vorschaltgeräte der gleichen Lampengruppe einer DALI-Gruppe zugeordnet werden: Eingabefeld für den Schwellwert, ab dem DALI-Vorschaltgeräte der gleichen Lampengruppe einer DALI-Gruppe zugeordnet werden.
Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die entsprechende Eingangsklemme mit diesem Modul verknüpft werden kann.

Geräte

Dieser Dialog listet alle gescannten DALI Geräte auf und zeigt alle verfügbaren Parameter und Befehle an. Drei DALI Typen sind verfügbar:
  • Standard
  • Gerät für Notbeleuchtung
  • SmartSPOT

Adressierung

Das Menü zur Adressierung bietet Zugriff auf die Adressierungsmöglichkeiten. Weitere Informationen erhalten Sie auf den folgenden Seiten:
  • Zufällige Adressierung
  • Einzel Zuordnung
  • Adresse ändern

Online

Zustand
  • aktuelle Auslastung: Die aktuelle Auslastung in Prozent.
  • maximale Auslastung: Die maximale Auslastung in Prozent.
  • Anzahl der Überläufe: Zeigt die aktuelle Anzahl erfasster Überläufe an.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Geräte

Dieser Dialog listet alle gescannten DALI Geräte auf und zeigt alle verfügbaren Parameter und Befehle an. Drei DALI Typen sind verfügbar:
  • Standard
  • Gerät für Notbeleuchtung
  • SmartSPOT


Standard

Die folgenden Dialoge erlauben es ein DALI Gerät (Typ 0) mit dem Standard Befehlssatz zu konfigurieren und zu bedienen.

Gerät

Für die wichtigsten Funktionen befinden sich hier Schaltflächen, um entsprechende DALI Befehle an das ausgewählte Gerät zu senden.

Variablen

Mit DALI wurde die Intelligenz nicht zu 100% zentralisiert. Das bedeutet, dass viele Einstellungen und Lichtstufen als Variablen im Vorschaltgerät hinterlegt sind. Das Variablen Menü bietet einen Dialog an, um Variablen eines ausgewählten DALI Gerätes einzusehen und zu bearbeiten.

Gruppen

In diesem Menü kann jedes DALI Gerät zu bis zu 16 Gruppen hinzugefügt werden. Wenn ein DALI Gerät einen Befehl in Verbindung mit einer parametrisierten Gruppennummer erhält, dann wird es diesen ausführen.

Szenen

Hier können in jedem DALI Gerät 16 verschiedene Lichtstufen für Szenen hinterlegt werden. Erhält ein DALI Gerät eine parametrisierte Szenennummer (z.B. als Teil eines Broadcast), wird die Lichtintensität für die Szene gesetzt. Wenn der Wert 255 (Maske) für diese Szene hinterlegt wird, dann stellt das DALI Gerät den vorherigen Wert wieder her.


Gerät für Notbeleuchtung

Die autarke Notbeleuchtung (DALI-Gerät Typ 1) unterstützt neben dem Standard Befehlssatz noch einen typenspezifischen Befehlssatz, um den Anforderungen an eine Notbeleuchtung gerecht werden zu können. Für die Konfiguration und Bedienung stehen nachfolgende Dialoge zur Verfügung.

Gerät

Für die wichtigsten Funktionen befinden sich hier Schaltflächen, um entsprechende DALI Befehle an das ausgewählte Gerät zu senden.

erw. Befehle

Bietet Zugriff auf spezifische Befehle vom Gerät für die Notbeleuchtung.

Variablen

Mit DALI wurde die Intelligenz nicht zu 100% zentralisiert. Das bedeutet, dass viele Einstellungen und Lichtstufen als Variablen im Vorschaltgerät hinterlegt sind. Das Variablen Menü bietet einen Dialog an, um Variablen eines ausgewählten DALI Gerätes einzusehen und zu bearbeiten.

erw. Variablen

Zeigt alle Werte der erweiterten Variablen.

Gruppen

In diesem Menü kann jedes DALI Gerät zu bis zu 16 Gruppen hinzugefügt werden. Wenn ein DALI Gerät einen Befehl in Verbindung mit einer parametrisierten Gruppennummer erhält, dann wird es diesen ausführen.

Szenen

Hier können in jedem DALI Gerät 16 verschiedene Lichtstufen für Szenen hinterlegt werden. Erhält ein DALI Gerät eine parametrisierte Szenennummer (z.B. als Teil eines Broadcast), wird die Lichtintensität für die Szene gesetzt. Wenn der Wert 255 (Maske) für diese Szene hinterlegt wird, dann stellt das DALI Gerät den vorherigen Wert wieder her.


SmartSPOT

Der smartSPOT (DALI-Gerät Typ 254) für die Bewegungserkennung bietet vergleichsweise zu anderen DALI-Geräten nur wenige Konfigurations- und Bedienmöglichkeiten. Für die notwendigen Einstellungen stehen nachfolgende Dialoge bereit.

Gerät

Für die wichtigsten Funktionen befinden sich hier Schaltflächen, um entsprechende DALI Befehle an das ausgewählte Gerät zu senden.

Gruppen

In diesem Menü kann jedes DALI Gerät zu bis zu 16 Gruppen hinzugefügt werden. Wenn ein DALI Gerät einen Befehl in Verbindung mit einer parametrisierten Gruppennummer erhält, dann wird es diesen ausführen.


Adressierung

Die folgenden Adressierungen sind verfügbar:

  • Zufällige Adressierung
  • Einzel Zuordnung
  • Adresse ändern


Zufällige Adressierung

Die zufällige Adressvergabe kann in diesem Dialog gestartet werden.

Mit dieser Methode werden die Adressen zufällig vergeben. Dabei kann kein Einfluss auf die Reihenfolge der vergebenen Adressen genommen werden. Jedoch ist eine nachträgliche Änderung über das Adresse ändern Menü möglich.


Einzel Zuordnung

In diesem Menü kann die Adressvergabe für jedes Gerät einzeln vorgenommen werden.

Alle verfügbaren DALI Slaves die mit der KL6811 verbunden sind, werden die gleiche neue Adresse haben. In der Praxis sieht es so aus, dass nur der DALI Slave verbunden wird der die Adresse erhalten soll, bevor die Start Schaltfläche betätigt wird.


Adresse ändern

Dieses Menü ermöglicht die Adressänderung eines Gerätes.

Markieren Sie in der rechten Liste das Gerät, dessen Adresse Sie ändern möchten. Über die Auswahlbox neben der Liste können Sie dem markierten Gerät eine neue Adresse zuweisen. Drücken Sie die Start Schaltfläche, nachdem Sie alle neuen Adressen zugewiesen haben.

Hinweis
Damit die Adressen geändert werden können, muss mindestens eine freie Adresse im DALI Netzwerk vorhanden sein.


EnOcean

EnOcean Module ermöglichen eine Funkübertragung ohne Batterien oder externe Stromzufuhr im Sender. Unterstützte EnOcean Module können durch die KL6021-0023 oder KL6581 über eine EnOcean Linie eingebunden werden.

Einstellungen

Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem diesem Modul ein kompatibler Kanal von einer Klemme der E/A Geräte zugewiesen werden kann.

Mapping

Diese Liste zeigt alle Sensoren an die mit einer EnOcean Linie verknüpft sind.
  • Transmitter Id: Definiert die einzigartige Transmitter Id, die durch die Firma EnOcean spezifiziert wurde.
  • Modul Typ: Beschreibt den EnOcean Modul Typ.
  • Verknüpfter Sensor: Zeigt, welches digitale Signal als EnOcean Modul konfiguriert ist und mit welcher EnOCean Line es verknüpft ist.
Unterstützte EnOcean Modul Typen:
  • PTM 100 - Tast-Funksendermodul
  • PTM 200 - Tast-Funksendermodul
  • PTM 250 - Tast-Funksendermodul
  • STM 100 - Sensor Sendermodul
  • STM 250 - Drahtloser Magnetkontakt
Weitere Informationen erhalten Sie auf der offiziellen EnOcean Website.

Online

Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


Serielle Kommunikation

Die serielle Kommunikation ermöglicht die Datenerfassung nach RS232/RS485 über einen COM Port (64 Bytes), der KL6031/KL6041 (22 Bytes) oder der KL6001/KL6021 (5 Bytes).

Einstellungen

Parameter Einstellungen für Typ 1 - RS232/RS485 via COM Port (64 Bytes).

Parameter
  • Baudrate: Auswahl der gewünschten Baudrate. Die folgenden Werte sind verfügbar: 50, 75, 110, 150, 300, 600, 1200, 2400, 4800, 9600, 14400, 19200, 38400, 57600, 115200, 230400, 460800.
  • Hardware FIFO (Byte): Auswahl der gewünschten Byte Größe des Fifo. Die folgenden Werte sind verfügbar: 16, 128.
  • Datenbits: Auswahl der gewünschten Anzahl von Datenbits pro Byte. Die folgenden Werte sind verfügbar: 8, 7, 6, 5.
  • Schnittstelle: Auswahl des zu verwendenden RS Typs. Die folgenden Werte sind verfügbar: RS232, RS485.
  • Stoppbits: Auswahl der gewünschten Anzahl von Stoppbits. Die folgenden Werte sind verfügbar: 1, 2.
  • Parität: Auswahl des zu verwendenden Testverfahrens für die Parität. Die folgenden Werte sind verfügbar: Keine, Gerade, Ungerade, Benutzerdefiniert.
  • Sync Mode: Der Austausch von Prozessdaten mit der SPS ist synchron, wenn der Sync Mode aktiv ist.

Das Betätigen der verknüpft mit... Schaltfläche öffnet einen Dialog in dem die entsprechende serielle Kommunikations Linie mit diesem Modul verknüpft werden kann.

Wenn mit RS232/RS485 via KL6031/KL6041 oder KL6001/KL6021 gearbeitet wird, dann können hier keine Parameter eingestellt werden. In diesem Fall muss nur der entsprechende Kanal der Klemme ausgewählt und mit diesem Modul verknüpft werden.

Online

Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.
Dieses Verhalten ist identisch für RS232/RS485 via KL6031/KL6041 und KL6001/KL6021.


Energiemessung

Das Energiemessungs Subsystem ermöglicht die Messung von elektrischen Daten eines dreiphasigen Versorgungsnetzes. Die Einspeisung erfolgt dabei über die 3-Phasen Leistungsmessklemme KL3403.

Einstellungen

Parameter
  • Transformationsfaktor des Stromwandlers: Eingabefeld für den Transformationsfaktor des derzeitigen Stromwandlers.
Das Betätigen der verknüpft mit... Schaltfläche öffnet jeweils einen Dialog in dem die entsprechende Phase der Energiemessklemme mit diesem Modul verknüpft werden kann.

Online

Befehle
  • Energieverbrauch zurücksetzen: Setzt die Werte der Energiemessung zurück.
Zustand
  • Strom (Effektivwert): Stromstärke aller Phasen.
  • Spannung (Effektivwert): Spannungswert aller Phasen.
  • Wirkleistung: Summe der effektiven Wirkleistung.
  • Energieverbrauch: Energieverbrauch insgesamt.
  • Leistungsfaktor (cos φ): Leistung aller Phasen.
  • Blindleistung: Gesamte Blindleistung.
  • Scheinleistung: Summe der Scheinleistung.
Zustand SPS-Modul
  • Ausführungszustand: Gibt an, ob das Modul läuft oder gestoppt ist.
  • Fehler: Im Fehlerfall sind hier der Fehler-Code und der Fehler-Parameter zu sehen.
  • Start/Stopp: Startet/stoppt das Modul.


E/A Geräte

TS8100 | TwinCAT Building Automation Framework V2.2x

E/A Geräte CX1000\CX9000 Echtzeit Ethernet, CX1100-KB, CX9000 Netzteil/Klemmenanschaltung

Einstellungen

Wenn die Suche nach E/A Geräten erfolgreich war, dann erscheinen deren Informationen hier.

Buskoppler

Das Buskoppler Menü listet alle Buskoppler eines ausgewählten E/A Gerätes auf.


Bus Coupler

TS8100 | TwinCAT Building Automation Framework V2.2x

Buskoppler BK9000, BK9010, BK9050

Einstellungen

Adresse und Echtzeitverhalten eines Buskopplers können in diesem Dialog bearbeitet werden.

Klemmen

Das Klemmen Menü listet alle Klemmen auf.

Um die Klemmenliste eines Kopplers auszudrucken klicken Sie mit der rechten Maustaste auf den Koppler. Es erscheint das bekannte Kontextmenü mit drei zusätzlichen Einträgen:

  • Drucken...: Druckt die Klemmenliste des Kopplers aus.
  • Druckvorschau...: Zeigt die Druckvorschau an.
  • Seite einrichten...: Einstellungen zu Papiergröße und Rand.


Klemmen

Bei einem Klick auf eine Klemme im Navigationsbaum werden die Kanäle angezeigt und wohin sie verknüpft sind. Mehr Informationen über einen Kanal erhält man, wenn er angeklickt wird.

Variablen

Dieser Dialog bietet grundlegende Informationen zum Kanal und wohin er verknüpft ist.

Online

Das Online Menü bietet ebenfalls grundlegende Informationen zum Kanal und dessen Wert.


Dyn. Gruppenzuordnung bei Lampen

Sobald Gruppierungen von Lampen über mehrere Controller verteilt sind, kann das Realisieren von Beleuchtungsaufgaben zu einer zeitaufwendigen Aufgabe werden. Insbesondere dann, wenn die Lampen über Subsysteme wie DALI angeschlossen sind und sich eine Lampengruppe über mehrere DALI-Linien erstreckt.

Das TwinCAT Building Automation Framework ist darauf spezialisiert, die Inbetriebnahme von solchen Applikationen möglichst zu vereinfachen. Erreicht wird dieses durch verschiedene Maßnahmen:

  • das Objekt Lampengruppe unterstützt verschiedene Lampentypen (DALI, Dimmerklemme und digitaler Ausgang). Diese können, falls gefordert, gemeinsam in eine Lampengruppe gelegt werden.
  • das Objekt Lampengruppe kann Lampen verwalten, die sich über verschiedene Linien als auch Controller verteilen. Der TwinCAT Building Automation Manager erzeugt automatisch die notwendigen Netzwerkvariablen.
  • das Objekt Lampengruppe weist den einzelnen DALI-Lampen über das Objekt Subsystem DALI die notwendigen DALI-Gruppen zu. Dies erfolgt automatisch während die Konfiguration aktiviert wird. Es ist nicht notwendig, die Zuweisung von den DALI-Lampen zu den DALI-Gruppen separat (evtl. mit einem weiteren Inbetriebnahmewerkzeug) umzusetzen.

Gruppierung

Die einfachste Form der Gruppierung stellt das Zusammenfassen mehrerer Lampen eines Controllers zu einer Gruppe dar. Unabhängig vom eigentlichen Lampentyp lassen sich die gewünschten Lampen gruppieren und bedienen, auch über die Grenzen des Controllers hinaus. Für komplexere Beleuchtungsszenarien ist eine Verschachtelung möglich, wodurch Lampen die bereits zu einer Gruppe gehören noch weiteren Gruppen zugewiesen werden können.

Gruppe 1

Eine einfache Zusammenfassung von DALI-Lampen an einer DALI-Linie zu einer Gruppe. Da sich alle DALI-Lampen an einer DALI-Linie befinden, werden diese einer DALI-Gruppe zugewiesen.

Gruppe 2

Die Lampengruppe 2 stellt die umfangreichste Variante dar. Es werden 5 DALI-Lampen von Controller 1 der Lampengruppe zugeordnet. Des Weiteren ist eine nicht dimmbare Standard-Lampe (KL2114) und eine dimmbare Standard-Lampe (KL2751) von Controller 1 in der Lampengruppe 2.

Von Controller 2 werden von der DALI-Linie 1 drei DALI-Lampen und von DALI-Linie 2 eine DALI-Lampe der Lampengruppe 2 zugeordnet. Zusätzlich wird noch eine weitere Standard-Lampe (KL2751) hinzugefügt.

Die 4 DALI-Lampen (an DALI-Linie 1) von Controller 1 werden einer DALI-Gruppe zugeordnet. Diese Zuordnung geschieht automatisch bei der Aktivierung der Konfiguration. Die einzelne DALI-Lampe von Controller 1 und die DALI-Lampen von Controller 2 werden per Kurzadresse angesprochen.

Das Objekt Lampengruppe sichert die richtige Verteilung der notwendigen Befehle. Dabei ist es egal, ob das Objekt über den Online-Dialog des TwinCAT Building Automation Managers bedient wird oder per SPS Funktionsbaustein FB_BAFLampGroupStandard.

Sobald zwei oder mehr DALI-Lampen einer DALI-Linie einer lokalen Lampengruppe zugeordnet werden, weist der TwinCAT Building Automation Manager diese einer DALI-Gruppe zu. Bei Applikationen mit vielen Lampengruppen kann es notwendig sein, dass der Schwellwert (Anzahl der DALI-Lampen, ab der eine DALI-Gruppe belegt wird) erhöht werden muss. Dadurch kann eine DALI-Lampe mehr als 16 Lampengruppen zugeordnet werden. Der Parameter kann individuell für jede DALI-Linie einzeln eingestellt werden (sie Subsystem DALI-Linie).

Gruppe 3

Lampengruppe 3 enthält vier Lampen. Zwei DALI-Lampen der DALI-Linie 2, eine DALI-Lampe der DALI-Linie 1 und eine dimmbare Standard-Lampe (KL2751). Die DALI-Lampen der DALI-Linie 2 werden einer DALI-Gruppe zugeordnet. Die DALI-Lampe der Linie 1 wird, da sie die einzige DALI-Lampe der DALI-Linie innerhalb dieser Lampengruppe ist, per Kurzadresse angesprochen.


Szenenkaskadierung

Das Objekt Szene bietet die Möglichkeit, eine Serie von Befehlen zu definieren (siehe Standard Szene). Somit können Aktoren durch den Aufruf einer Szene gesteuert werden. Das Besondere bei dem Szenen-Management des TwinCAT Building Automation Frameworks ist die Möglichkeit, dass eine Szene wiederum eine Szene aufrufen kann. Diese Szene kann auch auf einem anderen Controller definiert sein. Der TwinCAT Building Automation Manager legt die notwendigen Netzwerkvariablen an.

Das folgende Beispiel zeigt, wie mit Hilfe der Szenen ein Gebäude mit mehreren Controllern auf Ereignisse automatisch reagiert. Überschreitet die Windgeschwindigkeit einen bestimmten Schwellwert, so sollen alle Beschattungen nach oben gefahren werden.

Eine sinnvolle Variante ist es, auf jedem Controller eine Szene anzulegen, die alle Jalousien des Controllers nach oben fährt. Der Controller, der die Daten der Wetterstation auswertet, aktiviert von allen Controllern diese Szene. Der TwinCAT Building Automation Manager legt beim Aktivieren der Konfiguration die notwendigen Netzwerkvariablen an. Diese werden auch so optimiert, dass die Netzwerkbelastung minimal ist (z.B. durch die Verwendung von Multicast-Netzwerkvariablen). Dadurch werden auf einfache Weise alle Szenen im Gebäude aktiviert, um die Beschattung nach oben zu fahren.

Eine weitere Variante besteht darin, die Szenenaufrufe zu kaskadieren. Bei dem diesem Beispiel erfolgt die Kaskadierung über zwei Ebenen. Pro Etage, gibt es einen Controller, der eine Szene enthält, mit der alle Controller der jeweiligen Etage angesprochen werden. Der Controller mit der Wetterstation, braucht jetzt nicht mehr auf allen Controllern die Szenen aufzurufen. Es ist ausreichend, wenn die Szene aufgerufen wird, die alle weiteren Szene der Etage aktiviert.

Die Kaskadierung bietet die Möglichkeit, flexibler auf Änderungen zu reagieren. Soll eine bestimmte Etage nicht mehr mit berücksichtigt werden, so kann dieses durch das Entfernen eines einzigen Befehls aus der Szene des Controllers mit der Wetterstation erreicht werden.


Ändern von Betriebszuständen

Die Effizienz eines Gebäudes wird durch vielerlei Faktoren bestimmt. Unter anderem von der verwendeten Gebäudeautomatisierung. Je nach Aufbau und Komplexität kann die Effizienz während des Betriebs gesteigert und die Kosten vermindert werden. Eine einfache und effektive Methode ist die zeitliche Einteilung des Gebäudes in die Betriebszustände Haupt- und Nebenzeit.

Dem Projekt werden die Szenen Hauptzeit, Nebenzeit und ein wöchentlicher Zeitschaltkanal (einzelne Wochentage) Betriebswechsel hinzugefügt. Zuerst wird die Szene Hauptzeit konfiguriert.

Hauptzeit

Die Lichtstärke der Beleuchtung soll zur Hauptzeit im Gebäude 100% betragen. Dazu erhält die Szene Hauptzeit für jede Lampengruppe ein Kommandoeintrag im Dialog Kommandos der die maximale Stellgröße ändert. Für die Heizungen wird entsprechend das Energieniveau auf Komfort gesetzt.

Nebenzeit

Zur Nebenzeit werden alle Lampengruppen auf eine maximale Stellgröße von 80% und die Heizungen auf das Energieniveau Bereitschaft gesetzt.

Zeitschaltkanal

Zum Schluss erfolgt die Konfiguration des Zeitschaltkanals im Dialog Einstellungen, damit die Szenen in Abhängigkeit von Wochentag und Uhrzeit aufgerufen werden. Es wird eine normale Arbeitswoche von Montag bis Freitag angenommen in der die Hauptbetriebszeit des Gebäudes von 6 Uhr bis 18 Uhr definiert ist.

Im Dialog Szenen erfolgt die Zuweisung der Szenenaufrufe abhängig vom Zustand des Zeitschaltkanals. Beim Einschalten soll die Hauptzeit Szene und beim Ausschalten die Nebenzeit Szene aufgerufen werden.

Nach Aktivierung der Konfiguration wird das Gebäude zeitgesteuert seine Betriebszustände für die festgelegte Uhrzeit und Wochentage ändern.


Verlinkung von Einspeiseklemmen mit Diagnose

Die Einspeiseklemmen mit Diagnose verfügen über einen Kanal mit zwei Eingangsbits und können daher nicht einfach mit einem digitalen Signal im TwinCAT Building Automation Manager verlinkt werden. Die Schritte gestalten sich etwa anders, um an die Werte zu gelangen.

Vorgehensweise

Zuerst werden die Eingangsbits der Klemme durch SPS-Symbole in die SPS geführt. Erstellen Sie dazu im SPS-Programm zwei Eingangsvariablen vom Typ BOOL und lesen Sie im TwinCAT Building Automation Manager die neu erstellte *.tpy Datei ein. Anschließend verlinken Sie die SPS-Symbole mit den Eingangsbits der Klemme.

Damit die SPS-Symbole wie normale digitale Signale im TwinCAT Building Automation Manager genutzt werden können, müssen Sie noch zwei digitale Signale anlegen und sich die Objekt Ids (siehe Objekt Id) merken. Anhand dieser Objekt Ids können jetzt die angelegten digitalen Signale an beliebiger Stelle im SPS-Programm mit den Werten der SPS-Symbole überschrieben werden.

Downloadbereich

Beispiel anhand der KL9110.

  • KL9110_Beispiel


Übersicht SPS Funktionsblöcke

Die im TwinCAT Building Automation Framework konfigurierten Objekte lassen sich mit den folgenden Funktionsblöcken auch aus der SPS aus nutzen. Leistungsmerkmale, die nicht durch die Standardfunktionen des TwinCAT Building Automation Framework abgedeckt werden, können so mit Hilfe dieser Funktionsblöcke realisiert werden. Enthalten sind die Funktionsblöcke in der SPS-Bibliothek TcBAFramework2.20.lib.

Die Funktionsblöcke sind fest an den jeweiligen Typ gebunden. So kann z.B. mit dem Baustein FB_BAFLampDALI() auch nur eine DALI Lampe angesprochen werden. Wird versucht ein Standard Lampenobjekt oder eine DALI Lampe für die Sicherheitsbeleuchtung anzusprechen, so wird eine Fehlermeldung zurückgegeben.

Sensoren

Name des Funktionsblocks | Beschreibung
FB_BAFDigitalSignalStandard | Funktionsblock zum Steuern eines digitalen Signals.
FB_BAFDigitalSignalEnOcean | Funktionsblock zum Steuern eines digitalen EnOcean Signals.
FB_BAFDigitalSignalSmartSPOT | Funktionsblock zum Steuern eines digitalen (Präsenzmelder) smartSPOT Signals.
FB_BAFDigitalSignalUpDownCounterKL1512 | Funktionsblock zum Steuern eines Vorwärts-/Rückwärts-Zählers per KL1512.
FB_BAFAnalogSignalStandard | Funktionsblock zum Steuern eines analogen Signals.
FB_BAFAnalogSignalEnOcean | Funktionsblock zum Steuern eines analogen EnOcean Signals.
FB_BAFAnalogSignalSmartSPOT | Funktionsblock zum Steuern eines analogen (Helligkeit) smartSPOT Signals.

Aktoren

Name des Funktionsblocks | Beschreibung
FB_BAFLampStandard | Funktionsblock zum Steuern einer Lampe.
FB_BAFLampDALI | Funktionsblock zum Steuern einer DALI Lampe.
FB_BAFLampDALIEmergencyLighting | Funktionsblock zum Steuern einer DALI Lampe für Notbeleuchtung.
FB_BAFBlindDriveStandard | Funktionsblock zum Steuern eines Jalousieantriebs.
FB_BAFBlindDriveKL2532 | Funktionsblock zum Steuern eines Jalousieantriebs verbunden mit KL2532.
FB_BAFWindowDriveStandard | Funktionsblock zum Steuern eines Fensterantriebs.
FB_BAFValveActuator2Point | Funktionsblock zum Steuern eines 2-Punkt Ventil Stellantriebs.
FB_BAFValveActuator3Point | Funktionsblock zum Steuern eines 3-Punkt Ventil Stellantriebs.
FB_BAFValveActuatorContinuous | Funktionsblock zum Steuern eines stetigen Ventil Stellantriebs.

Sensorgruppen

Name des Funktionsblocks | Beschreibung
FB_BAFDigitalSignalGroupStandard | Funktionsblock zum Steuern einer digitalen Signalgruppe.
FB_BAFAnalogSignalGroupStandard | Funktionsblock zum Steuern einer analogen Signalgruppe.

Aktorgruppen

Name des Funktionsblocks | Beschreibung
FB_BAFLampGroupStandard | Funktionsblock zum Steuern einer Lampengruppe.
FB_BAFBlindDriveGroupStandard | Funktionsblock zum Steuern einer Jalousieantriebsgruppe.
FB_BAFWindowDriveGroupStandard | Funktionsblock zum Steuern einer Fensterantriebsgruppe.
FB_BAFValveActuatorGroupStandard | Funktionsblock zum Steuern einer Ventil Stellantriebsgruppe.

Funktionseinheiten

Name des Funktionsblocks | Beschreibung
FB_BAFLightingDimmerSwitch | Funktionsblock zum Steuern eines Dimmers.
FB_BAFLightingStairwellDimmer | Funktionsblock zum Steuern einer Treppenhausbeleuchtung.
FB_BAFLightingTwilightSwitch | Funktionsblock zum Steuern eines Dämmerungsschalters.
FB_BAFLightingDaylightLightControl | Funktionsblock zum Steuern einer tageslichtabhängigen Lichtsteuerung.
FB_BAFLightingConstantLightRegulation | Funktionsblock zum Steuern einer Konstantlichtregelung.
FB_BAFLightingTestsForEmergencyLighting | Funktionsblock zum Steuern eines Funktions- und Dauertests für die Sicherheitsbeleuchtung.
FB_BAFSunblindStandard | Funktionsblock zum Steuern einer Standard Beschattung.
FB_BAFSunblindSuntracking | Funktionsblock zum Steuern der Beschattung in Abhängigkeit des Sonnenstandes.
FB_BAFWindowStandard | Funktionsblock zum Steuern eines Standard Fensters.
FB_BAFHVACHeatingCooling | Funktionsblock zum Steuern einer Heizen und Kühlen Funktionseinheit.

Szenen

Name des Funktionsblocks | Beschreibung
FB_BAFSceneStandard | Funktionsblock zum Steuern einer Szene.

Zeitschaltkanäle

Name des Funktionsblocks | Beschreibung
FB_BAFSchedulerDaily | Funktionsblock zum Steuern eines täglichen Zeitschaltkanals.
FB_BAFSchedulerWeeklyIndividual | Funktionsblock zum Steuern eines wöchentlichen Zeitschaltkanals für einzelne Wochentage.
FB_BAFSchedulerWeeklyContinual | Funktionsblock zum Steuern eines wöchentlichen Zeitschaltkanals für fortlaufende Wochentage.
FB_BAFSchedulerMonthlyNthDay | Funktionsblock zum Steuern eines monatlichen Zeitschaltkanals für den n'ten Tag im Monat.
FB_BAFSchedulerMonthlyIndividualWeekday | Funktionsblock zum Steuern eines monatlichen Zeitschaltkanals für einen einzelnen Wochentag im Monat.

Wetterstationen

Name des Funktionsblocks | Beschreibung
FB_BAFWeatherStationVirtual | Funktionsblock zum Steuern einer virtuellen Wetterstation.
FB_BAFWeatherStationElsnerP03 | Funktionsblock zum Steuern einer Elsner P03 Wetterstation.
FB_BAFWeatherStationThiesClimaSensorD | Funktionsblock zum Steuern einer Thies Clima Sensor D Wetterstation.
FB_BAFWeatherStationAnalogDigitalSignals | Funktionsblock zum Steuern einer Wetterstation aus analogen / digitalen Signalen.

Subsysteme

Name des Funktionsblocks | Beschreibung
FB_BAFPowerMeasurementKL3403 | Funktionsblock zum Steuern einer Energiemessung per KL3403.

Applikation

Name des Funktionsblocks | Beschreibung
FB_BAFApplicationProgram | Funktionsblock zum Steuern der globalen Dienste des Applikationsprogramms.


Objekt Id

Jedes Objekt besitzt eine Id, mit deren Hilfe die Funktionsblöcke die einzelnen Objekte adressieren. Im TwinCAT Building Automation Manager finden Sie die Id in dem gleichen Dialog, in dem auch der Name des Objektes angegeben wird. Diese Id wird bei jedem Funktionsblock als Eingangsparameter mit angegeben. Mit Hilfe dieser Id wird die Verbindung zwischen dem Funktionsblock und dem konfigurierten Objekt im TwinCAT Building Automation Manager hergestellt.

Jede Id beginnt bei 1. Die Obergrenze kann durch das Deklarieren bestimmter Konstanten in der SPS frei festgelegt werden. Weitere Informationen zu den Konstanten finden Sie im Anhang.

Im TwinCAT Building Automation Manager wird die Obergrenze für jeden Objekttyp im Bereich Applikationsprogramm unter dem Dialog Leistungsmerkmale angezeigt. Beachten Sie, dass aus der SPS nur Objekte angesprochen werden können, die im TwinCAT Building Automation Manager angelegt und aktiviert wurden. Wird versucht ein Objekt anzusprechen, das nicht existiert, noch nicht aktiviert wurde oder dessen ID außerhalb des erlaubten Bereichs liegt, so gibt der SPS-Baustein eine Fehlermeldung zurück. Auch können die Objekte nur dann angesprochen werden, wenn sich das gesamte Applikationsprogramm im RUN-Zustand befindet.


SPS Funktionsblock Konstanten

TS8100 | TwinCAT Building Automation Framework V2.2x

Konstanten

In der SPS kann durch das Deklarieren von Konstanten festgelegt werden, wie viele Objekte eines bestimmten Typs angelegt werden können. Ist die entsprechende Konstante nicht vorhanden, so wird der unten aufgelistete Standardwert benutzt.

Wenn Sie eine der Konstanten verändern, so müssen Sie das SPS-Programm neu übersetzen (compilieren). Anschließend muss im TwinCAT Building Automation Manager die *.tpy Datei neu eingelesen und das Projekt neu aktiviert werden.

Auch nicht benutzte Objekte verbrauchen auf dem Zielsystem Ressourcen. Setzen Sie die Konstanten nicht höher als für die Anwendung notwendig. Eine Reserve von ca. 10 % kann hier als Richtwert gelten. Wenn zu erwarten ist, dass Sie z. B. maximal 142 Beleuchtungsaktoren haben, so sollten Sie die Konstante constBAFMaxLamps auf 157 setzen.

Im Folgenden ist ein Beispiel, wie die maximale Anzahl der Beleuchtungen auf 65 und die der Beschattungen auf 0 gesetzt wird.

Im TwinCAT Building Automation Manager wird der Wert der jeweiligen Konstante im Bereich Applikationsprogramm unter dem Dialog Leistungsmerkmale angezeigt.

Die Tabelle zeigt die Namen der einzelnen Konstanten und deren Standardwerte. Wird eine Konstante nicht neu deklariert, so wird der entsprechende Standardwert benutzt.

Sensoren | Name der Konstanten | Standard Wert
Digitale Signale | constBAFMaxDigitalSignals | 80
Analoge Signale | constBAFMaxAnalogSignals | 50
Aktoren |  |
Lampen | constBAFMaxLamps | 80
Jalousieantriebe | constBAFMaxBlindDrives | 60
Ventil Stellantriebe | constBAFMaxValveActuators | 60
Fensterantriebe | constBAFMaxWindowDrives | 60
Sensorgruppen |  |
Digitale Signalgruppen | constBAFMaxDigitalSignalGroups | 80
Analoge Signalgruppen | constBAFMaxAnalogSignalGroups | 50
Aktorgruppen |  |
Lampengruppen | constBAFMaxLampGroups | 80
Jalousieantriebsgruppen | constBAFMaxBlindDriveGroups | 60
Ventil Stellantriebsgruppen | constBAFMaxValveActuatorGroups | 60
Fensterantriebsgruppen | constBAFMaxWindowDriveGroups | 60
Funktionseinheiten |  |
Beleuchtungen | constBAFMaxLightings | 80
Beschattungen | constBAFMaxSunblinds | 60
HLK | constBAFMaxHVACs | 50
Fenster | constBAFMaxWindows | 60
Zusammengesetzte Module |  |
Zusammengesetzte Module | constBAFMaxCompositeModules | 40
Szenen |  |
Szenen | constBAFMaxScenes | 100
Zeitschaltkanäle |  |
Zeitschaltkanäle | constBAFMaxTimeSchedulerChannels | 50
Wetterstationen |  |
Wetterstationen | constBAFMaxWeatherStations | 4
Subsysteme |  |
EnOcean Linien | constBAFMaxEnOceanLines | 8
DALI Linien | constBAFMaxDALILines | 8
Serielle Kommunikations Linien | constBAFMaxSerialCommunicationLines | 4
Energiemessungs Linien | constBAFMaxPowerMeasurementLines | 4


CFC Beispiel

Im Folgenden ist ein Beispiel, in dem zwei digitale Signale (mit der Id 1 und der Id 2) eine Beleuchtung (mit der Id 1) ansteuern. Die Verlinkung zwischen den Tastern und der Beleuchtung finden in diesem Fall nicht im TwinCAT Building Automation Manager statt, sondern durch die manuelle Verbindung der beiden SPS-Bausteine im SPS-Programm.

Die freie Erweiterbarkeit durch eigene SPS-Bausteine ermöglicht es Leistungsmerkmale zu implementieren, die durch die Konfiguration im TwinCAT Building Automation Manager allein nicht möglich sind. Dabei werden alle Darstellungsarten der IEC61131-3 unterstützt. Außerdem stehen dem Programmierer alle TwinCAT Supplements und TwinCAT SPS-Bibliotheken zur Verfügung.


FB_BAFDigitalSignalStandard

Funktionsblock um ein Standard Digitales Signal direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSetCounterDirect                : BOOL;
udiSetCounterDirect              : UDINT;
bChangeOnDelay                   : BOOL;
tChangeOnDelay                   : TIME;
bChangeOffDelay                  : BOOL;
tChangeOffDelay                  : TIME;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des digitalen Signals.

bStopExecution: Stoppt die Instanz des digitalen Signals.

bSetCounterDirect: Setzt den Zähler auf den Wert vom udiSetCounterDirect Eingang.

udiSetCounterDirect: Siehe bSetCounterDirect.

bChangeOnDelay: Setzt die Einschaltverzögerung auf den Wert vom tChangeOnDelay Eingang.

tChangeOnDelay: Siehe bChangeOnDelay.

bChangeOffDelay: Setzt die Ausschaltverzögerung auf den Wert vom tChangeOffDelay Eingang.

tChangeOffDelay: Siehe bChangeOffDelay.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bRawValue                        : BOOL;
bValue                           : BOOL;
udiCounter                       : UDINT;
bRisingEdge                      : BOOL;
bFallingEdge                     : BOOL;
bEdgeChanged                     : BOOL;
bClick                           : BOOL;
bLongClick                       : BOOL;
bDoubleClick                     : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz vom digitalen Signal.

bRawValue: Der Rohwert des digitalen Signals.

bValue: Der Ausgabewert des digitalen Signals.

udiCounter: Der Zählerwert des Signals.

bRisingEdge: Wenn der Ausgang bValue true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bFallingEdge: Wenn der Ausgang bValue true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bEdgeChanged: Wenn der Ausgang bValue true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bClick: Wenn ein Tastendruck (kein doppelter oder langer Tastendruck) erkannt wurde, dann ist dieser Ausgang für einen SPS Zyklus true

bLongClick: Wurde ein langer Tastendruck erkannt, dann ist dieser Ausgang für einen SPS Zyklus true.

bDoubleClick: Wurde ein doppelter Tastendruck erkannt, dann ist dieser Ausgang für einen SPS Zyklus true.


FB_BAFDigitalSignalEnOcean

Funktionsblock um ein EnOcean Digitales Signal direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSetCounterDirect                : BOOL;
udiSetCounterDirect              : UDINT;
bChangeOnDelay                   : BOOL;
tChangeOnDelay                   : TIME;
bChangeOffDelay                  : BOOL;
tChangeOffDelay                  : TIME;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des digitalen Signals.

bStopExecution: Stoppt die Instanz des digitalen Signals.

bSetCounterDirect: Setzt den Zähler auf den Wert vom udiSetCounterDirect Eingang.

udiSetCounterDirect: Siehe bSetCounterDirect.

bChangeOnDelay: Setzt die Einschaltverzögerung auf den Wert vom tChangeOnDelay Eingang.

tChangeOnDelay: Siehe bChangeOnDelay.

bChangeOffDelay: Setzt die Ausschaltverzögerung auf den Wert vom tChangeOffDelay Eingang.

tChangeOffDelay: Siehe bChangeOffDelay.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bRawValue                        : BOOL;
bValue                           : BOOL;
udiCounter                       : UDINT;
bRisingEdge                      : BOOL;
bFallingEdge                     : BOOL;
bEdgeChanged                     : BOOL;
bClick                           : BOOL;
bLongClick                       : BOOL;
bDoubleClick                     : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz vom digitalen Signal.

bRawValue: Der Rohwert des digitalen Signals.

bValue: Der Ausgabewert des digitalen Signals.

udiCounter: Der Zählerwert des Signals.

bRisingEdge: Wenn der Ausgang bValue true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bFallingEdge: Wenn der Ausgang bValue true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bEdgeChanged: Wenn der Ausgang bValue true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bClick: Wenn ein Tastendruck (kein doppelter oder langer Tastendruck) erkannt wurde, dann ist dieser Ausgang für einen SPS Zyklus true

bLongClick: Wurde ein langer Tastendruck erkannt, dann ist dieser Ausgang für einen SPS Zyklus true.

bDoubleClick: Wurde ein doppelter Tastendruck erkannt, dann ist dieser Ausgang für einen SPS Zyklus true.


FB_BAFDigitalSignalSmartSPOT

Funktionsblock um ein DALI smartSPOT Digitales Signal direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSetCounterDirect                : BOOL;
udiSetCounterDirect              : UDINT;
bChangeOnDelay                   : BOOL;
tChangeOnDelay                   : TIME;
bChangeOffDelay                  : BOOL;
tChangeOffDelay                  : TIME;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des digitalen Signals.

bStopExecution: Stoppt die Instanz des digitalen Signals.

bSetCounterDirect: Setzt den Zähler auf den Wert vom udiSetCounterDirect Eingang.

udiSetCounterDirect: Siehe bSetCounterDirect.

bChangeOnDelay: Setzt die Einschaltverzögerung auf den Wert vom tChangeOnDelay Eingang.

tChangeOnDelay: Siehe bChangeOnDelay.

bChangeOffDelay: Setzt die Ausschaltverzögerung auf den Wert vom tChangeOffDelay Eingang.

tChangeOffDelay: Siehe bChangeOffDelay.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bRawValue                        : BOOL;
bValue                           : BOOL;
udiCounter                       : UDINT;
bRisingEdge                      : BOOL;
bFallingEdge                     : BOOL;
bEdgeChanged                     : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz vom digitalen Signal.

bRawValue: Der Rohwert des digitalen Signals.

bValue: Der Ausgabewert des digitalen Signals.

udiCounter: Der Zählerwert des Signals.

bRisingEdge: Wenn der Ausgang bValue true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bFallingEdge: Wenn der Ausgang bValue true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bEdgeChanged: Wenn der Ausgang bValue true wird, dann ist dieser Ausgang für einen SPS Zyklus true.


FB_BAFDigitalSignalCounterKL1512

Funktionsblock um ein Vörwärts-/Rückwärts-Zähler per KL1512 Digitales Signal direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSetCounterDirect                : BOOL;
udiSetCounterDirect              : UDINT;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des digitalen Signals.

bStopExecution: Stoppt die Instanz des digitalen Signals.

bSetCounterDirect: Setzt den Zähler auf den Wert vom udiSetCounterDirect Eingang.

udiSetCounterDirect: Siehe bSetCounterDirect.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
udiCounter                       : UDINT;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz vom digitalen Signal.

udiCounter: Der Zählerwert des Signals.


FB_BAFAnalogSignalStandard

Funktionsblock um ein Standard Analoges Signal direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des analogen Signals.

bStopExecution: Stoppt die Instanz des analogen Signals.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
iAnalogRawValue                  : INT;
lrAnalogScaledValue              : LREAL;
bThresholdSwitch1Value           : BOOL;
bThresholdSwitch1RisingEdge      : BOOL;
bThresholdSwitch1FallingEdge     : BOOL;
bThresholdSwitch2Value           : BOOL;
bThresholdSwitch2RisingEdge      : BOOL;
bThresholdSwitch2FallingEdge     : BOOL;
bReplacementValueUsed            : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz vom analogen Signal.

iAnalogRawValue : Rohwert des analogen Signals.

lrAnalogScaledValue: Skalierter Rohwert des anlogen Signals.

bThresholdSwitch1Value: Aktueller Wert vom Schwellwertschalter 1.

bThresholdSwitch1RisingEdge: Wenn der Schwellwertschalter 1 true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bThresholdSwitch1FallingEdge: Wenn der Schwellwertschalter 1 false wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bThresholdSwitch2Value: Aktueller Wert vom Schwellwertschalter 2.

bThresholdSwitch2RisingEdge: Wenn der Schwellwertschalter 2 true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bThresholdSwitch2FallingEdge: Wenn der Schwellwertschalter 2 false wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bReplacementValueUsed: Gibt an, ob der Ersatzwertbenutzt wird.


FB_BAFAnalogSignalEnOcean

Funktionsblock um ein EnOcean Analoges Signal direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des analogen Signals.

bStopExecution: Stoppt die Instanz des analogen Signals.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
iAnalogRawValue                  : INT;
lrAnalogScaledValue              : LREAL;
bThresholdSwitch1Value           : BOOL;
bThresholdSwitch1RisingEdge      : BOOL;
bThresholdSwitch1FallingEdge     : BOOL;
bThresholdSwitch2Value           : BOOL;
bThresholdSwitch2RisingEdge      : BOOL;
bThresholdSwitch2FallingEdge     : BOOL;
bReplacementValueUsed            : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz vom analogen Signal.

iAnalogRawValue : Rohwert des analogen Signals.

lrAnalogScaledValue: Skalierter Rohwert des anlogen Signals.

bThresholdSwitch1Value: Aktueller Wert vom Schwellwertschalter 1.

bThresholdSwitch1RisingEdge: Wenn der Schwellwertschalter 1 true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bThresholdSwitch1FallingEdge: Wenn der Schwellwertschalter 1 false wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bThresholdSwitch2Value: Aktueller Wert vom Schwellwertschalter 2.

bThresholdSwitch2RisingEdge: Wenn der Schwellwertschalter 2 true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bThresholdSwitch2FallingEdge: Wenn der Schwellwertschalter 2 false wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bReplacementValueUsed: Gibt an, ob der Ersatzwertbenutzt wird.


FB_BAFAnalogSignalDALISmartSPOT

Funktionsblock um ein DALI smartSPOT Analoges Signal direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des analogen Signals.

bStopExecution: Stoppt die Instanz des analogen Signals.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
iAnalogRawValue                  : INT;
lrBrightness                     : LREAL;
bThresholdSwitch1Value           : BOOL;
bThresholdSwitch1RisingEdge      : BOOL;
bThresholdSwitch1FallingEdge     : BOOL;
bThresholdSwitch2Value           : BOOL;
bThresholdSwitch2RisingEdge      : BOOL;
bThresholdSwitch2FallingEdge     : BOOL;
bReplacementValueUsed            : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz vom analogen Signal.

iAnalogRawValue : Rohwert des smartSPOTs.

lrBrightness: Helligkeit in lux.

bThresholdSwitch1Value: Aktueller Wert vom Schwellwertschalter 1.

bThresholdSwitch1RisingEdge: Wenn der Schwellwertschalter 1 true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bThresholdSwitch1FallingEdge: Wenn der Schwellwertschalter 1 false wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bThresholdSwitch2Value: Aktueller Wert vom Schwellwertschalter 2.

bThresholdSwitch2RisingEdge: Wenn der Schwellwertschalter 2 true wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bThresholdSwitch2FallingEdge: Wenn der Schwellwertschalter 2 false wird, dann ist dieser Ausgang für einen SPS Zyklus true.

bReplacementValueUsed: Gibt an, ob der Ersatzwertbenutzt wird.


FB_BAFLampStandard

Funktionsblock um eine Standard Lampe direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bOn                              : BOOL;
bOff                             : BOOL;
bCallMinControlValue             : BOOL;
bCallMaxControlValue             : BOOL;
bSetControlValueDirect           : BOOL;
lrSetControlValueDirect          : LREAL;
bFadeUp                          : BOOL;
bFadeDown                        : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bChangeMaximumControlValue       : BOOL;
lrChangeMaximumControlValue      : LREAL
bChangeMinimumControlValue       : BOOL;
lrChangeMinimumControlValue      : LREAL;
bSetOperatingHourCounterDirect   : BOOL;
udiSetOperatingHourCounterDirect : UDINT;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Lampe.

bStopExecution: Stoppt die Instanz der Lampe.

bOn: Wenn iResettingMode = 1: Die Lampe wird auf den Wert gesetzt der zuvor in lrResettingValue hinterlegt wurde.
Wenn iResettingMode = 0: Die Lampe wird auf lrMaxControlValue gesetzt.

bOff: Wenn iResettingMode = 1: Die Lampe wird ausgeschaltet. Zuvor wird die Stellgröße in lrResettingValue hinterlegt.
Wenn iResettingMode = 0: Die Lampe wird ausgeschaltet ohne die letzte Stellgröße zu speichern.

bCallMinControlValue: Die Stellgröße der Lampe wird auf lrMinControlValue gesetzt.

bCallMaxControlValue: Die Stellgröße der Lampe wird auf lrMaxControlValue gesetzt.

bSetControlValueDirect: Die Stellgröße der Lampe wird auf lrSetControlValueDirect gesetzt.

lrSetControlValueDirect: Der Wert (0% - 100%) auf den die Lampe nach dem bSetControlValueDirect Befehl gesetzt wird. Wird der Wert "0" an die Lampe gesendet schaltet sich diese direkt aus. Stellgrößen unterhalb von lrMinControlValue werden automatisch auf lrMinControlValue erhöht und Stellgrößen oberhalb von lrMaxControlValue werden automatisch auf lrMaxControlValue verringert.

bFadeUp: Erhöht die Stellgröße um lrFadeSteps. Wenn die Lampe ausgeschaltet ist, dann wird der Befehl nicht ausgeführt.

bFadeDown: Verringert die Stellgröße um lrFadeSteps. Es ist nicht möglich die Lampe mit diesem Befehl auszuschalten.

bStepUp: Erhöht den Wert der Lampe um die eingetragene Schrittweite.

bStepDown: Verringert den Wert der Lampe um die eingetragene Schrittweite.

bChangeMaximumControlValue: Die maximale Stellgröße der Lampe wird auf lrChangeMaximumControlValue gesetzt.

lrChangeMaximumControlValue: Bereich (0% - 100%) auf den die maximale Stellgröße der Lampe gesetzt wird, abhängig von bChangeMaximumControlValue.

bChangeMinimumControlValue: Die minimale Stellgröße der Lampe wird auf lrChangeMinimumControlValue gesetzt.

lrChangeMaxMinControlValue: Bereich (0% - 100%) auf den die minimale Stellgröße der Lampe gesetzt wird, abhängig von bChangeMinimumControlValue.

bSetOperatingHourCounterDirect: Der Betriebsstundenzähler der Lampe wird auf udiSetOperatingHourCounterDirect gesetzt.

udiSetOperatingHourCounterDirect: Der Wert, auf dem der Betriebsstundenzähler der Lampe durch den Eingang bSetOperatingHourCounterDirect gesetzt wird. Einheit ist Sekunden.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrControlValue                   : LREAL;
lrResettingValue                 : LREAL;
bReachedMinControlValue          : BOOL;
bReachedMaxControlValue          : BOOL;
udiOperatingHourCounter          : UDINT;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Lampe.

lrControlValue: Stellgröße (0% - 100%) der Lampe.

iResettingValue: Wiedereinschaltwert (0% - 100%) der Lampe.

bReachedMinControlValue: Die Stellgröße der Lampe lrControlValue ist gleich dem Parameter lrMinControlValue.

bReachedMaxControlValue: Die Stellgröße der Lampe lrControlValue ist gleich dem Parameter lrMaxControlValue.

udiOperatingHourCounter: Betriebsstundenzähler der Lampe. Einheit ist Sekunden.


FB_BAFLampDALI

Funktionsblock um eine DALI Lampe direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bOn                              : BOOL;
bOff                             : BOOL;
bCallMinControlValue             : BOOL;
bCallMaxControlValue             : BOOL;
bSetControlValueDirect           : BOOL;
lrSetControlValueDirect          : LREAL;
bFadeUp                          : BOOL;
bFadeDown                        : BOOL;
bChangeMaximumControlValue       : BOOL;
lrChangeMaximumControlValue      : LREAL
bChangeMinimumControlValue       : BOOL;
lrChangeMinimumControlValue      : LREAL;
bSetOperatingHourCounterDirect   : BOOL;
udiSetOperatingHourCounterDirect : UDINT;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Lampe.

bStopExecution: Stoppt die Instanz der Lampe.

bOn: Wenn iResettingMode = 1: Die Lampe wird auf den Wert gesetzt der zuvor in lrResettingValue hinterlegt wurde. Anschließend wird dieser Wert intern an den DALI Bereich (0..254) angepasst und mit dem DALI Befehl DIRECT ARC POWER an die Lampe gesendet.
Wenn iResettingMode = 0: Der DALI Befehl RECALL MAX LEVEL wird gesendet.

bOff: Wenn iResettingMode = 1: Die Lampe wird durch den DALI Befehl OFF ausgeschaltet. Zuvor wird die Stellgröße in lrResettingValue hinterlegt.
Wenn iResettingMode = 0: Die Lampe wird ausgeschaltet ohne die letzte Stellgröße zu speichern.

bCallMinControlValue: Der DALI Befehl RECALL MIN LEVEL wird gesendet.

bCallMaxControlValue: Der DALI Befehl RECALL MAX LEVEL wird gesendet.

bSetControlValueDirect: Die Stellgröße der Lampe wird auf lrSetControlValueDirect gesetzt.

lrSetControlValueDirect: Wenn bSetControlValueDirect gesetzt ist, dann wird der Wert (0% - 100%) intern an den DALI Bereich (0 - 254) angepasst und mit dem DALI Befehl DIRECT ARC POWER an die Lampe gesendet.

bFadeUp: Der DALI Befehl UP wird gesendet.

bFadeDown: Der DALI Befehl DOWN wird gesendet.

bChangeMaximumControlValue: Die maximale Stellgröße der Lampe wird auf lrChangeMaximumControlValue gesetzt.

lrChangeMaximumControlValue: Bereich (0% - 100%) auf den die maximale Stellgröße der Lampe gesetzt wird, abhängig von bChangeMaximumControlValue.

bChangeMinimumControlValue: Die minimale Stellgröße der Lampe wird auf lrChangeMinimumControlValue gesetzt.

lrChangeMaxMinControlValue: Bereich (0% - 100%) auf den die minimale Stellgröße der Lampe gesetzt wird, abhängig von bChangeMinimumControlValue.

bSetOperatingHourCounterDirect: Der Betriebsstundenzähler der Lampe wird auf udiSetOperatingHourCounterDirect gesetzt.

udiSetOperatingHourCounterDirect: Der Wert, auf dem der Betriebsstundenzähler der Lampe durch den Eingang bSetOperatingHourCounterDirect gesetzt wird. Einheit ist Sekunden.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrControlValue                   : LREAL;
lrResettingValue                 : LREAL;
bReachedMinControlValue          : BOOL;
bReachedMaxControlValue          : BOOL;
udiOperatingHourCounter          : UDINT;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Lampe.

lrControlValue: Stellgröße (0% - 100%) der Lampe.

iResettingValue: Wiedereinschaltwert (0% - 100%) der Lampe.

bReachedMinControlValue: Die Stellgröße der Lampe lrControlValue ist gleich dem Parameter lrMinControlValue.

bReachedMaxControlValue: Die Stellgröße der Lampe lrControlValue ist gleich dem Parameter lrMaxControlValue.

udiOperatingHourCounter: Betriebsstundenzähler der Lampe. Einheit ist Sekunden.


FB_BAFLampDALIEmergencyLighting

Funktionsblock um eine DALI Lampe für Notbeleuchtung direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bOn                              : BOOL;
bOff                             : BOOL;
bCallMinControlValue             : BOOL;
bCallMaxControlValue             : BOOL;
bSetControlValueDirect           : BOOL;
lrSetControlValueDirect          : LREAL;
bFadeUp                          : BOOL;
bFadeDown                        : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bStartFunctionTest               : BOOL;
bStartDurationTest               : BOOL;
bChangeMaximumControlValue       : BOOL;
lrChangeMaximumControlValue      : LREAL
bChangeMinimumControlValue       : BOOL;
lrChangeMinimumControlValue      : LREAL;
bSetOperatingHourCounterDirect   : BOOL;
udiSetOperatingHourCounterDirect : UDINT;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Lampe.

bStopExecution: Stoppt die Instanz der Lampe.

bOn: Wenn iResettingMode = 1: Die Lampe wird auf den Wert gesetzt der zuvor in lrResettingValue hinterlegt wurde. Anschließend wird dieser Wert intern an den DALI Bereich (0..254) angepasst und mit dem DALI Befehl DIRECT ARC POWER an die Lampe gesendet.
Wenn iResettingMode = 0: Der DALI Befehl RECALL MAX LEVEL wird gesendet.

bOff: Wenn iResettingMode = 1: Die Lampe wird durch den DALI Befehl OFF ausgeschaltet. Zuvor wird die Stellgröße in lrResettingValue hinterlegt.
Wenn iResettingMode = 0: Die Lampe wird ausgeschaltet ohne die letzte Stellgröße zu speichern.

bCallMinControlValue: Der DALI Befehl RECALL MIN LEVEL wird gesendet.

bCallMaxControlValue: Der DALI Befehl RECALL MAX LEVEL wird gesendet.

bSetControlValueDirect: Die Stellgröße der Lampe wird auf lrSetControlValueDirect gesetzt.

lrSetControlValueDirect: Wenn bSetControlValueDirect gesetzt ist, dann wird der Wert (0% - 100%) intern an den DALI Bereich (0 - 254) angepasst und mit dem DALI Befehl DIRECT ARC POWER an die Lampe gesendet.

bFadeUp: Erhöht den Lichtwert um die eingetragene Dimmstufe.

bFadeDown: Verringert den Lichtwert um die eingetragene Dimmstufe.

bStepUp: Erhöht den Wert der Lampe um die eingetragene Schrittweite.

bStepDown: Verringert den Wert der Lampe um die eingetragene Schrittweite.

bStartFunctionTest: Ein Funktionstest wird gestartet.

bStartDurationTest: Ein Dauertest wird gestartet.

bChangeMaximumControlValue: Die maximale Stellgröße der Lampe wird auf lrChangeMaximumControlValue gesetzt.

lrChangeMaximumControlValue: Bereich (0% - 100%) auf den die maximale Stellgröße der Lampe gesetzt wird, abhängig von bChangeMaximumControlValue.

bChangeMinimumControlValue: Die minimale Stellgröße der Lampe wird auf lrChangeMinimumControlValue gesetzt.

lrChangeMaxMinControlValue: Bereich (0% - 100%) auf den die minimale Stellgröße der Lampe gesetzt wird, abhängig von bChangeMinimumControlValue.

bSetOperatingHourCounterDirect: Der Betriebsstundenzähler der Lampe wird auf udiSetOperatingHourCounterDirect gesetzt.

udiSetOperatingHourCounterDirect: Der Wert, auf dem der Betriebsstundenzähler der Lampe durch den Eingang bSetOperatingHourCounterDirect gesetzt wird. Einheit ist Sekunden.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrControlValue                   : LREAL;
lrResettingValue                 : LREAL;
bReachedMinControlValue          : BOOL;
bReachedMaxControlValue          : BOOL;
udiOperatingHourCounter          : UDINT;
tElapsedTestTime                 : TIME;
byEmergencyMode                  : BYTE;
byEmergencyStatus                : BYTE;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Lampe.

lrControlValue: Stellgröße (0% - 100%) der Lampe.

iResettingValue: Wiedereinschaltwert (0% - 100%) der Lampe.

bReachedMinControlValue: Die Stellgröße der Lampe lrControlValue ist gleich dem Parameter lrMinControlValue.

bReachedMaxControlValue: Die Stellgröße der Lampe lrControlValue ist gleich dem Parameter lrMaxControlValue.

udiOperatingHourCounter: Betriebsstundenzähler der Lampe. Einheit ist Sekunden.

tElapsedTestTime: Wenn der Test bereits läuft, dann zeigt dieser Ausgang die bereits verstrichene Zeit an. Der Ausgang wird seine Ergebnisse nach Ende des Tests beibehalten.

byEmergencyMode: Zeigt den Notfallmodus während eines Tests an. Wenn kein Test läuft, dann wird dieses DALI spezifische Zustands Byte nicht automatisch aktualisiert.

byEmergencyState: Zeigt den Notfallzustand während eines Tests an. Wenn kein Test läuft, dann wird dieses DALI spezifische Zustands Byte nicht automatisch aktualisiert.


FB_BAFBlindDriveStandard

Funktionsblock um einen Standard Jalousieantrieb direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSafetyPositionSet               : BOOL;
bSafetyPositionReset             : BOOL;
bUp                              : BOOL;
bDown                            : BOOL;
bStop                            : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bSetPositionDirect               : BOOL;
lrSetPositionDirect              : LREAL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des Jalousieantriebs.

bStopExecution: Stoppt die Instanz des Jalousieantriebs.

bSafetyPositionSet: Anfahren der Sicherheitsposition ist aktiv. In diesem Fall wird die Jalousie tDriveTime + 10% hochgefahren. Keine anderen Befehle, außer bSafetyPositionReset, werden in dieser Zeit akzeptiert.

bSafetyPositionReset: Freigabe der Sicherheitsposition.

bUp: Fährt die Jalousie hoch.

bDown: Fährt die Jalousie runter.

bStop: Hält die Jalousie an.

bStepUp: Fährt die Jalousie für tStepTime hoch.

bStepDown: Fährt die Jalousie für tStepTime runter.

bSetPositionDirect: Die Jalousie wird zur von lrSetPositionDirect vorgegebenen Position gefahren.

lrSetPositionDirect: Siehe bSetPositionDirect. 0% entspricht vollständig geöffnet, 100% vollständig geschlossen.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bSafetyPosition                  : BOOL;
bDriveUp                         : BOOL;
bDriveDown                       : BOOL;
lrActualPosition                 : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz des Jalousieantriebs.

bSafetyPosition: Das Anfahren der Sicherheitsposition wurde aktiviert.

bDriveUp: Die Jalousie fährt hoch.

bDriveDown: Die Jalousie fährt runter.

lrActualPosition: Die Position (0% - 100%) des Jalousieantriebs.


FB_BAFBlindDriveKL2532

Funktionsblock um einen Jalousieantrieb verbunden mit KL2532 direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSafetyPositionSet               : BOOL;
bSafetyPositionReset             : BOOL;
bUp                              : BOOL;
bDown                            : BOOL;
bUpSlow                          : BOOL;
bDownSlow                        : BOOL;
bStop                            : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bSetPositionAngleDirect          : BOOL;
lrSetPositionDirect              : LREAL;
lrSetAngleDirect                 : LREAL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des Jalousieantriebs.

bStopExecution: Stoppt die Instanz des Jalousieantriebs.

bSafetyPositionSet: Anfahren der Sicherheitsposition ist aktiv. In diesem Fall wird die Jalousie für tDriveTime + 10% hochgefahren. Keine anderen Befehle, außer bSafetyPositionReset, werden in dieser Zeit akzeptiert.

bSafetyPositionReset: Freigabe der Sicherheitsposition.

bUp: Fährt die Jalousie hoch.

bDown: Fährt die Jalousie runter.

bUpSlow: Fährt die Jalousie langsam hoch.

bDownSlow: Fährt die Jalousie langsam runter.

bStop: Hält die Jalousie an.

bStepUp: Fährt die Jalousie für tStepTime hoch.

bStepDown: Fährt die Jalousie für tStepTime runter.

bSetPositionAngleDirect: Der Jalousieantrieb fährt den unter lrSetAngleDirect angegebenen Winkel an. Das BA-Framework Element Standard Jalousieantrieb Unterstützt nicht das Anfahren eines Winkels - im Gegensatz zum Jalousieantrieb verbunden mit KL2532 - dieser Befehl wird nur Auswirkungen auf die Position haben.

lrSetPositionDirect: 0% entspricht vollständig geöffnet, 100% vollständig geschlossen.

lrSetAngleDirect: Siehe bSetPositionAngleDirect.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bSafetyPosition                  : BOOL;
bDriveUp                         : BOOL;
bDriveDown                       : BOOL;
lrActualPosition                 : LREAL;
lrActualPositionMM               : LREAL;
uiCounterReversing               : UINT;
lrVelocity                       : LREAL;
byVelocity                       : BYTE;
uiAmountOfCalibrations           : UINT;
bCalibratingReady                : BOOL;
eOperatingMode                   : E_BAF_SuntrackingOperatingMode;
lrLastDrivenAngle                : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz des Jalousieantriebs.

bSafetyPosition: Das Anfahren der Sicherheitsposition wurde aktiviert.

bDriveUp: Die Jalousie fährt hoch.

bDriveDown: Die Jalousie fährt runter.

lrActualPosition: Die aktuelle Position in Prozent.

lrActualPositionMM: Die aktuelle Position in Millimetern.

uiCounterReversing: Der Zähler im Reversierungsmodus.

lrVelocity: Aktuelle Geschwindigkeit in [mm/s].

byVelocity: Aktuelle Geschwindigkeit in [%].

uiAmountOfCalibrations: Anzahl der Kalibrierungen.

bCalibratingReady: Achse ist Kalibriert.

eOperatingMode: Aktueller Ausführungszustand.

lrLastDrivenAngle: Zuletzt angefahrener Winkel.


FB_BAFWindowDriveStandard

Funktionsblock um einen Standard Fensterantrieb direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSafetyPositionSet               : BOOL;
bSafetyPositionReset             : BOOL;
bClose                           : BOOL;
bOpen                            : BOOL;
bStop                            : BOOL;
bSetPositionDirect               : BOOL;
lrSetPositionDirect              : LREAL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des Fensterantriebs.

bStopExecution: Stoppt die Instanz des Fensterantriebs.

bSafetyPositionSet: Anfahren der Sicherheitsposition ist aktiv. In diesem Fall wird der Fensterantrieb für tDriveTime + 10% hochgefahren. Keine anderen Befehle, außer bSafetyPositionReset, werden in dieser Zeit akzeptiert.

bSafetyPositionReset: Freigabe der Sicherheitsposition.

bClose: Das Fenster wird geschlossen.

bOpen: Das Fenster wird geöffnet.

bStop: Hält den Fensterantrieb an.

bSetPositionDirect: Der Fensterantrieb wird zur von lrSetPositionDirect vorgegebenen Position gefahren.

lrSetPositionDirect: Siehe bSetPositionDirect. 0% entspricht vollständig geschlossen, 100% vollständig geöffnet.

VAR_OUTPUT

uiErrorId                       : UINT;
iErrorParameter                 : INT;
eExecutionState                 : E_BAF_ExecutionState;
bSafetyPosition                 : BOOL;
bDriveClose                     : BOOL;
bDriveOpen                      : BOOL;
lrActualPosition                : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz des Fensterantriebs.

bSafetyPosition: Das Anfahren der Sicherheitsposition wurde aktiviert.

bDriveClose: Das Fenster schließt sich.

bDriveOpen: Das Fenster öffnet sich.

lrActualPosition: Die Position (0% - 100%) des Fensterantriebs.


FB_BAFValveActuator2Point

Funktionsblock um einen 2-Punkt Ventil Stellantrieb direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bClose                           : BOOL;
bOpen                            : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des Ventil Stellantriebs.

bStopExecution: Stoppt die Instanz des Ventil Stellantriebs.

bClose: Schließt das Ventil.

bOpen: Öffnet das Ventil.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bDriveClose                      : BOOL;
bDriveOpen                       : BOOL;
lrControlValue                   : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand des Ventil Stellantriebs.

bDriveClose: Das Ventil schließt sich.

bDriveOpen: Das Ventil öffnet sich.

lrControlValue: Stellgröße zwischen 0% und 100%.


FB_BAFValveActuator3Point

Funktionsblock um einen 3-Punkt Ventil Stellantrieb direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bClose                           : BOOL;
bOpen                            : BOOL;
bStop                            : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des Ventil Stellantriebs.

bStopExecution: Stoppt die Instanz des Ventil Stellantriebs.

bClose: Schließt das Ventil.

bOpen: Stopp öffnen/schließen des Ventils.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bDriveClose                      : BOOL;
bDriveOpen                       : BOOL;
lrControlValue                   : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand des Ventil Stellantriebs.

bDriveClose: Das Ventil schließt sich.

bDriveOpen: Das Ventil öffnet sich.

lrControlValue: Stellgröße zwischen 0% und 100%.


FB_BAFValveActuatorContinuous

Funktionsblock um einen Stetigen Ventil Stellantrieb direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bClose                           : BOOL;
bOpen                            : BOOL;
bSetControlValueDirect           : BOOL;
lrSetControlValueDirect          : LREAL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des Ventil Stellantriebs.

bStopExecution: Stoppt die Instanz des Ventil Stellantriebs.

bSetPositionDirect: Das Ventil öffnet sich bis zur unter lrSetPositionDirect angegebenen Position.

lrSetPositionDirect: Siehe bSetPositionDirect. 0% entspricht geschlossen, 100% vollständig geöffnet.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrControlValue                   : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand des Ventil Stellantriebs.

lrControlValue: Stellgröße zwischen 0% und 100%.


FB_BAFDigitalSignalGroupStandard

Funktionsblock um eine Standard Digitale Signalgruppe direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bChangeOnDelay                   : BOOL;
tChangeOnDelay                   : TIME;
bChangeOffDelay                  : BOOL;
tChangeOffDelay                  : TIME;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der digitalen Signalgruppe.

bStopExecution: Stoppt die Instanz der digitalen Signalgruppe.

bChangeOnDelay: Setzt die Einschaltverzögerung auf den Wert vom Eingang tChangeOnDelay.

tChangeOnDelay: Siehe bChangeOnDelay.

bChangeOffDelay: Setzt die Ausschaltverzögerung auf den Wert vom Eingang tChangeOffDelay.

tChangeOffDelay: Siehe bChangeOffDelay.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
udiAmountOfSignals               : UDINT;
udiAmountOfFaultySignals         : UDINT;
udiAmountOfActiveSignals         : UDINT;
bRawValue                        : BOOL;
bValue                           : BOOL;
bRisingEdge                      : BOOL;
bFallingEdge                     : BOOL;
bEdgeChanged                     : BOOL;
bClick                           : BOOL;
bLongClick                       : BOOL;
bDoubleClick                     : BOOL;
tRemainingTimeOnDelay            : TIME;
tRemainingTimeOffDelay           : TIME;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der digitalen Signalgruppe.

udiAmountOfSignals: Anzahl digitaler Signale die zu dieser Gruppe gehören.

udiAmountOfFaultySignals: Anzahl digitaler Signale die zu dieser Gruppe gehören und sich in einem Fehlerzustand befinden (uiErrorId > 0).

udiAmountOfActiveSignals: Anzahl digitaler Signale die zu dieser Gruppe gehören und aktiv sind.

bRawValue: Der bValue Ausgang des digitalen Signals kann verzögert sein. Dieser Ausgang zeigt das Ergebnis der ODER-Verknüpfung der nicht verzögerten Signalzustände der digitalen Signale dieser Gruppe an.

bValue: Dieses Signal ist das Ergebnis der ODER-Verknüpfung aller bValue Ausgänge der digitalen Signale dieser Gruppe.

bRisingEdge: Die ansteigende Flanke von bValue dieser Gruppe.

bFallingEdge: Die fallende Flanke von bValue dieser Gruppe.

bEdgeChanged: Ein Flankenwechsel von bValue dieser Gruppe.

bClick: Ein kurzer Tastendruck in der Gruppe wurde erkannt.

bLongClick: Ein langer Tastendruck in der Gruppe wurde erkannt.

bDoubleClick: Ein doppelter Tastendruck in der Gruppe wurde erkannt.

tRemainingTimeOnDelay: Zeigt die verbleibende Zeit der Einschaltverzögerung.

tRemainingTimeOffDelay: Zeigt die verbleibende Zeit der Ausschaltverzögerung.


FB_BAFAnalogSignalGroupStandard

Funktionsblock um eine Standard Analoge Signalgruppe direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der analogen Signalgruppe.

bStopExecution: Stoppt die Instanz der analogen Signalgruppe.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
udiAmountOfSignals               : UDINT;
udiAmountOfFaultySignals         : UDINT;
iAverageRawValue                 : INT;
lrAverageValue                   : LREAL;
bThresholdSwitch1Value           : BOOL;
bThresholdSwitch1RisingEdge      : BOOL;
bThresholdSwitch1FallingEdge     : BOOL;
bThresholdSwitch2Value           : BOOL;
bThresholdSwitch2RisingEdge      : BOOL;
bThresholdSwitch2FallingEdge     : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der analogen Signalgruppe.

udiAmountOfSignals: Anzahl analoger Signale die zu dieser Gruppe gehören.

udiAmountOfFaultySignals: Anzahl analoger Signale die zu dieser Gruppe gehören und sich in einem Fehlerzustand befinden (uiErrorId > 0).

iAverageRawValue: Durchschnitt der Rohwerte aller analogen Signale dieser Gruppe.

lrAverageValue : Durchschnittswert aller analogen Signale dieser Gruppe.

bThresholdSwitch1Value: Bereich 1 des Schwellwertschalters wurde erreicht.

bThresholdSwitch1RisingEdge: Schwellwertbereich 1 wurde erreicht - steigende Flanke.

bThresholdSwitch1FallingEdge: Schwellwertbereich 1 wurde erreicht - fallende Flanke.

bThresholdSwitch2Value: Bereich 2 des Schwellwertschalters wurde erreicht.

bThresholdSwitch2RisingEdge: Schwellwertbereich 2 wurde erreicht - steigende Flanke.

bThresholdSwitch2FallingEdge: Schwellwertbereich 2 wurde erreicht - fallende Flanke.


FB_BAFLampGroupStandard

Funktionsblock um eine Standard Lampengruppe direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bOn                              : BOOL;
bOff                             : BOOL;
bCallMinControlValue             : BOOL;
bCallMaxControlValue             : BOOL;
bSetControlValueDirect           : BOOL;
lrSetControlValueDirect          : LREAL;
bFadeUp                          : BOOL;
bFadeDown                        : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bStartFunctionTest               : BOOL;
bStartDurationTest               : BOOL;
bChangeMaximumControlValue       : BOOL;
lrChangeMaximumControlValue      : LREAL;
bChangeMinimumControlValue       : BOOL;
lrChangeMinimumControlValue      : LREAL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Lampengruppe.

bStopExecution: Stoppt die Instanz der Lampengruppe.

bOn: Der bOn Befehl aller Lampen in dieser Gruppe wird ausgeführt.

bOff: Der bOff Befehl aller Lampen in dieser Gruppe wird ausgeführt.

bCallMinControlValue: Der bCallMinControlValue Befehl aller Lampen in dieser Gruppe wird ausgeführt.

bCallMaxControlValue: Der bCallMaxControlValue Befehl aller Lampen in dieser Gruppe wird ausgeführt.

bSetControlValueDirect: Der bSetControlValueDirect Befehl aller Lampen in dieser Gruppe wird ausgeführt.

lrSetControlValueDirect: Wenn bSetControlValueDirect gesetzt ist, dann wird der Wert dieser Variablen (0% - 100%) an alle Lampen in der Gruppe weitergegeben.

bFadeUp: Der bFadeUp Befehl aller Lampen in dieser Gruppe wird ausgeführt.

bFadeDown: Der bFadeDown Befehl aller Lampen in dieser Gruppe wird ausgeführt.

bStepUp: Der bStepUp Befehl aller Lampen in dieser Gruppe wird ausgeführt.

bStepDown: Der bStepDown Befehl aller Lampen in dieser Gruppe wird ausgeführt.

bStartFunctionTest: Ein Funktionstest für alle DALI Notbeleuchtungen wird gestartet. Alle anderen Lampen in dieser Gruppe ignorieren diesen Befehl.

bStartDurationTest: Ein Dauertest für alle DALI Notbeleuchtungen wird gestartet. Alle anderen Lampen in dieser Gruppe ignorieren diesen Befehl.

bChangeMaximumControlValue: Der bChangeMaximumControlValue Befehl aller Lampen in dieser Gruppe wird ausgeführt.

lrChangeMaximumControlValue: Wenn bChangeMaximumControlValue gesetzt ist, dann wird der Wert dieser Variablen (0% - 100%) zum Maximalwert alle Lampen weitergegeben.

bChangeMinimumControlValue: Der bChangeMinimumControlValue- Befehl aller Lampen in dieser Gruppe wird ausgeführt.

lrChangeMinimumControlValue: Wenn bChangeMinimumControlValue gesetzt ist, dann wird der Wert dieser Variablen (0% - 100%) zum Minimalwert alle Lampen weitergegeben.

VAR_OUTPUT

uiErrorId                           : UINT;
iErrorParameter                     : INT;
eExecutionState                     : E_BAF_ExecutionState;
udiAmountOfLamps                    : UDINT;
udiAmountOfFaultyLamps              : UDINT;
udiAmountOfActiveLamps              : UDINT;
lrAverageControlValue               : LREAL;
lrAverageResettingValue             : LREAL;
udiAmountOfLampsWithMinControlValue : UDINT;
udiAmountOfLampsWithMaxControlValue : UDINT;

udiAmountOfSignals: Anzahl Lampen die zu dieser Gruppe gehören.

udiAmountOfFaultySignals: Anzahl Lampen die zu dieser Gruppe gehören und sich in einem Fehlerzustand befinden (uiErrorId > 0).

udiAmountOfActiveSignals: Anzahl digitaler Signale die zu dieser Gruppe gehören und aktiv sind.

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Lampengruppe.

udiAmountOfLamps: Anzahl aller Lampen die zu dieser Gruppe gehören.

udiAmountOfFaultyLamps: Anzahl aller Lampen die zu dieser Gruppe gehören und sich in einem Fehlerzustand befinden (uiErrorId > 0).

udiAmountOfActiveLamps: Anzahl aller aktiven Lampen die zu dieser Gruppe gehören. Die Stellgröße muss größer als 0 und die nErrorId 0 sein.

lrAverageControlValue: Die durchschnittliche Stellgröße aller Lampen in dieser Gruppe die sich nicht in einem Fehlerzustand befinden.

lrAverageResettingValue: Der durchschnittliche Wiedereinschaltwert aller Lampen in dieser Gruppe die sich nicht in einem Fehlerzustand befinden.

udiAmountOfLampsWithMinControlValue: Anzahl aller Lampen in der Gruppe die sich nicht in einem Fehlerzustand befinden und deren bReachedMinControlValue Ausgang gesetzt ist.

udiAmountOfLampsWithMaxControlValue: Anzahl aller Lampen in der Gruppe die sich nicht in einem Fehlerzustand befinden und deren bReachedMaxControlValue Ausgang gesetzt ist.


FB_BAFBlindDriveGroupStandard

Funktionsblock um eine Standard Jalousieantriebsgruppe direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                              : UINT;
bStartExecution                   : BOOL;
bStopExecution                    : BOOL;
bSafetyPositionSet                : BOOL;
bSafetyPositionReset              : BOOL;
bUp                               : BOOL;
bDown                             : BOOL;
bStop                             : BOOL;
bStepUp                           : BOOL;
bStepDown                         : BOOL;
bSetPositionAngleDirect           : BOOL;
lrSetPositionDirect               : LREAL;
lrSetAngleDirect                  : LREAL;
bDriveToFavoritePosition          : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Jalousieantriebsgruppe.

bStopExecution: Stoppt die Instanz der Jalousieantriebsgruppe.

bSafetyPositionSet: Führt den bSafetyPositionSet Befehl für alle Jalousieantriebe in dieser Gruppe aus.

bSafetyPositionReset : Führt den bSafetyPositionReset Befehl für alle Jalousieantriebe in dieser Gruppe aus.

bUp : Führt den bUp Befehl für alle Jalousieantriebe in dieser Gruppe aus.

bDown: Führt den bDown Befehl für alle Jalousieantriebe in dieser Gruppe aus.

bStop : Führt den bStop Befehl für alle Jalousieantriebe in dieser Gruppe aus.

bStepUp : Führt den bStepUp Befehl für alle Jalousieantriebe in dieser Gruppe aus.

bStepDown: Führt den bStepDown Befehl für alle Jalousieantriebe in dieser Gruppe aus.

bSetPositionAngleDirect: Die Jalousieantriebe werden an die unter lrSetPositionDirect angegebene Position [0%..100%] gefahren. Das BA-Framework Element Standard Jalousieantrieb Unterstützt nicht das Anfahren eines Winkels - im Gegensatz zum Jalousieantrieb verbunden mit KL2532 - dieser Befehl wird nur Auswirkungen auf die Position haben.

lrSetPositionDirect: Spezifische Position zu der die Jalousien gefahren werden.

lrSetAngleDirect: Spezifischer Winkel auf den die Jalousien gefahren werden.

bDriveToFavoritePosition: Die Jalousieantriebe fahren die bevorzugte Position an.

VAR_OUTPUT

uiErrorId                         : UINT;
iErrorParameter                   : INT;
eExecutionState                   : E_BAF_ExecutionState;
udiAmountOfBlindDrives            : UDINT;
udiAmountOfFaultyBlindDrives      : UDINT;
udiAmountOfDriveUp                : UDINT;
udiAmountOfDriveDown              : UDINT;
udiAmountOfActiveSafetyPosition   : UDINT;
lrAveragePosition                 : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Jalousieantriebsgruppe.

udiAmountOfBlindDrives: Anzahl Jalousieantriebe die zu dieser Gruppe gehören.

udiAmountOfFaultyBlindDrives: Anzahl Jalousieantriebe die zu dieser Gruppe gehören und sich in einem Fehlerzustand befinden (uiErrorId > 0).

udiAmountOfDriveUp: Anzahl Jalousieantriebe die zu dieser Gruppe gehören und sich gerade öffnen (uiErrorId muss 0 sein).

udiAmountOfDriveDown: Anzahl Jalousieantriebe die zu dieser Gruppe gehören und sich gerade schließen (uiErrorId muss 0 sein).

udiAmountOfActiveSafetyPosition: Anzahl Jalousieantriebe die zu dieser Gruppe gehören und sich derzeit in der Sicherheitsposition befinden (uiErrorId muss 0 sein).

lrAveragePosition: Die durchschnittliche Position (0% - 100%) aller aktiven Jalousieantriebe in dieser Gruppe.


FB_BAFWindowDriveGroupStandard

Funktionsblock um eine Standard Fensterantriebsgruppe direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                              : UINT;
bStartExecution                   : BOOL;
bStopExecution                    : BOOL;
bSafetyPositionSet                : BOOL;
bSafetyPositionReset              : BOOL;
bClose                            : BOOL;
bOpen                             : BOOL;
bStop                             : BOOL;
bSetPositionDirect                : BOOL;
lrSetPositionDirect               : LREAL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Fensterantriebsgruppe.

bStopExecution: Stoppt die Instanz der Fensterantriebsgruppe.

bSafetyPositionSet: Führt den bSafetyPositionSet Befehl für alle Fensterantriebsgruppe in dieser Gruppe aus.

bSafetyPositionReset: Führt den bSafetyPositionReset Befehl für alle Fensterantriebsgruppe in dieser Gruppe aus.

bClose: Führt den bClose Befehl für alle Fensterantriebsgruppe in dieser Gruppe aus.

bOpen: Führt den bOpen Befehl für alle Fensterantriebsgruppe in dieser Gruppe aus.

bStop: Führt den bStop Befehl für alle Fensterantriebsgruppe in dieser Gruppe aus.

bSetPositionDirect: Alle Fensterantriebe in dieser Gruppe werden die unter lrSetPositionDirect angegebene Position anfahren.

lrSetPositionDirect: Siehe bSetPositionDirect. 0% entspricht geschlossen, 100% vollständig geöffnet.

VAR_OUTPUT

uiErrorId                         : UINT;
iErrorParameter                   : INT;
eExecutionState                   : E_BAF_ExecutionState;
udiAmountOfWindowDrives           : UDINT;
udiAmountOfFaultyWindowDrives     : UDINT;
udiAmountOfDriveClose             : UDINT;
udiAmountOfDriveOpen              : UDINT;
udiAmountOfActiveSafetyPosition   : UDINT;
lrAveragePosition                 : LREAL;
iValue                            : INT;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Fensterantriebsgruppe.

udiAmountOfValveActuators: Anzahl Fensterantriebe die zu dieser Gruppe gehören.

udiAmountOfFaultyValveActuators: Anzahl Fensterantriebe die zu dieser Gruppe gehören und sich in einem Fehlerzustand befinden (uiErrorId > 0).

udiAmountOfValveActuatorDriveClose: Anzahl Fensterantriebe die zu dieser Gruppe gehören und sich gerade schließen (uiErrorId muss 0 sein).

udiAmountOfValveActuatorDriveOpen: Anzahl Fensterantriebe die zu dieser Gruppe gehören und sich gerade öffnen (uiErrorId muss 0 sein).

udiAmountOfActiveSafetyPosition: Anzahl Fensterantriebe die zu dieser Gruppe gehören und sich derzeit in der Sicherheitsposition befinden (uiErrorId muss 0 sein).

lrAveragePosition: Die durchschnittliche Position (0% - 100%) aller aktiven Fensterantriebe in dieser Gruppe.

iValue: Wert der Fensterantriebsgruppe.


FB_BAFValveActuatorGroupStandard

Funktionsblock um eine Standard Ventil Stellantriebsgruppe direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                              : UINT;
bStartExecution                   : BOOL;
bStopExecution                    : BOOL;
bClose                            : BOOL;
bOpen                             : BOOL;
bStop                             : BOOL;
bSetControlValueDirect            : BOOL;
lrSetControlValueDirect           : LREAL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Ventil Stellantriebsgruppe.

bStopExecution: Stoppt die Instanz der Ventil Stellantriebsgruppe.

bClose: Der bClose Befehl aller Ventile in dieser Gruppe wird ausgeführt.

bOpen: Der bOpen Befehl aller Ventile in dieser Gruppe wird ausgeführt.

bStop: Der bStop Befehl aller Ventile in dieser Gruppe wird ausgeführt.

bSetControlValueDirect: Der bSetControlValueDirect Befehl aller Ventile in dieser Gruppe wird ausgeführt.

lrSetControlValueDirect: Nach dem Senden des bSetControlValueDirect Befehls werden alle Ventile der Gruppe diesen Wert anfahren. 0% entspricht geschlossen, 100% vollständig geöffnet.

VAR_OUTPUT

uiErrorId                          : UINT;
iErrorParameter                    : INT;
eExecutionState                    : E_BAF_ExecutionState;
udiAmountOfValveActuators          : UDINT;
udiAmountOfFaultyValveActuators    : UDINT;
udiAmountOfValveActuatorDriveClose : UDINT;
udiAmountOfValveActuatorDriveOpen  : UDINT;
lrAverageControlValue              : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Ventilgruppe.

udiAmountOfValveActuators: Anzahl Ventile die zu dieser Gruppe gehören.

udiAmountOfFaultyValveActuators: Anzahl Ventile die zu dieser Gruppe gehören und sich in einem Fehlerzustand befinden (uiErrorId > 0).

udiAmountOfValveActuatorDriveClose: Anzahl Ventile die zu dieser Gruppe gehören und sich gerade schließen (uiErrorId muss 0 sein).

udiAmountOfValveActuatorDriveOpen: Anzahl Ventile die zu dieser Gruppe gehören und sich gerade öffnen (uiErrorId muss 0 sein).

lrAverageControlValue: Die durchschnittliche Position aller Ventile in dieser Gruppe die sich nicht in einem Fehlerzustand befinden.


FB_BAFLightingDimmerSwitch

Funktionsblock um einen Dimmer direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bOn                              : BOOL;
bOff                             : BOOL;
bToggleLastControlValue          : BOOL;
bToggleMaxControlValue           : BOOL;
bCallMinControlValue             : BOOL;
bCallMaxControlValue             : BOOL;
bSetControlValueDirect           : BOOL;
lrSetControlValueDirect          : LREAL;
bFadeUp                          : BOOL;
bFadeDown                        : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Beleuchtung.

bStopExecution: Stoppt die Instanz der Beleuchtung.

bOn: Die zugewiesene Lampengruppe wird eingeschaltet.

bOff: Die zugewiesene Lampengruppe wird ausgeschaltet. Wenn der Durchschnittswert der Lampengruppe (lrAverageControlValue) größer als 0 ist, dann wird er in lrResettingValue hinterlegt.

bToggleLastControlValue: uiToggleMode = 0 (Wechseln zwischen An und Aus): Die zugewiesene Lampengruppe wird eingeschaltet, wenn der Mittelwert der Stellgröße 0 ist und ausgeschaltet, wenn der Wert größer als 0 ist. Hierzu wird entsprechend der bOn oder bOff Befehl gesendet.
uiToggleMode = 0 (Wechseln zwischen lrResettingValue und Aus): Wenn der Mittelwert der Stellgröße der zugewiesenen Lampengruppe 0 ist, dann wird die Lampengruppe auf den lrResettingValue gesetzt, indem der bSetControlValueDirect Befehl gesendet wird. Die Lampengruppe wird ausgeschaltet, wenn der Mittelwert der Stellgröße größer als 0 ist, indem der bOff Befehl gesendet wird.

bToggleMaxControlValue: Die zugewiesene Lampengruppe wechselt zwischen Aus und der maximalen Stellgröße. Wenn der Mittelwert der Stellgröße größer als 0 ist, dann wird der bOff Befehl zur entsprechenden Gruppe gesendet. Ist der Wert 0, dann wird der bCallMaxControlValue Befehl ausgeführt.

bCallMinControlValue: Der bCallMinControlValue Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bCallMaxControlValue: Der bCallMaxControlValue Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bSetControlValueDirect: Der bSetControlValueDirect Befehl der zugewiesenen Lampengruppe wird ausgeführt. Wenn lrSetControlValueDirect ist 0, dann wird der Wert von lrAverageControlValue in lrResettingValue hinterlegt.

lrSetControlValueDirect: Stellgröße die zur zugewiesenen Lampengruppe gesendet wird, wenn bSetControlValueDirect ausgeführt wird.

bFadeUp: Der bFadeUp Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bFadeDown: Der bFadeDown Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bStepUp: Der bStepUp Befehl wird für alle Lampen der zugewiesenen Lampengruppe ausgeführt.

bStepDown: Der bStepDown Befehl wird für alle Lampen der zugewiesenen Lampengruppe ausgeführt.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrAverageControlValue            : LREAL;
lrResettingValue                 : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Beleuchtung.

lrAverageControlValue: Mittelwert der Stellgröße (0% - 100%) der zugewiesenen Lampengruppe.

lrResettingValue: Wiedereinschaltwert (0% - 100%) der Beleuchtung. Vor dem Ausschalten der Beleuchtung wird der Durchschnittswert lrAverageControlValue in dieser Variablen hinterlegt.


FB_BAFLightingStairwellDimmer

Funktionsblock um eine Treppenhausbeleuchtung direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bStart                           : BOOL;
bOff                             : BOOL;
bChangeProlongDuration           : BOOL;
tChangeProlongDuration           : TIME;
bChangePresenceExtensionDuration : BOOL;
tChangePresenceExtensionDuration : TIME;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Beleuchtung.

bStopExecution: Stoppt die Instanz der Beleuchtung.

bStart: Die Treppenhaus Sequenz der zugewiesenen Lampengruppe wird gestartet.

bOff: Die Treppenhaus Sequenz wird beendet und die zugewiesene Lampengruppe ausgeschaltet.

bChangeProlongDuration: Die Nachlaufzeit der Beleuchtung wird auf tChangeProlongDuration gesetzt.

tChangeProlongDuration: Siehe bChangeProlongDuration.

bChangePresenceExtensionDuration: Die Präsenzverlängerung der Beleuchtung wird auf tChangePresenceExtensionDuration gesetzt.

tChangePresenceExtensionDuration: Siehe bChangePresenceExtensionDuration.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrAverageControlValue            : LREAL;
tRemainingTime                   : TIME;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Beleuchtung.

lrAverageControlValue: Mittelwert der Stellgröße (0% - 100%) der zugewiesenen Lampengruppe.

tRemainingTime: Verbleibende Zeit bis die Beleuchtung ausgeschaltet wird.


FB_BAFLightingTwilightSwitch

Funktionsblock um einen Dämmerungsschalter direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bOn                              : BOOL;
bOff                             : BOOL;
bToggleLastControlValue          : BOOL;
bToggleMaxControlValue           : BOOL;
bCallMinControlValue             : BOOL;
bCallMaxControlValue             : BOOL;
bSetControlValueDirect           : BOOL;
lrSetControlValueDirect          : LREAL;
bFadeUp                          : BOOL;
bFadeDown                        : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bSetSetpointValueShiftDirect     : BOOL;
lrSetSetpointValueShiftDirect    : LREAL;
bSetpointValueShiftUp            : BOOL;
bSetpointValueShiftDown          : BOOL;
bDisableRegulator                : BOOL;
bEnableRegulator                 : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Beleuchtung.

bStopExecution: Stoppt die Instanz der Beleuchtung.

bOn: Die zugewiesene Lampengruppe wird eingeschaltet.

bOff: Die zugewiesene Lampengruppe wird ausgeschaltet. Wenn der Durchschnittswert der Lampengruppe (lrAverageControlValue) größer als 0 ist, dann wird er in lrResettingValue hinterlegt.

bToggleLastControlValue: uiToggleMode = 0 (Wechseln zwischen An und Aus): Die zugewiesene Lampengruppe wird eingeschaltet, wenn der Mittelwert der Stellgröße 0 ist und ausgeschaltet, wenn der Wert größer als 0 ist. Hierzu wird entsprechend der bOn oder bOff Befehl gesendet.
uiToggleMode = 0 (Wechseln zwischen lrResettingValue und Aus): Wenn der Mittelwert der Stellgröße der zugewiesenen Lampengruppe 0 ist, dann wird die Lampengruppe auf den lrResettingValue gesetzt, indem der bSetControlValueDirect Befehl gesendet wird. Die Lampengruppe wird ausgeschaltet, wenn der Mittelwert der Stellgröße größer als 0 ist, indem der bOff Befehl gesendet wird.

bToggleMaxControlValue: Die zugewiesene Lampengruppe wechselt zwischen Aus und der maximalen Stellgröße. Wenn der Mittelwert der Stellgröße größer als 0 ist, dann wird der bOff Befehl zur entsprechenden Gruppe gesendet. Ist der Wert 0, dann wird der bCallMaxControlValue Befehl ausgeführt.

bCallMinControlValue: Der bCallMinControlValue Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bCallMaxControlValue: Der bCallMaxControlValue Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bSetControlValueDirect: Der bSetControlValueDirect Befehl der zugewiesenen Lampengruppe wird ausgeführt. Wenn lrSetControlValueDirect ist 0, dann wird der Wert von lrAverageControlValue in lrResettingValue hinterlegt.

lrSetControlValueDirect: Stellgröße die zur zugewiesenen Lampengruppe gesendet wird, wenn bSetControlValueDirect ausgeführt wird.

bFadeUp: Der bFadeUp Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bFadeDown: Der bFadeDown Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bStepUp: Der bStepUp Befehl wird für alle Lampen der zugewiesenen Lampengruppe ausgeführt.

bStepDown: Der bStepDown Befehl wird für alle Lampen der zugewiesenen Lampengruppe ausgeführt.

bSetSetpointValueShiftDirect: Die unter lrSetSetpointValueShiftDirect eingetragene Sollwertverschiebung wird übernommen.

lrSetSetpointValueShiftDirect: Siehe lrSetSetpointValueShiftDirect.

bSetpointValueShiftUp: Die Sollwertverschiebung wird um lrSetpointValueShiftStepSize erhöht (Parameter Struktur).

bSetpointValueShiftDown: Die Sollwertverschiebung wird um lrSetpointValueShiftStepSize verringert (Parameter Struktur).

bDisableRegulator: Eine aufsteigende Flanke an diesem Eingang deaktiviert den Dämmerungsschalter.

bEnableRegulator: Eine aufsteigende Flanke an diesem Eingang aktiviert den Dämmerungsschalter.

Alle Befehle zur direkten Änderung der Stellgröße (bOn, bOff, bToggleLastControlValue, bToggleMaxControlValue, bCallMinControlValue, bCallMaxControlValue, bSetControlValueDirect, bFadeUp and bFadeDown) werden deaktiviert, solange die Funktionseinheit aktiv ist.

Das automatische Schalten der zugewiesenen Lampengruppe um den Schaltwert wird von einer programmierten Hysterese (lrControlHysteresis, Parameter Struktur) vorgenommen.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrAverageControlValue            : LREAL;
lrResettingValue                 : LREAL;
lrActualValue                    : LREAL;
lrSetpointValue                  : LREAL;
lrSetpointValueShift             : LREAL;
bRegulatorActive                 : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Beleuchtung.

lrAverageControlValue: Mittelwert der Stellgröße (0% - 100%) der zugewiesenen Lampengruppe.

lrResettingValue: Wiedereinschaltwert (0% - 100%) der Beleuchtung. Vor dem Ausschalten der Beleuchtung wird der Durchschnittswert lrAverageControlValue in dieser Variablen hinterlegt.

lrActualValue: Gemessener (Tages-) Lichtwert der Beleuchtung.

lrSetpointValue: Ergebnis vom Basis Schaltwert (lrBasicSetpointValue) und der Schaltwertverschiebung (lrSetpointValueShift).

lrSetpointValueShift: Aktuelle Schaltwertverschiebung.

bRegulatorActive: Zeigt an, ob die Beleuchtung derzeit aktiviert oder deaktiviert ist.


FB_BAFLightingDaylightLightControl

Funktionsblock um eine tageslichtabhängige Lichtsteuerung direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bOn                              : BOOL;
bOff                             : BOOL;
bToggleLastControlValue          : BOOL;
bToggleMaxControlValue           : BOOL;
bCallMinControlValue             : BOOL;
bCallMaxControlValue             : BOOL;
bSetControlValueDirect           : BOOL;
lrSetControlValueDirect          : LREAL;
bFadeUp                          : BOOL;
bFadeDown                        : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bDisableRegulator                : BOOL;
bEnableRegulator                 : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Beleuchtung.

bStopExecution: Stoppt die Instanz der Beleuchtung.

bOn: Die zugewiesene Lampengruppe wird eingeschaltet.

bOff: Die zugewiesene Lampengruppe wird ausgeschaltet. Wenn der Durchschnittswert der Lampengruppe (lrAverageControlValue) größer als 0 ist, dann wird er in lrResettingValue hinterlegt.

Wird dieser Befehl gesendet während die Lichtregelung aktiv ist, so werden alle zugewiesenen Lampengruppen ausgeschaltet und der Regulator deaktiviert.

bToggleLastControlValue: uiToggleMode = 0 (Wechseln zwischen An und Aus): Die zugewiesene Lampengruppe wird eingeschaltet, wenn der Mittelwert der Stellgröße 0 ist und ausgeschaltet, wenn der Wert größer als 0 ist. Hierzu wird entsprechend der bOn oder bOff Befehl gesendet.
uiToggleMode = 0 (Wechseln zwischen lrResettingValue und Aus): Wenn der Mittelwert der Stellgröße der zugewiesenen Lampengruppe 0 ist, dann wird die Lampengruppe auf den lrResettingValue gesetzt, indem der bSetControlValueDirect Befehl gesendet wird. Die Lampengruppe wird ausgeschaltet, wenn der Mittelwert der Stellgröße größer als 0 ist, indem der bOff Befehl gesendet wird.

bToggleMaxControlValue: Die zugewiesene Lampengruppe wechselt zwischen Aus und der maximalen Stellgröße. Wenn der Mittelwert der Stellgröße größer als 0 ist, dann wird der bOff Befehl zur entsprechenden Gruppe gesendet. Ist der Wert 0, dann wird der bCallMaxControlValue Befehl ausgeführt.

bCallMinControlValue: Der bCallMinControlValue Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bCallMaxControlValue: Der bCallMaxControlValue Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bSetControlValueDirect: Der bSetControlValueDirect Befehl der zugewiesenen Lampengruppe wird ausgeführt. Wenn lrSetControlValueDirect ist 0, dann wird der Wert von lrAverageControlValue in lrResettingValue hinterlegt.

lrSetControlValueDirect: Stellgröße die zur zugewiesenen Lampengruppe gesendet wird, wenn bSetControlValueDirect ausgeführt wird.

bFadeUp: Der bFadeUp Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bFadeDown: Der bFadeDown Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bStepUp: Der bStepUp Befehl wird für alle Lampen der zugewiesenen Lampengruppe ausgeführt.

bStepDown: Der bStepDown Befehl wird für alle Lampen der zugewiesenen Lampengruppe ausgeführt.

bSetSetpointValueShiftDirect: Die unter lrSetSetpointValueShiftDirect eingetragene Sollwertverschiebung wird übernommen.

lrSetSetpointValueShiftDirect: Siehe lrSetSetpointValueShiftDirect.

bSetpointValueShiftUp: Die Sollwertverschiebung wird um lrSetpointValueShiftStepSize erhöht (Parameter Struktur).

bSetpointValueShiftDown: Die Sollwertverschiebung wird um lrSetpointValueShiftStepSize verringert (Parameter Struktur).

bDisableRegulator: Eine aufsteigende Flanke an diesem Eingang deaktiviert den Dämmerungsschalter.

bEnableRegulator: Eine aufsteigende Flanke an diesem Eingang aktiviert den Dämmerungsschalter.

Alle Befehle zur direkten Änderung der Stellgröße (bOn, bOff, bToggleLastControlValue, bToggleMaxControlValue, bCallMinControlValue, bCallMaxControlValue, bSetControlValueDirect, bFadeUp and bFadeDown) werden deaktiviert, solange die Funktionseinheit aktiv ist.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrAverageControlValue            : LREAL;
lrResettingValue                 : LREAL;
lrActualValue                    : LREAL;
bRegulatorActive                 : BOOL;
lrControlValueSubLampGroup1      : LREAL;
lrControlValueSubLampGroup2      : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Beleuchtung.

lrAverageControlValue: Mittelwert der Stellgröße (0% - 100%) der zugewiesenen Lampengruppe.

lrResettingValue: Wiedereinschaltwert (0% - 100%) der Beleuchtung. Vor dem Ausschalten der Beleuchtung wird der Durchschnittswert lrAverageControlValue in dieser Variablen hinterlegt.

lrActualValue: Gemessener (Tages-) Lichtwert der Beleuchtung.

bRegulatorActive: Zeigt an, ob die Beleuchtung derzeit aktiviert oder deaktiviert ist.

lrControlValueSubLampGroup1: Mittelwert der Stellgröße (0% - 100%) der zugewiesenen Lampenuntergruppe 1.

lrControlValueSubLampGroup2: Mittelwert der Stellgröße (0% - 100%) der zugewiesenen Lampenuntergruppe 2.


FB_BAFLightingConstantLightRegulation

Funktionsblock um eine Konstantlichtregelung direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bOn                              : BOOL;
bOff                             : BOOL;
bToggleLastControlValue          : BOOL;
bToggleMaxControlValue           : BOOL;
bCallMinControlValue             : BOOL;
bCallMaxControlValue             : BOOL;
bSetControlValueDirect           : BOOL;
lrSetControlValueDirect          : LREAL;
bFadeUp                          : BOOL;
bFadeDown                        : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bSetSetpointValueShiftDirect     : BOOL;
lrSetSetpointValueShiftDirect    : LREAL;
bSetpointValueShiftUp            : BOOL;
bSetpointValueShiftDown          : BOOL;
bDisableRegulator                : BOOL;
bEnableRegulator                 : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Beleuchtung.

bStopExecution: Stoppt die Instanz der Beleuchtung.

bOn: Die zugewiesene Lampengruppe wird eingeschaltet.

bOff: Die zugewiesene Lampengruppe wird ausgeschaltet. Wenn der Durchschnittswert der Lampengruppe (lrAverageControlValue) größer als 0 ist, dann wird er in lrResettingValue hinterlegt.

Wird dieser Befehl gesendet während die Lichtregelung aktiv ist, so werden alle zugewiesenen Lampengruppen ausgeschaltet und der Regulator deaktiviert.

bToggleLastControlValue: uiToggleMode = 0 (Wechseln zwischen An und Aus): Die zugewiesene Lampengruppe wird eingeschaltet, wenn der Mittelwert der Stellgröße 0 ist und ausgeschaltet, wenn der Wert größer als 0 ist. Hierzu wird entsprechend der bOn oder bOff Befehl gesendet.
uiToggleMode = 0 (Wechseln zwischen lrResettingValue und Aus): Wenn der Mittelwert der Stellgröße der zugewiesenen Lampengruppe 0 ist, dann wird die Lampengruppe auf den lrResettingValue gesetzt, indem der bSetControlValueDirect Befehl gesendet wird. Die Lampengruppe wird ausgeschaltet, wenn der Mittelwert der Stellgröße größer als 0 ist, indem der bOff Befehl gesendet wird.

bToggleMaxControlValue: Die zugewiesene Lampengruppe wechselt zwischen Aus und der maximalen Stellgröße. Wenn der Mittelwert der Stellgröße größer als 0 ist, dann wird der bOff Befehl zur entsprechenden Gruppe gesendet. Ist der Wert 0, dann wird der bCallMaxControlValue Befehl ausgeführt.

bCallMinControlValue: Der bCallMinControlValue Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bCallMaxControlValue: Der bCallMaxControlValue Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bSetControlValueDirect: Der bSetControlValueDirect Befehl der zugewiesenen Lampengruppe wird ausgeführt. Wenn lrSetControlValueDirect ist 0, dann wird der Wert von lrAverageControlValue in lrResettingValue hinterlegt.

lrSetControlValueDirect: Stellgröße die zur zugewiesenen Lampengruppe gesendet wird, wenn bSetControlValueDirect ausgeführt wird.

bFadeUp: Der bFadeUp Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bFadeDown: Der bFadeDown Befehl der zugewiesenen Lampengruppe wird ausgeführt.

bStepUp: Der bStepUp Befehl wird für alle Lampen der zugewiesenen Lampengruppe ausgeführt.

bStepDown: Der bStepDown Befehl wird für alle Lampen der zugewiesenen Lampengruppe ausgeführt.

bSetSetpointValueShiftDirect: Die unter lrSetSetpointValueShiftDirect eingetragene Sollwertverschiebung wird übernommen.

lrSetSetpointValueShiftDirect: Siehe lrSetSetpointValueShiftDirect.

bSetpointValueShiftUp: Die Sollwertverschiebung wird um lrSetpointValueShiftStepSize erhöht (Parameter Struktur).

bSetpointValueShiftDown: Die Sollwertverschiebung wird um lrSetpointValueShiftStepSize verringert (Parameter Struktur).

bDisableRegulator: Eine aufsteigende Flanke an diesem Eingang deaktiviert den Dämmerungsschalter.

bEnableRegulator: Eine aufsteigende Flanke an diesem Eingang aktiviert den Dämmerungsschalter.

Alle Befehle zur direkten Änderung der Stellgröße (bOn, bOff, bToggleLastControlValue, bToggleMaxControlValue, bCallMinControlValue, bCallMaxControlValue, bSetControlValueDirect, bFadeUp and bFadeDown) werden deaktiviert, solange die Funktionseinheit aktiv ist.

Das Dimmen der zugewiesenen Lampengruppe um den Schaltwert wird von einer programmierten Hysterese (lrControlHysteresis, Parameter Struktur) vorgenommen.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrAverageControlValue            : LREAL;
lrResettingValue                 : LREAL;
lrActualValue                    : LREAL;
lrSetpointValue                  : LREAL;
lrSetpointValueShift             : LREAL;
bRegulatorActive                 : BOOL;
lrDeviation                      : LREAL;
tControlDelay                    : TIME;
lrControlValueSubLampGroup1      : LREAL;
lrControlValueSubLampGroup2      : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Beleuchtung.

lrAverageControlValue: Mittelwert der Stellgröße (0% - 100%) der zugewiesenen Lampengruppe.

lrResettingValue: Wiedereinschaltwert (0% - 100%) der Beleuchtung. Vor dem Ausschalten der Beleuchtung wird der Durchschnittswert lrAverageControlValue in dieser Variablen hinterlegt.

lrActualValue: Gemessener (Tages-) Lichtwert der Beleuchtung.

lrSetpointValue: Ergebnis vom Basis Schaltwert (lrBasicSetpointValue) und der Schaltwertverschiebung (lrSetpointValueShift).

lrSetpointValueShift: Aktuelle Schaltwertverschiebung.

bRegulatorActive: Zeigt an, ob die Beleuchtung derzeit aktiviert oder deaktiviert ist.

lrDeviation: Regelabweichung (lrSetpointValue - lrActualValue).

tControlDelay: Aktuelle Verzögerung bis eine neue Stellgröße übernommen wird. Diese Verzögerung wird automatisch berechnet und ist Abhängig von der momentanen Regelabweichung. Umso höher die Regelabweichung, desto geringer die Verzögerung.

lrControlValueSubLampGroup1: Mittelwert der Stellgröße (0% - 100%) der zugewiesenen Lampenuntergruppe 1.

lrControlValueSubLampGroup2: Mittelwert der Stellgröße (0% - 100%) der zugewiesenen Lampenuntergruppe 2.


FB_BAFLightingTestsForEmergencyLighting

Funktionsblock um einen Funktions- und Dauertest für die Sicherheitsbeleuchtung direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bOn                              : BOOL;
bOff                             : BOOL;
bStartFunctionTest               : BOOL;
bStartDurationTest               : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Beleuchtung.

bStopExecution: Stoppt die Instanz der Beleuchtung.

bOn: Schaltet die Beleuchtung An.

bOff Schaltet die Beleuchtung Aus.

bStartFunctionTest: Ein Funktionstest für alle DALI Notbeleuchtungen in der zugewiesenen Lampengruppe wird gestartet.

bStartDurationTest: Ein Dauertest für alle DALI Notbeleuchtungen in der zugewiesenen Lampengruppe wird gestartet.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrAverageControlValue            : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Beleuchtung.

lrAverageControlValue: Mittelwert der Stellgröße der Beleuchtung.


FB_BAFSunblindStandard

Funktionsblock um eine Standard Beschattung direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSafetyPositionSet               : BOOL;
bSafetyPositionReset             : BOOL;
bUp                              : BOOL;
bDown                            : BOOL;
bStop                            : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bSetPositionDirect               : BOOL;
lrSetPositionDirect              : LREAL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Beschattung.

bStopExecution: Stoppt die Instanz der Beschattung.

bSafetyPositionSet: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe (siehe Parameter uiBlindDriveGroupId) werden auf ihre Sicherheitsposition gefahren.

bSafetyPositionReset: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe werden freigegeben, um die Sicherheitsposition verlassen zu können.

bUp: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe fahren hoch.

bDown: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe fahren runter.

bStop: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe halten an.

bStepUp: Der bStepUp Befehl der zugewiesenen Jalousieantriebsgruppe wird ausgeführt.

bStepDown: Der bStepDown Befehl der zugewiesenen Jalousieantriebsgruppe wird ausgeführt.

bSetPositionDirect: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe fahren die unter lrSetPositionDirect eingetragene Position an.

lrSetPositionDirect: Siehe bSetPositionDirect. 0% entspricht vollständig geöffnet, 100% vollständig geschlossen.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrAveragePosition                : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Beschattung.

lrAveragePosition: Die durchschnittliche Position (0% - 100%) der zugewiesenen Jalousieantriebsgruppe.


FB_BAFSunblindSuntracking

Funktionsblock um eine Beschattung in Abhängigkeit des Sonnenstandes direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSafetyPositionSet               : BOOL;
bSafetyPositionReset             : BOOL;
bUp                              : BOOL;
bDown                            : BOOL;
bStop                            : BOOL;
bStepUp                          : BOOL;
bStepDown                        : BOOL;
bSetPositionAngleDirect          : BOOL;
lrSetPositionDirect              : LREAL;
lrSetAngleDirect                 : LREAL;
bSetControlMode                  : BOOL;
iSetControlMode                  : INT;
bDriveToFavoritePosition         : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Beschattung.

bStopExecution: Stoppt die Instanz der Beschattung.

bSafetyPositionSet: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe (siehe Parameter uiBlindDriveGroupId) werden auf ihre Sicherheitsposition gefahren.

bSafetyPositionReset: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe werden freigegeben, um die Sicherheitsposition verlassen zu können.

bUp: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe fahren hoch.

bDown: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe fahren runter.

bStop: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe halten an.

bStepUp: Der bStepUp Befehl der zugewiesenen Jalousieantriebsgruppe wird ausgeführt.

bStepDown: Der bStepDown Befehl der zugewiesenen Jalousieantriebsgruppe wird ausgeführt.

bSetPositionAngleDirect: Alle Jalousieantriebe in der zugewiesenen Jalousieantriebsgruppe fahren den unter lrSetAngleDirect eingetragenen Winkel an. Das BA-Framework Element Standard Jalousieantrieb Unterstützt nicht das Anfahren eines Winkels - im Gegensatz zum Jalousieantrieb verbunden mit KL2532 - dieser Befehl wird nur Auswirkungen auf die Position haben.

lrSetPositionDirect: Siehe bSetPositionAngleDirect. 0% entspricht vollständig geöffnet, 100% vollständig geschlossen.

lrSetAngleDirect: Siehe bSetPositionAngleDirect.

bSetControlMode: Versetzt die Beschattung in den unter iSetControlMode angegebenen Steuerungsmodus.

iSetControlMode: Siehe bSetControlMode.

bDriveToFavoritePosition: Fährt die Beschattung auf die bevorzugte Position.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrAveragePosition                : LREAL;
iTypeOfSeason                    : INT;
bMotionDetection                 : BOOL;
lrOutdoorBrightness              : LREAL;
lrRoomTemperature                : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Beschattung.

lrAveragePosition: Die durchschnittliche Position (0% - 100%) der zugewiesenen Jalousieantriebsgruppe.

iTypeOfSeason: Zeigt den aktuellen Operationsmodus an: (0: Undefiniert ; 1: Wintermodus ; 2: Sommermodus).

bMotionDetection: Gibt an, ob Bewegung erkannt wurde.

lrOutdoorBrightness: Zeigt die Außenhelligkeit an.

lrRoomTemperature: Zeigt die Raumtemperatur an.


FB_BAFWindowStandard

Funktionsblock um ein Standard Fenster direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bSafetyPositionSet               : BOOL;
bSafetyPositionReset             : BOOL;
bClose                           : BOOL;
bOpen                            : BOOL;
bStop                            : BOOL;
bSetPositionDirect               : BOOL;
lrSetPositionDirect              : LREAL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz vom Fenster.

bStopExecution: Stoppt die Instanz vom Fenster.

bSafetyPositionSet: Alle Fensterantriebe in der zugewiesenen Fensterantriebsgruppe werden auf ihre Sicherheitsposition gefahren.

bSafetyPositionReset: Alle Fensterantriebe in der zugewiesenen Fensterantriebsgruppe werden freigegeben, um die Sicherheitsposition verlassen zu können.

bClose: Alle Fensterantriebe in der zugewiesenen Fensterantriebsgruppe schließen sich.

bOpen: Alle Fensterantriebe in der zugewiesenen Fensterantriebsgruppe öffnen sich.

bStop: Alle Fensterantriebe in der zugewiesenen Fensterantriebsgruppe halten an.

bSetPositionDirect: Alle Fensterantriebe in der zugewiesenen Fensterantriebsgruppe fahren die unter lrSetPositionDirect angegebene Position an.

lrSetPositionDirect: Siehe bSetPositionDirect. 0% entspricht vollständig geschlossen, 100% vollständig geöffnet.

VAR_OUTPUT

uiErrorId                       : UINT;
iErrorParameter                 : INT;
eExecutionState                 : E_BAF_ExecutionState;
lrAveragePosition               : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz vom Fenster.

lrAveragePosition: Die durchschnittliche Position (0% - 100%) der zugewiesenen Fensterantriebsgruppe.


FB_BAFHVACHeatingCooling

Funktionsblock um die Funktionseinheit für die Temperaturregelung Heizen und Kühlen direkt aus dem SPS Programm zu steuern.

VAR_INPUT

uiId                              : UINT;
bStartExecution                   : BOOL;
bStopExecution                    : BOOL;
bSetSetpointValueShiftUserDirect  : BOOL;
lrSetSetpointValueShiftUserDirect : LREAL;
bSetpointValueShiftUserUp         : BOOL;
bSetpointValueShiftUserDown       : BOOL;
bSetEnergyLevel                   : BOOL;
eSetEnergyLevel                   : E_BAF_HVACEnergyLevel;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz.

bStopExecution: Stoppt die Instanz.

bSetSetpointValueShiftUserDirect: Bei einer positiven Flanke wird die lokale Sollwertverschiebung (Sollwertverschiebung Benutzer) auf den unter lrSetSetpointValueShiftUserDirect eingetragenen Wert gesetzt.

lrSetSetpointValueShiftUserDirect: Siehe bSetSetpointValueShiftUserDirect: Der Wert kann durch Parameter auf einen minimalen und maximalen Wert begrenzt werden.

bSetpointValueShiftUserUp: Durch eine positive Flanke wird die lokale Sollwertverschiebung (Sollwertverschiebung Benutzer) erhöht. Über Parameter kann festgelegt werden, um wie viel sich der Wert ändern soll.

bSetpointValueShiftUserDown: Durch eine positive Flanke wird die lokale Sollwertverschiebung (Sollwertverschiebung Benutzer) verringert. Über Parameter kann festgelegt werden, um wie viel sich der Wert ändern soll.

bSetEnergyLevel: Vorgabe Energieniveau. Fensterkontakte oder Bewegungsmelder, die durch digitale Signale an die Heizungsregelung angebunden werden, können diese Vorgabe überschreiben.

eSetEnergyLevel: Siehe bSetEnergyLevel.

VAR_OUTPUT

uiErrorId                              : UINT;
iErrorParameter                        : INT;
eExecutionState                        : E_BAF_ExecutionState;
lrActualValue                          : LREAL;
lrSetpointValueShiftUser               : LREAL;
lrSetpointValueShiftSummerCompensation : LREAL;
lrOutdoorTemperature                   : LREAL;
lrSetpointComfortHeating               : LREAL;
lrSetpointPreComfortHeating            : LREAL;
lrSetpointEconomyHeating               : LREAL;
lrSetpointProtectionHeating            : LREAL;
lrSetpointComfortCooling               : LREAL;
lrSetpointPreComfortCooling            : LREAL;
lrSetpointEconomyCooling               : LREAL;
lrSetpointProtectionCooling            : LREAL;
lrDeviation                            : LREAL;
lrSetpointValue                        : LREAL;
lrYOutHeating                          : LREAL;
bYOutHeating                           : BOOL;
lrYOutCooling                          : LREAL;
bYOutCooling                           : BOOL;
eEnergyLevelActual                     : E_BAF_HVACEnergyLevel;
eEnergyLevelSet                        : E_BAF_HVACEnergyLevel;
eControlFunctionActual                 : E_BAF_HVACControlFunction;
bWindowContact                         : BOOL;
bMotionDetection                       : BOOL;
bDewPoint                              : BOOL;

uiErrorId: Beinhaltet den Fehlercode (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz.

lrActualValue: Istwert.

lrSetpointValueShiftUser: Lokale Sollwertverschiebung (Sollwertverschiebung Benutzer).

lrSetpointValueShiftSummerCompensation: Sollwertverschiebung durch die Sommerkompensation.

lrOutdoorTemperature: Außentemperatur, falls eine Wetterstation mit der Klimaregelung verbunden wurde.

lrSetpointComfortHeating: Basissollwert für das Heizen bei Energieniveau Komfort.

lrSetpointPreComfortHeating: Basissollwert für das Heizen bei Energieniveau Bereitschaft.

lrSetpointEconomyHeating: Basissollwert für das Heizen bei Energieniveau Absenkung.

lrSetpointProtectionHeating: Basissollwert für das Heizen bei Energieniveau Gebäudeschutz.

lrSetpointComfortCooling: Basissollwert für das Kühlen bei Energieniveau Komfort.

lrSetpointPreComfortCooling: Basissollwert für das Kühlen bei Energieniveau Bereitschaft.

lrSetpointEconomyCooling: Basissollwert für das Kühlen bei Energieniveau Absenkung.

lrSetpointProtectionCooling: Basissollwert für das Kühlen bei Energieniveau Gebäudeschutz.

lrDeviation: Regelabweichung (Sollwert - Istwert).

lrSetpointValue: Berechneter Sollwert. Der resultierende Sollwert setzt sich zusammen aus einem der 8 Basissollwerte, der lokalen Sollwertverschiebung (Sollwertverschiebung Benutzer), der zentralen Sollwertverschiebung und der Sollwertverschiebung durch die Sommerkompensation.

lrYOutHeating: Analoge Stellgröße für das Heizen von 0% bis 100%

bYOutHeating: Digitale Stellgröße für das Heizen. PWM-Signal der analogen Stellgröße.

lrYOutCooling: Analoge Stellgröße für das Kühlen von 0% bis 100%.

bYOutCooling: Digitale Stellgröße für das Kühlen. PWM-Signal der analogen Stellgröße.

eEnergyLevelActual: Berechnetes Energieniveau.

eEnergyLevelSet: Vorgabe Energieniveau.

eControlFunctionActual: Berechnete Regelfunktion.

bWindowContact: Zustand Fensterkontakt, falls Fensterkontakte mit der Klimaregelung verbunden wurden.

bMotionDetection: Zustand Bewegungsmelder, falls Bewegungsmelder mit der Klimaregelung verbunden wurden.

bDewPointValue: Zustand Taupunktfühler, falls Taupunktfühler mit der Klimaregelung verbunden wurden.


FB_BAFScenesStandard

Funktionsblock um eine Standard Szene direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bInvoke                          : BOOL;
bSwitchOff                       : BOOL;
bStoreCurrentScenery             : BOOL;
bPushButtonLightingFadeUpDown    : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Szene.

bStopExecution: Stoppt die Instanz der Szene.

bInvoke: Die Szene wird aufgerufen.

bSwitchOff: Alle Elemente, die in dieser Szene enthalten sind, erhalten den Befehl Aus oder Stopp. Unterstützt ein Element keines der beiden Befehle, so wird es ignoriert.

bStoreCurrentScenery: Der Befehl hat nur Auswirkung auf Funktionseinheiten vom Typ Beleuchtung, Beschattung und Fenster, wenn diese mit dem Befehl Stellgröße direkt setzen bzw. Position direkt setzen innerhalb der Szene angesprochen werden. Wird der Befehl bStoreCurrentScenery ausgeführt, so wird von den jeweiligen Funktionseinheiten der aktuelle Zustand als neuer Parameter für den Befehl Stellgröße direkt setzen bzw. Position direkt setzen benutzt.

bPushButtonLightingFadeUpDown: Der Befehl hat nur Auswirkung auf Funktionseinheiten vom Typ Beleuchtung. Durch einen kurzen Impuls (Tastendruck) wird die Szene aufgerufen. Steht das Signal kontinuierlich an, so werden die Lampen der Funktionseinheit hoch und runter gedimmt.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Szene.


FB_BAFSchedulerDaily

Funktionsblock um einen täglichen Zeitschaltkanal direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des täglichen Zeitschaltkanals.

bStopExecution: Stoppt die Instanz des täglichen Zeitschaltkanals.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bValue                           : BOOL;
tRamainingOnTime                 : TIME;
tRamainingOffTime                : TIME;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz des täglichen Zeitschaltkanals.

bValue: Der Ausgabezustand des Signals.

tRamainingOnTime: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.

tRamainingOffTime: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.


FB_BAFSchedulerWeeklyIndividual

Funktionsblock um einen wöchentlichen Zeitschaltkanal (einzelne Wochentage) direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des wöchentlichen Zeitschaltkanals.

bStopExecution: Stoppt die Instanz des wöchentlichen Zeitschaltkanals.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bValue                           : INT;
tRamainingOnTime                 : TIME;
tRamainingOffTime                : TIME;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz des monatlichen Zeitschaltkanals.

bValue: Der Ausgabezustand des Signals.

tRamainingOnTime: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.

tRamainingOffTime: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.


FB_BAFSchedulerWeeklyContinual

Funktionsblock um einen wöchentlichen Zeitschaltkanal (fortlaufende Wochentage) direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des wöchentlichen Zeitschaltkanals.

bStopExecution: Stoppt die Instanz des wöchentlichen Zeitschaltkanals.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bValue                           : INT;
tRamainingOnTime                 : TIME;
tRamainingOffTime                : TIME;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz des wöchentlichen Zeitschaltkanals.

bValue: Der Ausgabezustand des Signals.

tRamainingOnTime: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.

tRamainingOffTime: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.


FB_BAFSchedulerMonthlyNthDay

Funktionsblock um einen monatlichen Zeitschaltkanal (n'te Tag im Monat) direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des monatlichen Zeitschaltkanals.

bStopExecution: Stoppt die Instanz des monatlichen Zeitschaltkanals.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bValue                           : INT;
tRamainingOnTime                 : TIME;
tRamainingOffTime                : TIME;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz des monatlichen Zeitschaltkanals.

bValue: Der Ausgabezustand des Signals.

tRamainingOnTime: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.

tRamainingOffTime: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.


FB_BAFSchedulerMonthlyIndividualWeekday

Funktionsblock um einen monatlichen Zeitschaltkanal (einzelner Wochentag im Monat) direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz des monatlichen Zeitschaltkanals.

bStopExecution: Stoppt die Instanz des monatlichen Zeitschaltkanals.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
bValue                           : INT;
tRamainingOnTime                 : TIME;
tRamainingOffTime                : TIME;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz des monatlichen Zeitschaltkanals.

bValue: Der Ausgabezustand des Signals.

tRamainingOnTime: Verbleibende Zeit die der Zeitschaltkanal eingeschaltet ist.

tRamainingOffTime: Verbleibende Zeit die der Zeitschaltkanal ausgeschaltet ist.


FB_BAFWeatherStationVirtual

Funktionsblock um eine virtuelle Wetterstation direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                                        : UINT;
bStartExecution                             : BOOL;
bStopExecution                              : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der virtuellen Wetterstation.

bStopExecution: Stoppt die Instanz der virtuellen Wetterstation.

VAR_OUTPUT

uiErrorId                                   : UINT;
iErrorParameter                             : INT;
eExecutionState                             : E_BAF_ExecutionState;
lrTemperature                               : LREAL;
lrWindSpeed                                 : LREAL;
lrBrightnessEast                            : LREAL;
lrBrightnessSouth                           : LREAL;
lrBrightnessWest                            : LREAL;
lrDaylight                                  : LREAL;
lrRain                                      : LREAL;
lrRelativeHumidity                          : LREAL;
lrDampedTemperature                         : LREAL;
eTypeOfSeason                               : E_BAF_WeatherStationTypeOfSeason;
bThresholdSwitchTemperatureValue            : BOOL;
bThresholdSwitchTemperatureRisingEdge       : BOOL;
bThresholdSwitchTemperatureFallingEdge      : BOOL;
bThresholdSwitchWindSpeed1Value             : BOOL;
bThresholdSwitchWindSpeed1RisingEdge        : BOOL;
bThresholdSwitchWindSpeed1FallingEdge       : BOOL;
bThresholdSwitchWindSpeed2Value             : BOOL;
bThresholdSwitchWindSpeed2RisingEdge        : BOOL;
bThresholdSwitchWindSpeed2FallingEdge       : BOOL;
bThresholdSwitchWindSpeed3Value             : BOOL;
bThresholdSwitchWindSpeed3RisingEdge        : BOOL;
bThresholdSwitchWindSpeed3FallingEdge       : BOOL;
bThresholdSwitchBrightnessEastValue         : BOOL;
bThresholdSwitchBrightnessEastRisingEdge    : BOOL;
bThresholdSwitchBrightnessEastFallingEdge   : BOOL;
bThresholdSwitchBrightnessSouthValue        : BOOL;
bThresholdSwitchBrightnessSouthRisingEdge   : BOOL;
bThresholdSwitchBrightnessSouthFallingEdge  : BOOL;
bThresholdSwitchBrightnessWestValue         : BOOL;
bThresholdSwitchBrightnessWestRisingEdge    : BOOL;
bThresholdSwitchBrightnessWestFallingEdge   : BOOL;
bThresholdSwitchDaylightValue               : BOOL;
bThresholdSwitchDaylightRisingEdge          : BOOL;
bThresholdSwitchDaylightFallingEdge         : BOOL;
bThresholdSwitchRainValue                   : BOOL;
bThresholdSwitchRainRisingEdge              : BOOL;
bThresholdSwitchRainFallingEdge             : BOOL;
bThresholdSwitchRelativeHumidityValue       : BOOL;
bThresholdSwitchRelativeHumidityRisingEdge  : BOOL;
bThresholdSwitchRelativeHumidityFallingEdge : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der virtuellen Wetterstation.

lrTemperature: Aktuelle Außentemperatur.

lrWindSpeed: Momentane Windgeschwindigkeit.

lrBrightnessEast: Helligkeit auf der Ostseite.

lrBrightnessSouth: Helligkeit auf der Südseite.

lrBrightnessWest: Helligkeit auf der Westseite.

lrDaylight: Zeigt die Tageshelligkeit an.

lrRain: Gibt die Intensität des Niederschlags an.

lrRelativeHumidity: Gemessene relative Luftfeuchtigkeit.

lrDampedTemperature: Über den Tag gemessene Durchschnittstemperaturen

eTypeOfSeason: Zeigt die Jahreszeit in Abhängigkeit der gedämpften Temperatur an.

bThresholdSwitchTemperatureValue: Zustand vom Schwellwertschalter zur Überwachung der Außentemperatur.

bThresholdSwitchTemperatureRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Außentemperatur aktiv wird.

bThresholdSwitchTemperatureFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Außentemperatur deaktiv wird.

bThresholdSwitchWindSpeed1Value: Zustand vom 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed1RisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed1FallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchWindSpeed2Value: Zustand vom 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed2RisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed2FallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchWindSpeed3Value: Zustand vom 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed3RisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed3FallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchBrightnessEastValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite.

bThresholdSwitchBrightnessEastRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite aktiv wird.

bThresholdSwitchBrightnessEastFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite deaktiv wird.

bThresholdSwitchBrightnessSouthValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite.

bThresholdSwitchBrightnessSouthRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite aktiv wird.

bThresholdSwitchBrightnessSouthFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite deaktiv wird.

bThresholdSwitchBrightnessWestValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite.

bThresholdSwitchBrightnessWestRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite aktiv wird.

bThresholdSwitchBrightnessWestFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite deaktiv wird.

bThresholdSwitchDaylightValue: Zustand vom Schwellwertschalter zur Überwachung der Tageshelligkeit.

bThresholdSwitchDaylightRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Tageshelligkeit daktiv wird.

bThresholdSwitchDaylightFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Tageshelligkeit deaktiv wird.

bThresholdSwitchRainValue: Zustand vom Schwellwertschalter zur Überwachung des Niederschlags.

bThresholdSwitchRainRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung des Niederschlags aktiv wird.

bThresholdSwitchRainFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung des Niederschlags deaktiv wird.

bThresholdSwitchRelativeHumidityValue: Zustand vom Schwellwertschalter zur Überwachung der relativen Luftfeuchtigkeit.

bThresholdSwitchRelativeHumidityRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der relativen Luftfeuchtigkeit aktiv wird.

bThresholdSwitchRelativeHumidityFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der relativen Luftfeuchtigkeit deaktiv wird.


FB_BAFWeatherStationElsnerP03

Funktionsblock um eine 'Elsner P03' Wetterstation direkt aus dem SPS Programm zu steuern.

VAR_INPUT

uiId                                        : UINT;
bStartExecution                             : BOOL;
bStopExecution                              : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der 'Elsner P03' Wetterstation.

bStopExecution: Stoppt die Instanz der 'Elsner P03' Wetterstation.

VAR_OUTPUT

uiErrorId                                   : UINT;
iErrorParameter                             : INT;
eExecutionState                             : E_BAF_ExecutionState;
uiErrorId                                   : UINT;
iErrorParameter                             : INT;
eExecutionState                             : E_BAF_ExecutionState;
lrTemperature                               : LREAL;
lrWindSpeed                                 : LREAL;
lrBrightnessEast                            : LREAL;
lrBrightnessSouth                           : LREAL;
lrBrightnessWest                            : LREAL;
lrDaylight                                  : LREAL;
lrRain                                      : LREAL;
lrDampedTemperature                         : LREAL;
eTypeOfSeason                               : E_BAF_WeatherStationTypeOfSeason;
dtTimeDate                                  : DT;
iDaylightSavingTime                         : INT;
bThresholdSwitchTemperatureValue            : BOOL;
bThresholdSwitchTemperatureRisingEdge       : BOOL;
bThresholdSwitchTemperatureFallingEdge      : BOOL;
bThresholdSwitchWindSpeed1Value             : BOOL;
bThresholdSwitchWindSpeed1RisingEdge        : BOOL;
bThresholdSwitchWindSpeed1FallingEdge       : BOOL;
bThresholdSwitchWindSpeed2Value             : BOOL;
bThresholdSwitchWindSpeed2RisingEdge        : BOOL;
bThresholdSwitchWindSpeed2FallingEdge       : BOOL;
bThresholdSwitchWindSpeed3Value             : BOOL;
bThresholdSwitchWindSpeed3RisingEdge        : BOOL;
bThresholdSwitchWindSpeed3FallingEdge       : BOOL;
bThresholdSwitchBrightnessEastValue         : BOOL;
bThresholdSwitchBrightnessEastRisingEdge    : BOOL;
bThresholdSwitchBrightnessEastFallingEdge   : BOOL;
bThresholdSwitchBrightnessSouthValue        : BOOL;
bThresholdSwitchBrightnessSouthRisingEdge   : BOOL;
bThresholdSwitchBrightnessSouthFallingEdge  : BOOL;
bThresholdSwitchBrightnessWestValue         : BOOL;
bThresholdSwitchBrightnessWestRisingEdge    : BOOL;
bThresholdSwitchBrightnessWestFallingEdge   : BOOL;
bThresholdSwitchDaylightValue               : BOOL;
bThresholdSwitchDaylightRisingEdge          : BOOL;
bThresholdSwitchDaylightFallingEdge         : BOOL;
bThresholdSwitchRainValue                   : BOOL;
bThresholdSwitchRainRisingEdge              : BOOL;
bThresholdSwitchRainFallingEdge             : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der 'Elsner P03' Wetterstation.

lrTemperature: Aktuelle Außentemperatur [°C].

lrWindSpeed: Momentane Windgeschwindigkeit [m/s].

lrBrightnessEast: Helligkeit auf der Ostseite [kLux].

lrBrightnessSouth: Helligkeit auf der Südseite [kLux].

lrBrightnessWest: Helligkeit auf der Westseite [kLux].

lrDaylight: Zeigt die Tageshelligkeit an [0-999 lux].

lrRain: Wird auf 1.0 gesetzt, sobald Niederschlag erkannt wird. Beachten Sie, dass der Niederschlag bei dieser Wetterstation nur die Werte 0.0 (kein Niederschlag) oder 1.0 (Niederschlag) annehmen kann.

lrDampedTemperature: Über den Tag gemessene Durchschnittstemperatur [°C].

eTypeOfSeason: Zeigt die Jahreszeit in Abhängigkeit der gedämpften Temperatur an.

dtTimeDate: Datum und Uhrzeit die vom Zeitsignalsender DCF77 empfangen werden.

iDaylightSavingTime: Vom Zeitsignalsender DCF77 empfangene Angabe, ob Sommer- oder Winterzeit vorherrscht (0: undefiniert, 1: Winterzeit, 2: Sommerzeit).

bThresholdSwitchTemperatureValue: Zustand vom Schwellwertschalter zur Überwachung der Außentemperatur.

bThresholdSwitchTemperatureRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Außentemperatur aktiv wird.

bThresholdSwitchTemperatureFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Außentemperatur deaktiv wird.

bThresholdSwitchWindSpeed1Value: Zustand vom 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed1RisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed1FallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchWindSpeed2Value: Zustand vom 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed2RisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed2FallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchWindSpeed3Value: Zustand vom 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed3RisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed3FallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchBrightnessEastValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite.

bThresholdSwitchBrightnessEastRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite aktiv wird.

bThresholdSwitchBrightnessEastFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite deaktiv wird.

bThresholdSwitchBrightnessSouthValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite.

bThresholdSwitchBrightnessSouthRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite aktiv wird.

bThresholdSwitchBrightnessSouthFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite deaktiv wird.

bThresholdSwitchBrightnessWestValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite.

bThresholdSwitchBrightnessWestRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite aktiv wird.

bThresholdSwitchBrightnessWestFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite deaktiv wird.

bThresholdSwitchDaylightValue: Zustand vom Schwellwertschalter zur Überwachung der Tageshelligkeit.

bThresholdSwitchDaylightRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Tageshelligkeit aktiv wird.

bThresholdSwitchDaylightFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Tageshelligkeit deaktiv wird.

bThresholdSwitchRainValue: Zustand vom Schwellwertschalter zur Überwachung des Niederschlags.

bThresholdSwitchRainRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung des Niederschlags aktiv wird.

bThresholdSwitchRainFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung des Niederschlags deaktiv wird.


FB_BAFWeatherStationThiesClimaSensorD

Funktionsblock um eine 'Thies Clima Sensor D' Wetterstation direkt aus dem SPS Programm zu steuern.

VAR_INPUT

uiId                                        : UINT;
bStartExecution                             : BOOL;
bStopExecution                              : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der 'Thies Clima Sensor D' Wetterstation.

bStopExecution: Stoppt die Instanz der 'Thies Clima Sensor D' Wetterstation.

VAR_OUTPUT

uiErrorId                                   : UINT;
iErrorParameter                             : INT;
eExecutionState                             : E_BAF_ExecutionState;
lrWindSpeed                                 : LREAL;
lrBrightnessEast                            : LREAL;
lrBrightnessSouth                           : LREAL;
lrBrightnessWest                            : LREAL;
lrDaylight                                  : LREAL;
lrRain                                      : LREAL;
lrRelativeHumidity                          : LREAL;
lrDampedTemperature                         : LREAL;
eTypeOfSeason                               : E_BAF_WeatherStationTypeOfSeason;
bThresholdSwitchTemperatureValue            : BOOL;
bThresholdSwitchTemperatureRisingEdge       : BOOL;
bThresholdSwitchTemperatureFallingEdge      : BOOL;
bThresholdSwitchWindSpeed1Value             : BOOL;
bThresholdSwitchWindSpeed1RisingEdge        : BOOL;
bThresholdSwitchWindSpeed1FallingEdge       : BOOL;
bThresholdSwitchWindSpeed2Value             : BOOL;
bThresholdSwitchWindSpeed2RisingEdge        : BOOL;
bThresholdSwitchWindSpeed2FallingEdge       : BOOL;
bThresholdSwitchWindSpeed3Value             : BOOL;
bThresholdSwitchWindSpeed3RisingEdge        : BOOL;
bThresholdSwitchWindSpeed3FallingEdge       : BOOL;
bThresholdSwitchBrightnessEastValue         : BOOL;
bThresholdSwitchBrightnessEastRisingEdge    : BOOL;
bThresholdSwitchBrightnessEastFallingEdge   : BOOL;
bThresholdSwitchBrightnessSouthValue        : BOOL;
bThresholdSwitchBrightnessSouthRisingEdge   : BOOL;
bThresholdSwitchBrightnessSouthFallingEdge  : BOOL;
bThresholdSwitchBrightnessWestValue         : BOOL;
bThresholdSwitchBrightnessWestRisingEdge    : BOOL;
bThresholdSwitchBrightnessWestFallingEdge   : BOOL;
bThresholdSwitchDaylightValue               : BOOL;
bThresholdSwitchDaylightRisingEdge          : BOOL;
bThresholdSwitchDaylightFallingEdge         : BOOL;
bThresholdSwitchRainValue                   : BOOL;
bThresholdSwitchRainRisingEdge              : BOOL;
bThresholdSwitchRainFallingEdge             : BOOL;
bThresholdSwitchRelativeHumidityValue       : BOOL;
bThresholdSwitchRelativeHumidityRisingEdge  : BOOL;
bThresholdSwitchRelativeHumidityFallingEdge : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der 'Thies Clima Sensor D' Wetterstation.

lrTemperature: Aktuelle Außentemperatur [°C].

lrWindSpeed: Momentane Windgeschwindigkeit [m/s].

lrBrightnessEast: Helligkeit auf der Ostseite [kLux].

lrBrightnessSouth: Helligkeit auf der Südseite [kLux].

lrBrightnessWest: Helligkeit auf der Westseite [kLux].

lrDaylight: Zeigt die Tageshelligkeit an [lux].

lrRain: Wird auf 1.0 gesetzt, sobald Niederschlag erkannt wird. Beachten Sie, dass der Niederschlag bei dieser Wetterstation nur die Werte 0.0 (kein Niederschlag) oder 1.0 (Niederschlag) annehmen kann.

lrRelativeHumidity: Gemessene relative Luftfeuchtigkeit [%].

lrDampedTemperature: Über den Tag gemessene Durchschnittstemperatur [°C].

eTypeOfSeason: Zeigt die Jahreszeit in Abhängigkeit der gedämpften Temperatur an.

bThresholdSwitchTemperatureValue: Zustand vom Schwellwertschalter zur Überwachung der Außentemperatur.

bThresholdSwitchTemperatureRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Außentemperatur aktiv wird.

bThresholdSwitchTemperatureFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Außentemperatur deaktiv wird.

bThresholdSwitchWindSpeed1Value: Zustand vom 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed1RisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed1FallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchWindSpeed2Value: Zustand vom 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed2RisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed2FallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchWindSpeed3Value: Zustand vom 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed3RisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed3FallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchBrightnessEastValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite.

bThresholdSwitchBrightnessEastRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite aktiv wird.

bThresholdSwitchBrightnessEastFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite deaktiv wird.

bThresholdSwitchBrightnessSouthValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite.

bThresholdSwitchBrightnessSouthRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite aktiv wird.

bThresholdSwitchBrightnessSouthFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite deaktiv wird.

bThresholdSwitchBrightnessWestValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite.

bThresholdSwitchBrightnessWestRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite aktiv wird.

bThresholdSwitchBrightnessWestFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite deaktiv wird.

bThresholdSwitchDaylightValue: Zustand vom Schwellwertschalter zur Überwachung der Tageshelligkeit.

bThresholdSwitchDaylightRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Tageshelligkeit aktiv wird.

bThresholdSwitchDaylightFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Tageshelligkeit deaktiv wird.

bThresholdSwitchRainValue: Zustand vom Schwellwertschalter zur Überwachung des Niederschlags.

bThresholdSwitchRainRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung des Niederschlags aktiv wird.

bThresholdSwitchRainFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung des Niederschlags deaktiv wird.

bThresholdSwitchRelativeHumidityValue: Zustand vom Schwellwertschalter zur Überwachung der relativen Luftfeuchtigkeit.

bThresholdSwitchRelativeHumidityRisingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der relativen Luftfeuchtigkeit aktiv wird.

bThresholdSwitchRelativeHumidityFallingEdge: Der Ausgang wird für einen SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der relativen Luftfeuchtigkeit deaktiv wird.


FB_BAFWeatherStationAnalogDigitalSignals

Funktionsblock um eine Wetterstation mit analogen / digitalen Signalen direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                                        : UINT;
bStartExecution                             : BOOL;
bStopExecution                              : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Wetterstation mit analogen / digitalen Signalen.

bStopExecution: Stoppt die Instanz der Wetterstation mit analogen / digitalen Signalen.

VAR_OUTPUT

uiErrorId                                   : UINT;
iErrorParameter                             : INT;
eExecutionState                             : E_BAF_ExecutionState;
lrTemperature                               : LREAL;
lrWindSpeed                                 : LREAL;
lrBrightnessEast                            : LREAL;
lrBrightnessSouth                           : LREAL;
lrBrightnessWest                            : LREAL;
lrDaylight                                  : LREAL;
lrRain                                      : LREAL;
lrRelativeHumidity                          : LREAL;
lrDampedTemperature                         : LREAL;
eTypeOfSeason                               : E_BAF_WeatherStationTypeOfSeason;
bThresholdSwitchTemperatureValue            : BOOL;
bThresholdSwitchTemperatureRisingEdge       : BOOL;
bThresholdSwitchTemperatureFallingEdge      : BOOL;
bThresholdSwitchWindSpeed1Value             : BOOL;
bThresholdSwitchWindSpeed1RisingEdge        : BOOL;
bThresholdSwitchWindSpeed1FallingEdge       : BOOL;
bThresholdSwitchWindSpeed2Value             : BOOL;
bThresholdSwitchWindSpeed2RisingEdge        : BOOL;
bThresholdSwitchWindSpeed2FallingEdge       : BOOL;
bThresholdSwitchWindSpeed3Value             : BOOL;
bThresholdSwitchWindSpeed3RisingEdge        : BOOL;
bThresholdSwitchWindSpeed3FallingEdge       : BOOL;
bThresholdSwitchBrightnessEastValue         : BOOL;
bThresholdSwitchBrightnessEastRisingEdge    : BOOL;
bThresholdSwitchBrightnessEastFallingEdge   : BOOL;
bThresholdSwitchBrightnessSouthValue        : BOOL;
bThresholdSwitchBrightnessSouthRisingEdge   : BOOL;
bThresholdSwitchBrightnessSouthFallingEdge  : BOOL;
bThresholdSwitchBrightnessWestValue         : BOOL;
bThresholdSwitchBrightnessWestRisingEdge    : BOOL;
bThresholdSwitchBrightnessWestFallingEdge   : BOOL;
bThresholdSwitchDaylightValue               : BOOL;
bThresholdSwitchDaylightRisingEdge          : BOOL;
bThresholdSwitchDaylightFallingEdge         : BOOL;
bThresholdSwitchRainValue                   : BOOL;
bThresholdSwitchRainRisingEdge              : BOOL;
bThresholdSwitchRainFallingEdge             : BOOL;
bThresholdSwitchRelativeHumidityValue       : BOOL;
bThresholdSwitchRelativeHumidityRisingEdge  : BOOL;
bThresholdSwitchRelativeHumidityFallingEdge : BOOL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Wetterstation mit analogen / digitalen Signalen.

lrTemperature: Aktuelle Außentemperatur.

lrWindSpeed: Momentane Windgeschwindigkeit.

lrBrightnessEast: Helligkeit auf der Ostseite.

lrBrightnessSouth: Helligkeit auf der Südseite.

lrBrightnessWest: Helligkeit auf der Westseite.

lrDaylight: Zeigt die Tageshelligkeit an.

lrRain: Gibt die Intensität des Niederschlags an.

lrRelativeHumidity: Gemessene relative Luftfeuchtigkeit.

lrDampedTemperature: Über den Tag gemessene Durchschnittstemperatur.

eTypeOfSeason: Zeigt die Jahreszeit in Abhängigkeit der gedämpften Temperatur an.

bThresholdSwitchTemperatureValue: Zustand vom Schwellwertschalter zur Überwachung der Außentemperatur.

bThresholdSwitchTemperatureRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Außentemperatur aktiv wird.

bThresholdSwitchTemperatureFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Außentemperatur deaktiv wird.

bThresholdSwitchWindSpeed1Value: Zustand vom 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed1RisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed1FallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 1. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchWindSpeed2Value: Zustand vom 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed2RisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed2FallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 2. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchWindSpeed3Value: Zustand vom 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit.

bThresholdSwitchWindSpeed3RisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit aktiv wird.

bThresholdSwitchWindSpeed3FallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der 3. Schwellwertschalter zur Überwachung der Windgeschwindigkeit deaktiv wird.

bThresholdSwitchBrightnessEastValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite.

bThresholdSwitchBrightnessEastRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite aktiv wird.

bThresholdSwitchBrightnessEastFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Ostseite deaktiv wird.

bThresholdSwitchBrightnessSouthValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite.

bThresholdSwitchBrightnessSouthRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite aktiv wird.

bThresholdSwitchBrightnessSouthFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Südseite deaktiv wird.

bThresholdSwitchBrightnessWestValue: Zustand vom Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite.

bThresholdSwitchBrightnessWestRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite aktiv wird.

bThresholdSwitchBrightnessWestFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Helligkeit auf der Westseite deaktiv wird.

bThresholdSwitchDaylightValue: Zustand vom Schwellwertschalter zur Überwachung der Tageshelligkeit.

bThresholdSwitchDaylightRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Tageshelligkeit daktiv wird.

bThresholdSwitchDaylightFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der Tageshelligkeit deaktiv wird.

bThresholdSwitchRainValue: Zustand vom Schwellwertschalter zur Überwachung des Niederschlags.

bThresholdSwitchRainRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung des Niederschlags aktiv wird.

bThresholdSwitchRainFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung des Niederschlags deaktiv wird.

bThresholdSwitchRelativeHumidityValue: Zustand vom Schwellwertschalter zur Überwachung der relativen Luftfeuchtigkeit.

bThresholdSwitchRelativeHumidityRisingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der relativen Luftfeuchtigkeit aktiv wird.

bThresholdSwitchRelativeHumidityFallingEdge: Der Ausgang wird für ein SPS-Zyklus auf true gesetzt, wenn der Schwellwertschalter zur Überwachung der relativen Luftfeuchtigkeit deaktiv wird.


FB_BAFPowerMeasurementKL3403

Funktionsblock um eine Energiemessung direkt aus dem SPS Programm zu Steuern.

VAR_INPUT

uiId                             : UINT;
bStartExecution                  : BOOL;
bStopExecution                   : BOOL;
bResetEnergyConsumption          : BOOL;

uiId: Objekt-Id der Instanz (siehe auch).

bStartExecution: Startet die Instanz der Energiemessung.

bStopExecution: Stoppt die Instanz der Energiemessung.

bResetEnergyConsumption: Setzt die Werte der Energiemessung zurück.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
lrCurrentRMSValuesL1             : LREAL;
lrCurrentRMSValuesL2             : LREAL;
lrCurrentRMSValuesL3             : LREAL;
lrVoltageRMSValuesL1             : LREAL;
lrVoltageRMSValuesL2             : LREAL;
lrVoltageRMSValuesL3             : LREAL;
lrEffectivePowerL1               : LREAL;
lrEffectivePowerL2               : LREAL;
lrEffectivePowerL3               : LREAL;
lrEnergyConsumptionsL1           : LREAL;
lrEnergyConsumptionsL2           : LREAL;
lrEnergyConsumptionsL3           : LREAL;
lrPowerFactorsL1                 : LREAL;
lrPowerFactorsL2                 : LREAL;
lrPowerFactorsL3                 : LREAL;
lrEffectivePower                 : LREAL;
lrEnergyConsumption              : LREAL;
lrPowerFactor                    : LREAL;
lrIdlePower                      : LREAL;
lrApparentPower                  : LREAL;
lrFrequencyL1                    : LREAL;
lrFrequencyL2                    : LREAL;
lrFrequencyL3                    : LREAL;
lrCurrentRMSValue                : LREAL;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand der Instanz der Energiemessung.

lrCurrentRMSValuesL1: Aktuelle Stromstärke von Phase L1.

lrCurrentRMSValuesL2: Aktuelle Stromstärke von Phase L2.

lrCurrentRMSValuesL3: Aktuelle Stromstärke von Phase L3.

lrVoltageRMSValuesL1: Spannungswert von Phase L1.

lrVoltageRMSValuesL2: Spannungswert von Phase L2.

lrVoltageRMSValuesL3: Spannungswert von Phase L3.

lrEffectivePowerL1: Wirkleistung von Phase L1.

lrEffectivePowerL2: Wirkleistung von Phase L2.

lrEffectivePowerL3: Wirkleistung von Phase L3.

lrEnergyConsumptionsL1: Energieverbrauch von Phase L1.

lrEnergyConsumptionsL2: Energieverbrauch von Phase L2.

lrEnergyConsumptionsL3: Energieverbrauch von Phase L3.

lrPowerFactorsL1: Leistungsfaktor von Phase L1.

lrPowerFactorsL2: Leistungsfaktor von Phase L2.

lrPowerFactorsL3: Leistungsfaktor von Phase L3.

lrEffectivePower: Wirkleistung aller Phasen.

lrEnergyConsumption: Energieverbrauch aller Phasen.

lrPowerFactor: Leistungsfaktor aller Phasen.

lrIdlePower: Gesamte Blindleistung.

lrApparentPower: Summe der Scheinleistung.

lrFrequencyL1: Frequenz von Phase L1.

lrFrequencyL2: Frequenz von Phase L2.

lrFrequencyL3: Frequenz von Phase L3.

lrCurrentRMSValue: Gesamte Stromstärke.


FB_BAFApplicationProgram

Funktionsblock zum Starten und Stoppen des Applikationsprogramms. Der Baustein liefert noch weitere, allgemeine Informationen. Diese können beim Ergänzen des SPS-Programms hilfreich sein.

VAR_INPUT

bStartExecution                  : BOOL;
bStopExecution                   : BOOL;

bStartExecution: Startet das Applikationsprogramm.

bStopExecution: Stoppt das Applikationsprogramm.

VAR_OUTPUT

uiErrorId                        : UINT;
iErrorParameter                  : INT;
eExecutionState                  : E_BAF_ExecutionState;
stApplicationVersion             : ST_BAF_ApplicationVersion;
bFirstCycle                      : BOOL;
dtLocalTimeDate                  : DT;
dtGreenwichMeanTimeDate          : DT;
lrSunAzimuth                     : LREAL;
lrSunElevation                   : LREAL;
todSunrise                       : TOD;
todSunset                        : TOD;

uiErrorId: Beinhaltet den Fehlercode des zuletzt ausgeführten Befehls (siehe Fehlercodes).

iErrorParameter: Beinhaltet die spezifischen Parameter des Fehlercodes (siehe Fehlercodes).

eExecutionState: Beinhaltet den aktuellen Ausführungszustand des Applikationsprogramms.

stApplicationVersion: Beinhaltet die Versionsnummer des Applikationsprogramms.

bFirstCycle: Wechselt das Applikationsprogramm in den Ausführungszustand Running, so wird dieser Ausgang für ein SPS-Zyklus gesetzt.

dtLocalTimeDate: Die lokale Uhrzeit.

dtGreenwichMeanTimeDate: Greenwich-Zeit (GMT).

lrSunAzimuth: Sonnenrichtung (0° Norden / 90° Osten / 180° Süden / 270° Westen).

lrSunElevation: Sonnenhöhe (0° horizontal / 90° vertikal).

todSunrise: Der berechnete Zeitpunkt des Sonnenaufgangs. Für eine korrekte Berechnung muss der Längen- und Breitengrad angegeben werden (siehe Projekt --> Einstellungen --> Position).

todSunset: Der berechnete Zeitpunkt des Sonnenuntergangs.


SPS Funktionsblöcke Datentypen

TS8100 | TwinCAT Building Automation Framework V2.2x

Datentypen

ST_BAF_ApplicationVersion

TYPE ST_BAF_ApplicationVersion:
STRUCT
  usiMajor     : USINT;
  usiMinor     : USINT;
  uiBuild      : UINT;
END_STRUCT
END_TYPE

E_BAF_ExecutionState

TYPE E_BAF_ExecutionState :
(
  eBAFExecutionStateInvalid := 0,
  eBAFExecutionStateStarting,
  eBAFExecutionStateLoadingConfiguration,
  eBAFExecutionStateConfigurationLoaded,
  eBAFExecutionStateCheckingConfiguration,
  eBAFExecutionStateConfigurationChecked,
  eBAFExecutionStateInitializing,
  eBAFExecutionStateInitialized,
  eBAFExecutionStateRunning,
  eBAFExecutionStateStopping,
  eBAFExecutionStateStopped
);
END_TYPE

E_BAF_SuntrackingOperatingMode

TYPE E_BAF_SuntrackingOperatingMode :
(
  eBAFSuntrackingOperatingModeNormal := 0,
  eBAFSuntrackingOperatingModeCalibrating := 1,
  eBAFSuntrackingOperatingModeReversing := 2,
  eBAFSuntrackingOperatingModeAngleForMaximumShading := 3,
  eBAFSuntrackingOperatingModeAngleForMaximumIllumination := 4,
  eBAFSuntrackingOperatingModeCompletelyClosed := 5,
  eBAFSuntrackingOperatingModeBlindHorizontal := 6,
  eBAFSuntrackingOperatingModeDriveUp := 7,
  eBAFSuntrackingOperatingModeOutOfOperatingRange := 10,
  eBAFSuntrackingOperatingModeTheSunHasSet := 11
);
END_TYPE

E_BAF_SuntrackingControlMode

TYPE E_BAF_SuntrackingControlMode:
(
  eBAFSuntrackingControlModeManual := 0,
  eBAFSuntrackingControlModeAutomatic := 1
);
END_TYPE

E_BAF_HVACEnergyLevel

TYPE E_BAF_HVACEnergyLevel :
(
  eBAFHVACEnergyLevelProtection := 1,
  eBAFHVACEnergyLevelEconomy := 2,
  eBAFHVACEnergyLevelPreComfort := 3,
  eBAFHVACEnergyLevelComfort := 4
);
END_TYPE

E_BAF_HVACControlFunction

TYPE E_BAF_HVACControlFunction :
(
  eBAFHVACControlFunctionOff := 0,
  eBAFHVACControlFunctionHeating := 1,
  eBAFHVACControlFunctionCooling := 2
);
END_TYPE

E_BAF_WeatherStationTypeOfSeason

TYPE E_BAF_WeatherStationTypeOfSeason :
(
  eBAFWeatherStationTypeOfSeasonUndefined := 0,
  eBAFWeatherStationTypeOfSeasonSummer := 1,
  eBAFWeatherStationTypeOfSeasonWinter := 2
);
END_TYPE


SPS Funktionsblöcke Fehlercodes

TS8100 | TwinCAT Building Automation Framework V2.2x

Fehlercodes

Hex | Dez | Beschreibung | Parameter
0x0000 0 Kein Fehler. -
0x8001 32769 Der SPS Funktionsblock sendet Befehle an ein Objekt, dass sich nicht im Zustand Ausführung befindet. -
0x8002 32770 Die Id liegt außerhalb des gültigen Bereichs. -
0x8003 32771 Der Typ des Objekts ist nicht kompatibel zum SPS-Funktionsblock. -
0x8004 32772 Status Byte eines Klemmenkanals ist ungleich 0. -
0x8005 32773 Noch keine Daten empfangen. -
0x8006 32774 Zeitüberschreitung. -
0x8007 32775 Falsche Version der Boot-Konfiguration. -
0x8008 | 32776 | Fehler beim Öffnen der Boot-Konfigurationsdatei der Szenen auf dem Zielsystem. | Fehler Id von FB_FileOpen()
0x8009 | 32777 | Fehler beim Lesen der Boot-Konfigurationsdatei der Szenen auf dem Zielsystem. | Fehler Id von FB_FileRead()
0x800A | 32778 | Fehler beim Schreiben der Boot-Konfigurationsdatei der Szenen auf dem Zielsystem. | Fehler Id von FB_FileWrite()
0x800B | 32779 | Fehler beim Schließen der Boot-Konfigurationsdatei der Szenen auf dem Zielsystem. | Fehler Id von FB_FileClose()
0x800C | 32780 | Fehler beim Öffnen der Boot-Konfigurationsdatei auf dem Zielsystem. | Fehler Id von FB_FileOpen()
0x800D | 32781 | Fehler beim Lesen der Boot-Konfigurationsdatei auf dem Zielsystem. | Fehler Id von FB_FileRead()
0x800E | 32782 | Fehler beim Schreiben der Boot-Konfigurationsdatei auf dem Zielsystem. | Fehler Id von FB_FileWrite()
0x800F | 32783 | Fehler beim Schließen der Boot-Konfigurationsdatei auf dem Zielsystem. | Fehler Id von FB_FileClose()
0x8015 32789 Die Parameter des Beschattungs-Objektes sind ungültig. 1: Die Id von BlindDriveGroup liegt außerhalb des gültigen Bereichs.
2: Die Id von DigitalSignalGroupUp liegt außerhalb des gültigen Bereichs.
3: Die Id von DigitalSignalGroupDown liegt außerhalb des gültigen Bereichs.
4: Die Id von WeatherStation liegt außerhalb des gültigen Bereichs.
5: Die Id von RoomTemperatureSignalGroup liegt außerhalb des gültigen Bereichs.
6: Die Id von MotionDetectionDigitalSignalGroup liegt außerhalb des gültigen Bereichs.
7: Die Id von DigitalSignalGroupAutomaticOff liegt außerhalb des gültigen Bereichs.
8: Die Id von DigitalSignalGroupUpDown liegt außerhalb des gültigen Bereichs.
0x8016 32790 Die Parameter des Lampen-Objektes sind ungültig. 1: MinControlValue ist größer oder gleich MaxControlValue.
2: FadeSteps ist größer oder gleich (MaxControlValue - MinControlValue).
3: Die Id von DALILine liegt außerhalb des gültigen Bereichs.
4: DALIShortAddress liegt außerhalb des gültigen Bereichs.
0x8017 32791 Die Parameter des Beleuchtung-Objektes sind ungültig. 1: Die Id von ActualValueSignalGroup liegt außerhalb des gültigen Bereichs.
2: Die Id von LampGroup liegt außerhalb des gültigen Bereichs.
3: Die Id von DigitalSignalGroupDimmUp liegt außerhalb des gültigen Bereichs.
4: Die Id von DigitalSignalGroupDimmDown liegt außerhalb des gültigen Bereichs.
5: Die Id von DigitalSignalGroupDimmUpDown liegt außerhalb des gültigen Bereichs.
6: Die Id von DigitalSignalGroupMotionDetection liegt außerhalb des gültigen Bereichs.
7: Die Id von DigitalSignalGroupMotionDetection ist 0.
8: PresenceValue ist kleiner als 0.
9: ProlongValue ist kleiner als 0.
10: Die Id von ActualValueSignalGroupId liegt außerhalb des gültigen Bereichs.
11: Die Id von ActualValueSignalGroupId ist 0.
12: Berechneter Tiefpunkt der Hysterese (BasicSetpointValue + SetpointValueShift - ControlHysteresis / 2) ist kleiner als 0.
13: SwitchOnLevel ist kleiner als 0.
14: SetpointValueShiftStepSize ist kleiner als 0.
15: MaximalSetpointValueShift ist kleiner als MinimalSetpointValueShift.
16: Die Id von LampGroupSub1Id liegt außerhalb des gültigen Bereichs.
17: Die Id von LampGroupSub2Id liegt außerhalb des gültigen Bereichs.
18: FactorControlValueSubLampGroup1 ist kleiner als 0.
19: FactorControlValueSubLampGroup2 ist kleiner als 0.
20: MaxControlDelay ist kleiner als das Minimum von t#1s.
21: ControlHysteresis ist kleiner als 0.
22: ControlOnUpperLimit ist kleiner oder gleich 0.
23: Die Id von WeatherStation liegt außerhalb des gültigen Bereichs.
24: Die Id von WeatherStation ist 0.
0x8018 32792 Die Parameter des HLK-Objektes sind ungültig. 1: Die Id von AnalogSignalGroupRoomTemperature liegt außerhalb des gültigen Bereichs.
2: Die Id von AnalogSignalSetpointValueShift liegt außerhalb des gültigen Bereichs.
3: Die Id von DigitalSignalGroupDewPoint liegt außerhalb des gültigen Bereichs.
4: Die Id von DigitalSignalGroupWindowContact liegt außerhalb des gültigen Bereichs.
5: Die Id von DigitalSignalGroupMotionDetection liegt außerhalb des gültigen Bereichs.
6: -
7: -
8: Die Id von ValveActuatorGroupHeating2Point liegt außerhalb des gültigen Bereichs.
9: Die Id von ValveActuatorGroupCooling2Point liegt außerhalb des gültigen Bereichs.
10: Die Id von ValveActuatorGroupHeatingContinuous liegt außerhalb des gültigen Bereichs.
11: Die Id von ValveActuatorGroupCoolingContinuous liegt außerhalb des gültigen Bereichs.
12: Die Id von WeatherStationOutdoorTemperature liegt außerhalb des gültigen Bereichs.
13: Der Parameter SummerCompensationStartLevel >= SummerCompensationEndLevel.
14: Der Parameter SummerCompensationGradient liegt außerhalb des gültigen Bereichs.
15: Die Sollwerte sind ungültig.
16: Der Parameter PWMPeriodDurationCooling liegt außerhalb des gültigen Bereichs.
17: Der Parameter PWMPeriodDurationHeating liegt außerhalb des gültigen Bereichs.
18: Der Parameter YMinPIDCooling liegt außerhalb des gültigen Bereichs.
19: Der Parameter YMaxPIDCooling liegt außerhalb des gültigen Bereichs.
20: Der Parameter YMinPIDCooling >= YMaxPIDCooling.
21: Der Parameter YMinPIDHeating liegt außerhalb des gültigen Bereichs.
22: Der Parameter YMaxPIDHeating liegt außerhalb des gültigen Bereichs.
23: Der Parameter YMinPIDHeating >= YMaxPIDHeating.
0x8019 32793 Die Parameter des analogen Signal-Objetktes sind ungültig. 1: EnOceanMappingListItem liegt außerhalb des gültigen Bereichs.
2: EnOceanDataByte liegt außerhalb des gültigen Bereichs.
3: Die Id von DALILine liegt außerhalb des gültigen Bereichs.
4: Die DALIShortAddress liegt außerhalb des gültigen Bereichs.
5: Die Id von EnOceanLine liegt außerhalb des gültigen Bereichs.
0x801A 32794 Die Parameter des digitalen Signal-Objektes sind ungültig. 1: EnOceanMappingListItem liegt außerhalb des gültigen Bereichs.
2: EnOceanDataByte liegt außerhalb des gültigen Bereichs.
3: EnOceanDataBit liegt außerhalb des gültigen Bereichs.
4: Die Id von EnOceanLine liegt außerhalb des gültigen Bereichs.
5: Die Id von DALILine liegt außerhalb des gültigen Bereichs.
6: Die DALIShortAddress liegt außerhalb des gültigen Bereichs.
0x801B 32795 Das Signal-Objekt für den aktuellen Wert befindet sich im Fehlerzustand. -
0x801C 32796 Das Signal-Objekt für den Taupunktwert befindet sich im Fehlerzustand. -
0x801D 32797 Die Parameter des Fenster-Objektes sind ungültig. 1: Die Id von WindowDriveGroup liegt außerhalb des gültigen Bereichs.
2: Die Id von DigitalSignalGroupClose liegt außerhalb des gültigen Bereichs.
3: Die Id von DigitalSignalGroupOpen liegt außerhalb des gültigen Bereichs.
0x801E 32798 Das DALI-Vorschaltgerät befindet sich im Fehlerzustand. -
0x801F 32799 Die KL3403 befindet sich im Fehlerzustand. 0x100: Zeitüberschreitungsfehler. Die erlaubte Ausführungszeit wurde überschritten.
0x200: Parameterfehler (z.B. eine falsche Registernummer).
0x300: Die gesammelten Werte unterscheiden sich von den geschriebenen Werten. (Schreibzugriff auf das Register ist wohlmöglich nicht erlaubt oder schlug fehl).
0x8020 32800 Die Parameter des iFront Jalousieantrieb-Objektes sind ungültig. -
0x8021 32801 Überlastung - Der Schleppabstand (LagDistance) größer als erlaubt. -
0x8022 32802 Geber zählt nicht. -
0x8023 32803 Antrieb nicht kalibriert (bei Start zur Zielposition). -
0x8024 32804 Klemme nicht bereit. -
0x8025 32805 Klemmenfehler. -
0x8026 32806 Die Parameter des Zeitschaltkanal-Objektes sind ungültig. 1: Periodizität ist gleich 0 oder größer als 365.
2: Periodizität ist gleich 0 oder größer als 52.
3: Kein Wochentag ausgewählt.
4: Es konnte kein Schaltereignis innerhalb der nächsten 1500 Tage ermittelt werden.
5: Periodizität ist gleich 0 oder größer 31.
6: Kein Monat ausgewählt.
7: Periodizität ist gleich 0 oder größer als 4.
8: Der Initialtag ist gleich 0 oder größer als 365.
9: Die Initialwoche ist gleich 0 oder größer als 52.
0x8027 32807 Die Parameter des Wetterstation-Objektes sind ungültig. 1: Die Id von AnalogSignalTemperature liegt außerhalb des gültigen Bereichs.
2: Die Id von AnalogSignalWindSpeed liegt außerhalb des gültigen Bereichs.
3: Die Id von AnalogSignalBrightnessEast liegt außerhalb des gültigen Bereichs.
4: Die Id von AnalogSignalBrightnessSouth liegt außerhalb des gültigen Bereichs.
5: Die Id von AnalogSignalBrightnessWest liegt außerhalb des gültigen Bereichs.
6: Die Id von AnalogSignalDaylight liegt außerhalb des gültigen Bereichs.
7: Die Id von AnalogSignalRain liegt außerhalb des gültigen Bereichs.
8: Die Id von AnalogSignalRelativeHumidity liegt außerhalb des gültigen Bereichs.
9: Die Id von SerialCommunicationLine liegt außerhalb des gültigen Bereichs.
0x8028 32808 Fehler beim Zugriff auf DALI-Vorschaltgerät. 1: Keine Antwort von der DALI-Klemme.
2: Keine Antwort von dem DALI-Vorschaltgerät.
3: Überlauf Kommunikationsbuffer.
4: Keine Antwort von dem Kommunikationsbaustein.
5: DALI-Kollision auf dem Rückkanal (Backward Channel) erkannt: während der Übertragung eines DALI-Telegramms wurde eine Kollision mit den Sendedaten eines anderen DALI-Slaves erkannt.
6: DALI-Kollision auf dem Hinkanal (Foreward Channel) erkannt: während der Übertragung eines DALI-Telegramms wurde eine Kollision mit den Sendedaten eines anderen DALI-Masters erkannt.
7: Überlastung des internen DALI-Netzteils der KL6811 (Busunterspannung).
0x8029 32809 Fehler beim Empfang der Daten am Wetterstation-Objektes. 1: Zeitüberschreitung.
2: Datenpaket hat falsche Länge.
3: Fehler Prüfsumme.
0x802A 32810 Die Parameter des zusammengesetztes Modul-Objektes sind ungültig. 1: Die Id von DigitalSignalPushButton liegt außerhalb des gültigen Bereichs.
2: Die Id von LampFeedbackLED liegt außerhalb des gültigen Bereichs.
3: Die Id von Lighting liegt außerhalb des gültigen Bereichs.
4: Die Id von SunblindWindow liegt außerhalb des gültigen Bereichs.
5: Die Id von Scene liegt außerhalb des gültigen Bereichs.
0x802B | 32811 | Die Parameter des Jalousieantrieb-Objektes sind ungültig. | 1: Die Id von DigitalSignalGroupLockDriveDown ist außerhalb des gültigen Bereichs.
0x802C 32812 Klemme ist nicht initialisiert. -
0x802D 32813 Drehrichtung vom Motor ist falsch. Verkabelung prüfen. -