Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Spezifikation "Index-Group" für NC ( ID [0x01...0xFF] )

Spezifikation "Index-Group" für NC ( ID [0x01...0xFF] )

Index-Group ( Hex ) |  | Beschreibung | Anmerkung
0x1000 |  | Ring-0-Manager: Parameter | Optional !
0x1100 |  | Ring-0-Manager: Zustand | Optional !
0x1200 |  | Ring-0-Manager: Funktionen | Optional !
0x1300 |  | Ring-0-Manager: zyklische Prozessdaten | Nicht implementiert !
0x2000 + ID |  | Kanal mit entspr. ID: Parameter |
0x2100 + ID |  | Kanal mit entspr. ID: Zustand |
0x2200 + ID |  | Kanal mit entspr. ID: Funktionen |
0x2300 + ID |  | Kanal mit entspr. ID: zyklische Prozessdaten |
0x3000 + ID |  | Gruppe mit entspr. ID: Parameter | Optional !
0x3100 + ID |  | Gruppe mit entspr. ID: Zustand | Optional !
0x3200 + ID |  | Gruppe mit entspr. ID: Funktionen | Optional !
0x3300 + ID |  | Gruppe mit entspr. ID: zyklische Prozessdaten | Nicht implementiert !
0x4000 + ID |  | Achse mit entspr. ID: Parameter |
0x4100 + ID |  | Achse mit entspr. ID: Zustand |
0x4200 + ID |  | Achse mit entspr. ID: Funktionen |
0x4300 + ID |  | Achse mit entspr. ID: zyklische Prozessdaten |
0x5000 + ID |  | Encoder mit entspr. ID: Parameter | Optional !
0x5100 + ID |  | Encoder mit entspr. ID: Zustand | Optional !
0x5200 + ID |  | Encoder mit entspr. ID: Funktionen | Optional !
0x5300 + ID |  | Encoder mit entspr. ID: zyklische Prozessdaten | Optional !
0x6000 + ID |  | Regler mit entspr. ID: Parameter | Optional !
0x6100 + ID |  | Regler mit entspr. ID: Zustand | Optional !
0x6200 + ID |  | Regler mit entspr. ID: Funktionen | Optional !
0x6300 + ID |  | Regler mit entspr. ID: zyklische Prozessdaten | Nicht implementiert !
0x7000 + ID |  | Drive mit entspr. ID: Parameter | Optional !
0x7100 + ID |  | Drive mit entspr. ID: Zustand | Optional !
0x7200 + ID |  | Drive mit entspr. ID: Funktionen | Optional !
0x7300 + ID |  | Drive mit entspr. ID: zyklische Prozessdaten | Optional !
0xA000 + ID |  | Tabellen (n x m) mit entspr. ID: Parameter |
0xA100 + ID |  | Tabellen (n x m) mit entspr. ID: Zustand |
0xA200 + ID |  | Tabellen (n x m) mit entspr. ID: Funktionen |
0xA300 + ID |  | Tabellen (n x m) mit entspr. ID: zyklische Prozessdaten | Nicht implementiert !
0xF000 ... 0xFFFF |  | Reservierter Bereich (TwinCAT Systembereich) |
IndexGroup: | IndexOffset: |  |
0xF081 | 0x00000000 ... 0xFFFFFFFF (n Elemente) | ADSIGRP_SUMUP_WRITE Das Read-Write-Kommando ist ein Sammelkommando und enthält in den Write-Daten eine Liste von mehreren ADS-Write-Kommandos. Aufbau der Write-Daten: [ IdxGrp(1), IdxOff(1), WriteLen(1), ..., IdxGrp(n), IdxOff(n), WriteLen(n), WriteData(1), ..., WriteData(n) ] Aufbau der Read-Daten: [ Error(1), ..., Error(n) ] |
0xF082 | 0x00000000 ... 0xFFFFFFFF (n Elemente) | ADSIGRP_SUMUP_READWRITE Das Read-Write-Kommando ist ein Sammelkommando und enthält in den Write-Daten eine Liste von mehreren ADS-Read-Write-Kommandos. Aufbau der Write-Daten: [ IdxGrp(1), IdxOff(1), ReadLen(1), WriteLen(1), ..., IdxGrp(n), IdxGrp(n), ReadLen(n), WriteLen(n), WriteData(1), ..., WriteData(n) ] Aufbau der Read-Daten: [ Error(1), ReadLen(1), ..., Error(n), ReadLen(n), ReadData(1), ..., ReadData(n) ] |
0xF084 | 0x00000000 ... 0xFFFFFFFF (n Elemente) | ADSIGRP_SUMUP_READ (READEX2) Das Read-Write-Kommando ist ein Sammelkommando und enthält in den Write-Daten eine Liste von mehreren ADS-Read-Kommandos. Aufbau der Write-Daten: [ IdxGrp(1), IdxOff(1), ReadLen(1), ..., IdxGrp(n), IdxGrp(n), ReadLen(n) ] Aufbau der Read-Daten: [ Error(1), ReadLen(1), ..., Error(n), ReadLen(n), ReadData(1), ..., ReadData(n) ] |


"Index-Offset" Spezifikation für Ring-0-Parameter (Index-Group 0x1000)

"Index-Offset" Spezifikation für Ring-0-Parameter (Index-Group 0x1000)

Index-Offset (Hex) | Zugriff | Ring 0 Manager | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000010 | Read | every | UINT32 | 100 ns |  | Zykluszeit SAF Task |
0x00000012 | Read | every | UINT32 | 100 ns |  | Zykluszeit SVB Task |
0x00000014 | Read | every | INT32 | ns |  | Global Time Compensation Shift (SAF Task) | NEU ab TC 211R3 Build 2234
0x00000020 | Read/Write | every | UINT16 | 1 | 0/1 | zyklische Überwachung und Korrektur der NC-Sollwerte auf Datenkonsistenz | ab TC 2.11 B1550


"Index-Offset" Spezifikation für Ring-0-Zustand (Index-Group 0x1100)

"Index-Offset" Spezifikation für Ring-0-Zustand (Index-Group 0x1100)

Index-Offset (Hex) | Zugriff | Ring 0 Manager | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | UINT32 | 1 | 0, 1...255 | Anzahl der Kanäle |
0x00000002 | Read | every | UINT32 | 1 | 0, 1...255 | Anzahl der Gruppen |
0x00000003 | Read | every | UINT32 | 1 | 0, 1...255 | Anzahl der Achsen |
0x00000004 | Read | every | UINT32 | 1 | 0, 1...255 | Anzahl der Encoder |
0x00000005 | Read | every | UINT32 | 1 | 0, 1...255 | Anzahl der Regler |
0x00000006 | Read | every | UINT32 | 1 | 0, 1...255 | Anzahl der Drives |
0x0000000A | Read | every | UINT32 | 1 | 0, 1...255 | Anzahl der Tabellen (n x m) |
0x00000010 | Read | every | UINT32 | 1 |  | Zykluszeitfehlerzähler SAF Task (nicht scopebar) | Reserviert !
0x00000014 | Read | every | UINT32 | 1 |  | IO-Zykluszeitfehlerzähler SAF Task (nicht scopebar) | Reserviert !
0x00000020 | Read | every | UINT32 | µs |  | Rechenzeit SAF Task (nicht scopebar) | Reserviert !
0x00000031 | Read | every | UINT32[Anzahl] | 1 | 0, 1...255 | Liefert die Kanal-IDs für sämtliche Kanäle im System |
0x00000032 | Read | every | UINT32[Anzahl] | 1 | 0, 1...255 | Liefert die Gruppen-IDs für sämtliche Gruppen im System |
0x00000033 | Read | every | UINT32[Anzahl] | 1 | 0, 1...255 | Liefert die Achs-IDs für sämtliche Achsen im System |
0x00000034 | Read | every | UINT32[Anzahl] | 1 | 0, 1...255 | Liefert die Encoder-IDs für sämtliche Encoder im System |
0x00000035 | Read | every | UINT32[Anzahl] | 1 | 0, 1...255 | Liefert die Regler-IDs für sämtliche Regler im System |
0x00000036 | Read | every | UINT32[Anzahl] | 1 | 0, 1...255 | Liefert die Drive-IDs für sämtliche Drives im System |
0x0000003A | Read | every | UINT32[Anzahl] | 1 | 0, 1...255 | Liefert die Tabellen-IDs für sämtliche Tabellen im System |
0x000001nn | Read | every | UINT32 | 1 | 0, 1...255 | Liefert für die Encoder-ID die zugehörige Achs-ID nn = Encoder-ID | Reserviert !
0x000002nn | Read | every | UINT32 | 1 | 0, 1...255 | Liefert für die Controller-ID die zugehörige Achs-ID nn = Controller-ID | Reserviert !
0x000003nn | Read | every | UINT32 | 1 | 0, 1...255 | Liefert für die Drive-ID die zugehörige Achs-ID nn = Drive-ID | Reserviert !


"Index-Offset" Spezifikation für Ring-0-Funktionen (Index-Group 0x1200)

"Index-Offset" Spezifikation für Ring-0-Funktionen (Index-Group 0x1200)

Index-Offset (Hex) | Zugriff | Ring 0 Manager | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000020 | Write | every | VOID | 1 |  | Clear Zykluszeitfehlerzähler SAF & SVB | Reserviert !


"Index-Offset" Spezifikation für Kanal-Parameter (Index-Group 0x2000 + ID)

"Index-Offset" Spezifikation für Kanal-Parameter (Index-Group 0x2000 + ID)

Index-Offset (Hex) | Zugriff | Kanal- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | UINT32 | 1 |  | Kanal-ID |
0x00000002 | Read | every | UINT8[30+1] | 1 |  | Kanal-Name |
0x00000003 | Read | every | UINT32 | 1 | ENUM | Kanal-Typ |
0x00000004 | Read | every | UINT32 | 1 | ENUM | Interpreter-Typ |
0x00000005 | Read | every | UINT32 | 1 |  | Programmladepuffergröße in Byte |
0x00000006 | Read | every | UINT32 | 1 |  | Programm-Nr laut Job-Liste |
0x00000007 | Read / Write | every | UINT32 | 1 | ENUM | Setze Lade-Logmodus |
0x00000008 | Read / Write | every | UINT32 | 1 | ENUM | Setze Trace-Modus |
0x00000009 | Read / Write | every | UINT32 | 1 |  | RESERVIERT |
0x0000000A | Read / Write | every | UINT32 | 1 | 0/1 | Protokolliert alle Feeder-Einträge in einer Log-Datei mit dem Namen "TcNci.log" |
0x0000000B | Read / Write | every | UINT32 | 1 | 0/1 | kanalspezifischer Level für NC Logger Messages 0: nur Fehler 1: alle NC-Meldungen | ab TwinCAT V2.8 B747 V2.9 B948
0x00000010 | ReadWrite | every | Write |  |  |  |
 |  |  | { |  |  |
 |  |  | UINT32 | 1 | 0..159 | Start Index der M-Fkt.
 |  |  | UINT32 | 1 | 1..160 | Anzahl der zu lesenden M-Fkt.
 |  |  | } |  |  |
 |  |  | Read[Anzahl] |  |  |
 |  |  | { |  |  |
 |  |  | UINT8 | 1 | 0..159 | Regelbit Maske der M-Fkt.
 |  |  | INT32[10] | 1 | -1..159 | Nr. der abzulöschenden M-Fkt.
 |  |  | } |  |  |
0x00000011 | Write | Interpolation |  |  |  | Schreibe M-Funktionsbeschreibung | ab TC V2.9 B803 internal use only!
0x00000012 | Read / Write | Interpolation | LREAL64 | 1 |  | Faktor für G70 | ab TC V2.9 Build 803
0x00000013 | Read / Write | Interpolation | LREAL64 | 1 |  | Faktor für G71 | ab TC V2.9 Build 803
0x00000014 | Write | Interpolation | { |  |  | Benutzersymbole für Achsen | noch nicht freigegeben
 |  |  | char[32] |  |  | Benutzersymbol (nullterminiert)
 |  |  | char[10] |  |  | Systemsymbol (nullterminiert)
 |  |  | } |  |  |
0x00000015 | Read / Write | Interpolation | UINT16 bzw. UINT32 | 1 | 0/1 Default: FALSE | Aktivierung von Default G-Code | NEU ab TC 2.11R3 B2241
0x00000021 | Read | every | UINT32 | 1 |  | Gruppen-ID (nur eindeutig für 3D- und FIFO-Kanal |
0x00000031 | Read / Write | Interpolation | UINT16 | 1 |  | Standard Output Port des Interpreters | Reservierte Funktion, kein Standard!
0x00000032 | Read / Write | Interpolation | UINT16 | 1 | 0/1 | cartesian tool offset entry | Reservierte Funktion, kein Standard!
0x00000040 | Read / Write | Interpolation | { |  |  | Ziel-Adresse des Interpreter Hooks | Reservierte Funktion, kein Standard!
 |  |  | char[6] |  |  | Ams Net ID
 |  |  | UINT16 |  |  | Port
 |  |  | UINT32 |  |  | Index Group
 |  |  | UINT32 |  |  | Index Offset
 |  |  | } |  |  |
0x00000050 | Read / Write | Interpolation | UINT32 | 1 | ENUM | Reaktion wenn bei der Radiuskorrektur ein Flaschenhals erkannt wird 0: Fehler und Abbruch 1: Hinweis & Behebung 2: Nur Hinweis, ohne Konturanpassung | ab TwinCAT Version 2.8
0x00000051 | Read / Write | Interpolation | UINT32 | 1 | 1..24 | Look Ahead für die Flaschenhalserkennung | ab TwinCAT Version 2.8
0x00000052 | Read / Write | Interpolation | UINT32 | 1 | 0/1 | Fase an/aus | Reservierte Funktion, kein Standard!
0x00000053 | Read / Write | Interpolation | UINT32 | 1 |  | Aktivierung zum Lesen der aktuell wirkenden Interpolationsregeln, Nullpunktverschiebungen & Rotation 0: aus 1: ein | ab TC V2.10 B1303
0x00000054 | Read / Write | Interpolation | UINT32 | 1 | 0/1 | Retrace an/aus | Reservierte Funktion, kein Standard!
0x00000055 | Read / Write | Interpolation | UINT32[4] | 1 |  | Konfiguration des zyklischen Kanalinterface für UINT32 max. 4 Index Offsets können konfiguriert werden. | voraussichtlich ab TC V2.10 B1320
0x00000056 | Read / Write | Interpolation | UINT32[4] | 1 |  | Konfiguration des zyklischen Kanalinterface für LREAL max. 4 Index Offsets können konfiguriert werden. | voraussichtlich ab TC V2.10 B1320
0x00010K0L | Read / Write | every | REAL64 | z.B. mm | ±MAX REAL64 | Wert für Nullpunktverschiebung (NPV) |
 |  |  |  |  | [1..3] | Index der Achse: K=1 → X K=2 → Y K=3 → Z
 |  |  |  |  | [1..0xA] | L=1 → G54F L=2 → G54G L=3 → G55F ...
0x0002ww00 | Read / Write | every | UINT16 |  |  | Tool-Nummer: Werte für Werkzeugkorrektur |
0x0003ww00 | Read / Write | every | UINT16 |  | [1...50] | Tool-Typ: ww = Werkzeug 1...50 |
0x0004wwnn | Read / Write | every | REAL64 |  | [1...14] | Parameter: nn = Index 1...14 |
0x000500gg | Read / Write | every | REAL64 | z.B. mm | ≥ 0 (Wert) [1...9] (g) | Radius der Toleranzkugel gg = Gruppe des Kanals (Default: 1) |


"Index-Offset" Spezifikation für Kanal-Zustand (Index-Group 0x2100 + ID)

"Index-Offset" Spezifikation für Kanal-Zustand (Index-Group 0x2100 + ID)

Index-Offset (Hex) | Zugriff | Kanal- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | INT32 | 1 | ENUM | Fehlercode Kanal |
0x00000002 | Read | every | UINT32 | 1 |  | Anzahl Gruppen im Kanal |
0x00000003 | Read | every | UINT32 | 1 | ENUM | Interpreterstatus | Nicht oszilloskopierbar!
0x00000004 | Read | every | UINT32 | 1 |  | Interpreter Betriebsart (interpreter/channel operation mode) |
0x00000005 | Read | every | UINT32 | 1 |  | Aktuell geladenes Programm |
0x00000007 | Read | every | UINT8[...] | 1 |  | Programmname des aktuell geladenen Programms (100 Zeichen, Null-Terminiert) | max. 100 Zeichen, Null-Terminiert
0x00000008 | Read | Interpreter | UINT32 | 1 | [0,1] | Interpreter Simulationsmode 0: off (default) 1: on | ab V2.9 B946 Nicht oszilloskopierbar!
0x00000010 | Read | Interpreter | UINT32 | 1 |  | Text Index Falls sich der Interpreter im Aborted Status befindet, kann hiermit der aktuelle Text Index ausgelesen werden | Nicht oszilloskopierbar!
0x00000011 | ReadWrite | Interpreter | Write |  |  |  | Nicht oszilloskopierbar!
 |  |  | UINT32 | 1 |  | Text Index
 |  |  | Read |  |  |
 |  |  | UINT8[..] | 1 |  | Zeile des NC-Teileporgramms ab dem Textindex
0x00000012 | Read | Interpreter | { |  |  |  | ab TC V2.10 B1243
 |  |  | UINT32 | 1 |  | Aktuelle Anzeige für 1: SAF 2: Interpreter 3: Fehleroffset
 |  |  | UINT32 | 1 |  | Fileoffset
 |  |  | UINT8[260] | 1 |  | Pfad + Programmname
 |  |  | } |  |  |
0x00000013 | Read | Interpreter | UINT32[18] |  |  | Anzeige für aktuell wirkenden G-Code | voraussichtlich ab TC V2.10 B1303
0x00000014 | Read | Interpreter | { |  |  | Ermittlet die aktuell wirkende Nullpunktverschiebung | voraussichtlich ab TC V2.10 B1303
 |  |  | UINT32 | 1 |  | Satzzähler
 |  |  | UINT32 |  |  | dummy
 |  |  | LREAL[3] | 1 |  | Nullpunktverschiebung G54..G57
 |  |  | LREAL[3] | 1 |  | Nullpunktverschiebung G58
 |  |  | LREAL[3] | 1 |  | Nullpunktverschiebung G59
 |  |  | } |  |  |
0x00000015 | Read | Interpreter | { |  |  | Ermittelt die aktuell wirkende Rotation | voraussichtlich ab TC V2.10 B1303
 |  |  | UINT32 | 1 |  | Satzzähler
 |  |  | UINT32 | 1 |  | dummy
 |  |  | LREAL[3] | 1 |  | Rotation in Grad von X, Y & Z
 |  |  | } |  |  |
0x00000016 | Read | Interpreter | UINT32 | 1 | [0,1] | Feeder Info | internal usage kein Standard
0x00000100 | Read | every | UINT32[Anzahl] | 1 | [0, 1...255] | Liefert die jeweiligen Achs-IDs im Kanal | Anzahl: [1...255] Achs-ID's: [0, 1...255] Nicht oszilloskopierbar!


"Index-Offset" Spezifikation für Kanal-Funktionen (Index-Group 0x2200 + ID)

"Index-Offset" Spezifikation für Kanal-Funktionen (Index-Group 0x2200 + ID)

Index-Offset (Hex) | Zugriff | Kanal- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Write | every | UINT32 | 1 |  | Lade NC-Programm per Programmnummer |
0x00000002 | Write | every | VOID |  |  | Starte Interpreter |
0x00000003 | Write | every | VOID |  |  | RESERVIERT |
0x00000004 | Write | every | UINT8[...] |  |  | Lade NC-Programm per Programmnamen. Der Standard NC-Pfad muss nicht (darf aber) mit angegeben werden. Auch andere Pfade sind zulässig. |
0x00000005 | Write | every | UINT16 | ENUM | s. Anhang Interpreter Betriebsarten | Setze Interpreter Betriebsart (interpreter/channel operation mode) | ab TwinCAT V2.9 Buld 901
0x00000006 | Write | Interpreter | UINT8[...] |  |  | Setze Pfad für Unterprogramme | ab TwinCAT V2.9 Build 1001
0x00000008 | Write | Interpreter | UINT32 | 1 |  | Interpreter Simulationsmode: 0: off (default) 1: on | noch nicht freigegeben
0x0000000F | Write | every | VOID |  |  | RESERVIERT |
0x00000010 | Write | every | VOID |  |  | "Reset" Kanal |
0x00000011 | Write | every | VOID |  |  | "Stopp" Kanal |
0x00000012 | Write | every | VOID |  |  | "Retry" Kanal (Wiederanlauf Kanal) | nicht implementiert!
0x00000013 | Write | every | VOID |  |  | "Skip" Kanal (Überspringe Auftrag/Satz) | nicht implementiert!
0x00000014 / 0x00000015 | Write | every | { |  |  | "Enable Retrace" / "Disable Retrace" | Reservierte Funktion, kein Standard!
 |  |  | UINT32 | 1 | >0 | Feeder Abarbeitungsrichtung: 1: vorwärts, 2: rückwärts
 |  |  | UINT32 | 1 | ≥ 0 | Entry-Index
 |  |  | REAL64[3] | mm | ±∞ | Pos. der Hauptachsen X, Y, Z
 |  |  | REAL64[5] | mm | ±∞ | Pos. der Hilfsachsen Q1, ..., Q5
 |  |  | } |  |  |
0x00000020 | Write | every | VOID |  |  | "Save" Nullpunktverschiebung (NPV) |
0x00000021 | Write | every | VOID |  |  | "Load" Nullpunktverschiebung (NPV) |
0x00000022 | Write | every | VOID |  |  | "Save" Werkzeugkorrekturen |
0x00000023 | Write | every | VOID |  |  | "Load" Werkzeugkorrekturen |
0x00000024 | Write | Inter- polation | { |  |  | Speichert Snapshot des Interpreters in eine angegebene Datei | ab TwinCAT V2.9 Build 1002
 |  |  | char[32] |  |  | Dateiname im TwinCAT\CNC-Verzeichnis
 |  |  | UINT32 | 1 | 0..1 | Maske: 0x1: R-Parameter 0x2: Nullpunktverschiebungen (ab Build 1235) 0x4: Werkzeugbeschreibungen (ab Build 1235)
 |  |  | } |  |  |
0x00000025 | Write | Inter- polation | { |  |  | Liest Snapshot aus einer angegebenen Datei in den Interpreter ein | ab TwinCAT V2.9 Build 1002
 |  |  | char[32] |  |  | Dateiname im TwinCAT\CNC-Verzeichnis
 |  |  | UINT32 | 1 | 0..1 | Maske: 0x1: R-Parameter 0x2: Nullpunktverschiebungen (ab Build 1235) 0x4: Werkzeugbeschreibung (ab Build1235)
 |  |  | } |  |  |
0x00000026 | Write | Inter- polation | VOID |  |  | Setzt alle Werkzeugparameter (inkl. Type und Nummer) auf Null | ab TwinCAT V2.9 Build 1031
0x00000027 | Write | Inter- polation | VOID |  |  | Setzt alle Nullpunktverschiebungen auf Null | ab TwinCAT V2.9 Build 1031
0x00000030 | Write | every | VOID |  |  | Wiederanlauf (Go Ahead) des Interpreters nach programmierten Interpreterstopp |
0x00000040 | Write | every | VOID |  |  | Triggerevent zum Restweglöschen in der NCI |
0x00000041 | Write | every |  |  |  | RESERVIERT für Messereignis |
0x00000050 | Write | Inter- polation | VOID | 1 |  | Setzt ExecIdleInfo im Interpreter | Reservierte Funktion, kein Standard!
0x00000051 | Write | Inter- polation | UINT32 | 1 |  | Setzt Satzunterdrückungsmaske im Interpreter Parameter: SkippingMask | Reservierte Funktion, kein Standard!
0x00000052 | Write | Inter- polation | UINT32 | 1 |  | Setzt ItpOperationMode im Interpreter Parameter: Maske des OperationsModes | Reservierte Funktion, kein Standard!
0x00000053 | Write | Inter- polation | VOID |  |  | Setzt ScanningFlag im NC Device | Reservierte Funktion, kein Standard!
0x00000054 | Write | Inter- polation |  |  |  | ScanPosition | Reservierte Funktion, kein Standard!
 |  |  | double[8] |  |  | Position
0x00000055 | Write | Inter- polation |  |  |  | Reserviert |
0x00000056 | Write | Inter- polation | VOID |  |  | Setzt Interpreter in Aborted Status | Reservierte Funktion, kein Standard!
0x00000060 | Write | Interp- polation | UINT16 | 1 | 0..159 | Manuelles Zurücksetzen einer schnellen M-Funktion |


"Index-Offset" Spezifikation für zyklische Kanal-Prozessdaten (Index-Group 0x2300 + ID)

"Index-Offset" Spezifikation für zyklische Kanal-Prozessdaten (Index-Group 0x2300 + ID)

Index-Offset (Hex) | Zugriff | Kanal- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000000 | Read | every (PLC→NC) | {150 Byte} |  | STRUCT s. Kanal-Interface | KANAL-STRUKTUR (PLC→NC) | Die aktuelle zugehörige PLC Struktur ist: NciChannelFromPlc alte Struktur: PLCTONC_CHANNELSTRUCT
0x00000001 | Read | every | UINT8[...] min. 30 Byte | 1 |  | Interpreter Programmanzeige | Nicht oszilloskopierbar!
0x00000002 | Read / Write | every (PLC→NC) | UINT32 | % | [0...1000000] | Geschwindigkeitsoverride Kanal (Achsen im Kanal) | 1000000 = 100%
0x00000003 | Read / Write | every (PLC→NC) | UINT32 | % | [0...1000000] | Geschwindigkeitsoverride Spindel | 1000000 = 100%
0x00000080 | Read | every (NC→PLC) | {150 Byte} |  | STRUCT s. Kanal-Interface | KANAL-STRUKTUR (NC→PLC) | Die aktuelle zugehörige PLC Struktur ist: NciChannelToPlc alte Struktur: NCTOPLC_CHANNELSTRUCT
0x10000000 + Registerindex | Read / Write | every | REAL64 | 1 | [0...999] | R-Parameter des Interpreters | Nicht oszilloskopierbar!
0x20000001 | Read | every | UINT8[...] min. 30 Byte | 1 | [1...9] | Programmanzeige der Gruppenabarbeitung (SAF) | Nicht oszilloskopierbar!


"Index-Offset" Spezifikation für Gruppen-Parameter (Index-Group 0x3000 + ID)

"Index-Offset" Spezifikation für Gruppen-Parameter (Index-Group 0x3000 + ID)

Index-Offset (Hex) | Zugriff | Gruppen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | UINT32 | 1 |  | Gruppen ID |
0x00000002 | Read | every | UINT8[30+1] | 1 |  | Gruppen-Name |
0x00000003 | Read | every | UINT32 | 1 |  | Gruppen-Typ |
0x00000004 | Read | every | UINT32 | µs |  | SAF-Zykluszeit Gruppe |
0x00000005 | Read | every | UINT32 | µs |  | SVB-Zykluszeit Gruppe |
0x00000006 | Read / Write | every | UINT16 | 1 | 0/1 | Einzelsatz-Betriebsart? |
0x0000000B | Read | every | UINT32 | 1 |  | Größe der SVB-Tabelle (max. Anzahl von SVB-Einträgen |
0x0000000C | Read | every | UINT32 | 1 |  | Größe der SAF-Tabelle (max. Anzahl von SAF-Einträgen |
0x00000010 | Read / Write | every | UINT32 | 1 | [1,2...32] | Interner SAF-Zykluszeit Divisor (dividiert die interne SAF-Zykluszeit um diesen Faktor) | Default: 1
0x00000021 | Read | Kanal: every | UINT32 | 1 |  | Kanal-ID |
0x00000022 | Read | Kanal: every | UINT8[30+1] | 1 |  | Kanal-Name |
0x00000023 | Read | Kanal: every | UINT32 | 1 |  | Kanal-Typ |
0x00000024 | Read | Kanal: every | UINT32 | 1 | >0 | Nummer im Kanal |
0x00000500 | Read / Write | DXD-Gruppe | INT32 | ENUM | [0, 1] | Kurvengeschwindigkeits- reduktionsmethode 0: Coulomb-Scattering 1: Cosinus-Gesetz 2: VeloJump |
0x00000501 | Read / Write | DXD-Gruppe | REAL64 | 1 | [0.0...1.0] | Geschwindigkeitsreduktionsfaktor C0-Übergang (stetiger Verlauf, aber weder einmal noch zweimal stetig differenzierbar) |
0x00000502 | Read / Write | DXD-Gruppe | REAL64 | 1 | [0.0...1.0] | Geschwindigkeitsreduktionsfaktor C1-Übergang (stetiger Verlauf und einmal stetig differenzierbar) |
0x00000503 | Read / Write | DXD-Gruppe | REAL64 | Grad | [0.0...180.0] | Kritischer Winkel am Segmentübergang "Low" (muss echt kleiner gleich dem Geschwindigkeitsreduktionswinkel C0 sein) |
0x00000504 | Read / Write | DXD-Gruppe | REAL64 | Grad | [0.0...180.0] | Kritischer Winkel am Segmentübergang "High" (muss echt kleiner gleich dem Geschwindigkeitsreduktionswinkel C0 sein) |
0x00000505 | Read / Write | DXD-Gruppe | REAL64 | mm/s | ≥ 0 | Mindestgeschwindigkeit, die an Segmentübergängen trotz möglicher Geschwindigkeitsreduktion nicht unterschritten werden darf. |
0x00000506 | Read / Write | DXD-Gruppe | REAL64 | z.B. mm | [0.0...1000.0] | Radius der Toleranzkugel für Verschleifungen | nicht implementiert!
0x00000507 | Read / Write | DXD-Gruppe | REAL64 | 1 |  | Geschwindigkeitsreduktionsfaktor C2-Übergang |
0x00000508 | Read / Write | DXD- Gruppe | UINT32 | 1 | 0/1 | aktiviert Berechnung der totalen verbleibenden Bahnlänge |
0x00000509 | Read / Write | DXD- Gruppe | UINT16 | 1 | 0/1 | Allgemeine Aktivierung der Software Endlagenüberwachung für die Hauptachsen (X, Y, Z) (s. Encoderparameter) | ab TwinCAT V2.9 B959
0x0000050A | Read / Write | DXD- Gruppe | UINT32 | 1 | 0/1 | NCI Overridetype 0: Bezogen auf interne reduzierte Geschwindigkeit (ohne Iteration) 1: Bezogen auf originale externe (programmierte) Geschwindigkeit | ab TwinCAT V2.9 B948
0x0000050B | Read / Write | DXD- Gruppe | UINT16 | 1 | 0/1 | NCI Override 0: Override begrenzt auf 100% 1: Override >100% möglich | ab TwinCAT V2.10 B1226 noch nicht freigegeben
0x00000510 | Read / Write | DXD-Gruppe | REAL64 | 1 | ≥ 0 | Für Reduktionsmethode VeloJump Reduktionsfaktor für C0-Übergänge: X-Achse | nicht implementiert!
0x00000511 | Read / Write | DXD-Gruppe | REAL64 | 1 | ≥ 0 | Für Reduktionsmethode VeloJump Reduktionsfaktor für C0-Übergänge: Y-Achse | nicht implementiert!
0x00000512 | Read / Write | DXD-Gruppe | REAL64 | 1 | ≥ 0 | Für Reduktionsmethode VeloJump Reduktionsfaktor für C0-Übergänge: Z-Achse | nicht implementiert!
0x00000513 | Read / Write | DXD-Gruppe | LREAL64 | 1 | ]0.0..1.0[ | Verschleifung für Hilfsachen: Ist die resultierende Bahngeschwindigkeit kleiner als die prog. mal diesem Faktor, so wird ein Genauhalt eingefügt | voraussichtlich ab TwinCAT V2.11 B1552 noch nicht freigegeben
0x00000604 | Read / Write | Encoder-Gruppe | REAL64 | z.B.mm/s | [0.0...1000.0] | Geschwindigkeitsfenster bzw. Stillstandsfenster | Base Unit / s
0x00000605 | Read / Write | Encoder-Gruppe | REAL64 | s | [0.0...60.0] | Filterzeit für Stillstandsfenster in Sekunden |
0x00000606 | Read / Write | Encoder-Gruppe | REAL64 | s | [0.0...60.0] | Totzeitkompensation Master/Slave- Kopplung ("Winkelvorsteuerung") |
0x00000701 | Read | FIFO-Gruppe | UINT32 | 1 | [1...8] bzw. [1...16] | FIFO-Dimension (m = Anzahl der Achsen) (ab TC 2.11 Build 1547 ist die FIFO-Dimension von 8 auf 16 erhöht worden) | (n x m)-FIFO Boot-Daten !
0x00000702 | Read | FIFO-Gruppe | UINT32 | 1 | [1...10000] | FIFO-Größe (Länge) (n = Anzahl der FIFO-Einträge) | (n x m)-FIFO Boot-Daten !
0x00000703 | Read | FIFO-Gruppe | UINT32 | 1 | 0 | Interpolationstyp für FIFO-Sollwertgenerator | nicht implementiert!
0x00000704 | Read / Write | FIFO-Gruppe | UINT32 | 1 | [1, 2] | Overridetyp für FIFO-Sollwertgenerator Typ 1: OVERRIDETYPE_INSTANTANEOUS (Default) Typ 2: OVERRIDETYPE_PT2 |
0x00000705 | Read / Write | FIFO-Gruppe | REAL64 | s | > 0.0 | P-T2-Zeit für Overrideänderung (T1=T2=T0) |
0x00000706 | Read / Write | FIFO-Gruppe | REAL64 | s | ≥ 0.0 | Zeitdelta für zwei aufeinanderfolgende FIFO-Einträge (Zeitbasis der FIFO-Einträge) |
0x00000801 | ReadWrite | Kinematik-Gruppe | Write |  |  | Berechnung der kinematischen Hintransformation für die Positionen (ACS -> MCS) |
 |  |  | { |  |  |
 |  |  | REAL64[8] | z.B. Grad | ±∞ | Positionen der ACS-Achsen (Axis Coordinate System), max. Dimension: 8
 |  |  | UINT32 | 1 | ≥ 0 | Reserve
 |  |  | UINT32 | 1 | ≥ 0 | Reserve
 |  |  | } |  |  |
 |  |  | Read |  |  |
 |  |  | { |  |  |
 |  |  | REAL64[8] | z.B. mm | ±∞ | Positionen der MCS-Achsen (Machine Coordinate System), max. Dimension: 8
 |  |  | UINT32 | 1 | ≥ 0 | Reserve
 |  |  | UINT32 | 1 | ≥ 0 | Reserve
 |  |  | } |  |  |
0x00000802 | ReadWrite | Kinematik-Gruppe | Write |  |  | Berechnung der kinematischen Rücktransformation für die Positionen (MCS -> ACS) |
 |  |  | { |  |  |
 |  |  | REAL64[8] | z.B. mm | ±∞ | Positionen der MCS-Achsen (Machine Coordinate System), max. Dimension: 8
 |  |  | UINT32 | 1 | ≥ 0 | Reserve
 |  |  | UINT32 | 1 | ≥ 0 | Reserve
 |  |  | } |  |  |
 |  |  | Read |  |  |
 |  |  | { |  |  |
 |  |  | REAL64[8] | z.B. Grad | ±∞ | Positionen der ACS-Achsen (Axis Coordinate System), max. Dimension: 8
 |  |  | UINT32 | 1 | ≥ 0 | Reserve
 |  |  | UINT32 | 1 | ≥ 0 | Reserve
 |  |  | } |  |  |


"Index-Offset" Spezifikation für Gruppen-Zustand (Index-Group 0x3100 + ID)

"Index-Offset" Spezifikation für Gruppen-Zustand (Index-Group 0x3100 + ID)

Index-Offset (Hex) | Zugriff | Gruppen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | INT32 | 1 | ENUM | Fehlercode Gruppe |
0x00000002 | Read | every | UINT32 | 1 |  | Anzahl Masterachsen |
0x00000003 | Read | every | UINT32 | 1 |  | Anzahl Slaveachsen |
0x00000004 | Read | every | UINT32 | 1 | s. ENUM | SVB-Gruppenstatus (Zustand) |
0x00000005 | Read | every | UINT32 | 1 | s. ENUM | SAF-Gruppenstatus (main state) |
0x00000006 | Read | every | UINT32 | 1 | s. ENUM | Bewegungszustand (Zustand) |
0x00000007 | Read | every | UINT32 | 1 | s. ENUM | SAF-Sub-Gruppenstatus (sub state) |
0x00000008 | Read | every | UINT32 | 1 | s. ENUM | Referenzierstatus (Zustand) |
0x00000009 | Read | every | UINT32 | 1 | s. ENUM | Koppelstatus (Zustand) | Nicht oszilloskopierbar!
0x0000000A | Read | every | UINT32 | 1 | ≥0 | Koppeltabellen-Index | Nicht oszilloskopierbar!
0x0000000B | Read | every | UINT32 | 1 | ≥0 | Aktuelle Anzahl SVB-Einträge/Aufträge | Symbolischer Zugriff: 'SvbEntries' (DXD)
0x0000000C | Read | every | UINT32 | 1 | ≥0 | Aktuelle Anzahl SAF-Einträge/Aufträge | Symbolischer Zugriff: 'SafEntries' (DXD)
0x0000000D | Read | every | UINT32 | 1 |  | Aktuelle Satznummer (nur für Interpolationsgruppe aktiv) | Symbolischer Zugriff: 'BlockNumber' (DXD)
0x0000000E | Read | every | UINT32 | 1 | ≥0 | Aktuelle Anzahl freier SVB-Einträge/Aufträge | ab TwinCAT V2.9 B903 Nicht oszilloskopierbar!
0x0000000F | Read | every | UINT32 | 1 | ≥0 | Aktuelle Anzahl freier SAF-Einträge/Aufträge | ab TwinCAT V2.9 B903 Nicht oszilloskopierbar!
0x00000011 | Read | every | UINT16 | 1 | 0/1 | Emergency Stop (E-Stop) aktiv ? | Nicht oszilloskopierbar!
0x00000110 | Read | PTP-Gruppe | { |  |  | Interne NC-Informationen (Auflösungen) | Reserviert !
 |  |  | REAL64 | z.B. mm | ± ∞ | ExternalEndPosition
 |  |  | REAL64 | z.B. mm/s | >0 | ExternalTargetVelocity
 |  |  | REAL64 | z.B. mm/s^2 | >0 | ExternalAcceleration
 |  |  | REAL64 | z.B. mm/s^2 | >0 | ExternalDeceleration
 |  |  | REAL64 | z.B. mm/s^3 | >0 | ExternalJerk
 |  |  | UINT32 | 1 | >0 | ExternalOverrideType
 |  |  | REAL64 | z.B. mm | ± ∞ | InternalEndPosition
 |  |  | REAL64 | z.B. mm/s | >0 | InternalTargetVelocity (refers to 100 %)
 |  |  | REAL64 | % | [0 ... 100] | InternalActualOverride
 |  |  | REAL64 | z.B. mm/s^2 | >0 | InternalAcceleration
 |  |  | REAL64 | z.B. mm/s^2 | >0 | InternalDeceleration
 |  |  | REAL64 | z.B. mm/s^3 | >0 | InternalJerk
 |  |  | REAL64 | z.B. mm | >0 | PositionResolution
 |  |  | REAL64 | z.B. mm/s | ≥0 | VelocityResolution
 |  |  | REAL64 | z.B. mm/s^2 | ≥0 | AccelerationResolution
 |  |  | REAL64 | z.B. mm/s | ≥0 | VelocityResolutionAtAccelerationZero
 |  |  | } |  |  |
0x00000500 | Read | DXD-Gruppe | REAL64 | z.B. mm | ≥ 0 | Bahnrestweg (verbleibende Bogenlänge) auf dem aktuellen Bahnsegment | Symbolischer Zugriff: 'SetPathRemLength'
0x00000501 | Read | DXD-Gruppe | REAL64 | z.B. mm | ≥ 0 | abgefahrene Bogenlänge auf dem aktuellen Bahnsegment | Symbolischer Zugriff: 'SetPathLength'
0x00000502 | Read | DXD-Gruppe | REAL64 | z.B. mm/s | ≥ 0 | aktuelle Bahnsollgeschwindigkeit | Symbolischer Zugriff: 'SetPathVelo'
0x00000503 | Read | DXD-Gruppe | REAL64 | z.B. mm/s^2 | ± ∞ | aktuelle Bahnsollbeschleunigung | Symbolischer Zugriff: 'SetPathAcc'
0x00000504 | Read | DXD-Gruppe | REAL64 | z.B. mm/s^2 | ≥ 0 | Betrag der aktuellen vektoriellen Sollbeschleuniging | Symbolischer Zugriff: 'SetPathAbsAcc'
0x00000505 | Read | DXD-Gruppe | REAL64 | z.B. mm/s | ≥ 0 | maximale Segmentendbahnsollgeschwindigkeit | Symbolischer Zugriff: 'SetPathVeloEnd'
0x00000506 | Read | DXD-Gruppe | REAL64 | z.B. mm/s | ≥ 0 | Segmentmaximalbahnsollgeschwindigkeit | Symbolischer Zugriff: 'SetPathVeloMax'
0x00000507 | Read | DXD-Gruppe | REAL64 | z.B. mm | ≥ 0 | aktueller relativer Bremsweg bezogen auf die aktuelle Bogenlänge | Symbolischer Zugriff: 'SetPathStopDist'
0x00000508 | Read | DXD-Gruppe | REAL64 | z.B. mm | ± ∞ | Sicherheitsabstand = Segmentbogenlänge - aktuelle Bogenlänge - relativer Bremsweg | Symbolischer Zugriff: 'SetPathSecurityDist'
0x00000509 | Read | DXD-Gruppe | REAL64 | 1 | 0/1 | Segmentübergang | Symbolischer Zugriff: 'SetPathSegmentChange'
0x0000050A | Read | DXD-Gruppe | REAL64 | % | [0 ... 100] | Bahngeschwindigkeitsoverride | Symbolischer Zugriff: 'SetPathOverride'
0x00000511 | Read | DXD-Gruppe | REAL64 | z.B. mm/s | ≥ 0 | Betrag der Bahnistgeschwindigkeit | Symbolischer Zugriff: 'ActPathAbsVelo'
0x00000512 | Read | DXD-Gruppe | REAL64 | z.B. mm/s^2 | ± ∞ | Bahnistbeschleunigung auf aktuellem Segment | Symbolischer Zugriff: 'ActPathAcc'
0x00000513 | Read | DXD-Gruppe | REAL64 | z.B. mm/s^2 | ≥ 0 | Betrag der Bahnistbeschleunigung auf aktuellem Segment | Symbolischer Zugriff: 'ActPathAbsAcc'
0x00000514 | Read | DXD-Gruppe | REAL64 | z.B. mm | ± ∞ | Positionsfehler auf der Bahn in tangentialer Richtung (mit Vorzeichen für Vor- und Nacheilen) | Symbolischer Zugriff: 'PathDiffTangential'
0x00000515 | Read | DXD-Gruppe | REAL64 | z.B. mm | ≥ 0 | Positionsfehler auf der Bahn in orthogonaler Richtung | Symbolischer Zugriff: 'PathDiffOrthogonal'
0x00000520 | Read | DXD-group | REAL64 | 1 | ≥ 0 | Abgefahrene Bogenlänge des aktuellen Segmentes (normiert auf 1.0) |
0x00000521 | Read | DXD-group | REAL64 | 1 | 0/1 | Teilsegmentwechsel (Radius der Toleranzkugel) |
0x00000522 | Read | DXD- group | REAL64 | 1 | ≥ 0 | gesamter Bahnrestweg bis zum letzten Geometrieeintrag oder zum nächsten Genauhalt |
0x00000523 | Read | DXD- group | REAL64 | 1 | ≥ 0 | programmierte Geschwindigkeit des aktuellen Segments | ab TC V2.9 B1031
0x00000530 | Read | DXD-Gruppe | { |  |  | Aktuelle bzw. letzte Zielposition der Hauptachsen X, Y und Z |
 |  |  | REAL64 | z.B. mm | ± ∞ | Zielposition X-Achse
 |  |  | REAL64 | z.B. mm | ± ∞ | Zielposition Y-Achse
 |  |  | REAL64 | z.B. mm | ± ∞ | Zielposition Z-Achse
 |  |  | } |  |  |
0x00000531 | Read | DXD-Gruppe | { |  |  | Aktuelle bzw. letzte Zielposition der Hilfsachsen Q1 bis Q5 |
 |  |  | REAL64[5] | z.B. mm | ± ∞ | Zielposition der Q1- bis Q5-Achse
 |  |  | } |  |  |
0x00000532 | Read | DXD-Gruppe | { |  |  | Lesen der Bahnlänge, H-Parameter und Entry ID der nächsten 11 Segmente bezogen auf die aktuelle DC-Time | ab TC 2.11 B2226 nicht allg. freigegeben
 |  |  | UINT32 |  |  | DC Time
 |  |  | UINT32 |  |  | reserved
 |  |  | PreViewTab[11] |  |  | 11*24 Bytes
 |  |  | } |  |  |
 |  |  | PreViewTab |  |  |
 |  |  | { |  |  |
 |  |  | REAL64 | z.B. mm |  | Segmentlänge
 |  |  | UINT32 | 1 |  | Blocknummer
 |  |  | UINT32 | 1 |  | H-Parmeter
 |  |  | UINT32 | 1 |  | Entry ID
 |  |  | UINT32 | 1 |  | reserved
 |  |  | } |  |  |
0x0000054n | Read | DXD-Gruppe | REAL64 | 1 | 0/1 | Innerhalb der Toleranzkugel der Hilfsachse n = 1..5 Nummer der Hilfsachse (nicht Achs-ID) | ab TC V2.9 B932
0x00000550 | Read | DXD-Gruppe | { |  |  | Lesen der Achs-ID's innerhalb der 3D-Gruppe: |
 |  |  | UINT32 | 1 | [0, 1...255] | X-Achsen ID
 |  |  | UINT32 | 1 | [0, 1...255] | Y-Achsen ID
 |  |  | UINT32 | 1 | [0, 1...255] | Z-Achsen ID
 |  |  | } |  |  |
0x00000552 | Read | DXD-Gruppe FIFO-Gruppe Kinematik-Gruppe | { UINT32[m] } | 1 | [0, 1...255] | Achsbelegung der Gruppe: 1. Achs-ID. ..., m.-Achs-ID m: Dimension der 3D-Gruppe mit Haupt- und Zusatzachsen (X, Y, Z, Q1, Q2, Q3, Q4, Q5) bzw. der FIFO-Gruppe bzw. die ACS-Achsen der Kinematik-Gruppe |
0x00000553 | Read | Kinematik-Gruppe | { |  |  | Lesen der Achsbelegung (ID's) innerhalb der Kinematik-Gruppe: |
 |  |  | UINT32[8] | 1 | [0, 1...255] | MCS-Achsen ID's (Machine Coordinate System)
 |  |  | UINT32[8] | 1 | [0, 1...255] | ACS-Achsen ID's (Axis Coordinate System)
 |  |  | UINT32 | 1 | ≥ 0 | Reserve
 |  |  | UINT32 | 1 | ≥ 0 | Reserve (NEW)
 |  |  | } |  |  |
0x0000056n | Read | DXD- Gruppe | REAL64 | 1 | ± ∞ | aktueller Fehler der Hilfsachse innerhalb der Toleranzkugel (nur sollwertseitig) Nur für Hilfsachsen n = 1..5 Nummer der Hilfsachse (nicht Achs-ID) | voraussichtl. ab TC V2.9 B932


"Index-Offset" Spezifikation für Gruppen-Funktionen (Index-Group 0x3200 + ID)

"Index-Offset" Spezifikation für Gruppen-Funktionen (Index-Group 0x3200 + ID)

Index-Offset (Hex) | Zugriff | Gruppen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Write | every | VOID |  |  | Reset Gruppe |
0x00000002 | Write | every | VOID |  |  | Stop Gruppe |
0x00000003 | Write | every | VOID |  |  | Clear Gruppe (Buffer/Auftrag) |
0x00000004 | Write | PTP-Gruppe, 3D-Gruppe | { |  |  | Emergency Stop (E-Stop) (Notstop mit geregelter Rampe) |
 |  |  | REAL64 | z.B. mm/s^2 | ≥ 0.0 | Verzögerung (muss größer gleich der Originalverzögerung sein)
 |  |  | REAL64 | z.B. mm/s^3 | ≥ 0.0 | Ruck (muss größer gleich dem Originalruck sein)
 |  |  | } |  |  |
0x00000005 | Write | PTP-Gruppe | { |  |  | Parametrierbarer Stop (mit geregelter Rampe) | Reservierte Funktion, kein Standard!
 |  |  | REAL64 | z.B. mm/s^2 | ≥ 0.0 | Verzögerung (beliebig)
 |  |  | REAL64 | z.B. mm/s^3 | ≥ 0.0 | Ruck (beliebig)
 |  |  | } |  |  |
0x00000006 | Write | PTP-Gruppe, 3D-Gruppe | VOID |  |  | Weiterfahren ("Step on") nach Emergency-Stop (E-Stop) |
0x00000050 | Write | PTP-Gruppe 3D-Gruppe | { |  |  | Achsbelegung der Gruppe: |
 |  |  | UINT32 | 1 | [0, 1...255] | X-Achsen ID
 |  |  | UINT32 | 1 | [0, 1...255] | Y-Achsen ID
 |  |  | UINT32 | 1 | [0, 1...255] | Z-Achsen ID
 |  |  | } |  |  |
0x00000051 | Write | PTP-Gruppe 3D-Gruppe FIFO-Gruppe | { |  |  | Achsbelegung der Gruppe: |
 |  |  | UINT32 | 1 | [1...255] | Achsen ID
 |  |  | UINT32 | 1 | [0 ... (m-1)] | Platz-Index der Achse in der Gruppe m: Gruppen-Dimension (PTP: 1;DXD: 3, FIFO: 8 bzw. 16) (ab TC 2.11 Build 1547 ist die FIFO-Dimension von 8 auf 16 erhöht worden)
 |  |  | } |  |  |
0x00000052 | Write | 3D-Gruppe FIFO-Gruppe | { UINT32[m] } | 1 | [0, 1...255] | Achsbelegung der Gruppe: 1. Achs-ID. ..., m.-Achs-ID m: Dimension der 3D-Gruppe (X, Y, Z, Q1, Q2, Q3, Q4, Q5) bzw. FIFO-Gruppe |
0x00000053 | Write | 3D-Gruppe FIFO-Gruppe Kinematik-Gruppe | VOID |  |  | Auflösen der 3D-, FIFO- oder Kinematik-Achsbelegung und Rückführung der Achsen in ihre persönlichen PTP-Gruppen |
0x00000054 | Write | Kinematik-Gruppe | { |  |  | Achsbelegung der Kinematik-Gruppe: |
 |  |  | UINT32[8] | 1 | [0, 1...255] | MCS-Achsen ID's (Machine Coordinate System)
 |  |  | UINT32[8] | 1 | [0, 1...255] | ACS-Achsen ID's (Axis Coordinate System)
 |  |  | UINT32 | 1 | ≥ 0 | Reserviert
 |  |  | UINT32 | 1 | ≥ 0 | Reserviert (NEU)
 |  |  | } |  |  |
0x00000060 | ReadWrite | 3D-Gruppe |  | 1 |  | Internes "Feed Group" Kommando ("Feeder") | Internes Kommando!
0x00000061 | ReadWrite | 3D-Gruppe |  | 1 |  | Internes "Feed Group" Kommando ("Feeder") | Internes Kommando!
0x00000110 | Write | 1D-Gruppe | VOID |  |  | Referenziere 1D-Gruppe ("Eichen") |
0x00000111 | Write | 1D-Gruppe | { |  |  | Neue Endposition 1D-Gruppe |
 |  |  | UINT32 | ENUM | s. Anhang | Endpositionstyp (s.Anhang)
 |  |  | REAL64 | z.B. mm | ±∞ | Neue Endposition (Zielposition)
 |  |  | } |  |  |
0x0000011A | Write | 1D-Gruppe | { |  |  | Setze Istposition 1D-Gruppe | Vorsicht bei Benutzung! Immer an SAF-Port 501!
 |  |  | UINT32 | ENUM | s. Anhang | Istpositionstyp (s.Anhang)
 |  |  | REAL64 | z.B. mm | ±∞ | Istposition für Achse
 |  |  | } |  |  |
0x0000011B | Write | 1D-Gruppe | UINT32 | 1 | 0/1 | Setze Referenzierflag ("Eichflag") | Vorsicht bei Benutzung!
0x00000120 | Write | 1D-Gruppe | { |  |  | Start 1D-Gruppe (Standard Start): |
 |  |  | UINT32 | ENUM | s. Anhang | Starttyp (s.Anhang)
 |  |  | REAL64 | z.B. mm | ±∞ | Endposition (Zielposition)
 |  |  | REAL64 | mm/s | ≥ 0.0 | Geforderte Geschwindigkeit
 |  |  | } |  |  |
0x00000121 | Write | 1D-Gruppe (SERVO) | { |  |  | Start 1D-Gruppe (Erweiteter Start): |
 |  |  | UINT32 | ENUM | s. Anhang | Starttyp (s.Anhang)
 |  |  | REAL64 | z.B.mm | ±∞ | Endposition (Zielposition)
 |  |  | REAL64 | mm/s | ≥0.0 | Geforderte Geschwindigkeit
 |  |  | UINT32 | 1 | 0/1 | Standard Beschleunigung?
 |  |  | REAL64 | mm/s^2 | ≥ 0.0 | Beschleunigung
 |  |  | UINT32 | 1 | 0/1 | Standard Verzögerung?
 |  |  | REAL64 | mm/s^2 | ≥ 0.0 | Verzögerung
 |  |  | UINT32 | 1 | 0/1 | Standard Ruck?
 |  |  | REAL64 | mm/s^3 | ≥ 0.0 | Ruck
 |  |  | } |  |  |
0x00000122 | Write | 1D-Gruppe (MW-SERVO) | { |  |  | Start 1D-Gruppe (Spezieller Start): | Reservierte Startfunktion, kein Standard!
 |  |  | UINT32 | ENUM | s. Anhang | Starttyp (s.Anhang)
 |  |  | REAL64 | z.B. mm | ±∞ | Endposition (Zielposition)
 |  |  | REAL64 | mm/s | ≥0.0 | Geforderte Anfangsgeschwindigkeit
 |  |  | REAL64 | z.B. mm | ±∞ | Position, fuer neues Geschwindigkeitsniveau
 |  |  | REAL64 | mm/s | ≥0.0 | Neues Endgeschwindigkeitsniveau
 |  |  | UINT32 | 1 | 0/1 | Standard Beschleunigung?
 |  |  | REAL64 | mm/s^2 | ≥0.0 | Beschleunigung
 |  |  | UINT32 | 1 | 0/1 | Standard Verzögerung?
 |  |  | REAL64 | mm/s^2 | ≥0.0 | Verzögerung
 |  |  | UINT32 | 1 | 0/1 | Standard Ruck?
 |  |  | REAL64 | mm/s^3 | ≥0.0 | Ruck
 |  |  | } |  |  |
0x00000126 | Write | 1D-Gruppe | { |  |  | Start Drive-Output: |
 |  |  | UINT32 | ENUM | s. Anhang | Ausgabetyp (s.Anhang)
 |  |  | REAL64 | z.B. % | ±∞ | Geforderter Ausgabewert (z.B. %)
 |  |  | } |  |  |
0x00000127 | Write | 1D-Gruppe | VOID |  |  | Stop Drive-Output |
0x00000128 | Write | 1D-Gruppe | { |  |  | Änderung/Wechsel des Drive-Outputs: |
 |  |  | UINT32 | ENUM | s. Anhang | Ausgabetyp (s.Anhang)
 |  |  | REAL64 | z.B. % | ±∞ | Geforderter Ausgabewert (z.B. %)
 |  |  | } |  |  |
0x00000130 | Write | 1D-Gruppe (SERVO) | { |  |  | 1D-Streckenkompensation (SERVO): |
 |  |  | UINT32 | ENUM | s. Anhang | Kompensations-Typ (s.Anhang)
 |  |  | REAL64 | mm/s/s | ≥ 0.0 | Max. Beschleunigungserhöhung
 |  |  | REAL64 | mm/s/s | ≥ 0.0 | Max. Verzögerungserhöhung
 |  |  | REAL64 | mm/s | ≥ 0.0 | Max. Erhöhungsgeschwindigkeit
 |  |  | REAL64 | mm/s | ≥ 0.0 | Grundgeschwindigkeit des Prozesses
 |  |  | REAL64 | z.B. mm | ±∞ | Auszugleichende Wegdifferenz
 |  |  | REAL64 | z.B. mm | ≥ 0.0 | Weglänge für Kompensation
 |  |  | } |  |  |
0x00000131 | Write | 1D-Gruppe SERVO | VOID |  |  | Stop Streckenkompensation (SERVO) |
0x00000140 (0x00n00140) | Write | Master / Slave-Kopplung: 1D-Gruppe (SERVO) | { |  |  | Master/Slave Kopplung (SERVO): | Erweiterung für "Fliegende Säge"! Winkel >0.0 und £ 90.0 Grad (Parallelsäge: 90.0 Grad)
 |  |  | UINT32 | ENUM | s. Anhang | Slavetyp/Kopplungstyp (s.Anhang)
 |  |  | UINT32 | 1 | [1...255] | Achs-ID der Masterachse / Gruppe
 |  |  | UINT32 | 1 | [0...8] | Subindex n der Masterachse (Default: -Wert: 0)
 |  |  | UINT32 | 1 | [0...8] | Subindex n der Slaveachse (Default: -Wert: 0)
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 1: Linear: Getriebefaktor FlySawVelo: Reserve FlySaw: Abs. Synchronposition Master [mm]
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 2: Linear: Reserve FlySawVelo: Reserve FlySawPos: Abs. Synchronposition Slave [mm]
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 3: Linear: Reserve FlySawVelo: Neigungswinkel in [GRAD] FlySawPos: Neigungswinkel in [GRAD]
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 4: Linear: Reserve FlySawVelo: Getriebefaktor FlySawPos: Getriebefaktor
 |  |  | } |  |  |
0x00000141 | Write | Master / Slave-Entkopplung: 1D-Gruppe (SERVO) | VOID |  |  | Master / Slave Entkopplung (SERVO) |
0x00000142 | Write | Master / Slave-Parameter 1D-Gruppe (SERVO) | { |  |  | Änderung der Kopplungsparameter (SERVO): |
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 1: Linear: Getriebefaktor
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 2: Linear: Reserve
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 3: Linear: Reserve
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 4: Linear: Reserve
 |  |  | } |  |  |
0x00000144 | Write | Slave-Stop 1D-Gruppe (SERVO) | VOID |  |  | Stop der "Fliegende Säge" (SERVO) | Nur für "Fliegende Säge"
0x00000149 | Write | Slave-Tabellen 1D-Gruppe (SERVO) | REAL64 | 1 | ±∞ | Setzen der Slave-Tabellenskalierung einer Solo-Tabellenkopplung (SERVO) | Nur für Solo-Tabellenslave
0x00000150 | Write | 1D-Gruppe | VOID |  |  | Deaktiviere komplette 1D-Gruppe/Achse (Disable) |
0x00000151 | Write | 1D-Gruppe | VOID |  |  | Aktiviere komplette 1D-Gruppe / Achse (Enable) |
0x00000160 | Write | 1D-Gruppe | VOID |  |  | Deaktiviere Drive-Output der 1D-Gruppe (Disable) |
0x00000161 | Write | 1D-Gruppe | VOID |  |  | Aktiviere Drive-Output der 1D-Gruppe (Enable) |
0x00000362 | Write | Eil/Schleich-Gruppe | UINT16 | 1 | 0/1 | Feststellbremse lösen ? 0: automatische Ansteuerung (Default) 1: zwingend immer gelöst ! |
0x00000701 | Write | FIFO-Gruppe | VOID |  |  | Start FIFO-Gruppe (FIFO-Tabelle muss zuvor gefüllt worden sein) | (n*m)-FIFO
0x00000710 | Write | FIFO-Gruppe | { REAL64[x*m] } | z.B. mm | ±∞ | Schreiben von x FIFO Einträgen (Zeilen): (x*m)-Werte (eine oder mehrere Zeilen) n: FIFO-Länge (Zeilenanzahl) m: FIFO-Dimension (Spaltenanzahl) Wertebereich x: [1 ... n] | Nur zeilenweise möglich! (ganzzahliges vielfaches)
0x00000711 | Write | FIFO-Gruppe | { REAL64[x*m] } | z.B. mm | ±∞ | Überschreiben der letzten x FIFO Einträge (Zeilen): (x*m)-Werte (eine oder mehrere Zeilen) n: FIFO-Länge (Zeilenanzahl) m: FIFO-Dimension (Spaltenanzahl) Wertebereich x: [1 ... n] | Nur zeilenweise möglich! (ganzzahliges vielfaches)
0x00000801 | Write | Kinematik-Gruppe | VOID |  |  | Start Kinematik-Gruppe | Reservierte Funktion, kein Standard!


"Index-Offset" Spezifikation für Achs-Parameter (Index-Group 0x4000 + ID)

"Index-Offset" Spezifikation für Achs-Parameter (Index-Group 0x4000 + ID)

Index-Offset

(Hex)

 Zugriff

Achs-

typ

Daten-

typ

Phys.

Einheit

Definitions-

bereich

Beschreibung

Anmerkung

0x00n00000 Read every
(Struktur für alle Achsparameter) 		{ Allgemeine ACHS-PARAMETER-STRUKTUR (NC/CNC),
beinhaltet auch die Unterelemente wie Encoder, Regler und Drive
(s. MC_ReadParameterSet in TcMc.lib)
UINT32 | 1 | Achs-ID
UINT8[30+1+1] | z.B. mm | Achs-Name
UINT32 | 1 | Achs-Typ
. . . . . . . . . . . .
} 512 Byte
0x00000001 | Read | every | UINT32 | 1 | Achs-ID
0x00000002 | Read | every | UINT8[30+1] | 1 | Achs-Name
0x00000003 | Read | every | UINT32 | ENUM | Achs-Typ
0x00000004 | Read | every | UINT32 | µs | Zykluszeit Achse (SAF)
0x00000005 | Read | every | UINT8[10+1] | 1 | Physikalische Einheit
0x00000006 | Read / Write | every | REAL64 | z.B. mm/s | Ref. Geschw. in Nockenrichtung
0x00000007 | Read / Write | every | REAL64 | z.B. mm/s | Ref. Geschw. in Syncrichtung
0x00000008 | Read / Write | every | REAL64 | z.B. mm/s | Geschwindigkeit Hand Slow
0x00000009 | Read / Write | every | REAL64 | z.B. mm/s | Geschwindigkeit Hand Fast
0x0000000A | Read / Write | every | REAL64 | z.B. mm/s | Geschwindigkeit Eilgang
0x0000000F | Read / Write | every | UINT16 | 1 | 0/1 | Positionsbereichsüberwachung?
0x00000010 | Read / Write | every | REAL64 | z.B. mm | Positionsbereichsfenster
0x00000011 | Read / Write | every | UINT16 | 1 | 0/1 | Bewegungsüberwachung?
0x00000012 | Read / Write | every | REAL64 | s | Bewegungsüberwachungszeit
0x00000013 | Read / Write | every | UINT16 | 1 | 0/1 | Schleife?
0x00000014 | Read / Write | every | REAL64 | z.B. mm | Schleifenweg (±)
0x00000015 | Read / Write | every | UINT16 | 1 | 0/1 | Zielpositionsüberwachung?
0x00000016 | Read / Write | every | REAL64 | z.B. mm | Zielpostionsfenster
0x00000017 | Read / Write | every | REAL64 | s | Zielpositionsüberwachungszeit
0x00000018 | Read / Write | every | REAL64 | z.B. mm | Pulsweg in pos. Richtung
0x00000019 | Read / Write | every | REAL64 | z.B. mm | Pulsweg in neg. Richtung
0x0000001A Read / Write every UINT32 ENUM (≥0) Fehlersignalisierung/Fehlerreaktion:
0: sofort (Default)
1: verzögert
(z.B. für Master/Slave-Kopplung) 		ab TC 2.11
0x0000001B Read / Write every REAL64 s [0...1000] Fehlerverzögerungszeit
(wenn verzögerte Fehlerreaktion angewählt ist) 		ab TC 2.11
0x0000001C | Read / Write | every | UINT16 | 1 | 0/1 | Slaves über Ist-Werte koppeln wenn nicht betriebsbereit? | ab TC 2.11
0x0000001D Read / Write every REAL64 z.B. mm/s^2 [0, 0.01...1.0E10] Beschleunigung für Übergangsprofil für die Umschaltung von SOLL- auf IST-Werte (Fading der Position):
Default: 0 (hier wird das Minimum der Achsbeschleunigungen verwendet, also MIN(Acc, Dec) ) 		NEU !
ab TC 2.11 R2
0x0000001E Read / Write every UINT32 ENUM (≥0)

Fast Axis Stop Signal Type:
Auswahl des Signaltypes durch den ein Fast Axis Stop ausgelöst wird (s. Bit 7 im Drive->nStatus4)

"0 (SignalType_OFF)",
"1 (SignalType_RisingEdge)",
"2 (SignalType_FallingEdge)",
"3 (SignalType_BothEdges)",
"4 (SignalType_HighActive)",
"5 (SignalType_LowActive)" 		ab TC 2.11 R3
0x00000020 Read / Write every UINT16 1 0/1 Bewegungskommandos für Slaveachse erlauben?
Default: FALSE 		ab TC 2.11
0x00000021 Read / Write every UINT16 1 0/1 Bewegungskommandos für Achsen mit aktiver externer Sollwertgenerierung erlauben?
Default: FALSE 		ab TC 2.11 R2
0x00000026 Read / Write every UINT32 1 Interpretation der Einheiten (Position, Geschwindigkeit, Zeit)

Bit 0: Geschwindigkeit in x/min statt x/s
Bit 1: Position in tausendstel der Basiseinheit
Bit 2: Modulopositionsanzeige

 siehe Encoder!

Bitarray

0x00000027 | Read / Write | every | REAL64 | z.B. mm/s | Maximal erlaubte Fahrgeschwindigkeit
0x00000028 | Read / Write | every | REAL64 | z.B. mm | Bewegungsüberwachungsfenster
0x00000029 | Read / Write | every | UINT16 | 1 | 0/1 | PEH-Zeitüberwachung ? | Posi. Ende und Genauhalt
0x0000002A | Read / Write | every | REAL64 | s | PEH Überwachungszeit
0x0000002B | Read / Write | every | UINT16 | 1 | 0/1 | Losekompensation?
0x0000002C | Read / Write | every | REAL64 | z.B. mm | Lose
0x00000030 Read every UINT16 1 [0,1] Persistente (dauernd anhaltende) Daten für z.B. Istposition und Referenzierstatus des Encoders?

Boot-Parameter
0x00000031 Read every {
UINT8[6]
 UINT16
} 		AmsAddr 1 Lesen der Hardware AMS-Adresse (AMS Net ID und Geräte Port)

ALT !
0x00000031 Read every {
UINT8[6]
UINT16
UINT16
}
AmsAddr

ChannelNo 		1 Lesen der Hardware AMS-Adresse (AMS Net ID und Geräte Port) und der Kanalnummer (0=Channel A, 1= Channel B)

0x00000033 Read every {
UINT16 ApplRequestBit
UINT16 ApplRequestType
UINT32 ApplCmdNo
UINT32 ApplCmdVersion
. . .
} 1024 Byte
1
1
1
1
0/1
≥0
>0
≥0 		Allgemeine APPLICATION REQUEST-STRUKTUR (NC/NCI),
z.B. für ApplicationHoming-Request
(s. MC_Read ApplicationRequest in TcMc 2.lib) 		NEU !

ab TC 2.11 R2
0x00000051 | Read | Kanal: every | UINT32 | Kanal-ID
0x00000052 | Read | Kanal: every | UINT8[30+1] | Kanal-Name
0x00000053 | Read | Kanal: every | UINT32 | Kanal-Typ
0x00000054 | Read | Gruppe: every | UINT32 | Gruppen-ID
0x00000055 | Read | Gruppe: every | UINT8[30+1] | Gruppen-Name
0x00000056 | Read | Gruppe: every | UINT32 | Gruppen-Typ
0x00000057 | Read | every | UINT32 | Anzahl der Encoder
0x00000058 | Read | every | UINT32 | Anzahl der Regler
0x00000059 | Read | every | UINT32 | Anzahl der Drives
0x0000005A Read every { Lesen der sämtlicher Unterelemente einer Achse:
UINT32[ 9 ] | 1 | [0, 1...255] | Encoder ID's der Achse
UINT32[ 9 ] | 1 | [0, 1...255] | Regler ID's der Achse
UINT32[ 9 ] | 1 | [0, 1...255] | Drive ID's der Achse
} 108 bytes
0x00000101 | Read / Write | Servo | REAL64 | z.B. mm/s^2 | Beschleunigung
0x00000102 | Read / Write | Servo | REAL64 | z.B. mm/s^2 | Verzögerung
0x00000103 | Read / Write | Servo | REAL64 | z.B. mm/s^3 | Ruck
0x00000104 | Read / Write | Servo | REAL64 | s | [0.0 ... 1.0] | Verzögerungszeit zwischen Geschwindigkeits- und Positionswerten des Sollwertgenerators in Sekunden | Defaultwert: 0.0 s
0x00000105 Read / Write Servo UINT32 ENUM Override Typ für Geschwindigkeit:

1: Bezogen auf interne reduzierte Geschwindigkeit (ohne Iteration)
2: Bezogen auf originale externe Startgeschwindigkeit (ohne Iteration)
3: Bezogen auf interne reduzierte Geschwindigkeit (Optimierung mittels Iteration)
4: Bezogen auf originale externe Startgeschwindigkeit (Optimierung mittels Iteration)

Defaultwert: Typ 1

0x00000106 Read / Write Servo REAL64 1 [0.0 ... 1.0E6] Maximal erlaubter Geschwindig- keitssprung für Dynamikreduktion

D V = Faktor * min(A+, A-) * DT

Defaultwert: 0.0

0x00000107 Read / Write Servo UINT16 1 [0,1] Aktiviert Beschleunigungs- und Ruckbegrenzung für die Hilfsachse (Q1 bis Q5)

Defaultwert: 1

0x00000108 | Read / Write | Servo | REAL64 | z.B. mm | [0.0..1000.0] | Größe des Toleranzballs für die Hilfsachsen | ab TC V2.9 B932
0x00000109 Read / Write Servo REAL64 z.B. mm [0.0..10000.0] maximal erlaubte Positionsabweichung bei verkleinertem Toleranzball
Nur für Hilfsachsen 		ab TC V2.9 B1013
0x0000010A Read / Write Servo REAL64 z.B. mm/s^2 [0.01 ... 1.0E20] Fast Axis Stop: Beschleunigung
(s.a. Fast Axis Stop Signal Type) 		ab TC 2.11 R3
0x0000010B Read / Write Servo REAL64 z.B. mm/s^2 [0.01 ... 1.0E20] Fast Axis Stop: Verzögerung
(s.a. Fast Axis Stop Signal Type) 		ab TC 2.11 R3
0x0000010C Read / Write Servo REAL64 z.B. mm/s^3 [0.1 ... 1.0E30] Fast Axis Stop: Ruck
(s.a. Fast Axis Stop Signal Type) 		ab TC 2.11 R3
0x00000201 | Read / Write | Schrittmotor | UINT32 | ENUM | Betriebsmodus Schrittmotor
0x00000202 | Read / Write | Schrittmotor | REAL64 | z.B. mm/STEP | [1.0E-6 ... 1000.0] | Wegskalierung eines Motorschrittes
0x00000203 | Read / Write | Schrittmotor | REAL64 | z.B. mm/s | [0.0 ... 1000.0] | Mindestgeschwindigkeit für Geschwindigkeitsprofil
0x00000204 | Read / Write | Schrittmotor | UINT32 | 1 | [0 ... 100] | Anzahl der Schritte pro Frequenz-/Geschwindigkeitsstufe
0x00000205 | Read / Write | Schrittmotor | UINT32 | 1 | Motormaske als Syncimpuls | Nicht implementiert !
0x00000301 | Read / Write | Eil/Schleich | REAL64 | z.B. mm | [0.0 ... 100000.0] | Schleichweg in pos.Richtung
0x00000302 | Read / Write | Eil/Schleich | REAL64 | z.B. mm | [0.0 ... 100000.0] | Schleichweg in neg. Richtung
0x00000303 | Read / Write | Eil/Schleich | REAL64 | z.B. mm | [0.0 ... 100000.0] | Bremsweg in pos. Richtung
0x00000304 | Read / Write | Eil/Schleich | REAL64 | z.B. mm | [0.0 ... 100000.0] | Bremsweg in neg. Richtung
0x00000305 | Read / Write | Eil/Schleich | REAL64 | s | [0.0 ... 60.0] | Bremsverzög. in pos. Richtung
0x00000306 | Read / Write | Eil/Schleich | REAL64 | s | [0.0 ... 60.0] | Bremsverzög. in neg. Richtung
0x00000307 | Read / Write | Eil/Schleich | REAL64 | s | [0.0 ... 60.0] | Umschaltzeit Eil auf Schleich
0x00000308 | Read / Write | Eil/Schleich | REAL64 | z.B. mm | [0.0 ... 100000.0] | Schleichweg Stop
0x00000309 | Read / Write | Eil/Schleich | REAL64 | s | [0.0 ... 60.0] | Verzögerungszeit um Bremse zu lösen
0x0000030A | Read / Write | Eil/Schleich | REAL64 | s | [0.0 ... 60.0] | Pulszeit in pos. Richtung
0x0000030B | Read / Write | Eil/Schleich | REAL64 | s | [0.0 ... 60.0] | Pulszeit in neg. Richtung
ENCODER:
0x00n10001 Read Encoder: every UINT32 1 [1 ... 255] Encoder-ID

n = 0: Standardencoder der Achse

n > 0: n-ter Encoder der Achse (optional)

0x00n10002 | Read | Encoder: every | UINT8[30+1] | 1 | 30 Zeichen | Encoder-Name
0x00n10003 | Read | Encoder: every | UINT32 | 1 | s. ENUM (>0) | Encoder-Typ
0x00n10004 | Read / Write | Encoder: every | UINT32 | 1 | Byteoffset | Input-Adress-Offset (IO-Input-Image) | Änderung der IO-Adresse
0x00n10005 | Read / Write | Encoder: every | UINT32 | 1 | Byteoffset | Output-Adresse-Offset (IO-Output-Image) | Änderung der IO-Adresse
0x00n10006 Read / Write Encoder: every REAL64 z.B. mm/INC [1.0E-12 ... 1.0E+30] Resultierender Skalierungsfaktor (Zähler / Nenner)

Anm.: ab TC 3.0 besteht der Skalierungsfaktor aus zwei Komponenten, Zähler und Nenner (Default: 1.0).
0x00n10007 | Read / Write | Encoder: every | REAL64 | z.B. mm | [±1.0E+9] | Positionsoffset
0x00n10008 | Read / Write | Encoder: every | UINT16 | 1 | [0,1] | Geberzählrichtung
0x00n10009 | Read / Write | Encoder: every | REAL64 | z.B. mm | [0.001 ... 1.0E+9] | Modulo-Faktor
0x00n1000A | Read / Write | Encoder: every | UINT32 | 1 | s. ENUM (>0) | Encoder-Modus
0x00n1000B | Read / Write | Encoder: every | UINT16 | 1 | 0/1 | Softend-Min-Überwachung ?
0x00n1000C | Read / Write | Encoder: every | UINT16 | 1 | 0/1 | Softend-Max-Überwachung ?
0x00n1000D | Read / Write | Encoder: every | REAL64 | mm | Softendlage Min
0x00n1000E | Read / Write | Encoder: every | REAL64 | mm | Softendlage Max
0x00n1000F Read / Write Encoder: every UINT32 1 s. ENUM (≥0) Encoder Auswerterichtung (Freigabe log. Zählrichtung)

s. Anhang

0x00n10010 | Read / Write | Encoder: every | REAL64 | s | [0.0...60.0] | Filterzeit für Positionsistwert in Sekunden(P-T1)
0x00n10011 | Read / Write | Encoder: every | REAL64 | s | [0.0...60.0] | Filterzeit für Geschwindigkeitsistwert in Sekunden (P-T1)
0x00n10012 | Read / Write | Encoder: every | REAL64 | s | [0.0...60.0] | Filterzeit frr Beschleunigungsistwert in Sekunden (P-T1)
0x00n10013 | Read / Write | Encoder: every | UINT8[10+1] | 1 | Physikalische Einheit | Nicht implementiert !
0x00n10014 Read / Write Encoder: every UINT32 1 Interpretation der Einheiten (Position, Geschwindigkeit, Zeit)

Bit 0: Geschwindigkeit in x/min statt x/s

Bit 1: Position in tausendstel der Basiseinheit

Nicht implementiert !

Bitarray

0x00n10015 Read Encoder: every UINT32 INC [0x0...

0xFFFFFFFF]

 Geber-Maske (Maximalwert des Geber-Istwertes in Inkrementen)

Anm.: Ab TwinCAT 2.11 R2 darf die Geber-Maske ein beliebiger Zahlenwert sein (z.B. 3600000) und muss nicht mehr wie bisher einer durchgehende Folge von binären Einsen entsprechen (2n-1). 		NEU

ReadOnly-Parameter

s.a. Param. "Geber-Sub-Maske"
0x00n10016 | Read / Write | Encoder: every | UINT16 | 1 | 0/1 | Istpositionskorrektur (Meßsystemfehlerkorrektur)?
0x00n10017 | Read / Write | Encoder: every | REAL64 | s | [0.0...60.0] | Filterzeit für Istpositionskorrektur in Sekunden (P-T1)
0x00n10019 Read / Write Encoder: every UINT32 1 s. ENUM (≥0) Encoder Bezugsmaßsystem

s. Anhang

0x00n1001A Read / Write Encoder: every UINT32 1 s. ENUM (≥0) Encoder Positionsinitialisierung

Nicht implementiert !

0x00n1001B | Read / Write | Encoder: every | REAL64 | z.B. mm | [≥0, Modulo-Faktor/2] | Toleranzfenster für Modulo-Start
0x00n1001C | Read | Encoder: every | UINT32 | 1 | s. ENUM (≥0) | Encoder Vorzeichen-Interpretation (Datentyp)
0x00n1001D Read Encoder: every UINT16 1 0/1 Inkremental- oder Absolut-Encoder ?
0: Inkrementaler Encoder-Typ
1: Absoluter Encoder-Typ
0x00n10023 Read / Write Encoder: every REAL64 z.B. mm/INC [1.0E-12 ... 1.0E+30] Komponente des Skalierungsfaktors: Zähler
(=> Skalierungsfaktor Zähler / Skalierungsfaktor Nenner) 		NEU ab TC 3.0
0x00n10024 Read / Write Encoder: every REAL64 1 [1.0E-12 ... 1.0E+30] Komponente des Skalierungsfaktors: Nenner
(=> Skalierungsfaktor Zähler / Skalierungsfaktor Nenner)
Default: 1.0 		NEU ab TC 3.0
0x00n10025 Read / Write Encoder: every {
REAL64
REAL64
}
z.B. mm/INC
1
[1.0E-12 ... 1.0E+30]
[1.0E-12 ... 1.0E+30]
Komponente des Skalierungsfaktors: Zähler
Komponente des Skalierungsfaktors: Nenner
(=> Skalierungsfaktor Zähler / Skalierungsfaktor Nenner)
         NEU ab TC 3.0
0x00n10030 Read / Write Encoder: every UINT32 1

Internes Encoder Control Doppelwort zur Festlegung der Betriebsarten und Eigenschaften

Reserviert !
ab 211R3 B2227
0x00n10101 | Read / Write | E: INC | UINT16 | 1 | [0,1] | Suchrichtung für Ref.nocken invers?
0x00n10102 | Read / Write | E: INC | UINT16 | 1 | [0,1] | Suchrichtung für Syncimpuls invers?
0x00n10103 | Read / Write | E: INC | REAL64 | z.B. mm | [±1000000.0] | Referenzposition
0x00n10104 | Read / Write | E: INC | UINT16 | 1 | [0,1] | Abstandsüberwachung zwischen Ref.nocken und Syncimpuls aktiv? | Nicht implementiert !
0x00n10105 | Read / Write | E: INC | UINT32 | INC | [0 ... 65536] | Mindestabstand Ref.nocken zum Syncimpuls in Inkrementen | Nicht implementiert !
0x00n10106 | Read / Write | E: INC | UINT16 | 1 | [0,1] | Externer Syncimpuls?
0x00n10107 Read / Write E: INC UINT32 1 s. ENUM (>0) Referenzier Modus

s. Anhang

0x00n10108 Read / Write E: INC UINT32 1 [0x0000000F...

0xFFFFFFFF]

Binärmaske: (2n - 1)

 Geber-Sub-Maske (Maximalwert des Absolutbereichs des Geber-Istwertes in Inkrementen)
Wird z.B. verwendet als Referenzmarke für den Referenzier Mode "Software Sync" und für die NC Retain Daten("ABSOLUTE (MODULO)", "INCREMENTAL (SINGLETURN ABSOLUTE)" ).

Anm.1: Die Geber-Sub-Maske muss kleiner gleich der Geber-Maske sein.
Anm.2: Die Geber-Maske muss ein ganzzahliges Vielfaches der Geber-Sub-Maske sein.
Anm.3: Die Geber-Sub-Maske muss einer durchgehenden Folge von binären Einsen entsprechen (2n-1), z.B. 0x000FFFFF. 		NEU

s.a. Param. "Geber-Maske"
0x00n10110 | Read / Write | E: INC (Encoder-Simulation) | REAL64 | 1 | [0.0 ... 1000000.0] | Skalierung/Gewichtung des Rauschanteils fuer Simulationsencoder
CONTROLLER:
0x00n20001 Read Regler: every UINT32 1 [1 ... 255] Regler ID

n = 0: Standardregler der Achse

n > 0: n-ter Regler der Achse (optional)

0x00n20002 | Read | Regler: every | UINT8[30+1] | 1 | 30 Zeichen | Regler-Name
0x00n20003 | Read | Regler: every | UINT32 | 1 | s. ENUM (>0) | Regler-Typ
0x00n2000A Read / Write Regler: every 1 s. ENUM (>0) Regler-Modus

0x00n2000B Read / Write Regler: every REAL64 % [0.0 ... 1.0] Gewichtung der Geschwindigkeitsvorsteuerung (Standardwert: 1.0 = 100 %)
0x00n20010 | Read / Write | Regler: every | UINT16 | 1 | 0/1 | Schleppabstandüberw. Pos.?
0x00n20011 | Read / Write | Regler: every | UINT16 | 1 | 0/1 | Schleppabstandüberw. Geschw.?
0x00n20012 | Read / Write | Regler: every | REAL64 | z.B. mm | Max. Schleppabstand Position
0x00n20013 | Read / Write | Regler: every | REAL64 | s | Max. Schleppfilterzeit Position
0x00n20014 | Read / Write | Regler: every | REAL64 | z.B. mm/s | Max. Schleppabstand Geschw.
0x00n20015 | Read / Write | Regler: every | REAL64 | s | Max. Schleppfilterzeit Geschw.
0x00n20100 Read / Write P/PID (Pos.,

(Geschw.)

 REAL64 1 [0.0...1.0] Maximale Ausgabebegrenzung (±) für Regler-Gesamtausgabe (Standardwert:

0.5 == 50%)
0x00n20102 Read / Write P/PID (Pos.) REAL64 z.B. mm/s/ mm [0.0...1000.0] Proportionalverstärkung kp bzw. kv
Einheit: Base Unit / s / Base Unit 		Positionsregelung
0x00n20103 | Read / Write | PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Nachstellzeit Tn | Positionsregelung
0x00n20104 | Read / Write | PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Vorhaltzeit Tv | Positionsregelung
0x00n20105 | Read / Write | PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Verzögerungszeit Td | Positionsregelung
0x00n20106 Read / Write PP (Pos.) REAL64 z.B. mm/s/ mm [0.0...1000.0] Zusätzliche Proportionalverstärkung kp bzw. kv, die oberhalb einer Genzgeschwindigkeit in Prozent gilt.
Einheit: Base Unit / s / Base Unit 		Positionsregelung
0x00n20107 Read / Write PP (Pos.) REAL64 % [0.0...1.0] Schwellgeschwindigkeit in Prozent, oberhalb derer die zusätzliche Proportionalverstärkung kp bzw. kv gilt
0x00n20108 | Read / Write | P/PID (Acc.) | REAL64 | s | [0.0 ... 100.0] | Proportionalverstärkung ka | Beschleunigungs- vorsteuerung
0x00n2010D Read / Write P/PID REAL64 mm [0.0 ... 10000.0] Totzone ("dead band") für Positionsfehler (Regelabweichung)
(für P/PID-Regler mit Geschwindigkeits- oder Momenteninterface)

Reservierte Funktion

0x00n2010F Read / Write P/PP/PID (Pos.)
Slave-Regelung 		REAL64 (mm/s) / mm [0.0...1000.0] Slave-Koppeldifferenzregelung:
Proportionalverstärkung kcp

Slave-Koppeldifferenzregelung

0x00n20110 | Read / Write | P (Pos.) | UINT16 | 1 | 0/1 | Automatischer Offsetabgleich: aktiv/passiv
0x00n20111 | Read / Write | P (Pos.) | UINT16 | 1 | 0/1 | Automatischer Offsetabgleich: Halte-Modus
0x00n20112 | Read / Write | P (Pos.) | UINT16 | 1 | 0/1 | Automatischer Offsetabgleich: Fading-Modus
0x00n20114 Read / Write P (Pos.) REAL64 % [0.0 ... 1.0] Automatischer Offsetabgleich: Vorsteuer-Grenze
0x00n20115 | Read / Write | P (Pos.) | REAL64 | s | [0.1 ... 60.0] | Automatischer Offsetabgleich: Zeitkonstante
0x00n20116 Read / Write PID (Pos.) REAL64 % [0.0...1.0] Maximale Ausgabebeschränkung (±) für I-Anteil in Prozent (Defaulteinstellung: 0.1 = 10 %)
0x00n20117 Read / Write PID (Pos.) REAL64 % [0.0...1.0] Maximale Ausgabebeschränkung (±) für D-Anteil in Prozent (Defaulteinstellung: 0.1 = 10 %)
0x00n20118 Read / Write PID (Pos.) UINT16 1 0/1 Abschalten des I-Anteils während eines aktiven Positioniervorganges (sofern I-Anteil aktiv)?

(Defaulteinstellung: 0 = FALSE)

0x00n20120 Read / Write P/PID (Pos.) REAL64 s ≥0 PT-1 Filterwert für Positionsfehler (Pos.-Regeldifferenz)

Reservierte Funktion,
kein Standard!

0x00n20202 Read / Write P/PID (Geschw.) REAL64 1 [0.0...1000.0] Proportionalverstärkung kp bzw. kv Geschwindigkeits-
regelung
0x00n20203 Read / Write PID (Geschw.) REAL64 s [0.0 ... 60.0] Nachstellzeit Tn Geschwindigkeits-
regelung
0x00n20204 Read / Write PID (Geschw.) REAL64 s [0.0 ... 60.0] Vorhaltzeit Tv Geschwindigkeits-
regelung
0x00n20205 Read / Write PID (Geschw.) REAL64 s [0.0 ... 60.0] Verzögerungszeit Td Geschwindigkeits-
regelung
0x00n20206 Read / Write PID (Geschw.) REAL64 % [0.0...1.0] Maximale Ausgabebeschränkung (±) fuer I-Anteil in Prozent (Defaulteinstellung: 0.1 = 10 %) Geschwindigkeits-
regelung
0x00n20207 Read / Write PID (Geschw.) REAL64 % [0.0...1.0] Maximale Ausgabebeschränkung (±) fuer D-Anteil in Prozent (Defaulteinstellung: 0.1 = 10 %) Geschwindigkeits-
regelung
0x00n2020D Read / Write P/PID (Geschw.) REAL64 mm/s [0.0 ... 10000.0] Totzone ("dead band") für Geschwindigkeitsfehler (Regelabweichung)
(für P/PID-Regler mit Geschwindigkeits- oder Momenteninterface)

Reservierte Funktion

0x00n20220 Read / Write P/PID (Geschw.) REAL64 s ≥0 PT-2 Filterwert für Geschwindigkeitsfehler (Geschw.-Regeldifferenz)

Geschwindigkeits-
regelung, kein Standard!

0x00n20221 Read / Write P/PID (Geschw.) REAL64 s ≥0 PT-1 Filterwert für Geschwindigkeitsfehler (Geschw.-Regeldifferenz)

Reservierte Funktion,
kein Standard!

0x00n20250 Read / Write P/PI (Beobachter) UINT32 1 s. ENUM (≥0) Beobachter-Modus für Regelung im Momenten-Interface

0: OFF (default)
1: LUENBERGER

ab TC 2.10 Build 1320

0x00n20251 Read / Write P/PI (Beobachter) REAL64 Nm / A >0.0 Motor:
Drehmomentkonstante KT
0x00n20252 Read / Write P/PI (Beobachter) REAL64 kg m2 >0.0 Motor:
Trägheitsmoment JM
0x00n20253 Read / Write P/PI (Beobachter) REAL64 Hz [100.0 ... 2000.0]

Default: 500

Bandbreite f0
0x00n20254 Read / Write P/PI (Beobachter) REAL64 1 [0.0 ... 2.0]

Default: 1.0

Korrekturfaktor kc
0x00n20255 Read / Write P/PI (Beobachter) REAL64 s [0.0 ... 0.01]

Default: 0.001

Geschwindkeits-Filter (1. Ordnung):
Zeitkonstante T
0x00n20A03 | Read / Write | P/PID (MW) | REAL64 | cm^2 | [0.0 ... 1000000] | Zylinderfläche AA der A-Seite in cm^2 | Reservierte Parameter !
0x00n20A04 | Read / Write | P/PID (MW) | REAL64 | cm^2 | [0.0 ... 1000000] | Zylinderfläche AB der B-Seite in cm^2 | Reservierte Parameter !
0x00n20A05 | Read / Write | P/PID (MW) | REAL64 | cm^3/s | [0.0 ... 1000000] | Nennvolumenstrom Qnenn in cm^3/s | Reservierte Parameter !
0x00n20A06 | Read / Write | P/PID (MW) | REAL64 | bar | [0.0 ... 1000000] | Nenndruck bzw. Ventildruckabfall Pnenn in bar | Reservierte Parameter !
0x00n20A07 | Read / Write | P/PID (MW) | UINT32 | 1 | [1 ... 255] | Achs-ID für den Systemdruck Po | Reservierte Parameter !
DRIVE:
0x00n30001 | Read | Drive: every | UINT32 | 1 | [1 ... 255] | Drive ID
0x00n30002 | Read | Drive: every | UINT8[30+1] | 1 | 30 Zeichen | Drive-Name
0x00n30003 | Read | Drive: every | UINT32 | 1 | s. ENUM (>0) | Drive-Typ
0x00n30004 | Read / Write | Drive: every | UINT32 | 1 | Byteoffset | Input-Adress-Offset (IO-Input-Image) | Änderung der IO-Adresse
0x00n30005 | Read / Write | Drive: every | UINT32 | 1 | Byteoffset | Output-Adresse-Offset (IO-Output-Image) | Änderung der IO-Adresse
0x00n30006 | Read / Write | Drive: every | UINT16 | 1 | [0,1] | Motorpolarität
0x00n3000A Read / Write Drive: every UINT32 1 s. ENUM (>0) Drive-Modus

0x00n3000B Read / Write Drive: every REAL64 % [-1.0 ... 1.0] Minimale Ausgabeschranke (Ausgabelimitierung)

(Defaulteinstellung: -1.0 = -100%)

0x00n3000C Read / Write Drive: every REAL64 % [-1.0 ... 1.0] Maximale Ausgabeschranke (Ausgabelimitierung) (Defaulteinstellung: 1.0 = 100%)
0x00n3000D | Read | Drive: every | UINT32 | INC | Maximale Anzahl von Ausgabeinkrementen (Ausgabemaske)
0x00n30010 Read / Write Drive: every UINT32 1

Internes Drive Control Doppelwort zur Festlegung der Antriebs-Betriebsarten

Reserviert !

0x00n30011 Read / Write every UINT32 1 ≥ 5

Interner Drive Reset Zähler
(Zeit in NC-Zyklen für Enable und Reset)

Reserviert !

0x00n30101 | Read / Write | D: Servo | REAL64 | z.B. mm/s | >0.0 | Bezugsgeschwindigkeit bei Bezugs- bzw. Referenzoutput (Geschwindigkeitsvorsteuerung)
0x00n30102 Read / Write D: Servo REAL64 % [0.0 ... 5.0] Bezugs- bzw. Referenzoutput in Prozent

(Defaulteinstellung: 1.0 = 100%)
0x00n30103 | Read | D: Servo | REAL64 | z.B. mm/s | >0.0 | Resultierende Geschwindigkeit bei 100% Output
0x00n30104 Read / Write D: Servo REAL64 z.B. mm/s ±∞ Geschwindigkeitsoffset (DAC-Offset) für Driftabgleich (Offsetabgleich) der Achse
0x00n30105 | Read / Write | D: Servo (Sercos, Profi Drive, AX200x, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | Geschwindigkeitsskalierung (Skalierungsfaktor um auf Wichtung im Antrieb zu reagieren) | Für Sercos, Profi Drive, AX200x, CANopen
0x00n30106 | Read / Write | D: Profi Drive DSC | UINT32 | 0.001 * 1/s | ≥ 0 | Profibus/Profi Drive DSC: Lageregelverstärung Kpc | Nur für Profi Drive DSC
0x00n30107 | Read / Write | D: Profi Drive DSC | REAL64 | 1 | ≥ 0.0 | Profibus/Profi Drive DSC: Skalierung für Berechnung von 'XERR' (Default: 1.0) | Nur für Profi Drive DSC
0x00n30109 | Read / Write | D: Servo (Sercos, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | Positionsskalierung (Skalierungsfaktor um auf Wichtung im Antrieb zu reagieren) | Für Sercos, CANopen
0x00n3010A | Read / Write | D: Servo (Sercos, Profi Drive, AX200x, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | Beschleunigungsskalierung (Skalierungsfaktor um auf Wichtung im Antrieb zu reagieren) | Für Sercos, Profi Drive, AX200x, CANopen
0x00n30120 Read / Write D: Servo/

Hydraulik/

 UINT32 1 ≥ 0 Tabellen-ID
(0: keine Tabelle)

Nur für KL4xxx, M2400, Universal
0x00n30121 Read / Write D: Servo/

Hydraulik

 UINT32 1 ≥ 0 Interpolation-Type

0: Linear
2: Spline

Nur für KL4xxx, M2400, Universal
0x00n30122 Read / Write Servo/

Hydraulik

 REAL64 % [-1.0 ... 1.0] Ausgabeoffset in Prozent

Anmerkung:
Wirkt nach der Kennlinienauswertung !

Nur für KL4xxx, M2400, Universal
0x00n30151 Read / Write D: Servo / Nichtlinear REAL64 1 [0.0 ... 100.0] Quadrantenausgleichsfaktor

(Verhältnis zwischen I und III Quadr.)

0x00n30152 | Read / Write | D: Servo / Nichtlinear | REAL64 | 1 | [0.01 ... 1.0] | Geschwindigkeits-Stützstelle in Prozent (1.0 = 100 %)
0x00n30153 | Read / Write | D: Servo / Nichtlinear | REAL64 | 1 | [0.01 ... 1.0] | Ausgabe-Stützstelle in Prozent (1.0 = 100 %)
0x00030301 | Read / Write | D: Schrittmotor | UINT8 | 1 | Bit-Maske: Zyklus 1
0x00030302 | Read / Write | D: Schrittmotor | UINT8 | 1 | Bit-Maske: Zyklus 2
0x00030303 | Read / Write | D: Schrittmotor | UINT8 | 1 | Bit-Maske: Zyklus 3
0x00030304 | Read / Write | D: Schrittmotor | UINT8 | 1 | Bit-Maske: Zyklus 4
0x00030305 | Read / Write | D: Schrittmotor | UINT8 | 1 | Bit-Maske: Zyklus 5
0x00030306 | Read / Write | D: Schrittmotor | UINT8 | 1 | Bit-Maske: Zyklus 6
0x00030307 | Read / Write | D: Schrittmotor | UINT8 | 1 | Bit-Maske: Zyklus 7
0x00030308 | Read / Write | D: Schrittmotor | UINT8 | 1 | Bit-Maske: Zyklus 8
0x00030310 | Read / Write | D: Schrittmotor | UINT8 | 1 | Bit-Maske: Haltestrom


"Index-Offset" Spezifikation für Achsen-Zustand (Index-Group 0x4100 + ID)

"Index-Offset" Spezifikation für Achsen-Zustand (Index-Group 0x4100 + ID)

Index-Offset (Hex) | Zugriff | Achsen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00n00000 | Read | every (Online Struktur für Achsdaten) | { |  |  | ACHS-ONLINE-STRUKTUR (NC/CNC) | Nicht oszilloskopierbar! (NCAXISSTATE_ ONLINESTRUCT)
 |  |  | INT32 | 1 |  | Fehlerstatus
 |  |  | REAL64 | z.B. mm |  | Istposition
 |  |  | REAL64 | z.B. Grad |  | Modulo-Istposition
 |  |  | REAL64 | z.B. mm |  | Sollposition
 |  |  | REAL64 | z.B. Grad |  | Modulo-Sollposition
 |  |  | REAL64 | z.B. mm/s |  | Optional: Istgeschwindigkeit
 |  |  | REAL64 | z.B. mm/s |  | Sollgeschwindigkeit
 |  |  | UINT32 | % | 0...1000000 | Geschwindigkeitsoverride (1000000 == 100%)
 |  |  | REAL64 | z.B. mm |  | Schleppabstand Position
 |  |  | REAL64 | z.B. mm |  | PeakHold-Wert für max. neg. Schleppabst. (Pos.)
 |  |  | REAL64 | z.B. mm |  | PeakHold-Wert für max. pos. Schleppabst. (Pos.)
 |  |  | REAL64 | % |  | Reglerausgabe in Prozent
 |  |  | REAL64 | % |  | Gesamtausgabe in Prozent
 |  |  | UINT32 | 1 | ≥ 0 | Achs-Status-Doppelwort
 |  |  | UINT32 | 1 | ≥ 0 | Achs-Steuer-Doppelwort
 |  |  | UINT32 | 1 | ≥ 0 | Slave Koppelstatus (Zustand)
 |  |  | UINT32 | 1 | 0; 1,2,3... | Achs Regelkreis Index
 |  |  | } |  |  | 112 Byte
0x00000001 | Read | every | UINT32 | 1 |  | Fehlercode Achs-Status | Symbolischer Zugriff: 'ErrState''
0x00n00009 | Read | every | UINT32 | 1 | ≥ 0 | Soll-Zykluszähler (SAF-Timestamp) |
0x00n0000A | Read | every | REAL64 | z.B. mm |  | Sollposition | Symbolischer Zugriff: 'SetPos''
0x00n0000B | Read | every | REAL64 | z.B. GRAD |  | Modulo-Sollposition | Symbolischer Zugriff: 'SetPosModulo''
0x00n0000C | Read | every | INT32 | 1 |  | Modulo-Sollumdrehung |
0x00n0000D | Read | every | REAL64 | 1 | [-1.0, 0.0, 1.0] | Sollfahrrichtung |
0x00n0000E | Read | every | REAL64 | z.B. mm/s |  | Sollgeschwindigkeit | Symbolischer Zugriff: 'SetVelo''
0x00n0000F | Read | every | REAL64 | z.B. mm/s^2 |  | Sollbeschleunigung | Symbolischer Zugriff: 'SetAcc''
0x00n00010 | Read | every | REAL64 | z.B. mm/s^3 |  | Soll-Ruck (zeitliche Ableitung der Soll-Beschleunigung) |
0x00n00011 | Read | every | REAL64 | Nm bzw. N |  | Soll-Moment (rot. Motor) bzw. Soll-Kraft (Linearmotor) |
0x00n00012 | Read | every | REAL64 | 1 |  | Soll-Koppelfaktor (Soll-Getriebeverhältnis) |
0x00n00013 | Read | every | REAL64 | z.B. mm |  | Voraussichtliche Zielposition (Target Position) |
0x00n00014 | Read | Servo | { |  |  | Verbleibende Fahrzeit und Restweg (SERVO): | Immer an SAF-Port 501!
 |  |  | REAL64 | s | ≥ 0 | Verbleibende Fahrzeit
 |  |  | REAL64 | z.B. mm | ≥ 0 | Verbleibender Restweg
 |  |  | } |  |  |
0x00n00015 | Read | every | UINT32 | 1 | ≥ 0 | Soll-Kommandonummer |
0x00n00016 | Read | Servo | REAL64 | s | ≥ 0 | Positionierzeit des letzten Fahrauftrags (Start → Zielpositionsfenster) |
0x00000018 | ReadWrite | Servo | Write |  |  | Lesen der "Stopp Informationen" (Stopp-Weg, Stopp-Zeit) | ab TC 2.11 R2 Nur Port 500 !
 |  |  | REAL64 | z.B. mm/s^2 | ≥ 0 | Verzögerung für Achs-Stopp
 |  |  | REAL64 | z.B. mm/s^3 | ≥ 0 | Ruck für Achs-Stopp
 |  |  | Read |  |  |
 |  |  | REAL64 | z.B. mm | ≥ 0 | Stopp-Weg
 |  |  | REAL64 | s | ≥ 0 | Stopp-Zeit
0x00n0001A | Read | every | REAL64 | z.B. mm |  | Unkorrigierte Sollposition |
0x00n0001D | Read | every | REAL64 | 1 | [-1.0, 0.0, 1.0] | Unkorrigierte Sollfahrrichtung |
0x00n0001E | Read | every | REAL64 | z.B. mm/s |  | Unkorrigierte Sollgeschwindigkeit |
0x00n0001F | Read | every | REAL64 | z.B. mm/s^2 |  | Unkorrigierte Sollbeschleunigung |
0x00000020 | Read | every | UINT32 | 1 | s. ENUM | Koppelstatus (Zustand) |
0x00000021 | Read | every | UINT32 | 1 | ≥ 0 | Koppeltabellen-Index |
0x00000022 | Read | Servo Master / Slave- Kopplung Typ: LINEAR, (&SPECIAL) | { |  |  | Lesen der Kopplungsparameter (SERVO): |
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 1: Linear: Getriebefaktor
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 2: Linear: Reserve
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 3: Linear: Reserve
 |  |  | REAL64 | 1 | [±1000000.0] | Parameter 4: Linear: Reserve
 |  |  | } |  |  |
0x00000023 | Read | Servo Master / Slave- Kopplung Typ: LINEAR, (&SPECIAL) | REAL64 | 1 | [±1000000.0] | Lesen des Getriebefaktors (SERVO) Typ: LINEAR, |
0x00000024 | Read | Servo | UINT32 | 1 | ≥ 0 | Nummer / Index des aktiven Achsregelkreises (Trippel aus Encoder, Regler und Achsinterfaces) | NEU
0x00000025 | Read | Servo | UINT16 | 1 | 0/1 | Externe Sollwertvorgabe über Achsinterface PLCtoNC aktiv ? | NEU
0x00000026 | Read | Servo Master / Slave- Kopplung Typ: SYNCHRONIZING | REAL64 [64] | 1 | ±∞ | Lesen der charakteristischen Kennwerte des Slave Aufsynchronisierungsprofils Typ: SYNCHRONIZING |
0x00000027 | ReadWrite | Servo Master / Slave- Kopplung Typ: TABULAR, MF | Write |  |  | Lesen der "Tabellen Kopplungs Informationen" | Nur Port 500 !
 |  |  | VOID oder REAL64 | z.B. mm | ±∞ | - Keine Daten für die "aktuelle Information", - Optional für eine bestimmte "Master Achspostion"
 |  |  | Read |  |  |
 |  |  | REAL64 [32] |  | ±∞ | Lesen der Struktur für die Tabellen Kopplungs Informationen
0x00000028 | ReadWrite | Servo Master / Slave- Kopplung Typ: MULTICAM (CamAddition) | Write |  |  | Lesen der "Multi-Tabellen Kopplungs Informationen" (CamAddition) | Nur Port 500 !
 |  |  | UINT32 | 1 | ≥ 0 | Tabellen-ID auf die sich die Anfrage bezieht
 |  |  | Read |  |  |
 |  |  | 96 Byte |  |  | Lesen der Struktur für die Multi-Tabellen Kopplungs Informationen
0x00000029 | Read | Servo | UINT32 | 1 |  | verzögerter Fehlercode (Fehlervorwarnung) im Falle einer verzögerten Fehlerreaktion (s. Bit ErrorPropagationDelayed) | ab TC 2.11 R3 B2229
0x0000002A | Read | Servo | REAL64 | z.B. mm | ±∞ | Positionsdifferenz beim Überblenden von Sollpositionen auf Istpositionen (Fading Anteil) | NEU ! ab TC 2.11 R2
0x0000002B | Read | Servo | REAL64 | z.B. mm/s | ±∞ | Relative Geschwindigkeit beim Überblenden von Sollpositionen auf Istpositionen (Fading Anteil) | NEU ! ab TC 2.11 R2
0x0000002C | Read | Servo | REAL64 | z.B. mm/s ^2 | ±∞ | Relative Beschleunigung beim Überblenden von Sollpositionen auf Istpositionen (Fading Anteil) | NEU ! ab TC 2.11 R2
0x00000050 | Read | every | UINT32 | 1 |  | SollFahrphase (SWGenerator) | Nicht oszilloskopierbar!
0x00000051 | Read | every | UINT16 | 1 |  | Ist Achse deaktiviert ? | Nicht oszilloskopierbar!
0x00n00060 | Read / Write | every (Online Sollwert - Struktur) | { |  |  | ACHS-SOLLWERT-STRUKTUR (NC/CNC) | Nicht oszilloskopierbar!
 |  |  | REAL64 | z.B. mm |  | Sollposition
 |  |  | REAL64 | z.B. mm/s |  | Sollgeschwindigkeit
 |  |  | REAL64 | z.B. mm/s^2 |  | Sollbeschleunigung / Sollverzögerung
 |  |  | REAL64 | 1 | [-1.0, 0.0, 1.0] | Sollfahrtrichtung
 |  |  | REAL64 | z.B. mm/s^3 |  | Sollruck
 |  |  | REAL64 | Nm bzw. N |  | Soll-Moment bzw. Soll-Kraft (neu ab TC V2.11 B1514)
 |  |  | } |  |  |
0x00n00061 | Read / Write | every (Online Dynamik Sollwert-Struktur) | { |  |  | ACHS-DYNAMIK-SOLLWERT STRUKTUR (NC/CNC) |
 |  |  | REAL64 | z.B. mm/s |  | Sollgeschwindigkeit
 |  |  | REAL64 | z.B. mm/s^2 |  | Sollbeschleunigung / Sollverzögerung
 |  |  | REAL64 | 1 | [-1.0, 0.0, 1.0] | Sollfahrtrichtung
 |  |  | REAL64 | z.B. mm/s^3 |  | Sollruck
 |  |  | REAL64 | Nm bzw. N |  | Soll-Moment bzw. Soll-Kraft (neu ab TC V2.11 B1514)
 |  |  | } |  |  |
0x00n10002 | Read | every (Encoder) | REAL64 | z.B. mm |  | Istposition (verrechnet mit Istpositionskorrekturwert) n = 0: Standardencoder der Achse n > 0: n-ter Encoder der Achse (optional) | Symbolischer Zugriff: 'ActPos''
0x00n10003 | Read | every (Encoder) | REAL64 | z.B. GRAD |  | Modulo-Istposition | Symbolischer Zugriff: 'ActPosModulo'
0x00n10004 | Read | every (Encoder) | INT32 | 1 |  | Modulo-Istumdrehung |
0x00n10005 | Read | every (Encoder) | REAL64 | z.B. mm/s |  | Optional: Istgeschwindigkeit | Symbolischer Zugriff: 'ActVelo''
0x00n10006 | Read | every (Encoder) | REAL64 | z.B. mm/s^2 |  | Optional: Istbeschleunigung | Symbolischer Zugriff: 'ActAcc''
0x00n10007 | Read | every (Encoder) | INT32 | INC |  | Geber-Istinkremente |
0x00n10008 | Read | every (Encoder) | INT64 | INC |  | Software - Istinkrementalzähler |
0x00n10009 | Read | every (Encoder) | UINT16 | 1 | 0/1 | Referenzierflag ("Eichflag") |
0x00n1000A | Read | every (Encoder) | REAL64 | z.B. mm |  | Istpositionskorrekturwert (Meßsystemfehlerkorrektur) |
0x00n1000B | Read | every (Encoder) | REAL64 | z.B. mm |  | Istposition ohne Istpositionskorrekturwert | Nicht oszilloskopierbar!
0x00n10010 | Read | every (Encoder) | REAL64 | z.B. mm/s |  | Istgeschwindigkeit ohne Istpositionskorrekturwert |
0x00n10012 | Read | every (Encoder) | REAL64 | z.B. mm |  | Ungefilterte Istposition (verrechnet mit Istpositionskorrekturwert) |
0x00n10015 | Read | every (Encoder) | REAL64 | z.B. mm/s |  | Optional: Ungefilterte Istgeschwindigkeit | Base Unit / s
0x00n10101 | Read | INC (Encoder) | REAL64 | z.B. mm |  | Rücklesen der Positionsdifferenz zwischen Aktivieren und Gültig werden des internen Hardwarelatches | Nicht oszilloskopierbar!
0x00n20001 | Read | R: every | INT32 | 1 |  | Fehlerstatus des Reglers n = 0: Standardregler der Achse n > 0: n-ter Regler der Achse (optional) |
0x00n20002 | Read | R: every | REAL64 | z.B. mm/s |  | Reglerausgabe in absoluten Einheiten | Symbolischer Zugriff: 'CtrlOutput''
0x00n20003 | Read | R: every | REAL64 | % |  | Reglerausgabe in Prozent | Nicht oszilloskopierbar!
0x00n20004 | Read | R: every | REAL64 | V |  | Reglerausgabe in Volt | Nicht oszilloskopierbar!
0x00n2000D | Read | R: every | REAL64 | z.B. mm |  | Schleppabstand Position (ohne Totzeitkompensation) | Base Unit
0x00n2000F | Read | R: every | REAL64 | z.B. mm |  | Schleppabstand Position (mit Totzeitkompensation) | Symbolischer Zugriff: 'PosDiff''
0x00n20010 | Read | R: every | REAL64 | z.B. mm |  | PeakHold-Wert für maximalen negativen Schleppabstand der Position |
0x00n20011 | Read | R: every | REAL64 | z.B. mm |  | PeakHold-Wert für minimalen positiven Schleppabstand der Position |
0x00n20012 | Read | R: every | REAL64 | z.B. mm/s |  | Schleppabstand Geschwindigkeit | Nicht implementiert !
0x00n20021 | Read | R: every | REAL64 | z.B. mm |  | Differenz (Abweichung) der Positions-Schleppabstände zwischen Master- und Slaveachse (Master- minus Slaveschleppabstand) | Symbolischer Zugriff: 'PosDiffCouple'
0x00n20022 | Read | R: every | REAL64 | z.B. mm |  | PeakHold-Wert für maximale negative Differenz der Schleppabstände (Position) zwischen Master- und Slaveachse | Base Unit
0x00n20023 | Read | R: every | REAL64 | z.B. mm |  | PeakHold-Wert für maximale positive Differenz der Schleppabstände (Position) zwischen Master- und Slaveachse | Base Unit
0x00n20101 | Read | R: P/PID (Pos.) | REAL64 | z.B. mm/s |  | P-Anteil des Reglers in absoluten Einheiten |
0x00n20102 | Read | R: PID (Pos.) | REAL64 | z.B. mm/s |  | I-Anteil des Reglers in absoluten Einheiten |
0x00n20103 | Read | R: PID (Pos.) | REAL64 | z.B. mm/s |  | D-Anteil des Reglers in absoluten Einheiten |
0x00n20104 | Read | R: PID (Pos.) | UINT16 | 1 | 0/1 | Begrenzung des I-Anteils aktiv? |
0x00n20105 | Read | R: PID (Pos.) | UINT16 | 1 | 0/1 | Begrenzung des D-Anteils aktiv? |
0x00n20106 | Read | R: PID (Pos.) | UINT16 | 1 | 0/1 | ARW-Massnahmen des I-Anteils aktiv? ARW: Anti Reset Windup | Nicht implementiert !
0x00n20110 | Read | R: PID (Pos.) | REAL64 | z.B. mm/s |  | Beschleunigungsvorsteuerung Yacc des Reglers in absoluten Einheiten Anmerkung: Funktion abhängig vom Reglertyp! | Beschleunigungs- vorsteuerung
0x00n20111 | Read | R: PP (Pos.) | REAL64 | mm/s/ mm | ≥0 | Interne interpolierte Proportionalverstärkung kp bzw. kv | PP-Regler
0x00n20201 | Read | R: P,PID (Geschw.) | REAL64 | z.B. mm/s |  | Geschwindigkeitsanteil des Reglers | Base Unit / s
0x00n20202 | Read | R: P,PID (Geschw.) | REAL64 | % |  | Geschwindigkeitsanteil des Reglers in Prozent | Nicht oszilloskopierbar!
0x00n20203 | Read | R: P,PID (Geschw.) | REAL64 | V |  | Geschwindigkeitsanteil des Reglers in Volt | Nicht oszilloskopierbar!
0x00n20201 | Read | R: P/PID (Geschw.) | REAL64 | z.B. mm/s |  | P-Anteil des Reglers in absoluten Einheiten |
0x00n20202 | Read | R: P/ PID (Geschw.) | REAL64 | z.B. mm/s |  | I-Anteil des Reglers in absoluten Einheiten |
0x00n20203 | Read | R: P/ PID (Geschw.) | REAL64 | z.B. mm/s |  | D-Anteil des Reglers in absoluten Einheiten |
0x00n20204 | Read | R: P/ PID (Geschw.) | UINT16 | 1 | 0/1 | Begrenzung des I-Anteils aktiv? |
0x00n20205 | Read | R: P/ PID (Geschw.) | UINT16 | 1 | 0/1 | Begrenzung des D-Anteils aktiv? |
0x00n20206 | Read | R: P/ PID (Geschw.) | UINT16 | 1 | 0/1 | ARW-Massnahmen des I-Anteils aktiv? | ARW: Anti Reset Windup
0x00n2020A | Read | R: P/ PID (Geschw.) | REAL64 | z.B. mm/s |  | Gesamteingangsgröße des Geschwindigkeits-Reglers |
0x00n20A00 | Read | R: PID (MW) | REAL64 | % | [-1.0...1.0] | Verrechnung der Sollgeschwindigkeit (Vorsteuerung) | Reservierte Parameter !
0x00n20A01 | Read | R: PID (MW) | REAL64 | z.B. mm/s |  | P-Anteil des Reglers in absoluten Einheiten oder Prozent (je nach Ausgabegewichtung) | Reservierte Parameter !
0x00n20A02 | Read | R: PID (MW) | REAL64 | z.B. mm/s |  | I-Anteil des Reglers in absoluten Einheiten oder Prozent (je nach Ausgabegewichtung) | Reservierte Parameter !
0x00n20A03 | Read | R: PID (MW) | REAL64 | z.B. mm/s |  | D-Anteil des Reglers in absoluten Einheiten oder Prozent (je nach Ausgabegewichtung) | Reservierte Parameter !
0x00n20A04 | Read | R: PID (MW) | UINT16 | 1 | 0/1 | Begrenzung des I-Anteils aktiv? | Reservierte Parameter !
0x00n20A05 | Read | R: PID (MW) | UINT16 | 1 | 0/1 | Begrenzung des D-Anteils aktiv? | Reservierte Parameter !
0x00n20A06 | Read | R: PID (MW) | UINT16 | 1 | 0/1 | ARW-Massnahmen des I-Anteils aktiv? ARW: Anti Reset Windup | Reservierte Parameter !
0x00n20A10 | Read | R: PID (MW) | REAL64 | z.B. mm/s |  | Beschleunigungsvorsteuerung Yacc des Reglers in absoluten Einheiten | Reservierte Parameter !
0x00n30001 | Read | D: every | INT32 | 1 |  | Fehlerstatus des Drives |
0x00n30002 | Read | D: every | REAL64 | z.B. mm/s |  | Gesamtausgabe in absoluten Einheiten | Symbolischer Zugriff: 'DriveOutput'
0x00n30003 | Read | D: every | REAL64 | % |  | Gesamtausgabe in Prozent |
0x00n30004 | Read | D: every | REAL64 | V |  | Gesamtausgabe in Volt | Nicht oszilloskopierbar!
0x00n30005 | Read | D: every | REAL64 | z. B. mm/s |  | PeakHold-Wert für maximale negative Gesamtausgabe | Base Unit / s
0x00n30006 | Read | D: every | REAL64 | z. B. mm/s |  | PeakHold-Wert für maximale positive Gesamtausgabe | Base Unit / s
0x00n30013 | Read | D: every | REAL64 | % |  | Gesamtausgabe in Prozent (nach nichtlinearer Kennlinie !) |
0x00n30014 | Read | D: every | REAL64 | V |  | Gesamtausgabe in Volt (nach nichtlinearer Kennlinie !) | Nicht oszilloskopierbar!


"Index-Offset" Spezifikation für Achs-Funktionen (Index-Group 0x4200 + ID)

"Index-Offset" Spezifikation für Achs-Funktionen (Index-Group 0x4200 + ID)

Index-Offset

(Hex)

 Zugriff

Achs-

typ

Daten-

typ

Phys.

Einheit

Definitions-

bereich

Beschreibung

Anmerkung

0x00000001 | Write | every | VOID | Reset Achse | Auch für FIFO-Achsen!
0x00000002 | Write | every | VOID | Stop Achse | Auch für FIFO-Achsen!
0x00000003 | Write | every | VOID | Clear Achse (Auftrag) | Auch für FIFO-Achsen!
0x00000004 Write every { Emergency Stop

(Notstop mit geregelter Rampe)

Nur für PTP-Achsen!

REAL64 z.B. mm/s^2 > 0.0 Verzögerung

(muss größer gleich der Originalverzögerung sein!)
REAL64 z.B. mm/s^3 > 0.0 Ruck

(muss größer gleich dem Originalruck sein!)
}
0x00000005 Write PTP-Achse { Parametrierbarer Stop

(mit geregelter Rampe)

Nur für PTP-Achsen!

Reservierte Funktion,
kein Standard!

REAL64 z.B. mm/s^2 > 0.0 Verzögerung

(beliebig)

REAL64 z.B. mm/s^3 > 0.0 Ruck

(beliebig)

}
0x00000009 Write PTP-Achse { Orientierter Stop
(orientierte Endposition)

Nur für PTP-Achsen!

REAL64 | z.B. Grad | ≥ 0.0 | Modulo-Endposition (Modulo-Zielposition)
REAL64 z.B. mm/s^2 > 0.0 Verzögerung

(momentan nicht wirksam)

REAL64 z.B. mm/s^3 > 0.0 Ruck

(momentan nicht wirksam)

}
0x00000010 | Write | every | VOID | Referenziere Achse ("Eichen")
0x00000011 Write every { Neue Endposition Achse
UINT32 | ENUM | s. Anhang | Endpositionstyp (s. Anhang)
REAL64 z.B. mm ±∞ Neue Endposition (Zielposition)
}
0x00000012 Write every { Neue Endposition und neue Geschwindigkeit Achse
UINT32 | ENUM | s. Anhang | Kommandotyp (s.Anhang)
UINT32 | ENUM | s. Anhang | Endpositionstyp (s.Anhang)
REAL64 z.B. mm ±∞ Neue Endposition (Zielposition)
REAL64 | z.B. mm/s | ≥ 0.0 | Neue Endgeschwindigkeit (angeforderte Fahrgeschw.)
REAL64 z.B. mm ±∞ Optional:

Umschaltposition ab der neues Fahrprofil aktiviert wird

}
0x00000015 Write every { Neue Dynamikparameter für aktive Positionierung
REAL64 | z.B. mm/s^2 | > 0.0 | Beschleunigung
REAL64 | z.B. mm/s^2 | > 0.0 | Verzögerung
REAL64 | z.B. mm/s^3 | > 0.0 | Optional: Ruck (momentan nicht wirksam)
}
0x00000016 ReadWrite every

SERVO

Write

(76 byte)

Universeller Achsstart (UAS):
Verschmelzung von Einzelkommandos wie z.B. Achsstart, und Online-Änderungen in Kombination mit "Buffer-Mode" (s. TcMc2.lib)

Immer an SAF-Port 501!

{
UINT32 | ENUM | s. Anhang | Starttyp (s.Anhang)
UINT32 1 ≥ 0 Bitmaske für Überprüfungen und Betriebsarten
(Default-Wert: 0)
REAL64 z.B. mm ±∞ Endposition (Zielposition)
REAL64 | z.B. mm/s | ≥ 0.0 | Geforderte Geschwindigkeit Vrequ
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Optional: Beschleunigung
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Optional: Verzögerung
REAL64 | z.B. mm/s^3 | ≥ 0.0 | Optional: Ruck
UINT32 | ENUM | s. Anhang | Buffer-Mode (Kommandozwischenspeicher)
REAL64 z.B. mm ±∞ Optional: Blending-Position (Kommandoüberblendungsposition)
REAL64 z.B. mm/s ≥ 0.0 Optional: Segment Anfangsgeschwindigkeit Vi
(0 ≤ Vi ≤ Vrequ)
REAL64 z.B. mm/s ≥ 0.0 Optional: Segment Endgeschwindigkeit Vf
(0 ≤ Vf ≤ Vrequ)
}
Read
{
UINT16 | 1 | ≥ 0 | Kommando Nummer (Job Nummer)
UINT16 | 1 | ≥ 0 | Kommando Status
}
0x00000017 ReadWrite

SERVO

Write

(76 byte)

"Master/Slave Entkopplung" und "Universeller Achsstart (UAS)":
Verschmelzung vom Abkoppelkommando einer Slaveachse (IdxOffset: 0x00000041) und nachfolgendem Universellen Achsstart (UAS) (IdxOffset: 0x00000016)

noch nicht freigegeben !

{
UINT32 | ENUM | s. Anhang | Starttyp (s.Anhang)
UINT32 1 ≥ 0 Bitmaske für Überprüfungen und Betriebsarten
(Default-Wert: 0)
REAL64 z.B. mm ±∞ Endposition (Zielposition)
REAL64 | z.B. mm/s | ≥ 0.0 | Geforderte Geschwindigkeit Vrequ
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Beschleunigung
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Verzögerung
REAL64 | z.B. mm/s^3 | ≥ 0.0 | Ruck
UINT32 | ENUM | s. Anhang | Buffer-Mode (Kommandozwischenspeicher)
REAL64 z.B. mm ±∞ Optional: Blending-Position (Kommandoüberblendungsposition)
REAL64 z.B. mm/s ≥ 0.0 Optional: Segment Anfangsgeschwindigkeit Vi
(0 ≤ Vi ≤ Vrequ)
REAL64 z.B. mm/s ≥ 0.0 Optional: Segment Endgeschwindigkeit Vf
(0 ≤ Vf ≤ Vrequ)
}
Read
{
UINT16 | 1 | ≥ 0 | Kommando Nummer (Job Nummer)
UINT16 | 1 | ≥ 0 | Kommando Status
}
0x00000018 | Write | every | VOID | Aufhebung der Achssperre für Bewegungskommandos (TcMc2)
0x00000019 | Write | every | UINT32 | 1 | > 0 | Setze externen Achsfehler (Laufzeitfehler) | Vorsicht bei Benutzung !
0x00n0001A Write every { Setze Istposition Achse

Vorsicht bei Benutzung !

Auch für FIFO-Achsen!

Immer an SAF-Port 501!
UINT32 | ENUM | s. Anhang | Istpositionstyp (s.Anhang)
REAL64 z.B. mm ±∞ Istposition für Achse

n = 0: Standardencoder der Achse
n > 0: n-ter Encoder der Achse (optional)
}
0x00n0001B Write every UINT32 1 0/1 Setze Referenzierflag ("Eichflag")

n = 0: Standardencoder der Achse
n > 0: n-ter Encoder der Achse (optional)

Vorsicht bei Benutzung !

Auch für FIFO-Achsen!
0x00n0001C Write SERVO { Setze nur Istposition Achse, ohne Manipulation der Sollposition (auch für Slave und bei aktivem Verfahren)

Vorsicht bei Benutzung !
UINT32 | ENUM | s. Anhang | Istpositionstyp (s.Anhang)
REAL64 z.B. mm ±∞ Istposition für Achse

n = 0: Standardencoder der Achse

n > 0: n-ter Encoder der Achse (optional)

Vorsicht bei Benutzung!!!

}
0x00n0001D Write every { Antriebseitiges Istwertsetzen der Achse
(Positionsinterface und Encoder-Offset von Null vorausgesetzt !)
n = 0: Standardencoder der Achse
n > 0: n-ter Encoder der Achse (optional)

Vorsicht bei Benutzung !

Nur für CANopen
UINT32 | ENUM | s. Anhang | Istpositionstyp (s.Anhang)
REAL64 z.B. mm ±∞ Istposition für Achse
}
0x00n0001E Write every { Fliegendes Setzen eines neuen Encoder-Skalierungsfaktors
(in Bewegung der Achse) 		Vorsicht bei Benutzung !

NEU !

Immer an SAF-Port 501!
UINT32 ENUM 1 Encoder-Skalierungsfaktortyp
1: Absolut
2: Relativ
REAL64 z.B. mm/INC [1.0E-8 ... 100.0] Neuer Encoder-Skalierungsfaktor
n = 0: Standardencoder der Achse
n > 0: n-ter Encoder der Achse (optional)
}
0x00n0001F Write every { Fliegendes Istwertsetzen der Achse
(in Bewegung der Achse) 		Vorsicht bei Benutzung !

Immer an SAF-Port 501!
UINT32 ENUM Positionstyp für Fliegendes Istwertsetzen
1: Absolut
2: Relativ
UINT32 | 1 | Kontrolldoppelwort für z.B. "Ablöschen des Schleppabstandes"
REAL64 | Reserve
REAL64 z.B. mm ±∞ Neue Istposition der Achse
UINT32 | Reserve
UINT32 | Reserve
}
0x00000020 Write every

1D-Start

{ Standard Achsstart:
UINT32 | ENUM | s. Anhang | Starttyp (s.Anhang)
REAL64 z.B. mm ±∞ Endposition (Zielposition)
REAL64 | z.B. mm/s | ≥0.0 | Geforderte Geschwindigkeit
}
0x00000021 Write every

1D-Start

{ Erweiteter Achsstart (SERVO):
UINT32 | ENUM | s. Anhang | Starttyp (s.Anhang)
REAL64 z.B. mm ±∞ Endposition (Zielposition)
REAL64 | z.B. mm/s | ≥ 0.0 | Geforderte Geschwindigkeit
UINT32 | 0/1 | 0/1 | Standard Beschleunigung?
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Beschleunigung
UINT32 | 0/1 | 0/1 | Standard Verzögerung?
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Verzögerung
UINT32 | 0/1 | 0/1 | Standard Ruck?
REAL64 | z.B. mm/s^3 | ≥ 0.0 | Ruck
}
0x00000022 Write SERVO(MW) { Spezieller Achsstart (SERVO): Reservierte Startfunktion, kein Standard !
UINT32 | ENUM | s. Anhang | Starttyp (s.Anhang)
REAL64 z.B. mm ±∞ Endposition (Zielposition)
REAL64 | mm/s | ≥ 0.0 | Geforderte Anfangsgeschwindigkeit
REAL64 z.B. mm ±∞ Position, fuer neues Geschwindigkeitsniveau
REAL64 | z.B. mm/s | ≥ 0.0 | Neues Endgeschwindigkeitsniveau
UINT32 | 0/1 | 0/1 | Standard Beschleunigung?
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Beschleunigung
UINT32 | 0/1 | 0/1 | Standard Verzögerung?
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Verzögerung
UINT32 | 0/1 | 0/1 | Standard Ruck?
REAL64 | z.B. mm/s^3 | ≥ 0.0 | Ruck
}
0x00000023 Write SERVO
{ 		Start externe Sollwertvorgabe (Vorgabe durch zyklisches Achsinterface PLCtoNC)
UINT32 ENUM

1: Absolut
2: Relativ

Starttyp
REAL64 z.B. mm ±∞ Neue Endposition (Zielposition) optional !
}
0x00000024 Write SERVO VOID Stop/Disable externe Sollwertvorgabe
(zykl. Achsinterface PLCtoNC)
0x00000025 Write SERVO { Start Reversierbetrieb für Positionierung (SERVO):
UINT32 | ENUM | 1 | Starttyp (default: 1)
REAL64 z.B. mm ±∞ Endposition 1 (Zielposition)
REAL64 z.B. mm ±∞ Endposition 2 (Zielposition)
REAL64 | 0/1 | 0/1 | Geforderte Geschwindigkeit
REAL64 | s | ≥ 0.0 | Pausenzeit (idle time)
}
0x00000026 Write every { Start Drive-Output:
UINT32 | ENUM | s. Anhang | Ausgabetyp (s.Anhang)
REAL64 z.B. % ±∞ Geforderter Ausgabewert (z.B. %)
}
0x00000027 | Write | every | VOID | Stop Drive-Output
0x00000028 Write every { Änderung/Wechsel des Drive-Outputs:
UINT32 | ENUM | s. Anhang | Ausgabetyp (s.Anhang)
REAL64 z.B. % ±∞ Geforderter Ausgabewert (z.B. %)
}
0x00000029 | Write | every | VOID | Aktuellen Override-Wert instantan übernehmen und einfrieren bis zur nächsten Overrideänderung! | Reservierte Funktion, kein Standard !
0x0000002A Write every {
32 bytes
} 		calculate and set encoder offset Reservierte Funktion, kein Standard !
0x0000002B ReadWrite every WriteData: s. 'UAS'
ReadData: s. 'UAS' 		stop external setpoint generator and continuous endless motion ('UAS': Universal axis start) Reservierte Funktion, kein Standard !
0x00000030 Write SERVO { Start Streckenkompensation (SERVO)
UINT32 | ENUM | s. Anhang | Kompensations-Typ (s.Anhang)
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Max. Beschleunigungserhöhung
REAL64 | z.B. mm/s^2 | ≥ 0.0 | Max. Verzögerungserhöhung
REAL64 | z.B. mm/s | > 0.0 | Max. Erhöhungsgeschwindigkeit
REAL64 | z.B. mm/s | > 0.0 | Grundgeschwindigkeit des Prozesses
REAL64 z.B. mm ±∞ Auszugleichende Wegdifferenz
REAL64 | z.B. mm | > 0.0 | Weglänge für Kompensation
}
0x00000030 ReadWrite SERVO

liefert die wirklich umgesetzten Größen als Rückgabewerte zurück

{
READ+WRITE: 		Start Streckenkompensation (SERVO)
Anmerkung: nur in 'TcMc2.lib' enthalten
UINT32 | ENUM | s. Anhang | Kompensations-Typ (s.Anhang)
REAL64 z.B. mm/s^2 ≥ 0.0 => Max. Beschleunigungserhöhung
<= liefert umgesetzte Beschleunigungserhöhung zurück (neu in 'TcMc2.lib')
REAL64 z.B. mm/s^2 ≥ 0.0 => Max. Verzögerungserhöhung
<= liefert umgesetzte Verzögerungserhöhung zurück (neu in 'TcMc2.lib')
REAL64 z.B. mm/s > 0.0 => angeforderte max. Erhöhungsgeschwindigkeit
<= liefert umgesetzte Erhöhungsgeschwind. zurück
REAL64 | z.B. mm/s | > 0.0 | Grundgeschwindigkeit des Prozesses
REAL64 z.B. mm ±∞ => angeforderte auszugleichende Wegdifferenz
<= liefert umgesetzte Wegdifferenz zurück
REAL64 z.B. mm > 0.0 => angeforderte max. Weglänge für Kompensation
<= liefert umgesetzte Weglänge zurück
UINT32 | 1 | ≥ 0 | <= liefert Warnungs-ID (z.B. 0x4243) zurück
}
0x00000031 | Write | SERVO | VOID | Stop Streckenkompensation (SERVO)
0x00000032 Write SERVO { Start Reversierbetrieb mit Geschwindigkeitssprüngen (SERVO):
(kann zur Ermittlung der Geschwindigkeits- Sprungantwort verwendet werden)
UINT32 | ENUM | 1 | Starttyp (default: 1)
REAL64 z.B. mm/s ±∞ Geforderte Geschwindigkeit 1
(auch negative Werte erlaubt)
REAL64 z.B. mm/s ±∞ Geforderte Geschwindigkeit 2
(auch negative Werte erlaubt)
REAL64 | s | > 0.0 | Fahrzeit für Geschwindigkeit 1 und 2
REAL64 | s | ≥ 0.0 | Pausenzeit (idle time)
UINT32 1 0, 1,2,3... Optional: Anzahl der Wiederholungen,
Default "0": zeitlich unbegrenzt
}
0x00000033 Write SERVO { Sinus Oscillation Sequence
- used as single sinus oscillation (sinus generator)
- used as sinus oscillation sequence (e.g. for bode plot) 		NEW
UINT32 | ENUM | 1 | start type (fixed to start type 1 yet)
REAL64 | e.g. mm/s | > 0.0 | base amplitude (e.g. 2.5 mm/s)
REAL64 | Hz | [0.0 .... 10.0] | base frequency (e.g. 1.953125 Hz)
REAL64 | e.g. mm/s | ≥ 0.0 | start amplitude at begin (e.g. 0.0 mm/s)
REAL64 | e.g. mm/REV | > 0.0 | feed constant motor (per motor turn) (e.g. 10.0 mm/REV)
REAL64 | Hz | ≥ 1.0 | frequency range: start frequency (e.g. 20.0 Hz)
REAL64 | Hz | ≤ 1/(2*dT) | frequency range: stop frequency (e.g. 500.0 Hz)
REAL64 | s | > 0.0 | step duration (e.g. 2.048s)
UINT32 | 1 | [1 ... 200] | number of measurements (step cycles) (e.g. 20)
UINT32 | 1 | number of parallel measurements (e.g. 1) not used yet!
}
0x00000040

(0x00n00040)

Write Master / Slave- Kopplung:

(SERVO)

{ Master/Slave Kopplung (SERVO):

Erweiterung für "Fliegende Säge" !
UINT32 | ENUM | s. Anhang | Slavetyp/Kopplungstyp (s. Anhang)
UINT32 | 1 | [1...255] | Achs-ID der Masterachse/Gruppe
UINT32 | 1 | [0...8] | Subindex n der Masterachse (Default:-Wert: 0)
UINT32 | 1 | [0...8] | Subindex n der Slaveachse (Default:-Wert: 0)
REAL64 1 [±1000000.0]

Parameter 1:

Linear: Getriebefaktor
FlySawVelo: Reserve
FlySaw: Abs. Synchronposition Master [mm]
REAL64 1 [±1000000.0]

Parameter 2:

Linear: Reserve
FlySawVelo: Reserve
FlySawPos: Abs. Synchronposition Slave [mm]

REAL64 1 [±1000000.0]

Parameter 3:

Linear: Reserve
FlySawVelo: Neigungswinkel in [GRAD]
FlySawPos: Neigungswinkel in [GRAD]

Winkel >0.0 und £ 90.0 Grad

(Parallelsäge: 90.0 Grad)

REAL64 1 [±1000000.0]

Parameter 4:

Linear: Reserve
FlySawVelo: Getriebefaktor
FlySawPos: Getriebefaktor

}
0x00000041 | Write | Master / Slave- Entkopplung (SERVO) | VOID | Master/Slave Entkopplung (SERVO)
0x00000041 Write Master / Slave- Entkopplung mit konfigurierbarer Folgefunktion (SERVO) { Master/Slave Entkopplung mit konfigurierbarer Folgefunktion (z.B. neue Endposition, neue Geschwindigkeit, Stop, E-Stop) (SERVO)

noch nicht freigegeben !

UINT32 | ENUM | s. Anhang | Entkopplungs-Typ (s. Anhang)
REAL64 z.B. mm ±∞ Optional: Neue Endpostion
REAL64 | z.B. mm/s | > 0.0 | Optional: Neue geforderte Geschwindigkeit
REAL64 z.B. mm/s^2 ≥ 0.0
(0: Default) 		Optional: Beschleunigung für neue Endposition, neue Geschwindigkeit und Emergency Stop (E-Stop)
REAL64 z.B. mm/s^2 ≥ 0.0
(0: Default) 		Optional: Verzögerung für neue Endposition, neue Geschwindigkeit und Emergency Stop (E-Stop)
REAL64 z.B. mm/s^3 ≥ 0.0
(0: Default) 		Optional: Ruck für neue Endposition, neue Geschwindigkeit und Emergency Stop (E-Stop)
}
0x00000042 Write Master / Slave- Kopplung

Typ: LINEAR (&SPECIAL)

 { Änderung der Kopplungsparameter (SERVO):
REAL64 1 [±1000000.0]

Parameter 1:

Linear: Getriebefaktor
REAL64 1 [±1000000.0]

Parameter 2:

Linear: Reserve
REAL64 1 [±1000000.0]

Parameter 3:

Linear: Reserve
REAL64 1 [±1000000.0]

Parameter 4:

Linear: Reserve
}
0x00000043 Write Master / Slave- Tabellen- Kopplung

Typ: TABULAR

{ Änderung der Tabellen- Kopplungsparameter (SERVO):
REAL64 mm ±∞ Slave Positions-Offset
REAL64 mm ±∞ Master Positions-Offset
}
0x00000043 Write Master / Slave- Tabellen- Kopplung

Typ: TABULAR
und
"Motion Function"

{ Änderung der Tabellen- Kopplungsparameter (SERVO): Auch für "Motion Function"
REAL64 mm ±∞ Slave Positions-Offset
REAL64 mm ±∞ Master Positions-Offset
REAL64 | 1 | ±∞ (<> 0.0) | Slave Positions-Skalierung
REAL64 | 1 | ±∞ (<> 0.0) | Master Positions-Skalierung
}
0x00000043 Write Master / Slave- Tabellen- Kopplung

Typ: TABULAR

{ Änderung der Tabellen- Kopplungsparameter (SERVO):
REAL64 mm ±∞ Slave Positions-Offset
REAL64 mm ±∞ Master Positions-Offset
REAL64 | 1 | ±∞ (<> 0.0) | Slave Positions-Skalierung
REAL64 | 1 | ±∞ (<> 0.0) | Master Positions-Skalierung
REAL64 z.B. mm ±∞ Absolute Master Aktivierungsposition
}
0x00000044 | Write | Slave-Stop (SERVO) | VOID | Stop der "Fliegende Säge" (SERVO) | Nur für "Fliegende Säge"
0x00000045

(0x00n00045)

Write Master / Slave- Tabellen- Kopplung (SERVO) { Master / Slave Tabellen-Kopplung (SERVO):
UINT32 | ENUM | s. Anhang | Slavetyp / Kopplungstyp (s.Anhang)
UINT32 | 1 | [1...255] | Achs-ID der Masterachse
UINT32 | 1 | [0...8] | Subindex n der Masterachse (Default:-Wert:: 0)
UINT32 | 1 | [0...8] | Subindex n der Slaveachse (Default:-Wert: 0)
SOLO-TABELLEN ABSCHNITT:
REAL64 mm ±∞ Slave Positions-Offset (Typ: TABULAR)
REAL64 mm ±∞ Master Positions-Offset (Typ: TABULAR)
UINT32 | 1 | [0,1] | Slave Positionen absolut (Typ: TABULAR)
UINT32 | 1 | [0,1] | Master Positionen absolut (Typ: TABULAR)
UINT32 | 1 | [1...255] | Tabellen-ID der Koppeltabelle (Typ: TABULAR)
MULTI-TABELLEN ABSCHNITT:
UINT16 1 [0...8] Anzahl der Tabellen (Typ: MULTITAB)

Anmerkung: Missbraucht als Interpolations-Typ für Solo-Tabellen
UNIT16 | 1 | [0...8] | Anzahl der Profil-Tabellen (Typ: MULTITAB)
UNIT32[8] | 1 | [1...255] | Tabellen-IDs der Koppeltabellen (Typ: MULTITAB)
}
0x00000046 Write Master / Slave Multitabellen

UINT32

1

[1...255]

 Aktivierung Korrekturtabelle

Korrektur-Tabellen-ID

0x00000046 Write Master / Slave Multitabellen { Aktivierung Korrekturtabelle
UINT32 1

[1...255]

 Korrektur-Tabellen-ID
REAL64 z.B. mm ±∞ Absolute Master Aktivierungsposition
}
0x00000047 Write Master / Slave

Multitabellen

UINT32 1 [1..255] Deaktivierung Profiltabelle am Zyklusende

Tabellen-ID der aktuellen monozyklischen Profiltabelle

0x00000048 ReadWrite Master / Slave

Multitabellen

Write: UINT32 1 [1..255] Lesen des letzen Korrekturoffsets:

Tabellen-ID der Korrekturtabelle

Read: REAL32 z.B. mm ±∞ Offset durch Abfahren der Korrekturtabelle mit der entsprechenden Tabellen-ID
0x00000049 Write Master / Slave- Tabellen- Kopplung

Typ: TABULAR

REAL64

1

±∞

Ändern der Slave-Tabellenskalierung

Skalierungsfaktor der Slave-Tabellenspalte
(Default-Wert: 1.0)

0x0000004A

(0x00n0004A)

Write Master / Slave- Universelle- Tabellen- Kopplung (SERVO) { Master / Slave Solo-Tabellen-Kopplung (SERVO):
UINT32 | ENUM | s. Anhang | Slavetyp / Kopplungstyp (s.Anhang)
UINT32 | 1 | [1...255] | Achs-ID der Masterachse
UINT32 | 1 | [0...8] | Subindex n der Masterachse (Default:-Wert:: 0)
UINT32 | 1 | [0...8] | Subindex n der Slaveachse (Default:-Wert: 0)
UINT32 | 1 | 1...255] | Tabellen-ID der Koppeltabelle (Typ: TABULAR)
UINT32 | 1 | Tabellen-Interpolations-Typ
REAL64 mm ±∞ Slave Positions-Offset (Typ: TABULAR)
REAL64 mm ±∞ Master Positions-Offset (Typ: TABULAR)
REAL64 mm ±∞ Slave Positions-Skalierung (Typ: TABULAR)
REAL64 mm ±∞ Master Positions-Skalierung (Typ: TABULAR)
UINT32 1 [0,1] Slave Positionen absolut ?
(Typ: TABULAR)
UINT32 1 [0,1] Master Positionen absolut ?
(Typ: TABULAR)
UINT32 ENUM s. Anhang Aktivierungstyp der Änderung (NEU)

0: 'instantaneous' (default)
1: 'at master cam position'
2: 'at master axis position'
3: 'next cycle'

REAL64 mm ±∞ Aktivierungsposition (NEU)
UINT32 ENUM s. Anhang Master Skalierungstyp (NEU)
0: user defined (default)
1: scaling with auto offset
2: off
UINT32 ENUM s. Anhang Slave Skalierungstyp (NEU)
0: user defined (default)
1: scaling with auto offset
2: off
}
0x0000004B

(0x00n0004B)

Write Master / Slave-Universelle Fliegende Säge (SERVO) { Master / Slave Sychronisierungs- Kopplung (SERVO):
UINT32 | ENUM | s. Anhang | Slavetyp / Kopplungstyp (s.Anhang)
UINT32 | 1 | [1...255] | Achs-ID der Masterachse
UINT32 | 1 | [0...8] | Subindex n der Masterachse (Default:-Wert:: 0)
UINT32 | 1 | [0...8] | Subindex n der Slaveachse (Default:-Wert: 0)
REAL64 | 1 | ±∞ (<> 0.0) | Getriebefaktor
REAL64 mm ±∞ Master Synchronposition
REAL64 mm ±∞ Slave Synchronposition
REAL64 mm/s ≥ 0.0 Slave Geschwindigkeit

(optional)

REAL64 mm/s^2 ≥ 0.0 Slave Beschleunigung

(optional)

REAL64 mm/s^2 ≥ 0.0 Slave Verzögerung

(optional)

REAL64 mm/s^3 ≥ 0.0 Slave Ruck

(optional)

UINT32 1 ≥ 0 Bitmaske für Überprüfungen und Betriebsarten

(Default-Wert: 0)

}
0x0000004D

(0x00n0004D)

Write Master / Slave- Tabellen- Kopplung

Typ: TABULAR
und MF

{ Änderung der Tabellen- Skalierung (SERVO):

NEU !

Auch für MF

Reservierte Funktion,
kein Standard!

UINT32 ENUM s. Anhang Aktivierungstyp der Änderung

0: 'instantaneous' (default)
1: 'at master cam position'
2: 'at master axis position'
3: 'next cycle'

REAL64 z.B. mm ±∞ Aktivierungsposition
UINT32 ENUM s. Anhang Master Skalierungstyp
0: user defined (default)
1: scaling with auto offset
2: off
UINT32 ENUM s. Anhang Slave Skalierungstyp
0: user defined (default)
1: scaling with auto offset
2: off
REAL64 z.B. mm ±∞ Master Positions-Offset
REAL64 z.B. mm ±∞ Slave Positions-Offset
REAL64 | 1 | ±∞ (<> 0.0) | Master Positions-Skalierung
REAL64 1 ±∞ Slave Positions-Skalierung
}
0x00000050 | Write | every | VOID | Deaktiviere komplette Achse (Disable)
0x00000051 | Write | every | VOID | Aktiviere komplette Achse (Enable)
0x00000052 Write SERVO { Änderung des aktiven Achsregelkreises (Trippel aus Encoder, Regler und Achsinterfaces) mit/ohne externe Sollwertvorgabe:
UINT32 1 ≥ 0 Nummer/Index des Achsregelkreises
(Default -Wert: 0)
UINT32 ENUM s.Anhang (>0) Umschalttyp für Auf-

synchronisierungsverhalten
1: 'Standard'
REAL64 1 ±∞ Synchronisierungswert für Umschaltung (optional)
UINT32 0/ 1 0/1 Externe Sollwertvorgabe mittels Achsinterface ?
Anmerkung: Wird bisher nicht verwendet!
}
0x00000060 | Write | every | VOID | Deaktiviere Drive-Output (Disable)
0x00000061 | Write | every | VOID | Aktiviere Drive-Output (Enable)
0x00000062 Write Eil/Schleich UINT16 1 0/1 Feststellbremse lösen ?

0: automatische Ansteuerung (Default)
1: zwingend immer geloest !

Anmerkung:
Wird beim Achsreset auf '0' zurückgesetzt !
0x00000070 | Write | every | VOID | Rückführung der Achse aus z. B. einer 3D-Gruppe in ihre persönliche PTP-Gruppe


"Index-Offset" Spezifikation für zyklische Achs-Prozessdaten (Index-Group 0x4300 + ID)

"Index-Offset" Spezifikation für zyklische Achs-Prozessdaten (Index-Group 0x4300 + ID)

Index-Offset (Hex) | Zugriff | Achs- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00n00000 | Read / Write | every (PLC→NC) | { 128 Byte } |  | STRUCT s. Achs- interface | ACHS-STRUKTUR (PLC→NC) n = 0: Standardinterface der Achse n > 0: n-tes Interface der Achse (optional) | Write-Befehl nur Optional! Sicherheitsaspekte beachten!
0x00n00001 | Read / Write | every (PLC→NC) | UINT32 | 1 | >0 | Steuer - Doppelwort | Write-Befehl nur Optional!
0x00n00002 | Read / Write | every (PLC→NC) | UINT16 | 1 | 0/1 | Reglerfreigabe | Nicht oszilloskopierbar!
0x00n00003 | Read / Write | every (PLC→NC) | UINT16 | 1 | 0/1 | Vorschubfreigabe Plus | Nicht oszilloskopierbar!
0x00n00004 | Read / Write | every (PLC→NC) | UINT16 | 1 | 0/1 | Vorschubfreigabe Minus | Nicht oszilloskopierbar!
0x00n00007 | Read / Write | every (PLC→NC) | UINT16 | 1 | 0/1 | Referenziernocke | Nicht oszilloskopierbar!
0x00n00021 | Read / Write | every (PLC→NC) | UINT32 | % | 0...1000000 | Geschwindigkeitsoverride (1000000 == 100%) | Write-Befehl nur Optional!
0x00n00022 | Read / Write | every (PLC→NC) | UINT32 | 1 | ENUM | Betriebsart Achse | Write-Befehl nur Optional!
0x00n00025 | Read / Write | every (PLC→NC) | REAL64 | z.B. mm |  | Istpositionskorrekturwert (Meßsystemfehlerkorrektur) | Write-Befehl nur Optional!
0x00n00026 | Read / Write | every (PLC→NC) | REAL64 | z.B. mm/s |  | Externer Regleranteil (Lageregleranteil) | Write-Befehl nur Optional!
0x00n00027 | Read / Write | every (PLC→NC) | { |  |  | Externe Sollwertgenerierung | Write-Befehl nur Optional!
 |  |  | REAL64 | z.B. mm | ±∞ | Externe Sollposition
 |  |  | REAL64 | z.B. mm/s | ±∞ | Externe Sollgeschwindigkeit
 |  |  | REAL64 | z.B. mm/s^2 | ±∞ | Externe Sollbeschleuinigung
 |  |  | INT32 | 1 | +1, 0, -1 | Externe Sollfahrrichtung
 |  |  | } |  |  |
0x00n00080 | Read | every (PLC→NC) | { 128 Byte } |  | STRUCT s. Achs- interface | ACHS-STRUKTUR (NC→PLC) n = 0: Standardinterface der Achse n > 0: n-tes Interface der Achse (optional) | NCTOPLC_AXLESTRUCT
0x00n00071 | Read | every (PLC→NC) | UINT8 | 1 | >0 | Status-Doppelwort: Byte 1 |
0x00n00072 | Read | every (PLC→NC) | UINT8 | 1 | >0 | Status-Doppelwort: Byte 2 |
0x00n00073 | Read | every (PLC→NC) | UINT8 | 1 | >0 | Status-Doppelwort: Byte 3 |
0x00n00074 | Read | every (PLC→NC) | UINT8 | 1 | >0 | Status-Doppelwort: Byte 4 |
0x00n00081 | Read | every (PLC→NC) | UINT32 | 1 | >0 | Status-Doppelwort (komplett) |
0x00n00082 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse ist betriebsbereit | Nicht oszilloskopierbar!
0x00n00083 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse ist referenziert | Nicht oszilloskopierbar!
0x00n00084 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse in geschützter Betriebsart (z.B. Slave-Achse) | Nicht oszilloskopierbar!
0x00n00085 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse in Eilgangsbetriebsart | Nicht oszilloskopierbar!
0x00n00088 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse hat ungültige IO Daten | Nicht oszilloskopierbar!
0x00n00089 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse ist im Fehlerzustand | Nicht oszilloskopierbar!
0x00n0008A | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse fährt größer | Nicht oszilloskopierbar!
0x00n0008B | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse fährt kleiner | Nicht oszilloskopierbar!
0x00n0008C | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse ist im Stillstand (Lageregler?) | Nicht oszilloskopierbar!
0x00n0008D | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse ist am Referenzieren | Nicht oszilloskopierbar!
0x00n0008E | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse ist im Positionsbereichsfenster | Nicht oszilloskopierbar!
0x00n0008F | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse ist in Zielposition (Zielposition erreicht) | Nicht oszilloskopierbar!
0x00n00090 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse hat V-Konst oder Drehzahl | Nicht oszilloskopierbar!
0x00n0009A | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Betriebsart nicht ausgeführt (Busy) | Nicht oszilloskopierbar!
0x00n0009B | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Achse hat Auftrag / Führt Auftrag aus | Nicht oszilloskopierbar!
0x00n000B1 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | Fehlercode Achse |
0x00n000B2 | Read | every (PLC→NC) | UINT32 | 1 | ENUM | Bewegungszustand der Achse |
0x00n000B3 | Read | every (PLC→NC) | UINT32 | 1 | ENUM | Betriebsart der Achse (Rück. NC) |
0x00n000B4 | Read | every (PLC→NC) | UINT32 | 1 | ENUM | Referenzierstatus der Achse |
0x00n000B5 | Read | every (PLC→NC) | UINT32 | 1 | ENUM | Koppelstatus der Achse |
0x00n000B6 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | SVB-Einträge/Aufträge der Achse (PRE-Tabelle) |
0x00n000B7 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | SAF-Einträge/Aufträge der Achse (EXE-Tabelle) |
0x00n000B8 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | Achs-ID |
0x00n000B9 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | Betriebsarten Status-Doppelwort: Bit 0: Positionsbereichsüberwachung aktiv? Bit 1: Zielpositionsfensterüberwachung aktiv? Bit 2: Schleifenweg aktiv? Bit 3: Physikalische Bewegungsüberwachung aktiv? Bit 4: PEH-Zeitüberwachung aktiv? Bit 5: Losekompensation aktiv? Bit 6: NEU: Verzögerte Fehlerreaktion aktiv? Bit 7: NEU: Modulo Betriebsart aktiv (Modulo-Achse)? Bit 16: Schleppabstandüberwachung Pos. aktiv? Bit 17: Schleppabstandüberwachung Gesch. aktiv? Bit 18: Endlagenüberwachung Min. aktiv? Bit 19: Endlagenüberwachung Max. aktiv? Bit 20: Istpositionskorrektur aktiv? |
0x00n000BA | Read | every (PLC→NC) | REAL64 | z.B. mm |  | Istposition (verrechneter Absolutwert) |
0x00n000BB | Read | every (PLC→NC) | REAL64 | z.B. mm |  | Modulo-Istposition |
0x00n000BC | Read | every (PLC→NC) | INT32 | 1 |  | Modulo-Umdrehungen |
0x00n000BD | Read | every (PLC→NC) | REAL64 | z.B. mm/s |  | Istgeschwindigkeit (optional) |
0x00n000BE | Read | every (PLC→NC) | REAL64 | z.B. mm |  | Schleppabstand Position |
0x00n000BF | Read | every (PLC→NC) | REAL64 | z.B. mm |  | Sollposition |
0x00n000C0 | Read | every (PLC→NC) | REAL64 | z.B. mm/s |  | Sollgeschwindigkeit |
0x00n000C1 | Read | every (PLC→NC) | REAL64 | z.B. mm/s^2 |  | Sollbeschleunigung |
0x00n000C2 | Read | every (PLC→NC) | REAL64 |  |  | Reserve 2 |
0x00n000C3 | Read | every (PLC→NC) | REAL64 |  |  | Reserve 3 |
0x00n000C4 | Read | every (PLC→NC) | REAL64 |  |  | Reserve 4 |
0x00n10000 | Read / Write | Encoder: every (NC→IO) | { 12 Byte } |  | STRUCT s. Encoder-interface | ENCODER-OUTPUT-STRUKTUR (NC→IO, 12 Byte) | Write-Befehl nur Optional! Sicherheitsaspekte beachten!
0x00n10000 | Read / Write | Encoder: every (NC→IO) | { 40 Byte } |  | STRUCT s. new Encoder-interface | ENCODER-EXTENDED-OUTPUT-STRUKTUR (new) (NC→IO, 40 Byte) | Write-Befehl nur Optional! Sicherheitsaspekte beachten!
0x00n10080 | Read | Encoder: every (IO→NC) | { 12 Byte } |  | STRUCT s. Encoder-interface | ENCODER-INPUT-STRUKTUR (IO→NC, 12 Byte) |
0x00n10080 | Read | Encoder: every (IO→NC) | { 40 Byte } |  | STRUCT s. new Encoder-interface | ENCODER-EXTENDED-INPUT-STRUKTUR (new) (IO→NC, 40 Byte) |
0x00n30000 | Read / Write | Drive: every (NC→IO) | { 12 Byte } |  | STRUCT s. Drive- interface | DRIVE-OUTPUT-STRUKTUR (NC→IO, 12 Byte) | Write-Befehl nur Optional! Sicherheitsaspekte beachten!
0x00n30000 | Read / Write | Drive: every (NC→IO) | { 40 Byte } |  | STRUCT s. new Drive-interface | DRIVE-EXTENDED-OUTPUT-STRUKTUR (new) (NC→IO, 40 Byte) | Write-Befehl nur Optional! Sicherheitsaspekte beachten!
0x00n30080 | Read | Drive: every (IO→NC) | { 12 Byte } |  | STRUCT s. Drive-interface | DRIVE-INPUT-STRUKTUR (NC→IO, 12 Byte) |
0x00n30080 | Read | Drive: every (IO→NC) | { 40 Byte } |  | STRUCT s. new Drive-interface | DRIVE-EXTENDED-INPUT-STRUKTUR (new) (NC→IO, 40 Byte) |


"Index-Offset" Spezifikation für Encoder-Parameter (Index-Group 0x5000 + ID)

"Index-Offset" Spezifikation für Encoder-Parameter (Index-Group 0x5000 + ID)

Index-Offset

(Hex)

 Zugriff

Gruppen-

typ

Daten-

typ

Phys.

Einheit

Definitions-

bereich

Beschreibung

Anmerkung

0x00000001 | Read | every | UINT32 | 1 | [1 ... 255] | Encoder-ID
0x00000002 | Read | every | UINT8[30+1] | 1 | 30 Zeichen | Encoder-Name
0x00000003 | Read | every | UINT32 | 1 | s. ENUM (>0) | Encoder-Typ
0x00000004 | Read / Write | every | UINT32 | 1 | Byteoffset | Input-Adress-Offset (IO-Input-Image) | Änderung der IO-Adresse
0x00000005 | Read / Write | every | UINT32 | 1 | Byteoffset | Output-Adresse-Offset (IO-Output-Image) | Änderung der IO-Adresse
0x00000006 Read / Write every REAL64 z.B. mm/INC [1.0E-12 ... 1.0E+30] Resultierender Skalierungsfaktor (Zähler / Nenner)

Anm.: ab TC 3.0 besteht der Skalierungsfaktor aus zwei Komponenten, Zähler und Nenner (Default: 1.0).
0x00000007 | Read / Write | every | REAL64 | z.B. mm | [±1.0E+9] | Positionsoffset
0x00000008 | Read / Write | every | UINT16 | 1 | [0,1] | Geberzählrichtung
0x00000009 | Read / Write | every | REAL64 | z.B. mm | [0.001 ... 1.0E+9] | Modulo-Faktor
0x0000000A | Read / Write | every | UINT32 | 1 | s. ENUM (>0) | Encoder Modus | s. Anhang
0x0000000B | Read / Write | every | UINT16 | 1 | 0/1 | Softend-Min-Überwachung?
0x0000000C | Read / Write | every | UINT16 | 1 | 0/1 | Softend-Max-Überwachung?
0x0000000D | Read / Write | every | REAL64 | mm | Softendlage Min
0x0000000E | Read / Write | every | REAL64 | mm | Softendlage Max
0x0000000F Read / Write every UINT32 1 s. ENUM (≥0) Encoder Auswerterichtung (Freigabe log. Zählrichtung)

s. Anhang

0x00000010 | Read / Write | every | REAL64 | s | [0.0...60.0] | Filterzeit fuer Positionsistwert in Sekunden(P-T1)
0x00000011 | Read / Write | every | REAL64 | s | [0.0...60.0] | Filterzeit fuer Geschwindigkeitsistwert in Sekunden (P-T1)
0x00000012 | Read / Write | every | REAL64 | s | [0.0...60.0] | Filterzeit fuer Beschleunigungsistwert in Sekunden (P-T1)
0x00000013 | Read / Write | every | UINT8[10+1] | 1 | Physikalische Einheit | Nicht implementiert!
0x00000014 Read / Write every UINT32 1 Interpretation der Einheiten (Position, Geschwindigkeit, Zeit)

Bit 0: Geschwindigkeit in x/min statt x/s
Bit 1: Position in tausendstel der Basiseinheit

Nicht implementiert!

Bitarray

0x00000015 Read every UINT32 INC [0x0...

0xFFFFFFFF]

 Geber-Maske (Maximalwert des Geber-Istwertes in Inkrementen)

Anm.: Ab TwinCAT 2.11 R2 darf die Geber-Maske ein beliebiger Zahlenwert sein (z.B. 3600000) und muss nicht mehr wie bisher einer durchgehende Folge von binären Einsen entsprechen (2n-1). 		NEU

ReadOnly-Parameter

s.a. Param. "Geber-Sub-Maske"
0x00000016 | Read / Write | every | UINT16 | 1 | 0/1 | Istpositionskorrektur (Meßsystemfehlerkorrektur)?
0x00000017 | Read / Write | every | REAL64 | s | [0.0...60.0] | Filterzeit für Istpositionskorrektur in Sekunden (P-T1)
0x00000018 Read / Write every UINT32 1 [0x0...

0xFFFFFFFF]

Filtermaske für rohen Inkrementalwert

(0x0: voller Durchlass )
0x00000019 Read / Write every UINT32 1 s. ENUM (≥0) Encoder Bezugsmaßsystem

s. Anhang

0x0000001A Read / Write every UINT32 1 s. ENUM (≥0) Encoder Positionsinitialisierung

Nicht implementiert!

0x0000001B | Read / Write | every | REAL64 | z.B. mm | [≥0, Modulo-Faktor/2] | Toleranzfenster für Modulo-Start
0x0000001C | Read | every | UINT32 | 1 | s. ENUM (≥0) | Encoder Vorzeichen-Interpretation (Datentyp)
0x0000001D Read every UINT16 1 0/1 Inkremental- oder Absolut-Encoder ?
0: Inkrementaler Encoder-Typ
1: Absoluter Encoder-Typ
0x00000020 Read / Write every UINT32 1 s. ENUM (≥0) Encoder Totzeitkompensations Modus
0: Aus (Default)
1: Ein (mittels Geschwindigkeit)
2: Ein (mittels Geschwindigkeit und Beschleunigung)

0x00000021 Read / Write every UINT32 1 Steuerdoppelwort (32 Bits) für die Encoder Totzeitkompensation:

Bit 0 = 0: relative IO Zeiten (Default)
Bit 0 = 1: absolute IO Zeiten

0x00000022 | Read / Write | every | INT32 | ns | [±1.0E+9] | Summe der parametrierten zeitlichen Verschiebung für die Encoder Totzeitkompensation (typischerweise positive Zahlenwerte)
0x00000023 Read / Write every REAL64 z.B. mm/INC [1.0E-12 ... 1.0E+30] Komponente des Skalierungsfaktors: Zähler
(=> Skalierungsfaktor Zähler / Skalierungsfaktor Nenner) 		Neu ab
TC 3.0
0x00000024 Read / Write every REAL64 1 [1.0E-12 ... 1.0E+30] Komponente des Skalierungsfaktors: Nenner
(=> Skalierungsfaktor Zähler / Skalierungsfaktor Nenner)
Default: 1.0 		Neu ab
TC 3.0
0x00000025 Read / Write every {
REAL64
REAL64
} 16 bytes
z.B. mm/INC
1
[1.0E-12 ... 1.0E+30]
[1.0E-12 ... 1.0E+30]
Komponente des Skalierungsfaktors: Zähler
Komponente des Skalierungsfaktors: Nenner
(=> Skalierungsfaktor Zähler / Skalierungsfaktor Nenner) 		Neu ab
TC 3.0
0x00000030 Read / Write every UINT32 1

Internes Encoder Control Doppelwort zur Festlegung der Betriebsarten und Eigenschaften

Reserviert !
ab 211R3 B2227
0x00000101 | Read / Write | INC | UINT16 | 1 | [0,1] | Suchrichtung für Ref.nocken invers?
0x00000102 | Read / Write | INC | 1 | [0,1] | Suchrichtung für Syncimpuls invers?
0x00000103 | Read / Write | INC | REAL64 | z.B. mm | [±1.0E+9] | Referenzposition
0x00000104 | Read / Write | INC | UINT16 | 1 | [0,1] | Abstandsüberwachung zwischen Ref.nocken und Syncimpuls aktiv? | Nicht implementiert!
0x00000105 | Read / Write | INC | UINT32 | INC | [0 ...65536] | Mindestabstand Ref.nocken zum Syncimpuls in Inkrementen | Nicht implementiert!
0x00000106 | Read / Write | INC | UINT16 | 1 | [0,1] | Externer Syncimpuls?
0x00000107 Read / Write INC UINT32 1 s. ENUM (>0) Referenzier Modus

s. Anhang

0x00000108 Read / Write INC UINT32 1 [0x0000000F...

0xFFFFFFFF]

Binärmaske: (2n - 1)

 Geber-Sub-Maske (Maximalwert des Absolutbereichs des Geber-Istwertes in Inkrementen)
Wird z.B. verwendet als Referenzmarke für den Referenzier Mode "Software Sync" und für die NC Retain Daten("ABSOLUTE (MODULO)", "INCREMENTAL (SINGLETURN ABSOLUTE)" ).

Anm.1: Die Geber-Sub-Maske muss kleiner gleich der Geber-Maske sein.
Anm.2: Die Geber-Maske muss ein ganzzahliges Vielfaches der Geber-Sub-Maske sein.
Anm.3: Die Geber-Sub-Maske muss einer durchgehenden Folge von binären Einsen entsprechen (2n-1), z.B. 0x000FFFFF. 		NEU

s.a. Param. "Geber-Maske"
0x00000110 | Read / Write | INC (Encoder- Simulation) | REAL64 | 1 | [0.0 ... 1000000.0] | Skalierung/Gewichtung des Rauschanteils für Simulationsencoder


"Index-Offset" Spezifikation für Encoder-Zustand (Index-Group 0x5100 + ID)

"Index-Offset" Spezifikation für Encoder-Zustand (Index-Group 0x5100 + ID)

Index-Offset (Hex) | Zugriff | Gruppen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | INT32 |  |  | Fehlerstatus Encoder |
0x00000002 | Read | every | REAL64 |  |  | Istposition (verrechnet mit Istpositionskorrekturwert) | Symbolischer Zugriff möglich! 'fPosIst'
0x00000003 | Read | every | REAL64 |  |  | Modulo-Istposition | Symbolischer Zugriff möglich! 'FModuloPosIst'
0x00000004 | Read | every | INT32 |  |  | Modulo-Istumdrehung | Symbolischer Zugriff möglich! 'nModuloTurns'
0x00000005 | Read | every | REAL64 |  |  | Optional: Istgeschwindigkeit | Base Unit / s Symbolischer Zugriff möglich! 'fVeloIst'
0x00000006 | Read | every | REAL64 |  |  | Optional: Istbeschleunigung | Base Unit / s^2 Symbolischer Zugriff möglich! 'fAccIst'
0x00000007 | Read | every | INT32 |  |  | Geber-Istinkremente | Symbolischer Zugriff möglich! 'nHardIncs'
0x00000008 | Read | every | INT64 |  |  | Software-Istinkrementalzähler | Symbolischer Zugriff möglich! 'nSoftIncs'
0x00000009 | Read / Write | every | UINT16 |  |  | Referenzierflag ("Eichflag") |
0x0000000A | Read | every | REAL64 |  |  | Istpositionskorrekturwert (Meßsystemfehlerkorrektur) |
0x0000000B | Read | every | REAL64 |  |  | Istposition ohne Istpositionskorrekturwert |
0x0000000C | Read | every | REAL64 | z.B. mm |  | Istpositionskorrekturwert aufgrund der Totzeitkompensation |
0x0000000D | Read | every | REAL64 | s |  | Summe der zeitlichen Verschiebung für Encoder Totzeitkompensation (parametrierte und variable Totzeit) Anm.: Eine Totzeit wird im System als positiver Wert angegeben. |
0x0000000E | Read | every | REAL64 | z.B. mm |  | Interner Positionsoffset als Korrekturwert für eine Wertereduktion auf die Grundperiode (Modulobereich) |
0x00000010 | Read | every | REAL64 | z.B. mm/s |  | Istgeschwindigkeit ohne Istpositionskorrekturwert |
0x00000012 | Read | every | REAL64 | z.B. mm |  | Ungefilterte Istposition (verrechnet mit Istpositionskorrekturwert) |
0x00000015 | Read | every | REAL64 | z.B. mm/s |  | Optional: Ungefilterte Istgeschwindigkeit | Base Unit / s
0x00000016 | Read | every | READ (16 byte * N) |  |  | Lesen des Istpositions-Puffer | NEU ab TC 2.11 R3
 |  |  | { |  |  |
 |  |  | UINT32 | ns | ≥0 | Zeitstempel (DcTimeStamp mit 32 Bit)
 |  |  | UINT32 |  |  | Reserve
 |  |  | REAL64 | z.B. mm | ±∞ | Istposition zum zugehörigen Zeitstempel
 |  |  | } [N] |  |  |
0x00000101 | Read | INC | REAL64 | z.B. mm |  | Rücklesen der Positionsdifferenz zwischen Aktivieren und Gültig werden des Hardwarelatches | Nicht oszilloskopierbar!
0x00000200 | Read Write | function group "TouchProbeV2": - SERCOS (SoE), - EtherCAT (CANopen DS402) - SoftDrive (TCom) | WRITE (24 byte) |  |  | read "Touch Probe" state (state of external latch) | New since TC 2.11 Build 1547 only for SAF-port 501
 |  |  | { |  |  |
 |  |  | UINT32 | 1 | [1,2,3,4] | probe unit (probe 1, 2, 3, 4)
 |  |  | UINT32[5] |  |  | reserved
 |  |  | } |  |  |
 |  |  | READ (64 byte) |  |  |
 |  |  | { |  |  |
 |  |  | UINT32 | 1 | [0/1] | touch probe rising edge active?
 |  |  | UINT32 | 1 | [0/1] | touch probe rising edge became valid?
 |  |  | REAL64 | e.g. mm |  | touch probe rising edge position value
 |  |  | UINT32 | 1 | ≥0 | touch probe rising edge counter (continuous mode)
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 | 1 | [0/1] | touch probe falling edge active?
 |  |  | UINT32 | 1 | [0/1] | touch probe falling edge became valid?
 |  |  | REAL64 | e.g. mm |  | touch probe falling edge position value
 |  |  | UINT32 | 1 | ≥0 | touch probe falling edge counter (continuous mode)
 |  |  | UINT32[5] |  |  | reserved
 |  |  | } |  |  |
0x00000201 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT16 | 1 | [0,1] | "Externe Latch Funktion" aktiv ? bzw. "Meßtasterfunktion" aktiv ? (flankenunabhängig) | Nicht oszilloskopierbar!
0x00000201 | Read | CANopen | UINT32[4] | 1 | [0,1] | "Externe Latch Funktionen 1 bis 4" aktiv ? bzw. "Meßtasterfunktionen 1 bis 4" aktiv ? | Nicht oszilloskopierbar!
0x00000202 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT16 | 1 | [0,1] | Externer Latchwert gültig geworden? bzw. Meßtaster gelatcht ? (flankenunabhängig) | s. a. Achsinterface NcToPlc (Statusdoppelwort)
0x00000202 | Read | CANopen | UINT32[4] | 1 | [0,1] | Externe Latchwerte 1 bis 4 gültig geworden? bzw. Meßtaster 1 bis 4 gelatcht ? | s. a. Achsinterface NcToPlc (Statusdoppelwort)
0x00000203 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT32 | INC |  | Externer / Meßtaster Hardwareinkrementallatchwert |
0x00000204 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT64 | INC |  | Externer / Meßtaster Softwareinkrementallatchwert |
0x00000205 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | REAL64 | z.B. mm |  | Externer / Meßtaster Positionslatchwert | Base Unit
0x00000205 | Read | CANopen | REAL64[4] | z.B. mm |  | Externe Meßtasterwerte / Positionslatchwerte | Base Unit
0x00000206 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT32 | INC |  | Differenz Hardwareinkrementallatchwerte (NewLatch - LastLatch) | Nicht oszilloskopierbar!
0x00000207 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT64 | INC |  | Differenz Softwareinkrementallatchwerte (NewLatch - LastLatch) | Nicht oszilloskopierbar!
0x00000208 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | REAL64 | z.B. mm |  | Differenz Positionslatchwerte (NewLatch - LastLatch) | Nicht oszilloskopierbar! Base Unit
0x00000210 | Read | KL5101, AX2xxx, ProviDrive | UINT16 | 1 | [0,1] | "Externe Latch Funktion" für steigende Flanke aktiv ? bzw. "Meßtasterfunktion" für steigende Flanke aktiv ? | Erweiterung für KL5101 (3E), AX2xxx (3.51) und ProviDrive (3.1) Nicht oszilloskopierbar!
0x00000210 | Read | CANopen | UINT16[4] | 1 | [0,1] | "Externe Latch Funktion" für steigende Flanke aktiv ? bzw. "Meßtasterfunktion" für steigende Flanke aktiv ? | Nicht oszilloskopierbar!
0x00000211 | Read | KL5101, AX2xxx, ProviDrive | UINT16 | 1 | [0,1] | "Externe Latch Funktion" für fallende Flanke aktiv ? bzw. "Meßtasterfunktion" für fallende Flanke aktiv ? | Erweiterung für KL5101 (3E), AX2xxx (3.51) und ProviDrive (3.1) Nicht oszilloskopierbar!
0x00000211 | Read | CANopen | UINT16[4] | 1 | [0,1] | "Externe Latch Funktion" für fallende Flanke aktiv ? bzw. "Meßtasterfunktion" für fallende Flanke aktiv ? | Nicht oszilloskopierbar!


"Index-Offset" Spezifikation für Encoder-Funktionen (Index-Group 0x5200 + ID)

"Index-Offset" Spezifikation für Encoder-Funktionen (Index-Group 0x5200 + ID)

Index-Offset (Hex) | Zugriff | Gruppen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x0000001A | Write | every | { |  |  | Setze Istposition Encoder/Achse | Base Unit
 |  |  | UINT32 | ENUM | s. Anhang | Istpositionstyp (s.Anhang)
 |  |  | REAL64 | mm | ±∞ | Istposition für Encoder/Achse Vorsicht bei Benutzung !
 |  |  | } |  |  |
0x00000200 | Write | function group "TouchProbeV2": - SERCOS (SoE), - EtherCAT (CANopen DS402) - SoftDrive (TCom) | { |  |  | activate "Touch Probe" (external latch) | NEU ab TC 2.11 Build 1547 only for SAF-port 501
 |  |  | UINT32 | 1 | [1,2,3,4] | probe unit (probe 1, 2, 3, 4)
 |  |  | UINT32 | 1 | [0,1] | signal edge (0=rising edge, 1=falling edge)
 |  |  | UINT32 | 1 | [1,2] | probe mode (1=single, 2=continuous, ...)
 |  |  | UINT32 |  |  | reserved (e.g. signal source)
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 |  |  | reserved
 |  |  | } 24 bytes |  |  |
0x00000201 | Write | KL5101, SERCOS, AX2xxx, PROFIDrive | VOID |  |  | Aktiviere "Externes Latch" bzw. Aktiviere "Messtasterfunktion" (typischerweise steigende Flanke) |
0x00000201 | Write | CANopen | UINT32[4] |  |  | Aktiviere "Externes Latch" 1 bis 4 bzw. Aktiviere "Messtasterfunktion" 1 bis 4 (typischerweise steigende Flanke) |
0x00000202 | Write | KL5101, AX2xxx, PROFIDrive | VOID |  |  | Aktiviere "Externes Latch" bzw. Aktiviere "Messtasterfunktion" (fallende Flanke) |
0x00000202 | Write | CANopen | UINT32[4] |  |  | Aktiviere "Externes Latch" 1 bis 4 bzw. Aktiviere "Messtasterfunktion" 1 bis 4 (fallende Flanke) |
0x00000205 | Write | function group "TouchProbeV2": - SERCOS (SoE), - EtherCAT (CANopen DS402) - SoftDrive (TCom) | { |  |  | deactivate "Touch Probe" (external latch) | NEU ab TC 2.11 Build 1547 only for SAF-port 501
 |  |  | UINT32 | 1 | [1,2,3,4] | probe unit (probe 1, 2, 3, 4)
 |  |  | UINT32 | 1 | [0,1] | signal edge (0=rising edge, 1=falling edge)
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 |  |  | reserved
 |  |  | } 24 byte |  |  |
0x00000205 | Write | KL5101, SERCOS, AX2xxx, PROFIDrive | VOID |  |  | Deaktiviere "Externes Latch" bzw. Deaktiviere "Messtasterfunktion" |
0x00000205 | Write | CANopen | UINT32[4] |  |  | Deaktiviere "Externes Latch" bzw. Deaktiviere "Messtasterfunktion" |
0x00000210 | Write | KL5101, SERCOS, AX2xxx, PROFIDrive | REAL64 | z.B. mm | ±∞ | Setze "Externes Latch Ereignis" und "Externe Latchposition" | Nur für Simulation !


"Index-Offset" Spezifikation für zyklische Encoder-Prozessdaten (Index-Group 0x5300 + ID)

"Index-Offset" Spezifikation für zyklische Encoder-Prozessdaten (Index-Group 0x5300 + ID)

Index-Offset (Hex) | Zugriff | Gruppen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000000 | Read / Write | every (NC→IO) | { |  | STRUCT s. Encoder-Interface bzw. s. erweitertes Encoder-Interface | ENCODER-OUTPUT-STRUKTUR (NC→IO, 12 Byte) bzw. optional ENCODER-OUTPUT-STRUKTUR (NC→IO, 40 Byte) | Write-Befehl nur Optional! Sicherheitsaspekte beachten! NEU
 |  |  | INT32 | INC | ≥ 0 | nOutData1
 |  |  | INT32 | INC | ≥ 0 | nOutData2
 |  |  | UINT8 | 1 | ≥ 0 | nControl1
 |  |  | UINT8 | 1 | ≥ 0 | nControl2
 |  |  | UINT8 | 1 | ≥ 0 | nControl3
 |  |  | UINT8 | 1 | ≥ 0 | nControl4
 |  |  | Optional: |  |  |
 |  |  | INT32 | INC | ≥ 0 | nOutData3
 |  |  | INT32 | INC | ≥ 0 | nOutData4
 |  |  | INT32 | INC | ≥ 0 | nOutData5
 |  |  | INT32 | INC | ≥ 0 | nOutData6
 |  |  | UINT8 | 1 | ≥ 0 | nControl5
 |  |  | UINT8 | 1 | ≥ 0 | nControl6
 |  |  | UINT8 | 1 | ≥ 0 | nControl7
 |  |  | UINT8 | 1 | ≥ 0 | nControl8
 |  |  | INT32 |  | ≥ 0 | reserviert
 |  |  | INT32 |  | ≥ 0 | reserviert
 |  |  | } |  |  |
0x00000080 | Write | every (IO→NC) | { |  | STRUCT s. Encoder-Interface bzw. s. erweitertes Encoder-Interface | ENCODER-INPUT-STRUKTUR (IO→NC, 12 Byte) bzw. optional ENCODER-INPUT-STRUKTUR (IO→NC, 40 Byte) | NEU
 |  |  | INT32 | INC | ≥ 0 | nInData1
 |  |  | INT32 | INC | ≥ 0 | nInData2
 |  |  | UINT8 | 1 | ≥ 0 | nStatus1
 |  |  | UINT8 | 1 | ≥ 0 | nStatus2
 |  |  | UINT8 | 1 | ≥ 0 | nStatus3
 |  |  | UINT8 | 1 | ≥ 0 | nStatus4
 |  |  | Optional: |  |  |
 |  |  | INT32 | INC | ≥ 0 | nInData3
 |  |  | INT32 | INC | ≥ 0 | nInData4
 |  |  | INT32 | INC | ≥ 0 | nInData5
 |  |  | INT32 | INC | ≥ 0 | nInData6
 |  |  | UINT8 | 1 | ≥ 0 | nStatus5
 |  |  | UINT8 | 1 | ≥ 0 | nStatus6
 |  |  | UINT8 | 1 | ≥ 0 | nStatus7
 |  |  | UINT8 | 1 | ≥ 0 | nStatus8
 |  |  | INT32 |  | ≥ 0 | reserviert
 |  |  | INT32 |  | ≥ 0 | reserviert
 |  |  | } |  |  |


"Index-Offset" Spezifikation für Regler-Parameter (Index-Group 0x6000 + ID)

"Index-Offset" Spezifikation für Regler-Parameter (Index-Group 0x6000 + ID)

Index-Offset (Hex) | Zugriff | Regler- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | UINT32 | 1 | [1 ... 255] | Regler ID |
0x00000002 | Read | every | UINT8[30+1] | 1 | 30 Zeichen | Regler-Name |
0x00000003 | Read | every | UINT32 | 1 | s. ENUM (>0) | Regler-Typ |
0x0000000A | Read / Write | every | UINT32 | 1 | s. ENUM (>0) | Regler-Modus |
0x0000000B | Read / Write | every | REAL64 | % | [0.0 ... 1.0] | Gewichtung der Geschwindigkeitsvorsteuerung (Standardwert: 1.0 == 100%) |
0x00000010 | Read / Write | every | UINT16 | 1 | 0/1 | Schleppabstandüberw. Pos.? |
0x00000011 | Read / Write | every | UINT16 | 1 | 0/1 | Schleppabstandüberw. Geschw.? |
0x00000012 | Read / Write | every | REAL64 | mm |  | Max. Schleppabstand Position |
0x00000013 | Read / Write | every | REAL64 | s |  | Max. Schleppfilterzeit Position |
0x00000014 | Read / Write | every | REAL64 | mm/s |  | Max. Schleppabstand Geschw. |
0x00000015 | Read / Write | every | REAL64 | s |  | Max. Schleppfilterzeit Geschw. |
0x00000021 | Read / Write | every | REAL64 | 1 | [0.0...1000000.0] | Skalierungsfaktor (Multiplikator) für Differenz der Schleppabstände zwischen Master und Slaveachse (Umrechnung in das selbe Koordinatensytem des Masters) | Reservierte Funktion, kein Standard!
0x00000100 | Read / Write | P/PID (Pos., (Geschw.) | REAL64 | 1 | [0.0...1.0] | Maximale Ausgabebegrenzung (±) für Regler-Gesamtausgabe | (Standardwert: 0.5 == 50%)
0x00000102 | Read / Write | P/PID (Pos.) | REAL64 | (mm/s) / mm | [0.0...1000.0] | Proportionalverstärkung kp bzw. kv | Base Unit / s / Base Unit Positionsregelung
0x00000103 | Read / Write | PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Nachstellzeit Tn | Positionsregelung
0x00000104 | Read / Write | PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Vorhaltzeit Tv | Positionsregelung
0x00000105 | Read / Write | PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Verzögerungszeit Td | Positionsregelung
0x00000106 | Read / Write | PP (Pos.) | REAL64 | (mm/s) / mm | [0.0...1000.0] | Zusätzlicher Proportionalverstärkung kp bzw. kv, die oberhalb einer Grenzgeschwindigkeit in Prozent gilt. | Base Unit / s / Base Unit Positionsregelung
0x00000107 | Read / Write | PP (Pos.) | REAL64 | % | [0.0...1.0] | Schwellgeschwindigkeit in Prozent, oberhalb derer die zusätzliche Proportionalverstärkung kp bzw. kv gilt | (Standardwert: 0.01 == 1%)
0x00000108 | Read / Write | P/PID (Acc.) | REAL64 | s | [0.0 ... 100.0] | Proportionalverstärkung ka | Beschleunigungs- vorsteuerung
0x0000010A | Read / Write | every | UINT32 | 1 | ENUM | Filter für Maximalsteigung der Sollgeschwindigkeit (beschleunigungsbegrenzt): 0: Off, 1: Velo, 2: Pos+Velo | Reservierte Funktion, kein Standard!
0x0000010B | Read / Write | every | REAL64 | mm/s^2 |  | Filterwert für die Maximalsteigung der Sollgeschwindigkeit (Maximalbeschleunigung) | Reservierte Funktion, kein Standard!
0x0000010D | Read / Write | P/PID | REAL64 | mm | [0.0 ... 10000.0] | Totzone ("dead band") für Positionsfehler (Regelabweichung) (für P/PID-Regler mit Geschwindigkeits- oder Momenteninterface) | NEU ! Reservierte Funktion
0x0000010F | Read / Write | P/PP/PID (Pos.) Slave-Regelung | REAL64 | (mm/s) / mm | [0.0...1000.0] | Slave-Koppeldifferenzregelung: Proportionalverstärkung kcp | NEU ! Slave-Koppeldifferenzregelung
0x00000110 | Read / Write | P (Pos.) | UINT16 | 1 | 0/1 | Automatischer Offsetabgleich: aktiv/passiv |
0x00000111 | Read / Write | P (Pos.) | UINT16 | 1 | 0/1 | Automatischer Offsetabgleich: Halte-Modus |
0x00000112 | Read / Write | P (Pos.) | UINT16 | 1 | 0/1 | Automatischer Offsetabgleich: Fading-Modus |
0x00000114 | Read / Write | P (Pos.) | REAL64 | % | [0.0 ... 1.0] | Automatischer Offsetabgleich: Vorsteuer-Grenze | (Standardwert: 0.05 == 5%)
0x00000115 | Read / Write | P (Pos.) | REAL64 | s | [0.1 ... 60.0] | Automatischer Offsetabgleich: Zeitkonstante |
0x00000116 | Read / Write | PID (Pos.) | REAL64 | % | [0.0...1.0] | Maximale Ausgabebeschränkung (±) für I-Anteil in Prozent (Defaulteinstellung: 0.1 == 10%) |
0x00000117 | Read / Write | PID (Pos.) | REAL64 | % | [0.0...1.0] | Maximale Ausgabebeschränkung (±) für D-Anteil in Prozent (Defaulteinstellung: 0.1 == 10%) |
0x00000118 | Read / Write | PID (Pos.) | UINT16 | 1 | 0/1 | Abschalten des I-Anteils während eines aktiven Positioniervorganges (sofern I-Anteil aktiv)? (Defaulteinstellung: 0 = FALSE) |
0x00000120 | Read / Write | PID (Pos.) | REAL64 | s | ≥0 | PT-1 Filterwert für Positionsfehler (Pos.-Regeldifferenz) | Reservierte Funktion, kein Standard!
0x00000202 | Read / Write | P/PID (Geschw.) | REAL64 | 1 | [0.0...1000.0] | Proportionalverstärkung kp bzw. kv | Geschwindigkeits- regelung
0x00000203 | Read / Write | PID (Geschw.) | REAL64 | s | [0.0 ... 60.0] | Nachstellzeit Tn | Geschwindigkeits- regelung
0x00000204 | Read / Write | PID (Geschw.) | REAL64 | s | [0.0 ... 60.0] | Vorhaltzeit Tv | Geschwindigkeits- regelung
0x00000205 | Read / Write | PID (Geschw.) | REAL64 | s | [0.0 ... 60.0] | Verzögerungszeit Td | Geschwindigkeits- regelung
0x00000206 | Read / Write | PID (Geschw.) | REAL64 | % | [0.0...1.0] | Maximale Ausgabebeschränkung (±) fuer I-Anteil in Prozent (Defaulteinstellung: 0.1 == 10%) | Geschwindigkeits- regelung
0x00000207 | Read / Write | PID (Geschw.) | REAL64 | % | [0.0...1.0] | Maximale Ausgabebeschränkung (±) fuer D-Anteil in Prozent (Defaulteinstellung: 0.1 == 10%) | Geschwindigkeits- regelung
0x0000020D | Read / Write | P/PID (Geschw.) | REAL64 | mm/s | [0.0 ... 10000.0] | Totzone ("dead band") für Geschwindigkeitsfehler (Regelabweichung) (für P/PID-Regler mit Geschwindigkeits- oder Momenteninterface) | Reservierte Funktion
0x00000220 | Read / Write | P/PID (Geschw.) | REAL64 | s | ≥0 | PT-2 Filterwert für Geschwindigkeitsfehler (Geschw.-Regeldifferenz) | Geschwindigkeits- regelung, kein Standard!
0x00000221 | Read / Write | P/PID (Geschw.) | REAL64 | s | ≥0 | PT-1 Filterwert für Geschwindigkeitsfehler (Geschw.-Regeldifferenz) | Reservierte Funktion, kein Standard!
0x00000250 | Read / Write | P/PI (Beobachter) | UINT32 | 1 | s. ENUM (≥0) | Beobachter-Modus für Regelung im Momenten-Interface 0: OFF (default) 1: LUENBERGER | NEU ! ab TC 2.10 Build 1320
0x00000251 | Read / Write | P/PI (Beobachter) | REAL64 | Nm / A | >0.0 | Motor: Drehmomentkonstante KT | NEU !
0x00000252 | Read / Write | P/PI (Beobachter) | REAL64 | kg m2 | >0.0 | Motor: Trägheitsmoment JM | NEU !
0x00000253 | Read / Write | P/PI (Beobachter) | REAL64 | Hz | [100.0 ... 2000.0] Default: 500 | Bandbreite f0 | NEU !
0x00000254 | Read / Write | P/PI (Beobachter) | REAL64 | 1 | [0.0 ... 2.0] Default: 1.0 | Korrekturfaktor kc | NEU !
0x00000255 | Read / Write | P/PI (Beobachter) | REAL64 | s | [0.0 ... 0.01] Default: 0.001 | Geschwindkeits-Filter (1. Ordnung): Zeitkonstante T | NEU !
0x00000A03 | Read / Write | PID (MW) | REAL64 | cm^2 | [0.0 ...1000000] | Zylinderfläche AA der A-Seite in cm^2 |
0x00000A04 | Read / Write | PID (MW) | REAL64 | cm^2 | [0.0 ...1000000] | Zylinderfläche AB der B-Seite in cm^2 |
0x00000A05 | Read / Write | PID (MW) | REAL64 | cm^3/s | [0.0 ...1000000] | Nennvolumenstrom Qnenn in cm^3/s |
0x00000A06 | Read / Write | PID (MW) | REAL64 | bar | [0.0 ...1000000] | Nenndruck bzw. Ventildruckabfall Pnenn in bar |
0x00000A07 | Read / Write | PID (MW) | UINT32 | 1 | [1 ... 255] | Achs-ID für den Systemdruck Po |


"Index-Offset" Spezifikation für Regler-Zustand (Index-Group 0x6100 + ID)

TwinCAT ADS Device NC

"Index-Offset" Spezifikation für Regler-Zustand (Index-Group 0x6100 + ID)

Index-Offset (Hex) | Zugriff | Regler- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | INT32 |  |  | Fehlerstatus Regler | Symbolischer Zugriff möglich! 'nErrState'
0x00000002 | Read | every | REAL64 | z.B. mm/s |  | Reglerausgabe in absoluten Einheiten | Base Unit / s Symbolischer Zugriff möglich! 'fOutput'
0x00000003 | Read | every | REAL64 | % |  | Reglerausgabe in Prozent | Nicht oszilloskopierbar!
0x00000004 | Read | every | REAL64 | V |  | Reglerausgabe in Volt | Nicht oszilloskopierbar!
0x0000000D | Read | every | REAL64 | mm |  | Schleppabstand Position (ohne Totzeitkompensation) | Base Unit
0x0000000E | Read | every | REAL64 | mm |  | Schleppabstand Position (ohne Sollpositionskorrektur) | Base Unit
0x0000000F | Read | every | REAL64 | mm |  | Schleppabstand Position (mit Sollpositionskorrektur und mit Totzeitkompensation) | Base Unit Symbolischer Zugriff möglich! 'fPosDiff'
0x00000010 | Read | every | REAL64 | mm |  | PeakHold-Wert für maximalen negativen Schleppabstand der Position | Base Unit
0x00000011 | Read | every | REAL64 | mm |  | PeakHold-Wert für minimalen positiven Schleppabstand der Position | Base Unit
0x00000012 | Read | every | REAL64 | mm/s |  | Schleppabstand Geschwindigkeit | Base Unit / s
0x00000021 | Read | every | REAL64 | mm |  | Differenz (Abweichung) der Positions-Schleppabstände zwischen Master- und Slaveachse (Master- minus Slaveschleppabstand) | NEU ! Base Unit Symbolischer Zugriff über Achse möglich! 'fPosDiffCouple'
0x00000022 | Read | every | REAL64 | mm |  | PeakHold-Wert für maximale negative Differenz der Schleppabstände (Position) zwischen Master- und Slaveachse | NEU ! Base Unit
0x00000023 | Read | every | REAL64 | mm |  | PeakHold-Wert für maximale positive Differenz der Schleppabstände (Position) zwischen Master- und Slaveachse | NEU ! Base Unit
0x00000101 | Read | P/PID (Pos.) | REAL64 | z.B. mm/s |  | P-Anteil des Reglers in absoluten Einheiten |
0x00000102 | Read | PID (Pos.) | REAL64 | z.B. mm/s |  | I-Anteil des Reglers in absoluten Einheiten |
0x00000103 | Read | PID (Pos.) | REAL64 | z.B. mm/s |  | D-Anteil des Reglers in absoluten Einheiten |
0x00000104 | Read | PID (Pos.) | UINT16 | 1 | 0/1 | Begrenzung des I-Anteils aktiv? |
0x00000105 | Read | PID (Pos.) | UINT16 | 1 | 0/1 | Begrenzung des D-Anteils aktiv? |
0x00000106 | Read | PID (Pos.) | UINT16 | 1 | 0/1 | ARW-Massnahmen des I-Anteils aktiv? | ARW: Anti Reset Windup
0x00000110 | Read | PID (Pos.) | REAL64 | z.B. mm/s |  | Beschleunigungsvorsteuerung Yacc des Reglers in absoluten Einheiten Anmerkung: Funktion abhaengig vom Reglertyp! | Beschleunigungs- vorsteuerung
0x00000111 | Read | PP (Pos.) | REAL64 | mm/s/ mm | ≥0 | Interne interpolierte Proportionalverstärkung kp bzw. kv | NEU ! PP-Regler
0x0000011A 0x0000011B 0x0000011C 0x0000011D 0x0000011E 0x0000011F 0x00000120 0x00000121 0x00000122 0x00000123 0x00000124 | Read | P (Pos.) | UINT32 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 | 1 mm mm/s mm/s mm/s^2 mm mm mm/s mm/s^2 mm/s mm/s^2 |  | Sollgeschwindigkeitsfilter: InternalPhase InternalPosSollError ! TestVeloSoll InternalLimitedVeloSoll InternalAccSollRel InternalPosSollRel PosSollCorrected ! VeloSollCorrected ! AccSollCorrected ! TestVeloSollCorrected TestAccSollCorrected | NEU ! Reservierte Funktion, kein Standard!
0x00000201 | Read | P,PID (Geschw.) | REAL64 | z.B. mm/s |  | Geschwindigkeitsanteil des Reglers | Base Unit / s
0x00000202 | Read | P,PID (Geschw.) | REAL64 | % |  | Geschwindigkeitsanteil des Reglers in Prozent | Nicht oszilloskopierbar!
0x00000203 | Read | P,PID (Geschw.) | REAL64 | V |  | Geschwindigkeitsanteil des Reglers in Volt | Nicht oszilloskopierbar!
0x00000201 | Read | P/PID (Geschw.) | REAL64 | z.B. mm/s |  | P-Anteil des Reglers in absoluten Einheiten | Neu
0x00000202 | Read | P/PID (Geschw.) | REAL64 | z.B. mm/s |  | I-Anteil des Reglers in absoluten Einheiten | Neu
0x00000203 | Read | P/PID (Geschw.) | REAL64 | z.B. mm/s |  | D-Anteil des Reglers in absoluten Einheiten | Neu
0x00000204 | Read | P/PID (Geschw.) | UINT16 | 1 | 0/1 | Begrenzung des I-Anteils aktiv? | Neu
0x00000205 | Read | P/PID (Geschw.) | UINT16 | 1 | 0/1 | Begrenzung des D-Anteils aktiv? | Neu
0x00000206 | Read | P/PID (Geschw.) | UINT16 | 1 | 0/1 | ARW-Massnahmen des I-Anteils aktiv? | Neu ARW: Anti Reset Windup
0x0000020A | Read | P/PID (Geschw.) | REAL64 | z.B. mm/s |  | Gesamteingangsgröße des Geschwindigkeits-Reglers | Neu
0x00000250 | Read | P/PI (Beobachter) | REAL64 | z.B. mm |  | Beobachter: Positionsdifferenz (Ist-Position - Beobachter-Position | NEU !
0x00000251 | Read | P/PI (Beobachter) | REAL64 | z.B. mm |  | Beobachter: Position | NEU !
0x00000252 | Read | P/PI (Beobachter) | REAL64 | z.B. mm/s |  | Beobachter: Geschwindigkeit 2 (für P-Anteil) | NEU !
0x00000253 | Read | P/PI (Beobachter) | REAL64 | z.B. mm/s |  | Beobachter: Geschwindigkeit 1 (für I-Anteil) | NEU !
0x00000254 | Read | P/PI (Beobachter) | REAL64 | z.B. mm/s^2 |  | Beobachter: Beschleunigung | NEU !
0x00000255 | Read | P/PI (Beobachter) | REAL64 | A |  | Beobachter: Motor-Ist-Strom | NEU !
0x00000256 | Read | P/PI (Beobachter) | UINT16 | 1 | 0/1 | Beobachter: Begrenzung des I-Anteils aktiv? | NEU !
0x00000A00 | Read | PID (MW) | REAL64 | % | [-1.0...1.0] | Verrechnung der Sollgeschwindigkeit (Vorsteuerung) in Prozent |
0x00000A01 | Read | PID (MW) | REAL64 | z.B. mm/s |  | P-Anteil des Reglers in absoluten Einheiten oder Prozent (je nach Ausgabegewichtung) |
0x00000A02 | Read | PID (MW) | REAL64 | z.B. mm/s |  | I-Anteil des Reglers in absoluten Einheiten oder Prozent (je nach Ausgabegewichtung) |
0x00000A03 | Read | PID (MW) | REAL64 | z.B. mm/s |  | D-Anteil des Reglers in absoluten Einheiten oder Prozent (je nach Ausgabegewichtung) |
0x00000A04 | Read | PID (MW) | UINT16 | 1 | 0/1 | Begrenzung des I-Anteils aktiv? |
0x00000A05 | Read | PID (MW) | UINT16 | 1 | 0/1 | Begrenzung des D-Anteils aktiv? |
0x00000A10 | Read | PID (Pos.) | REAL64 | z.B. mm/s |  | Beschleunigungsvorsteuerung Yacc des Reglers in absoluten Einheiten | Beschleunigungs- vorsteuerung


"Index-Offset" Spezifikation für Regler-Funktionen (Index-Group 0x6200 + ID)

TwinCAT ADS Device NC

"Index-Offset" Spezifikation für Regler-Funktionen (Index-Group 0x6200+ ID)

"Index-Offset" Spezifikation für Regler-Funktionen (Index-Group 0x6200+ ID)

Index-Offset (Hex) | Zugriff | Regler- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung


"Index-Offset" Spezifikation für Drive-Parameter (Index-Group 0x7000 + ID)

"Index-Offset" Spezifikation für Drive-Parameter (Index-Group 0x7000 + ID)

Index-Offset (Hex) | Zugriff | Drive- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | UINT32 | 1 | [1 ... 255] | Drive ID |
0x00000002 | Read | every | UINT8[30+1] | 1 | 30 Zeichen | Drive-Name |
0x00000003 | Read | every | UINT32 | 1 | s. ENUM (>0) | Drive-Typ |
0x00000004 | Read / Write | every | UINT32 | 1 | Byteoffset | Input-Adress-Offset (IO-Input-Image) | Änderung der IO-Adresse
0x00000005 | Read / Write | every | UINT32 | 1 | Byteoffset | Output-Adresse-Offset (IO-Output-Image) | Änderung der IO-Adresse
0x00000006 | Read / Write | every | UINT16 | 1 | [0,1] | Motorpolarität |
0x0000000A | Read / Write | every | UINT32 | 1 | s. ENUM (>0) | Drive-Modus |
0x0000000B | Read / Write | every | REAL64 | % | [-1.0 ... 1.0] | Minimale Ausgabeschranke (Ausgabelimitierung) (Defaulteinstellung: -1.0 == -100%) |
0x0000000C | Read / Write | every | REAL64 | % | [-1.0 ... 1.0] | Maximale Ausgabeschranke (Ausgabelimitierung) (Defaulteinstellung: 1.0 == 100%) |
0x0000000D | Read | every | UINT32 | INC |  | Maximale Anzahl von Ausgabeinkrementen (Ausgabemaske) |
0x00000010 | Read / Write | every | UINT32 | 1 |  | Internes Drive Control Doppelwort zur Festlegung der Antriebs-Betriebsarten | Reserviert !
0x00000011 | Read / Write | every | UINT32 | 1 | ≥ 5 | Interner Drive Reset Zähler (Zeit in NC-Zyklen für Enable und Reset) | Reserviert !
0x00000020 | Read / Write | every | UINT32 | 1 | s. ENUM (≥0) | Drive Totzeitkompensations Modus 0: Aus (Default) 1: Ein (mittels Geschwindigkeit) 2: Ein (mittels Geschwindigkeit und Beschleunigung) | s. Anhang
0x00000021 | Read / Write | every | UINT32 | 1 |  | Steuerdoppelwort (32 Bits) für die Drive Totzeitkompensation: Bit 0 = 0: relative IO Zeiten (Default) Bit 0 = 1: absolute IO Zeiten |
0x00000022 | Read / Write | every | INT32 | ns | [±1.0E+9] | Summe der parametrierten zeitlichen Verschiebung für die Drive Totzeitkompensation (typischerweise positive Zahlenwerte) |
0x00000101 | Read / Write | Servo | REAL64 | z.B. mm/s | >0.0 | Bezugsgeschwindigkeit bei Bezugs- bzw. Referenzoutput (Geschwindigkeitsvorsteuerung) | Base Unit / s
0x00000102 | Read / Write | Servo | REAL64 | % | [0.0 ... 5.0] | Bezugs- bzw. Referenzoutput in Prozent |
0x00000103 | Read | Servo | REAL64 | z.B. mm/s | >0.0 | Resultierende Geschwindigkeit bei 100% Output | Base Unit / s
0x00000104 | Read / Write | Servo | REAL64 | z.B. mm/s | ±∞ | Geschwindigkeitsoffset (DAC-Offset) für Driftabgleich (Offsetabgleich) der Achse | Base Unit / s
0x00000105 | Read / Write | Servo (Sercos, Profi Drive, AX200x, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | Geschwindigkeitsskalierung (Skalierungsfaktor um auf Wichtung im Antrieb zu reagieren) | Für Sercos, Profi Drive, AX200x, CANopen
0x00000106 | Read / Write | Profi Drive DSC | UINT32 | 0.001 * 1/s | ≥ 0 | Profibus/Profi Drive DSC: Lageregelverstärung Kpc | Nur für Profi Drive DSC
0x00000107 | Read / Write | Profi Drive DSC | REAL64 | 1 | ≥ 0.0 | Profibus/Profi Drive DSC: Skalierung für Berechnung von 'XERR' (Default: 1.0) | Nur für Profi Drive DSC
0x00000109 | Read / Write | Servo | REAL64 | 1 | [0.0 ... 100000000.0] | Positionsskalierung (Skalierungsfaktor um auf Wichtung im Antrieb zu reagieren) | Für Sercos, CANopen (NEU)
0x0000010A | Read / Write | Servo | REAL64 | 1 | [0.0 ... 100000000.0] | Beschleunigungsskalierung (Skalierungsfaktor um auf Wichtung im Antrieb zu reagieren) | Für Sercos, Profi Drive, AX200x, CANopen (NEU)
0x0000010B | Read / Write | Servo | REAL64 | 1 | [0.0 ... 100000000.0] | Drehmomentskalierung (rot. Motor) bzw. Kraftskalierung (Linearmotor) (Skalierungsfaktor um auf Wichtung im Antrieb zu reagieren) | Für Sercos, Profi Drive, AX200x, CANopen (NEU)
0x0000010D | Read / Write | Servo (Sercos, CANopen) | REAL64 | s | [0.0 ... 1.0] | Verzögerungszeit für Drive-Geschwindigkeitsausgabe | Für Sercos, CANopen (NEU)
0x0000010E | Read / Write | Servo (Sercos, CANopen) | REAL64 | s | [0.0 ... 1.0] | Verzögerungszeit für Drive-Beschleunigungsausgabe | Für Sercos, CANopen (NEU)
0x0000010F | Read / Write | Servo (Sercos, CANopen) | REAL64 | s | [0.0 ... 1.0] | Verzögerungszeit für Drive-Drehmomentausgabe bzw. Kraftausgabe | Für Sercos, CANopen (NEU)
0x00000110 | Read / Write | Servo (Sercos, CANopen) | UINT32 | 1 | s. ENUM (≥0) | Optionale Ausgabefilterung des Positionsollwertes: Filter Typ 0: OFF (Default) 1: Moving Average 2: P-Tn | Für Sercos, CANopen (NEU) noch nicht freigegeben!
0x00000111 | Read / Write | Servo (Sercos, CANopen) | REAL64 | s | [0.0 ... 1.0] | Optionale Ausgabefilterung des Positionsollwertes: Filterzeit Anmerkung: Die maximale Filterzeit ist von der NC Zykluszeit abhängig und wird auf folgenden Maximalwert limitiert: 1 ms => 64 ms 2 ms => 128 ms 3 ms => 192 ms | FFür Sercos, CANopen (NEU) noch nicht freigegeben!
0x00000112 | Read / Write | Servo (Sercos, CANopen) | UINT32 | 1 | [0 ... 10] | Optionale Ausgabefilterung des Positionsollwertes: Filter Ordnung 'n' (nur für P-Tn Typ) | Für Sercos, CANopen (NEU) noch nicht freigegeben!
0x00000120 | Read / Write | Servo/ Hydraulik/ | UINT32 | 1 | ≥ 0 | Tabellen-ID (0: keine Tabelle) | Nur für KL4xxx, M2400, Universal
0x00000121 | Read / Write | Servo/ Hydraulik | UINT32 | 1 | ≥ 0 | Interpolation-Type 0: Linear 2: Spline | Nur für KL4xxx, M2400, Universal
0x00000122 | Read / Write | Servo/ Hydraulik | REAL64 | % | [-1.0 ... 1.0] | Ausgabeoffset in Prozent Anmerkung: Wirkt nach der Kennlinienauswertung ! | Nur für KL4xxx, M2400, Universal
0x00000151 | Read / Write | Servo / Nichtlinear | REAL64 | 1 | [0.0 ... 100.0] | Quadrantenausgleichsfaktor (Verhältnis zwischen I und III Quadr.) |
0x00000152 | Read / Write | Servo / Nichtlinear | REAL64 | 1 | [0.01 ... 1.0] | Geschwindigkeits-Stützstelle in Prozent (1.0 == 100%) |
0x00000153 | Read / Write | Servo / Nichtlinear | REAL64 | 1 | [0.01 ... 1.0] | Ausgabe-Stützstelle in Prozent(1.0 == 100%) |
0x00000301 | Read / Write | Schrittmotor | UINT8 |  |  | Bit-Maske: Zyklus 1 |
0x00000302 | Read / Write | Schrittmotor | UINT8 |  |  | Bit-Maske: Zyklus 2 |
0x00000303 | Read / Write | Schrittmotor | UINT8 |  |  | Bit-Maske: Zyklus 3 |
0x00000304 | Read / Write | Schrittmotor | UINT8 |  |  | Bit-Maske: Zyklus 4 |
0x00000305 | Read / Write | Schrittmotor | UINT8 |  |  | Bit-Maske: Zyklus 5 |
0x00000306 | Read / Write | Schrittmotor | UINT8 |  |  | Bit-Maske: Zyklus 6 |
0x00000307 | Read / Write | Schrittmotor | UINT8 |  |  | Bit-Maske: Zyklus 7 |
0x00000308 | Read / Write | Schrittmotor | UINT8 |  |  | Bit-Maske: Zyklus 8 |
0x00000310 | Read / Write | Schrittmotor | UINT8 |  |  | Bit-Maske: Haltestrom |


"Index-Offset" Spezifikation für Drive-Zustand (Index-Group 0x7100 + ID)

"Index-Offset" Spezifikation für Drive-Zustand (Index-Group 0x7100 + ID)

Index-Offset (Hex) | Zugriff | Drive- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | INT32 |  |  | Fehlerstatus Drive | Symbolischer Zugriff möglich! 'nErrState'
0x00000002 | Read | every | REAL64 | z. B. mm/s |  | Gesamtausgabe in absoluten Einheiten | Base Unit / s Symbolischer Zugriff möglich! 'fOutput'
0x00000003 | Read | every | REAL64 | % |  | Gesamtausgabe in Prozent |
0x00000004 | Read | every | REAL64 | V |  | Gesamtausgabe in Volt | Nicht oszilloskopierbar!
0x00000005 | Read | every | REAL64 | z. B. mm/s |  | PeakHold-Wert für maximale negative Gesamtausgabe | Base Unit / s
0x00000006 | Read | every | REAL64 | z. B. mm/s |  | PeakHold-Wert für maximale positive Gesamtausgabe | Base Unit / s
0x0000000C | Read | every | REAL64 | z.B. mm |  | Soll-Positionskorrekturwert für Drive Ausgabe aufgrund der Totzeitkompensation | NEU
0x0000000D | Read | every | REAL64 | s |  | Summe der zeitlichen Verschiebung für Drive Totzeitkompensation (parametrierte und variable Totzeit) Anm.: Eine Totzeit wird im System als positiver Wert angegeben. | NEU
0x00000013 | Read | every | REAL64 | % |  | Gesamtausgabe in Prozent (nach nichtlinearer Kennlinie !) |
0x00000014 | Read | every | REAL64 | V |  | Gesamtausgabe in Volt (nach nichtlinearer Kennlinie !) | Nicht oszilloskopierbar!


"Index-Offset" Spezifikation für Drive-Funktionen (Index-Group 0x7200 + ID)

"Index-Offset" Spezifikation für Drive-Funktionen (Index-Group 0x7200 + ID)

Index-Offset (Hex) | Zugriff | Drive- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000102 | Write | SERVO | { |  |  | Austragen und Löschen der Kennlinien-Tabelle im Drive | NEU ! nur für SAF-Port 501!
 |  |  | ULONG | 1 | >0 | s. Achs-Funktion mit Index-Offset 0x00000012
 |  |  | } |  |  |


"Index-Offset" Spezifikation für zyklische Drive-Prozessdaten (Index-Group 0x7300 + ID)

"Index-Offset" Spezifikation für zyklische Drive-Prozessdaten (Index-Group 0x7300 + ID)

Index-Offset (Hex) | Zugriff | Drive- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000000 | Read / Write | every (NC→IO) | { |  | STRUCT s. Drive-Interface bzw. s. erweitertes Drive-Interface | DRIVE-OUTPUT-STRUKTUR (NC→IO, 12 Byte) bzw. optional DRIVE-OUTPUT-STRUKTUR (NC→IO, 40 Byte) | Write-Befehl nur Optional! Sicherheitsaspekte beachten! NEU
 |  |  | INT32 | INC | ≥ 0 | nOutData1
 |  |  | INT32 | INC | ±2^31 | nOutData2
 |  |  | UINT8 | 1 | ≥ 0 | nControl1
 |  |  | UINT8 | 1 | ≥ 0 | nControl2
 |  |  | UINT8 | 1 | ≥ 0 | nControl3
 |  |  | UINT8 | 1 | ≥ 0 | nControl4
 |  |  | O ptional: |  |  |
 |  |  | INT32 | INC | ≥ 0 | nOutData3
 |  |  | INT32 | INC | ≥ 0 | nOutData4
 |  |  | INT32 | INC | ≥ 0 | nOutData5
 |  |  | INT32 | INC | ≥ 0 | nOutData6
 |  |  | UINT8 | 1 | ≥ 0 | nControl5
 |  |  | UINT8 | 1 | ≥ 0 | nControl6
 |  |  | UINT8 | 1 | ≥ 0 | nControl7
 |  |  | UINT8 | 1 | ≥ 0 | nControl8
 |  |  | INT32 | 1 | ≥ 0 | reserviert
 |  |  | INT32 | 1 | ≥ 0 | reserviert
 |  |  | } |  |  |
0x00000080 | Write | every (IO→NC) | { |  | STRUCT s. Drive-Interface bzw. s. erweitertes Drive-Interface | DRIVE-INPUT-STRUKTUR (IO→NC, 12 Byte) bzw. optional DRIVE-INPUT-STRUKTUR (IO→NC, 40 Byte) | NEU
 |  |  | INT32 | INC | ≥ 0 | nInData1
 |  |  | INT32 | INC | ±2^31 | nInData2
 |  |  | UINT8 | 1 | ≥ 0 | nStatus1
 |  |  | UINT8 | 1 | ≥ 0 | nStatus2
 |  |  | UINT8 | 1 | ≥ 0 | nStatus3
 |  |  | UINT8 | 1 | ≥ 0 | nStatus4
 |  |  | O ptional: |  |  |
 |  |  | INT32 | INC | ≥ 0 | nInData3
 |  |  | INT32 | INC | ≥ 0 | nInData4
 |  |  | INT32 | INC | ≥ 0 | nInData5
 |  |  | INT32 | INC | ≥ 0 | nInData6
 |  |  | UINT8 | 1 | ≥ 0 | nStatus5
 |  |  | UINT8 | 1 | ≥ 0 | nStatus6
 |  |  | UINT8 | 1 | ≥ 0 | nStatus7
 |  |  | UINT8 | 1 | ≥ 0 | nStatus8
 |  |  | INT32 | 1 | ≥ 0 | reserviert
 |  |  | INT32 | 1 | ≥ 0 | reserviert
 |  |  | } |  |  |


"Index-Offset" Spezifikation für Tabellen-Parameter (Index-Group 0xA000 + ID)

"Index-Offset" Spezifikation für Tabellen-Parameter (Index-Group 0xA000 + ID)

Index-Offset ( Hex ) | Zugriff | Tabellen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00000001 | Read | every | UINT32 | 1 | [1 ... 255] | Tabellen ID |
0x00000002 | Read | every | UINT8[30+1] | 1 | 30 Zeichen | Tabellen-Name |
0x00000003 | Read | every | UINT32 | 1 | s. ENUM (>0) | Tabellen-Untertypen |
0x00000004 | Read | every | UINT32 | 1 | s. ENUM (>0) | Tabellen-Haupttypen |
0x00000010 | Read | every | UINT32 | 1 | [0... 16777216] | Anzahl von Zeilen (n) |
0x00000011 | Read | every | UINT32 | 1 | [0... 16777216] | Anzahl von Spalten (m) |
0x00000012 | Read | every | UINT32 | 1 | ≥0 | Anzahl von Gesamtelementen (n*m) |
0x00000013 | Read | äquidistante Tab. | REAL64 | z.B. mm | ≥0.0 | Schrittweite (Positions-Delta) (äquidistante Tabellen) | Base Unit
0x00000014 | Read | zyklische Tab. | REAL64 | z.B. Grad | ≥0.0 | Masterperiode (zyklische Tabellen) | Base Unit
0x00000015 | Read | zyklische Tab. | REAL64 | z.B. Grad | ≥0.0 | Slavedifferenz pro Masterperiode (zyklische Tabellen) | Base Unit
0x0000001A | Read / Write | "Motion Function" (Bewegungs-gesetze) | { |  |  | Aktivierungstyp für Online-Änderungen von Tabellendaten (nur MF) |
 |  |  | UINT32 | ENUM | s. Anhang | Aktivierungstyp 0: 'instantaneous' (default) 1: 'master cam pos.' 2: 'master' axis pos.' 3: 'next cycle' 4: 'next cycle once' 5: 'as soon as possible' 6: 'off' 7: 'delete queued data'
 |  |  | REAL64 | z.B. mm | ±∞ | Aktivierungsposition
 |  |  | UINT32 | ENUM | s. Anhang | Master Skalierungstyp 0: user defined (default) 1: scaling with auto offset 2: off
 |  |  | UINT32 | ENUM | s. Anhang | Slave Skalierungstyp 0: user defined (default) 1: scaling with auto offset 2: off
 |  |  | } |  |  |
0x00000020 | Read / Write | every | { |  |  | Schreiben Einzelwert [n,m]: |
 |  |  | UINT32 | 1 | [0 ... 16777216] | n-te Zeile
 |  |  | UINT32 | 1 | [0 ... 16777216] | m-te Spalte
 |  |  | REAL64 | z.B. mm | ±∞ | Einzelwert
 |  |  | } |  |  |
0x00000021 | ReadWrite | every | *REAL64 | z.B. mm | ±∞ | Slaveposition zur vorgegebenen Masterposition lesen (bezieht sich auf "Rohwerte" der Tabelle) |
0x00000022 | ReadWrite | "Motion Function" (Bewegungs-gesetze) | Write |  |  | Lesen der "Motion Function" als "Punktewolke" | Nur zeilenweise möglich! (ganzzahliges vielfaches)
 |  |  | { |  |  |
 |  |  | UINT16 | 1 | 0/1 | Konsistente Datenübernahme veranlassen ?
 |  |  | UINT16 | 1 | Bitmask (≥0) | Auswahl-Bitmaske (Spaltenanzahl m ist Masterposition plus Anzahl Bits): Bit 0: Pos (Slave) Bit 1: Velo (Slave) Bit 2: Acc (Slave) Bit 3: Jerk (Slave)
 |  |  | REAL64 | z.B. mm | ±∞ | Startposition (Master)
 |  |  | REAL64 | z.B. mm | > 0.0 | Schrittweite
 |  |  | } |  |  |
 |  |  | Read |  |  |
 |  |  | { |  |  |
 |  |  | REAL64[x*m] | z.B. mm | ±∞ | Lesen von x Zeilen ab der Master-Startposition: (x*m)-Werte (eine oder mehrere Zeilen)
 |  |  | } |  |  |
0x00000023 | ReadWrite | every | Write |  |  | Slavewerte zur vorgegebenen Masterposition lesen (bezieht sich auf "Rohwerte" der Tabelle) |
 |  |  | REAL64 | z.B. mm | ±∞ | Masterposition
 |  |  | Read |  |  |
 |  |  | { |  |  |
 |  |  | REAL64 | z.B. mm | ±∞ | Slaveposition
 |  |  | REAL64 | mm/s | ±∞ | Slavegeschwindigkeit
 |  |  | REAL64 | mm/s^2 | ±∞ | Slavebeschleunigung
 |  |  | } |  |  |
0x00000050 | Read / Write | every | REAL64 [64] | 1 | ±∞ | Charakteristische Kennwerte der Tabelle |
0x00000050 | ReadWrite | every | Write |  |  | Lesen der Charakteristischen Kennwerte einer Tabelle in Abhängigkeit der nominalen Mastergeschwindigkeit |
 |  |  | REAL64 [64] | ... | ±∞ | Optionale nominale Masterbezugsgeschwindigkeit "fMasterVeloNom" (normiert => 1.0 mm/s), die restlichen Element werden nicht ausgewertet
 |  |  | Read |  |  |
 |  |  | REAL64 [64] | ... | ±∞ | Lesen der Charakteristische Kennwerte einer Tabelle
0x00000115 | Write | monoton linear, monoton zykl., | { |  |  | Setzen/Ändern der Tabellen-Skalierung: |
 |  |  | REAL64 | 1 | [±1000000.0] | Originalgewichtung der Tabelle
 |  |  | REAL64 | z.B. mm | [±1000000.0] | Positionsoffset der Masterspalte
 |  |  | REAL64 | 1 | [±1000000.0] | Skalierung der Masterspalte
 |  |  | REAL64 | z.B. mm | [±1000000.0] | Positionsoffset der Slavespalte
 |  |  | REAL64 | 1 | [±1000000.0] | Skalierung der Slavespalte
 |  |  | REAL64 | z.B. mm | [±1000000.0] | Untere Bereichsgrenze (Anfangsposition)
 |  |  | REAL64 | z.B. mm | [±1000000.0] | Obere Bereichsgrenze (Endposition)
 |  |  | } |  |  |
0x01000000 +n-te Startzeile | Read / Write[<=16777216] | every | { REAL64[x*m] } | z.B. mm | ±∞ | Lesen/Schreiben von x Zeilen ab der n-ten Zeile: (x*m)-Werte (eine oder mehrere Zeilen) Wertebereich n: [0 ... 16777216] | Nur zeilenweise möglich! (ganzzahliges vielfaches)
0x02000000 +m-te Startspalte | Read / Write[<=16777216] | every | { REAL64[x*n] } | z.B. mm | ±∞ | Lesen/Schreiben x Spalten ab der m-ten Spalte: (x*n)-Werte (eine oder mehrere Spalten) Wertebereich m: [0 ... 16777216] | Nur spaltenweise möglich! (ganzzahliges vielfaches)
0x05000000 +n-te Startzeile | Read / Write[<=16777216] | "Motion Function" (Bewegungs-gesetze) Daten: STRUCT[x*m] | { |  |  | Lesen/Schreiben von x Zeilen ab der n-ten Zeile: (x*m)-Strukturen (eine oder mehrere Zeilen) Wertebereich n: [0 ... 16777216] | Nur zeilenweise möglich! (ganzzahliges vielfaches)
 |  |  | UINT32 | 1 |  | Abs. Punkt Index (nicht ausgewertet)
 |  |  | UINT16 | ENUM |  | Funktions Typ 1: Polynom 1 15: Polynom 5
 |  |  | UINT16 | ENUM |  | Punkt Typ 0: default 1: ignore
 |  |  | INT32 | 1 |  | rel. Adressindex auf Zielpunkt (Default: 1)
 |  |  | REAL64 | mm |  | Master Position
 |  |  | REAL64 | mm |  | Slave Position
 |  |  | REAL64 | mm/s |  | Slave Geschwind.
 |  |  | REAL64 | mm/s^2 |  | Slave Beschleun.
 |  |  | REAL64 | mm/s^3 |  | Slave Ruck
 |  |  | } |  |  |
0x06000000 +m-te Startspalte | Read / Write[<=16777216] | "Motion Function" (Bewegungs-gesetze) Daten: STRUCT[x*n] | { |  |  | Lesen/Schreiben x Spalten ab der m-ten Spalte: (x*n)-Strukturen (eine oder mehrere Spalten) Wertebereich m: [0 ... 16777216] | Nur spaltenweise möglich! (ganzzahliges vielfaches)
 |  |  | UINT32 | 1 |  | Abs. Punkt Index (nicht ausgewertet)
 |  |  | UINT16 | ENUM |  | Funktions Typ 1: Polynom 1 15: Polynom 5
 |  |  | UINT16 | ENUM |  | Punkt Typ 0: default 1: ignore
 |  |  | INT32 | 1 |  | rel. Adressindex auf Zielpunkt (Default: 1)
 |  |  | REAL64 | mm |  | Master Position
 |  |  | REAL64 | mm |  | Slave Position
 |  |  | REAL64 | mm/s |  | Slave Geschwind.
 |  |  | REAL64 | mm/s^2 |  | Slave Beschleun.
 |  |  | REAL64 | mm/s^3 |  | Slave Ruck
 |  |  | } |  |  |


"Index-Offset" Spezifikation für Tabellen-Zustand (Index-Group 0xA100 + ID)

"Index-Offset" Spezifikation für Tabellen-Zustand (Index-Group 0xA100 + ID)

Index-Offset ( Hex ) | Zugriff | Tabellen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x0000000A | Read | every | INT32 | 1 | ≥ 0 | 'User Counter' (Anzahl der Nutzer dieser Tabelle) | Nicht oszilloskopierbar!


"Index-Offset" Spezifikation für Tabellen-Funktionen (Index-Group 0xA200 + ID)

"Index-Offset" Spezifikation für Tabellen-Funktionen (Index-Group 0xA200 + ID)

Index-Offset (Hex) | Zugriff | Tabellen- typ | Daten- typ | Phys. Einheit | Definitions- bereich | Beschreibung | Anmerkung
0x00010000 | Write | Kurvenscheibe | { |  |  | Erzeugt Kurvenscheiben- Tabelle mit Dimension (n*m): | Tabellentypen: 1,2,3,4 Dimension: mind. 2x1
 |  |  | UINT32 | 1 | s. ENUM (>0) | Tabellen-Typ (s. Anhang)
 |  |  | UINT32 | 1 | [2...16777216] | Anzahl der Zeilen
 |  |  | UINT32 | 1 | [1...16777216] | Anzahl der Spalten
 |  |  | } |  |  |
0x00010001 | Write | Kennlinie | { |  |  | Erzeugt Kennlinien-Tabelle mit Dimension (n*m): | Tabellentypen: 1,3 Dimension: mind. 2x1
 |  |  | UINT32 | 1 | s. ENUM (>0) | Tabellen-Typ (s. Anhang)
 |  |  | UINT32 | 1 | [2...16777216] | Anzahl der Zeilen
 |  |  | UINT32 | 1 | [1...16777216] | Anzahl der Spalten
 |  |  | } |  |  |
0x00010010 | Write | "Motion Function" (Bewegungs-gesetze) | { |  |  | Erzeugt "Motion Function"-Tabelle mit Dimension (n*m): | Tabellentypen: 3,4 Dimension: mind. 2x1
 |  |  | UINT32 | 1 | s. ENUM (>0) | Tabellen-Typ (s. Anhang)
 |  |  | UINT32 | 1 | [2...16777216] | Anzahl der Zeilen
 |  |  | UINT32 | 1 | [1...16777216] | Anzahl der Spalten
 |  |  | } |  |  |
0x00020000 | Write | every | VOID |  |  | Löscht Tabelle mit Dimension (n*m) | Tabellentypen: 1,2,3,4
0x00030000 | Write | every | VOID |  |  | Initialisiert Tabelle Initialisierung ist nicht mehr nötig, da dies jetzt automatisch in folgenden Fällen passiert: a) beim Ankoppeln mittels Tabelle b) beim Auslesen der Slaveposition (s. Tabellenpara.) |


Anhang

Enum Kanaltypen

Define	Kanaltypen

1	Standard
2	Interpreter
3	FIFO
4	Kinematic Transformation

Enum Interpretertypen

Define	Interpretertypen

0	NICHT DEFINIERT
1	reserviert
2	DIN 66025 (Siemensdialekt)

Enum Interpreter Betriebsarten (Operation-Mode)

Define	Interpreter Betriebsarten

0x0	Defaultbelegung (Abwahl der übrigen Betriebsarten)
0x1	Einzelsatzbetrieb im NC-Kern (Satzausführungstask/SAF)
0x1000	reserviert
0x2000	reserviert
0x4000	Einzelsatzbetrieb im Interpreter

Enum Interpolations Lade-Logmodus

Define	Lade-Logmodus

0	Loaderlog aus
1	nur Source
2	Source & Compiled

Enum Interpolations Trace-Modus

Define	Trace-Modus

0	Trace aus
1	Trace Zeilennummern
2	Trace Source

Enum Interpreter-Status

verschoben nach: System Manager Interface für den Interpreter - Interpreter Element

Enum Gruppentypen

Define	Gruppentypen

0	NICHT DEFINIERT
1	PTP-Gruppe + x Slave
2	1D-Gruppe + x Slave
3	2D-Gruppe + x Slave
4	3D-Gruppe + x Slave
5	Eil/Schleich + x Slave
6	Low Cost Schrittmotor (dig. IO) + x Slave
7	Tabellen-Gruppe + x Slave
9	Encoder-Gruppe + x Slave
11	FIFO-Gruppe + x Slave
12	Kinematik-Transformations-Gruppe + x Slave

Enum Kurvengeschwindigkeitsreduktionsmethode

verschoben nach: System Manager Interface für den Interpreter - Gruppen Element

Enum Achstypen

Define	Achstypen

0	NICHT DEFINIERT
1	Kontinuierliche Achse (Servo)
2	Diskrete Achse (Eil/Schleich)
3	Kontinuierliche Achse (Schrittmotor)

Enum Schrittmotorbetriebsart

Define	Schrittmotorbetriebsart

0	NICHT DEFINIERT
1	2-Phasige Erregung (4 Zyklen)
2	1-2-Phasige Erregung (6 Zyklen)
3	Leistungteil

Enum Override-Typen für PTP-Achsen (Geschwindigkeitsoverride)

Define	Override-Typen

1	Reduziert 		Alte Variante, abgelöst durch "(3) Reduziert (iteriert)"
2	Original 			Alte Variante, abgelöst durch "(4) Original (iteriert)"
3	Reduziert (iteriert)	Default-Wert: Der Overridewert wird auf die im Sonderfall intern reduzierte Geschwindigkeit bezogen.
                Somit ergibt sich für den gesamten Overridebereich von 0...100% eine direkt proportionale
                Geschwindigkeit (=> linearer Zusammenhang).
4	Original (iteriert)	Der Overridewert wird immer auf die durch den Anwender programmierte Geschwindigkeit bezogen.
                Wenn allerdings diese Geschwindigkeit nicht gefahren werden kann, dann ergibt sich ein
                maximaler Overridewert, ab dem keine höhere Geschwindigkeit erreicht wird (=> Limitierung).

Enum Gruppen/Achs-Starttypen

Define	Gruppen/Achs-Starttypen

0	NICHT DEFINIERT
1	Absolutstart
2	Relativstart
3	Endlosstart positiv
4	Endlosstart negativ
5	Modulostart (ALT)
261	Modulostart auf kürzestem Weg
517	Modulostart in positiver Fahrtrichtung (mit Modulo-Toleranzfenster)
773	Modulostart in negativer Fahrtrichtung (mit Modulo-Toleranzfenster)
4096	Stop und Sperre (Achse wird fuer Bewegungskommandos gesperrt)
8192	Halt (ohne Bewegungs-Sperre)

Enum Kommandospeichertypen (buffer mode) für Universellen Achs-Start (UAS)

Define	Kommandospeichertypen (buffer mode)

0	ABORTING (Default)	(instantan, löst eine aktuelle Bewegung ab und löscht gepufferte Kommandos)
1	BUFFERED		(Auftrag wird im Kommandozwischenspeicher gepuffert um ihn im Anschluss an eine aktive Bewegung auszuführen)
18	BLENDING LOW 	(gepuffert, kein Stopp, Zwischenziel wird mit der niedrigsten Geschwindigkeit zweier Kommandos durchlaufen)
19	BLENDING PREVIOUS	(gepuffert, kein Stopp, Zwischenziel wird mit der Geschwindigkeit des aktiven Kommandos durchlaufen)
20	BLENDING NEXT	(gepuffert, kein Stopp, Zwischenziel wird mit der Geschwindigkeit des gepufferten Kommandos durchlaufen)
21	BLENDING HIGH	(gepuffert, kein Stopp, Zwischenziel wird mit der höheren Geschwindigkeit zweier Kommandos durchlaufen)

Enum Endpositionstypen (Neue Endposition)

Define	Endpositionstypen

0	NICHT DEFINIERT
1	Absolutposition
2	Relativposition
3	Endlosposition positiv
4	Endlosposition negativ
5	Moduloposition

Enum Kommandotypen für neue Endposition mit neuer Geschwindigkeit (Neue Endposition und/oder neue Geschwindigkeit)

Define	Kommandotypen für neue Endposition mit neuer Geschwindigkeit

0	NICHT DEFINIERT
1	Position (instantan)
2	Geschwindigkeit (instantan)
3	Position und Geschwindigkeit (instantan)
9	Position (Umschaltposition)
10	Geschwindigkeit (Umschaltposition)
11	Position und Geschwindigkeit (Umschaltposition)

Enum Istpositionstypen (Setze Istposition)

Define	Istpositionstypen

0	NICHT DEFINIERT
1	Absolutposition
2	Relativposition
5	Moduloposition

Enum Kompensationstypen (Streckenkompensation bzw. Superimposed)

Define	Kompensationstypen

0	NICHT DEFINIERT
1	VELOREDUCTION_ADDITIVEMOTION	Die max. Geschwindigkeit VelocityDiff wird reduziert. Die Strecke, auf der die
                       Ausgleichsfahrt wirkt, setzt sich additiv aus Length+Distance zusammen.
2	VELOREDUCTION_LIMITEDMOTION		Die max. Geschwindigkeit VelocityDiff wird reduziert. Die Strecke, auf der die
                       Ausgleichsfahrt wirkt, ist durch den Parameter Length festgelegt.
3	LENGTHREDUCTION_ADDITIVEMOTION	Die max. zur Verfügung stehende Strecke wird reduziert und setzt sich maximal aus Length+Distance
                         zusammen. Es wird versucht die max. Geschwind. VelocityDiff zu nutzten.
4	LENGTHREDUCTION_LIMITEDMOTION  	Die max. zur Verfügung stehende Strecke wird reduziert und ist durch den Parameter Length begrenzt.
                        Es wird versucht die max. Geschwind. VelocityDiff zu nutzten.

Enum Slavetypen

Define	Slavetypen

0	NICHT DEFINIERT
1	Linear
2	Fliegende Säge (Geschwindigkeit, ruckbegrenztes Profil)
3	Fliegende Säge (Position und Geschwindigkeit, ruckbegrenztes Profil)
5	Synchronisierungsgenerator (Geschwindigkeit, ruckbegrenztes Profil)
6	Synchronisierungsgenerator (Position und Geschwindigkeit, ruckbegrenztes Profil)
10	Tabular
11	Multitabular
13	'Motion Function' (MF)
15	Linear mit zyklischer Getriebefaktoränderung (Rampenfilter zur Beschleunigungsbegrenzung)
100	Specific

Enum Slave-Entkopplungstypen (für nachfolgendes Achs-Kommando)

Define	Slave Entkopplungstypen (für nachfolgendes Achs-Kommando)

0	Stopp, E-Stopp oder P-Stopp (Default)					(STOP)
1	Orientierter Stopp (O-Stopp)						(ORIENTEDSTOP)
2	Beschleunigungsfrei fahren(!) und weiterfahren auf endlose Zielposition		(ENDLESS)
3	Weiterfahren auf endlose Zielposition mit neuer geforderter Geschwindigkeit	(ENDLESS_NEWVELO)
4	neue Endposition								(NEWPOS)
5	neue Endposition und neue geforderte Geschwindigkeit				(NEWPOSANDVELO)
6	logisch Abkoppeln und Achse sofort ohne Geschwindigkeitsrampe stillsetzen		(INSTANTANEOUSSTOP)

Enum Reglertypen

Define	Reglerypen

0	NICHT DEFINIERT
1	P-Regler (Standard)				(Position)
2	PP-Regler (mit ka)					(Position)
3	PID-Regler (mit ka)				(Position)
5	P-Regler						(Geschwindigkeit)
6	PI-Regler						(Geschwindigkeit)
7	Eil/Schleich-Regler				(Position)
8	Schrittmotor-Regler				(Position)
9	SERCOS-Regler					(Position im Antrieb)
10	RESERVIERT
11	RESERVIERT
12	RESERVIERT
13	RESERVIERT
14	TCom Controller (Soft Drive)			(Position im Antrieb)

Enum Regler Beobachter-Modus

Define	Regler Beobachter-Modus
Anmerkung: setzt Regelkreis mit Momenteninterface voraus

0	Kein Beobachter aktiv (Default)
1	"Luenberger"-Beobachter (klassischer Beobachter-Entwurf)

Enum Encodertypen

Define	Encodertypen

0	NICHT DEFINIERT
1	Simulation Encoder							(Inkremental)
2	M3000 Encoder (Multi/Single-Turn)					(Absolut)
3	M31x0 / M2000 Encoder						(Inkremental)
4	MDP 511 Encoder:	EL7041, EL7342, EL5101, EL5151, EL2521, EL5021, IP5101	(Inkremental)
5	MDP 500/501 Enc.:	EL5001, IP5009, KL5001 (SSI)			(Absolut)
6	MDP 510 Encoder:	KL5051, KL2502-30K Encoder (BiSSI)			(Inkremental)
7	KL30xx Encoder (Analog)						(Absolut)
8	SERCOS und EtherCAT SoE (Position)					(Inkremental)
9	SERCOS und EtherCAT SoE (Position und Geschwindigkeit)			(Inkremental)
10	Binärer Encoder (0/1)						(Inkremental)
11	M2510 Encoder							(Absolut)
12	FOX50 Encoder							(Absolut)
14	AX2000 (Lightbus)							(Inkremental)
15	Provi-Drive MC (Simodrive 611U)					(Inkremental)
16	Universal Encoder (variable Bitmaske)				(Inkremental)
17	NC Rückwand							(Inkremental)
18	spezieller CANopen Typ (z.B. Lenze Drive 9300)			(Inkremental)
19	MDP 513 (DS402):	CANopen und EtherCAT CoE (AX2xx-B1x0/B510, EL7201)	(Inkremental)
20	AX2xx-B900 (Ethernet)						(Inkremental)
21	KL5151 Encoder							(Inkremental)
24	IP5209 Encoder							(Inkremental)
25	KL2531/KL2541 Encoder (Stepper Motor)				(Inkremental)
26	KL2532/KL2542 Encoder (DC Motor),
    KL2535/KL2545 (PWM Stromklemme)					(Inkremental)
27	Time Base Encoder (Zeitgeber)					(Inkremental)
28	TCom Encoder (Soft Drive)						(Inkremental)

Enum Encodermodus

Define	Encodermodus

0	NICHT DEFINIERT
1	Ermittlung Position
2	Ermittlung Position und Geschwindigkeit
3	Ermittlung Position, Geschwindigkeit und Beschleunigung

Enum Encoder-Auswerterichtung (log. Zählrichtung)

Define	Encoder-Auswerterichtung (log. Zählrichtung)
Anmerkung: nicht für alle Encoder-Typen, sondern nur für KL5101, KL5151, KL2531, KL2541, IP5209, Universal-Encoder, ...

0	Auswertung in positive und negative Zählrichtung (Defaultbelegung, d.h. kompatibel zum bisherigen Zustand)
1	Auswertung nur in positive Zählrichtung
2	Auswertung nur in negative Zählrichtung
3	Auswertung weder in positive noch in negativer Zählrichtung (Auswertung gesperrt)

 | Encoder Typen
Enc.-Auswerterichtung (Log. Zählrichtung) | KL5101, ... | Universal-Encoder | übrige Typen
0: positiv und negativ | √ | √ | —
1: nur positiv | √ | √ | —
2: nur negativ | √ | √ | —
3: gesperrt | √ | √ | —

Enum Vorzeichen-Interpretation (Datentyp) des Encoders

Define	Vorzeichen-Interpretation (Datentyp) der Encoder-Istinkremente
Anmerkung: vorerst nur für KL30xx/KL31xx
0	NICHT DEFINIERT (Defaultbelegung, d.h. kompatibel zum bisherigen Stand)
1	UNSIGNED: Vorzeichenlose Interpretation der Encoder-Istinkremente
2	SIGNED: Vorzeichenbehaftete Interpretation der Encoder-Istinkremente

Enum Encoder Bezugsmaßsystem

Define	Encoder Bezugsmaßsystem
Anmerkung: nicht für alle Encoder-Typen, sondern nur für Profi Drive MC, M3000, KL5001/EL5001, IP5009, SERCOS, UNIVERSAL, ...

0	INC: Inkrementelles Bezugsmaßsystem mit Unter- und Überlaufverrechnung (Default, d.h. kompatibel zum bisherigen Stand)
1	ABS: Absolutes Bezugsmaßsystem ohne Unter- und Überlaufverrechnung (keine Unter- oder Überläufe des Gebers erlaubt)
2	ABS MODULO: Bedingt absolutes Bezugsmaßsystem da mit Unter- und Überlaufverrechnung (Absolutwert, der sich modulo (endlos) fortsetzt)

Enum Encoder Positionsinitialisierung

Define	Encoder Positionsinitialisierung
Anmerkung: vorerst nur für SERCOS

0	Direkte Übernahme der Positionsinkremente ohne weitere Logik (Defaultbelegung, d.h. kompatibel zum bisherigen Stand)
1	Mit Unter- und Überlaufverrechnungslogik (direkte Übernahme oder Unterlauf- oder Überlaufverrechnung)

Enum Referenziermodus für Inkrementalencoder

Define	Referenziermodus für Inkrementalencoder

0	NICHT DEFINIERT (Defaultbelegung, d.h. kompatibel zum bisherigen Stand)
1	Latchereignis: Herunterfahren von der SPS Nocke (negative Flanke)
2	Latchereignis: Hardware Syncimpuls (Nullspur)
3	Latchereignis: Externes Hardware Latch mit positiver Flanke (Messtaster bzw. Fliegendes Messen mit pos. Flanke)
4	Latchereignis: Externes Hardware Latch mit negativer Flanke (Messtaster bzw. Fliegendes Messen mit neg. Flanke)
5	Latchereignis: Synthetisch nachgebildeter Software Syncimpuls (Software Nullspur); VORAUSSETZUMG: absolut pro Motorumdreh., z.B. Resolver!
6	Latchereignis: im Antrieb definiertes Hardware Latch Ereignis mit positiver Flanke (z.B. für SoftDrive) (NEU)
7	Latchereignis: im Antrieb definiertes Hardware Latch Ereignis mit negativer Flanke (z.B. für SoftDrive) (NEU)

20	Anwenderspezifische Implementierung der Referenzierung (SPS Code): Anwender Anforderung wird der SPS mittels des ApplicationRequest-Bits signalisiert (NEU)

 | Referenziermodus: Latchereignis
Encoder Typen | 0: nicht definiert | 1: SPS Nocke (neg. Flanke) | 2: Hardware Syncimpuls (Null-/C-Spur) | 3: Externes Hardware Latch mit pos. Flanke | 4: Externes Hardware Latch mit neg. Flanke | 5: Software Syncimpuls (Software Nullspur)
AX2xxx-B200 (Lightbus) | — | √ | √ | √ | √ | √ (nur Resolver)
AX2xxx-B510 (CANopen) | — | √ | — | — | — | √ (nur Resolver) (s. Param. "Referenz Maske")
AX2xxx-B1x0 (EtherCAT) | — | √ | √ | √ | √ | √ (nur Resolver) (fest 20 Bit)
AX2xxx-B900 (Ethernet) | — | √ | √ | √ | √ | √ (nur Resolver)
Sercos | — | √ | √ | √ (AX5xxx spezifisch implementiert) | √ | √ (s. Param. "Referenz Maske")
Profi Drive | — | √ | √ | √ | √ | √
KL5101 IP5109 | — | √ | √ | √ | √ | √
KL5111 | — | √ | √ | — | — | √
KL5151 | — | √ | √ | √ | √ | √ (nicht sinnvoll)
IP5209 | — | √ | √ | — | — | √ (nicht sinnvoll)
CANopen (z.B. Lenze) | — | √ | — | √ (Eingang E1) | √ (Eingang E2) | √ (nur Resolver) (fest 16 Bit)
übrige Typen | — | — | — | — | — | —

Enum Drivetypen

Define	Drivetypen

0	NICHT DEFINIERT
1	Analog Servo Drive: M2400 DAC 1					(Analog)
2	Analog Servo Drive: M2400 DAC 2					(Analog)
3	Analog Servo Drive: M2400 DAC 3					(Analog)
4	Analog Servo Drive: M2400 DAC 4					(Analog)
5	MDP 252 Drive:	Analog Servo Drive: KL4xxx, KL2502-30K		(Analog)
6	MDP 252 Drive:	Analog Servo Drive (Nichtlinear): KL4xxx, KL2502-30K	(Analog)
7	Eil/Schleich-Drive	 						(Digital)
8	Schrittmotor-Drive 						(Digital)
9	SERCOS-Drive							(Digital)
10	MDP 510 Drive:	KL5051 (BiSSI-Interface)				(Digital)
11	AX2000 (Lightbus)							(Digital)
12	Provi-Drive MC (Simodrive 611U)					(Digital)
13	Universal Drive 							(Analog)
14	NC Rückwand							(Analog)
15	spezieller CANopen Typ (z.B. Lenze Drive 9300)			(Digital)
16	MDP 742 (DS402):	CANopen und EtherCAT CoE (AX2xx-B1x0/B510)		(Digital)
17	AX2xx-B900 Drive (Ethernet)						(Digital)
20	KL2531/KL2541 Encoder (Stepper Motor)				(Digital)
21	KL2532/KL2542 Encoder (DC Motor),
    KL2535/KL2545 Encoder (PWM Stromklemme)				(Digital)
22	TCom Drive (Soft Drive)						(Digital)
23	MDP 733 Drive:	Profile MDP 733 (EL7332, EL7342, EP7342)		(Digital)
24	MDP 703 Drive:	Profile MDP 703 (EL7031, EL7041, EP7041)		(Digital)

Enum Drive-Output-Starttypen

Define	Drive-Output-Starttypen

0	NICHT DEFINIERT
1	Ausgabe als Prozentwert
2	Ausgabe als Geschwindigkeit z.B. m/min

Enum Fahrphasen / Bewegungszustand für Masterachsen

Define	Fahrphasen / Bewegungszustand (unterschieden nach interner und externer Sollwertgenerierung)
    Interne Sollwertgenerierung:
0	Sollwertgenerator nicht aktiv (INACTIVE)
1	Sollwertgenerator aktiv (RUNNING)
2	Geschwindigkeitsoverride ist Null (OVERRIDE_ZERO)
3	Konstante Geschwindigkeit (PHASE_VELOCONST)
4	Beschleunigungsphase (PHASE_ACCPOS)
5	Verzögerungsphase (PHASE_ACCNEG)
    Externe Sollwertgenerierung:
41	Externe Sollwertgenerierung aktiv (EXTSETGEN_MODE1)
42	Interne und externe Sollwertgenerierung aktiv (EXTSETGEN_MODE2)

Enum Fahrphasen / Bewegungszustand für Slaveachsen

Define	Fahrphasen / Bewegungszustand
Anmerkung: vorerst nur für Slaves vom Typ Synchronisierungsgenerator

0	Slavegenerator nicht aktiv (INACTIVE)
11	Slave befindet sich in einer Bewegungs-Vorphase (PREPHASE)
12	Slave ist am Aufsynchronisieren (SYNCHRONIZING)
13	Slave ist aufsynchronisiert und fährt synchron (SYNCHRON)

Enum Tabellen-Haupttypen

Define	Tabellen-Haupttypen

1	(n*m) 	Kurvenscheiben Tabellen (Camming)

10	(n*m) 	Kennlinien Tabellen (Characteristics) (z.B. Hydraulik Ventilkennlinien)
        es werden nur nichtzyklische Tabellen-Untertypen (1, 3) unterstützt!
16	(n*m) 	'Motion Function' Tabellen (MF)
        es werden nur nichtäquidistante Tabellen-Untertypen (3, 4) unterstützt!

Enum Tabellen-Untertypen

Define	Tabellen-Untertypen

1	(n*m) 	Tabelle mit äquidistanten Masterpositionen und keiner
        zyklischen Fortsetzung des Mastereprofils (äquidistant linear)
2	(n*m) 	Tabelle mit äquidistanten Masterpositionen und einer
        zyklischen Fortsetzung des Masterprofils (äquidistant zyklisch)
3	(n*m) 	Tabelle mit nicht äquidistanten aber streng monoton steigenden
        Masterpositionen und einer nicht zyklischen Fortsetzung des
        Masterprofils (monoton linear)
4	(n*m) 	Tabelle mit nicht äquidistanten aber streng monoton steigenden
        Masterpositionen und einer zyklischen Fortsetzung des
        Masterprofils (monoton zyklisch)

Enum Tabellen Interpolationstypen

Define	Tabellen Interpolationstyp zwischen den Stützstellen

0	Linear-Interpolation (NC_INTERPOLATIONTYPE_LINEAR) (Standard)
1	4-Punkt-Interpolation (NC_INTERPOLATIONTYPE_4POINT) (nur für äquidistante Tabellentypen)
2	kubische Spline-Interpolation über alle Stützstellen ("globaler Spline") (NC_INTERPOLATIONTYPE_SPLINE)
3	gleitende kubische Spline-Interpolation über n Stützstellen ("lokaler Spline") (NC_INTERPOLATIONTYPE_SLIDINGSPLINE) (ab TC V2.11 B1514)

Struktur der Tabellen (CAM) Kopplungs Informationen

    Tabellen (CAM) Kopplungs Informationen

nTableID;              1.  cam table ID
nTableMainType;        2.  e.g. CAMMING, CHARACTERISTIC, MOTIONFUNCTION
nTableSubType;         3.  e.g. EQUIDIST_LINEAR, EQUIDIST_CYCLE, NONEQUIDIST_LINEAR, NONEQUIDIST_CYCLE
nInterpolationType;    4.  e.g. LINEAR, 4POINT, SPLINE
nNumberOfRows;         5.  number of rows/elements
nNumberOfColumns;      6.  number of columns
fRawMasterPeriod;      7.  master period/cycle (raw value, not scaled)
fRawSlaveStroke;       8.  slave difference per master period/cycle (raw value, not scaled)
fMasterOffset;         9.  total master offset
fSlaveOffset;          10. total slave offset
fMasterScaling;        11. total master scaling
fSlaveScaling;         12. total slave scaling
fActualMasterAxisPos;  13. actual master axis setpos (absolute)
fActualSlaveAxisPos;   14. actual slave axis setpos (absolute)
fActualMasterCamPos;   15. actual master cam setpos
fActualSlaveCamPos;    16. actual master cam setpos

Struktur der charakteristischen Kennwerte

    Charakteristische Kennwerte

fMasterVeloNom;        1.  master nominal velocity (normed: => 1.0)
fMasterPosStart;       2.  master start position
fSlavePosStart;        3.  slave start position
fSlaveVeloStart;       4.  slave start velocity
fSlaveAccStart;        5.  slave start acceleration
fSlaveJerkStart;       6.  slave start jerk
fMasterPosEnd;         7.  master end position
fSlavePosEnd;          8.  slave end position
fSlaveVeloEnd;         9.  slave end velocity
fSlaveAccEnd;          10. slave end acceleration
fSlaveJerkEnd;         11. slave end jerk
fMPosAtSPosMin;        12. master pos. at slave min. position
fSlavePosMin;          13. slave minimum position
fMPosAtSVeloMin;       14. master pos. at slave min. velocity
fSlaveVeloMin;         15. slave minimum velocity
fMPosAtSAccMin;        16. master pos. at slave min. acceleration
fSlaveAccMin;          17. slave minimum acceleration
fSVeloAtSAccMin;       18. slave velocity at slave min. acceleration
fSlaveJerkMin;         19. slave minimum jerk
fSlaveDynMomMin;       20. slave minimum dynamic momentum (NOT SUPPORTED YET !)
fMPosAtSPosMax;        21. master pos. at slave max. position
fSlavePosMax;          22. slave maximum position
fMPosAtSVeloMax;       23. master pos. at slave max. velocity
fSlaveVeloMax;         24. slave maximum velocity
fMPosAtSAccMax;        25. master pos. at slave max. acceleration
fSlaveAccMax;          26. slave maximum acceleration
fSVeloAtSAccMax;       27. slave velocity at slave max. acceleration
fSlaveJerkMax;         28. slave maximum jerk
fSlaveDynMomMax;       29. slave maximum dynamic momentum (NOT SUPPORTED YET !)
fSlaveVeloMean;        30. slave mean absolute velocity
fSlaveAccEff;          31. slave effective acceleration

Enum Achsregelkreis-Umschalttypen

Define	Achsregelkreis-Umschalttypen

0	NICHT DEFINIERT
1	Einfaches Umschalten (ähnlich einem Achsreset) (STANDARD)
2	Umschalten/Aufsynchronisieren mittels I/D-Anteil des Reglers auf einen internen Initialwert (ruckfrei/stoßfrei)
3	Umschalten/Aufsynchronisieren mittels I/D-Anteil des Reglers auf einen parametrierbaren Initialwert