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1 Foreword

1.1 Notes on the documentation
This description is only intended for the use of trained specialists in control and automation engineering who
are familiar with applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing
and commissioning the components. 
It is the duty of the technical personnel to use the documentation published at the respective time of each
installation and commissioning.

The responsible staff must ensure that the application or use of the products described satisfy all the
requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under
development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the
data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, TwinCAT/BSD®, TC/BSD®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®,
Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by
Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own
purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and
patents:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
with corresponding applications or registrations in various other countries.

EtherCAT® is a registered trademark and patented technology, licensed by Beckhoff Automation GmbH,
Germany

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to
others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a
patent, utility model or design.
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1.2 Safety instructions

Safety regulations

Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring,
commissioning etc.

Exclusion of liability

All the components are supplied in particular hardware and software configurations appropriate for the
application. Modifications to hardware or software configurations other than those described in the
documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.

Personnel qualification

This description is only intended for trained specialists in control, automation and drive engineering who are
familiar with the applicable national standards.

Description of symbols

In this documentation the following symbols are used with an accompanying safety instruction or note. The
safety instructions must be read carefully and followed without fail!

 DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of
persons.

 WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of per-
sons.

 CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.

NOTE
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or
equipment.

Tip or pointer
This symbol indicates information that contributes to better understanding.
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1.3 Notes on information security
The products of Beckhoff Automation GmbH & Co. KG (Beckhoff), insofar as they can be accessed online,
are equipped with security functions that support the secure operation of plants, systems, machines and
networks. Despite the security functions, the creation, implementation and constant updating of a holistic
security concept for the operation are necessary to protect the respective plant, system, machine and
networks against cyber threats. The products sold by Beckhoff are only part of the overall security concept.
The customer is responsible for preventing unauthorized access by third parties to its equipment, systems,
machines and networks. The latter should be connected to the corporate network or the Internet only if
appropriate protective measures have been set up.

In addition, the recommendations from Beckhoff regarding appropriate protective measures should be
observed. Further information regarding information security and industrial security can be found in our
https://www.beckhoff.com/secguide.

Beckhoff products and solutions undergo continuous further development. This also applies to security
functions. In light of this continuous further development, Beckhoff expressly recommends that the products
are kept up to date at all times and that updates are installed for the products once they have been made
available. Using outdated or unsupported product versions can increase the risk of cyber threats.

To stay informed about information security for Beckhoff products, subscribe to the RSS feed at https://
www.beckhoff.com/secinfo.

https://www.beckhoff.com/secguide
https://www.beckhoff.com/secinfo
https://www.beckhoff.com/secinfo
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2 Introduction
The TwinCAT3 Project Compare Tool (TcProjectCompare) is an application program that can be used to
compare and merge TwinCAT3 projects. The tool can be integrated in Visual Studio or used in stand-alone
mode.

If a TwinCAT3 project is managed with the help of source code control software (e.g. integrated in Visual
Studio), the source control clients can be set so that they automatically call the TcProjectCompare tool in the
case of comparing or merging files or projects. Further information on the configuration of source control
clients can be found in the section Configuration of the TcProjectCompare for use with source control
[} 14].
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3 Use of the TcProjectCompare
Encryption
If encryption is used in the TwinCAT project, you can only use the TcProjectCompare version that is
integrated in Visual Studio (see Use of the TcProjectCompare [} 10]).

The following dialog appears after starting the TCProjectCompare tool:

With this dialog you can select the two TwinCAT projects that are to be compared. The left-hand project is
the project that is being edited (into which merging takes place). The right-hand project is the project that is
being used for comparison.

In order to display the changes in a TwinCAT object (e.g. a POU), open the comparison for this element with
a double click.
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Not all changes are visible in the PLC editors
All files from TwinCAT are saved as XML. There are two different views for the PLC files. One is the
display when using PLC editors, the other is an XML display. Therefore, a distinction is made for
these files between content changes and formal changes. The latter can only be displayed in the
XML view (see Use of the TcProjectCompare [} 11]). Content changes are indicated by displaying
the name of the POU in a different color. Formal changes are indicated by a red bar in front of the
name of the POU.

Starting the TcProjectCompare plugin in Visual Studio

To start the TcProjectCompare in Visual Studio, select the menu item TwinCAT -> TcProjectCompare.
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For TwinCAT versions prior to 3.1.4024.0, use the menu item View -> Other Windows ->
TcProjectCompare.

XML comparison of TwinCAT objects

All TwinCAT files are stored as XML files on the hard disk. If only formal changes have been made to a file
(marked by the vertical red bar in front of the POU name), these changes are not recognizable in a
comparison using the PLC editor. Formal changes are, for example, changed GUIDs of individual objects or
changed LineIDs (required for breakpoint handling). These changes can only be made visible with an Xml
comparison. To do this, open the context menu of the TwinCAT object (by right-clicking) and select the
option Compare in Xml-Diff.
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3.1 Starting the Project Compare tool via the command
line

The transfer/command line parameters of the Project Compare tool are described in the section Transfer
parameters of the TcProjectCompare [} 17]:

Sample: The command line call for a comparison with the TcProjectCompare of version 4020 or newer
therefore looks like this:

C:\TwinCAT\3.1\Components\TcProjectCompare\TcProjectCompare.exe /filel <Datei
linke Seite> /filer <Datei rechte Seite>

Optionally, the title that is to be displayed for the left or right side of the comparison window can be
transferred with the option /dl or /dr respectively.

3.2 Defining the shortcuts
The TcProjectCompare can be operated via the keyboard with the help of shortcuts. These can be viewed
and adapted on the Hotkeys tab of the options.
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Defining/changing shortcuts:
1. Open the Options dialog via the menu command Tools -> Options…
2. Select the Hotkeys tab.
3. Select the command for which you wish to change the key command.
4. Jump to the selection box in front of the Assign button with a mouse click or using the Tab key.
5. Actuate the desired shortcut.

ð The shortcut is entered in the selection box.
6. Confirm your selection by clicking on OK or select a further command for which you wish to change the

shortcut.
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4 Configuration of the TcProjectCompare for use
with source control

The configuration of the TcProjectCompare can be generated from the software for use with some of the
most frequently used source control clients. At the moment, these are the following clients:

• Microsoft Team Foundation Server
• Git
• AnkhSVN

Generating the configuration of these clients

To generate the settings for one of the source control clients listed above, proceed as follows:

1. Open TcProjectCompare.
2. Select the menu Tools -> Configure User Tools....

3. Click on Export Configuration.
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4. In the following dialog, select the source control client for which the settings are to be generated from the
selection box.

5. In case Git is the source control client, you can select in the following dialog whether you want the
settings for the selection of the Compare Tool used to be saved globally or for the specific project. If you
save them for the specific project, select the .gitconfig file from your local repository. Then confirm your
selection with OK.

ð The configuration has been created.

Configuring other source control clients:

If you use a source control client that is not listed above, you must configure the use of the
TcProjectCompare in the respective source control client. To do this, use the transfer parameters listed in the
section Transfer parameters of the TcProjectCompare [} 17].

Dealing with non-TwinCAT flies

Some clients only allow a general compare/merge tool for all file extensions. For this reason the TwinCAT
Project Compare tool offers the option to define further compare tools for special file extensions.

Setting an external compare tool for file extensions:

1. Open the TcProjectCompare.



Configuration of the TcProjectCompare for use with source control

TwinCAT 316 Version: 1.0.1

2. Select the menu Tools -> Configure User Tools....

3. Click on Add.

4. In the following dialog describe which file extension is used, which tool is to be called (Command line)
and which transfer parameters are required for compare or merge. Confirm the settings with OK.
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4.1 Transfer parameters of the TcProjectCompare
Since not all special features of the various clients can be dealt with here, the transfer parameters of the
TwinCAT Project Compare Tools are briefly described below:

Transfer parameters for TwinCAT version 4020 or higher:

/filel File path – left side.
/filer File path, right side.
/filem File path for the merged file.
/dl Display name, left side.
/dr Display name, right side.
/sc Call via source control client.

Transfer parameters for TwinCAT versions 4018 or lower:

File path – left side.
File path, right side.
File path of merged file.

/dl Display name, left side.
/dr Display name, right side.
/sc Call via source control client.

In Project Compare tool version or lower 4018 the file paths for the left, right and merged file were
determined based on the order in which they are called. The order was always left, right, merged file.

Samples:

Compare (Compare/Diff):

Version 4018 for PlasticSCM:

C:\TwinCAT\3.1\Components\TcProjectCompare\TcProjectCompare.exe
"@destinationfile" "@sourcefile" /sc

Version 4018 for TFS:

C:\TwinCAT\3.1\Components\TcProjectCompare\TcProjectCompare.exe %2 %1 /dl %7 /dr
%6 /sc

Version 4020 for TFS:

C:\TwinCAT\3.1\Components\TcProjectCompare\TcProjectCompare.exe /filel %2 /filer
%1 /dl %7 /dr %6 /sc

Merge:

Version 4018 for PlasticSCM:

C:\TwinCAT\3.1\Components\TcProjectCompare\TcProjectCompare.exe /dl
"@destinationsymbolic" /dr "@sourcesymbolic" "@destinationfile" "@sourcefile"
"@output" /sc

Version 4018 for TFS:

C:\TwinCAT\3.1\Components\TcProjectCompare\TcProjectCompare.exe %2 %1 %4 /dl
%7 /dr %6 /sc

Version 4020 for TFS:

C:\TwinCAT\3.1\Components\TcProjectCompare\TcProjectCompare.exe /filel %2 /filer
%1 /filem %4 /dl %7 /dr %6 /sc
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5 Reference, user interface
The user interface of the TwinCAT Project Compare Tool consists of the following components:

1 Menu bar
2 Toolbar
3 Toolbar of the comparison windows
4 Comparison window
5 Error list

5.1 Menu bar

5.1.1 Files

Choose Files…

Function: This command opens a dialog in which you can select the two files to be compared.

Call: Menu Files-> Choose Files
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Merging of files is only possible in one direction
In the TcProjectCompare, the merging of contents is only possible from the right-hand comparison
window to the left-hand comparison window. The files must therefore be selected accordingly. If you
wish to change the merging direction, swap the files using the command Switch Files.

Save All

Function: The command saves all changes in all opened comparison windows.

Call: Menu Files -> Save all

Reload

Function: This command reloads the two files to be compared (e.g. after some changes have been made
and saved).

Call: Menu Files -> Reload

Switch Files

Function: This command swaps the files in the two comparison windows. In other words, the file previously
opened in the left-hand comparison window will be opened in the right-hand comparison window and vice
versa.

Call: Menu Files -> Switch Files

Exit

Function: This command terminates the TcProjectCompare.

Call: Menu Files -> Exit

5.1.2 Tools

Expand all

Function: This command expands the complete tree view in the TcProjectCompare.

Call: Menu Tools -> Expand all

Show Error List

Function: This command shows the Error List window, in which the errors and warnings of the
TcProjectCompare are displayed.

Call: Menu Tools -> Show Error List
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Error list is only selectable in stand-alone mode
If the TcProjectCompare is displayed integrated in Visual Studio, the Visual Studio error list is used.

Configure User Tools…

Function: This command opens the Configure User Tools… dialog (see Configure User Tools [} 26]).

Call: Menu Tools -> Configure User Tools…

Options…

Function: This command opens the Options dialog (see Options [} 27]).

Call: Menu Tools -> Options

5.2 Toolbar
The toolbar of the TcProjectCompare provides the following commands:

Select the two files to be compared.

Save the changes in the current comparison window.

Save all outstanding changes.

Reload the two files to be compared.

Expand the complete tree.

Swap the sides of the two files to be compared.

Open the Options dialog (see Options [} 27]).

Open the Configure User Tools… dialog (see Configure User Tools [} 26]).

5.3 Comparison window
The results of the comparison of the two projects/files are displayed in the comparison windows. There are
three different comparison views, which are explained below. If the comparison of single files has been
initiated (e.g. by command line or via the source control client), the corresponding comparison window opens
directly. If two TwinCAT projects have been selected for comparison, the TcProjectCompare starts with the
comparison windows of the TwinCAT 3 project (see TwinCAT3 project comparison window [} 21]).

Handling the status information in the comparison windows:

The status information for the current comparison is located on the left-hand side of the toolbar in the
comparison windows. It indicates how many additions, deletions and changes have been found. It always
refers to a comparison starting from the left-hand side, as that is the side in which contents are merged.
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Example of the status display after a comparison:

Starting from this example, this would be:

• No contents, which are present on the left-hand side, but not on the right-hand side.
• One entry that is present on the right-hand side, but not (yet) on the left-hand side.
• Once change in an entry

In the comparison editors, the changes are displayed in the same colors as the status bar, so that it can
immediately be seen whether an addition, deletion or change is concerned.

NOTE
Unwanted deletion of contents when accepting additions
Additions show changes that exist on the left-hand side, i.e. on the side on which merging is to take place.
Since this is the side that is currently being edited, the contents are mostly new contents of its own. How-
ever, the merging (acceptance of changes) refers to the right-hand side of the comparison window. This
may contain changes by third parties or in comparison with old project versions. Since merging takes place
from the right-hand side to the left-hand side, the non-existence on the right-hand side of the comparison
window is therefore accepted when accepting an addition. In other words, the content of an addition is
deleted upon acceptance.

5.3.1 TwinCAT3 project comparison window
A distinction is made in the comparison window of the TwinCAT3 project between logical (content) and
formal changes. In the case of logical changes, the name of the item is displayed in red. These are changes
that relate to the behavior of the machine/plant. Formal changes are indicated by a vertical red bar in front of
the item name. These are changes that are important for the project handling, but have no meaning for the
project in terms of content. One example of formal changes is the LineIDs. These are required to assign
code lines within a POU to binary code positions of the generated runtime module. They are required to
display breakpoints set in a POU in the right positions, even after code changes that do not require
recompilation (e.g. comment lines or empty lines). Formal changes cannot be displayed in the PLC
comparison windows; therefore, they have to be compared (if need be) in the XML comparison windows.

Toolbar in the comparison editor of the TwinCAT3 project:



Reference, user interface

TwinCAT 322 Version: 1.0.1

Additions Number of newly added elements.
Deletions Number of elements to be deleted.
Logical Number of content changes (only in the TwinCAT3 project comparison

window).
Formal Number of formal changes (only in the TwinCAT3 project comparison

window).

Shows the direction in which merging takes place.

Search box for searching for components/entries.
Available in the comparison editors of the TwinCAT3 project and the
XML comparison.
Jump to the next change.

Jump to the previous change.

Accept selected change.

Accept all changes.

Context menu in the comparison window of the TwinCAT tree:

Context menu on a free area in the comparison editor of the TwinCAT project
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Hide Items Opens the submenu Hide Items.
Hide Items -> None Selection: Do not hide any items.
Hide Items -> Hide equal items Selection: Hide equal items.
Hide Items -> Hide equal items + formal Changes Selection: Hide equal items and items with only formal

changes.
Show Plc Folders Selection: Show PLC folders.

With the help of the option Show Plc Folders, you can set whether the POUs are to be compared in the
existing folder structure of the PLC or in an alphabetically sorted flat list. The comparison using the folder
structure thus displays a change for POUs that are identical in terms of content and form, even if they are
located in different folders of the PLC.

Since these POUs are not "opposite" one another in the comparison windows, they are not compared in
terms of content, but displayed as Addition and Deletion at the respective points. The content comparison
can be initiated with the option Compare To… (see TwinCAT3 project comparison window [} 23]).
However, since this assignment has to take place manually for every POU pair located in different places
within the PLC folder structure, the comparison can also be initiated in a flat, alphabetically sorted list by
deactivating the option Show Plc Folders. In order to merge all changes (content, formal and structural) it
may therefore be useful to compare a project with the option Show Plc Folders switched on and also with it
switched off.

Changes when switching over the option Show Plc Folders are not recognized with-
out a Reload
Since the displayed status information and thus the determined changes relate to the last success-
ful comparison, it is necessary to reload the project after switching over the option Show Plc Fold-
ers. Otherwise a POU that has remained the same both content-wise and formally will nevertheless
be recognized as changed if it is contained in two different folders.

Context menu at a node in the TwinCAT project tree

Compare To… Manual assignment to an object to be compared.
Compare in Xml-Diff Comparison using the XML comparison.
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If objects or sub-projects are renamed in the course of the project, they are displayed in the
TcProjectCompare as Addition or Deletion respectively. A content or formal comparison does not take
place. In order to be able to compare these objects or sub-projects with each other despite that, it is possible
to force a manual assignment/manual comparison with the option Compare To….

5.3.2 PLC comparison window

Toolbar in the comparison editors:

Additions Number of new elements to be added.
Deletions Number of elements to be deleted.
Changes Number of changes (only in the comparison editors of the PLC and

XML comparison).

Shows the direction in which merging takes place.

Amend comparison of changes (oppose changes).

Jump to the next change.

Jump to the previous change.

Accept selected change.

Accept all changes of the selected block.

Accept all changes.

If code lines are not to be directly compared, it is possible to display these code lines with an offset on both

sides by activating the option  Oppose Changes. This makes it possible to accept the change on the
right-hand side of the comparison window without overwriting the code line on the left-hand side of the
comparison window.

Sample: Display of a code line with the function Oppose Changes activated.

5.3.3 XML comparison window

Toolbar in the comparison editors:
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Additions Number of new elements to be added.
Deletions Number of elements to be deleted.
Changes Number of changes (only in the comparison editors of the PLC and

XML comparison).

Shows the direction in which merging takes place.

Search box for searching for components/entries; available in the
comparison editors of the Twin CAT3 project and XML comparison.

Jump to the next change.

Jump to the previous change.

Accept selected change.

Accept all changes to the attributes of the selected node.

Accept all changes.

Context menu on a free area in the Xml comparison editor

Hide equal Items Hide all equal items.

Sample: Display with option Hide equal Items activated.
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5.4 Configure User Tools
The windows and options of the dialog Configure User Tools… are described below. The specific
procedure to set the TcProjectCompare or the source control clients can be found in the chapter
Configuration of the TcProjectCompare for use with source control [} 14].

Add… Add a file type for forwarding to an external comparison tool (see Configure User
Tools [} 26]).

Remove Delete a file type.
Modify Edit the settings for a file type.
Export Configuration Export the configuration for the TcProjectCompare for a source control client (see

Configure User Tools [} 27]).
OK Confirm the settings made.
Cancel Cancel and discard the settings made.

Add file type dialog

Extension File extension of the file type.
Command Selection of the comparison tool to be called (path to .EXE file).
Compare Args Command line parameters of the comparison tool for a comparison.
Merge Args Command line parameters of the comparison tool for merging.
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Export Configuration Dialog

Selection box Selection box for selecting a source control client.
OK Confirm the selection.
Cancel Cancel and discard the selection.

Git Configuration Dialog

Selection box Global / Specific Project Choice between global and project-specific configuration.
Selection box for the .gitconfig file Selection of the gitconfig file of a local repository.
OK Confirm the selection.
Cancel Cancel and discard the selection.

5.5 Options
Further options for adapting the TcProjectCompare tool to your specific requirements are available under
Tools -> Options. These options are described in the following sub-chapters.

5.5.1 General tab
General settings of the TcProjectCompare are stored on the General tab.
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In the area Automatic reload after modification, you can set whether the file/project should be reloaded
after a change.

Yes Reloads both files after each change.
No Does not carry out an automatic reload.
Always ask Following a change, asks whether a reload should be

carried out.

You can set the logging for the TcProjectCompare in the LogFile area:

Delete log if no error occurred Deletes all log files if no error has occurred.
Bundle loaded files to a zip archive if error
occurred

In the case of an error, the loaded files and the log files are
stored as a ZIP archive.

The log files of the TcProjectCompare are stored in the folder
%TWINCAT3DIR%Components\TcProjectCompare\LastLog.

Further general settings:

Multiple viewer instances Allows several instances of the individual comparison
windows (with the exception of the TwinCAT3 project
comparison window).

Ignore read only flag Ignores the read-only flag when saving.

If projects or files that are subject to source control handling are compared with one another, it can be the
case – depending on the source control client – that files that are not checked out are read-only. These files
can be merged despite that by activating the option Ignore read only flag. However, they won't
automatically be checked out!

5.5.2 Source Control tab
All properties of the TcProjectCompare that are important in the case of a call by a source control client are
displayed on the Source Control tab.
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In the Merge into area you can specify whether merging takes place into the local file or into the server file
in the case of a call by a source control client. Since the TcProjectCompare can only merge from the right-
hand side to the left-hand side, this setting specifies which side of the comparison window the local and
server files are loaded into.

Local file Merge into the local file; the local file is loaded into the left-hand
comparison window.

Server file Merge into the server file; the server file is loaded into the left-hand
comparison window.

Under Visual Studio Integration you can specify whether TcProjectCompare is to be used in stand-alone
mode or integrated in Visual Studio. The latter option is only available from TwinCAT version 3.1 build 4020
or higher.

Load Visual Studio integrated version Opens the version of the TcProjectCompare that is integrated in
Visual Studio.

Load standalone version Opens the stand-alone version of the TcProjectCompare.

5.5.3 Project tab
All settings that are important in the TwinCAT3 project comparison window are listed on the Project tab.
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In the Expansion area you can specify whether the complete tree or only the parts containing changes are
expanded when opening a project file.

Expand all All elements are expanded.
Only expand changes Only the changes are expanded.

In the Search area you can specify whether search queries within the TcProjectCompare include only the
changed elements or all elements.

Search all All elements are searched.
Only search changes Only changes are searched.

In the Display Defaults area you can define the default values for the options Show Plc Folders and Hide
Items.

Show Plc Folders Display the PLC folder structure.
Hide Items -> None No items are hidden.
Hide Items -> Hide equal items Equal items are hidden.
Hide Items -> Hide equal items + formal Changes Equal items and formal changes are hidden.

In the Handle as formal changes area, you can specify what are regarded as formal changes.

Io:IDs In the TwinCAT I/O node, all changes to the IDs of the
sub-items are displayed as formal changes.

Io:ImageData In the TwinCAT I/O node, all changes to the ImageData
(the images displayed in the tree) are displayed as formal
changes.
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5.5.4 Plc tab
All settings that are important in the PLC comparison window are displayed on the Plc tab.

Ignore whitespaces Spaces (with the exception of semantically relevant spaces) are
ignored in the comparison.

Ignore comments Comments are ignored in the comparison.

5.5.5 Xml tab
All settings that concern the XML comparison window are displayed on the XML tab.
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Under Expansion you can specify whether the whole tree is expanded or only the parts containing
modifications when an XML file is opened.

Expand all Expands the complete XML tree.
Do not expand attributes Expands the complete XML tree, but no attributes.
Only expand changes Only expands the changes.

Under Search you can specify whether search queries within the TcProjectCompare tool apply only to the
modified elements or all elements, and whether the search should also include the values or comments of
the XML elements.

Search all Search all Xml nodes.
Only search in changes Search only Xml nodes with changes.
Search in values Also search the values in Xml nodes.
Search in comments Also search the comments of the Xml items.

The default settings when opening an Xml comparison window are defined in the Display Defaults area.

None All items are displayed.
Hide equal Items Hides all equal items.

5.5.6 Tmc tab
All settings that concern the comparison of TMC files are displayed on the TMC tab.
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Under Expansion you can specify whether the whole tree is expanded or only the parts containing
modifications when an TMC file is opened.

Expand all Expands the complete TMC tree.
Only expand changes Only expands the changes.

In the Search area you can specify whether search queries within the TcProjectCompare should include only
the changed items or all items.

Search all Search all TMC nodes.
Only search in changes Search only TMC nodes with changes.

The default settings when opening an TMC comparison window are defined in the Display Defaults area.

None All items are displayed.
Hide equal Items Hides all equal items.

5.5.7 Hotkeys tab
Shortcuts for the operation of the TcProjectCompare with the keyboard can be defined on the Hotkeys tab.
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Assign Assigns the selected shortcut to the selected command.
OK Confirm the selection.
Cancel Cancel and discard the changes.

5.6 Error list
All errors and messages of the TcProjectCompare are displayed in the Error List window.

Clear Deletes the entries in the Error List window.
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