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1 Documentation notes
This description is only intended for the use of trained specialists in
control and automation engineering who are familiar with the appli-
cable national standards.
It is essential that the documentation and the following notes and
explanations are followed when installing and commissioning the
components.
The responsible staff is always obliged to use the currently valid
documentation.
The responsible staff must ensure that the application or use of the
products described satisfy all the requirements for safety, including
all the relevant laws, regulations, guidelines and standards.

1.1 Disclaimer
Beckhoff products are subject to continuous further development.
We reserve the right to revise the documentation at any time and
without notice. No claims for the modification of products that have
already been supplied may be made on the basis of the data, dia-
grams, and descriptions in this documentation.

1.1.1 Trademarks
Beckhoff®, TwinCAT®, TwinCAT/BSD®, TC/BSD®, EtherCAT®, Ether-
CAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®,
TwinSAFE®, XFC®, XTS® and XPlanar® are registered and licensed
trademarks of Beckhoff Automation GmbH.
The use by third parties of other brand names or trademarks con-
tained in this documentation may lead to an infringement of the
rights of the respective trademark owner.

1.1.2 Patents
The EtherCAT technology is protected by patent rights through the
following registrations and patents with corresponding applications
and registrations in various other countries:

• EP1590927
• EP1789857
• EP1456722
• EP2137893
• DE102015105702

EtherCAT® is a registered trademark and patented technology, li-
censed by Beckhoff Automation GmbH.
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1.1.3 Limitation of liability
The software described in this operating manual is combined with a
specific configuration of hardware components depending on the
application requirements. Modifications and changes to the hard-
ware or software configuration that go beyond the documented op-
tions are prohibited and nullify the liability of Beckhoff Automation
GmbH & Co. KG.

The following is excluded from the liability:
• Failure to observe this operating manual
• Improper use
• Use of untrained personnel
• Use of unauthorized spare parts

1.1.4 Copyright
© Beckhoff Automation GmbH & Co. KG, Germany
The copying, distribution and utilization of this document as well as
the communication of its contents to others without express autho-
rization is prohibited. Offenders will be held liable for the payment of
damages. 
We reserve all rights in the event of registration of patents, utility
models and designs.
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1.2 Version numbers

Provision of revision levels
On request we can send you a list of revision levels for changes to
the documentation.
• Send your request to: motion-documentation@beckhoff.de
Origin of the document
This documentation was originally written in German. All other lan-
guages are derived from the German original.

Product features
The valid product features are always those specified in the current
documentation. Further information given on the product pages of
the Beckhoff homepage, in emails or in other publications is not au-
thoritative.

1.3 Scope of the documentation
In addition to this documentation, the following documents are part
of the complete documentation:

Manual | TF5410
Description of the optional package for collision avoidance when op-
erating multiple axes.

Direct link to the documentation TF5410 | TwinCAT 3 Motion
Collision Avoidance

Translation of the original manual | XTS
Description of the mechanical and electrical parameters as well as
all necessary information for the assembly of the XTS system.

https://www.beckhoff.com/en-en/support/download-finder/search-result/?download_group=339413613
https://www.beckhoff.com/en-en/support/download-finder/search-result/?download_group=339413613
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1.4 Explanation of symbols
Various symbols  are used for a clear arrangement:

► The triangle indicates instructions that you should execute
 • The bullet point indicates an enumeration

1.4.1 Pictograms

NOTICE
Notes
Notes are used for important information on the product. The
possible consequences of failure to observe these include:
• Malfunctions of the product
• Damage to the product
• Damage to the environment

Information
This sign indicates information, tips and notes for dealing with the
product or the software.

Examples
This symbol shows examples of how to use the product or software.
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1.5 Beckhoff Services
Beckhoff and its international partner companies offer comprehen-
sive support and service.

1.5.1 Support
The Beckhoff Support offers technical advice on the use of individ-
ual Beckhoff products and system planning. The employees support
you in the programming and commissioning of sophisticated auto-
mation systems.

Hotline: +49(0)5246/963-157
Fax: +49(0)5246/963-199
E-mail: support@beckhoff.com
Web: www.beckhoff.de/support

1.5.2 Training
Training in Germany takes place in our training center at the Beck-
hoff headquarters in Verl, at branch offices or, by arrangement, at
the customer's premises.

Hotline: +49(0)5246/963-5000
Fax: +49(0)5246/963-95000
e-mail: training@beckhoff.com
Web: www.beckhoff.de/training

1.5.3 Service
The Beckhoff Service Center supports you with after-sales services
such as on-site service, repair service or spare parts service.

Hotline: +49(0)5246/963-460
Fax: +49(0)5246/963-479
E-mail: service@beckhoff.com
Web: www.beckhoff.de/service

1.5.4 Download area
In the download area you will find product information, software up-
dates, the TwinCAT software, documentation and much more.

Web: www.beckhoff.de/download

1.5.5 Headquarters
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Germany

Phone: +49(0)5246/963-0
Fax: +49(0)5246/963-198
E-mail: info@beckhoff.com
Web: www.beckhoff.de

The addresses of the international Beckhoff branches can be found
on the Beckhoff website: http://www.beckhoff.de

http://www.beckhoff.de
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2 For your safety
Read this chapter containing general safety information. In all cases
observe the safety instructions for your own safety, the safety of
other persons and the safety of the product.
When working with control and automation products, many dangers
can result from careless or incorrect use. Work particularly thor-
oughly, not under time pressure and responsibly towards other peo-
ple.

2.1 General safety instructions
This chapter contains information on safety relating to the software
and the associated products. Please also read the original operating
manual for the hardware components you are using.

2.1.1 Before operation
Danger from magnetic fields
The magnetic fields of some of the components of the XTS are dan-
gerous to:
• people fitted with cardiac pacemakers
• persons with magnetically conducting implants
• implanted and external defibrillators
• magnetic data storage devices, chip cards with magnetic strips

and other electronic devices

Maintain a safety distance to all magnetic parts and prevent direct
contact between magnetic parts and parts that are sensitive to inter-
ference.
Observe the requirements of BGV B 11 for electromagnetic fields
(Germany) and applicable national regulations in other countries.

Use output voltages SELV / PELV
Operate all electronic modules and components in the drive system
only with a SELV (Safety Extra Low Voltage) or PELV (Protective
Extra Low Voltage) output voltage.

Keep the immediate environment clean
Keep your workplace and the surrounding area clean. Ensure safe
working.

Shut down and secure the machine or plant
Shut down the machine or plant. Secure the machine or plant
against being inadvertently started up.
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Do not use damaged components
Adhere to the specifications from the technical data for storage,
transport and operation. Do not use damaged components.

Risk of injury when handling cutting tools
You can sustain cutting or puncturing injuries through careless work-
ing with cutting tools.
Ensure safe working. Wear protective gloves if necessary.

Risk of injury when handling adhesives
Adhesive can irritate the eyes, the respiratory organs and the skin.
Do not inhale the vapor. Avoid contact of the adhesive with the eyes
and skin. If adhesive should get into your eyes, immediately rinse
out your eyes thoroughly with water and consult a doctor.
Refer to the manufacturer's documentation when handling adhe-
sives. Wear protective gloves and safety glasses if necessary.

Check safety pictograms
Check whether the designated pictograms are on the product. Re-
place missing or illegible stickers.

Observe tightening torques
Mount and repeatedly check connections and components, comply-
ing with the prescribed tightening torques.

Correctly ground electrical components or modules
Avoid electric shocks due to improper grounding of electrical compo-
nents or modules. Ground all conductive components according to
the specifications in the chapters "Electrical Installation" and "Me-
chanical Installation".

Use the original packaging only
When shipping, transporting, storing and packing, use the original
packaging or non-conductive materials.

2.1.2 During operation
Observe the GND concept
Special conditions need to be observed for the grounding of the
XTS. Be sure to read the chapter "Grounding of the supply".

Do not work on live electrical parts
Ensure proper connection of the protective conductor. Never loosen
electrical connections when live. Only work on the XTS when the
voltage has dropped to < 10 V. Disconnect all components from the
mains and secure them against being switched on again.

Do not touch hot surfaces
Check the cooling of the surfaces with a thermometer. Do not touch
the components during and immediately after operation. Allow the
components to cool sufficiently after switching off.
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Avoid overheating
Operate the components according to the technical specifications.
Refer here to the chapter: "Technical data". Provide for sufficient
cooling. Switch the components off immediately if the temperature is
too high.

Do not touch any moving or rotating components
Do not touch any moving or rotating components. Fasten all parts or
components on the machine or plant.

2.1.3 After operation
De-energize and switch off components before working on
them
Check the functionality of all safety-relevant devices. Secure the
working environment. Secure the machine or plant against being in-
advertently started up. Observe the chapter: "Decommissioning".
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3 Notes on information security
The products from Beckhoff Automation GmbH & Co. KG – if they
are reachable online – are equipped with Security functions that
support the secure operation of plants, systems, machines and net-
works. Despite the security functions, the creation, implementation
and constant updating of a holistic security concept for the operation
are necessary to protect the respective plant, system, machine and
networks against cyber threats. The products sold by Beckhoff are
only part of the overall security concept. The customer is responsi-
ble for preventing unauthorized access by third parties to its equip-
ment, systems, machines and networks. The latter should be con-
nected to the corporate network or the Internet only if appropriate
protective measures have been set up.
Beckhoff recommends the following protective measures for infor-
mation security and industrial security:

www.infosys.beckhoff.com

Beckhoff products and solutions undergo continuous further devel-
opment. This also applies to security functions. In light of this contin-
uous further development, Beckhoff expressly recommends that the
products are kept up to date at all times and that updates are in-
stalled for the products once they have been made available. Using
outdated or unsupported product versions can increase the risk of
cyber threats. Subscribe to the RSS feed to stay informed about in-
formation security for Beckhoff products. For more information, see:

www.infosys.beckhoff.com

https://infosys.beckhoff.com/content/1033/ipc_security/976055435.html
https://infosys.beckhoff.com/content/1033/ipc_security/976057355.html
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4 General Information
These operating manual will help you to commission and program
an XTS system.
The following chapters will guide you through the basic configuration
of the XTS hardware components in TwinCAT  3, so that you can
move the XTS movers via the basic NC interface and program them
in the PLC. The aim is to move the XTS Mover for the first time and
to verify the system concept. You will also receive an initial overview
of all XTS functionalities of the TF5850 TC3 XTS Extension.

The documentation for the TF5850 TC3 XTS Extension is currently
still under construction and will be continuously expanded. The cur-
rent version of these operating manual can be found at:

www.beckhoff.com/de-de/support/downloadfinder/

4.1 Compatibility
This documentation refers to the following software versions of
TF5850 TC3 XTS Extension, TF5400 TC3 Advanced Motion Pack
Extension and TwinCAT 3:

Software Version
TF5850 3.21.703.0 or higher
TF5400 3.1.10.52 or higher
TC3 3.1.4024.22 or higher

This documentation is only suitable to a limited extent for commis-
sioning XTS systems with older software versions. If you have any
questions, please contact the product specialist responsible for your
region.

4.2 Presentation of the screenshots
The language setting English in TwinCAT was used for this docu-
mentation. All screenshots in this documentation are shown as ex-
amples in English. The terms from the screenshots are used in the
corresponding instructions.
All functions and settings can be found in the same place in the soft-
ware, regardless of the language set on your PC.

https://www.beckhoff.com/de-de/support/downloadfinder/suchergebnis/?c-1=26779659
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4.3 User interface overview
The TwinCAT user interface is divided into the following areas:

1 2 3 4 5 6

7 8

Position Explanation
1 Solution Explorer
2 Menu bar
3 Project window
4 Toolbar
5 XTS Tool Window
6 Toolbox or Properties Window
7 Message window Error List and Output
8 Information bar and status bar
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5 Installation and software update
Before you can commission an XTS system, you must first install
the TF5850  |  TwinCAT  3 XTS Extension software. The following
steps are also required when updating to the latest version of
TF5850 | TwinCAT 3 XTS Extension.
If you have already installed a software version, check if you have
installed the latest version. Further information can be found in
chapter "Check version", [Page 22].

As a prerequisite for the installation, a version of TwinCAT  3 XAE
(TcXaeShell or higher) must already exist on your system.

You can find the latest version of the software in the download
finder:

www.beckhoff.com/de-de/support/downloadfinder/

► Download and save software TF5850 | TwinCAT 3 XTS Exten-
sion

► Double-click on the TF5850-XTS-Technology icon on your
desktop

The installation is started.

► Click on Yes to allow changes to the device

► Select the desired installation language from the drop-down
menu

► Confirm with OK

The installation is prepared.

https://www.beckhoff.com/de-de/support/downloadfinder/suchergebnis/?c-1=26782567
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► Click on Next > to proceed with the installation
► Click on Next > to proceed with the installation

► Accept the license terms
► If required, click Print to print the license terms
► Click on Next > to proceed with the installation

► Enter the user name in the input field User Name
► Enter the company name in the input field Organization
► Click on Next > to proceed with the installation

► Select Complete setup type
► Click on Next > to proceed with the installation

► Confirm with Install
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The program will be installed.

► Click on Finish

► Click on Yes to restart the device and apply the changes

If you have updated the TF5850  | TwinCAT 3 XTS Extension, you
must reload the TcCom objects. Further information can be found in
chapter "Reload TcCom objects", [Page 23].
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5.1 Check version

Observe operating system
Calling up the version depends on the operating system installed on
your device and may differ from the variant described here.

► Click Start
► Call up the Control Panel

The window Control Panel opens.
► Click on Programs

The window Programs opens.
► Click on Programs and Features

The Programs and Features window opens.
► Check the version of Beckhoff TF5850 TC3 XTS Technology
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5.2 Reload TcCom objects
If you have updated the TF5850  | TwinCAT 3 XTS Extension, you
must reload the TcCom objects.

► Expand Solution Explorer > TwinCAT Project > SYSTEM
► Double click on TcCOM Objects

► In the project window click on the Project Objects tab
► Select all objects
► Right-click the selected objects to open the context menu
► Click on Reload TMI/TMC Description(s) in the context menu
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6 Functions of the driver

6.1 XTS Configuration
The XTS system consists of hardware components and software
components that must communicate and function together. To make
the system behave as expected, you need to understand the gen-
eral processes and communication paths between software and
hardware.
An XTS system consists of the modules, guide rails and movers as
well as some software components running on an IPC.

Communication levels

SPS

NC
TF5410* 

SoftDriveXTS
TF5850 

IO 

Collision 
Avoidance Group*

AXES_GROUP_REF*AXIS_REF

CoE 
Status/Control

CoE 
Status/Control

CoE 
Status/Control

NC Data

CA motion profile

PLC application

MC commandsNC data

XTS Driver
(XTS Processing Unit / XTS IO Driver)

XTS Module

Mover setpoint 
current values

Raw coil 
current values

Raw 
sensor values

Mover actual 
position values

Setpoint values
(Pos., Vel., Acc.)

Actual values
(Pos., Vel., Acc.)

NC Axis

CA-Group 
data

CA-Group 
commands

* Optional
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The basis for communication is the hardware, consisting of the mod-
ules. The modules transmit sensor values to the driver.
The driver uses the sensor values of the modules to determine the
position of the movers and transmits the position values of each in-
dividual mover to the respective SoftDrive.
The SoftDrive transmits the current position values and velocity val-
ues to the NC axes. The NC axes generate motion profiles based on
the values received and transmit setpoints for the position and ve-
locity back to the SoftDrive.
The SoftDrive interpolates the values and performs a set/actual
value comparison and transmits the current values of the mover re-
sulting from the control structure back to the driver. The driver calcu-
lates and transmits the current setpoints to the 15 coils of the mod-
ules.
If the NC axes are included in a Collision Avoidance group, the NC
axes receive external setpoints back that represent the motion pro-
file of each individual mover.
Motion commands and administrative commands are transferred by
the user from the PLC application via libraries directly to the NC
axes or the Collision Avoidance group.
The communication of the XTS is based on and takes place via the
CANopen communication structure. Additional data is transferred
between objects to calculate coil current, commutation, dynamics,
and motion profiles.
For more information on the individual objects, please refer to the
respective documentation.

6.1.1 Integration of the XTS driver
On the software side, the XTS system consists of several compo-
nents that are inserted into a TwinCAT project as a TwinCAT Com-
ponent object, or TcCom object for short. Each module and each
mover requires a corresponding driver TcCom object, via whose in-
terfaces data is exchanged with other components:
• The TcCom object Module has Data Pointers. These Data Point-

ers are interfaces that are linked to the process data of the XTS
IO modules. The TcCom object Module receives the sensor val-
ues of the module via the Data Pointers.

• The TcCom object Mover has Data Areas. These Data Areas are
interfaces to the corresponding SoftDrive object that is created
under each NC axis. Via the Data Areas, the TcCom object
Mover receives new current setpoints and supplies the current
position to the NC axis via the SoftDrive.

In addition to the TcCom objects Module and Mover, the system re-
quires other TcCom objects to perform general system calculations
and to manage basic system parameters. For more information, see
the chapters "Configuration setup", [Page  29] and "Create new
XTS system manually", [Page 39].
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6.1.2 Basic principles
The new user interface of the XTS software simplifies the work and
handling of the ever larger and more sophisticated systems imple-
mented with XTS. The simple pictorial structure makes a decisive
contribution to fast commissioning and intuitive operation. A large
number of XTS systems can now be set up very easily, regardless
of length, shape or variant.
A main goal of the XTS software is to support the various software
functionalities such as Track Management or Leave and Arrive:
• Using the Track Management function, you can split the XTS

system into individual sections, which you then join together to
form continuous tracks. This gives you the possibility to mechan-
ically align individual sections in different ways and thus use the
movers more flexibly on the system.

• Using the Leave and Arrive function, you can remove movers or
add more movers while the system is running.

6.1.2.1 Example configurations for XTS systems
The two example configurations show how differently an XTS sys-
tem can be set up.

Closed XTS system

A closed system with 180° turns and ten movers, corresponding to
the configuration of a 3 m XTS starter kit.
Further information can be found in chapter "System configuration",
[Page 261].

XTS system with Track Management

XTS Track Management with four XTS Parts and six movers. This
setup is usually referred to as switch or elevator.
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The difference between these two system configurations is that in a
closed XTS system the order of modules and movers always re-
mains constant. The movers thus have only one possible XTS Track
on which they can move.
In an XTS system with Track Management, modules can change
their position and align with other modules. Thus, the order of mod-
ules and movers can be changed, as new tracks can be formed. To
be able to keep the overview of these new functions, the XTS Parts
and XTS Tracks functions have been introduced.

Part 1

Part 1

Track 1 

6

1
2

3 4
11 10 9

8
7

5

The XTS Part is the physical hardware component on which the
mover travels, comparable to a road section for a car. The XTS
Track, on the other hand, is the actual track of the mover. The track
is created by assembling the individual hardware components. In
comparison with the car, a possible track with different road sections
is created.
XTS Parts and XTS Tracks are objects that can be created in the
TwinCAT project using the XTS Configurator. A simple XTS system
can be created with only one XTS Part and one XTS Track for all
movers.

16

Part 5
Track 2

Part 1

Track 1
Part 3

Part 2
Part 4

P

5
8

9

12

7 6
11

1
2 10

3 4

More sophisticated XTS systems can consist of several XTS Parts
that are joined together to form different XTS Tracks. In comparison
with the car, a car ferry is used between two possible tracks.
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SERVICE
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STOCKXTS System

With the Leave and Arrive function, it is possible for single movers to
be taken off the system or for additional movers to be brought onto
the system. In comparison with the car, the additional road section
serves as an entrance and exit. Outside the XTS Parts there are
parking lots for unused cars, new car dealers with additional cars
and workshops for broken cars.
Transferred to the XTS system, it means that you can, for example:
• Be able to remove the mover for maintenance
• Be able to add new movers if needed
• Be able to remove movers that are no longer needed
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6.1.3 Configuration setup

Manual creation or use of TwinCAT Tools
You have the option of creating the hardware components and the I/
O components manually or quickly and easily via the TwinCAT tools
XTS Configurator and XTS Simulation Builder. Further information
about the TwinCAT Tools can be found in chapters "XTS Configura-
tor", [Page 258] and "XTS Simulation Builder", [Page 229].
Configurator replaces the XTS Manager
The Configurator replaces the XTS Manager, which was integrated
in the XTS IO  Driver object in the software versions up to version
3.18.715.0. Further information can be found in chapter "Compatibil-
ity mode", [Page 71].

Before you can use an XTS system, it must first be fully configured
with all I/O components and all Real Time and Distributed Clock set-
tings.
The main steps in configuring a system are as follows:
• XTS Processing Units
• XTS Parts
• XTS Modules
• XTS Tracks
• XTS Movers
• XTS Stations
• NC axis
• SoftDrive
• I/O Terminal



Functions of the driver

30 ─── Version: 1.1.1TF5850

6.1.3.1 XTS Processing Units
The Processing Unit is the center of an XTS system. All the neces-
sary objects converge in the Processing Unit and are logically linked
to each other.

The XTS Processing Unit replaces the XTS IO Driver object of the
previous software version.

You can create one or more Processing Units, depending on the
number of individual systems used in the machine. Each Processing
Unit requires at least one Task that is not used in other Processing
Units.

Required settings:
• Task
• OperationMode
• MoverType
• MagnetPlateType
• IdDetectionMode
• IsTeachingEnabled

Optional settings:
• MoverSortOrder
• MinMechanicalMoverDistance
• all other parameters
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6.1.3.2 XTS Parts
A part is the minimum required component of an XTS system. The
smallest possible part is a single module. Normally, a part consists
of one infeed line, but multiple supplies within a part are also possi-
ble.
During manual creation in the correct order, it is determined which I/
O Devices are included and to which Processing Unit the part be-
longs.
The optional settings are used to display the view in the XTS Sys-
tem View as realistically as possible.

Motormodul

Part

Module

Module

...

Module

...

Module

Module
with infeed

Module
with infeed

 
 3 

m
≤

 
 3 

m
≤

...

Required settings:
• none

Optional settings:
• TaskOID
• ModuleSide
• OriginTransform
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6.1.3.3 XTS Modules
A module corresponds to a physical module AT2xxx-0xxx and is al-
ways a subordinate object of a part.
A task must be assigned to each Module in the Context tab in order
to be able to perform active calculations. Only modules with feed
and modules with connector have EtherCAT communication inter-
faces. Connector cards are used to establish the EtherCAT commu-
nication to other modules.

Simulation mode or machine mode
No hardware is required for the simulation mode of the driver.
For real machine operation, a physical AT2xxx-0xxx module must be
assigned to each module.

Each module must be assigned a corresponding hardware compo-
nent.

Data Pointer

Module

Data Pointer

Module
with infeed

Required settings:
• Task
• PositionIndex
• MotorTerminalOid
• SensorTerminalOid
• Linking with I/O objects

Optional settings:
• Gap
• Offset
• ScalingFactor
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6.1.3.4 XTS Tracks
A track is a route that can be used by movers and consists of one or
more parts. A part can also occur more than once in a particular
XTS Track or be inserted in several different tracks. You can create
as many tracks as you like.
To create a track, you must define which parts are contained in this
track and in which order the parts occur.
An important setting option is whether the track is closed. With this
specification you determine whether the movers have the possibility
to drive endlessly in a circle or whether the system has endpoints.

NOTICE
Avoid damage to the product and functional errors
Be sure to correctly specify whether you are configuring a closed
system or a system with defined endpoints.
If the specification is incorrect, the movers may leave the system
if it is open. In the case of a closed system with incorrect specifi-
cation, the movers cannot travel in a circle as usual.

To determine the correct number of movers when the system starts,
you must define which tracks perform the detection. It is important
that each part within a track only occurs once in the detection
process, otherwise too many movers may be displayed. It is best to
use all tracks to detect the movers that are active in your current
hardware configuration. You can also set the detection parameters
via the PLC.

Required settings:
• IsClosed
• IsIncludedInDetection
• PartConfigItems
• ObjectID

Optional settings:
• Polarity
• Offset
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6.1.3.5 XTS Movers
The movers, together with the modules, are the main components of
the XTS system. The movers travel on the parts in the system by
activating the corresponding tracks using NC functionalities of Twin-
CAT 3. Currently, 250 movers with collision avoidance function can
be controlled simultaneously within a project.
Each mover is connected to an NC axis via the SoftDrive and has its
own SoftDrive object to communicate with the NC and establish
compatibility with the basic control commands. The SoftDrive is a
software controller for the axes that controls the movers of the low-
est level. This means that the SoftDrive can adapt the control of the
movers to different loads.

Required settings:
• Task
• Linking with the SoftDrive of the NC axes
• SimulatedStartUpPart
• SimulatedStartUpPosition
• SimulatedStartUpId

Optional settings:
• none
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6.1.3.6 XTS Stations, Beta

The XTS Stations function is currently still in beta phase. In the fu-
ture, even more functions and information will be available and the
current interface may also change.

The Stations are very useful to manage the system and related ap-
plications. A station provides information about where individual pro-
cesses take place within the system to illustrate the structure of the
entire application. The information can also be read out using the
XTS Utility in the PLC.
Each station has its own identification data: ID, color, name and de-
scription. Regardless of the Is Enabled selection box, each station
has a defined start position and end position. These positions form
the frame of the station and can extend over several parts.
Within the station, you can configure stop positions that indicate
where the movers should stop or where a specific task is completed.

Required settings:
• Part
• Start position
• End position

Optional settings:
• all other parameters
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6.1.3.7 NC axis
Each mover is connected to an NC axis that generates the setpoint
profile for the movement of the respective mover. The NC axis is
created in the project under MOTION and linked to a mover via a
SoftDrive object.
The NC axes can be operated directly via the TwinCAT NC interface
or via the PLC using libraries with PLC-open-compliant function
blocks.

Required settings:
• Link to I/O
• Axis type
• Maximum dynamics and default dynamics
• Modulo Factor
• Tolerance Window for Modulo Start

Optional settings:
• Inversion of drive running direction and encoder running direc-

tion
• Following error monitoring
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6.1.3.8 SoftDrive
The SoftDrive connects each mover to an NC axis. The SoftDrive
uses the NC setpoint profile to control the position, velocity and cur-
rent for moving the movers and generates the required current and
current direction.
The SoftDrive provides the NC axis with the actual data required to
generate the NC profiles. The connection between the SoftDrive and
the respective Mover is made via DataPointer.

For more information on SoftDrive, refer to the XTS Soft Drive docu-
mentation or contact the product specialist responsible for your re-
gion.

Required settings:
• Task
• Linking with TcCom object Mover
• Hardware modulo

Optional settings:
• Control parameters for velocity controller and position controller
• Control parameters for acceleration pre-control
• Filter
• Settings for the behavior of the encoder
• Switching control modes
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6.1.3.9 I/O-Terminal
Each module is connected to the IPC via EtherCAT, this connection
is represented by the I/O terminal. A physical module of an infeed
line is assigned to each I/O terminal. Each infeed line is displayed
as EtherCAT master in the I/O overview.
After scanning, the status of the EtherCAT connection and the indi-
vidual sensor data and status data of the hardware can be called in
the I/O overview. The connection of the I/O terminal with the module
of the driver is done via DataPointer.

 IO-Terminal

Module

Required settings:
• Link to TcCom objects XTS modules

Optional settings:
• Access to CoE data
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6.1.4 Create new XTS system manually

Manual creation or use of TwinCAT Tools
You have the option of creating the hardware components and the
TcCom objects manually or quickly and easily via the TwinCAT tools
XTS Configurator and XTS Simulation Builder.
For more information, see the chapters "XTS Configurator", [Page
 258] and "XTS Simulation Builder", [Page 229].

This chapter describes how to create hardware components and Tc-
Com objects manually and without the help of XTS Tools.

6.1.4.1 Add TcCom objects
The TcCom objects must be created in the following order:
• Processing Unit
• Part
• Modules
• Track
• Mover

Example configuration
The creation of the XTS TcCom objects is shown once for each ob-
ject as an example. Repeat the corresponding steps until you have
created the configuration you want.
Make sure that you always add all other TcCom objects to each Pro-
cessing Unit you create.

Processing Unit
► Expand Solution Explorer > TwinCAT Project > SYSTEM
► Right-click on TcCOM Objects to open the context menu
► Click Add New Item... in the context menu

The Insert TcCOM Object dialog box opens.
► Expand Beckhoff Automation GmbH > XTS Modules
► Select XtsProcessingUnit [Module]
► Double click on the selection or confirm with OK
A Processing Unit is added to the TcCom objects.
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Part
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

Com Objects
► Right-click on Object (XtsProcessingUnit) to open the context

menu
► Click Add New Item... in the context menu

The Insert TcCOM Object dialog box opens.
► Expand Beckhoff Automation GmbH > XTS Modules
► Select XtsPart [Module]
► Enter the number of parts required in the input field Multiple
► Double click on the selection or confirm with OK
One or more parts are added to the Processing Unit.

Modules
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (XtsProcessingUnit)
► Right-click on Object (XtsPart) to open the context menu
► Click Add New Item... in the context menu
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The Insert TcCOM Object dialog box opens.
► Expand Beckhoff Automation GmbH > XTS Modules
► Select AT2xxx-0xxx [Module]
► Enter the number of modules required in the input field Multiple
► Double click on the selection or confirm with OK
One or more modules are added to Object (XtsPart).

Track
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

Com Objects
► Right-click on Object (XtsProcessingUnit) to open the context

menu
► Click Add New Item... in the context menu

The Insert TcCOM Object dialog box opens.
► Expand Beckhoff Automation GmbH > XTS Modules
► Select XtsTrack [Module]
► Enter the number of tracks required in the input field Multiple
► Double click on the selection or confirm with OK
One or more tracks are added to the Processing Unit.
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Mover
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

Com Objects
► Right-click on Object (XtsProcessingUnit) to open the context

menu
► Click Add New Item... in the context menu

The Insert TcCOM Object dialog box opens.
► Expand Beckhoff Automation GmbH > XTS Modules
► Select XtsMover [Module]
► Enter the number of movers required in the input field Multiple
► Double-click on the selection
OR
► Confirm with OK
One or more movers are added to the Processing Unit.
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InfoServer
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

Com Objects
► Right-click on Object (XtsProcessingUnit) to open the context

menu
► Click Add New Item... in the context menu

The Insert TcCOM Object dialog box opens.
► Expand Beckhoff Automation GmbH > XTS Modules
► Select XtsInfoServer [Module]
► Enter the number of InfoServers required in the input field Multi-

ple
► Double click on the selection or confirm with OK
One or more InfoServers are added to the Processing Unit.
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Stations
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

Com Objects
► Right-click on Object (XtsProcessingUnit) to open the context

menu
► Click Add New Item... in the context menu

The Insert TcCOM Object dialog box opens.
► Expand Beckhoff Automation GmbH > XTS Modules
► Select XtsStationInfo [Module]
► Enter the number of StationInfo required in the input field Multi-

ple
► Double click on the selection or confirm with OK
One or more StationInfos are added to the Processing Unit.
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6.1.4.2 Add Motion objects
The Motion objects must be created in the following order:
• NC task
• NC axis
• SoftDrive

Example configuration
The creation of Motion objects is shown once for each object as an
example. Repeat the corresponding steps until you have created the
configuration you want.

NC task
► Expand Solution-Explorer > TwinCAT Project
► Right-click on MOTION to open the context menu
► Click Add New Item... in the context menu

The Insert Motion Configuration dialog box opens.
► Select NC/PTP NCI Configuration
► Confirm with OK
An NC task SAF is added.

NC axis
► Expand Solution-Explorer > TwinCAT Project > MOTION >

NC‑Task 1 SAF
► Right-click on Axes to open the context menu
► Click Add New Item... in the context menu

The Insert NC Axis dialog box opens.
► Select Continuous Axis in the drop-down menu Type
► Confirm with OK
An NC axis is added.
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SoftDrive
► Expand Solution-Explorer > TwinCAT Project > MOTION >

NC‑Task SAF > Axes
► Right-click on Axis to open the context menu
► Click Add  in the context menu
► Click Add Object(s)...  in the submenu

The Insert TcCom Object dialog box opens.
► Expand Beckhoff Automation GmbH > SoftDrive Modules
► Select CTcSoftDrive [Module]
► Confirm with OK
A SoftDrive object is added.
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6.1.4.3 Add I/O objects

NOTICE
Scan existing XTS hardware
If you want to use your existing XTS hardware, use the scan
function of TwinCAT to avoid configuration errors and to save
time. Further information can be found in chapter "XTS Configu-
rator", [Page 258].

Use XTS Simulation Builder
With the XTS Simulation Builder you have the possibility to create
I/O objects to save time. Further information can be found in
chapter "XTS Simulation Builder", [Page 229]. 

Manual configuration
If you want to configure the I/O objects manually, you must en-
sure that you create exactly those components that are installed
in your XTS system.

The I/O objects must be created in the following order:
• Real-time Ethernet adapter
• EtherCAT Master
• CU2508 Ethernet Port
• XTS module
• XTS sensor channel

Real-time Ethernet adapter
The Real-time Ethernet adapter is used to establish the physical
connection between the XTS Ethernet lines and the IPC.

Example CU2508 real-time Ethernet adapter
The addition of a real-time Ethernet adapter is shown with a CU2508
adapter as an example. You can add four EtherCAT masters to the
CU2508 adapter. Depending on the number of EtherCAT masters, a
corresponding number of real-time Ethernet adapters must be
added.
You have the possibility to add other adapters. Note that these
adapters differ in the form of display and have fewer connectors.

► Expand Solution Explorer > TwinCAT Project > I/O
► Right-click on Devices to open the context menu
► Click Add New Item... in the context menu
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The Insert Device dialog box opens.
► Expand Ethernet
► Select Real-Time Ethernet Adapter (Multiple Protocol Han-

dler)
► If required, enter a name for the Real-Time Ethernet adapter in

the Name input field
► Confirm with OK
A Device (RT-Ethernet Adapter) is added to the I/O Devices.

EtherCAT Master
For each infeed line an EtherCAT master is required among the I/O
objects. You may use four EtherCAT masters under one Real-Time
Ethernet adapter. If you use more than four EtherCAT masters, you
have to add another Real-Time Ethernet adapter to the I/O objects.

► Expand Solution Explorer > TwinCAT Project > I/O
► Right-click on Devices to open the context menu
► Click Add New Item... in the context menu

The Insert Device dialog box opens.
► Expand EtherCAT
► Select EtherCAT Master
► If required, enter a name for the EtherCAT Master in the Name

input field.
► Confirm with OK
A Device (EtherCAT) is added to the I/O objects.
A CU2508 Ethernet port and the modules of an infeed line must be
added to the EtherCAT master.

CU2508 Ethernet Port
A CU2508 Ethernet port must be added to the EtherCAT master be-
fore the modules are added.
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► Expand Solution Explorer > TwinCAT Project > I/O > Devices
► Right-click on Device (EtherCAT) to open the context menu
► Click Add New Item... in the context menu

The Insert Device dialog box opens.
► Expand Beckhoff Automation GmbH & Co. KG > Ethernet Port

Multiplier (CU25xx)
► Select CU2508 Ethernet Port
► If required, enter a name for the CU2508 Ethernet Port in the

Name input field
► Confirm with OK
A Box (CU2508) is added to the EtherCAT master.
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XTS module
After the CU2508 Ethernet port has been added to the EtherCAT
master, the modules of the infeed line must be added.

Example module with feed
Since a module with feed has to be added to the EtherCAT master
first, the addition of a module is shown with an AT2001-0250 module
with feed as an example.

Modules with feed are marked with with feed in the selection list.

► Expand Solution Explorer > TwinCAT Project > I/O > Devices
► Right-click on Device (EtherCAT) to open the context menu
► Click Add New Item... in the context menu

The Insert Device dialog box opens.
► Expand Beckhoff Automation GmbH & Co. KG > XTS
► Select AT2001-0250 Motor module with feed 250 mm, 48 V
► If required, enter a name for the module in the input field Name
► Confirm with OK
A Term (AT2001-0250) is added to the EtherCAT master.
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XTS sensor channel
A sensor channel must be added to each module.

Example sensor channel for module with feed
The addition of a sensor channel is shown with an AT0250-5250 as
an example. It belongs to an AT2001-0250 module with feed.

► Expand Solution Explorer > TwinCAT Project > I/O > Devices >
Device (EtherCAT)

► Right-click on Term (AT2001-0250) to open the context menu
► Click Add New Item... in the context menu

The Insert Device dialog box opens.
► Expand Beckhoff Automation GmbH & Co. KG > XTS
► Select AT2001-5250 Sensor line with feed
► If required, enter a name for the sensor channel in the input field

Name
► Confirm with Ok 
A Term (AT2001-5250) is added to the module Term
(AT2001-0250).

After the sensor channel has been added to the module with feed,
all further modules of the infeed line can be added to the EtherCAT
master.
► Add all further modules of the infeed line with a corresponding

sensor channel in the same way
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6.1.4.4 Link TcCom objects
Once all objects have been created, some links have to be created
in order to be able to exchange data between the objects.

Modules and I/O objects
The modules must be linked to the corresponding I/O objects.

NOTICE
Careful linking
To ensure that the system can be started without problems, pro-
ceed carefully and in sequence when linking the modules to the I/
O objects.
Incorrect linking can cause problems when starting the system.

Control
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (XtsProcessingUnit) > Object (XtsPart) >
Object (AT2001-0250) > Data Pointer

► Right-click on Control to open the context menu
► Click on Change Link… in the context menu

The Attach Variable Control dialog box opens.
► Expand Solution-Explorer > TwinCAT Project > I/O > Devices >

Devices (EtherCAT) > Term 2 (AT2001-0250)
► Select Control
► Confirm with OK

A gray arrow on the variable indicates successful linking.
Further information can be found in chapter "Linking details", [Page
 57].
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CurrentSetpointValues
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (XtsProcessingUnit) > Object (XtsPart) >
Objekt (AT2001-0250) > Data Pointer

► Select CurrentSetpointValues[0] to CurrentSetpointVal-
ues[14] from top to bottom

► Right-click on the top variable of the selection to open the con-
text menu

► Click Change Multi Link…  in the context menu

The Attach Variable 30.0 Byte(s) dialog box opens.
► Expand Solution-Explorer > TwinCAT Project > I/O > Devices >

Devices (EtherCAT) > Term 2 (AT2001-0250)
► Check checkbox at All Types
► Select Current setpoint value Ch.1 to Current setpoint value

Ch.15
► Confirm with OK

A gray arrow on the variable indicates successful linking.
Further information can be found in chapter "Linking details", [Page
 57].
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Status
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (XtsProcessingUnit) > Object (XtsPart) >
Object (AT2001-0250) > Data Pointer

► Right-click on Status to open the context menu
► Click on Change Link… in the context menu

The Attach Variable Status dialog box opens.
► Expand Solution-Explorer > TwinCAT Project > I/O > Devices >

Devices (EtherCAT) > Term 2 (AT2001-0250)
► Select Status
► Confirm with OK

A gray arrow on the variable indicates successful linking.
Further information can be found in chapter "Linking details", [Page
 57].

CurrentActualValues
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (XtsProcessingUnit) > Object (XtsPart) >
Objekt (AT2001-0250) > Data Pointer

► Select CurrentActualValues[0] to CurrentActualValues[14]
from top to bottom

► Right-click on the top variable of the selection to open the con-
text menu

► Click Change Multi Link…  in the context menu
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The Attach Variable 30.0 Byte(s) dialog box opens.
► Expand Solution-Explorer > TwinCAT Project > I/O > Devices >

Devices (EtherCAT) > Term 2 (AT2001-0250)
► Check checkbox at All Types
► Select Current actual value Ch.1 to Current actual value

Ch.15
► Confirm with OK

A gray arrow on the variable indicates successful linking.
Further information can be found in chapter "Linking details", [Page
 57].

RawPositionValues
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (XtsProcessingUnit) > Object (XtsPart) >
Objekt (AT2001-0250) > Data Pointer

► Select RawPositionValues[0] to RawPositionValues[31] from
top to bottom

► Right-click on the top variable of the selection to open the con-
text menu

► Click Change Multi Link…  in the context menu
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The corresponding Value Channels to the RawPositionValues are
located in the added term of the XTS sensor channel. Be sure to se-
lect the correct term when linking.

The Attach Variable 64.0 Byte(s) dialog box opens.
► Expand Solution-Explorer > TwinCAT Project > I/O > Devices >

Devices (EtherCAT) > Term 3 (AT2001-0250)
► Check checkbox at All Types
► Select Value Channel 01 to Value Channel 32
► Confirm with OK

A gray arrow on the variable indicates successful linking.
Further information can be found in chapter "Linking details", [Page
 57].
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Linking details
After successful linking of the modules TcCom objects with the
physical modules of the I/O, the linking is indicated by gray arrows
at the individual Data Pointer variables of the TcCom objects. You
now have the option to view more details about the linking.

Linking example
This chapter uses a successful control linking as an example to
show you how to display the details of the linking.

► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects > Object (XtsProcessingUnit) > Object (XtsPart) >
Objekt (AT2001-0250) > Data Pointer

► Double click on Control

► Click on the Variable tab in the project window
Details of the linking are displayed at Linked to....
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TcCom objects Mover and Motion
To be able to control the movers, the setpoints of the movers must
be calculated. For this purpose, each TcCOM object Mover must be
linked to an NC axis.

Create corresponding TcCom objects Mover with TC1250 and
TF5020
To link the TcCom objects with the NC axes, corresponding XTS
Mover software objects must be created with the software TC1250 |
TwinCAT 3 PLC/NC PTP 10 and TF5020 | TwinCAT 3 NC PTP Axes
Pack unlimited. For more information, please see the following links:

Direct link to documentation TC1250 | TwinCAT 3 PLC/NC
PTP 10

Direct link to the documentation TF50x0 | TwinCAT 3 | NC
PTP

NOTICE
Careful linking
To ensure that the system starts smoothly, proceed carefully and
sequentially when linking the movers to the Motion objects.
Incorrect linking can cause problems when starting the system.

SoftDrive Input
The position setpoints and dynamics setpoints for the mover are
provided for the calculation.

► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects > Object (XtsProcessingUnit) > Object (XtsMover)
> Inputs

► Right-click on SoftDriveInput to open the context menu
► Click on Change Link… in the context menu

https://infosys.beckhoff.com/content/1033/tc1250_tc3_plc_ncptp/index.html?id=4414599728561591270
https://infosys.beckhoff.com/content/1033/tc1250_tc3_plc_ncptp/index.html?id=4414599728561591270
https://download.beckhoff.com/download/Document/automation/twincat3/TF50x0_TC3_NC_PTP_DE.pdf
https://download.beckhoff.com/download/Document/automation/twincat3/TF50x0_TC3_NC_PTP_DE.pdf
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The Attach Variable SoftDriveInput (Output) dialog box opens.
► Expand MOTION > NC-Task 1 SAF > Axes > Axis 1 >

Axis 1_Obj (CTcSoftDrive)
► Select InputPointer
► Confirm with OK

A gray arrow on the variable indicates successful linking.

Linking details
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (XtsProcessingUnit) > Object (XtsMover)
> Inputs

► Double-click on SoftDriveInput

► Click on the Variable tab in the project window
Details of the linking are displayed at Linked to….



Functions of the driver

60 ─── Version: 1.1.1TF5850

SoftDrive Output
The actual values for the position and dynamics of the mover are
provided for the application.

► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects > Object (XtsProcessingUnit) > Object (XtsMover)
> Outputs

► Right-click on SoftDriveOutput to open the context menu
► Click on Change Link… in the context menu

NOTICE
For SoftDrive Output linking, make sure that you select the same
mover that you used for SoftDrive Input linking.

The Attach Variable SoftDriveOutput (Input) dialog box opens.
► Expand MOTION > NC-Task 1 SAF > Axes > Axis 1 >

Axis 1_Obj (CTcSoftDrive)
► Select OutputPointer
► Confirm with OK

A gray arrow on the variable indicates successful linking.
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Linking details
► Expand Solution-Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (XtsProcessingUnit) > Object (XtsMover)
> Outputs

► Double-click on SoftDriveOutput

► Click on the Variable tab in the project window
Details of the linking are displayed at Linked to….
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6.1.4.5 Required settings
Once the linking has been completed, further settings are required
for the TcCom objects, Motion objects and I/O objects before the
XTS system can be put into operation.
If the XTS Configurator was used to create the XTS system, the re-
quired settings have been created automatically.

Processing Unit
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects
► Double-click on Object (XtsProcessingUnit)

► Click the Parameter (Init) tab in the project window
► Expand General
► Select OperationMode Normal or Simulation in the drop-down

menu

► Expand Mover
► Select the appropriate mover in the drop-down menu MoverType

► Select the corresponding magnetic plate set of the mover in the
drop-down menu MagnetPlateType

► Expand Mover ID Detection
► In the drop-down menu IdDetectionMode, select whether no, one

or several Mover 1 are used on the XTS system
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► Expand Teaching
► Select TRUE in the IsTeachingEnabled drop-down menu
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Modules
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (ProcessingUnit)
► Double-click on Object (AT2xxx-0xxx)

► In the project window click on the Context tab
► Select the appropriate task from the Task drop-down menu

The PositionIndex defines the position of the module in the XTS
system. The first module has the hardware position 0, the other
modules are counted in ascending order. The number of modules
minus one gives the hardware position for the last module.

► Click the Parameter (Init) tab in the project window
► Expand General
► Enter a continuous value in the PositionIndex input field, starting

with 0 for the first module
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► Select the module used in the drop-down menu MotorTermi-
nalOID

► Select sensor channel in the SensorTerminalOID drop-down
menu
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Track
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > Object (ProcessingUnit)
► Double-click on Object (XtsTrack)

► Click the Parameter (Init) tab in the project window
► Expand General
► Select TRUE in the IsClosed drop-down menu if the system is

closed
OR
► Select FALSE in the IsClosed drop-down menu if the system is

open

► Select TRUE in the drop-down menu IsIncludedInDetection if the
track is included from Mover ID detection

OR
► Select FALSE in the drop-down menu IsIncludedInDetection if

the track is excluded from Mover ID detection

► In the column Units of the drop-down menu select the number of
parts that are included in the track

► Expand PartConfigItems
► In the ObjectId drop-down menu, select the part or parts that be-

long to the track
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Mover
When creating movers manually, a universal mover object is in-
serted by default. In addition to the selection of the mover type, the
start position of the mover must also be determined.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects > Object (XtsProcessingUnit)

► Double-click on Object (XtsMover)

► In the project window click on the Context tab
► Select the task in the Task drop-down menu

► Click the Parameter (Init) tab in the project window
► Expand Simulation
► In the SimulatedStartUpPart drop-down menu select a part on

which the mover is to start

► Enter the exact position of the mover on the part in the Simulat-
edStartUpPosition input field
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NC axis
► Expand Solution Explorer > TwinCAT Project > MOTION > NC-

SAF 1 Task > Axes
► Double click on Axis 1

► In the project window click on the Settings tab
► Click Link To I/O…

The dialog box Select I/O Box/Terminal opens.
► Select the corresponding SoftDrive (Object) from the list
► Confirm with OK

When the SoftDrive is selected, the Axis Type automatically
changes to SoftDrive (Object).

► In the project window click on the Parameter tab
► Expand Maximum Dynamics
► Enter the value 4200.0 in the input field Reference Velocity
► Enter the value 4000.0 in the input field Maximum Velocity
► Enter the value 80000.0 in the input fields Maximum Accelera-

tion and Maximum Deceleration
► Expand Default Dynamics
► Enter the value 20000.0 in the input fields Deafult Acceleration

and Default Deceleration
► Enter the value 200000.0 in the input field Default Jerk
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► Expand Solution Explorer > TwinCAT Project > MOTION > NC-
Task 1 SAF > Axes > Axis 1

► Double click on Enc

► In the project window click on the Parameter tab
► Expand Encoder Evaluation
► Enter the value 3000 in the input field Modulo Factor
► Enter the value 0.2 in the input field Tolerance Window for Mod-

ulo Start
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SoftDrive
► Expand Solution Explorer > TwinCAT Project > MOTION > NC-

Task 1 SAF > Axes > Axis
► Double click on Axis 1_Obj1 (CTcSoftDrive)

► In the project window click on the Context tab
► Select the appropriate task from the Task drop-down menu

► Click the Parameter (Init) tab in the project window
► Expand General
► Enter the value 3000.0 in the input field Hardware Modulo

NOTICE
Configuration of existing hardware components
All objects must correspond to the existing hardware components
so that the configuration can be used in simulation and operation.

Once all objects correspond to the desired XTS system, the configu-
ration can be used in the simulation. If required, modules and ob-
jects can be added or removed for a pure simulation project without
existing hardware.
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6.1.5 Compatibility mode
The compatibility mode allows you to switch from the previous XTS
Manager of software versions up to version 3.18.715.0 to the
TF5850  | TwinCAT 3 XTS Extension without having to reconfigure
the XTS system. The old XTS Manager can still be used with all
functions. Old versions of the XTS Utility Library, the XTS Tools as
well as the XTS Viewer and the XTS Support Assistant will still work
after the update.

Please note that while using the compatibility mode, the new func-
tions, such as XTS Track Management and the Leave and Arrive
functionality, or some new functions for simulation and visualization
are not available. To extend your XTS system and use the new func-
tions, you must convert your current configuration of XTS objects
into a new project. Further information can be found in chapter "Con-
version of old XTS system", [Page 72].

Old configuration New configuration

To activate the new XTS software after the change, you only need
to reload the XTS TcCOM objects. The old configuration and the
XTS system work as usual without adjusting the project. Further in-
formation can be found in chapter "Reload TcCom objects", [Page
 23].
During operation, a hidden new configuration is created in the back-
ground using the new object structure XTS Parts and XTS Tracks,
which is internally linked to the old objects. This configuration can be
seen in the Online Objects tab.
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6.1.6 Conversion of old XTS system

Please note that while using the compatibility mode, the new func-
tions of the XTS Track Management as well as the Leave and Arrive
functionality or some new functions for simulation and visualization
are not available. To extend your XTS system and use the new func-
tions, you must convert your current configuration of XTS objects
into a new project.

When converting an old XTS system up to software version
3.18.715.0, the following areas must be adjusted and carefully con-
trolled, as only small changes in these areas produce large effects
in the entire project:
• XTS TcCOM objects
• NC axes and SoftDrives
• XTS Utility Library

Example configuration
The conversion of an old system and the associated project is de-
scribed using a closed system with 180° curves and four movers as
an example.

To be safe, make a copy of your project before starting the conver-
sion. It cannot be guaranteed that the following steps can be applied
one hundred percent to every project. If you have difficulties with the
conversion, contact the product specialist responsible for your re-
gion.
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6.1.6.1 Removing old XTS Task and XtsIoDriver TcCOM object
First, the XTS Task and the structure of the XtsIoDriver TcCOM ob-
ject must be removed from the old project.

If required, create a list of the most important settings of the XtsIo-
Driver TcCOM object so that you can apply them later to the XTS
Processing Unit object.

XTS Task
► Expand Solution Explorer > TwinCAT Project > SYSTEM >

Tasks
► Right-click on XTS Task to open the context menu
► In the context menu click Remove

XtsIoDriver TcCOM object
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects
► Right-click on Object (XtsIoDriver) to open the context menu
► In the context menu click Remove
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Execute TMC Reload

If not already done, a TMC Reload must be performed. Further infor-
mation can be found in chapter "Compatibility mode", [Page 71].

► In the project window click on the Project Objects tab
► Select all objects
► Right-click the selected objects to open the context menu
► Click on Reload TMI/TMC Description(s) in the context menu

Creating a new XTS TcCOM structure
To convert an old XTS system, a new XTS system must first be con-
figured. To do this, activate the XTS Tool Window. Further informa-
tion can be found in chapter "Activation of the XTS Tool Window",
[Page 224].
Start configuring the system. Further information can be found in
chapter XTS system configuration. If required, you can set new pa-
rameters such as stations or simulation parameters for the movers
already during configuration.
When configuring the movers, you can either accept the existing NC
axes and SoftDrives or create new ones. Taking over the existing
NC axes has the advantage that you do not have to set new links to
the PLC. Furthermore, all tuning parameters and settings of the NC
axes are taken over.

Reuse of NC axes

The Add Movers for existing Axes? dialog box opens only if there
are fewer movers than old NC axes in the new project.

The Add Movers for existing Axes? dialog box opens.
► Select all NC axes for which movers are to be created
► Confirm with OK
Note that the order in which the movers are selected has an influ-
ence on which mover is linked to which NC axis.
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Once the configuration has been completed, all configured TcCOM
objects are displayed in the project tree of the Solution Explorer.
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6.1.6.2 Reuse XtsIoDriver parameters
Special parameters, such as Mover 1 functionality, that you set un-
der the old XtsIoDriver object can be set in the XTS Processing Unit
object. In the XTS Processing Unit object you will find the setting op-
tions for all old parameters.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects

► Double click on XtsProcessingUnit
► Click the Parameter (Init) tab in the project window
► Check settings
► If necessary enter the settings of the old XTS project
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6.1.6.3 Adjusting the cycle time of the XTS task

The cycle time of the new XTS task must be set to 250 µs.

► Expand Solution Explorer > TwinCAT Project > SYSTEM
► Double-click on Real-Time 

► In the project window click on the Settings tab
► Ensure that the XTS task is running on the correct RT-Core
► If required, change RT-Core via the drop-down menu
► Ensure that the Base Time is set to 250 µs
► If required, set Base Time value to 250 µs via the drop-down

menu
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► Expand Solution Explorer > TwinCAT Project > SYSTEM >
Tasks

► Double-click on the new XTS Task 

► In the project window click on the Task tab
► Enter the value 1 in the input field Cycle ticks or set it using the

arrow keys

For more information on the required Real Time settings, please re-
fer to the relevant documentation or contact the product specialist
responsible for your region.
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6.1.6.4 Check of NC axes and SoftDrive parameters
New NC axes If you use new NC axes, all previous parameters must be taken over

from the old XTS project. The parameters can either be added man-
ually or imported in the XTS Configurator as a parameter set of the
movers. For more information on all available parameters for the NC
axes and the SoftDrive, refer to the SoftDrive documentation.

The new NC axes must be linked to the PLC:

► Expand Solution Explorer > TwinCAT Project > MOTION >
NC SAF

► Double click on Axes

► In the project window, select all axes that are to be linked to the
PLC

► Right-click the selected axes to open the context menu
► In the context menu click on Change Axis PLC Links...

The Select Axis PLC Reference dialog box opens.
► Select the PLC with which the axes are to be linked
► Confirm with OK

The Modulo Factor for the NC axes and the SoftDrive must be set to
the correct length of the system:

► Expand Solution Explorer > TwinCAT Project > MOTION > NC
SAF > Axes

► Expand the axis whose settings are to be adjusted
► Double click on Enc
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► In the project window click on the Parameter tab
► Expand Encoder Evaluation
► Ensure that the Modulo Factor is set to the length of the current

system
► If required, enter the length of the current system in the input

field Modulo Factor

► Expand Solution Explorer > TwinCAT Project > MOTION > NC
SAF > Axes

► Expand the axis whose settings are to be adjusted
► Double click on SoftDrive

► Click the Parameter (Init) tab in the project window
► Expand General
► Ensure that the HardwareModulo value is set to the length of

the current XTS system
► If required, enter the length of the current system in the input

field HardwareModulo
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Existing NC axes

If you use existing NC axes from your old project, you must check
the parameter PositionFeedbackMode of the corresponding Soft-
Drive object. Incorrect settings can result in a changed behavior of
the NC position.

► Expand Solution Explorer > TwinCAT Project > MOTION > NC
SAF > Axes

► Expand the axis whose settings are to be adjusted
► Expand SoftDrive
► Double click on SoftDriveEncoder

► Click the Parameter (Init) tab in the project window
► Expand General
► Ensure that the PositionFeedbackMode is set to MOD-

ULO_START
► If required, select MODULO_START in the PositionFeedback-

Mode drop-down menu
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6.1.6.5 Replace old XTS Utility calls
As the structure of the XTS objects in the project has changed fun-
damentally during the conversion, the structure of the XTS Utility
has also been changed. In the new configuration the old calls of the
function blocks FB_XtsUnit and FB_XtsVisuDiag do not work cor-
rectly anymore.
Because the ADS read commands and write commands refer to
other object IDs in the background, it is not possible to read data
from or write data to the XtsIoDriver object. The XtsUnit structure
does not allow access to the data of the corresponding XTS objects,
such as the Module CoE data.
Each XTS Utility call to the PLC must be checked and replaced with
a new function to obtain the desired values. It is necessary to find all
the places where the old XtsUnit structure was used and determine
the values that were written or read there.
Many of the old calls to the XtsUnit structure can be replaced with
the XTS Environment structure method.
A basic example of what needs to be changed in the structure is the
procedure for Mover ID detection:

//MoverId Functionality
//check whether the position detection of the Movers has been completed.
IF fbXtsUnit.stXtsUnit.stTcIoXtsDrv.stParameter.bAreAllMoverPositionsValid THEN

    //Check if “MoverIdDetectionMode” has been activated under the XtsIoDriver object
    IF fbXtsUnit.stXtsUnit.stTcIoXtsDrv.stParameter.eMoverIdDetectionMode =
E_MoverIdDetectionMode.Mover1
        //and that we are not running in simulation.
        AND NOT bSimulation
        THEN
            //Check whether the “MoverIdDetection” has already been started or the Mover1 was found.
            IF NOT (bMoverIdDetectionStarted OR bMoverIdDetected)
            THEN
                //Trigger the “MoverIdDetection”.
                fbXtsUnit.stXtsUnit.stTcIoXtsDrv.ipTcXtsIo.TriggerMoverIdDetection();
                // “bMoverIdDetectionStarted” is set to “True” after a single initiation.
                bMoverIdDetectionStarted := TRUE;
            END_IF

//Check for error or success of “MoverIdDetection”.
bMoverIdDetectionError := fbXtsUnit.stXtsUnit.stTcIoXtsDrv.stParameter.bHasMoverIdDetectionError;
bMoverIdDetected := fbXtsUnit.stXtsUnit.stTcIoXtsDrv.stParameter.bIsMoverIdDetectionValid;

//Do not process any further until the “MoverId” was detected.
IF NOT bMoverIdDetected THEN
RETURN;
END_IF
// If the “MoverIdDetection” was not activated in the XtsIoDriver object or running in simulation,
// then the activation of the “MoverIdDetection” and the search of Moer1 is skipped.
ELSE
;
END_IF

//If not all Mover positions are valid, do not process any further.
ELSE
RETURN;
END_IF
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In the old configuration, some calls to the Mover ID detection got the
information of the XtsIoDriver object using the XtsUnit structure:

Since the XtsIoDriver object is not present in the new configuration,
the calls must be adapted so that the XtsEnvironment structure pro-
vides the information of the XtsProcessingUnit object for the calls:

In this way, many of the calls can be replaced. It should be noted
that the XtsEnvironment structure differs from the old XTS structure
in terms of initialization and collection of cycle data. Further informa-
tion can be found in chapter "Add library", [Page 428].
Once all XtsUnit calls have been removed from the project, the con-
figuration can be activated.
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6.1.6.6 Activating the configuration
When you have made all changes in the project, you can activate
the configuration, switch to the operation mode and start the PLC. If
you have difficulty during activation, contact the product specialist
responsible for your region.
If all calls have been replaced correctly, there will be no differences
in the operation of the XTS system compared to the old configura-
tion. In addition, all new functions for simulation and visualization
are now usable and the project is ready for future updates of the
XTS driver.
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6.2 XTS Simulation functionality
The simulation functionality allows you to test a system without us-
ing real hardware. Further information can be found in chapter "XTS
Simulation Builder", [Page 229].

6.2.1 Activating simulation mode
When you configure a system with the XTS Simulation Builder, the
simulation mode is automatically activated and it is not necessary to
manually activate the simulation mode.

► Expand Solution Explorer > TwinCAT Project > SYSTEM >
TcCOM Objects

► Double click on XtsProcessingUnit

► Click the Parameter (Init) tab in the project window
► Expand General
► Select Simulation in the drop-down menu OperationMode
► Set all other XTS Processing Units that are to run in simulation

mode to simulation mode in the same way

Beckhoff recommends disabling the corresponding hardware of the
XTS system in the I/O configuration to avoid accidental activation.
All virtual devices must be disabled to activate an I/O configuration
without existing hardware.
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6.2.1.1 Disabling Devices
► Expand Solution Explorer > TwinCAT Project > I/O > Devices
► Right-click on a Device to open the context menu
► Click Disable in the context menu
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6.2.2 Important simulation settings
There are important parameters to be set under the TcCOM objects
to determine how the simulation behaves when the XTS system is
started. By default, the simulation behaves like a real system. For
example, no XTS movers will be found if there are no XTS tracks in
the detection process, or no axes can be activated if Mover ID de-
tection has not been started.

6.2.2.1 XTS Mover Simulation Parameters
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > XtsProcessingUnit
► Double-click Mover 1

► Click the Parameter (Init) tab in the project window
► Expand Simulation
► In the SimulatedStartUpPart drop-down menu, select the part on

which the mover is to start
► Enter the value for the start position of the mover in the input

field SimulatedStartUpPosition
► Enter the value 1 in the input field SimulatedStartUpId so that the

mover is detected as Mover 1 at startup
OR
► Do not enter a value in the input field SimulatedStartUpId so that

the mover is detected as a standard mover
These entries can also be made in the XTS Configurator and in the
XTS Simulation Builder on the Movers page. For more information,
see the chapters "XTS Configurator", [Page 258] and "XTS Simula-
tion Builder", [Page 229].
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XTS Simulation Builder
► Expand the sidebar and click on Configure

► Click on the tab Movers
► Select the mover for which the settings are to be adjusted

► Expand Details
► Enter the start position of the mover in the input field Start-Up

Position
► In the Start-Up Part drop-down menu, select the part on which

the mover is to start
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XTS Configurator
► Fold out the sidebar and click on Movers

► Expand Mover List
► Select the mover for which the settings are to be adjusted
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► Expand Mover Details to show the Simulation Start-Up Settings
► In the drop-down menu Part, select the part on which the mover

is to start
► Enter the start position of the mover in the input field Position
► Enter 1 in the input field ID so that the mover is detected as

Mover 1 when starting up
OR
► Do not enter a value in the input field ID so that the mover is de-

tected as a standard mover

Parameter (Init)

Parameter Group Type PTCID Explanation
SimulatedStartUpPart Simulation OTCID 0x03080278 Determines the part on

which the mover starts in
simulation mode.

SimulatedStartUpPosi-
tion

Simulation LREAL 0x03080279 Determines the position of
the selected part at which
the mover is in simulation
mode.
Any position between 0 and
the length of the part is pos-
sible. The mover will not be
found if other values are
used.
Unit: mm

SimulatedId Simulation STRING(3) 0x0308027E Determines which ID the
mover should have when the
XTS system is in simulation
mode and a Mover ID detec-
tion is started.

• 1 The mover is detected as
Mover 1 in the simulation.

• - The mover is detected as a
standard mover in the simu-
lation.
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6.2.2.2 XTS Processing Unit Parameter
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects
► Double click on XtsProcessingUnit

► Click the Parameter (Init) tab in the project window
► Expand Simulation
► Select TRUE or FALSE in the drop-down menu IsPosition-

NoiseEnabled and IsRandomStartUpEnabled
► Enter a value in the input fields MoverDistance, PositionOffset,

PositionNoiseBandwidth and RandomStartUpBandwidth
► Select parameters for the start position of the movers in the

drop-down menu PositionStartUpSimulationMode
► Select parameters for the Mover ID in the drop-down menu

MoverIdStartUpSimulationMode
► Select the type of random distribution in the drop-down menu

RandomInitMode
► Enter a value in the input field RandomInitMode
Further information can be found in chapter "Parameter (Init)", [Page
 91].

6.2.2.2.1 Parameter (Init)

Parameter Group Type PTCID Explanation
MoverDistance Simulation LREAL 0x0308022E Determines the distance be-

tween the movers when the
PositionStartUpSimulation-
Mode UseOffsetAndDistance
is selected.
If the distance is too great,
the movers will not fit on the
XTS system and will there-
fore not be found.
Unit: mm

PositionOffset Simulation LREAL 0x0308022D Determines the position of
the first mover when the Po-
sitionStartUpSimulationMode
UseOffsetAndDistance is se-
lected.
If the offset is too large, the
movers will not fit on the XTS
system and will therefore not
be found.
Unit: mm
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Parameter Group Type PTCID Explanation
PositionNoiseBandwidth Simulation LREAL 0x03080231 Determines the maximum

deviation of the simulated
position delay of the movers
when the position noise is
activated in the simulation.
Unit: mm

RandomStartUpBand-
width

Simulation LREAL 0x03080232 Determines the maximum
deviation of the start position
between the movers when
the PositionStartUp simula-
tion mode UseOffsetAndDis-
tance is selected.
If the bandwidth is too large,
the movers will not fit on the
XTS system and will there-
fore not be found.
Unit: mm

PositionStartUpSimula-
tionMode

Simulation XTS.PositionStartUp-
SimulationMode

0x03080230 Determines which parameter
provides the start position of
the mover in the simulation.

• UseOffsetAndDistance – – – The parameter of the Tc-
COM object ProcessingUnit
is used

• UseMoverParameters – – – The parameter of the Tc-
COM object Mover is used

• UseRandomDistribu-
tion

– – – The movers are distributed
randomly.

MoverIdStartUpSimula-
tionMode

Simulation XTS.MoverIdStartUp-
SimulationMode

0x0308027D Determines which parameter
provides the Mover ID in the
simulation.

• UseRandomDistribu-
tion

– – – The movers get their ID ran-
domly according to the set-
tings of the parameters IdDe-
tectionMode and Expected-
MoverIds.

• UseMoverParameters – – – The parameter of the Tc-
COM object Mover is used.

• UseAlternation – – – The movers receive their ID
one after the other, starting
at 1.

RandomInitMode Simulation XTS.RandomInit-
Mode

0x0308027F Determines how the random
distribution is applied.

• UseSystemTime – – – Creates a value based on
the system time.

• UseInitSeed – – – Use of the value at parame-
ter RandomInitSeed.

RandomInitSeed Simulation DINT 0x03080280 Determines the number for
the random distribution if the
RandomInitMode UseInit-
Seed is selected.
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6.3 Mover 1 functionality
Mover  1 serves as the reference mover of the XTS system. It is
equipped with a special magnetic plate set. The special magnetic
plate set Mover 1 is identified by an engraving on the set itself and a
logo on the encoder flag.

6.3.1 Mover ID detection
During Mover ID detection, all movers are set in motion, barely visi-
ble, and reordered by the system. Since Mover 1 exhibits different
behavior than the other movers due to its special magnetic plate set,
it is automatically detected by the system. In this way, a clear as-
signment of the mover hardware to the NC axis is possible.
If the setting StartAtFirstMover is selected at the parameter Mover-
PositionAssignment, the Mover  1 always has either the largest or
the smallest position of all NC axes. If this is not yet the case after
startup, standard detection and successful Mover ID detection, the
complete system length is added to the position of single movers. 

Example position calculation

Planned Mover 1
position

Parameter Mover-
SortOrder

Mover 1 Mover 6

Positions in the NC axes before Mover ID detection [mm]
Smallest position Ascending 360 27
Largest position Descending 40 280
Positions in the NC axes during Mover ID detection [mm]
Smallest position Ascending - 27 + 3000 system length
Largest position Descending 40 + 3000 system length -
Positions in the NC axes after Mover ID detection [mm]
Smallest position Ascending 360 3027
Largest position Descending 3040 280

Planned Mover 1
position

Parameter Mover-
SortOrder

Positions in the NC axes [mm] Mover 1 Mover 6

Smallest position Ascending Before Mover ID detection 360 27
During Mover ID detection – 27 + 3000

system
length

After Mover ID detection 360 3027
Largest position Descending Before Mover ID detection 40 + 3000

system
length

280

During Mover ID detection 360 3027
After Mover ID detection 3040 280
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Planned Mover 1
position

Parameter
MoverSort-
Order

Positions in the NC
axes before Mover ID
detection

Positions in the NC
axes during Mover ID
detection

Positions in the NC
axes after Mover ID de-
tection

Mover 1 Mover 6 Mover 1 Mover 6 Mover 1 Mover 6
Smallest position Ascending 360 mm 27 mm – 27 mm +

3000 mm
system
length

360 mm 3027 mm

Largest position Descending 40 mm 280 mm 40 mm +
3000 mm
system
length

– 3040 mm 280 mm

48 V power supply required
The 48 V power supply is required to perform Mover ID detection.
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6.3.2 Application in XTS Processing Unit object

6.3.2.1 Parameter

If you use the compatibility mode, you can control the Mover ID de-
tection as usual via the TcIoXtsDrv object. For this, follow the de-
scriptions below for the application in the XTS Processing Unit ob-
ject. In case of discrepancies between the two objects, it will be indi-
cated separately.

Mover ID detection is controlled via the XTS Processing Unit object.
You have the possibility to make settings via general parameters 
and to trigger the Mover ID detection manually without having to add
a PLC project.
The following parameters are available for settings and for checking
in the XTS Processing Unit object or in the TcIoXtsDrv object:

XTS Processing Unit object
Parameter Explanation
IdDetectionMode Setting whether one or more Movers 1

are present in the system.
MoverPositionAssignment Setting that the Mover 1 receives the

largest or smallest position of the NC
axes on the system depending on the
sort order.

ExpectedMoverIds
[0].Id Configure the expected mover IDs for

ID detection mode MultipleMover 1.
• 1 Mover with magnetic plate set Mover 1.
• 0 Mover with magnetic plate set Mover

Standard.
[0].Count Number of expected Movers 1.
TriggerMoverIdDetection Manual start of Mover ID detection.
HasIdDetectionError Display whether an error has occurred

during Mover ID detection.
IsIdDetectionValid Display whether Mover 1 was detected.
IsIdDetectionActive Display whether Mover ID detection is

running.

TcIoXtsDrv object
Parameter Explanation
MoverIdDetectionMode Setting whether a Mover 1 is present in

the system.
MoverPositionAssignment Setting that the Mover 1 receives the

largest or smallest position of the NC
axes on the system depending on the
sort order.

TriggerMoverIdDetection Manual start of Mover ID detection.
IsMoverIdDetectionValid Display whether Mover 1 was detected.
HasMoverIdDetection-
Error

Display whether an error has occurred
during Mover ID detection.
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MoverIdDetection
► Expand Solution Explorer > XtsProject > SYSTEM > TcCOM Ob-

jects
► Double click XtsProcessingUnit

Parameter (Init)
► Click the Parameter (Init) tab in the project window
► Expand MoverIdDetection

 WARNING
Risk of injury due to unforeseen movements
If you do not select a parameter even though there is one or
more movers with the special Mover 1 magnetic plate set on the
system, the movers will be energized incorrectly and the movers
may move unpredictably.
Unforeseen movements of the movers can cause serious injuries
to fingers due to crushing and damage to tools and the machine.
• Select the parameter Mover1 or MultipleMover1.

► Select Mover1 or MultipleMover1 in drop-down menu IdDetec-
tionMode

To apply the settings, the configuration must be reactivated and the
TwinCAT system must be restarted.
► Restart TwinCAT

► Select StartAtFirstMover in the drop-down menu MoverPosi-
tionAssignment

To apply the settings, the configuration must be reactivated and the
TwinCAT system must be restarted.
► Restart TwinCAT
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► Expand ExpectedMoverIds
► Select 1 (Array Elements) or 2 (Array Elements) in the drop-

down menu ExpectedMoverIds in the column Unit
► Enter the Mover ID type in the input field [0].Id
► Enter the number of expected Movers 1 in the input field

[0].Count

► Right-click in the input field TriggerMoverIdDetection to open the
context menu

► In the context menu click Download
The Mover ID detection is now manually triggered. All movers start
the movement.

Parameter (Online)
► In the project window click on the Parameter (Online) tab

► Check result at HasIdDetectionError:

TRUE
Mover 1 was not detected. Possible causes:
• Mover ID detection was not started
• IsIdDetectionValid displays FALSE

FALSE
Mover 1 was detected. No errors occurred.

► Check result at IsIdDetectionValid:

TRUE
Mover 1 was detected. No errors occurred.

FALSE
Mover 1 was not detected. Possible causes:
• Mover ID detection was not started
• HasIdDetectionValid displays TRUE
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If the Mover ID detection has failed:
► Check notifications in the message windows Error List and Out-

put
► Activate the hidden parameter "DetectionInfoMessage", [Page

 110]
► Adapt the parameter in the "TcSoftDrive object", [Page 107]
► Adjust hidden parameters of the XTS Processing Unit
► Perform Mover ID detection again

► Check result at IsIdDetectionActive

TRUE
Mover ID detection is active. No errors occurred.

FALSE
Mover ID detection is not active. Possible cause:
• Mover ID detection is not active

Check Mover IDs
After the Mover IDs have been detected, you can call and check
them via the Processing Unit or the Mover object:
Under the Processing Unit you will find the Mover IDs for all movers
under the following path:
Parameter (Online) > Mover ID Detection > MoverIds

Under the Mover object, you will find the Mover IDs for each mover
individually under the following path:
Parameters (Online) > Mover ID Detection > Id
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6.3.2.2 Hidden Parameters
For the advanced operation of the Mover ID detection you have the
option to use Hidden Parameters . For example, you can change the
time delay with which movers are moved within a pack and define
the intervals at which movers are detected as a pack. However, usu-
ally the default parameters match your XTS system. The Mover ID
detection can be started immediately. The search takes a few sec-
onds and depends on the number of movers and the respective set-
tings.
The following hidden parameters are available for settings:

IdDiagConfiguration Calculation parameters of Mover ID detection. Do not change!

DelayBetweenMoversInPack Time delay [s] between triggering movers which are directly next to
each other within the MoverPackGap. Unit: s.

DelayBetweenMoverPacks Time delay [s] between triggering movers simultaneously which are
not in the same mover pack. Unit: s

GapToDefineMoverPack Gap [mm] between movers to define a new mover pack. Unit: mm

CompleteCriteria Setting, from when a search should be evaluated as successful.

► Activate the check box Show Hidden Parameter to show the
Hidden Parameters

To prevent movers mechanical influencing one another, only the
movement of one mover is triggered at any one time in a mover
pack. On expiry of the search of a preceding mover in a pack and on
expiry of the time DelayBetweenMoversInPack, the search for the
next mover in the pack is started.



Functions of the driver

100 ─── Version: 1.1.1TF5850

6.3.3 Use in the PLC

6.3.3.1 Versions
Via the PLC you have the possibility to trigger the Mover ID detec-
tion  by using the program code. Two options are available for this:

PLC variant I (trigger via XtsUtility)
Start Mover ID detection by calling the method TriggerMoverIdDe-
tection.

PLC variant II (trigger via ADS-Write)
Start of Mover ID detection by an ADSWRITE command on the pa-
rameter TriggerMoverIdDetection in the XTS Processing Unit object.

Observe computing time
The call of the PLC variant I requires more computing time. If the
computing time for the application proves to be a problem, use the
PLC variant II.

Add library
For the application of the PLC variant I (trigger via XtsUtility) the
suitable library must be added:

Name for file path different
When creating the library under PLC, a name must be assigned. In
the following example, no name has been assigned, so the file path
is shown as Untitled. Note that your file path will look different ac-
cordingly.

► Expand Solution Explorer > TwinCAT Project > PLC > Untitled1
> Untitled Project

► Right-click on References to open the context menu
► In the context menu click on Add library ...

The dialog box Add Library opens.
► Expand (Miscellaneous)
► Click on Tc3_XTS_Utility
► Confirm with OK
The library is added to the project.
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► Expand Solution Explorer > TwinCAT Project > PLC > PLC1 >
PLC Project > References

► Check whether the Tc3_XTS_Utility library has been added to
the project

Depending on whether the Processing Unit object or the TcIoXtsDrv
object is used, the functions in the library differ.
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PLC variant I (trigger via XtsUtility)
You have the option to trigger the Mover ID detection via PLC vari-
ant I. To trigger the search automatically, you can use the following
sample codes for the Processing Unit object or the TcIoXtsDrv ob-
ject:

XTS Processing Unit object

// Declaration Part
PROGRAM MAIN
VAR
     stMoverRef                       : ARRAY [1..cAxcnt] OF AXIS_REF;

     fbXtsUnit                        : FB_XtsUnit;

     eMoverIdDetectionMode            : MoverIdDetectionMode:= MoverIdDetectionMode.Mover1; 
                                        //Should be the same as shown in the TcIoXtsDrv object
     bStartMoverIdDetection           : BOOL := TRUE; //Can also be written to trigger the process
                                        manually after start up

     bMoverIdDetectionError           : BOOL;
     bMoverIdDetected                 : BOOL;
     bMoverIdDetectionActive          : BOOL;
END_VAR

VAR CONSTANT
     cAxcnt                           : INT:=10; // Example
END_VAR

//----------------------------------------------------------------------------------------------------

// Programm Part
// Cyclic call of the main block of the XtsUtility Library.
fbXtsUnit(Axis := stMoverRef);

// Check if the position detection of the Movers has been completed.
IF NOT fbXtsUnit.stXtsUnit.stTcIoXtsDrv.stParameter.bAreAllMoverPositionsValid THEN
     // If not all Mover positions are valid, do not process any further.
     RETURN;
END_IF

// Mover1 Functionality
// Check if "MoverIdDetectionMode" has been activated.
IF eMoverIdDetectionMode = E_MoverIdDetectionMode.Mover1 THEN

     // Check if the "MoverIdDetection" has already been started or the Mover1 was found.
     IF bStartMoverIdDetection AND NOT (bMoverIdDetectionActive OR bMoverIdDetected) THEN
          bStartMoverIdDetection:=FALSE;

          // Trigger the "MoverIdDetection".
          fbXtsUnit.stXtsUnit.stTcIoXtsDrv.ipTcXtsIo.TriggerMoverIdDetection();
          bMoverIdDetectionActive:=TRUE;
     END_IF

     // Check for error or success of "MoverIdDetection".
     bMoverIdDetectionError := fbXtsUnit.stXtsUnit.stTcIoXtsDrv.stParameter.bHasMoverIdDetectionError;
     bMoverIdDetected       := fbXtsUnit.stXtsUnit.stTcIoXtsDrv.stParameter.bIsMoverIdDetectionValid;

     // If the detection has an error, check for errors in output and try again.
     IF bMoverIdDetectionError THEN
          bMoverIdDetectionActive:=FALSE;
          RETURN;
     END_IF

     // Do not process any further until the "MoverId" was deteced.
     IF NOT bMoverIdDetected THEN
          RETURN;
     END_IF
     bMoverIdDetectionActive:=FALSE;

// If the "MoverIdDetection" was not activated,
// then the start of the "MoverIdDetection" and the search of Mover1 is skipped.
ELSE
     ;
END_IF
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TcIoXtsDrv object

// Declaration Part
PROGRAM MAIN
VAR
     fbXtsEnvironment                 : FB_TcIoXtsEnvironment;
     bInit                            : BOOL;

     bStartMoverIdDetection           : BOOL:=TRUE; // Can also be written to trigger the process
                                        manually after start up

     bMoverIdDetectionError           : BOOL;
     bMoverIdDetected                 : BOOL;
     bMoverIdDetectionActive          : BOOL;
END_VAR

//----------------------------------------------------------------------------------------------------

// Programm part
//Trigger only once in init.
IF NOT bInit THEN
     IF fbXtsEnvironment.Init(TRUE) THEN
          fbXtsEnvironment.Init(FALSE);
          bInit:=TRUE;
     END_IF
     RETURN;
END_IF

// Check if the position detection of the Movers has been completed.
IF NOT fbXtsEnvironment.XpuTcIo(1).GetAreAllPositionsValid() THEN
     // If not all Mover positions are valid, do not process any further.
     RETURN;
END_IF

// Mover1 Functionality
// Check if "MoverIdDetectionMode" has been activated under the XtsProcessingUnit object.
IF fbXtsEnvironment.XpuTcIo(1).GetMoverIdDetectionMode() = MoverIdDetectionMode.Mover1 THEN

     // Check if the "MoverIdDetection" has already been started or the Mover1 was found.
     IF bStartMoverIdDetection AND NOT (bMoverIdDetectionActive OR bMoverIdDetected) THEN
          bStartMoverIdDetection:=FALSE;

          // Trigger the "MoverIdDetection".
          fbXtsEnvironment.XpuTcIo(1).TriggerMoverIdDetection();
     END_IF

     // Check for error or success of "MoverIdDetection".
     bMoverIdDetectionError := fbXtsEnvironment.XpuTcIo(1).GetHasMoverIdDetectionError();
     bMoverIdDetected := fbXtsEnvironment.XpuTcIo(1).GetIsMoverIdDetectionValid();
     bMoverIdDetectionActive := fbXtsEnvironment.XpuTcIo(1).GetIsMoverIdDetectionActive();

     // If the detection has an error, check for errors in output and try again.
     IF bMoverIdDetectionError THEN
          RETURN;
     END_IF

     // Do not process any further until the "MoverId" was deteced.
     IF NOT bMoverIdDetected THEN
          RETURN;
     END_IF

     // Do not process any further until the "MoverId" was deteced.
     IF NOT bMoverIdDetected THEN
          RETURN;
     END_IF

// If the "MoverIdDetection" was not activated in the XtsProcessingUnit object,
// then the activation of the "MoverIdDetection" and the search of Mover1 is skipped.
ELSE
     ;
END_IF
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PLC variant II (trigger via ADS-Write)
You have the option to trigger the Mover ID detection via PLC vari-
ant II. Parameters of the XTS Processing Unit object can be ac-
cessed via ADSREAD or ADSWRITE commands.
For more information, please see the following links:

Direct link to the TE1000 TwinCAT 3 manual | PLC library:
Tc2_System

Direct link to the function blocks

You need the following XTS-specific information for parameteriza-
tion:

Parameter Code block Explanation
Task Port PORT : T_AmsPort; Task Port of the XTS task.
Object Id IDXGRP : UDINT; Object ID from the XTS

Processing Unit object.
PTCID IDXOFFS : UDINT; PTCID of the parameter.

► Expand Solution Explorer > TwinCAT Project > SYSTEM >
Tasks

► Double-click on XTS Task

► In the project window click on the Task tab
► Read value at Port
The value 350  is preset by default.

https://download.beckhoff.com/download/Document/automation/twincat3/TwinCAT_3_PLC_Lib_Tc2_System_DE.pdf
https://download.beckhoff.com/download/Document/automation/twincat3/TwinCAT_3_PLC_Lib_Tc2_System_DE.pdf
https://infosys.beckhoff.com/content/1033/tcplclib_tc2_system/4566798475.html
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Object Id
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects
► Double-click on XTS Processing Unit

► In the project window, click on the Object tab
► Read value at Object Id

PTCID
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects
► Double-click on XTS Processing Unit
The displayed values of the XTS Processing Unit object and the
TcIoXtsDrv object differ from each other.

► Click the Parameter (Init) tab in the project window
► Read value at TriggerMoverIdDetection
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Sample TriggerMoverIdDetection
Below are sample codes for a TriggerMoverIdDetection:

ADSWRITE

// Declaration part
PROGRAM MAIN
VAR
     fbAdsWrite     : ADSWRITE;
END_VAR

//----------------------------------------------------------------------------------------------------

// Programm part
fbAdsWrite(
     NETID      := ´´,
     PORT       := 350,               // Taskport of the XTS-Task
     IDXGRP     := 16#01010010,       // Object Id of the driver object
     IDXOFFS    := 16#205,            // PTDCID of TriggerMoverIdDetection
     WRITE      := TRUE);             // Trigger

ADSREAD

// Declaration part
PROGRAM MAIN
VAR
     fbAdsRead     : ADSREAD;
     TempData      : BOOL; // Needs to be the data type that is read
END_VAR

//----------------------------------------------------------------------------------------------------

// Programm part
fbAdsRead(
     NETID      := ´´,
     PORT       := 350,               // Taskport of the XTS-Task
     IDXGRP     := 16#01010010,       // Object Id of the driver object
     IDXOFFS    := 16#251,            // PTDCID of IsIdDetectionValid
     LEN        := SIZEOF(TempData),  // Size of the read out data
     DESTADDR   := ADR(TempData),     // Address to which the data should be written to
     READ       := TRUE);             // Trigger
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6.3.4 Extended operation in the TcSoftDrive object

6.3.4.1 Parameter
The Processing Unit object is used to control and execute the Mover
ID detection for each mover axis. You have the possibility to adjust
the sequence of the search, by setting some parameters as well as
configuring the detection procedure via the mover axis. However,
usually the default parameters match your XTS system.
The following tables show the default parameters for the Beckhoff
movers:

Parameter Default Min Max Unit Tab
DetectionMinMovement 0.1 0.01 2.0 mm Init
DetectionFilter 250 0 5000 Hz Init
DetectionCurrentRamp 25 10 1000 mA/ms Init
DetectionMaxCurrent 12 0.5 13 A Init

Adjustment of the default parameters with customer-specific
movers
With customer-specific movers that differ from the Beckhoff movers
in terms of rigidity, mass or some other deviating mechanical behav-
ior, it may be necessary to adjust the default parameters in order to
optimize the Mover ID detection.

DetectionMinMovement Minimum position change that the mover must experience during
Mover ID detection for detection to be successful.

DetectionFilter Filter for current change.

DetectionCurrentRamp Ramp of the current of the Mover ID detection.

DetectionMaxCurrent Maximum value of the current of the Mover ID detection.

DetectionStatus Status of Mover ID detection.

► Expand Solution Explorer > TwinCAT Project > MOTION > NC
SAF > Axes > Mover Axis > SoftDrive > Data Pointer

► Double click on FeedForward_Obj6 (CTcSdFeedForward)
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Parameter (Init)
► Click the Parameter (Init) tab in the project window
► Expand MoverIdDetection

► If necessary, reduce the value for the minimum position change
during Mover ID detection in the input field DetectionMinMove-
ment to reduce the position change of the movers

OR
► If necessary, increase the value for the minimum position

change during Mover ID detection in the input field DetectionMin-
Movement to increase the position change of the movers

► If necessary, reduce the value for the current change filter in the
input field DetectionFilter to build up the current more slowly and
make Mover ID detection smoother

OR
► If necessary, increase the value for the current change filter in

the input field DetectionFilter to build up the current more quickly
and make Mover ID detection more jerkily

► If necessary, change the DetectionCurrentRamp value for the
ramp of the Mover ID detection current

► If necessary, change the DetectionMaxCurrent value for the limit
of the Mover ID detection current
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Parameter (Online)
► In the project window click on the Parameter (Online) tab
► Check result at DetectionStatus:

OFF
Mover ID detection is not used.

ACTIVE
Mover ID detection is running.

ERROR
Mover ID detection failed.

FOUND_Standard
The standard magnetic plate set was found for a specific mover.

FOUND_Mover1
The magnetic plate set Mover 1 was found for a specific mover.
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6.3.4.2 Hidden Parameters
For the advanced operation and configuration of the Mover ID de-
tection you have the option to use Hidden Parameters. For example,
you can adjust various waiting times of the movers.
The following table shows the default parameters:

Hidden Parameters Default Min Max Unit Tab
DetectionStandstillVelocityLimit 15 1 1000 mm/s Init
DetectionStandstillSwitchTime 0.015 0.00 1.0 s Init
DetectionTimeOut 2 0 10 s Init
DetectionInfoMessage FALSE FALSE TRUE -- Init

► Activate the checkbox Show Hidden Parameter to show the
Hidden Parameters

DetectionStandstillVeloc-
ityLimit

Definition of the maximum velocity for the standstill monitoring.
Value < default parameter:
The search changes to the next phase later.
Value > default parameter:
The search changes to the next phase earlier.

DetectionStandstillSwitchTime Time in which the velocity of the mover must be below the value of
the parameter DetectionStandstillVelocityLimit .
Value < default parameter:
The search is accelerated.
Value > default parameter:
The search is decelerated.

DetectionTimeOut Total timeout for the Mover ID detection. An error occurs if this time
is reached. Possible causes:
• too little movement due to too small a value in the input field De-

tectionMaxCurrent
• missing 48 V power supply
• too large a value in the input field DetectionMaxMovement
• too small a value in the input field DetectionMaxMovement

You should always be able to achieve the DetectionMinMovement
with the default parameter DetectionMaxCurrent.

DetectionInfoMessage Messages are displayed in the TwinCAT output window.
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6.3.5 Detection phases of Mover ID detection
The following figures show the effects of the parameters of a Mover
ID detection. Phases 1 to 4 are mapped with the default parameters
as an example.

6.3.5.1 Phase 1
► Set first current vector

Position Explanation
1 The absolute value of the current vector is increased in accordance with the parameter Detection-

CurrentRamp.
2 The movement is monitored until the value of the DetectionMinMovement parameter is reached.
3 The current is decreased via a filter, defined by the DetectionFilter parameter.
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6.3.5.2 Phase 2
► Wait until the mover comes to a standstill again

Position Explanation
1 Wait until the velocity is below the limit set with the parameter DetectionStandstillVelocityLimit.
2 The velocity must lie continuously below the limit velocity for the time set with the parameter Detec-

tionStandstillSwitchTime.
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6.3.5.3 Phase 3
► Set a second current vector in the opposite direction

Position Explanation
1 The absolute value of the current vector is increased in accordance with the parameter Detection-

CurrentRamp.
2 The movement is monitored until the value of the DetectionMinMovement parameter is reached.
3 The current is decreased via a filter, defined by the DetectionFilter parameter.
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6.3.5.4 Phase 4
► Wait until the mover comes to a standstill again

Position Explanation
1 Wait until the velocity is below the set limit of the parameter DetectionStandstillVelocityLimit.
2 The velocity must lie continuously below the limit velocity for the time set with the parameter Detec-

tionStandstillSwitchTime.
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6.4 Teaching functionality

6.4.1 Teaching at standstill
Teaching at standstill is an additional function that can be used to
calibrate the null value signal of sensors on XTS modules.
All sensor values are recorded from modules on which no mover is
present that could affect the sensors. The recorded values are
saved in a special teaching file that is used to set the real values to
0. If, for example, a sensor of a module on which no mover is
present returns 500, this value is recorded and saved so that the off-
set has to be -500 to achieve the null value.
Teaching at standstill can be performed to eliminate interfering ef-
fects on the module and to achieve improved accuracy and im-
proved detection of the movers.

NOTICE
Pay attention to the revision number
Modules with a sensor revision level of ≥ 18 are already compen-
sated in production. Additional teaching is only necessary if the
accuracy has to be improved or if there are problems with the de-
tection of the movers.
Modules with a sensor revision level of ≤  17 must be manually
compensated in order to start the system and detect the movers.

Pay attention to the type of system
Teaching at standstill can only be used with the XTS Standard sys-
tem and is not available for the XTS Hygienic system.

6.4.1.1 Activating teaching
► Click the Parameter (Init) tab in the project window
► Expand Teaching
► Select TRUE in the drop-down menu  IsTeachingEnabled  to en-

able teaching
You also have the option of enabling teaching in the XTS Configura-
tor. Further information can be found in chapter "Teaching", [Page
 265].
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6.4.1.2 Enter the number of the teaching file
Teaching must be enabled in order to enter the number of the teach-
ing file.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects

► Double click on XtsProcessingUnit

Change teaching file number
Always change the number of the teaching file before commenc-
ing with a new teaching. The old file will be used and overwritten
if the number of the teaching file is not changed or if the configu-
ration is not loaded.
Beckhoff recommends using the current date for the number of
the teaching file. For the first teaching on April 3rd, 2021, for ex-
ample, the numbers 202104031 could be used and for the sec-
ond teaching on the same day the numbers 202104032 and so
on.

► Click the Parameter (Init) tab in the project window
► Expand Teaching
► Enter the number of the teaching file in the input field Teaching-

FileNumber
You also have the option of changing the TeachingFileNumber in
the XTS Configurator. Further information can be found in chapter
"Teaching", [Page 265].

► Click the ActivateConfiguration button to activate the configu-
ration and load the number of the teaching file
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6.4.1.3 Selecting the teaching mode
Before teaching at standstill, you must define the teachingSelection
parameter with which the teaching is to be executed. The selection
of the parameters decides which module has to be entered in the in-
put field .selectionString.

ExcludeSpecifiedItems Modules on which a mover is present should be excluded from the
teaching. The corresponding module numbers must be entered in
the input field .selectionString.

IncludeSpecifiedItems Modules on which there are no movers are included in the teaching.
The corresponding module numbers must be entered in the input
field .selectionString.

► Expand StartStandStillTeaching
► Select ExcludeSpecifiedItems in the drop-down menu .teach-

ingSelection to exclude modules with movers from the teaching
OR
► Select IncludeSpecifiedItems in the drop-down menu .teach-

ingSelection to include modules without movers into the teaching

Pay attention to distances
Teaching a module on which a mover is present can lead to in-
correct compensation of a neighboring module if the distance be-
tween the mover and the edge is too small.

► Make sure that the encoder flag of a mover does not affect the
teaching of an empty module.

2020

1 2

It is important when selecting the teachingSelection parameter that
the distance between the encoder flag [1] of a mover and the outer
edge [2] of an empty module is at least 20 mm.
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6.4.1.4 Entering the module

The module number can be found in Solution Explorer > TwinCAT
Project > SYSTEM > TcCOM Objects > XtsProcessingUnit > Part >
Module.

► Enter the module number in the input field of .selectionString
The module numbers can be entered using the characters - and , or
a combination of both characters, for example 1‑4, 1,2,3,4 or 1‑3,4.

► Click the Parameter (Init) tab in the project window
► Enter the hardware position in the input field PositionIndex
The first module has the hardware position 0.

6.4.1.5 Starting teaching
After selecting the teaching mode and entering the respective mod-
ule, the teaching can be started.

► Right-click in the input field StartStandStillTeaching to open the
context menu

► In the context menu click Download
The teaching is started and takes a few seconds.
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The messages Teaching is started and Teaching is stopped appear
in the message window Error List.

If the message […] are not in the expected range
(-600.000000, 600.000000) appears, the modules are not compen-
sated and have a sensor revision level of ≤ 17.
If the message Mover lost errors appears:
► Check whether the correct teaching mode has been entered in

the drop-down menu teachingSelection
► Check whether the correct modules have been entered in the in-

put field .selectionString
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If warnings are displayed in the Error List or Output message win-
dows, there may be a problem with your module's encoder. Contact
the product specialist responsible for your region.

The teaching is complete as soon as all empty modules have been
compensated. Depending on the number of modules, the movers
and the teaching mode, teaching must be repeated several times
until each module has been calibrated empty. In the IncludedSpeci-
fiedItems mode, check that there are no movers on the modules en-
tered in the input field selectionString.
The configuration must be activated again after checking and cor-
recting the entries.

► Click on the button Activate Configuration to activate the con-
figuration

Messages appear in the Error List message window indicating that
the teaching file was loaded and the plausibility check was success-
ful.

If the teaching file was not loaded and the plausibility check was not
successful:
► Check which messages are displayed at Output

If warnings are displayed in the Error List or Output message win-
dows, there may be a problem with your module's encoder. Contact
the product specialist responsible for your region.
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If TwinCAT is in Run mode, the result of the teaching can also be
checked in the project window on the Parameter (Online) tab.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects

► Double click on XtsProcessingUnit

► In the project window click on the Parameter (Online) tab
► Expand Teaching
If the teaching file has been overwritten, the parameter IsTeach-
ingChanged indicates TRUE.
If the teaching was valid and the teaching file was loaded correctly,
the parameter IsTeachingValid indicates TRUE.
If the teaching file uses the latest version, the parameter IsTeach-
ingFileUpToDate indicates TRUE.

6.4.1.6 Teaching file update
An already saved teaching that was created with an older software
version can be used by the latest software version.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects

► Double click on XtsProcessingUnit

► In the project window click on the Parameter (Online) tab
► Expand Teaching
► Check the online status of the parameter IsTeachingFileFor-

matUpToDate
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If the online status of the parameter IsTeachingFileFormatUpToDate
indicates FALSE:

► Click the Parameter (Init) tab in the project window
► Expand Teaching
► Right-click in the input field TriggerTeachingFileFormatUpdate to

open the context menu
► In the context menu click Download

If the download was successful, the parameters IsTeachingValid
and IsTeachingFileFormateUpToDate indicate TRUE.
If the download was unsuccessful, the parameters IsTeachingValid
and IsTeachingFileFormateUpToDate indicate FALSE and an error
message is displayed in the Error List message window.
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6.5 Track Management functionality
With the Track Management functionality, an XTS system can be
split into individual, spatially separated track sections. Moving track
sections, for example, allow movers to switch between two fixed but
spatially separated track sections. On the moved track sections,
both the movers and the modules have their full functionality and re-
main as a full track.
An XTS system with Track Management requires more advanced
programming to move the movers and monitor their position than an
XTS standard system because the movers no longer travel con-
stantly on a single closed track and their sequence changes as they
move to other tracks.

6.5.1 Closed XTS system

In a closed XTS system, the sequence of modules and movers al-
ways remains constant. The movers thus have only one possible
track on which they can move.

6.5.2 XTS system with Track Management

In an XTS system with Track Management, modules can change
their position and align with other modules. In this way, new tracks
are created and the order of the movers changes.
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6.5.3 Requirements
In order to use an XTS system with Track Management, some soft-
ware and hardware requirements must be met.

6.5.3.1 Software
The following software versions must be available on your system:

Software Version
TwinCAT 3 3.1.4024.0 or higher
TF5850 | TwinCAT 3 XTS Extension 3.20.700.0 or higher
TF5400 TwinCAT 3 Advanced Motion Pack 3.1.10.14 or higher

6.5.3.2 Hardware
To implement XTS Track Management, you need at least one mod-
ule with AT2002‑0249 connector in addition to several modules, to
enable an air gap between the modules for the moving track section.
In addition, one or more movers and a suitable mechanical system
for the moving track section, such as a spindle axis or linear motor,
are required.
The following components must be present in your XTS system to
use Track Management:
• At least one shortened module with connector AT2002‑0249
• Cables with connectors
• Mover: AT9011-0x70, AT9014-0x70 or external Mover

For more information, refer to the chapter "Configuration setup",
[Page 125] and the XTS original operating instructions:

Direct link to the XTS original operating instructions

https://download.beckhoff.com/download/document/motion/xts_ba_de.pdf
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6.5.4 Configuration setup
In contrast to a closed XTS system, an XTS system with Track Man-
agement differs significantly in its structure with fixed and moving
track sections. In order for a track section to be moved, an air gap is
required between the moving and fixed track sections. The required
air gap can be realized by using shortened modules and corre-
sponding guide rails.

6.5.4.1 Traversing axes for moving track sections

The interlocking of the Beckhoff guide rails enables a track section
to be moved in the X-direction and Y-direction. Movement in the Z-
direction is not possible due to the interlocking of the guide rails.
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For moving a track section in X-direction and Y-direction or in Z-di-
rection, parallel guide rails from third party manufacturers must be
used, which do not interlock.
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6.5.4.2 Air gap
The required air gap can be realized with one or two AT2002-0249
modules. This module is 1 mm shorter than a standard XTS module
and allows an air gap of 1 mm or 0.5 mm on both sides.

For an XTS system with Track Management with Beckhoff guide
rails, two AT2002-0249 modules are used as modules with a length
of 250 mm. This results in a gap of 1 mm on both sides of the mov-
ing track section.
Due to the interlocking of the Beckhoff guide rails, this air gap is
large enough to move the track section and small enough to move
the movers without problems.
The air gap must be entered in the parameters. Further information
can be found in chapter "Enter air gap", [Page 135].

For a Track Management system without Beckhoff guide rails, an
AT2002-0249 module is used as a module with a length of 250 mm.
This results in a gap of 0.5 mm on both sides of the moving track
section.
The air gap must be entered in the parameters. Further information
can be found in chapter "Enter air gap", [Page 135].

NOTICE
Only one AT2002-0249 module for external guide rails
External guide rails may only be used with a single AT2002-0249
module, as the tolerances are lower. Rails that do not interlock
result in higher friction when passing over the physical air gap.

Contact the manufacturer of the external guide rail to clarify whether
the guide rail can be used for XTS Track Management.
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6.5.4.3 Mover

Only use Beckhoff 70 mm movers or external movers
Only Beckhoff movers with a length of 70 mm and external movers
that comply with the specified tolerances may be used for Track
Management.

Only the following movers are approved for Track Management:
• AT9011-0070
• AT9014-0070
• External movers

Contact the manufacturer of the external mover to clarify whether
the mover can be used for Track Management and whether the
mover and the guide system are suitable.

6.5.4.4 Cabling
Compared to a closed XTS system, an XTS system with Track Man-
agement uses more modules with feed, since each moving track
section requires its own feed.
For applications with more than 32 modules with feed, contact the
product specialist responsible for your region.
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6.5.4.5 Tracks
Based on parts, the exact position of the mover and its travel path is
determined. The different parts combine to form tracks on which the
movers travel.

Example with four parts
The composition of parts into tracks is illustrated using an XTS sys-
tem with four parts as an example

Further information can be found in chapter "XTS Configuration",
[Page 24].
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6.5.4.6 Variants for the mover organization
The order of the movers changes permanently due to the moved
track sections. Therefore, it is necessary to use object-oriented pro-
gramming to organize the movers within the system.
For example, the mover organization can take a local or a global ap-
proach. Furthermore, these approaches can be combined and the
advantages of both approaches can be used optimally.

Local approach
The local approach is suitable for an XTS system with:
• many movers
• many moving parts

This approach gives you the possibility to work with a small number
of tracks. In this example, the XTS system has ten possible tracks,
but only two tracks are used. Movers switch from one track to the
next in virtual stations.

The decisive factor when using the local approach is that collision
avoidance must be performed manually. When a mover changes
from one track to another, the remaining movers no longer detect
the mover on the moving track section, since collision avoidance is
track-based. The programmer must ensure that the movers are on
the correct track and do not collide with each other.
For more information on collision avoidance, see the chapter "Colli-
sion Avoidance functionality", [Page 140].
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Global approach
The global approach is suitable for an XTS system with:
• few movers
• few moving parts

This approach gives you the possibility to work without virtual sta-
tions and only with tracks. In this example, the XTS system has ten
possible tracks that are not simultaneously activated for the movers.
In this approach, the movers are switched to the correct track based
on the position of the moving track sections.

While the two outer track sections move, in this configuration all
parts are independent tracks. As soon as a moving track section
matches the upper module, a new configuration with a new track is
formed. In this example, Part  2, Part  3 and Part  4 together form
Track 5 and the movers automatically switch to this new track.
This global approach is suitable for a manageable number of
movers and tracks. The more moving track sections there are in
your XTS system, the more possible tracks there are. The exponen-
tial growth leads to the fact that at a certain point the number of pos-
sible configurations is too large and the global approach is unsuit-
able for this system.
The collision avoidance of the movers takes place without manual
testing and correctly.
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Activation of a new track stops active movement commands
The MC_ActivateTrack currently cancels the active movement com-
mand of all movers as soon as a new track is activated. The move-
ment command must then be reactivated manually. You must check
if it is possible to activate the new tracks for all movers, otherwise an
error will be thrown at the function block.

Mixed approach
The mixed approach combines the respective advantages of the lo-
cal and global approach. The XTS system is split into sections
where the tracks manage the movers globally. Each of these sec-
tions has a limited number of possible configurations that are easy
to configure. Collision avoidance can be used to its full extent.
Two globally organized sections are then interconnected with a vir-
tual station using the local approach, allowing movers to move from
one global system to the other.
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6.5.5 Programming of an XTS system with Track Management
Since the movers no longer travel constantly on a single closed
track, their continuous position, which is specified by the NC,
changes. Due to the moving track sections, it is possible for movers
to overtake each other. As a result, the starting positions of the
movers change and movers can have the same continuous position.
It is required that an XTS system with Track Management uses ad-
vanced programming to move and monitor the position of the
movers.

Standard XTS system

In a closed XTS system, each position exists only once. The maxi-
mum position corresponds to the length of the system. After the
mover has traveled the entire length once, it is started again at posi-
tion 0.
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XTS system with Track Management
For the position determination of the movers on an XTS system with
Track Management, the positions and the object IDs of all parts or
all tracks are required to avoid duplicate positions of movers.

If the position determination is only based on the position on a part,
Mover 1, Mover 2, Mover 3, Mover 4 and Mover 5 in this example all
have the same position of 190 mm. Only by combining PartPosition
and PartId is a single exact position determination for each mover
possible. Alternatively, the combination of TrackPosition and TrackId
can be used to determine the exact position of the movers, since
this combination also only exists once in the system.
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6.5.5.1 Enter air gap
The air gap for moving track sections realized with a shortened
AT2002-0249 module must be entered in TwinCAT. When entering,
please note from which side your system is displayed in TwinCAT.

If the XTS system is displayed in the view Front, the air gap [1] is lo-
cated on the left side of the module [2].
If the XTS system is displayed in the Back view, the air gap [1] is lo-
cated on the right side of the name plate [3] of the module [2].

Manual input or use of TwinCAT Tools
You have the option of creating the air gap manually or quickly and
easily via the TwinCAT Tools XTS Configurator and XTS Simulation
Builder.
For more information, see the chapters "XTS Configurator", [Page
 258] and "XTS Simulation Builder", [Page 229].

Enter manually
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Object > Object (XtsProcessingUnit)
► Double-click on Object (AT2002_0249)

► Click the Parameter (Init) tab in the project window
► Expand General
► Enter a value for the gap between the modules in the Gap input

field
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Enter in the XTS Configurator
► Open page Parts
► Click on the Modules tab
► Click on a module
► Enter a value for the gap between the modules in the Gap input

field

Enter in the XTS Simulation Builder
► Expand XtsProcessingUnit > Parts > Part 1 > Modules
► Click on a module
► Enter a value for the gap between the modules in the Gap input

field
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6.5.5.2 Enable track
The movers need activated tracks so that the XTS Driver gets the
information which coils have to be activated to move the movers. Af-
ter the start, all movers have their active track on which they are
found. You have the possibility to activate tracks manually by down-
loading the respective parameters with the TrackId. To activate an-
other track for a mover, the mover must be on a part of the XTS
track to be activated.

Read with XTS Utility library or ADS
The actual values for the position can be read using the XTS Utility
library or ADS.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects > XTSProcessingUnit

► Double-click on Object (XtsMover)

► In the project window click on the Parameter (Online) tab
► Expand General
► Right-click in the input field ActiveTrackObjectId to open the con-

text menu
► In the context menu click Download
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Read out in PLC
MC_ActivateTrack function block
The MC_ActivateTrack function block is used to activate a track.
The Execute command triggers an event and status bits can be read
to get feedback from the function block.
The function block can be used in the PLC and takes over the Track
Object ID from the track object. If the Track Object ID is set to 0, the
absolute reference system, which is used by default, can be reacti-
vated for the NC axis.
While the track for the mover is activated in the XTS driver in order
to be able to drive over the modules, the track is also activated as a
reference system in the NC. The reference system can then be used
for positioning in various motion functions, for example MoveAbso-
luteCA, HaltCA, GearInPosCA.
The axis must be part of a CA group for the function block to work.
The function block MC_ActivateTrack automatically cancels other
motion commands when they are triggered.
Further information can be found in the documentation TF5410
TwinCAT 3 | Collision Avoidance:

Direct link to the documentation TF5410 | TwinCAT 3 | Motion
Collision Avoidance

6.5.5.3 Determine track positions
Determining the position of the movers based on parts of a circulat-
ing track does not work for an XTS system with Track Management,
since the parts can be parts of different tracks. The MC_ReadTrack-
Positions function is used to determine the position and object ID of
all parts and all tracks. This information can be used to determine
the exact position of a mover in the system.

Read with XTS Utility library or ADS
The actual values for the position can be read using the XTS Utility
library or ADS.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects > XTSProcessingUnit

► Double-click on Object (XtsMover)

► In the project window click on the Parameter (Online) tab
► Expand Mover Detection > PositionInfo
► Read values for .partPosition, .trackPosition, .partObjectId

and .trackObjectId

https://download.beckhoff.com/download/document/automation/twincat3/tf5410_tc3_collision_avoidance_DE.pdf
https://download.beckhoff.com/download/document/automation/twincat3/tf5410_tc3_collision_avoidance_DE.pdf
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Read out in PLC
The MC_ReadTrackPosition function block can be used to transfer
setpoints from the NC to the PLC.

MC_ReadTrackPositions function block
This function block is different from the other motion function blocks.
Enable activates the function block and enables a cyclic reading
process of the positions. Status signals are read to get a feedback
from the function block.
The function block returns the current set positions of the parts and
tracks and the associated object IDs. The axis of the movers located
on the parts and tracks must be part of a CA group so that the func-
tion block returns valid values. If no track is activated for the axis,
the absolute setpoints, the track and the Part ID are returned with 0.
Further information can be found in the documentation TF5410
TwinCAT 3 | Collision Avoidance:

Direct link to the documentation TF5410 | TwinCAT 3 | Motion
Collision Avoidance

https://download.beckhoff.com/download/document/automation/twincat3/tf5410_tc3_collision_avoidance_DE.pdf
https://download.beckhoff.com/download/document/automation/twincat3/tf5410_tc3_collision_avoidance_DE.pdf
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6.5.5.4 Move to an absolute position
In the options of the motion command MC_MoveAbsoluteCA there
is a Position Reference System and a Dynamic Reference System
where the track on which the mover is located must be specified. By
entering the track, the motion profile is calculated correctly and re-
jected if necessary, if the motion profile is outside the limits of the
track. If the input of the track is missing, it is calculated against the
absolute system. If the part is entered instead of the track, it is cal-
culated against the part.

Read out in PLC
MC_MoveAbsoluteCA function block
This function block instructs a single axis to move to the absolute
position defined in the function block, based on collision avoidance.
Collision  avoidance has higher priority than the motion command.
Therefore, the axis may slow down or wait while the motion com-
mand is executed to avoid a collision. The function block does not
output the signal Done until the axis has reached its target position.
Further information can be found in the documentation TF5410
TwinCAT 3 | Collision Avoidance:

Direct link to the documentation TF5410 | TwinCAT 3 | Motion
Collision Avoidance

6.5.5.5 Collision Avoidance functionality
The Track Management supports the Collision Avoidance functional-
ity. Collision Avoidance works like a closed XTS system, but there
are a few special features to consider.
Only one CA group is required for an XTS system. Under the CA
group, there is a hidden domain management that manages the col-
lision avoidance for the different track combinations. Each track is
represented by a domain and the movers of this domain can avoid
collision among themselves. This means that collision avoidance
works exclusively on the basis of tracks.
If the movers travel on the same track, they recognize each other
and can automatically avoid a collision. If the movers are on differ-
ent tracks but on the same part, they will not recognize each other
and may collide without manual control.

Track-based collision avoidance
Currently, only a track-based collision avoidance calculation is avail-
able. A parts-based collision avoidance system is still under devel-
opment.

https://download.beckhoff.com/download/document/automation/twincat3/tf5410_tc3_collision_avoidance_DE.pdf
https://download.beckhoff.com/download/document/automation/twincat3/tf5410_tc3_collision_avoidance_DE.pdf
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6.6 Leave and Arrive functionality
The Leave and Arrive functionality enables dynamic adjustment of
the number of movers in an XTS system during operation. Movers
can be removed from the system for service work, for example, or
removed from the system and added again as required.

Current cycle rate of 60 movers per minute
Adding and removing movers is currently limited to a cycle rate of
60 movers per minute.

6.6.1 Examples

Service

With the Leave and Arrive functionality, movers can be removed
from the system for maintenance while the rest of the system re-
mains in operation.

Movers can be removed from the system if they are temporarily not
needed, for example, during a product change. Removed movers
can be added back to the system if necessary.
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Movers can leave the system, move to a track section without XTS
functionality and be added back to the system at another location.
Beckhoff recommends transport using simple conveyor technology
only for systems with a length of at least 30 m.
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6.6.2 Requirement
It is necessary to add an additional task so that the mover detection
can take place in parallel with the operation of the other modules
and movers.
The additional task is added during configuration with the XTS Con-
figurator. However, the additional task can also be added manually if
needed. Further information can be found in chapter "AUX Task for
the Leave and Arrive functionality", [Page 310].

6.6.2.1 Add additional task manually
► Expand Solution Explorer > TwinCAT Project > SYSTEM
► Right-click on Tasks to open the context menu
► Click Add New Item... in the context menu

The Insert Task dialog box opens.
► Enter a name for the task in the input field Name
► Confirm with OK

► Expand Solution Explorer > TwinCAT Project > SYSTEM >
Tasks

► Double-click on XTS Aux Task
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► In the project window click on the Task tab
► Make sure that the Cycle ticks are set to 0.250 ms
Further information can be found in chapter "Real-Time", [Page
 305].

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
Com Objects

► Double-click on XTSProcessingUnit

► In the project window click on the Context tab
► In the drop-down menu of Results ID 2 select XTS Aux Task

After a task has been added for mover detection, movers can be re-
moved using the Leave function or added again using the Arrive
function.
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6.6.3 System startup
After the system startup and the first mover detection, all detected
movers are switched to active. The first mover detection is required
and is automatic. After the first mover detection you have the possi-
bility to adjust the settings for further mover detections.

6.6.4 Leave function
The controllers of an active mover are switched on and the mover
may be integrated into a CA motion command, for example
MC_MoveAbsoluteCA. The mover must first be stopped and re-
moved from the control system before it can be removed from the
system.
For the removal of the mover, the control is switched off for the Tc-
COM object Mover using the PLC and the AXIS_REF interface.
Once the mover is passive via the XTS Utility, its information has
been reset to the default settings and its position is 0, it can be re-
moved from the system without the mover triggering an error. The
links of the mover to its corresponding SoftDrive object and to its NC
axis remain.
The diagram shows the structure of the Leave sequence required to
remove a mover from the system.
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6.6.4.1 Remove Mover

NOTICE
Errors in the control system and damage to movers and
modules due to incorrectly removed movers
If active movers are removed that are not in control, it can lead to
problems with the control system and the entire system can be
put into an error state.
• Remove from the system only passive movers that are not in

control and have been removed from the CA group.

Disabling movers
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > XtsProcessingUnit
► Double-click on the mover, which is to be removed from the sys-

tem

► Click the Parameter (Init) tab in the project window
► Expand Mover Detection
► Right-click in the input field TriggerLeave to open the context

menu
► In the context menu click Download

Checking the result
After the download, you can check whether the mover has been
successfully deactivated and whether the total number of movers
has decreased.

► In the project window click on the Parameter (Online) tab
► Expand Mover Detection
► Make sure the IsActive parameter is FALSE
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► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects

► Double click on XtsProcessingUnit

► In the project window click on the Parameter (Online) tab
► Expand Mover Detection
► Check if the number of movers has decreased at ActiveMover-

Count
If the mover is passive and the number of movers has decreased,
the mover can be removed from the system.
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6.6.5 Arrive function

Use Arrive function only to add movers
The Arrive function can only be used to add movers to an XTS sys-
tem that were previously removed using the Leave function or were
already passive when the system was started. It is not possible to
change the configuration of an XTS system with the Arrive function.

One or more passive movers must be activated, placed in control
and added to a group before they can be moved via a CA motion
command.
The links of the mover to its corresponding SoftDrive object and to
its NC axis already exist. The mover must be active, added to a
group, and on the correct track to be powered up and moved on the
system using the PLC and the AXIS_REF interface.

6.6.5.1 Structure
Adding movers can be done in two different ways:
• multiple movers
• single mover

The two Arrive sequences differ from each other in their structure.
The corresponding sequences can be found on the following pages.
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Multiple movers
The figure shows the structure of the required Arrive sequence to
add multiple passive movers to the system.

* Required if not all movers return to the system and/or a separate track is used for mover detection.
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Single mover
The figure shows the structure of the required Arrive sequence to
add a mover to the system.



Functions of the driver

Version: 1.1.1 ─── 151TF5850

6.6.5.2 Adding movers
You have the possibility to add several movers back to the system
at the same time with a mover detection. You can also add a single
mover in this way or use the variant for adding a single mover. With
the second variant, only a single mover can be added at a time and
not several movers at the same time. For more information on
adding a single mover, see the chapter "Single mover", [Page 153].

NOTICE
Errors in the control system and damage to movers and
modules caused by other movers
Only movers that match the configuration may be added. It is not
possible to add additional movers, a different type of mover or
movers with a different magnetic plate set, since it is not possible
to move these movers.
• Make sure to add only movers that match the configuration of

your system.

Multiple movers
If one or more movers are added, a new mover detection must be
started to find the movers. After you have defined how many movers
should be detected on which tracks, the mover detection can be
started.
Unlike the initial mover detection, a mover detection to add movers
is performed only once and is not repeated cyclically. Cyclic repeti-
tion only occurs if the corresponding parameter for repetition has
been adjusted.

Enabling movers

NOTICE
Errors in the control system and damage to movers and
modules caused by movers that are already in control
There must not be any movers on the track on which the mover
detection of additional movers is to be executed that are already
in control. Movers that are already in control can react uncontrol-
lably in the event of a mover detection and cause damage to
movers and modules.
• Make sure that there are no movers on the track for mover de-

tection of new movers that are already in control.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects

► Double click on XtsProcessingUnit
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► Click the Parameter (Init) tab in the project window
► Expand Mover Detection
► Enter the number of movers to be detected in the input field Con-

figuredDetectionCount
► Make sure that no movers that are in control are on the track that

is to be used for mover detection

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects > XtsProcessingUnit

► Click on the track to be used for mover detection

► Click the Parameter (Init) tab in the project window
► Expand General
► Select TRUE in the drop-down menu IsIncludedInDetection

► Double click on XtsProcessingUnit

► Right-click in the input field TriggerDetection to open the context
menu

► In the context menu click Download

Checking the result
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After downloading, you can check if the mover detection was suc-
cessful or if the number of passive and detected movers differs.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects

► Double click on XtsProcessingUnit

► In the project window click on the Parameter (Online) tab
► Expand Mover Detection
► Check if the number of active movers is correct at ActiveMover-

Count
► Check how many mover detections are displayed at Detection-

CycleCount
► Check whether the parameter DetectionState indicates Suc-

ceeded

For each mover it is possible to check whether it is active or pas-
sive. Only active movers are displayed in the XTS View. Passive
movers are not displayed in the XTS View because passive movers
remain undetected by the system.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects > XtsProcessingUnit

► Click on the mover whose state is to be checked

► Check whether the parameter IsActive indicates TRUE

Single mover

Simultaneous addition of multiple movers not possible
With this variant, only a single mover can be added to the system. If
you want to add multiple movers, you need to repeat the steps for
each mover or use the variant to add multiple movers. Further infor-
mation can be found in chapter "Multiple movers", [Page 151].
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A mover detection is needed to find a single mover and add it to the
system. Unlike the initial mover detection after system startup, a
mover detection to add movers is performed only once and is not re-
peated cyclically. Cyclic repetition only occurs if the corresponding
parameter for repetition has been adjusted.

Enabling movers
► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-

COM Objects > XtsProcessingUnit
► Click on the Mover to be activated

► Click the Parameter (Init) tab in the project window
► Expand Mover Detection
► In the drop-down menu ConfiguredDetectionTrackObjectId se-

lect the track on which the mover is located

► Right-click in the input field TriggerArrive to open the context
menu

► In the context menu click Download

Checking the result
► In the project window click on the Parameter (Online) tab
► Expand Mover Detection
► Check whether the parameter IsActive indicates TRUE
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6.6.6 Parameter
Special parameters of the XTS system can be set for the Leave and
Arrive functionality. The following tables contain all parameters that
can be assigned to the Leave and Arrive functionality.

6.6.6.1 Processing Unit

6.6.6.1.1 Parameter (Init)

Parameter Group Type PTCID Explanation
ConfiguredDetection-
Count

Mover Detection UDINT 0x030802B4 Sets the number of movers
for mover detection.

ConfiguredRetryCount Mover Detection UDINT 0x030802F1 Sets the number of repeti-
tions for mover detection if
not all configured movers are
detected.

TriggerDetection Mover Detection TriggerDetection 0x030802B5 When the TriggerDetection is
downloaded, a mover detec-
tion is performed for the
number of configured
movers on the configured
tracks.
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6.6.6.1.2 Parameter (Online)

Parameter Group Type PTCID Explanation
ActiveMoverCount Mover Detection UDINT 0x030802B7 Returns the number of active

movers.
AreAllPositionsValid Mover Detection BOOL 0x03080256 Returns TRUE if the posi-

tions of all movers are cor-
rect.

DetectionCycleCount Mover Detection UDINT 0x03080259 Returns the number of
mover detections.

DetectionCycleCountTo-
tal

Mover Detection UDINT 0x030802EC Returns the number of
mover detections since the
driver was started.

DetectionState Mover Detection XTS.DetectionSta-
teEnum

0x030802ED Returns the state of the
mover detection.

DetectedMoverCount Mover Detection UDINT 0x0308033E Returns the number of de-
tected movers currently on
the system.

DetectedMoverCount Mover Detection UDINT 0x03080257 Returns the number of
movers detected during the
last mover detection.

ExpectedMoverCount Mover Detection UDINT 0x03080258 Returns the number of ex-
pected movers - equal to the
number of created mover ob-
jects.

ScannedModuleCount Mover Detection UDINT 0x03080225 Returns the number of mod-
ules found during a mover
detection.
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6.6.6.2 Mover

6.6.6.2.1 Parameter (Init)

Parameter Group Type PTCID Explanation
ConfiguredDetection-
TrackObjectId

Mover Detection UDINT 0x030802F0 Sets the object ID of the
track on which the mover de-
tection is executed when
TriggerArrive is triggered.

TriggerArrive Mover Detection TriggerArrive 0x030802EE When TriggerArrive is down-
loaded, a mover detection is
performed for a mover on the
configured track. After suc-
cessful mover detection, the
mover becomes active.

TriggerLeave Mover Detection TriggerLeave 0x030802EF When TriggerLeave is down-
loaded, the active mover is
removed from the control.
The mover can no longer be
used and can be removed
from the system without trig-
gering an error.

6.6.6.2.2 Parameter (Online)

Parameter Group Type PTCID Explanation
IsActive Mover Detection BOOL 0x030802B6 Determines the value indicat-

ing whether the mover is ac-
tively used or is currently
passive. An active mover
can be removed from the
control if you plan to remove
it from the system.



Functions of the driver

158 ─── Version: 1.1.1TF5850

6.7 Parameter
Numerous parameters of the XTS system can be set with TwinCAT.
The following tables contain all parameters that can be assigned to
the TcCOM objects.

6.7.1 Processing Unit

6.7.1.1 Parameter (Init)

Parameter Group Type PTCID Explanation
OperationMode General OperationMode 0x0308022C Choose between 'Normal' to

work with actual hardware
and 'Simulation' to work in
simulation.
For more information, see
"OperationMode", [Page
 188].

MoverType Mover MoverType 0x00000090 Choose the appropriate
mover type. Use custom for
a non Beckhoff mover.
For more information, see
"MoverType", [Page 188].

MagnetPlateType Mover MagnetPlateType 0x00000091 Selection of the magnetic
plate set.
Attention! Choose the cor-
rect magnet plate type. If not
correct the mover can jump
unexpectedly.
For more information, see
"MagnetPlateType", [Page
 188].

MoverSortOrder Mover SetOrderEnum 0x00000048 Choose the sort order of the
movers.
For more information, see
"MoverSortOrder", [Page
 188].

MinMechanicalMover-
Distance

Mover LREAL 0x0308027A Gets/sets the minimum posi-
tion distance between the
movers, which has to be
measured in the curve. As a
default the distance belong-
ing to the mover type is
used.

IdDetectionMode MoverIdDetection MoverIdDetection-
Mode

0x03080246 Choose the ID detection
mode to enable Mover 1 de-
tection.
For more information, see
"IdDetectionMode", [Page
 189].

MoverPositionAssign-
ment

MoverIdDetection MoverPosition-
Assignment

0x03080253 Defines the lowest/highest
position
For more information, see
"MoverPositionAssignment",
[Page 189].
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Parameter Group Type PTCID Explanation
ExpectedMoverIds MoverIdDetection – 0x03080267 Configure the expected

mover IDs for ID detection
mode MultipleMover 1.
For more information, see
"ExpectedMoverIds", [Page
 189].

TriggerMoverIdDetection MoverIdDetection TriggerMoverIdDe-
tection

0x03080250 Triggers the Mover ID detec-
tion.
Attention! The axes con-
troller will be momentary en-
abled.

TeachingFileNumber Teaching UDINT 0x0308022A The number is appended to
the teaching file name - like
'TcIoXts.Teaching-
Data.0.bootdata'.
For more information, see
"Enter the number of the
teaching file", [Page 116].

StartStandStillTeaching Teaching – 0x03080228 On download the teaching is
started on the specified mod-
ules and will be stopped au-
tomatically.
For more information, see
"StartStandStillTeaching",
[Page 189].

StartMovementTeaching Teaching – 0x03080269 On download the teaching is
started. Then move movers
over every module.
For more information, see
"StartMovementTeaching",
[Page 190].

StopMovementTeaching Teaching StopMovement-
Teaching

0x03080270 On download the teaching
will be applied instanta-
neously.

IsAbortOnTeaching-
WarningsEnabled

Teaching BOOL 0x00000057 If set to TRUE then a teach-
ing warning causes that the
driver does not start up.
For more information, see
"IsAbortOnTeachingWarn-
ingsEnabled", [Page 190].

IsTeachingCheckSum-
CheckEnabled

Teaching BOOL 0x00000055 If set to TRUE then the spec-
ified check sum is used to
validate that the correct
teaching file is loaded and is
not corrupt.
For more information, see
"IsTeachingCheckSum-
CheckEnabled", [Page 190].
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Parameter Group Type PTCID Explanation
TeachingCheckSum Teaching – 0x00000054 Array of values of the teach-

ing check sum. After a new
teaching one can read (up-
load) the checksum from the
driver.
For more information, see
"TeachingCheckSum", [Page
 190].

TeachingWarningLevel Teaching TeachingWarn-
ingLevel

0x0308028C Specifies how strict the val-
ues of the teaching are
checked.
For more information, see
"TeachingWarningLevel",
[Page 191].
1 means very strict and
3 is the lowest level.

TriggerTeachingFileFor-
matUpdate

Teaching TriggerTeachingFile-
FormatUpdate

0x000000A9 Triggers the system to up-
date the teaching file format
of the given teaching file on
changing back to config
mode
(overwrites the old file).

IsAutoDumpWritingEn-
abled

Diagnostics BOOL 0x00000049 If enabled then the driver
writes dump files automati-
cally in certain situations (at
start up, in error cases).
For more information, see
"IsAutoDumpWritingEn-
abled", [Page 191].

IsInputCheckEnabled Diagnostics BOOL 0x03080283 Enables the plausibility
check of all input channels
on the system.
For more information, see
"IsInputCheckEnabled",
[Page 191].

WriteDump Diagnostics WriteDump 0x00000044 If downloaded manually then
the driver writes a dump file.

UsedEventLogger Diagnostics EventMessenger 0x000000A4 Specifies how events/mes-
sages are reported by the
driver.
For more information, see
"UsedEventLogger", [Page
 191].

EtherCatMasterSync-
TaskObjectId

Advanced OTCID 0x03080233 Set the object ID of the task
which is responsible for trig-
gering the EtherCAT master
which is set to independent
DC time.
Suggested when using the
16 port EtherCAT network
card.

IsCycleTimeWarning-
Suppressed

Advanced BOOL 0x00000046 If enabled then the warning
that the driver does not run
at 250 us is disabled.
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Parameter Group Type PTCID Explanation
IsMoverFrozenErrorActi-
vated

Advanced BOOL 0x00000097 If enabled then the mover
position is observed -
if it does not change for a
number of cycles then an er-
ror is issued.
For more information, see
"IsMoverFrozenErrorActi-
vated", [Page 192].

IsPositionBasedError-
ForwardingEnabled

Advanced BOOL 0x00000092 If enabled then a hardware
error is forwarded based on
the position to the movers
which are located on the
faulting modules.
For more information, see
"IsPositionBasedErrorFor-
wardingEnabled", [Page
 192].

Optimization Advanced OptimizationEnum 0x00000047 Optimizes the movers move-
ment or positioning slightly.
Standard is optimize posi-
tioning.
For more information, see
"Optimization", [Page 192].

TriggerRedetection Advanced TriggerRedetection 0x00000098 If downloaded then all
movers will loose their posi-
tion and a new detection is
performed. The order of
movers might change.

CalculateNormAmplitude Advanced BOOL 0x030802B1 If set to TRUE then the
mover's amplitude will be
normalized.

IsPositionNoiseEnabled Simulation BOOL 0x0308022F If enabled then a random
noise using the specified
bandwidth is added to the
mover positions.

IsRandomStartUp-
Enabled

Simulation BOOL 0x03080285 If enabled and mode UseOff-
setAndDistance is active
then the start-up positions of
the movers are randomized
using the specified band-
width.

MoverDistance Simulation LREAL 0x0308022E Gets/sets the distance be-
tween simulated movers at
start-up.

PositionOffset Simulation LREAL 0x0308022D Gets/sets the position where
the first simulated mover
should be detected.

PositionNoiseBandwidth Simulation LREAL 0x03080231 Gets/sets a bandwidth which
describes how much a posi-
tion should toggle.

RandomStartUpBand-
width

Simulation LREAL 0x03080232 Gets/sets a bandwidth which
is used to modify the start-up
positions of the movers. It is
additionally applied to the
offset and distance.
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Parameter Group Type PTCID Explanation
PositionStartUpSimula-
tionMode

Simulation PositionStartUpSimu-
lationMode

0x03080230 Defines how the start-up po-
sitions for the movers should
be generated.
For more information, see
"PositionStartUpSimulation-
Mode", [Page 193].

MoverIdStartUpSimula-
tionMode

Simulation MoverIdStartUpSim-
ulationMode

0x0308027D Defines how the mover ID(s)
are generated at start-up.
For more information, see
"MoverIdStartUpSimulation-
Mode", [Page 193].

RandomInitMode Simulation RandomInitMode 0x0308027F Defines the mode to initialize
the random seed.
For more information, see
"RandomInitMode", [Page
 193].

RandomInitSeed Simulation DINT 0x03080280 Gets/sets the seed which is
used to generate random
numbers used for the posi-
tions and IDs.
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6.7.1.2 Hidden Parameter (Init)

Parameter Group Type PTCID Explanation
IdDiagConfiguration MoverIdDetection – 0x03080100 Configure the memory size

of ID Detection in the dump
file.
Attention! Do not change.
For more information, see
"IdDiagConfiguration", [Page
 193].

DelayBetweenMoversIn-
Pack

MoverIdDetection LREAL 0x03080247 Time delay [s] between trig-
gering movers which are di-
rectly next to each other
within the MoverPackGap.
Unit: s

DelayBetweenMover-
Packs

MoverIdDetection LREAL 0x03080248 Time delay [s] between trig-
gering movers simultane-
ously which are not in the
same mover pack.
Unit: s

GapToDefineMoverPack MoverIdDetection LREAL 0x03080249 Gap [mm] between movers
to define a new mover pack.
Unit: mm

CompletionCriteria MoverIdDetection MoverIdDetection-
CompletionCriteria

0x0308027B Defines the criteria to com-
plete the ID Detection.
For more information, see
"CompletionCriteria", [Page
 194].

DumpWriterFallback-
Mode

Diagnostics DumpWriterFallback-
Mode

0x030802B2 Gets/sets the mode which
specifies if extra memory can
be used to write a dump file
or not. This may be used if
the normal buffer for the
dump is too small.

IsPartBasedHandling-
Activated

Advanced BOOL 0x03080284 If enabled then the status
and control of all terminals is
evaluated based on parts.
Attention! Beta functionality.

IncludedTrackCheck-
Timeout

Advanced UDINT 0x03080293 Gets/sets the timeout in sec-
onds after which a warning is
thrown, if no tracks are in-
cluded to detection.
Unit: s
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6.7.1.3 Parameter (Online)

Parameter Group Type PTCID Explanation
AreAllPositionsValid MoverDetection BOOL 0x03080256 Returns TRUE if all mover

positions are valid.
DetectionCycleCount MoverDetection UDINT 0x03080259 Returns the number of de-

tection cycles.
DetectedMoverCount MoverDetection UDINT 0x03080257 Returns the number of de-

tected movers during the lat-
est detection cycle.

ExpectedMoverCount MoverDetection UDINT 0x03080258 Returns the number of ex-
pected movers - equal to the
number of created mover ob-
jects.

ScannedModuleCount MoverDetection UDINT 0x03080225 Returns the number of mod-
ules which are scanned dur-
ing one detection cycle.

MoverPositions MoverDetection – 0x0308020D Returns an array containing
the actual positions of all
movers.

HasIdDetectionError MoverIdDetection BOOL 0x03080252 Returns TRUE if the mover
ID detection has failed.

IsIdDetectionValid MoverIdDetection BOOL 0x03080251 Returns TRUE if the mover
IDs are detected.

IsIdDetectionActive MoverIdDetection BOOL 0x03080268 Returns TRUE if the mover
ID detection is running.

MoverIds MoverIdDetection – 0x0308027C Returns an array containing
the IDs of all movers.

IsTeachingChanged Teaching BOOL 0x0308022B Returns TRUE if a teaching
has been performed during
the driver is running.

IsTeachingValid Teaching BOOL 0x03080255 Returns TRUE if the teach-
ing is valid.

IsTeachingFileFor-
matUpToDate

Teaching BOOL 0x03080290 Returns TRUE if the teach-
ing file uses the latest format
definition.

HasInputCheckError Diagnostics BOOL 0x0308028F Returns the result of the in-
puts check.

DriveState Info DriveState 0x000000A0 Returns the state of the drive
system.

PartOrigins Info – 0x03080261 Returns an array containing
all the origin transforms of
the parts.

VersionString Info STRING(31) 0x03080287 Returns the version string of
the driver.

MoverCount Structure UDINT 0x0308020A Returns the number of
movers.

MoverObjectIDs Structure – 0x0308020B Returns an array containing
the object IDs of all movers.

PartCount Structure UDINT 0x03080203 Returns the number of parts.
PartObjectIDs Structure – 0x03080224 Returns an array containing

the object IDs of all parts.
TaskCount Structure UDINT 0x0000009C Returns the number of tasks.
TaskObjectIDs Structure – 0x0000009D Returns an array with the

task object IDs.
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Parameter Group Type PTCID Explanation
TrackCount Structure UDINT 0x0308020E Returns the number of

tracks.
TrackObjectsIDs Structure – 0x0308020F Returns an array containing

the object IDs of all tracks.
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6.7.2 Mover

6.7.2.1 Parameter (Init)

Parameter Group Type PTCID Explanation
AdsPort General WORD 0x03002090 Gets/sets the ads port.

The port should be used to
read/ write parameters via
ADS.

ActiveTrackObjectId General OTCID 0x03080209 Gets/sets the Track object ID
that is currently active/should
be activated for the mover.

TaskOID General OTCID 0x03002060 Gets/sets the XTS Task that
is used for calculations for
the mover.

SimulatedStartUpPart Simulation OTCID 0x03080278 Gets/sets the part on which
the mover is detected during
simulation.

SimulatedStartUpPosi-
tion

Simulation LREAL 0x03080279 Gets/sets the parts position
on which the mover is de-
tected during simulation.

SimulatedStartUpId Simulation STRING(3) 0x0308027E Gets/sets the ID of the
mover on which is used in
simulation.
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6.7.2.2 Hidden Parameter (Init)

Parameter Group Type PTCID Explanation
IsCommutationInverted General BOOL 0x03080200 Attention! Parameter is only

for tests - if the commutation
is inverted and the magnet
plate set does not match, the
mover cannot be safely con-
trolled!
Attention! Beta functionality.
For more information, see
"IsCommutationInverted",
[Page 194].

6.7.2.3 Parameter (Online)

Parameter Group Type PTCID Explanation
Id MoverIdDetection STRING(3) 0x03080266 Returns the ID of the mover.
AxisId Info UDINT 0x03080288 Gets the ID of the associated

axis.
AxisObjectId Info OTCID 0x0308028A Gets the object ID of the as-

sociated axis.
DistanceDriven Info LREAL 0x00000050 Returns the value of the ab-

solute distance driven by the
mover in mm.
Unit: mm

DistanceDrivenInKm Info LREAL 0x00000051 Returns the value of the ab-
solute distance driven by the
mover in km.
Unit: km

DriveAddress Info UINT 0x00000087 Returns the address of the
drive (motor) terminal on
which the mover is currently
on.

DriveModuleNumber Info UDINT 0x00000066 If HasDriveError is TRUE
then the drive number is set
to the first module number
which signals an error.

DriveTerminalOid Info OTCID 0x00000070 If HasDriveError is TRUE
then the object ID of the
drive terminal is set.

EncoderAddress Info UINT 0x00000088 Returns the address of the
encoder (sensor) terminal on
which the mover is currently
on.

EncoderModuleNumber Info UDINT 0x00000067 If HasEncoderError is TRUE
then the encoder number is
set to the first module num-
ber which signals an error.

EncoderTerminalOid Info OTCID 0x00000071 If HasEncoderError is TRUE
then the object ID of the en-
coder is set.

HasDriveError Info BOOL32 0x00000068 Returns TRUE if the motor
module which is used by a
mover signals an error.
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Parameter Group Type PTCID Explanation
HasEncoderError Info BOOL32 0x00000069 Returns TRUE if the encoder

module which is used by a
mover signals an error.

MasterNetId Info AMSNETID 0x00000089 Returns the NetId of the
EtherCAT master to which
the drive/encoder belong to.

PositionInfo Info – 0x03080286 Returns the part and track
position as well as their ob-
ject IDs.

SoftDriverOid Info OTCID 0x03080289 Gets the object ID of the soft
drive.
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6.7.2.4 Data Area

Inputs
Parameter Type Size Offset Explanation
SoftDriveInput SoftDriveInput 104 0 Cyclic data structure for

communication from Mover
object to SoftDrive object of
the axis.

Outputs
Parameter Type Size Offset Explanation
SoftDriveOutput SoftDriveOutput 96 0 Cyclic data structure for

communication from Soft-
Drive object to Mover object.
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6.7.3 Part

6.7.3.1 Parameter (Init)

Parameter Group Type PTCID Explanation
TaskOID General OTCID 0x03002060 Gets/sets the XTS Task that

is used for calculations for
the part.

ModuleSide General ModuleSide 0x03080262 Module side of the part
shown in the Tool Window
and XTS Viewer.
For more information, see
"ModuleSide", [Page 194].

OriginTransform General – 0x03080260 Origin transformation for the
Part shown in the Tool Win-
dow and XTS Viewer.

6.7.3.2 Parameter (Online)

Parameter Group Type PTCID Explanation
DriveState Info DriveState 0x000000A0 Returns the state of the drive

system.
GlobalNumber Info UDINT 0x03080227 The GlobalNumber is used

to distinguish all parts which
are managed by one XPU.

Length Info LREAL 0x03080206 Returns the length of the
part.

AreaCount Structure UDINT 0x03080234 Returns the number of ar-
eas.

AreaObjectIDs Structure – 0x03080235 Returns an array containing
the object IDs of all areas.

ModuleCount Structure UDINT 0x03080207 Returns the number of mod-
ules.

ModuleObjectIDs Structure – 0x03080208 Returns an array containing
the object IDs of all modules.
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6.7.4 Info Server

6.7.4.1 Parameter (Init)

Parameter Group Type PTCID Explanation
AdsPort General WORD 0x03002090 Gets/sets the ads port.

The port should be used to
read/ write parameters via
ADS.

6.7.4.2 Parameter (Online)

Parameter Group Type PTCID Explanation
StationInfoCount Structure UDINT 0x03080275 Returns the number of

movers.
StationInfoObjectIds Structure – 0x03080276 Returns an array containing

the object IDs of all station
infos.
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6.7.5 Station Info

6.7.5.1 Parameter (Init)

Parameter Group Type PTCID Explanation
AdsPort General WORD 0x03002090 Gets/sets the ads port.

The port should be used to
read/ write parameters via
ADS.

StationId General UDINT 0x03080271 Gets/sets the station ID.
StationColor General UDINT 0x03080277 Gets/sets the station color

in ARGB.
StartPositionOnPart General LREAL 0x03080272 Gets/sets the start position

on the first part.
EndPositionOnPart General LREAL 0x03080273 Gets/sets the end position

on the last part.
StopPositions General LREAL 0x03080274 Gets/sets an array of stop

positions. The valid range
starts from 0 mm to the total
length of all configured parts.

PartObjectIds General – 0x03080224 Gets/sets the parts which be-
long to the station.

IsEnabled General BOOL 0x0308023C Gets/sets whether the station
is enabled or not.
For more information, see
"IsEnabled", [Page 194].

Description General STRING(1023) 0x0308023A Description of the station.
Attention! Entering a de-
scription is optional.

6.7.5.2 Parameter (Online)

Parameter Group Type PTCID Explanation
PartCount Structure UDINT 0x03080203 Returns the number of parts.
StopPositionCount Structure UDINT 0x0308028E Returns the number of stop

positions.
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6.7.6 Io Driver

6.7.6.1 Parameter (Init)

Parameter Group Type PTCID Explanation
AdsPort General WORD 0x03002090 Gets/sets the ads port.

The port should be used to
read/ write parameters via
ADS.

MoverType General MoverType 0x00000090 Choose the appropriate
mover type. Use custom for
a non Beckhoff mover.
For more information, see
"MoverType", [Page 188].

MagnetPlateType General MagnetPlateType 0x00000091 Selection of the magnetic
plate set.
Attention! Choose the cor-
rect magnet plate type. If not
correct the mover can jump
unexpectedly.
For more information, see
"MagnetPlateType", [Page
 188].

MoverSortOrder General SortOrderNum 0x00000048 Choose the sort order of the
movers.
For more information, see
"MoverSortOrder", [Page
 188].

MinMechanicalMover-
Distance

General LREAL 0x0308027A Gets/sets the minimum posi-
tion distance between the
movers, which has to be
measured in the curve.
As a default the distance be-
longing to the mover type is
used.

PermanentDataConfigu-
ration

Teaching – 0x00000020 Gets/sets a structure con-
taining the teaching file num-
ber.

StartStandStillTeaching-
Parameter

Teaching – 0x00000010 Gets/sets a structure con-
taining the result of the
teaching process.

StopStandStillTeaching-
Parameter

Teaching – 0x00000011 Gets/sets a structure con-
taining the result of the
teaching process.

IsAbortOnTeaching-
WarningsEnabled

Teaching BOOL 0x00000057 If enabled , will abort startup
of the driver if there are
teaching warnings.
For more information, see
"IsAbortOnTeachingWarn-
ingsEnabled", [Page 190].
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Parameter Group Type PTCID Explanation
IsTeachingCheckSum-
CheckEnabled

Teaching BOOL 0x00000055 If enabled, a teaching check
sum check is applied at
startup.
For more information, see
"IsTeachingCheckSum-
CheckEnabled", [Page 190].

TeachingCheckSum Teaching – 0x00000054 Array of values of the teach-
ing check sum. After a new
teaching one can read (up-
load) the checksum from the
driver.

TeachingWarningLevel Teaching TeachingWarn-
ingLevel

0x0308028C Determines the value above
which the input check and
the teaching issue warnings.
Level_1: very strict
Level_3: low

TriggerTeachingFileFor-
matUpdate

Teaching TriggerTeaching-
FileFormatUpdate

0x03080291 Triggers the system to up-
date the teaching file format
of the given teaching file on
changing back to config
mode
(overwrites the old file).

MoverIdDetectionMode MoverIdDetection MoverIdDetection-
Mode

0x00000201 Choose the ID detection
mode to enable Mover 1 de-
tection. Standard means that
mover ID detection is off.
For more information, see
"MoverIdDetectionMode",
[Page 194].

MoverPositionAssign-
ment

MoverIdDetection MoverPosition-
Assignment

0x00000208 Defines the lowest/highest
position.
For more information, see
"MoverPositionAssignment",
[Page 195].

TriggerMoverIdDetection MoverIdDetection TriggerMoverIdDe-
tection

0x00000205 Triggers the Mover ID Detec-
tion.
Attention! The axes con-
troller will be momentary en-
abled.

IsAutoDumpWritingEn-
abled

Diagnostics BOOL 0x00000049 If enabled then the driver
writes dump files automati-
cally in certain situations (at
start up, in error cases).
For more information, see
"IsAutoDumpWritingEn-
abled", [Page 191].
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Parameter Group Type PTCID Explanation
IsInputCheckEnabled Diagnostics BOOL 0x03080283 Enables the plausibility

check of all input channels
on the system.
For more information, see
"IsInputCheckEnabled",
[Page 191].

WriteDump Diagnostics WriteDump 0x00000044 If downloaded manually then
the driver writes a dump file.

UsedEventLogger Diagnostics EventMessenger 0x03080292 Specifies how events/mes-
sages are reported by the
driver.
For more information, see
"UsedEventLogger", [Page
 191].

IncludeModuleAreasIn-
Record

Diagnostics BOOL 0x00000095 Attention! Do not change!
Obsolete parameter.
For more information, see
"IncludeModuleAreasIn-
Record", [Page 195].

IncludeMoverAreasIn-
Record

Diagnostics BOOL 0x00000096 Attention! Do not change!
Obsolete parameter.
For more information, see
"IncludeMoverAreasIn-
Record", [Page 195].

DumpWriterFallback-
Mode

Diagnostics DumpWriterFall-
backMode

0x030802B2 Gets/sets, which extra mem-
ory can be used for dump
writing, if the driver fails to
write a dump in first attempt.

IsCycleTimeWarning-
Suppressed

Advanced BOOL 0x00000046 If enabled, surpressed warn-
ings for cycle times different
than 250 us (only possible
when working in simulation)

IsMoverFrozenErrorActi-
vated

Advanced BOOL 0x00000097 If enabled, throws an error
instead of a warning, if a
mover position is frozen.
For more information, see
"IsMoverFrozenErrorActi-
vated", [Page 192].

IsPositionBasedError-
ForwardingEnabled

Advanced BOOL 0x00000092 If enabled, makes it possible
to start up and shut down
single parts instead of the
whole XTS.
Attention! Beta functionality.
For more information, see
"IsPositionBasedErrorFor-
wardingEnabled", [Page
 192].

Optimization Advanced OptimaizationEnum 0x00000047 Optimizes the movers move-
ment or positioning slightly.
Standard is optimize posi-
tioning.
For more information, see
"Optimization", [Page 192].
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Parameter Group Type PTCID Explanation
TriggerRedetection Advanced TriggerRedetection 0x00000098 Triggers a new Mover detec-

tion process.
TriggerResort Advanced BOOL 0x00000061 Triggers a resort of the

Mover Positions. Based on
the MoverSortOrder parame-
ter, the first Mover will get
the lowest or highest posi-
tion.

6.7.6.2 Hidden Parameter (Init)

Parameter Group Type PTCID Explanation
DelayBetweenMoversIn-
Pack

MoverIdDetection LREAL 0x00000202 Time delay [s] between trig-
gering movers which are di-
rectly next to each other
within the MoverPackGap.
Unit: s

DelayBetweenMover-
Packs

MoverIdDetection LREAL 0x00000203 Time delay [s] between trig-
gering movers simultane-
ously which are not in the
same mover pack.
Unit: s

GapToDefineMoverPack MoverIdDetection LREAL 0x00000204 Gap [mm] between movers
to define a new mover pack.
Unit: mm

IncludedTrackCheck-
Timeout

Advanced UDINT 0x000000A5 Gets/sets the timeout in sec-
onds after which a warning is
thrown, if no tracks are in-
cluded to detection.
Unit: s

6.7.6.3 Parameter (Online)

Parameter Group Type PTCID Explanation
IsTeachingFileFor-
matUpToDate

Miscellaneous BOOL 0x000000A8 Gets if the teaching file for-
mat of the current loaded
teaching file is correct for the
used driver version.

AreAllMoverPositionVa-
lid

Miscellaneous BOOL32 0x00000072 Returns TRUE if all movers
have been detected.

IsTeachingValid Miscellaneous BOOL32 0x00000073 Returns TRUE if teaching
data is valid.

DetectedMoverCount Miscellaneous DINT 0x00000074 Returns the count of de-
tected movers.

ExpectedMoverCount Miscellaneous DINT 0x00000075 Returns the count of ex-
pected movers.

ModuleCount Miscellaneous DINT 0x00000078 Returns the number of mod-
ules.

ModuleObjectIDs Miscellaneous – 0x00000079 Returns an array containing
the object IDs of all modules.

MoverCount Miscellaneous DINT 0x00000080 Returns the number of
movers.

MoverObjectIDs Miscellaneous – 0x00000081 Returns an array containing
the object IDs of all movers.
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Parameter Group Type PTCID Explanation
MoverPositions Miscellaneous – 0x0000008A Returns an array containing

the actual positions of all
movers.

IsMoverIdDetectionValid Miscellaneous BOOL32 0x00000206 Returns TRUE if the Mover
ID Detection have been de-
tected.

HasMoverIdDetection-
Error

Miscellaneous BOOL32 0x00000207 Returns TRUE if the Mover
ID Detection failed.

6.7.6.4 Data Area

Info
Parameter Type Size Offset Explanation
AreAllMoverPosi-
tionsValid

BOOL32 4.0 0 Returns TRUE if all movers
have been detected.

IsTeachingValid BOOL32 4.0 4 Returns TRUE if teaching
data is valid.

DetectedMoverCount DINT 4.0 8 Returns the count of de-
tected movers.

ExpectedMoverCount DINT 4.0 12 Returns the count of ex-
pected movers.
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6.7.7 Track

6.7.7.1 Parameter (Init)

Parameter Group Type PTCID Explanation
TaskOID General OTCID 0x03002060 Gets/sets the XTS Task that

is used for calculations for
the mover.

IsClosed General BOOL 0x0308021D Gets/sets if the track is
closed as a circle or open
ended.

IsIncludedInDetection General BOOL 0x03080226 Gets/sets if the track is in-
cluded in the detection
process of the mover and
the mover Id detection.

Polarity General Polarity 0x03080201 Gets/sets which direction the
track has in the global con-
text.
Attention! Only positive is
supported at the moment.

Offset General LREAL 0x03080202 Gets/sets the offset for the
track.

PartConfigItems General – 0x03080204 Gets/sets an array of part
configuration items contain-
ing the part object id and the
polarity the part has, within
the track.
Attention! Only positive po-
larity is supported at the mo-
ment!

6.7.7.2 Parameter (Online)

Parameter Group Type PTCID Explanation
Length Info LREAL 0x03080206 Gets the actual length of the

track.
ModuleCount Info UDINT 0x03080207 Gets the number of modules

included in the track.
PartCount Structure UDINT 0x03080203 Gets the number of parts in-

cluded in the track.
PartInfoItems Structure – 0x03080205 Gets an array of part infor-

mation items containing the
part object id, the polarity the
part has within the track, the
offset the part has in the
track and the actual part
length.
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6.7.8 Control Area

6.7.8.1 Parameter (Init)

Parameter Group Type PTCID Explanation
Name General STRING(1023) 0x03080239 Name of the area.

Attention! Entering a name
is optional.

Description General STRING(1023) 0x0308023A Description of the area.
Attention! Entering a de-
scription is optional.

StartPosition General LREAL 0x03080236 Position on the part in mm
where the area starts.
Unit: mm

EndPosition General LREAL 0x03080237 Position on the part in mm
where the area ends.
Unit: mm

BlendInLength General LREAL 0x0308023E Length from the start of the
area until the new parame-
ters are fully used.

BlendOutLength General LREAL 0x0308023F Length before the end of the
area where the previously
used parameter set is started
to be used again.

IsEnabled General BOOL 0x0308023C Gets/sets if the current con-
trol areas is active or not.
For more information, see
"IsEnabled", [Page 194].

6.7.8.2 Parameter (Online)

Parameter Group Type PTCID Explanation
Length Info LREAL 0x03080238 The length of the area

(end position – start posi-
tion).

IsValid Info BOOL 0x0308023D Returns TRUE, if all settings
are valid and the control
area can be used.
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6.7.9 AT20xx_0xxx

6.7.9.1 Parameter (Init)

Parameter Group Type PTCID Explanation
AdsPort General WORD 0X03002090 Gets/sets the ads port.

The port should be used to
read/ write parameters via
ADS.

TaskOID General OTCID 0X03002060 Gets/sets the XTS Task that
is used for calculations for
the mover.

MotorTerminalOID General OTCID 0x00000009 Sets the object ID of the cor-
responding motor terminal.

SensorTerminalOID General OTCID 0x0000000A Sets the object ID of the cor-
responding sensor terminal.

PositionIndex General UDINT 0x00000006 The index defines the posi-
tion of the module in the XTS
system.
The first module has the
hardware position 0, the
other modules are counted
in ascending order.
The number of modules mi-
nus one gives the hardware
position for the last module.

Gap General LREAL 0x0308028B Defines the gap between the
previous module and this
module.

Offset General LREAL 0x00000007 Defines an offset for the
module to compensate me-
chanical tolerances of the
modules production process.

ScalingFactor General LREAL 0x00000008 Defines a ScalingFactor for
the module to compensate
mechanical tolerances of the
modules production process.
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6.7.9.2 Parameter (Online)

Parameter Group Type PTCID Explanation
Angle Info LREAL 0x00000083 Returns the angle of the

module in mm.
Unit: mm

GlobalNumber Info UDINT 0x03080227 The global number is used to
distinguish all modules which
are manged by one XPU.

Length Info LREAL 0x00000082 Returns the length of the
module in mm. The length is
measured along the center
of the coils.
Unit: mm

MasterNetId Info AMSNETID 0x00000086 Returns the NetId of the
EtherCAT master to which
the terminals belong to.

DriveAddress Drive Info UINT 0x00000084 Returns the address of the
drive (motor) terminal.

DriveConfigIdentity Drive Info – 0x00000062 Gets a structure of the con-
figured drive identity contain-
ing the vendor id, the code,
the revision and the serial
number.
For more information, see
"DriveConfigIdentity", [Page
 196].

DriveOnlineIdentity Drive Info – 0x00000063 Gets a structure of the online
drive identity containing the
vendor id, the code, the revi-
sion and the serial number.
For more information, see
"DriveOnlineIdentity", [Page
 196].

DriveState Drive Info DriveState 0x000000A0 Gets the state of the motor
module.

EncoderAdress Encoder Info UINT 0x00000085 Returns the address of the
encoder (sensor) terminal.

EncoderConfigIdentity Encoder Info – 0x00000064 Gets a structure of the con-
figured encoder identity con-
taining the vendor id, the
code, the revision and the
serial number.
For more information, see
"EncoderConfigIdentity",
[Page 196].

EncoderOnlineIdentity Encoder Info – 0x00000065 Gets a structure of the online
encoder identity containing
the vendor id, the code, the
revision and the serial num-
ber.
For more information, see
"EncoderOnlineIdentity",
[Page 196].
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Parameter Group Type PTCID Explanation
EncoderSensorValues Encoder Info – 0x00000093 Gets the array of the 32 en-

coder sensor channel val-
ues.
For more information, see
"EncoderSensorValues",
[Page 197].

DriveDeviceType Drive CoE UDINT 0x030802A0 Gets the DeviceType from
the CoE interface of the mo-
tor Module.

DriveDeviceName Drive CoE STRING(15) 0x030802A1 Gets the DeviceName from
the CoE interface of the mo-
tor Module.

DriveHardwareVersion Drive CoE STRING(7) 0x030802A2 Gets the HardwareVersion
from the CoE interface of the
motor Module.

DriveSoftwareVersion Drive CoE STRING(7) 0x030802A3 Gets the SoftwareVersion
from the CoE interface of the
motor Module.

DriveBtn Drive CoE Btn 0x030802AF Gets the BTN* from the CoE
interface of the motor Mod-
ule.

* The Beckhoff Traceability Number, BTN for short, can be found on every mover and on every module under
the DataMatrix code.

6.7.9.3 Data Pointer

Parameter Type PTCID HW VariableName Size
Control UINT 0x00000005 Control 2
CurrentSetpoint-
Values[0..14]

INT 0x00000002 Current setpoint value
Ch1‑15

2

State UINT 0x00000004 State 2
CurrentActual-
Values[0..14]

INT 0x00000001 Current actual value Ch.1‑15 2

RawPosition-
Values[0..31]

INT 0x3F000101 Value Channel 01‑32 2
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6.7.10 ATH20x0_0xxx

6.7.10.1 Parameter (Init)

Parameter Group Type PTCID Explanation
AdsPort General WORD 0x03002090 Gets/sets the ads port.

The port should be used to
read/ write parameters via
ADS.

TaskOID General OTCID 0x03002060 Gets/sets the XTS Task that
is used for calculations for
the mover.

MotorTerminalOID General OTCID 0x00000009 Sets the object ID of the cor-
responding motor terminal.

SensorTerminalOID General OTCID 0x0000000A Sets the object ID of the cor-
responding sensor terminal.

PositionIndex General UDINT 0x00000006 The index defines the posi-
tion of the module in the XTS
system.
The first module has the
hardware position 0, the
other modules are counted
in ascending order.
The number of modules mi-
nus one gives the hardware
position for the last module.

Gap General LREAL 0x0308028B Defines the gap between the
previous module and this
module.

Offset General LREAL 0x00000007 Defines an offset for the
module to compensate me-
chanical tolerances of the
modules production process.

ScalingFactor General LREAL 0x00000008 Defines a ScalingFactor for
the module to compensate
mechanical tolerances of the
modules production process.
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6.7.10.2 Parameter (Online)

Parameter Group Type PTCID Explanation
Angle Info LREAL 0x00000083 Returns the angle of the

module in mm.
Unit: mm

GlobalNumber Info UDINT 0x03080227 The global number is used to
distinguish all modules which
are manged by one XPU.

Length Info LREAL 0x00000082 Returns the length of the
module in mm. The length is
measured along the center
of the coils.
Unit: mm

MasterNetId Info AMSNETID 0x00000086 Returns the NetId of the
EtherCAT master to which
the terminals belong to.

DriveAddress Drive Info UINT 0x00000084 Returns the address of the
drive (motor) terminal.

DriveConfigIdentity Drive Info – 0x00000062 Gets a structure of the con-
figured drive identity contain-
ing the vendor id, the code,
the revision and the serial
number.
For more information, see
"DriveConfigIdentity", [Page
 196].

DriveOnlineIdentity Drive Info – 0x00000063 Gets a structure of the online
drive identity containing the
vendor id, the code, the revi-
sion and the serial number.
For more information, see
"DriveOnlineIdentity", [Page
 196].

DriveState Drive Info DriveState 0x000000A0 Gets the state of the motor
module.

EncoderAddress Encoder Info UINT 0x00000085 Returns the address of the
encoder (sensor) terminal.

EncoderConfigIdentity Encoder Info – 0x00000064 Gets a structure of the con-
figured encoder identity con-
taining the vendor id, the
code, the revision and the
serial number.
For more information, see
"EncoderConfigIdentity",
[Page 196].

EncoderOnlineIdentity Encoder Info – 0x00000065 Gets a structure of the online
encoder identity containing
the vendor id, the code, the
revision and the serial num-
ber.
For more information, see
"EncoderOnlineIdentity",
[Page 196].
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Parameter Group Type PTCID Explanation
EncoderSensorValues Encoder Info – 0x00000093 Gets the array of the 64 en-

coder sensor channel val-
ues.
For more information, see
"EncoderSensorValues",
[Page 197].

DriveDeviceType Drive CoE UDINT 0x030802A0 Gets the DeviceType from
the CoE interface of the mo-
tor Module.

DriveDeviceName Drive CoE STRING(15) 0x030802A1 Gets the DeviceName from
the CoE interface of the mo-
tor Module.

DriveHardwareVersion Drive CoE STRING(7) 0x030802A2 Gets the HardwareVersion
from the CoE interface of the
motor Module.

DriveSoftwareVersion Drive CoE STRING(7) 0x030802A3 Gets the SoftwareVersion
from the CoE interface of the
motor Module.

DriveBtn Drive CoE Btn 0x030802AF Gets the BTN* from the CoE
interface of the motor Mod-
ule.

* The Beckhoff Traceability Number, BTN for short, can be found on every mover and on every module under
the DataMatrix code.

6.7.10.3 Data Area

Decompressed Sensor Data
Parameter Type Size Offset Explanation
EncoderSensorValues ARRAY [0..53] OF

LREAL
432.0 0 64 hall sensor values

Data Pointers
Parameter Type PTCID HW VariableName Size
Control UINT 0x00000005 Control 2
CurrentSetpoint-
Values[0..14]

INT 0x00000002 Current setpoint value
Ch.1‑15

2

State UINT 0x00000004 State 2
CurrentActual-
Values[0..14]

INT 0x00000001 Current actual value
Ch.1‑15

2

HallSensorValues ATHCompressed-
Data64

0x000000A2 BinaryData 2
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6.7.11 Data Recorder

6.7.11.1 Parameter (Init)

Parameter Group Type PTCID Explanation
BufferSize General ULINT 0x00010003 Gets/sets the number of

samples for the buffer.
CycleDelay General UDINT 0x00010011 Gets/sets the number of cy-

cles for the delay for the
record.

ImageSections General – 0x00010001 Gets/sets an array of image
section items containing ob
ject id, area number, start
address and size.
For more information, see
"ImageSections", [Page
 197].

IsRingBufferModeActi-
vated

General BOOL 0x00010009 Gets/sets if the ring buffer is
activated or not.
For more information, see
"IsRingBufferModeActi-
vated", [Page 197].

WriteRecord General WriteRecord 0x00010005 Triggers the recording
process.

TraceLevelMax Diagnostics TcTraceLevel 0x03002103 Controls the amount of log
messages.
For more information, see
"TraceLevelMax", [Page
 197].

FilePartSize Advanced UDINT 0x00010006 Gets/sets the size of a file
part.

FileOperationTimeout Advanced UDINT 0x00010007 Gets/sets the time in ms af-
ter which the file operation
should abort.
Unit: ms

ResetInfoArea Advanced BOOL 0x00010002 Gets/sets if the info area
should be reset after record.
For more information, see
"ResetInfoArea", [Page 197].
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6.7.11.2 Parameter (Online)

Parameter Type PTCID Explanation
FrameCount ULINT 0x00010004 Gets the number of frames

that should be recorded.
FrameSize UDINT 0x00010008 Gets the size of the frames

that should be recorded.
RecorderFrameCount ULINT 0x00010010 Gets the number of frames

that were actually recorded.

6.7.11.3 Data Area

Info
Parameter Type Size Offset Explanation
UpdateTime LREAL 8.0 0 Estimated update time
UpdateTimeMin LREAL 8.0 8 Minimal update time
UpdateTimeMax LREAL 8.0 16 Maximum update time
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6.7.12 Specific data types

These parameters provide you with additional information to the pa-
rameters listed so far. At the end of each table you have the option
of jumping back to the beginning of the respective parameter group.

6.7.12.1 OperationMode

Parameter Type Explanation
Normal OperationMode TwinCAT runs with the current hardware.
Simulation OperationMode TwinCAT runs in simulation mode

Back to Processing Unit "Parameter (Init)", [Page 158]

6.7.12.2 MoverType

EnumInfo Type Explanation
UserSpecific MoverType User-specific mover
AT9011_0050 MoverType Mover AT9011-0050
AT9011_0070 MoverType Mover AT9011-0070
AT9012_0050 MoverType Mover AT9012-0050
ATH9011_0075 MoverType Mover ATH9011-0075

Back to Processing Unit "Parameter (Init)", [Page 158]
Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.3 MagnetPlateType

EnumInfo Type Explanation
AT9001_0550 MagnetPlateType Magnetic plate set AT9001-0550
AT9001_0450 MagnetPlateType Magnetic plate set AT9001-0450
AT9002_0550 MagnetPlateType Magnetic plate set AT9002-0550
AT9001_0AA0 MagnetPlateType Magnetic plate set AT9001-0AA0
AT9001_0883 MagnetPlateType Magnetic plate set AT9001-0883
AT9001_0775 MagnetPlateType Magnetic plate set AT9001-0775
ATH9001-0550 MagnetPlateType Magnetic plate set ATH9001-0550

Back to Processing Unit "Parameter (Init)", [Page 158]
Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.4 MoverSortOrder

Parameter Type Explanation
Ascending SortOrderEnum Movers will be counted positive, starting at 1 beginning at the XTS

hardware zero position.
Descending SortOrderEnum Movers will be counted negative, starting at the highest mover

number beginning at the XTS hardware zero position.
Back to Processing Unit "Parameter (Init)", [Page 158]

Back to Io Driver "Parameter (Init)", [Page 173]
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6.7.12.5 IdDetectionMode

Parameter Type Explanation
Standard MoverIdDetection-

Mode
All movers have a Mover Standard magnetic plate set. Mover ID
detection is switched off.

Mover1 MoverIdDetection-
Mode

One Mover has the Mover 1 magnetic plate set.

MultipleMover1 MoverIdDetection-
Mode

Several movers have the Mover 1 magnetic plate set.

Back to Processing Unit "Parameter (Init)", [Page 158]

6.7.12.6 MoverPositionAssignment

Parameter Type Explanation
Standard MoverPositionAssign-

ment
All movers keep their absolute position.

StartAtFirstMover MoverPositionAssign-
ment

The first mover gets the highest or lowest absolute position de-
pending on the MoverPositionAssignment.

Back to Processing Unit "Parameter (Init)", [Page 158]

6.7.12.7 ExpectedMoverIds

Parameter Type Value Explanation
Id STRING(3) 1 Mover ID.

"1" for movers with the magnetic plate set
Mover 1.
"-" for movers with magnetic plate set Stan-
dard.

Count UDINT 2 Number of expected movers.
Back to Processing Unit "Parameter (Init)", [Page 158]

6.7.12.8 StartStandStillTeaching

Parameter Type Explanation
TeachingSelection TeachingSelection Selection, if the modules from the string should be included or ex-

cluded for the teaching process.
• ExcludeSpeci-

fiedItems
– Modules with movers. These modules should be excluded from

teaching.
• IncludeSpeci-

fiedItems
– Empty modules. These modules should be integrated into teach-

ing.
selectionString STRING(1023) Module numbers according to the parameter TeachingSelection.

The module numbers can be entered with the sign "-" or "," or a
combination of both signs, e.g. "1‑4", "1,2,3,4" or "1‑3,4".

Back to Processing Unit "Parameter (Init)", [Page 158]
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6.7.12.9 StartMovementTeaching

Pay attention to the type of system
StartMovementTeaching can only be used with the XTS Standard
system and is not available for the XTS Hygienic system. These pa-
rameters are ignored in the XTS Hygienic system.

Parameter Type Explanation
teachingSelection TeachingSelection Selection, if the modules from the string should be included or ex-

cluded for the teaching process.
• ExcludeSpeci-

fiedItems
– Modules with movers. These modules should be excluded from

teaching.
• IncludeSpeci-

fiedItems
– Empty modules. These modules should be integrated into teach-

ing.
selectionString STRING(1023) Module numbers according to the parameter TeachingSelection.

The module numbers can be entered with the sign "-" or "," or a
combination of both signs, e.g. "1‑4", "1,2,3,4" or "1‑3,4".

Back to Processing Unit "Parameter (Init)", [Page 158]

6.7.12.10 IsAbortOnTeachingWarningsEnabled

Parameter Type Explanation
TRUE BOOL Driver will abort start up when there are teaching warnings.
FALSE BOOL Driver will not abort start up when there are teaching warnings.

Back to Processing Unit "Parameter (Init)", [Page 158]
Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.11 IsTeachingCheckSumCheckEnabled

Parameter Type Explanation
TRUE BOOL Teaching check sum check is performed at startup.
FALSE BOOL Teaching check sum check is not performed at startup.

Back to Processing Unit "Parameter (Init)", [Page 158]
Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.12 TeachingCheckSum

Parameter Type Explanation
[0]…[15] BYTE Values for the teaching check sum.

Back to Processing Unit "Parameter (Init)", [Page 158]
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6.7.12.13 TeachingWarningLevel

Parameter Type Explanation
Level_1 TeachingWarn-

ingLevel
Very strict

Level_2 TeachingWarn-
ingLevel

Normal

Level_3 TeachingWarn-
ingLevel

Low

Back to Processing Unit "Parameter (Init)", [Page 158]

6.7.12.14 IsAutoDumpWritingEnabled

Parameter Type Explanation
TRUE BOOL Dumps are written automatically at special events, e. g. mover de-

tection, mover id detection, mover lost, …
FALSE BOOL No dumps are written automatically.

Back to Processing Unit "Parameter (Init)", [Page 158]
Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.15 IsInputCheckEnabled

Parameter Type Explanation
TRUE BOOL Activates the plausibility check of all input channels of the system.
FALSE BOOL Deactivates the plausibility check of all input channels of the sys-

tem.
Back to Processing Unit "Parameter (Init)", [Page 158]

Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.16 UsedEventLogger

Parameter Type Explanation
StandardMessage-
Interface

EventMessenger Messages are thrown in the user chosen standard massaging in-
terface.

EventLogger EventMessenger Messages are thrown in the VS Event Logger.
TC3EventLogger EventMessener Messages are thrown in the TC3 Event Logger.

Back to Processing Unit "Parameter (Init)", [Page 158]
Back to Io Driver "Parameter (Init)", [Page 173]
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6.7.12.17 IsCycleTimeWarningSuppressed

Parameter Type Explanation
TRUE BOOL No cycle time warnings are thrown.
FALSE BOOL Cycle time warnings are thrown if the XTS task cycle time devi-

ates from 250us.
Back to Processing Unit "Parameter (Init)", [Page 158]

Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.18 IsMoverFrozenErrorActivated

Parameter Type Explanation
TRUE BOOL If a mover freezes, an error will be thrown.
FALSE BOOL If a mover freezes, a warning will be thrown.

Back to Processing Unit "Parameter (Init)", [Page 158]
Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.19 IsPositionBasedErrorForwardingEnabled

Parameter Type Explanation
TRUE BOOL DriveDeviceError bit of the NC axis will show TRUE if the respec-

tive Mover stands on a module with a fault even before the mover
axis is enabled.

FALSE BOOL DriveDeviceError bit of the NC axis won´t show TRUE if the re-
spective mover stands on a module with a fault before the mover
axis is enabled. It will show TRUE, when the mover axis is en-
abled.

Back to Processing Unit "Parameter (Init)", [Page 158]
Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.20 Optimization

Parameter Type Explanation
No OptimizationEnum No optimization is applied.
MaximizePositionAc-
curacyOP1

OptimizationEnum The system will be optimized for position accuracy.

SmoothMovemen-
tOM1

OptimizationEnum The system will be optimized for movement smoothness.

CombinationOC1 OptimizationEnum The system will be optimized for a combination of smoother move-
ments and position accuracy.

Back to Processing Unit "Parameter (Init)", [Page 158]
Back to Io Driver "Parameter (Init)", [Page 173]
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6.7.12.21 PositionStartUpSimulationMode

Parameter Type Explanation
UseMoverParame-
ters

PositionStartUpSimu-
lationMode

Movers will start up in simulation with their given simulated start
up position.

UseOffsetAndDis-
tance

PositionStartUpSimu-
lationMode

Movers will start up in simulation based on the configured offset
and distance position parameters.

UseRandomDistribu-
tion

PositionStartUpSimu-
lationMode

Movers will start up in simulation with a random position.

Back to Processing Unit "Parameter (Init)", [Page 158]

6.7.12.22 MoverIdStartUpSimulationMode

Parameter Type Explanation
UseMoverParame-
ters

MoverIdStartUpSimu-
lationMode

Movers will start up in simulation with their given simulated start
up position.

UseAlternation MoverIdStartUpSimu-
lationMode

Movers will start up in simulation with an alternating id based on
the expected mover ids settings.

UseRandomDistribu-
tion

MoverIdStartUpSimu-
lationMode

Movers will start up in simulation with a random id based on the
expected mover ids settings.

Back to Processing Unit "Parameter (Init)", [Page 158]

6.7.12.23 RandomInitMode

Parameter Type Explanation
UseSystemTime RandomInitMode Random distribution is calculated based on system time.
UseInitSeed RandomInitMode Random distribution is calculated based on seed.

Back to Processing Unit "Parameter (Init)", [Page 158]

6.7.12.24 IdDiagConfiguration

Parameter Type Explanation
floatBufferSize UDINT Allocated buffer space for position and current values.
intBufferSize UDINT Allocated space for communication data between SoftDrive and

TcIoXts.
requiredCurrentDevi-
ation

REAL Necessary current change difference to consider.

requiredPositionDe-
viation

REAL Necessary position change difference to consider.

Back to Processing Unit "Hidden Parameter (Init)", [Page 163]
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6.7.12.25 CompletionCriteria

Parameter Type Explanation
CheckEveryMover MoverIdDetection-

CompletionCriteria
Every Mover gets the detection movement and will be checked for
its id.

CompleteAfter-
Mover1Found

MoverIdDetection-
CompletionCriteria

Once the mover with the special Mover 1 magnetic plate set is
found, the detection process will be finished.

Back to Processing Unit "Hidden Parameter (Init)", [Page 163]

6.7.12.26 IsCommutationInverted

Parameter Type Explanation
TRUE OTCID Attention! The parameter is only for tests - if the commutation is

inverted and the magnetic plate set does not match, the inverter
cannot be controlled safely!

FALSE OTCID Attention! The parameter is only for tests - if the commutation is
inverted and the magnetic plate set does not match, the inverter
cannot be controlled safely!

Back to Mover "Hidden Parameter (Init)", [Page 167]

6.7.12.27 ModuleSide

Parameter Type Explanation
Back ModuleSide Modules are shown from the motor type plate side.
Front ModuleSide Modules are shown from the encoder side.

Back to Part "Parameter (Init)", [Page 170]

6.7.12.28 IsEnabled

Parameter Type Explanation
TRUE BOOL Gets/sets whether the station is enabled.
FALSE BOOL Gets/sets whether the station is disabled.

Back to Station Info "Parameter (Init)", [Page 172]
Back to Control Area "Parameter (Init)", [Page 179]

6.7.12.29 MoverIdDetectionMode

Parameter Type Explanation
Standard MoverIdDetection-

Mode
Detection mode is disabled. Only standard movers are used.

Mover1 MoverIdDetection-
Mode

Detection mode is enabled. A Mover 1 is used.

MultipleMover1 MoverIdDetection-
Mode

Detection mode is enabled. Several Mover 1 are used.

Back to Io Driver "Parameter (Init)", [Page 173]
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6.7.12.30 MoverPositionAssignment

Parameter Type Explanation
Standard MoverPositionAssign-

ment
Defines the lowest/highest position.

StartAtFirstMover MoverPositionAssign-
ment

Defines the lowest/highest position.

Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.31 IncludeModuleAreasInRecord

Parameter Type Explanation
TRUE BOOL Module areas are included in record.

Attention! Do not change! Obsolete parameter.
FALSE BOOL Module areas are not included in record.

Attention! Do not change! Obsolete parameter.
Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.32 IncludeMoverAreasInRecord

Parameter Type Explanation
TRUE BOOL Mover areas are included in record.

Attention! Do not change! Obsolete parameter.
FALSE BOOL Mover areas are not included in record.

Attention! Do not change! Obsolete parameter.
Back to Io Driver "Parameter (Init)", [Page 173]

6.7.12.33 IsClosed

Parameter Type Explanation
TRUE BOOL The track is closed as a circle.
FALSE BOOL The track is open ended.

Back to Track "Parameter (Init)", [Page 178]

6.7.12.34 IsIncludedInDetection

Parameter Type Explanation
TRUE BOOL Track is included in process of mover detection and mover id de-

tection.
FALSE BOOL Track is not included in process of mover detection and mover id

detection.
Back to Track "Parameter (Init)", [Page 178]
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6.7.12.35 Polarity

Parameter Type Explanation
Positive Polarity Track has positive counting direction.
Negative Polarity Track has negative counting direction.

Attention! Not supported at the moment.
Back to Track "Parameter (Init)", [Page 178]

6.7.12.36 DriveConfigIdentity

Parameter Type Explanation
vendor UDINT Vendor ID
code UDINT Product code
revision UDINT Product revision
serial UDINT Serial number

Back to AT20xx_0xxx "Parameter (Online)", [Page 181]
Back to ATH20x0_0xxx "Parameter (Online)", [Page 184]

6.7.12.37 DriveOnlineIdentity

Parameter Type Explanation
vendor UDINT Vendor ID
code UDINT Product code
revision UDINT Product revision
serial UDINT Serial number

Back to AT20xx_0xxx "Parameter (Online)", [Page 181]
Back to ATH20x0_0xxx "Parameter (Online)", [Page 184]

6.7.12.38 EncoderConfigIdentity

Parameter Type Explanation
vendor UDINT Vendor ID
code UDINT Product code
revision UDINT Product revision
serial UDINT Serial number

Back to AT20xx_0xxx "Parameter (Online)", [Page 181]
Back to ATH20x0_0xxx "Parameter (Online)", [Page 184]

6.7.12.39 EncoderOnlineIdentity

Parameter Type Explanation
vendor UDINT Vendor ID
code UDINT Product code
revision UDINT Product revision
serial UDINT Serial number

Back to AT20xx_0xxx "Parameter (Online)", [Page 181]
Back to ATH20x0_0xxx "Parameter (Online)", [Page 184]
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6.7.12.40 EncoderSensorValues

Parameter Type Explanation
[0] - [31] LREAL Encoder sensor value of respective channel

Back to AT20xx_0xxx "Parameter (Online)", [Page 181]
Back to ATH20x0_0xxx "Parameter (Online)", [Page 184]

6.7.12.41 ImageSections

Parameter Type Explanation
ObjectID OTCID Object ID
AreaNumber UDINT Area number
StartAddress UDINT Start position
Size UDINT Image size

Back to Data Recorder "Parameter (Init)", [Page 186]

6.7.12.42 IsRingBufferModeActivated

Parameter Type Explanation
TRUE BOOL Ring buffer is active
FALSE BOOL Ring buffer is not active

Back to Data Recorder "Parameter (Init)", [Page 186]

6.7.12.43 TraceLevelMax

Parameter Type Explanation
tlAlways TcTraceLevel Controls the amount of log messages. All messages are thrown.
tlError TcTraceLevel Controls the amount of log messages. Only error messages are

thrown.
tlWarning TcTraceLevel Controls the amount of log messages. Error and warnings are

thrown.
tlInfo TcTraceLevel Controls the amount of log messages. Errors, warnings and infos

are thrown.
tlVerbose TcTraceLevel Controls the amount of log messages. No messages are thrown.

Back to Data Recorder "Parameter (Init)", [Page 186]

6.7.12.44 ResetInfoArea

Parameter Type Explanation
TRUE BOOL Info area is reset.
FALSE BOOL Info area is not reset.

Back to Data Recorder "Parameter (Init)", [Page 186]
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7 Commissioning
The first steps of commissioning depend on whether you have hard-
ware or not. If a different procedure is required, the corresponding
links are shown at the beginning of the respective chapter.

7.1 Open or create project

Hardware available
If you have hardware, you can open an existing project or create a
new project. You can continue with one of the following chapters:
• "Opening an existing project", [Page 198]
• "Creating a new project", [Page 199]

Hardware not available
If you do not have any hardware, you can open an existing project or
create a new project using the XTS Simulation Builder. Beckhoff rec-
ommends using the XTS Simulation Builder. You can continue with
one of the following chapters:
• "Opening an existing project", [Page 198]
• "XTS Simulation Builder", [Page 229]

7.1.1 Opening an existing project
Once you have opened TwinCAT, you have the option of opening
an existing project on the start screen or in the menu.

Start screen The list shows you the most recently opened projects from the previ-
ous day, the previous week, the previous month and the previous
period.

► Click on an existing project in the list to open it

Menu
► In the menu File click on the menu item Open...
► Click on Project/Solution in the submenu
► Click on an existing project to open it
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7.1.2 Creating a new project
To set up an XTS system and connect it to all hardware compo-
nents, you must first set up a TwinCAT 3 project. For commission-
ing, you must create a new TwinCAT XAE project with Solution.

► In the menu File click on the menu item New
► Click on Project in the submenu

The New Project dialog box opens.
► Click on TwinCAT Projects
► Enter a name in the input field Name
► Select a file path from the drop-down menu Location
OR
► Click on Browse to open the Project Location dialog box and se-

lect a file path
► Enter a name in the input field Solution name
► Confirm with OK
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7.2 Preparing hardware

Hardware not available
If you do not have any hardware, you can configure a system. You
can continue with the following chapter:
• "System configuration", [Page 204]

Hardware available
If you have hardware, you can continue with the following steps.

7.2.1 Check hardware
► Check correct connection of all XTS hardware components to

the IPC and the mains connection
The following LEDs must be lit on all modules:
• Link / Act
• 24 V / 4 A

If the LEDs do not light up:
► Check cables and connectors
► Check EtherCAT settings for communication with the target PC

7.2.2 Connect target PC

Same software version on target PC and engineering PC
Make sure that the same software version is installed on your target
PC as on your engineering PC.

► Expand Solution Explorer > TwinCAT Project
► Double-click on SYSTEM

► In the project window, click on the General tab
► Click Choose Target
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The dialog box Choose Target System opens.
The dialog box Choose Target System lists all target PCs to which
there are routes from the development system.
If the desired target PC is not yet listed:
► Click Search (Ethernet)...
If you work locally on your engineering PC:
► Click <Local>
After you have selected <Local>, you can continue with the following
chapter:
• "Check target PC", [Page 202]

The dialog box Add Route Dialog opens.
► Activate the checkbox Advanced Settings

► Activate the checkbox IP Address
► Click Broadcast Search

The dialog box Select Adapter(s) opens.
► Deactivate the checkbox Realtek USB GbE Family Controller
► Confirm with OK

► Click on the target PC
► Click Add Route
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The dialog box Add Remote Route opens.
► Enter the password for the target PC in the input field Password
► Confirm with OK

The successful connection of the target PC is indicated by a closed
lock in the Connected column.
► Confirm with Close

The dialog box Choose Target System opens.
► Confirm with OK

7.2.2.1 Check target PC
► Check whether the target PC is selected
► If required, select the target PC from the drop-down menu

7.2.3 Scanning I/O Devices
► Ensure that TwinCAT is in Config Mode
► If required, click on the button Restart TwinCAT (Config Mode)

to activate the Config Mode
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► Expand Solution Explorer > TwinCAT Project > I/O
► Right-click on Devices to open the context menu
► Click Scan in the context menu

The dialog box TcXaeShell opens.
► Confirm with OK

Depending on the components of your XTS system, there are differ-
ent devices to choose from:
• one RT-Ethernet adapter for each connected CU2508
• one EtherCAT Device for each infeed line of the XTS system
• EtherCat Devices for the bus terminals contained in the control

cabinet

Beckhoff recommends naming the devices clearly for a better over-
view.
The dialog box 8 new I/O devices found opens.
► Activate the checkboxes of the devices that are to be selected

for the current configuration
► Confirm with OK

The dialog box TcXaeShell opens.
► Confirm with Yes
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7.3 System configuration
You have various options for configuring an XTS system. The proce-
dure for configuring a system depends on whether you have hard-
ware or not:

Hardware available
If hardware is available, you can create the system with the XTS
Configurator or manually. Beckhoff recommends using the XTS
Configurator. You can continue with one of the following chapters:
• "XTS Configurator", [Page 258]
• "Create new XTS system manually", [Page 39]

Hardware not available
If no hardware is available, you can create the system with the XTS
Simulation Builder or manually. Beckhoff recommends using the
XTS Simulation Builder. You can continue with one of the following
chapters:
• "XTS Simulation Builder", [Page 229]
• "Create new XTS system manually", [Page 39]
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7.4 Checking I/O devices

Connection to the power supply and 48 V required
To commission a real XTS system, the system must be connected
to the power supply and 48 V must be connected.

Once you have configured the XTS system, you can put the configu-
ration into operation and move the movers.

Hardware available
To put a system into operation, the I/O devices must be enabled.

Hardware not available
To put a simulated system into operation, the I/O devices must be
disabled.

You can see whether the devices are enabled or disabled by the
display of the devices in the Solution Explorer:

The device is enabled.

The device is disabled.

► Expand Solution Explorer > TwinCAT Project > I/O > Devices
► Check whether all XTS-relevant devices are enabled
If the devices are disabled, the devices must be enabled.

7.4.1 Activate
► Press and hold the button Ctrl to select the devices
► Right-click on the XTS relevant devices
► Click Disable in the context menu
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7.5 Activating the configuration
► Click on the button Activate Configuration to activate the con-

figuration

The dialog box Activate Configuration opens.
► Make sure that the correct project and the correct target PC are

selected in the input fields Project and Target
► Confirm with OK

As soon as the system is activated, an animated TwinCAT symbol is
displayed in the information bar and status bar. The XTS system is
ready for operation. You can make changes to the current configura-
tion at any time by reopening the XTS Configurator.

The XTS Tool Window can only be set to Running mode if the con-
figuration is activated and TwinCAT is in Run mode.

► In the XTS Tool Window activate the button Check to enable
live view

The XTS Tool Window is in Running mode and shows the current
mover positions.

7.6 Mover ID detection
Perform a Mover ID detection to locate Mover 1 on the system. Fur-
ther information can be found in chapter "Mover  1 functionality",
[Page 93].
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7.7 Activating NC axes
Before you can move a mover, you must activate the corresponding
NC axis of the mover.

► Expand Solution Explorer > TwinCAT Project > MOTION > NC-
Task 1 > Axes

► Double-click Mover Axis 1

► In the project window, click on the Online tab
► Click Set

Use the button All to enable the controllers Controller, Feed Fw and
Feed Bw to move the movers. If you click on the button All, the Set
Enabling window closes automatically.

The dialog box Set Enabling opens.
► Click on All to enable all controllers
OR
► Activate the checkboxes Controller, Feed Fw and Feed Bw to

enable the controllers
► Confirm with OK
The axis controllers are enabled and the corresponding mover can
be moved.
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7.8 Moving the mover
Once you have activated the configuration and the NC axes of the
movers, you can now move one or more movers.
Observe the representation of a simulated system
If no real XTS system is connected and you are working with a sim-
ulated system, the movers overtake and overlap in the display in the
XTS Tool Window. In a real system, this overlapping is not possible;
instead, the movers collide.
The movers can be moved to any position using the buttons or to a
defined position using a direct motion command. In addition, certain
functions can be used for movement, but these are not controlled
via the buttons.

7.8.1 Controls
The list shows the most important controls:

Fast backwards
Moves the mover backwards at the velocity entered in the input field
Manual Velocity (Fast).
Preset: 600 [mm/s]

Slowly backwards
Moves the mover backwards at the velocity entered in the input field
Manual Velocity (Slow).
Preset: 100 [mm/s]

Slowly forward
Moves the mover forwards at the velocity entered in the input field
Manual Velocity (Slow).
Preset: 100 [mm/s]

Fast forward
Moves the mover forwards at the velocity entered in the input field
Manual Velocity (Fast).
Preset: 600 [mm/s]

Start a direct motion command
Starts a direct motion command to the target position entered in the
input field Target Position at the velocity entered in the input field
Target Velocity.

Stop direct motion command
Stops the direct motion command.

Cancel motion command and reset
Stops the current motion command and resets the NC axis.

Controller enable
Enables the controller for moving the movers.

Target Position input field
Enables the target position of the mover to be entered for a direct
motion command.
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Velocity input field
Enables the velocity for the mover to be entered for a direct motion
command.

7.8.2 Any position

Button only controls the selected mover
The buttons for moving the movers only control the selected NC axis
with the corresponding mover on the currently active track.
If you want to move several movers using the buttons, the movers
must be coupled. Further information can be found in chapter "Cou-
pling movers", [Page 222].

If the buttons are inactive, the selected NC axis of the mover is not
activated or the NC axis is coupled with another NC axis.

Backward
► Left-click and hold the F1 button to move the mover quickly

backwards
OR
► Left-click and hold the F2 button to move the mover slowly back-

wards

Forward
► Left-click and hold the F3 button to move the mover slowly for-

wards
OR
► Left-click and hold the F4 button to move the mover quickly for-

wards
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7.8.3 Direct motion command

The distances traveled so far are added up to an absolute position
[1]. From this absolute position, the mover moves in a positive or
negative direction until the target position [2] is reached at the de-
fined velocity [3].
In contrast, with the Modulo function, the distances traveled are not
added up and the distance already traveled does not have to be
completely reversed in order to reach the target position. Further in-
formation can be found in chapter "Modulo / Modulo shortest way /
Modulo plus direction / Modulo minus direction", [Page 215].

► Enter a value for the position to which the mover is to be moved
in the input field Target position

► Enter the velocity at which the mover is to be moved in the input
field Target Velocity

► Click on the F5 button to start the direct motion command
The mover is moved to the target position at the defined velocity.
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Cancel direct motion command
► Click on the F6 button to cancel the direct motion command

7.8.4 Functions
Various motion commands are available in the Functions tab and
can be used after entering a few values.

► In the project window, click on the Functions tab
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7.8.4.1 Absolute
This function moves the mover to the entered position.

Starting
► Select Absolute in the drop-down menu Start Mode

► Enter the target positions in the input field Target Position
► Enter a value for the velocity in the input field Target Velocity
► If required, activate the checkbox Acceleration to enter a value

for the acceleration in the input field
► If required, activate the checkbox Deceleration to enter a value

for the deceleration in the input field
► If required, activate the checkbox Jerk to enter a value for the

jerk in the input field
► Click on Start to start the function Absolute
The mover moves to the target position entered.

Stop

Stopping only during the procedure
The function can only be stopped during the movement to the target
position. After moving to the target position, the button Stop is auto-
matically disabled.

► Click on Stop to stop the function Absolute
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7.8.4.2 Relative
With this function, the mover travels a defined route.

Starting
► Select Relative in the drop-down menu Start Mode

► Enter a value for the length of the route in the input field Target
Position

► Enter a value for the velocity in the input field Target Velocity
► If required, activate the checkbox Acceleration to enter a value

for the acceleration in the input field
► If required, activate the checkbox Deceleration to enter a value

for the deceleration in the input field
► If required, activate the checkbox Jerk to enter a value for the

jerk in the input field
► Click on Start to start the function Relative
The mover travels the defined length of the route.

Stop

Stopping only during the procedure
The function can only be stopped during the movement to the target
position. After moving to the target position, the button Stop is auto-
matically disabled.

► Click on Stop to stop the function Relative
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7.8.4.3 Endless + / Endless -
With this function, the mover moves infinitely in a positive or nega-
tive direction.

Starting
► Select Endless + in the drop-down menu Start Mode
OR
► Select Endless - in the drop-down menu Start Mode

► Enter a value for the velocity in the input field Target Velocity
► If required, activate the checkbox Acceleration to enter a value

for the acceleration in the input field
► If required, activate the checkbox Deceleration to enter a value

for the deceleration in the input field
► If required, activate the checkbox Jerk to enter a value for the

jerk in the input field
► Click on Start to start the function Endless + or Endless -
The mover moves infinitely forwards or backwards.

Stop
► Click on Stop to stop the function Endless + or Endless -
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7.8.4.4 Modulo / Modulo shortest way / Modulo plus direction / Modulo minus direction
The mover moves to a defined position with these functions. De-
pending on the selected modulo function, the mover travels the
shortest distance, forwards or backwards to the target position. The
following functions are available:

Modulo The mover moves to the target position. If the value in the input field
Target Position is negative, the mover moves backwards to the tar-
get position.

Modulo shortest way The mover moves forwards or backwards the shortest way to the
target position. It is not possible to enter a negative value in the in-
put field Target Position .

Modulo plus direction The mover only moves forward to the target position. It is not possi-
ble to enter a negative value in the input field Target Position.

Modulo minus direction The mover only moves backwards to the target position. It is not
possible to enter a negative value in the input field Target Position.

Modulo example
The input of values is shown using the function Modulo as an exam-
ple.

Starting
► Select Modulo in the drop-down menu Start Mode

► Enter a value for the target position in the input field Target Posi-
tion

► Enter a value for the velocity in the input field Target Velocity
► If required, activate the checkbox Acceleration to enter a value

for the acceleration in the input field
► If required, activate the checkbox Deceleration to enter a value

for the deceleration in the input field
► If required, activate the checkbox Jerk to enter a value for the

jerk in the input field
► Click on Start to start the function Modulo
The mover moves to the target position entered.
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Stop

Stopping only during the procedure
The function can only be stopped during the movement to the target
position. After moving to the target position, the button Stop is auto-
matically disabled.

► Click on Stop to stop the function Modulo
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7.8.4.5 Reversing Sequence
With this function, the mover moves back and forth between two po-
sitions.

Starting
► Select Reversing Sequence in the drop-down menu Start Mode

► Enter a value for the first target position in the input field Target
Position1

► Enter a value for the velocity in the input field Target Velocity
► Enter a value for the second target position in the input field Tar-

get Position2
► Enter a value for the idle time at the target in the input field Idle

Time
► Click on Start to start the function Reversing Sequence
The mover now moves continuously back and forth between the two
target positions.

Stop
► Click on Stop to stop the function Reversing Sequence
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7.8.4.6 Start/Stop Sequence
With this function, the mover travels a defined distance to the next
stop and executes this function permanently.

Starting
► Select Start/Stop Sequence in the drop-down menu Start Mode

► Enter a value for the distance to the next stop in the input field
Target Position

► Enter a value for the velocity in the input field Target Velocity
► Enter a value for the idle time at the target in the input field Idle

Time
► Click on Start to start the function Start/Stop Sequence
The mover now travels the entered distance continuously until the
next stop.

Stop
► Click on Stop to stop the function Start/Stop Sequence
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7.8.4.7 Velo Step Sequence
With this function, the mover moves between two target positions at
two different velocities.

Starting
► Select Velo Step Sequence in the drop-down menu Start Mode

The distances between the first and second target positions can
be different, as they depend on the two velocities and the identi-
cal travel time.

► Enter the velocity values in the input fields Target Velocity1 and
Target Velocity2

► Enter a value for the driving time in the input field Driving Time
► Enter a value for the idle time at the target in the input field Idle

Time
► Enter a value for the number of driving cycles in the input field

No of cycles
► Click on Start to start the function Velo Step Sequence
The mover now travels the entered number of travel cycles or per-
manently the time-dependent route to the two target positions.
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Stop

Stop depending on No of cycles
If no value has been entered in the input field No of cycles, the
mover moves continuously. The function can be ended at any time
using the Stop button.
If a value has been entered in the input field No of cycles, the mover
stops automatically after the entered number of cycles and the Stop
button is automatically disabled. The cycles can be ended at any
time using the Stop button.

► Click on Stop to stop the function Velo Step Sequence
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7.8.4.8 Sine Sequence (Bode)
With this function, the mover moves forwards and backwards peri-
odically.

Starting
► Select Sinus Sequence (Bode) in the drop-down menu Start

Mode

► Enter values for the frequencies in the input fields Start Fre-
quency and Stop Frequency

► Enter a value for the number of frequencies in the input field Fre-
quency Steps

► Enter a value for the velocity in the input field Sinus Base Veloc-
ity

► Enter a value for the feed motor in the input field Feed Constant
Motor

► Click on Start to start the function Sinus Sequence (Bode)

Stop

Stopping only during the procedure
The function can only be stopped during the movement to the target
position. After moving to the target position, the button Stop is auto-
matically disabled.

► Click on Stop to stop the function Sinus Sequence (Bode)
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7.9 Coupling movers
You have the option of coupling different NC axes with each other
and moving several movers simultaneously.

Mover positions are retained
With the linear coupling of movers with a coupling factor of 1, the
current positions of the movers to be coupled are used and the dis-
tance between the movers is maintained when the movers are
moved.

Coupling example NC axis 2 with NC axis 1
The coupling of the movers is described using NC axis 2 with NC
axis 1 as an example.

► Expand Solution Explorer > TwinCAT Project > MOTION > Axes
► Click on  Mover Axis 2

The selected NC axis is not listed, as the NC axis cannot be cou-
pled with itself.

► In the project window, click on the Coupling tab
► Select the axis in the drop-down menu Master Axis to which the

axis is to be coupled
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► Click on Couple to couple the NC axes

7.10 Decoupling movers
► Expand Solution Explorer > TwinCAT Project > MOTION > Axes
► Click on Mover Axis 2

► In the project window, click on the Coupling tab
► Click on Decouple to decouple the NC axis
The NC axis is decoupled and can be coupled with another NC axis
or moved individually.
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8 XTS Tools

8.1 XTS Tool Window
The XTS Tool Window is the user interface for all XTS-related com-
ponents of your TwinCAT project. It is the main page to control all
XTS systems of your running project. In the XTS Tool Window you
will find helpful tools such as the XTS Configurator, the XTS Simula-
tion Builder and the XTS System View.

8.1.1 Activation of the XTS Tool Window
After you have successfully installed TF5850 TC3 XTS Extension
and opened a new project in TwinCAT 3 XAE (TcXaeShell or VS
2013), you must first activate the XTS Tool Window.

► In the menu TwinCAT click on the menu item XTS
► Click on XTS Tool Window in the submenu
XTS Tool Window opens.
Like all other dialog boxes, you can place the XTS Tool Window in
the Visual Studio environment.
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8.1.2 Operating elements
The list shows the most important controls:

Project selection drop-down menu
Displays the selected project and lists the available projects.

Update
Updates the contents of the selected project.

Open XTS Configurator
Opens the XTS Configurator to configure the hardware.

Open XTS Simulation Builder
Opens the XTS Simulation Builder to configure a simulated system.

Open XTS IO Timing Configurator
Opens the XTS IO Timing Configurator for configuring the real-time
and distributed clocks.

Theme drop-down menu
Displays the selected theme and lists the available themes.

Options
Opens the dialog box Options…

Zoom window width
Scales the view to the window width.

Zoom original size
Scales the view to the preset original size.

Custom zoom
Scales the view to the custom size.

XTS Parts tab
Lists all XTS Parts of the current configuration.
Displays the properties of all XTS Parts.

XTS Tracks tab
Lists all XTS Tracks of the current configuration.
Displays the properties of all XTS Tracks.

XTS Mover tab
Lists all XTS Movers in the current configuration.
Displays the properties of all XTS Mover.

XTS Stations tab
Lists all XTS Stations of the current configuration.
Displays the properties of all XTS Stations.
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8.1.3 Information lists
The information lists of Parts, Tracks, Movers and Stations provide
detailed information about the respective objects and their proper-
ties.

8.1.3.1 Information list Parts
► Click on the Parts tab to call up the information list Parts
The information list Parts displays all parts of the currently selected
processing unit and provides information about the length, orienta-
tion and position in the coordinate system in the XTS View.
A processing unit can be selected using the filter in the upper area.
The parts belonging to the processing unit are listed.
In the lower list all modules of a part are listed with the most impor-
tant information. Selected modules are highlighted in the list and in
the view.

8.1.3.2 Information list Tracks
► Click on the Tracks tab to call up the information list Tracks
A processing unit can be selected via the filter in the upper area.
The information list Tracks shows all tracks of the currently selected
processing unit.
Selected tracks are visualized in the view.
All parts of a track are listed in the lower list. In addition, important
information of the part is displayed.
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8.1.3.3 Information list Movers
► Click on the Movers tab to call up the information list Movers
The information list Movers shows all movers of the currently se-
lected processing unit and provides information about the NC axes,
the SoftDrive and the simulation settings.
A processing unit can be selected using the filter in the upper area.
The movers belonging to the processing unit are listed.
Selected movers are highlighted in the list and in the view.

8.1.3.4 Information list Stations
► Click on the Stations tab to call up the information list Stations
The information list Stations shows all stations and their properties.
The start position and the end position on the respective part as well
as all stop positions are listed.
The stations are visualized in the view.
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8.1.4 Open Options... dialog box
Numerous options are available for configuring the XTS View. The
settings of the XTS View are stored in so-called themes. These
themes can be edited and used by all windows that can display XTS
Views.
► Click on the button Options…
The dialog box Options opens.
Further information can be found in chapter "Dialog box Options…",
[Page 353].
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8.2 XTS Simulation Builder
With the XTS Simulation Builder you can create virtual constructions
of the XTS hardware in Sandbox style and generate I/O components
for simulation in TwinCAT.
The creation and adjustment of a virtual XTS system is fully sup-
ported by the XTS View, so that you can operate the XTS Simula-
tion Builder intuitively. In addition, many configuration options of the
XTS software are supported so that you can make full use of the
tool for planning and simulating new XTS systems.

Example configuration
In this example configuration, a closed XTS system with 180°
clothoids and ten movers is set up, corresponding to the configura-
tion of a 3 m XTS starter kit.

8.2.1 Open XTS Simulation Builder
► Activate the XTS Tool Window as described in the chapter "XTS

Tool Window", [Page 224]

► Click on the button Start the XTS Simulation Builder... in the
XTS Tool Window

The XTS Simulation Builder opens.
When the XTS Simulation Builder is opened, the start page shows a
welcome screen with information on the interactive usage options of
the XTS Simulation Builder.
► If necessary, enlarge window for better operability
► If required, activate the checkbox Don't show this again to hide

the welcome screen
You can reactivate the function at any time via the menu item Op-
tions....
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Below the welcome screen is a list of templates from which you can
select preconfigured XTS systems. You can easily change the tem-
plates with just a few parameters, for example to adjust the length of
the system or the type of curve segments.

8.2.1.1 Controls

Start page
The list shows the most important controls:

Preview and edit
Opens the page for previewing and editing the template.

Generate system
Accepts the template as a system and opens the page Builder.

Open sidebar
Opens the sidebar.

Close sidebar
Closes the sidebar.

Button Go To Previous Step
Opens the previous page.

Button Go To Next Step
Opens the next page.
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8.2.2 Open template
For a quick start, you can use one of the templates and adapt it to
the desired size of the system if required.

► Click on the button Oval Template
The Preview & Edit Template... dialog box opens. The exact config-
uration of the system with the set parameters is displayed and can
be adjusted and edited.

The small preview image shows the shape of the selected XTS sys-
tem. The large display shows the exact system size and module ar-
rangement for the set parameters.
► Select an XTS system in the drop-down menu
► Enter values for the exact system size in the input fields Length

and Typical Feed-in Length
► Select the curve segment type of the modules in the drop-down

menu Curve Type
► Click on the button Create System from template and go to

next page. to continue
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8.2.3 Simulate XTS system

The following pages describe how to set up an XTS system with the
XTS Simulation Builder without using a template. The functions de-
scribed are also available when using a template. The variant with
template is therefore not described separately.

► Click on the button Go To Next Step to continue
OR
► Click on the button >> to expand the sidebar
Further information on the sidebar can be found in chapter "Side-
bar", [Page 254].

Navigation with buttons or the sidebar
The pages can be accessed using the buttons Go To Previous Step
and Go To Next Step or using the sidebar. Both variants can be
combined with each other at any time.

The individual steps are described using the variant with the buttons
Go To Next Step as an example.

The page Configure opens.
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8.2.3.1 Modules

The tab Modules contains all the functions for adding, removing, re-
placing or changing modules.
Existing modules can be selected by clicking on a single module, by
clicking on several modules while holding down the Ctrl or Shift key
or by clicking on all modules while holding down the Alt key.

Controls
The list shows the most important controls:

Add
Module

Add module
Adds a module before or after the selection in the module list or re-
places an existing module.

Remove
Module

Remove module
Removes one or more selected modules.

Modules drop-down menu
Displays the available modules. The module type can be selected or
added directly by double-clicking.

End of
Part

Insert at the end of the part
Activates the insertion of a new module at the end of the active part.

After
Selection

Insert after selection
Activates the insertion of a new module after the selected module. If
several modules are selected, a new module is added after each
module.

Before
Selection

Insert before selection
Activates the insertion of a new module before the selected module.
If several modules are selected, a new module is added before each
module.

Replace
Selected

Replace selection
Activates the replacement of the selected module with a new mod-
ule. If several modules are selected, each module is replaced by a
new module.

  Change
Infeed Type

Infeed Type drop-down menu
Displays the available infeed types and changes it for the selected
module. If several modules are selected, all infeed types are
changed.



XTS Tools

234 ─── Version: 1.1.1TF5850

Add modules
► Double-click on AT2050-0500 to add the module to the XTS

System View
OR
► Click on AT2050-0500 to select the module

► Click Add Module

The module is displayed in the XTS System View.

► Double-click on AT2001-0250 to add the module to the XTS
System View

OR
► Click on AT2001-0250 to select the module

► Click Add Module

The module is displayed in the XTS System View.

► Double-click on AT2000-0250 to add the module to the XTS
System View

OR
► Click on AT2000-0250 to select the module
► Add three more modules AT2000-0250 in the same way
The modules are displayed in the XTS System View.
► Add one module AT2050-0500 and AT2001-0250 and three

modules AT2000-0250 in the same order



XTS Tools

Version: 1.1.1 ─── 235TF5850

The system is closed and completed.

8.2.3.1.1 Check modules
You can click on the modules in the menu in the left-hand column to
obtain further information.

► Click on a module
The following information is displayed under Details:

• Gap
• Length of the selected module

Selected modules are highlighted in the list and in the XTS System
View.
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8.2.3.2 Parts

The Parts tab contains all settings and functions for creating and re-
moving parts.
Parts can be selected by clicking on a single module, by clicking on
several modules while holding down the Ctrl or Shift key or by click-
ing on all modules of a part while holding down the Alt key.
You can move parts in the coordinate system of the XTS view while
pressing and holding the Alt key and the left mouse button. The X-
coordinates and Y-coordinates are then automatically adjusted. Al-
ternatively, you can move a part by changing the coordinates manu-
ally. With the function Module-Side you can choose between the
front and rear view of the modules.

Controls
The list shows the most important controls:

Add
Part

Add Part
Adds a part to the selected Processing Unit

Template

Add from template
Opens the dialog box Add part from template... for inserting a part
from a template.

Remove
Part

Remove Part
Removes the selected part from the selected Processing Unit.

Split

Split Part
Creates a separate part from the selected modules of a part.

Keep
Position

Keep Position
Keeps the positions of the modules when splitting a part.

Merge

Merge Parts
Adds two selected parts to the first selected part.

Module-Side drop-down menu
Displays the selected module side and lists the available module
sides.

Rotation drop-down menu
Allows you to select a preset angle between -180° and 180° or enter
your own value. The reference point is the first module of a part.

X-Offset input field
Allows you to enter an offset for the reference point of the first mod-
ule of a part on the X coordinate.
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Y-Offset input field
Allows you to enter an offset for the reference point of the first mod-
ule of a part on the Y coordinate.

Show
Close Gap

Show Close Gap
Shows the distance from the starting point to the end point of a part
with a line. The exact distance of the X-coordinate and Y-coordinate
are displayed as a tooltip when the mouse pointer is moved over the
displayed value. If the button Show Close Gap is activated, all dis-
tances are also shown in the status bar.

Add Part
All added modules are automatically assigned to a part. If required,
the system can be split into several parts.

Example configuration
In this example configuration, one part is sufficient. The following de-
scription is for explanatory purposes only.

► Click on the tab Parts

Split the system into parts
► Press and hold the button Ctrl to click on all modules that are to

be added to a new part

► Click on Split
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The selected modules are removed from Part  1. A new Part  2 is
added with the selected modules.

Check parts
You can click on the parts in the menu in the left-hand column to ob-
tain further information.

► Click on a part
The following information is displayed under Details:

• Alignment in the coordinate system
• Position in the coordinate system

Selected parts are highlighted in the list and in the XTS System
View.
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Set properties You can select for each part whether the front or the back of the
XTS modules is to be shown and how the position and installation
position are to be displayed. With these properties, every possible
view of an XTS system can be tested or adapted to your existing
XTS system.

Module side

Front Back

► Select the module side in the drop-down menu Front Side

► Enter values for the position of the part in the input fields X and
Y

► Enter the value for the installation position of the part in the Al-
pha input field

Example configuration
In this example configuration, the part is positioned in the center
of the XTS System View, the front is selected as the view, and
the installation position is left at 0°.

► Press and hold the left mouse button and the Alt key to move
the part into the correct position
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8.2.3.3 Movers

The tab Movers contains all the functions for adding, removing, re-
placing or changing movers.
Movers can be selected by selecting a single mover, by selecting
several movers while holding down the Ctrl or Shift key or by select-
ing all movers while holding down the Alt key.

Controls
The list shows the most important controls:

Add
Mover

Adding movers
Adds a mover.

Remove
Mover

Remove Mover
Removes the selected mover(s).

Input field number of movers
Allows you to enter the required number of movers.

Apply number
Applies the number from the input field.

Mover selection drop-down menu
Displays the available mover types and allows you to select the
mover type.
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Adding movers
You have the option of adding a single mover or several movers at
the same time.

► Click on the tab Movers

► Expand the drop-down menu if required

Single movers
► Double-click on AT9011-0070, to add the mover to the XTS Sys-

tem View
OR
► Click on AT9011-0070 to select the mover

► Click on Add Mover
► Add more movers in the same way

Multiple movers
► Click on AT9011-0070 to select the mover

► Enter the number of movers in the input field Edit the Mover
Count of the active Part

► Click on the button Apply to add the number of movers

The movers are added to the system.
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Check movers
You can click on the movers in the menu in the left-hand column to
obtain more detailed information.

► Click on a Mover
The following information is displayed under Details:

• Name of the mover
• Start position of the mover
• Part on which the mover starts

Selected movers are highlighted in the list and in the XTS System
View.
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8.2.3.4 Tracks

The tab Tracks contains all the functions for adding and removing
tracks.
You can select the tracks from the list. The parts and modules of the
track are then marked with a green line.

Controls
The list shows the most important controls:

Add
Empty

Add empty track
Adds an empty track.

Remove
Track

Remove Track
Removes the selected track.

Create
from Parts

Create track
Creates a track from the selected parts. The order of the parts within
the track is defined by the order in which the parts are selected

Show
Close Gap

Show Close Gap
Shows the distance from the starting point to the end point of a part
with a line. The exact distance of the X-coordinate and Y-coordinate
are displayed as a tooltip when the mouse pointer is moved over the
displayed value. If the button Show Close Gap is activated, all dis-
tances are also shown in the status bar.

Add Track
All added parts are automatically assigned to a track. If required, a
system with several parts can be split into several tracks.

► Click on the tab Tracks
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Split system into tracks

Example configuration
In this example configuration, one track is sufficient. The following
description is for explanatory purposes only.

► In the menu or in the XTS System View, click on all parts that
are to be added to a new track

► Click on Create from Parts

A second track with the selected part is added.
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Check tracks
You can click on the tracks in the menu in the left-hand column to
obtain more detailed information.

► Click on a track
The following information is displayed under Details:

• Length of the track
• Closed or open system
• included in mover detection or not

The selected track is displayed with a green line in the XTS System
View.

Set properties

NOTICE
Avoid damage to the product and functional errors
Be sure to correctly specify whether you are configuring a closed
XTS system or an XTS system with defined endpoints.
If the specification is incorrect, the movers may leave the XTS
system if the XTS system is open. In the case of a closed XTS
system with incorrect specification, the movers cannot travel in a
circle as usual.

► Activate the checkbox Is closed so that the movers can move
around the start/end position of the track

OR
► Deactivate the checkbox Is closed

For systems without Track Management or systems with only one
track, the checkbox Is included in detection must always be acti-
vated.

► Activate the checkbox Is included in detection so that all
movers are detected by a module that belongs to the part of this
track

OR
► Deactivate the checkbox Is included in detection
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8.2.3.5 Stations

The Stations tab contains all the functions for adding and creating
stations.

Controls
The list shows the most important controls:

Add
Station

Add Station
Adds a station.

Remove
Station

Remove Part
Removes the selected station.

Add Station
► Click on the tab Stations

► Click on Add Station

A station is added to the system.

► Click on Add Part over which the station should be drawn to
add a part to the station
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The station is displayed in color in the XTS System View.

Adding stop positions
► Click on Add stop position to add a stop position

► Enter a value for the stop position in the input field

The stop position is displayed as a diamond on the line of the sta-
tion.
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Check station
You can click on the stations in the menu in the left-hand column to
obtain further information.

► Click on a station
The following information is displayed under Details:

• Enabled or disabled
• ID of the station
• Color of the station
• Name of the station
• Description of the station
• Start position
• End position

The properties of the selected station are displayed under the menu.

Set properties
► Activate the checkbox Is enabled to show the station
OR
► Deactivate the checkbox Is enabled to hide the station
► Enter a value in the input field ID
► Choose a color from the drop-down menu Color
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].
► Enter a name for the station in the input field Name
► If required, enter a short description of the station in the Descrip-

tion input field
► Enter a value in the input field Start Position On First Part
► Enter a value in the input field End Position On Last Part
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8.2.3.6 Processing Unit
The tab Processing Unit contains all settings and functions for creat-
ing and removing Processing Units.
Processing Units can be selected by clicking on them in the list. Pro-
cessing Unit settings can be edited directly below the list after selec-
tion and important information are displayed.

Controls
The list shows the most important controls:

Add Processing Unit
Adds a Processing Unit.

Remove Processing Unit
Removes the selected Processing Unit.

Add Processing Unit
► Click on the tab Processing Unit

► Click on Add

A Processing Unit is added to the system.

► Click on the button Go To Next Step to continue
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8.2.3.7 Real-Time
In the last step, the real-time settings for the XTS system can be
made. 

Controls
The list shows the most important controls:

Load target CPU
Loads a new target CPU and overwrites existing CPUs.

Input field Number of CPUs
Allows you to enter the number of CPUs required.

Input field Number of isolated CPUs
Allows you to enter the number of isolated CPUs.

Apply number
Applies the number from the input field.

AUX Task display
Displays the configuration of the AUX task.

Move CPU upwards
Moves the selected task up one CPU.

Move CPU downwards
Moves the selected task down one CPU.

Remove task
Removes the selected task from the CPU.

Processing Unit and System button
Switches between the Processing Unit and System.

Add Processing Unit or TwinCAT System Task
Adds a Processing Unit or a TwinCAT System Task.

Remove Processing Unit
Removes the selected Processing Unit.

Open sidebar
Opens the sidebar.
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Close sidebar
Closes the sidebar.

Button Go To Previous Step
Opens the previous page.

Button Go To Next Step
Opens the next page.

Real-time settings
You have the option of making settings for the available TwinCAT
tasks and the Processing Units.

► Select a value in the drop-down menu Base Time of the CPU
The set value is adopted for the task connected to the CPU and the
number of cycle ticks is adjusted accordingly. Further information
can be found in chapter "Real-Time", [Page 305].

If all settings have been made correctly, you can go to Generation
Settings.

► Click on the button Go To Next Step to continue
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8.2.3.8 Generation settings
Finally, you can make general settings for I/O generation. For exam-
ple, you can choose whether a new project or a new Solution should
be created. You can also integrate the I/O objects into an existing
project.
The generation settings of the XTS Simulation Builder help you to
transfer the I/O configuration to an existing project or to generate a
new TC3 XAE project and a solution in Visual Studio.
If a TC3 project is already open, the option Modify TwinCAT Project
is available to add the I/O devices of the configured XTS system to
the existing project.
There are several options that can be selected when creating the
new project:

► Enter a name in the input fields Project Name and Solution
Name

By default, the names XtsProject and XtsSolution are preset.
Project Full Path and Solution Full Path specify the exact path
where the files are located after creation. These paths cannot be
edited and are only used for a better overview.
► Enter a file path in the input field Location
OR
► Click on ... to open the Project Location dialog box and select a

file path

► Activate the checkbox Append to Solution? to create a Solution
► Activate the checkbox Solution Directory? to add the project to

an existing Solution
If none of the options are selected, the project and the Solution are
in the same directory.

If errors occur when creating the Solution or project with the speci-
fied settings, the input fields with incorrect entries are highlighted in
red.
In this example, the Solution from the specified directory is to be ap-
pended. A warning appears as there is already a project and a Solu-
tion with the same name. If you continue with the creation, the exist-
ing files will be overwritten.
If all settings have been made correctly, you can create the Solution
or project.

► Click on the button Go To Next Step to continue

8.2.3.9 Completing the configuration
On the next page, you will see that all the information has been en-
tered and that the XTS Simulation Builder can generate the I/O ob-
jects.
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► Click on the button Go To Next Step to continue
If the checkbox Close automatically after finished is deactivated, the
page Finished is displayed.
► Click on x to close the XTS Simulation Builder
The XTS Simulation Builder closes. The I/O objects are created and
the project is ready for use.
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8.2.3.10 Sidebar
The sidebar can be expanded on every page of the XTS Simulation
Builder. The sidebar provides an overview of the pages of the XTS
Simulation Builder and can be used to navigate between the pages.

Controls
The list shows the most important controls:

Open sidebar
Opens the sidebar.

Close sidebar
Closes the sidebar.

Project loaded
Indicates that the project has been loaded. This button cannot be
clicked.

Start page
Displays the start page of the XTS Simulation Builder.

Button Configure
Opens the page Configure to configure the desired system.

Button Real-Time
Opens the page Real-Time to edit the real-time settings.

Button Generation Settings
Opens the page Generation Settings to edit the generation settings.

Button Summary
Opens the page Summary. The checkbox Close automatically after
finished can be activated or deactivated.

Button Build
Applies all settings and builds the configuration.
Closes the XTS Simulation Builder.

Page Finished
Indicates that all settings have been applied and the configuration is
finished. This page is only displayed if the checkbox Close automati-
cally after finished is deactivated.

Display Page open
Indicates that the page has been opened and exited with a button in
the sidebar.

Display Page edited
Indicates that the page has been opened and exited with the button
Go To Next Step.

Navigation
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Instead of navigating with the buttons Go To Next Step and Go To
Previous Step, you have the option of opening the sidebar and navi-
gating between the individual pages of the XTS Simulation Builder
using the buttons.

► Click on the button to open the sidebar

The sidebar opens. You can use the buttons to navigate between
the pages of the XTS Simulation Builder:
► Click on a button to call up the corresponding page

Completing the configuration
► Click on the button Build to build the configuration
OR

► Click on the button Go To Next Step to continue
The configuration is built and the XTS Simulation Builder closes.
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8.2.4 File
The File tab contains all general settings for the XTS Simulation
Builder, such as options and theme settings.

8.2.4.1 Controls
The list shows the most important controls:

Options
Opens the dialog box Options…

Import Construction
Opens the dialog box Import Construction... for importing an existing
xml system construction.

Export Construction
Opens the dialog box Export Construction... for exporting the current
system construction as an xml file.

Export Image
Opens the dialog box Export Image... for exporting the system con-
struction as a png file.

Theme drop-down menu
Displays the selected theme and lists the available themes.

8.2.4.2 Open Options... dialog box
► Click on the File tab
► Click on Open options…
The dialog box Options… opens.
Further information can be found in chapter "Dialog box Options…",
[Page 353].

8.2.4.3 Import system construction
► Click on the File tab
► Click on Import Construction…
The dialog box Import Construction... opens.
► Select an xml file on the PC
► Click Open
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8.2.4.4 Export system construction
► Click on the File tab
► Click on Export Construction…
The dialog box Export Construction... opens.
► Enter a name in the input field Filename
► Select a file path on the PC
► Click Save
The current system construction is saved as an xml file on your PC.

8.2.4.5 Export Image
You have the option of exporting current views.

► Click on the File  tab
► Click on Export Image…

The dialog box Export Image… opens.
► Select Current View in the drop-down menu Select the view to

export to save only one view of the system without borders
OR
► Select Full View in the drop-down menu Select the view to ex-

port to save the entire view
► If required, select a color for the background in the drop-down

menu Select the background color
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].
► Click on Copy to copy the view to the clipboard
OR
► Click on Save As... to save the view as a png image and select

the storage location
OR
► Cancel with Close
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8.3 XTS Configurator
The new user interface of the XTS software simplifies the work and
handling of the ever larger and more sophisticated track layouts im-
plemented with XTS. The simple pictorial structure makes a decisive
contribution to fast commissioning and intuitive operation. A large
number of XTS systems can be set up very easily, regardless of
length, shape or variant. The new configurator replaces the XTS
Manager, which was integrated in the XTS IO Driver object in the
previous software version.
A main aim of the XTS software is to support the Track Manage-
ment function. Using this function, you can split the XTS system into
individual sections, which you then join together to form continuous
tracks. This gives you the possibility to mechanically align individual
sections in different ways and thus use the movers more flexibly on
the XTS system.

Example presentation
This chapter shows the individual steps of the XTS Configurator. If
there is a different procedure between a closed XTS system and an
XTS system with Track Management, this is indicated in the text.

The individual steps of the XTS Configurator are shown as exam-
ples for the following two XTS systems:

Closed XTS system

A closed XTS system with 180° clothoids and ten movers, corre-
sponding to the configuration of a 3 m XTS starter kit.

XTS system with Track Management

XTS Track Management with four parts and six movers.
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The difference between these two configurations of an XTS system
is that in a closed XTS system the order of modules and movers al-
ways remains constant. The movers thus have only one possible
track on which they can move.
In an XTS system with Track Management, modules can change
their position and align with other modules. Thus, the order of mod-
ules and movers can be changed, as new tracks can be formed. To
be able to keep the overview of these functions, the parts and tracks
have been introduced.
The part is the physical hardware component on which the mover
travels, comparable to a road section for a car. The Track, on the
other hand, is the actual path that the mover follows. The path is
created by assembling the individual hardware components. In com-
parison with the car, a possible route with different roads is created.
Further information can be found in chapter "Basic principles", [Page
 26].
Parts and tracks are objects that can be created in the TwinCAT
project using the XTS Configurator. A simple XTS system can be
created with only one part and one track for all movers. More com-
plex XTS systems can consist of several Parts that are joined to-
gether to form different tracks. This opens up completely new possi-
bilities for handling XTS components.
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8.3.1 Open XTS Configurator
Before you open the XTS Configurator, you must create a project,
check your hardware, connect the system to the target PC and scan
the I/O devices. Further information can be found in chapter "Com-
missioning", [Page 198].
► Activation of the XTS Tool Window
► Further information can be found in chapter "XTS Tool Window",

[Page 224].

► Click on the button Start the XTS Configurator...

The XTS Configurator opens.
► If necessary, enlarge window for better operability
► Click on the button Go To Next Step to continue
OR
► Click on the button >> to expand the sidebar
Further information can be found in chapter "Sidebar", [Page 312].

Navigation with buttons or the sidebar
The pages can be accessed using the buttons Go To Previous Step
and Go To Next Step or using the sidebar. Both variants can be
combined with each other at any time.

The individual steps are described using the variant with the buttons
Go To Next Step as an example.
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8.3.2 System configuration

The Processing Unit page opens.
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8.3.2.1 Processing Units

XTS
On the first page of the XTS Configurator, the Processing Unit is
created. To get an overview, it is possible to filter the objects of the
Processing Unit.
Since software version 3.21.700, the Processing Unit has replaced
the XTS IO Driver object.

Controls
The list shows the most important controls:

Add Processing Unit
Adds a Processing Unit.

Naming Assistant
Opens the dialog box Rename…

Options
Opens the dialog box Options…

Remove Processing Unit
Removes the selected Processing Unit.

Open sidebar
Opens the sidebar.

Close sidebar
Closes the sidebar.

Button Go To Previous Step
Opens the previous page.

Button Go To Next Step
Opens the next page.
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Add Processing Unit

► Click the button + to add another Processing Unit
► If necessary, click the button x to remove a selected Processing

Unit

In this example configuration, one Processing Unit is sufficient. Mul-
tiple Processing Units are used when there is more than one inde-
pendent system on the IPC or in the project. Independent means
that none of the modules or movers are used by another XTS sys-
tem.

The following settings must be made for the Processing Unit:

Operation Mode
► Expand General
► Select Normal in the drop-down menu Operation Mode to spec-

ify that the system is in operation
OR
► Select Simulation in the drop-down menu Operation Mode to

specify that the system runs in simulation mode
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Mover
► Expand Mover
► Select the mover type in the drop-down menu Mover Type

► Select the magnetic plate set in the drop-down menu Magnet
Plate Type

► Select Ascending in the drop-down menu Mover Sort Order if
the movers are to be counted in ascending order from the sys-
tem zero point

OR
► Select Descending in the drop-down menu Mover Sort Order if

the movers are to be counted in descending order from the sys-
tem zero point

Mover ID detection
► Expand Mover ID Detection
► Select the number of Movers 1 in the drop-down menu ID Detec-

tion Mode
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Teaching

Note the revision number on the module
Teaching is only required for modules with a revision level less than
or equal to 17. For more information, refer to the chapter "Name
plate" in the XTS Standard original operating instructions.

Change teaching file number
Always change the number of the teaching file before commencing
with a new teaching. The old file will be used and overwritten if the
number of the teaching file is not changed or if the configuration is
not loaded.
Beckhoff recommends using the current date for the number of the
teaching file. For the first teaching on  April 3rd, 2021, for example,
the numbers 202104031 could be used and for the second teaching
on the same day the numbers 202104032 and so on.

► Expand Teaching
► Activate the checkbox Is Teaching Enabled to display the input

field Teaching File Number
OR
► Deactivate the checkbox Is Teaching Enabled to hide the input

field Teaching File Number
► Enter a number in the input field Teaching File Number
Further information can be found in chapter "Teaching functionality",
[Page 115].

Diagnostic
► Expand Diagnostic
► Activate the checkbox Auto Dump Writing to activate the auto-

matic writing of dump files
OR
► Deactivate the checkbox Auto Dump Writing to switch off the

automatic writing of dump files

If the Auto Dump Writing is activated, you can specify in which
cases a dump file should be written.

► Activate the checkboxes On Mover Detection Error, On Mover
Lost, On Failing ID Detection, On Module Error and On Mod-
ule Warning to write a dump file

OR
► Activate the checkboxes On Mover Detection Error, On Mover

Lost, On Failing ID Detection, On Module Error and On Mod-
ule Warning deto avoid writing dump files

► Click on the button Go To Next Step to continue
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8.3.2.2 Parts
After you have created the Processing Unit and added a Task, the
next step is to add parts.
A closed XTS system usually consists of a single part. For an XTS
system with Track Management, several parts are required.

Controls
The list shows the most important controls:

Filter Processing Unit
Filters the list based on the selected Processing Unit.

Processing Unit drop-down menu
Displays the selected Processing Unit and lists the available Pro-
cessing Units.

Add Part
Adds a part to the selected Processing Unit.

Remove Part
Removes the selected part from the selected Processing Unit. The
part remains in the list of available parts.

Naming Assistant
Opens the dialog box Rename…

Options
Opens the dialog box Options…

Theme drop-down menu
Displays the selected theme and lists the available themes.

Button Parts and Modules
Switches between the display of parts and modules.

Zoom window width
Scales the view to the window width.

Zoom original size
Scales the view to the preset original size.

Custom zoom
Scales the view to the custom size.

Open sidebar
Opens the sidebar.

Close sidebar
Closes the sidebar.



XTS Tools

Version: 1.1.1 ─── 267TF5850

Button Go To Previous Step
Opens the previous page.

Button Go To Next Step
Opens the next page.

Controls in the Parts tab
Add device
Opens the dialog box Choose Devices for Part... and shows the
available infeed lines.

Remove device
Removes the selected device from the selected part. The device re-
mains available in the list of available devices.

Move device upwards
Moves the selected device up one level.

Move device downwards
Moves the selected device down one level.

Controls in the dialog box
Choose Devices for Part…

Filter Devices
Only shows available devices in the list.

Filter infeed line
Only shows available infeed lines in the list.

Filter module
Only shows available modules in the list.

Button OK
Confirms the entries and closes the dialog box.

Button Cancel
Closes the dialog box without saving the entries.
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Add Part
► In the drop-down menu XTS Processing Unit select the Process-

ing Unit to which a Part is to be added
► Click + button to add a new part
► If required, click on the x button to remove a selected part

Filter
► Activate the Filter button to show only the parts of the selected

Processing Unit
OR
► Deactivate the Filter button to show the Parts of the entire

project

Part properties
► Click on a part in the Part List to display its properties
The properties of the selected part are displayed at Details: Part 1.
The information can also be read out using the XTS Utility in the
PLC.
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Depending on whether you want to configure a closed XTS system
or an XTS system with Track Management, the following steps differ
from each other.

Closed XTS system
The following steps are required if you want to configure a closed
XTS system.
Further information on the configuration of an XTS system with
Track Management can be found in chapter "XTS system with Track
Management", [Page 273].

Assigning devices
In the lower area of the detail display, you can select devices for
your part. Select the order of the devices according to their occur-
rence in the XTS system.

► Click on the button + to add a device

The dialog box Choose Devices for Part... opens.
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You have the possibility to filter the devices or to add only single in-
feed lines or modules to the selected part. You can choose from the
following filters:
• Select devices
• Select infeed lines
• Select individual modules

Select devices
► Click on the button Select devices to activate the filter
► Click on a device
OR
► Press and hold the Ctrl key to select multiple devices in the ap-

propriate order

Select infeed lines
► Click on the button Select infeed lines to activate the filter
► Click on an infeed line
OR
► Press and hold the Ctrl key to select multiple infeed lines in the

appropriate order

Select individual modules
► Click on the button Filter Module to activate the filter
► Click on a module
OR
► Press and hold the Ctrl key to select multiple modules in the ap-

propriate order

► Confirm with OK
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Checking devices
► Click the Zoom to fit button
The configured part is displayed and can be scaled to the appropri-
ate format.
► Check whether the correct devices have been selected in the ap-

propriate order

Sorting devices
If the order is not correct:
► Click on a device
► Use the arrow keys to move the device up or down
OR
► Click on the x button to remove a device
► Add more devices if needed
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Set properties Next you can set the properties of the parts. You can select for each
part whether the front or the back of the modules is to be shown and
how the position and installation position are to be displayed. With
these properties, every possible view of your XTS system can be
mapped and adapted to your existing XTS system.

Module side

Front Back

The value for the length cannot be changed in the properties.

► Select module side in the drop-down menu Module Side
► Enter the position of the part in the input fields X and Y
► Enter the value for the installation position of the part in the Al-

pha input field

Example configuration
In this example configuration, the part is positioned in the center of
the XTS System View, the front is selected as the view, and the in-
stallation position is left at 0°.

You can enter the values for the position of the part manually or
move the part to the correct position by holding down Alt and press-
ing the left mouse button.

► Click on the button Go To Next Step to continue

The following pages describe the steps required to configure the
parts for an XTS system with Track Management. The further steps
for a closed XTS system can be found in the chapter "Tracks",
[Page 278].
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XTS system with Track Management
The following steps are required if you want to configure an XTS
system with Track Management.
Further information on the configuration of a closed XTS system can
be found in chapter "Closed XTS system", [Page 269].

Assigning devices
Select the order of the devices according to their occurrence in the
XTS system. In this example configuration, four parts with one de-
vice each are required. Two of these parts consist of one movable
module and two further parts consist of four modules each, which
form a 1 m long, fixed module segment.

► Click on the button + to add a device

The dialog box Choose Devices for Part... opens.
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You have the possibility to filter the devices or to add only single in-
feed lines or modules to the selected part. You can choose from the
following filters:
• Device
• Infeed line
• Module

Select devices
► Click on the button Select devices to activate the filter
► Click on a device
OR
► Press and hold the Ctrl key to select multiple devices in the ap-

propriate order

Select infeed lines
► Click on the button Select infeed lines to activate the filter
► Click on an infeed line
OR
► Press and hold the Ctrl key to select multiple infeed lines in the

appropriate order
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Select individual modules
► Click on the button Select individual modules to activate the fil-

ter
► Click on a module
OR
► Press and hold the Ctrl key to select multiple modules in the ap-

propriate order

► Confirm with OK
To configure the XTS system with Track Management, three more
parts must be configured.
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Checking devices
► Click the Zoom to fit button
The configured parts are displayed and can be scaled to the appro-
priate format.
► Check whether the correct devices have been selected in the ap-

propriate order
► If necessary, press and hold the left mouse button and the Alt

key to move parts into the correct position

Sorting devices
If the order is not correct:
► Click on a device
► Use the arrow keys to move the device up or down
OR
► Click on the x button to remove a device
► Add more devices if needed
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Set properties Next you can set the properties of the parts. You can select for each
part whether the front or the back of the modules is to be shown and
how the position and installation position are to be displayed. With
these properties, every possible view of your XTS system can be
mapped and adapted to your existing XTS system.

Module side

Front Back

The value for the length cannot be changed in the properties.

► Select module side in the drop-down menu Module Side
► Enter the position of the part in the input fields X and Y
► Enter the value for the installation position of the part in the Al-

pha input field

Example configuration
In this example configuration, the parts are positioned in the center
of the XTS System View, the front is selected as the view, and the
installation position is left at 0°.

You can enter the values for the position of the parts manually or
move the parts to the correct position by holding down Alt and
pressing the left mouse button.

► Click on the button Go To Next Step to continue
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8.3.2.3 Tracks
The next step is to add Tracks.
A closed XTS system usually consists of a single track that contains
one or more parts. Several Tracks are required for an XTS system
with Track Management so that the movers can switch between dif-
ferent part combinations.

Controls
The list shows the most important controls:

Filter Processing Unit
Filters the list based on the selected Processing Unit.

Processing Unit drop-down menu
Displays the selected Processing Unit and lists the available Pro-
cessing Units.

Add Track
Adds a Track to the selected Processing Unit.

Remove Track
Removes the selected Track from the selected Processing Unit.

Naming Assistant
Opens the dialog box Rename…

Options
Opens the dialog box Options…

Theme drop-down menu
Displays the selected theme and lists the available themes.

Zoom window width
Scales the view to the window width.

Zoom original size
Scales the view to the preset original size.

Custom zoom
Scales the view to the custom size.

Add Part
Adds a part to the selected Processing Unit.

Remove Part
Removes the selected part from the selected Processing Unit. The
part remains in the list of available parts.

Close sidebar
Closes the sidebar.
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Button Go To Previous Step
Opens the previous page.

Button Go To Next Step
Opens the next page.

Add track
► In the drop-down menu XTS Processing Unit select the Process-

ing Unit to which a Track is to be added
► Click + button to add a new track
► If required, click on the x button to remove a selected track

Filter
► Activate the Filter button to show only the tracks of the selected

Processing Unit
OR
► Deactivate the Filter button to show all tracks of the entire

project

Track properties
► Click on a track in the Track List to display its properties
The properties of the selected track are displayed at Details:
Track 1. The information can also be read out using the XTS Utility
in the PLC.
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Define parameters
For each track you need to set the three most important parameters:

NOTICE
Avoid damage to the product and functional errors
Be sure to correctly specify whether you are configuring a closed
XTS system or an XTS system with defined endpoints.
If the specification is incorrect, the movers may leave the XTS
system if the XTS system is open. In the case of a closed XTS
system with incorrect specification, the movers cannot travel in a
circle as usual.

► Activate the checkbox Is closed if the XTS system is closed
OR
► Deactivate the checkbox Is closed if the XTS system is open

► Activate the checkbox Is included in detection if the XTS sys-
tem is closed or only has one track

OR
► Deactivate the checkbox Is included in detection if the XTS

system is open or has multiple tracks

If the XTS system contains tracks that share parts, you must define
which tracks perform the detection. It is important that each part
within a Processing Unit only occurs once in the detection process,
otherwise too many movers may be displayed and the startup of the
XTS system may be prevented.



XTS Tools

Version: 1.1.1 ─── 281TF5850

Add Parts Select the order of the parts according to their appearance in the
XTS system. Make sure that the parts form a continuous line on
which the movers can move.

► Click + button to add an XTS Part

► In the drop-down menu XTS Part select the Part to be added to
the current track

Closed XTS system

In this example configuration, the track contains only the previously
configured part. Thus, the circular track of the XTS system automati-
cally appears as a colored line.

A colored line appears outside the tracks assigned to the part. Using
this line you can check if the selected track is valid and if the parts
have been added in the correct order.

► Click on the button Go To Next Step to continue

XTS system with Track Management
A green line appears outside the tracks assigned to the part. Using
the green line you can check if the selected track is valid and if the
parts have been added in the correct order.
In this example configuration there are ten possible and reasonable
configuration variants of the tracks:
• each part as single track = 4 tracks
• both movable modules are positioned next to the upper or lower

part = 2 tracks
• only one of the movable modules is next to the lower and next to

the upper part = 4 tracks
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The more parts there are in the XTS system, the more possibilities
there are to connect them mechanically to form tracks. However, it
often does not make sense to configure as many tracks as possible.
Each part must be assigned to a track so that the mover detection
can be carried out. Additional tracks can be created on the XTS sys-
tem depending on the required movements of the movers.
In this example configuration, none of the tracks has a closed track,
so the checkbox Is Closed is not set for any of the configured tracks.
Since there are some tracks that share individual parts, the check-
box Is included in detection cannot be activated for every track . The
checkbox must be activated for the tracks that match the current
hardware configuration at the time of mover detection.

If both moving parts are next to the upper part, there are two tracks
in the current configuration.
• Track 5 consists of Part 1, Part 2 and Part 3
• Track 4 consists of Part 4

For these two tracks, the checkbox Is included in detection is acti-
vated to ensure that the correct number of movers is detected on
the XTS system. The checkbox is not activated for all other tracks.
If there are changes to the hardware configuration up to the time of
commissioning, you can redefine the parameter Is included in detec-
tion via the PLC. If necessary, this change should be made during
commissioning of the XTS system.
Often it is sufficient to include the track in the detection process.
However, this only works if there is no mover on the transition be-
tween two parts, otherwise too many movers will be detected by the
XTS system.

► Click on the button Go To Next Step to continue
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8.3.2.4 Stations

The Stations function is currently still in beta phase. In the future,
even more functions and information will be available and the cur-
rent interface may also change.

The Stations are very useful to visualize the XTS system and related
applications. A Station provides information about where individual
processes take place within the XTS system to illustrate the struc-
ture of the entire application.

Controls
The list shows the most important controls:

Add Station
Adds a station.

Remove Part
Removes the selected station.

Naming Assistant
Opens the dialog box Rename…

Options
Opens the dialog box Options…

Theme drop-down menu
Displays the selected theme and lists the available themes.

Zoom window width
Scales the view to the window width.

Zoom original size
Scales the view to the preset original size.

Custom zoom
Scales the view to the custom size.

Add Part
Adds a part to the selected station.

Part selection drop-down menu
Displays the selected part and lists the available parts.

Remove Part
Removes the selected part from the station. The part remains in the
list of available parts. This button is only visible if a part has been
added to the station.

Add stop position
Adds a stop position to the selected station.
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Remove stop position
Removes the selected stop position from the station. This button is
only visible if a stop position has been added.

Open sidebar
Opens the sidebar.

Close sidebar
Closes the sidebar.

Button Go To Previous Step
Opens the previous page.

Button Go To Next Step
Opens the next page.

Adding station
► Click on the + button to add a station
► If required, click on the x button to remove a selected XTS sta-

tion

Station properties
► Click on a station in the Station List to display its properties
The properties of the selected station are displayed at Details: Sta-
tion 1. The information can also be read out using the XTS Utility in
the PLC.
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► Activate the checkbox Is Enabled to show the station in the XTS
View

OR
► Deactivate the checkbox Is Enabled to hide the station in the

XTS View
► Enter a value in the input field ID
► Choose a color from the drop-down menu Color
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].
► Enter a name for the station in the input field  Name
► If required, enter a short description of the station in the Descrip-

tion input field
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Start position and end position
A start position and an end position must be defined for each sta-
tion. It makes a difference whether you have created a single part or
multiple parts in your XTS system.
A single part
The following specifications must be observed for a single part:
• The value in the input field End Position On Last Part must be

greater than the value in the input field Start Position On First
Part

• The entered value in the input field End Position On Last Part
can only be smaller than the entered value in the input field Start
Position On First Part, if the part is added a second time to the
Parts

Symbol Explanation
Start position of the station, Start Position On First
Part

End position of the station, End Position On Last
Part
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Multiple parts
The following specifications must be observed for multiple parts:
• The start position is on the first part and the end position on the

last part of the selected list
• The order of the parts must be selected according to their ap-

pearance in the XTS system. The parts must form a continuous
line on which the movers can move

Further information can be found in chapter "Add Part", [Page 288].

Symbol Explanation
Start position of the station, Start Position On First
Part

End position of the station, End Position On Last
Part

► Enter a value in the input field Start Position On First Part
► Enter a value in the input field End Position On Last Part
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Add Part
The stations have precisely defined start positions and end posi-
tions. The start position is on the first part and the end position on
the last part of the selected list. For all other parts of the list, the sta-
tion stretches over the full length.

Select the order of the parts according to their appearance in the
XTS system. Make sure that the parts form a continuous line on
which the movers can move.

Closed XTS system

In this example configuration, the station only contains the previ-
ously configured part. For example, a simple station is created.

► Click on the + button to add a part
► If required, click on the x button to remove a selected part

► Select a part in the drop-down menu
► Add and select additional parts as needed

The station is displayed as a line outside the track. If the line is not
displayed or the line is not continuous, check the entries of the start
positions and end positions as well as the order of the parts.
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XTS system with Track Management

In this example configuration, a simple feeder station is created on
the previously configured Part 3.

► Click on the + button to add a part
► If required, click on the x button to remove a selected part

► Select a part in the drop-down menu
► Add and select additional parts as needed

The station is displayed as a line outside the track. If the line is not
displayed or the line is not continuous, check the entries of the start
positions and end positions as well as the order of the parts.
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Adding stop positions
After all parts for the station have been added and selected, stop
positions for the movers can be defined.

Stop position within the station
A new stop position is always automatically located at the start of
the station with the position 0 mm. When entering the position, make
sure that you move the position from the start of the station and that
the value is within the defined length of the station.
Example of a stop position

While the station shown has a start position of 300 mm and an end
position of 1200 mm on the part, these values do not apply to the
stop position. Only values between 0 mm and 900 mm can be as-
signed for the stop positions, which corresponds to the length of the
station. In this example, an entered value of 300 mm for the stop po-
sition corresponds to a position of 600 mm on the part.

► Click on the + button to add a stop position

► Enter a value for the stop position in the input field

The stop position is displayed as a diamond on the line of the sta-
tion.

► Click on the button Go To Next Step to continue
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8.3.2.5 Movers
In this step, the movers for the XTS system are added. Each mover
is connected to an NC axis and communicates with the NC via its
SoftDrive object. Each XTS system requires at least one mover.

Controls
The list shows the most important controls:

Filter Processing Unit
Filters the list based on the selected Processing Unit.

Adding movers
Adds a mover to the selected Processing Unit.

Input field number of movers
Allows you to enter the required number of movers.

Keep mover
Deactivates excess movers if the number of movers entered in the
input field is less than the existing number of movers.

Apply number
Applies the number from the input field.

Display Mover activated
Indicates that the mover is activated in the project.

Display Mover deactivated
Indicates that the mover is deactivated in the project.

Remove Mover
Removes the selected mover.

Export parameter set
Opens the dialog box Export Parameter Set…

Import parameter set
Opens the dialog box Import Parameter Set…

Reset parameter set
Resets the parameter sets of all movers to the default settings.

Activation of the copy template of the parameter sets
Activates or deactivates the parameter set copy template.

Parameter set copy template input field
Allows you to enter the copy template of the parameter sets that are
to be applied to the movers of the selected Processing Unit.

Display of the parameter set copy template
Displays the copy templates of the parameter sets.
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Naming Assistant
Opens the dialog box Rename…

Options
Opens the dialog box Options…

Theme drop-down menu
Displays the selected theme and lists the available themes.

Zoom window width
Scales the view to the window width.

Zoom original size
Scales the view to the preset original size.

Custom zoom
Scales the view to the custom size.

Open sidebar
Opens the sidebar.

Close sidebar
Closes the sidebar.

Button Go To Previous Step
Opens the previous page.

Button Go To Next Step
Opens the next page.
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Filtering movers
► Activate the Filter button to show only the movers of the se-

lected Processing Unit
OR
► Deactivate the Filter button to show all movers of the entire

project

Adding movers
You have the possibility to use existing axes or to create new ones.

Use existing axes
The following dialog box opens if you have already configured NC
axes in the project with a SoftDrive object that are not yet linked.

► In the drop-down menu XTS Processing Unit, select the Pro-
cessing Unit to which movers are to be added

► Activate the checkbox Yes, but only for selected axes if not all
axes are to be selected

► Select individual axes
► Confirm with OK
If the dialog box is closed with Cancel, it will open again the next
time if there are still unused axes in the project.

Creating new movers
► In the drop-down menu XTS Processing Unit, select the Pro-

cessing Unit to which movers are to be added

► Select the mover type used from the drop-down menu Mover
Type

► Select the corresponding magnetic plate set of the mover in the
drop-down menu MagnetPlateType
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Individual movers
► Click on the + button to add a new mover

Multiple movers
► Enter the number of movers required in the input field Number of

Movers 
► Click on the Apply button to add the number of movers
The distance from the center of the mover to the center of the mover
is 80 mm.
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Remove Mover
You have the possibility to remove a single mover or several movers
at the same time. When removing multiple movers, you have two
options.

Single movers
► In the Mover List, click on a mover that is to be removed
► Click on the x button to remove the selected mover

Multiple selected movers
► Press and hold the Ctrl key to select multiple movers in the

Mover List
► Click on the x button to remove the selected movers

Any several movers
► Deactivate the button Keep existing Movers on Apply

► Enter the number of movers required in the input field Number of
Movers

► Click on the Apply button
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At the end of the Mover List, as many movers are deleted until the
number of movers corresponds to the value in the input field Num-
ber of Movers.
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Disabling movers
You can disable single movers or several movers at the same time.
By disabling them, the movers and their properties are preserved
and do not need to be recreated later.

Single movers
► Click on the button Enable/Disable State of a mover to disable

the mover
► If required, click on the button Enable/Disable State of a mover

to enable the mover again

Multiple movers If the Keep existing Movers on Apply button is enabled, the movers
will not be removed, but disabled.

► Activate the button Keep existing Movers on Apply

► Enter the number of movers required in the input field Number of
Movers

► Click on the Apply button

At the end of the Mover List, as many movers are disabled until the
number of movers corresponds to the value in the input field Num-
ber of Movers.
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Mover properties

In this example configuration, we add a total of ten movers to the
XTS system. These movers are automatically lined up on the first
part of the selected Processing Unit. The movers can be selected to
display their properties.

You can give each mover, NC axis and SoftDrive object its own
name. If no name is assigned, the movers are numbered in se-
quence. When adding or removing movers, note that this may
change the naming order.

► If required, enter a name in the input fields Name, Axis Name
and SoftDrive Name

Simulation settings
To test the behavior of the movers virtually, you can create a simula-
tion. There are three possible settings for the movers in this simula-
tion:
• Selection of a part
• Determination of a precise position
• Using a mover as Mover 1

► In the drop-down menu Part select a part on which the mover is
to start

► Enter a value for the exact position of the mover on the part at
Position 

If the MoverIdDetection is activated, the value in the input field ID
defines whether the XTS Mover is created as Mover  1. Otherwise
the input field ID remains without an entry.

► Enter a mover ID in the input field ID
► Make sure that the number of IDs defined matches the settings

of the Parameters (Init) tab under the Processing Unit object.
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Parameter Sets
By creating and reusing Parameter Sets, you can transfer special
properties, such as the controller settings for a specific mover load-
ing, from one mover to another. Furthermore, you have the possibil-
ity to use different standard Parameter Sets for different movers.
By default, new movers receive the Parameter Set that corresponds
to the specified mover type. However, you have the option to assign
an empty Parameter Set to each mover.
Movers that have already been created do not have a Parameter
Set and will not be changed when the Configurator is run unless
they are assigned a different Parameter Set.

The Parameter Sets are defined for movers without load. If you use
the movers with a load, the Parameter Sets must be adjusted. If you
have any questions, please contact the product specialist responsi-
ble for your region.

Selecting a Parameter Set
► Select a Parameter Set from the drop-down menu Parameter

Set

Creating a Source Set
► Click on the button Source Set of a mover
A Source Set is added. The first Source Set is named A1. If there
are already several Source Sets, continue with the next letter of the
alphabet. For example, if there are already three Source Sets, the
next Source Set will be named D1.
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Selecting a Source Set
► Activate the button Enable or disable Parameter Copy Pattern

to enable the input field Edit the Parameter Copy Pattern 

The Source Set can be selected manually for each mover.

Transfer source set
You can transfer Source Sets to single or multiple movers. You can
select a Source Set for each single mover or define one or more
Source Sets using the Parameter Copy Pattern function. If different
Source Sets are selected, this order is transferred to all movers of
the selected Processing Unit.

To a single mover You can select Source Sets from the drop-down menu Parameter
Sets and transfer them to other movers.

► Select a Parameter Set from the drop-down menu Parameter
Set
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To multiple movers
► Click on Enable or disable Parameter Copy Pattern to enable

the input field for the Source Sets

Use existing Source Sets
If Source Sets have already been created, you can now enter them
in the input field in the desired order. Source Sets can also be used
several times.

► The sequence of the new Source Sets is adopted in the input
field Edit the Parameter Copy Pattern.

The entered Source Sets are transferred to the movers one after the
other.

Using new Source Sets
If no Source Sets have been created yet and Parameter Copy Pat-
tern is enabled, the new Source Sets will be applied in the order in
which you select them.

► Click on the button Source Set of a mover
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► Click on the Source Set button of another mover

► If required, click on the Source Set button of further movers

The sequence of the new Source Sets is adopted in the input field
Edit the Parameter Copy Pattern.

The order of the new Source Sets is transferred to all movers simul-
taneously.
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Exporting Source Sets
Source Sets can be exported and imported as well as saved on your
computer. This way you get a better overview of the different mover
settings.

► Click on the button Export a Parameter Set …

The dialog box Export Parameter Set ... opens.
► Select a Source Set for the export in the drop-down menu

Choose Parameter Set

By default, the name of the selected Source Set of a mover type is
copied to the input fields Name and Comment. For Source Sets that
are self-added, the name of the mover that provides the basis for
the Source Set is inserted.

► Enter a name for the Source Set in the input field Name
► If required, enter a comment in the input field Comment
► Confirm with Export As... to start the export
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Importing a Source Set
► Click on the button Import a Parameter Set …

The dialog box Import Parameter Set opens.
► Click the ... button to open the dialog box Open a Parameter

Set…
► In the dialog box Open a Parameter Set... select a correspond-

ing file on the computer

By default, the name of the selected Source Set of a mover type is
copied to the input fields Name and Comment.
► Confirm with Import to start the import
Imported Source Sets are added to the end of the Parameter Set list
and marked with @I and a consecutive number.

The Source Set is added to the list of Parameter Sets and can be
selected from the Parameter Set drop-down menu of a mover.

Resetting a Source Set
You can reset all movers to the default Parameter Set at the same
time.

► Go to and click the button Reset to Defaults

► Click on the button Go To Next Step to continue
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8.3.2.6 Real-Time
The last step is to make the real-time settings for the XTS system.

Controls
The list shows the most important controls:

Load target CPU
Loads a new target CPU and overwrites existing CPUs.

Input field Number of CPUs
Allows you to enter the number of CPUs required.

Input field Number of isolated CPUs
Allows you to enter the number of isolated CPUs.

Apply number
Applies the number from the input field.

AUX Task display
Displays the configuration of the AUX task.

Move CPU upwards
Moves the selected task up one CPU.

Move CPU downwards
Moves the selected task down one CPU.

Remove task
Removes the selected task from the CPU.

Processing Unit and System button
Switches between the Processing Unit and System.

Add Processing Unit or TwinCAT System Task
Adds a Processing Unit or a TwinCAT System Task.

Remove Processing Unit
Removes the selected Processing Unit.

Open sidebar
Opens the sidebar.

Close sidebar
Closes the sidebar.

Button Go To Previous Step
Opens the previous page.
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Button Go To Next Step
Opens the next page.

Real-time settings
You have the option of making settings for the available TwinCAT
tasks and the Processing Units.

► Select a value in the drop-down menu Base Time of the CPU
The set value is adopted for the task connected to the CPU. The
number of Cycle Ticks is adjusted accordingly.

Scan available cores
If you are using a real XTS system with a corresponding IPC, the
available cores of the IPC must be scanned. The cores can also be
isolated after scanning.

► Click on the button Read target CPU to scan the available cores

The dialog box Info opens.
► Confirm with Yes

The number of available cores is displayed in the left-hand field after
scanning.
The number of isolated cores that are fully used for TwinCAT is dis-
played in the right-hand field.
Further information on isolating cores can be found in chapter "Iso-
lating cores", [Page 311].
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Enable cores for TwinCAT

Example IPC with 4 cores
The procedure for distributing the tasks to the cores is shown as an
example for an IPC with 4 cores.

► Click on the button + of Available TwinCAT Tasks to call up the
overview of available cores and tasks

The dialog box Add TwinCAT Task opens.
The available cores and tasks are listed in the overview. The iso-
lated cores are identified by a colored marking of the respective line.

Each task may only run on one core and must be set to 250 µs.

► Activate the checkbox of the core CPU 3
► Ensure that the Base Time is set to 250 µs
► If required, select 250 µs in the drop-down menu Base Time
► Click on the arrow buttons Mover task CPU up and Mover task

CPU down to move the XTS Task 1 to the core CPU 3
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► Make sure that the Cycle Ticks of the XTS Task 1 of the CPU 3
core are set to 1

► If required, select 1 in the drop-down menu Cycle Ticks
► Activate the checkbox of the core CPU 2
► Make sure that the Base Time is set to 1 ms
► If required, select 1 ms in the drop-down menu Base Time
► Click on the arrow buttons Mover task CPU up and Mover task

CPU down to move the NC-Task 1 SVB and the NC-Task 1 to
the core CPU 2

► Activate the checkbox of the core CPU 1
► Make sure that the Base Time is set to 1 ms
► If required, select 1 ms in the drop-down menu Base Time
► Click on the arrow buttons Mover task CPU up and Mover task

CPU down to move the I/O Idle Task to the core CPU 1

► Deactivate the checkbox of the core CPU 0
► Confirm with OK
The dialog box Add TwinCAT Task is closed.
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The settings are displayed in the XTS Configurator and XTS Task 1
is added to XtsProcessingUnit 1.

Alternative view
You have the option of displaying the distribution of cores and tasks
in an alternative view. This view corresponds to the display of the
cores and tasks in the dialog box Add TwinCAT Task.

► Click on the System tab to display the alternative view

Add more cores
If you need more cores for your configuration, you can add them to
XtsProcessingUnit 1.

► Click on the button + of XtsProcessingUnit 1 to add further cores
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AUX Task for the Leave and Arrive functionality
An AUX Task under XtsProcessingUnit 1 is required for the Leave
and Arrive functionality.

► Click on the button AUX to add an XTS Aux Task to XtsPro-
cessingUnit 1

► Click on the button + of XTS Aux Task to add a task

The dialog box Assign Aux-Task to XTSProcessingUnit 1 opens.
► Activate the checkbox of a task to select it
► Confirm with OK
The selected task is added to the XTS Aux Task.

► Ensure that the Base Time is set to 250 µs
► If required, select 250 µs in the drop-down menu Base Time
► Make sure that the Cycle Ticks of the I/O Idle Task of the XTS

Aux Task are set to 1
► If required, enter 1 in the input field Cycle Ticks

► Click on the button Go To Next Step to continue
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Isolating cores
The number of available cores depends on the IPC used. Most sys-
tems have 4 or 12 cores, but 8 or 64 cores are also possible. Each
core used for the XTS system must be isolated. At least one core
must not be isolated in order to be able to use it for Windows. For
more information on the distribution of cores, please contact the
product specialist responsible for your region.

XTS Configurator must be closed
Isolating cores is only possible if the XTS Configurator is closed.

► Expand Solution Explorer > TwinCAT Project > SYSTEM
► Double-click on Real-Time

► Click on Read from Target to call up the distribution of the cores

► Click on Set on Target to change the distribution of the cores

NOTICE
Saving and closing other applications
As the IPC is automatically restarted after entering the cores to
be isolated, save and close all other applications that are open on
the IPC.

The dialog box Change number of shared cores opens.
► Enter the number of isolated cores using the arrow keys
OR
► Enter the number of isolated cores in the input field Available

(Shared/Isolated)
► Confirm with Set
The IPC restarts automatically.
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8.3.2.7 Sidebar
The sidebar can be expanded on every page of the Configurator.
The sidebar provides an overview of the Configurator pages and
can be used to navigate between the pages.

Controls
The list shows the most important controls:

Open sidebar
Opens the sidebar.

Close sidebar
Closes the sidebar.

Project loaded
Indicates that the project has been loaded. This button cannot be
clicked.

Start page
Displays the start page of the XTS Configurator.

Button Processing Units
Opens the page Processing Units to edit the Processing Units.

Button Parts
Opens the page Parts to edit the parts.

Button Tracks
Opens the page Tracks to edit the tracks.

Button Stations
Opens the page Stations to edit the stations.

Button Movers
Opens the page Movers to edit the movers.

Button Real-Time
Opens the page Real-Time to edit the real-time settings.

Button Summary
Opens the page Summary. The checkbox Close automatically after
finished can be activated or deactivated.

Button Build
Applies all settings and builds the configuration.
Closes the XTS Configurator.

Page Finished
Indicates that all settings have been applied and the configuration is
finished. This page is only displayed if the checkbox Close automati-
cally after finished is deactivated.
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Display Page open
Indicates that the page has been opened and exited with a button in
the sidebar.

Display Page edited
Indicates that the page has been opened and exited with the button
Go To Next Step.

Navigation
Instead of navigating with the arrow keys, you have the option of
opening the sidebar and using the buttons to navigate between the
pages of the XTS Configurator.

► Click on the button to open the sidebar

The sidebar opens. You can use the buttons to navigate between
the pages of the XTS Configurator:
► Click on a button to call up the corresponding page

Completing the configuration
► Click on the button Build to build the configuration
OR

► Click on the button Go To Next Step to continue
The configuration is built and the XTS Configurator closes.

8.3.3 Completing the configuration
After all the required settings have been made, you can complete
the configuration.
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► Click on the button Go To Next Step to continue
The changes are saved and the XTS Configurator closes.
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8.3.4 Checking the configuration
All configured TcCOM objects are displayed in the Solution Explorer
project tree.

You can view the configured XTS system in the XTS System View
of the XTS Tool Windows. Use the Zoom to fit function for a better
detailed view.
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The settings and properties of all configured objects can now be ac-
cessed in the information windows of the Parts, Tracks, Mover and
Stations.
► Check that all settings and properties are correct
► Change settings and properties if required

► Activate the button Filter to show only the objects of the selected
Processing Unit

OR
► Deactivate the button Filter to show all objects of the entire

project
If all settings are correct, you can put the configuration into opera-
tion. Further information can be found in chapter "Commissioning",
[Page 198].
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8.3.5 Naming Assistant

The naming assistant is available in the XTS Configurator for all
components. The procedure is illustrated using the renaming of a
Processing Unit as an example.

The name of the button of the naming assistant depends on the
component that is to be renamed. The appearance of the button is
identical on every page of the XTS Configurator and the name al-
ways begins with Choose names for.

► Click on the button to open the naming assistant
The naming assistant Rename Tasks and Processing Units...
opens.
You have the option of renaming one or more components at the
same time.

NOTICE
Do not use duplicate names
Be careful not to enter names that are already in use. This can
lead to configuration problems.

8.3.5.1 Renaming an individual component
► Enter a name in the input field New Name
► Confirm with Apply
The entry is saved and the dialog box closes.

8.3.5.2 Renaming multiple components
► Enter a name in the input field Base Name
► Enter a number in the input field Starting Number
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► Press and hold the Ctrl key to select several Processing Units in
the list

The number of selected Processing Units is displayed in the field
Count of selected renamings to which the pattern is applied .

Second tab for renaming the tasks
The Processing Unit naming assistant is the only one to have a sec-
ond tab. Tasks can be renamed in the same way using this second
tab.

► Click the button Apply Naming Pattern
The Base Name and the Starting Number are applied to the se-
lected Processing Units. The Starting Number is increased by the
value 1 one after the other.
► Confirm with Apply
The entry is saved and the dialog box closes.

8.3.6 Open Options... dialog box
► Click on the button Options…
The dialog box Options… opens.
Further information can be found in chapter "Dialog box Options…",
[Page 353].
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8.4 IO Timing Configurator
The IO Timing Configurator contributes to fast commissioning and
intuitive operation. It supports the setting of the distributed clocks re-
quired to synchronize all EtherCAT devices of the XTS system.

8.4.1 Checking I/O devices
The I/O devices that are not used for the XTS system must be dis-
abled so that the automatic settings for the XTS system can be
used. You can see whether the devices are enabled or disabled by
the display of the devices in the Solution Explorer:

Enabled
The device is enabled.

Disabled
The device is disabled

► Expand Solution Explorer > TwinCAT Project > I/O > Devices
► Check whether all XTS-relevant devices are disabled
If the devices are enabled, the devices must be disabled.

8.4.1.1 Disabling
► Press and hold the Ctrl key to select all XTS relevant devices
► Right-click on all XTS relevant devices to open the context menu
► Click Disable in the context menu
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8.4.2 Opening of IO Timing Configurator
► Activation of the XTS Tool Window
Further information can be found in chapter "Activation of the XTS
Tool Window", [Page 224].

► Click on the button Start the IO Timing Configurator … in the
XTS Tool Window

The IO Timing Configurator opens.
► If necessary, enlarge window for better operability
► Click on the button Go To Next Step to continue

8.4.3 DC Settings

The DC Settings page opens.
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8.4.3.1 Controls
The list shows the most important controls:

Button Automatic configuration settings
Applies the preset configuration settings for the devices.

Drop-down menu Reference Clock
Displays the reference clock selected for the device and lists the
available reference clocks.

Button Go To Previous Step
Opens the previous page.

Button Go To Next Step
Opens the next page.

Display DC Master
Identifies the selected DC Master.

8.4.3.2 Searching the device
In the DC Settings menu you have the possibility to search for de-
vices.

Name parts sufficient for the search
Only a part of the device name is needed for the search. All devices
that contain the entered string at any position in the device name are
listed.

► Enter a term or parts of the device name in the input field to
search for one or more devices

The search result for the entered string is displayed.
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8.4.3.3 Automatic configuration settings

NOTICE
Use automatic configuration settings
Beckhoff recommends using the automatic configuration settings
and not changing these values.

To use the automatic configuration settings, the I/O devices that do
not contain XTS components must be disabled. Further information
can be found in chapter "Checking I/O devices", [Page 319].

► Click on the button Automatic configure settings to apply the
automatic configuration settings

8.4.3.4 Selecting DC Master
► Select a DC Master in the drop-down menu Select a DC Master 

The selected DC Master is marked with a crown.
The DC Master is always the first supply segment, which later
serves as master for all other CU2508. The port multiplier containing
this infeed line is the master port multiplier from which lines are
pulled to other port multipliers. For more information, see the Real-
Time and Distributed Clocks documentation.

► Click on the button Go To Next Step to continue
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8.4.4 DC Sync Cables

Visibility depending on CU2508
The DC Sync Cables page is only displayed if a CU2508 is used in
the configuration. For more information please refer to the Real-
Time documentation.

8.4.4.1 Controls
The list shows the most important controls:

Button Go To Previous Step
Opens the previous page.

Button Go To Next Step
Opens the next page.

8.4.4.2 Searching for ports
In the DC Sync Cables menu you have the possibility to search for
ports.

► Enter a digit in the input box to search for one or more ports

The search result for the entered digit is displayed.
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8.4.4.3 Setting ports
For each port, you have the option of selecting whether it should re-
main unused, be used as a Sync Master or as a Sync Slave.

Example CU2508
Setting a sync connection between Port 5 and Port 8 is shown as an
example for two CU2508.

► Select Sync-Master in the drop-down menu of Port 5

The subordinate CU2508 receives the data from the Sync Master
and becomes a Sync Slave.

► Select Sync-Slave in the drop-down menu of Port 8

► Click on the button Go To Next Step to continue
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8.4.5 Completing the configuration
After all the required settings have been made, you can complete
the configuration.

► Click on the button Go To Next Step to continue
The changes are saved and the IO Timing Configurator closes.

8.4.6 Enabling I/O devices
After the IO Timing Configurator has been closed, all I/O devices
can be enabled again in the Solution Explorer.

► Expand Solution Explorer > TwinCAT Project > I/O > Devices
► Press and hold the Ctrl key to select the XTS relevant devices
► Right-click on the XTS relevant devices to open the context

menu
► Click Disable in the context menu
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8.5 XTS Viewer

8.5.1 Opening the viewer
After you have successfully installed TF5850 TC3 XTS Extension,
you can open the XTS Viewer like any other Windows application.
You can find the XTS Viewer under the file path C:\TwinCAT\Func-
tions\TF5850-TC3-XTS-Technology\TcXtsViewer or as an icon on
your desktop.

► Double-click on the XTS Viewer icon on your desktop
The XTS Viewer opens.

8.5.2 Operating elements
The list shows the most important controls:

Drop-down menu Target PC
Displays the configuration of the selected target PC and lists the
available PCs.

Connect to target PC
Enables the connection to the target PC.

Continuous update
Continuously updates the connection with the target PC.

Add additional view
Adds an additional window for the target PC.

Options
Opens the dialog box Options…

Module-Side drop-down menu
Displays the selected module side and lists the available module
sides.

Rotation drop-down menu
Allows you to select a preset angle between -180° and 180° or enter
your own value. The reference point is the first module of a part.

Theme drop-down menu
Displays the selected theme and lists the available themes.

Configuring View
Opens the dialog box Configure View.

Zoom window width
Scales the view to the window width.
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Zoom original size
Scales the view to the preset original size.

Custom zoom
Scales the view to the custom size.

8.5.3 Connecting to the target system
An XTS Viewer application can only be connected to one target PC.
The main window XTS Viewer and the additional windows XTS View
can be customized, although they share the same target and op-
tions. To connect multiple target PCs, additional XTS Viewer appli-
cations must be opened.
To connect an XTS Viewer application to a target PC, you have two
options:
• Start screen
• In the Viewer

8.5.3.1 Start screen
► Select the target PC in the drop-down menu
► Click on the button Connect

The XTS system of the target PC, which is in Run Mode, is dis-
played in the XTS Viewer.

Target also valid for additional views
The selected target PC also applies to any additional view added via
the button Add additional View.
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8.5.3.2 In the Viewer
► Click on the button Connect to selected Target to deactivate

the previous target PC

► Select a target PC in the drop-down menu Choose Target…

► Click on the button Connect to selected Target to activate the
new target PC

The XTS system of the target PC, which is in Run Mode, is dis-
played in the XTS Viewer.
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8.5.4 Continuous update
By deactivating the continuous update, the positions of the movers
and modules are no longer updated. If the movers are moving too
fast, it is possible to create a standstill view by deactivating the con-
tinuous update.

Deactivation also applies to other XTS views
Disabling continuous updating also applies to any XTS views added
via the button.

► Click on the button Continous Update to disable continuous up-
date

OR
► Click on the button Continous Update to enable the continuous

update

8.5.5 Create View
► Click on button Additional View

An additional XTS View opens.
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8.5.6 Open Options... dialog box
Numerous options are available for configuring the XTS Views and
for the basic settings of the XTS Tools. The settings of the XTS
Views are stored in so-called themes. These themes can be edited
and used by other windows with XTS View integration, such as the
XTS Tool Window.
► Click on the button Options…
The dialog box Options opens.
Further information can be found in chapter "Dialog box Options…",
[Page 353].

8.5.7 Open pop-up menu
► Right-click on the background to open the pop-up menu
The pop-up menu opens. Further information can be found in chap-
ter "Pop-up menu", [Page 337].

8.5.8 ToolTips
The ToolTips provide information on most of the XTS Viewer con-
trols and components.

8.5.8.1 Mover
► Move the mouse pointer over the mover
The tooltip shows the name of the mover and its position.

8.5.8.2 Modules
► Move the mouse pointer over the module
The tooltip shows the name and the type of the module as well as
the affiliation to the part.
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8.5.8.3 Tracks
► Move the mouse pointer over the track
The tooltip shows the name of the track.

8.5.8.4 Parts
► Move the mouse pointer over the part
The tooltip shows the name of the part.
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8.6 XTS Support Assistant, Beta
The XTS Support Assistant collects debug information of the XTS
system currently running on the TwinCAT target system. The desk-
top application stores the collected debug information in so-called
reports. The reports can be sent to an XTS specialist or XTS sup-
port to get a quicker overview of the XTS system.
Currently reports can only be generated on the TwinCAT target PC.
Running the XTS Support Assistant on an engineering PC does not
provide all the required information.

The XTS Support Assistant is currently still in beta phase. In the fu-
ture, even more functions and information will be available.

8.6.1 Open XTS Support Assistant
After you have successfully installed TF5850 TC3 XTS Extension,
you can open the XTS Support Assistant like any other Windows ap-
plication.
You can find the XTS Support Assistant as an icon on your desktop
or under the file path C:\TwinCAT\Functions\TF5850-TC3-XTS-
Technology\TcXtsSupportAssistant.

► Double-click on the XTS Support Assistant icon on your desk-
top

The XTS Support Assistant opens.

8.6.2 Operating elements
The list shows the most important controls:

Information area
Opens the input fields of the information area.

Drivers and versions
Opens the list of TwinCAT drivers and their versions.

Attachments
Opens the list of attachments.

Save
Opens the dialog box for saving the report.
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Controls in the attachments
area

Boot Files Button Boot Files
Activates or deactivates whether the boot files should be sent as at-
tachments.

Target Files Button Target Files
Activates or deactivates whether the target files should be sent as
attachments.

TcIoXts Dump Files Button TcIoXts Dump Files
Activates or deactivates whether the TcIoXts files should be sent as
attachments.

8.6.3 Information area
► Enter the customer name in the input field Customer
► Enter a detailed description of the problem in the field Descrip-

tion
The fields ID and Date Created are filled in automatically.

8.6.4 Driver versions
► Click on the button Driver Versions
The page Drivers Versions shows all installed TwinCAT drivers and
the versions used.

8.6.5 Attachments
► Click on the button File Attachments
The page File Attachments shows all files that are sent as attach-
ments. The files are divided into three categories:
• Boot Files
• Target Files
• TcIoXts Dump Files
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The information that is sent as an attachment with the report is di-
vided into the following categories:

Boot Files The boot files are customer-specific files based on the project. For
example, they contain the current project configuration without the
PLC project and logged events from the application log.

Target Files Target files are project-independent base files, such as system
teaching files.

TcIoXts Dump Files TcIoXts Dump Files are files containing all relevant data written from
the Processing Unit object or the XtsIoDrv object of the TcIoXts
Driver using the WriteDump parameter or the automatic dump func-
tionality

8.6.5.1 Selecting
Beckhoff recommends sending as much information as possible
with the report so that the product specialist responsible for your re-
gion has all the necessary information.
All categories are activated by default. Deactivated categories are
excluded from the report.

► If required, click on the button Boot Files, Target Files or
TcIoXts Dump Files to deactivate the category and exclude it
from the report

OR
► If required, click on the button Boot Files, Target Files or

TcIoXts Dump Files to activate the category and send it as at-
tachments

Excluding a single file
Single files cannot be removed from the list of a category. You can
exclude single files from the report only by moving the files from
their original location to another location. After the report has been
created, the files must be inserted back into their original location.

8.6.5.2 Saving
► Click on the Save button
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The dialog box Safe report… opens.
► Select a file path
► Enter a name in the input field File name
By default, the file name consists of Report, the date and the time at
which the XTS Support Assistant was started, for example Re-
port-2023-10-28-09-22-40.zip
► Confirm with Save

8.6.5.3 Writing dump files
The dump files can be written via the TcCom objects XtsProcessing-
Unit or XtsIoDriver.

Example XtsProcessingUnit
Writing the dump files is shown using the TcCom object XtsPro-
cessingUnit as an example.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects

► Double click on XtsProcessingUnit

Manual
► Click the Parameter (Init) tab in the project window
► Expand Diagnostics
► Right-click in the input field Write Dump to open the context

menu
► In the context menu click Download

The dump files are written manually and stored in C:\ on your target
PC.

The Error List and Output message windows display messages indi-
cating that the dump files were written successfully.
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Automatic
► Expand Diagnostics
► Select TRUE in the drop-down menu IsAutoDumpWritingEn-

abled

To apply the settings, the configuration must be reactivated and the
TwinCAT system must be restarted.
► Restart TwinCAT
For example, the dump files are written automatically on events
such as a Mover detection or a Mover ID detection and stored in C:\
on your target PC.
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8.7 Pop-up menu
The pop-up menu is available in the XTS Tool Window and XTS
Viewer.

Different display type
The color of the pop-up menu differs in the XTS Tool Window and in
the XTS Viewer. The functionality is identical in both tools. The de-
scription of the functionality is illustrated using the XTS Tool Window
as an example.

XTS Tool Window XTS Viewer

8.7.1 Show parts
► Right-click on the background to open the pop-up menu
► Click on Show all parts in the pop-up menu to show all parts

8.7.2 Hide parts
► Right-click on the background to open the pop-up menu
► Click on Hide all parts in the pop-up menu to hide all parts
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8.7.2.1 Hide a part
A pop-up menu with fewer setting options appears when you click
on a module instead of the background.

► Right-click on the module to open the pop-up menu
► Click on Hide Part 1 in the pop-up menu to hide Part 1

8.7.2.2 Do not hide a part
► Right-click on the module to open the pop-up menu
► Click on Hide all but Part 1 in the pop-up menu to hide all parts

except Part 1
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8.7.3 Configure View
The dialog box Configure View... is opened in the same way in the
XTS Tool Window and in the XTS Viewer. The XTS Viewer also has
an additional button to open the dialog box.

Open dialog box in XTS Tool Window and XTS Viewer
► Right-click on the background to open the pop-up menu
► Click on Configure View... in the pop-up menu

The dialog box Configure View opens.

► If required, adjust the positioning and opacity of the dialog box
Further information can be found in chapter "Positioning and opac-
ity", [Page 351].

The dialog box allows you to search for component types or for a
specific component. You can also filter components and show or
hide them.

Open dialog box in XTS Viewer
In the XTS Viewer you also have the option of opening the dialog
box Configure View using a button:

► Click on button Configure View
The dialog box Configure View opens.
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8.7.3.1 Controls
The list shows the most important controls:

Filter Parts
Activates or deactivates the parts in the list.

Filter Tracks
Activates or deactivates the tracks in the list.

Filter Mover
Activates or deactivates the movers in the list.

Filter Part Info Bars
Activates or deactivates the part info bars and dimensions in the list.

Filter Info Bars
Activates or deactivates the info bars in the list.

Component search input field
Allows you to enter a search term. All components containing this
term are searched for.

Exact search checkbox
Activates or deactivates the search for an exact search term. If the
checkbox is activated, only the component that exactly matches the
search term is searched for.

Reset entries
Deletes all entries in the Component search input field.
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8.7.3.2 Search components

Example search for Mover 1
The effects of the spelling of a search term are illustrated using the
search for Mover 1 as an example.

Standard search
For the standard search, it is sufficient to enter only part of the
search term. The upper or lower case of the search term is irrele-
vant.

► Enter the search term over 1 in the input field Search
All components that contain the part of the search term are dis-
played in the results list. Both Mover 1 and Movers 10 to 19 contain
the search term over 1.

Exact search
With the exact search, the search term must be entered exactly. The
upper or lower case of the search term is relevant.

► Activate the checkbox Exact text match

► Enter the search term Mover 1 in the input field Search
Only the component that corresponds exactly to the term entered is
displayed in the results list. Only Mover 1 corresponds exactly to the
search term. Movers 10 to 19 are not displayed as their name con-
tains another digit.
If the search does not return a result, check the spelling of the
search term. Pay attention to upper and lower case letters and the
correct spelling of the search term.

Even if a new search does not return any results:
► Deactivate the checkbox Exact text match to use the standard

search
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8.7.3.3 Filter components
You can filter by component type to show or hide certain compo-
nents in the view. By default, all filters are enabled.

Dependence of parts and tracks
It is not possible to hide only the part or the track. Parts and tracks
are dependent on each other and can only be shown or hidden to-
gether. Single modules can also not be hidden.

► Deactivate the button Filter Parts
The parts are deactivated and cannot be expanded in the Configure
View.
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8.7.3.4 Show or hide components
You can use the list of components to show or hide single compo-
nents or entire component types.

Example Show or hide components
Showing and hiding the components is illustrated using the movers
as an example.

Single components
► Expand Mover
► Activate the checkbox of a mover to show the mover
OR
► Deactivate the checkbox of a mover to hide the mover

Component group
► Activate the checkbox of the Mover component group to show all

movers
OR
► Deactivate the checkbox of the Mover component group to hide

all movers
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8.7.4 Show scope

Example scope for a mover and a parameter
The display of a scope is shown in the diagrams using Mover 1 and
the parameter Hardware Position as an example. The procedure is
identical for all movers and parameters.

► Right-click on the background to open the pop-up menu
► Click on Scope... in the pop-up menu

The dialog box Scope opens.

► If required, adjust the positioning and opacity of the dialog box
Further information can be found in chapter "Positioning and opac-
ity", [Page 351].

► Select a mover in the drop-down menu Select target mode

► Click on the button + to add the mover to the scope

► Click the button
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You have the possibility to select different parameters from the fol-
lowing categories:
• SoftDrive – Scope Variables
• General

The dialog box Select Parameters opens.
► Click on a parameter
► Confirm with OK

► Click on the button + to add the parameter

A scope for the selected mover and parameter is displayed.
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8.7.5 Mover information
► Right-click on the background to open the pop-up menu
► Click on Show mover infos in the pop-up menu

The dialog box Movers opens.

► If required, adjust the positioning and opacity of the dialog box
Further information can be found in chapter "Positioning and opac-
ity", [Page 351].

The positions of the movers are displayed.
► If required, click on the button to open the dialog box Select Col-

umn Values

You have the possibility to select different parameters from the fol-
lowing categories:
• SoftDrive – Scope Variables
• General

The dialog box Select Column Values opens.
► Activate the checkboxes of the parameters
OR
► Deactivate the checkboxes of the parameters
► Confirm with OK

Select Mover
► Click on a mover in the view
OR
► Click on a mover in the dialog box Movers
The selected mover is highlighted in color in the Movers dialog box
and in the view. This function facilitates the search for the corre-
sponding mover and its position on the system.
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► Click on a mover in the view
OR
► Click on a mover in the dialog box Movers
► Press and hold the Ctrl key to click on additional movers with the

left mouse button
The selected movers are highlighted in color in the dialog box
Movers and in the view. This function facilitates the search for the
corresponding movers and their positions on the system.
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8.7.6 Module information
► Right-click on the background to open the pop-up menu
► Click on Show module infos in the pop-up menu

The dialog box Modules opens.

► If required, adjust the positioning and opacity of the dialog box
Further information can be found in chapter "Positioning and opac-
ity", [Page 351].

► If required, click on the button to open the dialog box Select Col-
umn Values

You have the possibility to select different parameters from the fol-
lowing categories:
• Drive CoE – I2T Diag Data
• General
• Drive CoE – Info Data
• Drive CoE – Vendor Data
• Drive CoE – General
• Drive CoE – Amplifier Settings
• Drive Info

The dialog box Select Column Values opens.
► Activate the checkboxes of the parameters
OR
► Deactivate the checkboxes of the parameters
► Confirm with OK

Selecting modules
► Click on a module in the view
OR
► Click on a module in the dialog box Modules
The selected module is highlighted in color in the dialog box Mod-
ules and in the view. This function facilitates the search for the cor-
responding module and its position on the system.
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► Click on a module in the view
OR
► Click on a module in the dialog box Modules
► Press and hold the Ctrl key to click on additional modules with

the left mouse button
The selected modules are highlighted in color in the dialog box Mod-
ules and in the view. This function facilitates the search for the cor-
responding modules and their position on the system.

8.7.7 Diagnostic process
► Right-click on the background to open the pop-up menu
► Click on Show diagnosis history in the pop-up menu

The dialog box Diagnosis Messages opens.

► If required, adjust the positioning and opacity of the dialog box
Further information can be found in chapter "Positioning and opac-
ity", [Page 351].

Error messages, warning messages and notes are displayed in the
dialog box.
► Click on a module to display the associated error messages,

warning messages and notes
► If required, activate the buttons Errors, Warnings and Mes-

sages to display the corresponding messages
OR
► If required, deactivate the buttons Errors, Warnings and Mes-

sages to hide the corresponding messages
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8.7.8 Save view
► Right-click on the background to open the pop-up menu
► Click on Snapshot in the pop-up menu

The dialog box Export Image… opens.

► If required, adjust the positioning and opacity of the dialog box
Further information can be found in chapter "Positioning and opac-
ity", [Page 351].

► Select Current View in the drop-down menu Select the view to
export to save only one view of the system without borders

OR
► Select Full View in the drop-down menu Select the view to ex-

port to save the entire view
► If required, select a color for the background in the drop-down

menu Select the background color
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].
► Click on Copy to copy the view to the clipboard
OR
► Click on Save As... to save the view as a png image and select

the storage location
OR
► Cancel with Close
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8.7.9 Positioning and opacity
The dialog box opened with the pop-up menu can be positioned as
required in the XTS Tool Window or in the XTS Viewer. You can
also use the buttons in the dialog box Dialog Settings to position the
respective dialog box at the outer edges and set the opacity.
► Right-click on the header of the dialog box to open the context

menu
► Click on Dialog Settings

The dialog box Dialog Settings opens.
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8.7.9.1 Controls
The list shows the most important controls:

Top left
Aligns the dialog box at the top left of the open XTS tool.

Top
Aligns the dialog box at the top across the entire width of the open
XTS Tool.

Top right
Aligns the dialog box at the top right of the open XTS Tool.

Left
Aligns the dialog box to the left over the entire height of the open
XTS Tool.

Middle
Aligns the dialog box to the middle of the open XTS Tool.

Right
Aligns the dialog box to the right over the entire height of the open
XTS Tool.

Bottom left
Aligns the dialog box at the bottom left of the open XTS Tool.

Bottom
Aligns the dialog box at the bottom across the entire width of the
open XTS Tool.

Bottom right
Aligns the dialog box at the bottom right of the open XTS Tool.

Opacity slider
Sets the opacity for the dialog box.

► Click on a button to set the orientation for the dialog box
► Use the slider Opacity to set the opacity for the dialog box
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8.8 Dialog box Options…

The dialog box Options... is valid for all XTS Tools
This chapter describes all the settings that you can make in all XTS
Tools in the dialog box Options....

In the dialog box Options... , you can adjust the settings for the XTS
Views using the tabs XTS View Themes and General.

8.8.1 XTS View Themes
First, a theme must be selected for which the settings are to be ad-
justed.

► Click on the tab XTS View Themes
► Select the theme you want to adjust from the drop-down menu
• Base Theme
• XTS Viewer Theme
• Simulation Builder Theme
• Tool Window Theme
• Configurator Theme

8.8.1.1 View
► Click on View
► Activate the checkbox Textured Background to display a tex-

tured background
OR
► Deactivate the checkbox Textured Background to display a sin-

gle-color background
► Select a color from the drop-down menu XTS View Background
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].

Property Explanation Default setting
Textured Background Textured background, chessboard pattern Enabled
XTS View Background Color for the background in XTS View AliceBlue
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8.8.1.2 Modules
► Expand Module
► Click on ... of Module Dialog Columns to open the dialog box Se-

lect Components

The dialog box Select Components opens.
► Activate the parameter checkbox to select the parameter
OR

► Deactivate the parameter checkbox to remove the parameter
from the selection

► Confirm with OK

► Activate the checkbox Show heat map to display the tempera-
ture

OR
► Deactivate the checkbox Show heat map to hide the tempera-

ture
► Set opacity with the slider Temperature heat map trans-

parency
► Select the component in the drop-down menu Heat map compo-

nent whose temperature is to be displayed

Property Explanation Default setting
Show heat map Temperature display Disabled
Heat map transparency Slider for the opacity of the temperature display 100
Heat map component Selection of the component PCB Temperatures
• PCB Temperatures PCB Temperatures –
• Amplifier I2T Temperatures I2T controller temperatures –
• DC Link Voltage Direct current voltage –
• Max DC link voltage - last

500 ms
Maximum DC voltage of the last 500 ms –

• Max overall current - last
500 ms

Maximum overall current of the last 500 ms –
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Text
► Click on Text
► If required, enter a parameter in the input field Text
OR
► Click on Browse to open the dialog box Module Components

The dialog box Module Components opens.

► Click on a parameter
► Confirm with OK

► Click on the buttons at Horizontal Alignment, Vertical Align-
ment and Text Baseline to select the alignment of the text

► Choose a color from the drop-down menu Text Brush
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].
► Select the preset value in the drop-down menu Font Size
OR
► Enter a value in the input field Font Size
► Enter values for the distances between the text and the frame in

the input fields Margin
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Property Explanation Default setting
Text Input field for a parameter displayed on the mod-

ules.
–

Horizontal Alignment Horizontal alignment of the text to the module Left
 Left Left aligned –
 Center Centered –
 Right Right aligned –

Vertical Alignment Vertical alignment of the text to the module Top
 Top Top –
 Center Centered –
 Bottom Bottom –

Text Baseline Text baseline Top
 Top Top –
 Middle Middle –
 Bottom Bottom –

Text Brush Font color AliceBlue
Font Size Font size 16
Margin Distance of the text to the frame –

 Left Left 0
 Right Right 0
 Top Top 0
 Bottom Bottom 0
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ToolTip
Use the Tooltip parameters to specify which information is displayed
when you move the mouse over the modules.

► Click on Tooltip
► Click on Browse to open the dialog box Module Components

The dialog box Module Components opens.

► Click on a parameter
► Confirm with OK

Add Tooltip
► Click on the button + to add a new tooltip
A new tooltip is added to the list.
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Remove tooltip
► Click on a tooltip to be removed
► Click on the button x to remove the selected tooltip from the list
The tooltip is removed from the list.
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Drive Status
► Click on Drive Status
► Activate the checkbox Show Module drive warning to display

warnings
OR
► Deactivate the checkbox Show Module drive warning to hide

warnings
► Activate the checkbox Show Module drive error to display error

messages
OR
► Deactivate the checkbox Show Module drive error to hide error

messages
► Click on the buttons of Icon Horizontal Alignment, Icon Verti-

cal Alignment, Icon Horizontal Baseline and Icon Vertical
Baseline to select the alignment of the icon

► Enter values for the distances between the icon and the frame in
the input fields Icon margin

Property Explanation Default setting
Show Module drive warning Display of the module warning Enabled
Show Module drive error Display of the module error Enabled
Icon Horizontal Alignment Horizontal alignment of the icon Center

 Left Left aligned –
 Center Centered –
 Right Right aligned –

Icon Vertical Alignment Vertical alignment of the icon Bottom
 Top Top –
 Center Centered –
 Bottom Bottom –

Icon Horizontal Baseline Horizontal icon baseline Center
 Left Left aligned –
 Center Centered –
 Right Right aligned –

Icon Vertical Baseline Vertical icon baseline Bottom
 Top Top –
 Center Centered –
 Bottom Bottom –

Icon margin Distance icon to frame –
 Left Left 0
 Right Right 0
 Top Top 0
 Bottom Bottom 0
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8.8.1.3 Mover
► Expand Mover 
► Select a color for selected movers from the drop-down menu

Mover Selection Color
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].
► Click on ... of Mover Dialog Columns to open the dialog box Se-

lect Components

The dialog box Select Components opens.
► Activate the parameter checkbox to select the parameter
OR

► Deactivate the parameter checkbox to remove the parameter
from the selection

► Confirm with OK

Text
► Click on Text
► If required, enter parameter in the input field Text
OR
► Click on Browse to open the dialog box Mover Components

The dialog box Mover Components opens.

► Click on a parameter
► Confirm with OK
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► Click on the buttons at Horizontal Alignment, Vertical Align-
ment and Text Baseline to select the alignment of the text

► Choose a color from the drop-down menu Text Brush
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].
► Select the preset value in the drop-down menu Font Size
OR
► Enter a value in the input field Font Size
► Enter values for the distances between the text and the frame in

the input fields Margin

Property Explanation Default setting
Text Input field for parameters displayed on the movers –
Horizontal Alignment Horizontal alignment of the text to the module Left

 Left Left aligned –
 Center Centered –
 Right Right aligned –

Vertical Alignment Vertical alignment of the text to the mover Top
 Top Top –
 Center Centered –
 Bottom Bottom –

Text Baseline Text baseline Top
 Top Top –
 Middle Middle –
 Bottom Bottom –

Text Brush Font color AliceBlue
Font Size Font size 16
Margin Distance of the text to the frame –

 Left Left 0
 Right Right 0
 Top Top 0
 Bottom Bottom 0
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ID
► Click on ID
► Activate the checkbox Shade Mover IDs to highlight the Mover

IDs
OR
► Deactivate the checkbox Shade Mover IDs to not highlight the

Mover IDs
► Select a color for the color highlighting of Mover 1 in the drop-

down menu ID 1 Color
► Select a color for the color highlighting of the movers in the drop-

down menu Other Color
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].

Property Explanation Default setting
Shade Mover IDs Color highlighting of the Mover IDs Enabled
ID 1 Color Color for highlighting the selected Movers 1 PaleGreen
Other Color Color for highlighting the selected movers Steelblue
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Tooltip
► Click on Tooltip
► Click on Browse to open the dialog box Mover Components

The dialog box Mover Components opens.

► Click on a parameter
► Confirm with OK

Add Tooltip
► Click on the button + to add a new tooltip
A new tooltip is added to the list.

Remove tooltip
► Click on a tooltip to be removed
► Click on the button x to remove the selected tooltip from the list
The tooltip is removed from the list.
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8.8.1.4 Track
► Activate checkboxes Enabled, Show Name and Show name

on each segment
OR
► Deactivate the checkboxes Enabled, Show Name and Show

name on each segment 
► If necessary, change the value in the input field Thickness
► Click on the buttons at Text Baseline and Text Alignment to

select the alignment of the text
► Select the preset value in the drop-down menu Text Font Size
OR
► Enter a value in the input field Text Font Size
► Enter values for the distance between the text and the frame in

the input fields Text Margin

Property Explanation Default setting
Enabled Display of track information Enabled
Show Name Track name Enabled
Show name on each segment Name of the track for each segment Enabled
Thickness Line width 8
Text Baseline Text baseline Top

 Top Top –
 Middle Middle –
 Bottom Bottom –

Text Alignment Text alignment Left
 Left Left aligned –
 Center Centered –
 Right Right aligned –

Text Font Size Font size 48
Text Margin Distance of the text to the frame –

 Left Left 0
 Right Right 0
 Top Top 0
 Bottom Bottom 0
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8.8.1.5 Close-Gap
► Click on Close-Gap 
► Activate the checkbox Track Close-Gap Info to display the dis-

tance from the start point to the endpoint of the track
OR
► Deactivate the checkbox Track Close-Gap Info to hide the dis-

tance from the start point to the endpoint of the track
► If necessary, change the value in the input field Thickness
► Choose a color from the drop-down menu Brush
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].
► Activate the checkbox Show Text to show the text
OR
► Deactivate the checkbox Show Text to hide the text
► Click on the buttons at Text Baseline and Text Alignment to

select the alignment of the text
► Select the preset value in the drop-down menu Text Font Size
OR
► Enter a value in the input field Text Font Size

Property Explanation Default setting
Track Close-Gap Info Display of the distance from the start point to the

endpoint of the track
Enabled

Thickness Line width 8
Brush Font color LightSkyBlue
Show text Display of the text Enabled
Text Baseline Text baseline Bottom

 Top Top –
 Middle Middle –
 Bottom Bottom –

Text Alignment Text alignment Center
 Left Left aligned –
 Center Centered –
 Right Right aligned –

Text Font Size Font size 48
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8.8.1.6 Station
► Click on Station 
► Activate the checkbox Show Name to display the name of the

station
OR
► Deactivate the checkbox Show Name to hide the name of the

station
► Activate the checkbox Show name on each segment to display

the name of the station on each segment
OR
► Deactivate the checkbox Show name on each segment to hide

the name at each station
► If necessary, change the value in the input field Thickness
► Click on the buttons at Text Baseline and Text Alignment to

select the alignment of the text
► Select the preset value in the drop-down menu Text Font Size
OR
► Enter a value in the input field Text Font Size
► Enter values for the distance between the text and the frame in

the input fields Text Margin

Property Explanation Default setting
Show Name Display of the name of the station Enabled
Show name on each segment Display of the name of the station on each segment Disabled
Thickness Line width 8
Text Baseline Text baseline Top

 Top Top –
 Middle Middle –
 Bottom Bottom –

Text Alignment Text alignment Left
 Left Left aligned –
 Center Centered –
 Right Right aligned –

Text Font Size Font size 48
Text Margin Distance of the text to the frame –

 Left Left 0
 Right Right 0
 Top Top 0
 Bottom Bottom 0
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8.8.1.7 Part
► Click on Part
► Activate the checkbox Dimensions Enabled to show the dimen-

sions of the part
OR
► Deactivate the checkbox Dimensions Enabled to hide the di-

mensions of the part
► Choose a color from the drop-down menu Dimensions Brush
Further information can be found in chapter "Drop-down menu
Brush | Color", [Page 374].
► Select the preset value in the drop-down menu Dimensions

Marker Font Size
OR
► Enter a value in the input field Dimensions Marker Font Size
► If necessary, change the values in the input fields Part Dimen-

sions Marker Label Modulo, Dimensions Marker Size and Di-
mensions Thickness

Property Explanation Default setting
Dimensions Enabled Display of the part dimensions Enabled
Dimensions Brush Color of the dimensions AliceBlue
Dimensions Marker Font Size Font size for the dimensions at the marker 26
Part Dimensions Marker Label
Modulo

Interval for displaying the label of the part dimen-
sions at the marker

2

Dimensions Marker Size Length of the marker of the dimensions 30
Dimensions Thickness Width of the marker of the dimensions 8
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8.8.2 General
General settings can be made in the General tab.

8.8.2.1 Common

NOTICE
Do not change the Common parameter
The parameters Common should not be changed in order to
avoid communication errors.

Proceed as follows if you need to change the parameters Common:

► Click on the General tab
► Click on Common
► If required, change the value in the input field CoE Update Inter-

val [ms]
► Activate the checkbox Cycle Update Info Server
OR
► Deactivate the checkbox Cycle Update Info Server
► Enter a storage location for the snapshots in the input field Snap-

shot Default Path
OR
► Click on Browse to open the dialog box Browse For Folder and

select a storage location for the snapshots

Property Explanation Default setting
CoE Update Intervall [ms] CoE update interval 50
Cycle Update Info Server Cycle update info server Disabled

Addition of an EtherCAT Description
► Click on the button + to add a file path
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Removing an EtherCAT Description
► Click on a file path that is to be removed
► Click on the button x to remove the selected file path
The file path is removed from the list.



XTS Tools

370 ─── Version: 1.1.1TF5850

8.8.2.2 Configurator
By default, the Default Configuration creates a part and a track with
all necessary settings. This setting is useful if you want to configure
a closed XTS system with the XTS Configurator. If you work mainly
with Track Management, this setting should be disabled.

► Click on Configurator
► Activate the checkbox Default Configuration to configure a

closed system
OR
► Deactivate the checkbox Default Configuration to configure a

system with Track Management
► Activate the checkbox Show Advanced Settings to show ad-

vanced settings
OR
► Deactivate the checkbox Show Advanced Settings to hide ad-

vanced settings

Property Explanation Default setting
Default Configuration Simplifies the configuration of parts and tracks in a

closed XTS system in the XTS Configurator
Enabled

Show Advanced Settings Display of the advanced settings Disabled
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8.8.2.3 Simulation Builder
By default, the Default Configuration creates a part and a track with
all necessary settings. This setting is useful if you want to configure
a closed XTS system with the XTS Simulation Builder. If you work
mainly with Track Management, this setting should be disabled.

► Click on Simulation Builder
► Activate the checkbox Default Configuration to configure a

closed system
OR
► Deactivate the checkbox Default Configuration to configure a

system with Track Management
► Activate the checkbox Show Introduction to display the wel-

come screen
OR
► Deactivate the checkbox Show Introduction to hide the wel-

come screen

Property Explanation Default setting
• Default Configuration Simplifies the configuration of parts and tracks in a

closed XTS system in the XTS Simulation Builder
Enabled

Show Introduction Display of the welcome screen in the Simulation
Builder

Enabled
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8.8.3 Close Options... dialog box
The dialog box Options... can be closed in three different ways.

8.8.3.1 Save & Close
With Save & Close all settings are saved permanently.

Immediate use in the XTS Tool Window
The settings are applied after saving in the XTS Tool Window. In
other tools, the settings are only applied after a restart.

► Click on Save & Close to save the settings permanently
The dialog box Options… closes.

8.8.3.2 Close
With Close, the updated settings in the dialog box Options... are
temporarily saved. When you reopen the dialog box Options...,
these settings are still available.

NOTICE
Save settings securely
Make sure that your settings are not accidentally deleted or
saved.
Use the Save & Close button to save the current settings in order
to avoid accidental deletion when TwinCAT is closed.
Use the Cancel button to delete the updated settings to avoid ac-
cidentally saving them.

► Click Close to close the dialog box Options...
OR
► Click x to close the dialog box Options...
The settings are saved temporarily and are available until TwinCAT
is closed.
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8.8.3.3 Cancel
With Cancel, all updated settings that have not yet been saved with
Save & Close are deleted.

► Cancel with Cancel
All settings that have not yet been saved with Save & Close are
deleted and are no longer available when the dialog box Options...
is opened again.
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8.8.4 Drop-down menu Brush | Color
In the drop-down menu Brush | Color, you have two options for set-
ting a color:
• select a predefined color in the System tab
• define a color in the Custom tab

8.8.4.1 System
There are 141 predefined colors to choose from in the System area. 

Show the name of the color
If you move the mouse pointer over the color, the name of the color
is displayed.

► Open the drop-down menu

► Click on the  System tab
► Select a color from the drop-down menu System
After selecting the desired color, the drop-down menu closes auto-
matically.
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8.8.4.2 Custom
In the Custom area you have the possibility to define a color. 

► Open the drop-down menu

► Click on the Custom tab to display the settings area Custom

Position Explanation
1 Selection tool in the selection area
2 Selection area
3 Color slider
4 Input fields and sliders for RGB color values
5 Input field and slider for the opacity
6 Input field for HEX color code
7 Display area of the defined color

The adjustment range Custom is displayed.
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Set solid color
► Define a color with the selection tool [1] in the selection area [2]

and the color slider [3]
► Enter values in the input fields R, G and B [4] to define the color
OR
► Use the R, G and B [4] sliders to set values for the color
► Enter a value for the opacity in the input field A [5]
OR
► Use the A [5] slider to set the opacity

Enter HEX color code
► Enter a code for the HEX color in the input field [6]

► Click outside the settings area to close the drop-down menu



XTS Tools

Version: 1.1.1 ─── 377TF5850

8.8.5 Positioning and opacity
By default, the dialog box Options... opens in the center of the XTS
Tool. You have the option of placing the dialog box with buttons in
different places and setting the opacity of the dialog box.
► Right-click on the header of the dialog box to open the context

menu
► Click on Dialog Settings

The dialog box Dialog Settings opens.

8.8.5.1 Controls
The list shows the most important controls:

Top left
Aligns the dialog box at the top left of the open XTS tool.

Top
Aligns the dialog box at the top across the entire width of the open
XTS Tool.

Top right
Aligns the dialog box at the top right of the open XTS Tool.

Left
Aligns the dialog box to the left over the entire height of the open
XTS Tool.

Middle
Aligns the dialog box to the middle of the open XTS Tool.

Right
Aligns the dialog box to the right over the entire height of the open
XTS Tool.

Bottom left
Aligns the dialog box at the bottom left of the open XTS Tool.

Bottom
Aligns the dialog box at the bottom across the entire width of the
open XTS Tool.

Bottom right
Aligns the dialog box at the bottom right of the open XTS Tool.

Opacity slider
Sets the opacity for the dialog box.
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► Click on a button to set the orientation for the dialog box
► Use the slider Opacity to set the opacity for the dialog box
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9 XTS HMI Controls
To install and use the XTS HMI Controls, you need the following
software packages:

Software Version
TE2000 HMI Engineering 1.12.748 or higher
TF2000 HMI Server 1.12.748 or higher
Beckhoff.TwinCAT.HMI.XTS.Controls 3.2107.1 or higher
Beckhoff.TwinCAT.HMI.XTS 3.2107.1 or higher
TF5850 TC3 XTS Extension 3.21.700.0 or higher
TwinCAT 3.1 3.1.4024.0 or higher

System requirements for the XTS HMI Controls
Operating system Version
Windows 10 or higher

9.1 Installation of the NuGet package
After you have successfully installed TF5850 TC3 XTS Extension
and TE2000 HMI Engineering and opened a new HMI project, you
can add the XTS HMI Controls to your project. To add the HMI con-
trols, you need to add and configure the required NuGet packages.

► In the Solution Explorer right-click on TcHmiProject to open the
context menu

► In the context menu click on Manage NuGet Packages ...

In the project window, the tab NuGet: TcHmiProject opens.
► Select TwinCAT XTS Technology in the drop-down menu

Package source
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► Click on Browse
► Click on Beckhoff.TwinCAT.HMI.XTS.Controls

You can also find the HMI XTS package and the HMI XTS Con-
trols package at the following file path in your Explorer:
C:\TwinCAT\Functions\TF5850-TC3-XTS-Technology\TcXtsHmi-
Control.

► Confirm with Install to install the Beckhoff.Twin-
CAT.HMI.XTS.Controls package

With the installation of the Beckhoff.TwinCAT.HMI.XTS.Controls
package, the Beckhoff.TwinCAT.HMI.XTS package is also automati-
cally installed.

The dialog box Preview Changes opens.
► Confirm with OK

After installation, the XTS View is available at XTS Controls in the
Toolbox.



XTS HMI Controls

Version: 1.1.1 ─── 381TF5850

9.2 Server Extension configuration
To view an XTS system in the XTS View, you must configure a con-
nection to the target PC. On the target PC, an XTS project must be
in Run Mode. A local connection is preconfigured.

► Expand Solution Explorer > TcHmiProject > Server
► Double click on TcXtsHmiServerExtension

The TwinCAT HMI Server Configuration tab opens in the project
window.
► Click on TcXtsHmiServerExtension
► Expand TARGET_SYSTEMS
► Click + Add

Assign names for better overview
The name for the connection has no function. Beckhoff recommends
assigning a name in order to identify the target PC.

The dialog box Add opens.
► Enter a name for the connection in the input field Name
► Enter the AMS Net Id of the target PC with which the connection

is to be established in the input field NETID
► If necessary, adjust the value in the input field UPDATE_RATE
► Confirm with Add
► Add more connections in the same way

► Confirm with Accept to complete the configuration
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9.2.1 Edit entries
You can delete or edit your entries:

► Click on the name of the connection to expand the input fields
► Click on the button x to remove the connection
OR
► Click in the input fields NETID and UPDATE_RATE to edit the

entries

► Click on the edit button
The dialog box Rename opens.
► Enter a new name in the input field New name
► Confirm with Rename
OR
► Click on the button x to cancel the process and close the dialog

box



XTS HMI Controls

Version: 1.1.1 ─── 383TF5850

9.3 XTS View configuration
After installing the NuGet package and the Server Extension config-
uration, an XTS View Control instance can be added and then con-
figured.

9.3.1 Add XTS View

► Expand Toolbox > XTS Controls
► Press and hold the Ctrl key to drag XTS View from the toolbox

to Desktop View

When the XTS system is in Run mode, the system is immediately
displayed in the same layout as in the XTS Viewer. If the XTS sys-
tem is not in Run mode, the Desktop View remains empty.
If you have a connection to another target PC, the system of the tar-
get PC will be displayed after the TargetName of the control has
been changed. If the XTS system on the target PC is not in Run
mode, the Desktop View remains empty.
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9.3.2 XTS View properties
In addition to the usual layout properties such as frame, layout and
background image, the controller supports some specific properties.

► Click on the menu item Properties Window in the menu View

XtsView must be selected
The XtsView element must be selected to change the XTS HMI
View properties. The Properties window remains empty if the
XtsView element is not selected.

The Properties Window opens.
► Click on the XtsView element in the project window
In the Properties window the available properties are displayed and
can be adjusted as required.
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9.3.2.1 Reset settings
With the XTS HMI Controller, you have the option to reset settings
made to the preset settings.

Example using the settings under System Layout
The settings under System Layout are used as an example to show
you which parameters you have changed.

After you have selected settings in a drop-down menu or entered
values in the input fields, the font size of the parameter changes and
the checkbox behind the input field is activated.

Default settings Settings changed

• Font normal
• no item added
• Checkbox deactivated

• Font bold
• an item added
• Checkbox activated

► Expand Properties > System Layout
► Click on the activated checkbox PartTransformations

► Click on Reset in the pop-up menu
The previous settings are deleted and reset to the preset values.
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9.3.2.2 Link formula
With the XTS HMI Controller you can convert input fields to enter
formulas.

Example using the settings under System Layout
The settings under System Layout show an example of how you can
convert the input field.

After you have selected settings in a drop-down menu or entered
values, the font size of the parameter changes and the checkbox
behind the input field is activated.

Default settings Settings changed

• Standard input field • Input field converted

► Click on the deactivated checkbox

► Click on Create function binding  in the pop-up menu
The previous input field is converted and an input field for a function
is inserted.

► Enter a function in the input field PartTransformations
OR
► Click on the button to open the Multiline editor

The dialog box Multiline editor opens when you click on the button.
► Enter a function in the input field
► Confirm with OK
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9.3.2.3 Colors
► Expand Properties > Colors
► Click in the input field ModuleSelectionColor to set the color for

the module selection
► Click in the input field MoverSelectionColor to set the color for

the mover selection
The adjustment range is displayed.
Further information can be found in chapter "Colors", [Page 424].

► Click in the input field BackgroundColor to set the color for the
background

► Click in the input field BorderColor to set the color for the border
The adjustment range is displayed.
Further information can be found in chapter "Colors", [Page 424].

The table shows the default parameter settings for the Colors prop-
erties:

Property Explanation Default setting
ModuleSelectionColor Module selection color Solid Color
• None No color –
• Theme Graphic –
• Solid Color Solid color #FF000000
MoverSelectionColor Mover selection color Solid Color
• None No color –
• Theme Graphic –
• Solid Color Solid color #FF000000
BackgroundColor Background color Theme
• None No color –
• Theme Graphic –
• Solid Color Solid color –
• Gradient Color Color gradient –
BorderColor Border color Theme
• None No color –
• Theme Graphic –
• Solid Solid color –
• Gradient Color Color gradient –
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9.3.2.4 Connection
► Expand Properties > Connection
► Enter the target PC in the input field TargetName
OR
► Click on the button to open the Multiline editor
► If necessary, adjust the value in the input field RefreshRate

The table shows the default parameter settings for the Connection
properties:

Property Explanation Default setting
TargetName Name of the target PC, specified connection to the

XTS system
Local

RefreshRate Refresh rate for adaptation to end devices 16
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9.3.2.5 System Layout
With this setting you determine how your XTS system is displayed in
the HMI.

► Expand Properties > SystemLayout
► Select the appropriate display option in the drop-down menu

Layout

► Click ... from InfoImages

XtsInfoImages can be inserted into the controller and can be
zoomed and moved with the XTS system. XtsInfoImages are used
as an array.
The dialog box XtsView | InfoImages opens.
► Click on Add
An XtsInfoImage is added. The properties of the XtsInfoImage can
be set in the Properties area.

► Expand General
► Click on the button Image to select a file path for the graphic
► Select the display in the drop-down menu View
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Reference point and origin
The reference point for the graphic is the top left-hand corner.
The origin refers to the first module added in the XTS Configura-
tor.

► Expand Layout
► Enter values for the position in the input fields PositionX and Po-

sitionY
► Enter values for the size in the input fields Width and Height
► Enter a rotation angle in the input field Rotation
► Activate the checkbox Visible to show the graphic
OR
► Deactivate the checkbox Visible to hide the graphic
► Enter a value in the input field zIndex
Further information can be found in chapter "General settings",
[Page 422].

► Confirm with OK
The dialog box XtsView | InfoImages closes.

► Click ... from PartTransformations

Part Transformations can be inserted into the controller and deter-
mine the XTS layout. You can define the layout for each XTS part.
Part Transformations are used as an array.
The dialog box XtsView | PartTransformations opens.
► Click on Add
A Part Transformation is added. The properties of the part transfor-
mation can be set in the Properties area.
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► Expand General
► Enter values in the input fields PartIndex and Rotation
► Select the appropriate display option in the drop-down menu

PartSide

► Expand X-Transformation
► Enter values in the input fields Offset, ValueScale and AxisBind-

ing
► Expand Y-Transformation
► Enter values in the input fields Offset, ValueScale and AxisBind-

ing

► Confirm with OK
The dialog box XtsView | PartTransformations closes.
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The table shows the default parameter settings for the System Lay-
out properties:

Property Explanation Default setting
Layout View of the system SystemView
• SystemView View of the system as previously configured in the

XTS Configurator
–

• InvertedSystemView View of the system as previously configured in the
XTS Configurator, but from the other side of the sys-
tem

–

• Custom View of the system that is configured manually in the
PartTranformation properties

–

InfoImages …
 General

• Image File path for the graphic –
• View View of the system SystemView
  • SystemView View of the system as previously configured in the

XTS Configurator
–

  • InvertedSystemView View of the system as previously configured in the
XTS Configurator, but from the other side of the sys-
tem

–

  • Custom View of the system that is configured manually in the
PartTranformation properties

–

 Layout
• PositionX X-position of the graphic

Reference point is the global zero point
0

• PositionY Y-position of the graphic
Reference point is the global zero point

0

• Width Width of the graphic
By default, the width of the graphic is indicated in px.
Entering a value changes the width, proportionally
the height of the graphic changes. Entering values
for Width and Height can cause the graphic to be dis-
torted.
Unit: mm, related to the real system size

–

• Height Height of the graphic.
By default, the height of the graphic is indicated in
px. Entering a value changes the height, proportion-
ally the width of the graphic changes. Entering val-
ues for Width and Height can cause the graphic to be
distorted.
Unit: mm, related to the real system size

–

• Rotation Rotation angle of the graphic.
Unit: degrees

0

• Visible Visibility of the tool  True
  •  True Checkbox activated –
  •  False Checkbox deactivated –
• zIndex Z-position of the graphic. Provides information about

updating the graph.
1000
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Property Explanation Default setting
PartTransformations

 General
• PartIndex Index of the configured part 0
• Rotation Rotation angle of the part.

Unit: degrees
0

• PartSide Display page of the part Default
  • Default Default use of the view defined in the layout proper-

ties
–

  • Front Front side –
  • Back Rear side –

 X-Transformation
• Offset Configuration of the X offset of the part.

Unit: mm, related to the real system size
0

• ValueScale X-scaling of the axis offset when an X-axis binding is
used.

1

• AxisBinding Integration of a TwinCAT NC for transformation of an
X offset, e.g. in order to represent a switching axis.
Unit: mm, related to the real system size

–

 Y-Transformation
• Offset Configuration of the Y offset of the part.

Unit: mm, related to the real system size
0

• ValueScale Y-scaling of the axis offset when using a Y-axis bind-
ing

1

• AxisBinding Integration of a TwinCAT NC for transformation of an
Y offset, e.g. in order to represent a switching axis.
Unit: mm, related to the real system size

–
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9.3.2.6 Mover Layout
The Mover Layout allows you to display personalized tools in the
form of images or text on a mover. The Mover Layout is used as an
array.

► Expand Properties > Mover Layout
► Click ... from Tools

The dialog box XtsView | Tools opens.
► Click on Add
An XTS Tool is added. The properties of the XTS Tool can be set in
the Properties area.

► Expand General
► Select the appropriate display option in the drop-down menu

Tooltype

► Select the appropriate display option in the drop-down menu
MoverSide

► Expand Image
► Click on the button ImageSource to select a file path for the

graphic
► Enter values in the input fields ImageWidth and ImageHeight
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► Expand Mover Identification
► Select the appropriate display option in the drop-down menu

MoverIdentificationMode

► Enter the Mover ID or the MoverIndex in the input field MoverI-
dentification

OR
► Click on the button to open the Multiline editor

► Expand Text
► Select the text type in the drop-down menu TextType

► Enter a text in the input field CustomText
OR
► Click on the button to open the Multiline editor
► Click ... from TextOptions
The dialog box TextOptions opens.
Further information can be found in chapter "TextOptions", [Page
 422]"General settings", [Page 422].

► Expand Transformation
► Enter values in the input fields Position X, Position Y, Width,

Height and Rotation
► Activate the checkbox Visible to show the text
OR
► Deactivate the checkbox Visible to hide the text
► Enter a value in the input field zIndex
Further information can be found in chapter "General settings",
[Page 422].
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► Confirm with OK
The dialog box TextOptions closes.

The table shows the default parameter settings for the Mover Layout
properties:

Property Explanation Default setting
Tools …

 General
• ToolType Type of tool Image
   • Image Graphic –
   • Text Text –
• MoverSide Side of the mover on which the tool is displayed Front
   • Front Front side –
   • Back Rear side –

 Image
• ImageSource File path of the graphic, if the ToolType Image is se-

lected
–

• ImageWidth Width of the graphic, if the ToolType Image is se-
lected
By default, the width of the graphic is indicated in px.
Entering a value changes the width, proportionally
the height of the graphic changes. Entering values
for Width and Height can cause the graphic to be
compressed.
Unit: mm, related to the real system size

–

• ImageHeight Height of the graphic, if the ToolType Image is se-
lected
By default, the height of the graphic is indicated in
px. Entering a value changes the height, proportion-
ally the width of the graphic changes. Entering val-
ues for Width and Height can cause the graphic to be
compressed.
Unit: mm, related to the real system size

–

 MoverIdentification
• MoverIdentificationMode Determining how a mover or mover group is defined All
   • All All movers on the system –
   • MoverId Requires an entry of the Mover ID in the input field of

MoverIdentification
–

   • MoverIndex Requires an entry of the Mover Index in the input
field of MoverIdentification

–

• MoverIdentification Input field for the MoverId or the MoverIndex, accord-
ing to the selected property at MoverIdentification-
Mode

–
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Property Explanation Default setting
 Text

• TextType Properties of the text, if the ToolType Text is selected
Type of text node, if the ToolType Text is selected.

Custom

   • Custom Custom –
   • MoverId Mover ID –
   • MoverIndex Mover index –
   • MoverPosition Mover position –
• CustomText Input field for text, if the ToolType Text and the Text-

Type Custom are selected
–

• TextOptions Properties for text design …
 Transformation

• OffsetX X offset
Unit: mm, related to the real system size

0

• OffsetY Y offset
Unit: mm, related to the real system size

0

• Rotation Angle of rotation
Unit: degrees

0

• Visible Visibility  True
   •  True Checkbox activated –
   •  False Checkbox deactivated –
• zIndex Z-position of the graphic, information about the up-

date of the graphic.
11000
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9.3.2.7 Pan & Zoom
► Expand Properties > Pan & Zoom
► Activate the checkbox LockZoomGesture to enable the zoom

function
OR
► Deactivate the checkbox LockZoomGesture to disable the

zoom function
► Activate the checkbox LockPanGesture to enable the panning

function
OR
► Deactivate the checkbox LockPanGesture to disable the pan-

ning function
► Enter values in the input fields Padding

The table shows the default parameter settings for the Pan & Zoom
properties:

Property Explanation Default setting
LockZoomGesture Zoom function False
LockPanGesture Panning function False
Padding Distance between the displayed XTS system and the

edge of the controller. Default zoom when loading
the control.
Unit: px or %

px

• Left distance 0
• Right distance 0
• Upper distance 0
• Lower distance 0
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9.3.2.8 Selections
The Selection properties define how you can select the movers and
modules in the controller.

► Expand Properties > Selections
► Select the selection mode in the drop-down menu Selection-

Mode

► Click ... from MoverSelection

The dialog box XtsView | MoverSelection opens.
► Click on Add
A XTS Mover is added. The properties of the XTS Mover can be set
in the Properties area.
If the SelectionMode SingleSelection or MultiSelection is selected
and the list of selected movers is edited by clicking on it, the event
onSelectedMoverChanged is triggered.
The mover is displayed in the color you have set at MoverSelection-
Color. Further information can be found in chapter "Colors", [Page
 387].
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► Expand General
► Enter a value in the input field MoverIndex

► Confirm with OK

► Click on ... from ModuleSelection

The dialog box XtsView | ModuleSelection opens.
► Click on Add
An XTS module is added. The properties of the XTS module can be
set in the Properties area.
If the SelectionMode SingleSelection or MultiSelection is selected
and the list of selected modules is edited by clicking on it, the event
onSelectedModuleChanged is triggered.
The module is displayed in the color that you have set at ModuleSe-
lectionColor. Further information can be found in chapter "Colors",
[Page 387].

► Expand General
► Enter values in the input fields PartIndex and ModuleIndex
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► Confirm with OK

The table shows the default parameter settings for the Selections
properties:

Property Explanation Default setting
SelectionMode Off
• Off Selection of a module or a mover by clicking not pos-

sible
–

• SingleSelection Selection of a module or a mover by clicking on it.
The selection of the previously selected module or
mover is cleared.
Clicking on an empty space deselects modules and
movers.
Trigger event onSelectedMoverChanged.

–

• MultiSelection Selection of further modules or movers by clicking.
Modules and movers that have already been se-
lected can be removed from the selection by clicking
on them again.
Clicking on an empty space deselects modules and
movers.
Trigger event onSelectedMoverChanged.

–

MoverSelection …
 General

• MoverIndex Identification of the selected mover 0
ModuleSelection …

 General
• PartIndex Identification of the selected part 0
• ModuleIndex Identification of the selected module 0
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9.3.2.9 Station Layout
► Expand Properties > StationLayout
► Activate the checkbox DisplayStations to show the station
OR
► Deactivate the checkbox DisplayStations to hide the station
► Click ... from StationOptions

The dialog box StationOptions opens.
► Expand Layout
► Enter values in the input fields Displacement, Thickness and zIn-

dex

► Expand Text
► Select the text for the station in the drop-down menu Text

► Click on a button from TextInfoBarPlacement to select the
alignment of the text

► Enter a value in the input field TextDisplacement
► Click ... from TextOptions
The dialog box TextOptions opens.
Further information can be found in chapter "TextOptions", [Page
 422]"General settings", [Page 422].
► Confirm with OK
The dialog box StationOptions closes.
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► Click ... from StationMarkerOptions

The dialog box StationMarkerOptions opens.
► Expand Layout
► Select the representation of the station endpoints in the drop-

down menu MarkerType

► Enter values in the input fields Size, Thickness and zIndex
Further information can be found in chapter "General settings",
[Page 422].

► Expand Text
► Select None in the drop-down menu Text if no text is to be dis-

played
OR
► Select StopPosition in the drop-down menu Text if the stop po-

sition is to be displayed
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► Enter a value in the input field TextDisplacement
► Click ... from TextOptions
The dialog box TextOptions opens.
Further information can be found in chapter "TextOptions", [Page
 422]"General settings", [Page 422].

► Confirm with OK
The dialog box StationMarkerOptions closes.
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The table shows the default parameter settings for the Station Lay-
out properties:

Property Explanation Default setting
DisplayStations Display of the dimensions True
StationOptions …

 Layout
• Displacement Offset between InfoBar and the center of the stator 150
• Thickness InfoBar thickness 8
• zIndex Z-position, position of the visual element and infor-

mation about the update of the visual element
1000

 Text
• Text Text for the station None
   • None No text –
   • StationDescription Description of the station –
   • StationId Id of the station –
• TextInfoBarPlacement Alignment of the InfoBar  left-justified
   •  left-justified Left aligned –
   •  centered Centered –
   •  right-justified Right aligned –
• TextDisplacement Offset of the text 10
• TextOptions Properties for text design …
StationMarkerOptions …

 Layout
• MarkerType Display of the station endpoints None
   • None No endpoints –
   • Diamond Diamond endpoints –
   • Tick Tick endpoints –
• Size Size of the endpoint 20
• Thickness Thickness of the endpoint 8
• zIndex Z-position, position of the visual element and infor-

mation about the update of the visual element
Select Type…

 Text
• Text Text for the station None
   • None No text –
   • StopPosition Stop position –
• TextDisplacement Offset of the text 20
• TextOptions Properties for text design …
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9.3.2.10 Dimensions
► Expand Dimensions
► Activate the checkbox DisplayDimensions to show the dimen-

sions
OR
► Deactivate the checkbox DisplayDimensions to hide the dimen-

sions
► Activate the checkbox InvertDimensions
OR
► Deactivate the checkbox InvertDimensions
► Click ... from DimensionOptions

The dialog box DimensionOptions opens.
► Expand Colors
► Click on InfoBarColor or MarkerColor to set the color
The adjustment range is displayed.
Further information can be found in chapter "Colors", [Page 424].

► Expand Layout
► Enter values in the input fields Displacement, Thickness, Mark-

erThickness and MarkerSize
► Click on Select Type... from zIndex
Further information can be found in chapter "zIndex", [Page 426].

► Select the marker type from the drop-down menu MarkerType
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► Expand Text
► Enter values in the input fields TextPattern and TextDisplace-

ment
► Click ... from TextOptions
The window TextOptions opens.
Further information can be found in chapter "TextOptions", [Page
 422]"General settings", [Page 422].

► Confirm with OK
The dialog box DimensionsOptions closes.



XTS HMI Controls

408 ─── Version: 1.1.1TF5850

The table shows the default parameter settings for the Dimensions
properties:

Property Explanation Default setting
DisplayDimensions Display of the dimensions False
DimensionOptions …

 Colors
• InfoBarColor Color that can be defined for the In-

foBar
#FF000000

• MarkerColor Color that can be defined for the
marker

#FF000000

 Layout
• Displacement Offset of the dimensions 100
• Thickness Thickness of dimensions 8
• MarkerType Selection of the marker type Tick
   • None No marker –
   • Diamond Diamond –
   • Tick Tick –
• MarkerThickness Marker thickness 5
• MarkerSize Marker size 25
• zIndex Z-position, position of the visual ele-

ment and information about the up-
date of the visual element

1200

 Text
• TextPattern Text pattern for the description of

the scaling of the system. With 1, for
example, the scaling takes place in
steps of 250.

2

• TextDisplacement Offset of the text 10
• TextOptions Properties for text design …
InvertDimensions False
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9.3.2.11 InfoBars
► Expand InfoBars
► Click … from InfoBars

The dialog box XtsView | InfoBars opens.
► Click on Add
An XtsInfoBar is added. The properties of the XtsInfoBar can be set
in the Properties area.

► Expand Colors
The adjustment range is displayed.
Further information can be found in chapter "Colors", [Page 424].

► Expand General
► Enter values in the input fields PartIndex, PartStartPosition and

PartEndPosition
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► Expand Layout
► Enter values in the input fields InfoBarThickness and InfoBarDis-

placement
► Activate the checkbox Visible to show the InfoBar
OR
► Deactivate the checkbox Visible to hide the InfoBar
► Enter a value in the input field zIndex

► Expand Marker
► Click … from Marker

The dialog box Marker opens.
► Click on Add
An XtsInfoBarMarker is added. The properties of the XtsInfoBar-
Marker can be set in the Properties area.

► Expand Colors
The adjustment range is displayed.
Further information can be found in chapter "Colors", [Page 424].
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► Expand General
► Enter a value in the input field InfoBarPosition

► Expand Layout
► Select the marker type from the drop-down menu MarkerType

► Enter values in the input fields MarkerThickness, MarkerSize
and zIndex

Further information can be found in chapter "zIndex", [Page 426].

► Expand Text
► Enter a text in the input field MarkerText
OR
► Click on the button to open the Multiline editor
Further information can be found in chapter "Link formula", [Page
 386].
► Enter a value in the input field TextDisplacement
► Click ... from TextOptions
The dialog box TextOptions opens.
Further information can be found in chapter "TextOptions", [Page
 422]"General settings", [Page 422].

► Confirm with OK
The dialog box Marker  closes.
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► Expand Text
► Enter a text in the input field InfoBarText
OR
► Click on the button to open the Multiline editor
► Click on a button at TextPlacement to select the alignment of

the text
► Enter a value in the input field TextDisplacement
► Click ... from TextOptions
The dialog box TextOptions opens.
Further information can be found in chapter "TextOptions", [Page
 422]"General settings", [Page 422].

► Confirm with OK
The dialog box XtsInfoBars closes.
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The table shows the default parameter settings for the InfoBars
properties:

Property Explanation Default setting
InfoBars …

 Colors
• InfoBarColor Color that can be defined for the InfoBar #FF00000

 General
• PartIndex 0
• PartStartPosition Point at which the part begins 10
• PartEndPosition Point at which the part ends 200

 Layout
• InfoBarThickness InfoBar thickness 8
• InfoBarDisplacement Offset of the text 100
• Visible Visibility of the tool True
• zIndex Z-position, position of the visual element and infor-

mation about the update of the visual element
1000

 Marker
Marker …
• MarkerColor Color that can be defined for the marker #FF000000
• InfoBarPosition Position of the InfoBar 100
• MarkerType Selection of the marker type Diamond
   • None No marker –
   • Diamond Diamond –
   • Tick Tick –
• MarkerThickness Marker thickness 5
• MarkerSize Marker size 25
• zIndex Z-position, position of the visual element and infor-

mation about the update of the visual element
1001

• MarkerText Text displayed with the marker –
• TextDisplacement Offset of the text 15
• TextOptions Properties of the text design …

 Text
• InfoBarText Text that is displayed in the InfoBar –
• TextPlacement Text alignment Left-justified
   •  left-justified Left aligned –
   •  centered Centered –
   •  right-justified Right aligned –
• TextDisplacement Offset of the text 15
• TextOptions Properties of the text design …
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9.3.2.12 Layout
► Expand Layout
► Enter values in the input fields Left, Top, Right, Bottom, Width

and Height
► Change the unit in the drop-down menu if required

► Expand menu by clicking on the button

► Enter a value in the input field Opacity
► Select the visibility in the drop-down menu Visibility

► Select Value in the drop-down menu WidthMode
OR
► Select Parent in the drop-down menu WidthMode
► Select Value in the drop-down menu HeightMode
OR
► Select Parent in the drop-down menu HeightMode
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► Click ... from Transform

You can add different transformation types to XtsView | Transform.
When the window opens, Rotate is selected by default. The follow-
ing transformations are available:
• Rotate
• Scale
• Translate
• Skew
• Origin
• Perspective

The dialog box XtsView | Transform opens.
► In the drop-down menu, select the transformation type to be

added
► Click on Add
The selected transformation is added.
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The different properties of the transformations can be set in the
Properties area.

Rotate
► Expand General
► Enter a rotation angle in the input field Angle
► Change the unit in the drop-down menu if required
► Enter values in the input fields VectorX, VectorY and VectorZ

Scale
► Expand General
► Enter values in the input fields X, Y and Z

Translate
► Expand General
► Enter values in the input fields X, Y and Z
► Change the unit in the drop-down menu if required

Skew
► Expand General
► Enter a value for the horizontal angle of inclination in the input

field XAngle
► Enter a value for the vertical angle of inclination in the input field

YAngle
► Change the unit in the drop-down menu if required

Origin
► Expand General
► Enter values in the input fields X, Y and Z
► Change the unit in the drop-down menu if required
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Perspective
► Expand General
► Enter values in the input fields Distance, OriginX and OriginY
► Change the unit in the drop-down menu if required

Remove or change transforma-
tion

You can remove individual transformations or change the order of
the transformations.

► Select the transformation to be moved or removed
► Click on X to remove the transformation
OR
► Click on the buttons to move the transformation up or down step

by step

► Confirm with OK
The dialog box XtsView | Transform closes.
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► Enter values in the input fields MaxWidth, MaxHeight, MinWidth
and MinHeight

► Change the unit in the drop-down menu if required

► Enter values in the input fields GridColumnIndex, GridRowIndex
and Zindex

Further information can be found in chapter "zIndex", [Page 426].

► Click ... from BoxShadow
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The dialog box XtsView | BoxShadow opens.
► Click on Add
A BoxShadow definition is added. The properties of the shadow can
be set in the Properties area.

► Expand Colors
The adjustment range is displayed.
Further information can be found in chapter "Colors", [Page 424].

► Expand General
► Enter a value for the distance of the shadow in the X direction in

the input field OffsetX
► Enter a value for the distance of the shadow in the Y direction in

the input field OffsetY values
► Activate the checkbox Inset
OR
► Deactivate the checkbox Inset
► Enter a value for the blurring of the shadow in the input field Blur
► Enter a value for the spread of the shadow in the input field

Spread
► Change the unit in the drop-down menu if required

► Confirm with OK
The dialog box XtsView | BoxShadow closes.
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The table shows the default parameter settings for the Layout prop-
erties:

Property Explanation Default setting
Left Left distance.

Unit: px or %
448

Top Upper distance.
Unit: px or %

298

Right Right distance.
Unit: px or %

-

Bottom Lower distance.
Unit: px or %

-

Width Width.
Unit: px or %

329

Height Height.
Unit: px or %

280

Opacity Value for the opacity 1
Visibility Drop-down menu for visibility Visible
• Visible Visible
• Hidden Hidden
• Collapsed Collapsed
WidthMode Value
• Value Value -
• Parent Parent -
HeightMode Value
• Value Value -
• Parent Parent -
Transform Transformation type …
Rotate Rotational displacement

 General
• Angle Angle of rotation -
• VectorX Vector X-axis -
• VectorY Vector Y-axis -
• VectorZ Vector Z-axis -
Scale Scaling

 General
• X Value for width 1
• Y Value for the height 1
• Z Value for the depth 1
Translate Translational displacement

 General
• X Value for the displacement in the X direction.

Unit: px or %
-

• Y Value for the displacement in the Y direction.
Unit: px or %

-

• Z Value for the displacement in the Z direction.
Unit: px or %

-
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Property Explanation Default setting
Skew Skew

 General
• XAngle Angle for horizontal inclination -
• YAngle Angle for vertical inclination -
Origin Origin

 General
• X Value in X direction -
• Y Value in Y direction -
• Z Value in Z direction -
Perspective Perspective distortion

 General
• Distance Distance -
• OriginX Origin in X-direction -
• OriginY Origin in Y-direction -
MaxWidth Maximum width -
MaxHeight Maximum height -
MinWidth Minimum width -
MinHeight Minimum height -
GridColumnIndex Value for the grid column width 0
GridRowIndex Value for the grid row height 0
Zindex -
BoxShadow Value for the shadow …

 Colors
• Color Color of the shadow ##FF000000

 General
• OffsetX Offset of the shadow in the X direction.

Unit: px or %
0

• OffsetY Offset of the shadow in the Y direction.
Unit: px or %

0

• Inset Inset False
• Blur Blurring of the shadow.

Unit: px or %
0

• Spread Spread of the shadow.
Unit: px or %

0
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General settings
In this chapter you will find more information about the settings Col-
ors, TextOptions and zIndex.

TextOptions
► Expand Colors
The adjustment range is displayed.
Further information can be found in chapter "Colors", [Page 424].
► Define color via the adjustment range

General
► Expand General
► Select the font style from the drop-down menu Fontstyle

► Select the font weight from the drop-down menu FontWeight

► Enter the font family in the input field FontFamily
OR
► Click on the button to open the Multiline editor
► Select text alignment at HorizontalAlignment and Verti-

calAlignment
► Enter a value in the input field FontSize
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► Confirm with OK
The dialog box TextOptions closes.

The table shows the default parameter settings for the TextOptions
properties:

Property Explanation Default setting
 Colors

• Color Text color Solid Color
   • None No color –
   • Theme Graphic –
   • Solid Color Solid color, RGBA #FF000000

 General
• FontStyle Font Normal
   • Normal Normal –
   • Italic Italic font –
   • Oblique Oblique font –
   • Auto Automatic –
• FontWeight Font weight Normal
   • Normal Normal –
   • Bold Bold –
   • Auto Automatic –
• FontFamily Font family –
• HorizontalAlignment Horizontal text alignment Left-justified
   •  Left-justified Left aligned –
   •  Centered Centered –
   •  Right-justified Right aligned –
• VerticalAlignment Vertical text alignment Bottom
   •  Top Top –
   •  Middle Centered –
   •  Bottom Bottom –
• FontSize Font size 20
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Colors
In addition to defining a solid color, some setting areas offer the op-
tion of defining a color gradient. An additional tab is then available
for defining the color gradient.

Different setting ranges
The setting of the colors is shown as an example in a setting range
with a color gradient.

Position Explanation
1 No color
2 Graphic
3 Solid color
4* Color gradient
5** Input field for RGB color values
6** Input field for opacity
7** Color slider
8** Input field for HEX color code
9** Pipette
10*** Color 1 of the color gradient
11*** Position of color value 1 of the color gradient [%]
12*** Rotation angle of the color gradient [°]
13*** Display area of the defined color 1 of the color gradient
14*** Display area of the defined color 2 of the color gradient
15*** Slider for the rotation angle of the color gradient
16*** Color 2 of the color gradient
17** Display range of the last colors used
18** Selection area
19** Selection tool in the selection area

* not available in every adjustment range
** only visible in the Solid color tab [3] or in the Gradient tab [4]
*** only visible in the Color gradient tab [4]
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You have various options for setting a color for the background and
the frame.

No color
► Click on the button [1] to not select a color

Use graphic
► Click on the button [2] to use a graphic

Set solid color
► Click on the button [3] to set a solid color
► Define a color with the selection tool [19] in the selection area

[18] and the color slider [7]
OR
► Enter the values in the input fields R, G and B [5] to define the

color
► Enter a value for the opacity in the input field A [6]
OR
► Enter a code for the HEX color in the input field [8]
OR
► Use the pipette [9] to select a color

Setting the color gradient
► Click on the button [4] to set a color gradient
► Click on Color 1 [17] to set the first color of the color gradient
► Set solid color to set the first color of the color gradient
► Click on Color 2 [16] to set the second color of the color gradient
► Set solid color to set the second color of the color gradient

The defined colors are shown in the display area.
► Left-click outside the adjustment range to close the adjustment

range
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zIndex
The zIndex specifies the Z position where the visual element is lo-
cated.
The first level has a zIndex of up to 5000, which includes modules
with a zIndex of 0, for example. As soon as an interaction occurs,
such as changing the padding, the first level is updated. An InfoIm-
age can be placed on this first level.
The next level has a zIndex of 5000-15000, this includes the movers
with a zIndex of 10000. An InfoImage can be placed on this level, as
it is updated with the movers.
As soon as the zIndex exceeds a value of 15000, the visual ele-
ments in this level are updated. An InfoImage that is not updated
with the movers can be placed on this level.
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10 Tc3 XTS Utility
The Tc3 XTS Utility is installed together with the TF5850 software
package. The Tc3 XTS Utility is a PLC library and is used to read or
set parameters of the XTS system.
The following diagram shows the structure of the Tc3 XTS Utility:
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10.1 Add library
To be able to use the visualization, a Tc3 XTS Utility library must be
added to the PLC.

10.1.1 Add standard PLC project
► Expand Solution Explorer > TwinCAT Project
► Right-click on PLC to open the context menu
► Click Add New Item... in the context menu

The dialog box Add New Item opens.
► Click on Standard PLC Project
► Enter a name in the input field Name
► Click on Add to add a PLC project

10.1.2 Adding the Tc3 XTS Utility library
► Expand Solution Explorer > TwinCAT Project > PLC > Untitled >

Untitled Project
► Right-click on References to open the context menu
► In the context menu click on Add library ...

The dialog box Add Library opens.
► Expand (Miscellaneous)
► Click on Tc3_XTS_Utility
► Confirm with OK
The Tc3_XTS_Utility library is added.
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10.2 Initialization
The function block FB_TcIoXtsEnvironment must be configured
once for the XTS project so that all parameters of the Processing
Unit can be accessed. If XTS objects are to be used in the project,
the function block FB_XtsEnvironment must also be configured.
The function blocks for accessing the parameters of the InfoServer
and CA group are integrated in the Tc3 XTS Utility. You must acti-
vate the function blocks for initialization so that the function blocks
can be used in the further course via the FB_TcIo-XtsEnvironment.
The function block FB_TcIoXtsEnvironment must be initialized once
when starting or during an online change in order to obtain informa-
tion about all objects. After initialization all parameters are available
via FB_TcIoXtsEnvironment. All parameters can be accessed by
calling the corresponding methods. There is no automatic cyclic up-
date of the data.

10.2.1 Sample code

// Declaration Part
PROGRAM MAIN
VAR
     fbXtsEnvironment                 : FB_TcIoXtsEnvironment;
     stXtsEnvironmentConfiguration    : ST_XtsEnvironmentConfiguration;
     nEnvironmentState                : INT:=1;
END_VAR

//----------------------------------------------------------------------------------------------------

// Programm Part
CASE nEnvironmentState OF

     1: //Enable init items
            //Enable init Info Server if needed
            stXtsEnvironmentConfiguration.bEnableInitInfoServer := TRUE;

            //Enable init CA Group if needed
            stXtsEnvironmentConfiguration.bEnableInitCaGroup := TRUE;

            //Set configuration of XtsUtility init
            fbXtsEnvironment.P_XtsEnvironmentConfiguration := stXtsEnvironmentConfiguration;

            //Next Step
            nEnvironmentState:=2;

     2://Init
           //Start init
           IF fbXtsEnvironment.Init(TRUE) THEN
                 //Stop init 
                 fbXtsEnvironment.Init(FALSE);

                 //Next Step
                 nEnvironmentState:=3;
           END_IF

     3: //Check if init succeeded
           //Check IsInitialized property
           IF fbXtsEnvironment.P_IsInitialized THEN

                 //Next Step 
                 nEnvironmentState:=4;
          END_IF

     4: //Init done
          ;

END_CASE
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10.3 PLC access

10.3.1 Call Chain
With the following Call Chain you have the possibility to access the
essential parameters of the XTS objects. An overview of the param-
eters can be found in the chapter "Parameter", [Page 443].

10.3.2 Accessing TcIo parameters
In principle, all TcIo parameters can be accessed in the PLC. Ac-
cess takes place via the TcCom objects in the Solution Explorer.

Example Number of detected movers
Access to TcIo parameters is illustrated by reading out the number
of detected movers. Calling up the online parameters is done in the
same way for all TcIo parameters.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects

► Double click on XtsProcessingUnit

► In the project window click on the Parameter (Online) tab
► Expand Mover Detection
► Read out the number of detected movers at DetectedMover-

Count
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10.3.3 Access to the parameters in the PLC
You need these calls to access various parameters in the PLC:

Reading out the number of detected movers

nDetectedMoverCount :=      fbXtsEnvironment.XpuTcIo(1).GetDetectedMoverCount();

Reading the DriveState of XPU1

//read the DriveState of XPU1

eDrive:=fbXtsEnvironment.XpuTcIo(1).GetDriveState();

Reading the module count of XPU1

//read the ModuleCount of XPU1-Part2

nModuleCount:=fbXtsTcIo(1)-.PartTcIo(2).GetModuleCount();

Reading the length of XPU1

//read the Length of XPU1-Part2-Module3

fLength:=fbXtsEnvironment.XpuTcIo(1).PartTcIo(2).ModuleTcIo(3).GetLength();

Reading the axis ID of XPU1

//read the AxisId of XPU1-Mover3

nAxisId:=fbXtsEnvironment.XpuTcIo(1).MoverTcIo(3).GetAxisId();

Reading the track length of XPU1

//read the Length of XPU1-Track2

fLength:=fbXtsEnvironment.XpuTcIo(1).TrackTcIo(2).GetLength();

Reading the start position of the InfoStation

//read the StartPositionOnPart of Infostation2

fPosition:=fbXtsEnvironment.InfoServerTcIo(1).InfoStationTcIo(2). GetStartPositionOnPart();

Reading the GabControl mode of the CA group

//read the GapControlMode of CaGroup1

GapControlMode:=fbXtsEnvironment.Mc2CaGroup(1).GetDefaultGapControlMode();
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10.3.4 Access to the SoftDrive parameters
You need these calls to access the SoftDrive parameters:

Reading the KP from VelocityControlLoop

//read Kp of velocity control loop

fbXtsEnvironment.XpuTcIo(1).MoverTcIo(1).SoftDrive.VelocityControl.GetKp();

Setting the KP of VelocityControlLoop

//set kp of velocity control loop

fbXtsEnvironment.XpuTcIo(1).MoverTcIo(1).SoftDrive.VelocityControl.SetKp(1.5);
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10.3.5 Access to the CoE data
The CoE data is accessed either via the module object or by reading
the CoE register.

10.3.5.1 Module object
The driver offers the possibility to read the CoE data directly via the
module object.

Driver interval influences up-to-dateness of CoE data
The driver updates the CoE data at a self-determined interval. It is
therefore possible that the information issued is not up to date.

Sample
The access to the CoE data is illustrated by reading the DC Link
Voltage. Calling up the CoE data takes place in the same way for all
CoE data.

► Expand Solution Explorer > TwinCAT Project > SYSTEM > Tc-
COM Objects > XtsProcessingUnit > Part

► Double-click on Module

► In the project window click on the Parameter (Online) tab
► Click on + of Drive CoE - Info Data
► Read value at DC Link Voltage
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Update of the CoE data via the TcIo module
With the CoE read function via the TcIo module, you can access dif-
ferent CoE data simultaneously. The access takes place via the fol-
lowing call:

fDcLink:=fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).GetDCLinkVoltage();

aI2T REF=fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).GetI2TTemperatures();

10.3.5.2 Update the CoE data by directly reading the CoE registers

The Tc3 XTS Utility organizes access to the CoE data to avoid com-
munication errors. You can only update using an update method and
you can only access one module of a supply segment at a time. In
addition, the Tc3 XTS Utility offers the possibility to read CoE data
via the I/O module.

► Expand Solution Explorer > TwinCAT Project > I/O > Devices >
Device 1

► Double-click on Term 1

► In the project window click on the CoE - Online tab
► Click on CC I2T Diag Data
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Call to read the registers (only possible with connected hard-
ware)
Reading out the CoE data via the calls is only possible with con-
nected hardware and only in Run mode.
If no hardware is connected or the system is being operated in simu-
lation, the calls may cause error messages.

The following call prevents the registers from being read if no hard-
ware is connected and the system is being operated in simulation:

IF NOT fbXtsEnvironment.XpuTcIo(1).GetOperationMode() = OperationMode.Simulation THEN
       "Methode, die genutzt werden soll"
END_IF

The following calls can be used to read the registers when hardware
is connected and the system is being operated in Run mode:

IF fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).CoE.I2TDiagData.Update() THEN
     aI2T:=fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).CoE.I2TDiagData.TemperatureCoilCh;
END_IF

IF fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).CoE.InfoData.Update() THEN
     nDcLink:=fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).CoE.InfoData.DcLinkVoltage;
END_IF

10.3.5.3 Access to all data of a CoE object
For example, if you need access to all I2T values, you can make the
entire object available through the all property. The following calls
are required for this:

pCoEI2TDiagData   : POINTER TO ST_AT2xxxI2TDiagData;

IF fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).CoE.I2TDiagData.Update() THEN
   pCoeI2TDiagData:=fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).CoE.I2TDiagData.all;
END_IF

10.3.5.4 Update and access to all CoE objects
The Tc3 XTS Utility allows you to update and access all CoE objects
with just one call. The following calls are required for this:

stAllCoEData   : ST_AT2xxxI2TDiagData;

IF fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).CoE.AllCoE.UpdateAllCoEData() THEN
   stAllCoEData:=fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).CoE.AllCoE.AllCoEData;
END_IF
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10.3.6 Access to the diagnostic history
You can directly access the diagnostic history from the I/O module
as well as other CoE data. The following call is required for this:

  IF fbXtsEnvironment.XpuTcIo(1)PartTcIo(1).ModuleTcIo(1).CoE.DiagHistoryData.UpdateDiagHistory() THEN
     stAT2xxxI2TDiagHistory:= fbXtsEnvironment.XpuTcIo(1).PartTcIo(1).ModuleTcIo(1).CoE.DiagHistory-
     Data.DiagHistory;
  END_IF

10.3.7 Setting Mover ID detection
The following call is required for Mover ID detection:

  IF fbXtsEnvironment.XpuTcIo(1).SetMoverIdDetectionMode(MoverIdDetectionMode.Mover1) THEN
     nEnvironmentState:=8;
  END_IF

10.3.8 Save mover commands
The command history function can be used to store up to 25 com-
mands for a mover. Each command contains the command type, the
station, a text and a timestamp.

If there is no timestamp, the function will add one automatically.

The following calls are required to manage the command history:

stCommand         : ST_TcIoXtsMoverCommand;

refCommandHistory : REFERNCE TO ARRAY[1..TcIoXtsEnvironmentParameterList.MaxMessageCommandHistory] OF
ST_TcIoXtsMoverCommand;

//preparing the message to store in command history
//if there is no time stamp in the message, the program will add one automatically
stCommand.sCommandType   := ‘MoverAbsoluteCA‘;
stCommand.sStation       := ‚Station2’;
stCommand.sText          := ‚Pos:1000,Acc/Dec:10000‘;

//adding message int command history
fbXtsEnvironment.XpuTcIo(1).MoverTcIo(1).AddCommand(stCommand);

//read command history
refCommandHistry REF= fbXtsEnvironment.XpuTcIo(1).MoverTcIo(1).P_CommandHistory;

//clear all messages in command history
fbXtsEnvironment.XpuTcIo(1).MoverTcIo(1).ClearCommandHistory();
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10.4 Visualization
The function block FB_XtsEnvironmentVisu uses an interface
pointer as input, which must refer to the function block FB_TcIoXts-
Environment in order to access the parameters of the XTS objects.
The method Cycle of FB_XtsEnvironmentVisu must be called for
cyclic update of all parameters.

NOTICE
Visualization only serves as support during programming
The visualization is only for support during programming of an
XTS system and cannot be used for visualization in the plant op-
erator interface.
• Further information can be found in chapter "XTS HMI Con-

trols", [Page 379].

10.4.1 Sample code

// Declaration Part
PROGRAM MAIN

VAR
     fbXtsEnvironment                 : FB_TcIoXtsEnvironment;
     nEnvironmentState                : INT:=1;
END_VAR

//----------------------------------------------------------------------------------------------------

// Programm Part
CASE nEnvironmentVisuState OF

     1: //Link data pointer
     fbXtsEnvironmentVisu(ipTcIoXtsEnvironment:=fbXtsEnvironment);

     Next Step
     nEnvironmentVisuState:=2;

     2: //Cyclic update of Visu information
     fbXtsEnvironmentVisu.Cycle();

END_CASE

► Expand Solution Explorer > TwinCAT Project > PLC > Untitled >
Untitled Project

► Right-click on VISUs to open the context menu
► Click Add in the context menu to open another context menu
► In the context menu click on Visualization...
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The dialog box Add Visualization opens.
► Activate the checkbox VisuSymbols (System)
► Click Open
The Visualization is added to VISUs.

► Expand Solution Explorer > TwinCAT Project > PLC > Untitled >
Untitled Project > VISUs

► Double click on Visualization
The Visualization tab opens in the project window.
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10.4.2 Standard visualization
► Expand Toolbox > Tc3_XTS_Utility
► Press and hold the left mouse button and drag VI_Xts_Environ-

mentVisu into the project window Visualization

The visualization is displayed in the project window Visualization.
► If required, enlarge the visualization for better operability
► If necessary, position the visualization in the project window
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10.4.3 Update cycle data

To use the visualization, the Tc3 XTS Utility must be initialized be-
forehand.

After the DataPointer has been transferred, the Cycle method of the
function block FB_XtsEnvironmentVisu must be called cyclically in
the PLC program to update the parameters of all XTS objects:

//Link data pointer
fbXtsEnvironmentVisu(ipTcIoXtsEnvironment:=fbXtsEnvironment);

//Cyclic update of Visu information
fbXtsEnvironmentVisu.Cycle();

10.4.4 Control visualization
In addition to the start page, there are five other tabs for displaying
parameters:
• Xpu
• Part
• Modules
• Mover
• Track

Display example
The parameter display is shown as an example on the Mover tab.

► Click on the Mover tab

► Click on a mover to open detailed information about the mover
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► Click on + or – to switch between the movers
OR
► Enter the number of the mover in the input field

10.4.4.1 Single page of visualization
Besides using the default visualization VI_XtsEnvironmentVisu, it is
also possible to use a visualization as a standalone page. You can
drag the desired page into the visualization by pressing and holding
the left mouse button and then call the corresponding method in the
PLC program to update the data.

In the following example, the VI_XtsMover page is added to the vi-
sualization to show more detailed information of the mover.

► Expand Toolbox >Tc3_XTS_Utility
► Press and hold the left mouse button and drag VI_XtsMover into

the project window Visualization
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The visualization of the movers is displayed in the project window
Visualization.
► If required, enlarge the visualization for better operability
► If necessary, position the visualization in the project window
After the DataPointer has been transferred, the CatMover method
must be called cyclically in the PLC to update the data:

//Link data pointer
fbXtsEnvironmentVisu(ipTcIoXtsEnvironment:=fbXtsEnvironment);

//cyclic update of Mover Visu information
fbXtsEnvironmentVisu.CatMover ();
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10.5 Parameter

10.5.1 FB_TcIoXtsEnvironment – I_TcIoXtsEnvironment

10.5.1.1 Method

Parameter Group Return Type Input Type Explanation
Init – BOOL BOOL Initialization
GetXpuCount – BOOL BOOL Updates the total number

of Processing Units that
can be get via P_Xpu-
Count or P_XpuCountUnit.

GetXpuOids – BOOL BOOL Updates the object ID list
of Processing Units, which
can be get via P_XpuOids.

GetInfoServerCount – BOOL BOOL Updates the total number
of InfoServers that can be
get via the P_InfoServer-
Count.

GetInfoServerOids – BOOL BOOL Updates the object ID list
of InfoServers, which can
be get via P_InfoS-
erverOids.

GetCaGroupCount – BOOL BOOL Updates the total number
of CA groups that can be
get via P_CaGroupCount.

GetCaGroupOids – BOOL BOOL Updates the object ID list
of CA groups, which can
be get via P_Ca-
GroupOids.

Subitem
XpuTcIo – I_TcIoXtsProcessing-

Unit
UINT Entering the Processing

Unit number selects this
Processing Unit for further
operation.

InfoServerTcIo – I_TcIoXtsInfoServer UINT Entering the InfoServer
number selects this server
for further operation.

Mc2CaGroup – I_Mc2CaGroup UINT Entering the CA group
number selects this CA
group for further operation.
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Properties

Parameter Group Return Type Input Type Explanation
P_XpuCount – UDINT – Returns the total number

of Processing Units.
P_XpuCountUnit – UINT – Returns the total number

of Processing Units in
UINT.

P_XpuOids – REFERENCE TO
ARRAY [1..TcIoXts-
EnvironmentParamet
erList.MaxXtsProces
singUnits] OF OTCID

– Returns the object ID list of
the XPUs.

P_InoServerCount – UINT – Returns the total number
of InfoServers.

P_InfoServerCount-
Oids

– REFERENCE TO
ARRAY [1..TcIoXts-
EnvironmentParamet
erList.MaxXtsInfoSer
ver] OF OTCID

– Returns the object ID list of
the InfoServers.

P_CaGroupCount – UINT – Returns the total number
of the CA group.

P_CaGroupCount-
Oids

– REFERENCE TO
ARRAY [1..TcIoXts-
EnvironmentParamet
erList.MaxXtsCaGrou
p] OF OTCID

– Returns the object ID list of
the CA group.

P_IsInitialised – BOOL – Returns the state of the ini-
tialization.

P_XtsEnvironment-
Configuration

– ST_XtsEnvironment-
Configuration

– Returns the configuration
of the XTS environment.
This parameter is used to
select the initialization of
the XTS environment, such
as the initialization of the
InfoServer or CA group.



Tc3 XTS Utility

Version: 1.1.1 ─── 445TF5850

10.5.2 FB_TcIoXtsProcessingUnit – I_ TcIoXtsProcessingUnit

10.5.2.1 Method - parameter (Init)

Parameter Group Return Type Input Type Explanation
GetOperationMode General OperationMode – Returns the selected oper-

ation mode.
GetEtherCatMaster-
SyncTaskObjectId

General OTCID – Returns the EtherCAT
Master Synchro Task Ob-
ject ID.

GetMoverType Mover MoverType – Returns the selected
mover type.

GetMagnetPlateType Mover MagnetPlateType – Returns the selected mag-
netic plate type.

GetMoverSortOrder Mover SortOrderEnum – Returns the selected sort
order of the movers.

GetMoverWidth Mover LREAL – Returns the minimum dis-
tance between the movers.

GetConfiguredDetec-
tionCount

MoverDetection UDINT – Returns the specified de-
tection count.

SetConfiguredDetec-
tionCount

MoverDetection BOOL UDINT Sets the detection count.

TriggerDetection MoverDetection BOOL – Triggers a mover detec-
tion.

TriggerRedetection MoverDetection BOOL – Triggers mover redetec-
tion.

GetExpected-
MoverIds

MoverIdDetection ARRAY[1..2] OF
ST_Expected-
MoverIds

– Returns the expected
mover IDs for ID detection
with multiple Movers 1.

GetMoverIdDetec-
tionMode

MoverIdDetection MoverIdDetection-
Mode

– Returns the specified
Mover ID detection mode

GetMoverPositionAs-
signment

MoverIdDetection MoverPositionAs-
signment

– Returns the mover position
assignment.

TriggerMoverIdDe-
tection

MoverIdDetection BOOL – Triggers a Mover ID detec-
tion.

SetExpected-
MoverIds

MoverIdDetection BOOL Expected-
MoverIds : AR-
RAY[1..2] OF
ST_Expected-
MoverIds

Sets the expected Mover
IDs in ID detection with
multiple Movers 1.

SetMoverIdDetec-
tionMode

MoverIdDetection BOOL MoverIdDetec-
tionMode

Sets the Mover ID detec-
tion mode.

SetMoverPositionAs-
signment

MoverIdDetection BOOL MoverPosi-
tionAssignment

Sets the assignment of the
mover position.

GetTeaching-
FileNumber

Teaching UDINT – Returns the numbering/
name of the teaching file.

GetIsAbortOnTeach-
ingWarningEnabled

Teaching BOOL – Returns the setting of the
teaching warning. If TRUE,
the system start may be
aborted because of the
warning.
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Parameter Group Return Type Input Type Explanation
GetIsTeachingCheck-
SumCheckEnabled

Teaching BOOL – Returns the setting of the
teaching checksum check.
Returns TRUE if the speci-
fied checksum is used to
verify that the correct
teaching file is loaded and
not corrupted.

SetTeaching-
FileNumber

Teaching BOOL UDINT Sets the numbering/name
of the applied teaching file

GetIsAutoDump-
WriteEnabled

Diagnostics BOOL – Returns the setting of auto-
matic writing of the dump
file. If TRUE, the driver au-
tomatically writes a dump
file in certain situations like
at startup or in case of an
error.

GetIsInputCheck-
Enabled

Diagnostics BOOL – Returns the settings of the
input check. If TRUE, all
plausibility checks of all in-
put channels in the system
are activated.

GetUsedEventLog-
ger

Diagnostics EventMessenger – Returns selected specifica-
tions how events and mes-
sages are transmitted by
the driver

WriteDump Diagnostics BOOL – Writes a dump file.
SetIsInputCheckEn-
abled

Diagnostics BOOL BOOL Sets the activation/deacti-
vation of the input check

GetIsCycleTime-
WarningSuppressed

Advanced BOOL – Returns the setting of the
suppressed cycle time
warning. If enabled, the
warning that the driver is
not running at a cycle time
of 250 us is disabled.
ATTENTION: Only avail-
able in simulation mode.

GetIsMoverFrozen-
ErrorActivated

Advanced BOOL – Returns the setting of the
error of a frozen mover. If
enabled, the driver will give
an error message instead
of a warning when a posi-
tion of the mover is frozen.

GetIsPositionBased-
ErrorForwardingEnab
led

Advanced BOOL – Returns the setting of the
position-related error for-
warding. If enabled, a
hardware fault is forwarded
to movers located on the
faulty modules based on
their position.

GetOptimization Advanced OptimizationEnum – Returns the selected opti-
mization.

GetIsPosition-
NoiseEnabled

Simulation BOOL – Returns position noise in
the simulation.

GetIsRandomStart-
UpEnabled

Simulation BOOL – Returns the setting of the
random start position of
movers.

GetMoverDistance Simulation LREAL – Returns the mover dis-
tance at startup
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Parameter Group Return Type Input Type Explanation
GetPositionOffset Simulation LREAL – Returns the position offset

of the movers at startup
GetPositionNoise-
Bandwidth

Simulation LREAL – Returns the bandwidth of
the position noise

GetRandomStartUp-
Bandwidth

Simulation LREAL – Returns the bandwidth of
the random start

GetPositionStartUp-
SimulationMode

Simulation PositionStartUpSimu-
lationMode

– Returns the selected mode
for the start position

GetMoverIdStartUp-
SimulationMode

Simulation MoverIdStartUpSim-
ulationMode

– Returns the selected mode
for generating the mover
ID

GetRandomInitMode Simulation RandomInitMode – Returns the selected mode
for initialization of random
selection

GetRandomInitSeed Simulation DINT – Returns the start value
used for random genera-
tion of mover position and
mover ID.
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10.5.2.2 Method - parameter (Online)

Parameter Group Return Type Input Type Explanation
GetAreAllPosi-
tionsValid

MoverDetection BOOL – Returns the state when all
mover positions are valid.

GetDetectionCycle-
Count

MoverDetection UDINT – Returns the number of de-
tection cycles.

GetDetectedMover-
Count

MoverDetection UDINT – Returns the number of
movers detected during
the last detection process.

GetExpectedMover-
Count

MoverDetection UDINT – Returns the number of
movers expected on the
system.

GetScannedModule-
Count

MoverDetection UDINT – Returns the number of
modules that were
scanned during the last de-
tection.

GetMoverPositions MoverDetection BOOL – Updates the current posi-
tion of all movers.

GetActiveMover-
Count

MoverDetection UDINT – Returns the number of ac-
tive movers.

GetHasMoverIdDe-
tectionError

MoverIdDetection BOOL – Returns the state of the
Mover ID detection. If
TRUE, an error has oc-
curred during Mover ID de-
tection.

GetIsMoverIdDetec-
tionValid

MoverIdDetection BOOL – Returns the state of the
Mover ID detection. If
TRUE, the Mover ID has
been detected.

GetIsMoverIdDetec-
tionActive

MoverIdDetection BOOL – Returns the state of the
Mover ID detection. If
TRUE, the Mover ID detec-
tion is running.

GetMoverIds MoverIdDetection ARRAY [1..TcIoXts-
EnvironmentParamet
erList.MaxXtsMovers
PerXpu] OF
STRING(3);

– Returns a list of Mover IDs.

GetIsTeach-
ingChanged

Teaching BOOL – Returns the state of the
teaching. If TRUE, the
teaching is running.

GetIsTeachingValid Teaching BOOL – Returns the state of the
teaching. If TRUE, the
teaching is valid.

GetDriveState Info DriveState – Returns the state of the
drive system.

GetMoverCount Structure UDINT – Returns the total number
of movers.

GetMoverOids Structure BOOL – Updates the object ID of all
movers.

GetPartCount Structure UDINT – Returns the total number
of all parts.

GetPartOids Structure BOOL – Updates the object ID of all
parts.

GetTaskCount Structure UDINT – Returns the total number
of all tasks.
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Parameter Group Return Type Input Type Explanation
GetTaskOids Structure BOOL – Updates the object ID of all

tasks.
GetTrackCount Structure UDINT – Returns the total number

of all tracks.
GetTrackOids Structure BOOL – Updates the object ID of all

tracks.
Subitems
MoverTcIo – I_TcIoXtsXpuMover UINT Selects a mover for further

operation by entering the
number of the selected
mover.

PartTcIo – I_TcIoXtsXpuPart UINT Selects a part for further
operation by entering the
number of the selected
part.

TrackTcIo – I_TcIoXtsXpuTrack UINT Selects a track for further
operation by entering the
number of the selected
track.

10.5.2.3 Properties

Parameter Group Return Type Input Type Explanation
P_MoverPositions – REFERENCE TO

ARRAY [1..TcIoXts-
EnvironmentParamet
erList.MaxXtsMovers
PerXpu] OF
ST_XpuMoverPosi-
tions

– Returns the position of the
part, the object ID of the
part and the object ID of
the track on which the
mover is located.

P_MoverOids – REFERENCE TO
ARRAY [1..TcIoXts-
EnvironmentParamet
erList.MaxXtsMovers
PerXpu] OF OTCID

– Returns the object ID of all
movers.

P_PartOids – REFERENCE TO
ARRAY [1..TcIoXts-
EnvironmentParamet
erList.MaxXtsPartsP
erXpu] OF OTCID

– Returns the object ID of all
parts.

P_TaskOids – REFERENCE TO
ARRAY [1..12] OF
OTCID

– Returns the object ID of all
tasks.

P_TrackOids – REFERENCE TO
ARRAY [1..TcIoXts-
EnvironmentParamet
erList.MaxXtsTracks
PerXpu] OF OTCID

– Returns the object ID of all
tracks.

P_IsInitialised – BOOL – Returns the state of the ini-
tialization.
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10.5.3 FB_TcIoXtsXpuPart - I_TcIoXtsXpuPart

10.5.3.1 Method - parameter (Init)

Parameter Group Return Type Input Type Explanation
GetTaskOid General OTCID – Returns the object ID of

the task.
GetModuleSide General ModuleSide – Returns the side of the

module displayed in the
XTS Tool Window and
XTS Viewer. Selection be-
tween Front and Back.

GetOriginTransform General ST_OriginTransform – Returns the origin transfor-
mation for the part dis-
played in the XTS Tool
Window and XTS Viewer.

SetIsClosed General BOOL BOOL Sets the part as a closed
shape.

SetModuleSide General BOOL ModuleSide Returns the module side of
the part displayed in the
XTS Tool Window and
XTS Viewer.

SetOriginTransform General ST_originTransform – Returns the origin transfor-
mation displayed in the
XTS Tool Window and
XTS Viewer.
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10.5.3.2 Method - parameter (Online)

Parameter Group Return Type Input Type Explanation
GetDriveState Info DriveState – Returns the state of the

drive system.
GetGlobalNumber Info UDINT – Returns the global number

of a part. The global num-
ber is used to distinguish
all parts managed by the
Processing Unit.

GetLength Info LREAL – Returns the length of the
selected part.

GetAreaCount Structure UDINT – Returns the total number
of areas on the part.

GetAreaOids Structure BOOL – Updates the object ID of
the areas on the part.

GetModuleCount Structure UDINT – Returns the total number
of modules on the part.

GetModuleOids Structure BOOL – Updates the object ID of
the modules on the part.

Subitems
ModuleCoE – I_AT2xxxXtsMotor UINT Selects a module for fur-

ther reading of the CoE by
entering the number of the
selected module.

ModuleTcIo – I_TcIoXtsPartModule UINT Selects a module for fur-
ther operation by entering
the number of the selected
module.

10.5.3.3 Properties

Parameter Group Return Type Input Type Explanation
P_AreaOids – REFERENCE TO

ARRAY [1..100] OF
OTCID

– Returns the object ID of
the areas on the part.

P_ModuleOids – REFERENCE TO
ARRAY [1..TcIoXts-
EnvironmentParamet
erList.MaxModulesP
erPart] OF OTCID

– Returns the object ID of
the modules on the part.

P_IsInitialised – BOOL – Returns the state of the ini-
tialization.
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10.5.4 FB_TcIoXtsPartControlArea – I__TcIoXtsPartControlArea

10.5.4.1 Method - parameter (Init)

Parameter Group Return Type Input Type Explanation
GetName General STRING(1023) – Returns the name of the

control area.
GetDescription General STRING(1023) – Returns the description of

the control area.
GetStartPosition General LREAL – Returns the start position

of the control area on the
part.

GetEndPosition General LREAL – Returns the end position of
the control area on the
part.

GetBlendInLength General LREAL – Returns the length from
the start of the control area
to the position where the
control parameters are
completely used.

GetBlendOutLength General LREAL – Returns the length from
which the control parame-
ters are no longer com-
pletely used until the end
of the control area.

GetIsEnabled General BOOL – Returns the activation
state of the control area.

SetName General BOOL STRING(1023) Sets the name for the con-
trol area.

SetDescription General BOOL STRING(1023) Sets the description of the
control area.

SetStartPosition General BOOL LREAL Sets the start position of
the control area.

SetEndPosition General BOOL LREAL Sets the end position of
the control area.

SetBlendInLength General BOOL LREAL Sets the BlendInLength.
SetBlendOutLength General BOOL LREAL Sets the BlendOutLength.
SetIsEnabled General BOOL BOOL Sets the activation/deacti-

vation of the control area.
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10.5.4.2 Method - parameter (Online)
Parameter Group Return Type Input Type Explanation
GetLength Info LREAL – Returns the length of the

control area.
GetIsValid Info BOOL – Returns TRUE if all set-

tings of the control area
are valid.

10.5.4.3 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.5 FB_TcIoXtsPartModule – I_TcIoXtsPartModule

10.5.5.1 Method - parameter (Init)

Parameter Group Return Type Input Type Explanation
GetAdsPort General WORD – Returns the ADS port.
GetTaskOid General OTCID – Returns the object ID of

the task.
GetMotorTermi-
nalOid

General OTCID – Returns the object ID of
the associated motor ter-
minal.

GetSensorTerminal General OTCID – Returns the object ID of
the associated sensor ter-
minal.

GetPositionIndex General UDINT – Returns the index of the
module in the XTS system.
The first module has the
index 0.

GetOffset General LREAL – Returns the offset of the
module to compensate for
mechanical tolerances.

GetScalingFactor General LREAL – Returns the scaling factor
to compensate for me-
chanical tolerances.

SetAdsPort General BOOL WORD Sets the ADS port.
SetTaskOid General BOOL OTCID Sets the task for a part by

entering the task object ID.
SetMotorTerminalOid General BOOL OTCID Sets the object ID of the

motor terminal.
SetSensorTerminal-
Oid

General BOOL OTCID Sets the object ID of the
sensor terminal.

SetPositionIndex General BOOL UDINT Sets the index of the mod-
ule in the XTS system.

SetOffset General BOOL LREAL Sets the offset of the mod-
ule.

SetScalingFactor General BOOL LREAL Sets the scaling factor of
the module.
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10.5.5.2 Method - parameter (Online)

Parameter Group Return Type Input Type Explanation
GetAngle Info LREAL – Returns the angle of the

module in mm.
GetGlobalNumber Info UDINT – Returns the global number

of the module. The global
number is used to distin-
guish all modules man-
aged by the Processing
Unit.

GetLength Info LREAL – Returns the length of the
module in mm.

GetMasterNetId Info AMSNETID – Updates the Net ID of the
EtherCAT master.

GetDriveAddress DriveInfo UINT – Returns the address of the
drive terminal.

GetDriveConfigIden-
tity

DriveInfo ST_DriveConfigIden-
tity

– Returns the structure of
the configured drive iden-
tity with the vendor ID, the
code, the revision and the
serial number.

GetDriveOnlineIden-
tity

DriveInfo ST_DriveOnlineIden-
tity

– Returns the structure of
the online drive identity
with vendor ID, the code,
the revision and the serial
number.

GetDriveState DriveInfo DriveState – Returns the state of the
drive terminal.

GetEncoderAddress EncoderInfo UINT – Returns the address of the
encoder terminal.

GetEncoderConfig-
Identity

EncoderInfo ST_EncoderConfig-
Identity

– Returns the structure of
the configured encoder
identity with the vendor ID,
the code, the revision and
the serial number.

GetEncoderOnline-
Identity

EncoderInfo ST_EncoderOnline-
Identity

– Returns the structure of
the online encoder identity
with vendor ID, the code,
the revision and the serial
number.

GetEncoderSensor-
Values

EncoderInfo ARRAY[1..32] OF
ST_EncoderSensor-
Values

– Returns the values of the
encoder sensor.

GetDriveBTN General BTN – Returns the Beckhoff
Traceability Number
(BTN).

GetDriveDevice-
Name

General STRING(15) – Returns the device name.

GetDriveDeviceType General UDINT – Returns the device type.
GetDriveHardware-
Version

General STRING(15) – Returns the hardware ver-
sion.

GetDriveSoftware-
Version

General STRING(15) – Returns the software ver-
sion.

GetI2TWarnLevel AmplifierSettings USINT – Returns the I2T warning
level.

GetI2TErrorLevel AmplifierSettings USINT – Returns the I2T error level.
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Parameter Group Return Type Input Type Explanation
GetTemperature-
WarnLevel

AmplifierSettings UINT – Returns the temperature
warning level.

GetTemperatureEr-
rorLevel

AmplifierSettings UINT – Returns the temperature
error level.

GetMaxDcLinkVolt-
age

AmplifierSettings UDINT – Returns the maximum of
the DC link voltage.

GetMinDcLinkVolt-
age

AmplifierSettings UDINT – Returns the minimum of
the DC link voltage

GetEnabledBrake-
Chopper

AmplifierSettings BOOL – Returns the settings of the
brake chopper.

GetBreakAfter-
BridgeDisable

AmplifierSettings BOOL – Returns the setting of the
interruption after disabling
the data transmission.

GetI2TTemperatures I2T REFERENCE TO
ARRAY [1..15] OF
REAL

– Returns the I2T value.

GetAuxiliaryVolt-
age5V

InfoData REAL – Returns the operating volt-
age of 5 V.

GetAuxiliaryVolt-
age10V

InfoData REAL – Returns the operating volt-
age of 10 V.

GetAuxiliaryVolt-
age24V

InfoData REAL – Returns the operating volt-
age of 24 V.

GetDCLinkVoltage InfoData REAL – Returns the DC link volt-
age.

GetCurrentScaling InfoData REAL – Returns the scaling of the
current intensity.

GetChipID InfoData ULINT – Returns the chip ID.
GetDeviceInfo InfoData UDINT – Returns the device infor-

mation.
GetMaxDCLinkVolt-
ageLast500ms

InfoData REAL – Returns the maximum DC
link voltage of the last
500 ms.

GetMaxOverallCur-
rentLast500ms

InfoData REAL – Returns the overall current
of the last 500 ms

GetOverallCurrent InfoData REAL – Returns the overall current.
GetPCBTempera-
tures

InfoData REFERNCE TO AR-
RAY [1..4] OF REAL

– Returns the temperature of
PCB.

GetCode VendorData ULINT – Returns the code.
GetCoilOvercurrent-
Threshold

VendorData UDINT – Returns the overcurrent
threshold of the coil.

GetCoilPeakCurrent VendorData UDINT – Returns the current peaks
of the coil.

GetCoilRatedCurrent VendorData UDINT – Returns the nominal cur-
rent of the coil.

GetCoilThermalTime-
Constant

VendorData UINT – Returns the thermal time
constant of the coil.

GetEnableOverall-
CurrentPeakDetec-
tion

VendorData BOOL – Returns the setting of the
peak current detection.

GetEnableOverall-
NegativeCur-
rentChangeError

VendorData BOOL – Returns the setting of the
error for the negative over-
all current change.

GetEnableOverall-
NegativepowerError

VendorData BOOL – Returns the setting of the
overall negative error.
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Parameter Group Return Type Input Type Explanation
GetOverallCurrentFil-
ter

VendorData UINT – Returns the overall current
filter.

GetOverallCurrent-
Gain

VendorData UINT – Returns the gain of the
overall current.

GetOverallCurrent-
Offset

VendorData DINT – Returns the offset of the
overall current.

GetOverallOvercur-
rentThreshold

VendorData UDINT – Returns the overall over-
current threshold.

GetPolarity VendorData UDINT – Returns the polarity.

10.5.5.3 Properties

Parameter Group Return Type Input Type Explanation
Subitems
CoE – I_AT2xxxXtsMotor – Selects the CoE read func-

tion for further operation.
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.6 FB_AT2xxxXtsMotor (ModuleCoE/CoE) - I_AT2xxxXtsMotor (ModuleCoE/CoE)

10.5.6.1 Method

Parameter Group Return Type Input Type Explanation
Update – BOOL – Updates the selected CoE

data.
UpdateDiagHistory – BOOL – Updates the diagnosis his-

tory data. (beta version)
UpdateAllCoEData – BOOL – Updates the data of all

CoE objects. The data can
be accessed via the Up-
dateAllCoEData property.
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10.5.6.2 Properties

Parameter Group Return Type Input Type Explanation
AllCoE UpdateAllCoEData I_AT2xxxAllCoEData – Selects all CoE objects.
UpdateAllCoEData UpdateAllCoEData ST_AT2xxxAllCoE-

Data
– Returns the data of all CoE

objects.
AmplifierSettings-
Data

AmplifierSetting I_AT2xxxAmplifier-
Settings

– Selects the amplifier set-
tings.

BrakeAfterBridgeDis-
able

AmplifierSetting BOOL – Returns the state of the
brake after the bridge has
been disabled.

EnableBrakeChopper AmplifierSetting BOOL – Returns the state of the ac-
tivation of the brake chop-
per.

I2TErrorLevel AmplifierSetting USINT – Returns the error level of
I2T.

I2TWarnLevel AmplifierSetting USINT – Returns the warning level
of I2T.

MaxDcLinkVoltage AmplifierSetting UDINT – Returns the maximum of
the DC link voltage.

MinDcLinkVoltage AmplifierSetting UDINT – Returns the minimum of
the DC link voltage.

TemperatureError-
Level

AmplifierSetting UINT – Returns the error level of
the temperature.

TemperatureWarn-
Level

AmplifierSetting UINT – Returns the warning level
of the temperature.

BtnData BTN I_AT2xxxBtn – Returns the Beckhoff
Traceability Number
(BTN).

Btn BTN STRING(13) – Returns the Beckhoff
Traceability Number
(BTN).

DeviceNameData DeviceName I_AT2xxxDevice-
Name

– Selects the device name.

DeviceName DeviceName STRING(17) – Returns the device name.
DeviceTypeData DeviceType I_AT2xxxDeviceType – Selects the device type.
DeviceType DeviceType UDINT – Returns the device type.
DiagData DiagData I_AT2xxxDiagData – Selects the diagnostic

data.
WarningActual DiagData UINT – Returns the diagnostic

data.
ErrorLatch DiagData UINT – Returns the memory error.
ErrorActual DiagData UINT – Returns the current error.
DiagHistoryData DiagHistory I_AT2xxxDiagHistory – Selects the diagnostic his-

tory.
DiagHistory DiagHistory ST_AT2xxxDiagHis-

tory
– Returns the diagnostic his-

tory.
AmsNetId Ethercat T_AMSNETID – Returns the Net ID.
DriveAdr Ethercat UINT – Returns address of the

driver.
HardwareVersion-
Data

HardwareVersion I_AT2xxxHardware-
Version

– Selects the hardware ver-
sion.

HardwareVersion HardwareVersion STRING(2) – Returns the hardware ver-
sion.
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Parameter Group Return Type Input Type Explanation
I2TDiagData I2TDiagData I_AT2xxxI2TDiag-

Data
– Selects the I2T diagnosis.

TemperatureCoilCh I2TDiagData ARRAY[1..15] OF
USINT

– Returns the I2T values of
the coils.

IdentityData IdentityData I_AT2xxxIdentity – Selects the ID.
ProductCode IdentityData UDINT – Returns the product code.
Revision IdentityData UDINT – Returns the revision sta-

tus.
SerialNumber IdentityData UDINT – Returns the serial number.
VendorId IdentityData UDINT – Returns the vendor ID.
InfoData InfoData I_AT2xxxInfoData – Selects the information

data.
AuxiliaryVoltage10V InfoData UINT – Returns the measured

auxiliary voltage of 10 V.
AuxiliaryVoltage24V InfoData UINT – Returns the measured

auxiliary voltage of 24 V.
AuxiliaryVoltage5V InfoData UINT – Returns the measured

auxiliary voltage of 5 V.
ChipId InfoData ARRAY [1..16] OF

BYTE
– Returns the ID of the chip.

CurrentScaling InfoData INT – Returns the scaling of the
current.

DcLinkVoltage InfoData UINT – Returns the DC link volt-
age.

DeviceInfo InfoData UDINT – Returns the device infor-
mation.

MaxDCLinkVoltage-
Last500ms

InfoData UDINT – Returns the maximum DC
link voltage of the last
500 ms.

MaxOverallCurrent-
Last500ms

InfoData DINT – Returns the overall current
of the last 500 ms.

OverallCurrent InfoData DINT – Returns the overall current.
PcbTemp InfoData ARRAY[1..4] OF

UINT
– Returns the temperature in

the module.
SoftwareVersionData SoftwareVersion I_AT2xxxSoftware-

Version
– Selects the software ver-

sion.
SoftwareVersion SoftwareVersion STRING(2) – Returns the software ver-

sion.
VendorData VendorData I_AT2xxxVendorData – Returns the vendor data.
Code VendorData ARRAY [1..16] OF

BYTE
– Returns the software ver-

sion.
CoilOvercurrent-
Threshold

VendorData UDINT – Returns the overcurrent
threshold of the coil.

CoilPeakCurrent VendorData UDINT – Returns the current peaks
of the coil.

CoilRatedCurrent VendorData UDINT – Returns the nominal cur-
rent of the coil.

CoilThermalTime-
Const

VendorData UINT – Returns the thermal time
constant of the coil.

EnableOverallCur-
rentPeakDetection

VendorData BOOL – Returns the setting of the
peak current detection.

EnableOverallNega-
tivCurrentChangeEr-
ror

VendorData BOOL – Returns the setting of the
error for the negative over-
all current change.
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Parameter Group Return Type Input Type Explanation
EnableOverallNega-
tivePowerError

VendorData BOOL – Returns the setting of the
overall negative error.

OverallCurrentFilter VendorData UINT – Returns the overall current
filter.

OverallCurrentGain VendorData UINT – Returns the gain of the
overall current.

OverallCurrentOffset VendorData DINT – Returns the offset of the
overall current.

OverallCurrent-
Threshold

VendorData UDINT – Returns the overall over-
current threshold.

Polarity VendorData UDINT – Returns the polarity.
All All PVOID – Returns all data of a sub-

range, for example Ven-
dorData and SoftwareVer-
sion.
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10.5.7 FB_TcIoXtsModuleMotorTerminal - I_TcIoXtsModuleMotorTerminal

10.5.7.1 Method

Parameter Group Return Type Input Type Explanation
GetObjectName – STRING(21) – Returns the name of the

motor terminal.

10.5.7.2 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.

10.5.8 FB_TcIoXtsModuleSensorTerminal – I_TcIoXtsModuleSensorTerminal

10.5.8.1 Method

Parameter Group Return Type Input Type Explanation
GetObjectName – STRING(20) – Returns the name of the

sensor terminal.

10.5.8.2 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.9 FB_TcIoXtsXpuTrack – I_TcIoXtsXpuTrack

10.5.9.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetTaskOid General OTCID – Returns the object ID of

the task for the track.
GetIsClosed General BOOL – Returns the state if the

track is closed.
GetIsIncludedInDe-
tection

General BOOL – Returns the state whether
the track is integrated into
the detection mode.

GetPolarity General Polarity – Returns the polarity.
GetOffset General LREAL – Returns the offset.
GetPartConfigItems General ARRAY[1..TcIoXts-

EnvironmentParamet
erList.MaxPartsPerTr
ack] OF ST_Part-
ConfigItems

– Returns the information of
the part in this track.

SetIsClosed General BOOL BOOL Sets the state if the track is
closed.

SetIsIncludedInDe-
tection

General BOOL BOOL Sets the state whether the
track is integrated in the
detection mode.

SetPolarity General BOOL Polarity Sets the polarity.
SetOffset General BOOL LREAL Sets the offset.
SetTaskOid General BOOL OTCID Sets the task for the track

by entering the object ID.

10.5.9.2 Method – parameter (Online)

Parameter Group Return Type Input Type Explanation
GetLength Info LREAL – Returns the length of the

track.
GetModuleCount Info UDINT – Returns the number of

modules.
GetPartCount Info UDINT – Returns the number of

parts.
GetPartInfoItems Info ARRAY[1..TcIoXts-

EnvironmentParamet
erList.MaxPartsPer-
Track] OF ST_PartIn-
foItems

– Returns an array of part in-
formation containing the
part object ID, the polarity
of the part, the offset of the
part in the track and the
current length of the part.

10.5.9.3 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.10 FB_TcIoXtsXpuMover – I_TcIoXtsXpuMover

10.5.10.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetAdsPort General WORD – Returns the ADS port.
GetActiveTrackOb-
jectId

General OTCID – Returns the object ID of
the active track.

GetTaskOid General OTCID – Returns the object ID of
the task.

SetActiveTrackOb-
jectId

General BOOL OTCID Sets the active track by en-
tering the object ID of the
track.

GetIsActivated General BOOL – Returns the activated state
of the mover.

SetIsActivated General BOOL BOOL Sets the activated state of
the mover.

GetSimulatedStart-
UpPart

Simulation OTCID – Returns the object ID of
the start part in the simula-
tion.

GetSimulatedStart-
UpPosition

Simulation LREAL – Returns the position at
startup.

GetSimulatedStart-
UpId

Simulation STRING(3) – Returns the ID of the
mover.

SetSimulatedStart-
UpPart

Simulation BOOL OTCID Sets the start part by en-
tering the object ID of the
part.

SetSimulatedStart-
UpPosition

Simulation BOOL LREAL Sets the start position.

SetSimulatedStart-
UpId

Simulation BOOL STRING(3) Sets the ID of the mover.
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10.5.10.2 Method – parameter (Online)

Parameter Group Return Type Input Type Explanation
GetMoverId MoverIdDetection STRING(3) – Returns the ID of the

mover.
GetAxisId Info UDINT – Returns the ID of the axis.
GetAxisObjectId Info OTCID – Returns the object ID of

the axis.
GetDistanceDriven Info LREAL – Returns the value of the

absolute travel distance.
Unit: mm

GetDis-
tanceDrivenInKm

Info LREAL – Returns the value of the
absolute travel distance.
Unit: km

GetDriveAddress Info UINT – Returns the address of the
module on which the
mover is located.

GetDriveModu-
leNumber

Info UDINT – Returns the number of the
module on which the
mover is located.

GetDriveTerminalOid Info OTCID – Returns the object ID of
the module on which the
mover is located.

GetEncoderAddress Info UINT – Returns the address of the
encoder terminal on which
the mover is located.

GetEncoderModu-
leNumber

Info UDINT – Returns the number of the
encoder terminal on which
the mover is located.

GetEncoderTerminal-
Oid

Info OTCID – Returns the object ID of
the encoder terminal on
which the mover is located.

GetHasDriveError Info BOOL32 – Returns the error state of
the drive.

GetHasEncoderError Info BOOL32 – Returns the error state of
the encoder terminal.

GetMasterNetId Info AmsNetId – Returns the Net ID of the
module.

GetPositionInfo Info REFERENCE TO
ST_PositionInfo

– Returns the position infor-
mation of the part and the
track

GetSoftdriveOid Info OTCID – Returns the object ID of
the SoftDrive.
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10.5.10.3 Properties

Parameter Group Return Type Input Type Explanation
P_AxisOid Info REFERNCE TO

OTCID
– Returns the object ID of

the axis.
P_SoftdriveOid Info REFERENCE TO

OTCID
– Returns the object ID of

the SoftDrive.
P_IsInitialised Info BOOL – Returns the state of the ini-

tialization.
Softdrive Softdrive I_McXtsMoverSoft-

drive
– Selects the SoftDrive for

further operation.
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10.5.11 FB_McXtsMoverSoftdrive – I_McXtsMoverSoftdrive

10.5.11.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetAdsPort General WORD – Returns the ADS port of

the SoftDrive.
GetHardwareModulo General LREAL – Returns the hardware

modulo factor.
GetOperationMode General UDINT – Returns the operation

mode.
GetMaxCurrentOut-
put

General LREAL – Returns the maximum out-
put current.

GetEmergencyRamp General LREAL – Returns the emergency
brake function.

GetEmergencyTime-
Out

General LREAL – Returns the total emer-
gency downtime.

GetStandstill-
SwitchTime

General LREAL – Returns the switching time
required by the mover to
switch to standstill.
Control parameters after
standstill.

GetStandstillSwitch-
Mode

General TcSdStandStill-
SwitchMode

– Returns the mode in which
the mover switches to
standstill.

GetControlAreas ControlAreas REFERENCE TO
ARRAY[1..TcIoXts-
EnvironmentParamet
erList.MaxAreasPerP
art] OF ST_Contro-
lAreas

– Returns the settings for the
control areas.

GetAreaOwner ExternalIO OTCID – –
GetIoChildAreaLoca-
tion

ExternalIO REFERNCE TO AR-
RAY[1..2] OF
ST_IoChildAReaLo-
cation

– –
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10.5.11.2 Method – parameter (Online)

Parameter Group Return Type Input Type Explanation
GetEncoderOid General OTCID – Returns the object ID of

the encoder.
GetFeedForwardOid General OTCID – Returns the object ID of

the feed forward control.
GetFilter1Oid General OTCID – Returns the object ID of fil-

ter 1.
GetFilter2Oid General OTCID – Returns the object ID of fil-

ter 2.
GetInterpolatorOid General OTCID – Returns the object ID of

the interpolator.
GetMoverOid General OTCID – Returns the object ID of

the mover.
GetPositionControl-
Oid

General OTCID – Returns the object ID of
the position control.

GetSoftdriveOid General OTCID –– Returns the object ID of
the SoftDrive.

GetTcNc3ActData General REFERENCE TO
ST_TcNc3ActData

– Obsolete parameter.

GetTuningAssistOid General OTCID – Returns the object ID of
the tuning assistant.

GetVelocityControl-
Oid

General OTCID – Returns the object ID of
the velocity control.

10.5.11.3 Properties

Parameter Group Return Type Input Type Explanation
Encoder – I_SoftdriveEncoder – Selects the encoder for fur-

ther operation.
FeedForward – I_SoftdriveFeedFor-

ward
– Selects the feed forward

for further operation.
Filter1 – I_SoftdriveFilter1 – Selects the filter 1 for fur-

ther operation.
Filter2 – I_SoftdriveFilter2 – Selects the filter 2 for fur-

ther operation.
Interpolator – I_SoftdriveInterpola-

tor
– Selects the interpolator for

further operation.
PositionControl – I_Softdriveposition-

Control
– Selects the position control

for further operation.
VelocityControl – I_SoftdriveVelocity-

Control
– Selects the velocity control

for further operation.
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.12 FB_SoftdriveEncoder – I_SoftdriveEncoder

10.5.12.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetVelocityFeed-
backMode

General TcSdVelocityFeed-
backMode

– Returns the feedback
mode of the velocity.

GetPositionFeed-
backMode

General TcSdPositionFeed-
backMode

– Returns the feedback
mode of the position.

GetPositionLowPass-
Filter

General LREAL – Returns the frequency of
the position low-pass filter.

GetVelocityFilter-
Bandwidth

General LREAL – Returns the bandwidth of
the velocity filters.

GetStartUpPosition General TcSdStartUpPosi-
tionType

– Returns the type of the
start position.

SetVelocityFeed-
backMode

General BOOL TcSdVeloci-
tyFeedback-
Mode

Sets the feedback mode of
the velocity.

SetPositionLowPass-
Filter

General BOOL LREAL Sets the frequency of the
position low-pass filter.

SetVelocityFilter-
Bandwidth

General BOOL LREAL Sets the bandwidth of the
velocity filter.

GetCorrectionFactor Advanced LREAL – Returns the correction fac-
tor of the monitoring
model.

GetSimulationOffset Advanced LREAL – Returns the offset of the
start position in the simula-
tion.

GetCommutation-
ErrorVelocity

Advanced LREAL – Returns the threshold
value of the communica-
tion error velocity.

SetCorrectionFactor Advanced BOOL – Sets the correction factor.
SetSimulationOffset Advanced BOOL – Sets the offset of the start

position in the simulation.
SetCommutation-
ErrorVelocity

Advanced BOOL – Sets the threshold value of
the communication error
velocity.

10.5.12.2 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.13 FB_SoftdriveFeedForward – I_SoftdriveEncoder

10.5.13.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetFeedForward-
Type

General TcSdFeedForward-
Type

– Returns the type of feed
forward control.

GetKpAccFFT General LREAL – Returns the acceleration
feed forward gain.

GetKpAccFFTArea General LREAL – Returns the acceleration
feed forward gain of the
area.

GetFrictionCompen-
sation

General LREAL – Returns the current feed
forward to compensate for
static friction.

GetFrictionCompen-
sationArea

General LREAL – Returns the current feed
forward to compensate for
the static friction of the
area.

GetAreaCurrentLimit General LREAL – Returns the current limit of
the area.

SetFeedForward-
Type

General BOOL TcSdFeedFor-
wardType

Sets the feed forward type.

SetKpAccFFT General BOOL LREAL Sets the acceleration feed
forward gain.

SetKpAccFFTArea General BOOL LREAL Sets the acceleration feed
forward gain of the area.

SetFrictionCompen-
sation

General BOOL LREAL Sets the current feed for-
ward to compensate for
static friction.

SetFrictionCompen-
sationArea

General BOOL LREAL Sets the current feed for-
ward to compensate for
the static friction of the
area.

SetAreaCurrentLimit General BOOL LREAL Sets the current limit of the
area.

GetDetectionMin-
Movement

MoverIdDetection LREAL – Returns the minimum
movement of Mover 1 dur-
ing Mover 1 detection.

GetDetectionFilter MoverIdDetection LREAL – Returns the low-pass filter
of the Mover 1 detection.

GetDetectionCurrent-
Ramp

MoverIdDetection LREAL – Returns the current rise of
the Mover 1 detection.

GetDetectionMax-
Current

MoverIdDetection LREAL – Returns the maximum cur-
rent for Mover 1 detection.

SetDetectionMin-
Movement

MoverIdDetection BOOL LREAL Sets the minimum move-
ment for Mover 1 during
Mover 1 detection.

SetDetectionFilter MoverIdDetection BOOL LREAL Sets the low-pass filter of
the Mover 1 detection.

SetDetectionCurrent-
Ramp

MoverIdDetection BOOL LREAL Sets the current rise of the
Mover 1 detection.

SetDetectionMaxCur-
rent

MoverIdDetection BOOL LREAL Sets the maximum current
of the Mover 1 detection.

GetOpenloopMove-
Current

Advanced LREAL – Returns the motion current
of the open loop.
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Parameter Group Return Type Input Type Explanation
SetOpenloopMove-
Current

Advanced BOOL LREAL Sets the motion current of
the open loop.

10.5.13.2 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.

10.5.14 FB_SoftdriveFilter1/ FB_SoftdriveFilter2 - I_SoftdriveFilter1/ I_SoftdriveFilter2

10.5.14.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetConfigurationFil-
ter

General REFERENCE TO
ST_ConfigurationFil-
ter

– Returns the configuration
of the filter.

SetConfigurationFil-
ter

General BOOL ST_Configura-
tionFilter

Sets the configuration of
the filter.

10.5.14.2 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.



Tc3 XTS Utility

472 ─── Version: 1.1.1TF5850

10.5.15 FB_SoftdriveInterpolator – I_SoftdriveInterpolator

10.5.15.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetInterpolatorType General TcSdInterpola-

torType
– Returns the interpolator

type.
SetInterpolatorType General BOOL TcSdInterpola-

torType
Sets the interpolator type.

10.5.15.2 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.16 FB_SoftdrivePositionControl – I_SoftdrivePositionControl

10.5.16.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetPositionLoop-
Type

General TcSdPositionLoop-
Type

– Returns the control mode
of the control loop.

GetKp General LREAL – Returns the proportional
gain of the position control.

GetKpStandstill General LREAL – Returns the proportional
gain of the position control
at standstill.

GetKpArea General LREAL – Returns the proportional
gain of the position control
in the area.

GetKpAreaStandstill General LREAL – Returns the proportional
gain of the position control
in the area at standstill.

SetpositionLoopType General BOOL TcSdPosition-
LoopType

Sets the control mode of
the control loop.

SetKp General BOOL LREAL Sets the proportional gain
of the position control.

SetKpStandstill General BOOL LREAL Sets the proportional gain
of the position control at
standstill.

SetKpArea General BOOL LREAL Sets the proportional gain
of the position control in
the area.

SetKpAreaStandstill General BOOL LREAL Sets the proportional gain
of the position control in
the area at standstill.

GetPosLoopFilter Advanced LREAL – Returns the setting of the
low-pass frequency of the
position filter.

SetPosLoopFilter Advanced BOOL LREAL Sets the low-pass fre-
quency of the position fil-
ter.

10.5.16.2 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.17 FB_SoftdriveVelocityControl – I_SoftdriveVelocityControl

10.5.17.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetVelocityLoopType General TcSdVelocityLoop-

Type
– Returns the control mode

of the velocity control.
GetKp General LREAL – Returns the proportional

gain of the velocity control.
GetKpStandstill General LREAL – Returns the proportional

gain of the velocity control
at standstill.

GetKpArea General LREAL – Returns the proportional
gain of the velocity control
in the area.

GetKpAreaStandstill General LREAL – Returns the proportional
gain of the velocity control
in the area at standstill.

GetTn General LREAL – Returns the integer time
constant of the velocity
control.

GetTnStandstill General LREAL – Returns the integer time
constant of the velocity
control at standstill.

GetTnArea General LREAL – Returns the integer time
constant of the velocity
control in the area.

GetTnAreaStandstill General LREAL – Returns the integer time
constant of the velocity
control in the area at
standstill

SetVelocityLoopType General BOOL TcSdVelocity-
LoopType

Sets the control mode of
the velocity control loop.

SetKp General BOOL LREAL Sets the proportional gain
of the velocity control.

SetKpStandstill General BOOL LREAL Sets the proportional gain
of the velocity control at
standstill.

SetKpArea General BOOL LREAL Sets the proportional gain
of the velocity control in
the area.

SetKpAreaStandstill General BOOL LREAL Sets the proportional gain
of the velocity control in
the area at standstill.

SetTn General BOOL LREAL Sets the integer time con-
stant of velocity control.

SetTnStandstill General BOOL LREAL Sets the integer time con-
stant of the velocity control
at standstill.

SetTnArea General BOOL LREAL Sets the integer time con-
stant of the velocity control
in the area.

SetTnAreaStandstill General BOOL LREAL Sets the integer time con-
stant of the velocity control
in the area at standstill.

GetMaxVelocity Advanced LREAL – Returns the setting for the
maximum velocity.
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Parameter Group Return Type Input Type Explanation
SetMaxVelocity Advanced BOOL LREAL Sets the maximum veloc-

ity.

10.5.17.2 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.18 FB_TcIoXtsInfoServer – I_TcIoXtsInfoServer

10.5.18.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetAdsPort General WORD – Returns the ADS port of

the InfoServer.

10.5.18.2 Method – parameter (Online)

Parameter Group Return Type Input Type Explanation
GetInfoStationCount Info UDINT – Updates and returns the

total number of InfoSta-
tions.

GetInfoStationOids Info BOOL – Updates the object IDs of
all InfoStations.

Subitems
InfoStationTcIo – – – Selects the InfoStation for

further operation by enter-
ing the number of the Info-
Station.

10.5.18.3 Properties

Parameter Group Return Type Input Type Explanation
P_InfoStationCount – UINT – Returns the total number

of InfoStations.
P_InfoStationOids – REFERENCE TO

ARRAY[1..TcIoXts-
EnvironmentParamet
erList.MaxXtsInfoStat
ion] OF OTCID

– Returns all object IDs.

P_IsInitialised – BOOL – Returns the state of the ini-
tialization.
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10.5.19 FB_TcIoXtsInfoServerInfoStation – I_TcIoXtsInfoServerInfoStation

10.5.19.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetAdsPort General WORD – Returns the ADS port of

the station.
GetStationId General UDINT – Returns the ID of the sta-

tion.
GetStationColor General UDINT – Returns the color of the

station.
Unit: ARGB

GetStartPositionOn-
Part

General LREAL – Returns the start position
of the station on the part.

GetEndPositionOn-
Part

General LREAL – Returns the end position of
the station on the part.

GetStopPosition General LREAL – Returns the stop position
on the part.

GetStopPositions General ARRAY[1..TcIoXts-
EnvironmentParamet
erList.MaxXtsStopPo
sitionPerStation] OF
LREAL

– Returns the stop positions
on the part.

GetPartObjectIds General ARRAY[1..TcIoXts-
EnvironmentParamet
erList.MaxXtsStopPo
sitionPerStation] OF
OTCID

– Returns all part information
of the station.

GetIsEnabled General BOOL – Returns the state of the
station.

GetDescription General STRING(1023) – Returns the description of
the station.

10.5.19.2 Method – parameter (Online)

Parameter Group Return Type Input Type Explanation
GetPartCount Structure UDINT – Returns the number of

parts that belong to this
station.

GetStopPosition-
sCount

Structure UDINT – Returns the total number
of stop positions.

10.5.19.3 Properties

Name Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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10.5.20 FB_Mc2CaGroup – I_Mc2CaGroup

10.5.20.1 Method – parameter (Init)

Parameter Group Return Type Input Type Explanation
GetRailLength Geometry LREAL – Returns the length of the

guide rails.
GetRailsRing Geometry BOOL – Returns that the guide rails

are closed.
SetRailLength Geometry BOOL LREAL Sets the length of the

guide rails.
SetRailsRing Geometry BOOL BOOL Sets that the guide rails

are closed.
GetDefaultGapCon-
trolMode

Gap Control MC_DE-
FAULT_GAP_CON-
TROL_MODE

– Returns the gap control
mode.

GetGapControlDirec-
tion

Gap Control MC_GAP_CON-
TROL_DIRECTION

– Returns the direction of the
gap control.

GetStandbyGapCon-
trol

Gap Control BOOL – Returns the standby state
of the gap control.

GetDefaultGap Gap Control LREAL – Returns the default value
of the gap.

GetDefaultVelocity Gap Control LREAL – Returns the default velocity
of the gap control.

GetDefaultAccelera-
tion

Gap Control LREAL – Returns the default accel-
eration of the gap control.

GetDefaultDecelera-
tion

Gap Control LREAL – Returns the default decel-
eration of the gap control.

GetDefaultJerk Gap Control LREAL – Returns the default jerk of
the gap control.

SetDefaultGapCon-
trolMode

Gap Control BOOL MC_DE-
FAULT_GAP_
CON-
TROL_MODE

Sets the gap control mode.

SetGapControlDirec-
tion

Gap Control BOOL MC_GAP_CON-
TROL_DIREK-
TION

Sets the direction of the
gap control.

SetStandbyGapCon-
trol

Gap Control BOOL BOOL Sets the standby state of
gap control.

SetDefaultGap Gap Control BOOL LREAL Sets the default value of
the gap.

SetDefaultVelocity Gap Control BOOL LREAL Sets the default velocity of
the gap control.

SetDefaultAccelera-
tion

Gap Control BOOL LREAL Sets the default accelera-
tion of the gap control.

SetDefaultDecelera-
tion

Gap Control BOOL LREAL Sets the default decelera-
tion of the gap control.

SetDefaultJerk Gap Control BOOL LREAL Sets the default jerk of the
gap control.

10.5.20.2 Properties

Parameter Group Return Type Input Type Explanation
P_IsInitialised – BOOL – Returns the state of the ini-

tialization.
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